
 

Avaya Integrated Management 
Release 5.0
Enterprise Network Management with 
IP Office Manager 
Quick Start

14-601903
Issue 2

January 2008



 

© 2008 Avaya Inc.
All Rights Reserved.

Notice
While reasonable efforts were made to ensure that the information in this 
document was complete and accurate at the time of printing, Avaya Inc. can 
assume no liability for any errors. Changes and corrections to the information 
in this document may be incorporated in future releases.

For full legal page information, please see the complete document, Avaya 
Legal Page for Software Documentation, Document number 03-600758.
To locate this document on the website, simply go to 
http://www.avaya.com/support and search for the document number in the 
search box. 

Documentation disclaimer
Avaya Inc. is not responsible for any modifications, additions, or deletions to 
the original published version of this documentation unless such modifications, 
additions, or deletions were performed by Avaya. Customer and/or End User 
agree to indemnify and hold harmless Avaya, Avaya's agents, servants and 
employees against all claims, lawsuits, demands and judgments arising out of, 
or in connection with, subsequent modifications, additions or deletions to this 
documentation to the extent made by the Customer or End User. 

Link disclaimer
Avaya Inc. is not responsible for the contents or reliability of any linked Web 
sites referenced elsewhere within this documentation, and Avaya does not 
necessarily endorse the products, services, or information described or offered 
within them. We cannot guarantee that these links will work all of the time and 
we have no control over the availability of the linked pages.

Warranty
Avaya Inc. provides a limited warranty on this product. Refer to your sales 
agreement to establish the terms of the limited warranty. In addition, Avaya’s 
standard warranty language, as well as information regarding support for this 
product, while under warranty, is available through the following Web site:
http://www.avaya.com/support 

Copyright 
Except where expressly stated otherwise, the Product is protected by copyright 
and other laws respecting proprietary rights. Unauthorized reproduction, 
transfer, and or use can be a criminal, as well as a civil, offense under the 
applicable law.

Avaya support
Avaya provides a telephone number for you to use to report problems or to ask 
questions about your product. The support telephone number 
is 1-800-242-2121 in the United States. For additional support telephone 
numbers, see the Avaya Web site:
http://www.avaya.com/support 

http://www.avaya.com/support
http://www.avaya.com/support
http://www.avaya.com/support/


Issue 2 January 2008 3

Chapter 1: Introduction .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 5
Purpose.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  5
Intended Audience.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  5
Conventions Used in This Book  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  5
Support Resources  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  5

Avaya Technology and Consulting (ATAC)  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  6
Communications, Solutions, and Integration (CSI) Group 
of Software Services .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  6

Avaya Global Services Delivery (GSD) .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  7
Avaya Global Technical Services.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  7
Customized Management Solutions for Avaya Integrated Management.  .  .  .  7
Avaya Contact Information  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  8

Product Documentation .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  9
How to Access Books on the Web  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  9

Chapter 2: Overview.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 11
Enterprise Network Management with IP Office Manager   .  .  .  .  .  .  .  .  .  .  .  .  .  11
Pre-Installation Tasks  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  12
Ensure Browser Settings Allow Active Scripting  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  14

Chapter 3: Installing Enterprise Network Management .  .  .  .  .  .  .  .  .  . 15
Overview .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  15
Windows Server Requirements .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  16
Windows Client PC Requirements  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  18
Installing the Software   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  20
Opening the Firewall Between the Network Management
Console Server and a Remote Client PC  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  24

Uninstalling the Server Software .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  26

Chapter 4: Installing IP Office Manager Release 6.1   .  .  .  .  .  .  .  .  .  .  . 27
Overview .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  27
PC Requirements   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  28
Installing the Software.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  29

Contents



Contents

4 Enterprise Network Management with IP Office Manager Quick Start

Chapter 5: Preparing Your IP Office Network for Use with Enterprise Network 
Management  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 31

Overview .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  31
Step 1: Enable SNMP on the IP Office Devices  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  31
Step 2: Add IP Office Devices to Avaya Network Management Console.  .  .  .  .  .  32

Discover Devices Automatically  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  32
Add Devices Manually .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  33
Import a CSV File   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  33

Step 3: Configure the Access Parameters for IP Office Devices .  .  .  .  .  .  .  .  .  .  36
IP Office Devices Running Firmware Earlier Than 4.0.307  .  .  .  .  .  .  .  .  .  .  .  36

Step 1: Create Users .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  36
Step 2: Assign Users   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  37

IP Office Devices Running Firmware 4.0.307 or Later .  .  .  .  .  .  .  .  .  .  .  .  .  .  38
Step 1: Create Users .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  38
Step 2: Assign Users to IP Office Devices .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  39

Step 4: Upgrade the IP Office Devices Using 
Avaya Software Update Manager  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  40

Logging into Avaya Network Management Console   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  43

Chapter 6: Managing IP Office Devices  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 45
Overview .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  45
Accessing IP Office Systems .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  45
Backing Up the Configurations of all the IP Office Devices   .  .  .  .  .  .  .  .  .  .  .  .  46
Working with Templates.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  47

Create a General Template  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  48
Create a Hardware Template  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  49
Create an Auto Attendant Template  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  50
Create a Users Template   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  51
Distribute Templates   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  52

Working with Device Profiles .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  53
Create a Device Profile   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  53

Working with Groups  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  55
Create a Static Group  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  55
Create a Dynamic Group   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  56

Importing Licenses  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  58
Backing up Provisioning and Installation Manager Files .  .  .  .  .  .  .  .  .  .  .  .  .  .  59

Index  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  61



Issue 2 January 2008 5

 

Chapter 1: Introduction

Purpose
This book describes how to install and configure the Avaya Integrated Management, Enterprise 
Network Management offer for users who have only Avaya IP Office devices. 

Intended Audience
This book is written for system administrators who are responsible for 

● installing software on Windows servers and clients

● managing Avaya IP Office devices

Conventions Used in This Book
The following typographical conventions are used:

● Bold type is used to indicate information that you type, buttons in a window, and the Enter 
key on the keyboard. It is also used for emphasis.

● Courier font is used for any information that the computer screen displays. 

● Arrows indicate options that you select from cascading menus; for example, “Select File > 
Open” means choose the “Open” option from the “File” menu.

Support Resources
Avaya provides a variety of planning, consulting, and technical services. The following sections 
describe the resources and services that are available. 
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Avaya Technology and Consulting (ATAC)
Avaya Technology and Consulting (ATAC) works with client teams to develop detailed solutions 
for connectivity to Avaya Communication Manager solutions. The ATAC also designs network 
configurations.

Communications, Solutions, and Integration (CSI) Group 
of Software Services

Avaya Communications, Solutions, and Integration (CSI) Group of Software Services offers 
customers the following services:

● Platform readiness verification

● Remote implementation and installation

● Network management server configuration 

● Customer acceptance verification

● Custom on-site services

The CSI Group consists of the following two teams:

● Converged Solutions Implementation Engineering
The Converged Solutions Implementation Engineering (CSIE) team implements multi-site 
media gateway (G350/G450/G650/G700) deployment projects for both voice and data 
design. The overall direction of the CSIE team is to bring the correct methodology to these 
complex deployments that span various regions and to provide continuity to the overall 
project from the voice and data implementation standpoint.

● Data Network Implementation Engineering (formerly RNIS)
The Data Network Implementation Engineering team implements and/or upgrades existing 
or new data networks. This team analyzes the customer’s network design requirements and 
performance expectations, and then creates the hardware and software installation 
specification used to implement data devices including Cajun, VPN, Wireless LAN, Secure 
Gateways, Extreme, and multi-vendor data equipment.

The CSI Group provides support on a contract basis. You can purchase various implementation 
offers from the CSI Group in Tampa, Florida. See Table 1: Customer-Accessible Resources on 
page 8 for contact information.



Support Resources

Issue 2 January 2008 7

 

Avaya Global Services Delivery (GSD)
Avaya Global Services Delivery (GSD) provides support to the Avaya Integrated Management 
client teams, field technicians, and customers. GSD will bill customers for support on a time and 
materials basis if the following conditions exist:

● Customers do not provide remote access.

● Customers do not have a current maintenance agreement.

● Customers do not procure and install the required systems and software as defined in the 
Integrated Management Services Support Plan.

● Customers request support that is outside the purchase agreement.

GSD does not support hardware or software that customers purchase from third-party vendors.

Avaya Global Technical Services
Avaya Global Technical Services answers customer calls about products in Avaya Integrated 
Management. They will either answer your questions directly or connect you with an associate 
who can answer questions about the products.

Customized Management Solutions for Avaya Integrated 
Management

The Integrated Management Product Team understands customer’s needs and is focused on 
customer satisfaction. See Table 1: Customer-Accessible Resources on page 8 for contact 
information. The Product Team will assist customers with Avaya Integrated Management 
projects and will provide:

● Project Management — An Integrated Management project person will work with the 
customer to access configuration and customization requirements for any or all 
applications within each Avaya Integrated Management offer. If custom work is required, 
the evaluation will include a proposed statement of work and price. Note that this offer is 
not intended to provide installation for customers that choose to implement Integrated 
Management applications using Avaya Services or third-party implementation services.

● Training — Basic training can be performed remotely using an interactive medium to 
display the applications and a conference bridge for audio. On-site training can be 
customized to meet the customer’s needs. Customized training will focus on application 
functionality that is relevant to the customer and provide focused knowledge transfer to 
facilitate application-specific training. 
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Avaya Contact Information
Table 1 and Table 2 provide contact information that you may use if you need assistance during 
the process of installing and setting up Avaya Integrated Management. To access the links in 
Table 2, you must be able to access the Avaya intranet. 

Table 1: Customer-Accessible Resources

Resource Contact Information

Avaya Support Center http://www.avaya.com/support

Avaya Global 
Technical Services

+1 800 242-2121, extension 15921

Communications, 
Solutions, and 
Integration (CSI) 
Group of Software 
Services

+1 800 730-9108, prompt 3

Integrated 
Management Product 
Team

Send email to: AIMtraining@avaya.com

Toll Fraud Intervention +1 800 643-2353, prompt 1

Table 2: Avaya Internal Resources 

Resource Contact Information

Avaya System 
Management Support

http://aem-support.dr.avaya.com

Avaya Technology and 
Consulting (ATAC)

+1 888 297-4700, prompt 2,6
http://forum.avaya.com (requires a password)

Communications, 
Solutions, and 
Integration (CSI) 
Group of Software 
Services

http://associate2.avaya.com/sales_market/products/
data-implementation-services/

Integrated 
Management Services 
Support Plan

http://associate2.avaya.com/solution/support_plans/#Enterprise

http://www.avaya.com/support
http://aem-support.dr.avaya.com
http://forum.avaya.com
http://associate2.avaya.com/sales_market/products/data-implementation-services/
http://associate2.avaya.com/solution/support_plans/#Enterprise
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Product Documentation
The latest version of Avaya Integrated Management product documentation, including this 
book, is available from the Avaya Support Web Site. To view or download these books from the 
Web, you must have access to the Internet, an Internet browser, and Adobe Reader. Adobe 
Reader 7.0 is provided on the Enterprise Network Management CD and is also available from 
http://www.adobe.com. See How to Access Books on the Web for instructions on how to view or 
download these books.

How to Access Books on the Web
To view or download books from the Avaya Support Web Site, follow these steps:

1. Access http://www.avaya.com/support.

2. Click FIND DOCUMENTATION and TECHNICAL INFORMATION by PRODUCT NAME.

3. Click the letter I in the alphabet listing.

4. Locate the Integrated Management product or offer name and click the corresponding link.

5. Click View all documents to display a list of available books for that product or offer.

http://www.adobe.com
http://www.avaya.com/support
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Chapter 2: Overview

Enterprise Network Management with IP Office Manager
The Avaya Integrated Management Release 5.0 Enterprise Network Management offer allows 
you to administer and manage networks that contain Avaya IP Office systems, Avaya 
Communication Manager systems, and Avaya converged devices (such as gateways). This 
offer provides a complete converged solution that helps you manage your network through a 
common web-based user interface. The Network Management Console with System View 
provides the ability to see your whole voice system structure and hierarchy. 

Note:
Note: This document describes how to install and configure Avaya Integrated 

Management Release 5.0 Enterprise Network Management with IP Office 
Manager on networks that contain only Avaya IP Office devices. For instructions 
on how to install this offer on networks that also contain Avaya Communication 
Manager systems and Avaya converged devices, see the Avaya Integrated 
Management Release 5.0 Enterprise Network Management with IP Office 
Manager Installation and Upgrade, document number 14-601398.

The Enterprise Network Management CD contains the following applications that you will use to 
manage Avaya IP Office devices:

● Avaya Network Management Console with System View

● Avaya Secure Access Administration

● Avaya Software Update Manager

● Avaya IP Office Manager Release 6.1

● Avaya Provisioning and Installation Manager for IP Office

● COPSSH SCP Server (installed so that Avaya Software Update Manager can use this 
SCP server for secure file transfer)

● Avaya Integrated Management Launch Page (automatically installed when any Avaya 
Integrated Management application is installed)

Note:
Note: Avaya Network Management applications do not support devices that use 

Network Address Translation (NAT) addresses. Although Avaya Network 
Management Console may detect devices that are configured using NAT, some 
Network Management framework features are not available. However, IP Office 
devices behind a NAT server will be supported if the IP Office device is the only 
device that can access the network and be reachable from the network.
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For a full description of the applications provided in the Enterprise Network Management offer, 
see the Avaya Integrated Management Release 5.0 Overview, document number 14-601718.

Pre-Installation Tasks
Before installing Avaya Integrated Management products on the server, you must complete the 
following pre-installation tasks. 

Note:
Note: It is important to perform these tasks in the order provided to ensure the correct 

version of each application is installed. 

1. Check the minimum hardware and software requirements for the following.

● Windows server (see Windows Server Requirements on page 17).

● Windows client PC (see Windows Client PC Requirements on page 19).

2. For upgrade installations, check that all previous sequential upgrades and/or major 
releases of Avaya Integrated Management products were installed before installing this 
release. If the wizard detects a software upgrade that is not sequential, the wizard will stop 
and display a message to install the skipped releases. The wizard will then abort the 
installation. 

3. Uninstall Release 3.2 or earlier of the IP Office Administration Suite from the Windows 
server. If the installation wizard detects that the IP Office Administration Suite Release 3.2 
or earlier is installed on the server, the wizard will abort the installation. 

4. Carefully review Avaya Integrated Management Release 5.0 Implementation Guidelines, 
document number 14-601823. This document is available from the Avaya Support Web 
Site. (See How to Access Books on the Web on page 9.) This document describes server 
configuration requirements and provides pre-installation forms that must be completed 
before you begin installing the Avaya Integrated Management products. The pre-installation 
forms contain information that you will need to install the products, such as IP addresses, 
server domain names, and port addresses.
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5. If you want to access other applications from the Avaya Integrated Management Launch 
Page, you will need the IP addresses of the servers on which the following optional 
applications reside:

Note:
Note: If there are only IP Office systems in your network, you do not need to know the 

IP addresses of these applications. These applications are relevant only if there 
are Avaya Communication Manager systems in your network.

● Avaya Fault and Performance Manager

● Avaya MultiSite Administration

● Avaya Integrated Management Database

● Avaya VoIP Monitoring Manager

● Avaya SIP Enablement Services

● Motorola NSM

● Avaya easy Management

● Message Networking

● Modular Messaging

● Polycom GMS

● Extreme EpiCenter

6. Carefully review this entire book before you start the installations on the servers and client 
PCs. 

Note:
Note: If you are installing the Network Management applications on a Windows 2003 

server, ensure that the browser security settings are set to allow active scripting. 
See Ensure Browser Settings Allow Active Scripting on page 14.
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Ensure Browser Settings Allow Active Scripting
If you are installing Avaya Integrated Management Release 5.0 Enterprise Network 
Management with IP Office Manager on a Windows 2003 server, be sure the server’s browser 
security settings are set to allow active scripting. Active scripting must be enabled in order for all 
components in the Provisioning and Installation Manager for IP Office graphical user interface 
(GUI) to appear when you launch the application. 

To ensure browser settings are set to allow active scripting, follow these steps:

1. From the toolbar In your browser window, select Tools > Internet Options.

2. Click the Security tab, and then click the Custom Level button.

3. Scroll down to Scripting, and ensure Active Scripting is enabled.
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Chapter 3: Installing Enterprise Network 
Management

Overview
This chapter provides:

● the minimum hardware requirements for a Windows server 

● the minimum hardware requirements for a Windows client PC (if you want to use Avaya 
Integrated Management Release 5.0 Enterprise Network Management with IP Office 
remotely instead of sitting at the Windows server)

● the procedure to install Avaya Integrated Management Release 5.0 Enterprise Network 
Management with IP Office onto a Windows server. 
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Windows Server Requirements
Table 3 provides the minimum requirements for a Windows server. 

Table 3: Microsoft Windows Server Minimum Requirements 

Component Required Comments

Operating 
System

Microsoft Windows 2000 server with 
Service Pack 4,
Microsoft Windows XP Professional with 
Service Pack 2,
Microsoft Windows 2003 Standard Edition 
server with Service Pack 2,
Microsoft Windows 2003 Enterprise 
Edition server with Service Pack 2, 
Microsoft Windows Vista Business 
(32-bit and 64-bit editions), or
Microsoft Windows Vista Enterprise 
(32-bit and 64-bit editions)

NOTE:
You can install Enterprise Network 
Management on VMWare running one of 
the supported operating systems.

Only English operating 
systems are supported.

Enterprise Network 
Management cannot be 
installed on the same 
Windows server as VoIP 
Monitoring Manager.

Processor 3.0 GHz Pentium® 4 A maximum of two 
processors is supported.

Hard Drive 40 GB

Memory 2.0 GB RAM

Network 
Connectivity

TCP/IP 100 Mbit Network Card Only one network interface 
is supported. Dual network 
interface cards (NICs) or 
additional software 
network interfaces, such 
as a VPN interface, are not 
supported.

Modem 56K modem for remote access

CD-ROM Drive Required for installation.

Monitor SVGA 1024 X 768 display

1 of 2
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SNMP Agent The Simple Network Management 
Protocol (SNMP) Agent is the Windows 
Service that runs on your computer. It is 
provided with the Windows operating 
system CD. 

Extra Software Anti-virus software 
pcAnywhere 

Required for Avaya 
support.
pcAnywhere is required for 
remote access by Avaya 
Services.

Web Browser Internet Explorer 6.0 with Service Pack 1 
or Internet Explorer 7.0

Required for access to the 
Integrated Management 
Launch Page and 
web-based clients.

Table 3: Microsoft Windows Server Minimum Requirements  (continued)

Component Required Comments

2 of 2
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Windows Client PC Requirements
Once Enterprise Network Management is installed on the Windows server, you can access the 
applications from either the Windows server or a Windows client (remote) PC using a web 
browser. Table 4 provides the requirements for the client PC. 

Table 4: Microsoft Windows Client PC Minimum Requirements 

Component Required Comments

Operating 
system

Microsoft Windows 2000 Server with 
Service Pack 4,
Microsoft Windows 2000 Professional 
with Service Pack 4
Microsoft Windows XP Professional with 
Service Pack 2,
Microsoft Windows 2003 Standard Edition 
server with Service Pack 2,
Microsoft Windows 2003 Enterprise 
Edition server with Service Pack 2, 
Microsoft Windows Vista Business 
(32-bit and 64-bit editions), or
Microsoft Windows Vista Enterprise 
(32-bit and 64-bit editions)

Processor 1.5 GHz Pentium 

Hard Drive 40 GB Required to install all of the 
client components.

Memory 1 GB RAM

For Microsoft Windows Vista Business or 
Vista Enterprise operating systems, the 
minimum memory requirement is
2 GB RAM.

Monitor SVGA 1024 X 768 display

Network 
Connectivity

TCP/IP 10/100 Network Card

Modem 56K Modem May be required for remote 
access to the client PC.

CD-ROM Drive Required for installation.

1 of 2
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Other Software Internet Explorer 6.0 with Service Pack 1 
or Internet Explorer 7.0 and
Java Runtime Environment 1.5.0_11 
(Java Runtime Environment 1.5.0_11 is 
provided.)

Required to access the 
Integrated Management 
Launch Page and 
web-based clients. 

IP Office 
Manager

Release 6.1 Required to manage IP 
Office systems. 

Table 4: Microsoft Windows Client PC Minimum Requirements  (continued)

Component Required Comments

2 of 2
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Installing the Software 
Use this procedure to install the Enterprise Network Management with IP Office applications on 
a Windows server. Review the Pre-Installation Tasks on page 12 before beginning the 
installation.

Note:
Note: During the installation, COPSSH SCP server will be installed. If OpenSSH server 

is currently installed on the server, a dialog box will appear and prompt you to 
uninstall OpenSSH. If you click the Yes button in this dialog box, the installer will 
uninstall OpenSSH and then install COPSSH SCP server.

To install the software:

1. Ask all users to log off the system. 

2. Close all open windows and applications. 

3. Make sure that IP Office Administration Suite Release 3.2 or earlier is not installed on the 
server. If it is, uninstall it.

4. If you have IP Office Administration Suite Release 4.0, install it. 

5. Insert the Avaya Integrated Management Network Management 5.0 CD into the 
CD-ROM drive. 

The Avaya Integrated Management Network Management window appears. It provides the 
main menu.

Note:
Note: Install Acrobat Reader if it is not already installed on the computer. 

6. Click Install Network Management.
The Welcome dialog box appears.

7. Click the Next button. 

The License Agreement dialog box appears.

8. Read the license agreement. 

Note:
Note: You must accept the terms of the license agreement in order to continue with the 

installation.

9. If you accept the license agreement, click the I accept the terms of the license 
agreement option button, and then click the Next button.

The Choose Destination Location dialog box appears. By default, the files will be installed in 
c:\Program Files\Avaya.
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10. If you installed the IP Office Administration Suite, click the Change button, specify the folder 
where you installed the IP Office Administration Suite, and then click the OK button. 

Note:
Note: It is important that the destination folder specified here be the same as the 

destination folder specified for the IP Office Administration Suite installation (if 
installed).

11. Click the Next button.

The Setup Type dialog box appears.

12. Click the Avaya IP Office Only option button, and then click the Next button.

Depending on your configuration, one of the following dialog boxes appears:

● If IIS (Microsoft’s Web Server) is detected on the server, the IIS Installation Detected 
dialog box appears. Enter the new port number on which IIS should run, and then click 
the Next button. By default, the new port is 8989. The Apache Server Information dialog 
box appears. Go to Step 13.

● If IIS is not detected on the server, the Apache Server Information dialog box appears. 
Go to Step 13.

13. In the Domain box, enter the domain, 

14. In the Server box, enter the name of the server on which you are installing this software.

15. In the Admin box, enter the email address of the person to whom the system will send email 
messages if problems occur during the Apache installation.

16. Click the Next button.

The Enter IP Addresses dialog box appears.

17. Click the Next button.

The Enter IP Addresses dialog box appears.

18. Click the Next button.

The Enter IP Addresses dialog box appears.

19. Click the Next button.

The Enter IP Addresses dialog box appears.

20. Click the Next button.

The Enter IP Address dialog box appears.

21. Click the Next button.

The WebLM Port Information dialog box appears.
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22. Enter the port number that you want WebLM to use, and then click the Next button.

The SCP Server User Creation dialog box appears. You will use this dialog box to create a 
Windows user on the SCP server. Avaya Software Update Manager will use this Windows 
user to exchange files with devices in your network. This information is not used for IP 
Office devices.

By default, the installer generates a user name and password automatically. You can 
change the user name and password.

Note:
Note: Be sure to write down the user name and password.

23. If you want to change the automatically generated user name for SCP, enter the new user 
name in the Username box.

24. If you want to change the automatically generated password for SCP, enter the new 
password in the Password box. The password must consist of 8 to 16 alphanumeric 
characters and must contain at least one uppercase character, one lowercase character, 
and one numeric character.

25. Click the Next button.

A message box appears prompting you to write down the SCP username and password.

26. Click the OK button.

The Administrator Password dialog box appears.

27. In the Password box, enter the password for the Administrator login. You will use this 
password to log into the Avaya Integrated Management applications (such as Avaya 
Network Management Console, Avaya Software Update Manager, and Avaya Secure 
Access Administration).

This password must consist of at least 8 characters and must meet three of the following 
criteria:

● Contain at least one uppercase letter.

● Contain at least one lowercase letter.

● Contain at least one number.

● Contain at least one non-alphanumeric character (for example, #, %, or ^).

28. Re-enter the password in the Confirm Password box, and then click the Next button. 

One of the following appears:

● The Start Copying Files dialog box appears. Go to step 30.

● If the Windows firewall is activated, the Modifying Firewall dialog box appears. Go to step 
29. 
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29. Perform one of the following steps:

● If you want the installation program to modify the your firewall settings, click Let Setup 
modify the Firewall’s settings, and then click the Next button.

● If you do not want to make any changes to your firewall settings, click Do not make any 
changes, and then click the Next button.

The Start Copying Files dialog box appears.

30. Review the setup summary, and then click the Next button.

A message box appears showing the status of the installation. When the installation is 
complete, the welcome dialog box for the Avaya Enterprise Network Management 
Configuration Wizard appears. 

31. Click the Next button.

The Configure CM Servers dialog box appears. 

32. Click the Next button.

The Configure Global SNMP Parameters dialog box appears. 

33. Click the Next button.

The Configure Network Subnet to Discover dialog box appears.

34. Click the Next button.

The Configuration Complete dialog box appears.

35. Click the Finish button. 

The InstallShield Wizard Complete dialog box appears.

36. Remove the CD from the CD-ROM drive.

37. Click the Yes, I want to restart my computer now option button, and then click the Finish 
button. 

The computer reboots, and the network discovery begins automatically when the computer 
restarts. A dialog box appears stating that network discovery completed.

38. Ignore this dialog box and click the Close button.

Note:
Note: Regularly check the Avaya Support Web Site for software updates.

Go to Chapter 5: Preparing Your IP Office Network for Use with Enterprise Network 
Management on page 31 to configure the software.
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Opening the Firewall Between the Network Management
Console Server and a Remote Client PC

You are able to access the Network Management Console server from a remote client PC using 
an Internet browser. When there is a firewall between the Network Management Console server 
and the remote client PC, you must ensure that the ports required for the remote session are 
open. 

The client and server software communicate using Java Remote Method Invocation (RMI). For 
initial access to the server, the remote client PC must open an HTTP session on port 80 of the 
server. After the HTTP session is established, the client and server open bi-directional RMI 
sessions to enable interaction between Java applets running on the client and server. 

The ports that must be open for the bi-directional RMI sessions are listed in the cv.prop file, 
which is located in the installation directory. The default installation directory is C:\Program 
Files\Avaya\Network Management\private\gen on the server.

A sample cv.prop file is shown below. Note that the contents of the sample file may be different 
than that on your system. Review the cv.prop file on your server to determine the exact list of 
ports for your installation. RMI sessions work over TCP connections and the ports should be 
open for bi-directional traffic.
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Figure 1: Sample cv.prop File

Note:
Note: In order for changes to the cv.prop file to take effect, you must restart Avaya 

Services.

#web.server.protocol=http 
#web.server.port=80 
 
cv.jum.rmi.port=2843 
nm.web.protocol=http 
windows.snmptrap.port=162 
.rmiport.min=2900 
.rmiport.max=2950 
CMutil.socket.port=1980 
CMutil.process.max=2 
 
 
//cv.trap.port=2400 
cv.launcher.port=2401 
llm.clients.port=2402 
fileaccess.rmi.port=2403 
userver.rmi.port=2404 
llm.servers.port=2405 
userver.socket.port=2406 
service.smuserdb.port=2407 
service.snmpinfo.port=2408 
smon.rmi.port=2409 
nmlogin.local.port=2410 
nmlogin.remote.port=2411 
nmlogin.rmi.port=2412 
llm.fileaccess.port=2413 
cv.jre = ..\\jre\\ 
proxy.host= 
proxy.port= 
cv.jum.rmi.ip=149.49.138.142 
fileaccess.rmi.ip=149.49.138.142 
smServer.rmi.port=2500 
 
amServer.rmi.port=2330 
 
amProcess.rmi.port=2331 
 
llm.amClient.port=2332 
 
 
trapManipServer.rmi.port=6169
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Uninstalling the Server Software
Use this procedure to uninstall the Network Management applications and device managers 
from the Windows server.

1. Select Start > Control Panel.
The Control Panel window appears.

2. Click on Add or Remove Programs.
The Add or Remove Programs window appears.

3. Click on Avaya Integrated Management Network Management.
4. Click the Remove button.

A dialog box appears prompting you to confirm that you want to remove the applications.
5. Click the Yes button.

The Modifying Firewall dialog box appears. 

6. Select the appropriate option button, and then click the Next button.

You are prompted to uninstall Apache.
7. Click the Yes button.

If IIS is installed, you are prompted to set IIS back to port 80. Click the Yes button.
You are prompted to uninstall PostgreSQL.

8. Click the Yes button.
The status bar appears while files are uninstalled. When finished, the Uninstall Complete 
dialog box appears.

9. Click the Yes, I want to restart my computer now option button, and then click the Finish 
button.
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Chapter 4: Installing IP Office Manager Release 6.1

Overview
When Avaya Integrated Management Release 5.0 Enterprise Network Management with IP 
Office is installed onto a Windows server, Avaya IP Office Manager is installed automatically on 
that server. When you are working on the server, you can manage IP Office systems. However, 
if you want to manage IP Office systems remotely from a client PC, you must install IP Office 
Manager on that PC. This chapter provides the procedure to install Avaya IP Office Manager 
Release 6.1 onto a client PC.

Note:
Note: You must use the version of IP Office Manager Release 6.1 that is provided on 

the Avaya Integrated Management Launch page. 
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PC Requirements
Table 5 provides the requirements for a PC. 

Table 5: PC Requirements 

Component Required Comments

Operating system Microsoft Windows 2000 Server,
Microsoft Windows 2000 Professional,
Microsoft Windows XP Professional, or 
Microsoft Windows 2003 Server

Processor 1.5 GHz Pentium® 4 or equivalent

Hard Drive 40 GB Required to install all of 
the components.

Memory 512 MB RAM

Monitor SVGA 1024 X 768 display

Network Connectivity TCP/IP 10/100 Network Card

Web Browser Internet Explorer 6.0 Required to access the 
Integrated Management 
Launch Page and 
web-based clients. 
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Installing the Software 
Use this procedure to install Avaya IP Office Manager Release 6.1 onto a client PC.

1. Close all open windows and applications. 

2. Make sure that IP Office Administration Suite Release 3.2 or earlier is not installed on the 
PC. If it is, uninstall it.

3. Open your web browser and go to the Avaya Integrated Management Launch Products 
page.

4. Click on Avaya IP Office Manager 6.1.

The File Download - Security Warning dialog box appears.

5. Click the Save button.

6. Save the file IPOfficeManager.exe to your PC.

7. After the installer is downloaded to your PC, double-click on the file IPOfficeManager.exe.

The Welcome dialog box appears.

Note:
Note: If Microsoft .NET Framework 2.0 is not installed on the PC, the Microsoft .NET 

Framework 2.0 Setup dialog box appears. Follow the prompts to install this 
software. After Microsoft .NET Framework 2.0 is installed, click the Finish button. 
The Welcome dialog box appears. Go to Step 8.

8. Click the Next button. 

The Customer Information dialog box appears.

9. In the User Name box, enter the name of the person who will be using this software.

10. In the Organization box, enter the appropriate information.

11. Perform one of the following steps:

● If you want any user of this PC to be able to use Avaya IP Office Manager, click the 
Anyone who uses this computer (all users) option button.

● If you only want the user specified in the User Name box to user Avaya IP Office 
Manager, click the Only for me option button.

12. Click the Next button.

The Destination Folder dialog box appears. By default, the files will be installed in 
c:\Program Files\Avaya\IP Office.

13. If you want to change the default folder, click the Change button, specify the folder where 
you want to install the software, and then click the OK button. 
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14. Click the Next button.

The Custom Setup dialog box appears. 

15. Click the Next button.

The Ready to Install the Program dialog box appears. 

16. Click the Install button.

The software is installed. When the installation is complete, the InstallShield Wizard 
Completed message box appears.

17. If you want IP Office Manager to start automatically, click the Launch IP Office Manager 
check box.

18. Click the Finish button.
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Chapter 5: Preparing Your IP Office Network for Use 
with Enterprise Network Management

Overview
This chapter describes the tasks you should perform after installing Avaya Enterprise Network 
Management with IP Office. Initial configuration consists of the following steps:

1. Enable SNMP for each IP Office device.

2. Add IP Office devices to Avaya Network Management Console.

3. Configure access parameters for IP Office devices.

4. Upgrade the IP Office devices using Avaya Software Update Manager.

Step 1: Enable SNMP on the IP Office Devices
Before you can use Avaya Network Management Console to discover the IP Office devices 
automatically in your network, you must configure the community string in IP Office Manager for 
each IP Office device in your network. 

Note:
Note: If you have IP Office Release 2.1 or earlier, go to Step 2. SNMP is not supported 

in these releases.

Using IP Office Manager, perform the following steps for each IP Office device:

● Configure the SNMP community string and set the port to 161. 

● Enable trap destinations. Enter the IP address of the Windows server where Avaya 
Enterprise Network Management is installed, select all of the trap check boxes, set the 
port to 162, and configure the SNMP community string.
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Step 2: Add IP Office Devices to Avaya Network 
Management Console

Use this procedure to populate all of the IP Office devices in your network in Avaya Network 
Management Console. 

You can populate Avaya Network Management Console using the following methods:

● discover devices automatically

Use this method if your IP Office devices are accessible through the web and answer to 
SNMP.

● add devices manually

Use this method if you want to enter each IP Office device one at a time.

● import a CSV file

Use this method if your IP Office devices are accessible through the web, but do not answer 
to SNMP. (You can ping or access these devices via IP Office Manager.) 

Discover Devices Automatically

Use this procedure if your IP Office devices are accessible through the web and answer to 
SNMP.

To discover IP Office devices automatically, perform the following steps:

1. Log into Network Management Console. See Logging into Avaya Network Management 
Console on page 43.

2. Select Actions>IP Discovery. 

The Discovery window appears.

Note:
Note: If IP Discovery is disabled, select Actions>Get Write Permission. After the 

Write Permission Request dialog box closes, repeat Step 2.

3. Select Edit>Add. 

The Add New Subnet dialog box appears. 

4. In the Subnet IP box, enter the IP address of the subnet you want to add.

5. In the Subnet Mask box, enter the subnet mask.

6. Click Apply.

7. Click Close.

8. Repeat Steps 3 through 7 to add more subnets. When finished, go to Step 9.
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9. Select Actions>Start Network Discovery.

A progress bar appears displaying the progress of the discovery process. When the 
process is complete, the devices appear in the left panel.

Add Devices Manually

If your IP Office devices answer to SNMP and you want to discover them manually, perform the 
following steps:

1. Log into Network Management Console. See Logging into Avaya Network Management 
Console on page 43.

2. Select File>New>Device. 

The Add Device dialog box appears. The Basic Information tab is selected.

3. Enter the parameters for the IP Office device.

4. Click the SNMP Access tab.

5. Enter the SNMP parameters for the IP Office device.

6. When finished, click Apply.

The device is added to the Network Map. 

7. Click Close.

8. Repeat Steps 2 through 7 for each IP Office device you want to add.

Import a CSV File

If your IP Office devices are accessible through the web, but do not answer to SNMP, you must 
import a CSV file into Avaya Network Management Console. This CSV file must contain the 
following information for each IP Office device in your network:

● type

● IP address

● subnet mask

● MAC address

● name

● read community string

● write community string

● timeout interval

● retry interval

Table 6 describes the fields in each record of the CSV file.
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Table 6: CSV Import File Fields

Table 7: sysObjectIDs of Supported IP Office Devices

Field Description

Type The sysObjectID of the IP Office device. Table 7 
shows the sysObjectIDs of the supported IP 
Office devices.

IP The IP address of the IP Office device.

Mask The IP subnet mask of the IP Office device.

MAC The MAC address of the IP Office device.

Name The name of the IP Office device.

Read Community The read community string of the IP Office 
device.

Write Community The write community string of the IP Office 
device.

Timeout The number of milliseconds an application will 
poll the IP Office device without receiving a 
response before timing out. The recommended 
value is 5000 ms.

Retry The number of times an application will poll the 
IP Office device without receiving a response 
before timing out. The recommended value is 2.

Device Symbol ID SysObjectID

IP406-V2 IPOFFICE_406V2 1.3.6.1.4.1.6889.1.2.1.7.3

Small Office 2T+4A SMALL_OFFICE_4A 1.3.6.1.4.1.6889.1.2.1.5.1

Small Office 4T+8A SMALL_OFFICE_8A 1.3.6.1.4.1.6889.1.2.1.5.2

Small Office 4T+4A+8DS SMALL_OFFICE_8D 1.3.6.1.4.1.6889.1.2.1.5.4 

IP412 IPOFFICE_412 1.3.6.1.4.1.6889.1.2.1.4.1
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Figure 2 shows a sample CSV file that contains 15 IP Office devices.

Figure 2: Sample CSV File
##################################################################
# Avaya Map Export File 
# Map name: default.nrf 
# Created: Mar 7 2007 6:05:35 PM
# Copyright 2007 Avaya Inc. All Rights Reserved.
####################################################################
# Type,IP,Mask,MAC,Name,Read Community,Write Community,Timeout,Retry
.1.3.6.1.4.1.6889.1.2.1.7.3,149.49.78.101,255.255.255.0,00:e0:07:02:1e:f1,ITC_IPO_UNIT101,public,public,5000,2
.1.3.6.1.4.1.6889.1.2.1.7.3,149.49.78.99,255.255.255.0,00:e0:07:02:1e:f2,ITC_IPO_UNIT99,public,public,5000,2
.1.3.6.1.4.1.6889.1.2.1.5.4,149.49.78.97,255.255.255.0,00:e0:07:02:61:ba,ETC_IPO_UNIT97,public,public,5000,2
.1.3.6.1.4.1.6889.1.2.1.5.4,149.49.78.93,255.255.255.0,00:e0:07:01:fc:2e,ITC_IPO_UNIT93,public,public,5000,2
.1.3.6.1.4.1.6889.1.2.1.4.1,149.49.78.92,255.255.255.0,00:e0:07:02:60:df,ETC_IPO_UNIT92,public,public,5000,2
.1.3.6.1.4.1.6889.1.2.1.5.4,149.49.78.91,255.255.255.0,00:e0:07:02:68:0b,ETC_IPO_UNIT91,public,public,5000,2
.1.3.6.1.4.1.6889.1.2.1.4.1,149.49.78.130,255.255.255.0,00:e0:07:02:60:d4,ITC_IPO_UNIT130,public,public,5000,2
.1.3.6.1.4.1.6889.1.2.1.7.3,149.49.78.224,255.255.255.0,00:e0:07:02:32:38,ITC_IPO_UNIT224,public,public,5000,2
.1.3.6.1.4.1.6889.1.2.1.7.3,149.49.78.223,255.255.255.0,00:e0:07:02:1e:ef,ETC_IPO_UNIT223,public,public,5000,2
.1.3.6.1.4.1.6889.1.2.1.7.3,149.49.78.222,255.255.255.0,00:e0:07:02:2b:69,ITC_IPO_UNIT222,public,public,5000,2
.1.3.6.1.4.1.6889.1.2.1.7.3,149.49.78.124,255.255.255.0,00:e0:07:02:33:35,ITC_IPO_UNIT124,public,public,5000,2
.1.3.6.1.4.1.6889.1.2.1.7.3,149.49.78.122,255.255.255.0,00:e0:07:02:2b:b4,ETC_IPO_UNIT122,public,public,5000,2
.1.3.6.1.4.1.6889.1.2.1.7.3,149.49.78.13,255.255.255.0,00:e0:07:02:33:41,ITC_IPO_UNIT13,public,public,5000,2
.1.3.6.1.4.1.6889.1.2.1.7.3,149.49.78.114,255.255.255.0,00:e0:07:02:33:39,ITC_IPO_UNIT114,public,public,5000,2
.1.3.6.1.4.1.6889.1.2.1.7.3,149.49.78.112,255.255.255.0,00:e0:07:02:32:3a,ITC_IPO_UNIT112,public,public,5000,2

To import a CSV file, perform the following steps:

1. Log into Network Management Console. See Logging into Avaya Network Management 
Console on page 43.

2. Select File>Import map.

The Import Map dialog box appears.

3. Select the CSV file you want to import, and then click Open.

The devices in the CSV file are imported into the current Network Map. The devices appear 
in the Device Type View and the Subnet View.
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Step 3: Configure the Access Parameters for IP Office 
Devices

You must provide user names and passwords to the Avaya Enterprise Network Management 
server to access IP Office devices. These user names and passwords must match the security 
administrator name and password in the IP Office device. 

In this section, you will:

1. Create a new IP Office User in Avaya Secure Access Administration. 

This IP Office user and password must match the IP Office security administrator name and 
password. There can be only one IP Office user per IP Office device in Avaya Secure 
Access Administration. For more information about IP Office security administration, see the 
IP Office documentation.

Once you assign an Avaya Secure Access Administration IP Office User, Avaya Secure 
Access Administration will create a user (AIMAdmin) who has complete administration 
capabilities. 

2. Assign the IP Office User to IP Office devices.

The steps you perform depend on the firmware release of the IP Office device.

IP Office Devices Running Firmware Earlier Than 4.0.307
If any of the IP Office devices are running firmware earlier than 4.0.307, perform the procedures 
in this section.

Step 1: Create Users

Perform the following steps:

1. From the Avaya Network Management Console window, select Actions>Avaya Secure 
Access Administration.

The Avaya Secure Access Administration window appears.

2. Select Action>New>New IP Office User.
The New IP Office User dialog box appears.

3. In the Name box, enter the name for the IP Office User. This user and password will be 
used only after you upgrade the IP Office device to version 4.0.307 or later. 

4. In the Password box, enter the password for this user. This password must match the 
password of the Security Administrator as currently configured in the IP Office system. This 
password will only be used after you upgrade.
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5. In the Confirm Password box, reenter the password for this user.

6. In the TFTP Password box, enter the TFTP password for the IP Office device being 
administered. This password must match the system password for the IP Office device. This 
password will be used to upgrade the IP Office device.

7. In the Confirm TFTP Password box, reenter the TFTP password.

8. Click Apply.

The Secure Access Administration IP Office User is added.

9. Click Close.

Step 2: Assign Users

In this section, you will use Avaya Secure Access Administration to map the IP Office system 
password to the IP Office devices.

Perform the following steps:

1. Select Action>Assign Users to IP Office Devices.

The Assign IP Office Security Administration dialog box appears.

2. Select all of the IP Office devices running firmware earlier than 4.0.307.

3. From the User Name box, select the user you just created in the previous section.

4. From the Select Action Type box, select Don’t synchronize with devices.

! Important:
Important: You must select Don’t synchronize with devices.

5. Click Apply.

6. Click Close.

7. At this point, you must use Avaya Software Update Manager to upgrade your IP Office 
devices. Go to Step 4: Upgrade the IP Office Devices Using Avaya Software Update 
Manager on page 40. Avaya Software Update Manager will use the TFTP password for 
each IP Office device. After you upgrade your IP Office devices, go to Step 8.

8. After you upgrade the IP Office devices with Avaya Software Update Manager, open Avaya 
Secure Access Administration.

9. Select Action>Assign Users to IP Office Devices.

The Assign IP Office Security Administration dialog box appears.

10. Select all of the IP Office devices that were running firmware earlier than 4.0.307.

11. From the User Name box, select the user you created in the previous section.

12. From the Select Action Type box, select Apply All.



Preparing Your IP Office Network for Use with Enterprise Network Management

38 Enterprise Network Management with IP Office Manager Quick Start

 

13. Click Apply.

Avaya Secure Access Administration will try to contact the IP Office devices, change the 
TFTP password on each device, and define a service user called AIMAdmin.

Note:
Note: The AIMAdmin password is common to all IP Office devices. You can change this 

password using File>Options in Avaya Secure Access Administration.

14. Click Close.

15. Close Avaya Secure Access Administration.

IP Office Devices Running Firmware 4.0.307 or Later
If any of the IP Office devices are running firmware 4.0.307 or later, perform the procedures in 
this section.

Step 1: Create Users

Perform the following steps:

1. From the Network Management Console window, select Actions>Avaya Secure Access 
Administration.

The Avaya Secure Access Administration window appears.

2. Select Action>New>New IP Office User.
The New IP Office User dialog box appears.

3. In the Name box, enter the name for the IP Office User. This name must match the name of 
the Security Administrator of the IP Office device to which this user will be assigned.

4. In the Password box, enter the password for this user. This password must match the 
password of the Security Administrator as currently configured in the IP Office system.

5. In the Confirm Password box, reenter the password for this user.

6. In the TFTP Password box, enter the TFTP password for the IP Office devices being 
administered. After the user is assigned to the IP Office device, Avaya Secure Access 
Administration will change the TFTP password. (The TFTP password is referred to as the 
System password in the IP Office device.)

7. In the Confirm TFTP Password box, reenter the TFTP password.

8. Click Apply.

The Secure Access Administration IP Office User is added.

9. Click Close.
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Step 2: Assign Users to IP Office Devices

Perform the following steps:

1. Select Action>Assign Users to IP Office Devices.

The Assign IP Office Security Administration dialog box appears.

2. Select all of the IP Office devices running firmware 4.0.307 or later that you want to assign 
to an IP Office user.

3. From the User Name box, select the user you just created in the previous section.

4. From the Select Action Type box, select Apply changes.

5. Click Apply.

Avaya Secure Access Administration will try to contact the IP Office devices and change the 
TFTP password on each device and define a service user called AIMAdmin.

Note:
Note: The AIMAdmin password is common to all IP Office devices. You can change this 

password from File>Options in Avaya Secure Access Administration.

6. Click Close.

7. Close Avaya Secure Access Administration.
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Step 4: Upgrade the IP Office Devices Using 
Avaya Software Update Manager

In this section, you will start Avaya Software Update Manager and update all of the IP Office 
devices. 

! Important:
Important: For Avaya Software Update Manager to update IP Office devices, the IP Office 

devices must be assigned to an IP Office user in Avaya Secure Access 
Administration. 

Perform the following steps to upgrade the IP Office devices:

1. From the Avaya Network Management Console window, select Tools>Avaya Software 
Update Manager.
Avaya Software Update Manager automatically attempts to connect to the Avaya Support 
web site. If Avaya Software Update Manager connects to the Avaya Support web site, the 
Avaya Software Update Manager window appears and displays the Targets table in the 
Download View tab. The Targets Table displays a status icon for each managed device to 
indicate the status of the software currently running on the associated device. This status 
icon also indicates whether an upgrade or update is available. Go to Step 2.

If Avaya Software Update Manager does not connect to the Avaya Support web site, an 
error message box appears stating that the web site is unreachable. Click the OK button. 
You must configure the proxy server. Perform the following steps:

a. Close Avaya Software Update Manager.

b. Exit Avaya Network Management Console.

c. Using Windows Explorer, right click on the file cv.prop, which is located in C:\Program 
Files\Avaya\Network Management\private\gen. Note that C:\Program Files\Avaya\
Network Management is the default installation directory for Avaya Network 
Management. 

cv.prop is the properties file that contains the Internet proxy server settings for Avaya 
Software Update Manager. By default, these settings are blank. 

d. Select Open with Notepad.

The Notepad window appears and displays the contents of the selected file.

e. At the end of the line containing proxy.host=, enter the IP address or DNS name for the 
web proxy server.

f. At the end of the line containing proxy.port=, enter the TCP listening port used by the 
web proxy server.

g. Select File>Save.
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h. Select File>Exit.
At this point, you must stop and restart the Avaya Network Management Server 
application for the changes to the properties file to take effect.

i. From the Start menu on the server, select All Programs>Avaya>Network 
Management>Stop Avaya Network Management Server. 

j. From the Start menu on the server, select All Programs>Avaya>Network>Start Avaya 
Network Management Server.

k. Log into Avaya Network Management Console, and then go to Step 1.

2. Select Actions>Download Targets Detection.

The Download Targets Detection dialog box appears.

3. Select the Detect using filter option button.

4. In the Product Filter area, select the IP Office devices you want to update.

5. Click OK.

A warning dialog box appears.

6. Click Continue.

A message box appears stating that Avaya Software Update Manager will update the 
Download View table.

7. Click OK.

All of the current information (software version and firmware version) for the discovered 
devices in Avaya Network Management Console is displayed.

8. Select Tools>Image Analyzer.
Avaya Software Update Manager connects to the Avaya Support web site and compares 
the firmware on your IP Office devices with the current IP Office firmware available on the 
web site. Avaya Software Update Manager then displays a status icon in front of each IP 
Office device:

● If the icon is red, the device does not have the latest version of the firmware, and you do 
not have the latest version on your server.

● If the icon is yellow, the device does not have the latest version of the firmware, but you 
have the latest version on your server.

● If the icon is green, the device has the latest version of the firmware.

● If the icon is purple, the associated device is an expansion module that has the latest 
version of the firmware.

9. Select the IP Office devices that have red status icons.

10. Select Tools>Retrieve From the Web.

A dialog box appears.
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11. Click OK.

The files are downloaded to your server.

12. Select Tools>Image Analyzer.
All of the red status icons will turn yellow, indicating that the latest firmware versions are 
now on your server.

13. Select the devices you want to update.

14. Select Actions>Download Now.

The selected IP Office devices are updated. 

15. After all of the devices have been updated successfully (see the Current Version column), 
select Tools>Image Analyzer. 
All of the status icons should be green or purple.

Go to Chapter 6: Managing IP Office Devices on page 45 to start managing the IP Office 
devices from Avaya Network Management Console.
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Logging into Avaya Network Management Console
You can log into Avaya Network Management Console locally on the Windows server or 
remotely on a client PC using a web browser.

Note:
Note: If you use a client PC, that PC must be able to access the Windows server and 

have Avaya IP Office Manager Release 6.1 installed if you want to administer IP 
Office devices. See the Avaya Integrated Management Release 5.0 Enterprise 
Network Management with IP Office Manager Installation and Upgrade, 
document number 14-601398, to install Avaya IP Office Manager Release 6.1 on 
a client PC.

To log into Avaya Network Management Console, perform one of the following steps:

● If you are logged into the server where the Avaya Integrated Management applications are 
installed, perform the following steps:

a. Double-click the Windows desktop shortcut to the Avaya Integrated Management Launch 
Products page. 

The Avaya Integrated Management Launch Products page appears.

b. Click the link for Network Management Console. 

The Login dialog box appears. It prompts you for the user name and password you 
specified during installation.

c. In the User Name box, enter your user name.

d. In the Password box, enter your password, and click the Login button.

The Avaya Network Management Console window appears.

● If you are at a remote PC, perform the following steps:

a. Open Internet Explorer.

b. Enter the IP address of the server where the Avaya Integrated Management applications 
are installed, and then press Enter.
The Avaya Integrated Management Launch Products page appears.

c. Click the link for Network Management Console. 

The Login dialog box appears. It prompts you for the user name and password you 
specified during installation.

d. In the User Name box, enter your user name.

e. In the Password box, enter your password, and click the Login button.

The Avaya Network Management Console window appears.
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Chapter 6: Managing IP Office Devices

Overview
This chapter provides procedures for managing your IP Office devices from Avaya Network 
Management Console. 

Accessing IP Office Systems
Avaya Network Management Console shows the connected and registered endpoints 
associated with each of your IP Office devices. From the Avaya Network Management Console 
window, you can:

● view all ports in the network

● quickly locate a station by user name, extension, or IP address

● view the status of each device on your network.

● use Event Manager to view a historical log of all traps received from the devices on your 
network. You can also configure Event Manager to send you an email message, run a 
script, or play a WAV file when certain events occur.

● use Avaya Software Update Manager to retrieve the latest firmware versions from the 
Avaya Support web site and update the following devices in your network:

- control units

- expansion units

- VCM and slide-in modules

- license dongles 

Using the Job Scheduler, you can set

- the devices for which you want Avaya Software Update Manager to retrieve the latest 
firmware version

- when you want Avaya Software Update Manager to retrieve the latest firmware version 
for the selected devices

You can launch IP Office Manager for a specific IP Office device by double-clicking on the 
associated IP Office icon on the map in the Avaya Network Management Console window.
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Backing Up the Configurations of all the IP Office Devices
You should back up the configurations of all your IP Office devices before making any 
configuration changes. 

To back up the configurations of all the IP Office devices, perform the following steps:

1. From the Avaya Network Management Console window, select Tools>Avaya Provisioning 
and Installation Manager For IPO Devices.

The Provisioning and Installation Manager window appears.

2. Click the Device Profiles folder in the left panel.

The Device Profiles page appears.

3. Click Backup.

The General dialog box appears. The Job Name box displays a default name for this back 
up job. You can change this name.

4. In the Notes box, enter any notes about this backup job.

5. Click Next.
The Device Filter dialog box appears. From this dialog box, you can specify whether you 
want to back up all devices or a subset of devices. 

6. Select the All devices option button.

7. Click Next.
The Devices dialog box appears. The Available Devices list box shows all of the available 
devices.

8. Click >> to back up all the devices.

The selected devices appear in the Selected Devices box.

9. Click Next.
The Schedule dialog box appears. From this dialog box, you can set the back up to be 
performed now or at a later time. 

10. Select the Run now option button, and then click Next.
The Summary dialog box appears.

11. Click Next to start the back up.

A progress dialog box appears. When the back up is complete, the Finish Up dialog box 
appears. 

12. Click the Finish button.

13. Click the Jobs folder in the left panel to determine whether the back up was successful.
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Working with Templates
You can create and use templates to manage and maintain branches that have similar 
configurations. With templates, you can make your changes in one file and then propagate this 
file to a group of branches. 

Note:
Note: To create templates, IP Office Manager must be installed on the PC you are 

using.

When you create a template, you can specify configuration parameters manually. You can 
create the following templates:

● General
General templates contain the following information:

- account codes

- time profiles

- firewall profiles

- directories

- automatic route selection (ARS)

● Hardware
Hardware templates contain the following information:

- hardware configuration (control unit and expansion modules)

- short codes

- system parameters (LAN/WAN IP addresses, SNMP configuration, alarm notifications, 
and basic telephony parameters)

- line/trunk settings

- E911

- extensions

- wireless parameters (Small Office only)

● Auto Attendant
Auto Attendant templates contain the following information:

- time profiles

- short codes

- incoming call routes
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- associations of WAV files from the Voice Files library to time profiles. Avaya Provisioning 
and Installation Manager for IP Office enables you to upload WAV files from PCs to the 
Voice Files library. (You manage the Voice Files library from Avaya Provisioning and 
Installation Manager for IP Office.)

● Users
Users templates contain the following information:

- users and extensions

- hunt groups

- time profiles

- firewall profiles

- incoming call routes

- user rights. User rights is a template within a template. With user rights, you can define 
classes of users and associate defaults for the following settings in each class:

● short codes

● basic telephony parameters

● button programming

● Phone Manager

Create a General Template
To create a General template, perform the following steps:

1. From the Avaya Network Management Console window, select Tools>Avaya Provisioning 
and Installation Manager For IPO Devices.

The Provisioning and Installation Manager window appears.

2. Click Templates at the top of the window.

The Select Template Type wizard appears.

3. From the IPO Templates box, select the IPO-General option button, and then click Next.
The General dialog box appears.

4. In the Name box, enter the name for this template.

5. in the Notes box, enter any notes.

6. Click Next.
IPO Manager dialog box appears, and IP Office Manager starts in template mode. The IP 
Office Manager window appears.
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7. Using IP Office Manager, complete the General template. Use the online help for more 
information about the General template.

8. When you are finished creating the General template in IP Office Manager, select 
File>Save Template and Exit.
The IP Office Manager window closes, and the Summary dialog box appears.

9. Click Next.
The Finish Up dialog box appears.

10. Click Finish.

Create a Hardware Template
To create a Hardware template, perform the following steps:

1. From the Avaya Network Management Console window, select Tools>Avaya Provisioning 
and Installation Manager For IPO Devices.

The Provisioning and Installation Manager window appears.

2. Click Templates at the top of the window.

The Select Template Type wizard appears.

3. From the IPO Templates box, select the IPO-Hardware option button, and then click Next.
The General dialog box appears.

4. In the Name box, enter the name for this template.

5. in the Notes box, enter any notes.

6. Click Next.
The IPO Manager dialog box appears, and IP Office Manager starts in template mode. The 
Create Offline Configuration Wizard dialog box appears.

7. Complete each dialog box in the wizard. Click the Help button for information about the 
dialog box.

After you complete the Create Offline Configuration Wizard, the IP Office Manager window 
appears.

8. Using IP Office Manager, complete the Hardware template. Use the online help for more 
information about the Hardware template.

9. When you are finished creating the Hardware template in IP Office Manager, select 
File>Save Template and Exit.
The IP Office Manager window closes, and the Summary dialog box appears.
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10. Click Next.
The Finish Up dialog box appears.

11. Click Finish.

Create an Auto Attendant Template
Before creating an Auto Attendant template, you must upload the Auto Attendant voice files 
(WAV files) to Provisioning and Installation Manager for IP Office. To upload voice files, perform 
the following steps:

1. From the Avaya Network Management Console window, select Tools>Avaya Provisioning 
and Installation Manager For IPO Devices.

The Provisioning and Installation Manager window appears.

2. Click + in front of the Administration folder in the left panel of the window.

The Administration options appear.

3. Click Voice Files.

The Voice Files List page appears and lists all of the WAV files in Provisioning and 
Installation Manager for IP Office.

4. Click Add.

The PIM - Upload Voice File dialog box appears.

5. Using the Browse button, select the WAV file you want to upload to Provisioning and 
Installation Manager for IP Office.

6. Click Upload file.

7. Repeat Steps 2 through 6 for any other WAV files you want to upload to Provisioning and 
Installation Manager for IP Office.

To create an Auto Attendant template, perform the following steps:

1. From the Avaya Network Management Console window, select Tools>Avaya Provisioning 
and Installation Manager For IPO Devices.

The Provisioning and Installation Manager window appears.

2. Click Templates at the top of the window.

The Select Template Type wizard appears.

3. From the IPO Templates box, select the IPO-Auto Attendants option button, and then click 
Next.
The General dialog box appears.

4. In the Name box, enter the name for this template.

5. in the Notes box, enter any notes.
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6. Click Next.
The IPO Manager dialog box appears, and IP Office Manager starts in template mode. The 
IP Office Manager window appears.

7. Using IP Office Manager, complete the Auto Attendant template. Use the online help for 
more information about the Auto Attendant template.

8. When you are finished creating the Auto Attendant template in IP Office Manager, select 
File>Save Template and Exit.
The IP Office Manager window closes, and the Summary dialog box appears.

9. Click Next.
The Finish Up dialog box appears.

10. Click Finish.

Create a Users Template
To create a Users template, perform the following steps:

1. From the Avaya Network Management Console window, select Tools>Avaya Provisioning 
and Installation Manager For IPO Devices.

The Provisioning and Installation Manager window appears.

2. Click Templates at the top of the window.

The Select Template Type wizard appears.

3. From the IPO Templates box, select the IPO-Users option button, and then click Next.
The General dialog box appears.

4. In the Name box, enter the name for this template.

5. in the Notes box, enter any notes.

6. Click Next.
The IPO Manager dialog box appears, and IP Office Manager starts in template mode. The 
IP Office Manager window appears.

7. Using IP Office Manager, complete the Users template. Use the online help for more 
information about the Users template.

8. When you are finished creating the Users template in IP Office Manager, select File>Save 
Template and Exit.
The IP Office Manager window closes, and the Summary dialog box appears.
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9. Click Next.
The Finish Up dialog box appears.

10. Click Finish.

Distribute Templates
To distribute templates, perform the following steps:

1. From the Avaya Network Management Console window, select Tools>Avaya Provisioning 
and Installation Manager For IPO Devices.

The Provisioning and Installation Manager window appears.

2. Click the Templates folder in the left panel of the window.

The Templates page appears and displays the existing templates.

3. Click the option button of the template you want to distribute.

4. Click Job at the top of the window.

The General dialog box appears. A default name is provided for this job. You can change 
the job name.

5. Enter any notes.

6. Click the Save The Job check box if you want to save this job so you can use it at a later 
time.

7. Click Next.
The Device Filter dialog box appears. 

8. Select the devices you want to configure with the selected template, and then click Next.
The Devices dialog box appears.

9. From the Available list box, select the device(s) you want to configure with the selected 
template, and then click >. The selected devices appear in the Selected list box.

If you want to select all of the devices from the Available list box, click >>.

10. Click Next.
The Schedule dialog box appears.

11. Specify when you want to run this job, and then click Next.
The Job Options dialog box appears.

12. Specify how you want to run this job, and then click Next.
The Summary dialog box appears.
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13. Click Next.
The job is created, and the Finish Up dialog box appears.

14. Click Finish.

The job runs at the time you specified.

Working with Device Profiles
When Avaya Network Management Console discovers an IP Office device, it automatically 
creates a device profile. The device profile contains the following information:

● the name of the device

● the IP address of the device

● the type of device

● any notes entered about the device

● the Feature License Key data of the device

You may associate a device profile with existing templates (that is, General, Hardware, Auto 
Attendant, and Users).

Create a Device Profile
When you create a device profile, you can enter the IP address manually or select it from the 
Avaya Network Management Console. You can create a profile for the following devices:

● IP406-V2

● IP412

● Small Office 2T+4A

● Small Office 4T+8A

● Small Office 4T+4A+8DS

To create a device profile, perform the following steps:

1. From the Avaya Network Management Console window, select Tools>Avaya Provisioning 
and Installation Manager For IPO Devices.

The Provisioning and Installation Manager window appears.

2. Click Profiles at the top of the window.

The Device Profile Wizard dialog box appears.
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3. Make sure the IPO device option button is selected, and then click Next.
The Device Profile Wizard dialog box appears.

4. Perform one of the following steps:

● If you want to enter the IP address manually:

a. Click the Enter manually option button, and then click Next.
The Device Type dialog box appears.

b. Select the device type for which you want to create a profile, and then click Next.
The Profile Details dialog box appears.

c. Enter the appropriate information for the selected device, and then click Next.
The Template Associations dialog box appears.

d. Go to Step 5.

● If you want to select a device from Avaya Network Management Console:

a. Click the Select a device from NMC option button, and then click Next.
The IP Address Filter dialog box appears.

b. Enter the IP address of the device for which you want to create a profile or specify the 
filter criteria from which you want to select the IP address.

c. Click Next.
The IP Address dialog box appears.

4. Select the IP address of the device, and then click Next.
The Device Details dialog box appears and shows the name, type, and IP address of 
the selected device.

e. Click Next.
The Template Associations dialog box appears.

f. Go to Step 5.

5. If you want to associate a template type with this device profile, click the check box for the 
appropriate template type, and then select the appropriate template from the template 
selection drop-down list box.

6. Repeat Step 5 for each template type you want to associate with this device profile.

7. When finished associating templates, click Next.
The Licenses dialog box appears.

8. Enter the licenses for the device, and then click Next.
The Summary dialog box appears.
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9. Click Next.
The device profile is created, and the Finish Up dialog box appears.

10. Click Finish.

Working with Groups
A group is a collection of devices and is used in conjunction with templates to make it easy for 
you to change multiple devices at a time. There are two types of groups:

● Static group

A static group enables you to manage your branch offices logically. You can create static 
groups according to arbitrary criteria such as geographic location, device type, and type 
and/or size of the branch office.

● Dynamic group

A dynamic group enables you to select specific branch offices by building a query. You build 
a logical expression combining static groups that are manually administered. For example, 
if you choose AND, only the devices that are in both groups will be selected for the dynamic 
group. If you choose OR, all of the devices in both groups will be selected for the dynamic 
group.

Create a Static Group
To create a static group, perform the following steps:

1. From the Avaya Network Management Console window, select Tools>Avaya Provisioning 
and Installation Manager For IPO Devices.

The Provisioning and Installation Manager window appears.

2. Click Groups at the top of the window.

The Select Group Type dialog box appears.

3. Select the Static Group option button, and then click Next.
The General Information page appears.

4. In the Name box, enter the name for this group.

5. In the Notes box, enter any notes for this group.

6. Click Next.
The Filter dialog box appears.
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7. Select the criteria you want to use to filter the eligible devices for this group. For example, if 
you are only interested in IP Office devices on a specific subnet, select that subnet from the 
Subnet box.

8. Click Next.
The Select Devices dialog box appears.

9. From the Available list box, select the device(s) you want to add to the group, and then click 
>. The selected devices appear in the Selected list box.

If you want to select all of the devices from the Available list box, click >>.

10. Click Next.
The Summary dialog box appears.

11. Click Next.
The static group is created, and the Finish Up dialog box appears.

12. Click Finish.

Create a Dynamic Group
Before you can create a dynamic group, you must have already created static groups.

To create a dynamic group, perform the following steps:

1. From the Avaya Network Management Console window, select Tools>Avaya Provisioning 
and Installation Manager For IPO Devices.

The Provisioning and Installation Manager window appears.

2. Click Groups at the top of the window.

The Select Group Type dialog box appears.

3. Select the Dynamic Group option button, and then click Next.
The General Information page appears.

4. In the Name box, enter the name for this group.

5. In the Notes box, enter any notes for this group.

6. Click Next.
The Query builder dialog box appears.

7. From the Group Name box in the first row, select the static group you want to use.
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8. From the Condition box in the next row, select the condition you want to use to build the 
dynamic group. Choices are:

● AND

● AND_NOT

● OR

9. From the Group Name box in the row, select the static group you want to use.

10. If you want to add another condition, click Add Row.

A new row appears.

11. From the Condition box in the new row, select the condition you want to use. 

12. From the Group Name box in the new row, select the static group you want to use.

13. If you want to include parentheses around two or more groups, click ( and ) on the 
appropriate rows.

The text box at the bottom of the dialog box shows the query you have built so far.

14. Repeat Steps 10 through 13 to add more conditions to this query.

15. When finished, click Next.
The Summary dialog box appears.

16. Click Next.
The dynamic group is created, and the Finish Up dialog box appears.

17. Click Finish.
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Importing Licenses
You can import a CSV file that contains the license information for IP Office devices. Each 
record in the CSV file must contain the following information for each device:

● IP address

● the list of license keys for the device

To import licenses, perform the following steps:

1. From the Avaya Network Management Console window, select Tools>Avaya Provisioning 
and Installation Manager For IPO Devices.

The Provisioning and Installation Manager window appears.

2. Click the Import Licenses.

The General dialog box appears. The Job Name box displays a default name for this import 
job. You can change this name.

3. In the Notes box, enter any notes about this job.

4. Click Next.
The Import Licenses Wizard dialog box appears.

5. Use the Browse button to select the CSV file that contains the licenses you want to import.

6. Click Next.
The Add Templates dialog box appears.

7. If you want to distribute templates with the licenses, select the appropriate template types. 
The last template of the selected type that was sent to this device will be resent with the 
licenses. (The IP addresses in this license file will be matched to the existing IP Office 
devices in Avaya Network Management Console.) 

8. Click Next.
The Schedule dialog box appears.

9. Specify when you want to run this job, and then click Next.
The Job Options dialog box appears.

10. Specify how you want to run this job, and then click Next.
The Summary dialog box appears.

11. Click Next to start the import.

A progress dialog box appears. When the job is complete, the Finish Up dialog box 
appears. 

12. Click the Finish button.
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Backing up Provisioning and Installation Manager Files
During a backup session, files are archived in a zip file. The following Provisioning and 
Installation Manager for IP Office application files are included in a backup session: 

● Profiles

● Templates

● Groups

● Jobs in the job queue or log— except running jobs

● System settings such as job queue, log retention, and system log file size

The backup session also provides a list of files and the Provisioning and Installation Manager 
for IP Office version.

To perform a backup:

1. From the Avaya Network Management Console window, select Tools>Avaya Provisioning 
and Installation Manager For IPO Devices.

The Provisioning and Installation Manager window appears.

2. Click + in front of the Administration folder in the left panel.

3. Click Backup/Restore.

The Backup/Restore page appears.

4. Click Backup Now.

The File Download dialog box appears.

5. Click Save.

The Save As dialog box appears.

6. Select the folder and filename for the backup file, and click Save.

The Download complete dialog box appears.

7. Click Close.
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