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Notice
While reasonable efforts were made to ensure that the information in this 
document was complete and accurate at the time of printing, Avaya Inc. can 
assume no liability for any errors. Changes and corrections to the information 
in this document might be incorporated in future releases.

Documentation disclaimer
Avaya Inc. is not responsible for any modifications, additions, or deletions to 
the original published version of this documentation unless such modifications, 
additions, or deletions were performed by Avaya. Customer and/or End User 
agree to indemnify and hold harmless Avaya, Avaya's agents, servants and 
employees against all claims, lawsuits, demands and judgments arising out of, 
or in connection with, subsequent modifications, additions or deletions to this 
documentation to the extent made by the Customer or End User. 

Link disclaimer
Avaya Inc. is not responsible for the contents or reliability of any linked Web 
sites referenced elsewhere within this documentation, and Avaya does not 
necessarily endorse the products, services, or information described or offered 
within them. We cannot guarantee that these links will work all the time and we 
have no control over the availability of the linked pages.

Warranty
Avaya Inc. provides a limited warranty on this product. Refer to your sales 
agreement to establish the terms of the limited warranty. In addition, Avaya�s 
standard warranty language, as well as information regarding support for this 
product, while under warranty, is available through the Avaya Support Web 
site:
http://www.avaya.com/support 

License
USE OR INSTALLATION OF THE PRODUCT INDICATES THE END USER'S 
ACCEPTANCE OF THE TERMS SET FORTH HEREIN AND THE GENERAL 
LICENSE TERMS AVAILABLE ON THE AVAYA WEB SITE 
http://support.avaya.com/LicenseInfo/ ("GENERAL LICENSE TERMS"). IF 
YOU DO NOT WISH TO BE BOUND BY THESE TERMS, YOU MUST 
RETURN THE PRODUCT(S) TO THE POINT OF PURCHASE WITHIN TEN 
(10) DAYS OF DELIVERY FOR A REFUND OR CREDIT.
Avaya grants End User a license within the scope of the license types 
described below. The applicable number of licenses and units of capacity for 
which the license is granted will be one (1), unless a different number of 
licenses or units of capacity is specified in the Documentation or other 
materials available to End User. "Designated Processor" means a single 
stand-alone computing device. "Server" means a Designated Processor that 
hosts a software application to be accessed by multiple users. "Software" 
means the computer programs in object code, originally licensed by Avaya and 
ultimately utilized by End User, whether as stand-alone Products or 
pre-installed on Hardware. "Hardware" means the standard hardware 
Products, originally sold by Avaya and ultimately utilized by End User. 

License type(s)
Concurrent User License (CU). End User may install and use the Software on 
multiple Designated Processors or one or more Servers, so long as only the 
licensed number of Units are accessing and using the Software at any given 
time. A "Unit" means the unit on which Avaya, at its sole discretion, bases the 
pricing of its licenses and can be, without limitation, an agent, port or user, an 
e-mail or voice mail account in the name of a person or corporate function 
(e.g., webmaster or helpdesk), or a directory entry in the administrative 
database utilized by the Product that permits one user to interface with the 
Software. Units may be linked to a specific, identified Server.

Copyright 
Except where expressly stated otherwise, the Product is protected by copyright 
and other laws respecting proprietary rights. Unauthorized reproduction, 
transfer, and or use can be a criminal, as well as a civil, offense under the 
applicable law.

Third-party components
Certain software programs or portions thereof included in the Product may 
contain software distributed under third party agreements ("Third Party 
Components"), which may contain terms that expand or limit rights to use 
certain portions of the Product ("Third Party Terms"). Information identifying 
Third Party Components and the Third Party Terms that apply to them is 
available on the Avaya Support Web site:
http://support.avaya.com/ThirdPartyLicense/ 

Preventing toll fraud
"Toll fraud" is the unauthorized use of your telecommunications system by an 
unauthorized party (for example, a person who is not a corporate employee, 
agent, subcontractor, or is not working on your company's behalf). Be aware 
that there can be a risk of toll fraud associated with your system and that, if toll 

fraud occurs, it can result in substantial additional charges for your 
telecommunications services.

Avaya fraud intervention
If you suspect that you are being victimized by toll fraud and you need technical 
assistance or support, call Technical Service Center Toll Fraud Intervention 
Hotline at +1-800-643-2353 for the United States and Canada. For additional 
support telephone numbers, see the Avaya Support Web site:
http://www.avaya.com/support 

Trademarks
Avaya, the Avaya logo, DEFINITY, MultiVantage, and COMPAS are either 
registered trademarks or trademarks of Avaya Inc. in the United States of 
America and/or other jurisdictions.
All other trademarks are the property of their respective owners.

Downloading documents
For the most current versions of documentation, see the Avaya Support Web 
site:
http://www.avaya.com/support 

COMPAS
This document is also available from the COMPAS database. The COMPAS ID 
for this document is 125772.

Avaya support
Avaya provides a telephone number for you to use to report problems or to ask 
questions about your product. The support telephone number 
is 1-800-242-2121 in the United States. For additional support telephone 
numbers, see the Avaya Support Web site:
http://www.avaya.com/support 
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http://support.avaya.com/LicenseInfo/
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Preface

This section contains the following topics:

● Purpose on page 9

● Audience on page 9

● Reasons for reissue on page 9

● Related documents on page 10

Purpose
This document, Avaya IP Agent Installation and User Guide for Citrix, includes information that 
you need to know in order to install and use Avaya IP Agent for Citrix Release 7 (IP Agent R7). 
It also provides information on IP Agent for Citrix R7 features, basic operation, and 
administrative tasks.

Audience
This guide is intended primarily for anyone who is installing or using IP Agent R7 and 
performing station administration on an Avaya MultiVantage system or Avaya Media Server 
using Avaya Communication Manager. It assumes that you are familiar with the following items:

● The personal computer on which Avaya IP Agent R7 will be installed and run

● Windows XP Professional

● Standard Windows conventions and terminology

● Contact center configurations and operations

Reasons for reissue
This is the first release of Avaya IP Agent Installation and User Guide for Citrix. This document 
was previously released as an integral part of the Avaya IP Agent Installation and User Guide.
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Related documents
The following documents can help you configure your Avaya communication server for use with 
Avaya IP Agent R7:

● Administrator�s Guide for Avaya MultiVantage Software

● Administrator Guide for Avaya Communication Manager
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Chapter 1: Introduction

This chapter provides introductory and basic information about Avaya IP Agent.

This chapter includes the following sections:

● What is Avaya IP Agent for Citrix? on page 11

● Telecommuter configuration on page 14

● Compatible telephone types for Avaya IP Agent on page 14

● Network compatibility on page 16

What is Avaya IP Agent for Citrix?
Avaya IP Agent is a software application with advanced telephony features for agents in a 
contact center. Agents can use it to work in the following methods

● On-site at the contact center

● Off-site using analog connections over a Public Switched Telephone Network (PSTN)

● Through Windows Terminal Services. 

The advanced telephony features are controlled by Avaya IP Agent through its direct 
communication with an Avaya communication server.

Agents who are not located at the call center can connect to the Avaya communication server in 
the contact center and receive calls as if they were present at their contact center workstation. 
For example, if an agent cannot travel to the contact center because of transportation problems 
or weather conditions, the agent can still take calls by using Avaya IP Agent to connect to the 
Avaya communication server.

Avaya IP Agent features for Citrix
The following is a list of the features for Avaya IP Agent on Citrix:

● Windows Terminal Services compatibility - Those call centers that use Windows Terminal 
Services can now use a special edition of Avaya IP Agent to facilitate usage of the 
Telecommuter configuration in that environment.
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● User-to-user information (UUI) screen pop enhancement - Using external applications, 
unique identifiers can be added to incoming calls. If your Avaya communication server has 
the correct features and configuration, these identifiers can be passed to Avaya IP Agent 
and used in screen pops for agents.

Available configuration and supported communication servers
● Support of Avaya DEFINITY R10, MultiVantage, and Communication Manager systems.

● Telecommuter configuration - Agents using an analog or Digital Communication Protocol 
(DCP) telephone can use the advanced call features provided by the Avaya 
communication server. For example, an agent working from home can use Avaya IP Agent 
and their home telephone to transfer calls, place calls on hold, change agent work mode, 
and do other call center activities.

Call and contact center features
● VuStats support - Avaya IP Agent can display multiple lines of VuStats information in the 

VuStats dialog box. You can use VuStats information to assist in complete monitoring of 
the contact center.

● Emergency Call Handling Service (E911) - With this feature, agents using IP Endpoints 
can use numbers that connect to emergency services, such as 911 in the United States. 
Only those emergency services in the Public Safety Answering Point area where the 
Avaya communication server is located can be reached. Agents or extensions in remote 
locations should not use this feature for emergencies.

● External Number Formatting - For international users, Avaya IP Agent allows you to define 
how many digits are present in telephone numbers outside the contact center.

Contact management features
● Call history - Avaya IP Agent records a complete call history of incoming and outgoing 

calls, even for those calls that were missed because where the caller does not leave a 
voice message.

● Telephone directory - Avaya IP Agent provides a customizable telephone directory that 
lists physical addresses, multiple telephone numbers, speed-dial numbers, e-mail 
addresses, and notes for each contact.

● Search Public Directory - With this feature, agents have the ability to search through public 
or company information using the Lightweight Directory Access Protocol (LDAP).

● Screen Pops - Screen Pops can be initiated when a call is received or placed. Avaya IP 
Agent provides agents with the ability to display Web pages, start applications, or retrieve 
and display caller information from a database. Screen pops are created using the Screen 
Pops Wizard, which guides you through their creation. A screen pop can consist of any 
process or application that can be initiated through one of the commands in the following 
list:

- Windows executable or registered file type activation
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- Dynamic Data Exchange (DDE) "Execute" or "Poke" commands

Usability features
● Clipboard dialing - Avaya IP Agent can be used to dial any number copied to the clipboard 

or, in most personal computer applications, used to dial a number that an agent highlights 
by right-clicking on the Avaya IP Agent icon in the System Tray.

● Enhanced Phone features - The Phone Features window includes adding, renaming, and 
deleting of folders.

● Enhanced System Tray icon - The Avaya IP Agent icon in the System Tray contains 
release, drop, hold, transfer, conference, and agent work mode functions.

● Automatic login - An agent can automatically log in to the Avaya communication server 
when Avaya IP Agent is started. Avaya IP Agent uses the login information from the 
previous login.

● Speed dialer - Agents can assign telephone numbers to function keys (F2 through F8).

● Voice message icon - When voice messages are present for the extension currently in 
use, an icon is displayed in the System Tray. When it has been configured, you can click 
on this icon to connect to your voice mail system.

● Alternate user interfaces - These interfaces can be used in place of the standard interface. 
These alternate interfaces use much less space on your desktop, and then can eliminate 
the problem of the previous Avaya IP Agent interface being hidden behind other 
applications or requiring too much space on the desktop.

Security and management features
● Feature deactivation - Administrators can deactivate Avaya IP Agent features that should 

not be configured or used by agents. The features that can be deactivated include Screen 
Pops, Screen Pop administration, Phone Directory, Public Search Directory, Call History, 
Phone Features configuration, Personal Phone Features, and Program Options selection.

● Alternate Gatekeeper - When an agent registers an IP Endpoint with an Avaya 
communication server, a C-LAN circuit pack IP address is sent by the server to the IP 
Endpoint. If registration is successful, the Avaya communication server sends back the IP 
addresses of all the C-LAN circuit packs in the network region. These addresses can be 
used if call signaling on the original C-LAN circuit pack fails.

● Support for server load balancing across gatekeepers - Registration and usage of Avaya 
communication servers can be distributed across multiple C-LAN circuit packs within a 
network region. This increases performance and reliability for all IP Endpoints.
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Telecommuter configuration 
Use the Telecommuter configuration in situations where a personal computer can make a 
dial-up or network connection to an Avaya communication server for the signaling (data) path 
and a voice path to a telephone sent through a Public Switched Telephone Network (PSTN) 
connection. The telephone can be an analog telephone, a cellular telephone, or an extension on 
a local or remote switch. This configuration provides toll-quality audio and full telephony 
functionality through Avaya IP Agent. Agents make and receive calls through the Avaya IP 
Agent interface, and the voice path is sent to the specified telephone.

What you need to know about the Telecommuter configuration

The following is a list of the Telecommuter configuration requirements and capabilities:

● Connection - One dial-up or network connection from the personal computer running 
Avaya IP Agent to the Avaya communication server and a telephone capable of receiving 
calls from the Avaya communication server

● Personal computer hardware - Modem or Network Interface Card (NIC) for connection to 
the Avaya communication server

● Telephone set - Any telephone capable of receiving calls from the Avaya communication 
server

● Voice Quality - High

● Avaya communication server connections - One user connection for signaling connection 
and one of the following:

- For off-site use, one trunk connection
- For on-site use, an additional user connection

Compatible telephone types for Avaya IP Agent
This section contains the following topics:

● Supported telephone types on page 15

● Recommended telephone types on page 16
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Supported telephone types 

Note:
Note: When you change telephone types for a station, you must restart Avaya IP Agent 

for the change to take effect.

The following table provides the telephone types that are available on the Avaya communication 
server and officially supported for use with Avaya IP Agent:

Telephone model Communication 
platform

Additional features

Callmaster (602A1) DCP ● 80-character (2x40) display

Callmaster II (603D1) DCP ● 80-character (2x40) display

Callmaster III (603E1) DCP ● 80-character (2x40) display

Callmaster IV (603F1)� DCP ● 80-character (2x40) display

Callmaster V (607A1) DCP ● 48-character display

2402 DCP ● 48-character display
● Supported with Avaya 

Communication Manager 2.1 
or later

2420 DCP ● 203-character display
● Expansion module available

4606 IP ● 32-character display

4610 IP ● 168x80 pixel display
● Supported only on Avaya 

Communication Manager 2.1 
or later

4612 IP ● 48-character display

4620 IP ● 168x132 pixel display
● Expansion module available

4624 IP ● 48-character display

4630 IP ● 320x240 pixel display

6402D DCP ● 32-character (2x16) display 

6408D / 6408D+ DCP ● 48-character display



Chapter 1: Introduction

16 Avaya IP Agent Installation and User Guide for Citrix June 2007

 

Recommended telephone types
While Avaya IP Agent supports all of the telephone types listed in the previous table for the 
Telecommuter configurations, the following types provide the most buttons and features, and an 
80-character display:

● 606A1

● 8434D

Because of the greater number of characters used for display, these telephone types are better 
suited to handle VuStats or Prompted Digits information.

Network compatibility
Avaya IP Agent provides support for several H.323-compatible firewalls and Virtual Private 
Networks (VPNs). For shim-based VPNs, you must use the Advanced tab in the Avaya iClarity 
IP Audio dialog boxes used for login to set an IPSec IP address, that is assigned by the VPN 
gateway and that is visible to the application on the personal computer. If you need assistance, 
contact Avaya technical support.

6416D+ DCP ● 48-character display
● Expansion module available

6424D+ DCP ● 48-character display
● Expansion module available

8403B DCP ● 48-character display

8405D / 8405D+ DCP ● 48-character display

8410D DCP ● 48-character display

8411D DCP ● 48-character display
● For this telephone set, you 

must disable the data port, 
which is true for all softphones

8434D DCP ● 80-character (2x40) display
● Expansion module available

Telephone model Communication 
platform

Additional features
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The VPN solution provided by Avaya iClarity IP Audio only supports VPNs that use one-to-one 
IP address substitution. VPNs that use many-to-one IP address substitution cannot be used 
with Avaya IP Agent.
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Chapter 2: Configuring the Avaya 
communication server 

This section provides procedures and information on how to configure the following Avaya 
communication servers for use with Avaya IP Agent:

● Avaya communication servers with Communication Manager software

● Avaya communication servers with MultiVantage Software

● DEFINITY Enterprise Communication Server (ECS) R10

● DEFINITY Business Communications Server (BCS) and Guestworks R10

Before agents can receive calls with Avaya IP Agent, the Avaya communication server must be 
configured to support extension assignments, IP connectivity, telephone types, and other 
settings.

! Important:
Important: You should be familiar with administering your Avaya communication server 

before attempting any of the procedures in this section. If you are unfamiliar with 
the fields or settings described in this section, consult your Avaya communication 
server documentation for assistance.

This section includes the following topics:

● Required Avaya communication server circuit packs on page 19

● Validating Feature Access Codes on page 21

● Telecommuter configurations on page 22

Note:
Note: The screens shown in this section are from an Avaya communication server with 

the Expert Agent Selection (EAS) feature. If you do not have the EAS or some 
other features on your Avaya communication server, these interfaces may differ 
slightly from the screens shown. Because of this, each step in the procedure 
identifies when there is a distinction between an EAS and non-EAS system.

Required Avaya communication server circuit packs 
This section provides information and documentation resources for the circuit packs required by 
your Avaya communication server to support Avaya IP Agent.
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The following two circuit packs are used for remote agent connections over TCP/IP with Avaya 
IP Agent:

● Control LAN Circuit Pack (C-LAN) (TN799B or later)

● IP Media Processor

This section contains the following topics:

● C-LAN circuit pack on page 20

● IP Media Processor on page 20

● Documentation on page 21

C-LAN circuit pack
C-LAN is a packet port circuit pack for Avaya communication servers that provides TCP/IP 
connectivity to adjuncts for applications. It has one 10BaseT or 100BaseT Ethernet connection 
and up to 16 DS0 physical interfaces for PPP connections. Two integrated modems provide 
remote PPP connectivity over analog facilities. Multiple C-LAN circuit packs can be added to a 
system to increase TCP/IP capacity.

This circuit pack provides data signaling over TCP/IP for Avaya IP Agent. It is used for 
configurations where a data connection is made to the Avaya communication server. The voice 
path does not use this circuit pack.

Note:
Note: Avaya recommends that the TN799C V4 or later C-LAN circuit pack is used for its 

increased ability to handle maximum capacities. Previous versions could 
encounter difficulties when the maximum number of active endpoints is reached.

IP Media Processor
The IP Media Processor provides the transmission of voice data over an IP network. This 
enables support of applications that comply with H.323-v2 protocols. It also reduces per-port 
costs and improves quality through its dynamic jitter buffers. Additionally, it performs echo 
cancellation, silence suppression, Dual Tone Multi-Frequency (DTMF) detection, and 
conferencing. 

This circuit pack provides Voice-over-Internet Protocol (VoIP) that is used where a VoIP 
connection is made to the Avaya communication server.
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Documentation
For installation procedures and configuration information for the C-LAN and IP Media Processor 
circuit packs, see Administration for Network Connectivity for your Communication Manager, 
MultiVantage, or DEFINITY system.

Validating Feature Access Codes 
This section provides the procedure for administering the Feature Access Codes (FACs) on an 
Avaya communication server. Feature Access Codes are used by Avaya IP Agent to give 
agents the ability to perform the following actions: 

● Change the current work mode

● Log in

● Log out 

● Adjust the method with which an agent receives the next call (Auto-In, Manual-In)

● Request supervisor assistance

Before you begin
Feature Access Codes cannot be entered unless the fac capability is assigned in the dial plan.

To change settings on the Avaya communication server, you must have a user ID with the 
proper administrative permissions.

! Important:
Important: Screens presented in this section might differ in appearance from those of your 

Avaya communication server. All options on the specified forms mentioned in this 
procedure are available, but might not be on the page noted.

Steps for validating Feature Access Codes
To validate Feature Access Codes:

1. Log in to the Station Administration Terminal (SAT) on the Avaya communication server.



Chapter 2: Configuring the Avaya communication server

22 Avaya IP Agent Installation and User Guide for Citrix June 2007

 

2. Enter display dialplan to access the dial plan form and then ensure that the fac 
option is assigned in the dial plan.

If the fac option is not assigned in the dial plan, your dial plan does not currently support 
Feature Access Codes. For more information on configuring your dial plan for Feature 
Access Codes, see the documentation for your Avaya communication server.

3. Enter display feature-access-codes to view the feature-access-codes form.

4. Navigate to the call center portion of the feature-access-codes form.

Non-EAS Avaya communication servers will display only a subset of the access code 
fields shown in the following figure.

Note:
Note: The Feature Access Codes shown in the graphic are only an example and do not 

need to be configured as such on your Avaya communication server. You are free 
to determine your own Feature Access Codes.

5. Administer the Feature Access Codes for Login and Logout as well as any other FACs 
that you want available for your agents.

If Feature Access Codes are not assigned, see the documentation for your Avaya 
communication server to find instructions on adding Feature Access Codes.

Telecommuter configurations 
If you will be using any telephone as your extension, this section provides the procedures and 
information for proper administration of your Avaya communication server.

This section contains the following topics:

● Ensuring compatibility on page 23

● Configuring station settings on page 24
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Ensuring compatibility
In this procedure, you set features on your Avaya communication server so that Avaya IP Agent 
can be used in your call center.

Before you begin

The settings for IP connections can be enabled only if your Avaya communication server 
supports use of Internet Protocol (IP) for calls.

! Important:
Important: If any settings of your Avaya communication server do not conform with the steps 

in this procedure, you must contact Avaya to purchase the appropriate options or 
configuration for your Avaya communication server before you can use Avaya IP 
Agent.

If you need to configure a specific range of ports to use with IP communications because of 
firewalls or for some other reason, you must assign the range through both the Avaya 
communication server and Avaya iClarity IP Audio. See Advanced tab on page 138 for 
information on configuring port ranges on both systems.

Steps for ensuring Telecommuter station settings

To ensure that your Avaya communication server supports the Telecommuter configuration:

1. Log in to the Station Administration Terminal (SAT) on the Avaya communication server.

2. Enter display system-parameters customer-options.

The SAT displays Page 1 of the system-parameters customer-options form.
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3. Ensure that the Maximum Concurrently Registered IP Stations field is set to a number 
greater than zero. This number represents the total number of IP stations that can be 
connected to the Avaya communication server at one time. IP stations can consist of 
Avaya IP Agent, Avaya IP Softphone, and IP telephone sets.

4. Navigate to Page 3 of the customer-options form.

5. Ensure that the IP Stations field is set to y.

6. Navigate to Page 9 of the customer-options form.

7. Ensure that the Limit field for the IP_Agent Product ID is set to the number of licenses 
you purchased for Avaya IP Agent.

Configuring station settings 
This section provides the procedure for configuring station settings to support the Telecommuter 
configuration.
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Before you begin

Before configuring station settings on the Avaya communication server, you should have 
completed the procedures in Ensuring compatibility on page 23 to verify that your Avaya 
communication server supports Avaya IP Agent and Feature Access Codes.

To change settings on the Avaya communication server, you must have a user ID with the 
proper administrative permissions.

If the station has not yet been created, you must create it using the add station command on 
the Avaya communication server.

Steps for configuring Telecommuter station settings

To change station settings to support the Telecommuter configuration:

1. Log in to the Station Administration Terminal (SAT) on the Avaya communication server.

2. Enter change station XXXXX where XXXXX is the number of the station to be used 
with Avaya IP Agent.

The Avaya communication server displays the change station form for the specified 
station.

3. In the Type field, enter the type of telephone that Avaya IP Agent will emulate.

Avaya recommends using one of the following telephone types because of the number of 
features available and the ability to display 80 characters for contact center or call 
information:

● 8434D

● 606A1
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Note:
Note: In Telecommuter mode, Avaya IP Agent can take over the administration and 

functionality of a physical Digital Communication Protocol (DCP) telephone. The 
physical telephone must be one of those listed in Compatible telephone types for 
Avaya IP Agent on page 14. For DCP, the physical telephone is unusable while 
Avaya IP Agent is registered with its extension. The telephone will become usable 
again when the Avaya IP Agent session is disconnected from the Avaya 
communication server.

If you selected the 8434D type, and more feature buttons are needed for the station, enter 
y in the Expansion Module field.

4. Enter one of the following options in the Port field:

● X - This option specifies that station administration is done without hardware.

● port - This option is used when a remote agent takes direct control of a real extension 
that has a DCP connection to the Avaya communication server. Enter the port number 
of the actual telephone assigned to this extension. When a remote agent logs in to this 
extension using Avaya IP Agent, the actual telephone that is locally connected to the 
Avaya communication server port is disabled and cannot be used.

5. Enter a number in the Security Code field that will be used as a password during the 
extension login to the Avaya communication server.

If a security code is not entered, this station cannot log in to the Avaya communication 
server.

6. Set the IP Softphone field to y.

7. Navigate to Page 2 of the change station form.

8. Set the Multimedia Mode field to enhanced.

9. Set the Service Link Mode field to one of the following options:

● as-needed - Use this setting if the station has low call traffic or a toll is charged for 
calls.
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● permanent - Use this setting if the station has high call traffic or if it is set as an 
auto-answer station.

10. Ensure that the IP Emergency Calls field is set to the appropriate setting for your contact 
center.

11. If the Auto Answer field is set to All or ACD on the station or agent form, you must enable 
the Enable support for auto-answer feature in the Avaya IP Agent Program Options 
and then reboot. You can find this option under Tools > Program Options in the Avaya IP 
Agent main window.

12. Navigate to Page 3 of the change station form.

13. On pages 3, 4, and 5 of the station administration forms, assign functions to each button 
that you want to appear in your Avaya IP Agent Phone Features window.

You must assign the necessary agent work mode buttons that are used in your contact 
center:

● auto-in - This function makes agents available for new calls immediately after they 
finish with the current call.

● manual-in - This function makes the agent available to take a call and then places the 
agent in the After Call Work (ACW) mode when the call has been completed.

● after-call - This function places agents in the After Call Work (ACW) mode.

● aux-work - This function places agents in the Auxiliary Work (AUX) mode. Multiple 
Auxiliary Work buttons with different reason codes can be assigned to this extension.

Note:
Note: You can configure your Avaya communication server to prompt for reason codes 

when an agent enters the aux-work state.

● release - Assignment of this feature is mandatory. This feature terminates the current 
call and line appearance.

● callr-info - This function is required only with the Call Prompting feature so that agents 
are allowed to display information collected from the originator of the call. The Call 
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Prompting feature obtains information from a caller through a collect-digits vector 
step on the Avaya communication server.

! Important:
Important: The 4600, 6400, and 607A1 telephone types do not have a physical Drop button; 

therefore, you must assign a drop function for each station to ensure proper 
operation of the Avaya IP Agent Drop feature.

When this station is connected to the Avaya communication server, the assigned button 
functions are displayed in the Avaya IP Agent Phone Features window.

You can find information on all available button functions in the documentation for your 
Avaya communication server.
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Chapter 3: Installing Avaya IP Agent 

This section contains procedures and important information for installing and uninstalling Avaya 
IP Agent in a Microsoft Windows Terminal Services environment. 

Call centers that use Windows Terminal Services, Citrix MetaFrame XP, or Citrix Presentation 
Server can implement Avaya IP Agent to provide agents with enhanced call features and a 
computer telephone interface to their extension. Avaya IP Agent can be used only in the 
Telecommuter mode in this environment.

This section includes the following topics:

● Prerequisites on page 29

● Installing Avaya IP Agent on page 32

● Reinstalling Avaya IP Agent on page 34

● Uninstalling Avaya IP Agent on page 34

Prerequisites 
This section provides information on the necessary hardware and software for successful 
installation and use of Avaya IP Agent.

This section contains the minimum or recommended requirements for the following:

● Software download package contents on page 29

● Avaya communication server on page 30

● Server hardware on page 30

● Server software on page 31

Software download package contents
The Avaya IP Agent software download package available from the Avaya Support Web site 
contains the following:

● Avaya IP Agent installation program

● Avaya IP Agent program files



Chapter 3: Installing Avaya IP Agent

30 Avaya IP Agent Installation and User Guide for Citrix June 2007

 

● Documentation in PDF format - Adobe Acrobat® Reader 5.0 or later is required to 
view.PDF documents.

● A readme.txt file containing last minute information

Avaya communication server
The following Avaya communication servers can be used:

● Avaya communication servers with Avaya Communication Manager software

● Avaya communication servers with Avaya MultiVantage software

● DEFINITY Enterprise Communication Server (ECS) R10

● DEFINITY IP 600 R10

● DEFINITY ONE R10

● DEFINITY Business Communications System (BCS) R10

● DEFINITY Guestworks R10 

For the Windows Terminal Services implementation of Avaya IP Agent, the Avaya 
communication server must have one or more of the following component:

● A Control LAN Circuit Pack (C-LAN) circuit pack (TN799B or later)

Server hardware 
The following topics present minimum server hardware requirements for Avaya IP Agent:

Processor 

The minimum requirements for Windows Terminal Services are sufficient for Avaya IP 
Agent to run properly.

Hard disk space 

Avaya IP Agent requires a minimum of 30 MB per user installation. Avaya IP Agent can require 
more hard disk space, depending on the amount of data stored for the phone

 

directory, call 
history, and screen pops.
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RAM 

The following table provides the minimum memory requirements for the Windows Terminal 
Services edition of Avaya IP Agent:

Networking 

The desktop workstation must have one network (non-dialup) connection and one telephone 
connection (DCP or analog).

Peripherals 

The following peripheral is required for installation and use of Avaya IP Agent:

● Mouse or compatible pointing device

Note:
Note: If you are using the minimum hardware requirements for Windows Terminal 

Services, you may experience a degradation in performance when several users 
are simultaneously registered with the server.

Server software 
Avaya IP Agent requires the following software:

● One of the following Microsoft Windows operating systems with Windows Terminal 
Services:

- Windows 2000 Server
- Windows 2000 Advanced Server
- Windows 2003 Server - Standard Edition
- Windows 2003 Server - Enterprise Edition

● Microsoft Internet Explorer 5.5 or later

Note:
Note: Avaya IP Agent for Windows Terminal Services is compatible with Citrix 

MetaFrame XP Release 3.2 or later and Citrix Presentation Server 4.0 or later.

Server operating system Memory

Windows 2000 Server
Windows 2000 Advanced Server
Windows 2003 Server - Standard Edition
Windows 2003 Server - Enterprise Edition

128 MB
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Installing Avaya IP Agent
This section provides information and procedures for installing Avaya IP Agent for Windows 
Terminal Services.

Before you begin
Read and understand the following items before attempting to install Avaya IP Agent for 
Windows Terminal Services:

● After you install Avaya IP Agent to each server, you must initialize the configuration for 
each user.

● Read the readme.txt file in the Avaya IP Agent software download package for any 
last-minute information.

● If you are upgrading Avaya IP Agent, ensure that you have obtained new licenses for this 
version on your DEFINITY, MultiVantage, or Communication Manager system. If you have 
not done so or are unsure if you have done so, contact your Avaya representative for 
assistance.

● If you install applications for your users from the server, you should perform these 
installations during off-hours because the Avaya IP Agent installation might require a 
restart of the system.

Steps for installing Avaya IP Agent for Windows Terminal Services
To install Avaya IP Agent:

1. Use the Add/Remove program from the Control Panel to install Avaya IP Agent.

2. Run the Launcher.exe file in the Avaya IP Agent software download package.

The installation program displays the setup selection window.

3. Next to IP Agent Terminal Services Setup, select the Install button.

The installation program displays the Welcome window.

4. Select the Next button.

The installation program displays the Software License Agreement window.

5. Read the entire Software License Agreement carefully and select the Yes button if you 
understand and agree to the terms. Selecting No will cause the installation program to exit.

6. Select the Next button.

The installation program displays the Choose Destination Location window.
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7. If you want to install Avaya IP Agent in a folder other than the default, click the Browse 
button in the Destination Folder dialog box and select a new location.

8. When you are satisfied with the folder in which Avaya IP Agent will be installed, select the 
Next button.

The installation program displays the Setup Type window.

9. In the Setup Type window, select one of the following options and then select the Next 
button:

● Typical - This option installs the basic options in English as well as in the language of 
your Microsoft Windows operating system. Proceed to Step 13.

● Custom - This option installs the basic options in English as well as in any language 
you choose. Selecting this option and then the Next button will display the Select 
Language Components window where you specify the software language 
components to install. Proceed to the next step.

10. Indicate the language components to install by selecting the check box next to the option.

When selecting the language components to install, ensure that the Space Required does 
not exceed the Space Available that is indicated at the bottom of the window.

11. Select the Next button.

The installation program displays the Select Program Folder window.

12. Use the Select Program Folder window to specify the folder name that will appear in the 
Start menu through one of the following methods:

● You can accept the default Avaya IP Agent folder name that appears in the Program 
Folders field.

● You can enter a different folder name in the Program Folders field.

● You can select an existing folder in the Existing Folders field in which to install the 
Avaya IP Agent Start menu shortcuts.

13. Select the Next button.

The installation program displays the Shortcut and Startup Features window.

14. Select the associated check boxes for the shortcuts you want to be created.

Note:
Note: If you select a shortcut location but do not select any language, the install 

program displays a warning indicating that you need to select at least one or 
more languages.

15. If you selected one of the check boxes on the upper portion of this dialog box, you must 
highlight the languages in the Select the languages you would like to have added field 
for shortcuts to be created in those languages.

Note:
Note: The option Automatically start the following version of Avaya IP Agent when 

Windows is started is not available for Windows Terminal Services.
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16. Select the Next button.

The installation program displays the Start Copying Files window.

This window displays the options that you selected. If you need to make any changes to 
the selections you made, select the Back button until you reach the necessary window.

The install program begins copying files. When this process is complete, the View the 
Release Information File window is displayed.

17. Select the check box provided in the View the Release Information File window to view 
the latest information for Avaya IP Agent that could not be included in this document.

18. Select the Next button.

If you selected to view the Release Information, the installation program displays the 
readme.txt file. Otherwise, proceed to Step 20.

19. When you have read the readme.txt file, close the application displaying it.

The installation program displays the final installation window.

20. Select the Finish button.

The installation program closes.

Reinstalling Avaya IP Agent
If you reinstall Avaya IP Agent for Windows Terminal Services, the process is exactly as 
described in Installing Avaya IP Agent on page 32. Personalized configurations and data are 
preserved.

Uninstalling Avaya IP Agent
This section explains how to uninstall Avaya IP Agent. The uninstall program removes all files 
and directories that were created during the installation of Avaya IP Agent.

Introduction
You can uninstall Avaya IP Agent using the Windows Add/Remove Programs feature. 
Read-only folders that are shared with other applications are not removed. If you have added 
any files or directories to the Avaya IP Agent installation directory, those files will not be 
removed.
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The uninstall program removes:

● All installed Avaya IP Agent files, including all language versions

● Folders created by the Avaya IP Agent installation

● Log files created by Avaya IP Agent

Steps for uninstalling Avaya IP Agent
To uninstall the Avaya IP Agent application from Windows 2000 or Windows XP:

1. Close Avaya IP Agent if it is currently running.

2. In the Windows Control Panel, select Add/Remove Programs.

Windows displays the Add/Remove Programs dialog box.

3. In the Currently installed programs list box, highlight Avaya IP Agent.
4. Select the Change/Remove button.

InstallShield displays a message box asking you to confirm that Avaya IP Agent should be 
removed.

5. Select the Yes button to start the uninstall process.

InstallShield displays a message box asking if you want to preserve user data.

6. Select one of the following buttons regarding preservation of user data:

● Yes - Selecting this option saves all user data and settings so that a reinstallation of 
Avaya IP Agent retains the same configuration.

● No - Selecting this option removes all Avaya IP Agent user data from the personal 
computer.

When the uninstall process is complete, a window containing a successful message is 
displayed.

7. Select the Finish button to complete the uninstall process.

8. Close the Add/Remove Programs dialog box.
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Chapter 4: Avaya IP Agent enhanced 
configuration options 

This section provides information and procedures for configuring advanced features in a contact 
center that uses Avaya IP Agent.

This section contains the following topics:

● Configuring the Emergency Call Handling Service on page 37

● Configuring Alternate Gatekeeper on Avaya communication servers on page 40

● Configuring server load balancing across gatekeepers on page 40

Configuring the Emergency Call Handling Service 
The Emergency Call Handling Service (E911) allows IP Endpoints to use numbers that connect 
to emergency services, such as 911 in the United States. When used, this feature reaches only 
the emergency service in the Public Safety Answering Point area where the Avaya 
communication server is located.

! WARNING:!

WARNING: Because IP Endpoints do not dial to and connect with local emergency services 
when dialing from remote locations, agents or extensions in remote locations 
should not use this feature for emergencies.
Avaya Inc. is not responsible or liable for any damages resulting from misplaced 
emergency calls made from an Avaya endpoint. Your use of this product indicates that 
you have read this advisory and agree to use an alternative telephone to dial all 
emergency calls from remote locations.

This section contains the following topics:

● Administering the Avaya communication server for Emergency Call Handling on page 38

● Administering Avaya IP Agent for Emergency Call Handling on page 38
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Administering the Avaya communication server for Emergency 
Call Handling

See the documentation for your Avaya communication server for information on configuring the 
Emergency Call Handling feature.

Administering Avaya IP Agent for Emergency Call Handling 
This section provides the procedure for configuring Avaya IP Agent to use the Emergency Call 
Handling Service.

Before you begin

The Avaya communication server to which you are connecting must have each extension 
properly configured for the Emergency Call Handling Service before this feature can be used 
through Avaya IP Agent.

Steps

To configure the Emergency Call Handling Service in Avaya IP Agent:

1. Start Avaya IP Agent.

Windows displays Avaya IP Agent and the Login window.

2. In the Login window, select the Settings button.

Avaya IP Agent displays the Settings dialog box.
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3. Select the Emergency tab.

4. Place a check mark in the Enable emergency call handling feature check box.

5. Select the location that will be sent through the Avaya communication server for calls 
placed to emergency services:

● Your extension number XXXXXXX - Select this option button if you want your 
extension number to be sent to emergency personnel. This selection is best used for 
those stations within the contact center.

● Telephone number - Select this option button if you want a telephone number other 
than your extension sent to emergency services. Specify the telephone number to 
send in the provided field. For example, enter a number corresponding to a Digital 
Communications Protocol (DCP) telephone in your vicinity that has a fixed, known 
location so that emergency personnel know where to respond. If you are unsure of a 
number to enter, see your system administrator.

6. Select the OK button.

7. In the Login dialog box, select the Login button.

Any calls to emergency services will show the selected telephone number.
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Configuring Alternate Gatekeeper on Avaya 
communication servers 

Use the Alternate Gatekeeper feature when an IP Endpoint registers with an Avaya 
communication server. When Avaya IP Agent registers with an Avaya communication server, a 
C-LAN circuit pack IP address is sent to the IP Endpoint. If registration is successful, the Avaya 
communication server sends back the IP addresses of all C-LAN circuit packs defined in the 
same network region. Avaya IP Agent can use these addresses as alternatives if call signaling 
on the original C-LAN circuit pack fails.

Tip:
Tip: You can better control the usage and workload of C-LAN circuit packs by creating 

network regions.

Alternate Gatekeeper configuration
For information on defining Alternate Gatekeeper addresses, refer to your Avaya 
communication server documentation.

Configuring server load balancing across gatekeepers 
Load balancing for an Avaya communication server refers to the ability of distributing IP 
Endpoint traffic across all C-LAN circuit packs that are defined within the same network region.

Load Balancing configuration
Load balancing is achieved by defining all of the IP addresses of the C-LAN circuit packs to be 
part of a network region on an Avaya communication server. After this has been completed, IP 
Endpoints registering with the Avaya communication server will be automatically assigned to 
the different C-LAN circuit packs in sequential order. This helps distribute IP Endpoints evenly 
amongst the C-LAN circuit packs.
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! Important:
Important: It is important that you use the network region feature to control which C-LAN 

circuit packs are available when one pack loses connectivity. Without proper 
region assignments for your C-LAN circuit packs, Avaya IP Agent could attempt 
to connect to a C-LAN circuit pack that has not been properly configured or is not 
intended for use with Avaya IP Agent.

For more information on defining C-LAN circuit packs within a network region, refer to the 
documentation for your Avaya communication server.

Load Balancing documentation
For installation procedures and configuration information for the C-LAN and IP Media Processor 
circuit packs, see Administration for Network Connectivity for your Communication Manager, 
MultiVantage, or DEFINITY system.
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Chapter 5: Starting and Stopping Avaya IP 
Agent 

This chapter explains how to begin using Avaya IP Agent. It contains the following sections:

● Starting Avaya IP Agent on page 43

● Initializing IP Endpoint configurations on page 44

● Registering with the Avaya communication server on page 47

● Logging in as an agent (EAS) on page 49

● Logging in as an agent (non-EAS) on page 50

● Logging out of Avaya IP Agent on page 51

● Exiting Avaya IP Agent on page 52

● Using alternate user interfaces on page 52

Starting Avaya IP Agent 
This section provides the procedure for starting the Avaya IP Agent application.

Steps for starting Avaya IP Agent
To start Avaya IP Agent:

1. Select the Start button from the Windows task bar.

2. Select Programs > Avaya.

3. Select Avaya IP Agent - <language>.

The Avaya IP Agent window is displayed. Although Avaya IP Agent is now running, your 
extension is not yet registered with the Avaya communication server.

4. For IP Endpoint configurations, go to Initializing IP Endpoint configurations on page 44.
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Initializing IP Endpoint configurations 
If you have performed a new installation of Avaya IP Agent for an IP Endpoint configuration, the 
Configuration Wizard is displayed when you first start Avaya IP Agent. The Configuration 
Wizard prompts you to enter the necessary configuration information for registering with an 
Avaya communication server.

Steps
To configure your installation of Avaya IP Agent to register with an Avaya communication 
server:

1. Start Avaya IP Agent.

Avaya IP Agent starts the Configuration Wizard automatically.

2. Select the Next button.

Avaya IP Agent displays the next window of the Configuration Wizard.

3. Select the Log into Avaya call server option.

4. Select the Next button.

Avaya IP Agent displays the next window of the Configuration Wizard.

5. Enter the necessary information in the following fields:

● Extension - The extension number of the station that will be used with Avaya IP 
Agent.

● Password - The numeric password associated with the specified extension.
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● Remember password for next login session - Place a check mark in this check box 
if you do not want to enter your password each time you register with the Avaya 
communication server. If you are concerned with the possibility of unauthorized 
persons assuming this identity, leave this check box blank.

6. Select the Next button.

Avaya IP Agent displays the next window of the Configuration Wizard.

7. In the Primary Server Address field, enter the domain name or IP address of the Avaya 
communication server C-LAN circuit pack that will be used for connections.

8. In the Alternative Server Addresses field, you have the option of defining other C-LAN 
circuit pack addresses that will be used should the primary address fail. This field is 
optional. 

Tip:
Tip: The alternative server addresses should reside in the same network region as the 

primary server address. For more information on defining network regions, see 
the documentation for your Avaya communication server.

9. Select the Next button.

Avaya IP Agent displays the next window of the Configuration Wizard.

10. Select the pre-defined Dialing Location from the drop-down list. This selection will control 
certain telephony properties such as area code, outside line access, and so forth.

11. Select the Next button.

Avaya IP Agent displays a warning message regarding the Emergency Call Handling 
feature.
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12. Read the text of this warning completely and select the I Agree button if you understand 
and agree to the conditions stated in this message.

If you select the I Disagree button, the Configuration Wizard will exit or, for Windows 
Terminal Services, return to a previous Configuration Wizard window.

After you select I Agree, Avaya IP Agent displays the next window of the Configuration 
Wizard.

13. If you want to enable this feature, place a check mark in the Enable Emergency Call 
Handling feature check box.

14. If you enabled the Emergency Call Handling feature, select the location that will be sent 
through the Avaya communication server for calls placed to emergency services:

! WARNING:!

WARNING: Because IP Endpoints do not dial to and connect with local emergency services 
when dialing from remote locations, agents or extensions in remote locations 
should not use this feature for emergencies.

Avaya Inc. is not responsible or liable for any damages resulting from misplaced 
emergency calls made from an Avaya endpoint. Your use of this product indicates that 
you have read this advisory and agree to use an alternative telephone to dial all 
emergency calls from remote locations.

● Your extension number XXXXXXX - Select this option button if you want your 
extension number to be sent to emergency personnel. This selection is best used for 
those stations within the contact center. Enter the number of digits that your contact 
center uses for extensions. For DEFINITY R10 systems, extension numbers can 
range from one to five digits. For MultiVantage and Communication Manager systems, 
extension numbers can range from one to seven digits.
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● Telephone number - Select this option button if you want a telephone number other 
than your extension sent to emergency services. Specify the telephone number to 
send in the provided field.

This selection must be compatible with the station definition on the Avaya communication 
server in the IP Emergency Calls field. Failure to use the same setting as the Avaya 
communication server will result in login failure for this extension.

15. Select the Next button.

Avaya IP Agent displays the next window of the Configuration Wizard.

16. Specify the telephone or extension number that will be used to make and receive calls with 
Avaya IP Agent.

17. Select the Next button.

Avaya IP Agent displays the next window of the Configuration Wizard.

18. If you do not need to go back and readjust your audio settings, select the Finish button to 
complete the Configuration Wizard.

Registering with the Avaya communication server 
Before you can use Avaya IP Agent, you must register Avaya IP Agent with the Avaya 
communication server and register your extension through the Login window. Once you are 
registered with the Avaya communication server, you can make yourself available for ACD calls 
by performing an agent login. 

This section provides the procedure for registering with an Avaya communication server. This 
must be done so that you can use Avaya IP Agent for placing and answering calls in an IP 
Endpoint configuration.

Before you begin
If you attempt to log in to an Avaya communication server that is not a DEFINITY, MultiVantage, 
or Communication Manager system, Avaya IP Agent displays an Invalid Station Type error 
message. You must use a DEFINITY, MultiVantage, or Communication Manager system with 
Avaya IP Agent.
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Setting default registration information
The Settings button on the Login window can be used to configure more advanced features 
that are used with Avaya IP Agent and the Avaya communication server. For more information 
on these settings, see Login Settings dialog box on page 133.

Steps for registering with an Avaya communication server
To register with the Avaya communication server:

1. When you start Avaya IP Agent, the Login window is displayed. If this window is not 
displayed, select File > Station Login from the Avaya IP Agent main window.

Avaya IP Agent displays the Login window for your IP Endpoint configuration.

2. In the Extension field, enter your extension, which has been administered for Avaya IP 
Agent on the Avaya communication server.

3. In the Password field, enter the numeric password for the specified extension.

4. In the Call Server Address field, enter the IP Address or name of the Avaya 
communication server.

5. Ensure that the correct information is specified in the appropriate field:

● Telephone At - This is the telephone or extension number that will receive incoming 
calls. This number cannot be the same as the number entered in the Extension field. 
The Avaya communication server administrator will have created a new extension to 
support voice communication.

● Dialing Location - Select the entry that contains the appropriate telephony properties 
for your current location.

6. If you do not want to enter your password each time you register with the Avaya 
communication server, place a check mark in the Remember password for next login 
session check box. If you are concerned with the possibility of unauthorized persons 
registering as this extension, leave this check box blank.

7. If you want to automatically register with the Avaya communication server when Avaya IP 
Agent is started at a later time, enable the Automatically log in if possible when 
application restarts check box. You must have successfully registered with the Avaya 
communication server at least once in the past to use this option.

8. Select the Login button. When you successfully register with the Avaya communication 
server, the controls in the Avaya IP Agent main window are enabled.

9. Avaya IP Agent displays the Verify Telephone Number dialog box upon successful 
registration with the Avaya communication server. When you first start using Avaya IP 
Agent, it is important that you make some test calls to verify that you have set up your 
connection properly.
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Logging in as an agent (EAS) 
After registering with the Avaya communication server, you can, as an extension, receive calls 
through Avaya IP Agent. However, to receive calls from a skill, you need to log in as an agent of 
that skill. This section provides the procedure for logging in to Avaya IP Agent as an agent. This 
procedure is for logging in to Avaya communication servers that use the Expert Agent Selection 
(EAS) feature.

Steps for logging in (EAS)
To log in to Avaya IP Agent as a member of an ACD skill:

1. In the Avaya IP Agent window, select the Login button.

Avaya IP Agent displays the Agent Login dialog box.

2. In the Agent Login dialog box, enter your agent number and password in the appropriate 
fields.

3. Select the Login button.

The extension specified in the Login window will ring.

Note:
Note: If you do not answer your telephone immediately or if you entered the wrong 

number for the voice connection, Avaya IP Agent displays an error message. 
Acknowledge the error message by selecting the OK button and then repeat the 
login procedure.

4. Answer the telephone.

You will hear a confirmation tone, the buttons on the agent toolbar are enabled, and you 
will be automatically put in the AUX-work mode.

5. To leave the AUX-work mode, select either the Auto-In or Manual-In button.

For more information about Auto-In and Manual-In work modes, see Selecting an agent 
work mode on page 61.

You are now ready to begin receiving and making calls.
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Logging in as an agent (non-EAS) 
After registering with the Avaya communication server, you can, as an extension, receive calls 
through Avaya IP Agent. However, to receive calls from a split, you need to log in as an agent of 
that split. This section provides the procedure for logging in to splits through Avaya IP Agent. 
This procedure is for logging in to Avaya communication servers that do not have the Expert 
Agent Selection (EAS) feature.

Before you begin
In order for an agent to be able to log in to a split, Avaya IP Agent must be configured to support 
a non-EAS Avaya communication server. To change the Avaya IP Agent configuration:

1. Select Tools > Program Options.

2. From the Program Options window, select the ACD Agent item from the list box.

3. Remove the check mark from the Configure program for EAS agent support check box.

4. Ensure that a check mark is present in the Prompt for agent ID and password during 
agent login check box.

Note:
Note: If this feature is not enabled, you must enter your agent ID and password through 

the telephone key pad.

5. Select the OK button.

6. Close Avaya IP Agent by selecting File > Exit from the main window.

7. Restart Avaya IP Agent.

Steps for logging in (non-EAS)
To log in to Avaya IP Agent as a member of an ACD split:

1. In the Avaya IP Agent window, locate the Agent toolbar. This toolbar lists the splits 
assigned to this station.

If this toolbar is not visible, select View > Toolbars > Agent.
2. On the Agent toolbar, select the split you want to log into.

Avaya IP Agent displays a menu with a Login option.
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3. Select the Login option.

Avaya IP Agent displays the Agent Login dialog box.

4.  If your extension requires a password, enter the password for this split.

If you are logging in to a split that consists of only one or two digits, you may be required to 
place one or more zeros in front of the split number. This is dependent on the configuration 
of your Avaya communication server. See the documentation for your Avaya 
communication server.

5. Select the Login button.

6. Select the split from the Agent toolbar again.

7. Select the appropriate work mode from the resulting menu.

8. For each split you want to log in to, repeat this procedure.

An agent can log in to a total of four splits.

Logging out of Avaya IP Agent 
This section provides the procedure for logging out of Avaya IP Agent as an agent.

Steps
To log out of Avaya IP Agent:

1. Select the Logout button on the agent toolbar, or select Agent > Agent Logout from the 
menu bar.

If the Avaya communication server has been configured to require logout reason codes, 
Avaya IP Agent displays a prompt in the status bar for entry of the reason code.

2. Enter your logout reason code through the keyboard or the Dial Pad.
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Exiting Avaya IP Agent 
This section provides the procedure for exiting the Avaya IP Agent application.

Steps
To exit Avaya IP Agent and log out of the Avaya communication server:

1. After you have logged out as an agent, select File > Exit from the main window.

The Avaya IP Agent main window closes and your extension is logged out of the Avaya 
communication server.

Using alternate user interfaces 
This section provides information and procedures for the alternate user interfaces that are 
available in Avaya IP Agent.

In many contact center environments, agents use many different applications simultaneously. 
This can lead to overlapped application windows on the Windows desktop. This can cause 
difficulties in accessing or using the necessary application windows quickly and efficiently. To 
help overcome this problem, Avaya IP Agent provides three alternate user interfaces that use 
much less space on the Windows desktop than the default main window. The following figure 
compares interface size:

Default main window Alternate user interface example
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Note:
Note: The procedures in this document are written for the default main window. You will 

not be able to exactly follow these procedures when you are using an alternate 
user interface. However, the Program Menu button on the right side of the 
interface allows you to access the most commonly used features in Avaya IP 
Agent. Also, the shortcut key combinations for Avaya IP Agent do not function 
while you use an alternate user interface.

AutoAnswer interface

This interface uses the least amount of space, and is intended for agents using the Auto-In and 
Auto-answer features. Call-handling buttons, such as Transfer, Hold, and Release are 
present. Buttons for agent work modes and Avaya IP Agent features are not available in this 
interface.

Mini interface

This interface is slightly wider than the AutoAnswer interface and is intended for the contact 
center agent who determines the necessary work mode, such as AUX (Auxiliary Work) and 
ACW (After-Call Work). In addition to the call-handling buttons, this interface also contains 
buttons for any agent work modes assigned to this extension.

Titlebar interface

When an agent is on a call, this interface is the largest of the alternate interfaces. It includes 
call-handling buttons, agent work modes buttons, and buttons used to access other Avaya IP 
Agent features, such as the Phone Directory and Call History window.

Selecting an alternate interface
This section provides the steps for selecting one of the three alternate user interfaces available 
with Avaya IP Agent.
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Steps

To select an alternate user interface.

1. From the Avaya IP Agent main window, select View > Alternate Interfaces.

2. From the branching menu, select the interface that you want to use:

● AutoAnswer
● Mini Interface
● Titlebar
Avaya IP Agent displays the selected interface.

Accessing features
To access Avaya IP Agent features that are not represented by a button, click the Program 
Menu button on the far right side of the interface. A menu containing login and logout options, 
work modes, online help items, and features is displayed.

Returning to the main interface
To return to the Avaya IP Agent main window from an alternate user interface, click the 
Maximize button next to Program Menu button on the right side of the interface.

Removing alternate user interfaces
If you do not want these interfaces available for use, remove all files located in the following 
directory:
<install-directory>\Avaya\Avaya IP Agent\Skins

If you want only one interface available to agents, leave that file in the \Skins directory and 
delete the other files.
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Note:
Note: Avaya IP Agent cannot recreate these files once they have been deleted.

Renaming alternate user interfaces
If you want to change the name of an alternate user interface, rename the necessary file in the 
following directory:
<install-directory>\Avaya\Avaya IP Agent\Skins

Note:
Note: Because the names of these menu items are derived from actual filenames, 

these items will appear in English for international versions of Avaya IP Agent. To 
cause these menu items to appear in a specific language other than English, you 
must use a language-specific version of Windows and then rename the files as 
needed.
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Chapter 6: Using VuStats 

The VuStats feature is used to pass contact center information from the Avaya communication 
server to a display on a station or extension. Supervisors and agents use this feature to monitor 
contact center activity and statistics.

The VuStats window of Avaya IP Agent displays any VuStats buttons that have been assigned 
to the extension by the communication server administrator. 

Using Avaya IP Agent, you will be able to specify how long the program monitors each 
transmission of VuStats information before it moves to the next one.

This section includes the following topics:

● Configuring an extension for VuStats through the Avaya communication server on page 57

● Viewing a single set of VuStats information in Avaya IP Agent on page 58

● Adjusting intervals for monitoring VuStats on page 59

Configuring an extension for VuStats through the Avaya 
communication server 

For an Avaya IP Agent extension to display VuStats information, the following configurations on 
the Avaya communication server must be done:

● The extension must be assigned as a telephone type that has a display. Avaya 
recommends the 8434D or 606A1 telephone types for the Telecommuter configuration.

● The extension must have one or more buttons assigned with the vu-display feature. 
Different streams of VuStats information are available by specifying the format and ID 
parameters of the vu-display feature.

● For different views and formats, multiple VuStats configurations can be assigned to the 
buttons for this extension.

Configuration
For information on configuring extensions for the VuStats feature through your Avaya 
communication server, see the "VuStats" section of Avaya Call Center ACD Guide.
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Definitions and reference material for the VuStats fields on the forms of the Avaya 
communication server can be found in the Administrator's Guide for your Avaya communication 
server.

Viewing a single set of VuStats information in Avaya IP 
Agent 

This section provides the procedure for displaying a single set of VuStats information in the 
Phone Display panel of the Avaya IP Agent main window.

Before you begin
To view VuStats information in the main window of Avaya IP Agent, you must ensure that the 
Phone Display panel is visible. Select the View menu from the main menu and verify that a 
check mark next to the Phone Display menu item is present. If a check mark is not present, 
select the item to enable it.

Before performing this procedure, the VuStats feature must have been assigned to one or more 
buttons for this extension. See Configuring an extension for VuStats through the Avaya 
communication server on page 57 for more information.

Steps
To display VuStats in the Avaya IP Agent main window:

1. From the Avaya IP Agent main window menu bar, select Tools > Phone Features.

Avaya IP Agent displays the Phone Features window.
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2. Select the VuStats information to view by double-clicking the associated entry in the 
Phone Features window.

Avaya IP Agent displays the selected VuStats information in the Phone Display toolbar of 
the main window.

Adjusting intervals for monitoring VuStats 
When VuStats are being displayed through the VuStats Monitor, you can configure the 
following time-related items:

● Refresh Rate - The period of time that passes before focus is changed from the last line of 
display in the list to the first line.

● Display Interval - The period of time that passes before the VuStats Monitor changes 
focus from one VuStats line of display to the next one in the list.

Before you begin
You should ensure that you set the VuStats Monitor time intervals so that each line of display 
can be updated before the Refresh Rate changes focus to the top of the list. For example, if 
you have six VuStats lines of display in the VuStats Monitor and the Display Interval is set for 
10 seconds, your Refresh Rate should be 60 seconds or greater.

Tip:
Tip: If a VuStats line of display has not been updated before the next VuStats item 

begins to update, increase the Display Interval delay.
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Steps
To change the periods of time used in the VuStats Monitor window:

1. Start the VuStats Monitor.
2. Click the Refresh Rate button on the toolbar of the VuStats Monitor window.

Avaya IP Agent displays a menu with the following time intervals:

● 10 seconds

● 20 seconds

● 30 seconds

● 60 seconds

● 120 seconds

3. Select the interval that should pass before focus is changed from the last line of display to 
the first line.

4. Click the Display Interval button on the toolbar of the VuStats Monitor window.

Avaya IP Agent displays a menu with the following time intervals:

● 5 seconds

● 10 seconds

5. Select the interval that should pass before focus is changed from one line of display to the 
next line.

When focus moves to a line of display in the VuStats Monitor, the VuStats data for that 
line is updated.

6. After setting one or both time intervals, click the Start button on the toolbar.

The VuStats Monitor window begins displaying VuStats information according to the time 
intervals specified.



Avaya IP Agent Installation and User Guide for Citrix June 2007 61

 

Chapter 7: Avaya IP Agent basic 
operations

This chapter contains information on the basic operations of Avaya IP Agent.

This chapter includes the following topics:

● Selecting an agent work mode on page 61

● Handling incoming calls on page 63

● Transferring a call on page 67

● Conferencing calls on page 70

● Handling outgoing calls on page 75

Selecting an agent work mode 
During the course of placing calls, receiving calls, and performing work associated with those 
calls, work modes are used to indicate the availability of the agent or the work being performed.

Definitions of agent work modes

Auto-In and Manual-In

The Auto-In and Manual-In buttons are used to place an agent in the AVAIL (Available) work 
mode so that the agent can receive calls. 

If an agent is in Auto-In mode and completes a call, the agent is automatically available to 
receive another call, or can be placed in After-Call Work (ACW) mode for an administered 
length of time. When the timed ACW interval expires, the agent is automatically returned to 
available status. If the agent tries to change agent modes while active on a call, the change is 
not made until the agent disconnects from the call.

If the agent is in Manual-In mode and completes a call, the agent is automatically placed in 
After-Call Work (ACW) mode. To become available to receive another ACD call, the agent must 
manually select the Auto-In or Manual-In mode. If the agent tries to change agent modes while 
not on an active call, the change takes place immediately.



Chapter 7: Avaya IP Agent basic operations

62 Avaya IP Agent Installation and User Guide for Citrix June 2007

 

ACW (After-Call Work)

Agents use this work mode to indicate that tasks related to the previous call are being 
performed. This button is not usually used in conjunction with the Auto-In feature because 
agents with the Auto-In feature are made available for a new call when the current call is 
completed.

This work mode can be selected while the agent is on an active call. The change will not occur 
until the current call is finished and released. This work mode may not function correctly if the 
agent uses it while in Auto-In mode.

AUX (Auxiliary Work)

Agents use this work mode to indicate that they cannot receive calls. Usually, this indicates that 
the agent is not in the proximity of the telephone because of meals, approved periods of 
inactivity, meetings, training, and so forth.

It is possible for multiple Auxiliary Work modes to be assigned to an extension as each can 
possess a different reason code to indicate the various situations that an agent cannot receive 
calls.

This work mode can be selected while the agent is on an active call. The change will not occur 
until the current call is finished and released.

Changing work modes
The agent work modes can be changed through the following methods:

● Using shortcut keys - See Shortcut keys on page 141.

● Selecting the associated work mode button on the agent toolbar - See Agent toolbar on 
page 119.

● Selecting the work mode from the Avaya IP Agent System Tray icon - See System Tray 
icon on page 121.

● Selecting the work mode from the Agent menu in the main window - See Agent menu on 
page 114.

Note:
Note: When a work mode is active, the timer, which is displayed in the Call Information 

Panel, displays the total time that the agent has been in the selected work mode. 
To disable this timer, see How to remove the call timer on page 154.
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Handling incoming calls
This section describes those functions that you will be using every day when you receive an 
incoming call at your station, including answering a call and holding a call.

This section includes the following topics:

● Answering a call on page 63

● Holding a call on page 65

● Releasing a call on page 66

● Dropping a call on page 67

Answering a call 
Answering a call depends on how the Avaya communication server and the network are 
administered. Each contact center environment is different, which can affect the way agents 
answer calls. Avaya suggests that each contact center evaluate its configuration and instruct 
agents on the best way to answer calls with Avaya IP Agent. There are too many possible 
Avaya IP Agent configurations to list them in this document. The following are some suggested 
procedures on answering calls for different configurations.

Configuration settings for Telecommuter
The following list provides the options to set for this configuration:

● Agent Administration for auto-answer is set to station or none. 

● Station Administration for auto-answer is set to none. 

● Station Administration has service link set to as-needed. 

● Each time a call is received, the analog or DCP telephone that provides the voice path will 
ring. The personal computer will also emit a ringing sound if you have configured Avaya IP 
Agent to do so.

● Your Central Office (CO) must have the Answer Supervision feature. Contact your 
telecommunication provider for more information.

Steps for answering Telecommuter calls
To answer a call for this configuration:

1. The agent should wait for the telephone to ring and then answer it. Answering of the 
telephone will automatically be detected through Avaya IP Agent.
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2. After the call is completed and the calling party disconnects from the call, or after the agent 
selects Release for that call, the agent should hang up the telephone if no more calls are 
ringing on the Avaya IP Agent screen.

3. If there is another incoming call indicated on the screen, the agent should not hang up the 
telephone, but select the Answer button for the new call appearance on the Avaya IP 
Agent screen. The agent is then connected to the new call. The previous call is placed on 
hold.

Note:
Note: If an incoming call is displayed in the Avaya IP Agent main window before the 

telephone rings, the agent must wait for the telephone set to ring before 
answering.

Telecommuter (Auto-Answer)

Configuration settings for Telecommuter (Auto-Answer)

The following list provides the options to set for this configuration:

● Agent Administration for auto-answer is set to station, ACD, or all. 

● Station Administration for auto-answer is set to ACD or all. 

● Station Administration has the service link set to permanent. 

● During the event of agent login, the telephone will ring to deliver the login confirmation 
tone. 

Steps for answering Telecommuter (Auto-Answer) calls

To answer a call for this configuration:

1. The agent should answer the telephone and do not return it to the on-hook state for the 
remainder of the shift for that agent.

If the telephone is accidentally cut off or placed on-hook, the Avaya communication server 
rings the telephone when it has a call to deliver. The agent must answer by picking up the 
handset.

2. As with any auto-answer telephone, the Avaya communication server will provide a zip 
tone (a beep) to signal that a new call has arrived.
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Holding a call
You can put a call on hold by using either the Auto Hold or Manual Hold feature.

When a call is on hold, the text on the button for the associated Call Information Panel (CIP) 
changes to Reconnect.

Using Manual Hold
To perform a Manual Hold, select the Hold button on the Phone Button toolbar. Place a call on 
hold by pressing the Hold button on the telephone, if it is so equipped.

Using Auto Hold
The Auto Hold feature does not require pressing a Hold button. If you change to a second call 
appearance, the first call is automatically placed on hold.

Reconnecting to a call on hold
To reconnect to a call that is currently on hold, select the Reconnect button on the appropriate 
CIP. Alternatively, you may re-select the Hold button in the main window.

Hold button

Reconnect
button
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Releasing a call
There are different methods for releasing a call. These methods will work only if the Release 
feature has been administered for your station.

Steps for releasing a call
To release a call:

1. Do one of the following actions:

● While on an active call, select the Release button that is located on the Call 
Information Panel (CIP). You will not hear a dial tone after you select the Release 
button.

● Select the Release button that is located on the Phone Button toolbar.

● Hang up the handset.

● Select the Release item in the Phone Features window.

2. If you have a call on hold, you must first reconnect to it before you can release the call.

In the example below, you would have to reconnect to extension 1048 before you could 
release it.
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Dropping a call 
Use the Drop feature when you want to disconnect from a normal call or drop the last party 
added to a conference call.

To drop a call, select the Drop button located on the Phone Button toolbar. You are then 
disconnected from the call and hear a dial tone.

Transferring a call 
This section describes the following methods of transferring calls:

● Basic call transfer on page 67

● Unsupervised call transfer on page 68

● Enhanced call transfer on page 69

Before you begin
Read and understood the following items before using the procedures described in this topic:

● The Transfer button on the Phone Buttons toolbar can be configured for Basic, 
Unsupervised, or Enhanced transfer. Use the Call Handling screen in the Program 
Options dialog box to set this option. You can also choose a type of transfer that is 
different from the default, by selecting Call > Transfer from the menu bar.

● If all of your call appearances are currently in use, you can transfer a call only to an 
existing call appearance, not to a new telephone number.

● If you enable the Abort Transfer or Abort Conference feature on your Avaya 
communication server, Avaya IP Agent cannot transfer or conference between active call 
appearances.

Basic call transfer 
Use the Basic Transfer feature to send an active call to another extension or telephone number. 
With this type of transfer, you enter the number to receive the transfer through the keyboard and 
then announce the call to the receiving party.
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Steps for a Basic Transfer

To transfer a call using Basic Transfer:

1. While you are on an active call, select Call > Transfer > Basic Transfer from the menu 
bar.

The current call is automatically put on hold, a new Call Information Panel (CIP) is 
displayed, and a dial tone is heard.

2. Using the keyboard or Dial Pad, enter the number of the party to receive the transferred 
call.

3. When the receiving party answers, you can privately talk to the party and then select 
Basic Transfer again to complete the transfer.

Both CIPs are no longer displayed in the main window, indicating that the transfer was 
successful.

You can complete the transfer at any time after the number is entered, either during the 
ringing state or after the second party answers.

You can change this call transfer into a conference by selecting Basic Conference 
instead of Basic Transfer.

4. If there is no answer, the line is busy, or you decide the transfer is not needed, do the 
following steps to cancel the transfer:

● Select the Release button associated with the receiving party. This action terminates 
the call to the receiving party.

● Return to the call on hold by selecting the Reconnect button on the associated CIP.

Unsupervised call transfer 
Use the Unsupervised Transfer feature to transfer an active call to another extension or 
telephone number by entering the number of the receiving party into a dialog box. 
Announcement of the call to the receiving party is not available in this mode.
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Steps for an Unsupervised Transfer

To transfer a call using Unsupervised Transfer:

1. While you are on an active call, select Call > Transfer > Unsupervised Transfer.
Avaya IP Agent displays the Unsupervised Transfer dialog box.

2. In the available field, enter the number to receive the current call.

3. Select OK to transfer the call. 

Unlike the basic transfer, you do not have to select Transfer a second time to complete the 
transfer.

The Call Information Panel (CIP) will disappear from the main window which indicates that 
the transfer was successful.

Enhanced call transfer 
Use the Enhanced Transfer feature to transfer the active call to another extension or telephone 
number by entering the number of receiving party into a dialog box. With this mode, you have 
the ability to transfer the call directly without announcing it to the receiving party or you can wait 
to announce the call and then decide whether to transfer the call.

Steps for an Enhanced Transfer

To transfer a call using enhanced transfer:

1. While you are active on a call, select Call > Transfer > Enhanced Transfer.
Avaya IP Agent displays the Enhanced Transfer dialog box.

2. In the available field, enter the number of the receiving party.



Chapter 7: Avaya IP Agent basic operations

70 Avaya IP Agent Installation and User Guide for Citrix June 2007

 

3. Select the OK button.

The caller is automatically put on hold, a new Call Information Panel (CIP) is displayed, a 
dial tone is heard, and Avaya IP Agent displays a confirmation dialog box.

If you need to enter digits, such as answering prompts, use the number pad on the right 
side of this dialog box. If you are on hold or are delayed for some reason, you can return to 
the original call without losing this call by selecting the Switch to call on hold button and 
select this button again to return to the transfer.

4. Remain on the line and wait for an answer.

5. Perform one of the following actions:

Conferencing calls
This section provides information and procedures for conferencing multiple calls together so 
that all parties can communicate simultaneously.

This section contains the following topics:

● Basic Conference on page 71

● Enhanced Conference on page 73

Note:
Note: If all of your call appearances are currently in use, you can conference only with 

existing call appearances, not new telephone numbers.

If... Then...

The number dialed is answered Announce the call and select the OK button in the 
confirmation dialog.
Both CIPs are no longer displayed in the main 
window, indicating that the transfer was 
successful.

The number dialed is not answered 
or is busy

Select the Cancel button in the confirmation dialog 
and select the Reconnect button on the 
appropriate CIP to return to the held call.
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Basic Conference 
Use the Basic Conference feature to connect multiple calls together so that all parties can 
communicate simultaneously. With this method, you use the numbers on the keyboard or the 
Dial Pad to enter the telephone numbers to conference together.

Steps for using Basic Conference

To conference a call using Basic Conference:

1. While you are active on a call, select Call > Conference > Basic Conference.

The current call is automatically placed on hold, a new Call Information Panel (CIP) is 
displayed, and a dial tone is heard.

2. Use the keyboard or Dial Pad to enter the number of the party you want to add to the 
conference call.
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3. When the second party answers, you can privately talk to the second party and then select 
Basic Conference again to initiate the conference call. 

You may initiate the conference when the number is entered, during the ringing state, or 
after the second party answers.

One CIP is displayed in the main window, which displays CONFERENCE 2. indicating that 
a conference is active.

You may change the conference call into a transfer by selecting Basic Transfer instead of 
Basic Conference in Step 3.

4. Repeat the previous steps until you have conferenced all parties.

The single CIP displays CONFERENCE X, where X equals the number of parties 
participating in the call.

Example:
If you added three parties to the call, the CIP displays CONFERENCE 3.

1. If there is no answer, the line is busy, or you decide the conference is not needed: 

● Select the Release button associated with the party that was going to be added to the 
conference.

● Return to the held call by selecting the Reconnect button on the associated CIP.
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Enhanced Conference 
Use the Enhanced Conference feature to connect multiple calls together by entering the 
extensions or telephone numbers through a dialog box and then adding them to an active call.

Steps for using Enhanced Conference

To add a party to a current call, perform the following steps:

1. While you are on an active call, select Call > Conference > Enhanced Conference.

Avaya IP Agent displays the Enhanced Conference dialog box.

Note:
Note: The dialog box you see may be different because it depends on the number of 

call appearances that are present. If all available call appearances are active, the 
dialog box does not have a New Number field. If only one call appearance is 
active, the dialog box does not display the Existing Call field.

2. In the New Number field, enter the extension or telephone number of the party you want 
to add to the active call.

Note:
Note: If you have only one call appearance, the field in which you provide a telephone 

number is not labeled.

One call appearance More than one call appearance
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3. Select the OK button.

The current call is automatically placed on hold, a new CIP is displayed, a dial tone is 
heard, and Avaya IP Agent displays a confirmation dialog box.

If you need to enter digits, such as answering prompts, use the number pad on the right 
side of this dialog box. If you are on hold or are delayed for some reason, you can return to 
the original call without losing this call by selecting the Switch to call on hold button and 
select this button again to return to the conference.

4. When you decide to add the call to the conference, select the OK button. If there is no 
answer, the line is busy, or you decide to cancel the conference, select the Cancel button.

If you selected the Cancel button, select the Reconnect button on the CIP associated with 
the original call.

5. If you selected the OK button, wait for an answer.

6. Repeat the previous steps until you have conferenced all parties.

The single CIP displays CONFERENCE X, where X equals the number of parties 
participating in the call.

If... Then...

The number dialed is 
answered

You can privately talk to the new party and then 
select the OK button in the confirmation dialog to 
add the party to the call.
One CIP is displayed in your main window, which 
displays CONFERENCE 2, indicating that a 
conference is active.

The number dialed is not 
answered or is busy

Select the Cancel button in the confirmation dialog 
and then select the Reconnect button to return to 
the original call.
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Example:
If you added three parties to the call, the CIP displays CONFERENCE 3.

Any person on the conference call can hang up at any time.

1. To disconnect the last person added to the conference call, select the Drop button.

2. When the conference call is over, select the Release button.

 The CIP is removed from the main window.

Handling outgoing calls
There are several ways you can make the handling of outgoing calls more efficient. You can use 
a Recent Calls list, a Speed Dial number, or an Abbreviated Dial button.

Note:
Note: In the Phone Directory, you may notice that all telephone numbers are prefixed 

with a "+1" (in the United States). All external telephone numbers are displayed in 
the Phone Directory in canonical format, as seen in the following example:

+1 (800) 555-1234

This format is universally constant and allows this number to be dialed from anywhere 
in the world. This number is dialed only if deemed necessary through the Dialing 
Properties of your personal computer.

For example, a user with a laptop may have two or more sets of Dialing Properties 
configured. In the office, one set of Dialing Properties cause a number, sometimes a 
"9", to be dialed to access an external line. Alternatively, the same laptop could have a 
Dialing Properties set that does not use an external line number for when the user is 
at home or traveling. The format of telephone numbers in the Phone Directory 
ensures that all of these configurations will work without having to change the format.
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This section includes the following topics:

● Recent Calls list on page 76

● Using the Phone Directory on page 77

● Administering and using Speed Dial on page 80

● Abbreviated Dial button on page 82

Recent Calls list 
You can quickly dial or re-dial recent incoming or outgoing calls by using the Recent Calls list. 
Telephone numbers are not duplicated in the list, so if the last ten calls are to the same number, 
the number is displayed only once in the list. Only those calls with valid telephone numbers are 
added to the list.

Before you begin

Before using the Recent Calls list, read and understand the following items:

● You or your system administrator can control the number of recent call numbers displayed 
by setting that number in the Program Options dialog box. 

● The list can show a maximum of the last 25 unique numbers recorded in the Call History 
log. Abbreviated Dial buttons or numbers dialed on active calls (pin numbers) are not 
included in the list.

● Letters that are dialed, for example, 1800GOAVAYA, are displayed in the recent calls list 
as letters, not as the associated numbers.
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Steps for using the Recent Calls list

To make a call using the Recent Calls list:

1. Select the down arrow next to the Call History button. 

Avaya IP Agent displays a list of previously dialed and received numbers.

2. Select the number you want Avaya IP Agent to dial.

A call appearance is created and the selected telephone number is dialed.

Using the Phone Directory
The Phone Directory feature stores contact information that you provide. Through this 
interface, you can dial telephone numbers and send e-mail messages to those contacts that you 
have defined.

The Phone Directory stores the types of information shown in the following list:

● Name

● Address

● Email

● Category

● Telephone numbers

● Notes

● Pronunciation (Japanese version only)
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Menu bar

The following is a list of menus and menu items available for the Phone Directory window:

File
● New - This item displays the Properties dialog and allows entry of a new contact.

● Import
- Text File (Comma Separated Values) - This item allows you to import a .CSV file 

containing contacts and their associated information.

● Export - This item exports the Phone Directory to a comma-separated value file (.CSV)

Note:
Note: The entries for the comma-separated values are listed below in the order that 

they are displayed:

● Name

● Address

● Email

● Business

● Business Fax

● Home

● Home Fax

● Mobile

● Assistant

● Car

● Company

● Pager

● Pronunciation (Japanese version only)

Each item must be enclosed within quotation marks.

● Search Public Directory - This item opens the Search Public Directory window, which 
can be used to search for contact information through an Lightweight Directory Access 
Protocol (LDAP) service. Entries can be added to the Phone Directory from the Search 
Public Directory window. For more information on this feature, see Using a Public 
Directory with Avaya IP Agent on page 85.

● Close - Selecting this item closes the Phone Directory window.

Edit
● Name, Number, Email, Category - Edit the displayed information for the selected contact.
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● Delete - Delete the selected contact.

● Properties - View all information for the selected contact.

● Categories - Add, delete, or modify the categories defined in the Phone Directory.

● Field Organizer - Organize the fields displayed in the Phone Directory.

View
Use this menu to determine how the entries appear in the Phone Directory window. These 
items are similar to those used in Windows Explorer: Large Icons, Small Icons, List, and 
Details (default).

Action
● Call: (name) - Select this menu item to initiate a telephone call to the highlighted contact.

● Send Email - Select this menu item to initiate an e-mail message to the highlighted 
contact.

Toolbar

The toolbar of the Phone Directory window contains the following controls:

● Name - This field allows the dynamic filtering of the entries in the Phone Directory on any 
field. Select the name button to display the list of fields available for the Phone Directory. 
After you select the field on which to filter, enter letters or digits in the corresponding field. 
Each character entered in this field causes only those entries matching the filter to remain 
visible. For example, entering the letter S causes all entries that do not begin with that 
letter to be hidden. For numeric fields, any numbers entered in this field are used to filter 
the entries. The filtering for numeric fields is not sequential. Any entries that contain the 
string of numbers entered will remain visible. Additionally, any punctuation existing in the 
entry is ignored. For example, entering the numbers 123 would match against the 
following entries:

- (555) 555-1234
- (800) 123-5555
- 1 (230) 555-5555
- 512-3555

● Dial Number - Select this button to dial the telephone number of the highlighted entry.

● Send Email - Select this button to open an e-mail message to the highlighted entry.

● Properties - Select this button to display a dialog box containing the details of the 
highlighted entry. This dialog box also allows modification of this information.

● Delete - Select this button to delete the highlighted entry.

● New entry - Select this button to display the Properties dialog and enter the information 
for a new contact.
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● Categories - Select this button to display a list of all categories defined in the Phone 
Directory and to filter the existing contacts. Selecting one of the categories in this list 
results in only those contacts assigned to that category remaining visible.

Phone Directory window usage 

Within the Phone Directory window, you can perform the following actions on a selected 
contact:

● With the mouse, right-click on an entry to display a pop-up menu containing the following 
items:

- Call (contact) - Initiates a call to the selected contact.
- Send Email - Initiates an e-mail to the selected contact.
- Delete - Removes the selected contact from the Phone Directory.
- Properties - Displays a dialog box listing all information for the selected contact. This 

dialog box also allows editing of that information.

● Press the Enter key or double-click the mouse to initiate a call to a contact.

● Press Alt + Enter to display all information for the selected contact.

● Press the Delete key to remove the selected contact from the Phone Directory.

You can also sort the entries in the Phone Directory by clicking the title of any column. The 
sorting is done based on the column selected and alternates between ascending to descending 
order with subsequent clicks.

More information

The following topics provide additional information on the use of the Phone Directory window:

● Administering and using Speed Dial on page 80

● Searching a Public Directory on page 87

Administering and using Speed Dial 
Use the Speed Dial feature to dial frequently-used telephone numbers by selecting entries from 
the Speed Dial list or by pressing function keys (F2-F8) on the keyboard. Entries in the Phone 
Directory can be assigned as Speed Dial numbers. A maximum of 25 telephone numbers can 
be assigned to the Speed Dial list.
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Steps for assigning a Speed Dial number

To assign a telephone number in the Phone Directory to the Speed Dial list:

1. In the Avaya IP Agent main window, select Tools > Phone Directory.

Avaya IP Agent displays the Phone Directory dialog box.

2.

3. Enter or edit the appropriate information in the Properties dialog box.

4. Place a check mark in the Speed Dial check box next to the telephone number that you 
want to use as a Speed Dial number.

Avaya IP Agent displays the Speed Dial Function Keys dialog box.

5. If you want to have the telephone number for this Phone Directory entry available when a 
function key, such as F2, F3, ..., F8, is pressed, select the Assign this number to a 
function key option.

The Phone Directory entry appears in the F2 row.

If... Then...

You are creating a new entry Select File > New... from the menu bar.

You are editing an entry Highlight the entry and select Edit > 
Properties from the menu bar.
Avaya IP Agent displays the Properties 
dialog box.
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Note:
Note: If you want to assign this new entry to another function key, highlight it and use 

the up and down arrow icons in the dialog box to move the entry to a new location 
in the list.

6. When you are satisfied with the function key that this number has been assigned to, press 
the OK button.

7. In the Properties window, select the OK button to close it.

Using a Speed Dial number

To select a Speed Dial number:

1. Select the down arrow next to the Phone Directory button in the Avaya IP Agent main 
window.

Avaya IP Agent displays the Speed Dial Numbers list.

2. Select the party that you want to call.

A call appearance is created and the telephone number is dialed.

Note:
Note: If you have assigned a Phone Directory entry to a function key, you can simply 

press that function key to dial the associated telephone number.

Abbreviated Dial button
If the Abbreviated Dial feature has been administered on the Avaya communication server for 
your extension, you can store telephone numbers in the Phone Features window for quick and 
easy dialing. Each number can be a complete or partial telephone number, an extension 
number, a trunk, or feature code.
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Steps for using Abbreviated Dial

To make a call using an Abbreviated Dial button:

1. Select Tools > Phone Features.

Avaya IP Agent displays the Phone Features window.

2. In the Phone Features dialog box, select the Abbreviated Dial button associated with the 
number you want to dial.

A call appearance is created and the selected telephone number is dialed.

The button label for an Abbreviated Dial is a number, whereas the button label for an 
autodial button is the word autodial plus the number. This difference is shown in the 
following table:

Abbreviated Dial Autodial

51008 autodial 51008
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Chapter 8: Using a Public Directory with 
Avaya IP Agent 

This section provides information and procedures for the Search Public Directory feature of 
Avaya IP Agent.

This feature provides access to corporate or public directory services which enable you to query 
those services by any defined field.

The Search Public Directory feature is also called Search LDAP (Lightweight Directory Access 
Protocol).

! Important:
Important: Avaya IP Agent does not support the enhancements available in LDAP v3. If you 

use an LDAP v3 Public Directory service, you must use Avaya IP Agent as an 
LDAP v2 client.

This section includes the following topics:

● Defining a Public Directory service on page 85

● Searching a Public Directory on page 87

● Selecting the fields to display and the order on page 90

● Identifying multiple telephone number fields on page 91

● Deleting a Public Directory service on page 92

Defining a Public Directory service 
So that you can search for information on a Public Directory (LDAP) server by using Avaya IP 
Agent, a definition of the service must first be created and configured.

Steps for defining a Public Directory service
To define and configure a Public Directory service for Avaya IP Agent:

1. From the Avaya IP Agent menu bar, select Tools > Search Public Directory.

Avaya IP Agent displays the Search Public Directory window.
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2. From the menu bar of the Search Public Directory window, select File > Add Public 
Directory.

Avaya IP Agent displays the Directory Properties window.

3. In the following fields, enter the necessary information:

● Description - Enter a name by which you will identify this Public Directory server. This 
field is required.

● Server Address - Enter the network domain or IP address of the Public Directory 
server. This field is required.

● Login - If authorization is required by the Public Directory server, enter a valid user 
name in this field.

● Password - Enter the password for the user name specified in the previous field.

● Search Root - Enter an LDAP format string representing the type of information being 
sought. For example, ou=people, o=mycompany.com specifies that information 
under the organization unit of �people� within the organization of �mycompany.com� is 
used for the search. Refer to the documentation for your LDAP system and company 
database configuration for more information on Base DN or Search Root strings.

If you are unsure of the settings for your Public Directory server, contact the administrator 
of that system.

4. Select the Advanced tab if changes to the following defaults are required:

● Port: 389
● Search timeout: 200 (secs)

● Maximum number of entries returned per search: 200

5. After entering all necessary information, select the OK button.

Avaya IP Agent adds this Public Directory to the list of available services and closes the 
Directory Properties dialog box.
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Searching a Public Directory 
After a Public Directory service has been defined, a search against that database can now be 
performed. If a Public Directory service has not been defined, see Defining a Public Directory 
service on page 85.

Steps for searching a Public Directory
To search a Public Directory service:

1. In the Avaya IP Agent menu bar, select Tools > Search Public Directory.

Avaya IP Agent displays the Search Public Directory dialog box.

2. To select the Public Directory service to use, start by clicking the Directory Menu button.

Avaya IP Agent displays a menu listing all defined Public Directory services.

3. From the resulting list, select the Public Directory service that you will use.

The selected item from the menu is set as the active Public Directory service and the 
Directory Menu button displays its name.

Directory Menu button
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4. Click the Name field to view a list of available fields defined in this Public Directory service.

Note:
Note: If you have not connected previously to the Public Directory service, you must 

first run a query with the default settings. After this first query, all defined fields of 
the service will be available.

5. Select the field through which you want to conduct your search. The data field that you 
select appears as the label.

6. In the field to the right of the label, enter a string to search for within the selected data field 
and press the Enter key.

Avaya IP Agent sends the query to the Public Directory service, receives the data, and 
displays it in the Search Public Directory window.

For example, after setting the data type to Name, enter Smith in the field and press the 
Enter key.
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Tip:
Tip: You can use an asterisk as a wildcard for a string. For example, entering the 

string, j*n, returns all names beginning with a J and ending with an N with one 
or more characters in between. This could include entries such as John, but also 
entries such as Joseph Brown.

7. Right-click on an entry in the set of resulting data.

Avaya IP Agent displays a pop-up menu for the entry.

8. Select an action from the following table: 

If... Then...

You want Avaya IP Agent to dial the 
number listed for the selected entry

Select Call: Name.
If you have configured Avaya IP Agent to 
have multiple telephone numbers for each 
entry, another pop-up menu is displayed 
with this list of numbers. From this second 
list, select the number you want to call.

You want to compose an e-mail to the 
address associated with the selected entry

Select Send Email.

You want to view all available data for the 
selected entry

Select Properties.
Avaya IP Agent displays the Properties 
dialog box.

You want to add this entry to your Avaya IP 
Agent Phone Directory

Select Add to Directory.
Avaya IP Agent adds the name, telephone 
number, and e-mail address for this 
selection in the Phone Directory.
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Selecting the fields to display and the order 
Avaya IP Agent allows you to select which fields from the Public Directory service will be 
displayed in the Search Public Directory window.

Steps for displaying Public Directory fields
To configure which Public Directory fields will be displayed in the Search Public Directory 
window after a query and in which order they will be displayed:

1. From the main window menu bar, select Tools > Search Public Directory.

Avaya IP Agent displays the Search Public Directory window.

2. From the menu bar of the Search Public Directory window, select Edit > Field 
Organizer....
Avaya IP Agent displays the Field Organizer window.

Note:
Note: If the Field Organizer window does not contain any fields, you might need to first 

run a query of the Public Directory service with the default settings so that the list 
of available fields can be retrieved.

3. In the Available Fields list box, highlight the field you want to add to the Search Public 
Directory window.

You can highlight multiple fields in this list box by holding down the Ctrl key and clicking 
the cursor on each field name.
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4. After the necessary fields have been highlighted, select the right arrow button (>) to move 
the selected fields to the Show fields in this order list box.

The left arrow button (<) will remove the highlighted field from the Show fields in this 
order list box.

The double arrow buttons (<< and >>) will move all fields from one list box to the other.

5. To change the order of the fields in the Show fields in this order list box, highlight the 
field to move by clicking on it.

6. Use the up and down buttons at the bottom of the list box to move the position of the 
highlighted field.

7. Repeat Steps 5 and 6 for the pertinent fields to set the desired order.

8. Select the OK button.

Note:
Note: The selected fields and the associated order will not be displayed until you run a 

new query.

Identifying multiple telephone number fields 
Avaya IP Agent allows you to select multiple fields to be considered as telephone numbers. For 
example, the Public Directory service could have several numbers assigned to an individual, 
such as pager, fax, voice mail, mobile telephone, home telephone, and so forth.

When multiple telephone numbers are identified in Avaya IP Agent, the Call feature of the 
Search Public Directory window will ask you to select which of these numbers you want to 
call.

Steps for identifying telephone number fields
To select multiple telephone numbers to be available for the Call feature, perform the following 
steps:

1. From the main window menu bar, select Tools > Search Public Directory.

Avaya IP Agent displays the Search Public Directory window.



Chapter 8: Using a Public Directory with Avaya IP Agent

92 Avaya IP Agent Installation and User Guide for Citrix June 2007

 

2. From the Search Public Directory window menu bar, select Edit > Select Phone 
Numbers....
Avaya IP Agent displays the Select Phone Numbers window.

3. In the Available Fields list box, highlight the field you want to add as another telephone 
number for the contact.

You can highlight multiple fields in this list box by holding down the Ctrl key and clicking 
the cursor on each field name.

4. After the necessary fields have been highlighted, select the right arrow button (>) to move 
the selected fields to the Phone Number Fields list box.

5. Select the OK button.

Deleting a Public Directory service 
This section provides the procedure for deleting a Public Directory service from Avaya IP Agent.

Steps for deleting a Public Directory service
To delete a Public Directory service, perform the following steps:

1. From the main window menu bar, select Tools > Search Public Directory.

Avaya IP Agent displays the Search Public Directory window.

2. To select the Public Directory service to delete, click the Directory Menu button.

Avaya IP Agent displays a menu listing all defined Public Directory services.
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3. Select the Public Directory service from the Directory Menu.

The selected item from the menu is set as the active Public Directory service and the 
Directory Menu button displays its name.

4. Once again, click the Directory Menu button.

Avaya IP Agent displays Directory Menu.

5. From the Directory Menu, select Remove.

Avaya IP Agent deletes the active Public Directory service from Avaya IP Agent and sets the 
first remaining service as active.
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Chapter 9: Screen pops 

Screen pops are used to start an application or interface when an incoming call is received by 
Avaya IP Agent or when an outgoing call is placed.

Screen pops are most useful for the following actions:

● Starting an application so that the agent can enter customer or critical information 
regarding the call.

● Viewing data based on information transmitted with the call, such as customer information, 
the area from which they are calling, or the selections a customer made while being 
processed through a vector.

There are two types of screen pops:

● Windows application - This type of screen pop starts a Windows application, such as an 
HTML browser, a database interface, a trouble ticket program, or a custom application. 
This type of screen pop is also capable of passing parameters as part of an HTML string 
when it is initialized.

● Dynamic Data Exchange (DDE) - This type of screen pop retrieves information you specify 
from a call and passes it to a DDE server or application. The DDE server or application can 
then send information from its database or a file to an interface displayed on the personal 
computer.

This section includes the following topics:

● Creating a Windows application screen pop on page 96

● Creating a DDE screen pop on page 101

● Setting the active screen pop on page 105

● Modifying a screen pop on page 106

● Deleting a screen pop on page 107

Before you begin
Read and understand the following items before administering screen pops through Avaya IP 
Agent:

● Many DDE services have distinct features. For this reason, the complete syntax for a DDE 
query cannot be specified in this document. For information regarding your DDE service 
and how to query information from it, refer to the documentation supplied with that product.
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● User-to-User Information (UUI) is a unique identifier that is added to an incoming call 
through an external application, such as Avaya ASAI. To pass UUI, the Avaya 
communication server must have the Display UUI Information feature enabled. 
Additionally, the UUI feature does not support user-defined languages. This feature is only 
available for incoming calls, and it requires that a uui-info button is administered for the 
extension receiving the call.

Creating a Windows application screen pop 
This section provides the procedure for starting a Windows application when Avaya IP Agent 
receives an incoming call or an outgoing call is made.

Steps for creating an application screen pop
To create a Windows screen pop:

1. From the menu bar of the Avaya IP Agent window, select Tools > Screen Pops.

Avaya IP Agent displays the Screen Pops window.

2. Select File > New.

Avaya IP Agent displays the Screen Pops wizard.

3. Enter a name for this screen pop in the text box.

4. Ensure that the Window Explorer option button is selected.
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5. Select the Next button.

Avaya IP Agent displays the Screen Pops - Trigger window.
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6. Select the appropriate call condition from the following table:

7. If you want the screen pop to start when an incoming call appears on a specific VDN:

a. Place a check mark in the Pop the screen only when the VDN is check box.

b. In the associated field, enter the VDN name (up to 15 characters) that will cause this 
screen pop to run.

If... Then...

This screen pop should be run for 
incoming calls

Select one of the following options to 
indicate when it should start:
● Ringing - The screen pop starts 

when Avaya IP Agent receives an 
incoming call.

● Answered - The screen pop starts 
when an incoming call has been 
answered through the Avaya IP 
Agent interface or by picking up the 
handset in the Telecommuter 
configuration.

● Missed - The screen pop starts 
when the call appearance from an 
incoming call disappears after not 
being answered. This can be 
caused by the caller hanging up or if 
the call was routed to a voice mail 
system after a specific number of 
rings.

● Released - The screen pop starts 
when the Release button is pressed 
on a Call Information Panel (CIP) or 
when the agent hangs up the 
telephone in the Telecommuter 
configuration.

This screen pop should be run for 
outgoing calls

Select one of the following options to 
indicate when it should start:
● Connected - The screen pop starts 

when the party being called answers 
the telephone.

● Released - The Screen Pop starts 
when the Release button is pressed 
on a CIP or when the agents hangs 
up the telephone in the 
Telecommuter configuration.
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8. Select the Next button.

Avaya IP Agent displays the Screen Pop - Action window.

9. In the field provided, enter one of the following items:

● A Uniform Resource Locator (URL) address - This refers to a Web page. This could 
also include CGI scripts, java scripts, or many other Web-enabled tools.

● A filename - This can be any filename with an extension specified in the Windows 
Registry as having an associated application that is used to open it, for example,.HTM, 
.DOC, and .TXT. If a filename is specified that does not have a valid application 
association in the Registry, Windows will display an error message.

Note:
Note: If you enter a program name in the action field, be certain to enclose the program 

name in quotation marks. Failure to include the quotes may cause the screen pop 
to fail. For example: 

"C:\Program Files\Avaya\Avaya IP Agent\ipagent.exe"

10. Calls contain information that can also be included in this field as parameters of a URL 
address string. To include call information parameters with a URL string, select the arrow 
to the right of the field to display the Insert Call Data menu.

The information that may be available for retrieval from a call are:

● Caller Name (%n) - Passes the name of the other party on the call, if available

● Caller Number (%m) - Passes the telephone number of the other party on the call, if 
available

● Prompted Digits (%p) - Passes the digits the caller selected while being processed 
through a vector, if available.

● VDN (%v) - Passes the VDN name through which the call was connected

● UUI (%u) - Passes User-to-User-Information that was collected by the Avaya 
communication server from a centralized application.
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● Start Time (%s) - Passes the time when the telephone call was received by Avaya IP 
Agent

● Date (%d) - Passes the current date when the telephone call is received by Avaya IP 
Agent

You may also specify these parameters manually within the URL address string.

11. After entering the URL address or filename, select the Next button.

12. If you specified any parameters to be used in the Action window, you are presented with 
the Format Call Information window for each parameter. In this window, you can specify 
the number of characters or digits used for that parameter in the screen pop.

If you want to limit the number of characters presented for each parameter, do the 
following steps:

a. Enable the check box on the specific parameter screen.

b. Use the Number of characters to include and Location fields to adjust the 
boundaries of the string. 

c. After you have specified the boundaries of the parameter string, select the Next 
button.

If more than one parameter was specified in the Action dialog box earlier, the Format Call 
Information for the next parameter is presented. Select the Next button when you have 
finished configuring each parameter.

If there are no more parameters to configure, Avaya IP Agent displays the Testing dialog 
box.

13. Select the Test button to verify that the configuration of this screen pop works as intended.

If you are using parameters in your screen pop, you will be presented with another dialog 
box that allows you to enter Caller Name, Caller Number, Prompted Digits, VDN, and 
UUI as test information. Select the Continue button when all necessary test information 
has been entered in these fields.

Avaya IP Agent starts the screen pop.

14. After you have confirmed that the test of the screen pop was successful, close the screen 
pop and select the Next button on the Testing window.

Avaya IP Agent displays the Setup Completed window.

15. Select the Finish button.

Avaya IP Agent saves this screen pop and displays it in the Screen Pops window.
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Creating a DDE screen pop 
This section provides the procedure for starting a DDE screen pop when Avaya IP Agent 
receives an incoming call or when an outgoing call is made.

Steps for creating a DDE screen pop
To create a DDE screen pop:

1. From the menu bar of the Avaya IP Agent window, select Tools > Screen Pops.

Avaya IP Agent displays the Screen Pops window.

2. Select File > New.

Avaya IP Agent displays the Screen Pops wizard.

3. Select the Dynamic Data Exchange (DDE) option button.

4. Select the Next button.

Avaya IP Agent displays the Screen Pops - Trigger window.
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5. Select the appropriate call condition from the following table: 

6. If you want the screen pop to start when an incoming calls appears on a specific VDN:

a. Place a check mark in the Pop the screen only when the VDN is check box.

b. In the associated field, enter the VDN name (up to 15 characters) that will cause this 
screen pop to run.

If... Then...

This screen pop should be run for 
incoming calls

Select one of the following options to 
indicate when it should start:
● Ringing - The screen pop starts 

when Avaya IP Agent receives an 
incoming call.

● Answered - The screen pop starts 
when an incoming call has been 
answered through the Avaya IP 
Agent interface or by picking up the 
handset in the Telecommuter 
configuration.

● Missed - The screen pop starts 
when the call appearance from an 
incoming call disappears after not 
being answered. This can be 
caused by the caller hanging up or if 
the call was routed to a voice mail 
system after a specific number of 
rings.

● Released - The screen pop start 
when the Release button is pressed 
on a Call Information Panel (CIP) or 
when the agent hangs up the 
telephone in the Telecommuter 
configuration.

This screen pop should be run for 
outgoing calls

Select one of the following options to 
indicate when it should start:
● Connected - The screen pop starts 

when the party being called answers 
the telephone.

● Released - The screen pop starts 
when the Release button is pressed 
on a CIP or when the agent hangs 
up the telephone in the 
Telecommuter configuration.
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7. Select the Next button.

Avaya IP Agent displays the Action window.

8. In the Action window, enter the necessary DDE information for the following fields:

● Service - A string expression that identifies an application or DDE server that can 
participate in a DDE conversation. Usually, the application argument is the file name of 
a program for a Windows-based application. Do not specify the .EXE extension of the 
program

● Topic - A string expression that is the name of a topic recognized by the application 
argument. This will be the second parameter of the DDEInitiate() function.

! Important:
Important: Many DDE services have distinct features. For this reason, complete syntax for a 

DDE query cannot be specified in this document. For information regarding your 
DDE service, refer to the documentation supplied with that product.

9. Select which option will be used for the DDE conversation from the following list:

● Execute command - A string expression that specifies a command recognized by the 
server application. The string will only be changed to input caller information. The 
syntax must match the syntax required by the DDE program. For example, if 
embedded quotes are necessary, such as "name=""Smith""", you must enter the 
text string with all required quotation marks.

● Poke Item - A string expression that is the name of a data item recognized by the topic 
specified by the DDE Initiate() function.

Data - A string containing the data to be supplied to the other application.

10. Enter the appropriate information in the fields for the selected option. Use the arrow button 
to the right of the Execute command or Data fields to specify information for Avaya IP 
Agent to retrieve from the telephone call and pass to the DDE conversation.

The information that may be available for retrieval from a call are:
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● Caller Name (%n) - Passes the name of the other party on the call, if available

● Caller Number (%m) - Passes the telephone number of the other party on the call, if 
available

● Prompted Digits (%p) - Passes the digits the caller selected while being processed 
through a vector, if available.

● VDN (%v) - Passes the VDN name through which the call was connected

● UUI (%u) - Passes User-to-User-Information that was collected by the Avaya 
communication server from a centralized application.

● Start Time (%s) - Passes the time when the telephone call was received by Avaya IP 
Agent

● Date (%d) - Passes the current date when the telephone call is received by Avaya IP 
Agent

You may also specify these parameters manually within the string.

11. If you specified any parameters to be used in the Action window, you are presented with 
the Format Call Information window for each parameter. In this dialog box, you can 
specify the number of characters or digits used for that parameter in the screen pop.

If you want to limit the number of characters presented for each parameter, do the 
following steps:

a. Enable the check box on the specific parameter screen

b. Use the Number of characters to include and Location fields to adjust the 
boundaries of the string. 

c. After you have specified the boundaries of the parameter string, select the Next 
button.

If more than one parameter was specified in the Action window earlier, the Format Call 
Information window for the next parameter is presented. Select the Next button when you 
have finished configuring each parameter.

If there are no more parameters, Avaya IP Agent displays the Testing window.

12. Select the Test button to verify that the configuration of this screen pop works as intended.

If you are using parameters in your screen pop, you will be presented with another dialog 
box that allows you to enter Caller Name, Caller Number, Prompted Digits, VDN, and 
UUI as test information. Select the Continue button when all necessary test information 
has been entered in these fields.

Avaya IP Agent starts the screen pop.

13. After you have confirmed that the test of the screen pop was successful, close the screen 
pop and select the Next button on the Testing window.

Avaya IP Agent displays the Setup Completed window.
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14. Select the Finish button.

Avaya IP Agent saves this screen pop and displays it in the Screen Pops window.

Setting the active screen pop 
This section provides the procedure for specifying which screen pop will be set as the one used 
for incoming or outgoing calls.

Steps for setting an active screen pop
To set the active screen pop:

1. From the Avaya IP Agent main window menu bar, select Tools > Screen Pops.

Avaya IP Agent displays the Screen Pops window.

2. In the Name column, place a check mark next to the screen pops to use for all subsequent 
telephone calls.

It is possible to set multiple screen pops as being active if those screen pops do not 
conflict in their selection criteria. For example, if two or more screen pops are set to 
activate during a Ringing call, but are set for different VDNs, all of these can be active at 
the same time.

3. Close the Screen Pops window.

Avaya IP Agent saves this selection and uses the selected screen pops for any 
subsequent call, if applicable.
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Modifying a screen pop 
This section provides the procedure for modifying a screen pop that has already been created.

Steps for modifying a screen pop
To modify a screen pop:

1. From the Avaya IP Agent main window menu bar, select Tools > Screen Pops.

Avaya IP Agent displays the Screen Pops window.

2. Choose the screen pop that you want to modify and double-click it.

Avaya IP Agent opens the Screen Pops wizard and populates it with the data configured 
for this screen pop.

3. For each dialog, change the necessary configuration as needed and select the Next 
button to continue for each one.

See Creating a Windows application screen pop on page 96 or Creating a DDE screen 
pop on page 101 for specific information on each window of the Screen Pops wizard.

4. When you reach the Setup Completed window, select the Finish button.

Avaya IP Agent saves the changes made to the screen pop and closes the Screen Pops 
wizard.

5. Close the Screen Pops window.
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Deleting a screen pop 
This section provides the procedure for deleting a screen pop from Avaya IP Agent.

Note:
Note: Deletion of a screen pop cannot be undone.

Steps for deleting a screen pop
To delete a screen pop:

1. From the Avaya IP Agent main window menu bar, select Tools > Screen Pops.

Avaya IP Agent displays the Screen Pops window.

2. Highlight the screen pop to be deleted by clicking on it.

3. From the menu bar, select Edit > Delete.

The selected screen pop is deleted.

4. Close the Screen Pops window.
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Chapter 10: Dialog Reference 

This section provides descriptions of the graphical interfaces used in Avaya IP Agent and their 
basic functionality. Only those interfaces not described through other sections of this document 
are described here.

This section contains the following topics:

● Main window and menus on page 109

● Avaya IP Agent option dialogs on page 122

● Login Settings dialog box on page 133

● Volume and Ringer Settings dialog box on page 140

Main window and menus 
This section describes the menus and panels in the Avaya IP Agent main window.

This section includes the following topics:

● Menu bar on page 109

● Toolbars on page 117

● Information panels on page 120

● System Tray icon on page 121

Menu bar 
The Avaya IP Agent main window provides full-function, multi-line telephony support on your 
Windows session. This window is also used to access all the features found in Avaya IP Agent.

This section defines all of the items available in the Avaya IP Agent menus. Some menus and 
menu items are available only when they are valid for your current configuration. For example, 
the Call menu is not available when a call is not currently active. Other menus, menu items, and 
buttons on the interface will be disabled when the associated functionality cannot be used 
because of configuration, call instance, or agent work mode.

This section contains the following topics:

● File menu on page 110
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● Edit menu on page 111

● Call menu on page 112

● View menu on page 113

● Agent menu on page 114

● Tools menu on page 115

● Audio menu on page 116

● Help menu on page 117

File menu 

The following items are available on the File menu:

● Station Login, Station Logout - These items appear as the first item in this menu. They 
are used for logging the station or agent in and out of the Avaya communication server. 
This menu item varies between these two possibilities depending on your current login 
state.

● Import Settings - Selecting this menu item gives you the ability to open a file containing 
settings from another Avaya IP Agent installation and apply those settings to this 
installation.

● Export Settings - Selecting this menu item saves the settings from this installation of 
Avaya IP Agent to a file. This file can then be re-imported to this Server user session or to 
another Server user session with Avaya IP Agent.
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Note:
Note: When exporting and importing settings, most name changes to features in the 

Phone Features or Personal Phone Features windows are made on a per 
extension basis. To ensure that name changes are made for all extensions, 
right-click on the feature and select the Rename (All Extensions) item from the 
resulting menu. 

Exported settings are platform-dependent. If you export Avaya IP Agent settings from 
a Windows XP personal computer, do not import the settings to a personal computer 
that uses a different operating system.

Imported and exported files include the following settings:

- All settings available in the Program Options window
- Screen pops
- Lightweight Directory Access Protocol (LDAP) settings
- Personal Phone features
- Phone features
- Abbreviated Dialing settings
- Call Center features
- Telephone button labels
- Audio settings
- Speed-dial settings

● Exit - Selecting this menu item closes Avaya IP Agent after making the necessary logouts 
for the agent and the extension.

Edit menu 

The following items are available on the Edit menu:

● Cut - Removes any highlighted text in the Number field and places it on the Windows 
clipboard.

● Copy - Copies any highlighted text in the Number field and places it into any Windows 
application such as Notepad or Word.
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● Paste - Retrieves the last item placed on the Windows clipboard from any Windows 
application such as Notepad or Word and places it in the Number field.

Call menu 

The Call menu is available only when a call is made or received.

The following items are available on the Call menu:

● Release - Terminates an active call.

● Drop - Disconnects from a call without requiring you to hang up the handset, turn off the 
speakerphone, or press the switch hook.

! Important:
Important: 6400-series telephones must have a Drop button administered on the Avaya 

communication server in order for the Drop feature in the Avaya IP Agent window 
or menus to function properly.

● Hold - Places a call on hold until you can return to it. While the call is on hold, you can 
place another call, activate a feature, or answer another call.

● Transfer - Sends a call from your extension to another extension or outside number. Use 
this feature when the other party on the call needs to speak with someone else. There are 
three different types of transfers available.

The following types of call transfers are available with Avaya IP Agent:

- Basic Transfer - Select Transfer, dial the number on the keyboard or the Dial Pad, 
announce the call, and select Transfer again.

- Unsupervised Transfer - Select Transfer, enter the number to be called in the 
displayed dialog box, and select the OK button to transfer the call. You are not able to 
talk to the party receiving the transferred call with this type of transfer.

- Enhanced Transfer - Select Transfer, enter the number to be called in the displayed 
dialog, and select OK. You can announce the call and then, in the displayed message 
box, select OK to complete the transfer or Cancel to abort the transfer.
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● Conference - Adds other parties to a call. There are two different types of conferences 
available.

The following types of call conferencing are available with Avaya IP Agent:

- Basic Conference - Select Conference which displays another call appearance. Dial 
the number of the party to add to the conference through the keyboard or the Dial Pad, 
announce the conference to the new party, and select Conference again to add the 
new party.

- Enhanced Conference - Select Conference which displays a dialog box. Enter the 
number to call in the appropriate field, and select the OK button. After you announce 
the conference to the new party, select the Yes button in the resulting message box to 
add the new party.

View menu 

The following items are available on the View menu:

● Phone Display - Enabling this item displays a panel above the status bar. This panel can 
display information from sources such as VuStats or call-prompting digits.

● Dial Pad - Enabling this item displays a Dial Pad window, which contains a series of 
numbers and symbols resembling a telephone keypad. Use your mouse to dial numbers 
on the Dial Pad.

● Toolbars > Show Labels - Enabling this item displays labels for the buttons on the Phone 
buttons toolbar, the Agent toolbar, and the Phone features toolbar.

● Toolbars > Phone Buttons - Enabling this item displays the Phone buttons toolbar, which 
contains buttons for the Drop, Transfer, Conference, and Hold functions.
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● Toolbars > Dial Number - Enabling this item displays the Dial Number toolbar, which 
provides a field for entering digits. It also contains the buttons used to access the Call 
History feature, the Phone Directory feature, the Dial Pad, and the Search Public Directory 
feature.

● Toolbars > Audio Control -This item is not supported for the Windows Terminal Services 
edition of Avaya IP Agent.

● Toolbars > Agent - Enabling this item displays the Agent toolbar, which an agent can use 
to change their work modes. It also contains a Login/Logout button for agents.

● Toolbars > Phone Features - Enabling this item displays the Phone features toolbar, 
which is populated with previously selected folders from the Phone Features window. 
When you select a folder on this toolbar, a list is displayed with all of the available features 
that are currently assigned to that folder.

● Toolbars > Feature Buttons - Enabling this item displays the Feature button toolbar, 
which is populated with previously selected buttons from the Phone Features window. 
Buttons on this toolbar have an associated lamp that identifies the status of the feature the 
button represents.

● Toolbars > Headset - Enabling this item displays the Headset toolbar, which contains a 
button for answering a call or creating a new call appearance when a call is not currently 
active.

● Status Bar - Enabling this item displays the Status Bar at the bottom of the Avaya IP Agent 
main window. The Status Bar displays different types of information, such as current 
activity, notification of voice messages, the state of Avaya IP Agent, and tooltips.

● Alternate Interfaces - This menu item lists all alternate user interfaces that have been 
installed with Avaya IP Agent. The alternate user interfaces use much less desktop space 
than the default interface. See Using alternate user interfaces on page 52 for more 
information.

Agent menu 

The following items are available on the Agent menu:

● Agent Login - This item displays the Agent Login dialog box for entering your EAS Agent 
login ID number and password.
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● Agent Logout - This item enables you to log out so that calls are not routed to this 
extension.

● Auto-In Mode - This is an Automatic Call Distribution (ACD) work mode. Agents in the 
Auto-In mode are available to receive new calls upon completion of the current call.

● Manual-In Mode - This is an ACD work mode. Agents must use the Manual-In feature to 
re-enter the AVAIL (Available) work mode from the AUX (Auxiliary Work) work or the ACW 
(After Call Work) work mode.

● After Call Work (ACW) - This is an ACD work mode that indicates that an agent is 
performing tasks related to the last call.

● Auxiliary Work Mode (AUX) - This is an ACD work mode that indicates that an agent is 
not available to receive an ACD call. Depending on how the ACD is administered, the AUX 
work mode can require that agents provide a reason code before the work mode can be 
assigned. Multiple Auxiliary Work buttons with different reason codes can be assigned to 
an extension.

● Assist - This item initiates a request for assistance from a skill supervisor.

Tools menu 

The following items are available on the Tools menu:

● Phone Features - Selecting this item displays the Phone Features window which, lists 
the feature buttons that have been assigned to this extension.

● Personal Phone Features - Selecting this item displays the Personal Phone Features 
window, which is used to create a smaller list of phone features that are used often or for 
ease of access.

● Call History - Selecting this item displays the Call History window, which displays a log of 
all calls received by this extension. This log includes name, number, date, time, duration, 
and call notes.

● Phone Directory - Selecting this item displays the Phone Directory window, which is 
used to store names, addresses, phone numbers, and other information. See Using the 
Phone Directory on page 77 for more information.
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● Search Public Directory - Selecting this item displays the Search Public Directory 
window, which allows you to search Lightweight Directory Access Protocol (LDAP) servers 
by any field defined in the public directory. See Using a Public Directory with Avaya IP 
Agent on page 85 for more information.

● Screen Pops - Selecting this item displays the Screen Pops window, which lists all the 
screen pops that are defined on this personal computer. See Screen pops on page 95 for 
more information.

● VuStats Monitor - Selecting this item displays the VuStats Monitor window, which is used 
to view the VuStats information being sent to this extension. See Using VuStats on 
page 57 for more information.

● Program Options - Selecting this item displays the Program Options dialog box for 
Avaya IP Agent. See Avaya IP Agent option dialogs on page 122 for more information.

Audio menu 

Note:
Note: The playing of ring sounds through Windows Terminal Services is supported 

when the client uses Microsoft Remote Desktop and Citrix ICA software. The 
client cannot access the server through Terminal Services Client software.

The following item is available on the Audio menu:

● Volume and Ringer Settings - Selecting this item displays the Volume and Ringer 
Settings dialog box. Through this dialog box, you can adjust the volume for your ringer or 
mute it.

For more information, see Volume and Ringer Settings dialog box on page 140.
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Help menu 

The following items are available on the Help menu:

● Contents - Selecting this item displays the table of contents for Avaya IP Agent online 
help.

● About Avaya IP Agent - Selecting this item displays the About dialog box which provides 
product information for Avaya IP Agent.

Toolbars 
This section provides descriptions and additional information on the toolbars of the Avaya IP 
Agent window. Toolbars contain buttons that provide quick access to specific commands and 
tools. Toolbars can be added or removed from the main window by selecting each one in the 
View menu on page 113.

This section contains the following topics:

● Toolbar locations on page 117

● Phone buttons toolbar on page 118

● Dial Number toolbar on page 118

● Agent toolbar on page 119

● Phone features toolbar on page 119

● Feature button toolbar on page 119

● Headset toolbar on page 120

Toolbar locations 

Each toolbar can be moved to any location in the main window.
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To move a toolbar:

1. Move the mouse pointer on the far-left side of the toolbar until the mouse pointer changes 
its appearance to the resizing icon.

2. Click and hold the left mouse button.

3. Drag the toolbar to the necessary location. The toolbar will change positions as you move 
it over different areas of the main window.

4. When the toolbar is correctly positioned in its new location, release the left mouse button.

Phone buttons toolbar 

The Phone buttons toolbar provides quick access to the basic phone buttons: Hold, Drop, 
Transfer, and Conference.

The Transfer and Conference buttons provide drop-down lists that allow the agent to select the 
type of transfer or conference to make.

Dial Number toolbar 

The Dial Number toolbar contains the Number field for entering telephone numbers to dial. 

Additionally, this field can be used to enter the first characters of a name from the Phone 
Directory. If the first character of the string entered in this field is a letter, the title of the field will 
be changed from Number to Name. When you enter a partial name in this field and press the 
Enter key or click the telephone button on the right side of the field, a list is displayed with all 
entries in the Phone Directory that match the string of characters. 

For example, entering Sm in the field and pressing the Enter key could display a pop-up menu 
with the following entries in the Phone Directory:

This field will search for entries only in the Phone Directory. It cannot be used to search a 
public directory (LDAP).

This toolbar also contains the following features that you can access with a single click:

● Dial Pad window

● Phone Directory window
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● Speed-dial drop-down list

● Call History window

● Recent call drop-down list

● Search Public Directory window

Agent toolbar 

The Agent toolbar provides buttons for agent login and logout, as well as agent work modes for 
Avaya communication servers with Expert Agent Selection (EAS).

Note:
Note: If multiple Auxiliary Work buttons with differing reason codes are assigned to this 

extension, an arrow is displayed to the right of the Aux Work button. When you 
select this arrow, a menu that lists all of the Auxiliary Work reason codes is 
displayed. Select the appropriate reason code from this menu.

Phone features toolbar 

The Phone features toolbar can display one or more folders from the Phone Features window. 
When you click a button in this toolbar, Avaya IP Agent displays a list of the items contained 
within the associated folder. 

To display items on this toolbar, open the Phone Features window, right-click on the folder that 
you want to display, and select Display on Toolbar.

Note:
Note: This toolbar can support a maximum of seven buttons.

Feature button toolbar 

The Feature button toolbar can display one or more items from the Phone Features window. 

To display items on this toolbar, open the Phone Features window, right-click on a feature that 
you want to display, and select Display on Toolbar.

Note:
Note: This toolbar can support a maximum of seven buttons.
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Headset toolbar 

The Headset toolbar contains a button used to toggle the headset or handset on and off hook.

Note:
Note: If this station has been set as a 606A1 phone type on the Avaya communication 

server, this button may not function properly in the Telecommuter configuration.

Information panels
This section contains descriptions and information on the areas of the main window that display 
information to the user.

There are three different types of panels in Avaya IP Agent, which are described in the following 
topics:

● Call Information Panel on page 120

● Agent Information Panel on page 121

● Phone Display Panel on page 121

Call Information Panel

Avaya IP Agent displays the Call Information Panel (CIP) only during incoming and outgoing 
calls. It provides information about the call, such as call status, call display, call duration. It also 
displays an Answer/ Release/ Reconnect button. 

If a call is currently active and the other party is listed in the Phone Directory, that name is 
displayed in the CIP instead of the information passed from the ACD.

The call status, incoming, outgoing, or on-hold, is displayed in the first section. Right-click the 
CIP to display a pop-up menu containing available options for this call, such as hold, transfer, 
and conference.

The timer in this panel displays the amount of time that has elapsed for a call and the work done 
in a subsequent non-active work mode, such as ACW. When an agent enters Auto-In or 
Manual-In mode, the timer is reset to 0.

Note:
Note: To disable the call timer, see How to remove the call timer on page 154.
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Agent Information Panel 

Avaya IP Agent displays the Agent Information Panel when agent status information is available 
and no calls are currently active. If you are logged in as an agent, the status information also 
includes the current agent work mode.

Phone Display Panel 

The Phone Display Panel is a 40-character display that is located above the Status Bar. This 
display area is updated automatically with call-related and non-call-related information from the 
Avaya communication server, such as call-prompting digits, VuStats data, and the local date 
and time display from the ACD. Only those telephone types that are capable of displaying 80 
characters are compatible with this feature. See Compatible telephone types for Avaya IP 
Agent on page 14 for compatible telephone types.

System Tray icon 
The Avaya IP Agent System Tray icon is an easy way to access commonly used features and to 
change your agent work mode.

To display the System Tray icon menu, right-click the icon.

If you are not logged in as an agent, the work mode entries in this menu will not be displayed.

Placing calls through the System Tray icon

If you highlight a telephone number, right-click the selection, and select Copy, that number is 
saved to the Windows clipboard. Then, if you right-click the Avaya IP Agent System Tray icon, 
the top item of the resulting pop-up menu will display the telephone number that you copied to 
the clipboard.

Allow for calling telephone numbers with letters, such as 1-800-GO-AVAYA.
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Call handling with the System Tray icon

The Avaya IP Agent System Tray icon can also be used to access common telephone 
functionality, such as placing a call on Hold.

To use the capability, you must be on a call when you right-click the System Tray icon.

Avaya IP Agent option dialogs 
Use the Program Options dialog box to configure the many feature areas of Avaya IP Agent. 
Select Tools > Program Options... to display this dialog box.

This section contains descriptions for the following panels of the Program Options dialog box:

● General Settings panel on page 123

● ACD Agent panel on page 124

Avaya IP Agent
System Tray icon

dialing item
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● Call Handling panel on page 125

● Call History panel on page 126

● Call Information Display panel on page 127

● User Interface Options panel on page 128

● External Number Format panel on page 129

● Event Logging panel on page 130

● Voice Message Number panel on page 131

● Feature Access panel on page 132

General Settings panel 

The General Settings panel contains the following items:

● Enable automatic login - When this check box is enabled, Avaya IP Agent attempts to 
register with the Avaya communication server when started. It will use the information that 
was last used for a successful registration with the Avaya communication server.

● Enable support for auto-answer - When this check box is enabled, Avaya IP Agent 
automatically connects an incoming call without requiring the agent to pick up the handset 
or select the Answer or headset buttons on the main window. For this functionality, the 
auto-answer feature on the Avaya communication server must be assigned to this 
extension. After activating support for auto-answer, you must restart Avaya IP Agent.
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ACD Agent panel 

The ACD Agent panel contains the following items:

● Configure program for EAS agent support - When this check box is enabled, Avaya IP 
Agent supports the Expert Agent Selection (EAS) feature for Avaya communication 
servers. Otherwise, Avaya IP Agent supports a non-EAS environment. EAS environments 
use skills and non-EAS environments use splits.

● Prompt for agent ID and password during agent login - When this check box is 
enabled, Avaya IP Agent displays a dialog box when an agent requests a login to the 
Avaya communication server. The dialog box prompts the agent for agent ID and 
password.

● Save agent password during agent login - When this check box is enabled, Avaya IP 
Agent saves the password of an agent after a successful login.

● Automatically log into the ACD - When this check box is enabled, Avaya IP Agent 
attempts to automatically log the agent in to the Avaya communication server after 
successful extension registration.
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Call Handling panel 

The Call Handling panel contains the following items:

● Call Transfer - Use Basic Transfer - Selecting this option sets the default transfer mode 
to the basic method.

● Call Transfer - Use Unsupervised Transfer - Selecting this option sets the default 
transfer mode to the unsupervised method.

● Call Transfer - Use Enhanced Transfer - Selecting this option sets the default transfer 
mode to the enhanced method.

● Call Conferencing - Use Enhanced Conference - Enabling this check box sets the 
default conferencing mode to the enhanced method. Otherwise, Avaya IP Agent uses the 
basic conferencing mode.

Note:
Note: The default transfer mode in this panel is changed if you select a different transfer 

mode from the main window. For example, if you set Use Basic Transfer in this 
panel, but select to use an Enhanced Transfer from the main window, Use 
Enhanced Transfer is now set as the default in this panel.
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Call History panel 

The Call History panel contains the following items:

● Log incoming calls - When this check box is enabled, Avaya IP Agent makes a record of 
all calls received at this station in the Call History log.

● Log outgoing calls - When this check box is enabled, Avaya IP Agent makes a record of 
all calls made from this station in the Call History log.

● Months to keep calls in log - Use this field to specify the number of months for which 
records are stored in the Call History log.

● Number of recent calls displayed - Use this field to specify the number of records that 
are displayed when you click the Call History quick list on the Dial Number toolbar.

● Clear history - Selecting this button clears all records from the Call History log.
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Call Information Display panel 

The Call Information Display panel contains the following items:

● Display call information on the title bar during a call - When this check box is enabled, 
Avaya IP Agent displays information about the active call in the title bar of the main 
window.

● Replace call information with phone directory entry - When this check box is enabled, 
Avaya IP Agent uses the information from the Phone Directory if the telephone number 
for the active call is found. If the telephone number for the active call is not found, the call 
information from the Avaya communication server is displayed.

● Display call information using Japanese font - When this check box is enabled, Avaya 
IP Agent displays all information in Japanese. This feature is available only if the Japanese 
version of Avaya IP Agent was installed.

● Enter the size of the font to be used to display call information on Call Information 
Panel - Use this field to select the point size of the font that Avaya IP Agent uses to display 
call information in the Call Information Panel on the main window.
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User Interface Options panel 

The User Interface Options panel contains the following items:

● Always display the main window on top - When this check box is enabled, Avaya IP 
Agent always appears in the foreground of your Windows desktop, in front of all other 
application windows.

● Display tooltips for toolbars - When this check box is enabled, tooltips appear when the 
mouse cursor is placed over buttons on the toolbars of the main window.

● Display letters on the dialpad - When this check box is enabled, the Dial Pad displays 
the letters that correspond to the numbers on the number pad of a telephone.

● Display the Shortcut icon in the system tray - When this check box is enabled, the 
Avaya IP Agent icon is displayed in the System Tray on the Windows task bar.

● Incoming Calls - Display the main window for incoming calls - When this check box is 
enabled and a call is received, the main window is displayed in front of any other 
application windows that are currently open.

● Incoming Calls - Flash window for incoming calls - When this check box is enabled, 
the title of the main window in the task bar flashes when a call is incoming. This behavior 
resembles selection and de-selection of the window.
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External Number Format panel 

Note:
Note: The first three controls in this panel are automatically disabled if you have set 

your dialing properties for the United States. The controls are only available for 
those countries outside of the United States.

For countries outside the United States, information must be provided in this panel 
regarding the format of telephone numbers within the country. Using this panel, you 
can set the maximum and minimum length of telephone numbers used within the 
country, including city codes. This information determines when the code for another 
country should be added to a telephone number so that the number can be stored in 
the correct format.

The External Number Format panel contains the following items:

● Maximum number of digits in city code - Specify the number of digits that are dialed for 
telephone numbers that use a code to identify a city.

● Minimum number of digits in phone number, including city code - Specify the fewest 
number of digits that can be used to dial an external call. This number should also include 
the code used to identify a city.

● Maximum number of digits in phone number, including city code - Specify the largest 
number of digits that can be used to dial an external call. This number should also include 
the code used to identify a city.

● Enable 7 digit dial plan for internal calls - Enable this check box if your contact center 
uses a seven-digit dial plan. Dial plans of more than five digits are available only through 
MultiVantage or Communication Manager systems. When this check box is enabled, 
Avaya IP Agent treats a dialed number consisting of seven digits as an internal extension.
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Event Logging panel 

The Event Logging panel contains the following items:

● Enable logging for IP Agent - When this check box is enabled, all associated program 
activity is recorded. Avaya support personnel use this information to determine the cause 
of any problems with Avaya IP Agent.

● View Log - Select this button to display the Avaya IP Agent log file.

● Monitor - Select this button to display the Events Monitor window. This window displays 
all Avaya IP Agent events that are recorded with the logging feature. This window displays 
information only if the Enable logging for IP Agent check box is enabled.
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Voice Message Number panel 

The options on this dialog determine what action is taken when you click the voice message 
icon in the System Tray.

Note:
Note: This icon is displayed only when voice messages exist for an extension.

The Voice Message Number panel contains the following items:

● Do nothing - Avaya IP Agent does not initiate any action when you click the icon.

● Dial this number - Select this option and provide a telephone number or extension to dial 
in the associated field. When you click the icon, Avaya IP Agent dials the number in this 
field.

● Use Application - Select this option and provide the path and filename of an executable 
program file for Avaya IP Agent to run when you click the icon.

● Goto URL - Select this option and provide a Uniform Resource Locator (URL) address 
that will be opened when you click the icon.
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Feature Access panel 

! Important:
Important: In order for the Disable Modification feature to function properly, an 

administrative password must be set through the Set Password button. If a 
password is not set, the Disable Modification check box can have a check mark 
placed in it, but it cannot restrict users from modifying any options because a 
password must be used for validation.

Use the Feature Access panel to restrict users from administering or making changes to the 
various features of Avaya IP Agent. When any changes are made to these feature areas, you 
must restart Avaya IP Agent for these restrictions to take effect.

The Feature Access panel contains the following items:

● Feature List - Each of the Avaya IP Agent areas listed in this box can be protected from 
modifications. To select a feature area, click on the feature in this list.

● Disable Access - When this check box is enabled, users are restricted from accessing the 
specified feature panel. This option is not available for the Program Options feature. 
When access to a feature is disabled, the feature does not appear in the menus on the 
menu bar of the main window.

● Disable Modification - When this check box is enabled, users cannot alter the feature.

● Disable Selection - When this check box is enabled, users cannot activate a screen pop 
by double-clicking it in the Screen Pops window.

● Set Password/Enter Password - Select this button to display the Change Password... 
dialog box. When you enter a password, the options for the Feature Access dialog box 
cannot be changed until the proper password is entered.
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Note:
Note: The Event Logging panel is always available, even if you have restricted access 

to all features. In this manner, agents can activate logging without administrator 
intervention. You should need to record event logs only if they are requested by 
Avaya technical support personnel.

Login Settings dialog box 
Use the Login Settings dialog box to specify the necessary data for the Telecommuter 
configuration. This dialog box is accessed by pressing the Settings button on the Login 
window that is used to register with an Avaya communication server.

This section contains the following topics:

● Login tab on page 134

● Call Server tab on page 135

● Audio tab on page 136

● Emergency tab on page 137

● Advanced tab on page 138
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Login tab 

The Login tab of the Login Settings dialog box contains the following controls:

● Extension - The extension number used in conjunction with Avaya IP Agent.

● Password - The numeric password associated with the specified extension number.

● Remember password for next login session - When this check box is enabled, the 
Login window retains the password used to register this extension number with the Avaya 
communication server. If you are concerned about the possibility of unauthorized persons 
assuming this identity, leave this check box blank.

● Automatically login if possible when application restarts - When this check box is 
enabled, logging in to the Avaya communication server is attempted automatically when 
Avaya IP Agent is started.

● Dialing Location - Specify the dialing configuration that Windows should use when 
making telephone calls. For example, an agent using a notebook computer may have one 
configuration that dials 9 for an outside line when in the office, and a separate 
configuration that does not dial 9 when the notebook computer is used in other locations.

● Properties - Select this button to display or modify the configuration specified in Dialing 
Location list.
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Call Server tab 

The Server tab of the Login Settings dialog box contains the following controls:

● Primary Server Address - This field contains the domain name or IP address of the 
Avaya communication server that this extension will connect to.

● Alternate Server Addresses - This list box is automatically populated after registration of 
the Avaya communication server, specified in the Primary Server Address field, 
completes successfully. If communication with the primary Avaya communication server 
fails after Avaya IP Agent successfully registers with it, Avaya IP Agent attempts to use the 
other Avaya communication servers in this field.

● Number of alternate servers - This area displays the number of communication servers 
that are available in the Alternate Server Addresses field.

● Add - This button allows manual addition of an Avaya communication server to the list of 
alternate Avaya communication servers.

● Remove - Select this button to remove the currently highlighted communication server in 
the Alternate Server Addresses list. Removing an Avaya communication server from the 
list in this manner affects only the current Avaya IP Agent session. If you log off from the 
Avaya communication server or shut down Avaya IP Agent and then reconnect, this list of 
alternate server addresses is again refreshed from the list kept on the Avaya 
communication server.
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Audio tab 

The Audio tab of the Login Settings dialog box contains the following controls:

● Road Warrior (Voice over IP) - This field is not supported for the Windows Terminal 
Services edition of Avaya IP Agent.

● Bandwidth Setting - This field is not supported for the Windows Terminal Services edition 
of Avaya IP Agent.

● Telecommuter - Select this option to specify that the data channel is routed through the 
personal computer using Internet Protocol and that voice communications are conducted 
through a telephone. This is the only option available for the Windows Terminal Services 
edition of Avaya IP Agent.

● Telephone at - Enter or select the telephone number through which voice communications 
are to be conducted.
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Emergency tab 

The Emergency tab of the Login Settings dialog box contains the following controls:

● Enable Emergency Call Handling feature - When this check box is enabled, Avaya IP 
Agent notifies the Avaya communication server that this endpoint supports this feature and 
that emergency calls placed from this endpoint should transmit the specified telephone or 
extension number to emergency services.

● Your extension number - Select this option if you want your extension number to be 
transmitted to emergency services personnel when an emergency call is made.

● Telephone number - Select this option if you want a specific telephone number to be 
transmitted to emergency services personnel when an emergency call is made. Enter the 
telephone number in the associated field. See Configuring the Emergency Call Handling 
Service on page 37 for more information regarding this feature.
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Advanced tab 

The Advanced tab of the Login Settings dialog box contains the following controls:

● Choose from the following port range to communicate with the server - When this 
check box is enabled, Avaya iClarity IP Audio will use the port range that you specify in the 
associated fields. This feature is used to restrict the Avaya iClarity IP Audio to a limited 
range of ports with which to communicate through a network firewall. Avaya iClarity IP 
Audio uses the UDP and TCP/IP protocols in association with this range.

Note:
Note: The range specified must cover a range of at least 100 ports.

● Lowest port number - Enter the lowest port that Avaya iClarity IP Audio will use. The 
minimum for this field is 1025.

● Highest port number - Enter the highest port that Avaya iClarity IP Audio will use. The 
maximum for this field is 65535.

Audio Port Range Administration 

On the Avaya communication server, use the UDP Port Range fields on the IP Network 
Region administration screen to configure the port selections for an IP endpoint.
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Prior to administering the audio port range values, you must set the IP network region with 
which the endpoint will be associated. See the documentation for your Avaya communication 
server for information on network regions.

It is important that the intersection of the audio port ranges set for Avaya iClarity IP Audio and 
for the Avaya communication server overlap by at least 100 ports. In the event that the overlap 
is less than 100, the range reported by the Avaya communication server is ignored.

For example, if the port range is set to 51000-51100 and the Avaya communication server 
reports an audio port range of 50950-51005, then the overlap is 5 and Avaya iClarity IP Audio 
ignores the range reported by the Avaya communication server.

Note:
Note: The Avaya communication server may require that you enable ports 1719 and 

1720 on your firewall for proper communication.
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Volume and Ringer Settings dialog box 

The Volume and Ringer Settings dialog box contains the following applicable items:

Ringer
● Volume - Use this slider to adjust the volume of the sound that is played through your 

speakers or headset that occurs when you receive an incoming call.

● Mute - Enable this check box to eliminate any sound that indicates an incoming call.

Note:
Note: The unavailable fields you see displayed on this window are not supported for the 

Windows Terminal Services edition of Avaya IP Agent.
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Appendix A: Shortcut keys 

This section contains quick reference information for shortcut keys.

Shortcut keys refer to key combinations that you can use to invoke a particular command. For 
example, to place a call on hold, you can press Ctrl + H. Some of the most commonly used 
shortcut keys are shown in this section. In order for shortcut keys to work as documented, the 
Avaya IP Agent window must have focus as the current application.

Shortcut key functions
This section contains the shortcut keys that can be used when the Avaya IP Agent is the 
currently selected window on your desktop. These shortcut keys are divided into the following 
categories:

● Call features on page 141

● Agent features on page 142

● Avaya IP Agent features on page 142

● Windows features on page 143

Call features 

To... Press...

Place a call on hold Ctrl + H

Transfer a call Ctrl + T to dial the number and then again 
to transfer the call

Conference another party Ctrl + F to dial the number and then again 
to conference the call
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Agent features 

Avaya IP Agent features 

To... Press...

Log in Ctrl + Ins

Log out Ctrl + Del

Change to After Call Work (ACW) mode Ctrl + W

Change to Auxiliary Work (AUX) mode Ctrl + A

Change Available mode assignment to automatic (Auto-In) Ctrl + I

Change Available mode assignment to manual (Manual-In) Ctrl + M

Request supervisor assistance (Assist) Ctrl + S

Mark an event log entry Ctrl + E
Use this key combination 
to place an identifier on a 
line in the event log. This 
can be used to indicate 
when you notice a 
problem. This feature is 
only available when the 
event logging feature is 
enabled.

To... Press...

Display the Call menu for an incoming call Alt + C

Display the Call History window Alt + H

Display the Phone Directory window Alt + D

Display the Search Public Directory window Alt + S

Display online help F1
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Windows features 

Exit Avaya IP Agent or close the current active window Alt + F4

View the Properties of the selected item in the Search 
Public Directory, Screen Pops, or Phone Directory 
windows.

Alt + Enter

To... Press...

To... Press...

Alternate between running applications Alt + Tab

Cut selected text to the clipboard Ctrl + X

Copy the selected text to the clipboard Ctrl + C

Paste clipboard contents to the selected area Ctrl + V
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Appendix B: Language support

This section contains quick reference information for supported languages.

Untranslated components
The following Avaya IP Agent components are provided only in English:

● Installation

● Event log

● Avaya IP Agent internal files

● Shortcut keys

● readme.txt file 

● Uninstall program

Supported languages for Avaya IP Agent
The following languages are supported with Avaya IP Agent:

● English (US)

● Italian

● French

● German

● Portuguese (Brazilian)

● Spanish

● Japanese

● Korean

● Chinese (Simplified)
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The English version of Avaya IP Agent can be installed on supported operating systems using 
the languages specified above. Other language versions of Avaya IP Agent can be installed 
only on supported operating systems using that language. For example, the German version of 
Avaya IP Agent can be installed only on supported operating systems using German.
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Appendix C: Troubleshooting 

This section contains information used for troubleshooting problems with Avaya IP Agent. It is 
divided into the following topic areas so that it is easy for you to locate the information that you 
need:

● Diagnostic log files on page 147

● Login on page 148

● Making and receiving calls on page 150

● Other on page 152

● Alternative solution possibilities on page 154

Diagnostic log files
In the event an unhandled exception occurs in IP Agent, two log files will be generated in the 
<application data>\Log Files folder. If IP Agent is installed into the default directory, the log 
files will be found in:
C:\Documents and Settings\<user>\Application Data\Avaya\Avaya IP Agent\Log Files 

The following table describes the generated log files:

Filename Contents

Diagnostic_(mm-dd-yyyyhh.mm.ss).dmp1 The captured binary mini-dump file generated when an 
unhandled exception occurs in ipagent.exe.

Module_List_(mm-dd-yyyy hh.mm.ss).txt Ascii text file which includes summary information 
regarding the unhandled exception and a version listing 
of the modules loaded at application runtime.

1.  The mm-dd-yy hh.mm.ss value indicates the local system time when the exception occurred. Usethe timestamp to 
pair the Diagnostic and Module List files together.
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Login 
This section lists those problems associated with registering with the Avaya communication 
server and logging in as an agent.

Problem What to do

Cannot register with the Avaya 
communication server.

Check for a valid configuration:
● Avaya IP Agent has limited support for 

firewalls and Virtual Private Networks 
(VPN). See Advanced tab on page 138 
for more information on configuring 
Avaya IP Agent for use with VPNs.

● An Avaya communication server earlier 
than DEFINITY R10 cannot be used for 
Avaya IP Agent. MultiVantage and 
Communication Manager servers are 
fully supported.

● Ensure that the network connection 
from the personal computer is 
operating normally.

● Ensure that the integrated firewall 
feature of Windows XP is disabled. If 
this feature is enabled, iClarity IP Audio 
cannot function properly.

Agents cannot log in to EAS. Ensure that the following administration 
items have been addressed:
● Feature Access Codes are 

administered.
● If the Avaya communication server has 

the station set for Auto-answer, ensure 
that Avaya IP Agent has the Enable 
support for auto-answer option 
enabled in the Program Options 
window. 

● Ensure that the station is configured for 
an AUX button. Without this button, 
agents cannot log in correctly if the 
Avaya communication server is 
configured so that agents must enter 
AUX work mode when logging in to 
EAS.

You changed your login extension but the 
Avaya communication server does not 
recognize your login.

Restart your personal computer and 
attempt the login procedure again.
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The agent does not seem to be logged in 
because all of the icons are still disabled.

Verify the following configuration items:
● On the Avaya communication server, 

verify that the station has the following 
work mode features assigned to 
buttons. If these buttons are not 
assigned to the station, Avaya IP Agent 
cannot enable the work modes on 
Agent toolbar:
- Auto-in or Manual-in
- After Call Work (ACW) (optional)
- Auxiliary Work (AUX). 

● On the Avaya communication server, 
verify that the first AUX work mode 
button assigned to the station has a 
blank reason code or a reason code of 
0.

The agent logs in but is immediately logged 
out.

If the station or agent is administered as 
auto-answer on the Avaya communication 
server, you must activate Enable support 
for auto-answer in the Program Options 
for Avaya IP Agent. After changing this 
setting in Avaya IP Agent, you must restart 
Avaya IP Agent for the change to take 
effect. 

Agents are logged off repeatedly from EAS 
or the Avaya communication server.

● Ensure that the network is not having 
stability problems or failures in service.

● On the Avaya communication server, 
ensure that the Auto-In field for the 
agent is set to station and not aux. 
Also, ensure that the Enable 
automatic login option in the Program 
Options dialog for Avaya IP Agent is 
activated.

Problem What to do
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Making and receiving calls 
This section lists problems that are associated with placing outgoing calls and receiving 
incoming ACD calls through Avaya IP Agent.

Problem What to do

Agents cannot place calls. ● Ensure that the agent is logged in.
● Check the Windows Dialing Properties 

to rule out improper number formatting. 
Dialing rules must conform to the 
dialing rules of the country in which the 
Avaya communication server resides.

● Ensure that calling cards are not being 
used.
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Picking up the handset does not 
automatically answer the incoming call 
displayed in the Avaya IP Agent window.

● Ensure that the Service Link 
Mode: for the station is set to 
as-needed.

● Ensure that the Enable support for 
auto-answer option is disabled. This 
option is found in the Program 
Options in Avaya IP Agent. If this 
option is enabled, disable it and then 
reboot your personal computer.

● The auto-answer feature must be 
configured in Avaya IP Agent and for 
the station definition on the Avaya 
communication server.

The Avaya IP Agent main window does not 
display that a call is incoming until the 
second or third ring.
The main window is very slow in displaying 
the Call Information Panel for an incoming 
call.

● The processor of the personal 
computer is being used too heavily. To 
resolve this problem, close one or more 
applications to decrease the load on 
the processor.

● A virus scanning program is monitoring 
and validating the activity of the 
executable files for Avaya IP Agent and 
any log files. To resolve this problem, 
configure the virus scanning 
application to not scan the directory 
where Avaya IP Agent was installed. 
By default, this location is as follows: 
C:\Program Files\Avaya\
Avaya IP Agent
Alternatively, you can configure your 
virus scan program to scan instances 
only where program files are written to 
instead of all file types. This will 
decrease the necessity of your virus 
program to scan the log files that are 
modified in Avaya IP Agent when a call 
is received.

● Ensure that there is enough network 
bandwidth for Avaya IP Agent to 
receive the data channel information in 
a timely manner.

Problem What to do
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Other 
This section lists general problems that one might encounter with Avaya IP Agent.

Problem What to do

Collected digit information is not displayed. ● You must have a callr-info button 
assigned for non-Callmaster 
telephones so that collected digit 
information is displayed. Buttons are 
configured for extensions through the 
change station command on the 
Avaya communication server.

● Ensure that VuStats is deactivated. 
This can be done by double-clicking on 
the Normal Mode button in the Phone 
Features window.

User-to-User-Information (UUI) is not being 
displayed.

On the Avaya communication server, 
ensure that the UUI IE Treatment field in 
the Trunk-Group definition form is set to 
service-provider.

The Call Information Panel (CIP) is not 
displaying any data.

This problem can occur if you are 
emulating a phone type that is normally 
configured to display 40 characters of 
information and it is currently in use 
because of VuStats, Q-call, or if it is already 
busy with information from another 
incoming call. You can either change the 
phone type emulation to one that displays 
80 characters of information or disable 
VuStats so that the call information panel is 
not committed to displaying this 
information. See Compatible telephone 
types for Avaya IP Agent on page 14 for 
telephones that support 80 character 
displays.

Touch-tones are not sent when the agent 
presses the buttons of the number pad on 
the telephone.

This situation occurs because the data 
portion of the Telecommuter configuration 
is sent through Avaya IP Agent on the 
personal computer and not the telephone. 
Use the Dial Pad or the personal computer 
keyboard to enter numbers where Dual 
Tone Multi-Frequency (DTMF) signals are 
needed.
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Avaya IP Agent is reacting slowly. The Event Logging feature of Avaya IP 
Agent can inhibit product performance. If 
you are not working with Avaya support 
personnel to solve a problem with Avaya IP 
Agent, this feature should be disabled.

The settings for one Avaya IP Agent 
installation were exported, but the import 
did not seem to work on another 
installation.

● Ensure that you are not trying to use 
exported settings from an Avaya IP 
Agent installation on another operating 
system. Setting exports from an 
operating system, such as Microsoft 
Windows Server 2000, cannot be 
imported on a different operating 
system, such as Microsoft Windows 
Server 2003.

● If you are renaming items from the 
Phone Features or Personal Phone 
Features windows, you must use the 
Rename (All Extensions) option. 
Otherwise, the name change only 
occurs for the specific extension 
number.

The button feature assignments were 
changed for this extension, but the 
assignments either are not displayed in 
Avaya IP Agent or they fail to work.

Do the first item in the following list. If the 
first item does not correct the problem, use 
the subsequent items that are appropriate 
for your configuration.
● Select Tools > Phone Features from 

the main window and then select 
Rebuild All from the menu bar on the 
Phone Features window.

● For IP Endpoint configurations, exit and 
restart Avaya IP Agent.

Phone Feature buttons do not work or are 
performing a different function.

If you are logging in as a different extension 
than the one that was just used with Avaya 
IP Agent, you must reboot the personal 
computer and log in again to regain these 
functions.

The agent was in Auto-In mode, received a 
call, and selected the After Call Work 
mode. When the call was finished, the work 
mode changed back to Auto-In.

If the agent needs to use the After Call 
Work mode consistently, use the Manual-In 
work mode instead of the Auto-In work 
mode.

Problem What to do
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Alternative solution possibilities 
If the information in this section did not solve your problem, it is possible that areas other than 
Avaya IP Agent are at fault. You can investigate the following areas for solutions:

● Firewall configurations

● Network configurations and available bandwidth

● Speed and available resources of the personal computer being used with Avaya IP Agent

● Problems with the Central Office (your telephone service provider)

● Network failures (WAN/LAN)

● Problems occurring in the other party�s telephone system

● Avaya communication server configuration problems

The folders in the Phone Features window 
are not in the appropriate language.

This problem occurs when multiple 
languages are installed for Avaya IP Agent. 
When first opened, the Phone Features 
window displays the names of the folders in 
the language version of Avaya IP Agent 
that is currently running. However, if you 
change to a different language version, the 
folders in this window retain the language 
used when the window was first opened. To 
reset the folders to the current language, 
select File > Rebuild All from the menu 
bar on the Phone Features window. This 
action will reset all folders and features. 
Any customization you may have made to 
feature names will be lost.

How to remove the call timer The call timer can be removed from Call 
Information Panels by editing the following 
entry in the Registry:
[HKEY_CURRENT_USER\SOFTWARE\Avaya\
Avaya IP Agent\Config\Settings]
"HideCallTimer"=dword:00000001

Fatal errors are occurring when the Call 
History window is opened.

This could be a sign that the Avaya IP 
Agent database is corrupt. To resolve this 
problem, uninstall and reinstall Avaya IP 
Agent. Any data stored in the database 
previous to this action is lost.

Problem What to do
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Glossary

Abbreviated Dial 
Feature

Allows the agent to store telephone numbers, that the agent selects, for quicker 
and easier dialing by selecting a single button. Each number can be a complete 
or partial telephone number, an extension number, or a trunk or feature code.

ACD See Automatic Call Distribution (ACD).
Active Call A call appearance state where the voice (talk) path between two parties has 

been connected.
ACW See After Call Work (ACW).
Add/Remove 
Programs

A Microsoft Windows feature that allows you to remove programs that have 
been installed on your computer. The Add/Remove Programs component is 
found in the Control Panel.

After Call Work 
(ACW)

An ACD agent work mode in which agents are performing tasks related to a 
previously completed call. In this mode, the agents are unavailable to receive 
ACD calls.

Agent A person who receives calls that are delivered from a split or skill.
Agent Mode An agent logs into an Avaya communication server with a specific agent ID, 

which is associated with certain assigned skills and configuration settings. Do 
not confuse this with registering as an extension with the Avaya communication 
server as an agent must first register as an extension before logging in with an 
agent ID.
Logging in as an agent enables the Agent toolbar in the main window.

Agent Skill A centrally-defined attribute that is associated with an EAS ACD agent ID, 
which represents a certain ability or assignment for that agent. An agent can be 
assigned up to 20 skills. The meaning of each Agent Skill is customizable. 
Examples of what could be considered skills are: the ability to speak a 
particular language or the expertise to handle a certain product.

Agent work mode A feature of agent call handling. Agent work modes are the different call work 
modes and call states an agent can be in (logins, logouts, After Call Work, AUX, 
and so forth). Data about these states is displayed in the history log.

Agent toolbar A toolbar that provides buttons for agent login and logout and agent modes, 
such as Auto-In, Manual-In, and After Call Work.

Alternate 
Gatekeeper

A feature of Avaya communication servers that notifies IP endpoints of all IP 
addresses for a network region. If communication fails with an IP address on 
the Avaya communication server, Avaya IP Agent attempts to reconnect with 
another IP address within the same network region.

Alternate User 
Interface

Avaya IP Agent interfaces that use much less space on the Desktop than the 
main window.
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Assist Allows an agent to request assistance (whether on an active ACD call or not) 
from the split or skill supervisor by pressing the Assist button or by putting the 
call on hold and dialing the Assist feature access code, followed by the split 
group number. The agent must be logged into the split or skill.

Auto-answer An Avaya communication server feature where calls directed to an agent are 
connected without any action required on the part of the agent. An agent can 
begin conversing with the other party without having to accept the call by 
activating a call appearance or releasing the switch hook.

Autodial A telephone feature where a single button is used to dial a complete telephone 
number.

Auto-In An ACD work mode. In the Auto-In mode, when an agent disconnects from a 
call, that agent is automatically available to receive another ACD call.

Automatic Call 
Distribution (ACD)

A method of call distribution where EAS agents are placed in groups called 
skills. An EAS agent can be logged into up to 20 skills simultaneously. EAS 
distributes calls to the extension of an agent that possesses the necessary skill.

Automatic Number 
Identification (ANI)

A service that provides the telephone number of an incoming call.

AutoPlay A Microsoft Windows feature that causes an application on a CD-ROM to run 
without any user interaction as soon as the CD-ROM is inserted into the drive.

AUX See Auxiliary Work (AUX) mode.
AUX RC See Auxiliary Reason Code (AUX RC).
Auxiliary Reason 
Code (AUX RC)

A numeric code that describes the reason for entering the AUX work mode, 
such as lunch or meetings. This Expert Agent Selection (EAS) feature enables 
a contact center to track the time of an agent more precisely. 

Auxiliary Work 
(AUX) mode

An ACD agent work mode indicating that the agent is unavailable (for example, 
observing a pre-defined period of inactivity or in training) to receive an ACD 
call.

Available An agent state in which the agent is able to accept an ACD call. This is a 
sub-state of the Auto-In and Manual-In modes.

Avaya 
communication 
server

A DEFINITY, MultiVantage, or Communication Manager system. These 
systems receive and distribute communications throughout a contact center.

Avaya IP Softphone Avaya IP Softphone is an Avaya product that enables you to log in to an Avaya 
communication server as an extension. Avaya IP Softphone does not support 
agent login and cannot co-reside with Avaya IP Agent.

Bandwidth The maximum number of digital bits that can pass through a communications 
channel every second. For example, Ethernet 10BaseT has a maximum 
bandwidth of 10 megabits per second.
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Basic Conference A mode of joining multiple parties to the same call. Up to five parties can be 
added, for a total of six on a call. The agent selects Conference, dials the 
number through the keyboard, talks to the party, and selects Conference again. 
See also Enhanced Conference. 

Basic Transfer A transfer mode that sends the current call to another telephone number or 
extension. The agent remains on the line until the call is answered and can 
announce the call. See also Enhanced Transfer and Unsupervised Transfer.

Call appearance A call connected to an extension. Most telephone types can support multiple 
call appearances simultaneously. Each call appearance is represented with a 
Call Information Panel in the main window.

Call Information 
Panel (CIP)

A single panel (40-character display) that displays information about a single 
call, such as caller name, call duration, status icon, and control buttons, such as 
Answer/Release and Reconnect.

Call Prompting An Avaya communication server feature that routes incoming calls based on 
information entered by the calling party, such as an account number. The caller 
is prompted to select options from those listed in an announcement. See 
Prompted digits for related information.

Call Work Code A numeric sequence, up to 16 digits, entered by an agent that identifies the type 
of call received by the agent. These codes are user-defined and administered 
on the Avaya communication server.

CIP See Call Information Panel (CIP).
Circuit pack Expansion modules that can be used to expand a DEFINITY, MultiVantage, or 

Communication Manager server. For Avaya IP Agent, the required circuit packs 
are related to IP communications.

Comma-separated 
values

Fields and records in a text file that are delimited by commas. This is a simple 
form of a database.

Communication 
Manager

The software used in Avaya communication servers. Communication Manager 
systems succeed and surpass DEFINITY and MultiVantage systems.

Communication 
server

A general term for Avaya DEFINITY, MultiVantage, and Communication 
Manager systems.

Conference See Basic Conference or Enhanced Conference.
Connected A trunk state in which a caller and an agent are able to converse on an ACD 

call.
Contact center A location where communications are received and placed. These 

communications can be telephone calls, e-mail, Web-based instant messaging, 
and others.

DDE See Dynamic Data Exchange (DDE).
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DEFINITY ECS DEFINITY Enterprise Communications Server (ECS). The DEFINITY ECS is a 
telecommunications system that routes voice and data information between 
various endpoints, such as telephones, terminals, and computers. It provides 
highly robust networking capabilities and includes an extensive set of standard 
features, such as Attendant Consoles, Voice Processing Interface, Call 
Coverage, DS1/E1 Connectivity, Hospitality Support, Recorded Announcement, 
and Trunk-to-Trunk Transfer. It also allows for the addition of optional features 
and upgrades to the system as business needs change.

Delimited text file A file containing fields, records, and values that are separated by commas, 
tabs, semicolons, or other characters.

Dial Pad An Avaya IP Agent dialog box that displays the 12 characters available on a 
telephone.

Dial Number button A button on the Dial Number toolbar that an agent uses to go off-hook and 
initiate a dial tone or to dial the digits previously entered in the Number text box.

Dial Number toolbar A toolbar that provides a number text box, access to the phone directory, call 
history, speed dial, and recent calls list. When an agent enters a string (for 
example, lan) followed by Enter, a popup menu displays with a list of the 
directory entries that start with that string. If the first character of the number is 
a letter, the title of the field will be changed from Number to Name.

Dial Plan The configuration of an Avaya communication server that determines how 
extensions, external telephone numbers, and server features are contacted or 
activated. For example, a dial plan might determine that all internal extensions 
can be reached by dialing a five-digit number. Dial plans are configured through 
an Avaya communication server.

DNS See Domain Naming System (DNS).
Domain For Windows networking, a domain is a subnetwork comprised of a group of 

clients and servers under common control.
For the Internet, a domain is the highest subdivision of a domain name. For 
example, .com, .org, and .net are domains.

Domain Naming 
System (DNS)

An Internet mechanism where Uniform Resource Locator (URL) addresses are 
translated to Internet Protocol (IP) addresses. For example, www.avaya.com 
translates to a series of numbers that use the format 123.123.123.123. DNS 
servers can exist inside private networks that are separated from the Internet.

Drop An agent uses this feature to disconnect from a call and place another call or to 
disconnect the last person added to a conference call.

Dynamic Data 
Exchange (DDE)

A form of communication between Windows applications that allows the 
exchange of data, information, and commands.

EAS See Expert Agent Selection (EAS).
Emergency Call 
Handling (ECH)

An Avaya communication server feature that determines the location of IP 
endpoints that place a call to emergency services, such as 911 in the United 
States.
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Enhanced 
Conference

A feature that allows you to add up to six telephone numbers to a call. See also 
Basic Conference.

Enhanced Transfer A transfer option that sends the present call to another phone number or 
extension. See also Basic Transfer and Unsupervised Transfer.

Expert Agent 
Selection (EAS)

An optional Avaya communication server feature that builds on the power of the 
Call Vectoring and ACD features to send a particular call to an agent who has at 
least one of the skills that the caller requires.

FAC See Feature Access Code (FAC).
Feature Access 
Code (FAC)

A 1-to-4 digit number with an optional leading * or # that is assigned during 
Avaya communication server administration to invoke features. For example, 
*81 may invoke Service Observing Listen Only. FACs require an available call 
appearance with dial tone before the FAC can be sent to the Avaya 
communication server. Assigned FACs may not be available to all users on an 
Avaya communication server based on class of restrictions and whether the 
feature has been enabled in the Avaya communication server.

Feature button A button that can be assigned to any one of a number of Avaya communication 
server features. Feature buttons are assigned to an extension during station 
administration on the Avaya communication system.

Firewall Hardware, software, or a combination of the two that provide a boundary 
between two or more networks. Firewalls can be implemented on different 
devices with differing levels of security and access.

Graphical User 
Interface (GUI)

An environment where icons, dialog boxes, windows, buttons, fields, and other 
controls are presented through the use of program functions supplied by the 
operating system. You can interact with the interface with a pointing device, 
such as a mouse, and, usually, the keyboard.

GUI See Graphical User Interface (GUI).
H.323 A specification that defines packet standards for multimedia communications 

over IP networks that interact with telephony networks.
Hold A feature that allows an agent to leave a telephone call without disconnecting it. 

You can return to the call at any time.
HTML See HyperText Markup Language (HTML).
Hypertext A word or series of words in a software application that can be used to access 

information through user interaction.
HyperText Markup 
Language (HTML)

A structured language used in the authoring and presentation of information. 
See also Hypertext.

iClarity IP Audio An Avaya component that provides station registration and voice/data signalling 
with an Avaya communication server.

Installation folder The directory on the personal computer that contains the Avaya IP Agent files.
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Internet Protocol 
address (IP address)

A unique, 32-bit (4-byte) number that identifies a computer on a TCP/IP 
network and is used in the transmission and delivery of data packets. An IP 
address is represented in four, 8-bit (1 byte) values, separated by periods. For 
example, 128.10.10.1. From left to right, each byte represents greater detail 
about the logical location within the network.

IP Address See Internet Protocol address (IP address).
IP Endpoint A telephone extension that uses IP for data signaling, voice communication, or 

both. Extensions that use the Telecommuter configuration are considered IP 
Endpoints.

IP Telephone A telephone set that uses an Ethernet connection to relay voice 
communication. This is also the name for the configuration by which control of 
the telephone is shared by Avaya IP Agent.

LAN See Local Area Network (LAN).
LDAP See Lightweight Directory Access Protocol (LDAP).
Lightweight 
Directory Access 
Protocol (LDAP)

A network protocol used over TCP/IP networks for querying and retrieving 
information from a hierarchical directory.

Local Area Network 
(LAN)

A private, interactive communication network through which computers can 
communicate over short distances at high data transfer rates.

Log A record of activity.
Login The process of identifying a user with a computer, device, or server so that the 

user can use resources or features. In regards to Avaya IP Agent, an agent 
must log in to the Avaya communication server to receive ACD calls.

Login ID A number and that allows an EAS agent to log in to the Avaya communication 
server. Skills and other information are assigned to the login ID of the agent.

Logout The act of a user that notifies a computer, device, or server that no further tasks 
will be performed by this user at this time and that no resources should be 
allocated for this specific user.

Manual-In An ACD work mode. In the Manual-In mode, the agent automatically enters the 
ACW mode when the agent disconnects from an ACD call. To become available 
to receive another ACD call, the agent must manually select the Auto-In or 
Manual-In mode.

Media Encryption Communications between Avaya iClarity IP Audio and the Avaya 
communication server are encoded so that the information cannot be 
deciphered by unauthorized recipients.

MultiVantage A line of next-generation communication servers offered by Avaya. 
MultiVantage systems succeed and surpass DEFINITY systems.

Network A group of devices that are connected in such a way that data or 
communications can be transmitted and received between the devices.

Off-Hook The voice path to your telephone is active.
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On-Hook The voice path to your telephone is inactive.
Phone display A 40-character display that is located in the status bar of the Avaya IP Agent 

main window. This display area receives information from the Avaya 
communication server so that you can see call and non-call related information, 
such as call prompted digits and VuStats.

Prompted digits One or more numbers entered by a caller that indicate responses to automated 
questions posed when the call first enters the contact center.

PSTN See Public Switched Telephone Network (PSTN).
Public Directory A database that can be accessed through the Lightweight Directory Access 

Protocol (LDAP) protocol. A Public Directory usually contains information on 
people or personnel within some unit of organization, such as a business, 
educational facility, and so forth.

Public Switched 
Telephone Network 
(PSTN)

The worldwide voice telephone network.

RC See Reason Code (RC).
Read-only A folder or file that can be read, but not modified, updated, or deleted.
Reason Code (RC) A numeric code that describes the reason that an agent enters the AUX work 

mode or logs out of the system.
Registry The system-wide repository of information supported and used by Windows. 
Release Disconnects the current call.

Response file See Silent install.
Right-To-Use (RTU) A licensing mechanism used in Avaya communication servers. In some 

situations, multiple RTUs can be used by a single extension so that data and 
voice signaling are supported.

Screen Pop The automatic display of information on the screen of the personal computer 
from other sources, such as databases or Web pages. Screen Pops are 
activated by triggering criteria.

Skill An attribute that is assigned to an ACD Agent. Agent Skills can be thought of as 
the ability for an Agent with a particular set of skills to handle a call that requires 
one of those skills.

Softphone A software application that enables you to control telephone calls, both 
incoming and outgoing, directly from your computer, where communication is 
done through Voice-over-IP.

Split A group of extensions that receives special-purpose calls in an efficient, 
cost-effective manner. Normally, calls to a split arrive primarily over one or a few 
trunk groups.

Station Login The process of registering as an extension of an Avaya communication server. 
With Avaya IP Agent, a station login must be completed before an agent login 
can occur.
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Switch A private call-handling system providing voice-only or voice and data 
communications services, including access to public and private networks, for a 
group of terminals within a premises. See also Communication server.

System Tray The area of the Windows task bar where applications can display an icon for 
simplified access to special features. Avaya IP Agent displays an icon in the 
System Tray.

TAPI Assisted 
Dialing

Avaya IP Agent supports telephony-enabled applications, such as Microsoft 
Scheduler. This support provides the ability for telephony-enabled Windows 
applications to originate a call and have the call reflected in the Avaya IP Agent 
application.

Telecommuter An Avaya IP Agent configuration where voice communications are performed 
through a telephone and data communications are sent through the network to 
a personal computer. In this configuration, calls to an extension can be routed 
to any telephone number.

Telephone type Avaya produces many different models of telephone sets with differing 
capabilities. Each model supported by Avaya IP Agent is considered a 
telephone type. Telephone types are identified by the unique number 
associated with each model.

Toll quality A term used to compare audio quality and reliability of voice communications to 
that of telephone calls placed over the PSTN.

Toolbar A row of buttons used to activate various functions of Avaya IP Agent through 
the main window.

Tooltips Brief descriptions that are displayed when the mouse pointer is over a toolbar 
button or control in the application interface.

Transfer See Basic Transfer, Enhanced Transfer, or Unsupervised Transfer.
Unsupervised 
Transfer

A call transfer option that lets an agent send the present call to another phone 
number or extension. The agent does not talk to the party receiving the 
transferred call. See also Basic Transfer and Enhanced Transfer.

User-to-User 
Information (UUI)

A unique identifier that is added to an incoming call through an external 
application, such as Avaya ASAI.

VDN of Origin 
Announcement 
(VOA)

A short announcement that is assigned to a Vector Directory Number (VDN) 
through Avaya communication server administration. The VOA identifies the 
origin or purpose of a call for the call center agent who answers the call.

Vector On a communication server, a list of steps that processes calls according to a 
configuration set by the administrator. The steps in a vector can send calls to 
splits or skills, play announcements and music, disconnect calls, give calls a 
busy signal, prompt callers for information, or route calls to other destinations.

Virtual Private 
Network (VPN)

A group of computers or network devices that can communicate privately and 
securely over a public IP network through the use of encryption and special 
protocols.

VOA See VDN of Origin Announcement (VOA).
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Voice-over-Internet 
Protocol (VoIP)

A technology where speech is converted to a digital signal and transmitted 
through Internet Protocol packets over the Internet or an intranet.

VuStats An Avaya communication server feature that displays contact center activity 
and information on the display of a telephone set. For Avaya IP Agent, this 
information can be viewed in the status bar of the main window and the VuStats 
Monitor window.

Windows Terminal 
Server / Windows 
Terminal Services

A Windows-based server that allows client terminals, PCs, and other devices to 
use an environment and applications supplied by the server. Depending on the 
type of client, processing and storage can take place on the server or the client.

Zip Tone A short dial tone that indicates that an ACD call is being connected to the agent.
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