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Notice
While reasonable efforts were made to ensure that the information in this 
document was complete and accurate at the time of printing, Avaya Inc. 
can assume no liability for any errors. Changes and corrections to the 
information in this document may be incorporated in future releases.

Documentation disclaimer
Avaya Inc. is not responsible for any modifications, additions, or deletions 
to the original published version of this documentation unless such 
modifications, additions, or deletions were performed by Avaya. 
Customer and/or End User agree to indemnify and hold harmless Avaya, 
Avaya's agents, servants and employees against all claims, lawsuits, 
demands and judgments arising out of, or in connection with, subsequent 
modifications, additions or deletions to this documentation to the extent 
made by the Customer or End User. 

Link disclaimer
Avaya Inc. is not responsible for the contents or reliability of any linked 
Web sites and does not necessarily endorse the products, services, or 
information described or offered within them. We cannot guarantee that 
these links will work all of the time and we have no control over the 
availability of the linked pages.

Warranty
Avaya Inc. provides a limited warranty on this product. Refer to your 
sales agreement to establish the terms of the limited warranty. In 
addition, Avayaís standard warranty language, as well as information 
regarding support for this product, while under warranty, is available 
through the following Web site:
http://www.avaya.com/support 

Preventing toll fraud
"Toll fraud" is the unauthorized use of your telecommunications system 
by an unauthorized party (for example, anyone who is not a corporate 
employee, agent, subcontractor, or person working on your company's 
behalf). Be aware that there may be a risk of toll fraud associated with 
your system and that, if toll fraud occurs, it can result in substantial 
additional charges for your telecommunications services.

Avaya fraud intervention
If you suspect that you are being victimized by toll fraud and you need 
technical assistance or support, call Technical Service Center Toll Fraud 
Intervention Hotline at +1-800-643-2353 for the United States and 
Canada. For additional support telephone numbers, see the Avaya Web 
site:
http://www.avaya.com/support 

Providing telecommunications security
Telecommunications security (of voice, data, and video communications) 
is the prevention of any type of intrusion to (that is, either unauthorized or 
malicious access to or use of) your company's telecommunications 
equipment by some party.

Your company's "telecommunications equipment" includes both this 
Avaya product and any other voice/data/video equipment that could be 
accessed via this Avaya product (that is, "networked equipment").
An "outside party" is anyone who is not a corporate employee, agent, 
subcontractor, or person working on your company's behalf. Whereas, a 
"malicious party" is anyone (including someone who may be otherwise 
authorized) who accesses your telecommunications equipment with 
either malicious or mischievous intent.
Such intrusions may be either to/through synchronous (time-multiplexed 
and/or circuit-based) or asynchronous (character-, message-, or 
packet-based) equipment or interfaces for reasons of:

ï Use (of capabilities special to the accessed equipment)
ï Theft (such as, of intellectual property, financial assets, or 

toll-facility access)
ï Eavesdropping (privacy invasions to humans)
ï Mischief (troubling, but apparently innocuous, tampering)
ï Harm (such as harmful tampering, data loss or alteration, 

regardless of motive or intent)
Be aware that there may be a risk of unauthorized intrusions associated 
with your system and/or its networked equipment. Also realize that, if 
such an intrusion should occur, it could result in a variety of losses to your 
company (including, but not limited to, human and data privacy, 
intellectual property, material assets, financial resources, labor costs, and 
legal costs).

Your responsibility for your company's telecommunications 
security
The final responsibility for securing both this system and its networked 
equipment rests with you, an Avaya customer's system administrator, 
your telecommunications peers, and your managers. Base the fulfillment 
of your responsibility on acquired knowledge and resources from a 
variety of sources, including, but not limited to:

ï Installation documents
ï System administration documents
ï Security documents
ï Hardware-/software-based security tools
ï Shared information between you and your peers
ï Telecommunications security experts

To prevent intrusions to your telecommunications equipment, you and 
your peers should carefully program and configure:

ï Your Avaya-provided telecommunications systems and their 
interfaces

ï Your Avaya-provided software applications, as well as their 
underlying hardware/software platforms and interfaces

ï Any other equipment networked to your Avaya products.
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Preface

This section includes the following topics:

● Purpose of this document on page 17

● Intended user of this document on page 17

● Safety labels on page 18

● Reasons for reissuing this document on page 18

● Availability of this document on page 19

● Related documentation on page 20

Purpose of this document
The purpose of this document is to describe how to install, configure, and customize the 
Avaya IC for Siebel system.

Intended user of this document
This document is written for a system integrator. To use this document, you should have a 
working knowledge of Avaya Interaction Center (IC). In particular, you should have 
experience installing, configuring, and customizing Avaya IC and Avaya Agent.

Every detail required to integrate an Avaya IC for Siebel integration cannot be included in 
this document. Depending on your experience, you may need to access the Avaya IC and 
Siebel documentation sets in order to complete the integration.
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Safety labels
If you see any of the following safety labels in this document, take careful note of the 
information presented.

! CAUTION:
CAUTION: Caution statements call attention to situations that can result in harm to 

software, loss of data, or an interruption in service.

! WARNING:
WARNING: Warning statements call attention to situations that can result in harm to 

hardware or equipment.

! DANGER:
DANGER: Danger statements call attention to situations that can result in harm to 

personnel.

! SECURITY ALERT:
SECURITY ALERT: Security alert statements call attention to situations that can increase the 

potential for unauthorized use of a telecommunications system.

Reasons for reissuing this document
This issue of the document was created to additionally support Siebel 7.7.

The following changes have been made to this document for Issue 4.0:

● Global - Changed the path to many Siebel screens because of changes to the Siebel 
7.7 interface.

● Global - Changed many of the Siebel user interface steps based on recommendations 
from usability tests.

● Global - Changed workflow terms to match the Avaya IC terms.

● Fixed various wording errors.

● Added text to AICD domain guidelines on page 47.

● Added Customizing AUX reason codes on page 85

● Enhanced and rewrote Integration workflows on page 113.

● Added Installing the Siebel integration help files on page 178
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● Changed Step 1 in Creating a teleset on page 199

● Changed Step 1 in Adding responsibilities to lists (optional) on page 200

● Added note for the Use MIME Layer field in Adding the EAIWorkflow server on 
page 212

● Removed a step to unlock the Avaya IC project in Installing a custom integration 
object on page 216.

● Removed the sections titled, Shutting down and restarting Siebel Server components 
and Shutting down the Workflow Monitor Agent component in the Installation and 
configuration tasks for all channels chapter.

● Added new procedure in Importing and deploying the Siebel 7.7 workflow on page 222

● Added procedure in Activating the Siebel EAI workflow on page 223

● Changed steps in Installing eScripts and English error strings on the Siebel server on 
page 257

● Added Installing localized error strings on the Siebel server (optional) on page 260

● Added new steps in Building the Siebel-first workflow on page 277

● Added new steps in Building the qualify e-mail workflows on page 277

● Added sub-steps to Step 5 in Removing eScripts on page 282

● Changed steps in Installing eScripts and English error strings on the Siebel server on 
page 285

● Added Installing localized error strings on the Siebel server (optional) on page 289

● Modified section with added procedures in Administering the Siebel workflows on 
page 297

● Changed Step 1 in Creating a profile on page 302

● Changed Step 1 in Enabling Communications Outbound Manager on page 307

● Added Ensuring Avaya IC and Siebel compatibility on page 321

● Changed description of parameter in AgentUnavailable on page 396.

● Added Creating an integration object to query on a multi-value field on page 502

● Changed AICD driver parameters on page 527

Availability of this document
Copies of this document are available from one or both of the following sources. Although 
there is no charge for documents obtained through the Avaya Web site, documents 
obtained through the Avaya Publications Center must be purchased.
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● The Avaya online support Web site, http://www.avayadocs.com. 

● The Avaya Publications Center:

Voice: +1-207-866-6701
+1-800-457-1764 (Toll-free, U.S. and Canada only)

Fax: +1-207-626-7269
+1-800-457-1764 (Toll-free, U.S. and Canada only)

Write: Globalware Solutions
200 Ward Hill Avenue
Haverhill, MA 01835 USA
Attention: Avaya Account Manager

E-mail: totalware@gwsmail.com

Related documentation
This section includes the following topics:

● Avaya IC for Siebel documentation on page 20

● Avaya IC documentation on page 20

● Siebel documentation on page 22

Avaya IC for Siebel documentation

The electronic documentation for the Avaya IC for Siebel integration is included on the 
CD-ROM included with the integration software. In addition to this document, the CD-ROM 
contains the Avaya IC for Siebel User Guide.

Avaya IC documentation

This section includes the following topics:

● Recommended Avaya IC documentation on page 21

● Ways to access Avaya IC documents on page 21

● Readme file on page 22

http://www.avayadocs.com
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Recommended Avaya IC documentation

You might find the following documentation useful.

Ways to access Avaya IC documents

You can access Avaya IC documentation in PDF format from:

● Avaya Interaction Center CD-ROM - The PDF files are in the Doc directory on the 
product CD-ROM.

● Avaya Interaction Center Documentation CD-ROM - The PDF files on this CD-ROM 
also include the Avaya IC Product Documentation Guide. 

Document name Document number

Agent Script Workflow Reference 07-300104, Issue 2.0

Avaya Agent Integration 585-248-003

Avaya Agent User Guide 585-248-707

Avaya IC Media Workflow Reference 07-300103, Issue 2.0

Avaya IC Workflow API Reference 585-248-209

Avaya Workflow Designer User Guide 07-300109, Issue 2.0

Core Services Programmer Guide 585-248-213

Electronic Data Unit Server Programmer Guide 585-248-206

IC Administration Volume 1: Servers & Domains 07-300107, Issue 2.0

IC Administration Volume 2: Agents, Customers, & 
Queues 07-300108, Issue 2.0

IC Business Advocate Configuration and Administration 07-300106, Issue 2.0

IC Database Designer User Guide 585-248-215

IC Installation and Configuration 07-300100, Issue 2.0

IC Installation Planning and Prerequisites 07-300099, Issue 2.0

IC/OA Software Upgrade and Data Migration 07-300117, Issue 3.0

IC Scripts VBA Scripting Reference 585-248-217

IC Telephony Connectors Programmer Guide 07-300105, Issue 3.0
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● Documentation directory on a machine that hosts Avaya IC components - This directory 
includes all documentation that relates to the Avaya IC components on the machine.

Readme file

The Readme file is an HTML file included on the Avaya Interaction Center software 
CD-ROM. This file contains important information that was collected too late for inclusion in 
the paper documentation. The Readme file might include installation instructions, system 
requirements, information on new product features and enhancements, suggested 
work-arounds to known problems, and other information critical to successfully installing 
and using your Avaya software. You might also receive a paper Readme addendum 
containing similar information uncovered after the manufacture of the product CD-ROM. 
Review the Readme file and the Readme addendum before you install the integration 
software.

Siebel documentation

The product documentation set for Siebel eBusiness Applications is provided on the Siebel 
Bookshelf CD-ROM.

If you want to order additional Siebel documentation and copies of the Siebel Bookshelf 
CD-ROM, go to Books Online at http://ebusiness.siebel.com/booksonline. To access 
Books Online, you will need to provide the user name and password you received from 
Siebel Support Services (support@siebel.com).

http://ebusiness.siebel.com/booksonline
support@siebel.com
support@siebel.com
support@siebel.com
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Chapter 1: Integration overview

This section provides a high-level overview of how the Avaya IC for Siebel integration 
works and includes the following topics:

● Differences in terminology on page 24

● System description on page 25

● Media features on page 26

● Architecture overview on page 29

● Interaction between Avaya IC and Siebel on page 32

● Multi-site configurations on page 35
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Differences in terminology
Avaya IC and Siebel use the following similar terms that are applied differently in the two 
systems. This document uses the Avaya IC terminology except when referring to Siebel 
components.

Related topic

For more information, see Key-value parameters on page 383.

Avaya IC 
term Siebel term Description

Customer Contact Person initiating the interaction with the 
agent.

Contact Work item

A single interaction with an Avaya IC 
customer, in any of the following media 
channels:
● Voice (telephone call) 
● E-mail
● Chat (Web chat)
Because of the continuous exchange of data 
between the two systems, this document 
uses the terms contact and work item 
interchangeably.

Available
Not Available

Ready
Not Ready

Terms used to describe agent availability for 
receiving work items.

Name-value 
couple

Key-value 
parameter

Data that represents information about a 
contact or work item. The key, or name, is 
the name of the parameter being conveyed.
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System description
The Avaya Interaction Center for Siebel integration combines Avaya Interaction Center 
(IC) release 6.1.3 with the Siebel 7 applications. The integration of Avaya IC with Siebel 
allows you to use the customer management features in the Siebel software and the 
features in Avaya IC that automate the processing of customer contacts. This integration 
allows agents to interact with a customer in an individualized manner because agents can:

● Receive work items that are appropriate for their set of skills

● Perform contact work in multiple media channels

● Access any historical data about work previously performed for a specific customer

Related topics

For more information about how agents process work items, see Avaya IC for Siebel User 
Guide.
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Media features
This section includes the following topics:

● Voice channel on page 26

● E-mail channel on page 26

● Web channel on page 27

Voice channel

The Avaya IC for Siebel integration supports the following voice channel features:

Heterogeneous switch support - Agents can transfer and conference telephone calls 
regardless of switch type or location.

Interactive Voice Response (IR) support - Callers can choose from a list of prerecorded 
voice messages.

Business Advocate support - Business Advocate is used for switch and host-based 
call-routing support.

Multimedia work items - Agents can associate a phone call or a Voice over Internet 
Protocol (VoIP) call with a Web chat session.

Screen pop into the Siebel agent desktop - Screen pops display customer information 
in the Siebel desktop when agents accept a work item or activate a work item.

Siebel Communications Toolbar for phone functions - Agents use the toolbar for 
softphone functions, such as answer, hold, take off hold, conference, transfer, and so on.

Avaya Outbound Contact - Outbound Contact initiates telephone calls to customers 
while automatically displaying customer information and guiding users through the 
process.

E-mail channel

The Avaya IC for Siebel integration e-mail channel functions as follows:

● Avaya IC for e-mail receipt and routing on page 27



Media features

Issue 4.0 November 2004 27

● Siebel for e-mail response and Siebel Content Analysis on page 27

● Siebel desktop receives the e-mail on page 27

Avaya IC for e-mail receipt and routing

Avaya IC provides for the receipt and the routing of e-mail. Avaya IC uses the following 
features:

● Post Office Protocol 3 (POP3)

● WebACD routing

● Avaya Business Advocate routing

● Push mode delivery of customer e-mail contacts to agent desktop

● Blended delivery to a common desktop interface for e-mails blended with other work 
items

Siebel for e-mail response and Siebel Content Analysis

Siebel provides the e-mail responses and Content Analysis that includes:

● Auto-acknowledgements

● Suggested responses

● Auto-responses

● E-mail presentation to the agent through the Siebel user interface

Siebel desktop receives the e-mail

The Siebel desktop receives the e-mail work item that can include:

● Siebel templates so that agents can use messages that have already been created and 
approved for specific situations.

● E-mail history stored in the Siebel database and linked to the customer

Note:
Note: When the Avaya IC Web Agent is set to Siebel mode, the e-mail controls are 

removed from the interface.

Web channel

The Avaya IC for Siebel integration supports the following Web channel features:

● Avaya IC Web automatic call distributor (ACD) for logic and agent selection
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● The Internet Call Manager (ICM) server enables the following communication and 
collaboration functionality:

- Web chat

- VoIP

- Public Switched Telephone Network (PSTN) callback

- Collaboration, such as page push, forms assist, transcript, and so on.

● Downloadable caller-side applet for customer Web chat interface

● DataWake for tracking customer activity within a Web site

● Web Agent Client interface

● Web chat transcript saved in the Siebel database

● Integrated with Siebel Web engine for Web applications
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Architecture overview
This section includes the following topics:

● Architecture figure on page 29

● Communications infrastructure on page 30

● Avaya IC servers on page 30

● Siebel servers on page 30

● Clients on page 30

Architecture figure

The following figure shows the major parts of an Avaya IC for Siebel integrated system.
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Communications infrastructure

The communications infrastructure includes the PBX, Avaya Interactive Response (IR), 
e-mail, fax, and Web servers. These servers:

● Support the delivery of various media-channel communications to the contact center

● Can run Avaya-provided switch software

● Can run software from other vendors, such as Microsoft Exchange

The software on these servers is provided separately from the Avaya IC for Siebel 
integration software.

Avaya IC servers

The Avaya IC servers refers to all of the servers that comprise the Avaya IC system. For 
example, the Telephony Server is responsible for receiving messages from the telephone 
switch and passing the information along to other servers, and the Directory Server 
maintains an accurate list of agents and servers on the system.

You must enhance this software to support the Avaya IC for Siebel integration.

Related topics

For more information about Avaya IC servers, see:

● AICD and Avaya IC interfaces on page 98

● IC Administration Volume 1: Servers & Domains

Siebel servers

The Siebel servers refer to all of the servers on the Siebel system. To support the Avaya IC 
for Siebel integration, Avaya provides software that runs on the Siebel application servers.

Related topic

For more information about Siebel servers, see the Siebel documentation.

Clients

Clients refers to all of the client machines in the system.
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Software from both Siebel and Avaya may reside on the client. In the case of Siebel, only a 
browser is required at the client to interact with the system. For Avaya IC, you must install 
software on the client. This portion of the system also includes any physical 
communication devices used by agents, such as telephone sets.
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Interaction between Avaya IC and Siebel
There are three main types of interactions between Avaya IC and Siebel:

● Data exchange on page 32

● Work delivery and control on page 33

● E-mail response on page 34

Data exchange

Data exchange is the movement of information between Avaya IC and the Siebel 
databases, and the exchange of e-mail content back and forth between the two systems.

Data exchange figure

The following figure shows the data exchange software architecture.

Data exchange description

The data exchange process works as follows:

1. A voice, e-mail, or Web chat customer contact arrives in Avaya IC and a workflow 
starts to process that contact.



Interaction between Avaya IC and Siebel

Issue 4.0 November 2004 33

2. The workflow calls EAI-specific blocks to interact with Siebel. For example, an EAI Get 
Data block retrieves a previous contact record from the Siebel database that is 
associated with the current customer contact.

3. The EAI block calls the EAI server to request the data transfer. The EAI server 
maintains HTTP and XML-based EAI sessions with Siebel to perform the transfer.

4. On the Siebel side, the Siebel EAI adapter processes the inbound HTTP request. The 
requested data is retrieved from the Siebel database and sent back to Avaya IC 
through the EAI server.

5. The Avaya IC workflow processes the data. For example, the workflow may determine 
how the contact should be routed. The workflow can optionally store the data in the 
EDU.

6. In the case of e-mail transfers, the EAI server interacts with the IC Email server to read 
or write e-mail contents to and from the Avaya IC database.

7. For more sophisticated types of data transfer operations, or for e-mail transfers, Siebel 
workflows may need to be called to perform special operations on the data. Handling a 
Multipurpose Internet Mail Extensions (MIME) layer for e-mail is an example of a 
special operation.

Related topics

For more information about data exchange components, see any of the following topics:

● Integration workflows on page 113

● EAI server on page 66

Work delivery and control

The work delivery and control function coordinates the delivery of work to the agents. This 
coordination involves synchronizing the Siebel desktop with Avaya Agent during the 
following events:

● Delivering work initially, such as a screen-pop

● Completing work

● Switching between work items

● Transferring work items
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The following figure shows the overall work delivery and control architecture.

Related topics

See one of the following topics for more information about the work delivery and control 
components:

● AICD on page 97

● SCAPI interface on page 103

E-mail response

E-mail response refers to all Siebel e-mail response functionality, including e-mail 
presentation, Siebel Content Analysis, e-mail auto-acknowledgements, auto-responses, 
and e-mail suggested responses. In this integration, there are two types of e-mail methods: 
Avaya-first e-mail entry and Siebel-first e-mail entry.

Related topic

For more information, see E-mail entry methods on page 53.
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Multi-site configurations
In an integrated Avaya IC and Siebel environment, the entire integrated system is 
designed to operate in a multi-site environment.

This section includes the following topics:

● Multi-site configuration figure on page 36

● Centralized Siebel complex on page 36

● The database in multi-site configurations on page 37

● EAI in multi-site configurations on page 37

● E-mail in multi-site configurations on page 37

● Agents, sites, and Siebel Communications servers on page 37

● Associating a Siebel agent with a communications session on page 38
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Multi-site configuration figure

The following figure shows an example of a multi-site Avaya IC for Siebel integration. 
While only three sites are shown in this figure, your system can contain many more sites.

Centralized Siebel complex

Siebel requires that all of their application servers are co-located with the Siebel database 
and Siebel Web server. Therefore, customers need to set up a centralized Siebel complex 
that all agents access through their Web browser. Typically, the centralized Siebel complex 
should reside at one of the contact center sites, but this is not required. Reliable, 
high-speed Wide Area Network (WAN) connectivity between sites and to the centralized 
Siebel complex are required.
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The database in multi-site configurations

In Siebel, there is only one logical instance of the Siebel database, even in a multi-site 
environment. This facilitates easy access to all customer data in the database regardless 
of where the agent is located. Also, Avaya IC workflow blocks can access customer 
information from any site.

Similarly for Avaya IC, there is only one database for customer and agent information for 
the entire system. In the case of EDU and ADU servers, the system already allows multiple 
instances of the servers to exist within a single system. These servers implement 
mechanisms whereby a client needs to interact with only one server, but may obtain 
information that is actually resident in another instance of the server. That is, the ADU and 
EDU servers in the system are knowledgeable about and share their information with all 
other ADU and EDU servers in the entire system.

EAI in multi-site configurations

Each site that needs to access Siebel EAI data must have an EAI server. All access to EAI 
servers should be available throughout the Wide Area Network (WAN). Additionally, you 
should have high bandwidth and stable connections through the network connection to the 
centralized Siebel complex.

E-mail in multi-site configurations

Configure one of the sites in the complex as the entry point for e-mail. Correspondingly, 
configure one of the Siebel servers to run the AED if you are using Siebel Content 
Analysis.

Agents, sites, and Siebel Communications servers

A multi-site system configuration typically involves multiple Siebel Communications server 
instances running across multiple Siebel servers. Agents at each site can be fixed to 
particular Communication server instance using Siebel administration, or the agents can 
be configured to use one of many Communication server instances. Use of Siebel 
Resonate load balancing software allows assignment of agents to the most appropriate 
Communication server dynamically upon login. The selection of a Communication server 
for a particular agent login session also determines the AICD driver instance that is 
associated with the session.
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The Avaya IC for Siebel integration is flexible in terms of how to associate agents at 
different sites across multiple Siebel Communication servers and associated AICD 
instances. Plan carefully to ensure that the chosen configuration is appropriate for your 
particular customer implementation and application.

Using fixed agent-to-Communication server assignments

You can choose to use fixed agent-to-Communication server assignments to associate 
Communication server instances with particular sites. Use this method for the following 
reasons:

● Reduces the amount of proxying incurred by the ADU and EDU servers and allows the 
AICD to use the best available ADU and EDU servers for servicing the agents and 
contacts at a particular site.

● Helps define appropriate failover paths for requests to these servers made by the AICD.

To associate a Communication server instance with a site, configure agents from only one 
site to use that Communication server instance. If multiple Avaya IC agent domains are 
associated with a site, configure the Communication servers in accordance with the 
individual Avaya IC agent domains, if possible.

Related topic

For more information, see the Siebel documentation.

Not using fixed agent-to-Communication server assignments

You can choose not to use fixed agent-to-Communication server assignments. With this 
method, you do not have to associate Communication server instances with particular 
sites. Agents at any site can use any Communication server and AICD instance to log in 
and perform work. However, more EDU and ADU server proxying will occur in such 
configurations, and the overall performance of the Avaya IC system can be slightly 
reduced as a result. However, these configurations are more flexible compared to 
configurations requiring a one-to-one relationship between Communication server and 
sites. For example, these types of configurations can use load balancing software to better 
balance the load across multiple Siebel servers.

Associating a Siebel agent with a communications session

Normally, Siebel uses the Communications Session Manager that runs on the same 
machine as the agent Application Object Manager. However, if this default association is 
changed, create multiple Siebel communication configurations by modifying the following 
Computer Telephony Interface (CTI) parameters:
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● GatewayAddress - Specify the Siebel Gateway. For example, specify a value such as 
gateway-host for this parameter.

● EnterpriseServer - Specify the Siebel Enterprise Server. For example, specify a value 
such as siebel for this parameter.

● RequestServer - Specify the Siebel Request Server, the Siebel Server. For example, 
specify a value such as server-host for this parameter.

● CommSessionMgr - Specify the Communications Session Manager. For example, 
specify a value such as CommSessionMgr for this parameter. This parameter is 
optional.
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Chapter 2: Planning and prerequisites

This section describes the information and materials you will need to plan an Avaya IC for 
Siebel integration and the prerequisite tasks. Avaya Interaction Center for Siebel 7 
supports integration with the following versions of Siebel:

● Siebel 7.0

● Siebel 7.5

● Siebel 7.7 - available only with the Siebel-first e-mail method

This section includes the following topics:

● Supported platforms on page 42

● Avaya IC domain deployment guidelines on page 46

● Matching Siebel and Avaya IC agent login IDs and passwords on page 50

● The installation CDs on page 51

● Security on page 52
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Supported platforms
All of the software described in this section must be purchased separately.

This section includes the following topics:

● Avaya IC server platforms on page 42

● Databases on page 43

● Switches and switch software on page 43

● Client operating systems on page 43

● Other required software on page 44

● Media channels on page 45

Avaya IC server platforms

The integration supports the following server platforms.

*Solaris version 8 recommended patch cluster (kernel at level 13 or above) with one of the following 
patches:

- 109147-09 and above

- 108434-02 and above

Related topic

For more information about hardware and software requirements for Siebel server 
platforms, see the Siebel documentation.

Servers Supported versions

Windows Solaris AIX

All Avaya IC 
and Siebel 7.7

Windows 
2000 
Server 
SP4

Windows 
Server 
2003

Solaris 8* Solaris 9 AIX 5.1L 
ML3

AIX 5.2 
ML2

Siebel 7.0 and 
7.5

Windows 2000 Server Solaris 8 AIX 5.1
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Databases

For information about supported Avaya IC and Siebel databases, see:

● IC Installation Planning and Prerequisites

● The Siebel documentation

Switches and switch software

The following switches and switch software are supported in an Avaya IC for Siebel 
integration:

● Avaya DEFINITYÆ ECS R9.5 with CVLAN 8

● Avaya DEFINITY ECS R10 with CVLAN 8

● Avaya DEFINITY Server CSI/SI/R with Avaya Communication Manager R1.1 or later

● Avaya S8700 and S8300 Media Servers with Avaya Communication Manager R1.1 or 
later

● Nortelô  Symposium Server 4.2

● Aspect Call Center 8

Client operating systems

The following operating systems are supported on the client machines:

● Windows NT 4.0 Workstation Service Pack 6a or later

● Windows 2000 Professional Service Pack 3

● Windows 2003

● Windows XP Professional
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Other required software

Other required software is described in the following table.

Required 
software

Location
Supported versions

Windows Solaris AIX

Time 
synchronization 
utility

All server 
machines

Windows ntpd 
process. Can be a 
third-party utility, 
such as Tardis 
2000 v1.4

Solaris ntpd 
process

AIX ntpd 
process

PDF reader for 
documentation All machines Adobe Acrobat Reader 5.0 with Search

Java SDK Machine that 
hosts WebLM

Sun JDK 1.3.1_06 Sun JDK 
1.3.1_06

Email servers Machine that 
communicate
s with 
Notification 
server

SMTP and POP3 compliant email 
servers

SMTP and 
POP3 
compliant 
email servers

Web browser Admin 
machine

Internet Explorer 
5.5, 6.0

Not 
supported

Not 
supported
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Media channels

The following media channels are supported in an Avaya IC for Siebel integration:

● PBX voice - includes support for Interactive Voice Response (IVR) interaction

● Voice over Internet Protocol (VoIP)

● IP text chat

● Outbound dialer

● Assisted Web browsing - includes agent and customer interactive Web forms

● Web callbacks

● E-mail - these are supported as e-mail attachments only, not as separate channels:

- Fax

- Documents

- Web forms - not interactive
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Avaya IC domain deployment guidelines
This section provides suggestions for creating effective domains for the Siebel integration 
servers. The AICD, AED, and EAI are considered Siebel integration servers. Each Siebel 
integration server is administered as an Avaya IC VESP server and assigned to an Avaya 
IC domain. These guidelines will help you choose the best Avaya IC domain.

This section includes the following topics:

● About domains on page 46

● AED domain guideline on page 47

● AICD domain guidelines on page 47

● EAI domain guidelines on page 49

About domains

Installers create Avaya IC domains to partition Avaya IC servers into groups that can 
improve communication paths between clients and servers. Proper domain structure can 
improve performance by avoiding unnecessary communication hops between servers and 
clients. Performance is enhanced when unnecessary Wide Area Network (WAN) hops are 
avoided.

Once Avaya IC domains have been created, they can also be used to specify failover 
communication paths between servers and clients. During Avaya IC installation, each 
domain is administered with a set of failover domains. If communications are broken, either 
because the network path is lost, or because the server has stopped, the servers in the 
failover domains are tried in the order in which they were prescribed.

For most integrations, except for integrations that use load balancing software, you do not 
have to create any new Avaya IC domains.

Related topic

For a description of the deployment guidelines for the Avaya IC domains, see IC 
Installation Planning and Prerequisites guide.
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AED domain guideline

The following table describes the Adaptive E-mail Driver (AED) domain guideline.

Note:
Note: There can be only one AED on the system.

Related topics

For more information, see:

● Installing the AED on page 266

● The AED on page 96

AICD domain guidelines

A single Adaptive Interaction Center Driver (AICD) may service many agents, and there 
may be more than one AICD in a Siebel system. Within the AICD, a unique AICD agent 
session services a single agent.

For all types of configurations, use the AICD driver parameters, ServerUUID, 
ServerDomain, and ConfigurationName meticulously in order to suit your specific site 
needs.

Related topic

For more information, see AICD driver parameters on page 527.

Guideline Reason

Configure the AED to reside in the 
same domain as the Avaya IC e-mail 
Workflow server.

● Ensures that the AED locates the e-mail 
workflow server and the e-mail EDU server.

● Ensures that the AED follow the same failover 
path as the other Avaya IC e-mail 
components.
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Single-site configurations

The following table provides a list of the AICD domain guidelines for single-site 
configurations.

Multi-site configurations

The following table provides a list of the AICD domain guidelines for multi-site 
configurations.

Related topics

For more information, see the following topics:

● Configuring the AICD on page 195

Guideline Reason

If you have one AICD server for your site, 
configure the AICD server to reside in the 
primary agent domain.

● Ensures that the AICD uses the same 
EDU and ADU server as Avaya Agent

● Eliminates the proxy of requests and 
events between EDU servers and 
between ADU servers

● Ensures that the AICD uses the same 
failover domain path as Avaya Agent

If you have more than one AICD server for 
your site, configure each AICD server to be in 
a separate agent domain. For example, 
configure the AICD so that Siebel agents in 
domain A use the AICD for domain A.

For integrations using load balancing 
software, such as Siebel Resonate, create a 
separate domain for the AICD servers.

The load balancing software will 
automatically direct an agent login 
request to the appropriate server to 
balance the load across the Siebel 
servers.

Guideline Reason

Configure a separate AICD for each primary 
agent domain where you have one primary 
agent domain at each Avaya IC site. 
Administer the Siebel server to segregate the 
agents among each multi-site domain. This 
Siebel administration ensures that agents at 
site X use the AICD server for Avaya IC 
domain X.

● Ensures that the AICD uses the same 
EDU and ADU server as Avaya Agent

● Eliminates the proxy of requests and 
events between EDU servers and 
between ADU servers

● Ensures that the AICD uses the same 
failover domain path as Avaya Agent

For integrations using load balancing 
software, such as Siebel Resonate, create a 
separate domain for the AICD servers.

The load balancing software will 
automatically direct an agent login 
request to the appropriate server to 
balance the load across the Siebel 
servers.
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● AICD on page 97

EAI domain guidelines

The following table provides a list of the Enterprise Application Integration (EAI) domain 
guidelines.

Related topics

For more information, see the following topics:

● EAI server types on page 68

● Adding EAI servers to IC Manager on page 210

Guideline Reason

Configure only one instance 
of a given type of EAI server 
per domain. For example, do 
not place two EAIWorkflow 
servers in the same domain.

VESP uses the Avaya IC domain and VESP interface 
type to unambiguously resolve Avaya IC workflow 
requests to the EAI server. If an EAI server of the same 
type is duplicated in an Avaya IC domain, the duplicated 
EAI server will never be used.

Install an EAI and 
EAIWorkflow server in every 
Avaya IC domain that 
contains an Avaya IC 
Workflow server. These are 
domains that contain 
Telephony Server (TS), 
WebACD, and IC Email 
servers.

● Ensures that the Avaya IC workflows associated with 
each media type use a unique set of EAI servers. This 
enhances performance by segregating requests for 
each media type.

● Ensures that Avaya IC workflow requests failover to 
another set of EAI servers if EAI and EAIWorkflow 
servers are configured in the failover domains.

Install an EAIEmail server in 
the domain that contains the 
Avaya IC Workflow server 
that runs the Siebel e-mail 
Content Analysis workflows. 
This is the e-mail domain.

● Ensures that the Avaya IC e-mail workflows find the 
EAIEmail server and write the e-mail to Siebel.

● Ensures that Avaya IC workflow requests failover to 
another EAI server if EAIEmail servers are configured 
in the failover domains.

Install an EAIEmail server in 
the domain that contains the 
Workflow server that has 
been configured for handling 
the agent outbound e-mail 
requests.

● Ensures that the Avaya IC e-mail workflows find the 
EAIEmail server and read the outbound e-mail from 
Siebel.

● Ensures that the Avaya IC workflow requests failover 
to another EAI server if EAIEmail servers are 
configured in the failover domains.
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Matching Siebel and Avaya IC agent login IDs and passwords

Make sure that the Siebel and Avaya IC agent login IDs and passwords match. Matching 
login IDs are required for the Avaya IC for Siebel integration to work. Matching passwords 
make it possible to launch Avaya Agent and automatically log into the Siebel thin client. 
Make sure that the Avaya IC login ID does not have any uppercase letters.

Related topic

For more information, see Avaya IC for Siebel User Guide.
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The installation CDs
For this integration, you will need two installation CDs:

● The Avaya IC 6.1.3 Siebel 7 Integration CD on page 51

● The Avaya IC CD on page 51

The Avaya IC 6.1.3 Siebel 7 Integration CD

The Avaya IC 6.1.3 Siebel 7 Integration CD contains integration components that you will 
install on either Avaya IC or Siebel.

The following components are installed only on Avaya IC:

● Avaya Agent design components for the Siebel integration

● Avaya workflows for the Siebel integration

The following components are installed only on Siebel:

● AICD

● AED

● The Siebel integration components and Siebel workflows

The EAI server may be installed on Avaya IC or Siebel.

The Avaya IC CD

The Avaya IC CD contains the core system that you will install on both Avaya IC and 
Siebel. For example, the Object Request Broker (ORB) Server is installed on the Siebel 
server as well as the Avaya IC servers.
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Security
The same security policies for Avaya IC also apply to the Avaya IC for Siebel integration. 
The following security policies are unique for an Avaya IC for Siebel integration:

● Siebel authenticates clients before the client interacts with the AICD.

● The EAI servers authenticate with Siebel using a Siebel login and password. However, 
the login and password are passed as clear text to Siebel using HyperText Transfer 
Protocol (HTTP). Customers will need to ensure that the EAI servers and Siebel servers 
are connected over a private network and not accessible to the outside.

● The EAI server requires a login ID and password to access the IC Email server for the 
e-mail channel. This login should not be used by agents; it should be a separate user in 
the system just for use by the EAI server.

Related topics

For detailed security information about Avaya IC or Siebel, see the appropriate Avaya IC 
documentation or the Siebel documentation.
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Chapter 3: E-mail entry methods

This section contains the following topics:

● Overview of e-mail entry methods on page 54

● Avaya-first e-mail entry on page 56

● Siebel-first e-mail entry process on page 59

● Similarities and differences between Avaya-first and Siebel-first entry methods on 
page 61
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Overview of e-mail entry methods
This section includes the following topics:

● Siebel-first e-mail entry figure on page 54

● Avaya-first e-mail entry figure on page 54

● Advantages of the Siebel-first e-mail entry method on page 55

● Advantages of the Avaya-first e-mail entry method on page 55

Siebel-first e-mail entry figure

The following figure shows the Siebel-first e-mail entry method.

Avaya-first e-mail entry figure

The following figure shows the Avaya-first e-mail entry method.
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Advantages of the Siebel-first e-mail entry method

Siebel-first e-mail e-mail entry is intended for customers who already have Siebel eMail 
Response and want to have e-mail routed by Avaya IC and perhaps blended with other 
channel work. For these customers, changes to their system and configuration is 
minimized if they use the Siebel-first e-mail entry method.

Advantages of the Avaya-first e-mail entry method

Customers who are not already using Siebel eMail Response should prefer the Avaya-first 
e-mail entry method because it allows Avaya IC to manage all inbound e-mail contacts, not 
just the contacts that need to be handled by an agent. The main advantage of this method 
is that the Avaya IC and Operational Analyst (OA) reporting of e-mail contacts will be 
complete, whereas the Siebel-first e-mail entry method does not include any statistics for 
dismissed or auto-responded e-mails. The Avaya-first e-mail entry method is somewhat 
more complex because e-mails are copied to Siebel, and e-mail responses and replies are 
copied from Siebel back to Avaya IC. Additionally, more sophisticated Avaya IC workflows 
are required for this method.
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Avaya-first e-mail entry
This section includes the following topics:

● Avaya-first e-mail entry overview on page 56

● The Content Analysis process between Avaya IC and Siebel on page 56

● Avaya-first e-mail Content Analysis architecture on page 58

Avaya-first e-mail entry overview

In the Avaya-first entry method, e-mail enters Avaya IC through the POP3 e-mail server. 
Avaya IC uses the EAI to transfer the e-mail to Siebel. Avaya IC requests Siebel to perform 
Content Analysis on the e-mail. Siebel performs Content Analysis on the e-mail, and the 
results are passed back to the Avaya IC workflows that route the e-mail. Siebel generates 
auto-acknowledgement and auto-response e-mails after Siebel performs the Content 
Analysis. For the Avaya-first entry mode, the actual Content Analysis is performed by 
Siebel.

Related topic

For more information about e-mail workflows, see Avaya-first e-mail workflows on 
page 145.

The Content Analysis process between Avaya IC and Siebel

The e-mail Content Analysis process between Avaya IC and Siebel works as follows:

1. A new customer-generated e-mail enters the system.

2. A workflow processes the e-mail.

3. The Workflow server runs the Preanalyze CA workflow that contains a Trigger Siebel 
CA block that requests Content Analysis.

4. The AED, triggered by the Trigger Siebel CA block, passes a request through the 
Siebel Communications Inbound Manager to run a Siebel workflow that performs the 
e-mail Content Analysis.

5. Siebel runs a set of e-mail response workflows that perform e-mail Content Analysis 
and determine a disposition for the e-mail.

6. Siebel passes one of the following results to Avaya IC:

● Auto Response Ready
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● Agent Routing Ready

● Dismissed

● Error Occurred

7. The AED populates the results into its own data structure.

8. The AED sets the EDU values for confidence, category, language of e-mail, and 
number of confidences and categories.

9. The AED starts the Postanalyze workflow.

10. The Postanalyze workflow uses the EDU ID to extract the response data and process 
the information.

11. If Avaya IC does not receive a response from Siebel because of a timeout or because 
of any other type of failure, the AED starts the Postanalyze Error workflow. Avaya IC 
continues to process the e-mail, but the e-mail will be routed to a default queue, and 
the system may not pick the best agent to handle the e-mail.

Related topics

For more information about Siebel e-mail Content Analysis, see one of the following topics:

● Process of e-mail workflows within Avaya IC on page 70

● Avaya-first e-mail workflows on page 145

● For more information about e-mail Content Analysis within Siebel, see the Siebel 
documentation.
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Avaya-first e-mail Content Analysis architecture

The following figure shows the architecture for Siebel e-mail Content Analysis.
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Siebel-first e-mail entry process
In the Siebel-first entry method, e-mail enters through Siebel. If Siebel decides that the 
e-mail needs to be sent to an agent, Siebel sends a notification e-mail to Avaya IC. Avaya 
IC routes the e-mail to the agent.

The following process describes the Siebel-first e-mail entry method in more detail:

1. E-mail enters Siebel through the POP3 e-mail server.

2. Siebel runs an e-mail response workflow.

3. The e-mail response workflow determines how to process the e-mail. One of the 
following actions occur:

● Siebel dismisses the e-mail and the e-mail process ends. For example, Siebel 
dismisses the e-mail because it detects junk e-mail.

● Siebel performs Content Analysis on the e-mail and the resulting confidence level 
exceeds the administered threshold. An auto-response is sent without agent 
involvement. In this case, an auto-acknowledgement is typically not sent.

● Siebel performs Content Analysis on the e-mail and the resulting confidence level is 
below the administered threshold. The e-mail is routed to an agent using the 
process described in Steps 4 through 9. Typically, an auto-acknowledgement is sent 
to the customer because agents cannot always respond immediately to customer 
e-mail. This is optional.

4. Siebel composes an e-mail with new information encoded in the body and sends this 
notification e-mail to a mailbox on a POP3 e-mail server. The e-mail includes the 
following information:

● The To, From, and Subject information of the original e-mail

● Language as determined by Siebel Content Analysis

● Content Analysis results from Siebel

● ActivityID of the original Siebel e-mail

5. Avaya IC reads the e-mail from the POP3 server and starts a Siebel-first e-mail 
workflow to process it.

6. The workflow processes the e-mail so that Avaya IC can route the e-mail using the 
e-mail routing workflow.

7. Once the work item or e-mail appears on the agent desktop, the original e-mail is 
popped in the Siebel screen using the Activity ID that was passed from Siebel.

8. Once the agent has replied to or forwarded the e-mail, the agent releases the work 
item from the Siebel toolbar. The agent can also dismiss the e-mail without forwarding 
or replying.
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9. The AICD receives a message to release the work item and passes a disconnect 
e-mail message to Avaya Agent. The way Avaya Agent handles a disconnect message 
is similar to the way it handles a dismiss message. If a response has been sent to the 
customer, the dismiss is transparent to the agent on the Avaya Agent side. In other 
words, the agent will not see a dialog box asking for a dismiss reason. Instead, Avaya 
Agent will use a special pre-configured dismiss reason.

If the agent has dismissed the e-mail without replying or forwarding, the agent is asked 
for a dismiss reason.

10. Siebel sends out the e-mail response composed by the agent.

Related topics

See one of the following topics:

● For more information about how Content Analysis works within Siebel, see the Siebel 
documentation.

● For more information about e-mail workflows, see Siebel-first e-mail workflow on 
page 159.
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Similarities and differences between Avaya-first and 
Siebel-first entry methods

This section contains the following topics:

● Similarities between Avaya-first and Siebel-first on page 61

● Differences between Avaya-first and Siebel-first on page 62

Similarities between Avaya-first and Siebel-first

The following table describes the similarities between the Avaya-first and Siebel-first e-mail 
entries when configuring Siebel.

Area of 
functionality

Avaya-first Siebel-first

Business service - 
delivered as an 
SIF or js file

AICD AICD

Application level 
eScript

StoreId StoreId

ClearId ClearId

Applet level 
eScript Comm Outbound Item Form Applet Comm Outbound Item Form Applet
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Differences between Avaya-first and Siebel-first

The following table describes the differences between the Avaya-first and Siebel-first 
e-mail entries when configuring Siebel.

Area of 
functionality

Avaya-first Siebel-first

Applet Level 
eScript Send Communication Applet

No scripts were added to the Send 
Communication Applet because the AICD 
commands are not called. The e-mails are 
delivered by the Siebel driver. When 
sending new outbound e-mail using the 
Siebel toolbar, agents use a 
Siebel-provided mechanism.

Siebel workflows 
required by the 
AED

● Avaya IC Analyze Message
● Avaya IC Append Thread Id
● Avaya IC Identify Language
● Avaya IC Parse Junk Email
● Avaya IC Process Message
● Avaya IC Set Auto Acknowledge
● Avaya IC Set Auto Response
● Avaya IC Update Activity Status

The AED is not used for the Siebel-first 
e-mail method.

Avaya IC 
workflows

● Event = ICEmail.Analyze Flow = 
icemail_sbl.preanalyze_sbl

Event = ICEMail.Analyze Flow = 
icemail_sbl_first.analyze_sbl

● Event = ICEmail.OutboundEmail Flow = 
icemail_sbl.outboundemail_sbl -
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Related topics

For more information, see one of the following topics:

● Siebel-first e-mail entry process on page 59

● Avaya-first e-mail entry on page 56

● Process of e-mail workflows within Avaya IC on page 70

● For more information about e-mail Content Analysis within Siebel, see the Siebel 
documentation.

Siebel workflows

Default workflows are automatically activated during installation. These workflows are not 
included on the installation CD.

● eMail Response - Append Thread Id
● eMail Response - Response Workflow
● eMail Response - Update Activity Status

● eMail Response - Append Thread Id
● eMail Response - Create Activity
● eMail Response - Get Entitlement Id
● eMail Response - Identify Language
● eMail Response - Parse Junk Email
● eMail Response - Response Workflow
● eMail Response - SR Help
● eMail Response - Send 

Acknowledgement
● eMail Response - Send Auto Response
● eMail Response - Update Activity Status

Custom workflows are provided by Siebel are not modified for the integration. These 
workflows are included on the installation CD.

-

● eMail Response - Analyze Message
● eMail Response - Process Message
● eMail Response - Route Avaya
● eMail Response - Route Email

Custom workflows are provided by Siebel and modified for the integration. These workflows 
are included on the installation CD.

● eMail Response - Client Send Email
● Avaya IC Client Send Email ● eMail Response - Client Send Email

Area of 
functionality

Avaya-first Siebel-first
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Chapter 4: Components within Avaya IC

This section describes the integration components that reside within Avaya IC and 
includes the following topics:

● EAI server on page 66

● Process of e-mail workflows within Avaya IC on page 64

● Avaya IC management tools on page 71

● ORB Servers on page 73

● Web Agent on page 74
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EAI server
This section includes the following topics:

● About the EAI server on page 66

● EAI figure on page 67

● EAI interfaces on page 67

● EAI server types on page 68

● Server type limitations on page 69

About the EAI server

The Enterprise Application Integration (EAI) server is a new component of Avaya IC. The 
EAI server:

● Accepts requests from blocks on the Avaya IC to perform Get Data, Get Email, Put 
Data, and Put Email operations

● Transfers e-mails stored in the Avaya IC database back and forth between Avaya IC 
and Siebel

Related topics

For more information, see any of the following topics:

● Configuring the Avaya EAI servers on page 208

● EAI in multi-site configurations on page 37

● EAI server errors on page 358

● EAI Get and Put operations on page 497

● For more information about the EAI on Siebel, see the Siebel documentation.
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EAI figure

The following figure shows how the EAI interfaces with Siebel.

EAI interfaces

The EAI server communicates with the Avaya IC Directory, Alarm, IC Email, and Workflow 
servers. The Siebel EAI server uses the interfaces described in the following topics:

● IC Email server socket-based interface on page 67

● HTTP/MIME/XML interface on page 68

IC Email server socket-based interface

The EAI server uses the IC Email server socket-based interface to do the following actions 
so that the Avaya IC domain does not affect this communication:

● Retrieve e-mail content

● Pass the content to Siebel to store as a Siebel business record

● Transfer e-mail replies from Siebel to the Avaya IC Email server
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HTTP/MIME/XML interface

The Avaya IC EAI server and Siebel use the HTTP/MIME/XML interface to transfer 
encoded messages. The EAI server on Avaya IC works as a client to the Siebel EAI server 
through the Siebel Web server.

EAI server types

The Avaya EAI servers provide the communication links between Avaya IC and Siebel so 
that Avaya IC workflows can read and write customer data, as well as manage e-mail 
messages to and from the Siebel database. Each of the three EAI server types use 
different protocols to communicate with Siebel, and each protocol supports different 
integration capabilities and overhead.

The three types of EAI servers are described in the following table.

Related topics

For more information, see the following topics:

● Siebel palette blocks on page 117

● Adding the EAI server on page 210

● Adding the EAIWorkflow server on page 212

● Adding the EAIEmail server on page 213

Server type Description

EAI Supports the Avaya IC Get Data block in the default voice qualification 
workflow, incomingcall_sbl.

EAIWorkflow Supports the Avaya IC Put Data block in the default voice qualification 
workflow, incomingcall_sbl.

EAIEmail

Supports Avaya IC Get Email and Put Email blocks in the default e-mail 
qualification workflows, preanalyzeca_sbl, preanalyzenoca_sbl, and 
postanalyze_sbl. If you do not use e-mail, you do not need this server 
type.
You must install and configure other Siebel workflows in order for 
Avaya IC and Siebel to effectively process e-mail. This is described in 
the Installation and configuration tasks for all channels chapter.
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Server type limitations

The differences in EAI server type limitations are described in the following table.

1. The MIME layer allows attachments to be added to the request. For example, an attachment is required 
when creating a Web chat record along with the transcripts.

2. Use EAIWorkflow or EAIEmail for Put operations.

Example of a limitation

The EAI server type interacts directly with the EAI on Siebel. Because Siebel integration 
objects do not return a record ID on a Put request, the record ID cannot pop a Siebel 
screen to the agent with a newly-created record.

The EAIEmail server type encodes the Get or Put request in Multipurpose Internet Mail 
Extensions (MIME) and calls a special Siebel workflow that is contained within the Avaya 
IC EAI MIME.xml file. This Siebel workflow decodes the XML request. The EAIWorkflow 
server type optionally encodes the Put request in MIME and calls the same Siebel 
workflow to decode the MIME request. The Siebel ID is returned on a Put request so that 
the record ID can pop a Siebel screen to the agent with a newly-created record.

EAI server 
type Operation Attachments1 allowed?

Returns 
Siebel ID 
record?

EAI
Get No Yes

Put No No2

EAIWorkflow

Get No Yes

Put Optional attachments configured in IC 
Manager and IC Workflow Yes

EAIEmail
Get Yes Yes

Put Yes Yes
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Process of e-mail workflows within Avaya IC

Siebel Preanalyze CA workflow - This workflow uses the Siebel Put Email block to move 
the e-mail contents into Siebel. Siebel assigns an Activity ID for the e-mail that is stored in 
the EDU. Then, the Siebel Content Analysis block requests Siebel to perform Content 
Analysis on the e-mail. This block writes information into the EDU, which causes the 
Adaptive E-mail Driver (AED) to request Siebel to run an eMail Response workflow in 
Avaya IC.

Siebel Postanalyze workflow - This workflow is started by the AED when Siebel 
responds to the Content Analysis request. If any of the following events occur, the 
Postanalyze workflow will process the e-mail:

● The agent dismisses the e-mail

● Siebel decides to send an auto-response message

● Siebel decides to route the e-mail to an agent

Siebel Outbound Email workflow - This workflow completes the process of routing the 
e-mail to an agent. Using routing hints set up in the postanalyze_sbl workflow, the 
Outbound Email workflow routes the e-mail to an available agent with the best skills to 
handle the e-mail.

Related topics

For more information, see the following topics:

● Preanalyze CA workflow on page 146

● Postanalyze workflow on page 151

● Outbound Email workflow on page 158

● For a description of how e-mail blocks work between Avaya IC and Siebel, see 
Avaya-first e-mail entry on page 56 or Siebel-first e-mail entry process on page 59.

● For a more information about e-mail functionality within Siebel, see the Siebel 
documentation.
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Avaya IC management tools
You will need to use the following Avaya IC management tools to install, configure, and 
customize the Avaya IC for Siebel integration:

● Database Designer on page 71

● IC Manager on page 71

● Workflow Designer on page 72

Database Designer

The Database Designer is a tool used to configure databases, set database connections, 
customize or generate default applications, and push applications and IC Scripts to the 
database. Use Database Designer to configure the Avaya Agent databases to work with 
the integration.

Related topic

For more information about Database Designer, see IC Database Designer User Guide.

IC Manager

Use Interaction Center (IC) Manager to:

● Add new Siebel property values and modify existing Avaya IC property values

● Install an Avaya IC server on Siebel and configure a secondary ORB server

● Create, install, and monitor the AICD

● Install and monitor the EAI server

● Configure workflow servers to use Siebel voice, Web, and e-mail workflows

● Modify the Website to use Customer Management workflows for Web

● Configure Avaya IC Resolve Status so that Avaya Agent can release e-mail work 
without first responding to the e-mail sender

● Install the AED

Related topic

For more information about IC Manager, see IC Administration Volume 2: Agents, 
Customers, & Queues.
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Workflow Designer

Use Workflow Designer to install, configure, and customize the workflows that are specific 
to an Avaya IC for Siebel integration. Specifically, you will use Workflow Designer to:

● Add the default workflows for the integration

● Install and compile the Siebel incoming-call and Transcript Added workflows on Avaya 
IC

Related topic

For more information about Workflow Designer, see Avaya Workflow Designer User Guide.
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ORB Servers
The Avaya IC ORB Server controls and maintains servers. Every machine that runs 
servers must have an ORB Server. The ORB Server can start, stop, and monitor the status 
of any server.

ORB Servers on different machines communicate with each other to find the correct 
resource for a client request. If the requested service is not on the ORB Server machine, 
the request is rerouted to the correct ORB Server. If a server is not yet started, the ORB 
Server will start it.

Related topics

For more information, see the following topics:

● Installing an Avaya IC server on Siebel and configuring a secondary ORB Server on 
page 185

● Avaya IC Core Services Programmer Guide.
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Web Agent
This section includes the following topics:

● Definition of Web Agent on page 74

● Changes for the integration on page 74

Definition of Web Agent

In a non-integrated system, the Web Agent is a window in the GUI desktop that agents use 
to handle their e-mail and Web chat contacts after selecting these contacts from the Avaya 
Agent task lists.

Changes for the integration

In a Siebel integration, all e-mail, work transfer, and work completion options are disabled 
in the Avaya Web Agent window because these functions are now performed through the 
Siebel Application window.

The Web Agent application still performs the following tasks in the background:

● Supports a mode where it is the source of events and methods for e-mails, even though 
it does not display e-mails in the Avaya Web Agent window. The properties files for 
Web Agent were modified to accomplish this.

● Programs the wrap-up and completion of an e-mail task

● Transfers e-mails or chats using the Unified Agent Directory (UAD)
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Chapter 5: Avaya Agent integration

This section describes the integration components that reside within Avaya Agent and 
includes the following topics:

● Avaya Agent architecture on page 76

● Avaya Agent layout file on page 79

● About IC Scripts on page 81

● Integration hooks on page 82

● Customizing AUX reason codes on page 85

● AICDEngine on page 87

● Wrap-up on page 89

● Agent properties on page 92
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Avaya Agent architecture
This section includes the following topics:

● Avaya Agent architecture figure on page 76

● Areas of functionality on page 77

● Avaya Agent interactions on page 77

Avaya Agent architecture figure

The following figure shows a high level diagram of the Avaya Agent architecture as it 
applies to the Siebel integration.
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Areas of functionality

Avaya Agent has the following areas of functionality within an Avaya IC for Siebel 
integration.

Base Avaya Agent controls - Existing, default ActiveX controls that reside in Avaya 
Agent

Base IC Scripts - Existing set of IC Scripts shipped with Avaya IC

Siebel integration IC Scripts - IC Scripts written directly for the Siebel integration. These 
scripts are responsible for handling the actual requests from the AICD by calling methods 
on the Avaya Agent controls. When events occur in Avaya Agent, the Siebel integration IC 
Scripts are responsible for notifying the AICD.

AICDEngine - ActiveX control that serves as bridge between Avaya Agent and the AICD

Avaya Agent interactions

Avaya Agent has the following interactions within an Avaya IC for Siebel integration.

Siebel integration IC Scripts -> Siebel thin client - The Siebel thin client is launched 
using an Internet Explorer (IE) browser. This is accomplished by the Siebel integration IC 
Scripts.

AICDEngine <-> AICD - The AICDEngine is assigned to the AICD that is servicing the 
agent logged into Siebel. This allows a two-way communication path. The AICDEngine 
makes requests to the AICD, and the AICD triggers events that are picked up and 
propagated by the AICDEngine.

AICDEngine <-> ADU - One of the responsibilities of the Avaya Agent integration is to 
notify the AICD when certain ADU fields change value. The AICDEngine assigns to the 
ADU server for change events and sends these values to the AICD.

AICDEngine <-> EDU - The AICDEngine assigns to the EDU server so that the EDU 
server can receive broadcast message requests, as well as propagate EDU Change 
events for certain fields that are relevant to the AICD.

AICDEngine <-> Siebel integration IC Scripts - Siebel integration IC Scripts send 
requests to the AICD through the AICDEngine. Vice versa, all messages sent by the AICD 
come in the form of events to the AICDEngine. The AICDEngine then starts an event that 
are handled by the Siebel integration IC Scripts.
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Base IC Scripts <-> Siebel integration IC Scripts - This interaction occurs through 
integration hooks. The Siebel integration IC Scripts take appropriate action based on 
integration hooks that are being sent from the base IC Scripts.

Siebel integration IC Scripts -> Base Avaya Agent controls - When the AICD makes a 
request to Avaya Agent by triggering an event to the AICDEngine, the Siebel integration IC 
Scripts call methods on the base Avaya Agent control.
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Avaya Agent layout file
This section includes the following topics:

● CDL file description on page 79

● The Siebel integration CDL file on page 79

● Differences in the Avaya Agent taskbars on page 79

CDL file description

The CDL (Console Definition Language) file specifies the Avaya Agent screen layout and 
is written in XML (eXtensible Markup Language). During the Avaya Agent installation, the 
CDL was saved to the database after the file was customized.

When an agent logs in, the system accesses the stored layout from the CDL file and 
configures the client machine accordingly.

The Siebel integration CDL file

The following list describes how the Siebel integration CDL file differs from the default 
Avaya CDL file. The Siebel integration CDL file:

● Has a set of Siebel-specific EDU fields in the EDUFields QSection of the 
QPropertyDictionary

● Has a Siebel QSection in the QPropertyDictionary

● Contains only a bottom frame and a different arrangement of controls

● All call-handling controls are removed from the layout

● Does not contain a Status Dialog for handling conferences and transfers

● Still has status control, but it is not visible to the agent. Status control supports only the 
dialogs for restoring Blender server failures, and Siebel performs the status functions.

● Includes the AICDEngine in the layout

Differences in the Avaya Agent taskbars

The following figures show how the default Avaya Agent taskbars differ between a 
non-integrated system and an Avaya IC for Siebel integration.
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Note:
Note: The equivalent to the Prompter pane resides in the avaya_agent_sbl_*.cdl 

file, but it is hidden unless you change the default configuration.

Related topics

● For information about the Avaya Agent taskbar in an Avaya IC for Siebel integration, see 
Avaya IC for Siebel User Guide.

● For more information about the Avaya Agent CDL file in a non-Siebel-integrated system, 
see Avaya Agent Integration.

● For more information about installing the CDL file, see Generating the Windows 
application on page 175.

Avaya Agent taskbar in a 
non-integrated system

Avaya Agent taskbar in an Avaya IC for 
Siebel integration
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About IC Scripts
Avaya IC Scripts are Visual Basic for Applications (VBA)-based subroutines that the 
system runs, either explicitly or when an event is raised. Events can be raised by:

● Controls

● Pane activation or deactivation

● Mouse clicks

● Key presses

These subroutines can do a variety of tasks, from displaying an alert for the agent to 
saving information into the database.

The Avaya IC for Siebel integration includes a set of IC Scripts that are shipped with the 
Siebel integration. Do not customize these IC Scripts. Instead, use the integration hooks 
that have been built into the IC Scripts specifically for customizing the Siebel integration.

Related topic

For more information, see Integration hooks on page 82.
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Integration hooks
Integration hooks allow you to customize Avaya Agent to accomplish more advanced 
custom implementations without changing the base Avaya Agent IC Scripts. You can use 
integration hooks to handle any of the following advanced implementations:

● Handle the reason codes sent with the AgentUnavailable and ChangeAuxReasonCode 
AICD commands

● Handle the wrap codes sent with the ReleaseWork AICD command for Siebel wrap-up

● Handle OnNewOpenData broadcasts

● Implement custom AICD commands

Related topics

For more information, see the following topics:

● For a complete description of integration hooks, see Avaya Agent Integration.

● For a description of commands, see AICD commands on page 381

Integration hook handlers

A set of integration hook handlers are included in the Siebel integration. These integration 
hooks are included in the integration to provide you with examples so that you can create 
custom integration hooks for your site. This set of integration hook handlers are located on 
the design machine in <AVAYA_IC61_HOME>/design\qconsole\siebel\custom.

The following integration hooks are included with the integration:

● SiebelAICDEngine_AICDEngineStateChanged on page 83

● SiebelAICDEngine_BroadcastMsgReceived on page 83

● SiebelAICDEngine_RequestReceived on page 83

● Siebel_AICD_AgentUnavailable on page 83

● Siebel_AICD_ChangeAuxReasonCode on page 83

● Siebel_AICD_ReleaseWork on page 83

● Siebel_ResolveDestination on page 84
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SiebelAICDEngine_AICDEngineStateChanged

This integration hook is called when the state of the AICDEngine has changed. Use this 
integration hook to determine when the AICDEngine is establishing or losing its connection 
to the servers.

SiebelAICDEngine_BroadcastMsgReceived

This integration hook is called anytime the AICD generates a BroadcastEDU request from 
the AICDEngine. Use this integration hook to customize the OnNewOpenData broadcast 
message that reads data from the EDU.

SiebelAICDEngine_RequestReceived

This integration hook is called anytime the AICDEngine receives a request from the AICD. 
Use this integration hook to customize the AvayaAgentCommand request to create new 
functions. The AvayaAgentCommand is a generic request that can be triggered from 
Siebel.

Siebel_AICD_AgentUnavailable

This integration hook is called when the AICD sends the AgentUnavailable request. You 
can customize this integration hook to send a reason code with the AgentUnavailable 
request. The reason code is passed into the integration hook in the sReasonCode variable. 
In order for this to work, you must create a true sReasonCode and sReasonDigit to send 
back. The sReasonCode is a pkey of a classification code record in the IC Repository. The 
sReasonDigit is a 0 - 9 value that is sent to the Telephony Server (TS) for voice-enabled 
agents.

Siebel_AICD_ChangeAuxReasonCode

This integration hook is called when the AICD sends the ChangeAuxReasonCode request. 
Rules about what must be done here mirror the information explained in 
Siebel_AICD_AgentUnavailable.

Siebel_AICD_ReleaseWork 

This integration hook is called when the AICD sends the ReleaseWork request. The 
ReleaseWork request is sent only when wrap-up is enabled, and the WrapUpType is 
Siebel. When these conditions are met, you can choose to send data in the wrap codes 
parameter. You can then use this data to customize the storage of these wrap-up codes in 
the Avaya IC system using this script.
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Siebel_ResolveDestination 

This integration hook is called when the system tries to resolve a destination that was 
passed from Siebel into a MakeCall, InitConsultTransfer, InitConference, or 
InitMuteTransfer request. Use this integration hook if you want to change the way the 
default destination resolution is performed.
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Customizing AUX reason codes
This section includes the following topics:

● Using Avaya IC AUX reason codes on page 85

● Using Siebel AUX reason codes on page 85

Using Avaya IC AUX reason codes

In the default Siebel integration, if you configure and enable AUX reason codes in Avaya 
IC, Avaya Agent automatically prompts the agent for the codes. When the agent chooses 
Unavailable from the Siebel toolbar, the Aux Reason Dialog window pops up and 
prompts the agent to choose a code. This code is written to the ADU the same way as in a 
non-Siebel integrated environment. A numeric reason digit (0-9) associated with the AUX 
reason code is also passed to the Telephony Server (TS) for voice-enabled agents.

If you want to use AUX reason codes with your own dialog window, you must customize 
Avaya Agent using the integration hooks provided. Use integration hooks 
Siebel_AICD_AgentUnavailable or Siebel_AICD_ChangeAuxReasonCode. For a 
description of how the default integration hook works for Unavailable, see the custom 
samples shipped with the code at <AVAYA_IC61_HOME>\design\qconsole\siebel\
custom. These samples have examples and notations that may be useful.

Using Siebel AUX reason codes

If you want to prompt for AUX reason codes in Siebel using an applet and pass them to 
Avaya IC, customize the AICD.def file and Avaya Agent. You must also either build a 
custom Siebel applet or use a predefined applet, such as the Transfer Multiple LOV Popup 
Applet.

An AUX reason code can be passed from Siebel to Avaya IC using the Reason parameter 
to the AICDís AgentUnavailable or ChangeAuxReasonCode driver commands.

The default AICD.def file does not pass a Reason parameter on AgentUnavailable. 
However, for the ChangeAuxReasonCode command under the Siebel 
NotReadyWithPopup menu, the default code invokes the Siebel Transfer Multiple LOV 
Popup Applet and passes the selected Reason value to Avaya Agent using the 
sReasonCode parameter. You must customize the code in the appropriate Avaya Agent 
integration hook handler to translate the sReasonCode parameter to a true sReasonCode 
and sReasonDigit per the description on Siebel_AICD_AgentUnavailable on page 83. You 
may also need to modify the AICD.def in order to associate the correct buttons and menus 
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with your reason code applet and to pass the appropriate reason code values to the AICD 
AgentUnavailable or ChangeAuxReasonCode commands.
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AICDEngine
The AICDEngine is an integral part of the Avaya IC for Siebel integration. When 
implementing more advanced customizations, you might want to send a request 
to the AICD to trigger events in Siebel. Therefore, it is important to understand the 
API on the AICDEngine that sends requests to the AICD.

SendRequest

Description This method causes the AICDEngine to make a request to the AICD through 
VESP.

Syntax SendRequest (sRequest As String, oRequestDataSeqCouple As Object) As 
Boolean

Returns If successful, the function returns a value of True.

Argument Description

sRequest The request you want to send to the AICD

oRequestDataSeqCouple A Core SeqCouple of the name value pairs to 
send with your request
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Usage example

The following IC Script code is an example of the OnAvayaAgentEvent request. This 
request triggers an event within Siebel.

This code created OutRequestDataSeqCouple that contains the data that is needed to be 
passed to the event. You can then enhance the Siebel definition file to work with the 
requests you make.

Sub Sample_OnAvayaAgentEvent_Request()
Dim iApp As Application
Dim iSiebelAICDEngine As Object
Dim iOutRequestDataSeqCouple As Object

Set iApp = GetApp
Set iSiebelAICDEngine = iApp.GetActiveXControl("SiebelAICDEngine")
Set iOutRequestDataSeqCouple = _

CreateObject(iApp.GetProperty("ObjectClasses", "CoreSeqCouple"))

iOutRequestDataSeqCouple.AddCoupleByNameValue "event_name", "LookHere"
iOutRequestDataSeqCouple.AddCoupleByNameValue "foo", "bar"
iOutRequestDataSeqCouple.AddCoupleByNameValue "abc", "xyz"
bResult = iSiebelAICDEngine.SendRequest("OnAvayaAgentEvent", 

iOutRequestDataSeqCouple)

Set iOutRequestDataSeqCouple = Nothing

End Sub
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Wrap-up
This section includes the following topics:

● Description of wrap-up on page 89

● Integration wrap-up methods on page 89

● Avaya IC wrap-up vs. Siebel wrap-up figure on page 90

Description of wrap-up

Wrap-up is the state the agent enters after contact with a customer ends. This gives an 
agent time to finish tasks related to the contact as well as to enter reason codes for the 
contact. On most Avaya IC systems, an agent does not receive new contacts on a channel 
that is in a wrap-up state.

Integration wrap-up methods

In the Siebel integration, there are two ways to perform a wrap-up:

● Avaya IC wrap-up - The Avaya Agent implementation completes the wrap-up. Avaya IC 
wrap-up is done through the WrapUp Dialog or Prompter Scripting.

● Siebel wrap-up - The Siebel implementation completes the wrap-up.

In both cases, the Agent/Desktop.WrapUpEnabled property enables or disables wrap-up. 
If wrap-up is enabled, the Agent/Desktop.WrapUpType property is used to determine what 
type of wrap-up is performed. If this property is set to Siebel, the system uses the Siebel 
wrap-up. Otherwise, the system enforces the default Avaya IC wrap-up method.

Related topic

For more information about enabling or disabling wrap-up, see Setting Avaya IC 
properties on page 182.
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Avaya IC wrap-up vs. Siebel wrap-up figure

The following figure shows how the logic for wrap-up differs between the default Avaya IC 
implementation and the Siebel integration.

When Siebel wrap-up is enabled, the contact is completed only after the ReleaseWork 
command is sent from the AICD. The ReleaseWork command may include a 
comma-separated list of WrapUpCodes.
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Related topics

For more information, see the following topics:

● ReleaseWork on page 443

● Siebel_AICD_ReleaseWork on page 83
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Agent properties
This section describes how agent properties are used for an Avaya IC for Siebel 
integration and includes the following topics:

● Description of agent properties on page 92

● Siebel integration agent properties on page 92

Description of agent properties

Properties are options that define the behavior of agent business applications. Properties 
are defined in IC Manager and then assigned to Avaya IC tenants, workgroups, or agents.

IC Manager stores these properties in the database so that Avaya IC business applications 
can retrieve the property settings. Storing properties in the database also means that no 
matter what machine an agent uses, Avaya Agent always looks and behaves the same 
way. 

Related topics

For information about how to set agent properties or for more detailed conceptual 
information, see IC Administration Volume 2: Agents, Customers, & Queues.

Siebel integration agent properties

The following table lists the Siebel integration properties.

Property path Property name Description

Agent/Desktop/WAC

AlwaysOnTop
Determines whether or not to set 
the Web Agent Client (WAC) 
window on top.

AppMode Determines the mode of the Web 
Agent Client application.

Agent/Desktop/Siebel AutoLoginEnabled Determines whether or not to 
automatically log in to Siebel.
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Agent/Desktop

ContactSuspensionEnabled
Displays the Contact Suspension 
dialogs when an agent suspends a 
contact.

IntegratedApplication
Determines which third-party 
application is integrated with Avaya 
Agent.

Agent/Desktop/Siebel LaunchURL
Determines the URL that opens the 
Siebel application from Internet 
Explorer.

Agent/Desktop Layout Specifies which layout, or CDL file, 
to use for Avaya Agent.

Agent/Desktop/Siebel/
AutoLogin PasswordFormat

Determines how to change the 
case-sensitivity of the Avaya IC 
password so that Siebel accepts the 
password during AutoLogin.

Agent/Desktop/
ScreenPop

PopOnAllArrivingContacts
If screen pops are enabled, screen 
pops occur for all contacts arriving 
in Avaya Agent.

PopOnContactActivation
If screen pops are enabled, screen 
pops occur when contacts are 
activated in Avaya Agent.

PopOnFirstArrivingContact
If screen pops are enabled, screen 
pops occur when there are no other 
contacts in Avaya Agent.

Agent/Desktop/
OutboundAgent ProceedAfterWrapUp

Automatically selects the Proceed 
button when the agent completes a 
wrap-up.

Agent/Desktop ScreenPopEnabled Enables and disables screen pops.

Agent/Desktop/Siebel/
Email SendFlowName

Specifies the name of the e-mail 
workflow that runs in the 
WorkFlowServerName workflow 
server.

Agent/Desktop/Directory

ShowAgentsOnStartup Shows agents during startup in the 
Unified Agent Directory (UAD).

ShowAllAgents Shows all agents in the entire Agent 
Directory Tree in the UAD.

Property path Property name Description
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Related topics

For more information, see the following topics:

● Wrap-up on page 89

● Setting Avaya IC properties on page 182

● For more detailed conceptual information, see IC Administration Volume 2: Agents, 
Customers, & Queues.

Agent/Desktop/WAC

ShowOnChatActivate
Determines whether or not to show 
the WAC window when a Web chat 
is activated.

ShowOnChatSelect
Determines whether or not to the 
Web Agent client appears when an 
agent selects a Web chat task.

ShowOnEmailActivate
Determines whether or not to show 
the WAC window when an e-mail 
message is opened.

ShowOnEmailSelect
Determines whether or not to the 
Web Agent client appears when an 
agent selects an e-mail task.

Agent/Desktop/Siebel/
AutoLogin

UserNameFormat

Determines how to change the 
case-sensitivity of the Avaya IC user 
name so that Siebel accepts the 
name during AutoLogin.

WaitTime

Determines the number of seconds 
that the system waits for the Siebel 
login page to display before 
prompting a skip message.

Agent/Desktop/Siebel/
Email WorkFlowServerName Specifies the workflow server name 

for e-mail.

Agent/Desktop

WrapUpEnabled Enables and disables wrap-up.

WrapUpType If wrap-up is enabled, determines 
the type of wrap-up.

Property path Property name Description
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Chapter 6: Components within Siebel

This section describes the integration components that reside within Siebel and includes 
the following topics:

● The AED on page 96

● AICD on page 97

● Integration objects on page 100

● SCAPI interface on page 103

● Siebel activity records on page 104

● Siebel user interface on page 106

● Siebel Communications Server on page 107

● Siebel definition file on page 108

● Siebel Tools on page 111

● Smart Answer and Smart Answer Manager on page 112
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The AED
This section includes the following topics:

● Description of the AED

● E-mail content and the AED

● The AED in multi-site configurations

Description of the AED

The Adaptive E-mail Driver (AED) runs on a Siebel application server and passes a 
request from Avaya IC to Siebel to perform Content Analysis on e-mail. The AED passes 
requests through the SCAPI interface.

The AED runs as a Dynamic Link Library (DLL) on Windows or a shared library on Solaris/
AIX under the Siebel Inbound Communications Manager (SICM).

E-mail content and the AED

E-mail content does not pass through the AED. E-mail content is exchanged with Siebel 
only through the data exchange mechanism. It is assumed that an e-mail has been 
successfully transferred from Avaya IC to Siebel before a request to do Content Analysis is 
made. 

Related topic

For more information, see Data exchange on page 32.

The AED in multi-site configurations

This integration does not support the AED in multi-site configurations.
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AICD
This section includes the following topics:

● Overview of the AICD on page 97

● AICD and Siebel interfaces on page 98

● AICD and Avaya IC interfaces on page 98

● AICD and interfaces to Avaya Agent on page 99

● Multiple AICDs on page 99

Overview of the AICD

This section includes the following topics:

● What the AICD does on page 97

● AICD architecture figure on page 98

What the AICD does

The Adaptive Interaction Center Driver (AICD) is a new integration component that is 
located on a Siebel Application server. The AICD supplies a default integration between 
Avaya IC and Siebel that:

● Allows Avaya IC to pass work notifications and work-related events to Siebel

● Allows Siebel to pass work-related control commands to Avaya IC

● Synchronizes various agent actions and states between the Siebel browser-based 
desktop and the Avaya Agent desktop

● Manages some Siebel user interface tasks, such as updating the state of the Siebel 
toolbar buttons

The AICD runs on a Siebel server as a Dynamic Link Library (DLL) on windows or a 
shared library on Solaris/AIX under the Siebel Communications Server.
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AICD architecture figure

The following figure shows how the AICD functions within an integrated system.

AICD and Siebel interfaces

The AICD is a Siebel Communications Server driver that communicates to Siebel through 
the Siebel Adaptive Communications API (SCAPI) interface. The SCAPI interface passes 
work item events from the AICD to Siebel, and passes work item commands from Siebel to 
the AICD.

AICD and Avaya IC interfaces

The AICD uses the following components to communicate with Avaya IC:

VESP - The AICD uses the Avaya IC Voice Enhanced Services Platform (VESP) to 
communicate with the Avaya IC servers, and uses the Avaya IC Multi-Threaded Toolkit 
(MTT) to accomplish these communications.

TS - The AICD uses the Telephony Server (TS) to monitor the telephone extension of each 
agent. The AICD also sends commands to the TS in response to actions taken by the 
agent through the Siebel toolbar - for example, when an agent puts a call on hold.
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ADU - The AICD uses the Agent Data Unit (ADU) server to locate Avaya Agent in order to 
establish a direct communication link between the AICD and Avaya Agent.

EDU - The AICD uses the EDU server to:

● Extract information about a work item and pass it on to Siebel - this is the primary 
function

● Send broadcast-type communications with respective agents associated with the same 
contact

● Pass customer-specific data from Avaya IC workflows to Siebel

● Pass customer-specific data between different Siebel agents handling the same work 
item

Alarm server - The AICD uses the Alarm server to report abnormal events or conditions 
that require human intervention to resolve. For example, the inability to properly startup or 
communicate with an Avaya IC server causes an alarm.

AICD and interfaces to Avaya Agent

It is necessary for the AICD to send requests to Avaya Agent because most toolbar 
actions, especially for e-mail and Web contacts, need to be passed to Avaya Agent for 
execution. 

The AICD and Avaya Agent share a communication protocol that coordinates the Siebel 
desktop and Avaya Agent interfaces when an agent handles work items.

Multiple AICDs

You can configure an Avaya IC for Siebel integration to have multiple instances of the 
AICD. Specifically, you can have an AICD at each of several Siebel Application servers 
that run the Siebel Communications Server. Each AICD can support a number of Siebel 
agent sessions.
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Integration objects
This section includes the following topics:

● Description of integration objects on page 100

● Roadmap for creating integration objects on page 101

Description of integration objects

Siebel integration objects allow integration metadata for Siebel business objects and 
eXtensible Markup Language (XML) to be represented as common structures that the 
Siebel EAI framework can understand. Because these integration objects adhere to a set 
of structural conventions, they can be traversed and transformed programmatically.

A typical integration project involves transporting data from one application to another. For 
example, integrators can use integration objects to synchronize the data in a legacy 
system with the data in the Siebel application. Integration objects synchronize the external 
system so that the software can write data from the external system into the Siebel 
database. Likewise, the software can write data in the Siebel database into the external 
system.

There are Avaya-specific integration objects that you will need to import for the default 
integration to work. EAI Get and Put operations on page 497 describes the default 
Avaya-specific integration objects. Import the Avaya-specific Siebel workflow, Avaya IC 
EAI MIME for Put operations.

Related topics

For more information, see one of the following topics:

● EAI Get and Put operations on page 497

● Installing a custom integration object on page 216

● For more information about integration objects, see the Siebel documentation.
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Roadmap for creating integration objects

You do not need to do this procedure if you are using the default integration objects. Use 
this procedure only when you are creating a new integration object that will be referenced 
by the new Avaya IC Put Data block using the EAIWorkflow server. This procedure 
assumes that you have already imported the Avaya IC EAI MIME.xml workflow.

Related topic

For more information about importing the Avaya IC EAI MIME.xml workflow, see Importing 
and deploying the Siebel 7.7 workflow on page 222.

! Important:! Important:
Important: Test all changes to the Siebel object repository in a non production 

environment before deploying them in your production environment. Create 
a backup copy of the Siebel server object repository before making any 
changes using Siebel Tools.

For more information, see Working with Siebel Tools on page 167.

To create an integration object:

1. Use the EAI Siebel wizard in Siebel Tools to create an integration object.

This is documented in the Siebel documentation.

2. Is your EAI server type EAIWorkflow?

3. Log in to the Siebel thin client.

4. Go to the Site Map by pressing Ctrl+Shift+A.

5. Do one of the following tasks:

● For Siebel 7.0, go to Siebel Workflow Administration > Workflow Processes.

● For Siebel 7.5, go to Business Process Administration > Workflow Processes.

● For Siebel 7.7, go to Administration - Business Process > Workflow Processes.

If Then

Yes You must customize the Put Data block to recognize the new integration object. 
Go to Step 3.

No Quit
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6. Under the All Process tab, type the values shown in the following fields:

7. Select the Process Designer tab.

8. Double-click the Check if Put Operation block.

9. Under the Next Steps tab, click Yes.

10. Add the new integration object under the Values tab.

11. Select the All Process tab again.

12. Activate the workflow.

13. Restart Siebel services by doing one of the following tasks:

Field Type

Name Avaya IC EAI MIME

Status Active

For Windows For Solaris/AIX

Select Control Panel > services Consult the Siebel administration guide for 
instructions.
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SCAPI interface

The AICD communicates to Siebel through the Siebel Adaptive Communications API 
(SCAPI) interface. The SCAPI interface is a programmable software layer located between 
Siebel and Avaya IC that passes work item events from the AICD to Siebel, and work item 
commands from Siebel to the AICD.

The SCAPI interface is located on the Siebel system.

Related topic

For a detailed description of the SCAPI, see the Siebel documentation.
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Siebel activity records
A Siebel activity record tracks each interaction with a customer. It can record any of the 
following data:

● Time and date of interaction

● Brief customer data

● Duration of interaction

Activity records are often associated with a master record, such as an account, and are 
used to track interaction history.

The Avaya IC for Siebel integration provides two mutually exclusive ways to create a 
Siebel activity record:

● Using EAI on page 104

● Using Siebel event logs on page 104

Using EAI

You can use the example default integration Avaya IC workflows to create the Siebel 
activity record. The example workflows, ts_sbl.incomingcall_sbl and 
wacd_sbl.qualifychat_sbl use Enterprise Application Integration (EAI) to create the 
Siebel activity. However, the examples do not update the following Siebel activity fields; 
Start Time, Duration, and Status. If you want to update these fields, update the example 
default Avaya IC workflows or consider using Siebel event logs to create activities.

Using Siebel event logs

You can use Siebel event logs to create the activity record. Siebel provides definition file 
examples for using Siebel event logs. If you use Siebel event logs, you should do one of 
the following tasks:

● Use the standard Avaya IC ts.incomingcall and wacd.qualifychat workflows to route 
the contact. These workflows do not create Siebel activities.

● Edit the default Avaya IC ts_sbl.incomingcall_sbl and wacd_sbl.qualifychat_sbl 
workflows to remove the activity creation block.

The most likely place to trigger activity creation is from the event handler for the 
OnNewWorkItem event.
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Related topics

For more information, see the following topics:

● For a description of and for examples for creating Siebel event logs, see the Siebel 
Communications Server Administration Guide.

● For information about the OnNewWorkItem event, see OnNewWorkItem on page 484.
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Siebel user interface
Use the Siebel user interface to administer the AICD and the AED, and to modify Siebel 
workflows.

To use to the Siebel user interface:

1. Start the Siebel server components, if they do not automatically start.

2. Start the client machine in Internet Explorer, and type the values shown in the following 
table.

3. Go to the Site Map by pressing Ctrl+Shift+A.

Result: A large, alphabetized, multi-column list of hyperlinks to the Siebel windows 
opens.

Field Value

Login SADMIN

Password Type the client password.
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Siebel Communications Server
The Siebel Communications Server is a server located within Siebel that provides an 
infrastructure to support several kinds of communications activities for Siebel application 
users. The Communications Server supports:

● Multichannel interactive communications so that call center agents can make or receive 
voice calls and receive inbound e-mail messages

● The integration of third-party e-mail servers to process inbound e-mail

● The integration of third-party communications systems, such as e-mail servers, to send 
outbound communications

In this integration, the main function of the Siebel Communications Server is to exchange 
commands and events with the AICD in order to provide communication integration with 
Avaya IC.

Related topic

For more information, see the Siebel documentation.
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Siebel definition file
This section includes the following topics:

● Description of the definition file on page 108

● Commands and events on page 108

● About customizing the definition file on page 109

● Coordinating customizations on page 109

● Customizing the definition file on page 109

Description of the definition file

The Siebel definition file contains a Siebel proprietary language that processes the 
commands and events passed between Siebel and the AICD. The definition file:

● Determines Siebel desktop behavior, such as what Siebel screen to pop to the agent

● Controls the commands and events passed between Siebel and the AICD

You can modify the definition file to change either of these behaviors.

Commands and events

The Siebel definition file translates the commands and events so that the AICD and the 
Siebel Communications Server can communicate. Every Siebel driver has its own, and 
often unique, set of commands and events. The Siebel definition file translates these into 
standard Siebel operations. A typical operation is to pop a Siebel screen based on the 
event data.

Related topics

For more information, see the following topics:

● AICD commands on page 381

● AICD events on page 457
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About customizing the definition file

The AICD comes with a default Siebel definition file that performs default operations when 
work is delivered through events. The Siebel definition file maps the Siebel toolbar buttons 
to specific AICD commands. You can customize the default Siebel definition file for each 
customer installation.

You need to know which commands and events are supported by the AICD in order to 
customize the system configuration through the definition file.

Related topics

For more information, see one of the following topics:

● AICD commands on page 381

● AICD events on page 457

● Customizing the definition file on page 109

Coordinating customizations

You must coordinate the customization of the definition file with other customizations, such 
as:

● Avaya IC properties that control the behavior of Avaya Agent

● Avaya IC workflows

Example: An Avaya IC workflow that is activated with the arrival of a call may create a 
service request in Siebel using the EAI server. The workflow will insert the row ID of the 
newly-created service request into the EDU open data container for the call. The event 
handler for the OnNewWorkItem event in the definition file may then pop the service 
request record at an agent desktop, as the call is routed to the agent.

Customizing the definition file

To modify a definition file:

1. Obtain a copy of the Siebel definition file. Obtain either the original commented file, or 
export an uncommented file from Siebel.

The original commented file is located at SIEBEL_INSTALL_DIR\siebsrvr\
objects\enu.
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2. Configure the file to change the behavior of the system. You can edit the file with any 
text editor, such as Notepad.

For details on how to configure the definition file, see the Siebel documentation.

3. Import the file into the Siebel Communication Server.
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Siebel Tools
Siebel Tools is a declarative software development tool developed by Siebel that allows 
you to configure the underlying data and data presentation of your Siebel application 
without making changes to the program source code. Siebel Tools creates and maintains a 
custom Siebel Repository File (SRF) to store your custom configurations.

During installation and configuration, use Siebel Tools to add custom integration objects to 
Siebel and configure e-mail.

Related topic

For more information about Siebel Tools, see the Siebel documentation.
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Smart Answer and Smart Answer Manager
Smart Answer is a Siebel feature that analyzes the content of unstructured e-mails and 
either sends an automatic response or suggests an e-mail response.

Smart Answer Manager is a server used by Siebel Smart Answer to detect the meaning or 
the intent of incoming e-mails.

Related topics

See one of the following topics:

● Configuring Smart Answer Manager on page 274

● For more information about Smart Answer Manager, see the Siebel documentation.
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Chapter 7: Integration workflows

This section includes the following topics:

● Avaya IC and Siebel workflows on page 114

● Siebel Advocate workflows on page 116

● Siebel palette blocks on page 117

● Voice qualification workflow on page 137

● Chat qualification workflows on page 140

● Avaya-first e-mail workflows on page 145

● Siebel-first e-mail workflow on page 159

Related topic

For information about how to customize workflows, see Avaya Workflow Designer User 
Guide.
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Avaya IC and Siebel workflows
The following tables list the Avaya IC workflow and project names along with the 
corresponding Siebel integration workflow and project names. The following table 
describes the locations of the workflows.

Project and workflow names for new Siebel workflows

The project and workflow names for Avaya-first, Siebel-first, and Siebel-Advocate 
workflows are described in the following table. These workflows are new for the Avaya IC 
for Siebel integration.

Workflows Location

Avaya IC workflows <AVAYA_IC61_HOME>\design\IC\Flows\Avaya

Siebel integration workflows <AVAYA_IC61_HOME>\design\IC\Flows\Siebel

Siebel project 
name

Siebel workflow name More information

Avaya-first

icemail_sbl.prj

outboundemail_sbl Outbound Email workflow on page 158

postanalyze_sbl Postanalyze workflow on page 151

postanalyzeerror_sbl Postanalyze Error workflow on page 153

preanalyzeca_sbl Preanalyze CA workflow on page 146

preanalyzenoca_sbl Preanalyze no-CA workflow on page 149

triggerxfercleanup_sbl Trigger Cleanup Transfer workflow on page 155

triggerxferoutboundemailtoic_sbl Trigger Outbound Transfer workflow on page 154

xferoutboundemailtoic_sbl Outbound Transfer workflow on page 156

Siebel-first

icemail_sbl_first.prj analyze_sbl Siebel-first e-mail workflow on page 159

Siebel-Advocate

advocate_sbl.prj

qualifyvoice_adv_sbl

Siebel Advocate workflows on page 116qualifyemail_adv_sbl

qualifychat_adv_sbl
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Project and workflow names for existing Siebel integration workflows

The Avaya IC and Siebel project names and workflow names for workflows that have been 
modified for the integration are described in the following table.

Related topics

For more information about these workflows, see the following topics:

● Voice qualification workflow on page 137

● Chat qualification workflows on page 140

Avaya IC 
project name

Avaya IC 
workflow name

Siebel project 
name

Siebel workflow name

icm.prj transcriptadded icm_sbl.prj transcriptadded_icm

ts.prj incomingcall ts_sbl.prj incomingcall_sbl

webcenter.prj addcustomer webcenter_sbl.prj addcustomer_sbl

webcenter.prj deletecustomer webcenter_sbl.prj deletecustomer_sbl

webcenter.prj getauthenticated
customer webcenter_sbl.prj getauthenticatedcustomer_sbl

webcenter.prj getcustomer webcenter_sbl.prj getcustomer_sbl

webcenter.prj getregions webcenter_sbl.prj getregions_sbl

webcenter.prj schedulecallback webcenter_sbl.prj schedulecallback_sbl

webcenter.prj undeletecustomer webcenter_sbl.prj undeletecustomer_sbl

webcenter.prj updatecustomer webcenter_sbl.prj updatecustomer_sbl

wacd.prj qualifychat wacd_sbl.prj qualifychat_sbl

wacd.prj qualifyemail wacd_sbl.prj qualifyemail_sbl
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Siebel Advocate workflows
This section contains the following topics:

● Siebel Advocate e-mail and chat workflows on page 116

● Siebel Advocate voice workflow on page 116

Siebel Advocate e-mail and chat workflows

The Siebel Advocate e-mail and Web chat workflows, qualifyemail_adv_sbl and 
qualifychat_adv_sbl, determine a collection of Business Advocate qualifiers that describe 
the e-mail and Web chat contacts and then deliver this information to the Business 
Advocate system for routing. 

The Web Advocate Adapter (WAA) server starts these workflows when the WAA server 
detects a new incoming e-mail or chat contact. These workflows are not triggered by Voice 
Enhanced Services Platform (VESP) event. The qualifyemail_adv_sbl can be run on 
workflow servers with a WAA:media=email channel association. The qualifychat_adv_sbl 
can be run on workflow servers with a WAA:media=chat channel association

If the Avaya IC system includes the Siebel Advocate workflows, do not use the 
wacd.qualifyemail_sbl or wacd.qualifychat_sbl workflows.

Siebel Advocate voice workflow

The Siebel Advocate voice workflow, qualifyvoice_adv_sbl, determines a collection of 
Business Advocate qualifiers that describes the voice contacts and then delivers this 
information to the Business Advocate system for routing. 

This workflow is started by the Telephony Server Adapter (TSA) server whenever the TSA 
server detects a new incoming voice request. This workflow can run on any workflow 
server that has the channel association TSA:media=voice. 

If the Avaya IC system includes the Siebel Advocate workflows, do not use the 
wacd.qualifyvoice_sbl workflow.

Related topic

For more information about Business Advocate workflows, see Avaya IC Media Workflow 
Reference.
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Siebel palette blocks
The modified integration workflows and the new integration workflows include some 
unique blocks that are available on the Siebel palette in Workflow Designer. These blocks 
use the EAI interface to:

● Support the data exchange between Avaya IC and Siebel

● Request content analysis of e-mail

● Request auto-response functions from Siebel

This section describes the blocks on the Siebel palette and provides information about 
other new blocks that are used in Siebel integration workflows. This section includes the 
following topics:

● Create Agent Desktop Data block on page 117.

● EAI Get Data block on page 119.

● EAI Get Email block on page 123.

● EAI Put Data block on page 125.

● EAI Put Data with Attachment(s) block on page 128.

● EAI Put Email block on page 131.

● Set Extended Header block on page 134.

● Additional new blocks in Siebel integration workflows on page 135

Related topics

For more information, see the following topics:

● EAI server types on page 68

● EAI Get and Put operations on page 497

Create Agent Desktop Data block

The Siebel version of the block uses the EDU information to create the containers and data 
that Avaya Agent uses for screen pops. Create Agent Desktop Data is used in all of the 
routing workflows after the Siebel contact has been looked up. 

This block assigns values found in $scContactData and $VduData to the EDU couples. 
The values provide information about the customer and the contact that is immediately 
stored in the EDU record. 



Integration workflows

118 Avaya Interaction Center for Siebel 7 Integration

Sample workflow

For an example of how Create Agent Desktop Data can be used in a workflow, see Sample 
Incoming Call flow on page 139.

Basic properties

The Basic tab of Create Agent Desktop Data includes the properties in the following table.

Advanced properties

The Advanced tab of Create Agent Desktop Data includes the properties in the following 
table.

Property Default Value Description

ContactData $scContactData Script variable that stores the information 
retrieved from the Siebel Contact 
database through an EAI Get Data block.
This retrieved information can include:
● Customer information, including full 

name and ID
● Chat contacts only, username from 

website
● E-mail contacts only, sender of email
● Voice contacts only, primary ANI

Property Default Value Description

blockDebug off Debug level of the block. 
Before changing the default value, see 
Avaya IC Media Workflow Reference.

start Create Agent 
Desktop Data

Block IC Script.

VduData $VduData Script variable where sequence of 
couples returned by EDU server is stored.
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Alarms

Generates the alarms described in the following table:

Connections

Accepts the following connections:

● Input: 1 or more

● Output: 1

EAI Get Data block

The EAI Get Data block retrieves records from the Siebel database. This block:

1. Uses an integration object to identify the type of information that is to be retrieved from 
the Siebel database.

2. Sends a query key to Siebel based on the mediatype of the contact (voice, e-mail, or 
chat)

3. Siebel returns a predefined set of data related to the key. 

For example, to obtain a customer record for a voice contact, configure this block to use 
Avaya IC - Get Contact as the integration object and one of the query keys as the 
Automatic Number Identification (ANI) for the voice contact. The Siebel database returns 
customer and account information associated with that ANI.

Alarm Description

Failed to determine Media Type! This High alarm is generated whenever the EDU 
data stored in the $VduData variable does not 
contain the type field. 
An EDU will always include a value in the type 
field. Therefore, this alarm indicates that the EDU 
record identified by the EDU ID delivered in the 
event to activate the workflow no longer exists or 
has been lost.

No Customer Info for this 
Contact!

This High alarm is generated whenever the 
$scContactData variable does not contain the field 
Contact.FullName. 
This alarm typically indicates that the EAI Get Data 
block did not return a unique, matching Contact 
record from Siebel.
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Related topic

For more information, see:

● EAI Get Email block on page 123.

● EAI Put Data block on page 125.

Sample workflow

For an example of how EAI Get Data can be used in a workflow, see the EAI Get Data 
(Look for Contact) block in Sample Incoming Call flow on page 139.

Basic properties

The Basic tab of EAI Get Data includes the properties in the following table. For more 
information about Get Action integration objects and the types of records that they retrieve 
from Siebel, see EAI Get and Put operations on page 497.

Property Default Value Description

IntegrationObject empty A Get Action integration object retrieves 
information from the Siebel database 
about actions that agents took in 
response to previous contacts with this 
customer.
Type the exact name of a custom 
integration object or select a 
pre-configured integration object.
● Avaya IC - Get Account 
● Avaya IC - Get Action 
● Avaya IC - Get Contact
● Avaya IC - Get Order Entry
● Avaya IC - Get Quote
● Avaya IC - Get Service Request
To use a custom integration object, create 
the object before you type the name in 
this field.
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Advanced properties

The Advanced tab of EAI Get Data includes the properties in the following table.

QueryKeyName_N empty Name of the query key in the integration 
object that the block should use to retrieve 
data from the Siebel database. For 
example, the Avaya IC - Get Contact 
integration object includes the following 
default query keys: 
● Contact.Id
● Contact.FullName
● Contact.EmailAddress
● Contact.HomePhone
You can specify up to 5 query keys.

QueryKeyValue_N empty Target where the block should store 
values retrieved by the queries.
For example, if you specify a query key in 
QueryKeyName_01, enter the target for 
the data in QueryKeyValue_01.

Property Default Value Description

Property Default Value Description

BaseTag <default> Name of the base "List of" tag to be used 
in the xml document. 
If you do not specify a tag, the block uses 
ListOf"<integrationobject> for 
the tag name. 
<default> is the typical value for this 
property.

blockDebug off Debug level of the block. 
Before changing the default value, see 
Avaya IC Media Workflow Reference.

DTD Name <default> Name of the DTD used in the integration 
object. <default> indicates that the 
integration object uses the same DTD as 
the pre-configured integration objects.

MaxRecords 0 Specifies the maximum number of records 
to be returned by the search. 
A value of "0" returns all matching 
records.
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Alarms

Generates the alarms described in the following table:

NumberOfRecords
Retrieved

$sNumberOf
RecordsRetrieved

Script variable that holds the number of 
records retrieved from the Siebel 
database.

OutData $sscOutData Script variable that holds the results 
returned from the query of the Siebel 
database.

ReturnCode $sReturnCode Script variable that holds the value of the 
return code that is returned by the 
EAI.GetData() method.
A value other than "0" indicates an error.

Server EAI Name of the EAI server.

start EAI Get Data Block IC Script.

validateDTD false Determines whether the block needs to 
validate the DTD used in the integration 
object before querying the Siebel 
database.

Property Default Value Description

Alarm Description

ObjectName property not set!! This High alarm is generated when the 
IntegrationObject property is empty. 
To correct, configure the IntegrationObject property 
in the block with a value that represents a valid 
integration object, then recompile and reload the 
workflow.

ValidateDTD turned on, but 
DTDName property not set!!

This High alarm is generated when the ValidateDTD 
property is set to true and the DTDName property 
is empty.
To correct, do one of the following tasks:
● Configure the DTDName property with the name 

of the DTD of the xml file, then recompile and 
reload the workflow.

OR
● Change the value of the ValidateDTD property to 
false, then recompile and reload the workflow.
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Connections

Accepts the following connections:

● Input: 1 or more

● Output: 1

EAI Get Email block

The EAI Get Email block retrieves an outbound e-mail from Siebel through the EAI Email 
server, then sends the e-mail from Avaya IC.

The EAI Get Email block does not retrieve inbound e-mail.

Related topic

For more information, see:

● EAI Get Data block on page 119.

● EAI Put Email block on page 131.

Sample workflow

For an example of how EAI Get Email can be used in a workflow, see the EAI Get Email 
block in Postanalyze workflow on page 155.

EAI.GetData() Failed!! This High alarm is generated when the 
EAI.GetData() method returns with a returncode 
that has a value of greater than ì0î. The alarm also 
contains the exact error and suberror codes 
returned by the EAI server.

Alarm Description
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Basic properties

The Basic tab of EAI Get Email includes the properties in the following table. All properties 
in the Basic tab are mandatory.

Advanced properties

The Advanced tab of EAI Get Email includes the properties in the following table.

Property Default Value Description

ActivityID $activity_id Script variable that holds the Activity ID 
that Siebel assigned to the e-mail. 
Typically, the workflow retrieves the 
Activity ID from the EDU. 

ExtendedHeader $extended_header Script variable that holds the key-value 
pairs from the extended header.

ExternalWorkflow Avaya IC - Get 
Email

The name of the integration object used to 
retrieve the e-mail from Siebel. 
Note: Do not change this field unless you 
have created a custom integration object 
to perform this task.

MessageID $msgid String variable that contains the e-mail 
message ID found in the EDU. 

TrackingNumber $trackingnumber Script variable that contains the tracking 
number of the e-mail.

Property Default Value Description

blockDebug on Debug level of the block. 
Before changing the default value, see 
Avaya IC Media Workflow Reference.

ReturnCode $reasoncode Script variable that holds the value of the 
return code returned by the 
EAI.GetEmail() method. A value other 
than "0" indicates an error.

Server EAIEmail Name of the EAI Email server.

start EAI Get Email Block IC Script.

Validate false Determines whether the block needs to 
validate the DTD used in the integration 
object before querying the Siebel 
database.
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Alarms

Generates the alarms described in the following table:

Connections

Accepts the following connections:

● Input: 1 or more

● Output: 1

EAI Put Data block

The EAI Put Data block writes new records or updates existing records in the Siebel 
database. The blocks sends the "put data" action through the EAI Workflow server. The 
EAI Put Data block can perform the following tasks:

1. Send a request to Siebel to create new Siebel records. Siebel returns the ID of the 
newly-created record back to Avaya IC. Avaya IC can then use the ID to pop a screen 
to the agent. 

2. Reference an existing Siebel record by including the ID for the Siebel record with the 
request. In this case, Siebel updates the existing record.

Related topic

For more information, see:

● EAI Put Data with Attachment(s) block on page 128.

● EAI Put Email block on page 131.

Sample workflow

For an example of how EAI Put Data can be used in a workflow, see the EAI Put Data 
(Create Activity Record) block in Sample Incoming Call flow on page 139.

Alarm Description

EAIEmail.GetEmail() Failed!! This High alarm is generated when the 
EAI.GetEmail() method returns with a 
returncode that has a value of greater than ì0î. The 
alarm also contains the exact error and suberror 
codes returned by the EAI Email server.
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Basic properties

The Basic tab of EAI Put Data includes the properties in the following table. All properties 
in the Basic tab are mandatory.

Advanced properties

The Advanced tab of EAI Put Data includes the properties in the following table.

Property Default Value Description

InputData $scInputData Script variable that holds the data to be 
sent to Siebel. 

IntegrationObject Avaya IC - Put 
Action

The name of the integration object used to 
send information to Siebel.
Note: Do not change this field unless you 
have created a custom integration object 
to perform this task.

Property Default Value Description

BaseTag <default> Name of the base "List of" tag to be used 
in the xml document. 
If you do not specify a tag, the block uses 
ListOf"<integrationobject> for 
the tag name. 
<default> is the typical value for this 
property.

blockDebug off Debug level of the block. 
Before changing the default value, see 
Avaya IC Media Workflow Reference.

DTD Name <default> Name of the DTD used in the integration 
object. <default> indicates that the 
integration object uses the same DTD as 
the pre-configured integration objects.

OutData $sscOutData Script variable that holds the results 
returned from the attempt to send 
information to Siebel.

ReturnCode $sReturnCode Script variable that holds the value of the 
return code returned by the 
EAI.PutData() method. A value other 
than "0" indicates an error.

Server EAIWorkflow Name of the Workflow server that runs the 
workflow which includes this block.
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Alarms

Generates the alarms described in the following table:

Connections

Accepts the following connections:

● Input: 1 or more

● Output: 1

start EAI Put Data Block IC Script.

validateDTD false Determines whether the block needs to 
validate the DTD used in the integration 
object before sending information to 
Siebel.

Property Default Value Description

Alarm Description

ObjectName property not set!! This High alarm is generated when the 
IntegrationObject property is empty. 
To correct, configure the IntegrationObject property 
in the block with a value that represents a valid 
integration object, then recompile and reload the 
workflow.

ValidateDTD turned on, but 
DTDName property not set!!

This High alarm is generated when the ValidateDTD 
property is set to true and the DTDName property 
is empty.
To correct, do one of the following tasks:
● Configure the DTDName property with the name 

of the DTD of the xml file, then recompile and 
reload the workflow.

OR
● Change the value of the ValidateDTD property to 
false, then recompile and reload the workflow.

EAI.PutData() Failed!! This High alarm is generated when the 
EAI.PutData() method returns with a returncode 
that has a value of greater than ì0î. The alarm also 
contains the exact error and suberror codes 
returned by the EAI Workflow server.
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EAI Put Data with Attachment(s) block

The EAI Put Data with Attachment(s) block uses a Siebel integration object and the EAI 
Workflow server to save one or more files to the Siebel database. For example, you can 
use this block to save a transcript of a Web chat session to the database. The EAI Put Data 
with Attachment(s) block is similar to the EAI Put Data block.

Related topic

For more information, see EAI Put Data block on page 125.

Sample workflow

For an example of how EAI Put Data with Attachment(s) can be used in a workflow, see the 
EAI Put Data with Attachment(s) block in the Transcript Added workflow on page 142.

Basic properties

The Basic tab of EAI Put Data with Attachment(s) includes the properties in the following 
table. 

Property Default Value Description

Attachment $sAttachment Script variable that holds the attachment 
to be sent to the Siebel database. 

Attachments $ssAttachments Script variable that identifies that there is 
an attachment.
Caution: For Siebel integration, do not 
change the value of this property.

AttachmentTag ?Action.ListOf
ActionAttachment.
ActionAttachment

Mandatory.
Required for attachment.
Caution: For Siebel integration, do not 
change the value of this property.

FileExtTag ActivityFileExt Mandatory.
Determines the type of Siebel object to 
which the file attachments belong. For 
example, a chat transcript belongs to an 
Activity object.

FileIDTag AttachmentId Mandatory.
One part of a couple required for the 
attachment.
Caution: For Siebel integration, do not 
change the value of this property.
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Advanced properties

The Advanced tab of EAI Put Data with Attachment(s) includes the properties in the 
following table.

FileNameTag ActivityFileName Mandatory.
One part of a couple required for the 
attachment.
Caution: For Siebel integration, do not 
change the value of this property.

InputData $scInputData Script variable that holds the data to be 
sent to Siebel. 

IntegrationObject Avaya IC - Put 
Action

The name of the integration object used to 
send information to Siebel.
Note: Do not change this field unless you 
have created a custom integration object 
to perform this task.

Property Default Value Description

Property Default Value Description

BaseTag <default> Name of the base "List of" tag to be used 
in the xml document. 
If you do not specify a tag, the block uses 
ListOf"<integrationobject> for 
the tag name. 
<default> is the typical value for this 
property.

blockDebug off Debug level of the block. 
Before changing the default value, see 
Avaya IC Media Workflow Reference.

DTD Name <default> Name of the DTD used in the integration 
object. <default> indicates that the 
integration object uses the same DTD as 
the pre-configured integration objects.

OutData $sscOutData Script variable that holds the results 
returned from the attempt to send 
information to Siebel.

OutputID $sOutputId Unused script variable. 
Do not change the value of this property.
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Alarms

Generates the alarms described in the following table:

ReturnCode $sReturnCode Script variable that holds the value of the 
return code returned by the 
EAI.PutData() method. A value other 
than "0" indicates an error.

Server EAIWorkflow Name of the Workflow server that runs the 
workflow which includes this block.

start EAI Put Data with 
Attachment(s)

Block IC Script.

validateDTD false Determines whether the block needs to 
validate the DTD used in the integration 
object before sending information to 
Siebel.

Property Default Value Description

Alarm Description

ObjectName property not set!! This High alarm is generated when the 
IntegrationObject property is empty. 
To correct, configure the IntegrationObject property 
in the block with a value that represents a valid 
integration object, then recompile and reload the 
workflow.

ValidateDTD turned on, but 
DTDName property not set!!

This High alarm is generated when the ValidateDTD 
property is set to true and the DTDName property 
is empty.
To correct, do one of the following tasks:
● Configure the DTDName property with the name 

of the DTD of the xml file, then recompile and 
reload the workflow.

OR
● Change the value of the ValidateDTD property to 
false, then recompile and reload the workflow.

EAI.PutData() Failed!! This High alarm is generated when the 
EAI.PutData() method returns with a returncode 
that has a value of greater than ì0î. The alarm also 
contains the exact error and suberror codes 
returned by the EAI Workflow server.

No Attachments specified!! This High alarm is generated when no attachments 
have been given to the block in the script variable 
assigned to the Attachments property.
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Connections

Accepts the following connections:

● Input: 1 or more

● Output: 1

EAI Put Email block

The EAI Put Email block retrieves an e-mail from Avaya IC and puts it into the Siebel 
database. The Put Email block is similar to the Put Data block, except that the Put Email 
block processes e-mail instead of data.

Related topic

For more information, see:

● EAI Put Data block on page 125.

● EAI Get Email block on page 123.

Sample workflow

For an example of how EAI Put Email can be used in a workflow, see the Put Email to 
Siebel block in the Preanalyze CA workflow on page 150.

Basic properties

The Basic tab of EAI Put Email includes the properties in the following table. All properties 
in the Basic tab are mandatory.

Property Default Value Description

BaseTag ListOfAvayaIC-Put
Email

Name of the base "List of" tag to be used 
in the xml document. 
If you do not specify a tag, the block uses 
ListOf"<integrationobject> for 
the tag name. 
<default> is the typical value for this 
property.

ContactKey $ContactKey Script variable that holds the Avaya IC 
EDU ID for the e-mail.
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Advanced properties

The Advanced tab of EAI Put Email includes the properties in the following table.

EAIContactKeyField ListOfAction_
Contact.Action_
Contact.ContactId

Mandatory.
Required to put e-email.
Caution: For Siebel integration, do not 
change the value of this property.

MessageID $msgid String variable that contains the e-mail 
message ID found in the EDU. 

ObjectName Avaya IC - Put 
Email

The name of the integration object used to 
send information to Siebel.
Note: Do not change this field unless you 
have created a custom integration object 
to perform this task.

TagName Type Mandatory.
Required to put e-email.
Caution: For Siebel integration, do not 
change the value of this property.

TagValue Email - Inbound Identifies the type of e-mail that the 
workflow will save to the Siebel database.

TrackingNumber $trackingnumber Script variable that contains the tracking 
number of the e-mail.

validateDTD false Determines whether the block needs to 
validate the DTD used in the integration 
object before sending information to 
Siebel.

Property Default Value Description

Property Default Value Description

AdditionalArgs $scOutput Contains additional couples that should 
be included as part of the input arguments 
to the EAI.PutEmail() method.

blockDebug off Debug level of the block. 
Before changing the default value, see 
Avaya IC Media Workflow Reference.

DTD Name empty Name of the DTD used in the integration 
object. <default> indicates that the 
integration object uses the same DTD as 
the pre-configured integration objects.
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Alarms

Generates the alarms described in the following table:

Connections

Accepts the following connections:

● Input: 1 or more

● Output: 1

OutData $sscOutData Script variable that holds the results 
returned from the attempt to send 
information to Siebel.

ReturnCode $sReturnCode Script variable that holds the value of the 
return code returned by the 
EAI.PutEmail() method. A value other 
than "0" indicates an error.

Server EAIEmail Name of the EAI Email server that routed 
the e-mail which this block will save to the 
Siebel database.

start EAI PutEmail Block IC Script.

Property Default Value Description

Alarm Description

EAI.PutEmail() returned invalid 
activityid!!

This high alarm is generated whenever the 
EAI.PutEmail() method returns an empty 'Id' 
field

EAIEmail.PutEmail() Failed!! This High alarm is generated when the 
EAI.PutEmail() method returns with a 
returncode > 0. The alarm also contains the exact 
error and suberror codes returned by the EAIEmail 
server.
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Set Extended Header block

The Set Extended Header block assigns a valid key-value pair to be delivered as part of 
the extended headers argument of EAI.GetEmail. You can use this block to assign any 
valid key-value pair to the extended MIME header of an e-mail.

Each Set Extended Header block can assign one key-value pair. If you need to assign 
more than one key-value pair to the extended MIME header of an e-mail, include an 
additional Set Extended Header block for each key-value pair.

Sample workflow

For an example of how Set Extended Header can be used in a workflow, see Postanalyze 
workflow on page 155.

Basic properties

The Basic tab of Set Extended Header includes the properties in the following table.

Advanced properties

The Advanced tab of Set Extended Header includes the properties in the following table.

Property Default Value Description

HeaderName empty Specifies the name of the key to be 
included in the key-value pair.

HeaderValue empty Specifies the value of the key to be 
included in the key-value pair.

Property Default Value Description

blockDebug off Debug level of the block. 
Before changing the default value, see 
Avaya IC Media Workflow Reference.

ExtendedHeaderVar $extended_header Script variable that contains the 
cumulative collection of extended 
headers.

start Set Extended 
Header

Block IC Script.
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Alarms

Does not generate any alarms.

Connections

Accepts the following connections:

● Input: 1 or more

● Output: 1

Additional new blocks in Siebel integration workflows

The following workflow blocks used in the Siebel integration workflows are also new for the 
Siebel integration. These blocks are not available on the Siebel palette.

Tip:
Tip: Siebel integration workflows also use blocks that are available on other 

Workflow Designer palettes. For more information about those blocks, see 
Avaya IC Media Workflow Reference.

Block name Description

Create External Contact 
Mapping

Maps the records of an external contact (Siebel) to the 
contact record in Avaya IC. This mapping creates an 
association between the Avaya IC contact and the Siebel 
business objects associated with that contact.
For example, you can use the Create External Contact 
Mapping block to link an order, task, or other object that 
was either used or created as a result of the contact. The 
object can then be used to provide a link back into Siebel 
for historical and reporting purposes.
All of the Siebel qualification workflows use this block, 
including the workflows in the following projects:
● TS 
● wacd
● Advocate
For more information about ex*map tables, see Avaya 
Agent Integration.
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Related topic

Siebel integration workflows also use blocks that are available on other Workflow Designer 
palettes. For more information about those blocks, see Avaya IC Media Workflow 
Reference.

Get CA Results from EDU Retrieves the results of Siebelís Email Content Analysis 
from the EDU and stores the results in workflow variables.

Trigger Siebel CA Updates certain EDU fields that are being monitored by the 
AED. These EDU fields start a workflow in Siebel that 
analyze the e-mail using Siebelís Email Content Analysis 
engine.

Block name Description
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Voice qualification workflow
The voice qualification workflow for the Siebel integration with standard routing is the 
Incoming Call flow. The Incoming Call flow is sometimes called the call-routing workflow or 
the voice contact routing workflow.

This section describes the Incoming Call workflow. This section includes the following 
topics:

● Description of the Incoming Call flow on page 137

● Process of the Incoming Call flow on page 138

● Sample Incoming Call flow on page 139

Description of the Incoming Call flow

The Incoming Call flow retrieves customer information, routes inbound voice contacts, and 
can also, if desired, create, update, or delete a work item record. The version of the 
Incoming Call flow provided with the Siebel integration retrieves the customer information 
from the Siebel system through the EAI Get Data block.

During the installation and configuration of the Siebel integration, you replace the standard 
Avaya IC Incoming Call flow with the Incoming Call flow for Siebel. 

Facts about the Incoming Call flow are included in the following table.

Related topics

For related information, see the following topics:

● Configuring workflow servers to use Siebel voice workflows on page 164

● Building the Avaya voice qualification workflow on page 162

● Siebel Advocate workflows on page 116

Siebel project name ts_sbl.prj

Siebel filename incomingcall_sbl

How launched TS.IncomingCall event

Default workflow server WorkFlow_Voice
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Process of the Incoming Call flow

The sample Incoming Call flow works as follows:

1. When a call comes in, the Incoming Call flow uses the ANI information to query Siebel 
for a matching contact record. The Siebel query is done through the EAI server using 
the EAI Get Data block.

2. The Incoming Call flow uses the EAI Put Data block to create a Call Incoming activity 
record in Siebel.

3. If a contact record was found by the EAI Get Data block, the activity record is 
associated with the contact. 

4. The Incoming Call flow writes some of the information that it received from the EAI Get 
block to the EDU. 

5. This information is used to populate the EDU viewer, or to pop a particular screen in 
Siebel. 

6. The AICD.def file uses the contact ID placed in the EDU by the workflow to pop the 
Contact Detail View. If no matching contact was found by the workflow, the activity ID is 
used to pop the Activity Detail View.
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Sample Incoming Call flow

The following figure shows the sample Incoming Call flow provided with the Siebel 
integration.

Related topic

For a description of the non-Siebel blocks in this workflow, see Avaya IC Media Workflow 
Reference.
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Chat qualification workflows
The chat qualification workflows for the Siebel integration with standard routing, include the 
Qualify Chat flow and other workflows required for Avaya IC with Web Management. 

This section describes the chat qualification workflows. This section includes the following 
topics:

● Qualify Chat flow on page 140

● Customer Management workflows for Web on page 140

● Transcript Added workflow on page 142

Qualify Chat flow

The Qualify Chat flow retrieves customer information, routes inbound chat contacts, and 
can also, if desired, create, update, or delete a work item record. The version of the Qualify 
Chat flow provided with the Siebel integration retrieves the customer information from the 
Siebel system through the EAI Get Data block.

The Qualify Chat flow is sometimes called the chat contact routing workflow.

During the installation and configuration of the Siebel integration, you replace the standard 
Avaya IC Qualify Chat flow with the Qualify Chat flow for Siebel. 

Facts about the Qualify Chat flow are included in the following table.

Related topic

For more information, see Configuring workflow servers to use Siebel voice workflows on 
page 164.

Customer Management workflows for Web

Customer Management workflows for Web manage customer records for chat contacts. 
For example, these workflows associate customers who log in to the Website with 

Siebel project name wacd_sbl

Siebel filename qualifychat_sbl

How launched WACD.QualifyChat event

Default workflow server WorkFlow_Chat
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information about the customer in the Siebel database. In the agent applications, a screen 
pop displays this information to the agent.

Some customer management workflows require file-based IC Scripts. By default, the 
include property of the workflows contains the names of the required file-based IC Scripts. 
If you encounter any difficulties in these workflows, you must ensure that the IC Scripts 
specified by the include property are available. 

! CAUTION:
CAUTION: These are system workflows that are automatically installed. Do not alter or 

customize the Customer Management workflows for Web. 

Facts about the Customer Management workflows for Web are included in the following 
table.

Related topic

For more information, see Modifying Customer Management workflows for Web on 
page 232.

Siebel project name webcenter_sbl.prj

Siebel filenames

● addcustomer_sbl
● deletecustomer_sbl
● getauthenticatedcustomer_sbl
● getcustomer_sbl
● getregions_sbl
● schedulecallback_sbl
● undeletecustomer_sbl
● getcustomerlist_sbl
● updatecustomer_sbl

How launched MultiTenancy Admin & Chat Escalation login window

Default workflow server The WorkFlow_System server of the primary domain 
where the Avaya IC chat user is located
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Transcript Added workflow

The Transcript Added workflow is also called the chat-transcript workflow.

This section includes the following topics:

● Description of the Transcript Added workflow on page 142

● Location of the Workflow server and EAIWorkflow server on page 142

● Process of the Transcript Added workflow on page 142

● Sample Transcript Added workflow on page 144

Description of the Transcript Added workflow

The Transcript Added workflow puts a copy of the transcript from a chat contact into the 
Siebel system through an EAI server.

Facts about the transcript-added workflow are included in the following table.

Location of the Workflow server and EAIWorkflow server

Host and configure the Workflow server and the EAIWorkflow server on the same physical 
machine to avoid potential permission problems.

Related topic

For more information, see EAI server is unable to read a file attachment on page 360.

Process of the Transcript Added workflow

The Transcript Added workflow process works as follows:

1. When a chat session is wrapped up, Avaya IC writes a transcript of the session in raw 
form to a disk location.

2. The ICM server polls this location. When the ICM server finds the transcript, it reads 
and writes the transcript to IC Repository.

Siebel project name icm_sbl.prj

Siebel filename transcriptadded_sbl

How launched Called by the ICM server if ICM is configured to run this 
workflow when a transcript is added to the database

Default workflow server The WorkFlow_System server of the primary domain where 
the Avaya IC Web chat user is located
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3. If the ICM server has been configured properly, the ICM server triggers the Transcript 
Added workflow.

4. The Transcript Added workflow:

a. Receives the chat transcript in raw XML format as an input parameter.

b. Transforms the chat transcript into an HTML file, by default.

c. Puts the HTML file into a location specified in the workflow.

d. Makes a request to the EAI server to receive the HTML file and put the file into 
Siebel.

Related topic

For more information, see Installing the Web chat qualification workflow on page 236.
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Sample Transcript Added workflow

The following figure shows the sample Transcript Added workflow provided with the Siebel 
integration.
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Avaya-first e-mail workflows
If the Siebel integration system uses Avaya-first e-mail, Siebel performs Content Analysis 
on the e-mail, and the results are passed back to the Avaya IC workflows that route the 
e-mail. 

For the Avaya IC integration, there are eight new workflows that process e-mail between 
Avaya IC and the Siebel system to support the Avaya-first e-mail solution.

This section includes the following topics:

● Overview of incoming e-mail workflow processing on page 145

● Overview of outbound e-mail workflow processing on page 146

● Preanalyze CA workflow on page 146

● Preanalyze no-CA workflow on page 149

● Postanalyze workflow on page 151

● Postanalyze Error workflow on page 153

● Trigger Outbound Transfer workflow on page 154

● Trigger Cleanup Transfer workflow on page 155

● Outbound Transfer workflow on page 156

● Outbound Email workflow on page 158

Related topics

For a description of the Avaya-first e-mail solution, see Avaya-first e-mail entry on page 56.

Overview of incoming e-mail workflow processing

For the Avaya-first e-mail solution, incoming e-mail processing uses the following 
workflows: Preanalyze CA workflow, Preanalyze without Content Analysis workflow, and 
Postanalyze workflow.

These workflows work together to:

● Get new incoming e-mail into the Siebel system.

● Retrieve Content Analysis results from the Siebel system. 

● Populate the proper data elements that are used by the Qualify Email workflow. 

If there is an error detected during Siebel Content Analysis, a Postanalyze Error workflow 
is run instead of the Postanalyze workflow.
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Overview of outbound e-mail workflow processing

For outbound e-mail processing:

1. The Siebel desktop calls the Trigger Transfer Outbound workflow, 
triggerxferoutboundemailtoic_sbl, to start the process of moving the outbound 
e-mail from Siebel to Avaya IC. 

2. The Trigger Transfer Outbound workflow verifies all sent parameters and calls the 
xferoutboundemailtoic_sbl workflow to do the actual e-mail transfer to Avaya IC. 

3. If the IC Email server has Content Analyzer for e-mail turned on, the IC Email server 
triggers the Siebel Outbound Email workflow is run prior to delivery to the customer.

Preanalyze CA workflow

This section includes the following topics:

● Description of the Preanalyze CA workflow on page 146

● Process of the Preanalyze CA workflow on page 147

● Sample Preanalyze CA sample workflow on page 148

Description of the Preanalyze CA workflow

The Preanalyze CA workflow copies e-mail from Avaya IC to Siebel and triggers Siebel to 
run Content Analysis on the e-mail. This workflow requires that the Adaptive E-mail Driver 
(AED) is installed.

Facts about the Preanalyze CA workflow are included in the following table.

Related topic

For more information, see Installing the AED on page 266.

Siebel project name icemail_sbl.prj

Siebel filename preanalyzeca_sbl

How launched ICEmail.Analyze event and when Email Server / Analyze 
Tab / Run Analyze Flow is checked

Default workflow server WorkFlow_Email
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Process of the Preanalyze CA workflow

The Preanalyze CA process works as follows:

1. The Preanalyze CA receives e-mails from the Avaya IC Email server through a 
newly-created EDU.

2. The workflow calls the EAI Get Data block to retrieve customer data from Siebel.

3. The workflow calls the EAI Put Email block to move the e-mail from Avaya IC to Siebel. 
The workflow passes the e-mail message ID to the block and if the contact ID is found 
in the previous step, passes the contact ID that links the customer to the e-mail activity.

4. One of the following occurs:

● If the emailtype is not a new work item (NOR), the e-mail is related to an existing 
work item and Siebel will not perform Content Analysis on the e-mail. Instead, the 
e-mail is sent directly to the Avaya IC Email server for routing. The 
post-analyze_sbl workflow is not run for this e-mail.

● If the emailtype is a new work item, the workflow sets specific EDU fields that send 
an event to the Adaptive E-mail Driver (AED) server. This event causes the AED 
server to execute a Siebel workflow that performs Content Analysis on the e-mail. 
The post-analyze_sbl workflow is run for this e-mail.
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Sample Preanalyze CA sample workflow

The following figure shows the sample Preanalyze CA workflow provided with the Siebel 
integration.

Related topic

For more information, see Siebel palette blocks on page 117.
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Preanalyze no-CA workflow

This section includes the following topics:

● Description of the Preanalyze no-CA workflow on page 149

● Process of the Preanalyze no-CA workflow on page 149

● Sample Preanalyze no-CA workflow on page 150

Description of the Preanalyze no-CA workflow

The Preanalyze no-CA workflow copies e-mail from Avaya IC to Siebel. In contrast to the 
Preanalyze CA workflow, the Preanalyze no-CA workflow does not request Siebel to run 
Content Analysis on the e-mail.

Facts about the Preanalyze no-CA workflow are included in the following table.

Process of the Preanalyze no-CA workflow

The Preanalyze no-CA workflow process works as follows:

1. The Preanalyze no-CA workflow receives e-mails from the Avaya IC Email server 
through a newly-created EDU.

2. The workflow calls the EAI Get Data block to retrieve customer data from Siebel.

3. One of the following occurs:

● If the emailtype is not a new work item (NOR), the e-mail is sent directly to the 
Avaya IC Email server for routing.

● If the emailtype is a new work item, a keyword search block identifies a component 
of the e-mail, such as the subject line, and sets one of three possible routing hints. 
Three routing hint paths match search values. The fourth path occurs when no 
match is found.

4. The EAI Put Email block moves the e-mail from Avaya IC to Siebel.

5. Control of the e-mail processing is passed back to the IC Email server.

Siebel project name icemail_sbl.prj

Siebel filename preanalyzenoca_sbl

How launched ICEmail.Analyze event and when Email Server / Analyze 
Tab / Run Analyze Flow is checked

Default workflow server WorkFlow_Email



Integration workflows

150 Avaya Interaction Center for Siebel 7 Integration

Sample Preanalyze no-CA workflow

The following figure shows the Preanalyze no-CA workflow.

Related topic

For more information, see Siebel palette blocks on page 117.
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Postanalyze workflow

This section includes the following topics:

● Description of the Postanalyze workflow on page 151

● Sample Postanalyze workflow on page 152

Description of the Postanalyze workflow

When the AED determines that Siebel Content Analysis has successfully completed, the 
AED triggers the Postanalyze workflow. The AED sends processing data based on the 
returned disposition and Content Analysis data to the Postanalyze workflow. This can 
include auto-response or auto-acknowledgement e-mails, Content Analysis results, and 
other data. 

The returned dispositions for the Postanalyze workflow are described in the following table.

Facts about the Postanalyze workflow are included in the following table.

Disposition Description

Route to Agent

● If there is auto-acknowledgement, the EAI Get Email block 
moves the auto-acknowledgement e-mail from Siebel to 
Avaya IC.

● Retrieves the Siebel Content Analysis results
● Performs optional business logic
● Routes the e-mail
● Calls the IC Email Analyzed block

Auto Response

● Calls the EAI Get Email block to move the auto-response 
e-mail from Siebel to Avaya IC

● Sets the route disposition to auto-response
● Calls the ICEmail Analyzed block

Dismiss
● Dismisses the e-mail
● Calls the ICEmail Analyzed block

Siebel project name icemail_sbl.prj

Siebel filename postanalyze_sbl
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Sample Postanalyze workflow

The following figure shows the Postanalyze workflow.

Related topic

For more information, see Siebel palette blocks on page 117.

How launched

The AED uses information set by the preanalyze-CA 
workflow to launch this workflow. The default 
preanalyze_sbl workflow sets the postanalyze_sbl 
as the workflow to run after a successful completion 
of Content Analysis.

Default workflow server WorkFlow_Email
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Postanalyze Error workflow

This section includes the following topics:

● Description of the Postanalyze Error workflow on page 153

● Sample Postanalyze Error workflow on page 153

Description of the Postanalyze Error workflow

The Postanalyze Error workflow is run whenever the AED determines that a call to the 
Siebel Content Analysis engine has failed. If this happens, the system runs the 
Postanalyze Error workflow instead of the Postanalyze workflow.

Facts about the Postanalyze Error workflow are included in the following table.

Sample Postanalyze Error workflow

The following figure shows the Postanalyze-error workflow.

Siebel project name icemail_sbl.prj

Siebel filename postanalyzeerror_sbl

How launched

The AED uses information set by the 
preanalyze-CA workflow to launch this workflow. 
The default preanalyze_sbl workflow sets the 
postanalyzeerror_sbl as the workflow to run 
when an error occurs during Content Analysis.

Default workflow server WorkFlow_Email
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Trigger Outbound Transfer workflow

This section includes the following topics:

● Description of the Trigger Outbound Transfer workflow on page 154

● Sample Trigger Outbound Transfer workflow on page 154

Description of the Trigger Outbound Transfer workflow

The Trigger Outbound Transfer workflow verifies that the sending workflow requirements 
are met and calls the Outbound Transfer workflow. This workflow prevents Avaya Agent 
from blocking while the system is retrieving or sending e-mail messages.

Facts about the Trigger Outbound Transfer workflow are included in the following table.

Sample Trigger Outbound Transfer workflow

The following figure shows the Trigger Outbound Transfer workflow.

Siebel project name icemail_sbl.prj

Siebel filename triggerxferoutboundemailtoic_sbl

How launched Property in Agent/Desktop/Siebel/Email/
SendFlowName

Default workflow server

Set in property, Agent/Desktop/Siebel/Email/
WorkFlowServername. If left blank, failover goes into 
effect. In failover, the workflow uses whichever workflow 
server is in the agent domain.
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Trigger Cleanup Transfer workflow

This section includes the following topics:

● Description of the Trigger Cleanup Transfer workflow on page 155

● Sample Trigger Cleanup Transfer workflow on page 155

Description of the Trigger Cleanup Transfer workflow

The Trigger Cleanup Transfer workflow attempts to transfer outgoing e-mail from Siebel to 
Avaya IC if the original outbound e-mail transfer was unsuccessful.

Facts about the Trigger Cleanup Transfer workflow are included in the following table.

Sample Trigger Cleanup Transfer workflow

The following figure shows the Trigger Cleanup Transfer workflow.

Siebel project name icemail_sbl.prj

Siebel filename triggerxfercleanup_sbl

How launched Configured as a startup workflow, it is launched when 
the workflow server starts, and waits until needed

Default workflow server WorkFlow_Email
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Outbound Transfer workflow

This section includes the following topics:

● Description of Outbound Transfer workflow on page 156

● Sample Outbound Transfer workflow on page 157

Description of Outbound Transfer workflow

The Outbound Transfer workflow is run by the Trigger Outbound Transfer workflow 
whenever an agent either responds to an incoming e-mail or originates a new outgoing 
e-mail from the Siebel agent desktop.This workflow transfers the e-mail from Siebel to 
Avaya IC.

Facts about the Outbound Transfer workflow are included in the following table.

Siebel project name icemail_sbl.prj

Siebel filename xferoutboundemailtoic_sbl

How launched

Called by the Trigger Outbound Transfer and the Trigger 
Cleanup Transfer workflows.
This workflow is triggered when the agent presses the 
Send button on the agent desktop.

Default workflow server

Set in property, Agent/Desktop/Siebel/Email/
WorkFlowServername. If left blank, failover goes into 
effect. In failover, the workflow uses whichever workflow 
server is in the agentís failover domain.
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Sample Outbound Transfer workflow

The following figure shows the Outbound Transfer workflow.

Related topic

For more information, see Siebel palette blocks on page 117.
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Outbound Email workflow

This section includes the following topics:

● Description of Outbound Email workflow on page 162

● Sample Outbound Email workflow on page 162

Description of Outbound Email workflow

The Outbound Email workflow is run by the IC Email server for all outbound e-mails prior to 
the final delivery out of Avaya IC.

Facts about the Outbound Email workflow are included in the following table.

Sample Outbound Email workflow

The following figure shows the Outbound Email workflow.

Siebel project name icemail_sbl.prj

Siebel filename outboundemail_sbl

How launched ICEmail.OutboundEmail event and when Email Server / 
Analyze Tab / Run Outbound Email Flow is checked

Default workflow server WorkFlow_Email
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Siebel-first e-mail workflow
The Siebel-first e-mail workflow is the Analyze workflow. 

This section includes the following topics:

● Description of the Analyze workflow on page 159

● Sample Analyze workflow on page 160

Description of the Analyze workflow

The analyze workflow receives a notification e-mail from Siebel, parses it, and determines 
route parameters. Parsing the e-mail involves pulling Siebel-supplied information out of the 
e-mail body. This information includes the Content Analysis results, e-mail language, and 
the Siebel e-mail ActivityID of the original e-mail. The original e-mail is not copied to Avaya 
IC and remains only in Siebel. This workflow uses the parsed information to determine 
routing hints that allow the e-mail to be routed to the appropriate agent.

Facts about the analyze workflow are included in the following table.

Siebel project name icemail_sbl_first.prj

Siebel filename analyze_sbl

How launched ICEmailAnalyze event

Default workflow server

The workflow server that handles the ICEmail.Analyze 
event. The IC Email server should have the Analyze 
event turned on and the OutboundEmail event turned 
off.
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Sample Analyze workflow

The following figure shows the Analyze workflow.
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Chapter 8: Configuring voice qualification 
workflows

! Important:! Important:
Important: Use these procedures only if you are installing a voice channel on your 

system.

The integration software includes default voice workflows. These default workflows will not 
work until you customize the workflows for your location using these procedures.

This section includes the following topics:

● Building the Avaya voice qualification workflow on page 162

● Configuring workflow servers to use Siebel voice workflows on page 164
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Building the Avaya voice qualification workflow
The Incoming Call flow, or voice qualification workflow, uses Automatic Number 
Identification (ANI) information to query Siebel for matching records.

Related topic

For more information, see Process of the Incoming Call flow on page 138.

Where to perform this procedure

Perform this procedure at the location shown in the following table.

Procedure

To build the Avaya voice qualification workflow:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > Workflow Designer.

2. Select File > Open Project.

3. Browse to the ts_sbl.prj file.

Example: e:\<AVAYA_IC61_HOME>\Design\IC\flows\Siebel\TS\ts_sbl.prj

4. Select View > Toolbars > Project.

5. Double-click on the incomingcall_sbl workflow.

6. Select the Format ANI to be 10-digits block in the workflow chart.

7. Enter the telephone number format in the Format property of the Basic tab.

For more information about how to create a format string for telephone numbers, see 
IC Scripts VBA Scripting Reference.

8. Select Project > Settings.

9. Select the Database tab.

10. Type the Login Id and Password.

11. Click OK.

Interface System

Workflow Designer Avaya IC
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12. Select Build > Build Flowset to compile and store the workflow.

The default settings for the blocks, EAIGetData and EAIPutData, should work with the 
EAI server configuration described in this document.

Reference: For more information, see Adding EAI servers to IC Manager on page 210.

13. Continue to Configuring workflow servers to use Siebel voice workflows on page 164.
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Configuring workflow servers to use Siebel voice 
workflows

You must replace the Avaya IC Incoming Call flow with the Siebel incomingcall_sbl flow.

Related topic

For more information, see Voice qualification workflow on page 137.

Where to perform this procedure

Perform this procedure at the following location.

Procedure

To configure the Avaya IC Workflow server to run a Siebel voice workflow when the 
TS.IncomingCall event is raised:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC Manager.

2. Log in to IC Manager.

3. Make sure that the Server tab is selected, and double-click on the workflow server that 
you want to use to handle incoming voice interactions.

4. Select the Channels tab.

5. Has Avaya IC already been configured for calls?

6. Edit the workflows for the incoming call events.

Interface System

IC Manager Avaya IC

If Then

Yes
An association of the TS.IncomingCall event with a workflow already exists 
in IC Manager. Remove the existing association before continuing to Step 
14.

No Go to Step 6.
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7. Set the workflow to ts_sbl.incomingcall_sbl.

8. Click Ok.

Result:

9. Click Ok.

10. Select the Workflow tab.

11. Select Synchronous Startup Flows.

12. If the following row does not exist, add it to the synchronous startup flows:

a. Click New.

b. In the new row, enter web_routing.update_qw_cache

13. Click Ok.

14. Stop and start the Workflow server if the server has already started by doing the 
following:

a. Select the Server tab on the IC Manager window.

b. Select the server from the list on the right side of the window.

c. Select the Start or Stop button in the toolbar.

15. Make sure contact routing is set up for the voice channel.

Reference: For more information, see one of the following documents:

● For basic information, see Avaya IC Media Workflow Reference

● For more detailed information about setting up contact routing, see IC Installation 
and Configuration

● For Business Advocate contact routing, see IC Business Advocate Configuration 
and Administration
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16. What channel are you also installing?

If Then

Web chat Continue to Configuring Web chat qualification workflows on 
page 229.

E-mail - 
Avaya-first Continue to Configuring an Avaya-first e-mail channel on page 241.

E-mail - 
Siebel-first Continue to Configuring a Siebel-first e-mail channel on page 275.
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Chapter 9: Installation and configuration 
tasks for all channels

This section describes the tasks required to install and configure the Avaya IC for Siebel 
integration system. Use these procedures when installing and configuring any type of 
channel.

! Important:! Important:
Important: Always refer to the latest Siebel documentation when performing any of the 

procedures that use Siebel Tools or the Siebel windows. Avaya cannot 
guarantee the accuracy of these procedures.

Working with Siebel Tools

! Important:! Important:
Important: The Siebel procedures in this guide assume that you are working in a 

non-production environment. Adapt the procedures in this guide to conform 
to your company practices for modifying the Siebel object repository and 
Siebel database in your production environment. Test all changes to the 
Siebel object repository in a non-production environment before deploying 
them in your production environment.

Always create a backup copy of the Siebel Server object repository before 
making any changes using Siebel Tools.
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Overview of tasks

! Important:! Important:
Important: Do the following steps in the order shown.

Prerequisites

Verify the following conditions before you begin:

● The Avaya IC and Siebel systems should be installed and functional before proceeding. 
Read Planning and prerequisites on page 41 for details.

● Siebel is incompatible with the Sun Java Virtual Machine (JVM) and you may need to 
change browser settings on the Siebel client machines. For more information, see the 
Siebel Website.

Step Task Where performed

1 Installing integration components on Avaya IC on page 170

Avaya IC
2 Designing Avaya Agent databases on page 173

3 Installing the Siebel integration help files on page 178

4 Configuring Avaya IC on page 181

5 Installing an Avaya IC server on Siebel and configuring a secondary 
ORB Server on page 185 Siebel

6 Creating a Siebel AICD server on page 188 Avaya IC

7 Installing the AICD and the AED on page 191

Siebel
8 Configuring the AICD on page 195

9 Checking the AICD environment (optional) on page 203

10 Importing a custom eScript for Siebel Universal Agent on page 206

11 Configuring the Avaya EAI servers on page 208
● Avaya IC
● Siebel

12

Configuring one or more of the following workflows or channels:
● Configuring voice qualification workflows on page 161
● Configuring Web chat qualification workflows on page 229
● Configuring an Avaya-first e-mail channel on page 241 or Configuring 

a Siebel-first e-mail channel on page 275

Avaya IC
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● The Siebel thin client does not perform correctly on early versions of Internet Explorer. 
For more information, see the Siebel Website.
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Installing integration components on Avaya IC
This section includes the following topics:

● Where to perform this procedure on page 170

● Before you begin on page 170

● Installing the integration components on Avaya IC (Windows) on page 170

● Installing the integration components on Avaya IC (Solaris or AIX) on page 171

Where to perform this procedure

Perform this procedure on the Avaya IC system.

Before you begin

Shut down Avaya IC. Avaya IC should not be running when you install the integration.

Installing the integration components on Avaya IC (Windows)

To install the Avaya IC components when you have a Windows operating system:

1. Insert the integration CD.

2. Click Avaya Servers, Design & Administration Tools. This will install the EAI server, 
Avaya workflows, and other design files.

3. Click Yes, if you see the following message:

4. Follow the instructions in the installation wizard for accepting the license agreement 
and browsing to the correct directory. Click Next when prompted.

A Java Virtual Machine is being installed ...
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5. Select one or both of the following boxes.

6. Click Finish to complete the installation.

7. Continue to Designing Avaya Agent databases on page 173.

Installing the integration components on Avaya IC (Solaris or 
AIX)

To install the Avaya IC components when you have a Solaris or AIX operating system:

1. Insert the integration CD.

2. Do one of the following tasks:

● On Solaris, browse to and execute unix/Solaris/Avaya/setup.bin

● On AIX, browse to and execute unix/AIX/Avaya/setup.bin

This will install the Avaya servers, the EAI server, Avaya workflows, and other design 
files.

3. Follow the instructions in the installation wizard for accepting the license agreement 
and browsing to the correct directory. Click Next when prompted.

Select Description

Interaction Engine Servers

Installs the Siebel integration EAI server on this 
machine. You can install the Siebel integration EAI 
servers on an Avaya IC server or Siebel server. An 
Avaya IC ORB server must be installed on the 
machine for the EAI server to work.

Design & Admin

Installs the workflows and database files. These files 
should be installed on the machine where the Avaya IC 
Workflow Designer and Database Designer interfaces 
reside. This is the machine where you will design your 
agent, build your workflows, and generate your 
database.
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4. Select one or both of the following boxes.

5. Click Yes, if you see the following message:

6. Click Finish to complete the installation.

7. Continue to Designing Avaya Agent databases on page 173.

Select Description

Interaction Engine Servers

Installs the Siebel integration EAI server on this 
machine. You can install the Siebel integration EAI 
servers on an Avaya IC server or Siebel server. An 
Avaya IC ORB server must be installed on the 
machine for the EAI server to work.

Design & Admin

Installs the workflows and database files. These files 
should be installed on the machine where the Avaya IC 
Workflow Designer and Database Designer interfaces 
reside. This is the machine where you will design your 
agent, build your workflows, and generate your 
database.

A Java Virtual Machine is being installed ...
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Designing Avaya Agent databases
Before you can install any agents, you must design the Avaya Agent databases. You need 
to design the Avaya Agent databases only once on the Avaya IC system. These tasks are 
usually performed by a system administrator. 

This section includes the following topics:

● Where to perform these procedures on page 173

● Changing the ADL Include Path for ccq.adl on page 173

● Generating the Windows application on page 175

● Changing the ADL Include Path for repository.adl on page 176

● Reconfiguring the IC Repository on page 177

Where to perform these procedures

Perform these procedures at the location shown in the following table.

Changing the ADL Include Path for ccq.adl

To change the ADL Include Path to match your design machine:

1. Go to Database Designer by navigating to Start > Programs > Avaya Interaction 
Center 6.1 > Database Designer.

2. In the Workflow Designer, browse to the ccq.adl file and open it.

Example: c:\<AVAYA_IC61_HOME>\design\CallCenterQ\ccq.adl

Interface System

Database Designer Avaya IC
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3. In the ccq.adl - Database Designer window, select the ccq path name in the left 
navigation pane of Database Designer. 

Example:

4. Click the ellipsis (...) button to the right of the Upload scripts from these directories 
area in the middle of the window.

Example:

5. In the ADL Include Path window, add the qconsole\siebel path.

Example: e:<AVAYA_IC61_HOME>\design\qconsole\siebel

Additional information: To add a path, press the Add button and browse to the path you 
want to add.

Note:
Note: If you do not see this directory, verify that you have performed the Avaya 

installation described in Installing integration components on Avaya IC on 
page 170.

6. Click OK.

! Important:! Important:
Important: Do not omit saving this file in the next step, even though you will need to 

reopen it.

7. Press Ctrl+S to save the file.

8. Select File > Close.

9. Reopen the ccq.adl file.

Reference: See Steps 1 and 2.

10. Continue to Generating the Windows application on page 175.
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Generating the Windows application

To generate the Windows application:

1. Reopen the ccq.adl file.

2. Select File > Generate Windows Application...

3. On the Generate Windows Application window, select only the following fields:

● Messages

● IC Scripts

● Avaya Agent Layout

● EDU Layout

4. In the text box next to Avaya Agent Layout, select the appropriate layout file for the 
language you want installed.

* Default

Example:
e:\<AVAYA_IC61_HOME>\design\qconsole\siebel\avaya_agent_sbl_es.cdl

Language Filename

English * avaya_agent_sbl_en.cdl

Spanish avaya_agent_sbl_es.cdl

German avaya_agent_sbl_de.cdl

French avaya_agent_sbl_fr.cdl

Italian avaya_agent_sbl_it.cdl

Portuguese avaya_agent_sbl_pt.cdl

Chinese avaya_agent_sbl_zh.cdl

Korean avaya_agent_sbl_ko.cdl

Japanese avaya_agent_sbl_ja.cdl

Thai avaya_agent_sbl_th.cdl
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5. In the text box next to EDU Layout, select the appropriate eXtensible Stylesheet 
Language (XSL) file.

Example: e:\<AVAYA_IC61_HOME>\design\qconsole\eduviewer_en_US.xsl

6. In the Name field, select interaction_center.

7. Enter your Login Id and Password.

8. Click OK.

9. If you get the following message, click Yes:

10. Select File > Close.

11. Continue to Changing the ADL Include Path for repository.adl on page 176.

Changing the ADL Include Path for repository.adl

To change the repository.adl to match your design machine:

1. Browse to the repository.adl file and open it.

Example: e:\<AVAYA_IC61_HOME>\design\repository\repository.adl

2. In the respository.adl - Database Designer window, select the ADL path name in the 
left navigation pane of Database Designer. 

Language Filename

English eduviewer_en_US.xsl

Spanish eduviewer_es_CO.xsl

German eduviewer_de_DE.xsl

French eduviewer_fr_FR.xsl

Italian eduviewer_it_IT.xsl

Portuguese eduviewer_pt_BR.xsl

Chinese eduviewer_zh_CN.xsl

Korean eduviewer_ko_KR.xsl

Japanese eduviewer_ja_JP.xsl

Thai eduviewer_th_TH.xsl

Directory <directory path> is already present and files in that 
directory may be replaced. Do you want to proceed?
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3. Press the ellipsis (...) button to the right of the ADL Include Path area in the middle of 
the window.

4. In the ADL Include Path window, make sure that only the common and qconsole 
paths are listed.

Example:

● e:<AVAYA_IC61_HOME>\design\common

● e:<AVAYA_IC61_HOME>\design\qconsole

Additional information:

● To add a path, press the Add button and browse to the path you want to add.

● To remove a path, press the Remove button and browse to the path you want to 
remove.

5. If you made any changes, select File > Save.

6. Select File > Close to close the repository.adl file.

7. Continue to Reconfiguring the IC Repository on page 177.

Reconfiguring the IC Repository

To reconfigure the IC Repository:

1. Browse to the repository.adl file again and open it.

Example: e:\<AVAYA_IC61_HOME>\design\repository\repository.adl

2. Select File > Database Administration ...

3. Make sure that Reconfigure is selected.

4. Type the IC Administrator Login Id and Password.

5. Click Run.

Result: If you are using Oracle, you are prompted for your database password.

Wait until the process has completed.

6. Click Close.

7. Continue to Configuring Avaya IC on page 181.
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Installing the Siebel integration help files
The procedures in this section describe how to install the Siebel integration help files for 
Avaya Agent. This section includes the following topics:

● Where to perform this procedure on page 178

● Localized help file directories on page 178

● Prerequisite on page 179

● Installing only the English help file on page 179

● Installing localized Siebel help files on page 179

Where to perform this procedure

Perform this procedure on each of your agent PCs.

Localized help file directories

The LangPack_Siebel.exe installs the help files under these directories. Avaya Agent 
expects to find the help files at these locations under <AVAYA_IC61_HOME>\help\
AvayaAgent.

There is currently no Siebel localized help for Traditional Chinese.

Language Help file directory

English \en_US\agent_en_us.chm

Spanish \es_CO\agent_es_CO.chm

German \de_DE\agent_de_DE.chm

French \fr_FR\agent_fr_FR.chm

Italian \it_IT\agent_it_IT.chm

Portuguese \pt_BR\agent_pt_BR.chm

Korean \ko_KR\agent_ko_KR.chm

Japanese \ja_JP\agent_ja_JP.chm

Thai \th_TH\agent_th_TH.chm
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Prerequisite

Make sure all agent PCs have Avaya Agent installed.

Installing only the English help file

Use this procedure if you want to install only the English Avaya Agent help file for the 
Siebel integration.

To install only the English help file:

1. Locate the English help file at Docs\agent_en_us.chm on the integration CD.

! Important:! Important:
Important: You will overwrite the existing non-integrated Avaya Agent help file in the 

next step. The Siebel help file includes all relevant Avaya Agent and Siebel 
help topics, so this should not be a concern.

2. Copy the agent_en_us.chm file to the <AVAYA_IC61_HOME>\help\AvayaAgent\
en_US folder on the agent PC.

You can copy files by manually copying the help file to each agent PC or by using the 
Avaya Agent auto-update feature.

For more information about using the auto-update feature, see IC Installation and 
Configuration.

3. Continue to Configuring Avaya IC on page 181.

Installing localized Siebel help files

Use this procedure to install all of the localized help files for the Siebel integration, 
including English.

To install the localized help files:

1. Locate LangPack\LangPack_Siebel.exe on the integration CD.

! Important:! Important:
Important: You will overwrite the existing non-integrated Avaya Agent help files in the 

next step. The Siebel help files include all relevant Avaya Agent and Siebel 
help topics, so this should not be a concern.
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2. Run the executable file on an agent PC.

Result 1: If Avaya Agent is not installed, the following text displays:

Result 2: If Avaya Agent is installed, several installation messages display followed by 
the Language Pack 1 Installation Complete window. 

The program unpacked and copied the English and all localized help files to 
language-specific subdirectories under <AVAYA_IC61_HOME>\help\AvayaAgent. 
Depending on the language configuration of Avaya Agent, the appropriate help file is 
used when the agent selects Help.

For more information, see Localized help file directories on page 178.

3. Click Finish.

4. Restart Avaya Agent.

5. Perform Steps 2 through 4 on each remaining PC or use the Avaya Agent auto-update 
feature to automatically update all agent PCs.

For more information about using the auto-update feature, see IC Installation and 
Configuration.

6. Continue to Configuring Avaya IC on page 181.

Unable to locate an Avaya Agent XX installation
Please contact a product administrator
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Configuring Avaya IC
The procedures in this section describe how to configure the Avaya IC properties to enable 
the Avaya IC for Siebel integration.

This section includes the following topics:

● About the Commit Property Changes window on page 181

● Where to perform these procedures on page 181

● Setting Avaya IC properties on page 182

About the Commit Property Changes window

While you are performing these procedures, you may see the following window:

Always click Yes when you see this window or you will lose your changes.

Where to perform these procedures

Perform these procedures at the location shown in the following table.

Interface System

IC Manager Avaya IC
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Setting Avaya IC properties

Use this section to set the Avaya IC properties to enable the Avaya IC for Siebel 
integration.

To set the Avaya IC properties:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC Manager.

2. Select Tools > Groups.

3. Select IC in the top left corner of the Groups window.

4. Select the Properties tab.
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5. Select a section from the Sections list using the suggested values in the following 
table.

Section Property Property Value

All channels

Agent/Desktop

ContactSuspensionEnabled No

IntegratedApplication Siebel

Layout avaya_agent_sbl

ScreenPopEnabled Yes

WrapUpEnabled No (optional)

WrapUpType Siebel

Agent/Desktop/Directory
ShowAgentsOnStartup Yes (optional) 

Controls agents that are viewed in 
the UAD.ShowAllAgents

Agent/Desktop/
OutboundAgent ProceedAfterWrapUp Yes if WrapUpEnabled is set to 

Yes.

Agent/Desktop/ScreenPop

PopOnAllArrivingContacts No

PopOnContactActivation Yes

PopOnFirstArrivingContact Yes

Agent/Desktop/Siebel
AutoLoginEnabled Yes

LaunchURL URL for Siebel thin client

Agent/Desktop/Siebel/
AutoLogin

PasswordFormat None (optional)

UserNameFormat Upper

WaitTime 10

Agent/Desktop/WAC
AlwaysOnTop Yes

AppMode siebel

E-mail channel only

Agent/Desktop/WAC
ShowOnEmailActivate No

ShowOnEmailSelect No



Installation and configuration tasks for all channels

184 Avaya Interaction Center for Siebel 7 Integration

For more information, see the following topics:

● Wrap-up on page 89

● Siebel integration agent properties on page 92

6. Select a property from the Name and Value fields in the right pane using the table in 
Step 5.

7. Click the Edit server button to edit this property.

Example:

8. Change the value of the property in the Value field to the suggested value in the table.

9. Click Ok.

10. Return to Step 3 and repeat this procedure until you have edited all of the properties in 
the table.

11. Click Ok to close the Group Manager window.

12. Continue to Installing an Avaya IC server on Siebel and configuring a secondary ORB 
Server on page 185.

Agent/Desktop/Siebel/Email

SendFlowName
icemail_sbl. 
triggerxferoutboundemail
toic_sbl

WorkFlowServerName

Set to the name of the workflow 
server that handles the analysis of 
e-mail. For example, 
WorkFlow_System.
Leave this blank to enable failover.

Web chat channel only

Agent/Desktop/WAC
ShowOnChatActivate Yes

ShowOnChatSelect No

Section Property Property Value
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Installing an Avaya IC server on Siebel and 
configuring a secondary ORB Server

This section includes the following topics:

● Where to perform this procedure on page 185

● Before you begin on page 185

● Solaris and AIX operating systems on page 185

● Procedure on page 186

Where to perform this procedure

Perform the following procedure on the Siebel system. You will also need to use IC 
Manager on your primary Avaya IC system for some of the steps.

Before you begin

Before you can install the AICD Siebel server, you must install Avaya IC on the Siebel 
server, and configure a secondary ORB Server.

Related topic

For more information, see ORB Servers on page 73.

Solaris and AIX operating systems

This procedure assumes that you are installing the Avaya IC ORB Server on Windows. For 
information about installing and configuring an ORB Server when you have a Solaris or 
AIX operating system, see IC Installation and Configuration.
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Procedure

! Important:! Important:
Important: Repeat this procedure for every Siebel Communications Server in your 

environment.

To install an Avaya IC server on the Siebel Communications Server:

1. From the installation directory for Avaya IC, go to the \Windows\Install\SERVERS 
directory.

2. Double-click on setup.exe.

3. Click Avaya Servers, Design & Administration Tools.

● Although you can install in the Program Files directory, which is the default, you may 
want to use the directory that Avaya technicians traditionally use - [Drive]:\Avaya.

● You will not be performing any design or administration from this system, so clear 
the Design & Admin field.

4. Click No on the window with the following text:

5. Click Yes on the window with the following text:

6. When the Configuration Tool window opens, select the values in the following table.

7. Click Apply Settings. 

If you get a message that says your Oracle Home is not valid, click OK, then click Exit. 

Result: You will see a screen with the following text:

Do you wish to run Indexq or Outbound Reporting with this 
installation?

Do you want to run the Configuration Tool now?

Field Value

Select Mode Select Secondary

Primary Host Name Type the host name of the primary Avaya IC ORB Server.
For more information, see IC Installation and Configuration.

IC Password Type the Avaya IC password.

Start ORBServer Cleared

This wizard requires that you restart your computer.
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! CAUTION:
CAUTION: Your computer will have to be restarted for the changes to take effect. 

Restarting your Siebel Server is service affecting.

8. Restart your computer.

9. Go to your primary Avaya IC system and run IC Manager to check your secondary 
ORB Server installation. 

Tip:
Tip: Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC 

Manager.

10. Check for a new ORB Server in your default domain that will be named after the Siebel 
server on which you just installed your secondary ORB Server. 

Example: In the following figure, the secondary ORB Server is installed on a machine 
called jag_sbl1. 

11. Continue to Creating a Siebel AICD server on page 188.
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Creating a Siebel AICD server
Now that you have the secondary Avaya IC ORB installed on the Siebel server, you must 
create a Siebel AICD server by administering a new server component using IC Manager.

This section includes the following topics:

● Where to perform this procedure on page 188

● Procedure on page 188

Where to perform this procedure

Perform this procedure at the location shown in the following table.

Procedure

To create a Siebel AICD server:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC Manager.

2. Log in to IC Manager.

3. Select the Server tab, and select All Domains.

Interface System

IC Manager Primary Avaya IC
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4. Right-click inside the pane with the list of servers.

Example:

 

Note:
Note: Unlike this example, your window should display data.

5. Select New... from the right-click list.

6. In the Server Type field, select SiebelAICD.

7. Click Ok.

8. In the Server Editor window, type or select the following values.

9. Make sure that the Auto Start check box is unchecked.

The Avaya IC ORB Server does not start the AICD server. Instead, the AICD server is 
started and shut down by the Siebel Communications server.

Field Value

Name Type a name that identifies both the AICD and the Siebel host where the 
AICD will reside. 
Example: AICD_Jaguar2

Host Select the IP address of the Siebel host where the AICD will reside. 
Most other servers will have the IP address of the Avaya IC system. The 
Siebel AICD server has the IP address of the Siebel host.

Port Type a port number that does not conflict with an existing TCP/IP port on 
the Siebel host.

Domain For instructions on how to configure domains, see Avaya IC domain 
deployment guidelines on page 46.

Directory This field is not used, but select a valid directory name anyway.

Executable This field is not used, but select something anyway.



Installation and configuration tasks for all channels

190 Avaya Interaction Center for Siebel 7 Integration

10. Select the SiebelAICD tab.

11. Make sure that the Allow ORB to start AICD field is unchecked.

12. Select the Debug tab from the Server Editor window. 

13. Click the ellipsis (...) button next to the Trace Levels field.

Result: The Trace Levels window opens.

14. Choose one of the choices shown in the following table:

Reference: For more information about logging levels, see Log files on page 354.

! Important:! Important:
Important: Do not set your logging level to flush for normal operating conditions. The 

flush setting slows down all AICD processes. For normal system operations, 
the log level should not be set at a level greater than usr2.

15. Click Ok to accept the trace level changes you made.

16. Click Ok to complete the Siebel AICD server creation.

17. You must reproduce your recent changes on the other Avaya IC components and 
servers. To do this, navigate to Manager > Refresh.

18. Select Manager > Update ORB Servers.

If errors are reported, your vesp changes may not be properly updated on the servers. 
Isolate and correct the problems and return to Step 17.

19. Continue to Installing the AICD and the AED on page 191.

For minimal logging, select the 
following field:

For maximum logging, select the 
following fields:

idl ● usr1
● usr2
● usr3
● usr4
● flush
● idl
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Installing the AICD and the AED
This section includes the following topics:

● Before you begin on page 191

● Upgrading Avaya IC on page 191

● Where to perform these procedures on page 192

● Installing the AICD and AED (Windows) on page 192

● Installing the AICD and AED (Solaris or AIX) on page 193

Before you begin

Before you can install the AICD, you must install a secondary ORB on the Siebel server, 
and create the Siebel AICD server in IC Manager.

Related topics

For more information, see one of the following topics:

● Installing an Avaya IC server on Siebel and configuring a secondary ORB Server on 
page 185

● Creating a Siebel AICD server on page 188

Upgrading Avaya IC

This procedure automatically backs up the following directory so that you can save your 
customizations during an upgrade.

! Important:! Important:
Important: Only the AICD.def and AICDStrings.txt files are saved.

Source directory Backup directory

<SIEBEL_HOME>\siebel\siebsrvr\bin\enu <SIEBEL_HOME>\backup\siebel\siebsrvr\bin\enu
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Where to perform these procedures

Perform these procedures on the Siebel system.

Installing the AICD and AED (Windows)

To install the AICD and AED when you have a Windows operating system:

1. Insert the integration CD.

2. Click Avaya Drivers for Siebel 7. This will install the integration components on the 
Siebel server. This includes the AICD, AED, AICD definition file, and the 
AICDStrings.txt file.

3. Follow the instructions in the installation wizard for accepting the license agreement 
and browsing to the Siebel installation directory. Click Next when prompted.

Example: Browse to c:\sea752

Result: Progress gauges display.

4. Click Finish.

5. Continue to Updating the Windows system path on page 192.

Updating the Windows system path

You must update your Windows system path to add %AVAYA_IC61_HOME%\bin. This path 
is used by the AICD and AED to locate their supporting files.

To update the Windows system path:

Note:
Note: This procedure assumes you have Windows 2000. You will need to make 

adjustments to these procedures if you have any other Windows version.

1. Navigate to Start > Settings > Control Panel > System.

2. Select the Advanced tab.

3. Select Environment Variables.

4. Double-click Path in the System variables field.

Result: The Edit System Variable window opens.

5. In the Variable Value field, add this to the existing path:

%AVAYA_IC61_HOME%\bin
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Tip:
Tip: Use ; to separate the entries.

6. Click OK.

7. Restart the Siebel server.

8. Return to Installing the AICD and AED (Windows) on page 192 and repeat this 
procedure for every Siebel Communications Server in your environment.

9. Continue to Configuring the AICD on page 195.

Installing the AICD and AED (Solaris or AIX)

To install the AICD and AED when you have a Solaris or AIX operating system:

1. Insert the integration CD.

2. Do one of the following tasks:

● On Solaris, browse to and execute unix/Solaris/Siebel/setup.bin

● On AIX, browse to and execute unix/AIX/Siebel/setup.bin

This will install the integration components on the Siebel server.This includes the 
AICD, AED, AICD definition file, and the AICDStrings.txt file.

3. Follow the instructions in the installation wizard for accepting the license agreement 
and browsing to the correct directory. Click Next when prompted.

Example: Browse to C:\Avaya\IC61

The files are placed in the \opt\sea752 directory.

Result: Progress gauges display.

4. Click Finish.

5. Continue to Modifying Solaris and AIX variables on page 193.

Modifying Solaris and AIX variables

● You must modify or define three Solaris and AIX environment variables to integrate 
Avaya IC with Siebel. The variables are PATH, AVAYA_IC61_HOME, and 
LD_LIBRARY_PATH.

To modify the Solaris and AIX path variables:

1. Navigate to your siebenv.sh file for the Siebel server. This file should be located under 
a subdirectory called siebsrvr.

Make sure you do not use the siebenv.sh file for the Siebel Gateway server. The 
Gateway server is located under a subdirectory called gtwysrvr.
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2. Add the following three environment variables to the siebenv.sh file, preferably at the 
beginning of the file.

Solaris example:

AIX example:

Replace <AvayaHomeDir> with the full path to your Avaya Home Directory. 
Depending on the shell you use, syntax may be different, so please use the syntax 
appropriate to the shell you use for your Siebel server.

3. Restart the Siebel server.

4. Return to Installing the AICD and AED (Solaris or AIX) on page 193 and repeat this 
procedure for every Siebel Communications Server in your environment.

5. Continue to Configuring the AICD on page 195.

AVAYA_IC61_HOME=<AvayaHomeDir>

export AVAYA_IC61_HOME

LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${AVAYA_IC61_HOME}/lib

export LD_LIBRARY_PATH

PATH=$PATH:${AVAYA_IC61_HOME}/bin

export PATH

AVAYA_IC61_HOME=<AvayaHomeDir>

export AVAYA_IC61_HOME

LIBPATH=${LIBPATH}:${AVAYA_IC61_HOME}/lib

export LIBPATH

PATH=$PATH:${AVAYA_IC61_HOME}/bin

export PATH
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Configuring the AICD

! Important:! Important:
Important: The order of the configuration steps is significant. Information provided in 

earlier steps is used in later steps. Do not try to perform the steps in an order 
that is different from the order presented here unless you are familiar with 
how Siebel communication drivers are administered.

This section includes the following topics:

● Before you begin on page 195

● Where to perform these procedures on page 195

● AICD Siebel administration on page 196

● AICD Siebel administration on page 196

● Importing the AICD Siebel configuration on page 197

● Associating Siebel agents with the AICD on page 198

● Creating a teleset on page 199

● Adding at least one extension on page 200

● Adding responsibilities to lists (optional) on page 200

Before you begin

The following conditions should be true before you begin these procedures:

● The AICD is installed.

● Your employees have already been administered in the Siebel database.

Where to perform these procedures

Perform these procedures at the following location.

Interface System

Siebel windows Siebel
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Related topic

For more information, see Siebel user interface on page 106.

AICD Siebel administration

You can administer the AICD to support multiple AICD configurations and multiple AICD 
profiles as along as each AICD configuration has only one AICD profile and each agent is 
part of only one configuration.

Creating a communication configuration

You should run the Siebel thin client on the Siebel server, or on another machine that has 
access to the AICD.def file. If it is not possible to run the Siebel thin client on a machine 
with access to the AICD.def file, use ftp or copy the AICD.def file to a directory that is 
accessible. The AICD.def file was copied by the setup.exe onto the Siebel server in a 
subdirectory called bin\enu.

! Important:! Important:
Important: Save all entries before leaving a window.

To create a communication configuration:

1. Log in to the Siebel thin client as a Siebel administrator.

2. Go to the Site Map by pressing Ctrl+Shift+A.

3. Do one of the following tasks:

● For Siebel systems earlier than 7.7, go to Communication Administration > All 
Configurations.

● For Siebel 7.7, go to Administration - Communications > All Configurations.

4. Click New on the Configurations window menu bar.

5. Create an entry for the AICD with the values shown in the following table.

Field Value

Name You can enter anything with the words Avaya or AICD Configuration in 
the name.

Comments Type an appropriate comment.
Example: Avaya IC6
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! Important:! Important:
Important: Do not forget to do the following step.

6. Press Ctrl+S to save the record.

7. Continue to Importing the AICD Siebel configuration on page 197.

Importing the AICD Siebel configuration

In this procedure, you are going to import the AICD.def file. It must be available from the 
machine where you are running your Siebel thin client. If you are not running the Siebel 
thin client on the Siebel server, you must either copy the AICD.def file to a local directory, 
or mount the drive where the AICD.def file has been installed. The following directions 
assume that you are running the Siebel thin client on the Siebel server.

The AICD.def file has been installed in the \bin\enu directory on the Siebel server.

! Important:! Important:
Important: Save all entries before leaving a window.

To import the AICD Siebel configuration from the definition file:

1. Click Import Configuration, located on the right side of the window under the 
Configurations tab.

Example:

 

Result: A window with the following text opens:

Caution: Importing communications configuration parameters, 
commands and events, or communications drivers and profiles 
overwrites any existing configuration elements that use the same 
names. Click Next to proceed.
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2. Click Next.

3. Select all of the following boxes:

● Configuration Parameters

● Commands

● Events

● Drivers & Profiles

4. Browse to the AICD.def file, or to any other valid definition file.

Example: e:\sea752\siebsrv\bin\enu\AICD.def

5. Click OK.

Result: You might see the cursor change to an hourglass, and you may have to wait for 
several minutes. There should be no errors.

6. Set the AICD driver parameters on Avaya IC and Siebel. This step is optional if the 
default values for the driver parameters are adequate for your configuration.

Reference: For more information, see Driver parameters on page 525.

7. Continue to Associating Siebel agents with the AICD on page 198.

Associating Siebel agents with the AICD

This section includes the following topics:

● Before you begin on page 198

● Procedure on page 198

Before you begin

You must have already administered your Siebel agents under the Siebel Employee 
Administration window and administered your database.

Related topic

For more information about administering Siebel agents, see the Siebel documentation.

Procedure

! Important:! Important:
Important: Save all entries before leaving a window.
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To associate the Siebel agents with the AICD configuration:

1. Select the Agents tab located on the bottom third of the window.

2. Click New under the Agents tab.

Result: The Add Agents window opens.

3. Select the agents and click OK. 

4. Continue to Creating a teleset on page 199.

Creating a teleset

! Important:! Important:
Important: Save all entries before leaving a window.

To create a teleset:

1. Select All Telesets under the Administration - Communications tab.

Note:
Note: For Siebel systems earlier than 7.7, select All Telesets from the Show 

pull-down menu near the top-left corner of the Siebel thin client.

2. Click New in the Telesets window menu bar.

3. Select the values shown in the following table.

4. Press Ctrl+S to save the record.

5. Click New under the Agent tab. 

6. Select the Siebel agents and click OK. 

The All Telesets View displays your selections.

7. Continue to Adding at least one extension on page 200.

Field Value

Teleset AICD

Host AICD
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Adding at least one extension

! Important:! Important:
Important: Save all entries before leaving a window.

The extensions you are adding with this procedure are not used by the AICD. However, 
Siebel may expect these extensions to be administered.

To add at least one extension:

1. Select the Extensions tab located on the bottom third of the window.

2. Click New under the Extensions tab.

Result: The Add Agents window opens.

3. Select the values shown in the following table.

! Important:! Important:
Important: Do not forget to do the following step.

4. Press Ctrl+S to save the record.

5. Continue to Adding responsibilities to lists (optional) on page 200.

Adding responsibilities to lists (optional)

! Important:! Important:
Important: Save all entries before leaving a window.

Perform this procedure so that the agent can view responsibilities from certain pull-down 
lists, and view the responsibility pop screens. Your site will probably require additional 
views and responsibilities besides the ones described in this procedure. This procedure is 
optional.

To add new responsibilities:

1. From the Siebel user interface, go to the Site Map by pressing Ctrl+Shift+A.

2. Do one of the following tasks:

Field Value

Extension Type S

Extension Select a telephone number.
This number is not validated or used by the AICD.
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● For Siebel systems earlier than 7.7, go to Application Administration > 
Responsibilities.

● For Siebel 7.7, go to Administration - Application > Responsibilities.

3. In the Responsibilities window menu bar, click New.

4. Type AICD Responsibility in the Responsibility field.

5. Press Ctrl+S to save the record.

6. In the Views window menu bar, click New. 

The Views window is located on the lower half of the screen.

Note:
Note: For Siebel systems earlier than 7.7, the New button is located on the Views 

tab.

Result: The Add Views window opens. This will add a view to this responsibility.

7.  Select Activity Detail View in the text box next to the starting with field.

Example:

8. Click OK.

9. Repeat Steps 6 through 8 until you have added all of the following views:

● Activity Detail View

● All Activity List View

● All Contacts across Organizations

● Communication Detail - Response View

● Consumer Detail View

● Contact Detail View

● Home Page View (WCC)

10. Click New under the Users tab. This will associate an agent to this responsibility.
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11. Select an agent, and click OK.

12. Repeat Step 11 until you have added all of the agents.

13. Continue to Checking the AICD environment (optional) on page 203.
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Checking the AICD environment (optional)
This section includes the following topics:

● Checking the AICD under Solaris on page 203

● Checking the AICD under Windows on page 204

Checking the AICD under Solaris

You can use the Solaris command line utility, Ldd to check the AICD dependencies. The 
Solaris Ldd utility lists the dynamic dependencies of executable files or shared objects.

To check the AICD under Solaris:

1. On the UNIX command line, navigate to the Siebel Home directory.

2. Invoke the Siebel environment file, siebenv.sh.

You updated the siebenv.sh file in an earlier configuration step. The siebenv.sh file 
will set the UNIX environment variables that are necessary for the AICD to run.

3. Navigate to the Siebel bin directory. This is where the AICD should have been 
installed.
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4. Run the following command:

ldd libaicd.so

Result: The following ldd output shows unresolved dependencies for the files, 
libmttoolkit.so and libmttlogger.so.

This can be caused by:

● The libmttoolkit.so and libmttlogger.so files are not installed. These files should 
have been installed under <AVAYA_IC61_HOME>/bin when you installed Avaya IC 
on the Siebel Server.

● The LD_LIBRARY_PATH variable is inaccurate.

5. Continue to Importing a custom eScript for Siebel Universal Agent on page 206.

Checking the AICD under Windows

If your Siebel server has a Windows operating system, you can use a Microsoft tool called 
depends.exe to check the Siebel server configuration. This test ensures that your system 
path setting is accurate and that the Siebel Communications Server can load the AICD.dll.

You do not have to perform this procedure if you cannot locate a copy of depends.exe.

This section includes the following topics:

● Before you begin on page 204

● Procedure on page 205

Before you begin

You will need to have a copy of Microsoft Visual Basic to access depends.exe.

libnsl.so.1 => /usr/lib/libnsl.so.1
libc.so.1 => /usr/lib/libc.so.1
libmttoolkit.so => (file not found)
libmttlogger.so => (file not found)
libpthread.so.1 => /usr/lib/libpthread.so.1
librt.so.1 => /usr/lib/librt.so.1
libdl.so.1 => /usr/lib/libdl.so.1
libmp.so.2 => /usr/lib/libmp.so.2
libaio.so.1 => /usr/lib/libaio.so.1
/usr/platform/SUNW,Ultra-4/lib/libc_psr.so.1
libthread.so.1 => /usr/lib/libthread.so.1
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Procedure

To check the Siebel server AICD environment:

1. Get a copy of depends.exe from your Visual Basic software.

2. Run depends.exe on your Siebel server. 

3. Select File > Open and navigate to the Siebel server bin directory.

Example: Sea752/siebsrvr/bin

4. Locate the AICD.dll, and click Open.

Result: The Dependency Walker window opens.

This window lists the AICD.dll and all of the DLLs required by the AICD.

5. Check the entries for MTTOOLKIT.DLL and MTTLOGGER.DLL.

If the icons next to these filenames displays ?, one of the following problems may have 
occurred:

● The DLL is not installed.

● The system path variable is inaccurate.

● You did not reboot your Siebel server after updating the system path.

Example: In the following window, the MTTOOLKIT.DLL was not located.

6. Continue to Importing a custom eScript for Siebel Universal Agent on page 206.
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Importing a custom eScript for Siebel Universal 
Agent

This section includes the following topics:

● Where to perform this procedure on page 206

● Procedure on page 206

Where to perform this procedure

Perform this procedure on the Siebel system using Siebel Tools.

Related topic

For more information, see Siebel Tools on page 111.

Procedure

! Important:! Important:
Important: Test all changes to the Siebel object repository in a non production 

environment before deploying them in your production environment. Create 
a backup copy of the Siebel server object repository before making any 
changes using Siebel Tools.

For more information, see Working with Siebel Tools on page 167.

To import a custom eScript for the Siebel Universal Agent:

1. From Siebel Tools, select Application from the Object Explorer pane.

2. Select the Siebel Universal Agent application.

3. Select Tools > Lock Project.

4. In the Applications pane, right-click on Siebel Universal Agent.

5. Select Edit Server Scripts.

6. If you see the Scripting Language pop-up, make sure that eScript is selected and 
click OK.

 Result: The Script Editor window opens.

7. Go to File > Import.
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8. Select the \Integration\Email\AvayaFirst\SiebelUniversalAgent.js file from the 
integration CD and click ok.

Note:
Note: If you are using the Siebel-first e-mail method, the pathname is \Integration\

Email\SiebelFirst\SiebelUniversalAgent.js.

This will import the eScript.

9. Press Ctrl+S to save.

10. Close the window.

11. Do one of the following tasks to stop Siebel services:

12. From the Siebel Tools - Siebel Repository - Project List window, select Tools > 
Compile Projects.

Result: The Object Compiler window opens.

13. Select Locked Projects.

14. Browse to the SRF used by the Siebel server.

Example: e:\sea752\siebsrvr\objects\enu\siebel.srf

15. If Siebel Tools is not running on your Siebel server, you may have to make a local copy 
of the Siebel SRF file.

16. Click Compile.

17. Start the Siebel server.

18. Continue to Configuring the Avaya EAI servers on page 208.

If your operating system is: Then

Windows Stop Siebel services from Control Panel > services.

Solaris or AIX Consult the Siebel administration guide for instructions.

For Windows For Solaris/AIX

Select Control Panel > services Consult the Siebel administration guide for 
instructions.
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Configuring the Avaya EAI servers
Use the procedures in this section to configure the Avaya Enterprise Application 
Integration (EAI) servers. You can install the EAI server on any server that has an ORB 
server, including the Siebel server or another Avaya IC server.

This section includes the following topics:

● Creating an EAI e-mail agent (e-mail channel only) on page 208

● Adding EAI servers to IC Manager on page 210

● Updating the LIBPATH environment variable for AIX platforms on page 215

● Verifying the CLASSPATH environment variable on page 215

● Installing a custom integration object on page 216

● Importing the Siebel workflow on page 221

● Activating the Siebel EAI workflow on page 223

● Modifying the eai.cfg file on page 224

● Shutting down and restarting the EAI Object Manager component on page 224

● Starting the Avaya IC EAI servers on page 225

Related topic

For more information about the EAI servers, see EAI server on page 66.

Creating an EAI e-mail agent (e-mail channel only)

! Important:! Important:
Important: Use this procedure only if you are installing an e-mail channel on your 

system.

You must create a fictitious agent that the software will use to communicate between the 
Avaya IC Email server and the EAIEmail server. Do not select an actual agent as the EAI 
e-mail agent. The EAI e-mail agent will be too busy processing e-mail to function efficiently 
as a regular Avaya IC agent.
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Where to perform this procedure

Perform this procedure at the following location.

Procedure

To create an EAI e-mail agent:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC Manager.

2. Log in to IC Manager.

3. Select the Agents tab.

4. In the left pane, navigate to IC > DefaultTenant > Default.

5. Right-click in the Agent pane, and click New.

6. Select the General tab, and select the values shown in the following table.

7. Select the Security tab, and type or select the following information.

Note:
Note: You can choose a different password.

8. Continue to Adding EAI servers to IC Manager on page 210.

Interface System

IC Manager Avaya IC

Field Value

Domain Email

First Name Email

Last Name EAI

LoginID emailagent

Field Value

Agent Roles Select Agent

Password emailagent1

Confirm emailagent1

Force password change on login clear
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Adding EAI servers to IC Manager

This section includes the following topics:

● Where to perform these procedures on page 210

● Before you begin on page 210

● About configuring the Workflow and EAIWorkflow servers on page 210

● Adding the EAI server on page 210

● Adding the EAIWorkflow server on page 212

● Adding the EAIEmail server on page 213

Where to perform these procedures

Perform these procedures at the following location.

Before you begin

Read the following sections before proceeding:

● EAI domain guidelines on page 49

● EAI server types on page 68

About configuring the Workflow and EAIWorkflow servers

Configure the Workflow server and the EAIWorkflow server on the same physical machine 
to avoid potential permission problems.

Related topic

For more information, see EAI server is unable to read a file attachment on page 360.

Adding the EAI server

To add the Avaya EAI server to IC Manager:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC Manager.

2. Log in to IC Manager.

Interface System

IC Manager Avaya IC
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3. Select Server > New.

4. In the Server Type field, select EAI.

5. Select the General tab, and select the values shown in the following table.

6. Select the EAI tab, and type or select the values shown in the following table.

7. Select the Debug tab to set the trace levels to usr1 - user 4 depending on the amount 
of information needed in the EAI server log files.

Reference: For more information about logging levels, see Log files on page 354.

! Important:! Important:
Important: Do not set your logging level to flush for normal operating conditions. The 

flush setting slows down all EAI processes. For normal system operations, 
the log level should not be set at a level greater than usr2.

Field Value

Name Select EAI

Domain For instructions on how to configure domains, see Avaya IC domain 
deployment guidelines on page 46.

Host Select the appropriate Avaya IC host where this EAI server should run.

Directory
● For a Windows installation - Select AVAYA_IC61_HOME/Java/bin/server
● For a Solaris installation - Select AVAYA_IC61_HOME/Java/lib/sparc
● For an AIX installation - Select AVAYA_IC61_HOME/jre/bin

Field Value

Siebel Web Server Select the name of your Siebel server.

Siebel User Name Type the [Siebel login name]. The default Siebel 
login name is SADMIN.

Siebel Password Type the [Siebel password]. The default Siebel 
password is SADMIN.

Siebel Interface Type Select eai 

Active Session Count

Leave the default values.HTTP response Timeout(sec)

Heartbeat

Language Code
For English, type enu
See the Siebel documentation for other language 
codes.
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8. Click Ok.

9. Continue to Adding the EAIWorkflow server on page 212.

Adding the EAIWorkflow server

To add the Avaya EAIWorkflow server to IC Manager:

1. From IC Manager, select Server > New.

2. In the Server Type field, select EAIWorkflow.

3. Select the General tab, and select the values shown in the following table.

4. Select the EAI Workflow tab, and type or select the values shown in the following 
table.

Field Value

Name Select EAIWorkflow

Domain For instructions on how to configure domains, see Avaya IC domain 
deployment guidelines on page 46.

Host Select the appropriate Avaya IC host where this EAI server should run.

Directory
● For a Windows installation - Select AVAYA_IC61_HOME/Java/bin/server
● For a Solaris installation - Select AVAYA_IC61_HOME/Java/lib/sparc
● For an AIX installation - Select AVAYA_IC61_HOME/jre/bin

Field Value

Siebel Web Server Select the name of your Siebel server.

Siebel User Name Type the [Siebel login name]. The default Siebel 
login name is SADMIN.

Siebel Password Type the [Siebel password]. The default Siebel 
password is SADMIN.

Siebel Interface Type Select workflow

Use MIME Layer
Select *
Only for Siebel 7.0, make sure this field is 
unchecked.
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* You can configure EAIWorkflow without Multipurpose Internet Mail Extensions (MIME) if you do not 
require any attachments on a Put operation. For example, attachments are required when creating a 
Web chat record along with the transcripts.

5. Select the Debug tab to set the trace levels to usr1 - user 4 depending on the amount 
of information needed in the EAI server log files.

Reference: For more information about logging levels, see Log files on page 354.

! Important:! Important:
Important: Do not set your logging level to flush for normal operating conditions. The 

flush setting slows down all EAI processes. For normal system operations, 
the log level should not be set at a level greater than usr2.

6. Click Ok.

7. Are you installing an e-mail channel?

Adding the EAIEmail server

! Important:! Important:
Important: Use this procedure only if you are installing an e-mail channel on your 

system.

To add the Avaya EAI e-mail server to IC Manager:

1. From IC Manager, select Server > New.

2. In the Server Type field, select EAIEmail.

Active Session Count

Leave the default values.HTTP response Timeout(sec)

Heartbeat

Language Code
For English, type enu
See the Siebel documentation for other language 
codes.

If Then

Yes Continue to Adding the EAIEmail server on page 213.

No Continue to Verifying the CLASSPATH environment variable on page 215.

Field Value
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3. Select the General tab, and select the values shown in the following table.

4. Select the EAI Email tab, and type or select the values shown in the following table.

5. Select the Debug tab to set the trace levels to usr1 - user 4 depending on the amount 
of information needed in the EAI server log files.

Reference: For more information about logging levels, see Log files on page 354.

Field Value

Name Select EAIEmail

Domain For instructions on how to configure domains, see Avaya IC domain 
deployment guidelines on page 46.

Host Select the appropriate Avaya IC host where this EAI server should run.

Directory
● For a Windows installation - Select AVAYA_IC61_HOME/Java/bin/server
● For a Solaris installation - Select AVAYA_IC61_HOME/Java/lib/sparc
● For an AIX installation - Select AVAYA_IC61_HOME/jre/bin

Field Value

Siebel Web Server Select the name of your Siebel server.

Siebel User Name Type the [Siebel login name]. The default Siebel 
login name is SADMIN.

Siebel Password Type the [Siebel password]. The default Siebel 
password is SADMIN.

Siebel Interface Type Select email

IC Email Server Set the IC Email server to the machine where the 
Avaya IC Email server resides.

Email Server Login Type emailagent

Email Server Password Type emailagent1

Active Session Count

Leave the default values.HTTP response Timeout(sec)

Heartbeat

Language Code
For English, type enu
See the Siebel documentation for other language 
codes.
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! Important:! Important:
Important: Do not set your logging level to flush for normal operating conditions. The 

flush setting slows down all EAI processes. For normal system operations, 
the log level should not be set at a level greater than usr2.

6. Click Ok.

7. Do one of the following tasks:

● If you have an AIX platform, continue to Updating the LIBPATH environment 
variable for AIX platforms on page 215.

● If you have a Windows or Solaris platform, continue to Verifying the CLASSPATH 
environment variable on page 215.

Updating the LIBPATH environment variable for AIX platforms

On AIX platforms, the default LIBPATH environment variable that is set in the icenv file 
must be changed to include the path to the Java/bin directory, as well as the Java/bin/
classic directory. The EAI server on AIX platforms will not load unless this change is done.

To update the LIBPATH environment variable for an AIX platform:

1. Open the icenv file in an editor.

The icenv file is located in the <AVAYA_IC61_HOME>/bin directory.

2. Update the existing LIBPATH variable to also include the path to Java/bin.

Example: 

3. Continue to Verifying the CLASSPATH environment variable on page 215.

Verifying the CLASSPATH environment variable

Depending on what type of system you have, go to one of the following topics:

● Solaris and AIX on page 216

● Windows on page 216

LIBPATH=${AVAYA_IC61_HOME}/Java/bin:${LIBPATH}
export  LIBPATH
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Solaris and AIX

To verify the CLASSPATH environment variable for a Solaris or AIX system:

1. Verify the CLASSPATH environment variable in the icenv file under 
<AVAYA_IC61_HOME>/bin directory. Verify that this variable has paths to the 
following jar files:

● SyncObjects.jar

● jmimebz.jar

● ipworks.jar

● eaisvr.jar

2. If not, add the paths and restart the EAI server.

3. Continue to Installing a custom integration object on page 216.

Windows

To verify the CLASSPATH environment variable for a Windows system:

1. Verify the CLASSPATH environment variable under the System Environment Variables 
has paths to the following jar files: 

● SyncObjects.jar

● jmimebz.jar

● ipworks.jar

● eaisvr.jar

2. If not, add the paths and restart the EAI server. 

Note:
Note: On Windows 2000, go to Start > Settings > Control Panel. Navigate to the 

Advanced tab, and select Environment Variables.

3. Continue to Installing a custom integration object on page 216.

Installing a custom integration object

This section includes the following topics:

● Purpose on page 217

● Where to perform this procedure on page 217

● Where to perform this procedure on page 217
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Purpose

The Avaya IC EAI server requires integration objects to exchange Get and Put Data with 
Siebel.

Related topics

For more information, see the following topics:

● Integration objects on page 100

● EAI Get and Put operations on page 497

Where to perform this procedure

Perform this procedure at the following location.

Related topic

For more information, see Siebel Tools on page 111.

Procedure

! Important:! Important:
Important: Test all changes to the Siebel object repository in a non production 

environment before deploying them in your production environment. Create 
a backup copy of the Siebel server object repository before making any 
changes using Siebel Tools.

For more information, see Working with Siebel Tools on page 167.

To install the default integration objects on the Siebel server, and import the Siebel 
integration objects from a Siebel SIF file:

1. Start Siebel Tools.

2. Select Tools > Import from Archive.

If you get a message saying that you should be connected to the local database, 
ignore it.

3. Browse to the \Integration\eai\Avaya IC EAI Objects.sif file on the integration CD, 
and click Open.

4. Make sure that Merge the object definition from the archive file with the definition 
in the repository is selected.

Interface System

Siebel Tools Siebel
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5. Click Next.

Result: The Review Conflicts and Actions window opens. This window shows the 
Siebel integration objects found in the SIF file that you will import.

6. Click Next.

The following message displays:

7. Select Yes to get Siebel to import the integration object into the database.

Note:
Note: This operation may take 5 to 20 minutes to complete.

8. Select Project from the Object Explorer located in the top-left pane.

Example:

The operation is going to modify your repository as follows:
XXXX objects will be inserted
0 objects will be deleted
0 attributes will be updated

Do you wish to proceed?
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9. Select Avaya IC in the Projects pane.

Example:

10. Select the Locked column to lock the project.

Result:
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11. You must stop the Siebel server to write to the Siebel Repository File (SRF). Do one of 
the following tasks:

Windows example:

12. From the Siebel Tools - Siebel Repository - Project List window, select Tools > 
Compile Projects.

Result: The Object Compiler window opens.

If your operating system is: Then stop Siebel services by doing the following 
steps:

Windows
Use the Windows services control panel to:
1. Select Siebel Server.
2. Select Action > Stop.

Solaris or AIX Consult the Siebel administration guide for instructions.
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13. Are you using Siebel Tools from the actual Siebel server?

14. Browse to the SRF used by the Siebel server.

Example: e:\sea752\siebsrvr\objects\enu\siebel.srf

15. Select Locked projects.

16. Click Compile.

Note:
Note: This operation may take up to 10 minutes to complete.

17. If you had to make a copy of the SRF file in Step 13 above, move the copy back to the 
Siebel server.

18. Start the Siebel server.

19. Continue to Importing the Siebel workflow on page 221.

Importing the Siebel workflow

Do one of the following procedures:

● Importing the Siebel 7.0 or 7.5 workflow on page 221

● Importing and deploying the Siebel 7.7 workflow on page 222

Importing the Siebel 7.0 or 7.5 workflow

! Important:! Important:
Important: Perform this procedure only if you have a Siebel 7.0 or 7.5.

To import the Siebel workflow:

1. Start the Siebel thin client using Internet Explorer. 

2. Log in as an administrator.

Example: SADMIN

3. From the Siebel user interface, go to the Site Map by pressing Ctrl+Shift+A.

If Then

Yes Go to Step 14.

No You may not be able to browse to the Siebel Repository File (SRF). Copy the 
SRF file found on your Siebel server (<SiebelHomeDir>\siebsrvr\objects\
enu) to a location where Siebel Tools can access this file. In the next step, 
browse to this copy.
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4. Go to Business Process Administration > Workflow Processes.

Note:
Note: If you have a Siebel 7.0 system, the path is Siebel Workflow 

Administration > Workflow Processes.

5. Click the submenu button to the left of the Query button.

Example:

6. Select Import Workflow.

7. Import the \integration\eai\Avaya IC EAI MIME.xml workflow from the Avaya IC 
integration CD.

Note:
Note: Siebel may display an error message. This is an intermittent problem. Try 

again.

8. Query for the Avaya IC EAI MIME.xml workflow.

Result: The status shows:

In Progress

9. Verify that the Avaya IC EAI MIME workflow is still selected.

10. Click Activate.

11. Continue to Activating the Siebel EAI workflow on page 223.

Importing and deploying the Siebel 7.7 workflow

Perform this procedure only if you have a Siebel 7.7.

To import and deploy the Siebel workflow:

1. Start Siebel Tools.

2. If the Workflow Process is not visible in the Siebel Object Explorer window, do the 
following steps:

a. Go to View > Options.

b. Click Object Explorer.

c. Check Workflow Process.

3. Click the Workflow Process object.

4. Right-click on the Workflow Processes window and select Import Workflow 
Process.

5. Import the \integration\Siebel 7.7\eai\Avaya IC EAI MIME.xml workflow from the 
integration CD.
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6. Query for the Avaya IC EAI MIME.xml workflow.

Result: The status shows:

In Progress

7. Right-click on the Avaya IC EAI MIME workflow that has the In Progress status.

8. Select Validate.

Result: The Validate window opens.

9. Click Start.

Result: The total tests failed should be 0.

10. Make sure the Avaya IC EAI MIME workflow with the In Progress status is selected.

11. Click Deploy.

The status changes to Completed.

12. Write down the version number of the deployed workflow.

13. Compile the SRF.

For details, see Compiling the SRF on page 264.

14. Restart Siebel.

15. Continue to Activating the Siebel EAI workflow on page 223.

Activating the Siebel EAI workflow

To activate the Siebel EAI workflow:

1. From the Siebel user interface, go to the Site Map by pressing Ctrl+Shift+A.

2. Do one of the following tasks:

● For Siebel systems earlier than 7.7, go to Business Process Administration > 
Workflow Processes.

● For Siebel 7.7, go to Administration - Business Process > Workflow 
Deployment.

3. At the Repository Workflow Processes window menu bar, click the Query button.

4. In the Name field, type:

Avaya IC EAI MIME

5. Click Go.

6. Click Activate.

7. Continue to Modifying the eai.cfg file on page 224.
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Modifying the eai.cfg file

To modify the eai.cfg file:

1. Open the eai.cfg file and add the values shown in the following table.

● For Windows, browse to <SiebelHomeDir>\siebsrvr\bin\enu\eai.cfg

● For Solaris or AIX, browse to <SiebelHomeDir>/siebsrvr/bin/enu/eai.cfg

2. Continue to Shutting down and restarting the EAI Object Manager component on 
page 224.

Shutting down and restarting the EAI Object Manager 
component

This section includes the following topics:

● Where to perform this procedure on page 224

● Procedure on page 225

Where to perform this procedure

Perform this procedure at the following location.

Related topic

For more information, see Siebel user interface on page 106.

Pane Field Value

[HTTP Services] AvayaICEAIAdapter AvayaICEAIAdapter

[AvayaICEAIAdapter]

Mode Document

Method RunProcess

Service Avaya IC Integration 
Business Service

Interface System

Siebel windows Siebel
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Procedure

You must restart a Siebel Server components for the eai.cfg file changes to take effect.

To shut down and restart the Siebel Server components:

1. From the Siebel user interface, go to the Site Map by pressing Ctrl+Shift+A.

2. Do one of the following tasks:

● For Siebel systems earlier than 7.7, go to Server Administration > Servers.

● For Siebel 7.7, go to Administration - Server Management > Components.

3. Do one of the following tasks:

● For Siebel 7.7, at the Components window menu bar, click the Query button.

● For Siebel systems earlier than 7.7, at the Components tab, click the Query button.

4. In the Component field, type:

Workflow Process Manager

5. Click Go.

! CAUTION:
CAUTION: On a production system, restarting the Siebel Server component is service 

affecting.

6. Click Shutdown.

7. Query EAI Object Manager again.

8. Select Startup. 

9. Continue to Starting the Avaya IC EAI servers on page 225.

Starting the Avaya IC EAI servers

This section includes the following topics:

● Where to perform this procedure on page 226

● Before you begin on page 226

● Procedure on page 226
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Where to perform this procedure

Perform this procedure at the following location.

Before you begin

The Avaya IC EAI servers depend on the Siebel changes that you made earlier. You must 
have successfully completed the following steps on your Siebel server:

● Installing a custom integration object on page 216

● Importing and deploying the Siebel 7.7 workflow on page 222

Procedure

To start the Avaya IC EAI servers:

1. Start the Siebel EAI servers by selecting each server in IC Manager and selecting the 
Start server icon.

Example:

The EAI servers should initialize with no alarms or problems.

2. If you encounter problems, do the following steps:

● Check your configuration for passwords, directory, host, and executable.

● Verify that the eaisrv executable is present on your server and has permissions that 
enable it to be executed.

● Check the settings and configuration you established in this section, Configuring the 
Avaya EAI servers.

3. What type of channel are you installing?

Interface System

IC Manager Avaya IC

If Then

Voice Continue to Configuring voice qualification workflows on page 161.

Web chat Continue to Configuring Web chat qualification workflows on page 229.
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Note:
Note: If you are installing more than one type of channel, perform one procedure 

at a time.

E-mail - 
Avaya-first Continue to Configuring an Avaya-first e-mail channel on page 241.

E-mail - 
Siebel-first Continue to Configuring a Siebel-first e-mail channel on page 275.

If Then
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Chapter 10:Configuring Web chat 
qualification workflows

! Important:! Important:
Important: Use these procedures only if you are installing a Web chat channel on your 

system.

The integration software includes default Web chat workflows. These default workflows will 
not work until you use these procedures to customize the workflows for your location.

This section includes the following topics:

● Building the Avaya Web chat qualification workflows on page 230

● Modifying Customer Management workflows for Web on page 232

● Configuring workflow servers to use Web chat workflows on page 234

● Installing the Web chat qualification workflow on page 236
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Building the Avaya Web chat qualification workflows
This section contains the following topics:

● Where to perform this procedure on page 230

● Procedure on page 230

Where to perform this procedure

Perform this procedure at the location shown in the following table.

Procedure

To build default Web chat workflows:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > Workflow Designer.

2. Select File > Open Project.

3. Browse to one of the following files:

● icm_sbl.prj

● wacd_sbl.prj

● webcenter_sbl.prj

Example: e:\<AVAYA_IC61_HOME>\design\IC\Flows\Siebel\ICM\icm_sbl.prj

4. Select Project > Settings.

5. Select the Database tab.

6. Type the Login Id and Password.

Result: The Project Settings window opens.

Interface System

Workflow Designer Avaya IC



Building the Avaya Web chat qualification workflows

Issue 4.0 November 2004 231

7. Are you currently building the webcenter_sbl.prj?

8. Select the Directories tab.

9. Click the New Folder button to add the Webcenter directory.

Example: e:\<AVAYA_IC61_HOME>\design\IC\Flows\Siebel\Webcenter

10. Click OK.

11. Select Build > Build Flow Set.

There should be no errors.

12. Close the project.

13. Return to Step 3 and repeat this procedure until you have added all of the workflows.

14. Exit Workflow Designer.

15. Continue to Modifying Customer Management workflows for Web on page 232.

If Then

Yes Go to Step 8.

No Go to Step 10.
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Modifying Customer Management workflows for 
Web

Use this procedure to modify the Website that uses the Siebel versions of the Customer 
Management workflows for Web. The Customer Management workflows for Web are also 
called the customer management workflows.

Where to perform this procedure

Perform this procedure at the following location.

Procedure

To modify the Customer Management workflows for Web:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC Manager.

2. Log in to IC Manager.

3. Select Services > Multi-Tenancy Administration.

You might need to select the Ic Website Multi-Tenant Administration service. You 
can also reach this page by going to http://<yourserver>/website/admin.

4. In the left navigation pane, select Tenant Properties.

5. In the right content pane select, Default Tenant.

6. Select Customize Tenant.

7. In the right content pane, select flows.

Interface System

IC Manager Avaya IC
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8. Add _sbl to every flowset and workflow.

Example:

 

9. Click Update Data.

10. Exit the Multi-Tenancy Administration windows.

11. Continue to Configuring workflow servers to use Web chat workflows on page 234.
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Configuring workflow servers to use Web chat 
workflows

To configure the Avaya IC Workflow server to run a Siebel Web chat workflow when the 
WACD.QualifyChat event is raised:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC Manager.

2. Log in to IC Manager.

3. Double-click the Workflow server for Web chats in IC Manager.

4. Select the Channels tab of the appropriate Workflow server.

5. Has Avaya IC already been configured for Web chat?

6. Select New Channel.

7. In the Channel Editor dialog box, select the values shown in the following table.

8. Click Ok.

9. Select New Association.

10. In the Channel Association dialog box, type the values shown in the following table.

If Then

Yes
An association of the WACD.QualifyChat event with a workflow already 
exists in IC Manager. Remove the existing association before continuing 
to Step 9.

No Go to Step 6.

Field Value

Service WACD

Criteria media=chat

Field Value

Event WACD.QualifyChat

Flow wacd_sbl.qualifychat_sbl



Configuring workflow servers to use Web chat workflows

Issue 4.0 November 2004 235

Note:
Note: These fields are case-sensitive.

11. Click Ok.

Result:

12. Stop and start the Workflow server if the server has already started by doing the 
following:

a. Select the Server tab on the IC Manager window.

b. Select the server from the list on the right side of the window.

c. Select the Start or Stop button in the toolbar.

13. Make sure contact routing is set up for the Web chat channel.

Reference: For more information, see one of the following documents:

● For basic information, see Avaya IC Media Workflow Reference

● For more detailed information about setting up contact routing, see IC Installation 
and Configuration

● For Business Advocate contact routing, see IC Business Advocate Configuration 
and Administration

14. Continue to Installing the Web chat qualification workflow on page 236.
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Installing the Web chat qualification workflow
The integration software uses the Transcript Added workflow to put a copy of the 
transcript-added file into Siebel through the EAI.

This section includes the following topics:

● Changing the location of the Transcript Added workflow output file on page 236

● Changing the default transcript-added XSL file on page 237

● Configuring the ICM server to run the Transcript Added workflow on page 238

Related topic

For more information, see Transcript Added workflow on page 142.

Changing the location of the Transcript Added workflow 
output file

The Transcript Added workflow generates an output file that is located by default at c:\
temp. If in your case, the workflow and the EAI servers cannot efficiently access this 
location, then you must change the default location.

Where to perform this procedure

Perform this procedure at the location shown in the following table.

Procedure

To change the default location:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > Workflow Designer.

2. Select File > Open Project.

3. Browse to the icm_sbl.prj file.

Example: c:\Avaya\IC\design\IC\flows\Siebel\IC\icm_sbl.prj

4. Double-click the transcriptadded_sbl workflow to open it.

Interface System

Workflow Designer Avaya IC
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5. Select the block labeled Process Transcript.

Result: The Property Sheet window opens.

6. Select the location you want to use in the OutputFilePath field.

Note:
Note: If you specify a Universal Naming Convention (UNC) path in the 

OutputFilePath, add an extra backslash in front of the path. For example, if 
your path is \\servername\share, type \\\servername\share. Workflow 
Designer will trim the first backslash to make \\servername\share.

7. Select Build > Build Flowset to compile and store the workflow changes.

8. Continue to Changing the default transcript-added XSL file on page 237.

Changing the default transcript-added XSL file

As described in previous sections, the Transcript Added workflow is responsible for 
building an HTML file from a raw XML transcript file using an eXtensible Stylesheet 
Language (XSL) file. If you want to change the resultant HTML file, you must change the 
XSL file.

A basic XSL file for transforming the Transcript Added workflow is installed into 
\<AVAYA_IC61_HOME>\design\IC\flows\Siebel\ICM\transcriptadded_sbl.xsl. By 
default, the Transcript Added workflow is configured to read this from the working directory 
of the Workflow server that is running the workflow. This is typically the 
<AVAYA_IC61_HOME>\etc directory.

To copy the transcriptadded_sbl.xsl file to the correct location and change the name of 
this file:

1. Copy the transcriptadded_sbl.xsl file to the <AVAYA_IC61_HOME>\etc directory.

Note:
Note: If your EAI and workflow servers are running on UNIX, use ftp to move this 

file to the UNIX system in the appropriate location.

2. Do you want to change the name of this file or use a different location?

3. Navigate to Start > Programs > Avaya Interaction Center 6.1 > Workflow Designer.

If Then

Yes To modify the XSLFileName property of the Process Transcript block, go to 
Step 3.

No Continue to Configuring the ICM server to run the Transcript Added 
workflow on page 238.
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4. Select File > Open Project.

5. Browse to the icm_sbl.prj file.

Example: c:\Avaya\IC\design\IC\flows\Siebel\IC\icm_sbl.prj

6. Select the block labeled Process Transcript.

Result: The Property Sheet window opens.

7. Enter the location you want to use in the XSLFileName field.

Note:
Note: If you want to use a location other than <AAVAYA_IC61_HOME>\etc, 

specify the fullpath here.

8. Select Build > Build Flowset to compile and store the workflow changes.

9. Continue to Configuring the ICM server to run the Transcript Added workflow on 
page 238.

Configuring the ICM server to run the Transcript Added 
workflow

Your Internet Call Manager (ICM) server should already be configured and running 
properly. If you have a more complex ICM server configuration than what is described in 
this procedure, you may need to do more than the basic steps described in this procedure.

Related topic

For more information, see IC Installation and Configuration.

Where to perform this procedure

Perform this procedure at the following location.

Procedure

To configure IC Manager to run the Transcript Added workflow:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC Manager.

2. Log in to IC Manager.

3. Select the Configuration tab.

Interface System

IC Manager Avaya IC
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4. Select Chat > ICM > icm.

These directories are located in the left navigation pane.

5. Right-click anywhere in the gray area, and select Show Advanced Properties.

6. Scroll to the bottom to reveal the Enable Transcript Added Flow and Transcript 
Added Flow Name fields.

7. Select the Enable Transcript Added Flow field.

8. In the Transcript Added Flow Name field, type:

icm_sbl.transcriptadded_sbl

9. Click Apply.

10. Restart the Avaya IC ICM Service and Website for changes to take effect.

11. Continue to Configuring a Siebel-first e-mail channel on page 275

12. What channel are you also installing?

If Then

E-mail - 
Avaya-first Continue to Configuring an Avaya-first e-mail channel on page 241.

E-mail - 
Siebel-first Continue to Configuring a Siebel-first e-mail channel on page 275.
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Chapter 11:Configuring an Avaya-first e-mail 
channel

! Important:! Important:
Important: Consider the following items:

● Use these procedures only if you are installing an e-mail channel on your 
system and you are using the Avaya-first e-mail method.

● Always refer to the latest Siebel documentation when performing any of the 
procedures that use Siebel Tools or the Siebel user interface. Avaya cannot 
guarantee the accuracy of these procedures.

● You cannot use the Avaya-first e-mail method with Siebel 7.7.

This section includes the following topics:

● Obtaining the Catalog ID from Siebel on page 242

● Building the Avaya e-mail qualification workflows on page 245

● Configuring e-mail qualification workflows on page 246

● Configuring the workflow server to start the Trigger Cleanup Transfer workflow on 
page 250

● Configuring e-mail on page 251

● Installing the AED on page 266

● Configuring Siebel for the AED on page 268

● Configuring Smart Answer Manager on page 274
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Obtaining the Catalog ID from Siebel
Beginning with 6.1.3, agents replying to e-mails can access the full list of categories 
available in the Siebel catalog. This procedure adds that functionality.

This section includes the following topics:

● Where to perform this procedure on page 242

● Before you begin on page 242

● Procedure on page 243

Where to perform this procedure

Perform this procedure at the locations shown in the following table.

Before you begin

Before you can configure Avaya IC to obtain the Catalog ID, you must obtain the Row #. To 
obtain the Row #:

1. Start the Siebel thin client using Internet Explorer.

2. From the Siebel user interface, go to the Site Map by pressing Ctrl+Shift+A.

3. Go to Catalog Administration > More Info.

4. Select the Catalog Name you want.

5. Press Ctrl+Alt+K.

Result: The About Record window opens.

6. Write down the Row # value.

Procedure Interface System

Before you begin on page 242 Siebel windows Siebel

Procedure on page 243 Workflow Designer Avaya IC
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Procedure

You need to make the changes described in this procedure only for the 
preanalyzenoca_sbl workflow.

To obtain the Catalog ID from Siebel:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > Workflow Designer.

2. From the menu bar, select File > Open Project.

3. Open the preanalyzenoca_sbl.prj file.

This workflow is located in the following directory: <AVAYA_IC_HOME>\design\IC\
Flows\Siebel\ICEmail\icemail_sbl.prj

4. Select the Get EDU Values block in the workflow you just opened.

5. Under the Basic tab on the Property Sheet window frame, set an available Field_nn 
to:

currentemail.hasattachments

6. Set the corresponding Target_nn to:

$hasattachments

Example:

This sequence couple will contain a true value if the e-mail has an attachment.

Result: The value in $hasattachments in the Get EDU Values block is used in the 
Has Attachment? test data block. The Has Attachment? block occurs later in the 
workflow.

7. Select the BuildSeqCouple block.
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8. Enter the Row # value you obtained in Step 6 of Before you begin on page 242 in the 
Value_01 property.

Result: The output from the BuildSeqCouple block is passed to the PutEmail to 
Siebel block using the variable $scOutput in the AdditionalArgs property.

Example:

9. Continue to Building the Avaya e-mail qualification workflows on page 245.
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Building the Avaya e-mail qualification workflows
This section contains the following topics:

● Where to perform this procedure on page 245

● Procedure on page 245

Where to perform this procedure

Perform this procedure at the location shown in the following table.

Procedure

To build default workflows:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > Workflow Designer.

2. Select File > Open Project.

3. Browse to one of the following files:

● icemail_sbl.prj

● wacd_sbl.prj

Example:
e:\<AVAYA_IC61_HOME>\design\IC\Flows\Siebel\ICEmail\icemail_sbl.prj

4. Go to Project > Settings.

5. Select the Database tab.

6. Type the Login Id and Password and click OK.

7. Select Build > Build Flow Set. There should be no errors.

8. Close the project.

9. Return to Step 3 and repeat this procedure for the other workflow.

10. Exit Workflow Designer and continue to Configuring e-mail qualification workflows on 
page 246.

Interface System

Workflow Designer Avaya IC
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Configuring e-mail qualification workflows
The integration software includes default e-mail workflows. These default workflows will 
not work until you customize the workflows for your location using these procedures.

To configure the Avaya IC Workflow server to run an e-mail workflow when the 
TS.IncomingCall event is raised:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC Manager.

2. Log in to IC Manager.

3. Double-click the Workflow server in IC Manager.

4. Has Avaya IC already been configured for e-mail qualification workflows?

5. Select the Channels tab of the appropriate Workflow server.

6. Select New Channel.

7. In the Channel Editor dialog box, select the values shown in the following table.

8. Click Ok.

9. Select New Channel.

10. In the Channel Editor dialog box, select the values shown in the following table.

11. Click Ok.

If Then

Yes
An association of the WACD.QualifyEmail event with a workflow already 
exists in IC Manager. Remove the existing association before continuing 
to Step 12.

No Go to Step 5.

Field Value

Service ICEmail

Criteria *

Field Value

Service WACD

Criteria media=email
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12. Select New Association.

13. In the Channel Association dialog box, type the values shown in the following table.

Note:
Note: These fields are case-sensitive.

14. Click Ok.

15. Select New Association.

16. In the Channel Association dialog box, type the values shown in the following table.

Field Values for a system without Content 
Analysis

Values for a system with Content 
Analysis

Event ICEmail.Analyze ICEmail.Analyze

Flow icemail_sbl.preanalyzenoca_sbl icemail_sbl.preanalyzeca_sbl

Field Value

Event ICEmail.OutboundEmail

Flow icemail_sbl.outboundemail_sbl
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17. Click Ok.

Result for a system without Content Analysis:

Result for a system with Content Analysis:

18. Click Ok.

19. Stop and start the Workflow server if the server has already started by doing the 
following:

a. Select the Server tab on the IC Manager window.

b. Select the server from the list on the right side of the window.

c. Select the Start or Stop button in the toolbar.
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20. To cause the ICEmail.Analyze and ICEmail.OutboundEmail events to be triggered by 
the IC Email server, select the Run Analyze Flow and the Run Outbound Email 
Flow under the Analysis tab in the IC Email server.

21. Make sure contact routing is set up for the e-mail channel.

Reference: For more information, see.

● For basic information, see Avaya IC Media Workflow Reference

● For more detailed information about setting up contact routing, see IC Installation 
and Configuration

● For Business Advocate contact routing, see IC Business Advocate Configuration 
and Administration

22. Continue to Configuring the workflow server to start the Trigger Cleanup Transfer 
workflow on page 250.
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Configuring the workflow server to start the Trigger 
Cleanup Transfer workflow

Perform the following procedure after you have completed the procedures for building and 
configuring the Avaya-first e-mail qualification workflows.

To configure the workflow server to start the Trigger Cleanup Transfer workflow:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC Manager.

2. Log in to IC Manager.

3. Double-click the e-mail Workflow server in IC Manager.

4. Select the WorkFlow tab.

5. Click the ellipsis box to the right of Startup Flows.

6. Add icemail_sbl.triggerxfercleanup_sbl to the list of startup flows.

7. Click OK.

8. Stop and start the Workflow server if the server has already started.

9. Continue to Configuring e-mail on page 251.
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Configuring e-mail
Handling e-mail is a complicated process that requires coordinated configuration between 
Siebel and Avaya IC. This section includes directions for configuring the system to handle 
e-mail.

The following components must work together in order to support the e-mail integration for 
the AICD: 

● Siebel eScript

● Siebel workflows

● Siebel agent configuration

● Adaptive E-mail Driver, if you use e-mail Content Analysis

This section includes the following topics:

● Where to perform these procedures on page 252

● Configuring the Avaya IC Resolve Status on page 253

● Activating existing Siebel workflows on page 253

● Importing new Siebel workflows on page 254

● Activating new Siebel workflows on page 255

● Creating an e-mail profile on page 255

● Adding a charset variable on page 256

● Installing eScripts and English error strings on the Siebel server on page 257

● Importing the CommOutboundItemFormApplet.js file on page 261

● Importing the CommInboundItemListApplet.js file on page 262

● Importing the SendCommunicationApplet.js file on page 263

● Compiling the SRF on page 264
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Where to perform these procedures

Perform these procedures at the following locations.

Related topics

For more information, see the following topics:

● Siebel Tools on page 111

● Siebel user interface on page 106

Procedure Interface System

Configuring the Avaya IC Resolve Status on 
page 253 IC Manager Avaya IC

Activating existing Siebel workflows on 
page 253

Siebel windows

Siebel

Importing new Siebel workflows on 
page 254

Activating new Siebel workflows on 
page 255

Creating an e-mail profile on page 255

Adding a charset variable on page 256

Installing eScripts and English error strings 
on the Siebel server on page 257

Siebel Tools

Installing localized error strings on the 
Siebel server (optional) on page 260

Importing the 
CommOutboundItemFormApplet.js file on 
page 261

Importing the 
CommInboundItemListApplet.js file on 
page 262

Importing the SendCommunicationApplet.js 
file on page 263

Compiling the SRF on page 264
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Configuring the Avaya IC Resolve Status

Although Siebel processes incoming e-mail, Avaya IC tracks the status of every e-mail. 
Resolve Status makes it possible for Avaya Agent to release e-mail work without first 
responding to the e-mail sender. Without Resolve Status, Avaya Agent will display an error 
and will not allow the agent to dismiss e-mail.

To configure the Avaya IC Resolve Status:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC Manager.

2. Log in to IC Manager.

3. Select Services > Mail Template Administration.

4. Enter the Name, Password, and Address.

The address can be either the name or the IP address of your Avaya IC server. It may 
default to your exchange server, so be sure to change it.

5. Select Login.

Result: The Response Library Configuration tool opens.

6. Click New.

7. Select New Status.

8. In the Name field, type:

Resolved

9. Select Messages set to this status should be treated as answered.

10. Click Apply.

11. Click OK.

12. Exit the Response Library Configuration tool.

13. Continue to Activating existing Siebel workflows on page 253.

Activating existing Siebel workflows

To start some of the default e-mail response workflows:

1. From the Siebel user interface, go to the Site Map by pressing Ctrl+Shift+A.

2. Go to Business Process Administration > Workflow Processes.
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3. From the Queries field in the top-right corner, type the values shown in the following 
table.

4. Click Go.

5. Under the Workflow Processes tab, select the eMail Response - Append Thread Id 
workflow, and click Revise.

Result: The status changed to In Progress.

6. Click Activate.

Result: A new entry is activated that does not display in the window. The inactive 
workflow is still displayed.

7. Repeat Steps 5 and 6 for the following workflows:

● eMail Response - Response Workflow

● eMail Response - Update Activity Status

8. Query the workflows you just activated and verify that their status is now active.

9. Continue to Importing new Siebel workflows on page 254.

Importing new Siebel workflows

To import the Siebel workflows:

1. From the Siebel user interface, go to the Site Map by pressing Ctrl+Shift+A.

2. Go to Business Process Administration > Workflow Processes.

3. Click the submenu button to the left of the Query button.

Example: 

4. Select Import Workflow.

5. Import the \Integration\Email\AvayaFirst\eMail Response - Client Send Email.xml 
workflow from the integration CD.

6. Import the Avaya IC Client Send Email.xml workflow from the integration CD.

7. Continue to Activating new Siebel workflows on page 255.

Field Type

Name eMail Response*

Status Inactive
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Activating new Siebel workflows

To activate the workflows:

1. From the Siebel user interface, go to the Site Map by pressing Ctrl+Shift+A.

2. Go to Business Process Administration > Workflow Processes.

3. Click the submenu button to the left of the Query button.

Example: 

4. Query for the newly-added workflows.

5. Click Activate.

6. Continue to Creating an e-mail profile on page 255.

Creating an e-mail profile

This section includes the following topics:

● Before you begin

● Procedure

Before you begin

The Siebel e-mail profile name must match an Avaya IC e-mail account. This account is a 
mailbox that IC Email polls for incoming e-mail. Example: ic2@leda.usae.avaya.com. 

In IC Manager, navigate to Services > Email Accounts to view the e-mail accounts. You 
will use this name in Step 7.

Note:
Note: This is not the standard usage of the Siebel e-mail profile name. Normally, 

the profile name is text and the profile attributes are used to store specific 
information, such as the From address. For this integration, the profile name 
is the From address.

Procedure

To create an e-mail profile:

1. Log in to Siebel as a Siebel administrator.

2. From the Siebel user interface, go to the Site Map by pressing Ctrl+Shift+A.
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3. Go to Administration - Communication > Communications Drivers and Profiles.

4. Under the Communications Drivers tab, select Internet SMTP/POP3 Server.

5. Select the Profiles tab at the bottom of the window.

6. Click New under the Profiles tab to create a new profile.

7. Type the Avaya IC e-mail account name in the Name field.

This field is presented in a selection list to the agent when the agent replies to an 
e-mail. In Avaya-first e-mail, Avaya IC determines the actual From address on e-mails 
handled by Avaya IC.

8. Select the ellipsis in the Responsibilities field.

The Siebel ellipsis icon is located in the upper-right corner.

Result: The Responsibilities window opens.

9. Click New.

10. Select Responsibility in the Find field.

11. Type AICD in the search field and click Go.

12. Select AICD Responsibility.

13. Click OK.

Result: The Responsibilities window displays AICD Responsibility in the 
Responsibility field.

14. Click OK.

15. Continue to Adding a charset variable on page 256.

Adding a charset variable

To add a charset variable:

1. Log in to Siebel as a Siebel administrator.

2. From the Siebel user interface, go to the Site Map by pressing Ctrl+Shift+A.

3. Go to Administration - Communication > Communications Drivers and Profiles.

4. Select the Internet SMTP/POP3 Server as the driver.

5. Under the Driver Parameters tab, click New.
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6. Add the values shown in the following table.

7. Select File > Save.

Result: The charset value displays under the Name field, and iso-8859-1 displays 
under the Default Value field.

8. Continue to Installing eScripts and English error strings on the Siebel server on 
page 257.

Installing eScripts and English error strings on the Siebel 
server

Use this procedure to:

● Install the eScripts and English error strings on the Siebel server

● Import the eScripts and English error strings from a Siebel SIF file

! Important:! Important:
Important: Test all changes to the Siebel object repository in a non production 

environment before deploying them in your production environment. Create 
a backup copy of the Siebel server object repository before making any 
changes using Siebel Tools.

For more information, see Working with Siebel Tools on page 167.

To install and import the eScripts and English error strings:

1. Start Siebel Tools.

Field Value

Name charset

Default Value iso-8859-1
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2. Select Project from the Object Explorer located in the top-left pane.

Example:

3. Select Avaya IC in the Projects pane.

Example:

4. Select the Locked column to lock the project.

Result:

5. Return to Step 2, but this time lock the User Defined Errors project.
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6. Select Tools > Import from Archive.

If you get a message saying that you should be connected to the local database, 
ignore it.

7. Browse to the \Integration\Email\AvayaFirst\AvayaFirst.sif file on the Avaya IC 
integration CD.

8. Click Open.

9. Make sure that Merge the object definition from the archive file with the definition 
in the repository is selected.

10. Click Next.

Result: The Review Conflicts and Actions window opens. This window shows the 
Siebel integration objects found in the SIF file that you will import.

11. Click Next.

The following message displays:

12. Select Yes to get Siebel to import the eScripts into the database.

Note:
Note: This operation may take 1 to 2 minutes to complete.

13. .You must stop the Siebel server to write to the Siebel Repository File (SRF). Do one of 
the following tasks:

14. From the Siebel Tools - Siebel Repository - Project List window, select Tools > 
Compile Projects.

Result: The Object Compiler window opens.

The operation is going to modify your repository as follows:
XXXX objects will be inserted
0 objects will be deleted
0 attributes will be updated

Do you wish to proceed?

If your operating system is:
Then stop Siebel services by doing the following 
steps:

Windows
Use the Windows services control panel to:
1. Select Siebel Server.
2. Select Action > Stop.

Solaris or AIX Consult the Siebel administration guide for instructions.
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15. Are you using Siebel Tools from the actual Siebel server?

16. Browse to the SRF used by the Siebel server.

Example: e:\sea752\siebsrvr\objects\enu\siebel.srf

17. Select Locked projects.

18. Click Compile.

Note:
Note: This operation may take up to 10 minutes to complete.

19. Unlock the project and exit Siebel Tools.

20. If you had to make a copy of the SRF file in Step 15 above, move the copy back to the 
Siebel server.

21. Start the Siebel server.

22. Do you want to install localized error strings?

Installing localized error strings on the Siebel server (optional)

Perform this procedure only if you need to install localized error strings on the Siebel 
server.

To install localized error strings on the Siebel server:

1. Repeat all of the steps in Installing eScripts and English error strings on the Siebel 
server on page 257 up to Step 7.

2. Instead of Step 7, browse to <SIEBEL_HOME>\siebsrvr\Siebel7.5_L10N.sif on the 
Siebel server.

If Then

Yes Go to Step 16.

No You may not be able to browse to the Siebel Repository File (SRF). Copy the 
SRF file found on your Siebel server (<SiebelHomeDir>\siebsrvr\objects\
enu) to a location where Siebel Tools can access this file. In the next step, 
browse to this copy.

If Go to

Yes Installing localized error strings on the Siebel server (optional) on 
page 260

No Importing the CommOutboundItemFormApplet.js file on page 261
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3. Repeat all the steps after Step 7.

4. Continue to Importing the CommOutboundItemFormApplet.js file on page 261.

Importing the CommOutboundItemFormApplet.js file

! Important:! Important:
Important: Test all changes to the Siebel object repository in a non production 

environment before deploying them in your production environment. Create 
a backup copy of the Siebel server object repository before making any 
changes using Siebel Tools.

For more information, see Working with Siebel Tools on page 167.

The CommOutboundItemFormApplet.js file is a Siebel eScript file. Siebel eScript is a 
JavaScript-like scripting language used with Siebel Tools, just as Siebel Visual Basic is a 
VBScript-like scripting language used with Siebel Tools.

To import the CommOutboundItemFormApplet.js file:

1. Log in to Siebel Tools.

2. In Siebel Tools, select Applet from the Object Explorer navigation pane.

The Object Explorer navigation pane is located in the upper-left corner of the window.

3. Select the Comm Outbound Item Form Applet from the Applets content pane.

The Applets content pane is located in the large right pane of the window.

4. Select Tools > Lock Project.

This allows you to make changes to this applet.

5. Right-click the Comm Outbound Item Form Applet and select Edit Server Scripts.

6. If the Scripting Language window opens, make sure that eScript is selected and click 
OK.

Result: The Script Editor window opens.

7. Select File > Import to import the eScript.
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8. Select the \Integration\Email\AvayaFirst\CommOutboundItemFormApplet.js file 
from the integration CD, and click OK.

Result: This imports the eScript. The script editor window looks like the following 
screen after import. 

 

9. Select File > Save to save the script.

10. Select File > Close.

11. Continue to Importing the CommInboundItemListApplet.js file on page 262.

Importing the CommInboundItemListApplet.js file

! Important:! Important:
Important: Test all changes to the Siebel object repository in a non production 

environment before deploying them in your production environment. Create 
a backup copy of the Siebel server object repository before making any 
changes using Siebel Tools.

For more information, see Working with Siebel Tools on page 167.

The CommInboundItemListApplet.js file is a Siebel eScript file.

To import the CommInboundItemListApplet.js file:

1. Log in to Siebel Tools.

2. In Siebel Tools, select Applet from the Object Explorer navigation pane.

The Object Explorer navigation pane is located in the upper-left corner of the window.

3. Select the Comm Inbound Item List Applet from the Applets content pane.

The Applets content pane is located in the large right pane of the window.
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4. Select Tools > Lock Project.

This allows you to make changes to this applet.

5. Right-click the Comm Inbound Item List Applet and select Edit Server Scripts.

6. If the Scripting Language window opens, make sure that eScript is selected and click 
OK.

Result: The Script Editor window opens.

7. Select File > Import to import the eScript.

8. Select the \Integration\Email\AvayaFirst\CommInboundItemListApplet.js file from 
the integration CD, and click OK.

Result: This imports the eScript. 

9. Select File > Save to save the script.

10. Select File > Close.

11. Continue to Importing the SendCommunicationApplet.js file on page 263.

Importing the SendCommunicationApplet.js file

! Important:! Important:
Important: Test all changes to the Siebel object repository in a non production 

environment before deploying them in your production environment. Create 
a backup copy of the Siebel server object repository before making any 
changes using Siebel Tools.

For more information, see Working with Siebel Tools on page 167.

The SendCommunicationApplet.js file is a Siebel eScript file.

To import the SendCommunicationApplet.js file:

1. Log in to Siebel Tools.

2. In Siebel Tools, select Applet from the Object Explorer navigation pane.

The Object Explorer navigation pane is located in the upper-left corner of the window.

3. Select the Send Communication Applet from the Applets content pane.

The Applets content pane is located in the large right pane of the window.

4. Select Tools > Lock Project.

This allows you to make changes to this applet.

5. Right-click the Send Communication Applet and select Edit Server Scripts.
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6. If the Scripting Language window opens, make sure that eScript is selected and click 
OK.

Result: The Script Editor window opens.

7. Select File > Import to import the eScript.

8. Select the \Integration\Email\AvayaFirst\SendCommunicationApplet.js file from 
the integration CD, and click OK.

Result: This imports the eScript. 

9. Select File > Save to save the script.

10. On the left side of the Siebel Tools window, expand the Siebel Objects for the Send 
Communication Applet if it is not already expanded.

11. Select Control from the Object Explorer pane.

12. Select HTML Button 3 in the Controls pane.

13. Change the property Method Invoked to AICDEmailSend.

The Properties pane is usually located in the lower-left corner of the window.

14. Select File > Save to save the script.

15. Select File > Close.

16. Continue to Compiling the SRF on page 264.

Compiling the SRF

! Important:! Important:
Important: Test all changes to the Siebel object repository in a non production 

environment before deploying them in your production environment. Create 
a backup copy of the Siebel server object repository before making any 
changes using Siebel Tools.

For more information, see Working with Siebel Tools on page 167.

After importing the eScript for both the Comm Outbound Item Form Applet, the Comm 
Inbound Item List Applet and the Send Communication Applet, you must compile 
these changes to the Siebel Repository File (SRF).

To compile the SRF file:

1. Stop Siebel services.

For Windows For Solaris/AIX

Select Control Panel > services Consult the Siebel administration guide for instructions.
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2. In Siebel Tools, select Tools > Compile Projects.

Result: The Object Compiler window opens.

3. Select Locked projects.

4. Browse to the siebel.srf file in the \siebsrvr\objects\enu directory.

Note:
Note: If Siebel Tools is not running on your Siebel server, you will have to move a 

copy of siebel.srf to the Siebel Tools server.

5. Save a copy of the original siebel.srf file before proceeding.

6. Select Compile.

7. If you used a copy of siebel.srf, move it back to the Siebel server at the following 
location:

<SiebelHome>/siebsrvr/objects/enu

8. Start the Siebel services.

9. Continue to Installing the AED on page 266.

For Windows For Solaris/AIX

Select Control Panel > services Consult the Siebel administration guide for instructions.
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Installing the AED

! Important:! Important:
Important: Use this procedure only if your system is using Content Analysis.

The Adaptive E-mail Driver (AED) is required for the Avaya IC for Siebel e-mail integration 
when you use Content Analysis.

This section includes the following topics:

● Where to perform this procedure on page 266

● Creating a Siebel AED server on page 266

Related topic

For more information about the AED, see The AED on page 96.

Where to perform this procedure

Perform this procedure on Avaya IC.

Creating a Siebel AED server

If your integration will include e-mail with content analysis, you must create a Siebel AED 
server. The AED requires that you administer a new server component using the IC 
Manager. 

To create a Siebel AED server:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC Manager.

2. Log in to IC Manager.

3. Select the Server tab, and select All Domains.

All Domains is located in the left navigation pane.

4. Select the window with the list of servers and right-click anywhere in the window.

5. Select New... from the right-click list.

6. In the Server Type field, select SiebelAED.

7. Click Ok.
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8. Enter the values shown in the following table.

9. Select the Debug tab.

10. Click the ellipsis (...) button next to the Trace Levels field.

11. Select the following fields for minimal or maximum logging.

Reference: For more information about logging levels, see Log files on page 354.

! Important:! Important:
Important: Do not set your logging level to flush for normal operating conditions. The 

flush setting slows down processes. For normal system operations, the log 
level should not be set at a level greater than usr2.

12. Click Ok to accept the trace level changes you made.

13. Click Ok to create the Siebel AED.

14. Continue to Configuring Siebel for the AED on page 268.

Field Value

Name Enter a name that identifies the AED and the Siebel host where the AED 
will reside. For example, AEDJaguar2.

Host Enter the IP address of the Siebel host where the AED will reside. Note 
that most of the other servers will have the IP address of the Avaya IC 
system. The Siebel AED server has the IP address of the Siebel host.

Port Enter a port number that does not conflict with an existing TCP/IP port on 
the Siebel host.

Domain Select Email

Directory This field is not used, but enter a valid directory name anyway.

Executable This field is not used, but enter an executable path name anyway.

Minimal Maximum

idl ● usr1
● usr2
● usr3
● usr4
● flush
● idl
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Configuring Siebel for the AED

! Important:! Important:
Important: Use this procedure only if your system is using Content Analysis.

This section shows how to configure Siebel so that Siebel will start the AED software. It 
includes the following topics:

● Where to perform these procedures on page 268

● Adding the AED as a new Communication Driver on page 268

● Creating a profile for the AED on page 269

● Creating a response group for the AED on page 270

● Associating the profile with the response group on page 270

● Adding input arguments for the response group on page 271

● Importing the Siebel workflows on page 271

● Activating the workflows on page 272

Related topic

For more information about the AED, see The AED on page 96.

Where to perform these procedures

Perform these procedures at the following location.

Related topic

For more information, see Siebel user interface on page 106.

Adding the AED as a new Communication Driver

To add the AED as a Communications Driver in Siebel:

1. Go to View > SiteMap.

Interface System

Siebel windows Siebel
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2. Go to Administration - Communication > Communications Drivers and Profiles.

3. Press Ctrl+N to create a new driver.

4. Type or select the values shown in the following table.

5. Press Ctrl+S to save the record.

6. At the bottom applet, add the driver values shown in the following table.

7. Continue to Creating a profile for the AED on page 269.

Creating a profile for the AED

To create a new profile for the AED:

1. Select the Profiles tab.

The Profiles tab is located in the middle of the window.

2. Click the New button under the Profiles tab.

Field Value

Name Type Adaptive Email Driver

Channel Type Select Email

Channel String Type AED Channel

Inbound Select Inbound

Interactive Clear

Outbound Clear

Library Name Type aed.dll

Field Value

Driver:SiebelExpireTime The default is 60 seconds.

Driver:WaitToRelogin The default is 30 seconds. This field is optional.
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3. Create a profile using the values shown in the following table.

4. Press Ctrl+S.

5. Continue to Creating a response group for the AED on page 270.

Creating a response group for the AED

To create a response group for the AED:

1. Select All Response Groups.

2. Create a new response group with the values shown in the following table.

3. Click Save.

4. Continue to Associating the profile with the response group on page 270.

Associating the profile with the response group

You must associate a profile with every response group that you create. Otherwise, Siebel 
will not start the AED. 

Field Value

Name AED Profile

Organization The name of your organization

Field Value

Name Type Avaya Email Driver

Service name Workflow Process Manager

Method Name RunProcess

Administrator Email 
Address Enter the e-mail address for the administrator.

Server CVCTICC
Use the name of the Siebel server, not the host name of the 
machine.

Startup Automatic
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To associate a profile with a response group:

1. Select the Profiles tab.

2. Click New under the Profiles tab.

The Add Communications Profiles applet opens.

3. Select AED Profile on the Add Communications Profiles screen.

Note:
Note: You created the AED Profile in section, Adding the AED as a new 

Communication Driver on page 268.

4. Click OK.

The Add Communications Profiles applet closes.

5. Press Ctrl+S.

6. Continue to Adding input arguments for the response group on page 271.

Adding input arguments for the response group

To add input arguments for the response group:

1. Select the Input Arguments tab.

2. Add the values shown in the following table.

3. Continue to Importing the Siebel workflows on page 271.

Importing the Siebel workflows

To import the Siebel workflows:

1. From the Siebel user interface, go to the Site Map by pressing Ctrl+Shift+A.

2. Do one of the following tasks:

● For Siebel 7.0, go to Siebel Workflow Administration > Workflow Processes.

● For Siebel 7.5, go to Business Process Administration > Workflow Processes.

Field Value

ProcessName Avaya IC Process Message

RowId Leave blank
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3. Click the submenu button, located on the left of the Query button.

Example:

4. Select Import Workflow.

Note:
Note: If you receive the following error message, try again or change the order of 

the workflows that you import.

5. Import these workflows from the integration CD, one at a time:

● \Integration\Email\AvayaFirst\Avaya IC Analyze Message.xml

● \Integration\Email\AvayaFirst\Avaya IC Append Thread ID.xml

● \Integration\Email\AvayaFirst\Avaya IC Set Auto Acknowledge.xml

● \Integration\Email\AvayaFirst\Avaya IC Set Auto Response.xml

● \Integration\Email\AvayaFirst\Avaya IC Update Activity Status.xml

● \Integration\Email\AvayaFirst\Avaya IC Parse Junk Email.xml

● \Integration\Email\AvayaFirst\Avaya IC Process Message.xml

● \Integration\Email\AvayaFirst\Avaya IC Identify Language.xml

6. Continue to Activating the workflows on page 272.

Activating the workflows

To activate the workflows:

1. Click Query under the Workflow Processes tab.

2. Select Avaya* in the Name field, and click Go.

3. Select one of the following workflows from the integration CD:

● Avaya IC Analyze Message.xml

● Avaya IC Append Thread Id.xml

● Avaya IC Set Auto Acknowledge.xml

● Avaya IC Set Auto Response.xml

● Avaya IC Update Activity Status.xml

This operation is not allowed when there are no records 
displayed. Please execute a query that returns at least one 
record or add a new record.
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● Avaya IC Parse Junk Email.xml

● Avaya IC Process Message.xml

● Avaya IC Identify Language.xml

4. Click Activate.

5. Repeat Steps 3 and 4 until you have activated all of the workflows.

6. Restart the Siebel services before proceeding.

7. Continue to Configuring Smart Answer Manager on page 274.
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Configuring Smart Answer Manager
The following list provides suggested actions that you can take to configure Smart Answer 
Manager:

1. Create a knowledge base.

2. Import the knowledge base.

3. Enable the Smart Answer Manager server component.

4. Administer Smart Answer Manager

As an option, add text as one of the settings in Smart Answer Administration.

5. Add one or more response templates.

6. Set the response thresholds for the categories in your knowledge base.

7. Associate templates with categories.

For the optimal configuration for your company, these steps may not be sufficient. You 
should carefully read the relevant Siebel documents to understand the capabilities and 
settings of Siebel Smart Answer Manager.

Related topics

● For basic information about Smart Answer Manager, see Smart Answer and Smart 
Answer Manager on page 112.

● For a complete description of Smart Answer Manager, see the Siebel documentation.
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Chapter 12:Configuring a Siebel-first e-mail 
channel

! Important:! Important:
Important: Consider the following items:

● Use these procedures only if you are installing an e-mail channel on your 
system and you are using the Siebel-first e-mail method.

● Always refer to the latest Siebel documentation when performing any of the 
procedures that use Siebel Tools or the Siebel user interface. Avaya cannot 
guarantee the accuracy of these procedures.

This section includes the following topics:

● Configuring the Avaya IC server on page 276

● Modifying the Send Communication Applet on page 282

● Installing eScripts and English error strings on the Siebel server on page 285

● Installing localized error strings on the Siebel server (optional) on page 289

● Importing the CommOutboundItemFormApplet.js file on page 290

● Importing the CommInboundItemListApplet.js file on page 292

● Compiling the SRF on page 293

● Starting the default Siebel workflows on page 295

● Administering the Siebel workflows on page 297

● Configuring Siebel to poll the mailbox on page 302

● Configuring Smart Answer Manager on page 306

● Enabling Communications Outbound Manager on page 307
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Configuring the Avaya IC server
This section contains the following topics:

● Where to perform these procedures on page 276

● Configuring the Avaya IC Email server on page 276

● Building the Siebel-first workflow on page 277

● Building the qualify e-mail workflows on page 277

● Creating and configuring an Avaya IC workflow on page 278

● Creating a default Email Dismiss Reason code on page 280

Where to perform these procedures

Perform these procedures in the locations shown in the following table.

Configuring the Avaya IC Email server 

To configure the Avaya IC Email server:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC Manager.

2. Log in to IC Manager.

3. Select the Server tab.

Procedure Interface System

Configuring the Avaya IC Email server on 
page 276 IC Manager

Avaya IC

Building the Siebel-first workflow on page 277
Workflow Designer

Building the qualify e-mail workflows on page 277

Creating and configuring an Avaya IC workflow on 
page 278 IC Manager

Creating a default Email Dismiss Reason code on 
page 280

You must manually 
edit the CDL file and 
use Database 
Designer to rebuild 
Avaya Agent.
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4. Select All Domains.

5. Double-click on your IC Email server to open the properties.

6. Select the Analysis tab.

7. Do the following steps:

a. Select the Run Analyze Flow field.

b. Clear the Run Outbound Email Flow field.

8. Click Apply.

9. Continue to Building the Siebel-first workflow on page 277.

Building the Siebel-first workflow

To build the Siebel-first workflow:

1. Go to Database Designer by navigating to Start > Programs > Avaya Interaction 
Center 6.1 > Workflow Designer.

2. In the Workflow Designer, open the icemail_sbl_first project file.

This file is located in:
<AVAYA_IC61_HOME>\Design\IC\flows\Siebel\icemail_sbl_first.

3. Select Project > Settings.

4. Select the Database tab.

5. Type the Login Id and Password.

6. Click OK.

7. Compile and store the workflow using Menu Build > Build Flowset.

8. Continue to Building the qualify e-mail workflows on page 277.

Building the qualify e-mail workflows

To build the Siebel-first and qualify e-mail workflows:

1. Go to Database Designer by navigating to Start > Programs > Avaya Interaction 
Center 6.1 > Workflow Designer.

2. Do one of the following tasks:

● If you use Web Automatic Call Distributor (WACD), open the wacd_sbl project file.

Example:
<AVAYA_IC61_HOME>\Design\IC\flows\Siebel\WACD\wacd_sbl
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● If you use Business Advocate, open the advocate_sbl project file.

Example:
<AVAYA_IC61_HOME>\Design\IC\flows\Siebel\Advocate\advocate_sbl

3. Select Project > Settings.

4. Select the Database tab.

5. Type the Login Id and Password.

6. Click OK.

7. Compile and store the workflow using Menu Build > Build Flowset.

8. Repeat Steps 2 and 7 if you need to build the other workflow.

9. Continue to Creating and configuring an Avaya IC workflow on page 278.

Creating and configuring an Avaya IC workflow

To create and configure an Avaya IC workflow to run the Siebel-first workflow and the 
qualify workflow:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC Manager.

2. Log in to IC Manager.

3. Select the Server tab.

4. Select All Domains.

5. If not already created, create a Workflow server to run the Siebel-first workflow. The 
server should be in the e-mail domain.

For instructions on how to create a Workflow server, see IC Installation and 
Configuration.

6. Select the Channels tab of the e-mail Workflow server.

7. Right-click and select New Channel from the list.

8. In the Channel Editor dialog box, select the values shown in the following table.

9. Click Ok.

10. Select New Association.

Field Value

Service ICEmail

Criteria *
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11. In the Channel Association dialog box, type the values shown in the following table.

Note:
Note: These fields are case-sensitive.

12. Click Ok.

13. Select the Channels tab of the e-mail Workflow server.

14. Right-click and select New Channel from the list.

15. In the Channel Editor dialog box, select the values shown in the following table.

16. Click Ok.

17. Select New Association for this service.

18. In the Channel Association dialog box, type the values shown in the following tables.

● If you use Business Advocate:

● If you do not use Business Advocate:

Note:
Note: These fields are case-sensitive.

Field Value

Event ICEmail.Analyze

Flow icemail_sbl_first.analyze_sbl

Field Value

Service WACD

Criteria media=email

Field Value

Event WACD.QualifyEmail

Flow advocate_sbl.qualifyemail_adv_sbl

Field Value

Event WACD.QualifyEmail

Flow wacd_sbl.qualifyemail_sbl
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19. Click Ok.

20. Click Apply.

21. Stop and start the Workflow server if the server has already started by doing the 
following:

a. Select the Server tab on the IC Manager window.

b. Select the server from the list on the right side of the window.

c. Select the Start or Stop button in the toolbar.

22. Continue to Creating a default Email Dismiss Reason code on page 280.

Creating a default Email Dismiss Reason code

This section includes the following topics:

● About creating a default Email Dismiss Reason code on page 280

● The Email Dismiss Reason setting in the CDL file on page 280

● Creating a new Resolve Status in the Email Response Library on page 281

About creating a default Email Dismiss Reason code

A default reason code is used for every e-mail handled by Avaya Agent. Although Siebel 
handles the presentation of the e-mail to the agent, Avaya IC actually tracks the status of 
every e-mail. When the agent finishes composing the e-mail and selects the Release Work 
button from the Siebel toolbar, the agent may see an Email Dismiss Reason code dialog. 
The presentation of the reason code dialog depends on the following conditions:

● If the agent releases an e-mail without replying to it, Avaya Agent provides the agent 
with a list of e-mail dismiss reasons.

● If the agent sent an e-mail reply, Avaya Agent automatically uses the Email Dismiss 
Reason code configured in the CDL file. The Email Dismiss Reason code dialog is not 
presented to the agent.

It is important that the Email Dismiss Reason code in the CDL file agrees with a Resolve 
Status configured in the Email Response Library. Use the procedures in this section to 
configure the CDL file and create a new Resolve Status in the Email Response Library.

The Email Dismiss Reason setting in the CDL file

The Email Dismiss Reason code shown in the following figure is used when an agent 
replies to an e-mail. You can also configure different reason codes besides Replied, as 
long as you also configure these reason codes in the Email Response Library.
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If you want to use the following setting in the CDL file, create a status for this file in the 
Email Response Library using the procedure in Creating a new Resolve Status in the Email 
Response Library on page 281.

Creating a new Resolve Status in the Email Response Library

To create a new Avaya IC Resolve Status in the Email Response Library:

1. Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC Manager.

2. Log in to IC Manager.

3. Select Services > Mail Template Administration.

4. Enter the Name, Password, and Address.

The address can be either the name or the IP address of your Avaya IC server. It may 
default to your exchange server, so be sure to change it.

5. Select Login.

Result: The Response Library Configuration tool opens.

6. Click New.

7. Select New Status.

8. Type in the Name, and select Messages set to this status should be treated as 
answered.

Note:
Note: The Name must be the same as the Email Dismiss Reason that was in the 

CDL file.

9. Click Apply.

10. Click OK.

11. Exit the Response Library Configuration tool.

12. In order for the change to take effect, rebuild the Avaya Agent design. Go to 
Generating the Windows application on page 175. Select only Avaya Agent Layout in 
Step 3.

13. Continue to Modifying the Send Communication Applet on page 282.

<QSection Name="Siebel"
UserNameFieldname="SWEUserName"
PasswordFieldname="SWEPassword"
LoginOnClickCommand="SWEExecuteLogin"
SiebelFirstEmailDismissReason="Replied"
/>
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Modifying the Send Communication Applet

! Important:! Important:
Important: Use this procedure only if you have an Avaya-first e-mail method and are 

changing to a Siebel-first e-mail method. Otherwise, continue to Installing 
eScripts and English error strings on the Siebel server on page 285.

! Important:! Important:
Important: In order for agents to send new outbound e-mail using the Siebel toolbar, 

you must configure the Siebel Enterprise Server with the appropriate 
Siebel-provided mechanism.

For more information, see the Siebel documentation.

This section includes the following topics:

● Removing eScripts on page 282

● Changing the Invoke Method on the Send button on page 284

Perform these procedures at the following location.

Removing eScripts

! Important:! Important:
Important: Test all changes to the Siebel object repository in a non production 

environment before deploying them in your production environment. Create 
a backup copy of the Siebel server object repository before making any 
changes using Siebel Tools.

For more information, see Working with Siebel Tools on page 167.

To remove the eScripts:

1. Start Siebel Tools.

2. From the Object Explorer pane, select the Types tab.

Interface System

Siebel Tools Siebel



Modifying the Send Communication Applet

Issue 4.0 November 2004 283

3. Select Applet under the Siebel Objects folder.

Example:

4. From the Applets pane, select Send Communication Applet.

5. In the Object Explorer pane, expand Applet, and select Applet Server Script.

If there is no Applet Server Script node, add it to the view by doing the following 
steps:

a. Select View > Options.

Result: The Development Tools Options window opens.

b. Select the Object Explorer tab.

c. Expand the Applet node of the Object Explorer Hierarchy.

d. Check the box for Applet Server Scripts.

e. Click OK.

6. Right-click in the Applet Server Scripts pane and delete the records.

Result: There should not be any records in the Applet Server Scripts pane.

7. Continue to Changing the Invoke Method on the Send button on page 284.
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Changing the Invoke Method on the Send button

! Important:! Important:
Important: Test all changes to the Siebel object repository in a non production 

environment before deploying them in your production environment. Create 
a backup copy of the Siebel server object repository before making any 
changes using Siebel Tools.

For more information, see Working with Siebel Tools on page 167.

To change the Invoke Method on the Send button:

1. On the left-side of the Siebel Tools window, if it is not already expanded, expand the 
tree node Siebel > Objects > Applets for the Send Communication Applet.

2. Open Control.

3. Select HTML Button3.

4. Change the Method Invoked property from AICDEmailSend to EmailSend.

5. Continue to Installing eScripts and English error strings on the Siebel server on 
page 285.
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Installing eScripts and English error strings on the 
Siebel server

Use this procedure to:

● Install eScripts and English error strings on the Siebel server

● Import eScripts and English error strings from a Siebel SIF file

! Important:! Important:
Important: Test all changes to the Siebel object repository in a non production 

environment before deploying them in your production environment. Create 
a backup copy of the Siebel server object repository before making any 
changes using Siebel Tools.

For more information, see Working with Siebel Tools on page 167.

To install and import the eScripts and English error strings:

1. Start Siebel Tools.

2. Select Project from the Object Explorer located in the top-left pane.

Example:
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3. Select Avaya IC in the Projects pane.

Example:

4. Select the Locked column to lock the project.

Result:

5. Return to Step 2, but this time lock the User Defined Errors project.

6. Select Tools > Import from Archive.

If you get a message saying that you should be connected to the local database, 
ignore it.

7. Browse to one of the following files on the Avaya IC integration CD.

8. Click Open.

Siebel 
version

Browse to

7.0 \Integration\sea704\Email\SiebelFirst\SiebelFirst.sif

7.5 \Integration\Email\SiebelFirst\SiebelFirst.sif

7.7 \Integration\Siebel 7.7\Email\SiebelFirst\SiebelFirst.sif
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9. Make sure that Merge the object definition from the archive file with the definition 
in the repository is selected.

10. Click Next.

Result: The Review Conflicts and Actions window opens. This window shows the 
Siebel integration objects found in the SIF file that you will import.

11. Click Next.

The following message displays:

12. Select Yes to get Siebel to import the eScripts and English error strings into the 
database.

Note:
Note: This operation may take 1 to 2 minutes to complete.

13. .You must stop the Siebel server to write to the Siebel Repository File (SRF). Do one of 
the following tasks:

14. From the Siebel Tools - Siebel Repository - Project List window, select Tools > 
Compile Projects.

Result: The Object Compiler window opens.

The operation is going to modify your repository as follows:
XXXX objects will be inserted
0 objects will be deleted
0 attributes will be updated

Do you wish to proceed?

If your operating system is: Then stop Siebel services by doing the following 
steps:

Windows
Use the Windows services control panel to:
1. Select Siebel Server.
2. Select Action > Stop.

Solaris or AIX Consult the Siebel administration guide for instructions.
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15. Are you using Siebel Tools from the actual Siebel server?

16. Browse to the SRF used by the Siebel server.

Example: e:\sea752\siebsrvr\objects\enu\siebel.srf

17. Select Locked projects.

18. Click Compile.

Note:
Note: This operation may take up to 10 minutes to complete.

19. Unlock the project and exit Siebel Tools.

20. If you had to make a copy of the SRF file in Step 15 above, move the copy back to the 
Siebel server.

21. Start the Siebel server.

22. Do you want to install localized error strings?

If Then

Yes Go to Step 16.

No You may not be able to browse to the Siebel Repository File (SRF). Copy the 
SRF file found on your Siebel server (<SiebelHomeDir>\siebsrvr\objects\
enu) to a location where Siebel Tools can access this file. In the next step, 
browse to this copy.

If Go to

Yes Installing eScripts and English error strings on the Siebel server on 
page 285

No Importing the CommOutboundItemFormApplet.js file on page 290
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Installing localized error strings on the Siebel server 
(optional)

Perform this procedure only if you need to install localized error strings on the Siebel 
server.

Note:
Note: Localized error strings are supported only in Siebel 7.5 and later.

To install localized error strings on the Siebel server:

1. Repeat all of the steps in Installing eScripts and English error strings on the Siebel 
server on page 285 up to Step 7.

2. Instead of Step 7, browse to one of the following files on the Siebel server.

3. Repeat all of the steps after Step 7.

4. Continue to Importing the CommOutboundItemFormApplet.js file on page 290.

Siebel 
version

Browse to

7.5 <SIEBEL_HOME>\siebsrvr\Siebel7.5_L10N.sif

7.7 <SIEBEL_HOME>\siebsrvr\Siebel7.7_L10N.sif
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Importing the CommOutboundItemFormApplet.js file

! Important:! Important:
Important: Test all changes to the Siebel object repository in a non production 

environment before deploying them in your production environment. Create 
a backup copy of the Siebel server object repository before making any 
changes using Siebel Tools.

For more information, see Working with Siebel Tools on page 167.

The CommOutboundItemFormApplet.js file is a Siebel eScript file. Siebel eScript is a 
JavaScript-like scripting language used with Siebel Tools, just as Siebel Visual Basic is a 
VBScript-like scripting language used with Siebel Tools.

To import the CommOutboundItemFormApplet.js file:

1. Log in to Siebel Tools.

2. In Siebel Tools, select Applet from the Object Explorer navigation pane.

The Object Explorer navigation pane is located in the upper-left corner of the window.

3. Select the Comm Outbound Item Form Applet from the Applets content pane.

The Applets content pane is located in the large right pane of the window.

4. Select Tools > Lock Project.

This allows you to make changes to this applet.

5. Right-click the Comm Outbound Item Form Applet and select Edit Server Scripts.

6. If the Scripting Language window opens, make sure that eScript is selected and click 
OK.

Result: The Script Editor window opens.

7. Select File > Import to import the eScript.

8. Do one of the following tasks:

● For a Siebel system earlier than 7.7, select the \Integration\Email\SiebelFirst\
CommOutboundItemFormApplet.js file from the integration CD.

● For Siebel 7.7, select the \Integration\Siebel7.7\Email\SiebelFirst\
CommOutboundItemFormApplet.js file from the integration CD.
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9. Click OK.

Result: This imports the eScript. The script editor window looks like the following 
screen after import. 

 

10. Select File > Save to save the script.

11. Select File > Close.

12. Continue to Importing the CommInboundItemListApplet.js file on page 292.
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Importing the CommInboundItemListApplet.js file

! Important:! Important:
Important: Test all changes to the Siebel object repository in a non production 

environment before deploying them in your production environment. Create 
a backup copy of the Siebel server object repository before making any 
changes using Siebel Tools.

For more information, see Working with Siebel Tools on page 167.

To import the CommInboundItemListApplet.js file:

1. Log in to Siebel Tools.

2. In Siebel Tools, select Applet from the Object Explorer navigation pane.

The Object Explorer navigation pane is located in the upper-left corner of the window.

3. Select the Comm Inbound Item List Applet from the Applets content pane.

The Applets content pane is located in the large right pane of the window.

4. Select Tools > Lock Project.

This allows you to make changes to this applet.

5. Right-click the Comm Inbound Item List Applet and select Edit Server Scripts.

6. If the Scripting Language window opens, make sure that eScript is selected and click 
OK.

Result: The Script Editor window opens.

7. Select File > Import to import the eScript.

8. Do one of the following tasks:

● For a Siebel system earlier than 7.7, select the \Integration\Email\SiebelFirst\
CommInboundItemListApplet.js file from the integration CD.

● For Siebel 7.7, select the \Integration\Siebel7.7\Email\SiebelFirst\
CommInboundItemListApplet.js file from the integration CD.

9. Click OK.

Result: This imports the eScript. 

10. Select File > Save to save the script.

11. Select File > Close.

12. Continue to Compiling the SRF on page 293.
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Compiling the SRF

! Important:! Important:
Important: Test all changes to the Siebel object repository in a non production 

environment before deploying them in your production environment. Create 
a backup copy of the Siebel server object repository before making any 
changes using Siebel Tools.

For more information, see Working with Siebel Tools on page 167.

After importing the eScript for both the Comm Outbound Item Form Applet, the Comm 
Inbound Item List Applet and the Send Communication Applet, you must compile 
these changes to the Siebel Repository File (SRF).

To compile the SRF file:

1. Stop Siebel services.

2. In Siebel Tools, select Tools > Compile Projects.

Result: The Object Compiler window opens.

3. Select Locked projects.

4. Browse to the siebel.srf file in the \siebsrvr\objects\enu directory.

Note:
Note: If Siebel Tools is not running on your Siebel server, you will have to move a 

copy of siebel.srf to the Siebel Tools server.

5. Save a copy of the original siebel.srf file before proceeding.

6. Select Compile.

7. If you used a copy of siebel.srf, move it back to the Siebel server at the following 
location:

<SiebelHome>/siebsrvr/objects/enu

8. Start the Siebel services.

For Windows For Solaris/AIX

Select Control Panel > services Consult the Siebel administration guide for instructions.

For Windows For Solaris/AIX

Select Control Panel > services Consult the Siebel administration guide for instructions.
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9. Do one of the following tasks:

● For Siebel 7.7, continue to Administering the Siebel workflows on page 297.

● For earlier versions of Siebel, continue to Starting the default Siebel workflows on 
page 295.
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Starting the default Siebel workflows

! Important:! Important:
Important: You only need to perform this procedure if your version of Siebel is earlier 

than 7.7. If you have Siebel 7.7, continue to Administering the Siebel 
workflows on page 297.

To start some of the default e-mail response workflows:

1. From the Siebel user interface, go to the Site Map by pressing Ctrl+Shift+A.

2. Do one of the following tasks:

● For Siebel 7.0, go to Siebel Workflow Administration > Workflow Processes.

● For Siebel 7.5, go to Business Process Administration > Workflow Processes.

3. Click the Query button in the Workflow Process window.

4. In the following fields, enter these values.

5. Click Go.

6. Under the Workflow Processes tab, select the eMail Response - Append Thread Id 
workflow, and select Revise.

Result: The status changed to In Progress.

7. Click Activate.

Result: A new entry is activated that does not display in the window. The inactive 
workflow is still displayed.

8. Repeat Steps 6 and 7 for the following workflows:

● eMail Response - Create Activity

● eMail Response - Get Entitlement Id

● eMail Response - Identify Language

● eMail Response - Parse Junk Email

● eMail Response - Response Workflow

● eMail Response - SR Help

● eMail Response - Send Acknowledgement

Field Action

Name Type eMail Response* 

Status Select Inactive
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● eMail Response - Send Auto Response

● eMail Response - Update Activity Status

9. Continue to Administering the Siebel workflows on page 297.
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Administering the Siebel workflows
This section includes the following topics:

● Administering workflows for Siebel 7.0 and 7.5 on page 297

● Administering workflows for Siebel 7.7 on page 298

● Activating the Siebel workflows on page 300

Perform these procedures at the following location.

Administering workflows for Siebel 7.0 and 7.5

! Important:! Important:
Important: Perform this procedure only if you have Siebel 7.0 or 7.5.

Entering the Avaya e-mail address

To enter the Avaya e-mail address in the eMail Response - Process Message workflow:

1. From the Siebel user interface, go to the Site Map by pressing Ctrl+Shift+A.

2. Do one of the following tasks:

● For a Siebel 7.0 system, go to Siebel Workflow Administration > Workflow 
Processes.

● For a Siebel 7.5 system, go to Business Process Administration > Workflow 
Processes.

3. From the Queries field in the top-right corner, query for:

● Name = eMail Response* 

● Status = In Progress

4. If the workflow status is Active, select Revise to change the status to In Progress.

5. Select eMail Response - Process Message.

6. Select the Process Properties tab.

7. Query for Avaya Email Address. 

Interface System

Siebel Tools Siebel
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8. In the Default String field, type in the mailbox that is being polled by Avaya IC.

Example: sales@xyz.com

9. Press Ctrl+S to save the record.

10. Return to the previous screen by selecting the All Process tab.

11. Continue to Activating the Siebel workflows on page 300.

Administering workflows for Siebel 7.7

! Important:! Important:
Important: Perform the procedures in this section only if you have Siebel 7.7.

This section contains the following topics:

● Importing the Siebel 7.7 workflows on page 298

● Entering the Avaya e-mail address on page 299

● Deploying the imported Siebel 7.7 workflows on page 299

● Activating the Siebel workflows on page 300

Importing the Siebel 7.7 workflows

To import the Siebel workflows:

1. Start Siebel Tools.

2. If the Workflow Process is not visible in the Siebel Object Explorer window, do the 
following steps:

a. Go to View > Options.

b. Click Object Explorer.

c. Check Workflow Process.

3. Click the Workflow Process object.

4. Right-click anywhere on the Workflow Processes window and select Import 
Workflow Process.

5. Import the \integration\Siebel 7.7\Email\Siebel First\eMail Response - Analyze 
Message.xml workflow from the integration CD.

6. Query for the eMail Response - Analyze Message workflow.

Result: The status shows:

In Progress
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7. Right-click on the eMail Response - Analyze Message workflow with the In Progress 
status.

8. Select Validate.

Result: The Validate window opens.

9. Click Start.

Result: The total tests failed should be 0.

10. Repeat Steps 4 through 9 for the following workflows:

! Important:! Important:
Important: Write down the version number of the imported workflows.

● eMail Response - Process Message.xml

● eMail Response - Route Avaya.xml

● eMail Response - Route Email.xml

● eMail Response - Client Send Email.xml

11. Continue to Entering the Avaya e-mail address on page 299.

Entering the Avaya e-mail address

To enter the Avaya e-mail address in the eMail Response - Process Message workflow:

1. Query the eMail Response - Process Message workflow with the In Progress status.

2. Expand the Workflow Process Siebel Object in the Object explorer.

3. Select WF Process Prop.

Result: The WF Process Prop window opens.

4. Query for Avaya Email Address. 

5. In the Default String field, type in the mailbox that is being polled by Avaya IC.

Example: sales@xyz.com

6. Press Ctrl+S to save the record.

7. Continue to Deploying the imported Siebel 7.7 workflows on page 299.

Deploying the imported Siebel 7.7 workflows

To deploy the imported Siebel workflows:

1. Query the eMail Response - Analyze Message workflow with the In Progress status.

2. Make sure that the workflow is the same version that was imported in previous steps.

3. Click Deploy.
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4. Repeat Steps 1 through 3 for the following workflows:

● eMail Response - Process Message.xml

● eMail Response - Route Avaya.xml

● eMail Response - Route Email.xml

● eMail Response - Client Send Email.xml

5. Compile the SRF and restart Siebel.

For more information, see Compiling the SRF on page 293.

6. Continue to Activating the Siebel workflows on page 300.

Activating the Siebel workflows

To activate the Siebel workflows:

1. Log in to the Siebel thin client.

2. From the Siebel user interface, go to the Site Map by pressing Ctrl+Shift+A.

3. Do one of the following tasks:

● For a Siebel system earlier than 7.7, go to Business Process Administration > 
Workflow Processes.

● For Siebel 7.7, go to Administration - Business Process > Workflow 
Deployment.

4. Click the Query button in the Repository Workflow Process window.

5. In the Name field, type:

eMail Response *

6. Select eMail Response - Analyze Message.

7. Click Activate.

8. Repeat Steps 6 through 7 for the following workflows:

● eMail Response - Append Thread Id

● eMail Response - Create Activity

● eMail Response - Client Send Email.xml

● eMail Response - Get Entitlement Id

● eMail Response - Identify Language

● eMail Response - Parse Junk Email

● eMail Response - Process Message.xml

● eMail Response - Response Workflow
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● eMail Response - Route Avaya.xml

● eMail Response - Route Email.xml

● eMail Response - SR Help

● eMail Response - Send Acknowledgement

● eMail Response - Send Auto Response

● eMail Response - Update Activity Status

9. Continue to Configuring Siebel to poll the mailbox on page 302.
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Configuring Siebel to poll the mailbox
This section includes the following topics:

● Where to perform these procedures on page 302

● Creating a profile on page 302

● Creating a response group on page 303

● Associating the profile with the response group on page 304

● Adding input arguments for the response group on page 304

Where to perform these procedures

Perform these procedures at the following location.

Creating a profile

To create a profile:

1. From the Siebel user interface, go to the Site Map by pressing Ctrl+Shift+A.

2. Do one of the following tasks:

● For a Siebel system earlier than 7.7, go to Communications Administration > 
Communications Drivers and Profile.

● For Siebel 7.7, go to Administration - Communications > Communications 
Drivers and Profile.

3. Select Internet SMTP/POP3 Server in the Name field of the Communications 
Drivers window.

4. Select the Profiles tab located below the Communications Drivers window.

5. Create a new profile by selecting New.

6. In the Name field, type:

Siebel First Email Response

Interface System

Siebel windows Siebel
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7. In the Profile Parameters Overrides, select New to add the following parameter 
overrides.

8. Continue to Creating a response group on page 303.

Creating a response group

To create a response group:

1. Select All Response Groups located directly under the Administration - 
Communications tab.

2. Click New in the Response Groups window.

3. Create a new response group with the values shown in the following table.

4. Press Ctrl+S.

Name Value

From Address Enter the mailbox where you want Siebel to poll for new 
e-mails.

POP3 Account Name Enter the account name of the mailbox.

POP3 Account Password Enter the account password.

POP3 Server Enter the POP3 server.

PollingInterval Enter the interval time in seconds that you want Siebel to 
check the mailbox.

SMTP Server Enter the SMTP server.

Field Value

Name Siebel First Email Response

Service Name Workflow Process Manager

Method Name RunProcess

Administrator Email 
Address Enter the e-mail address for the administrator.

Server Use the name of the Siebel server, not the host name of the 
machine.

Startup Automatic
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5. Continue to Associating the profile with the response group on page 304.

Associating the profile with the response group

You must associate a profile with every response group that you create. 

To associate a profile with a response group:

1. Select the Profiles tab located under the Response Groups window.

2. Click New under the Profiles tab.

The Add Communication Profiles applet opens.

3. Select the name of your Siebel-first e-mail profile.

Example: Siebel First Email Response

4. Click OK.

The Add Communications Profiles applet closes.

5. Press Ctrl+S.

6. Continue to Adding input arguments for the response group on page 304.

Adding input arguments for the response group

To add input arguments for the response group:

1. Select the Input Arguments tab.

2. Click New.



Configuring Siebel to poll the mailbox

Issue 4.0 November 2004 305

3. Add the values shown in the following table.

4. Restart Siebel services by doing one of the following tasks:

5. Continue to Configuring Smart Answer Manager on page 306.

In the Name field Enter the following values in the Value field

ProcessName eMail Response - Process Message

Catalog Name

● If you are configuring the AED and Smart Answer Manager, 
enter the name of your knowledge base. Example: KB

● If you are not configuring the AED and Smart Answer 
Manager, leave this field blank.

Enable Avaya 
Integration TRUE

Enable Smart 
Answer

● If you are configuring the AED and Smart Answer Manager, 
select TRUE.

● If you are not configuring the AED and Smart Answer 
Manager, select FALSE.

RowId Leave blank

For Windows For Solaris/AIX

Select Control Panel > services Consult the Siebel administration guide for 
instructions.
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Configuring Smart Answer Manager
The following list provides suggested actions that you can take to configure Smart Answer 
Manager:

1. Create a knowledge base.

2. Import the knowledge base.

3. Enable the Smart Answer Manager server component.

4. Administer Smart Answer Manager

As an option, add text as one of the settings in Smart Answer Administration.

5. Add one or more response templates.

6. Set the response thresholds for the categories in your knowledge base.

7. Associate templates with categories.

For the optimal configuration for your company, these steps may not be sufficient. You 
should carefully read the relevant Siebel documents to understand the capabilities and 
settings of Siebel Smart Answer Manager.

Related topics

● For basic information about Smart Answer Manager, see Smart Answer and Smart 
Answer Manager on page 112.

● For a complete description of Smart Answer Manager, see the Siebel documentation.
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Enabling Communications Outbound Manager
This section contains the following topics:

● Where to perform these procedures on page 307

● Procedure on page 307

Where to perform these procedures

Perform these procedures at the location shown in the following table.

Related topic

For more information, see Siebel user interface on page 106.

Procedure

To enable the Comm Outbound Manager:

1. From the Siebel user interface, go to the Site Map by pressing Ctrl+Shift+A.

2. Do one of the following tasks:

● For a Siebel system earlier than 7.7, go to Server Administration > Enterprise 
Configuration.

● For Siebel 7.7, go to Administration - Server Configuration > Enterprises > 
Synchronize.

3. Do one of the following tasks:

● If your Siebel system is earlier than 7.7, select the Batch Component Admin tab.

If there are no records in this applet, select Synchronize. The screen refresh may 
take a few minutes.

● If you have a Siebel 7.7 system, select Synchronize.

4. Select the Query button and search for the Communications Outbound Manager 
component.

Interface System

Siebel windows Siebel
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5. If the Communications Outbound Manager component is not enabled, see the 
Siebel documentation to enable this component.

6. Restart the Siebel services that are on the Siebel server by doing one of the following 
tasks.

For Windows For Solaris/AIX

Select Control Panel > services Consult the Siebel administration guide for 
instructions.
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Chapter 13:Customizing open data and 
events

This section includes the following topics:

● Event parameters vs. open data on page 310

● About open data on page 311

● How open data is passed on page 313

● Assigning a workflow to monitor AICD open data changes on page 316

● Customizing events on page 318
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Event parameters vs. open data
You can use either customizable Siebel event parameters or open data to configure your 
system.

Customizable Siebel event parameters have an advantage over open data; Siebel event 
parameters can pass any EDU data that was previously written to the EDU by an Avaya IC 
server or Avaya IC workflow. Whereas open data can pass only data contained in the 
siebel.data.attachments EDU container.

Open data has the following advantages over customizable Siebel event parameters:

● The Siebel definition file can write open data to the EDU.

● The NewOpenData command can pass data after the agent receives the work item.

Related topics

For more information, see the following topics:

● About open data on page 311

● About events on page 458
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About open data
This section includes the following topics:

● Definition of open data on page 311

● Open data example on page 311

● Open data and the EDU container on page 312

● Open data requirements on page 312

Definition of open data

The AICD can pass data between Avaya IC workflows and the Siebel Communications 
Server without using or analyzing the content of the data being passed. The AICD is only a 
conduit through which the data passes. This type of data is known as open data. Open 
data stays associated with the work item as the system moves the work item between 
agents and Avaya IC workflows.

Open data is allowed on any command that causes work to be delivered to an agent. 
MuteTransferWork, InitConferenceCall, and MakeCall are examples of this type of 
command. Open data can be delivered with events that indicate that an agent is receiving 
new work. OnNewWorkItem and OnCallIncoming are examples of this type of event.

Open data example

The Siebel Bookmark is a Siebel mechanism that transfers a Siebel view from one Siebel 
agent to another agent so that both agents can see the same customer information. This 
work item transfer works as follows:

1. The Siebel Bookmark is passed to the AICD as open data, along with the driver 
command used to transfer the work item.

2. The AICD passes the open data, or Bookmark, to the Siebel event handler for the 
receiving agent.

3. The event handler uses the Bookmark to pop the Siebel screen.
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Open data and the EDU container

Whatever is in the siebel.data.attachments EDU container is passed to the Siebel 
Communication server when certain events are triggered. Likewise, any unrecognized 
parameters are copied to siebel.data.attachments when certain commands are called.

In order to accommodate specific customer needs, you can use the 
siebel.data.attachments EDU container with a customized definition file. For example, the 
container can provide an Avaya IC workflow with special processing instructions.

Open data requirements

Open data requirements are shown in the following table.

Related topic

For information about EDU container syntax restrictions, see the Avaya IC Electronic Data 
Unit Server Programmer Guide.

Key-value 
parameter Requirements

Key

● Must be an ASCII string
● Must be a string containing between 1 and 34 characters
● May contain any lowercase letters, uppercase letters, digits, or the 

underscore (_) character
● Names are case-sensitive
● Must conform to EDU container syntax restrictions
● Cannot contain the following parameter names because they 

conflict with standard command parameters:
- ActivityID
- AgentExtension
- AgentID
- Destination
- TrackingID
- SuppressUAD

Value
● Must be any string. The string size is limited only by the memory 

restrictions of the servers.
● Any character except the null character (í\0í) is legal
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How open data is passed
Open data passes data:

● From Avaya IC workflows to the Siebel Communication server on page 313

● From the Siebel Communications Server to the Avaya IC workflows on page 315

● Between agent desktops on page 315

From Avaya IC workflows to the Siebel Communication server

The Avaya IC workflows may place any key-value pair in the siebel-data-attachments EDU 
container and pass it as open data on certain AICD events. This data can be passed on to 
other events as well.

For example, Avaya IC workflows can specify what Siebel screen is popped to the Siebel 
agent. The workflow may specify the following EDU names with the appropriate values:

● siebel.data.attachments.viewID

● siebel.data.attachments.rowID

When the work is delivered to the Siebel agent, the OnNewWorkItem event includes the 
following parameters: 

● name: viewID value: <value>

● name: rowID value: <value>

Notice that these parameters are not standard with the OnNewWorkItem event, and were 
only included because they were in the siebel.data.attachments EDU container. You must 
customize the definition file to expect this data and to interact with Siebel to get the 
intended result.

Example scenario: Siebel screen pop controlled by Avaya IC workflow

This example describes how open data is used to allow an Avaya IC workflow to control 
the Siebel screen pop. However, you may want to configure your Siebel screen pops 
differently. This example only describes a Siebel single view screen pop and does not 
show a Siebel multi-view screen pop.

You can hard code all the necessary combinations of Siebel View Name, Siebel BusObj 
Name, and Siebel BusComp Name under separate event responses in the definition file, 
then select one of the event responses for a particular screen pop based on an open data 
parameter such as viewID.

Before the contact is routed, an Avaya IC workflow places the following names into the 
EDU Open Data container with appropriate values:
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● siebel.data.attachments.viewID

● siebel.data.attachments.rowID

Example parameters

If the EDU contains the name siebel.data.attachments.viewID with the value 
ContactRecordPop, the following key-value parameter is passed to the Siebel 
Communication server in the OnNewWorkItem event.

Example definition file excerpt

This is an example of a definition file with hard-coded example parameters.

This technique requires careful coordination between the Avaya IC workflow that may find 
or create the Siebel record using EAI, and the definition file that does a screen pop of the 
Siebel record. The viewID is used to select the correct event handler and the rowID is used 
to select the particular Siebel record. Also, the Avaya IC workflow must detect and resolve 
instances when multiple records are found in Siebel. For example, when multiple records 

Key-value parameter

Key viewID

Value ContactRecordPop

; Event Handler for Contact Record Pop
[EventHandler:XXXX]

DeviceEvent="OnNewWorkItem"
Filter.viewID="ContactRecordPop"
Filter.rowID="?*"
Response="OnNewWorkItem_ContactRecordPop"

EventResponse:OnNewWorkItem_ContactRecordPop]
QueryBusObj   = "Contact"
QueryBusComp  = "Contact"
QuerySpec     = "Id = '{rowID}'"
SingleView    = "Contact Detail View"

; Event Handler for Email Pop
[EventHandler:YYYY]

DeviceEvent="OnNewWorkItem"
Filter.viewID="EmailPop"
Filter.rowID="?*"
Response="OnNewWorkItem_EmailPop"

EventResponse:OnNewWorkItem_EmailPop]
QueryBusComp = "Action"
QueryBusObj  = "eMail Response"
QuerySpec    = "Id = '{rowID}'"
SingleView   = "Communication Detail - Response View"
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are found in Siebel, you may want to do a multi-view screen pop and let the agent select 
the correct record.

Related topics

● For more information about the OnNewWorkItem event, see OnNewWorkItem on 
page 484.

● Also see, Assigning a workflow to monitor AICD open data changes on page 316

● For detailed information about the Siebel definition file, see the Communications Server 
Administration Guide in the Siebel documentation.

From the Siebel Communications Server to the Avaya IC 
workflows

The Siebel Communications server can pass any key-value parameter on selected 
commands and the AICD populates the EDU container, siebel.data.attachments, with that 
key and value.

Example

The Siebel Communications server can pass any key-value parameter on selected 
commands and the AICD populates the EDU container, siebel.data.attachments, with that 
key and value.

Between agent desktops

The Siebel Communications Server can pass open data from one agent to another using 
AICD commands and events. The Siebel event handler for the agent receiving the data 
may use this open data to pop a different screen or to activate a control.

The default Siebel definition file, AICD.def, contains an example of a NewOpenData 
command that sends open data between Siebel agents. In this example, when agent 1 
transfers a call to agent 2, agent 1 uses the NewOpenData command to pass the wrap-up 
code to agent 2.

Key-value parameters Then the AICD creates the following EDU field:

Key agentname siebel.data.attachments.agentname

Value SYDNEY SYDNEY
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Assigning a workflow to monitor AICD open data 
changes

To assign a workflow to monitor AICD open data changes:

1. Create a workflow that will process the EDU event. This workflow will inspect the input 
parameters, which will be the modified fields on the AICD Open Data container, and 
will process this data.

Example: test.aicd_open_data

Reference: For information about creating a workflow, see Avaya Workflow Designer 
User Guide.

2. Choose a workflow server to handle the processing. Create a separate workflow server 
if you think this will cause too much processing. Create one workflow server per Media 
EDU server by placing the workflow server into the same domain as each of the Media 
EDU servers.

3. Navigate to Start > Programs > Avaya Interaction Center 6.1 > IC Manager.

4. Log in to IC Manager.

5. Double-click the Workflow server in IC Manager.

6. Select the Channels tab of the appropriate Workflow server.

7. Select New Channel.

8. In the Channel Editor dialog box, select the values shown in the following table.

Note:
Note: Criteria is: siebel.data.attachments.*=*{siebel.data.attachments.*}

9. Click Ok.

10. Select New Association.

Field Value

Service VDU

Criteria siebel.data.attachments
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11. In the Channel Association dialog box, type the values shown in the following table.

Note:
Note: These fields are case-sensitive.

12. Click Ok.

13. Select New Association.

14. In the Channel Association dialog box, type the values shown in the following table.

15. Click Ok.

16. Click Ok again.

Result: The test.aicd_open_data workflow will run whenever any field changes within 
the siebel.data.attachments container.

Field Value

Event VDU.change

Flow test.aicd_open_data

Field Value

Event VDU.watch

Flow test.aicd_open_data
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Customizing events
In the default configuration, there are many EDU fields that the AICD does not pass to the 
Siebel server. You can customize your integration to use these fields.

You can customize the following Siebel events:

● OnNewWorkItem

● OnWorkItemRemove

● OnCallIncoming

The AICD passes EDU fields that are written before the agent receives the work item. Do 
not customize parameters that are written to the EDU after the agent receives the work 
item. If the EDU field is written after the work item arrives, the EDU data does not get 
passed.

About customizing Siebel event parameters

Use the AICDStrings.txt file to customize the Siebel event parameters. The 
AICDStrings.txt file is read by the AICD during driver initialization and contains entries 
such as:

DEFINE_INTL_STRING(ON_NEW_WORK_ITEM_EDU_FIELD_1, "")

Each entry determines:

● The event that will pass the customizable Siebel event parameter

● The EDU field value that will be passed on the event

● The key name of the customizable Siebel event parameter

Each entry allows you to add one key-value parameter to an AICD > Siebel event. Modify 
an entry to contain an EDU field name, and the AICD will attempt to find that EDU field and 
pass its value on the event. If a customizable Siebel event parameter is not found in the 
EDU, then it is not passed on the event.

The key-name is the same as the EDU field name. For example, if you specify EDU field 
name, calltype, the key-name is calltype. If you specify an EDU field name such as, 
currentemail.header.XWF_ReplyType, the key-name will be, 
currentemail.header.XWF_ReplyType.

Example

Here is how you would customize the OnNewWorkItem event:

DEFINE_INTL_STRING(ON_NEW_WORK_ITEM_EDU_FIELD_1, "calltype")
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● The AICD will look for the EDU field name, calltype. If found, the AICD adds this EDU 
field name and value the key-event parameters passed to Siebel on the 
OnNewWorkItem event.
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Chapter 14:Ensuring Avaya IC and Siebel 
compatibility

This section explains the relationship between your Siebel administration and Avaya IC 
administration. If certain administration parameters do not match, the Siebel toolbars for 
some agents will be disabled.

The section includes the following topics:

● New Siebel driver configurations on page 322

● The AICD library and the SiebelAICD server on page 323

● Siebel configuration parameters and settings on page 325

● Calculating the number of AICD servers on page 328

● List of configuration examples on page 329

● Example 1 on page 330

● Example 2 on page 331

● Example 3 on page 333

● Example 4 on page 334

● Example 5 on page 335

● Example 6 on page 336
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New Siebel driver configurations
Starting with the 7.0 Service Pack 1 (SP1) Siebel 7 integration release, Avaya IC now 
supports Siebel driver configurations that were not previously supported. 

Note:
Note: There is a patch available that supports the following functions for 6.1.3.

These new configurations allow you to closely tailor your integration to customer needs. 
You can now perform the following actions with the new AICD.

Set Maximum MT Servers to a value greater than one - You can set the Maximum MT 
Servers parameter for the Communications Session Manager to a value greater than one. 
This Siebel parameter controls the number of Communications Session Managers that can 
run on a host. The AICD is loaded separately up to the value specified for Maximum MT 
Servers. For earlier AICD releases, Avaya Alert 611 stated that the Maximum MT Servers 
setting must remain at its default value of one.

For more information, see Maximum MT Servers parameter on page 325.

Specify multiple Siebel configurations that use the AICD library - You can specify 
multiple Siebel configurations that use the AICD library using the new AICD parameter, 
ConfigurationName. The AICD creates a new SiebelAICD server for each 
uniquely-identified Siebel configuration. In earlier AICD releases, you could create only 
one SiebelAICD server per Siebel Communication Server. When you can create more than 
one SiebelAICD server per Siebel Communication Server, you can partition your agents by 
Avaya IC domains using separate Siebel Computer Telephony Integration (CTI) 
configurations. You can also use this ability to optimize network usage and failover 
strategies for your system.

For more information, see:

● ConfigurationName parameter on page 326

● AICD driver parameters on page 527

Restrict a Siebel communications configuration to run under a specified Avaya IC 
domain - With the new AICD parameter, ServerDomain, you can restrict a Siebel 
communications configuration to run under a specified Avaya IC domain. This can optimize 
your network communication by ensuring that all agents in a Siebel configuration run under 
a particular Avaya IC domain.

For more information about the ServerDomain parameter, see AICD driver parameters on 
page 527.



The AICD library and the SiebelAICD server

Issue 4.0 November 2004 323

The AICD library and the SiebelAICD server
The Siebel Communications Server uses the AICD library to support the Siebel toolbar. By 
default, each loaded AICD library creates one or more SiebelAICD servers.

This section includes the following topics:

● SiebelAICD selection criteria on page 323

● SiebelAICD server administration on page 324

● AICDs and multihomed hosts on page 324

SiebelAICD selection criteria

When the AICD library starts each SiebelAICD server, the AICD library looks for any Avaya 
IC server configured by Avaya IC Manager in the <AVAYA_IC61_HOME>/etc/vesp.imp 
file that meets the following criteria:

● The Avaya IC server type is SiebelAICD.

● The SiebelAICD server IP address configured using Avaya IC Manager matches the 
host IP address. If the host is multihomed, the AICD library compares all host IP 
addresses.

● If the Siebel ServerDomain driver parameter is specified, the AICD library compares the 
domain of the SiebelAICD server configured using Avaya IC Manager with the value of 
the ServerDomain parameter configured by Siebel. Both values must match exactly, 
including the letter case.

● The network TCP port address configured using Avaya IC Manager must not be in use 
by another SiebelAICD server nor by any other host process.

If these criteria are not met, the AICD library returns an error to Siebel and some Siebel 
agents will have disabled Siebel toolbars when they login. These errors are logged in the 
<AVAYA_IC61_HOME>/logs/SiebelAICD.log file.

Note:
Note: If you are running a multihomed server, make sure that the Port values 

configured using Avaya IC Manager for all SiebelAICD servers on the host 
are unique. Otherwise, the AICD library will not be able to use some 
SiebelAICD servers. Avaya IC Manager cannot do this for you.
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SiebelAICD server administration

To control the communication paths among the SiebelAICD servers and the Avaya IC 
servers, you must perform the following administrative tasks:

● Use Avaya IC Manager to administer each SiebelAICD server as Avaya IC server-type 
SiebelAICD.

● Assign the Siebel Communication Server host's IP address to each SiebelAICD server.

● Configure the Avaya IC domain on each SiebelAICD server.

AICDs and multihomed hosts

A multihomed host is a computer with two or more IP addresses. Typically, this is any host 
with two or more Network Interface Cards (NICs), or a single NIC configured for multiple IP 
addresses. The AICD library supports multihomed hosts by monitoring all host IP 
addresses.

IP assignment and performance

If your Siebel Communications Server host is multihomed, how you assign IP addresses 
during SiebelAICD server configuration can affect performance. Consider the following 
network performance criteria to determine the best IP address:

● Network topology

● Network bandwidth

● Number of network hops between your Avaya IC servers and Siebel Communications 
server host

Port assignment

Normally, Avaya IC Manager ensures that the specified SiebelAICD port entries are 
unique. However, Avaya IC Manager does not provide safeguards when specifying 
SiebelAICD port entries for a multihomed server.

When creating SiebelAICD servers for the same host and different IP addresses, you must 
ensure that the port entries are unique for all Avaya IC servers that run on the same host. 
In some special situations you must ensure that the port entries are unique for all Avaya IC 
servers across multiple hosts. If you pay attention to how you specify unique port 
addresses, you will save troubleshooting steps later.
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Siebel configuration parameters and settings

This section describes the Siebel configuration parameters and settings that affect the 
number of SiebelAICD servers. Some configurations require you to administer more than 
one SiebelAICD server using Avaya IC Manager. This is controlled by the following Siebel 
and driver configuration parameters and settings as they apply to the AICD:

● Maximum MT Servers parameter on page 325

● ConfigurationName parameter on page 326

● Siebel Communications Server host setting on page 327

Maximum MT Servers parameter

Maximum MT Servers is a Siebel configuration parameter on the Siebel Communication 
Session Manager that determines the maximum number of Communications Session 
Managers that run on a host. Each session manager runs a new copy of the AICD. For 
each AICD, at least one SiebelAICD server is created. This parameter defaults to a value 
of one, but you can change the value using the Siebel Server Component 
Administration screen.

Example setting for Maximum MT Servers

If you specify the Maximum MT Servers parameter as 2, you can load the AICD library 
under two separate processes on the Communications Server host for a total of two 
SiebelAICD servers. In order for all SiebelAICD servers to work, your administration of 
Avaya IC Manager must specify two Avaya IC SiebelAICD servers, all configured for the IP 
address of the Siebel Communications Server host. If you do not specify enough Avaya IC 
servers with the correct IP addresses, some SiebelAICD servers will fail to initialize and 
some Siebel agents will have disabled Siebel toolbars.

Note:
Note: This example assumes you are running one Siebel Communications Server 

host.

Considerations for setting Maximum MT Servers

Consider the following items:

● You can set the Maximum MT Servers differently for each Siebel Communication 
Session Manager.
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● Siebel allows you to also configure the number of Minimum MT Servers for the 
Communication Session Manager. Set the number to a value greater than 0 and less 
than or equal to the Maximum MT Servers setting. If the value of Minimum MT Servers 
is less than the value of Maximum MT Servers, not all AICD library instances or 
SiebelAICD server instances will be loaded during startup. Instead, loading will occur 
only on an as needed basis, as load increases and more agents log in.

Related topic

For more information and for the recommended settings for Minimum MT Servers, 
Maximum MT Servers, and Maximum Tasks for the Siebel Communication Session 
Manager, see Siebel FAQ 2091: How do you use the MaxMTServers, MinMTServers, and 
MaxTasks parameters to improve stability of the Communications Session Manager and to 
manage multiple CommSessionMgr processes.

ConfigurationName parameter

The Siebel communications configuration associates the Siebel agents, AICD library, AICD 
parameters, and more. The AICD parameter, ConfigurationName, allows the AICD library 
to distinguish the configurations and create a new SiebelAICD server for each.

About setting the ConfigurationName parameter

Consider the following items when setting the ConfigurationName parameter:

● Use the Siebel Communications screens to specify each Siebel configuration.

● In each Siebel communications configuration, specify a unique value for the 
ConfigurationName parameter. The AICD library recognizes a new configuration by a 
change in this value and creates a new SiebelAICD server.

● You can use the ConfigurationName parameter and the AICD parameter, 
ServerDomain, to associate unique groups of Siebel agents with an Avaya IC domain. 
This can optimize the communication paths for the agents in the Siebel configuration.

● You must administer the correct number of SiebelAICD servers using Avaya IC 
Manager.

Example setting for ConfigurationName

If you specify two Siebel communications configurations and give each a unique 
ConfigurationName value, the AICD library creates two SiebelAICD servers. You must 
specify two Avaya IC SiebelAICD servers using Avaya IC Manager. If you do not specify 
the correct number of Avaya IC servers, some SiebelAICD servers will fail to initialize and 
some Siebel agents will have disabled Siebel toolbars.
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Note:
Note: This example assumes you are running one Siebel Communications Server 

host and the Maximum MT Servers parameter is set to the default value of 
1.

Related topic

For more information, see AICD driver parameters on page 527.

Siebel Communications Server host setting

During the installation of your Siebel enterprise, you can specify more than one Siebel 
Communications Server host. Each host can load the AICD library, and at least one 
SiebelAICD server is created for each Siebel Communications Server host. You must 
administer the correct number of SiebelAICD servers using Avaya IC Manager.

Example

If you administered two Siebel Communications Server hosts, you must specify two Avaya 
IC SiebelAICD servers using Avaya IC Manager. If you do not specify the correct number 
of Avaya IC servers, some SiebelAICD servers will fail to initialize and some Siebel agents 
will have disabled Siebel toolbars.

Note:
Note: This example assumes you are running one Siebel configuration and the 

Maximum MT Servers parameter is set to the default value of 1.
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Calculating the number of AICD servers
This section describes the formula you can use to determine the number of AICDs that you 
need to administer.

A = C multiplied by (sum of the values of M for each n).

Variable Definition

A Number of AICDs that need to be administered using IC Manager for each 
Siebel enterprise

C Number of AICD configurations in Siebel for each Siebel enterprise

n Number of hosts that can run Siebel Communication Servers

M Value of Maximum MT Servers for each Siebel Communication Server

A C M1 M2 … Mn+ + +( )=
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List of configuration examples
You can use the following examples to help you configure Siebel and Avaya IC to ensure 
compatibility:

● Example 1 on page 330 provides an example of one Siebel configuration with one 
Communication Server.

● Example 2 on page 331 provides an example of two Siebel configurations with one 
Communication Server

● Example 3 on page 333 provides an example of one Siebel configuration with one 
Communication Server, and the Maximum MT Servers parameter set to 2.

● Example 4 on page 334 provides an example of two Siebel configurations with one 
Communication Server, and the Maximum MT Servers parameter set to 2.

● Example 5 on page 335 provides an example of a multihomed host with two Siebel 
configurations, one Siebel Communication Server, and the Maximum MT Server 
parameter set to 2.

● Example 6 on page 336 provides an example of two Siebel configurations with two 
Communication Server hosts and the Maximum MT Servers parameter set to 2.
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Example 1

One Siebel configuration with one Siebel Communication Server

The simplest type of configuration consists of one Siebel configuration with one Siebel 
Communication Server. To set up this type of configuration:

1. Create one SiebelAICD server under the AICD library.

2. Using Avaya IC Manager, create only one Avaya IC server of type SiebelAICD.

When the AICD loads, it will determine the host IP address and use the only available 
SiebelAICD server that matches the IP address for its Siebel host.

Figure of example 1

The following figure shows a configuration that consists of one Siebel configuration with 
one Siebel Communication Server.
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Example 2

Two Siebel configurations with one Communication Server

This example shows how to use two Siebel communications configurations. Each 
configuration uses a different Avaya IC domain. Consider the following items:

● Although not shown in Figure of example 2 on page 332, each configuration contains a 
separate group of Siebel agents.

● Agents in Siebel configuration C1 use Avaya IC domain, User1.

● Agents in Siebel configuration C2 use Avaya IC domain, User2.

This technique optimizes the network communications between the SiebelAICD server and 
the other Avaya IC servers in the same Avaya IC domain. This is useful when the Avaya IC 
servers are distributed across a Wide Area Network (WAN).

About setting up example 2

To set up this type of configuration:

● Administer two Siebel configurations.

● Use the driver configuration parameter, ConfigurationName, to distinguish the 
configurations to the AICD. To use this parameter effectively, supply unique values for 
this configuration parameter. Otherwise, the Siebel configurations will be 
indistinguishable and only one SiebelAICD server will be created.

● Use the ServerDomain driver parameter to ensure that the driver creates a SiebelAICD 
server that is in the specified Avaya IC domain. It is important that this parameter value 
matches the Avaya IC domain name exactly. Otherwise, the server will not start.
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Figure of example 2

The following figure shows two Siebel communications configurations with one Siebel 
Communication Server.
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Example 3

One Siebel configuration with one Communication Server and the Maximum 
MT Servers parameter set to 2

The Siebel Communication Session Manager configuration parameter, Maximum MT 
Servers, determines the number of Communications Session Managers that run on a host. 
Each manager can run a new copy of the AICD library. This example shows the effect of 
the parameter on the number of SiebelAICD servers.

Figure of example 3

The following figure shows one Siebel communications configuration with one Siebel 
Communication Server and the Maximum MT Servers parameter set to 2.
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Example 4

Two Siebel configurations with one Communication Server, and the Maximum 
MT Servers parameter set to 2

This example combines the previous two examples and shows the effect on the number of 
SiebelAICD servers. You can use this configuration to provide redundancy for the Siebel 
agents in each configuration. If a server process were to fail, an alternate server process is 
available for the Siebel agents when they re-login.

Figure of example 4

The following figure shows two Siebel communications configurations with one Siebel 
Communication Server and the Maximum MT Servers parameter set to 2.
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Example 5

Multihomed host with two Siebel configurations, one Siebel Communication 
Server, and the Maximum MT Server parameter set to 2.

The multihomed host in this example has two IP addresses that are associated with the 
same host. In this example, Siebel agents in communications configuration 1 use Avaya IC 
domain User1, and IP address 111.111.111.1. Agents in configuration 2 use User2, and IP 
address 222.222.222.2. Like the previous example, you can use this configuration to 
provide redundancy for the Siebel agents in each configuration. If a server process fails, an 
alternate server process is available for the Siebel agents when they re-login.

Make sure that the port you specified in IC Manager is unique for all SiebelAICD servers 
on the host. Otherwise, the AICD library will not be able to use some of the SiebelAICD 
servers. Avaya IC Manager cannot determine whether or not the port is unique.

Figure for example 5

The following figure shows a multihomed host that consists of two Siebel communications 
configurations with one Siebel Communication Server and the Maximum MT Servers 
parameter set to 2.
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Example 6

Two Siebel configurations with two Siebel Communication Server hosts, and 
the Maximum MT Servers parameter set to 2

You can use this type of configuration to provide server redundancy and process 
redundancy for the Siebel agents in each system. If a server process or server host fails, 
an alternate server process is available for the Siebel agents when they re-login. Notice 
how quickly the number of SiebelAICD servers grows when you:

● Combine multiple Siebel Communications configurations

● Combine multiple Siebel Communication Server hosts

● Use the Siebel Communication Session Manager configuration parameter, Maximum 
MT Servers

Note:
Note: This example assumes you have set the Maximum MT Server configuration 

parameter for the Siebel Communication Session Manager the same for 
each host. However, you can set this parameter differently for each host.
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Figure for example 6

The following figure shows a two Siebel communications configuration with two Siebel 
Communication Servers and the Maximum MT Servers parameter set to 2.
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Chapter 15:Troubleshooting

This section includes the following topics:

● The Siebel toolbar is not visible on page 340

● All buttons on the Siebel toolbar are disabled on page 341

● Diagnosing and clearing AICD loading problems on page 343

● Siebel GUI is unresponsive on page 350

● Some of the Avaya IC services do not start on page 351

● The Avaya Agent taskbar fails on page 352

● EDU information is lost on page 353

● Log files on page 354

● EAI server errors on page 358

● EAI servers do not start (AIX platforms only) on page 359

● EAI server is unable to read a file attachment on page 360

● AED errors on page 361

● AED is unloaded by Comm. Inbound Manager following upgrade on page 362

● Replacing English with Thai text in toolbar on page 363
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The Siebel toolbar is not visible
If the Siebel toolbar is not visible, use the following remedy.

Remedy

1. In the Siebel Application window, go to Navigate > Communications > Reset 
Active Session Count.

Note:
Note: You can also press Ctrl+F8

2. Have the agent log out of Siebel and log back in.
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All buttons on the Siebel toolbar are disabled
The Siebel toolbar becomes inactive when Siebel cannot successfully load the Adaptive 
Interaction Center Driver (AICD) or the AICD instance fails. All agents who were obtaining 
toolbar support through the failed AICD will be unable to use the Siebel toolbar. Any 
requests that display a Siebel window or process a Siebel toolbar command stop 
functioning. Agents can continue to use the Siebel windows to complete data entry, but this 
work is not tracked by Avaya IC. 

Remedy 1

Have the agent log out of Siebel and log back in.

Remedy 2

The AICD may not be able to communicate with the Avaya IC servers because the 
vesp.imp file on the Siebel server contains old Avaya IC server or old Avaya IC domain 
information. 

1. Update the copy of the <AVAYA_IC61_HOME>/etc/vesp.imp file on each Siebel 
Communications Server that runs the AICD. Use Avaya IC Manager to force the 
update of all ORB servers by selecting Manager > Update All. This propagates all 
server additions, deletions, and changes to the Avaya IC ORB servers.

2. Restart the AICD. Use the Siebel Server Administration screens to shutdown, then 
start the Siebel Communications Server that is running the AICD. 

3. Log the agent into Siebel. This will load the AICD with the newest vesp.imp file.

Remedy 3

1. Relaunch the Siebel thin client, and carefully monitor the Siebel Message Area for 
messages. 

The Siebel Message Area is located above the Siebel toolbar. Messages sometimes 
appear for only 5 seconds, so watch carefully.

2. If you see the following message:

Follow the procedures in Diagnosing and clearing AICD loading problems on 
page 343. This procedure provides an ordered approach to troubleshoot AICD loading 
problems.

Remedy 4

Enable Siebel Communications Server logging. Siebel provides information on how to 
enable Communications Server Logging on their support Web site. With logging enabled, 

Unable to load aicd with Media Type String = Avaya
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you can use the Siebel log files to pinpoint where a problem may have occurred and 
determine how to fix the problem.

Remedy 5

You may have logged into Siebel and Avaya IC with different agent login IDs. The login IDs 
must be identical. Although the character case of the Siebel login ID may be different, the 
character case of the Avaya Agent login ID must all be in lowercase.

1. Log the agent out of Siebel.

2. Check the Avaya Agent login ID using the Avaya Agent taskbar feature, About Avaya 
Agent.

3. Log the agent into Siebel using a correct agent login id. You may have to account for 
Agent Login ID case differences for Siebel.

4. Make sure that the Avaya Agent login ID does not have any uppercase characters.

Related topic

For more information about agent login IDs, see Avaya IC for Siebel User Guide.
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Diagnosing and clearing AICD loading problems
There are configuration dependencies that must be fulfilled before Siebel can load the 
AICD. Normally, Siebel loads the AICD when the first Siebel agent logs into Siebel. 
However, there may be AICD, Siebel, and OS platform configuration issues that prevent 
the AICD from being loaded. Once these configuration problems are settled, the AICD will 
operate smoothly.

This section includes the following topics:

● For Solaris or AIX platforms on page 343

● For Windows platforms on page 346

For Solaris or AIX platforms

To troubleshoot and fix configuration issues on a Solaris or AIX platform:

1. Look for the libmttlogger.so and libmttoolkit.so files in your <AVAYA_IC61_HOME>/
lib directory on the Siebel Server.

These Avaya IC executable files must be present on the Siebel Server in order for the 
AICD to load properly. These files should have been placed on the Siebel Server when 
you installed the Avaya IC components.

2. Check that the Siebel environment file, siebenv.sh, has the correct settings.

Look for the siebenv.sh file in the <SIEBEL_HOME>\siebsrvr directory, but it could 
also be located in a different directory, depending on how you customized your Siebel 
installation.

Make sure that siebenv.sh has the following statements:

● For Solaris:

● For AIX:

Note:
Note: These settings must be adapted for your Siebel Server environment.

AVAYA_IC61_HOME=/opt/Avaya/IC61 ; export AVAYA_IC61_HOME

LD_LIBRARY_PATH=${AVAYA_IC61_HOME}/lib:${LD_LIBRARY_PATH} ; export LD_LIBRARY_PATH

AVAYA_IC61_HOME=/opt/Avaya/IC61 ; export AVAYA_IC61_HOME
LIBPATH=${AVAYA_IC61_HOME}/lib:${LIBPATH} ; export LIBPATH
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3. Check your current environment with the following statements on the UNIX command 
line before starting Siebel.

It is often worth checking your environment because of conditional statements in your 
Siebel environment file.

4. Make sure that the AICD library file, libaicd.so, is in the Siebel bin directory.

● Use the following command to verify that the file has UNIX file execute permissions:

ls -l libaicd.so

● If you need to add the file execute permissions, use the following command:

chmod +x libaicd.so

5. Make sure the AICD server was correctly configured using IC Manager. Check the 
following items under the Avaya IC Manager Server tab.

6. Make sure that the vesp.imp file on your Siebel Server is current.

On UNIX, this file is located under ${AVAYA_IC61_HOME}/etc.

If the IC ORB Server is installed and running on your Siebel Server, you can do one of 
the following tasks to force the update:

● Use Update All on IC Manager.

Solaris AIX

set | grep AVAYA_IC61_HOME

set | grep LD_LIBRARY_PATH

set | grep AVAYA_IC61_HOME

set | grep LIBPATH

Field Value

AICD Server 
Type

SiebelAICD

Host Make sure that this is the IP address of the Siebel Server that runs the 
AICD.

Port Make sure that the port number does not conflict with an existing TCP/
IP port on the Siebel Server. See Step 7.

Directory and 
Executable

These settings do not matter because the AICD is loaded by Siebel 
and not by the Avaya IC ORB Server. However, you must select a valid 
directory name to satisfy IC Manager.

Domain The preferred Avaya IC domain is one of the Avaya IC Agent domains 
or the default domain.
For more information, see Avaya IC domain deployment guidelines on 
page 46.
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● Copy the vesp.imp file from your Avaya IC server to your Siebel Server.

7. Make sure the TCP/IP port for the AICD on the Siebel Server does not conflict with 
another application on the Siebel Server.

Do one of the following tasks to detect a port conflict:

● Go to the Siebel Server and look at the SiebelAICD.log file under directory, 
<AVAYA_IC61_HOME>/logs. If you see the following message in the AICD log file, 
you have a port conflict.

● View the ports in use on your Siebel Server by using the following command:

netstat -a

If the netstat results show that the TCP/IP port number assigned to the AICD using 
Avaya IC Manager is in use, there is likely to be a port conflict.

8. If you have a TCP/IP port conflict, use Avaya IC Manager to change the TCP/IP port. 
IC Manager will not allow you to directly change the Port setting. If you want to change 
the AICD Server port assignment, first delete the old IC Manager AICD Server and 
create a new server of type SiebelAICD.

Make the same IC Manager changes on all servers. Use Update All on IC Manager.

For more information, see Creating a Siebel AICD server on page 188.

9. Check the status of the Avaya IC servers using Avaya IC Manager.

The AICD and Avaya Agent depend on a running Avaya IC system. If the Avaya IC is 
not running, the AICD will not start.

10. Look for the following log file:

<AVAYA_IC61_HOME>/logs/SiebelAICD.log

11. If your Siebel Server contains more than one network board, you must provide 
additional AICD configuration information. Do the following steps:

a. Look for the following message in the log file:

b. If you see this message, your Siebel Server contains more than one network board 
and you must define the AICD parameter, ServerUUID.

For more information, see AICD driver parameters on page 527.

12. Do the following steps to make sure that the Siebel agent login name is associated 
with the AICD, and the Siebel agent is assigned to a teleset:

Cannot get port XXXX - is this server already running?

Cannot login() to eContact. ServerUUID =  and ORBServerUUID = 
and ORBServer UUID= Check the vesp.imp file on this server 
and the Siebel Driver Configuration.
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a. Login to Siebel as SADMIN and navigate to the Siebel Communications 
Administration screen.

b. Under All Configurations, check that the Siebel login name for the agent is 
associated with the AICD configuration.

c. Select the AICD configuration, and select the Agents tab. The agent name should 
be listed here.

d. Navigate to All Telesets and check that the agent is assigned a teleset.

The AICD does not use this the teleset information, but Siebel will check for a 
teleset. You need only one teleset extension for all Avaya IC agents. All AICD 
agents may be assigned to the same teleset extension - extension type S.

13. Your AICD should now be able to start and be able to log any remaining problems in 
the AICD log files. Examine the AICD log file for any further errors and warnings.

For more information about log files, see Log files on page 354.

For Windows platforms

To troubleshoot and fix configuration issues on a Windows platform:

1. Look for the mttlogger.dll and mttoolkit.dll files in your <AVAYA_IC61_HOME>\bin 
directory on the Siebel Server.

These Avaya IC executable files must be present on the Siebel Server in order for the 
AICD to load properly. These files should have been placed on the Siebel Server when 
you installed the Avaya IC components.

2. Check your Windows system environment settings by doing the following steps:

a. Navigate to Start > Settings > Control Panel > System.

b. Select the Advanced tab.

c. Click Environment Variables.

d. Make sure the following system variables are set correctly.

System variable 
name

System variable value

AVAYA_IC61_HOME Make sure that this value is the Windows directory path to where 
Avaya IC was installed. 
Example: c:\AvayaIC61.

Path Make sure that the path contains an entry similar to this:
%AVAYA_IC61_HOME%\bin
Note: Use ; to separate the entries.
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! CAUTION:
CAUTION: Restarted a server is service affecting. Follow your company procedures for 

restarting a server.

e. If you changed any system variable settings, restart your server in order for the new 
settings to take effect for all processes on your Siebel Server.

f. Open a command prompt window to check your current environment.

g. Open a Windows command prompt, enter the following statements and examine the 
output to ensure that your environment is correctly set:

set AVAYA_IC61_HOME

set PATH

It is often worth checking the above statements in case you have accidently altered 
your current environment.

3. Make sure that the AICD executable file, aicd.dll, is in the Siebel bin directory.

This file should have been installed on your Siebel Server when you installed the 
Avaya IC for Siebel integration.

4. Make sure the AICD server was correctly configured using IC Manager. Check the 
following items under the Avaya IC Manager Server tab.

5. Make sure that the vesp.imp file on your Siebel Server is current. On Windows, this 
file is located under ${AVAYA_IC61_HOME}\etc.

If the IC ORB Server is installed and running on your Siebel Server, you can do one of 
the following tasks to force the update:

Field Value

AICD 
Server 
Type

SiebelAICD

Host Make sure that this is the IP address of the Siebel Server that runs the 
AICD.

Port Make sure that the port number does not conflict with an existing TCP/IP 
port on the Siebel Server. See Step 7.

Directory 
and 
Executable

These settings do not matter because the AICD is loaded by Siebel and not 
by the Avaya IC ORB Server. However, you must select a valid directory 
name to satisfy IC Manager.

Domain The preferred Avaya IC domain is one of the Avaya IC Agent domains or 
the default domain.
For more information, see Avaya IC domain deployment guidelines on 
page 46.
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● Use Update All on IC Manager.

● Copy the vesp.imp file from your Avaya IC server to your Siebel Server.

6. Make sure the TCP/IP port for the AICD on the Siebel Server does not conflict with 
another application on the Siebel Server.

Do one of the following tasks to detect a port conflict:

● Go to the Siebel Server and look at the SiebelAICD.log file under directory, 
<AVAYA_IC61_HOME>\log. If you see the following message in the AICD log file, 
you have a port conflict.

● View the ports in use on your Siebel Server by using the following command:

netstat -a

If the netstat results show that the TCP/IP port number assigned to the AICD using 
Avaya IC Manager is in use, there is likely to be a port conflict.

7. If you have a TCP/IP port conflict, use Avaya IC Manager to change the TCP/IP port. 
IC Manager will not allow you to directly change the Port setting. If you want to change 
the AICD Server port assignment, first delete the old IC Manager AICD Server and 
create a new server of type SiebelAICD.

Make the same IC Manager changes on all servers. Use Update All on IC Manager.

For more information, see Creating a Siebel AICD server on page 188.

8. Check the status of the Avaya IC servers using Avaya IC Manager.

The AICD and Avaya Agent depend on a running Avaya IC system. If Avaya IC is not 
running, the AICD will not start.

9. Check if the AICD can log in to Avaya IC by doing the following steps:

a. Look for the following log file:

<AVAYA_IC61_HOME>\logs\SiebelAICD.log

b. Look for the following message in the log file:

c. If you see this message, your Siebel Server contains more than one network board 
and you must define the AICD parameter, ServerUUID.

For more information, see AICD driver parameters on page 527.

10. Check the Siebel configuration for the AICD by doing the following steps:

Cannot get port XXXX - is this server already running?

Cannot login() to eContact. ServerUUID =  and ORBServerUUID = 
and ORBServer UUID= Check the vesp.imp file on this server 
and the Siebel Driver Configuration.
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a. Login to Siebel as SADMIN and navigate to the Siebel Communications 
Administration screen.

b. Under All Configurations, check that the Siebel login name for the agent is 
associated with the AICD configuration.

11. Select the AICD configuration, and select the Agents tab. The agent name should be 
listed here.

12. Navigate to All Telesets and check that the agent is assigned a teleset.

The AICD does not use this the teleset information, but Siebel will check for a teleset. 
You need only one teleset extension for all Avaya IC agents. All AICD agents may be 
assigned to the same teleset extension - extension type S.

13. Your AICD should now be able to start and be able to log any remaining problems in 
the AICD log files. Examine the AICD log file for any further errors and warnings.

For more information about log files, see Log files on page 354.
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Siebel GUI is unresponsive
Sometimes the Siebel GUI is unresponsive after the agent selects the Reply, Reply All, or 
Forward buttons. When these buttons are selected, Siebel invokes the eMail Response - 
Response Workflow. Siebel becomes unresponsive at the Expand Template step. When 
this happens, you need to restart the Siebel GUI.

Contact Siebel support if you need help troubleshooting this workflow.
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Some of the Avaya IC services do not start
You cannot start or stop the AED or AICD using Interaction Center (IC) Manager. These 
components are started and stopped only by Siebel. Siebel starts the AICD on the first 
agent login. Siebel stops the AICD when the Siebel Communications Session Manager is 
shutdown. Siebel starts the AED on server initialization.
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The Avaya Agent taskbar fails
One of the following events occurs if the Avaya Agent taskbar software fails:

● The Siebel login window takes up the entire screen and the Avaya Agent taskbar does 
not appear. 

● Avaya IC stops processing new or existing work for an agent. 

Agents can continue to work using only the Siebel window, but Avaya IC does not track the 
work. To resynchronize Avaya IC with Siebel, the agent has to start another Avaya Agent 
session and Siebel session. The new Siebel session overrides the old Siebel session. 

Remedy 1

1. Minimize the browser window, and look for a message box that might contain one of 
the following messages:

● Invalid state

● Link is Down

● Your configuration has changed 

2. Click the retry button to try the login again. It is not necessary to select your login 
information again.

Remedy 2

1. Close the internet browser window.

2. Verify that your telephone is not off the hook, and that you have no active calls.

3. Log out of the telephone if you are using Softphone.

4. Log in to Avaya Agent and Siebel.

Remedy 3

1. Use the ping command to determine connectivity to Avaya IC servers.

2. When connectivity to the other servers is established, log in to Avaya Agent and the 
Siebel thin client.
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EDU information is lost
Avaya IC telephony supports the tracking of calls when calls are transferred between 
Avaya IC agents. If a call is transferred from an Avaya IC agent to a non-Avaya IC agent 
telephone, Avaya IC ceases to track the call and retires the EDU. If this call is later 
transferred to an Avaya IC agent, the call looks like a new call and a new EDU is created.

Note:
Note: The original EDU information that provided the Siebel screen pop to the first 

Avaya IC agent is retired and not available when the call is transferred from 
the non-Avaya IC agent telephone.
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Log files
Errors, warnings, and trace messages are logged into log files at runtime. You can enable 
additional logging in order to get more information when troubleshooting the AED, AICD, or 
the EAI servers. For the AICD, you can create log files and files for each agent on the 
server where the AICD resides. For the AED and for the EAI servers, you can only create 
server log files.

This section includes the following topics:

● Creating log files for the server on page 354

● Creating log files for the AICD, AED, and EAI servers on page 355

● Siebel log files on page 356

Creating log files for the server

You can create server log files for the AICD, AED, and for the EAI servers.

Related topic

For more information about setting log files through IC Manager, see IC Administration 
Volume 1: Servers & Domains.

Server log names

Each AICD, AED, and EAI server logs into a file that has the same name as its interface 
suffixed with .log. Examples of log file names are included in the following table.

During startup, each AICD, AED, and EAI server logs into the Avaya IC system, finds its 
server name, and begins logging into a file that has the same name as its server name 
suffixed with .log. For example, if your EAI server name is xyz, when that is suffixed with 

Interface name Path and filename examples

SiebelAICD <AVAYA_IC61_HOME>/logs/SiebelAICD.log

SiebelAED <AVAYA_IC61_HOME>/logs/SiebelAED.log

EAI <AVAYA_IC61_HOME>/logs/EAI.log

EAIEmail <AVAYA_IC61_HOME>/logs/EAIEmail.log

EAIWorkflow <AVAYA_IC61_HOME>/logs/EAIWorkflow.log
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.log, the new log name will be xyz.log. All log files are logged into 
<AVAYA_IC61_HOME>logs.

AICD, AED, and EAI logging levels

For the AICD, AED, and EAI servers, set these Debug Trace Levels using the IC Manager 
Server Administration Dialogs.

Creating log files for the AICD, AED, and EAI servers

The AICD, AED and EAI servers create log files. Log files are enabled on a per agent basis 
using Siebel driver parameters.

Agent log names

The name of the log file is a combination of the agent name and the name of the server the 
agent is logged into. For example, if the AICD server for the agent is xyz and the name of 
the agent is abc, the log file for the agent will be xyz_abc.log.

Agent logging levels

For the AICD, use the service logging levels when you want to set up logging for each 
agent.

Server 
logging level Description

usr1 Errors

usr2 Warnings

usr3 Information

usr4 Debugging

flush Causes every statement to flush. Use this level sparingly as it slows 
down processes.

Service logging level Description

TraceLevelUsr1 Errors

TraceLevelUsr2 Warnings
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Facts about setting up agent log files

While the details of setting up driver-specific parameters and profiles are described in the 
Siebel documentation, consider the following items when performing those procedures:

● If you want to use TraceLevelFlush, you must first set a trace level between 1 and 4 so 
that logging will occur in a separate file for that agent.

● Do not set up log files for 50 or more agents as this may affect the performance of your 
Siebel Communication Server. On some systems, you may experience performance 
degradation with less than 50 agent log files.

● You can set driver parameters in one of two ways:

- Set a default value for a Siebel driver parameter.

- Specify an override value for the parameter in each profile you create for the Siebel 
driver.

● The setting for each agent overrides the common setting that was specified through IC 
Manager.

● If you used override values to set driver parameters, create a special Siebel profile that 
sets these override values for the AICD Siebel logging parameters.

● Associate this special profile with the agents that will have log files.

Related topics

For more information, see the following topics:

● For the AICD parameters used for logging, see AICD driver parameters on page 527.

● For a description on how to configure the Siebel service parameters for agent log files, 
see the Siebel documentation.

Siebel log files

Siebel also provides log files to help you track down a problem. Increase the level of 
logging for the Siebel Communications Server to get more detailed information in the 

TraceLevelUsr3 Information

TraceLevelUsr4 Debugging

TraceLevelFlush Causes every statement to flush. Use this level sparingly 
as it slows down processes.

Service logging level Description
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Siebel log files. You can use this information to see what commands and events have 
passed between the AED and Siebel, and between the AICD and Siebel.

Siebel describes how to enable logging on their support Web site at http://
ebusiness.siebel.com/supportweb.

http://ebusiness.siebel.com/supportweb
http://ebusiness.siebel.com/supportweb
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EAI server errors
The Enterprise Application Integration (EAI) server provides different tools that can be 
used for troubleshooting. The EAI server can:

● Create alarms for fatal errors with Siebel connectivity or errors returned from Siebel 
using the Alarm server. Any error information provided by Siebel is stored in the Siebel 
server log file, not the Alarm server.

● Support a server log file for improved diagnostics.

How the EAI server indicates errors

The EAI server indicates errors using the following different methods:

● Generates alarms to the alarm server based on the current condition. These are usually 
saved for severe errors such as connectivity problems or fatal server errors.

● Returns a code at the completion of each task. This code allows the calling workflow to 
determine if there was an error and what that error was. If available, the EAI server 
returns a text string that provides a detailed description of the problem.

● Maintains a complete and comprehensive log of all work within itself. This log is named 
after the alias name of the server itself. This logging functionality follows all of the 
standard conventions for interaction servers.
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EAI servers do not start (AIX platforms only)
If you have an AIX platform and the EAI servers do not start, you should see the following 
error message:

unable to create JVM

Look at the EAI log file to see this message. The EAI log file is located at 
<AVAYA_IC61_HOME>/logs, on the machine that runs the EAI server.

Related topic

For more information about log files, see Log files on page 354.

Remedy

To fix this error, set the LIBPATH correctly in the icenv file. Both of the following directories 
should be included in the LIBPATH:

● The directory containing libjvm.a ($<AVAYA_IC61_HOME>/Java/bin/classic)

● The parent directory ($<AVAYA_IC61_HOME>/Java/bin)

Example

This is a script code example for the setting of LIBPATH on AIX platforms. Place this code 
in the icenv file, located under <AVAYA_IC61_HOME>/bin.

Related topic

For more information, see Updating the LIBPATH environment variable for AIX 
platforms on page 215.

LIBPATH=${<AVAYA_IC61_HOME>}/Java/bin/classic:${<AVAYA_IC61_HOME>}/Java/bin: ${LIBPATH}
export  LIBPATH 
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EAI server is unable to read a file attachment
When adding a file attachment, you can run into permission problems if the workflow is 
trying to attach a file that exists on a different machine, and the filename is passed to the 
EAI server as a Universal Naming Convention (UNC) filename. If the EAI server is unable 
to read the file, the Put Data block will return an error code of 2, and an alarm is raised 
stating that the EAI server was unable to read the file. This is likely caused by permission 
issues between the remote machine and the user account that started the EAI server. By 
default, when the ORB Server starts the EAI server, the EAI server inherits the user 
account and permissions from the ORB server.

Remedy

1. Start the Avaya IC ORB service using a Windows domain account that has permission 
to view the remote directory.

2. If this is not possible, map the remote directory to a driver letter on the local machine. 
Use the fully-qualified domain name of the remote machine. Example: 
machine.usae.avaya.com/share/filename and not machine/share/filename or 
ipaddress/share/filename.

In order to avoid this situation, always locate file attachments on the same machine as the 
EAI server.
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AED errors
This section includes the following topics:

● The AED does not start on page 361

● IC servers have a new IP address and the AED does not work on page 361

● The AED is not returning all the expected data on page 361

The AED does not start

If there is no AED.log file in the <AVAYA_IC61_HOME>/logs directory:

● Make sure that the Avaya IC environment is running before you attempt to log in.

● Check that your AED configuration was done properly in accordance with the steps in 
the Configuring Siebel for the AED on page 268. Verify that the vesp.imp file in your 
<AVAYA_IC61_HOME>/etc directory on your Siebel server matches the one on your 
Avaya IC server. If you installed Avaya Agent on your Siebel Server before you 
administered the Siebel Server in IC Manager, the vesp entry for the AED is not present 
in the vesp.imp or vesp.ini on your Siebel Server.

● On the Siebel server, verify that the Avaya IC multi-threaded toolkit and logger are 
accessible to the AED. On Windows platforms, the files mttlogger.dll and mttoolkit.dll 
should be in your <AVAYA_IC61_HOME>/bin directory. On Solaris and AIX platforms, 
the libmttlogger.so and libmttoolkit.so files should be in your 
<AVAYA_IC61_HOME>/lib directory. The AED depends on both of these files, and 
there may be a path problem if it is not finding these files.

IC servers have a new IP address and the AED does not work

The AED communicates to the IC servers using GUIDs that are created from the IP 
addresses. Generate a new vesp.imp file and move the file to <AVAYA_IC61_HOME>/
etc.

The AED is not returning all the expected data

The maximum data the AED can receive from Siebel as part of the disposition is 50 name/
value pairs. If this number of name/value pairs is exceeded, the data is dropped and the 
failure is noted in the log as a warning.
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AED is unloaded by Comm. Inbound Manager 
following upgrade

After you upgrade to Siebel 7.5.2 patch 211, 214, or higher; Comm. Inbound Manager may 
error and shut down after starting.

To fix this upgrade error:

1. Log in to your call center application as SADMIN.

2. Navigate to Server Administration > Components.

3. Select Communication Inbound Manager.

4. Select the Parameters tab.

5. Search for the parameter, *Application Name*.

6. Change the name of the application to Siebel Universal Agent. 

This is the name of the application for call center.

7. Restart Siebel services.

Related topics

For more information, refer to the following Siebel Service Requests at the Siebel support 
Website:

● 38-929065651

● 38-950057351

● 38-941309360
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Replacing English with Thai text in toolbar
If your system is translated into Thai, you may get a mixture of English and Thai in the 
toolbar. This happens because Siebel does not currently support a language pack for Thai. 
If you want Thai language support for the toolbar, install Siebel in English, or another 
Siebel-supported language, and configure Avaya IC for Thai. You must now modify the 
toolbar so that the agent sees only Thai text in the tool tips.

Modifying tool tip text for disabled buttons

! Important:! Important:
Important: Test all changes to the Siebel object repository in a non production 

environment before deploying them in your production environment. Create 
a backup copy of the Siebel server object repository before making any 
changes using Siebel Tools.

For more information, see Working with Siebel Tools on page 167.

To modify the tool tip text for disabled buttons:

1. Log in to Siebel Tools.

2. In the Object Explorer navigation pane, select Toolbar.

The Object Explorer navigation pane is located in the upper-left corner of the window.

If you do not see the Toolbar object, enable it in View > Options > Object Explorer.

3. Navigate to Toolbar > Communication > Toolbar Item.

4. Modify the tool tip text by selecting one of the following toolbar items:

● Accepting Work

● Release Work

● Retrieve Work

● Hold Work

● Resume Work

● Forward Work

● SignOff

● InQueue Time

5. In the command associated with that toolbar item, navigate to the Tooltip Text 
property and modify the text.
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Note:
Note: For InQueue Time, change the Dynamic Tooltip value to FALSE.

6. Stop the Siebel Server.

7. Compile the SRF.

8. Start the Siebel Server.

Modifying tool tip text for enabled buttons

The tool tip specified in Siebel Tools is only visible for disabled buttons. The tool tip text for 
the enabled messages are derived either from the command parameter descriptions in the 
Siebel definition file, or from defaults provided by the AICD. The latter are changeable by 
editing the applicable AICDStrings.txt file that was installed with the AICD.

To modify the tool tip text for enabled buttons:

1. Decide where do you want to locate your tool tip text.

● In the command descriptions of the Siebel definition file

● In the defaults provided by the AICD

2. Open the file and modify the text in one of the following files:

● AICD definition file. Modify the command descriptions.

● AICDStrings.txt file. Modify the default file that was installed with the AICD.

3. Import the new AICD definition file or restart one of the following files:

● AICD definition file. Re-import the AICD definition file into Siebel.

● AICDStrings.txt file. Shutdown and restart the Siebel Comm. Session Manager in 
order to reload the AICD and have it reread the AICDStrings.txt file.
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Chapter 16:Integrating with Siebel 7.0.4

The Avaya IC integration with Siebel 7.0.4 integration is the same as integrations with 
other Siebel releases with the following exceptions:

● The files are in a different location on the CD. Go to:

\Integration\sea704

● Localized error strings are not supplied for Siebel 7.0.4.

● The EAIWorkflow servers support only workflows without MIME.

● The Web chat transcripts are not passed to Siebel.

● The Avaya-first e-mail method is not supported.

For a description of the changed Siebel objects, see:

● Siebel objects related to EAI on page 366

● Siebel objects related to e-mail on page 367
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Siebel objects related to EAI
The following table describes the differences in a Siebel 7.0.4 integration for Siebel objects 
located on the EAI server. This applies only to a Siebel-first e-mail method.

Siebel 
interface

Siebel 
object

Name Change for 7.0.4

Siebel Tools Business 
service

Avaya IC Identify 
Charset

Used only for Avaya-first e-mail 
method which is not supported in 
Siebel 7.0.4.

Siebel Tools Integration 
Object

Avaya IC - Get 
Contact

Status field is not available.

Avaya IC - Put 
Contact

Siebel GUI Siebel 
workflow

Avaya IC EAI MIME 7.0.4 does not support MIME.

eai.cfg file File - [HTTP Services]
AvayaICAdapter = AvayaICEAIAdapter

[AvayaICEAIAdapter]
Mode = Document
Method = RunProcess
Service = Avaya IC Integration Business 
Service
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Siebel objects related to e-mail
The following table describes the differences in a Siebel 7.0.4 integration for Siebel objects 
related to e-mail. This applies only to a Siebel-first e-mail method.

Siebel 
interface

Siebel 
object

Name Change for 7.0.4

Siebel Tools Siebel 
workflow

eMail Response - 
Analyze Message

The Categorize block uses Smart 
Answer Client Service instead of Smart 
Answer Manager. Smart Answer Client 
Service is a new Siebel 7.5 Business 
Service.

eMail Response - 
Process Message

The Parse Message block uses the 
new Siebel 7.5 AckHtmlTemplateName 
and AckTextTemplateName.



Integrating with Siebel 7.0.4

368 Avaya Interaction Center for Siebel 7 Integration



Issue 4.0 November 2004 369

Chapter 17:Upgrading from Avaya IC 6.1 to 
6.1.3

This section includes the following topics:

● Before you begin on page 369

● Overview of tasks on page 370

● Upgrading on Avaya IC on page 371

● Upgrading on Siebel on page 373

● Re-running installation steps for an upgrade on page 375

Before you begin
Do the following tasks before beginning an upgrade:

● Back up your Avaya IC 6.1 servers. If problems occur, you can restore your 6.1 
configurations.

● Make sure you have a copy of the 6.1.3 IC/OA Software Upgrade and Data Migration 
guide.

● Read the considerations and prerequisites in the 6.1.3 IC/OA Software Upgrade and 
Data Migration guide.
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Overview of tasks
The following table provides an overview of the tasks that are required to perform an 
upgrade to 6.1.3.

3. When these tasks are completed, perform Re-running installation steps for an 
upgrade on page 375.

Server Tasks to upgrade Avaya 
IC to 6.1.3

Tasks to upgrade the Avaya IC for Siebel 
integration to 6.1.3

Avaya IC Upgrading the Avaya IC 
servers on page 371

1. Upgrading the Avaya IC for Siebel 
integration components on Avaya IC on 
page 371

Siebel Upgrading the Siebel 
servers on page 373

2. Upgrading the Avaya IC for Siebel 
integration components on Siebel on 
page 373
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Upgrading on Avaya IC
This section includes the following topics:

● Upgrading the Avaya IC servers on page 371

● Upgrading the Avaya IC for Siebel integration components on Avaya IC on page 371

Upgrading the Avaya IC servers

Upgrade the Avaya IC servers using the procedures in IC/OA Software Upgrade and Data 
Migration. Continue to Upgrading the Avaya IC for Siebel integration components on 
Avaya IC on page 371.

Upgrading the Avaya IC for Siebel integration components on 
Avaya IC

To upgrade the Avaya IC for Siebel integration components on Avaya IC:

1. Run the installer located on the integration CD.

Reference: For a detailed procedure, see Installing integration components on Avaya 
IC on page 170.

● If you have EAI installed on your Avaya IC server, select Interaction Engine 
Servers to upgrade the EAI.

● Select Design & Admin to upgrade Avaya Agent and the workflows.

The following table describes the directories that are backed up when you perform 
the Design & Admin upgrade on the Avaya IC server.

Description Source directory Backup directory (including 
subdirectories)

Avaya Agent <AVAYA_IC61_HOME>\design\
QConsole\siebel 

<AVAYA_IC61_HOME>\backup\
siebel\design\QConsole\siebel

Integration 
workflows

<AVAYA_IC61_HOME>\design\
IC\Flows\Siebel

<AVAYA_IC61_HOME>\backup\
siebel\design\IC\Flows\Siebel

<AVAYA_IC61_HOME>\design\
common\QWorkFlowDesigner\
catalogs

<AVAYA_IC61_HOME>\backup\
siebel\design\common\
QWorkFlowDesigner\catalogs
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2. If you have customized Avaya IC 6.1 workflows, reapply the customizations to the 
6.1.3 workflows and test the result. 

3. If you have customized your Avaya Agent implementation, reapply the customizations. 
In particular, check your Avaya Agent Integration Hook Handlers under the following 
directory:

<AVAYA_IC_HOME>\design\QConsole\siebel\custom

4. Continue to Re-running installation steps for an upgrade on page 375.
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Upgrading on Siebel
This section includes the following topics:

● Upgrading the Siebel servers on page 373

● Upgrading the Avaya IC for Siebel integration components on Siebel on page 373

Upgrading the Siebel servers

Upgrade the ORB Server on the Siebel Communication Servers using the procedures in 
IC/OA Software Upgrade and Data Migration. 

Continue to Upgrading the Avaya IC for Siebel integration components on Siebel on 
page 373.

Upgrading the Avaya IC for Siebel integration components on 
Siebel

To upgrade the Avaya IC for Siebel integration components on Siebel:

1. Manually backup the AICD.def and AICDStrings.txt files. Locate each file under the 
sub-directories for the languages they support.

Siebel directory Language

...\siebsrvr\bin\ENU US English

...\siebsrvr\bin\ESN Spanish

...\siebsrvr\bin\DEU German

...\siebsrvr\bin\FRA French

...\siebsrvr\bin\ITA Italian

...\siebsrvr\bin\PTB Brazilian Portuguese

...\siebsrvr\bin\CHS Simplified Chinese

...\siebsrvr\bin\KOR Korean

...\siebsrvr\bin\JPN Japanese

...\siebsrvr\bin\THA Thai
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2. Uninstall the 6.1 integration by doing the following steps:

a. Go to the Control Panel.

b. Select Add/Remove Programs.

c. Select Avaya Interaction Center Servers for Siebel 7.

d. Click Change/Remove.

2. Perform the procedure in Installing the AICD and the AED on page 191.

3. If the Avaya IC EAI server was installed on Siebel, upgrade the EAI server.

Select Interaction Engine Servers when the wizard prompts you.

Reference: For a detailed procedure, see Installing integration components on Avaya 
IC on page 170.

4. Continue to Re-running installation steps for an upgrade on page 375.



Re-running installation steps for an upgrade

Issue 4.0 November 2004 375

Re-running installation steps for an upgrade
After upgrading the Avaya IC software and the Siebel integration software, re-run some of 
the installation steps. Use the installation steps to check the accuracy of your installation 
and to apply the updates.

Upgrading for all channels

To re-run the installation steps to apply updates or verify the accuracy of the upgrade for all 
channels:

! Important:! Important:
Important: Read the wording of each step closely. You do not always have to re-run the 

steps. In some steps, verifying information is all that is required.

1. Perform Generating the Windows application on page 175 to apply the 6.1.3 updates 
to the Avaya Agent databases.

2. Verify Configuring Avaya IC on page 181 to check the accuracy of the Avaya IC 
properties.

3. Verify Creating a Siebel AICD server on page 188 to make sure that your 6.1 settings 
accurately upgraded to 6.1.3.

4. Restore the AICD.def and the AICDStrings.txt files.

5. Verify Configuring the AICD on page 195 to make sure that your 6.1 configuration 
accurately upgraded to 6.1.3. You do not need to change the configuration of the AICD 
for 6.1.3.

6. Verify Checking the AICD environment (optional) on page 203 because the AICD 
executable has changed. Use this procedure to verify your configuration.

7. Verify Importing a custom eScript for Siebel Universal Agent on page 206 to check 
your configuration. The Siebel workflow, Siebel Universal Agent has not changed.

8. Verify most of the procedures in Configuring the Avaya EAI servers on page 208 to 
make sure that your 6.1 configuration accurately upgraded to 6.1.3. 

You must re-run Importing and deploying the Siebel 7.7 workflow on page 222. 
Consider the following items:

● The Siebel workflows have changed. Reinstall the updated Siebel workflows from 
the integration CD and re-run all installation steps on the Siebel server.

● If you have modified the default 6.1 Siebel workflows, reapply your customized 
workflow files to the default 6.1.3 workflows in order to take advantage of the 6.1.3 
enhancements.
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Upgrading for voice and Web chat channels

Your customized Avaya IC voice or Web chat workflows will continue to work, but you must 
re-apply your customized workflows to the default Avaya IC workflows to take advantage of 
the 6.1.3 enhancements.

To re-run the installation steps to apply updates for voice and Web chat channels:

1. If your system has a voice channel, perform Configuring voice qualification 
workflows on page 161. 

2. If your system has a Web chat channel, perform Configuring Web chat qualification 
workflows on page 229.

Upgrading for an e-mail channel

Use this section if your system has an e-mail channel. This section includes the following 
topics:

● Avaya IC and Siebel workflow changes on page 376

● 6.1.3 eScript files on page 376

● Upgrading for an Avaya-first e-mail channel on page 377

● Upgrading for a Siebel-first e-mail channel on page 378

Avaya IC and Siebel workflow changes

Your 6.1 customized Avaya IC and Siebel e-mail workflows will continue to work in 6.1.3, 
but you must re-apply your customized workflows to the default 6.1.3 Avaya IC and Siebel 
workflows to take advantage of the 6.1.3 enhancements.

6.1.3 eScript files

Some Siebel eScript files have been internationalized. You can continue to use your 
existing Siebel eScript files or install the new 6.1.3 Siebel eScript files. The following Siebel 
eScript files have been changed to internationalize the error strings:

● AvayaICDriver.js

● CommInboundItemListApplet.js

● CommOutboundItemFormApplet.js

● SendCommunicationApplet.js (Avaya-first only)
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The AvayaICDriver.js file and the English error strings are imported using AvayaFirst.sif 
(for Avaya-first e-mail) or SiebelFirst.sif (for Siebel-first e-mail) on the integration CD. The 
localized strings are imported using the Siebel7.5_L10N.sif file.

Upgrading for an Avaya-first e-mail channel

! Important:! Important:
Important: Read the wording of each step closely. You do not always have to re-run the 

steps. In some steps, verifying information is all that is required.

You cannot use the Avaya-first e-mail method with Siebel 7.7.

Re-run the installation steps to apply updates or verify the accuracy of the upgrade for an 
Avaya-first e-mail channel.

Procedure Description

Obtaining the Catalog ID from Siebel on 
page 242

Use this procedure so agents replying to 
e-mails can access the full list of 
categories available in the Siebel catalog. 
This is new for 6.1.3.

Building the Avaya e-mail qualification 
workflows on page 245

For more information, see Avaya IC and 
Siebel workflow changes on page 376.

Configuring e-mail qualification 
workflows on page 246

The Avaya IC 6.1 configuration should 
upgrade to 6.1.3. Use these procedures to 
check the accuracy of your settings.

Configuring the workflow server to start the 
Trigger Cleanup Transfer workflow on 
page 250

Configuring the Avaya IC Resolve 
Status on page 253

Activating existing Siebel workflows on 
page 253

Importing new Siebel workflows on 
page 254

For more information, see Avaya IC and 
Siebel workflow changes on page 376.

Activating new Siebel workflows on 
page 255

Perform this procedure if you have 
changed your Siebel workflows.

Creating an e-mail profile on page 255 Use this procedure to verify that your 
configuration is still accurate.

Adding a charset variable on page 256
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Upgrading for a Siebel-first e-mail channel

! Important:! Important:
Important: Read the wording of each step closely. You do not always have to re-run the 

steps. In some steps, verifying information is all that is required.

Re-run the installation steps to apply updates or verify the accuracy of the upgrade for an 
Siebel-first e-mail channel.

Installing eScripts and English error strings 
on the Siebel server on page 257

If you want to take advantage of the new 
internationalized eScripts, perform these 
procedures. For more information, see 
6.1.3 eScript files on page 376.Importing the 

CommOutboundItemFormApplet.js file on 
page 261

Importing the 
CommInboundItemListApplet.js file on 
page 262

Importing the 
SendCommunicationApplet.js file on 
page 263

Compiling the SRF on page 264 If you have made any changes to your 
Siebel configuration, you must perform this 
procedure.

Installing the AED on page 266 Use this procedure to verify that your AED 
configuration is still accurate.
For more information about importing and 
activating the workflows, see Avaya IC and 
Siebel workflow changes on page 376.

Configuring Siebel for the AED on 
page 268

Configuring Smart Answer Manager on 
page 274

Use this procedure to verify that your 
configuration is still accurate.

Procedure Description

Procedure Description

Configuring the Avaya IC server on 
page 276

For more information, see Avaya IC and 
Siebel workflow changes on page 376.

Modifying the Send Communication 
Applet on page 282

Use this procedure only if you currently 
have an Avaya-first e-mail channel and 
want to change to a Siebel-first e-mail 
channel.
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Installing eScripts and English error strings 
on the Siebel server on page 285

If you want to take advantage of the new 
internationalized eScripts, perform these 
procedures. For more information, see 
6.1.3 eScript files on page 376.Importing the 

CommOutboundItemFormApplet.js file on 
page 290

Importing the 
CommInboundItemListApplet.js file on 
page 292

Compiling the SRF on page 293 If you have made any changes to your 
Siebel configuration, you must perform this 
procedure.

Starting the default Siebel workflows on 
page 295

Use this procedure to verify that your 
configuration is still accurate.

Administering the Siebel workflows on 
page 297

For more information, see Avaya IC and 
Siebel workflow changes on page 376.

Configuring Siebel to poll the mailbox on 
page 302

Use these procedures to verify that your 
configuration is still accurate.

Configuring Smart Answer Manager on 
page 306

Enabling Communications Outbound 
Manager on page 307

Procedure Description
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Appendix A: AICD commands

This section includes the following topics:

● Command definition on page 382

● Key-value parameters on page 383

● Selected vs. current work item on page 384

● Commands and media types on page 385

● How to access the buttons on page 386

● Overview of buttons and AICD 
commands on page 389

● AcceptEmail on page 392

● AcceptVoicePreviewCall on page 393

● AcceptWeb on page 394

● AgentAvailable on page 395

● AgentUnavailable on page 396

● AnswerCall on page 397

● AvayaAgentCommand on page 399

● CancelConferenceCall on page 400

● CancelConferenceWork on page 402

● CancelConsultTransferCall on page 404

● CancelConsultTransferWork on page 406

● CancelEmail on page 408

● ChangeAuxReasonCode on page 409

● CompleteConferenceCall on page 410

● CompleteConferenceWork on page 412

● CompleteConsultTransferCall on page 414

● CompleteConsultTransferWork on 
page 416

● DeferEmail on page 418

● DisconnectWork on page 419

● EmailAvailable on page 420

● EmailUnavailable on page 421

● ForwardEmail on page 422

● HangupCall on page 424

● HoldCall on page 425

● HoldReconnectCall on page 426

● InitConferenceCall on page 427

● InitConferenceWork on page 429

● InitConsultTransferCall on page 431

● InitConsultTransferWork on page 433

● Login on page 435

● Logout on page 436

● MakeCall on page 437

● MuteTransferCall on page 438

● MuteTransferWork on page 439

● NewOpenData on page 440

● RejectVoicePreviewCall on page 442

● ReleaseWork on page 443

● ReplyEmail on page 444

● ResumeEmail on page 446

● SendEmail on page 447

● SendNewEmail on page 449

● SetCurrentWorkItem on page 450

● ShowStatusText on page 451

● VoiceAvailable on page 452

● VoiceUnavailable on page 453

● WebAvailable on page 454

● WebUnavailable on page 455
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Command definition
The system uses commands to send requests and data to the Adaptive Interaction Center 
Driver (AICD). When an agent presses a button on the Siebel toolbar, a command is sent 
to the AICD. The Siebel definition file defines the association of the Siebel toolbar buttons 
and the commands. Another way to call a command is through an event response.

Commands always flow from the Siebel Communications Server to the AICD.

Related topics

For more information, see any of the following topics:

● For a description of an event response, see AICD events on page 457.

● For a detailed description of the Siebel toolbar, see the Avaya IC for Siebel User Guide.

● Siebel definition file on page 108

● Customizing the definition file on page 109
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Key-value parameters
Key-value parameters represent input data to AICD commands. Most commands sent to 
the AICD have parameters. Each parameter consists of a parameter key and a parameter 
value. These parameters can be either mandatory or optional. If optional, the AICD 
assumes the default parameter value when the command is called. The default values for 
the optional parameters are specified in this appendix.

Related topic

For similar information, see Differences in terminology on page 24.
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Selected vs. current work item
This section describes the difference between selected work items and current work items.

Selected work item - A selected work item is always highlighted in the appropriate Avaya 
Agent task list and in the EDU Viewer. The Accept Work Item button is always associated 
with the selected work item.

The following commands default to the selected work item if no Tracking ID is provided:

● AcceptEmail

● AcceptVoicePreviewCall

● AcceptWeb

● AnswerCall

Current work item - The Work Item drop-down list always displays the current work item.

All remaining commands that are not associated with a selected work item will default to 
the current work item if no Tracking ID is provided.

The Tracking ID and work items - If the Tracking ID is provided, the Tracking ID is used 
to locate the work item. The Tracking ID overrides the default of current or selected work 
item. For example, the current work item can be a call, but someone can issue a 
ReleaseWork command on an e-mail by specifying the Tracking ID of the e-mail work item.

Related topic

For more information, see Avaya Agent User Guide.
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Commands and media types
In general, AICD commands are restricted to act on work items of a particular media type. 
For example, the DeferEmail command acts only on work items with an email media type. 
Also, a work item must be in the correct state for a command to act on it. For example, the 
HoldReconnectCCall command is permitted for work items with the voice media type, but 
only if the voice work item is currently on hold.

Related topic

For more information, see Media types on page 495.
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How to access the buttons
This section includes the following topics:

● Siebel Communications Toolbar on page 386

● Change Ready State submenu on page 386

● Send Email window on page 387

● Communication Detail - Response View on page 387

Siebel Communications Toolbar

Most of the buttons described in this chapter are accessed from the Siebel toolbar which is 
located near the top of the Siebel Application window.

Related topic

For more information about the Siebel toolbar, see the Avaya IC for Siebel User Guide.

Change Ready State submenu

Use the Change Ready State submenu to access the Change Ready State E-mail, Change 
Ready State Phone, and Change Ready State Web buttons. 

To display the Change Ready State submenu:

1. From the Siebel toolbar, click the arrow to the right of the Change Ready State button.

Example:

Result:
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Send Email window

The Send Email window opens when the agent presses the F9 key or selects the Initiate 
Email button. The agent uses this window to compose e-mail messages.

Communication Detail - Response View

Use the Communication Detail - Response View to access the Cancel E-mail, Forward 
E-mail, Reply E-mail, Reply All E-mail, and Send E-mail buttons. This view is located in the 
middle of the Siebel Application window and is used for outgoing e-mail messages.
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Communication
 Detail - Response View
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Overview of buttons and AICD commands
The following table shows the buttons, button names, button locations, and corresponding 
AICD commands.

Button Button name Button location Commands

Accept Work 
Item

Siebel 
Communications 
Toolbar

AcceptEmail

AcceptVoicePreviewCall

AcceptWeb

AnswerCall

Blind Transfer Siebel 
Communications 
Toolbar

MuteTransferCall

MuteTransferWork

Cancel E-mail Communication 
Detail - Response 
View

CancelEmail

Change 
Ready State

Siebel 
Communications 
Toolbar

AgentAvailable

AgentUnavailable

Change 
Ready State 
E-mail

Change Ready State 
submenu

EmailAvailable

EmailUnavailable

Change 
Ready State 
Phone

Change Ready State 
submenu

VoiceAvailable

VoiceUnavailable

Change 
Ready State 
Web

Change Ready State 
submenu

WebAvailable

WebUnavailable
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Conference 
Work Item

Siebel 
Communications 
Toolbar

CompleteConferenceCall

CompleteConferenceWork

InitConferenceCall

InitConferenceWork

Consultative 
Transfer

Siebel 
Communications 
Toolbar

InitConsultTransferCall

InitConsultTransferWork

CompleteConsultTransferCall

CompleteConsultTransferWork

Forward 
E-mail

Communication 
Detail - Response 
View

ForwardEmail

Initiate Work 
Item Email

Siebel 
Communications 
Toolbar

This button does not generate an 
AICD command. Instead, the 
Send Email window pops up so 
that the agent can compose an 
e-mail. This window includes a 
Send button that calls the 
SendNewEmail command.

Initiate Work 
Item Phone

Siebel 
Communications 
Toolbar

MakeCall

Pause Work 
Item

Siebel 
Communications 
Toolbar

DeferEmail

HoldCall

Release Work 
Item

Siebel 
Communications 
Toolbar

DisconnectWork

HangupCall

RejectVoicePreviewCall

CancelEmail

ReleaseWork

Reply E-mail Communication 
Detail - Response 
View

ReplyEmail

Button Button name Button location Commands
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Reply All 
E-mail

Communication 
Detail - Response 
View

ReplyEmail

Resume Work 
Item

Siebel 
Communications 
Toolbar

HoldReconnectCall

ResumeEmail

Cancel Work 
Item

Siebel 
Communications 
Toolbar

CancelConsultTransferCall

CancelConsultTransferWork

CancelConferenceCall

CancelConferenceWork

Send E-mail Send Email window SendNewEmail

Sign On Siebel 
Communications 
Toolbar

Login

Button Button name Button location Commands
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AcceptEmail
When the agent selects the blinking Accept Work Item button and the selected work item is 
an offered e-mail work item, the following actions occur:

● The e-mail work item is accepted.

● The e-mail work item is popped if not already popped.

● The e-mail work item is now the current work item. 

● If the TrackingID is passed, the e-mail specified by the TrackingID is accepted rather 
than the selected work item.

Parameter

The AcceptEmail command has the following parameter.

Media type

The AcceptEmail command is permitted on work items with only the email media type 
when offered.

Related topic

For more information, see Media types on page 495.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was 
supplied in the OnNewWorkItem event.

Yes
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AcceptVoicePreviewCall
When the agent selects the blinking Accept Work Item button and the selected work item is 
an offered voice preview call work item, the following actions occur:

● The voice preview work item is accepted and the call is placed.

● If the TrackingID is passed, the e-mail specified by the TrackingID is accepted rather 
than the selected work item.

Related topic

For more information, see RejectVoicePreviewCall on page 442.

Parameter

The AcceptVoicePreviewCall command has the following parameter.

Media type

The AcceptVoicePreviewCall command is permitted on work items with only the 
voicePreview media type when the voicePreview work item has been offered to the agent 
but the agent has not yet accepted or rejected the work item.

Related topic

For more information, see Media types on page 495.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was 
supplied in the OnNewWorkItem event.

Yes
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AcceptWeb
When the agent selects the blinking Accept Work Item button and the selected work item is 
an offered Web chat work item, the following actions occur:

● The Web chat work item is accepted and the call is placed.

● The Web chat work item is popped if not already popped.

● The Web chat work item is now the current work item.

● The Avaya Web Agent is brought to the foreground.

● If the TrackingID is passed, the Web chat specified by the TrackingID is accepted rather 
than the selected work item.

Parameter

The AcceptWeb command has the following parameter.

Media types

The AcceptWeb command is permitted on work items with the following media types when 
offered:

● web

● webIVChat

● webVoice

Related topic

For more information, see Media types on page 495.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was 
supplied in the OnNewWorkItem event.

Yes
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AgentAvailable
The AgentAvailable command makes the agent available for incoming customer contacts. 
The agent is available only on channels that the agent is logged into and the channel load 
is greater than zero. The agent will not receive outbound work while the agent is available 
for inbound work. If the agent is available for inbound work and is configured for outbound 
work and an outbound job is running, the agent can be drafted into receiving the outbound 
work item.

This command is permitted when the agent is unavailable for incoming work, and not in 
outbound mode.

Parameters

The AgentAvailable command has no parameters.
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AgentUnavailable
The AgentUnavailable command makes the agent unavailable for incoming customer 
contacts. The agent will receive neither inbound nor outbound work while the agent is 
unavailable. 

This command is permitted when the agent is available for incoming work, and not in 
outbound mode.

Parameter

The AgentUnavailable command has the following parameter.

Name Value Optional?

Reason A reason code for the agent being 
unavailable.

Yes. If not supplied, the reason 
code is set to ìî.
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AnswerCall
When the agent selects the blinking Accept Work Item button and the selected work item is 
an offered call, the following actions occur:

● The call is answered.

● The call work item is popped if not already popped.

● The call work item is now the current work item.

● If another call was previously active, the previously-active call is placed on hold.

● If the TrackingID is passed, the call specified by the TrackingID is answered rather than 
the selected work item.

Parameter

The AnswerCall command has the following parameter.

Media types

The AnswerCall command is permitted on work items with the following media types when 
offered:

● voice

● voiceAutoDial

● voiceOut

● voicePredictive

● voicePreview

● webIVChat

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied in 
the OnNewWorkItem event.

Yes
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● webVoice

Related topic

For more information, see Media types on page 495.
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AvayaAgentCommand
The AvayaAgentCommand enables the implementation of a custom driver command that 
can be associated with a toolbar button and does the following actions:

● Sends a request from the Siebel agent to a hook within Avaya Agent. 

● Functions as a placeholder. The actual custom command name can be passed as one 
of the parameters. All key-value parameters are delivered to Avaya Agent. The 
parameters are transferred to the custom script within Avaya Agent.

● Enabled as long as Avaya Agent is successfully assigned to the AICD.

Related topic

For more information, see OnAvayaAgentEvent on page 462.

Parameters

The AvayaAgentCommand accepts all parameters.
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CancelConferenceCall
The CancelConferenceCall command cancels a conference call while it is in the consult 
stage. If the TrackingID is passed, the conference call in progress for the work item 
specified by the TrackingID is cancelled. Otherwise, the current work item conference call 
is cancelled.

The CancelConferenceCall works as follows:

1. The InitConferenceCall command initiates a conference call.

2. The InitConferenceCall command puts the contact on hold while a consult call is 
attempted between the original agent and the conference-to agent. 

3. The original agent cancels the conference call from the Siebel toolbar.

4. The CancelConferenceCall command is generated. 

5. The consult call is dropped and the original call is reconnected.

Related topics

For more information, see the following topics:

● InitConferenceCall on page 317

● CompleteConferenceCall on page 312

Parameter

This command has the following parameter.

Media types

This command is permitted on work items with the following media types when a 
conference call is in the consult stage:

● voice

● voiceAutoDial

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied 
in the OnNewWorkItem event.

Yes
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● voiceOut

● voicePredictive

● voicePreview

Related topic

For more information, see Media types on page 495.
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CancelConferenceWork
The CancelConferenceWork command cancels the conference of a multimedia work item 
such as a webVoice or webIVChat while it is in the consult stage. If the TrackingID is 
passed, the conference in progress for the work item specified by the TrackingID is 
cancelled. Otherwise, the current work item conference is cancelled.

The CancelConferenceWork command works as follows:

1. The InitConferenceWork command initiates a multimedia conference call.

2. The InitConference command conferences the call portion of the multimedia item.

3. The contact phone call is put on hold while a consult call is attempted between the 
original agent and the conference-to agent. 

4. The original agent cancels the multimedia conference call from the Siebel toolbar.

5. The CancelConferenceWork command is generated.

6. The consult call is dropped and the original call reconnected.

Related topics

For more information, see the following topics:

● InitConferenceWork on page 318

● CompleteConferenceWork on page 313

Parameter

This command has the following parameter.

Media types

This command is permitted on work items with the following media types when the voice 
portion of the work item is in the consult stage of a conference call:

● webIVChat

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied in 
the OnNewWorkItem event.

Yes
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● webVoice

Related topic

For more information, see Media types on page 495.
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CancelConsultTransferCall
The CancelConsultTransferCall command cancels a consult transfer call while it is in the 
consult stage. If the TrackingID is passed, the consult transfer call in progress for the work 
item specified by the TrackingID is cancelled. Otherwise, the current work item consult 
transfer call is cancelled.

The CancelConsultTransferCall command works as follows:

1. The InitConsultTransferCall command initiates a consult transfer call.

2. The InitConsultTransferCall command puts the contact on hold while a consult call is 
attempted between the original agent and the conference-to agent.

3. The original agent cancels the consult transfer call from the Siebel toolbar.

4. The CancelConsultTransferCall command is generated.

5. The consult call is dropped and the original call is reconnected.

Related topics

For more information, see the following topics:

● InitConsultTransferCall on page 321

● CompleteConsultTransferCall on page 315

Parameter

This command has the following parameter.

Media types

This command is permitted on work items with the following media types when the consult 
transfer call is in the consult stage:

● voice

● voiceAutoDial

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied 
in the OnNewWorkItem event.

Yes
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● voiceOut

● voicePredictive

● voicePreview

Related topic

For more information, see Media types on page 495.
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CancelConsultTransferWork
The CancelConsultTransferWork command cancels the consult transfer of a multimedia 
work item such as a webVoice or webIVChat while it is in the consult stage. If the 
TrackingID is passed, the consult transfer in progress for the work item specified by the 
TrackingID is cancelled. Otherwise, the current work item consult transfer is cancelled.

The CancelConsultTransferWork command works as follows:

1. The InitConsultTransferWork command initiates a multimedia consult transfer call.

2. The InitConsultTransferWork command consult transfers the call portion of the 
multimedia work item.

3. The contact phone call is put on hold while a consult call is attempted between the 
original agent and the consult transfer-to agent.

4. The original agent cancels the multimedia consult transfer call from the Siebel toolbar.

5. The CancelConsultTransferWork command is generated.

6. The consult call is dropped and the original call is reconnected.

Related topics

For more information, see the following topics:

● InitConsultTransferWork on page 322

● CompleteConsultTransferWork on page 315

Parameter

This command has the following parameter.

Media types

This command is permitted on work items when the voice portion of the multimedia work 
item is in the consult stage of a consult transfer call:

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied in 
the OnNewWorkItem event.

Yes
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● webIVChat

● webVoice

Related topic

For more information, see Media types on page 495.
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CancelEmail
The CancelEmail command cancels the composition of an e-mail reply or forward 
message. If the TrackingID is passed, the e-mail reply or forward message in progress for 
the work item specified by the TrackingID is cancelled. Otherwise, the current work item 
e-mail reply or forward message is cancelled.

The CancelEmail command works as follows:

1. The Communication Detail - Response View is popped when the agent receives 
e-mail.

2. When the agent selects the Reply, Reply to All, or Forward buttons, the 
Communication Detail - Response View is enabled.

3. The agent replies to or forwards the e-mail. While the agent is composing the e-mail 
message, the agent cannot dismiss, transfer, or defer the original e-mail.

4. The agent cancels the e-mail by selecting the Cancel button from the Siebel toolbar.

5. The CancelEmail command cancels the composition of the e-mail message.

6. The Communication Detail - Response View is cleared and disabled.

7. The agent can now dismiss, transfer, or defer the original e-mail.

Parameter

This command has the following parameter.

Media type

This command is permitted on work items with the email media type when the e-mail is in 
the process of being replied to or forwarded.

Related topic

For more information, see Media types on page 495.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied 
in the OnNewWorkItem event.

Yes
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ChangeAuxReasonCode
The ChangeAuxReasonCode command changes the Aux Reason Code while the agent is 
unavailable. The agent can use this command if his or her reason for being unavailable 
changes. For example, the agent is at lunch, then attends a meeting directly afterwards.

The ChangeAuxReasonCode command is permitted when the agent is unavailable.

Parameter

This command has the following parameter.

Name Value Optional?

Reason A reason code for the agent being 
unavailable.

Yes. If not supplied, the 
reason code is set to ìî.
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CompleteConferenceCall
The CompleteConferenceCall command completes a conference call while it is in the 
consult stage. If the TrackingID is passed, the conference call in progress for the work item 
specified by the TrackingID is completed. Otherwise, the current work item conference call 
is completed.

The CompleteConferenceCall command works as follows:

1. The agent selects the Conference Work Item button from the Siebel toolbar.

2. The InitConferenceCall command generates a conference call and puts the contact on 
hold while a consult call is attempted between the original agent and the conference-to 
agent. 

3. The original agent completes the conference call by selecting the Conference Work 
Item button from the Siebel toolbar.

4. The CompleteConferenceCall command is generated. 

5. The consult call and the original call are merged, resulting in a conference call.

Related topics

For more information, see the following topics:

● InitConferenceCall on page 427

● CancelConferenceCall on page 400

Parameter

This command has the following parameter.

Media types

This command is permitted on work items with the following media types when the work 
item is in the consult stage of a conference call:

● voice

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was 
supplied in the OnNewWorkItem event.

Yes
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● voiceAutoDial

● voiceOut

● voicePredictive

● voicePreview

Related topic

For more information, see Media types on page 495.
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CompleteConferenceWork
The CompleteConferenceWork command completes the conference of a multimedia work 
item such as a combined chat&PSTN call or chat&VOIP call while it is in the consult stage. 
If the TrackingID is passed, the conference in progress for the work item specified by the 
TrackingID is completed. Otherwise, the current work item conference is completed.

The CompleteConferenceWork command works as follows:

1. The agent selects the Conference Work Item button from the Siebel toolbar.

2. The InitConferenceWork command initiates a multimedia conference call and 
conferences the call portion of the multimedia item.

3. The contact phone call is put on hold while a consult call is attempted between the 
original agent and the conference-to agent. 

4. Once the consult call is connected, the original agent completes the multimedia 
conference call by selecting the Conference Work Item button from the Siebel toolbar.

5. The CompleteConferenceWork command is generated. 

6. All parties are conferenced together, including the Web chat.

Related topics

For more information, see the following topics:

● InitConferenceWork on page 429

● CancelConferenceWork on page 402

Parameter

This command has the following parameter.

Media types

This command is permitted on work items with the following media types when the voice 
portion of the multimedia work item is in the consult stage of a conference call:

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was 
supplied in the OnNewWorkItem event.

Yes
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● web

● webIVChat

● webVoice

Related topic

For more information, see Media types on page 495.
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CompleteConsultTransferCall
The CompleteConsultTransferCall command completes a consult transfer call while it is in 
the consult stage. If the TrackingID is passed, the consult transfer call in progress for the 
work item specified by the TrackingID is completed. Otherwise, the current work item 
consult transfer call is completed.

The CompleteConsultTransferCall command works as follows:

1. The agent selects the Consultative Transfer button from the Siebel toolbar and initiates 
the InitConsultTransferCall command.

2. The contact is put on hold while a consult call is attempted between the original agent 
and the conference-to agent. 

3. While the consult call is connected, the original agent completes the consult transfer 
call by selecting the Consultative Transfer button from the Siebel toolbar.

4. The CompleteConsultTransferCall command is generated.

5. The customer and the transfer-to agent are connected into one call and the original 
agent is dropped.

Related topics

For more information, see the following topics:

● InitConsultTransferCall on page 431

● CancelConsultTransferCall on page 404

Parameter

This command has the following parameter.

Media types

This command is permitted on work items with the following media types when the work 
item is in the consult stage of a consult transfer call:

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was 
supplied in the OnNewWorkItem event.

Yes
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● voice

● voiceAutoDial

● voiceOut

● voicePredictive

● voicePreview

Related topic

For more information, see Media types on page 495.
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CompleteConsultTransferWork
The CompleteConsultTransferWork command completes the consult transfer of a 
multimedia item such as a webVoice or webIVChat, while it is in the consult stage. If the 
TrackingID is passed, the consult transfer in progress for the work item specified by the 
TrackingID is completed. Otherwise, the current work item consult transfer is completed.

The CompleteConsultTransferWork command works as follows:

1. The agent selects the Consultative Transfer button from the Siebel toolbar.

2. The InitConsultTransferWork command generates a multimedia consult transfer call.

3. The InitConsultTransferWork command performs a consult transfer on the call portion 
of the multimedia work item.

4. The contact phone call is put on hold while a consult call is attempted between the 
original agent and the consult transfer-to agent. 

5. The original agent completes the multimedia consult transfer call by selecting the 
Consultative Transfer button from the Siebel toolbar.

6. The CompleteConsultTransferWork command is generated.

7. The original agent is dropped from all calls and the consult-to agent is put on an active 
call with the customer contact. 

8. The Web chat is briefly conferenced between all parties before the original agent is 
dropped from the chat.

Related topics

For more information, see the following topics:

● InitConsultTransferWork on page 433

● CancelConsultTransferWork on page 406

Parameter

This command has the following parameter.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was 
supplied in the OnNewWorkItem event.

Yes
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Media types

This command is permitted on work items with the following media types when the voice 
portion of the multimedia work item is in the consult stage of a consult transfer call:

● webIVChat

● webVoice

Related topic

For more information, see Media types on page 495.
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DeferEmail
The DeferEmail command postpones the sending of an e-mail. If the TrackingID is passed, 
the e-mail work item specified by the TrackingID is deferred. Otherwise, the current work 
item is deferred.

Related topics

For more information, see ResumeEmail on page 446.

Parameter

This command has the following parameter.

Media type

This command is permitted on work items with the email media type when the work item is 
active.

Related topic

For more information, see Media types on page 495.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was 
supplied in the OnNewWorkItem event.

Yes
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DisconnectWork
The DisconnectWork command stops work on a customer interaction phase of an e-mail, 
Web chat, or multimedia work item. Conceptually, this is equivalent to hanging up on a 
phone call. For multimedia items, this disconnects the Web chat, but leaves the phone call 
active. The HangupCall command disconnects the phone call. Depending on the system 
configuration, a work item can go into wrap-up immediately after the DisconnectWork 
command. If the TrackingID is passed, the work item specified by the TrackingID is 
disconnected. Otherwise, the current work item is disconnected.

Related topics

For more information, see the following topics:

● HangupCall on page 424

● ReleaseWork on page 443

Parameter

This command has the following parameter.

Media types

This command is permitted on work items with the following media types when the work 
item is connected:

● email

● web

● webIVChat

● webVoice

Related topic

For more information, see Media types on page 495.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied in 
the OnNewWorkItem event.

Yes
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EmailAvailable
The EmailAvailable command makes the agent available for e-mail work. If making the 
agent available for e-mail also makes the agent available for all logged-in channels, the 
agent is also placed in automatic mode. 

The EmailAvailable command is permitted when the agent is:

● Available for incoming work

● Unavailable for e-mail

● Logged into the e-mail channel

● Not in outbound mode

Parameters

The EmailAvailable command has no parameters.
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EmailUnavailable
The EmailUnavailable command makes the agent unavailable for e-mail work. The agent 
is also placed in manual mode.

This command is permitted when the agent is:

● Available for incoming work

● Available for e-mail

● Logged into the e-mail channel

● Not in outbound mode

Parameters

The EmailUnavailable command has no parameters.
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ForwardEmail
The ForwardEmail command begins the process of forwarding an e-mail message. If the 
TrackingID is passed, an e-mail for the work item specified by the TrackingID is forwarded. 
Otherwise, the current work item is forwarded.

The ForwardEmail command works as follows:

1. The Communication Detail - Response View is popped when the agent receives an 
e-mail message.

2. The agent selects the Forward button on the Communication Detail - Response 
View.

3. The ForwardEmail command is generated.

4. The Communication Detail - Response View is enabled, and the agent can then edit 
the e-mail. 

5. When the agent is finished composing the e-mail, the agent selects the Send button in 
the Communication Detail - Response View. 

6. The SendEmail command forwards the e-mail message. 

7. The Communication Detail - Response View is cleared and disabled. 

8. The agent is permitted to dismiss, transfer, or defer the original e-mail, and can also 
compose a reply, or forward the e-mail again.

Related topics

For more information, see the following topics:

● SendEmail on page 447

● ReplyEmail on page 444

● CancelEmail on page 408

Parameter

This command has the following parameter.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied in 
the OnNewWorkItem event.

Yes
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Media type

This command is permitted on work items with the email media type when the work item is 
active.

Related topic

For more information, see Media types on page 495.
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HangupCall
The HangupCall command hangs up a call. If the TrackingID is passed, the work item 
specified by the TrackingID is hung up. Otherwise, the current work item is hung up.

Related topics

For more information, see the following topics:

● DisconnectWork on page 419

● ReleaseWork on page 443

Parameter

This command has the following parameter.

Media types

This command is permitted on work items with the following media types when the call is 
active:

● voice

● voiceAutoDial

● voiceOut

● voicePredictive

● voicePreview

● webIVChat

● webVoice

Related topic

For more information, see Media types on page 495.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was 
supplied in the OnNewWorkItem event.

Yes
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HoldCall
The HoldCall command puts a call on hold. For multimedia work items, the Web chat 
portion of the work item is still active even when the call is on hold. If the TrackingID is 
passed, the call work item specified by the TrackingID is put on hold. Otherwise, the 
current work item is put on hold. 

Related topics

For more information, see the following topics:

● DeferEmail on page 418

● HoldReconnectCall on page 426

Parameter

This command has the following parameter.

Media types

This command is permitted on work items with the following media types when the call is 
active and no consult call is ringing:

● voice

● voiceAutoDial

● voiceOut

● voicePredictive

● voicePreview

● webIVChat

● webVoice

Related topic

For more information, see Media types on page 495.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied in 
the supplied in the OnNewWorkItem event.

Yes
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HoldReconnectCall
The HoldReconnectCall command takes a call off hold. For multimedia work items, the 
Web chat portion of the work item is still active even when the call is on hold, so this 
command affects only the call. If the TrackingID is passed, the call work item specified by 
the TrackingID is taken off hold. Otherwise, the current work item is taken off hold. 

Related topics

For more information, see the following topics:

● DeferEmail on page 418

● HoldCall on page 425

Parameter

This command has the following parameter.

Media types

This command is permitted on work items with the following media types when the call is 
on hold:

● voice

● voiceAutoDial

● voiceOut

● voicePredictive

● voicePreview

● webIVChat

● webVoice

Related topic

For more information, see Media types on page 495.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied in 
the supplied in the OnNewWorkItem event.

Yes
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InitConferenceCall
The InitConferenceCall command initiates a conference call. If the TrackingID is passed, 
the conference call for the work item specified by the TrackingID is initiated. Otherwise, a 
conference call on the current work item is initiated.

The InitConferenceCall command works as follows:

1. The agent selects the Conference Work Item button from the Siebel toolbar.

2. The InitConferenceCall command initiates a conference call by putting the contact on 
hold while a consult call is attempted between the original agent and the conference-to 
agent.

3. The original agent does one of the following tasks:

● Completes the conference call by selecting the Conference Work Item button. This 
generates the CompleteConferenceCall command.

● Cancels the conference call by selecting the Cancel Work Item button. This 
generates the CancelConferenceCall command.

Related topics

For more information, see the following topics:

● CompleteConferenceCall on page 410

● CancelConferenceCall on page 400

Parameters

This command has the following parameters.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was 
supplied in the OnNewWorkItem event.

Yes

Destination An extension, phone number, agent ID, or queue Yes

SuppressUAD Can be true or false.
If true, and a destination is supplied, the presentation 
of the UAD is suppressed.

Yes. If not 
supplied, 
the default 
is false.

<Open> - Yes



AICD commands

428 Avaya Interaction Center for Siebel 7 Integration

Related topics

For more information, see the following topics:

● About open data on page 311

● OnNewWorkItem on page 484

Media types

This command is permitted on work items with the following media types when the call is 
active and not on hold:

● voice

● voiceAutoDial

● voiceOut

● voicePredictive

● voicePreview

Related topic

For more information, see Media types on page 495.
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InitConferenceWork
The InitConferenceWork command initiates the conference of a Web chat or multimedia 
work item such as a webVoice or webIVchat. If the TrackingID is passed, a conference for 
the work item specified by the TrackingID is initiated. Otherwise, a conference for the 
current work item is initiated.

The InitConferenceWork command works as follows:

1. The agent selects the Conference Work Item button on the Siebel toolbar to initiate a 
multimedia conference.

2. The InitConference command conferences the call portion of the multimedia work item. 
The contact phone call is put on hold while a consult call is attempted between the 
original agent and the conference-to agent. 

3. Once the consult call is connected, the original agent completes the multimedia 
conference call by selecting the Conference Work Item button on the Siebel toolbar.

4. The CompleteConferenceWork command is generated.

Note:
Note: The agent can also cancel the multimedia conference call by selecting the 

Cancel Work Item button and generating the CancelConferenceWork 
command. 

You can also use the InitConferenceWork command to initiate a Web chat conference. 
Chat conferences are one-step conferences. That is, they do not have a consult stage and 
they are completed automatically as soon as the other agent is connected. No further 
commands are needed to complete the chat conference, and it is not possible to cancel a 
chat conference.

Related topics

For more information, see the following topics:

● CompleteConferenceWork on page 412

● CancelConferenceWork on page 402
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Parameters

This command has the following parameters.

Related topic

For more information, see About open data on page 311.

Media types

This command is permitted on work items with the following media types when a Web chat 
is connected:

● web

● webIVChat

● webVoice

For webIVchat and webVoice, the call must be active and cannot be on hold.

Related topic

For more information, see Media types on page 495.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was 
supplied in the OnNewWorkItem event.

Yes

Destination An extension, phone number, agent ID, or 
queue

Yes

SuppressUAD Can be true or false.
If true, and a destination is supplied, the 
presentation of the UAD is suppressed.

Yes. If not 
supplied, the 
default is 
false.

<Open> - Yes
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InitConsultTransferCall
The InitConsultTransferCall command initiates a consult transfer call. If the TrackingID is 
passed, a consult transfer call for the work item specified by the TrackingID is initialized. 
Otherwise, a consult transfer call for the current work item is initialized.

The InitConsultTransferCall command works as follows:

1. The agent selects the Consultative Transfer button from the Siebel toolbar.

2. The InitConsultTransferCall command initiates a consult transfer call by putting the 
contact on hold while a consult call is attempted between the original agent and the 
conference-to agent. 

3. While the consult call is connected, the original agent does one of the following tasks:

● Completes the consult transfer call by selecting the Consultative Transfer button. 
This generates the CompleteConsultTransferCall command.

● Cancels the consult transfer call by selecting the Cancel Work Item button. This 
generates the CancelConsultTransferCall command.

Related topics

For more information, see the following topics:

● CompleteConsultTransferCall on page 414

● CancelConsultTransferCall on page 404
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Parameters

This command has the following parameters.

Related topic

For more information, see About open data on page 311.

Media types

This command is permitted on work items with the following media types when the call is 
active and not on hold:

● voice

● voiceAutoDial

● voiceOut

● voicePredictive

● voicePreview

Related topic

For more information, see Media types on page 495.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was 
supplied in the OnNewWorkItem event.

Yes

Destination An extension, phone number, agent ID, or 
queue

Yes

SuppressUAD Can be true or false.
If true, and a destination is supplied, the 
presentation of the UAD is suppressed.

Yes. If not 
supplied, the 
default is 
false.

<Open> - Yes
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InitConsultTransferWork
The InitConsultTransferWork command initiates the consult transfer of a multimedia item 
such as a webVoice or webIVChat. If the TrackingID is passed, a consult transfer for the 
work item specified by the TrackingID is initiated. Otherwise, a consult transfer of the 
current work item is initiated.

The InitConsultTransferWork command works as follows:

1. The agent selects Consultative Transfer button from the Siebel toolbar.

2. The InitConsultTransferWork command initiates a multimedia consult transfer call by 
performing a consult transfer of the call portion of the multimedia work item. 

3. The contact phone call is put on hold while a consult call is attempted between the 
original agent and the consult transfer-to agent.

4. The original agent does one of the following tasks:

● Completes the multimedia consult transfer call by selecting the Consultative 
Transfer button. This generates the CompleteConsultTransferWork command.

● Cancels the multimedia consult transfer by selecting the Cancel Work Item button. 
This generates the CancelConsultTransferWork command.

Related topics

For more information, see the following topics:

● CompleteConsultTransferWork on page 416

● CancelConsultTransferWork on page 406

Parameters

This command has the following parameters.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was 
supplied in the OnNewWorkItem event.

Yes

Destination An extension, phone number, agent ID, or queue Yes
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Related topics

For more information, see About open data on page 311.

Media types

This command is permitted on work items with the following media types when the voice 
portion of the multimedia work item is active and not on hold:

● webIVChat

● webVoice

Related topic

For more information, see Media types on page 495.

SuppressUAD Can be true or false.
If true, and a destination is supplied, the presentation 
of the UAD is suppressed.

Yes. If not 
supplied, 
the default 
is false.

<Open> - Yes

Name Value Optional?
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Login
The Login command logs the agent into the Interaction Center. This command is permitted 
when the agent is logged out.

The Login command forms the necessary association between the Siebel agent session 
and Avaya Agent. This command does not log the agent into an Automatic Call Distribution 
(ACD) split.

Parameter

This command has the following parameter.

Name Value Optional?

AgentID <UserName> 
Use the @UserName macro to obtain the Siebel agent login 
name that is passed as the value of the AgentID parameter.

No
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Logout
The Logout command logs the agent out of the Interaction Center. The Logout command is 
permitted when the agent is logged in.

Parameter

This command has the following parameter.

Name Value Optional?

AgentID <UserName> 
Use the @UserName macro to obtain this value.

No
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MakeCall
The MakeCall command places an outgoing call. MakeCall creates a voiceOut work item.

This command is permitted when the agent is connected to telephony services and is not 
already active on another call.

Parameters

This command has the following parameters.

Related topic

For more information, see About open data on page 311.

Name Value Optional?

Destination An extension, phone number, agent ID, or queue Yes

SuppressUAD Can be true or false.
If true, and a destination is supplied, the 
presentation of the UAD is suppressed.

Yes. If not 
supplied, the 
default is false.

<Open> - Yes
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MuteTransferCall
The MuteTransferCall command performs a one-step transfer of a call, also called a blind 
transfer. If the TrackingID is passed, a blind transfer for the work item specified by the 
TrackingID is performed. Otherwise, a blind transfer of the current work item is performed.

Parameters

This command has the following parameters.

Related topic

For more information, see About open data on page 311.

Media types

This command is permitted on work items with the following media types when the call is 
active and not on hold:

● voice

● voiceAutoDial

● voiceOut

● voicePredictive

● voicePreview

Related topic

For more information, see Media types on page 495.

Name Value Optional?

Destination An extension, phone number, agent ID, or 
queue

Yes

SuppressUAD Can be true or false.
If true, and a destination is supplied, the 
presentation of the UAD is suppressed.

Yes. If not 
supplied, the 
default is 
false.

<Open> - Yes
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MuteTransferWork
The MuteTransferWork command transfers an e-mail to another agent. If the TrackingID is 
passed, a one-step, or blind transfer, is performed for the e-mail work item specified by the 
TrackingID. Otherwise, a blind transfer of the current work item is performed.

Parameters

This command has the following parameters.

Related topic

For more information, see About open data on page 311.

Media type

This command is permitted on work items with the email media type when the e-mail is 
active.

Related topic

For more information, see Media types on page 495.

Name Value Optional?

Destination An extension, phone number, agent ID, or queue Yes

SuppressUAD Can be true or false.
If true, and a destination is supplied, the 
presentation of the UAD is suppressed.

Yes. If not 
supplied, the 
default is false.

<Open> - Yes
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NewOpenData
The NewOpenData command copies new open data to the open data container in the work 
item EDU. The TrackingID of the work item must be specified.

In addition to copying new data to the open data container in the EDU, the NewOpenData 
command can alert other components of the system that NewOpenData is available. For 
example, other agents on a conference call can be notified of the presence of the new 
open data, and can re-read the open data container in the EDU. This behavior is controlled 
by the SendEvent parameter.

The SendEvent parameter can be used to specify which parties should receive an event 
when the new open data is copied to the EDU. The following table describes the possible 
choices.

Related topic

For more information about the OnNewOpenData event, see OnNewOpenData on 
page 358.

All All agents monitoring the EDU receive the OnNewOpenData event.

JustIC No agents receive the OnNewOpenData event, but the IC Agent Scripts for 
this agent receive notification. This can be a useful customization hook.

JustMe Only the agent who originated the NewOpenData command can receive the 
OnNewOpenData event.

None Nobody receives the OnNewOpenData event, and the Avaya IC agent is not 
notified.

NotMe All agents receive the OnNewOpenData event, except for the agent who 
originated the NewOpenData command.



NewOpenData

Issue 4.0 November 2004 441

Parameters

This command has the following parameters.

Related topic

For more information, see About open data on page 311.

Media types

This command is permitted on work items with all media types in any state.

Related topic

For more information, see Media types on page 495.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and 
was supplied in the OnNewWorkItem event.

Yes

SendEvent One of the following values:
● All
● JustMe
● NotMe
● JustIC
● None

Yes. If not specified, the 
default is None.

<Open> - No
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RejectVoicePreviewCall
The RejectVoicePreviewCall rejects the voice preview call work item and the call is not 
placed. If the TrackingID is passed, the voice preview call specified by the TrackingID is 
rejected. Otherwise, the current voice preview call work item is rejected.

Related topic

For more information, see AcceptVoicePreviewCall on page 393.

Parameter

This command has the following parameter.

Media type

This command is permitted on work items with the voicePreview media type when the 
voicePreview work item has been offered but not yet accepted or rejected.

Related topic

For more information, see Media types on page 495.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied in 
the OnNewWorkItem event.

Yes
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ReleaseWork
The ReleaseWork command signals that the agent has completed Siebel wrap-up. This 
removes the work item from the agent work list.

Parameter

This command has the following parameter.

Media types

This command is permitted on work items with all media types when they are in Siebel 
wrap-up.

Related topics

For more information, see the following topics:

● Media types on page 495

● Wrap-up on page 89

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied in 
the OnNewWorkItem event.

Yes
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ReplyEmail
The ReplyEmail command begins the process of replying to an e-mail. If the TrackingID is 
passed, an e-mail for the work item specified by the TrackingID is sent a reply. Otherwise, 
the current work item is sent a reply.

The ReplyEmail command works as follows:

1. The Communication Detail - Response View is popped when the agent receives 
e-mail.

2. The agent selects either the Reply or Reply to All button.

3. The ReplyEmail command is generated. 

4. The Communication Detail - Response View is enabled.

5. The agent composes a reply e-mail. 

6. When the agent is finished composing the reply e-mail, the agent selects the Send 
button in the Communication Detail - Response View. 

7. The SendEmail command sends the e-mail message. 

8. The Communication Detail - Response View is cleared and disabled. 

9. The agent can again dismiss, transfer, or defer the original e-mail, and can also 
choose to compose another reply or forward the e-mail.

Related topics

For more information, see the following topics:

● SendEmail on page 447

● ForwardEmail on page 422

● CancelEmail on page 408

Parameter

This command has the following parameter.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied in 
the OnNewWorkItem event.

Yes
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Media type

This command is permitted on work items with the email media type when the e-mail is 
active.

Related topic

For more information, see Media types on page 495.



AICD commands

446 Avaya Interaction Center for Siebel 7 Integration

ResumeEmail
The ResumeEmail command removes an e-mail from its deferred status. Conceptually, 
this is similar to taking a call off hold. If the TrackingID is passed, the e-mail work item 
specified by the TrackingID is resumed. Otherwise, the current work item is resumed.

Related topic

For more information, see DeferEmail on page 418.

Parameter

This command has the following parameter.

Media type

This command is permitted on work items with the email media type when the work item 
has been deferred.

Related topic

For more information, see Media types on page 495.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied in 
the OnNewWorkItem event.

No



SendEmail

Issue 4.0 November 2004 447

SendEmail
The SendEmail command completes the process of replying to or forwarding an e-mail. If 
the TrackingID is passed, an e-mail for the work item specified by the TrackingID is used. 
Otherwise, the current work item is used.

The SendEmail command works as follows:

1. The Communication Detail - Response View is popped when the agent receives 
e-mail.

2. The agent selects the Reply, Reply to All, or Forward button. 

3. The Communication Detail - Response View becomes enabled.

4. The agent edits the e-mail.

5. When the agent is finished composing the e-mail, the agent selects the Send button in 
the Communication Detail - Response View. 

6. The SendEmail command sends the e-mail message.

7. The Communication Detail - Response View is cleared and disabled. 

8. The agent is again permitted to dismiss, transfer, or defer the original e-mail, and can 
also choose to compose another reply or forward the e-mail again.

Related topics

For more information, see the following topics:

● ReplyEmail on page 444

● ForwardEmail on page 422

● CancelEmail on page 408
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Avaya-first e-mail method parameters

This command has the following parameters if you are using the Avaya-first e-mail method.

Related topics

For more information, see About open data on page 311.

Siebel-first e-mail method parameter

This command has the following parameter if you are using the Siebel-first e-mail method.

Media type

This command is permitted on work items with the email media type when the agent is 
forwarding e-mail or sending a reply.

Related topic

For more information, see Media types on page 495.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied in 
the OnNewWorkItem event.

Yes

ActivityID Siebel ActivityID of the reply or forward e-mail No

<Open> - Yes

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied in 
the OnNewWorkItem event.

Yes
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SendNewEmail
The SendNewEmail command sends an e-mail.

The SendNewEmail command works as follows:

1. The agent presses the F9 key or selects the Initiate Email button to open the Send 
Email window. 

2. The agent composes the e-mail message and selects the Send button. 

3. The Send button creates an activity record in Siebel and calls the SendNewEmail 
command.

4. The SendNewEmail command retrieves the activity record from Siebel and sends the 
e-mail.

5. The SendNewEmail command creates a new EDU. Neither the selected nor the 
current work item is used, and no work item is specified using a TrackingID.

This command is permitted when the agent is logged into the e-mail channel.

Parameters

This command has the following parameters.

Related topic

For more information, see About open data on page 265.

Name Value Optional?

ActivityID Siebel ActivityID of the e-mail being sent. No

<Open> - Yes
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SetCurrentWorkItem
The SetCurrentWorkItem command sets the current work item to the work item that is 
specified by the TrackingID.

The agent chooses a work item from the Work Item drop-down list. This results in a 
SetCurrentWorkItem command that changes the current work item to the new work item 
the agent has chosen and pops the screen accordingly.

The SetCurrentWorkItem command is always permitted.

Parameter

This command has the following parameter.

Name Value Optional?

TrackingID Tracking ID that identifies the work item and was supplied in 
the OnNewWorkItem event.

No
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ShowStatusText
The ShowStatusText command displays the specified text string in the Siebel thin client 
status line.

The ShowStatusText command is always permitted.

Note:
Note: Indiscriminate use of this command can overwrite other useful status line 

data.

Parameter

This command has the following parameter.

Name Value Optional?

StatusText Status text string that is displayed No
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VoiceAvailable
The VoiceAvailable command makes the agent available for voice work. If making the 
agent available for voice causes the agent to become available for all logged-in channels, 
the agent is also placed in automatic mode.

The VoiceAvailable command is permitted when the agent is:

● Available for incoming work

● Unavailable for voice work

● Logged into the voice channel

● Not in outbound mode

Parameters

The VoiceAvailable command has no parameters.
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VoiceUnavailable
The VoiceUnavailable command makes the agent unavailable for voice work and places 
the agent in manual mode.

The VoiceUnavailable command is permitted when the agent is:

● Available for incoming work

● Available for voice work

● Logged into the voice channel

● Not in outbound mode

Parameters

The VoiceUnavailable command has no parameters.
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WebAvailable
The WebAvailable command makes the agent available for Web work. If making the agent 
available for the Web causes the agent to become available for all logged-in channels, the 
agent is also placed in automatic mode.

The WebAvailable command is permitted when the agent is:

● Available for incoming work

● Unavailable for Web work

● Logged into the chat channel

● Not in outbound mode

Parameters

The WebAvailable command has no parameters.
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WebUnavailable
The WebUnavailable command makes the agent unavailable for Web work and places the 
agent in manual mode.

The WebUnavailable command is permitted when the agent is available for incoming work, 
available for Web work, logged into the chat channel, and not in outbound mode.

Parameters

The WebUnavailable command has no parameters.
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Appendix B: AICD events

This section includes the following topics:

● About events on page 458

● Event parameter groups on page 459

- Common event parameters on 
page 459

- Common call event parameters on 
page 459

- Common e-mail event 
parameters on page 460

- Common Web event parameters on 
page 461

- Open event parameters on 
page 461

● Events

- OnAvayaAgentEvent on page 462

- OnCallAbandonded on page 463

- OnCallBusy on page 464

- OnCallConference on page 465

- OnCallConnect on page 466

- OnCallDisconnect on page 467

- OnCallDrop on page 468

- OnCallIncoming on page 469

- OnCallHold on page 470

- OnCallHoldReconnect on page 471

- OnCallQueued on page 472

- OnCallRinging on page 473

- OnCallTransfer on page 474

- OnChangeCurrentWorkItem on 
page 475

- OnEmailCancel on page 476

- OnEmailDeferred on page 477

- OnEmailForward on page 478

- OnEmailReply on page 479

- OnEmailSend on page 480

- OnLoginAgent on page 481

- OnLogoutAgent on page 482

- OnNewOpenData on page 483

- OnNewWorkItem on page 484

- OnSiebelWrapUp on page 486

- OnWorkConference on page 487

- OnWorkConnect on page 488

- OnWorkDisconnect on page 489

- OnWorkItemRemove on page 490

- OnWorkTransfer on page 492
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About events

An event notifies the Siebel Communications Server about a specific occurrence so that 
the Siebel Communications Server can take appropriate action. As a general rule, events 
are generated by occurrences that are controlled by Avaya IC. These are examples of 
occurrences that can generate events:

● The agent sends e-mail or places a voice call.

● A customer sends an inbound Web chat message, e-mail, or voice call.

Event handlers in the Siebel definition file evaluate each event. Event responses provide 
the instructions to act on the evaluated event. The typical event response is to pop a Siebel 
screen - although many other event responses are possible, such as sending an Adaptive 
Interaction Center Driver (AICD) command.

Events always flow from the AICD to the Siebel Communications Server.

Related topics

For more information, see any of the following topics:

● Media types on page 495

● Siebel definition file on page 108

● Customizing the definition file on page 109

● Customizing events on page 318

● AICD commands on page 381

● For a description of the Avaya IC events described in this appendix, for example 
TS.Hold, see IC Telephony Connectors Programmer Guide.
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Event parameter groups
This section includes the following topics:

● Common event parameters on page 459

● Common call event parameters on page 459

● Common e-mail event parameters on page 460

● Common Web event parameters on page 461

● Open event parameters on page 461

Common event parameters

The following event parameters are common to most of the events described in this 
appendix.

Common call event parameters

The following event parameters are common to some of the call-related events described 
in this appendix.

Name Value

AgentID The login ID for the Siebel agent.

AgentExtension The extension for the agent, if the agent has one.

EDUID The EDU ID of the work item.

TrackingID The TrackingID is a string that is generated by the AICD. The 
Tracking ID uniquely identifies the work item.

Name Value

ANI The ANI supplied by the TS event.

CallID The call_ref_id supplied by the TS event.

DNIS The DNIS supplied by the TS event.
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Common e-mail event parameters

The following event parameters are common to most of the email-related events described 
in this appendix.

OutboundCallNumber The outboundcallnumber placed in the EDU by the dialing 
kernel, if available.

PrimaryANI The PrimaryANI obtained from the EDU.

PrimaryDNIS The PrimaryDNIS obtained from the EDU.

VoiceDirection Indicates where the call originated. This will not change during 
the life of the call, including during transfers and conferences. 
VoiceDirection can have the following values:
● inbound
● outbound

Name Value

Name Value

EmailActivityID A Siebel activity ID that identifies the row ID of the Siebel record for 
the e-mail.

Recipient The e-mail address of the recipient. This will not be supplied if it is 
not available.

Sender The e-mail address of the sender. This will not be supplied if it is not 
available.

Subject The e-mail subject line. This will not be supplied if it is not available.
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Common Web event parameters

The following event parameters are common to most of the Web-related events described 
in this appendix.

Open event parameters

Events that have the <Open> parameter allow data attachments. In general, the <Open> 
parameters are allowed on most events that indicate that work has been delivered to the 
agent. For example, OnNewWorkItem and OnCallIncoming.

Related topic

For more information, see About open data on page 311.

Name Value

UserName Login ID for the customer. If the user logged in as a guest, the 
format of this parameter is:

guest_<UserNameDisplay>_<SomeUniqueString>

For example:

guest_Alice_23771953

UserNameDisplay The Login ID for the customer, or the name the guest supplied. If the 
user supplied the name, ìAlice,î the value will be ìAlice.î
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OnAvayaAgentEvent
The OnAvayaAgentEvent is generated in response to a request by the Avaya Agent. The 
parameters are supplied in the request from Avaya Agent. 

The OnAvayaAgentEvent allows you to implement a custom driver event sent from Avaya 
Agent to the AICD and to the Siebel agent. This event is a placeholder. The actual event 
name can be passed as one of the event parameters. An arbitrary number of parameters 
can be passed from Avaya Agent to Siebel. The Avaya Agent script constructs and defines 
the contents of the event. This event can be used to call the event handler defined in the 
AICD.def file and cause some action within Siebel.

Related topic

For more information, see AvayaAgentCommand on page 399.

Parameter

OnAvayaAgentEvent accepts all parameters. 
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OnCallAbandonded
This event is sent when a call has been abandoned before the call could be connected to 
an agent. The AICD sends OnCallAbandoned when it receives the TS.Abandoned event.

Parameters

The following parameters are supplied with the OnCallAbandoned event.

Name Value

NoInQueue The number_in_queue parameter from the TS.Abandoned 
event, if present.

Common event parameters on page 459

Common call event parameters on page 459
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OnCallBusy

This event is sent when a call receives a busy signal. The AICD sends OnCallBusy when it 
receives the TS.Busy event.

Parameters

The following parameters are supplied with the OnCalBusy event.

Name

Common event parameters on page 459

Common call event parameters on page 459
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OnCallConference
This event is sent when a conference call is successfully completed. The AICD sends 
OnCallConference when it receives the TS.Conference event.

Parameters

The following parameters are supplied with the OnCallConference event.

Name Value

OldCallID The CallID of the original call.

Common event parameters on page 459

Common call event parameters on page 459



AICD events

466 Avaya Interaction Center for Siebel 7 Integration

OnCallConnect
This event is sent when a call is answered. The AICD sends OnCallConnect when it 
receives the TS.Connect event.

Parameters

The following parameters are supplied with the OnCallConnect event.

Name

Common event parameters on page 459

Common call event parameters on page 459
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OnCallDisconnect
This event is sent when a call ends. The AICD sends OnCallDisconnect when it receives 
the TS.Disconnect event.

Parameters

Name Value

NoInQueue The number_in_queue parameter from the TS.Disconnect event, if 
present.

OldCallID The call_ref_id supplied by the TS.Disconnect event.

Common event parameters on page 459

Common call event parameters on page 459
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OnCallDrop
This event is sent when a party is dropped from a call involving two or more parties. The 
AICD sends OnCallDrop when it receives the TS.Drop event.

Parameters

The following parameters are supplied with the OnCallDrop event.

Name Value

CallID The call_ref_id supplied by the TS.Disconnect event.

DestinationNumber The dest parameter that is supplied with the TS.Drop event.

NoInQueue The number_in_queue parameter from the TS.Drop event, if 
present.

OriginatingNumber The orig parameter that is supplied with the TS.Drop event.

Common event parameters on page 459
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OnCallIncoming
This event is sent when an agent receives a call. The AICD sends OnCallIncoming when it 
receives the TS.IncomingCall event.

Parameters

The following parameters are supplied with the OnCallIncoming event.

Name Value

CalledNumber The called parameter supplied by the TS.Incoming event.

DestinationNumber The dest parameter that is supplied with the TS.Incoming event.

NoInQueue The number_in_queue parameter from the TS.Incoming event, 
if present.

OriginatingNumber The orig parameter that is supplied with the TS.Incoming event.

Common event parameters on page 459

Common call event parameters on page 459

Up to ten custom event parameters. For more information, see Customizing events on 
page 318.
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OnCallHold
This event is sent when an agent puts a call on hold. The AICD sends OnCallHold when it 
receives the TS.Hold event.

Parameters

The following parameters are supplied with the OnCallHold event.

Name Value

CallID The call_ref_id supplied by the TS.Hold event.

DestinationNumber The dest parameter that is supplied with the TS.Hold event.

Common event parameters on page 459
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OnCallHoldReconnect
This event is sent when an agent takes a call off hold. The AICD sends 
OnCallHoldReconnect when it receives the TS.HoldReconnect event.

Parameters

The following parameters are supplied with the OnCallReconnect event.

Name Value

CallID The call_ref_id supplied by the TS.HoldReconnect event.

Common event parameters on page 459
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OnCallQueued
This event is sent when a call is placed into a queue. The AICD sends OnCallQueued 
when it receives the TS.Queued event.

Parameters

The following parameters are supplied with the OnCallQueued event.

Name Value

CallID The call_ref_id supplied by the TS.Queued event.

NoInQueue The number_in_queue parameter from the TS.Queued event, if 
present.

Queue The queue parameter from the TS.Queued event.

Common event parameters on page 459
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OnCallRinging
This event is sent when a call has been delivered to its destination, but not yet answered. 
The AICD sends OnCallRinging when it receives the TS.Ring event.

Parameters

The following parameters are supplied with the OnCallRinging event.

Name Value

DestinationNumber The dest parameter that is supplied with the TS.Ring event.

OriginatingNumber The orig parameter that is supplied with the TS.Ring event.

Common event parameters on page 459

Common call event parameters on page 459
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OnCallTransfer
This event is sent when a an agent successfully transfers a call. The AICD sends 
OnCallTransfer when it receives the TS.Transfer event.

Parameters

The following parameters are supplied with the OnCallTransfer event.

Name Value

DestinationNumber The dest parameter that is supplied with the TS.Transfer event.

NoInQueue The number_in_queue parameter from the TS.Transfer event, if 
present.

OldCallID The CallID of the original call.

OriginatingNumber The orig parameter that is supplied with the TS.Transfer event.

Common event parameters on page 459

Common call event parameters on page 459
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OnChangeCurrentWorkItem
This event is sent when an agent changes the current work item. The current workitem 
may be changed when: 

● The agent selects another work item from the Work Item drop-down list.

● The agent double-clicks an item in the Call list, E-mail list, or Chat list. 

● New work arrives and is automatically accepted.

Parameters

The following parameters are supplied with the OnChangeCurrentWorkItem event, and 
refer to the new current work item.

Related topic

For more information, see Media types on page 495.

Name Value

Media Type Indicates the media type of the new current work item.

Common event parameters on page 459

Common call event parameters on page 459 for media types webVoice and webIVChat.

Common e-mail event parameters on page 460

Common Web event parameters on page 461 for media types webVoice and webIVChat.
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OnEmailCancel
When an agent cancels the composition of an e-mail reply or forwarding message, the 
OnEmailCancel event is generated.

To generate an OnEmailCancel event, the following actions occur:

1. The Communication Detail - Response View is popped when the agent receives 
e-mail.

2. When the agent selects the Reply, Reply to All, or Forward buttons, the 
Communication Detail - Response View is enabled.

3. Depending on which button was selected, either the OnEmailReply or the 
OnEmailForward events are generated.

4. The agent can compose a reply or forward an e-mail. While the e-mail message is 
being composed, the agent cannot dismiss, transfer, or defer the original e-mail.

5. The agent cancels the message by selecting the Cancel button from the Siebel toolbar.

6. The CancelEmail command cancels the message.

7. The Communication Detail - Response View is cleared and disabled.

8. The OnEmailCancel event is generated.

9. The agent can dismiss, transfer, or defer the original e-mail.

Parameters

The following parameters are supplied with the OnEmailCancel event.

Name

<Open> All values that are in the open data container of the EDU.

Common event parameters on page 459

Common call event parameters on page 459
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OnEmailDeferred
When an agent suspends work on an e-mail message, the following actions occur:

1. A DeferEmail command is generated

2. The DeferEmail command defers the e-mail and generates the OnEmailDeferred 
event.

Related topic

For more information, see DeferEmail on page 418.

Parameters

The following parameters are supplied with the OnEmailDeferred event.

Name

Common event parameters on page 459

Common e-mail event parameters on page 460
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OnEmailForward
When the agent begins composing an e-mail message the agent wants forwarded, the 
OnEmailForward event is generated.

To generate an OnEmailForward event, the following actions occur:

1. The Communication Detail - Response View is popped when the agent receives an 
e-mail message.

2. The agent selects the Forward button on the Communication Detail - Response 
View.

3. The ForwardEmail command is generated.

4. The Communication Detail - Response View is enabled.

5. The OnEmailForward event is generated.

6. The agent can edit the e-mail he or she wants forwarded.

Parameters

The following parameters are supplied with the OnEmailForward event.

Name

Common event parameters on page 459

Common e-mail event parameters on page 460
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OnEmailReply
When the agent begins composing a reply e-mail message, the OnEmailReply event is 
generated.

To generate an OnEmailReply event, the following actions occur:

7. The Communication Detail - Response View is popped when the agent receives an 
e-mail.

8. If the agent selects the Reply or the Reply to All buttons, the ReplyEmail command is 
called.

9. The Communication Detail - Response View is enabled.

10. The OnEmailReply event is generated.

11. The agent can compose a reply e-mail message.

Parameters

The following parameters are supplied with the OnEmailReply event.

Name

Common event parameters on page 459

Common e-mail event parameters on page 460
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OnEmailSend
When either an e-mail reply or an e-mail forward message is sent, the OnEmailSend event 
is generated.

To generate an OnEmailSend event, the following actions occur:

12. The Communication Detail - Response View is popped when the agent receives 
e-mail.

13. When the agent selects the Reply, Reply to All, or Forward buttons, the 
Communication Detail - Response View is enabled.

14. Depending on which button was selected, either the OnEmailReply or the 
OnEmailForward events are generated.

15. The agent can edit the e-mail.

16. When the agent has finished composing the e-mail, the agent selects the Send button.

17. The SendEmail command is called.

18. The Communication Detail - Response View is cleared and disabled.

19. The OnEmailSend event is generated.

20. The agent is now permitted to do any of the following tasks:

● Dismiss, transfer, or defer the original e-mail.

● Compose another reply or forward the e-mail again.

Parameters

The following parameters are supplied with the OnEmailSend event.

Name Value

NewEmailActivityID The Siebel Activity ID of the new reply or forward e-mail.

Common event parameters on page 459

<Open> All values that are in the open data container for the EDU.
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OnLoginAgent
When the Siebel agent has successfully logged into Avaya IC, the OnLoginAgent event is 
generated.

Parameters

The following parameters are supplied with the OnLoginAgent event.

Name Value

AgentID The login ID for the Siebel agent.

AgentExtension The extension for the agent, if the agent has one.
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OnLogoutAgent
When the Siebel agent has logged out of Avaya IC, the OnLogoutAgent event is 
generated.

Parameters

The following parameters are supplied with the OnLogoutAgent event.

Name Value

AgentID The login ID for the Siebel agent.

AgentExtension The extension for the agent, if the agent has one.
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OnNewOpenData
When there has been a request to generate an OnNewOpenData event, the 
OnNewOpenData event is generated. This request originates with the NewOpenData 
command.

Related topics

For more information, see the following topics:

● NewOpenData on page 440

● About open data on page 311

Parameters

The following parameters are supplied with the OnNewOpenData event.

Name Value

TrackingID A string generated by the AICD that uniquely identifies the work 
item.

<Open> All values that are in the open data container of the EDU.
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OnNewWorkItem
When the agent receives a new work item and indicates that the work item should be 
popped, the OnNewWorkItem event is generated.

The open data parameters in conjunction with the MediaType are typically used to 
determine which screen to pop. For example, SiebelViewBmk can be passed as an open 
data parameter. If the SiebelViewBmk parameter is included, the bookmark screen is 
popped. The AICD.def file contains many examples of popping the screen based on 
parameters that are available through open data in conjunction with the MediaType.

Parameters

The following parameters are supplied with the OnNewWorkItem event.

Name Value

Cause Indicates the source of this work item. Can be one of the following 
values:
● NEW
● TRANSFER
● CONFERENCE
Also see, Information about the cause parameter on page 485.

InitialPop Indicates whether this is the first time this work item is being popped. 
Can be one of the following values:
● Yes
● No

Media Type Indicates the Media types of the new current work item.

Common event parameters on page 459

Common call event parameters on page 459 for media types webVoice and webIVChat.

Common e-mail event parameters on page 460

Common Web event parameters on page 461 for media types webVoice and webIVChat.

Up to ten custom event parameters. For more information, see Customizing events on 
page 318.

<Open> All values that are in the open data container of the EDU.
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Information about the cause parameter

The cause parameter is accurate for all consultative transfers on Avaya communication 
servers. This includes transfer to queue, as long as the transferring agent remains on the 
call until the call arrives at the transferred-to agent.

However, in some blind transfers on Avaya communication servers, the cause field will 
have a NEW value even for the transferred call. This may occur on blind transfer to queue 
scenarios where the transferred-to agent is not available until after the blind transfer 
completes.

The cause field can also be inaccurate on non-Avaya communication servers. For 
example, cause may be NEW for a transferred call.
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OnSiebelWrapUp
When the work item is going into Siebel wrap-up, the OnSiebelWrapUp event is generated. 
OnSiebelWrapUp events are generated only if the wrap-up type for the agent is 
administered as Siebel and wrap-up is enabled for the agent.

Example: For a work item of media type voice, the following commands and events could 
occur if Siebel wrap-up was enabled and the customer contact hung up the call:

1. The OnCallDrop event indicates that the customer hung up.

2. The OnCallDisconnect event is generated.

3. The agent receives the OnSiebelWrapUp event. At this point, only the ReleaseWork 
command is permitted. The agent could perform any final actions related to the work 
item.

4. When the agent has completed all final actions, the agent sends the ReleaseWork 
command to release the work item.

Related topics

For more information, see the following topics:

● Wrap-up on page 89

● ReleaseWork on page 443

● OnCallDisconnect on page 467

● OnCallDrop on page 468

Parameters

The Common event parameters on page 459 are supplied with the OnSiebelWrapUp 
event.
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OnWorkConference
When another agent is conferenced into a Web chat, the OnWorkConference event is 
generated. The chat can be a combined voice-chat interaction.

Parameters

The following parameters are supplied with the OnWorkConference event.

Name

Common event parameters on page 459

Common Web event parameters on page 461
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OnWorkConnect
When either an e-mail or a Web chat is connected, the OnWorkConnect event is 
generated. This can occur when an agent does the following tasks:

● Accepts the work item

● Removes an e-mail work item from its deferred status

● Cancels an e-mail reply or message about to be forwarded

This event is similar to OnCallConnect, and indicates that both the agents and the 
customer contact are active on the work item.

Related topic

For more information, see OnCallConnect on page 466.

Parameters

The following parameters are supplied with the OnWorkConnect event.

Name

Common event parameters on page 459

Common e-mail event parameters on page 460

Common Web event parameters on page 461

<Open> All values that are in the open data container of the EDU.
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OnWorkDisconnect
When either an e-mail or a Web chat is disconnected, the OnWorkDisconnect event is 
generated. This is similar to OnCallDisconnect, and indicates that neither the agents nor 
the customer contact are connected on the work item. Although it is disconnected, the 
work item is still present at the agent desktop until the agent gets an OnWorkItemRemove 
event. The OnWorkDisconnect event occurs prior to the agent entering wrap-up, if wrap-up 
is enabled.

Related topics

For more information, see the following topics:

● OnCallDisconnect on page 467

● OnWorkItemRemove on page 490

Parameters

The following parameters are supplied with the OnWorkDisconnect event.

Name

Common event parameters on page 459

Common e-mail event parameters on page 460

Common Web event parameters on page 461

<Open> All values that are in the open data container of the EDU.
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OnWorkItemRemove
When the work item is removed from the Siebel toolbar, the OnWorkItemRemove event is 
generated. This is the final event for the work item, and is preceded by an 
OnWorkDisconnect event, and optionally an OnSiebelWrapUp event.

The parameters that were passed when the OnNewWorkItem event was generated are 
passed when the OnWorkItemRemove event is generated. Additional parameters can be 
passed if the original work item was of MediaType=web and it transitioned to 
MediaType=webVoice or MediaType=webIVChat while it was active at the agent desktop.

Related topics

For more information, see the following topics:

● OnWorkDisconnect on page 489

● OnNewWorkItem on page 484

Parameters

The following parameters are supplied with the OnWorkItemRemove event.

Name Value

Cause Indicates the source of this work item. Can be one of the following 
values:
● NEW
● TRANSFER
● CONFERENCE
Also see, Information about the cause parameter on page 485.

InitialPop Indicates whether this is the first time this work item is being popped. 
Can be one of the following values:
● Yes
● No

Media Type Indicates the Media types of the new current work item.

Common event parameters on page 459

Common call event parameters on page 459 for media types webVoice and webIVChat.

Common e-mail event parameters on page 460

Common Web event parameters on page 461 for media types webVoice and webIVChat.
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Up to ten custom event parameters. For more information, see Customizing events on 
page 318.

<Open> All values that are in the open data container of the EDU.

Name Value
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OnWorkTransfer
When an e-mail is transferred, the OnWorkTransfer event is generated.

Although a webVoice or webIVChat work item can be transferred, doing so will not 
generate an OnWorkTransfer event. When a webVoice or webIVChat is transferred, the 
voice portion of the work item is transferred first. Web chat transfers are not supported by 
Avaya IC, so the chat transfer is simulated. To simulate the chat transfer, the Web portion 
of the work item is conferenced and the original agent is dropped from the conference. 
There will be an OnWorkConference event when the chat is conferenced, but there will not 
be an OnWorkTransfer event.

Related topic

For more information, see OnWorkConference on page 487.

Parameters

The following parameters are supplied with the OnWorkTransfer event.

Name

Common event parameters on page 459

Common e-mail event parameters on page 460

Common Web event parameters on page 461
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Appendix C: TS call events

The following table lists the call events that are generated as Siebel events and the 
corresponding Telephony Server (TS) event names.

Voice connector event AICD event

TS.Abandoned OnCallAbandoned

TS.AgentOtherWork Not supported

TS.AuxWork Not supported

TS.Busy OnCallBusy

TS.Conference OnCallConference

TS.Connect OnCallConnect

TS.Disconnect OnCallDisconnect

TS.Diverted Not Supported

TS.Drop OnCallDrop

TS.Hold OnCallHold

TS.HoldReconnect OnCallHoldReconnect

TS.IncomingCall OnCallIncoming

TS.Login Not Supported

TS.Logout Not Supported

TS.Ready Not Supported

TS.Ring OnCallRinging

TS.SessionFailed Not Supported

TS.Transfer OnCallTransfer
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Appendix D: Media types

The following table describes the supported media types.

Media type Definition

email An inbound e-mail.

voice An inbound PBX call originated by a customer.

voiceAutoDial An outbound contact auto-dial mode. The PBX calls the customer 
and notifies the agent about the call as the call is dialing. The agent 
reviews the customer information at the same time that the PBX is 
placing the outbound call to the customer.

voiceOut An outbound PBX call originated by an agent.

voicePredictive An outbound contact predictive mode call. The PBX automatically 
initiates an outgoing call. If the customer answers, the call is routed to 
an available agent.

voicePreview An outbound contact preview mode call. The agent is notified before 
the PBX makes the call. This gives the agent the opportunity to 
review customer data before the PBX places the call.

web An inbound chat.

webIVChat Multimedia with inbound Chat & VoIP call.

webVoice Multimedia with inbound chat and Public Switched Telephone 
Network (PSTN) call.
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Appendix E: EAI Get and Put operations

This section describes the integration objects contained within the Get Data, Put Data, Get 
Email, and Put Email blocks. Each integration object has a unique format written in 
eXtensible Markup Language (XML) that conforms to a Document Type Definition (DTD). 
Each integration object contains a pair of messages: one for the request from Avaya IC to 
Siebel, and one for the response from Siebel to Avaya IC. You can customize your system 
by changing the content passed in the messages without changing the DTD.

This section includes the following topics:

● About customizing Get operations on page 498

● About customizing Put operations on page 499

● About attachments on page 501

● Get and Put Data on page 504

● Get and Put Email on page 522

Related topics

For more information, see the following topics:

● EAI server on page 66

● Siebel palette blocks on page 117

● Integration objects on page 100

Before you begin

This appendix assumes that you have installed the Avaya IC EAI Objects.sif.

Related topics

For more information, see the following topics:

● Installing a custom integration object on page 216

● For more information about Avaya IC EAI Objects, see the Siebel documentation.
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About customizing Get operations
To customize Get operations, you need the following information.

Integration object name - Always type the integration object name accurately. Spaces, 
capitalization, and spelling must match exactly or the request will return an error.

Query key name - For Get operations, this is the exact name you must specify when 
making the Get request. These are the names described in the Get structure figures in this 
appendix. For example, Contact.HomePhone is a query key name for the Get Contact 
integration object. A telephone number is passed as data with this query key name. The 
data type and number of digits must agree with what Siebel is expecting.

The data returned by Siebel will have the form shown in the structure figures.

There are no required fields for Get operations.
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About customizing Put operations
This section includes the following topics:

● Names on page 499

● Required fields on page 499

Names

To customize Put operations, you need the following information.

Integration object name - Always type the integration object name accurately. Spaces, 
capitalization, and spelling must match exactly or the request will return an error.

Name - For Put operations, this is the name of the field that will be populated with data. 
These are the names described in the Put structure figures in this appendix. For example, 
Action.Description is a name for the Put Action integration object.

The data returned by Siebel will have the form shown in the structure figures.

Required fields

The required fields for each Siebel integration object are shown in the structure figures, 
marked with a star. In general, these fields must be supplied and contain data that 
conforms to what Siebel expects. For example, the Avaya IC - Put Action integration object 
contains the following required primary fields:

Id - Siebel will validate that this field was supplied. However, a different Id will actually be 
created for the activity record. Avaya recommends that you supply the data <new> as a 
placeholder so that the Siebel validation works. 

Description - Siebel will validate that this field was supplied and populate the Description 
field of the activity. Keep in mind that Siebel has restrictions on the length of the 
Description field data. 

Type - Siebel will validate that this field was supplied and also validate that the text of this 
field conforms to a valid Siebel activity type. The Avaya IC - Put Action integration object 
also contains other required fields. However, they are required only when passing a 
ListOfActionAttachment or ListOfAction_Contact. Use Siebel Tools to examine the field 
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mapping for the integration object and Siebel business component requirements for the 
data. 
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About attachments
Along with the integration object figures in this appendix, you will also see a chart stating 
whether or not the integration object allows attachments. Integration objects can 
sometimes pass documents as attachments to and from Siebel, along with the Get and Put 
requests.
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Creating an integration object to query on a 
multi-value field

Default Integration Objects have Multi Value Groups (MVGs). Each of these MVGs needs 
a separate integration component definition. Each field defined for an integration 
component maps to a field in the MVG. When you have a requirement to execute a query 
on just a multi-value field, you must create another business object and an integration 
object based on the business object. The integration object must have the MVG as a root 
component, and its parent as its child component.

This section includes the following topics:

● Example on page 502

● Procedure on page 502

Example

A query on Account State using the Avaya IC - Get Account integration object does not 
return all accounts that fall under that state. You can query for all accounts that fall under 
that state by creating an integration object.

Procedure

To create an integration object to query on a multi-value field:

1. Create a business object with BusinessAddress as the parent business component.

Reference: For more information about creating a business object, see the Siebel 
documentation.

2. Create a link with BusinessAddress as the parent business component and Account 
as the child business component.

3. Associate the link with the business object.

4. Create the integration object using the business object you created in Step 1.

Reference: For more information about creating an integration object, see the Siebel 
documentation.

5. Activate or inactivate the fields in the integration object per the requirement.
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6. Change the Avaya IC workflow to send the right parameters to the EAI server.

Reference: For more information, see Roadmap for creating integration objects in the 
Avaya IC for Siebel 7 Integration guide.

Result: The integration object hierarchy should look like the following figure.
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Get and Put Data
Get Data and Put Data blocks contain the following integration objects:

● Get Action on page 505

● Put Action on page 507

● Get Account on page 508

● Get Contact and Put Contact on page 510

● Get Service Request on page 512

● Put Service Request on page 514

● Get Order Entry on page 515

● Put Order Entry on page 517

● Put Opportunity on page 518

● Get Quote on page 519

● Put Quote on page 521
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Get Action

The Get Action integration object retrieves information from the Siebel database about 
actions that agents took in response to previous contacts with this customer.

This section includes the following topics:

● Get Action query keys from Avaya IC to Siebel on page 505

● Get Action responses from Siebel to Avaya IC on page 506

Get Action query keys from Avaya IC to Siebel

The following figure shows the default query keys that Avaya IC requests from Siebel for 
data transfers using the Avaya IC - Get Action integration object.
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Get Action responses from Siebel to Avaya IC

The following figure shows the default fields that Avaya IC receives from Siebel for data 
transfers using the Avaya IC - Get Action integration object.

* Required field
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Put Action

The Put Action integration object requests Siebel to store information in the Siebel 
database about the current actions that an agent took in response to a customer contact.

The following figure shows the default fields that Siebel receives from Avaya IC for data 
transfers using the Avaya IC - Put Action integration object.
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Get Account

The Get Account integration object retrieves customer billing information from the Siebel 
database.

This section includes the following topics:

● Get Account query keys from Avaya IC to Siebel on page 508

● Get Account responses from Siebel to Avaya IC on page 509

Get Account query keys from Avaya IC to Siebel

The following figure shows the default query keys that Avaya IC requests from Siebel for 
data transfers using the Avaya IC - Get Account integration object.



Get and Put Data

Issue 4.0 November 2004 509

Get Account responses from Siebel to Avaya IC

The following figure shows the default fields that Avaya IC receives from Siebel for data 
transfers using the Avaya IC - Get Account integration object.



EAI Get and Put operations

510 Avaya Interaction Center for Siebel 7 Integration

Get Contact and Put Contact

The Avaya IC - Get Contact integration object retrieves identification and communication 
information for the current contact from the Siebel database.

The Avaya IC - Put Contact integration object requests Siebel to store identification and 
communication information into the Siebel database.

This section includes the following topics:

● Get Contact query keys from Avaya IC to Siebel on page 510

● Get and Put Contact responses from Siebel to Avaya IC on page 511

Get Contact query keys from Avaya IC to Siebel

The following figure shows the default query keys that Avaya IC requests from Siebel for 
data transfers using the Avaya IC - Get Contact integration object.
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Get and Put Contact responses from Siebel to Avaya IC

The following figure shows the default fields that Avaya IC receives from Siebel for data 
transfers using the Avaya IC - Get and Put Contact integration objects.
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Get Service Request

The Avaya IC - Get Service Request integration object retrieves information from the 
Siebel database about services that the agentís company provided to the customer.

This section includes the following topics:

● Get Service Request query requests from Avaya IC to Siebel on page 512

● Get Service Request responses from Siebel to Avaya IC on page 513

Get Service Request query requests from Avaya IC to Siebel

The following figure shows the default query keys that Avaya IC requests from Siebel for 
data transfers using the Avaya IC - Get Service Request integration object.
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Get Service Request responses from Siebel to Avaya IC

The following figure shows the default fields that Avaya IC receives from Siebel for data 
transfers using the Avaya IC - Get Service Request integration object.
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Put Service Request

The Put Service Request integration object requests Siebel to store information in the 
Siebel database about services that the agent provided to the customer.

The following figure shows the default fields that Avaya IC requests to Siebel for data 
transfers using the Avaya IC - Get Service Request integration object.
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Get Order Entry

The Get Order Entry integration object retrieves information from the Siebel database 
about customer purchases.

This section includes the following topics:

● Get Order Entry query requests from Avaya IC to Siebel on page 515

● Get Order Entry responses from Siebel to Avaya IC on page 516

Get Order Entry query requests from Avaya IC to Siebel

The following figure shows the default query keys that Avaya IC requests from Siebel for 
data transfers using the Avaya IC - Get Order Entry integration object.
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Get Order Entry responses from Siebel to Avaya IC

The following figure shows the default fields that Avaya IC receives from Siebel for data 
transfers using the Avaya IC - Get Order Entry integration object.
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Put Order Entry

The Put Order Entry integration object requests Siebel to store customer purchase 
information in the Siebel database.

The following figure shows the default fields that Avaya IC requests to Siebel for data 
transfers using the Avaya IC - Put Order Entry integration object.
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Put Opportunity

The Put Opportunity integration object requests Siebel to store sales contact information in 
the Siebel database.

The following figure shows the default fields that Avaya IC requests to Siebel for data 
transfers using the Avaya IC - Put Opportunity integration object.
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Get Quote

The Get Quote integration object retrieves price-quote information from the Siebel 
database.

This section includes the following topics:

● Get Quote query requests from Avaya IC to Siebel on page 519

● Get Quote responses from Siebel to Avaya IC on page 520

Get Quote query requests from Avaya IC to Siebel

The following figure shows the default query keys that Avaya IC requests from Siebel for 
data transfers using the Avaya IC - Get Quote integration object.
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Get Quote responses from Siebel to Avaya IC

The following figure shows the default fields that Avaya IC receives from Siebel for data 
transfers using Get Quote integration object.
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Put Quote

The Put Quote integration object requests Siebel to store price-quote information in the 
Siebel database.

The following figure shows the default fields that Avaya IC requests to Siebel for data 
transfers using the Avaya IC - Put Quote integration object.
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Get and Put Email
Get Email and Put Email blocks contain the following integration objects:

● Get Email on page 522

● Put Email on page 524

Get Email

This section includes the following topics:

● Get Email requests from Avaya IC to Siebel on page 522

● Get Email responses from Siebel to Avaya IC on page 523

Get Email requests from Avaya IC to Siebel

The following figure shows the default query keys that Avaya IC requests from Siebel for 
e-mail transfers using the Avaya IC - Get Email integration object.
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Get Email responses from Siebel to Avaya IC

The following figure shows the default fields that Avaya IC receives from Siebel for e-mail 
transfers using the Avaya IC - Get Email integration object.
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Put Email

The following figure shows the default fields that Avaya IC receives from Siebel for e-mail 
transfers using the Avaya IC - Put Email integration object.
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Appendix F: Driver parameters

This section includes the following topics:

● About driver parameters on page 526

● AICD driver parameters on page 527

● AED driver parameters on page 529
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About driver parameters
This section contains the driver parameters you need to set for a successful integration.

Related topics

For information about setting driver parameters, see:

● IC Administration Volume 1: Servers & Domains

● The Siebel documentation

Use To set the following driver 
parameters... For the...

IC Manager
● Error logging levels
● Server name

AICD and
AED

The Communications 
Drivers and Profiles view 
in the Siebel 
Communications 
Administration window

Error logging levels for the agent log files

AICD

Size of Thread Pool

Siebel Configuration Name

IC Domain

IC UUID



AICD driver parameters

Issue 4.0 November 2004 527

AICD driver parameters
The supported AICD driver parameters for the Siebel Communications Server are 
described in the following table. When setting up log files for agents, the only driver 
parameters you can set are the parameters with the name Service: as a prefix. All AICD 
driver parameters are optional, but may be required based on your specific needs.

Driver parameter name Default 
value Description

Driver:ConfigurationName N/A

The ConfigurationName is any string unique to 
the Siebel configuration and connected to the 
AICD. This driver parameter makes it possible for 
a single AICD library instance within a single 
Siebel Communications Server to support multiple 
configurations as long as multiple AICD servers 
have been configured in Avaya IC Manager.
To use this parameter correctly, you will need to 
have multiple AICD configurations in Siebel. Do 
the following steps:

1. Import the AICD.def file excluding the 
Drivers and Profiles into all but the first 
configuration.

2. Create multiple profiles for that AICD driver 
and correspondingly associate them with 
the AICD configurations.

You can now use this parameter as an AICD 
driver parameter and. override the parameter with 
unique values in various AICD profiles

Driver:InitialThreadCount 8

The InitialThreadCount is the number of threads 
created at driver start-up to process agent 
requests. Generally, the more agents you have 
serviced by this AICD, the higher you want this 
number. However, having excess threads will 
increase your server CPU overhead. On all 
platforms, this has a minimum value of 8 and a 
maximum value of 64.

Driver:ServerDomain N/A

The ServerDomain establishes a filter for the 
identity of the AICD to the Avaya IC server. 
Normally, the driver automatically gets the server 
UUID from the vesp.imp file. However, if this 
parameter is specified, only those UUIDs that 
match the specified domain are chosen as a 
possible identity.
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Driver:ServerUUID N/A

The ServerUUID explicitly establishes the identity 
of the AICD to the Avaya IC server. Normally, the 
driver automatically gets the server UUID from the 
vesp.imp file. However, if this parameter is given, 
the specified UUID overrides any other UUID that 
the AICD has automatically chosen. Use this 
parameter with caution.

Service:TraceLevelFlush false

If true, the agent-specific file is flushed from 
memory to the disk for every log statement. 
Setting this to true is likely to slow down the 
performance of the AICD.

Service:TraceLevelUsr1 false If true, errors are logged to an agent-specific file.

Service:TraceLevelUsr2 false If true, warnings are logged to an agent-specific 
file.

Service:TraceLevelUsr3 false If true, information messages are logged to an 
agent-specific file.

Service:TraceLevelUsr4 false If true, debugging information is logged to an 
agent-specific file.

Driver parameter name Default 
value Description
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AED driver parameters
The supported AED driver parameters for the Siebel Communications Server are 
described in the following table.

Driver parameter name
Default 
value Description

SiebelExpireTime 30

Time in seconds that the AED waits for Siebel to 
perform e-mail Content Analysis and respond with 
an e-mail disposition. If this timeout expires, the 
data is discarded and an alarm is raised. Should 
Siebel respond after the timeout has occurred, the 
data is still discarded.

AedStartupSleepTime 0

Time in seconds that the AED is inactive before 
logging into the Avaya IC environment. The default 
value is 0 and should work for most configurations. 
Change this value only if you experience problems 
with AED properly initializing with Avaya IC.
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Glossary

Adaptive E-mail Driver Avaya-provided driver software that runs under the Siebel Communications 
Server. The Adaptive E-mail Driver (AED) allows Avaya IC to request Siebel 
to perform Content Analysis on e-mails and return the results back to the 
Avaya IC.

Adaptive Interaction 
Center Driver

Avaya-provided driver that runs under the Siebel Communications Server. 
The Adaptive Interaction Center Driver (AICD) coordinates the delivery of 
work between Avaya IC and Siebel agents, and is also responsible for 
managing some aspects of the Siebel Communications Toolbar user 
interface.

ADU See Agent Data Unit. 

AED See Adaptive E-mail Driver.

agent An individual who handles inbound or outbound customer contacts through 
phone calls, e-mails, or Web chats. Each agent is associated with one or 
more media channels through their login IDs, and can be a member of one or 
more workgroups. 

Agent Data Unit A record created each time an agent logs into Avaya IC. The record contains 
information about agent activities during the Avaya Agent session, including 
information about each media channel and any active contacts assigned to 
the agent.

AICD See Adaptive Interaction Center Driver.

auto-acknowledgemen
t

An e-mail automatically sent in response to e-mail from a customer that 
acknowledges the receipt of the message.

auto-response An e-mail automatically sent in response to e-mail from a customer that is 
based on the Content Analysis of the e-mail.

available state The agent state in which the agent is ready to receive another contact 
through the media channels.
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Avaya Agent The client application that enables agents to handle customer contacts via 
incoming and outgoing phone calls, e-mails, and chat sessions. The Avaya 
Agent is displayed on agent desktops as a framework containing tabs and 
panes and their controls, such as task lists. Also called Avaya Agent 
Desktop.

Avaya Agent Desktop See Avaya Agent.

Avaya IC See Avaya Interaction Center.

Avaya Interaction 
Center

A complete software system for contact centers that routes and manages 
inbound and outbound agent-customer interactions. These interactions can 
occur across multiple media channels including voice, e-mail, and Web chat. 

Avaya Web Agent The GUI desktop application used by agents to interact with customers using 
Web management features. Fully integrated into the Avaya Agent, the Web 
Agent provides the interface that agents use to handle their chat contacts 
after selecting them from either the Avaya Agent chat task list or the Siebel 
work item list. 

For this integration, Avaya Web Agent supports only chat contacts.

Blender server A server on the Avaya IC system that controls agent availability across 
different channel types, and monitors ADU change events. The Blender 
server is preconfigured to run workflows when any agent state changes. The 
Blender server can also be configured to raise alarms or run flows when 
agent or queue ADU thresholds are exceeded.

blind transfer A one-step transfer of a work item. There is no consult phase for this type of 
transfer. 

block See workflow.

CDL See Console Design Layout file.

chat A system in which users can exchange typed messages in real-time over a 
computer network or the internet. 

Common Object 
Request Broker 
Architecture

An architecture that enables servers to communicate with one another 
regardless of the programming language in which they were written or the 
operating system on which they run. VESP (Voice Enhanced Services 
Platform) is the CORBA implementation used in Avaya IC.

Communications 
server

See Siebel Communications server.
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Console Design 
Layout file

A file that specifies the Avaya Agent screen layout.

consultative transfer A two-step transfer of a work item. This type of transfer allows the 
transferring agent to communicate with the person receiving the work item 
before completing the transfer.

contact (1) In Avaya IC, an event consisting of an interaction between a customer 
and an agent, or a request for such interaction. The interaction can occur by 
phone, e-mail, or chat. 

(2) In Siebel applications, the term contact refers to a business object or 
component that typically represents a customer.

contact center  A single site or multiple sites at which contacts are received and answered 
on voice, e-mail, and chat media channels for the purpose of communicating 
with customers, vendors, or employees.

Content Analysis An automated analysis of e-mail that determines the topic and language of 
the e-mail. Based on this analysis, automated responses are sent to 
customers, or to agents for final approval.

For this integration, the actual Content Analysis is performed by Siebel.

CORBA See Common Object Request Broker Architecture.

definition file See Siebel definition file.

EAI server See Enterprise Application Integration server.

Enterprise Application 
Integration server

A new Siebel component located within Avaya IC that accepts workflow 
blocks on Avaya IC to perform operations that read and write data and e-mail 
to and from the Siebel database.

EDU See Electronic Data Unit.

Electronic Data Unit A record maintained by Avaya IC about a contact from a customer. Avaya IC 
stores all information related to a particular contact in the Electronic Data 
Unit (EDU). Similar to the Agent Data Unit, which represent agents rather 
than customers.

e-mail Content 
Analysis

See Content Analysis.

flow See workflow.
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IC Email server A server that integrates with SMTP and POP3 servers. The IC Email server 
also manages all polling and forwarding, from the customer to the agent, of 
e-mails that come into the Avaya IC system. Through workflows, this server 
also handles the filtering of spam, the delivery of automatic replies, and the 
management of traffic flow to external agents and approval agents.

incoming call A call offered to a route or service from an external carrier. 

media channel The method by which contacts enter Avaya IC - voice, e-mail, and Web chat.

multihomed host A computer with two or more IP addresses.

mute transfer A term previously used by Siebel that is synonymous with blind transfer. See 
blind transfer.

on hold A caller is placed in a wait state.

ORB Server An Avaya IC server that controls and maintains other servers. Every machine 
that runs servers must have an ORB Server running. The ORB Server can 
start, stop, and monitor the status of any server on its machine.

outbound Calls or e-mail sent to a prospect or customer from a contact center.

queue A group of agents, often with similar skills or knowledge, to which customer 
contacts are routed in a contact center. For example, there may be a 
Hardware Sales queue, a Hardware Support queue, a Software Sales 
queue, and a Software Support queue, each containing agents who handle a 
particular type of issue.

ready state See available state. 

SCAPI See Siebel Adaptive Communications API.

screen pop A term used to describe how contact information is displayed in the Siebel 
Application Window in response to either new work being delivered to the 
agent or work being accepted by the agent. Typically a new screen or view 
that is associated with the incoming contact is presented, or popped, to the 
agent. In Siebel, screen pops are usually driven from driver events and the 
associated rules in the Siebel definition file that define the Siebel views to 
present to the agent, and the data items that should be queried from the 
Siebel database. 

shared browsing A set of features used during a chat session that enable the browsers for 
agents and customers to be synchronized so that they display the same Web 
pages simultaneously. 



UAD

Issue 4.0 November 2004 535

Siebel Adaptive 
Communications API

A Siebel driver interface that the Adaptive Interaction Center Driver (AICD) 
and Adaptive E-mail Driver (AED) use to communicate to Siebel. The Siebel 
Adaptive Communications API (SCAPI) interface is a C-Language function 
call interface that passes work item events from the AICD to Siebel, and work 
item commands from Siebel to the AICD.

The SCAPI interface is located on the Siebel system.

Siebel 
Communications 
server

A Siebel server that supports communication-related functions between the 
Siebel client PCs and application-specific drivers, such as the Adaptive 
Interaction Center Driver (AICD). Also called Siebel Comm. server.

Siebel definition file A Siebel proprietary language that describes the rules associated with how 
events and commands are processed and passed between Siebel and the 
Adaptive Interaction Center Driver (AICD). The definition file determines 
Siebel desktop behavior, such as what Siebel screen to pop. The definition 
file also controls the commands passed from Siebel to the AICD. Also called 
.def file.

Siebel Desktop A customizable graphical user interface (GUI) that hosts the Siebel 
application and runs in a browser. The agent also uses the Siebel Desktop to 
control the media through the Siebel Communications Toolbar.

Siebel integration 
servers

Servers that were created specifically for the Avaya IC for Siebel integration. 
The following servers and drivers are considered Siebel integration servers:

● Adaptive Interaction Center Driver (AICD)

● Adaptive E-mail Driver (AED)

● Enterprise Application Integration (EAI) server

suggested response E-mail responses that are generated automatically, after Content Analysis. 
When an agent receives an e-mail contact for which a set of suggested 
responses have been generated, the agent selects the most appropriate 
response and sends it to the customer.

Telephony Server A server on Avaya IC that monitors calls, including abandoned calls, and 
controls the routing of telephony requests. The TS uses the Electronic Data 
Unit to record information on incoming or outgoing calls.

TS See Telephony Server.

UAD See Unified Agent Directory.
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Unified Agent 
Directory

An internal directory that provides lists of contact center resources, which 
may include agents, queues, and customized contact lists. Agents use the 
Unified Agent Directory graphical user interface to select a destination for a 
transfer, conference, or make call operations, such as a queue, another 
agent, an external agent, a supervisor, or a person with a specified 
proficiency in a particular skill. 

work item (1) In Avaya IC, every contact a customer makes to an agent and vice versa 
is represented by a work item. If a customer calls, then sends e-mail, and 
then participates in a Web chat, each of these contacts is considered a 
separate work item. However, multi-media contacts are combined into one 
work item. For example, a Web chat + call is one work item.

(2) In Siebel, every entry in the Siebel Communications Toolbar Work 
Item Drop-Down List represents a unique work item.

workflow A script that defines a sequence of steps the system performs when handling 
voice, e-mail, and Web chat contacts. Workflows are flowcharts that consist 
of a series of connected blocks. Each block defines a step in the workflow. 
The order of the blocks in the workflow determines the order in which the 
steps are performed. Default workflows are provided during installation. 
Integrators can use the Avaya IC Workflow Designer to modify the default 
workflows. Also called flows.

workgroup A set of agents and queues. Workgroups enable the pooling of agents and 
queues by their related responsibilities and skills, resulting in better use of 
resources and more efficient management. Each workgroup can contain one 
or more agents and queues as well as other workgroups, structured 
hierarchically. A workgroup can contain supervisors, who are agents 
assigned the role of supervisor.

wrap-up State the agent enters after contact with a customer ends. During wrap-up, 
an agent can complete the transaction and may be required to enter reason 
codes or complete a script. 
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