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... System Set up for |EEE 802.1x Operation
Avaya Wireless Technical Bulletin September 200

I ntroduction

With the introduction of the new Avaya Wireless AP-3 access point, |IEEE 802.1x-
based security has been made available for wireless (mobile) users to prevent
unauthorized access to network resources, and to increase the protection against
eavesdropping by using dynamic assigned encryption keys. |IEEE 802.1x provides
security authentication and encryption schemes, involving three major network
elements:

= An authentication server to validate the authenticity of a user that
requests access to a network. A user is validated based on a unique
“certificate” its client PC provides and that is registered at the
authentication server. The authentication server typicaly is
implemented in the form of a RADIUS server.

» Provisionsin wireless Access Points, to alow uncontrolled access
to an authentication server only and controlled access to the rest of
the network, once authentication by the server has been
successfully completed, and encryption keys between the client and
the Access Point are established. I n the Avaya Wireless product
family this uncontrolled/controlled access facility is implemented
in the new AP-3 access point.

» Facilities within the client station to initiate the authentication
process and the establishment of the encryption keys. In standard
terms this is known as a “ Supplicant” function. At the time of
drafting this paper the only implementation of such a supplicant is
within Microsoft’s new Windows/XP Operating System. However
it is expected that more OS versions will include this functionality
over time.

Because of the complexity of these schemes and the configuration of the
various systems involved, the need for a step-by-step configuration
guideline/instruction was felt. This bulletin contains those instructions for a
specific set of implementations.

Requirementson Authentication server
and supplicant

At this point in time the actual configuration requires specific versions of operating
systems.

= Theonly currently available RADIUS implementation that supports
802.1x is the Microsoft Windows 2000 Advanced Server Build
2195 with service pack 2 installed.

= The currently available supplicant is implemented in Microsoft
Windows XP Professional (we used for the testing Release
Candidate 2 build 2526)
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... System Set up for IEEE 802.1x Operation

Detailed instructions of a set

configuration

Step 1. Preparations

a)
b)

c)
d)

Get a cross connect cable (or a hub with two patch cords)

Get aclient system with Windows XP Professional RC2 (build
2526) on it

Use built-in XP client manager instead of Avaya Wirdless client
manager

Get a server with Windows 2000 Advanced Server Build 2195 on
it.

= |pstall Service Pack 2 on the server

€)

Make sure on the server that the C drive is formatted with the
NTFSfile system:

= Check the properties of the C drive under “My Computer” to determine the
current file system
= |f ismot NTFS, run “convert C:/fs:ntfs” from a DOS window and then reboot.

Step 22 Nameyour server computer:

a)
b)

Right click My Computer - Network ID - Properties
Name the computer “radius’

Step 3. Install Active Directory on the server (start the Active Directory
wizard) with default options:

a)

b)

c)

Attach the server to a hub or connect the server to the AP with a
cross connect cable. If thisis not done, installing AD on the server
will fail.

Start-Programs - Administrative Tools—> Configure Y our Server
to start the Configure Y our Server Wizard or:

Click on the “Active Directory” link on the left pane or click Start
- Run and type “DCPROMQO” (DCPROMO is the default
command from a DOS window to start the AD wizard on W2k
server)

Click on the “Start the Active Directory Wizard” link at the bottom
of the page.

Select “Domain Controller for aNew Domain”, then “Create a
New Domain Tree”, and then “ Create a New Forest of Domain
Trees'.

For the DNS name use “wireless.com”

For Domain NetBIOS name use “wireless’

Database locations: WINNT\NTDS (default) > Next

Next

Select “OK” on the warning message, the select “Yes’ to install
DNS.

k) Seect preWindows 2000 servers
) No Admin password is needed, leave blank
m) Next. Advanced Server CD ROM will be required (exit CD autorun
if it garts)
n) Reboot
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... System Set up for IEEE 802.1x Operation

Step 3: Install DHCP ontheserver:

a)
b)
c)
d)

€)

Start > Programs - Settings - Control Panel
Add/Remove Programs = Windows Components

Select Networking Services and check DHCP

Assign a Static |P address for the NIC of the server: example
20.0.0.1, sub-mask 255.0.0.0, Default Gateway 20.0.0.1
Assign the DNS server to use 20.0.0.1, no secondary needed.

Step 4: Configurethe DHCP server and create a scope:

a)
b)

)

Start > Programs > Administrative Tools > DHCP

Click on the server, then Action - New Scope. Set scope rame =

‘scopename’

Use scope range of 20.0.0.1 to 20.0.0.200

Skip Exclusions::

(We used exclusion : static 20.0.0.1 for server NIC and static

20.0.0.2 for AP)

Length = 8, sub-net mask = 255.0.0.0.

Lease Duration: 8 days

Configure DHCP options. Yes

Skip default gateway

Parent domain = wireless.com

For Server Name for DNS use “radius’, then click Resolve

Click Add IP address

For WINS server, fill in the server name, Resolve, Add - Next.

Activate scope :Yes

Finish

Authorizethe DHCP server,

= Refresh screen [F5]

= Action > Authorize

» Refresh [F5]

Attach awired client to the server and verify receipt of an IP

address.

= On the wired client machine, run IPCONFIG and verify the IP
address.

=  Start > Programs - Accessories—> Command Prompt

= |PCONFIG /dl <CR>

= Verify IP address between 20.0.0.3 and 20.0.0.200

Step 5: Configurethe Domain Controller (server) so that passwords are stored
in reversible encrypted format for all users.

a)
b)

©)

d)

Set to Enabled.

Start > Admin Tools - Open Active Directory for Users and

Computers

Right click server name (wireless.com), then click properties

Highlight Group Policy and click Edit

Go to Windows Settings/Computer Configuration/Security

Settings/Account Policy/ Password Policy/Store password using

reversible encryption for al usersin the domain.

= Double click on * Store password using reversible encryption
for al usersin the domain’
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... System Set up for IEEE 802.1x Operation

Step 6: Createanew domain user on the Domain Controller:

a)
b)

c)

d)

Log on to the DC as administrator
Start > Admin Tools - Open Active Directory of Users and
Computers
Create a new username xxx
= Click Action > New = User xxx
» Pick a password xxx
» Finish the new user wizard

In the properties for the user, ensure that remote access dial-in is allowed

and store reversibly encrypted password for the user.

= Right click on the usa name that has just been created, and
select properties.

» |nthe Account tab, click the box to store password using
reversible encryption.

* |In the Dial-in tab, allow access for Remote Access Permission.

Step 7: Make the machines (client shown in figur e below) on network,
member s of the newly created domain.

DC
DHCP
DNS
RRAS
s
IAS

Client -t

Y

CA

> Server

y |
A

a) Login asthe Administrator of a XP client system
b) Edit the systems domain name to “wireless.com”
= Right click on My Computer - Properties - Computer Name - Change
= Domain Name: wireless.com
= Veify to see the ‘Welcome to the domain’ message
= Reboot the client
= Log on to “wireless.com” domain as administrator on the XP client
¢) Now add the previously created domain user xxx from the server, to the local
administrators group on the XP client (User Name: xxx and a password xxx,
domain of “wireless.com”)
= Start > Control Panel = User Accounts - Add
= User name: Xxx
= Domain: wireless.com
= Other: Administrator

= Finish
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... System Set up for IEEE 802.1x Operation

Step 8: Ensurelogin ispossible from XP client to the domain with user profile

a)

b)

0)

stored on Domain Controller (= roaming profile).

Configure the roaming profile on the server within user-account properties. Share
the user profile folder on the server and set the proper NTFS permissions
otherwise it will not be possible to load the roaming profile from the sener at
logon

Log on to Domain as a domain user of wireless.com using user name xxx and
password xxx that was created on Domain Controller.

Check in Control panel - System that a roaming profile exists

Step 9: Install other necessary serviceson the server machine.

a)

Start > Control Panel > Add/Remove Programs - Add Windows components:
Certificate services

= |nternet Information Services - (11S) - Full Options

= Networking services = Internet Authentication Service (IAS)

= Click Next

= Select Enterprise Root CA

= CA name: radius

= Next

= Next

= Select'OK tostop 1S
= Finish

Step 10: Setup | AS server

a)
b)

Start > Admin Tools 2 IAS

Create Radius client for the server

= OpenlAS

= Right click on Clients and select New Client

= Client Name: radius
IP address : 20.0.0.1 Use a shared secret key of “AP’ (shared key could be
anything)

= Check ‘Client must always send the signature attribute in the request.

= Right click on Clients and select New Client

= Client Name: AP-3

= |Paddress: address assigned to the AP-3. (20.0.0.2)

= shared secret key: of “AP’(shared key could be anything)

= Check ‘Client must always send the signature attribute in the request.

Create aclient for RAS server, which needs to authenticate using IAS. Since RAS

server will exist on the same machine as the IAS server, create a client for the

server address.

=  Start - Admin Tools = Routing and Remote Access

= Click on the server, then Action and Configure and Enable Routing and
Remote Access

= Use Manua Configured Server setting during the wizard.

=  FinishWizard

= Yesto start
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... System Set up for IEEE 802.1x Operation

= Right click on radius > Properties:
= Genera tab (Check Router)
= Select LAN and demand-dial routing
= Check Remote access server
= Security tab
= Authentication provider: “Radius Authentication”
d) Pressthe Configure button, Server name: 20.0.0.1
= Select the change button for the secret key, and type “AP’ as the secret key.
=  OK,OK, (including warning)
= Accounting provider: “Radius Accounting” .
e) Pressthe Configure button, Server name: 20.0.0.1
= Select the change button for the secret key, and type “AP’ as the secret key.
=  OK,OK, (including warning)
= Pressthe Authentication Methods button.
= Check “Extensible Authentication Protocol ”.
= Desdect any other boxes in this window
= EAP Methods. “ Smart Card or other Certificate’ should be included in the list

Step 11: Create Remote Access policies and create a new profilefor every
authentication mechanism that isneeded i.e.,, EAP-TLS.

a) Stat—-> Admin Tools > IAS.
b) Select Remote Access palicies.
¢) Right click and select New Remote Access Palicy.
d) Name EAP-TLS.
e) Condition > Add - Day and Time Restriction > Add
f) Use 24hr access (blue colored screen)
g Select Deny remote access permission
h) Edit the Profile:
= No Dial-in constraints
IP: Select Server settings define policy
Authentication: Select EAP only using smart card or other certificate.
Uncheck al other boxes
Configure the certificate by selecting Configure
= Select ‘radius.wireless.com’
= Encryption: All boxes checked except for No Encryption.
= Diakin Constraints: Check Restrict maximum session to: 200 minutes

Step 12: Toensure |l AS server works, setup Routing and RAS server on the
machine.
a) Ensurethat on IAS, the EAR-TLS profile is the first one from top in order.
= Start > AdminTools 2 IAS
= Click on Remote Access Policies
» Verify that EAP-TLS s thefirst profile listed
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... System Set up for IEEE 802.1x Operation

Step 13: Now on the Server machine:

a)

Start > Admin Tools - Active Directory Users and Computers

= Right click on Domain Controllers = properties

=  Group policy: Default domain policy - Edit

= Computer Configuration - Windows Settings - Security Settings - Public
Key Policies > Right Click on Automatic Certification Request Settings >
New > Automatic Certificate Request

= Default through the wizard.

Step 14: From the XP client machine, log in asa Domain User xxx of the

a)
b)
©)
d)
€)

f)

)

h)

i)
)

domain.

Start > Run - mmc [MS Management Consol €]

File > Add/Remove Snap-in

Add > Certificates > Add - close

Click on Certificates, then hit Return

Certificates > Right click on Personal > All Tasks > Request New Certificate
Next > User

= Check Advanced

= Check MS Enhanced Crypto Prov 1.0

= Uncheck Enable Strong Protection

Close MMC

Desktop
Right click on Internet Explorer on desktop = Properties—> Content >
Certificates 2>
Click on Certificates - Advanced

Check client authentication

Step 15: Createa VPN on the Client for VPN accessinto the RRAS server:

a)
b)
c)
d)
e
f)
)
h)
)
),

K)

Right click on My Network Places, select properties
Select Create a New Connection

Select Connection to the network at my workplace
Select VPN

Choose a company name

VPN Server Selection: 20.0.0.1

Connection Availability: My use only.

A "Connect Company name" screen will appear.
Finish

Click the properties > Security - Select Advanced (custom settings) > Settings
= Data Encryption: Require Encryption

= Use EAP: Smart Card or other Certificate

= Select Properties

» Select Use a Certificate on this computer

= Uncheck Validate Server certificate

= Check Use a different user name for the connection
Open Network Places - View Network Connections
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1)

m)

n)

Right click on the VPN connection - properties

Security: click on “Advanced (custom settings)

Authentication mechanism : EAP-TLS — “Smart Card or other Certificate
(encryption enabled)”.

Click on “Properties’ tab for EAP-TLS.

Check “Use a certificate on this computer” box.

Uncheck “Validate server certificate” box.

Connect to the VPN server, by double-clicking on the connection.
User will be prompted to select a certification.

Select (the only) one and the user should be authenticated.

0) This ensures that a certificate on the client can be used for successful
authentication with the server.

Step 16: Connect the AP -3 (with the Beta 2 fixed software) in the network

(shown in figure below).

DC
DHCP
DNS
RRAS

s
IAS

Client [——Wireless Link——» AP CA

A
Y

A
Y

Server

a) Use awired connection between AP and server (preferable cross-cable) + a

Step 17: Verify that your IP addressfor the AP and the DHCP addressfor the

a)
b)

<)
d)

€)

f)

9

h)

wirdess link (Avaya Wireless PC Card with FW version 7.52) between XP client

and AP

AP match on the server. Use|ASto changethe addressif needed.

Start > Admin Tools > DHCP > Scope > Address Leases
Start > Admin Tools 2 IAS

Clients & Check that the | P address for the AP-3 is correct

Open |E (Use the address of the AP = http://20.0.0.2)
User name is blank

AP password is ‘public’

Configure - Interfaces >

Change Network name (not required)
Disable closed system
Ok - back

Configure > Security

Radius Authentication leave unchanged
Ok - back

Radius MAC Access Control Status = leave disabled

Change passwordsto ‘AP
Ok - back

Radius Server > Server Status - Enable

IP address; 20.0.0.1
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... System Set up for IEEE 802.1x Operation

= Ok - back
j) Encryption:
= Configuration: 802.1x
= Enable used cards
= Ok - back
k) Commands - Reboot > OK

Step 18: On the XP client logon as domain user xxx on domain

a) Right click on wireless connection - properties - authentication
b) Use certification

¢) Uncheck ‘Validate....

d) Check ‘Useadifferent name for connection’

Step 19: On the XP client, logon as domain user xxx on domain, connect to the
VPN server, by double -clicking on the VPN connection.
a) User will be prompted to select a cert.
b) Select (the only !) one and the user should be authenticated.
c) Thisensuresthat a certificate on the client can be used for successful
authentication with the server via the AP.
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