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Abstract 
 
These Application Notes describe the configuration steps required for the Braxtel Fluency 
Communicator Interactive Voice Response (IVR) to successfully interoperate with the Avaya 
IP Office.  Braxtel Fluency Communicator IVR provides a wide range of customer interaction 
capabilities for the creation of dynamic, flexible IVR applications with an easy to use 
graphical call flow designer. Features and functionality were validated and performance testing 
was conducted in order to verify operation under load.  Information in these Application Notes 
has been obtained through interoperability compliance testing and additional technical 
discussions.  Testing was conducted via the DeveloperConnection Program at the Avaya 
Solution and Interoperability Test Lab. 
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1. Introduction 
These Application Notes describe the compliance-tested configuration utilizing Avaya IP Office 
2.1 and Braxtel Fluency Communicator IVR 3.8. 
 
The Braxtel Fluency Communicator IVR (Fluency IVR) is a Windows 2000 Server based system 
that provides a wide range of customer interaction capabilities for the creation of dynamic, 
flexible interactive voice response applications.  It supports a configurable automated attendant, 
a call flow designer to set up business rules for the interactive voice response and pager and cell 
phone notification.  Call Flows are created and modified using a graphical drag and drop tool, the 
Call Flow Designer. 
 
The Fluency IVR interoperates with the IP Office via T1/PRI.   Incoming calls routed to the 
Fluency IVR are serviced according to business rules defined in the call flow.  That is, the call 
might be processed either internally or transferred to the defined endpoint (IP Office extension, 
hunt group, and/or outside line).   It can also send a notification of a particular event within a call 
or type of call (as per the call flow rules) via phone, cell, pager or email (or combination 
thereof). 
 
The Fluency Communicator IVR is fully customizable.  Braxtel can provide services for 
customization of the Fluency Communicator IVR call flows, installation and configuration. 
Partners/Customers who have completed relevant training can install, configure, customize and 
create call flows using the Drag and Drop Fluency Call Flow Designer supplied as part of the 
Fluency Communicator package. 
 
The tested configuration is shown in Figure 1. 
 
The IP Office was setup with two PRI trunk cards.  The first PRI trunk port was connected to the 
central office.  The second PRI trunk port was connected to the Fluency IVR. The IP Office 
routed all inbound trunk calls (analog and PRI) to the Fluency IVR PRI trunk.  The Fluency IVR 
handled the incoming calls with a call flow setup to behave like an automated attendant. 
Transfers were made to various IP Office extensions based on digits entered and/or DTMF input.  
Routing by DNIS and cell phone notification were verified after making minor adjustments to 
the call flow through the IVR Dialog Generator.    
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Figure 1: Braxtel Fluency Communicator and Avaya IP Office Configuration  
 

2. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided: 
 

Equipment Software 
Avaya IP 412 Office System with 2 T1/PRI modules 2.1(15) 
Avaya IP 400 Phone 30 Expansion Module  4.1(15) 
Avaya IP 400 Digital Station 16 Expansion Module  4.1(15) 
Avaya IP 400 Analog Trunk 16 Expansion Module  4.1(15) 
Avaya IP Office Manager software 4.1(15) 
Avaya 4624 IP Telephones 1.81 
Avaya 6408D+, 6416D+M Telephones - 
Braxtel Fluency Communicator 3.8 
Generic PC for Avaya IP Office Manager Windows 2000 Professional 

Service Pack 4 
Generic PC for Braxtel Fluency Communicator Server Windows 2000 Server 

Service Pack 4 
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3. Configure Avaya IP Office 
This section addresses provisioning of the IP Office as it relates to integration of the Fluency 
Communicator.  This includes configuring the PRI trunk connected to the Fluency IVR, defining 
the shortcode and configuring the incoming call route.  For all other provisioning information, 
such as provisioning of the trunks for regular inbound and outbound dialing, call coverage, 
extensions, etc., please refer to the IP Office documentation. 
 

Step Description 
 Connect to IP Office 
1.  Log in to the IP Office Manager PC and go to Start → Programs → IP Office → 

Manager to launch the Manager application. Log in to the Manager application using the 
appropriate credentials. 

2.  In the Manager window that appears, select File → Open to search for the IP Office 
system in the network. 

3.  Log in to the IP Office system using the appropriate login credentials to receive its 
configuration. 

 Configure PRI trunk connected to Fluency Communicator 
4.  In the Manager window, go to the Configuration Tree and double-click Line to open the 

list of lines (trunks) available on the IP Office. 
5.  Double-click the Line connected to Fluency Communicator, e.g. 05.  
6.  In the Line tab of the PRI 24 Line window that appears, set Line SubType to PRI, Channel 

Allocation to 1 -> 23, Provider to AT&T and Switch Type to NI2.  Highlight all the 
channels listed in the channel pane of the PRI 24 Line window, right click and select Edit. 
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Step Description 
7.  In the Multiple Channel Edit window that appears, set Incoming Group to 5, Outgoing 

Group to 5, Admin to In Service and click OK. 
 

 
8.  In the PRI 24 Line window, click OK. 

 

 
 Define Shortcode for routing calls to Fluency IVR  
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Step Description 
9.  In the Manager window, go to the Configuration Tree and double-click Shortcode to open 

the list of short codes on the IP Office. 
10.  Right click in the Shortcode window and select New. 
11.  In the Shortcode window that appears, set Short Code to [6]N; and set Telephone Number 

to N, set Line Group ID to 5 (the Incoming Group number defined for the PRI trunk to the 
Fluency Communicator) and set Feature to Dial.  Click OK. 
 

 
 Configure Incoming Call Route 
12.  In the Manager window, go to the Configuration Tree and double-click Incoming Call 

Route to open the list of incoming call routes on the IP Office. 
13.  Right click the call route in the incoming call route window and select New. 
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Step Description 
14.  In the Incoming Call Route window that appears, set the Line Group ID to 1 (or a number 

that is not already in use), set Destination to 6. and click OK. 
 

 
For the purposes of these Application Notes, all PRI and analog trunks on the IP Office, 
except the PRI trunk connected to the Fluency Communicator, were assigned Line Group 
ID 1 to allow Fluency Communicator to process all incoming calls. 

 Save the configuration  
15.  In the Manager window, select File → Save to save the configuration to the IP Office 

system and wait for the system to update. 
 
 

4. Configure Braxtel Fluency Communicator IVR 
This section addresses provisioning of the Fluency Communicator IVR as it relates to the IP 
Office.  For all other provisioning information, such as installation of Fluency IVR components 
including Oracle Database, configuring and/or customizing the Fluency IVR server and/or 
components for use, please refer to the Braxtel product documentation and/or contact Braxtel 
technical support. 
 



4.1. Configure the Fluency IVR  
 

Step Description 
 Configure Intel Dialogic card for PRI  
1.  Log into the Fluency IVR server with the appropriate administrative privileges.  Go to 

Start → Programs → Intel Dialogic System Software → Configuration Manager → 
DCM.  

2.  In the Intel Dialogic Configuration Manager window that appears, right click on the board 
to be configured (in this case D/480SC-2T1 at ID 0) and select Configure Device. 
 

 

 

 
SCR; Reviewed: 
SPOC 3/10/2005 

Solution & Interoperability Test Lab Application Notes 
©2005 Avaya Inc. All Rights Reserved. 

8 of 23 
braxtel-ipo.doc 

 



 
SCR; Reviewed: 
SPOC 3/10/2005 

Solution & Interoperability Test Lab Application Notes 
©2005 Avaya Inc. All Rights Reserved. 

9 of 23 
braxtel-ipo.doc 

 

Step Description 
3.  In the Interface tab of the Intel Dialogic Configuration Manager – Properties for D/480SC-

2T1 at I… window that appears, set ISDNProtocol to NT1 and click OK. 
 

 
NOTE:  ISDNProtocol is listed twice because the D/480SC is a dual-port PRI card.  If a 
single port PRI card were used, ISDNProtocol would appear only once. 



 
Step Description 

 Setup Intel Dialogic Service for automatic startup  
4.  In the Intel Dialogic Configuration Manager window, select Service → Startup Mode → 

Automatic. 
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Step Description 

 Start the Intel Dialogic Service 
5.  In the Intel Dialogic Configuration Manager window, click the circled button on the 

toolbar to start the Intel Dialogic Service. 
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Step Description 
6.  Go to Start → Program Files → Fluency → Fluency Supervisor → Administration 

Tool.  In the Logon window that appears, enter the appropriate administrative privileges, 
set Connected System to fluency and click OK.  
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Step Description 
7.  In the Fluency Administration Tool window that appears, select Configuration → 

Telephony → Trunk. 
 

 



 
SCR; Reviewed: 
SPOC 3/10/2005 

Solution & Interoperability Test Lab Application Notes 
©2005 Avaya Inc. All Rights Reserved. 

14 of 23 
braxtel-ipo.doc 

 

Step Description 
8.  In the Fluency Administration Tool – Configuration / Telephony / Trunk window, right 

click in the Setup Trunk Access pane and select Insert Row.  In the row that appears, set 
Trunk Group to 0 and Description to PRI 1.  Perform another right click and select Insert 
Row. In the row that appears, set Trunk Group to 2 and Description to D-CHANNEL for 
the second row added.  Right click in the Setup LCR Rules pane and select Insert Row.  In 
the row that appears, set Description to All outbound calls, Trunk Group to (0) PRI 1, 
Lower Limit to 0 and Upper Limit to 64. 
 

 
9.  In the Fluency Administration Tool window, select Configuration → Telephony → Line 

Objects.  In the Fluency Administration Tools – Configuration / Telephony / Line Objects 
window that appears, right click the Setup Line Properties pane and select Insert Row.  In 
the Insert Row(s) popup that appears, set Number of rows to insert to 24 and Block start 
number to 1 and click OK.  

10.  In the Fluency Administration Tools – Configuration / Telephony / Line Objects window, 
set Description to PRI 1 for Row 1. 

11.  In the Fluency Administration Tools – Configuration / Telephony / Line Objects window, 
right-click the Description field for Row 1 and select Fill Column.  In the Are you sure 
you want to fill all the rows to the value ‘PRI 1’? confirmation pop up that appears, click 
Yes. 

12.  In the Fluency Administration Tools – Configuration / Telephony / Line Objects window, 
set Line Use to Bi-Directional for Row 1.  Set all rows to Bi-Directional by repeating 
Step 11 for the Line Use field.  
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Step Description 
13.  In the Fluency Administration Tools – Configuration / Telephony / Line Objects window, 

set Line Type to T1 ISDN for Row 1.  Set all rows to T1 ISDN by repeating Step 11 for 
Line Type field.  

the 

14.  In the Fluency Administration Tools – Configuration / Telephony / Line Objects window, 
set Description to D-CHANNEL for Row 24.  
 

 
15.  

usic Resources window that appears, set Channel to 24 and Location to the location of 

In the Fluency Administration Tool window, select Configuration → Telephony → 
Music Resources.  In the Fluency Administration Tools – Configuration / Telephony / 
M
the wave file to be used, e.g., d:\fluency\ivr_home\music.wav.  
 

 
16. 

roup window that appears, right click the Setup ACD Service pane and select Insert 

 In the Fluency Administration Tool window, select Configuration → ACD → Service 
and Group.  In the Fluency Administration Tools – Configuration / ACD / Service and 
G
Row.  In the Insert Row(s) pop up that appears, set Number of rows to insert to 1 and 
Block start number to 2 and click OK. 
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Step Description 
17.  ow, 

p ACD Services pane and set Service Name to 
In the Fluency Administration Tools – Configuration / ACD / Service and Group wind
select the newly inserted row in the Setu
Auto Attendant. 
 

 
18.  

ules.  In the Fluency Administration Tools – Configuration / ACD / Service Rules 
 

  

In the Fluency Administration Tool window, select Configuration → ACD → Service 
R
window that appears, right click the Setup Service Rules pane and select Insert Row.  In
the Add New Service Rule popup that appears, set Service to use to Auto Attendant, 
Number Dialed to 3000, and click OK. 
 

19.  In the Fluency Adm IVR → IVR.  In the 
uency Administration Tools – Configuration / IVR / IVR window that appears, right 

inistration Tool window, select Configuration → 
Fl
click the IVR Dialog Configuration pane and select Insert Row.  In the Insert Row(s) 
popup that appears, set Number of rows to insert to 1, Block start number to 100, and click 
OK.   
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Step Description 
20.  In the Fluency Administration Tools – Configuration / IVR / IVR window, select the 

newly inserted row in the IVR Dialog Configuration pane and set IVR Dialog Description 
to IPO Auto Attendant. 
 

 
21.  In the Fluency Administration Tool window, select Configuration → ACD → Routing 

Rules.  In the Fluency Administration Tools – Configuration / ACD / Routing Rules 
window that appears, right click the Setup Routing Rules pane and select Insert Row.  In 
the Add New Routing Rule popup that appears, set Service to Use to Auto Attendant, 
Time Type to Peak Time, set Day Type to Normal Working Day, set IVR Dialog to IPO 
Auto Attendant and click OK.   

 

4.2. Sample Call Flows viewed from the IVR Dialog Generator 
Please refer to the appropriate Braxtel Fluency product documentation for information on how to 
use the IVR Dialog Generator to define and/or modify call flows. The call flow displayed in this 
section is a default generic call flow for example purposes. 
 

Step Description 
1.  On the Fluency IVR server, go to Start → Programs → Fluency → Fluency Supervisor 

→ IVR Dialog Generator.  
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Step Description 
2.  In the IVR Dialog Generator login window that appears, enter the appropriate login 

credentials and click Ok. 
3.  In the Startup wizard window that appears, select Create a new IVR dialog from the 

template, set Template to AutoAtt_Not_In_Service.ivr and click Next >>. 
4.  In the Fluency “IVR Dialog Generator” window that appears, define the desired call flow. 
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Step Description 
5.  In the IVR Dialog Generator window, select View → Toolbox to display the toolbox. 

 

 
6.  To display another view of the call flow, click the Global Viewer tab on the bottom of the 

window. 
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5. Interoperability Compliance Testing 
This Interop
testing.  Feature and functionality testing examined Braxtel Fluency Communicator IVR’s ability 
to work with Avaya IP Office.  The following features were verified: transfers based on collected 
digits, transfers based on DTMF, barge-in, cell phone notification, and call routing based on 
DNIS.  Performance load tests verified the configuration continued operating under load.  
 

5.1. General Test Approach 
Feature and functionality testing was performed manually.  The IP Office was setup with two 
PRI trunk cards.  The first PRI trunk port was connected to the central office.  The second PRI 
trunk port was connected to the Fluency IVR. The IP Office routed all inbound trunk calls 
(analog and PRI) to the Fluency IVR PRI trunk.  The Fluency IVR handled the incoming calls 
with a call flow setup to behave like an automated attendant. Transfers were made to various IP 
Office extensions based on digits entered and/or DTMF input.  Routing by DNIS and cell phone 
notification were verified after making minor adjustments to the call flow through the IVR 
Dialog Generator.    
 
Performance testing was accomplished using a call generation tool connected to the IP Office.  
The PRI trunk connecting the IP Office to the central office was connected to the call generation 
tool.  Analog station ports on the IP Office were connected to analog station ports on the call 
generation tool.  The Fluency IVR call flow was modified to transfer calls to IP Office 
extensions connected to the call generation tool. Three call generation tool scripts were written.  
The first placed a call to the IP Office over the PRI trunk, dialed a sequence of digits for transfer 

econd script placed a call to the IP 
ng up. The third script placed a 

R to 

erability Compliance Test included feature, functionality and performance load 

to an extension, paused for a few seconds then hung up.  The s
Office over the PRI trunk, paused for a longer interval then hu
call to the IP Office over the PRI trunk, entered a predefined digit that caused the Fluency IV
play a message and then the Fluency IVR hung up the call. Throughout the performance test run, 
the call generator was configured to place calls using no more than 17* of the 24 channels on the 
PRI trunk. 

                                                 
* Because each transfer uses an additional PRI channel, some channels had to remain open to permit successful 
transfers. 
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5.2.1. Compliance Test Notes / Observations 
• CallerID not passing to Fluency IVR.  Fluency IVR server did not appear to receive 

CallerID information for calls from the IP Office.  Problem could not be reproduced 
using when a second hammer was connected to the IP Office in place of the Fluency 
IVR. 

• Issues maintaining call load during performance testing.  The Fluency IVR initially 
keeps up with the call load directed at it. However, something occurs on the server 
shortly after midnight,*** which causes the server to give a delayed response to all 
incoming calls within the timeout period expected for ISDN calls.  When this occurs, the 
calls are disconnected by IP Office, which in turn causes the call generator to interpret 
that an error has occurred and it stops placing new calls.  This is under investigation by 
Braxtel. 

6. Verification Steps 
The following steps can be used to verify system operation after a field installation: 

• Go to Start → Programs → Intel Dialogic System Software → Configuration 
Manager → DCM and verify the service is running. 

• Place an internal call to the Fluency IVR Automated Attendant, e.g., dial 63000.  Verify 
the Fluency IVR automated attendant prompt answers the call.   

• Follow the instructions provided by the attendant menu and transfer to an extension.  
Verify the correct extension rings. 

                                                

 

5.2. Test Results 
Most feature, functionality, and performance test cases passed.  All issues and/or observations 
noted during testing are presented in Section 5.2.1 of these Application Notes.  Overnight 
performance testing at a rate of 1,000 – 4,000** BHCA as reported by the call generation tool 
was conducted by placing calls from seventeen PRI channels on the call generator.  Performance 
statistics were captured on the Fluency Communicator server and clients to ensure that they were 
able to handle the call volume. 

 
** Problems encountered during testing resulted in loss of channels dropping the hourly call rate from 4000 to 1000.   

d at 
five o’clock in the afternoon.   

*** The issue has been pinpointed to occur around midnight regardless of whether the performance test was starte
noon or at 
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7. Support 
Customers should call the Braxtel Customer Service Center when having problems related to th
Fluency Communicator IVR product.  Braxtel will then determine the nature of the problem
recommend the best plan to the customer whether it is to: 
� Fix the problem through remote access. 
� Dispatch, at Braxtel’s discretion, on-site technical support. 

 
For technical support on the Fluency Communicator IVR software 
Braxtel Customer Service Center at US (800) 589-2477 an

po  email can be sent to support@braxtel.com. 
 

8. Conclusion 
The  A
Comm
and per
 

9. A
[1]  Avaya IP Office Installation Manual, 40DHB0002USCL, Issue 10c (5/11/2004) 
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se pplication Notes describe the required configuration steps for Braxtel Fluency 
unicator IVR to successfully interoperate with Avaya IP Office.  Features, functionality, 
formance were successfully validated. 
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9.1. Glossary 

CA Busy Hour Call Attempts 
MF Dual Tone Multi-Frequency 

Dialed Number Identification Service 

 

I Primary Rate Interface 
Integrated Services Digi



 
SCR; Reviewed: 
SPOC 3/10/2005 

Solution & Interoperability Test Lab Application Notes 
©2005 Avaya Inc. All Rights Reserved. 

23 of 23 
braxtel-ipo.doc 

 

 

vaya Inc.  All other trademarks are the 
property of their respective owners.  The information provided in these Application Notes is 
sub a, and recommendations 

rovided in these Application Notes are believed to be accurate and dependable, but are 
any 

lease e-mail any questions or comments pertaining to these Application Notes along with the 
full title name and filename, located in the lower right corner, directly to the Avaya 

 at devconnect@avaya.com

 
©2005 Avaya Inc. All Rights Reserved. 
Avaya and the Avaya Logo are trademarks of Avaya Inc.  All trademarks identified by ® and ™ 
are registered trademarks or trademarks, respectively, of A

ject to change without notice.  The configurations, technical dat
p
presented without express or implied warranty.  Users are responsible for their application of 
produBraxtel specified in these Application Notes. 
 
P

DeveloperConnection Program .  
 
 

 
 
 


	Introduction
	Equipment and Software Validated
	Configure Avaya IP Office
	Configure Braxtel Fluency Communicator IVR
	Configure the Fluency IVR
	Sample Call Flows viewed from the IVR Dialog Generator

	Interoperability Compliance Testing
	General Test Approach
	Test Results
	Compliance Test Notes / Observations


	Verification Steps
	Support
	Conclusion
	Additional References
	Glossary


