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Chapter 1
Getting started

Network Configuration Manager (NCM ) is a management application that provides 
centralized configuration and system management capabilities for a multi-BCM network. 
NCM  automates data backups and supports efficient distribution of common files. You 
can automate common configuration tasks by scheduling optimized work flows. With 
NCM , bulk distribution of BCM software updates become a simple, efficient, and 
automated process. The NCM  client software is the user interface to the NCM  server. 

NCM  provides remote support capabilities for all of the following BCM devices:

• BCM450 1.0
• BCM50 3.0 (SRG50 3.0)
• BCM50 2.0 (SRG50 2.0)
• BCM 4.0
• BCM50 1.0
• BCM 3.7

About this guide

This guide is part of the NCM  documentation suite and lists the release notes associated 
with the NCM 4.0 Release Pack 3.

Note: The complete NCM  documentation suite is located on the 
documentation CD that is included in the NCM  package. 
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Audience
This guide is intended for network engineers who use the Network Configuration Manager 
to configure and maintain networks. This guide is based on the assumption that you have 
the following background:

• understanding of networking terminology, theories, and practices
• familiarity with BCM450 1.0 configuration and management
• knowledge of the Windows operating system and graphical user interfaces (GUI)

Note: This guide distinguishes between NCM  users and the NCM  
administrator. NCM  users, the intended audience of this guide, are 
network engineers who use the NCM  software to configure networks. 
The NCM  administrator administers the NCM  server software.
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Symbols and text conventions
These symbols highlight critical information for the NCM  system:    

Caution: Alerts you to conditions where you can damage the equipment.

Danger: Alerts you to conditions where you can get an electrical shock.

Warning: Alerts you to conditions where you can cause the system to fail or 
work improperly.

Tip: Alerts you to additional information that can help you perform a task.

Note: A Note alerts you to important information.

!
Security Note: Indicates a point of system security where a default should be 
changed, or where the administrator needs decide the level of security required 
for the system.

Warning: Alerts you to ground yourself with an antistatic grounding strap before 
performing the maintenance procedure.

Warning: Alerts you to remove the NCM  main unit and the expansion unit 
power cords from the AC outlet before performing any maintenance procedure.
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These text conventions are used in this guide to indicate the information described:

Convention Description

bold Courier 
text

Indicates command names and options and text that you need 
to enter.
Example: Use the info command. 
Example: Enter show ip {alerts|routes}.

plain Courier 
text

Indicates command syntax and system output (for example, 
prompts and system messages).
Example: Set Trap Monitor Filters

angle brackets (< >) Indicate that you choose the text to enter based on the 
description inside the brackets. Do not type the brackets when 
entering the command.
Example: <InstallDir>\database\tftp

braces ({}) Indicate required elements in syntax descriptions where there 
is more than one option. You must choose only one of the 
options. Do not type the braces when entering the command.
Example: If the command syntax is  
setAccess {o|g|w}, you must enter 
setAccess o, setAccess g, or setAccess w.

brackets ([ ]) Indicate optional elements in syntax descriptions. Do not type 
the brackets when entering the command.
Example: If the command syntax is 
echo [-nonewline], you can enter either  
echo or echo -nonewline.

ellipsis points (. . . ) Indicate that you repeat the last element of the command as 
needed.

Example: If the command syntax is 
which [<command_name>] . . . , you enter 
which and as many command names as needed.
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Related publications

For more information about using NCM , refer to the following publications: 

• Using NCM  4.0 Release Pack 3 to Manage BCM450 1.0 (NN40020-601)
• NCM 4.0 Installation Guide (NN40120-303)
• NCM 4.0 Administration Guide (NN40120-601)

italic text Indicates new terms, book titles, and variables in command 
syntax descriptions. Where a variable is two or more words, 
the words are connected by an underscore.

Example: If the command syntax is 
spawn telnet <ip_address> , you enter 
spawn telnet 192.48.33.7.

separator ( > ) Shows menu paths.
Example: Choose View > Sort > by Name.

vertical line ( | ) Separates choices for command keywords and arguments. 
Enter only one of the choices. Do not type the vertical line 
when entering the command.
Example: If the command syntax is 
array NewArray = [<reference> | 
<referenceList>]  
you enter either 
array NewArray = <reference> or  
array NewArray = <referenceList>,  
but not both.

Convention Description
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How to get Help
This section explains how to get help for Nortel products and services.

Getting Help from the Nortel Web site

The best way to get technical support for Nortel products is from the Nortel Technical 
Support Web site:

http://www.nortel.com/support

This site provides quick access to software, documentation, bulletins, and tools to address 
issues with Nortel products. More specifically, the site enables you to:
• download software, documentation, and product bulletins
• search the Technical Support Web site and the Nortel Knowledge Base for answers to 

technical issues
• sign up for automatic notification of new software and documentation for Nortel 

equipment
• open and manage technical support cases

Getting Help over the phone from a Nortel Solutions Center

If you don’t find the information you require on the Nortel Technical Support Web site, 
and have a Nortel support contract, you can also get help over the phone from a Nortel 
Solutions Center.

In North America, call 1-800-4NORTEL (1-800-466-7835).

Outside North America, go to the following Web site to obtain the phone number for your 
region:

http://www.nortel.com/callus

Getting Help from a specialist by using an Express Routing Code

To access some Nortel Technical Solutions Centers, you can use an Express Routing Code 
(ERC) to quickly route your call to a specialist in your Nortel product or service. To locate 
the ERC for your product or service, go to:

http://www.nortel.com/erc

http://support.avaya.com
http://www.avaya.com/gcm/master-usa/en-us/tasks/connect/contacts/sales/salescontact.htm
http://support.avaya.com/supportfaqs
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Getting Help through a Nortel distributor or reseller 

If you purchased a service contract for your Nortel product from a distributor or 
authorized reseller, contact the technical support staff for that distributor or reseller.
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Chapter 2
Introduction

This guide lists the release notes associated with the NCM 4.0 Release Pack 3.

This chapter provides the following information:

• “Known anomalies in NCM 4.0 Release Pack 3 for BCM450 1.0 devices” on page 
15

• “Known anomalies in NCM 4.0 for all BCM devices” on page 16

• “Known anomalies in NCM 4.0 for BCM50 3.0 devices” on page 16

• “Known anomalies in NCM 4.0 for BCM 4.0 devices” on page 17

• “Known anomalies in NCM 4.0 for BCM50 1.0 devices” on page 18

• “Known anomalies in NCM 4.0 for BCM 3.7 and BCM 3.6 devices” on page 18

• “Known anomalies in previous versions of NCM” on page 25

Known anomalies in NCM 4.0 Release Pack 3 for BCM450 
1.0 devices

There are currently no known anomalies in NCM 4.0 for BCM450 1.0 devices.

Note: The complete NCM  documentation set is located on the 
documentation CD that is included in the NCM 4.0 Release Pack 3 
package. 
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Known anomalies in NCM 4.0 for all BCM devices

Server crashes during searches
NCM with 100+ BCMs imported, when we do a search for a BCM the search windows 
always stops at record 18876 and NCM freezes. (CR Q01861753) 

NCM Keycode not found issue
In some circumstances, the NCM server reports the following error, NCM Keycode not 
found, when trying to perform an import operation from the network, although the NCM 
keycode actually is installed on the BCM. If you encounter this situation, contact Nortel 
Support for instructions on how to resolve this issue. 

Reboot after applying keycodes
When applying keycodes through NCM that require a reboot to take effect, NCM does not 
prompt for a reboot, in some cases. After applying a keycode in NCM, you must reboot 
your system for the changes to take effect.

Unable to manually update run time when scheduling wizards
When scheduling a Wizard you cannot type the time to run the Wizard directly in the 
Date/Time field on the Schedule tab.

Click on the arrow beside the date and time to show a calendar. Select the date to run the 
Wizard on from the calendar and use the scroll arrows beside the hour, minute, second, 
and AM/PM fields to select the time for the Wizard to run. (CR Q01287591)

Known anomalies in NCM 4.0 for BCM50 3.0 devices
There are currently no known anomalies in NCM 4.0 for BCM50 3.0 devices.
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Known anomalies in NCM 4.0 for BCM 4.0 devices

BCM service affected during NCM import of telephony data
Running an NCM  import to retrieve configuration information from a BCM system can 
cause degradation of BCM services. Some examples of what the BCM end customer can 
experience are slow response times when the end user invokes a feature, delays in 
receiving a dial tone when a telephone goes off-hook, delays in processing end user key 
presses, and telephone time displays become out of sync with the BCM.

Use the NCM  scheduler to set up imports to run during off-peak hours. (CR Q01289358)

Copy tree functionality available only for BCM 3.x devices
NCM 3.6 RP3 can copy trees and subtrees from one imported device configuration to 
another imported device configuration listed in the NCM configuration tree for imported 
BCM 3.x devices only. 

Blank lines received when retrieving list of common files
When archiving common files from the network, NCM can return blank lines in the 
Device Files box that appears listing the files available from the network device. This can 
cause you to believe that there are no files available from the Network device.

NCM returns a message if there are no common files available on the network device. If 
the Device Files box appears empty after clicking Choose Files, in the Archive Files from 
Network pane, and no message appears, use the scroll bar on the side of the Device Files 
box to scroll to the next page to see if there are any files available. (Q01310398) 
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Known anomalies in NCM 4.0 for BCM50 1.0 devices

Declined integrated router connections
NCM  cannot import or export any router configuration data from a BCM50 device if 
there is another active management connection running, for example the Web GUI router 
interface. The BCM50 integrated router allows only one management connection at a 
time; therefore, NCM  connections will be refused if there is another active management 
connection. (CR Q01096896) 

Service Access Points table updates must be done through 
BCM50 SNMP Wizard

Modifications made in the Service Access Points table located in Telephony > 
Configuration > Administrator Access > SNMP > Service Access Points tab are not 
exported when exporting device configurations and will cause an error to occur on export. 
Use the BCM50 SNMP Wizard to add or delete Service Access Points settings. 
(CR Q01128851) 

Known anomalies in NCM 4.0 for BCM 3.7 and BCM 3.6 
devices

Web cache enhancement
NCM  does not support the Web Cache security enhancement implemented in BCM3.7. 
Configure the Web Cache enhancement through the Element Manager on the BCM.

Call Detail Recording settings
NCM does not support the Include Matrix File field under the Data File Transfer tab 
implemented in BCM3.7. Configure this field through the Unified Manager on the BCM. 
Exports of the existing supported parameters are not affected by this unsupported field.
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Connectivity broken issue
In some circumstances, the NCM server is unable to import a configuration from a BCM, 
and the NCM server reports the following error, Connectivity between NCM 
application & BCM device may have been broken during the operation. Once you 
have verified that there is no network connectivity issue, and that both NCM and BCM 
have been correctly set up to support NCM import operations, contact Nortel Support for 
instructions on how to resolve this issue. 

Inventory reporting
The following three issues can affect the number of MBMs and ports included in the 
inventory reporting:

• An inventory utility is run at nightly 3:00 a.m. on NCM-managed BCMs. 
Therefore, if new media bay modules (MBM) are added to an BCM, and an NCM 
re-import is performed that same day, the new MBMs are not visible yet to NCM.

• DSM MBMs must have at least one active set attached to them in order to be 
recognized and counted in the BCM inventory reports. This can cause 
discrepancies between the number of physical MBMs and ports physically 
installed and available on the BCM, and the MBMs and ports reported by NCM. 

• The BCM inventory is unable to differentiate between DSM16, DSM32, and 
DSM32+ MBMs. This causes the MBMs to be misrepresented in the Media Bay 
Modules report. 

Erroneous error message when exporting password changes 
for dialup, PPTP, and IPSec users

NCM generates an erroneous error message when exporting password changes for dialup, 
PPTP, and IPSec users. A dialog box appears at the end of the operation with the generic 
error, user name is in use by an IPsec Remote User. User cannot be deleted, when 
trying to change a user password. Ignore this error message, as the user password changes 
are exported successfully to the BCM. (CR Q00995001)
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Erroneous error message when exporting changes to callback 
settings

NCM will display an error message in a dialog box at the end of an export of either an 
enable or disable of Callback settings to BCM. Ignore the error message, as the changes 
are reflected in the BCM after the export. (CR Q00995003)

IPSec Branch Office Tunnel support
NCM Branch Office Tunnel wizard, visible only in NCM node Services > VPN > IPSec 
> Branch Office Accounts, is not supported. This wizard does not configure correctly 
branch office IPSec tunnels on BCMs. 

IPSec branch office tunnels must be created and enabled through the Unified Manager on 
the BCM. 

NCM can import existing IPSec branch office tunnels, and can be used to modify and 
export IPSec branch office tunnels that had previously been imported from a BCM. (CR 
Q00998229) (CR Q00998224)

IPSec Remote User Account support
NCM BCM IPSec Remote User Account Wizard, visible only in the NCM node Services 
> VPN > IPSec > Remote User Accounts, is not supported. This wizard does not 
configure correctly remote user accounts. 

IPSec remote user accounts must be created through Unified Manager on the BCM. 

NCM can import existing IPSec remote user accounts, and are used to modify and export 
IPSec remote user accounts previously imported from a BCM. (CR Q00998231)
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PPTP tunnel wizard support
NCM BCM PPTP Tunnel Wizard, visible only in the NCM node Services > VPN > 
PPTP, is not supported. This wizard does not configure correctly PPTP tunnels. 

PPTP tunnels must be created using Unified Manager on the BCM.

NCM can import existing PPTP tunnels, and are used to modify and export PPTP tunnels 
previously imported from a BCM. (CR Q00998234)

Intermittent call routing error messages
The Call Routing Wizard displays the error message, This node is no longer valid, after 
call routing configuration has completed, if the BCM core telephony feature is busy at the 
same time as the configuration change is attempted. You must re-apply the export at a 
later time. (CR Q00999256)

Keep-Alive-enabled field not present for IPSec Branch Office 
Account and Remote User Account

NCM does not support the Keep-Alive Enabled field for the IPSec Branch Office Account 
and the Remote User Account. This option must be configured through the Unified 
Manager on the BCM. 

Sending configuration and image files
You must disable the ASM module before you perform restore operations in NCM.

Export when voicemail is not initialized
You can export voicemail changes to an uninitialized CallPilot (prior to running the 
CallPilot wizard). However, such voicemail programming is activated upon the 
initialization of CallPilot. (CR Q00677039) 
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NCM NetIQ IP address value
The * value is a valid input for NetIQ Authorized Management Servers in Unified 
Manager. However, when you enter * as a value in NCM > Services > Net IQ IP, and 
then export the configuration to a BCM device, the IP address field is left blank. To 
properly export the field, enter a range of IP addresses in NCM3.6, or configure the field 
in Unified Manager. (CR Q00842257)

Extra holiday folders
When you create a number of holiday folders under NCM > Voice Mail > Auto 
Attendant > Holidays, without changing the defaults on each new holiday entry, the 
newly configured holidays are not exported until the extraneous holiday entries (those that 
are configured from the default) are deleted. (CR Q00837178)

H.323 trunks gatekeeper values blank
After importing a device to NCM, the H.323 Trunks Primary Gatekeeper IP, Backup 
Gatekeeper IP, and Alias Names fields are all blank in NCM. Unified Manager displays 
the default values for each field that is not set, but this behavior does not translate to NCM. 
(CR Q00823461) 

Config archive file naming
You must tab out of the Name field of the Config Archive dialog box before clicking the 
Send button to ensure the name is retained; otherwise, if you do not, the file automatically 
is named BCM. (CR Q00757238) 

Exporting policy to BCM fails
When you create a policy in NCM, and then export it to a BCM device, the export 
operation fails, and the policy is not exported to the device. You must add all new policies 
directly to the BCM device through Unified Manager. (CR Q00862240) 

ISDN field blank after import
When you create an ISDN entry on a BCM device, and then import the device to NCM, 
the import operation is successful, but the ISDN version field is blank. The value of the 
field is not imported properly. (CR Q00865090) 
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DLCI to IP mapping entries not imported
When you add a DLCI to IP Mapping tab entry on a BCM device, and then import the 
device to NCM, the import operation is successful, but the DLCI to IP Mapping entry is 
not imported properly. The DLCI and IP Address fields are blank. 

Also, the IP Mapping tab does not display the Local IP and Remote IP Address fields. 
These fields must be displayed under the IP Mapping tab. Due to the absence of these field 
values, you will receive an export error after changing DLCI to IP Mapping entries, and 
attempting to export them to the BCM device. (CR Q00868006 and Q00868013) 

Incorrect CallPilot version in IVR report
When you run the Report Generator Wizard in NCM, and select “Voicemail” IVR, the 
report window displays an incorrect version of the CallPilot Manager BCM Voicemail. 
Instead of displaying the current version, the report window displays CallPilot Manager 
BCM Voicemail version 1.0. (CR Q00841461)

Timeout errors when importing device configurations
When you import a BCM configuration for the first time, increase the timeout to at least 
600 (the default is 60) in the Import from Network dialog box. Increasing the timeout 
prevents the driver from timing out when the inventory process takes longer than the 
original timeout value.

When you import and export configurations to and from devices on the network, 
NCM 4.0 Release Pack 3 waits for a response from the device. If the timeout period, 
which is device-dependent, expires, and NCM 4.0 Release Pack 3 has not received a 
response from the device, NCM 4.0 Release Pack 3 displays a timeout error message. 

To increase or decrease the timeout period for a device, open its Properties dialog box, and 
click the Import or Export tab. Change the timeout period, and click OK.

In some situations (for example, over a busy WAN connection), the default timeout period 
is not long enough to receive a response from a device. In these situations, you can 
increase the timeout variable. You can set the timeout variable for devices on the Import 
tab and the Export tab for each device. 
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IVR service start
When using IVR, the IVR service is not started automatically after a restore operation. 
IVR service can be started from Unified Manager > Diagnostics > Service Manager. 
Search for Nortel Networks Startup Service, change the Startup to Automatic, and change 
Status to Started. The IVR then is functional. (CR Q00504754) 

Patch distribution
You must specify a longer timeout interval when running a Send Image to Network 
operation. 

Drop-down list not available
In NCM 3.0, under IP Firewall Filters > LAN/WAN/UTWAN > Destination Port 
Range, a drop-down menu is not available because it is located in Unified Manager. You 
must type in the label of the port, port number, or port range. (CR Q00671770) 

Naming conventions do not match Unified Manager
Naming conventions for dial-up items, such as Modem and ISDN interfaces in the 
Resources node, do not match the names found in Unified Manager. In NCM, the 
convention is Interface ID <interface or user name>.

Import data
Telephony changes to lines and sets are not reflected in import data until the next day. 
Changes made to the Business Communications Manager are not reflected in the import 
data immediately. You must schedule an import to take place after 3:00 a.m. (the time that 
the line and set inventory takes place) in order to update NCM.
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Known anomalies in previous versions of NCM

Progress bar
If you choose more than one configuration in the Configuration Data sub-tree, and import 
or export the configurations to the network, the progress bar behaves erratically, and is 
inconsistent with the actual progress of the operation. (CR Q00681693) 

NCM potentially unreachable with dual NIC
If the NCM server machine has multiple IP addresses, it is advisable to include the 
command line argument -host <ip_address of NCM server>, and inform all NCM clients 
of the IP address. 

Archive label not migrated from Oracle database
When you migrate archived entries, the label and comments are not migrated with the 
entries. Instead, a timestamp appears in place of the label, and any comments are gone. 
(CR Q00715339) 

Log rotators after migration
Log rotator settings are not migrated from NCM 2.0 to NCM 3.0. Instead, default log 
rotator settings are created when the NCM 3.0 database is created originally.

Server messages incorrectly formatted in File > Send
When selecting multiple Common Files to send to the network, the operation’s server log 
message combines all the file names into one string, and the message is formatted as 
though the multiple files are a single file. (CR Q00741834) 

Wrong filename shown after using Browse function
When sending Common Files to the network, you have the option of using Browse to 
select Configuration Data devices. However, when you use the Browse function, the 
progress label displays “sending file to null.” (CR Q00732291)
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Wrong filename shown in FTP Send
When performing a File > Send to FTP operation, you can change the filename by 
double-clicking it. However, the progress label does not register the change and instead 
reports “sending <old filename>.” (CR Q00732289) 

Starting syslog with the web server
When you start the server, if the web server cannot start on its port, the web server fails 
and does not set a “docroot” value for the path to the install directory. The syslog server 
needs this value to locate the appropriate syslog.txt file. Once the web server starts 
successfully at least once, the docroot is defined, and the syslog server can start with or 
without the web server.

Truncated menus
If you rely on the right-click method for running operations, you cannot view all menu 
options. The calculation for screen placement of the dialog box uses only the size of the 
main menu, without incorporating the size of any cascading submenus. It is possible, in 
some cases, to have a submenu truncated. In these cases, use the menu bar to perform the 
operations, or move the NCM client window to enable the submenus to display fully.

Audit log inconsistencies
Tools > Audit Log > on selected item does not display an audit log for these object types:

• device > subnodes
• Schedule folder > Log rotator objects
Audit log entries are not recorded for these operations:

• Operations on a device as a result of running a wizard
• Archive of common files
• File > Send to Network (CR Q00741839) 

Telnet session history list
The Telnet session panel history list remains empty regardless of how many device 
sessions you open.
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Send to TFTP using a remote server
When you Send to TFTP using a remote server across a WAN, a timeout message can 
appear, even though the operation was successful. To prevent the timeout message from 
displaying, ensure that all Send to TFTP operations use a remote server on the LAN. You 
also can place the files you want to send on your TFTP server, and then perform an 
Archive From TFTP from the remote server, rather than sending from a local server.

Log rotators
The log rotators sometimes can stop archiving log files after changes are made to the 
rotation schedule. If this occurs, uncheck and recheck the “Rotate Log Files by Date” 
checkbox under Server Setup > Log Setup > <log_file>. This resets the log rotator. 

Operation progress bar
During several operations, such as Import from Network and Send to Network, the 
progress bar remains at a percentage for a long time. This is normal, and can last for 
several minutes.

Viewing syslog messages
When you change the IP address for remote logging or change from remote to local 
logging, you cannot view syslog messages. You must disable, and then reenable, the 
syslog server to view syslog messages properly.

Operational notes
This section provides operational notes for the Network Configuration Manager 4.0 
release.
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General issues and recommendations
• NCM 4.0 Release Pack 3 supports multiple login sessions for a particular user ID. 

You can use this feature so that first-level support engineers can log in with one user 
ID, second-level support engineers can log in with another user ID, and so on. Note, 
however, that the audit log records information is based on user ID. Therefore, in this 
scenario, you determine only the level of the engineer who performed a particular 
task; you can not determine the identity of the particular engineer who performed a 
particular task. 

• If you change the settings on the system clock, you must restart the NCM 4.0 Release 
Pack 3 server and client software; otherwise, NCM 4.0 Release Pack 3 continues to 
operate based on the old system clock settings. 
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Chapter 3
Installing NCM 4.0 Release Pack 3

This chapter includes installation procedures for the Windows environment. NCM 4.0 
Release Pack 3 does not support the Solaris environment.You must implement the 
following three points to ensure successful installation of NCM 4.0 Release Pack 3. 
NCM 4.0 Release Pack 3 must also be installed on client PCs running the NCM  
Standalone Client.

• NCM  4.0 Server must be installed on the server before attempting to install 
NCM 4.0 Release Pack 3 on the server.

• NCM  4.0 Standalone Client must be installed on the client PC before you attempt to 
install NCM 4.0 Release Pack 3 on the client PC.

• NCM 4.0 Release Pack 3 must be installed in the same directory as NCM  4.0 
installation directory on both the server and the standalone client PC.

Installing NCM 4.0 Release Pack 3 in a Windows 
environment

Use the following steps to install NCM 4.0 Release Pack 3 on the NCM  server or the 
NCM  standalone client:

1 Verify your NCM  4.0 server or client is installed properly.

2 Retrieve NCM 4.0 Release Pack 3 from the NCM 4.0 Release Pack 3 CD or the Nortel 
Software Support web page.

3 Stop the NCM  4.0Server or the NCM  Server service if either is running. 

Note: Network Configuration Manager no longer supports the Solaris environment.
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You must stop the NCM  4.0 Server and NCM  Server service only if you install 
NCM 4.0 Release Pack 3 on the Server. Stopping the NCM  4.0 server or NCM  
Server service is not required if you are installing NCM 4.0 Release Pack 3 only on a 
client PC.

4 Double-click the downloaded NCM40RP3.exe file to run the install.

The NCM  for BCM450 1.0 Information screen appears and the installation files are 
extracted.

5 Click Next to proceed with the installation or click Cancel to quit the installation.

If you click Cancel, the installation prompts you to confirm that you want to quit the 
installation, upon which the program terminates.

If you select Next, the License Agreement screen appears. 

6 Select the I accept the terms of the License Agreement button.

Selecting the I accept the terms of the License Agreement button activates the Next 
button and the installation continues.

Selecting the I do NOT accept the terms of the License Agreement button causes 
the License Agreement Warning box to appear, enabling you to quit the installation.

7 Click Next to accept the licensing terms and continue with the installation.

The Important Information screen appears, asking you to ensure the NCM  4.0 Server 
or the NCM  Server service is stopped. Stop the NCM  4.0 Server or the NCM  Server 
service, only if you want to install NCM 4.0 Release Pack 3 on the NCM  Server. 
Stopping the NCM  4.0 Server or the NCM  Server service is not required if you install 
NCM 4.0 Release Pack 3 only on a client PC. 

Stop the NCM 4.0 Server by closing the NCM 4.0 Server command window. Stop the 
NCM  Server service, by clicking stop on the NCM Server service in the Windows 
Services Management window.

8 If required, stop the NCM  4.0 Server or the NCM  Server service.

Note: You must close the Windows Computer Management > Services 
window after the NCM  Server service is stopped. The installation 
process fails, and NCM Server cannot start, if you try to install 
NCM 4.0 Release Pack 3 with the Windows Computer Management > 
Services window open.
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9 Click Next.

The Choose Install Folder screen appears.

10 In the path field, update the install directory for the NCM  Server or NCM  Client.

The Choose Install folder screen opens with C:\Program Files\Nortel\ as the default 
install directory. NCM 4.0 Release Pack 3 must be installed in the same installation 
directory as the NCM  4.0 software. The installation directory is be incorrect if you 
did not install NCM  4.0 in the default installation path. You can update the install 
directory field manually or use the Choose button to browse your file system for the 
correct installation directory.

11 Click Next.

The Specify NCM  Server as Service Settings screen appears, stating that NCM  
server can be installed as a service.

12 Check the Install Server as system service check box if you are running NCM  4.0 as 
a service. Leave the Install Server as system service check box unchecked if you are 
not running NCM  4.0 as a service and go to step 14.

If the Install Server as system service check box is checked, the Start the service at 
the end of the installation check box becomes available.

13 Check the Start the service at the end of the installation check box if you want to 
the NCM  Server service started upon successful completion of the NCM 4.0 Release 
Pack 3 installation. Leave the Start the service at the end of the installation check 
box unchecked if you do not want to start the NCM  Server service upon successful 
completion of the NCM 4.0 Release Pack 3 installation.

14 Click Next.

The Configuration Task Complete screen appears.

15 Click Install.

The Installing screen appears, showing the progress of the installation.

When the installation is complete, the Install Complete screen appears.

16 Click Done.

17 The NCM  Server service starts automatically if NCM 4.0 Release Pack 3 was 
installed as a service and you checked the Start the service at the end of the 
installation check box. If the NCM  4.0 Server service starts automatically go to step 
19.

18 Start the NCM  4.0 Server.
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19 After installation is confirmed, you can delete the NCM40RP3.exe file from your 
system.

Uninstalling NCM 4.0 Release Pack 3 in a Windows 
environment

You can remove NCM 4.0 Release Pack 3 only by uninstalling and reinstalling the NCM  
4.0 product.
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