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Chapter 1: New in this release

The following sections describe what is new in Avaya Hospitality Messaging Server 400 Administration,
NN42350-600 for HMS 400 Release 3.0.

• Features on page 7

• Other changes on page 10

Features
See the following sections for information about feature changes.

• Upload greetings and Auto Attendant prompts as .wav files  on page 7

• Alphanumeric group code support on page 8

• Auto Attendant enhancements on page 8

• Reporting improvements on page 9

• VPIM messages to networked system Distribution Lists on page 9

• Language localization support for Web UI on page 10

Upload greetings and Auto Attendant prompts as .wav files
In HMS 400 Release 3.0, a WebUI page is provided to upload sound files in .WAV format in
PCM 16bit/8kHz/mono so that customers can use professional, studio recorded prompts.

These sounds files can only be used for:

• Auto Attendant prompts

• Welcome message

• Introductory message

• Auto Wakeup greeting

The HMS 400 converts the WAV format file into the appropriate d40 format for the Dialogic
HMP.
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Alphanumeric group code support
HMS 400 supports a group booking code from the Property Management System to create
distribution lists for group messages, Auto Wakeup, and welcome greetings. However, some
PMS systems use group codes that can be up to 23 alphanumeric characters long —
impractical for mailbox users to dial.

HMS 400 Release 3.0 provides a translation table between the group booking codes received
and a set of unique five-digit dialable numbers, accessed through a simple web GU.

30,001 – 99,999. Group codes 1 – 30,000 are used for group check-in from PMS using five-
digit numeric codes. Group code check-in from PMS can also use the codes in the range
30,001-99,999 if the code is not being used by HMS for alphanumeric groups name check-
ins.

Up to 99,999 group booking codes can be accommodated, Once all 99,999 numbers are used,
then the sequence starts again.

A setting is added to the WebUI user settings that only displays the booking code translation
table. This allows the super admin to configure WebUI users who can only access this table
and not the rest of the WebUI.

If a 5–digit code is received from the PMS, that code is automatically used as the distribution
list number without need for the translation table.

Auto Attendant enhancements
This section describes the Auto Attendant enhancements introduced in HMS 400 Release
3.0.

Dial-by-name from Auto Attendant
A new Auto Attendant layer type lets callers to Auto Attendant dial internal staff by spelling a
staff member’s name last name first from the telephone keypad.

 Note:
This feature is currently available in admin staff call flows.

Auto Attendant support of Voicemail leaving
This enhancement allows users in an Auto Attendant call flow to leave messages in guest and
admin mailboxes. This is an additional option assigned to the keys in Auto Attendant layer
design.

New in this release
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Adding notes to Auto Attendant layers
This enhancement allows users to include text remarks/information/notes with each Auto
Attendant layer.

Reporting improvements
This section describes the reporting improvements in HMS 400 Release 3.0.

Automatic Wake Up call report improvements
The following improvements have been made to Automatic Wake Up (AWU) call reports:

• AWU print transaction options have been separated from event logging. This enables the
administrator to optimize AWU event logging without impacting logging of other events.

• Guest Name information is included on the Failed Wake-Up call reports to improve staff
follow-up of missed wake-up calls.

• Recurring wake-up calls can be distinguished from single wake-up calls in logs.

Guest Directory report
Front desk staff can create a list of all checked-in guests to cross-check occupancy and provide
a quick reference.

System Traffic report
HMS 400 can create a report (and graph) providing an hourly summary of traffic to the different
services (for example: call answering, voice messaging, AWU) in CCS or Erlangs. This allows
customers, distributors and system engineers to evaluate which services are drawing the most
traffic and to determine peak usage hours.

Sort reports by any column
Reports can be sorted by data using selected columns as the sort key, enabling customized
reports.

VPIM messages to networked system Distribution Lists
Messages originating on an HMS 400 or CallPilot can be addressed to distribution lists on HMS
systems networked by VPIM. For example, if guests associated with group code 5678 reside
on two HMS 400 systems — HMS 400 system A and system B — a staff member on a CallPilot
can address a VPIM message to distribution list 5678 on HMS 400 A and HMS 400 B.

For more information on VPIM configuration, see Avaya Hospitality Messaging Server 400
Installation and Commissioning, NN42350-301.

Features
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Language localization support for Web UI
The Hotel Operation page and Admin User Mailbox page of the Web UI will be displayed in
the language selected by the user at the Web UI main login page.

The languages supported are:

• Simplified Chinese

• Japanese

• Korean

• French

• German

• Italian

• Russian

• LA Spanish

• Brazilian Portuguese

 Note:
Only the Hotel Operation page and the Staff Personal Mailbox page are displayed in the
selected language.

Other changes
See the following sections for information about other changes.

• ∙Revision history on page 10

Revision history

March 2012 Standard 06.01. This document is up-issued to support Avaya
Hospitality Messaging Server 400 Release 3.0 and to reflect changes
to the Internet Explorer security settings.

New in this release
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Chapter 2: Introduction

This document describes administration procedures for the Avaya Hospitality Messaging Server (HMS)
400.

Navigation:

• Auto Attendant administration on page 13

• Staff voice mail system administration on page 43

• Hotel administration on page 53

• Room status administration on page 63

• Minibar administration on page 69

• Auto Wake-Up administration on page 75

• Staff Telephone User Interface administration on page 85

• Report generation on page 89

• Backup and restore management on page 105

• Avaya Hospitality Messaging Server system recovery on page 115

• Common procedures on page 117
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Chapter 3: Auto Attendant administration

This chapter describes how to prepare and set up an Auto Attendant Flow.

Prerequisites to Auto Attendant administration:

• Install and commission the Avaya Hospitality Messaging Server 400 system.

For information about installation and commissioning, see Avaya Hospitality Messaging Server 400
Installation and Commissioning, NN42350-301.

Auto Attendant administration tasks
About this task
This work flow shows you the sequence of tasks you perform to administer the Auto
Attendant.
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Figure 1: Auto Attendant administration tasks

Auto Attendant administration navigation:

• Auto Attendant planning on page 14
• Auto Attendant configuration on page 28

Auto Attendant planning
This section describes how to prepare to create an Auto Attendant Flow.

Auto Attendant planning procedures
About this task
This task flow shows you the sequence of procedures you perform to administer Auto
Attendants.

Auto Attendant administration
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Figure 2: Auto Attendant planning procedures

Auto Attendant planning navigation:

• Downloading Auto Attendant  on page 16
• Recording a new voice prompt using the Auto Attendant software on page 20

Auto Attendant planning procedures
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• Uploading a pre-recorded voice prompt on page 21
• Changing HMS400R3 folder permissions on page 16
• Setting up Auto Attendant  on page 17
• Defining an Auto Attendant Flow on page 23
• Configuring entry points for Auto Attendants  on page 25
• Editing a voice prompt on page 26
• Deleting a voice prompt on page 27

Downloading Auto Attendant
About this task
Download Auto Attendant to prepare to create custom flowcharts of voice menus and options
for callers who call your preconfigured number.

Prerequisites:

• To install the Auto Attendant on a system other than the main Avaya Hospitality Messaging
Server 400 (HMS 400) server, download the Auto Attendant client application from the
Web UI (Hotel Operation > Auto Attendant).

• Have proper permissions to download the Auto Attendant client application from the Web
UI.

Procedure

1. Start a Web browser on your personal computer.

2. To access the Web UI, in the address bar, type the following URL: https://
hms400r3/hms400webui and press Enter.

3. Select Hotel Operation.

4. In the navigation pane, select Auto Attendant > Download AA Setup .

5. In the File Download dialog box, click Save to copy the setup files to your local
hard drive.

Changing HMS400R3 folder permissions
About this task
Change the HMS400R3 folder permissions to enable you to download and configure Auto
Attendants.

Auto Attendant administration
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Procedure

1. Log on to the HMS 400 server.
OR
Log on to the HMS 400 server through remote desktop.

2. In the Run dialog box, in the Open list, type the HMS 400 server IP address.

3. In the Login box, type administrator.

4. In the Password box, type hmsabc123.

5. In the HMS400R3 Properties dialog box, click the Sharing tab.

6. Click the Share this folder option.

7. Click Permissions.

8. In the Permissions for Everyone section, select the Full Control check box.

9. Click OK.

Setting up Auto Attendant
About this task
Set up Auto Attendant to prepare to create custom flowcharts of voice menus and options for
callers who call your preconfigured number.

Procedure

1. In the Download Complete dialog box, click Open to decompress the Auto
Attendant setup.exe file.

2. Double-click setup.exe.

3. If the system displays a security warning, click Run.

4. In the HMS400R3 Auto Attendant Setup dialog box, click OK.

5. Click the installer button. To identify the installer button, see Figure 3: Installation
icon on page 19.

6. In the HMS400R3 Auto Attendant Setup - Choose Program Group dialog box,
click Continue to accept the default folder name.

7. If you install HMS 400 on a computer with the WinXP Pro operating system, click
Ignore after you see the following error message:
C:\Windows\system32\msvcrt.dll
The destination file is in use. Please ensure that all other
applications are closed.

Auto Attendant planning procedures
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8. Click Yes.

9. Click OK.

10. In Windows Explorer, navigate to the folder in which you saved the Auto Attendant
files.

11. Double-click the MySQL ODBC 5.1.4 Installer icon.

12. Click Next.

13. Select the I accept the license agreement option.

14. Click Next to install MySQL ODBC.

15. After the system completes the MySQL ODBC installation, click Finish.

16. Click the Windows Start button.

17. Click Start > All Programs > Administrative Tools > Data Sources (ODBC) and
proceed to step 19 on page 18.
OR
Click Start > Settings > Control Panel.

18. In the Control Panel window, double-click Data Sources (ODBC).

19. In the ODBC Data Source Administrator dialog box, select the System DSN
tab.

20. Click Add.

21. In the Create New Data Source dialog box, scroll through the list and click MySQL
ODBC 5.1 Driver.

22. Click Finish.

23. In the MySQL Connector/ODBC Data Source Configuration dialog box, in the
Data Source Name box, type VoiceEngine and press Enter.

24. In the Server box, type the IP address of the HMS 400 server and press Enter.

25. In the Port box, type 3306 and press Enter.

26. In the User box, type root and press Enter.

27. In the Password box, type 000 and press Enter.

28. In the Database list, type voiceengine and press Enter.

29. Click Test to verify the connection.

30. Click OK.

31. Click OK.

Auto Attendant administration
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Variable Definitions

Variable Value Applies to
Database Use this list to connect to the HMS 400

database. Users must select the
VoiceEngine option.

Connector/OBDC - Add
Data Source Name dialog
box

Data Source Name Users must type VoiceEngine in this
field.

Connector/OBDC - Add
Data Source Name dialog
box

HMS 400 server IP IP address of the HMS 400 server. For
example, \\10.8.2.77.

Connector/OBDC - Add
Data Source Name dialog
box

Port Default value (3306). Connector/OBDC - Add
Data Source Name dialog
box

Password Database password. Users must type
the default database password: 000.

Connector/OBDC - Add
Data Source Name dialog
box

Server The identification of the server. Type
either the HMS 400 Server name or IP
Address.

Connector/OBDC - Add
Data Source Name dialog
box

User Database default access name. Users
must type root in this field.

Connector/OBDC - Add
Data Source Name dialog
box

Job aid

Use the installation icon to install the HMS 400 Release 3.0 Auto Attendant software.

Figure 3: Installation icon

Auto Attendant planning procedures
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Recording a new voice prompt using the Auto Attendant software
About this task
Record a new voice prompt using the Auto Attendant software to build the prompt components
that you add to an Auto Attendant Flow (AAF).

Alternatively, you can record new voice prompts using the Telephone User Interface. For
information about recording prompts with TUI, see Avaya Hospitality Messaging Server 400
Front Desk Staff User Guide, NN42350-100.

Prerequisites:

• Your PC has a working sound card.
• Your system includes a microphone.
• Your system includes a headset.
• Prepare the audio script for the voice prompt recording.
• Determine the prompt ID for recording.

Procedure

1. From the Auto Attendant application, select File > Prompt Maintenance.

2. In the Prompt Maintenance dialog box, click New Prompt.

3. In the WaveIn Recorder dialog box, in the Description box, type a description for
the new voice prompt.
The system automatically fills in the File Name box as you type the description.

4. In the Language list, click a language.

5. In the Output area, click the ellipsis (…) button next to the WAV Format box.

6. In the Select WAV output format dialog box, in the Format list, click CCITT u-
Law.

 Important:
Leave the sampling rate in the Attributes box as 8 000 kHz, 8 Bit, Mono.

7. Click OK.

8. When the script is ready, press Record.
For best results, record the voice prompt in a quiet room.

9. After you finish recording, click Stop.

 Important:
The system activates the Stop button only after 3 seconds.

10. Click Play to listen to your recording.

Auto Attendant administration
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11. If you are not satisfied with the recording, click Re-Record to record the voice
prompt again.
OR
To obtain the optimum volume and achieve the best recording, use the Volume
slider to increase or decrease the recording volume, and then click Re-Record to
record the voice prompt again.

12. Click Save.

13. Click OK.

14. Optionally, to record the same prompt in a different language, click Make Recording
for Another Language.
OR
Go to step 17 on page 21.

15. In the Language list, click a new language.

16. Repeat step 5 on page 20 to13 on page 21 to record the prompt.

17. Click Exit.

18. Click Exit.

Variable Definitions

Variable Value
Description Voice prompt name. Name the Description to something

meaningful.

File Name The description followed by the file extension. For example,
if the description is lang-select, the file name is lang-
select.d40.

Uploading a pre-recorded voice prompt
About this task
You can upload a pre-recorded voice prompt or sound files to HMS 400.

Auto Attendant planning procedures
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Prerequisites:

• A voice prompt or sounds file must have been created. For information on how to create
a voice prompt, see Recording a new voice prompt using the Auto Attendant software on
page 20.

• The voice prompt or sounds file must be in .WAV format in PCM 16bit/8kHz/mono.
• Obtain a Web Admin ID with proper permissions.

Procedure

1. Open a Web browser window.

2. In the address bar, type https://hms400R3/hms400webui and press Enter.

3. Log on to the Web UI as an Admin User.

4. On the Main Menu bar, click Utilities.

5. On the navigation bar, click Change System Prompts.

6. In the Wav File dialog box, browse to where the voice prompt or sound file is
located.

7. Click OpenK.

8. In the Prompt Type list, click the type of prompt.

9. In the Language list, click the voice prompt language.

10. In the File Name box, type a file name.

11. Click Upload.

Variable Definitions

Variable Value
Prompt Type The type of prompt for the sound file uploaded. Types

include:

• Auto-attendant Prompts

• Auto-wakeup Greeting

• Busy

• Introductory Message

• No Answer

• Welcome Message

Language Determines the language of the prompts played.

Auto Attendant administration
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Variable Value
File Name Name of sounds file or voice prompt. File name must be

numeric and the maximum length of file name is 4 numbers.
This is required for the Auto-attendant Prompts prompt
type.
For example: 1001.

Defining an Auto Attendant Flow
About this task
Define an Auto Attendant Flow to determine the basic design of a flow before you create it.

 Note:
Auto-replay of announcements is not supported by the Auto Attendant.

Prerequisites:

• Make a list of all the prompts that you must record for the Auto Attendant Flow.
• Determine whether to use office hours or language menus in the Auto Attendant Flow.

Procedure

1. Determine the Operator DNs for Day operators and, if applicable, for Night
operators, to which Auto Attendants send calls if callers opt to speak to an
operator.

2. Determine if the system permits callers to dial guest rooms directly.

3. Determine if you want the Auto Attendant Flow (AAF) prompts and options to vary
depending on office hours, lunch hours, off-hours, or holidays.

4. Determine which languages you want the Auto Attendant to offer.
You must select languages that you either installed on the system, or that you will
add using a software update (SU). You must select installed languages so that the
system contains the correct directories to manage the various prompt sets. For more
information about installing languages through SUs, see Avaya Hospitality
Messaging Server 400 Maintenance, NN42350-101.

5. Determine if the Auto Attendant offers Through-Dial during the entire call flow, or
during particular Layers (menus) of the call flow.
If you use the Through-Dial option in your Layers, then no option in that Layer can
begin with the same number as an extension. Otherwise, the system uses the first
digit in that extension as a menu choice and routes the call accordingly rather than
sending it to the Through-Dialed extension. Alternatively, to allow callers to dial an
extension directly from a menu, without conflicting with other numbers used in that
menu, you can designate one menu command to route to a prompt, which asks the
caller to enter the desired extension.
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To accommodate the use of Through-Dial, the system includes a built-in check for
user-entered numbers starting with digits with no corresponding key functions. In
these cases, it accepts the user-entered numbers as possible extension numbers.
The system waits for seven digits before transferring the call. If extensions use less
than seven digits, then the system prompts callers to dial the digits and press the
pound (#) key.
To change the number of digits expected in a Through-Dialed extension, or to
change the timeout settings that control the length of time the system waits for users
to dial the digits, contact your service representative.

6. Create a flow chart for each Auto Attendant, starting from the main menu and
moving sequentially to the last layer.
Avaya suggests that you create worksheets with spaces labeled 1 to 9, 0, *, and #,
on which you record the functions for each number. Create separate worksheets
for each menu that branches down from the first menu that callers hear, until you
complete the tree with possible Layers (menus) for your callers to hear on this Auto
Attendant. Each Auto Attendant Call Flow can contain up to 25 Layers.

7. Record the prompts for each Layer (menu), in each of the languages in which you
intend to offer the prompt.
Use the Telephone User Interface (TUI) to record a full set of prompts for this call
flow, in each of the languages you wish the system to offer. The location of these
recorded prompts depends on the language code the user enters. For example, if
the user enters the language code for Spanish (11), then the system saves the
recorded prompt in C:\HMS400r3\Sound\D40\Spanish\AAPrompt. For more
information about the TUI, see Avaya Hospitality Messaging Server 400
Fundamentals, NN42350-300.
You must name the prompts correctly for the system to function properly. For
example, if you offer four languages in an Auto Attendant, then you must record
four versions of each prompt. The only exception is the initial prompt, which typically
says “These are the languages available; press 1 for language A, press 2 for
language B…”
You must name each version of a prompt with the same four-digit number as the
first part of the name. The system saves each version of the prompt in the
corresponding language folder after recording. For example, if you name an English
prompt 1010.D40 and you name the matching French prompt 1010.D40, then the
system saves the prompts in the \English\AA Prompt and \French\AA Prompt
language folders respectively.
Record on paper which prompts match which four-digit numbers to help you assign
the correct prompts to the correct Layers (menus) when programming the system.
Also, keep records of the prompts and their unique four-digit identifiers so r that you
do not duplicate the four-digit identifiers in other Auto Attendant call flows. Record
prompts for the menu choices that require them (for example, if a caller chooses
the directory assistance option, the system requires the follow-up prompt that lists
the various departments to which the system can transfer a call).
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8. Repeat step 3 on page 23 to step 7 on page 24 for every Auto Attendant you set
up.
Keep accurate paper records of your plans and the prompts.

Job aid

To create a menu, you must define the choices the system offers, and map each choice to one
of the 12 keys (1 to 9, 0, *, #) on the keypad. The following table outlines the potential
choices.

Function Type Explanation
End Call Terminates a call after the system plays a prompt or a function.

Jump To Layer Links to another Layer with further options.

Prompt To Enter
Extension

An indirect way to transfer a call to another extension. For instance,
record a prompt that says, “Press 5 to transfer to another extension.”
After a users presses 5, the system plays, “Enter extension number
followed by pound.”

Repeat Based on a keypress (for example, [*]), the system replays the layer
prompt.

Retrieve Voice
Message

Users can access their mailboxes for message retrieval.

Transfer To
Extension

Direct method of transferring to a specified extension based on
keypress (for example, 7—typically used to offer directory
assistance).

Transfer To Day
Operator

Transfers a call to an Operator. (You must first set the Operator
extension from the "Configure Operator" option on the main GUI.)

Transfer To Night
Operator

Transfers a call to a Night Operator. (You must first set the Operator
extension from the "Configure Operator" option on the main GUI.)

Configuring entry points for Auto Attendants
About this task
Configure entry points for Auto Attendants to instruct the system to how to respond to and
handle calls. To configure entry points, you must define which call flows the system must use
based on the Calling Party and the Called Party data.

The system caters to multiple call flows by using different Service (Dummy ACD) DNs. The
system then maps each DN to a call flow file. You instruct the system how to perform the
mapping in the entry point configuration.
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 Important:
You need not designate specific voice channels for Auto Attendant services.

For information about configuring entry points, see Avaya Hospitality Messaging Server 400
Installation and Commissioning, NN42350-301.

Editing a voice prompt
About this task
Edit a voice prompt to change the properties.

Prerequisites:

• Create a voice prompt. See Recording a new voice prompt using the Auto Attendant
software on page 20.

• Your PC has a working sound card.
• Your system includes a microphone.
• Your system includes a headset.
• Prepare the audio script for the voice prompt recording.

Procedure

1. In the Auto Attendant - Call Flow window, on the File menu, select Prompt
Maintenance.

2. In the Prompt Maintenance window, in the Prompts list, double-click a prompt
ID.
OR
In the Filter String box, type the name of the prompt to locate, click Go, and then
double-click the prompt ID.

3. Optionally, to offer the new Auto Attendant Flow (AAF) in more than one language,
click Record for new Language in the Prompt Details Maintenance window.
OR
Go to step 5 on page 26.

4. In the Language list, click the other language.
This list includes only installed languages.

5. In the Output pane, next to the WAV Format box, click the ellipsis (…) button.

6. In the Select WAV output format dialog box, in the Format list, click CCITT u-
Law.

 Important:
Leave the sampling rate in the Attributes box as 8000 kHz, 8 Bit, Mono.
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7. Click OK.

8. When the script is ready, click Record.
For best results, record the voice prompt in a quiet room.

 Important:
The system activates the Stop button after 3 seconds.

9. After you finish recording, click Stop.

10. Click Play to listen to your recording.

11. If you are not satisfied with the recording, click Re-Record to record the voice
prompt again.
OR
To obtain the optimum volume and achieve the best recording, use the Volume
slider to increase or decrease the recording volume, and then click Re-Record to
record the voice prompt again.

12. Click Save.

13. Click OK.

Deleting a voice prompt
About this task
You can delete a voice prompt from HMS 400 if you no longer require it.

Prerequisites:

• A voice prompt must have been created. For information on how to create a voice prompt,
see Recording a new voice prompt using the Auto Attendant software on page 20.

• Create a list of all the recorded prompts and Auto Attendant Flows that are affected by
deleting the voice prompt.

Procedure

1. In the Auto Attendant window, click File > Prompt Maintenance.

2. In the Prompt Maintenance dialog box, double-click the prompt to delete.
OR
In the Filter String box, type a search string and click Go.

3. In the Prompt Details Maintenance dialog box, in the Language Prompt area, in
the table, click the prompt to delete.

4. Click Delete.

5. In the Prompt Maintenance dialog box, click Yes.
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6. Click OK.

Auto Attendant configuration
This section describes how to create and configure a new Auto Attendant Flow.

Prerequisites to Auto Attendant configuration:

• Create a list of all the recorded prompt numbers and record their placements in the call
flow.

• Create a list of all the required DNs for the call flow.

• Create a list of the options you require for Auto Attendant (such as languages, office hours,
and the ability to transfer to guest rooms).

Auto Attendant configuration procedures
About this task
This task flow shows you the sequence of procedures you perform to create and configure
Auto Attendants.
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Figure 4: Auto Attendant configuration procedures

Auto Attendant configuration navigation:

• Starting Auto Attendant from an HMS 400 server  on page 30
• Mapping a network drive on page 30
• Starting Auto Attendant from a remote server  on page 31
• Configuring language selection (optional) on page 32
• Configuring time of day on page 33
• Configuring layers on page 35
• Configuring holidays on page 37
• Configuring the operator DN on page 38
• Configuring the Transfer to Guests option on page 39
• Configuring announcement layers on page 39
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• Editing an Auto Attendant Flow on page 40
• Deleting an Auto Attendant Flow on page 41

Starting Auto Attendant from an HMS 400 server
About this task
Start Auto Attendant from an HMS 400 server to access the Auto Attendant locally.

Prerequisites:

• Work out each flow in detail paper.
• Write out the script for each prompt.
• Decide on the Calling DN to access each AA flow; for each number, you must configure

a corresponding ACD DN on the switch as well as an Entry Point in the HMS 400 system.
For more information about configuring DNs, see Avaya Hospitality Messaging Server
400 Installation and Commissioning, NN42350-301.

Procedure

1. On the HMS 400 server, on the main screen, click the Auto Attendant icon on the
toolbar.

2. To create a new flow, on the File menu, select New Call Flow.

3. To edit an existing flow, on the File menu, select Open Call Flow.

Mapping a network drive
About this task
Prerequisites:

• Obtain the user ID and password for the server.

Procedure

1. Double-click My Computer.

2. In the My Computer window, click Tools > Map Network Drive.

3. In the Map Network Drive dialog box, if not already selected, from the Drive list,
select an available drive.

4. In the Folder box, type \\<HMS 400 Server IP address>\c$.

5. Click Finish.
A dialog box appears prompting you for a user name and password .
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6. In the dialog box, in the User name box, type the user name for the HMS 400
server.

7. In the Password box, type the password.

8. Click OK.

Starting Auto Attendant from a remote server
About this task
Start Auto Attendant from a remote server to access the Auto Attendant remotely.

Prerequisites:

• Download the AA Setup package from the Web Configuration module (Hotel Operation
> Auto Attendant).

• Connect to the Host (HMS Server).
• Install the AA client module.
• Install MySQL ODBC Connector.
• Configure Windows ODBC to point to the database on the Host (HMS Server).
• Work out each flow in detail on paper.
• Write out the script for each prompt.
• Decide on the Calling DN to access each AA flow; for each number, you must configure

a corresponding ACD DN on the switch and an Entry Point in the HMS 400 system. For
more information about configuring DNs, see Avaya Hospitality Messaging Server 400
Installation and Commissioning, NN42350-301.

Procedure

1. On your desktop, double-click My Computer.

2. Navigate to C:\Program Files|Auto_Attendant.

3. In the Auto_Attendant folder, double-click Auto Attendant.exe.

4. In the Change Path dialog box, type \\ServerIP\C$\HMS400r3\ to point to your
HMS 400 server hidden Administrative Share.

5. Click OK.

6. Enter the administrator user name and password for the HMS server (user name =
administrator; password = hmsabc123).

7. If the Update Successful box appears, click OK.

8. To create a new flow, on the File menu, select New Call Flow.
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9. To edit an existing flow, on the File menu, select Open Call Flow.

Variable Definitions

Variable Value
Server IP IP address of the HMS 400 server. For example, \

\10.8.2.77.

Configuring language selection (optional)
About this task
Configure languages to enable different languages for a flow.

Prerequisites:

• Obtain a list of all the languages used in the site.
• Decide which keys activate each language in Auto Attendant.

Procedure

1. In the Auto Attendant - CallFlow window, in the Language Selection area, click
Enable Language Selection.

2. In the Language Selection dialog box, in the Prompt list, click the recorded prompt
that describes the available languages and the key to press for each language.

 Important:
After you enable Language Selection, your callers hear the available languages
prompt first.

The system also offers the Through-Dial feature when it plays the available
languages prompt. With this feature, callers can skip the language selection and
enter the extension number of the person they want to reach.

3. In the lists next to each telephone keypad key number, select the language to offer
after a user presses the key.

 Important:
The key/language options you select must correspond with the key/language
options you record in the prompt. The system only offers languages that you
installed on your system. You cannot assign the same language to more than one
key.

4. Optionally, to delete a language, in the list next to that key, select the blank
option.
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5. After you finish making your selections, click Save.

 Important:
You must assign at least two different languages before you can save the settings
in this window.

6. Click Exit.

7. To edit the language options, in the Auto Attendant - CallFlow window, in the
Language Selection area, click Edit Language Selection.
OR
Double-click the Language Selection layer.

Configuring time of day
About this task
Configure the Time of Day (TOD) to offer different Auto Attendant options at different times of
day or on holidays.

Prerequisites:

• Obtain a copy of office hours for the seven-day cycle, including lunch breaks.

Procedure

1. In the Auto Attendant window, on the File menu, select New Call Flow.
The system automatically names the first call flow CallFlow001.AA, and the second
as CallFlow002.AA. However, if a user deletes the 001.AA call flow, the system
names the next new call flow CallFlow 001.AA even though the system typically
names a new call flow the next number in the sequence.

2. In the Auto Attendant - CallFlow window, in the Time of Day area, click Enable
Time of Day.

3. To create time periods for each day of the week, in the Time of Day Detail dialog
box, click the button for the day of the week on which to create the time period.

4. In the Period Name list, click a time period name.
OR
Type a name for the time period.
OR
Click Copy to duplicate a specific time period for other days, select another day,
and then click Paste to paste the duplicate time periods.
OR
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Click Copy All to duplicate the entire list of time periods, select another day, and
then click Paste to paste the duplicate time periods.
OR
Click Remove to eliminate a time period for the day.
OR
Click Remove All to eliminate the entire list.

5. In the Start box, type a start time.

6. In the End box, type an end time.

7. Click Add to add the new time period to the table.
You can add several time periods that cover different hour ranges as long as they
total a 24-hour day. If the time periods for a particular day or week contain gaps,
the system creates a Default time period to prevent dropped calls.

8. Repeat step 3 on page 33 to step 7 on page 34 to complete the time periods for
each day of the week.

9. After you add and edit time periods, click Save.
The system represents each time period you create as an individual component
(layer). If you activate the Time of Day (TOD) feature, the system adds a Holiday
layer by default.

10. In the Periods of Day message box, click OK.

Variable definitions

Variable Value
End The time a time period ends. Use the military time format,

which uses 24-hour notation from 00 to 23. For example,
6:00 am is 0600 in military time; 11:00 p.m. is 2300 in military
time. You must enter an end time that is greater than the
start time. The start and end time must not overlap with
another time period.

Period Name Type a new time period name or select an existing one from
the list.

Start The time a time period starts. Use the military time format,
which uses 24-hour notation from 00 to 23. For example,
6:00 am is 0600 in military time; 11:00 p.m. is 2300 in military
time.
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Configuring layers
About this task
Configure layers to define the attributes of TOD time periods and Holiday layers.

If you create TOD time periods and Holidays, you must configure each TOD/Holiday layer.

Prerequisites:

• Gather your predefined call flow, which you use to map out each layer of the Auto
Attendant.

Procedure

1. If your system does not include TOD periods, in the Layers area, click Add Layer
to create the first layer.
OR
If the system does include TOD time periods, click the first layer on the left, which
is named after the first TOD you configured.

2. Double-click Layer 01.
The default name is Layer 01. The system assigns Layer 01 as the Startup Layer
by default. A Startup Layer is the first layer that an Auto Attendant Flow (AAF) uses
for calls. However, if you add more layers, you can reassign the Startup Layer to
other layers if necessary.

3. Optionally, enable different languages for this flow. To enable different languages,
see Configuring language selection (optional) on page 32.

4. If you did not previously name the layer, in the Layer dialog box in the Description
box, type a description for the layer.

5. In the Prompt list, click the prompt to play.

6. In the Timeout (sec) box, type the number of seconds that the system waits for a
user response.

7. In the Allowed Tries box, type the number of times the system lets a user time
out.

8. In the Default Type list, click the action for the system to follow after a user reaches
the maximum number of allowed tries.

9. In the table, highlight a key that you intend callers to use.

10. In the Type list, click a function for the highlighted key.
If the system requires further information, it displays another list below the Type
list.

11. If applicable, click an item in the new list below the Type list.
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12. Optionally, to add a layer that functions only as an announcement, without options
from which the caller can choose, see Configuring announcement layers on
page 39. Then, go to step 14 on page 36.
OR
Optionally, to add a layer that functions only as an announcement through a
standard layer, click Select All.

 Important:
Avaya recommends using the Configuring Announcement Layers procedure.

13. In the Type list, click END CALL.
This prevents the system from accepting a keypress as a valid function, which
occupies the line unnecessarily.

14. Click Save.

15. Repeat this entire procedure for each layer to be added to the Auto Attendant
Flow.

16. After you add all layers, confirm that you configure all Jump to Layer functions in
each layer to point to the correct next layer.

17. On the File menu, select Save Call Flow.

18. On the File menu, select Close Call Flow.

19. Repeat the entire procedure for each Auto Attendant call flow you require.
If you are creating more than one Auto Attendant call flow, then after you save a
subsequent call flow, the system displays the Save Auto Attendant Flow dialog
box.

20. Optionally, in the Save Auto Attendant Flow dialog box, in the Filename box, type
a new name for the file.

21. Click OK.

Variable Definitions

Variable Value
Allowed Tries The number of times the system lets a user timeout

(Maximum is 9).

Default Type Action to follow after Maximum Timeout period/retries.
Available actions are: End Call, Transfer to Day Operator,
or Transfer to Extension.

Description Layer Name. The Description can be changed to something
more meaningful, if desired. (Maximum of 25 characters.)
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Variable Value
Filename For subsequent renaming of an existing Call Flow. Names

must use alphanumeric characters and end with
extension .AA.

Prompt The prompt that the system plays after a user reaches this
layer.

Timeout (sec) User response waiting time (in seconds). Maximum 99
seconds.

Type Use this list to select the appropriate action/function to map
to a keypress. The options are:

• End Call

• Enter Extension – choose this option for the Dial by Name
feature

• Jump to Layer

• Leave voicemail – choose this option to leave a voicemail
message

• Repeat

• Retrieve voicemail

• Transfer to day operator

Remarks Type in notes/information/remarks related to the Auto
Attendant layer.

Configuring holidays
About this task
Configure particular days of the year as holidays.

Prerequisites:

• Obtain a list of all nonworking holidays for the site.

Procedure

1. In the Auto Attendant - Call flow window, on the File menu, select Holiday
Maintenance.

2. In the Holiday Maintenance dialog box, on the calendar, use the forward and back
arrows to locate the intended month of the holiday.

 Important:
You cannot navigate to past months.

3. On the calendar, click the day of the month to configure as a holiday.

Auto Attendant configuration procedures

Avaya Hospitality Messaging Server 400 Administration March 2012     37



4. In the box below the calendar, type a description for the holiday.

5. If the holiday recurs each year, select the Recurring check box.

6. Click Add.

7. Repeat step 2 on page 37 to step 6 on page 38 for each holiday to add.

8. Optionally, in the left pane, click Year View to see all scheduled holidays for the
remaining months of the year.
OR
Click Month View to see scheduled holidays for the selected month on the
calendar.

9. To edit a holiday entry, locate the entry, and then select it. Make the desired changes,
and then click Update.

10. To delete a holiday entry, select it and click Remove. In the Holiday message box,
click Yes.
OR
To delete all holiday entries, click Remove All. In the Holiday message box, click
Yes.

11. After you enter holidays, click Exit.

Configuring the operator DN
About this task
Configure the operator Dialed Number (DN) to allow the Auto Attendant to transfer calls to an
operator.

Prerequisites:

• Obtain DNs for the main operator, message desk, and night operator. For larger sites with
multiple operators, obtain the main number for the Automatic Call Distributor (ACD) group.

Procedure

1. In the Auto Attendant - CallFlow window, in the Others area, click Configure
Operator.

2. Optionally, to configure a night operator, in the Operators dialog box, in the Night
Operator box, type the DN for the night operator.

3. To configure a day operator, in the Day Operator box, type the DN for the day
operator.
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 Important:
Confirm that you enter valid DNs, as the system does not perform validation. If
the hotel does not use separate extensions for a day and a night operator, enter
the same DN in both the Night Operator and Day Operator boxes.

4. Click Save.

5. In the Operator message box, click OK.

6. Click Exit.

Configuring the Transfer to Guests option
About this task
Configure the Transfer to Guests option to support transfers to guest extensions.

Procedure

In the Auto Attendant - CallFlow window, in the Transfer to Guests area, click
Allowed.

Configuring announcement layers
About this task
Configure announcement layers to create a layer that functions only as an announcement
without options from which a caller can choose.

Prerequisites:

• Write down which prompt ID belongs to which announcement.

Procedure

1. In the Auto Attendant - CallFlow window, in the Layers area, click Add
Announcement.

2. Double-click the Announcement 01 Layer.

3. In the Announcement 01 dialog box, in the Prompt list, click the prompt to play.

4. In the Default Type list, click an option.

5. Click Save.

Auto Attendant configuration procedures

Avaya Hospitality Messaging Server 400 Administration March 2012     39



Variable Definitions

Variable Value
Default Type Action to perform after the announcement ends: End Call,

Transfer to Day Operator, or Transfer to Extension.

Prompt The prompt that the system plays after a user reaches this
layer.

Editing an Auto Attendant Flow
About this task
Edit an Auto Attendant Flow (AAF) to change the voice menus and options.

Prerequisites:

• Create an AAF.
• Map the new call flow before you change the Auto Attendant to detect potential conflicting

options or layers. See Defining an Auto Attendant Flow on page 23.

Procedure

1. In the Auto Attendant window, on the File menu, select Open Call Flow.

2. In the Open Auto Attendant Flow dialog box, click the file name of the flow to
edit.

3. Click OK.

4. In the Auto Attendant - Call Flow window, double-click the desired layer and make
the required changes.

5. Optionally, to delete a layer, click the layer and select Remove in the Layers area.
Then, click Yes in the Auto Attendant dialog box.

 Important:
After you delete a layer, you must reset other layers in the Auto Attendant Call
Flow that contain Jump to Layer options pointing to this layer.

You cannot delete a layer if the entire flow contains only one layer.

You cannot delete layers if you activate the Time of Day (TOD) feature.
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Deleting an Auto Attendant Flow
About this task
Delete an Auto Attendant Flow (AAF) to remove it from your Hospitality Messaging Server
(HMS) if you no longer require the AAF.

Prerequisites:

• Create an AAF.
• Remove all entry points associated with the Auto Attendant before you delete it.

Procedure

1. In the Auto Attendant window, on the File menu, select Open Call Flow.

2. In the Open Auto Attendant Flow dialog box, on the File menu, select Delete Call
Flow.

3. In the Auto Attendant dialog box, click Yes.

4. Click OK.

5. If necessary, edit internal call-direction resources (entry point) and external
publications of Direct Inward Dial to Auto Attendants to remove or change
references to the deleted Auto Attendant Flow. An example is if you no longer offer
this service or if you change the Auto Attendant slot to serve another purpose.

Auto Attendant configuration procedures

Avaya Hospitality Messaging Server 400 Administration March 2012     41



Auto Attendant administration

42     Avaya Hospitality Messaging Server 400 Administration March 2012
Comments? infodev@avaya.com

mailto:infodev@avaya.com?subject=Avaya Hospitality Messaging Server 400 Administration


Chapter 4: Staff voice mail system
administration

About this task
This chapter describes how to maintain Admin extensions and mailboxes for hotel staff.

Hotel staff mailboxes typically do not need constant administration as compared with guest mailboxes
because they do not change as much.

The following are the staff voice mail-related functions available through the Web user interface (UI).
Through the Web UI, you can:

• Configure admin users—extension/mailbox/disabled.
• Check the number of new and old messages in a mailbox as well as Mailbox number of a particular

extension.
• Reset Password and Personal Greeting prompt.
• Restore deleted voice messages.

Aside from configuring admin users, mailbox owners can administer their own mailboxes through a
dedicated HMS window. Because mailbox owners can serve themselves, the System Administrator (SA)
can focus more time on other tasks.

Prerequisites:

• Provide staff with a link to the Web UI and logon instructions.
Navigation:

• Viewing Admin information on page 44
• Editing Admin information on page 45
• Setting up an introductory message on page 46
• Restoring staff voice mail messages on page 46
• Resetting a staff voice mail PIN on page 48
• Removing staff voicemail greetings on page 49
• Configuring Admin Classes of Service on page 51
• Configuring Guest Classes of Service on page 51
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Viewing Admin information
About this task
View Admin information to access the following Admin user details: extension number, mailbox
ID, name, extension type, language, number of new and old messages, Class of Service
(COS), and phone numbers.

Prerequisites:

• You have a valid mailbox.
• You have access to the HMS Web UI.
• You have a valid password for the mailbox.

Procedure

1. Open the Web UI.

2. Select Administration.

3. In the navigation pane, select Admin Related Information > View/Edit Admin
Information.

4. Optionally, if the information does not fit onto one page, click a page number to
navigate to the corresponding page.

5. Optionally, to search by extension number, in the Extn No box, type an extension
number, and then click Display.

6. Optionally, to search by name, in the Name box, type the full or partial name, and
then click Display.

Variable Definitions

Variable Value
Extn No Enter the extension number you wish to look up; maximum

10 digits.

Name Enter the name of the mailbox owner you wish to look up;
maximum 30 alphanumeric characters.

Staff voice mail system administration
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Editing Admin information
About this task
Edit Admin information to change the Admin user's properties.

Prerequisites

• You have a valid mailbox.

Procedure

1. Open the Web UI.

2. Select Administration.

3. In the navigation pane, select Admin Related Information > View/Edit Admin
Information.

4. On the View/Edit Admin Information window, in the table, click the Change link
next to the Admin information to be edited.

5. Make the required changes to the following fields: Name, Extn Type, Language,
COS.
You can pass control of mailbox parameters to the mailbox owner, except for
Extension Type and COS. Only the System Administrator (SA) can change the
Extension Type and COS parameters.

 Important:
If the SA changes the type from a Mailbox to an Extension, the system retains all
the messages in the mailbox but resets the PIN to the original. The system sends
a command to turn off the Message Waiting Light (MWL). The mailbox owner
must delete all messages before changing from a Mailbox to an Extension.
Otherwise, the SA must reconfigure the extension back to a Mailbox type, and
then manually delete all previous messages by clicking the Delete All option from
the TUI. For more information about the Delete All option in the TUI, see
Hospitality Messaging Server 400 Front Desk Staff User Guide, NN42350-100.

6. Click Update.

Variable Definitions

Variable Value
COS Mailbox Class Of Service; maximum 2 digits.

Editing Admin information
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Variable Value
EXTN A phone with no voice mailbox, which you use primarily for

validating call transfers.

Extn Type The three types of Admin Users are EXTN, MAILBOX, and
PHANTOM. The SA can also click the Disable option to
disable the extension if required (for example, if a staff
member resigns). This option deletes all messages from
that mailbox. Therefore, the mailbox owner must retrieve all
messages before the SA disables the extension.

Language Allows the selection of the user’s preferred mailbox
language; the system only displays languages that are
installed.

MAILBOX A regular voice mailbox with an associated phone and
Message Waiting Light (MWL).

Name Use to configure mailbox owner’s name or leave it as default
(extension number); maximum 30 characters
(alphanumeric).

PHANTOM A fully functional voice mailbox without an associated phone
and therefore no MWL controls.

Setting up an introductory message
About this task
Configure an introductory message to define the message that is played every time a guest
accesses their mailbox.

If the source is an external number, or a number that is not found in the database, a system
default 'sender prompt' is played. ("This message was recorded from an unknown number".)

For information about configuring an introductory message, see Avaya Hospitality Messaging
Server 400 Installation and Commissioning, NN42350-301.

Restoring staff voice mail messages
About this task
Restore staff voice mail messages to reconstruct lost messages.

You can restore voice messages after a user or the system deletes them, provided that the
system did not permanently delete them.

Staff voice mail system administration
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Prerequisites:

• The deleted message must not be permanently deleted. You can only restore a deleted staff
voice mail message within a predefined time, which is set by the system administrator.

Procedure

1. Open the Web UI.

2. Select Administration.

3. In the navigation pane, select Mailbox Maintenance > Restore Message.

4. In the Restore Message window, in the Type area, click the Admin option.

5. Click the ellipsis (…) button next to the Extn box.
OR
In the Extn box, enter an extension number. Go to step 12 on page 47.

6. If a warning dialog box appears indicating that pop-ups are blocked, click the bar
and select Always allow pop-ups from this site and then click Yes, when
prompted, to allow pop-ups for this site.

7. In the ExtenList window, click the extension for which you want to restore a
message.

8. Click Select.

9. Click Show Message.
The system displays any deleted messages in the Deleted Message(s) pane.

10. In the Deleted Message(s) pane, click the message to restore.

 Important:
Use the Message IDs to help determine which message to restore. For example,
an ID of 1 means it is the first message in that mailbox. The date and time are
also useful.

11. Click the right arrow button (>) to move the selected message to the Selected
Message(s) pane.
OR
Click the double arrow button (>>|) to move all the messages in the Deleted
Message(s) pane to the Selected Message(s) pane.

12. Click Restore.
The system displays the following message after restoration:
Message(s) restored successfully.

Restoring staff voice mail messages
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Variable Definitions

Variable Value
Extn Enter the user’s extension number to look up (maximum 10

digits), or click the ellipsis to select from a listing.

Resetting a staff voice mail PIN
About this task
You can reset a staff voice mail PIN to allow staff access to their personal mailboxes again if
they forget their PIN, or if a user's PIN expires and the system locks them out of their personal
mailbox.

You must assign a PIN to each mailbox as a safety measure. For security purposes, users
should regularly change their PIN. By default, the system sets the user PIN to the extension
number.

The system administrator (SA) must also perform a reset if a user’s PIN expires and the system
locks the user out of his/her personal mailbox/Web page. Users can check their PIN expiration
by accessing their voice mail box through the Web UI. The HMS 400 system updates the user's
expiry date every day to remind the user to change it before it expires. The color of the Expiry
Date changes from black to orange if the PIN expires in 7 to 4 days. The color changes from
orange to red if the PIN expire in 3 or less days. However, if the user misses these warnings,
the administrator must reset the PIN. After the administer resets the PIN, the user must log on
to his/her mailbox/Web page within 2 hours to change the PIN. After 2 hours, the system does
not accept the user’s PIN.

If the user accesses his/her mailbox before his/her PIN expires, the system plays a reminder
prompt stating the number of days left before his/her PIN expires.

Prerequisites:

• You must be a system administrator with a valid user ID and password to administer HMS
400.

Procedure

1. Open the Web UI.

2. Select Administration.

3. In the navigation pane, select Mailbox Maintenance > Reset PIN/Remove
Greeting.

4. In the Reset PIN/Remove Greeting window, in the Type area, click the Admin
option.
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5. Click the ellipsis (…) button next to the Extn box.
OR
In the Extn box, enter an extension number. Go to step 9 on page 49.

6. If a warning dialog box appears indicating that pop-ups are blocked, click the bar
and select Always allow pop-ups from this site and then click Yes when prompted
to allow pop-ups for this site.

7. In the ExtenList window, click the extension for which you want to reset the PIN.

8. Click Select.

9. Select the Reset PIN check box.

10. Click Reset.
The system displays the following message after resetting the PIN:
Updated successfully.

Variable Definitions

Variable Value
Extn Enter the user’s extension number to look up; maximum 10

digits or click the ellipsis to select from a listing.

Removing staff voicemail greetings
About this task
You can delete a staff voicemail greeting from the their mailbox if the staff member no longer
requires the greeting.

An Admin mailbox supports up to three types of Personal Greeting Message: internal, external,
and temporary. There is also a system default message if the staff member does not record
personal greetings.

If the staff members records a temporary greeting, the system plays it for all cases as long as
it is still valid (not expired). If the staff member does not record a temporary greeting, the system
plays the Internal Greeting only if the caller is identified as a valid extension in the database.
If the staff member does not record an Internal Greeting or if the system cannot identify the
caller as a valid extension in the database, the system plays the External greeting. If the staff
member does not record an External Greeting, the system reverts to the system default
greeting.

Removing staff voicemail greetings
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 Important:
After you perform this procedure, the system permanently deletes the greeting.

Prerequisites:

• You must be a System Administrator with a valid user ID and password to remove a staff
voicemail greeting.

• Find out which greeting the user no longer needs.

Procedure

1. Open the Web UI.

2. Select Administration.

3. In the navigation pane, select Mailbox Maintenance > Reset PIN/Remove
Greeting.

4. On the Reset PIN/Remove Greeting window, in the Type area, click the Admin
option.

5. Click the ellipsis (…) button next to the Extn box.
OR
In the Extn box, enter an extension number. Go to step 8 on page 50.

6. In the ExtenList window, click the extension for which you want to delete a
greeting.

7. Click Select.

8. In the Remove Greeting area, select the check box next to the type of greeting to
delete: Internal Personal Greeting, External Personal Greeting, Temporary
Greeting.

9. Click Remove.
The system displays the following message after removing the greeting:
Removed successfully.

Variable Definitions

Variable Value
Extn Enter the user’s extension number to look up (maximum 10

digits), or click the ellipsis to select from a listing.
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Configuring Admin Classes of Service
About this task
Configure Admin Classes of Service (COS) to set the characteristics and behavior of the admin
mailbox.

For information about configuring Admin Classes of Service, see Avaya Hospitality Messaging
Server 400 Installation and Commissioning, NN42350-301.

Configuring Guest Classes of Service
About this task
Configure Guest Classes of Service (COS) to set the type of features and functions available
to guest.

For information about configuring Guest Classes of Service, see Avaya Hospitality Messaging
Server 400 Installation and Commissioning, NN42350-301.

Configuring Admin Classes of Service
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Chapter 5: Hotel administration

About this task
This chapter describes other administrative tasks handled by either the System Administrator or a
designated staff member with the correct permissions.

Prerequisites:

• Install and commission the Avaya Hospitality Messaging Server 400 system. For information about
installation and commissioning, see Avaya Hospitality Messaging Server 400 Installation and
Commissioning, NN42350-301.

Navigation:

• Creating employee IDs on page 53
• Viewing users on page 54
• Editing users on page 55
• Deleting users on page 56
• Creating system general distribution lists on page 57
• Editing system general distribution lists on page 59
• Deleting system general distribution lists on page 60
• Viewing Group Code Distribution Lists on page 61

Creating employee IDs
About this task
Create employee IDs to allow hotel employees to access the hotel services such as Minibar,
Room Status, Supervisor, and the Telephone User Interface (TUI).

Prerequisites:

• Find out from the relevant hotel departments the number of users who must use the
system.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select Hotel Services > Hotel Employees > User ID.
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4. In the User ID dialog box, in the User ID box, type a user ID.

5. In the User Name box, type a user name.

6. In the Password box, type a password.

7. In the Confirm Password box, retype the password.

8. In the Type Description list, click the type of user.

9. In the Language list, click the user's preferred language.
The system displays only installed languages.

10. Click Add.

Variable Definitions

Variable Value
Confirm Password Retype the password

Language Determines the language of the prompts played

Minibar For minibar posting only

Minibar/Room Status For both minibar and room status posting

Password Numbers only; minimum of 1 digit and maximum 8

Room Status For room status posting only

Supervisor For recording minibar items only

TUI For accessing Telephone User Interface (TUI) only

Type Description The type of user for which you create the ID. Types include
Minibar, Room Status, Minibar/Room Status, Supervisor,
and TUI.

User ID Numbers only; minimum of 1 digit and maximum 10

User Name Maximum of 20 characters

Viewing users
About this task
View users to see information for existing users such as user ID, user name, and user type.

Hotel administration
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Prerequisites:

• Create at least one user. See Creating employee IDs on page 53.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select Hotel Services > Hotel Employees > View/Edit/
Delete User.

4. On the View/Edit/Delete User window, in the User ID box, type a user ID, and then
click Search.
OR
In the table, click the Select link next to the desired User ID.

Variable Definitions

Variable Value
User ID Numbers only; minimum of 1 digit and maximum 10

Editing users
About this task
You can edit users to change the user's properties.

Prerequisites:

• A user must have been created. See Creating employee IDs on page 53.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select Hotel Services > Hotel Employees > View/Edit/
Delete User.

4. To locate the user to edit, in the User ID box, type a User ID, and then click
Search.
OR

Editing users
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In the table, click the Select link next to the desired User ID.

Variable Definitions

Variable Value
Confirm Password Retype the password

Language Determines the language of the prompts played

Minibar For minibar posting only

Minibar/Room Status For both minibar and room status posting

Password Numbers only; minimum of 1 digit and maximum 8

Room Status For room status posting only

Supervisor For recording minibar items only

TUI For accessing Telephone User Interface (TUI) only

Type Description The type of user for which you create the ID. Types include
Minibar, Room Status, Minibar/Room Status, Supervisor,
and TUI.

User ID Numbers only; minimum of 1 digit and maximum 10

User Name Maximum of 20 characters

Deleting users
About this task
Delete users to remove them from Hospitality Messaging Server (HMS).

Prerequisites:

• You must create a user. See Creating employee IDs on page 53.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select Hotel Services > Hotel Employees > View/Edit/
Delete User.

Hotel administration
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4. On the View/Edit/Delete User window in the User ID box, type a user ID, and then
click Search.
OR
In the table, click the Select link next to the desired User ID.

5. Click Delete to remove the ID from the list.

Variable Definitions

Variable Value
User ID Numbers only; minimum of 1 digit and maximum 10

Creating system general distribution lists
About this task
Create system general distribution lists to define lists made up of admin extensions only, guest
rooms only, or a mixture of both.

 Important:
HMS 400 Release 3.0 does not support nested distribution lists (distribution lists within
distribution lists).

Prerequisites:

 Important:
To return to a previous page while creating a new distribution List, click the Back button at
the end of the page. If you click the back icon in Internet Explorer, a "Webpage has Expired"
page appears.

• To enter a Voice Profile for Internet Mail (VPIM) address as a distribution list member, the
System Administrator (SA) must preconfigure the VPIM. For information about configuring
the VPIM, see Avaya Hospitality Messaging Server 400 Installation and Commissioning,
NN42350-301.

• Create admin extensions.
• Create guest extensions.
• You must create and save all hotel Admin extensions and Guest rooms in the

database.

Creating system general distribution lists

Avaya Hospitality Messaging Server 400 Administration March 2012     57



Procedure

1. Open the Web UI.

2. Select Administration.

3. In the navigation pane, select General Distribution List > System Distribution
List.

4. On the System Distribution List window, click New List.

5. In the List No box, type a new list number.

6. In the Description box, type a description for the new list.

7. Optionally, select the Select All Rooms check box to display both occupied and
vacant rooms in the Guest Rooms list. By default, the system displays only
occupied rooms.

8. To select a range of rooms, in the Room From box, type the first room number of
the range you want to select.
OR
To select individual guest room extensions, in the Guest Rooms/Extensions box,
click a room, and then click Select. Go to step 14 on page 58.
OR
To select individual admin extensions, in the Admin Extensions box, click an
extension, and then click Select. Go to step 14 on page 58.
OR
To add a Voice Profile for Internet Mail (VPIM) address as a member, in the VPIM
Addresses area, in the PSTN list, click the desired PSTN.
The system changes the Domain name according to the selected PSTN and vice
versa. Go to step 12 on page 58.

9. In the Room To box, type the last room of the range you want to select.

10. Click Select Range.

11. Click Select All. Go to step 14 on page 58.

12. In the Extn box, type a valid extension of the person that belongs to the other
system.

 Important:
HMS 400 cannot verify the validity of this extension.

13. Click Add to List.

14. Click Save List.

Hotel administration
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Variable Definitions

Variable Value
Description Type a short, meaningful name for the list being created.

Maximum 30 alphanumeric characters.

Extn Type the extension number of the recipient belonging to the
other system

List No Type a number from 10 to 9999 to identify the list

Room From Type the starting room number of the room range to be
included in the list

Room To Type the last room number of the room range to be included
in the list

Editing system general distribution lists
About this task
Edit a system general distribution list to change its properties. Properties that you can edit
include list description, selected extensions, and VPIM addresses.

Prerequisites:

• Create a system distribution list.
• To enter a Voice Profile for Internet Mail (VPIM) address as a distribution list member, the

System Administrator (SA) must preconfigure the VPIM. For information about configuring
the VPIM, see Avaya Hospitality Messaging Server 400 Installation and Commissioning,
NN42350-301.

Procedure

1. Open the Web UI.

2. Select Administration.

3. In the navigation pane, select General Distribution List > System Distribution
List.

4. Optionally, to search for a particular list, on the System Distribution List window
in the List No box, type the first digit of the list or the full list number.

5. Optionally, to determine the lists to which an extension belongs, type the extension
number in the Extension No box.

Editing system general distribution lists
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6. On the System Distribution List window, in the table, click the Details link next to
the desired list.

7. Make the required changes.

8. Click Save List.

Variable Definitions

Variable Value
Extension No Type a list member's extension to begin the search

List No Type a number from 10 to 9999 to begin the search

Deleting system general distribution lists
About this task
Delete a system general distribution list (DL) to remove it from the HMS 400 if you no longer
require the system DL.

Prerequisites:

• Create a system distribution list. See Creating system general distribution lists on
page 57.

Procedure

1. Open the Web UI.

2. Select Administration.

3. In the navigation pane, select General Distribution List > System Distribution
List.

4. Optionally, to search for a particular list, in the System Distribution List window,
in the List No box, type the first digit of the list or the full list number.

5. Optionally, to find out the lists to which an extension belongs, type the extension
number in the Extension No box.

6. In the System Distribution List window, in the table, click the Details link next to
the desired list.

7. Click Delete List.
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Variable Definitions

Variable Value
Extension No Type a list member's extension to begin the search

List No Type a number from 10 to 9999 to begin the search

Viewing Group Code Distribution Lists
About this task
View a Group Code Distribution List (DL) to access the following Group Code DL details: list
number and list description. You can use this function to locate a particular Group Code DL,
or to locate the Group Code DL for a particular guest extension.

The system automatically creates group lists whenever a user checks in a group of rooms with
a corresponding group code. The system creates a list based on the group code and adds to
that list a member for each subsequent check-in record (belonging to the same group)
received.

Keycodes control this feature. You must activate this feature and all group-code related
parameters in other windows with the keycode.

Prerequisites:

• Create a Group Code Distribution List.

Procedure

1. Open the Web UI.

2. Select Administration.

3. In the navigation pane, select General Distribution List > Group Code
Distribution List.

4. To view all current Group Code Distribution Lists, in the Group Code Distribution
List window, click Show All.
The system displays the lists in a table.
OR
To search for a particular list, in the Group Code/List No box, type the group
code.
OR

Viewing Group Code Distribution Lists
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To search for the group code for a particular extension, in the Guest Extension No
box, type the guest extension.

5. After you locate the list, click Details to see the members of the group.
Optionally, click Back to return to the Group Code Distribution List window to start
another search.

Variable Definitions

Variable Value
Group Code/List No Type a 5-digit number from 10000 to 99999 to begin the

search

Guest Extension No Type a list member's extension number to begin the search
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Chapter 6: Room status administration

This chapter describes how to create Maid IDs and Room Status codes. Maid supervisors or staff can
also post room status manually if they cannot access telephones at specific areas.

In the Room Status section, the person in charge can create and maintain all maid user profiles, create
room status codes and their corresponding Property Management System (PMS) codes, as well as
perform room status updates manually. Typically, staff perform room status posting over a telephone. Use
this feature to update the PMS system so that staff know which rooms are available for guests to check
in as well as to inform the housekeepers which rooms to clean or inspect.

Room Status functions include:

• Creating and maintaining Room Status users. See Creating employee IDs on page 53.

• Creating Room Status codes and mapping them with PMS codes. Codes are not fixed, so you must
correctly map them.

• Posting Room Status through the Web.

Prerequisites to room status administration:

• Install and commission the Hospitality Messaging Server 400 (HMS 400) system. For information
about installation and commissioning, see Avaya Hospitality Messaging Server 400 Installation and
Commissioning, NN42350-301.

• Obtain the Room Status codes from the Hotel PMS vendor.

Room status administration procedures
About this task
This task flow shows you the sequence of procedures you perform to administer room
status.
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Figure 5: Room status administration

Room status administration navigation:

• Configuring room status code mapping on page 64
• Editing room status code mapping on page 65
• Deleting room status code mapping on page 66
• Manually posting room status on page 67

Configuring room status code mapping
About this task
Configure room status code mapping to allow the HMS 400 system to properly communicate
room status codes to the Property Management System (PMS) interface.

To prevent miscommunication, hotel staff must post codes that correspond to the codes
understood by the PMS interface.

Room status administration
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Prerequisites:

• Obtain the room status codes from the Hotel PMS vendor.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select Room Status > Room Status Code Mapping.

4. In the Room Status Code Mapping window, in the Room Status Code box, type
the preferred room status code.

5. In the PMS Code box, type the corresponding PMS code as defined in the Hotel
PMS.

6. In the Description list, click a room status.

7. Click Add.

Variable Definitions

Variable Value
Description A list of the 21 available Room Statuses.

PMS Code The code in the Hotel PMS interface that corresponds to the
room status code. The system translates room status code
to a PMS code before posting to the Hotel PMS. The system
supports 2-byte alphanumeric characters.

Room Status Code The digits that staff input on a telephone for each room
status. The system supports a one- or two-digit code.

Editing room status code mapping
About this task
Edit room status code mapping to change a room's status.

The HMS 400 system includes 20 room status options. For more information about room status
options, see Avaya Hospitality Messaging Server 400 Fundamentals, NN42350-104.

Editing room status code mapping
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Prerequisites:

• Perform initial mapping of room status codes.
• Obtain the room status codes from the Hotel PMS vendor.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select Room Status > Room Status Code Mapping.

4. In the Room Status Code Mapping window, in the table, click the Edit link next to
the room status code to edit.

5. Apply the required changes. You can only apply changes in the PMS Code box and
the Description list.

6. After you finish making changes, click the Update link.

Variable Definitions

Variable Value
Description A list of the 20 available Room Statuses.

PMS Code The code in the Hotel PMS interface that corresponds to the
room status code. The system translates room status code
to a PMS code before posting to the Hotel PMS. The system
supports 2-byte alphanumeric characters.

Deleting room status code mapping
About this task
Delete room status code mapping to remove it from HMS 400 if you no longer require the
system to map that room status code, or if the room status code mapping is incorrect.

Prerequisites:

• Create a room status code.

Procedure

1. Open the Web UI.
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2. Select Hotel Operation.

3. In the navigation pane, select Room Status > Room Status Code Mapping.

4. On the Room Status Code Mapping window, in the table, click the Delete link next
to the room status code to delete.

Manually posting room status
About this task
Manually post room status to update room status to the PMS system if you cannot post over
a telephone.

Prerequisites:

• Create User ID with Room Status permissions.
• Create Room Status Code mapping.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select Room Status > Room Status Manual Posting.

4. In the Room Status Manual Posting window, select the check box next to the
desired room number.
You can select more than one check box at a time if the associated rooms have the
same status.

5. Click Room Status Posting.

6. In the Room Status Posting window, in the Maid ID box, type a maid ID.

 Important:
The Maid ID must have Room Status access permission.

7. In the Status Code list, click a status code.

8. Click Post.

Manually posting room status
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Variable Definitions

Variable Value
Maid ID Type a valid ID with Room Status permissions.

Room status administration
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Chapter 7: Minibar administration

This chapter describes how to create Minibar items and prices. Authorized staff can also manually post
Minibar items using this feature.

Minibar functions include:

• Configuring Minibar items, including codes, description, price (buying and selling), stock level,
surcharge and tax, and rounding of total charge.

• Manually posting to PMS.

Prerequisites to minibar administration:

• Install and commission the Avaya Hospitality Messaging Server 400 system. For information about
installation and commissioning, see Avaya Hospitality Messaging Server 400 Installation and
Commissioning, NN42350-301.

• Have the minibar items list and price list in hand.

• Create one Supervisor ID for prompt recording.

• Find someone suitable to record prompts for each minibar item.

Minibar administration procedures
About this task
This task flow shows you the sequence of procedures you perform to administer minibars.
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Figure 6: Minibar administration

Minibar administration navigation:

• Configuring minibar inventory on page 70
• Editing an item in the Minibar inventory on page 72
• Deleting an item from the minibar inventory on page 72
• Manually posting minibar items on page 73

Configuring minibar inventory
About this task
Configure minibar inventory to enable staff to post Minibar items.

You must create all Minibar items and record prompts for each item before you can post Minibar
items. The system supports up to 99 items. For information about recording minibar prompts,
see Avaya Hospitality Messaging Server 400 Staff Quick Reference Guide, NN42350-102.

Minibar administration
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Prerequisites:

• Have the minibar items list and price list in hand.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select Minibar > Item Configuration.

4. In the Item Configuration window, in the Item Code box, type an item code.

5. In the Item Description box, type a description of the item.

6. In the Category list, click a category.

7. Optionally, in the Buying Price box, enter the buying price.

8. In the Selling Price box, enter the selling price.

9. In the Quantity box, enter the number of items that staff can post.

10. Click Add.

Variable Definitions

Variable Value
Buying Price The cost of an item (optional box)

Category Assign each item to a specific category: Food/Beverage/
Others. You can use categories to apply different tax values
to different types of items.

Item Code Give each item a two-digit identifier code

Item Description The item name (maximum of 30 characters)

Selling Price The price for which you sell an item

Quantity This determines the number of items Minibar staff can post
at one time over a telephone. (maximum of 99)

Configuring minibar inventory
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Editing an item in the Minibar inventory
About this task
Edit an item in the Minibar inventory to change the properties. You can edit the following
properties: description, category, buying price, selling price, and quantity.

Prerequisites:

• You must create at least one Minibar inventory item.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select Minibar > Item Configuration.

4. In the Item Configuration window, in the table, click the Edit link next to the Minibar
item to edit.

5. Make the required changes.

6. Click Update to save the changes.

Deleting an item from the minibar inventory
About this task
Delete an item from the minibar inventory to remove it from HMS 400 if you no longer include
the minibar item in your inventory.

Prerequisites:

• You must create at least one minibar inventory item.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select Minibar > Item Configuration.

4. In the Item Configuration window, in the table, click the Edit link next to the minibar
item to delete.

5. Click Delete.

Minibar administration
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6. In the message box, click OK.

Manually posting minibar items
About this task
Manually post minibar items to update minibar items to the PMS system if you cannot post
over a telephone.

Prerequisites:

• Obtain a valid User ID with Minibar permissions.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select Minibar > Minibar Manual Posting.

4. In the Minibar Manual Posting window, select the check box next to the room for
which you want to post minibar items.

 Important:
You can select check boxes for more than one room at a time. However, do this
only if the rooms consumed the same items.

5. Click Minibar Posting.

6. In the Minibar Posting dialog box, in the Maid ID box, type a valid maid ID.

7. In the Item Code list, click an item code.

8. In the Quantity box, type the number of items consumed.

9. Click Add.

10. To enter more consumed items, repeat step 7 on page 73 to step 9 on page 73.

11. After you finish entering minibar items, click Post.

Variable Definitions

Variable Value
Item Code Use this list to select the item to be posted.

Manually posting minibar items
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Variable Value
Maid ID Type a valid ID with Room Status permissions.

Quantity Type the quantity of the item to be posted. Maximum of 2
digits.

Minibar administration
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Chapter 8: Auto Wake-Up administration

About this task
This chapter describes how to set up or cancel single or multiple wake-up calls for an individual room as
well as a range of rooms.

Auto Wake-Up (AWU) functions include:

• Setting or canceling a Wake-up job (able to set multiple Wake-up times for each room)
• Setting or canceling Group Wake-up jobs
• Viewing all AWU jobs set for that day (by guests and manually)

 Important:
If using Communication Manager with the Intuity Lodging interface, do not use the HMS 400 Web UI
to configure guest AWU requests.

Prerequisites:

• Install and commission the HMS 400 system. For information about installation and commissioning,
see Avaya Hospitality Messaging Server 400 Installation and Commissioning, NN42350-301.

• Record AWU prompts. For information about recording AWU prompts using the Telephone User
Interface (TUI), see Avaya Hospitality Messaging Server 400 Front Desk Staff User Guide,
NN42350-100.

Navigation:

• AWU and Do Not Disturb on page 83
• Setting a single AWU time on page 75
• Setting multiple AWU times using a room range on page 77
• Setting multiple AWU times using a distribution list on page 79
• Viewing AWU time on page 80
• Editing AWU time on page 82
• Canceling AWU time on page 83

Setting a single AWU time
About this task
Set a single Auto Wake-Up (AWU) time to specify one particular time for the HMS 400 system
to call a room extension to wake up the occupant.
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Operators can also set AWU calls from the front desk. This is accomplished by dialing a service
DN defined in the entry points as SETAWU. For information about defining entry points, see
Avaya Hospitality Messaging Server 400 Installation and Commissioning, NN42350-301.

In addition, you can record a custom AWU prompt. For information about recording custom
AWU prompts, see Avaya Hospitality Messaging Server 400 Front Desk Staff User Guide,
NN42350-100.

Prerequisites:

• The room is checked in.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select AWU > Set Single AWU Time.

4. In the Set Single AWU Time window, click the ellipsis (…) button next to the Room
No box.

5. In the Room No List dialog box, click the room number for which you want to set
a single AWU time.

6. Click Select.

7. Click the calendar icon next to the Date box. To identify the calendar icon, see Figure
7: Calendar icon on page 77.

8. Using the arrow buttons, navigate to the correct month on the calendar.

9. Click the date on which to configure a single AWU time.

 Important:
With the calendar icon, you can configure a wake-up call for any day from the
current day to a future date.

10. In the AWU Time lists, click the list items that represent the correct wake-up call
time.

11. Click Submit.

Job aid
Use the calendar icon to select a date.

Auto Wake-Up administration
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Figure 7: Calendar icon

Setting multiple AWU times using a room range
About this task
Set multiple AWU times to allow staff hotel to specify a recurring time for the HMS 400 system
to call a range of rooms to wake up the occupants.

Prerequisites:

• The rooms are checked in.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select AWU > Set Multiple AWU Time.

4. In the Set Multiple AWU Time window, click the room range option.

5. Click the ellipsis (…) button next to the Room No. To box.

6. In the Room No List dialog box, click the desired room number.

7. Click Select.

8. Click the ellipsis (…) button next to the Room No. From box.

9. In the Room No List dialog box, click the desired room number.
To configure multiple AWU times for only one room, enter the same number in both
the Room No. To and Room No. From boxes.

10. Click Select.

11. Click the desired distribution list number.

12. Click Select.

13. Click the calendar icon next to the Date From box. To identify the calendar icon,
see Figure 7: Calendar icon on page 77.

14. Using the arrow buttons, navigate to the correct month on the calendar.

15. Click the date for the first AWU time.

Setting multiple AWU times using a room range
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 Important:
With the calendar icon, you can configure a wake-up call for any day from the
current day to a future date.

16. Click the calendar icon next to the Date To box.

17. Using the arrow buttons, navigate to the correct month on the calendar.

18. Click the date for the last AWU time.

 Important:
You cannot configure the Date From value to a date in the past. You must
configure the value of the Date To box to either the same day or a future date.

19. In the AWU Time lists, click the list items that represent the correct wake-up call
time.

20. Click Select to list the array of rooms with the date and time for each call.

21. Click All->> to commit to the whole array of rooms.
OR
Click individual items in the left pane, and then click ->> to move them to the right
pane.

22. After you finish selecting rooms, click Submit.

Variable Definitions

Variable Value
Distribution List option Click this button to begin distribution list selection.

Distribution List box Type a valid list number from 10 to 9999 or a group code
number from 10000 to 99999. Optionally, press the button
next to the Distribution List box to select from the listing.

Room No. From box Type the starting room number of the room range to be
selected, or click the button next the Room No. From box
to select from the listing.

 Important:
To select only one room, type the same number in both
the Room No. From and Room No. To boxes.

Room No. To/From option Click this option to begin room number selection.

Room No. To box Type the last room number of the room range to be selected,
or click the button next the Room No. To box to select from
the listing.

Auto Wake-Up administration
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Variable Value

 Important:
To select only one room, type the same number in both
the Room No. From and Room No. To boxes.

Setting multiple AWU times using a distribution list
About this task
Set multiple AWU times to allow staff hotel to specify a recurring time for the HMS 400 system
to call the room extensions on a distribution list to wake up the occupants.

Prerequisites:

• A valid distribution list exists.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select AWU > Set Multiple AWU Time.

4. In the Set Multiple AWU Time window, click the Distribution List option.

5. Click the ellipsis (…) button next to the Distribution List box.

6. In the Distribution List dialog box, click the desired distribution list number.

7. Click Select.

8. Click the calendar icon next to the Date From box. To identify the calendar icon,
see Figure 7: Calendar icon on page 77.

9. Using the arrow buttons, navigate to the correct month on the calendar.

10. Click the date for the first AWU time.

 Important:
With the calendar icon, you can configure a wake-up call for any day from the
current day to a future date.

11. Click the calendar icon next to the Date To box.

12. Using the arrow buttons, navigate to the correct month on the calendar.

13. Click the date for the last AWU time.

 Important:
You cannot configure the Date From value to a date in the past. You must
configure the value of the Date To box for the same day or a future date.

Setting multiple AWU times using a distribution list
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14. In the AWU Time lists, click the list items that represent the correct wake-up call
time.

15. Click Select to list the array of rooms with the date and time for each call.

16. Click All->> to commit to the whole array of rooms.
OR
Click individual items in the left pane, and then click ->> to move them to the right
pane.

17. After you finish selecting rooms, click Submit.

Variable Definitions

Variable Value
Distribution List option Click this button to begin distribution list selection.

Distribution List box Type a valid list number from 10 to 9999 or a group code
number from 10000 to 99999. Optionally, press the button
next to the Distribution List box to select from the listing.

Room No. From box Type the starting room number of the room range to be
selected, or click the button next to the Room No. From box
to select from the listing.

 Important:
To select only one room, type the same number in both
the Room No. From and Room No. To boxes.

Room No. To/From option Click this option to begin room number selection.

Room No. To box Type the last room number of the room range to be selected,
or click the button next the Room No. To box to select from
the listing.

 Important:
To select only one room, type the same number in both
the Room No. From and Room No. To boxes.

Viewing AWU time
About this task
View AWU time to access the following details for each Auto Wake-Up time: room number,
guest name, extension, AWU time, and AWU status (single or recurring).

Auto Wake-Up administration
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Prerequisites:

• Check in the guest.
• You must set an AWU.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select AWU > View/Edit/Cancel AWU Time.
The system displays the View/Edit/Cancel AWU Time window, which lists current
AWU times. By default, the system displays all rooms with active wake-up calls.

4. Optionally, to view information for a specific range of rooms, complete step 5 on
page 81 to step 12 on page 81.

5. Click the room range option button.

6. Click the ellipsis (…) button next to the Room No. To box.

7. In the Room No List dialog box, click the desired room number.

8. Click Select.

9. Click the ellipsis (…) button next to the Room No. From box.

10. In the Room No List dialog box, click the desired room number.
To set for only one room, enter the same number in both the Room No. To and
Room No. From boxes.

11. Click Select.

12. Click Display.

13. Optionally, to view information for a distribution list, click the Distribution List option
button.

14. Click the ellipsis (…) button next to the Distribution List box.

15. In the Distribution List dialog box, click the desired distribution list number.

16. Click Select.

17. Click Display.

Variable Definitions

Variable Value
Distribution List box Click this button to begin distribution list selection.

Viewing AWU time
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Variable Value
Distribution List option Type a valid list number from 10 to 9999 or a group code

number from 10000 to 99999. Optionally, press the button
next to the Distribution List box to select from the listing.

Room No From box Type the starting room number of the room range to be
selected, or click the button next to the Room No. From box
to select from the listing.

 Important:
To select only one room, type the same number in both
the Room No. From and Room No. To boxes.

Room No From/To option Click this option to begin room number selection.

Room No To box Type the last room number of the room range to be selected,
or click the button next the Room No. To box to select from
the listing.

 Important:
To select only one room, type the same number in both
the Room No. From and Room No. To boxes.

Editing AWU time
About this task
Edit an AWU time to change its properties. Properties that you can edit include AWU date,
AWU time, extension, and AWU status (single or recurring).

Prerequisites:

• There must be at least one wake-up time already set.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select AWU > View/Edit/Cancel AWU Time.

4. On the View/Edit/Cancel AWU Time window, in the table, click the Change link
next to the desired room number.

5. Make the desired changes to the Date, Time, Extn, and Recurring fields.

6. After you finish applying changes, click Update.

7. Review the warning message, and then click OK.

8. Click Display to show the most current values.
OR

Auto Wake-Up administration
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Click Show All to show the most current values.

Variable Definitions

Variable Value
Date Click the calendar button to select a new date.

Extn Type a different extension number in this box.

Recurring Activate this feature to set the system to make the same
wake up call at the same time everyday (until the guest
checks out).

Time Click this list to select a new time.

Canceling AWU time
About this task
Cancel an AWU time to remove it from the HMS 400 if your guest no longer requires the
AWU.

Prerequisites:

• There must be at least one wake-up time already set.

Procedure

1. Open the Web UI.

2. Select Hotel Operation.

3. In the navigation pane, select AWU > View/Edit/Cancel AWU Time.

4. On the View/Edit/Cancel AWU Time window, in the table, click the Delete link next
to the desired room number.

AWU and Do Not Disturb
The Communication Manager Do Not Disturb (DND) feature blocks the HMS 400 AWU.

Canceling AWU time

Avaya Hospitality Messaging Server 400 Administration March 2012     83



It is not possible to control the DND status of a room through the Intuity Lodging interface. This
mean if an AWU call is created on the HMS 400, but DND is configured for the guest phone
on the Communication Manager, then the AWU call fails.

For the CS 1000–integrated version of HMS 400, the system can be configured so that an
AWU call can override the DND status.

Auto Wake-Up administration
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Chapter 9: Staff Telephone User Interface
administration

This chapter describes Staff Telephone User Interface (TUI) setup and features.

The Staff TUI provides an easy, convenient way for administrators to perform common maintenance and
administrative tasks from a telephone instead of directly from the system. It offers similar, but not all,
functions provided by the Meridian Mail HVS Guest Administration Console (GAC).

The system can play the TUI prompts in different languages, depending on the profile of the user calling
in.

Prerequisites to Staff TUI administration:

• Install and commission the Avaya Hospitality Messaging Server 400 system. For information about
installation and commissioning, see Avaya Hospitality Messaging Server 400 Installation and
Commissioning, NN42350-301.

• Create a TUI ID.

Staff Telephone User Interface administration procedures
About this task
This task flow shows you the sequence of procedures you perform to administer the staff
TUI.
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Figure 8: Staff Telephone User Interface administration

Staff Telephone User Interface administration navigation:

• Configuring TUI access on page 86
• Using the TUI menu on page 87

Configuring TUI access
About this task
Configure TUI access to allow administrators to perform common maintenance and
administrative tasks from a telephone.

Procedure

1. Configure a dummy ACD number on the switch specifically for TUI access.
Configure it as NCFW to the voice mail Pilot DN (in the same manner as you
program an Auto Attendant access number).
For information about configuring a dummy ACD number on the switch specifically
for TUI access, see Avaya Hospitality Messaging Server 400 Installation and
Commissioning, NN42350-301.

Staff Telephone User Interface administration
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2. In the Entry Point GUI, map the dummy ACD to Call Type TUI. For more
information about entry points, see Avaya Hospitality Messaging Server 400
Installation and Commissioning, NN42350-301.

3. Create at least one TUI User. For more information about creating TUI Users, see
Avaya Hospitality Messaging Server 400 Installation and Commissioning,
NN42350-301.

Using the TUI menu
About this task
Use the Telephone User Interface (TUI) to perform common maintenance and administrative
tasks from a telephone.

For information about using TUI access, see Avaya Hospitality Messaging Server 400 Front
Desk Staff User Guide, NN42350-100.

Using the TUI menu
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Chapter 10: Report generation

About this task
This chapter provides samples of each report in the system.

• Generating a system traffic report on page 89
• Generating an AWU call status report on page 90
• Generating a hotel employee listing report on page 93
• Generating an admin mailbox listing report on page 94
• Generating a guest room listing report on page 94
• Generating a minibar consumption report by items on page 95
• Generating a minibar user posting report on page 96
• Generating a minibar item list report on page 97
• Generating a minibar sales report on page 99
• Generating a room status posting report on page 98
• Exporting a report (optional) on page 102

Generating a system traffic report
About this task
You can generate an hourly summary of traffic for a service to analyze the usage of the
service.

Prerequisites:

• Make at least one call.

Procedure

1. Open the Web UI.

2. Select Reports.

3. In the navigation pane, select Statistic > System Traffic Report.

4. In the System Traffic Report window, click Category to select a service for which
to generate the traffic report.

5. In the Date area, click the calendar icon next to the box to select a date for the
report. To identify the calendar icon, see Figure 7: Calendar icon on page 77.
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6. Using the arrow buttons, navigate to the correct month on the calendar.

7. Click a date for the report.

8. Click the calendar icon next to the To box.

9. Click Show to display the report on the screen.

10. Optionally, click the Export icon to export the report as .rpt, .pdf, .xls,.doc, .csv, .rtf,
or .xml format. To identify the Export icon, see Job aid on page 92.

11. Optionally, click the Print icon to print the report. To identify the Print icon, see Job
aid on page 92.

Variable Definitions

Variable Value
Category Service for which to generate traffic report.

Available services are:

• AWU

• Voice Leave

• Voice Retrieve

• MB/RS/TU

• All Incoming

• All Outgoing

• All Calls

.

Date Date for which the report is be generated.

Generating an AWU call status report
About this task
You can generate an Auto Wake-Up (AWU) call status report to access details about AWU
calls made from a room or range of rooms during a specific time period.

You can view a report of AWU status calls either in whole or by selected status. The system
displays the report in table format.

 Note:

Report generation

90     Avaya Hospitality Messaging Server 400 Administration March 2012
Comments? infodev@avaya.com

mailto:infodev@avaya.com?subject=Avaya Hospitality Messaging Server 400 Administration


The system keeps only AWU calls made in the past 30 days in the database.

Prerequisites:

• Must have at least one complete AWU call cycle (answer/no answer/busy/failed).

Procedure

1. Open the Web UI.

2. Select Reports.

3. In the navigation pane, select AWU > AWU Call Statistic Report.

4. In the AWU Status list, click a status.

5. In the Room Number area, click options in the From and To lists to select a range
of rooms.
OR
Select the Select All Rooms check box.

6. In the AWU Date area, click the calendar icon next to the From box. To identify the
calendar icon, see Figure 7: Calendar icon on page 77.

7. Using the arrow buttons, navigate to the correct month on the calendar.

8. Click a start date for the report.

9. Click the calendar icon next to the To box.

10. Using the arrow buttons, navigate to the correct month on the calendar.

11. Click an end date for the report.

12. In the Sorted by list on the left, select a category as the sort key.

13. In the Sorted by list on the right, select whether to sort Ascending or
Descending.

14. Click Show to view the report.

15. Optionally, use the toolbar icons to perform various functions with the report. For
more information, see Job aid on page 92.

Variable Definitions

Variable Value
Sorted by (left list) Sort key options are:

• Room Number

• AWU Time

Generating an AWU call status report
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Variable Value

• Attempt

• Set By

• Guest Name

• Status

AWU Status Status options are

• ALL

• Answered

• Busy/No Answe

• Rescheduled

• Snoozed

• Pending

If you select Rescheduled, the system displays all the
Rescheduled AWU calls (only).

Job aid

Icon Function
EXPORT To save the report.

PREV To view the previous page.

PRINT To print the report.

NEXT To view the next page.

ZOOM To zoom in or out of the page.

Report generation
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Generating a hotel employee listing report
About this task
You can generate a hotel employee listing report to view a list of hotel employees filtered by
user type.

Prerequisites:

• User IDs must already be created.

Procedure

1. Open the Web UI.

2. Select Reports.

3. In the navigation pane, select Hotel Employee > Hotel Employee Listing.

4. In the Hotel Employee Listing window, in the User Type list, click a user type to
view the employee list for that user type.
By default, the system displays all employees on the report.

5. Optionally, use the toolbar icons to perform various functions with the report. For
more information, see Job aid on page 92.

Variable Definitions

Variable Value
User Type You can search and view reports according to a user type.

User types are:

• Supervisor

• Minibar Service

• Room Status

• Minibar & Room Status

• TUI

The system lists an employee whose user ID is TUI-
accessible under TUI User Type.

Generating a hotel employee listing report
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Generating an admin mailbox listing report
About this task
You can generate an admin mailbox listing report to view a list of admin mailbox users.

Prerequisites:

• Set up at least one admin mailbox.

Procedure

1. Open the Web UI.

2. Select Reports.

3. In the navigation pane, select Hotel Employee > Admin Mailbox Listing.
The system displays the entire report by default. There are no view options available
in this report. The system lists the Extension Numbers, Name, Class of Service
(COS) assigned, and the mailbox language, for viewing purpose only.

4. Optionally, use the toolbar icons to perform various functions with the report. For
more information, see Job aid on page 92.

Generating a guest room listing report
About this task
You can generate a guest room listing report to view a list of all guest rooms.

Prerequisites:

• Appropriate permissions to access the Reports section of the Web UI.

Procedure

1. Open the Web UI.

2. Select Reports.

3. In the navigation pane, select Hotel Employee > Guest Room Listing.
The system displays the entire report by default. There are no view options available
in this report. The system lists the Extension Number, Room Number, and Class of
Service (COS) assigned to the respective guest.

Report generation
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4. Optionally, use the toolbar icons to perform various functions with the report. For
more information, see Job aid on page 92.

Generating a minibar consumption report by items
About this task
You can generate a minibar consumption report by items to view a list of all the consumed
minibar items that staff post during a particular time period for specified rooms.

If you choose to view a consumption report for one room, the report displays the quantity
consumed together with the total amount. If you choose to view a consumption report of all
rooms in one report, the report displays the total amount following the last item listed for a
room.

Prerequisites:

• Configure minibar items.
• Must make minibar postings to at least one room.

Procedure

1. Open the Web UI.

2. Select Reports.

3. In the navigation pane, select Minibar > Consumption Report By Items.

4. In the Consumption Report By Items window, in the Room Number area, click
options in the From and To lists to select a range of rooms.
OR
Select the Select All Rooms check box.

5. In the Date Range area, click the calendar icon next to the From box. To identify
the calendar icon, see Figure 7: Calendar icon on page 77.

6. Using the arrow buttons, navigate to the correct month on the calendar.

7. Click a start date for the report.

8. Click the calendar icon next to the To box.

9. Using the arrow buttons, navigate to the correct month on the calendar.

10. Click an end date for the report.

11. Click Search to view the report.

Generating a minibar consumption report by items

Avaya Hospitality Messaging Server 400 Administration March 2012     95



12. Optionally, use the toolbar icons to perform various functions with the report. For
more information, see Job aid on page 92.

Variable Definitions

Variable Value
Date Range: From Click the calendar button to select the start date of the

report.

Date Range: To Click the calendar button to select the end date of the
report.

Room Number: From Use this list to select the starting room number of the room
range.

 Important:
To select only one room, use the same number in the
Room Number: From and Room Number: To boxes.

Room Number: To Use this list to select the last room number of the room
range.

 Important:
To select only one room, use the same number in the
Room Number: From and Room Number: To boxes.

Generating a minibar user posting report
About this task
You can generate a minibar user posting report to view a minibar consumption report listed
according to user ID.

This report displays details such as Room Number, Posting Time, Item Code, Item Description,
and Quantity.

Prerequisites:

• Create a User ID with minibar rights. See Creating employee IDs on page 53.
• Must make minibar postings to at least one room.

Procedure

1. Open the Web UI.

2. Select Reports.

Report generation
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3. In the navigation pane, select Minibar > User Posting Report.

4. In the User Posting Report window, in the User ID list, click a user ID.

5. In the Date Range area, click the calendar icon next to the From box. To identify
the calendar icon, see Figure 7: Calendar icon on page 77.

6. Using the arrow buttons, navigate to the correct month on the calendar.

7. Click a start date for the report.

8. Click the calendar icon next to the To box.

9. Using the arrow buttons, navigate to the correct month on the calendar.

10. Click an end date for the report.

11. Click Search to view the report.

12. Optionally, use the toolbar icons to perform various functions with the report. For
more information, see Job aid on page 92.

Generating a minibar item list report
About this task
You can generate a minibar item list report to view a list of all minibar items and the associated
details.

Minibar item details include item code, description, category, and buying and selling price. You
can sort this report by Item Code or Item Description.

Prerequisites:

• Must create at least one minibar item. See Configuring minibar inventory on page 70.

Procedure

1. Open the Web UI.

2. Select Reports.

3. In the navigation pane, select Minibar > Minibar Items Listing.

4. In the Search By list, click the desired search criterion.

5. In the Item ID list, click the item ID for a specific item.
OR
In the Item ID list, click ALL to display the entire Item Code or Description.

6. Click Search to view the report.

Generating a minibar item list report
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7. Optionally, use the toolbar icons to perform various functions with the report. For
more information, see Job aid on page 92.

Variable Definitions

Variable Value
Search By Options include Item Code and Item Description.

Generating a room status posting report
About this task
You can generate a room status posting report to view room status by room for a specified time
period.

Prerequisites:

• Configure room status codes. See Configuring room status code mapping on page 64
• Must post at least one room status change.

Procedure

1. Open the Web UI.

2. Select Reports.

3. In the navigation pane, select Room Status > Room Status Posting Report.

4. In the Room Status Posting Report window, in the Room Number list, click the
desired room number.

5. In the Date Range area, click the calendar icon next to the From box. To identify
the calendar icon, see Figure 7: Calendar icon on page 77.

6. Using the arrow buttons, navigate to the correct month on the calendar.

7. Click a start date for the report.

8. Click the calendar icon next to the To box.

9. Using the arrow buttons, navigate to the correct month on the calendar.

10. Click an end date for the report.

11. Click Search to view the report.

Report generation
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12. Optionally, use the toolbar icons to perform various functions with the report. For
more information, see Job aid on page 92.

Variable Definitions

Variable Value
Date Range From The start date for the report.

Date Range To The end date for the report.

Generating a minibar sales report
About this task
You can generate a minibar sales report to view minibar sales by item or by room.

If you click By Room in the Search Type list, the system displays the room range box. If you
click By Item in the Search Type list, the system displays the Item Name.

Prerequisites:

• Must make at least one minibar posting.

Procedure

1. Open the Web UI.

2. Select Reports.

3. In the navigation pane, select Minibar > Minibar Sales Report.

4. In the Minibar Sales Report window in the Search Type list, click By Room to sort
minibar sales by room.
OR
In the Search Type list, click By Item to sort minibar sales by item name. Go to step
6 on page 100.
If you click By Room in the Search Type list, the system displays the room range
box. If you click By Item in the Search Type list, the system displays the Item
Name.

5. In the Room Num area, click options in the From and To lists to select a range of
rooms. Go to step 7 on page 100.
OR
Select the Select All Rooms check box. Go to step 7 on page 100.

Generating a room status posting report
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6. In the Item Name list, click the desired item name.

7. In the Date Range area, click the calendar icon next to the From box. To identify
the calendar icon, see Figure 7: Calendar icon on page 77.

8. Using the arrow buttons, navigate to the correct month on the calendar.

9. Click a start date for the report.

10. Click the calendar icon next to the To box.

11. Using the arrow buttons, navigate to the correct month on the calendar.

12. Click an end date for the report.

13. Click Search to view the report.

14. Optionally, use the toolbar icons to perform various functions with the report. For
more information, see Job aid on page 92.

Variable Definitions

Variable Value
Date Range From Click the calendar button to select the start date of the

report.

Date Range To Click the calendar button to select the end date of the
report.

Room Number From Use this list to select the starting room number of the room
range.

 Important:
To select only one room, use the same number in the
Room Number: From and Room Number: To boxes.

Room Number To Use this list to select the last room number of the room
range.

 Important:
To select only one room, use the same number in the
Room Number: From and Room Number: To boxes.

Report generation
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Generating a guest directory report
About this task
You can enerate a guest directory report to view checked-in guests, to cross check for
occupancy, and for quick reference purposes.

Prerequisites:

• A guest must be checked in.

Procedure

1. Open the Web UI.

2. Select Reports.

3. In the navigation pane, select Guest Directory > Guest Directory Report.

4. In the Room Number area, click options in the From and To lists to select a range
of rooms.
OR
Select the Select All Rooms check box.

5. In the Group Code box, type in a group code to specify a particular group.
OR
Leave the Group Code box blank to generate all groups.

6. In the Date Check-In area, click the calendar icon next to the From box. To identify
the calendar icon, see Job aid on page 76

7. Using the arrow buttons, navigate to the correct month on the calendar.

8. Click an start date for the report.

9. In the Date Check-In area, click the calendar icon next to the To box. To identify
the calendar icon, see Job aid on page 76

10. Using the arrow buttons, navigate to the correct month on the calendar.

11. Click an end date for the report.

12. In the Sorted by list on the left, select a category as the sort key.

13. In the Sorted by list on the right, select select whether to sort Ascending or
Descending.

14. Click Show to view the report.

15. Optionally, use the toolbar icons to perform various functions with the report. For
more information, see Job aid on page 92.

Generating a guest directory report
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Variable Definitions

Variable Value
Date Check-In From The start date for the report.

Date Check-In To The end date for the report.

Group Code Type a 5-digit number from 10000 to 99999.

Exporting a report (optional)
About this task
You can export a report to save it in a different format.

Prerequisites:

• Generate a report.

Procedure

1. Click the Export icon

2. In the Export the Report dialog box, in the File Format list, click the format in which
to export the report.

3. In the Page Range area, click the All option. Go to step 6 on page 102.
OR
Click the Pages option.

4. In the To box, type the first page number of the information to export.

5. In the From box, type the last page number of the information to export.

6. Click OK.

7. In the File Download window, click Save.

8. In the Save As dialog box, browse to where you want to save the file.

9. Click Save.

10. In the Download Complete dialog box, click Close.

Report generation
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Variable Definitions

Variable Value
File Format Choose from .rpt, .pdf, .xls, .rtf, .doc, .csv, or .xml format.

Exporting a report (optional)
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Chapter 11: Backup and restore
management

This chapter describes how to back up and restore your Avaya Hospitality Messaging Server 400
system.

On the HMS 400 Release 3.0 system, Avaya offers only the Backup application from the Web UI, which
enables you to remotely execute a backup operation instead of having to perform it on the server itself.
In addition to archiving the database and system-critical files, you can also add system logs.

You can select a specific directory on a local drive, network drive, or portable USB drive as the destination
for the backup set.

Backup and restore management procedures
About this task
This task flow shows you the sequence of procedures you perform to back up and restore your
HMS 400 system.
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Figure 9: Backup and restore management

Backup and restore management navigation:

• Accessing the backup application remotely on page 107

Backup and restore management
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• Performing a scheduled backup (Auto Backup) on page 107
• Performing a manual backup (Ad-Hoc Backup) on page 110
• Restoring the system from backup files (HMS 400R3 Restore Application) on page 112
• Using the Backup File Items Context Menu (view or restore) on page 113

Accessing the backup application remotely
About this task
You can perform a backup operation remotely by navigating to the Web user interface (UI) to
access the backup application.

Prerequisites:

• Obtain a Web Admin ID with proper permissions.

Procedure

1. Open a Web browser window.

2. In the address bar, type https://hms400R3/hms400webui and press Enter.

3. Log on to the Web UI as an Admin User.

4. On the Main Menu bar, click Utilities.
By default, the system displays the Auto Backup Configuration page.

Performing a scheduled backup (Auto Backup)
About this task
You can perform a scheduled backup by configuring the backup task to run at a specific time
every day.

The system automatically saves backup data in .zip format to the specified location. However,
the system saves only one zip file for each set, regardless of the number of data options
chosen. You do not need to stop the system when performing a backup.

 Important:
To reduce system load, back up the system at off-peak hours.

Accessing the backup application remotely
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Prerequisites:

• Determine the most suitable time for backup to be done each day.

Procedure

1. To access the Backup/Restore option, on the system’s main screen, click the
Restore icon. To identify the Restore icon, see Performing a manual backup (Ad-
Hoc Backup) on page 110.
OR
On your desktop, double-click the My Computer icon, navigate to C:
\HMS400rR3\Bin, and then double-click the AutoBackupAndRestore.exe file.

2. In the Auto Backup Configuration window, select the Auto Backup check box.

3. In the message box, click OK.

4. In the Destination Path for Backup box, type a destination path.
OR
Do not type a new destination path to accept the default destination path.

 Important:
You must map the network drive to make it available in the Destination Path for
Backup box. The system displays the network drive as a drive letter. For portable
(USB) drives, confirm that you use the correct drive letter.

If you enter a C:\ or D:\ prefix followed by a folder name, then the system saves
the backup file to the folder entered (if the folder does not exist, the system
automatically creates it). If the system detects a \\ prefix, then it knows that this
is a network path. If the system detects neither (for example: only backup is
input), then the system saves the backup file to the default working folder, which
is C:\Hms400r3 (creating the sub-folder backup according to date).

5. In the Backup Retention list, click the number of generations of backup set folders
to keep.

 Important:
The system automatically deletes the backup sets after the number of days you
select in the Backup Retention list, counting from the day you activate the auto
backup.

6. In the Backup Files area, choose the data sets to back up by selecting the check
boxes next to one or more of the following items:

• System Database

• System Configuration Parameters & System Default Settings

• Mailboxes & Messages

• Call Flows

• Bin and Tools

• Voice Prompt

Backup and restore management
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• Logs

You typically save the first six categories of files after you successfully install the
system. These six categories comprise the foundation required for a complete
system-restore from a crashed/corrupted state back to a fully functional condition.

 Important:
If you perform more than one backup on the same day with the same data sets,
the system overwrites the previous data sets with the subsequent data sets.
However, if you select new data sets, then the system appends the new data sets
into the whole backup set.

7. If you select the Logs check box, select the check boxes for the desired log
categories.
OR
Click Select All to select all the log categories.

8. In the Auto Backup Time area, in the Time box, type the time for the backup.

9. In the Time list, click AM to specify a morning time.
OR
Click PM to specify an evening time.

 Important:
Perform backups between 2–4 a.m. to ensure the least amount of call traffic.

10. Click Apply.

Variable Definitions

Variable Value
Backup Retention The number of backup set folders to keep. The maximum is

9 sets.

Call Flows Backs up the entire Flow Script folder

Destination Path Type the destination to which you want to save the backup
set. (Destination can be a local drive, network drive, or
portable/removable drive.)

Logs Backs up all the specified System logs (as selected by user)

Mailboxes & Messages Backs up the entire Mailbox recorded folder

System Configuration
Parameters & System Default
Settings

Backs up all INI files in the system folder

Performing a scheduled backup (Auto Backup)
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Variable Value
System Database Backs up the system database

Bin and Tools Backs up the bin folder and tools folder

Voice Prompt Backs up the voice folder

Time box Type the time for the system to perform auto backup.
(Format is hh:mm, using the 12-hour clock format.)

Performing a manual backup (Ad-Hoc Backup)
About this task
You can perform a manual backup to back up system or application data right away.

You can perform a manual backup at anytime by selecting the data to save. A manual backup
can take between a few minutes to a couple of hours, depending on the amount of data to
archive.

 Important:
Perform a manual backup before you perform any major maintenance activity such as
replacing hardware or installing a software update (SU).

Prerequisites:

• Perform the manual backup during low-peak hours.

Procedure

1. To access the Backup/Restore option, on the system’s main screen, click the
Restore icon. To identify the Restore icon, see the following figure.

Figure 10: Restore icon

OR
On your desktop, double-click the My Computer icon, navigate to C:
\HMS400R3\Bin, and then double-click the AutoBackupAndRestore.exe file.

2. In the Auto Backup Configuration window, in the Destination Path for Backup
box, type a destination path.
OR
Do not type a new destination path to accept the default destination path.

Backup and restore management

110     Avaya Hospitality Messaging Server 400 Administration March 2012
Comments? infodev@avaya.com

mailto:infodev@avaya.com?subject=Avaya Hospitality Messaging Server 400 Administration


 Important:
You must map the network drive to make it available in the Destination Path for
Backup box. The system displays the network drive as a drive letter. For portable
(USB) drives, be sure that you use the correct drive letter.

3. In the Backup Files area, choose the data sets to back up by selecting the check
boxes next to any of the following items:

• System Database

• System Configuration Parameters & System Default Settings

• Mailboxes & Messages

• Call Flows

• Bin and Tools

• Voice Prompt

• Logs

You typically save the first six categories of files after you successfully install the
system. These six categories comprise the foundation required for a complete
system-restore from a crashed/corrupted state back to a fully functional condition.

 Important:
If you perform more than one backup on the same day with the same data sets,
the system overwrites the previous data sets with the subsequent data sets.
However, if you select new data sets, then the system appends the new data sets
into the whole backup set.

4. If you select the Logs check box, select the check boxes for the desired log
categories.
OR
Click Select All to select all the log categories.

5. Click Backup Now.
A window appears displaying the status of the backup.

 Important:
Performing a manual backup during peak periods can impact system
performance. Perform manual backups only when call traffic is low.

6. After the Backup Successful message appears, close the status window.
By default, the system creates a subfolder with the naming convention format of
yyyymmdd; for example. 20110721. You cannot change the name of the backup
set.

Performing a manual backup (Ad-Hoc Backup)
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Variable Definitions

Variable Value
Backup_category_mmdd.zip Category denotes the different category of

backup such as logs, system, mailbox, bin,
CallFlows, voice and Database.
mm denotes the month and dd denotes the
date of the backup.
For example; BACKUP_Logs_0621.zip,
BACKUP_System_mmdd.zip

Call Flows Backs up the entire Flow Script folder

Destination Path Type the destination to which you want to save
the backup set. (Destination can be the local
drive, network drive, or a portable/removable
drive.)

Logs Backs up all the specified System logs (as
selected by user)

Mailboxes & Messages Backs up the entire Mailbox folder

System Configuration Parameters &
System Default Settings

Backs up all INI files in the system folder

System Database Backs up the system database

Bin and Tools Backs up the Bin folder and Tools folder

Voice Prompt Backs up the Voice folder

Restoring the system from backup files (HMS 400R3 Restore
Application)

About this task
You can restore the system from backup files to reconstruct your data if your hard disk fails or
data corrupts.

You can access the Restore application only from the server itself.

Backup and restore management
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Prerequisites:

• Restoring the system is usually done after a re-image or if the system is unrecoverable.

Procedure

1. Shut down the entire HMS 400 system, including PMSI. For information about
shutting down the HMS 400 system, see HMS 400 Installation and Commissioning,
NN42350-301.

 Important:
HMS 400 does not pick up calls after you shut down the system.

2. On the HMS400R3 main screen toolbar, click the Restore icon. To identify the
Restore icon, see Performing a manual backup (Ad-Hoc Backup) on page 110.
OR
On your desktop, double-click the My Computer icon, navigate to C:
\HMS400R3\Bin, and then double-click the AutoBackupAndRestore.exe file.

3. In the HMS400R3 System Restore Manager window, in the left pane, select the
file to restore from the default folder (C:\Backup).
OR
To restore from a different location, click Change Source Folder, browse for the
desired folder in the Browse for Folder dialog box, and then click OK.
The system displays the data categories in the selected backup set.

4. Click Restore.
The system displays the restoration progress on the status bar. After the system
completes restoration, it displays a Restoration Complete message and the total
restoration time on the status bar.

 Caution:
Rerun the last software update (SU) installed after system restoration, as the
restore function overwrites the existing HMS 400 databases and configuration
files.

5. Restart the HMS 400 system.

Using the Backup File Items Context Menu (view or
restore)

About this task
You can use the Backup File Items Context Menu to start a restore process or to view the
properties of a backup set.

Using the Backup File Items Context Menu (view or restore)
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Prerequisites:

• There must be at least one backup set available.

Procedure

To view the properties of a backup set, right-click an item in the backup set list, and
then click Properties in the shortcut menu to view the details of that particular backup
set. Details include filename, full path, date created, and size.

Backup and restore management
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Chapter 12: Avaya Hospitality Messaging
Server system recovery

About this task
For information about Avaya Hospitality Messaging Server 400 system recovery, see Avaya Hospitality
Messaging Server 400 Installation and Commissioning, NN42350-301.
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Chapter 13: Common procedures

About this task
This chapter describes some common procedures.

Starting up the HMS 400 system
About this task
Start up the Avaya Hospitality Messaging Server 400 (HMS 400) system to restart the system
when the system is stalled or when you make changes to the system that require a restart.

For information about the visual layout of the HMS 400 interface, see Avaya Hospitality
Messaging Server 400 Fundamentals, NN42350-104.

Procedure

1. On your desktop, double-click the HMS400R3 icon to restart.
The system displays the HMS 400 splash screen, and then opens the HMS400 R3.0
window.

2. Check the system tray to confirm that all the following modules start: Voice Systems,
PBXI, , and PMSI.

 Important:
The module icons do not necessarily appear in this order.

Job aid
Check the system tray to verify that all the following modules start.

• Voice Systems

• PBXI

• PMSI
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Enabling Log Me In remote access
About this task
The Log Me In application (logmein) is used to access the HMS 400 system.

Access to logmein may be blocked by Internet Explorer indicating security levels are too high.
Use this procedure to add logmein to your list of trusted sites.

Procedure

1. Open Internet Explorer.

2. Click Tools > Internet Options.
 

 

3. Under the Security tab, click Trusted Sites

4. Click Sites.

5. In the Trusted Sites window, type https://secure.logmeinrescue.com in the Add this
website to the zone field.

6. Click Close to close the Trusted Sites window.

7. In the Internet Options window, click the Advanced tab.

8. Scroll down to Security in the Settings list box and uncheck Do not save encrypted
pages to disk.
 

Common procedures
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9. Restart Internet Explorer.

Enabling Log Me In remote access
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