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Notice
While reasonable efforts have been made to ensure that the information in this 
document is complete and accurate at the time of printing, Avaya assumes no 
liability for any errors. Avaya reserves the right to make changes and 
corrections to the information in this document without the obligation to notify 
any person or organization of such changes.

Documentation disclaimer
"Documentation" means information published by Avaya in varying mediums 
which may include product information, operating instructions and performance 
specifications that Avaya generally makes available to users of its products. 
Documentation does not include marketing materials. Avaya shall not be 
responsible for any modifications, additions, or deletions to the original 
published version of documentation unless such modifications, additions, or 
deletions were performed by Avaya.End User agrees to indemnify and hold 
harmless Avaya, Avaya's agents, servants and employees against all claims, 
lawsuits, demands and judgments arising out of, or in connection with, 
subsequent modifications, additions or deletions to this documentation, to the 
extent made by End User.

Link disclaimer
Avaya is not responsible for the contents or reliability of any linked websites 
referenced within this site or documentation provided by Avaya. Avaya is not 
responsible for the accuracy of any information, statement or content provided 
on these sites and does not necessarily endorse the products, services, or 
information described or offered within them. Avaya does not guarantee that 
these links will work all the time and has no control over the availability of the 
linked pages.

Warranty
Avaya provides a limited warranty on its hardware and Software ("Product(s)" ). 
Refer to your sales agreement to establish the terms of the limited warranty. In 
addition, Avaya’s standard warranty language, as well as information regarding 
support for this Product while under warranty is available to Avaya customers 
and other parties through the Avaya Support website
http://support.avaya.com
Please note that if you acquired the Product(s) from an authorized Avaya 
reseller outside of the United States and Canada, the warranty is provided to 
you by said Avaya reseller and not by Avaya. "Software" means computer 
programs in object code, provided by Avaya or an Avaya Channel Partner, 
whether as stand-alone products or pre-installed on hardware products, and 
any upgrades, updates, bug fixes, or modified versions.

Licenses
THE SOFTWARE LICENSE TERMS AVAILABLEON THE AVAYA WEBSITE, 
HTTP://SUPPORT.AVAYA.COM/LICENSEINFO ARE APPLICABLE TO 
ANYONE WHO DOWNLOADS, USES AND/OR INSTALLS AVAYA 
SOFTWARE, PURCHASED FROM AVAYA INC., ANY AVAYA AFFILIATE, OR 
AN AUTHORIZED AVAYA RESELLER (AS APPLICABLE) UNDER A 
COMMERCIAL AGREEMENT WITH AVAYA OR AN AUTHORIZED AVAYA 
RESELLER. UNLESS OTHERWISE AGREED TO BY AVAYA IN WRITING, 
AVAYA DOES NOT EXTEND THIS LICENSE IF THE SOFTWARE WAS 
OBTAINED FROM ANYONE OTHER THAN AVAYA, AN AVAYA AFFILIATE 
OR AN AVAYA AUTHORIZED RESELLER; AVAYA RESERVES THE RIGHT 
TO TAKE LEGAL ACTION AGAINST YOU AND ANYONE ELSE USING OR 
SELLING THE SOFTWARE WITHOUT A LICENSE. BY INSTALLING, 
DOWNLOADING OR USING THE SOFTWARE, OR AUTHORIZING OTHERS 
TO DO SO, YOU, ON BEHALF OF YOURSELF AND THE ENTITY FOR 
WHOM YOU ARE INSTALLING, DOWNLOADING OR USING THE 
SOFTWARE (HEREINAFTER REFERRED TO INTERCHANGEABLY AS 
“YOU” AND “END USER”), AGREE TO THESE TERMS AND CONDITIONS 
AND CREATE A BINDING CONTRACT BETWEEN YOU AND AVAYA INC. OR 
THE APPLICABLE AVAYA AFFILIATE ( “AVAYA”).
Avaya grants you a license within the scope of the license types described 
below, with the exception of Heritage Nortel Software, for which the scope of 
the license is detailed below. Where the order documentation does not 
expressly identify a license type, the applicable license will be a Designated 
System License. The applicable number of licenses and units of capacity for 
which the license is granted will be one (1), unless a different number of 
licenses or units of capacity is specified in the documentation or other materials 
available to you. “Designated Processor” means a single stand-alone 
computing device. “Server” means a Designated Processor that hosts a 
software application to be accessed by multiple users.

License type(s)

Heritage Nortel Software

“Heritage Nortel Software” means the software that was acquired by Avaya as 
part of its purchase of the Nortel Enterprise Solutions Business in December 
2009. The Heritage Nortel Software currently available for license from Avaya 
is the software contained within the list of Heritage Nortel Products located at 
http://support.avaya.com/licenseinfo under the link “Heritage Nortel Products”. 

For Heritage Nortel Software, Avaya grants Customer a license to use Heritage 
Nortel Software provided hereunder solely to the extent of the authorized 
activation or authorized usage level, solely for the purpose specified in the 
Documentation, and solely as embedded in, for execution on, or (in the event 
the applicable Documentation permits installation on non-Avaya equipment) for 
communication with Avaya equipment. Charges for Heritage Nortel Software 
may be based on extent of activation or use authorized as specified in an order 
or invoice.

Copyright 
Except where expressly stated otherwise, no use should be made of materials 
on this site, the Documentation, Software, or hardware provided by Avaya. All 
content on this site, the documentation and the Product provided by Avaya 
including the selection, arrangement and design of the content is owned either 
by Avaya or its licensors and is protected by copyright and other intellectual 
property laws including the sui generis rights relating to the protection of 
databases. You may not modify, copy, reproduce, republish, upload, post, 
transmit or distribute in any way any content, in whole or in part, including any 
code and software unless expressly authorized by Avaya. Unauthorized 
reproduction, transmission, dissemination, storage, and or use without the 
express written consent of Avaya can be a criminal, as well as a civil offense 
under the applicable law.

Third-party components
“Third Party Components” mean certain software programs or portions thereof 
included in the Software that may contain software (including open source 
software) distributed under third party agreements (“Third Party Components”), 
which contain terms regarding the rights to use certain portions of the Software 
(“Third Party Terms”). Information regarding distributed Linux OS source code 
(for those Products that have distributed Linux OS source code) and identifying 
the copyright holders of the Third Party Components and the Third Party Terms 
that apply is available in the Documentation or on Avaya’s website at: 
http://support.avaya.com/Copyright. You agree to the Third Party Terms for any 
such Third Party Components.
This product includes software developed by the OpenSSL Project for use in 
the OpenSSL Toolkit (http://www.openssl.org/).
This product includes cryptographic software written by Eric Young 
(eay@cryptsoft.com). 
This product includes software written by Tim Hudson (tjh@cryptsoft.com). 
This product includes Janus Button Bar by Janus Systems SA de CV. 
Copyright (C) 1998-2000. All rights reserved.

Note to Service Provider
The Product may use Third Party Components that have Third Party Terms 
that do not allow hosting and may need to be independently licensed for such 
purpose.

Preventing Toll Fraud
“Toll Fraud” is the unauthorized use of your telecommunications system by an 
unauthorized party (for example, a person who is not a corporate employee, 
agent, subcontractor, or is not working on your company's behalf). Be aware 
that there can be a risk of Toll Fraud associated with your system and that, if 
Toll Fraud occurs, it can result in substantial additional charges for your 
telecommunications services.

Avaya Toll Fraud intervention
If you suspect that you are being victimized by Toll Fraud and you need 
technical assistance or support, call Technical Service Center Toll Fraud 
Intervention Hotline at +1-800-643-2353 for the United States and Canada. For 
additional support telephone numbers, see the Avaya Support website: 
http://support.avaya.com.Suspected security vulnerabilities with Avaya 
products should be reported to Avaya by sending mail to: 
securityalerts@avaya.com.

Trademarks
The trademarks, logos and service marks (“Marks”) displayed in this site, the 
Documentation and Product(s) provided by Avaya are the registered or 
unregistered Marks of Avaya, its affiliates, or other third parties. Users are not 
permitted to use such Marks without prior written consent from Avaya or such 
third party which may own the Mark. Nothing contained in this site, the 
Documentation and Product(s) should be construed as granting, by implication, 
estoppel, or otherwise, any license or right in and to the Marks without the 
express written permission of Avaya or the applicable third party.
Avaya is a registered trademark of Avaya Inc.
All non-Avaya trademarks are the property of their respective owners, and 
“Linux” is a registered trademark of Linus Torvalds.

Downloading documents
For the most current versions of documentation, see the Avaya Support 
website:
http://support.avaya.com

http://support.avaya.com
http://support.avaya.com/licenseinfo
http://support.avaya.com/licenseinfo
http://support.avaya.com/Copyright
http://www.openssl.org
http://support.avaya.com
http://support.avaya.com


Contact Avaya Support
See the Avaya Support website: http://support.avaya.com for product notices 
and articles, or to report a problem with your Avaya product.
For a list of support telephone numbers and contact addresses, go to the 
Avaya Support website: http://support.avaya.com, scroll to the bottom of the 
page, and select Contact Avaya Support.

http://support.avaya.com
http://support.avaya.com
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Preface

This section contains the following topics:

● Purpose on page 3

● Intended audience on page 3

● Related resources on page 3

Purpose
This document describes tested product characteristics and capabilities including product 
overview and feature descriptions, interoperability, performance specifications, security, and 
licensing requirements.

Avaya Outbound Contact Express Supervisor consists of the following applications:

● Role Editor

● Editor

● Monitor

● Analyst

● Health Manager

Intended audience
This document is intended for anyone who wants to understand and use the features, 
functionality, capacities, and limitations of Avaya Outbound Contact Express Supervisor.

Related resources
This section contains the following topics:

● Documentation on page 4

● Training on page 6

● Avaya Mentor videos on page 6

mailto:infodev@avaya.com?subject=Using Avaya Outbound Contact Express Supervisor
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Documentation
The following table lists the documents related to this product. Download the documents from 
the Avaya Support website at http://support.avaya.com

Document 
number

Title Use this document to: Audience

Overview

Avaya IP Office Server 
Edition Solution
Description

Understand high-level 
solution features and 
functionality

Customers, 
Partners, Sales, 
Services and
Support 
personnel

Avaya Outbound Contact 
Express Solution 
Description

Understand high-level 
solution features and 
functionality

Customers, 
Partners, Sales, 
Services and
Support 
personnel

Implementing

Implementing Avaya 
Speech Analytics

Installation and 
configuration information

Partners, 
Services and 
Support 
personnel

Avaya Outbound Contact 
Express Intelligent 
Workbook

Installation and 
configuration worksheets 
and checklists

Partners, 
Services and 
Support 
personnel

Troubleshooting

Maintaining and
Troubleshooting Avaya
Proactive Contact 5.1

Perform Avaya Proactive
Contact maintenance and
troubleshooting tasks

System
administrators
and IT
personnel

Avaya IP Office SSL VPN
Solutions

Understand how SSL VPN 
is used for remote 
serviceability

System
administrators
and IT
personnel

mailto:infodev@avaya.com?subject=Using Avaya Outbound Contact Express Supervisor
http://support.avaya.com
http://support.avaya.com
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Avaya Proactive Contact
Safety and Regulatory
Information

Review international safety 
and regulatory information

System
administrators
and IT
personnel

Administering 

Administering Avaya 
Outbound Contact Express 

Perform administration 
tasks

System 
administrators

15–601063 Avaya IP Office
Administering Voicemail
Pro

Perform Voicemail Pro
administration tasks

System 
administrators

15–601011 Avaya IP Office Manager Perform advanced
administration tasks

System 
administrators

Administering Avaya
Speech Analytics

Perform advanced Avaya
Speech Analytics
administration tasks

System 
administrators

Using

Using Avaya Outbound 
Contact Express 
Supervisor

Manage outbound dialing
activities

Call center 
supervisors

Using Avaya Outbound 
Contact Express Web 
Agent

Perform agent tasks Call center 
agents

Using Avaya Outbound
Contact Express Script
Manager

Perform script 
management tasks

Call center 
supervisors

Avaya Outbound Contact 
Express Script Manager

Script management tasks Call center 
supervisors

Avaya Outbound Contact 
Express Response 
Element

Understand how script
response elements 
function

Call center 
supervisors

Avaya Speech Analytics
Reporting

Understand how to work 
with speech analysis 
reports

Customer 
supervisors

Document 
number

Title Use this document to: Audience

mailto:infodev@avaya.com?subject=Using Avaya Outbound Contact Express Supervisor
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Training
The following courses are available on http://avaya-learning.com. Enter the course code in the 
Search field and click Go to search for the course.

Avaya Mentor videos
Avaya Mentor is an Avaya-run channel on YouTube that includes technical content on how to 
install, configure, and troubleshoot Avaya products.

Visit http://www.youtube.com/AvayaMentor and do one of the following:

● Enter a key word or key words in the Search channel to search for a specific product or 
topic.

● Click the name of a playlist to scroll through the posted videos.

Support
Visit the Avaya Support website at http://support.avaya.com for the most up-to-date 
documentation, product notices, and knowledge articles.

On the Avaya Support website at http://support.avaya.com, search for notices, release notes, 
downloads, user guides, and resolutions to issues. Use the Web service request system to 
create a service request. Chat with live agents to help answer questions. If an issue requires 
additional expertise, agents can quickly connect you to a support team.

Course code Course title

AVA01013WEN Avaya Proactive Contact Solutions Overview

ASC00207WEN Contact Center Automated

AVA00989H00 Avaya Proactive Contact 5.0 Basic System Supervisor

AVA00990H00 Avaya Proactive Contact 5.0 Advanced System Supervisor

4S00006W IP Office Release 8.1 Mid-Market and Linux — Technical Overview

http://avaya-learning.com
mailto:infodev@avaya.com?subject=Using Avaya Outbound Contact Express Supervisor
http://www.youtube.com/AvayaMentor
http://support.avaya.com
http://support.avaya.com
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Chapter 1: About Health Manager

Health Manager provides information about programs and processes running on your Avaya 
Outbound Contact Express system. It also enables you to monitor the overall system health and 
start and stop services across several subsystem components.

Use the Health Manager to monitor key indicators of your Avaya Outbound Contact Express 
system performance. You can see status of the services that are running and restart services 
that have stopped. You can also view the system activity using the many views available in the 
Health Manager.

You must have permissions to access Health Manager. There are two types of permissions 
available for Health Manager as explained in the following table. To assign permission to your 
username please contact your administrator.

If you are connected to an e-mail system, you can subscribe to alerts that will notify you of the 
changes in the system health.

This section contains the following topics:

● Understanding Health Manager on page 9

● Using Health Manager on page 15

● Maintaining Health Manager on page 31

Application Permission Type

R (Read) J (Job) W (Write)

Health Manager X X

mailto:infodev@avaya.com?subject=Using Avaya Outbound Contact Express  Supervisor
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Chapter 2: Understanding Health Manager

Avaya Outbound Contact Express supports only a subset of the features of Avaya Proactive 
Contact. For the list of features not supported in Avaya Outbound Contact Express, see 
Features not supported in Avaya Outbound Contact Express on page 35.

This section includes the following topics:

● Overall Health Status on page 9

● Dialer Services on page 9

● Mid-Tier Services on page 11

● System Status on page 12

Note:
Note: The service names listed in the Health Manager vary according to the features 

configured on your system.

Note:
Note: You can only start and stop the Mid-Tier All services using Health Manager. But 

stopping or starting Mid-Tier All services does not start or stop all the Mid-Tier 
services, such as serviceMonitor, serviceAct, and NamingService.  
The starting and stopping of All Dialer processes has been disabled in Health 
Manager. Also, the starting and stopping of individual processes in Dialer and 
Mid-Tier has been disabled in Health Manager.

Overall Health Status
The Overall Health Services: Dialer Status view shows the status of all the dialers in the 
system. For more information, see View Overall System Health for All Dialers on page 17.

Dialer Services
The Dialer Services view shows the status of all the services on the selected dialer in the 
system. From this view, you can view health status for the following dialer service categories:

● Dialer Services: Core on page 10

● Dialer Services: Telephony on page 10

● Dialer Services: Data on page 10

mailto:infodev@avaya.com?subject=Using Avaya Outbound Contact Express Supervisor


Chapter 2: Understanding Health Manager

Features not supported in Avaya Outbound Contact Express on page 35

10     Using Outbound Contact Express Health Manager Comments? infodev@avaya.com March 2013

● Dialer Services: Dialer Command Control and Administration on page 10

● Dialer Services: Health Related on page 10

● Dialer Services: All on page 11

Dialer Services: Core
The Dialer Services: Core view shows the status of core services on the selected dialer in the 
system. From this view, you can set alerts for the activity events related to each service. For 
more information, see View Dialer Core Services Information on page 18.

Dialer Services: Telephony
The Dialer Services: Telephony view shows the status of telephony services on the selected 
dialer in the system. From this view, you can set alerts for activity events related to each 
service. For more information, see View Dialer Telephony Services Information on page 20.

Dialer Services: Data
The Dialer Services: Data view shows the status of data services on the selected dialer in the 
system. From this view, you can set alerts for activity events related to each service. For more 
information, see View Dialer Data Services Health Information on page 20.

Dialer Services: Dialer Command Control and Administration
The Dialer Services: Dialer command control and administration view shows the status of 
command control and administration services on the selected dialer in the system. From this 
view, you can set alerts for activity events related to each service. For more information, see 
View Dialer Command Control and Administration Service Information on page 21.

Dialer Services: Health Related
The Dialer Services: Health related view shows the status of health related services on the 
selected dialer in the system. From this view, you can set alerts for activity events related to 
each service. For more information, see View Dialer Health Related Service Information on 
page 21.

mailto:infodev@avaya.com?subject=Using Avaya Outbound Contact Express Supervisor
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Dialer Services: All
The Dialer Services: All view shows the status of all the services on the selected dialer in the 
system. From this view, you can set alerts for activity events related to each service. For more 
information, see View dialer health related service information.

Mid-Tier Services
The Mid-Tier Services view shows the status of all Mid-Tier services on the selected dialer in 
the system. From this view, you can view health status for the following dialer service 
categories:

● Mid-Tier Services: Framework on page 11

● Mid-Tier Services: Data on page 11

● Mid-Tier Services: Mid-Tier Command Control and Administration on page 11

● Mid-Tier Services: Health related on page 12

● Mid-Tier Services: All on page 12

Mid-Tier Services: Framework
The Mid-Tier Services: Framework view shows the status of Mid-Tier framework services on 
the selected dialer in the system. From this view, you can set alerts for activity events related to 
each service. For more information, see View Mid-Tier Framework Service Information on 
page 22.

Mid-Tier Services: Data
The Mid-Tier Services: Data view shows the status of Mid-Tier data services on the selected 
dialer in the system. From this view, you can set alerts for activity events related to each 
service. For more information, see View Mid-Tier Data Services Information on page 22.

Mid-Tier Services: Mid-Tier Command Control and Administration
The Mid-Tier Services: Mid-Tier Command Control and Administration view shows the 
status of Mid-Tier command control and administration services on the selected dialer in the 
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system. From this view, you can set alerts for activity events related to each service. For more 
information, see View Mid-Tier Command Control and Administration Service Information on 
page 23.

Mid-Tier Services: Health related
The Mid-Tier Services: Health related view shows the status of Mid-Tier health related 
services on the selected dialer in the system. From this view, you can set alerts for activity 
events related to each service. For more information, see View Mid-Tier Health Related Service 
Information on page 23.

Mid-Tier Services: All
The Mid-Tier Services: All view shows the status of all the Mid-Tier services on the selected 
dialer in the system. From this view, you can set alerts for activity events related to each 
service. For more information, see View All the Mid-Tier Services on page 24.

System Status
The System Status view shows the selected dialer’s CPU, disk, memory, and process status. 
From this view, you can view status for the following information:

● System Status: CPU Usage on page 12

● System Status: Disk Usage on page 13

● System Status: Memory Usage on page 13

● System Status: Processes on page 13

System Status: CPU Usage
The System Status: CPU view shows the selected dialer’s CPU usage statistics. For more 
information, see View CPU Usage Statistics on page 24.
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System Status: Disk Usage
The System Status: Disk view shows the selected dialer’s hard-disk usage statistics. For more 
information, see View Disk Usage Statistics on page 25.

System Status: Memory Usage
The System Status: Memory view shows the selected dialer’s memory usage statistics. For 
more information, see View Memory Usage Statistics on page 26.

System Status: Processes
The System Status: Processes view shows the selected dialer’s processes statistics. For 
more information, see View Processes Statistics on page 27.
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Chapter 3: Using Health Manager

Avaya Outbound Contact Express supports only a subset of the features of Avaya Proactive 
Contact. For the list of features not supported in Avaya Outbound Contact Express, see 
Features not supported in Avaya Outbound Contact Express on page 35.

Avaya Outbound Contact Express allows you to monitor the functioning of your system to 
improve reliability and maintainability.

This section contains the following topics:

● Log In to Health Manager on page 15

● Change Display Options on page 16

● Refresh Health Manager Data on page 16

● Sort the List of Dialers, Services, or Events on page 17

● View Overall System Health for All Dialers on page 17

● View System Health for One Dialer on page 17

●  View System Activity Events on page 27

● Subscribe to Activity Events on page 28

● Save Data as HTML on page 29

Log In to Health Manager
To log in to Health Manager:

1. Select Start > All Programs > Avaya > Proactive Contact > Health Manager or 
double-click the Health Manager icon on the desktop.

2. Type your administrator user name and password on the login message, and then click OK.

When you log in to Health Manager the first time, you will see the Overall Health Services: 
Dialer Status view. From the drop-down menu below the toolbar in the upper left corner, 
you can choose to view the status of one dialer or all dialers (if you have more than one 
dialer) in your system. 

Each time you log in to the Health Manager, you will see the last view you were viewing 
when you logged out of Health Manager. 
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Change Display Options
You can choose to show or hide columns and adjust column widths in the right pane when 
viewing information.

Show or Hide Columns
To show or hide columns:

1. From the Edit menu, click Hide/Show Columns. 

2. In the Columns dialog box, clear or select the check box. Alternatively, you can click the 
Show All or Hide All buttons.

3. Click OK.

The Health Manager view changes to reflect your choices. Health Manager saves the 
column settings and reuses them the next time you log in.

Tip:
Tip: You may need to maximize the window, adjust the column sizes, or use the scroll 

bar to view all the columns. You can sort the listed items by clicking the column 
headings. 

Adjust Column Widths
To adjust column widths:

1. Put your cursor near the column heading divider of the column you want to change until it 
changes into a column icon.

2. Drag the column divider to the desired length.

The Health Manager view changes to reflect your choices. Health Manager saves the 
column width settings and re-uses them the next time you log in.

Refresh Health Manager Data
To refresh the Health Manager data in any view:

● On the View menu, click Refresh.
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Note:
Note: To refresh data in the Activity Events Viewer, click the Refresh button.

Sort the List of Dialers, Services, or Events
To sort the lists of dialers, services, or events:

● Click the column heading to sort in ascending or descending order.

To reverse the sort order, click the column heading a second time. Health Manager saves 
the sort order and reuses it the next time you log in.

View Overall System Health for All Dialers
To view overall system health for all dialers:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager. If this is the first time you have logged into the Health Manager, the 
Overall Health Services: Dialer Status view appears. If you have logged into Health 
Manager before to view system health, the screen you were viewing when you exited 
Health Manager appears. 

2. If the Overall Health Services: Dialer Status view does not appear immediately after you 
log in, select All Dialers from the drop-down list in the upper left corner of the screen. 

The system displays the overall health statistics for all the dialers in the right pane. 

Status Item Name Description

Dialer Name Name of dialer in your system configuration

Dialer IP Address IP address for the selected dialer

Status Indicates whether the system is up or down

Uptime Duration of time the dialer has been up

View System Health for One Dialer
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To view overall system health for one dialer:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager. If this is the first time you have logged into Health Manager, the Overall 
Health Services: Dialer Status view appears. If you have logged into Health Manager 
before to view system health, the screen you were viewing when you exited Health 
Manager appears. 

2. Select a dialer name from the drop-down list in the upper left corner of the screen, below the 
toolbar. The left pane changes to show Dialer Services with icons for each aspect of the 
dialer service condition. From the left pane, you can choose to do the following:

● View Dialer Services on page 18

● View Mid-Tier Services on page 22

● View System Status on page 24

View Dialer Services
From the Dialer Services view, you can choose to do the following:

● View Dialer Core Services Information on page 18

● View Dialer Telephony Services Information on page 20

● View Dialer Data Services Health Information on page 20

● View Dialer Command Control and Administration Service Information on page 21

● View Dialer Health Related Service Information on page 21

●  View All the Dialer Services on page 21

Tip:
Tip: You can sort the information in the view by clicking the column headings. 

View Dialer Core Services Information

To view dialer core services health:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager. 

2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left 
pane changes to show Dialer Services with icons. 
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3. In the left pane under Dialer Services, click Core. Health Manager displays the following 
information in the right pane:

Service Name Description

AGENT Agent activity manager

AGENT_BLENDER AGENT_BLENDER

ACD_MONITOR Blend activity monitor

DISPATCHER Outbound agent manager

CBAMAIN Agent blend manager

CTI ACD gateway

CEP_PWAY Call events gateway

CHGSVR Switch gateway

CBA_USER CBA user

PORTER Call process manager (where n indicates the 
PORTER number on the system)

SIGNALIT Dialer OS signaling

PDS_STATUS PDS_STATUS

ROUTED Message router

CONN_MGR Agent connection manager

AGENT_COUNT Agent counter

JOB_STARTER Job linking manager

SWITCHER Audio connection manager

OPMON Agent headset port manager

LIST_SERVER List Sharing manager

RECALL_RMP Agent Owned Recall call manager

AO_RECALL Agent Owned Recall job manager
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View Dialer Telephony Services Information

To view dialer telephony services health:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager.

2. In the left pane under Dialer Services, click Telephony. Health Manager displays the 
following information in the right pane:

View Dialer Data Services Health Information

To view dialer data services health:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager.

2. In the left pane under Dialer Services, click Data. Heath Manager displays the following 
information in the right pane:

CHILD Child process

ENFORCER Licensing Connection Point

Note:
Note: If the Enforcer feature is not 

available on the dialer, then the 
system disables the processes 
related to Enforcer and displays the 
status as Not Enabled.

Service Name Description

Service name Description

SWIF_CT Avaya CT communications service

SWIF_DGn Avaya PG230RM communications service (where n indicates 
the system number).

IVR_CONN Dialer to Avaya IR connector
Note: If the IVR feature is not available on dialer, then the 
system disables the processes related to IVR and displays 
the status as Not Enabled.

Service name Description

HDSC Historical data services client
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View Dialer Command Control and Administration Service Information

To view Dialer Command Control and Administration Service health:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager.

2. In the left pane under Dialer Services, click Dialer Command Control and Admin. Health 
Manager displays the following information in the right pane:

View Dialer Health Related Service Information

To view dialer health related services health:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager.

2. In the left pane under Dialer Services, click Health related. Health Manager displays the 
following information in the right pane:

View All the Dialer Services

To view all the dialer related services:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager.

2. In the left pane under Dialer Services, click All. Health Manager displays all the dialer 
services information in the right pane.

EVENT_SERVICE Dialer event services

DATA_MANAGER Historical data recorder

Service name Description

Service name Description

DCCS Dialer command and control service

Service name Description

DIALER_SA Dialer Activation Service

DIALER_SM Dialer Health Monitoring Service

DIALER_SH Dialer System Health Monitoring Service
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View Mid-Tier Services 
From the Mid-Tier Services view, you can choose to do the following:

● View Mid-Tier Framework Service Information on page 22

● View Mid-Tier Data Services Information on page 22

● View Mid-Tier Command Control and Administration Service Information on page 23

● View Mid-Tier Health Related Service Information on page 23

●  View All the Mid-Tier Services on page 24

Tip:
Tip: You can sort the information in the view by clicking the column headings. 

View Mid-Tier Framework Service Information

To view Mid-Tier framework services health:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager.

2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left 
pane changes to show Dialer Services with icons.

3. In the left pane, click Middle-Tier Services. The left pane changes to show Mid-Tier 
services with icons.

4. Click Framework. Health Manager displays the following information in the right pane:

View Mid-Tier Data Services Information

To view Mid-Tier data services health:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager.

2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left 
pane changes to show Dialer Services with icons.

3. In the left pane, click the Mid-Tier Services tab. The left pane changes to show Mid-Tier 
services with icons.

Service name Description

LOGGER Primary CORBA logging service

NAME_SERVICE CORBA naming service
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4. In the left pane under Mid-Tier Services, click Data. Health Manager displays the following 
information in the right pane:

View Mid-Tier Command Control and Administration Service Information

To view Mid-Tier command control and administration service health:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager.

2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left 
pane changes to show Dialer Services with icons.

3. In the left pane, click the Mid-Tier Services tab. The left pane changes to show Mid-Tier 
services with icons.

4. In the left pane under Mid-Tier Services, click Mid-Tier Command Control and Admin. 
Health Manager displays the following information in the right pane:

View Mid-Tier Health Related Service Information

To view Mid-Tier health related service health information:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager.

2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left 
pane changes to show Dialer Services with icons.

3. In the left pane, click the Mid-Tier Services tab. The left pane changes to show Mid-Tier 
services with icons.

Service name Description

DATA_PUMP Historical data database writer

STATS_PUMP Real-time statistics database writer

RT_DATA Real-Time Data Service

Service name Description

CCS Primary command and control service
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4. In the left pane under Mid-Tier Services, click Health related. Health Manager displays the 
following information in the right pane:

View All the Mid-Tier Services

To view all the dialer related services:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager.

2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left 
pane changes to show Dialer Services with icons.

3. In the left pane, click the Mid-Tier Services tab. The left pane changes to show Mid-Tier 
services with icons.

4. In the left pane under Mid-Tier Services, click All. Health Manager displays all the Mid-Tier 
services information in the right pane.

View System Status
From the System Status view, you can choose to do the following:

● View CPU Usage Statistics on page 24

● View Disk Usage Statistics on page 25

● View Memory Usage Statistics on page 26

● View Processes Statistics on page 27

Tip:
Tip: You can sort the information in the view by clicking the column headings. 

View CPU Usage Statistics

You can view the overall CPU usage and load of the selected dialer to monitor. This view allows 
you to detect where the system resources may be tied up serving a limited number of 
processes, while other critical processes are trying to run.

Service name Description

SERV_MON Primary Health Monitoring Service

SERV_ACT Primary Activation Service

SYS_HEALTH Primary System Health Monitoring service
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To view system status information on CPU usage:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager.

2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left 
pane changes to show Dialer Services with icons.

3. In the left pane, click the System Status tab. The left pane changes to show System 
Status with icons.

4. In the left pane under System Status, click CPU Usage. Health Manager displays the 
following information in the right pane:

View Disk Usage Statistics

To view system status information on disk usage:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager.

2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left 
pane changes to show Dialer Services with icons.

3. In the left pane, click the System Status tab. The left pane changes to show System 
Status with icons.

Status Item Name Description

% Block Stat Percentage of time spent in Blocked state

% Idle Stat Percentage of time spent in Idle state

% Nice Stat Percentage of time spent in Nice state

Speed (MHz) Speed of the system in megahertz

% System State Percentage of time spent in System state

% User State Percentage of time spent in User state

Load Avg 15 Min Processor load average during last fifteen minutes

Load Avg 5 Min Processor load average during last five minutes

Load Avg 1 Min Processor load average during last one minute
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4. In the left pane under System Status, click Disk Usage. Health Manager displays the 
following information in the right pane:

View Memory Usage Statistics

You can see overall memory usage of the system to determine how much real memory is being 
used and how much swapping is occurring on the selected system.

To view system status information on memory usage:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager.

2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left 
pane changes to show Dialer Services with icons.

3. In the left pane, click the System Status tab. The left pane changes to show System 
Status with icons.

4. In the left pane under System Status, click Memory Usage. Health Manager displays the 
following information in the right pane:

Status Item Name Description

File System Available 
Blocks (KBytes)

Space available on volume partition

File System Free Blocks 
(KBytes)

Free space available on volume partition

File System Name Disk volume partition name

File System % Used Percentage of used space on volume partition

File System Total Blocks 
(KBytes)

Space on volume partition

File System Used Blocks 
(KBytes)

Used space on volume partition

Status Item Name Description

Active Real Memory 
(KBytes)

Real memory used

Active Virtual Memory 
(KBytes)

Virtual memory used

Free Memory (KBytes) Free memory

Physical Memory RAM 
(MBytes)

Total random access memory (RAM)
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View Processes Statistics

To view system status information on processes:

1. Log in to Health Manager as administrator. For information on logging in, see Log In to 
Health Manager.

2. Select a dialer name from the drop-down list in the upper left corner of the screen. The left 
pane changes to show Dialer Services with icons.

3. In the left pane, click the System Status tab. The left pane changes to show System 
Status with icons.

4. In the left pane under System Status, click Processes. Health Manager displays the 
following information in the right pane:

View System Activity Events

Real Memory (KBytes) Real memory

Virtual Memory (KBytes) Virtual memory

%Memory Usage Percentage of memory used

Status Item Name Description

Status Item Name Description

Process Name Name of system process

Process ID ID for system process

User ID ID of user currently using process

% CPU Usage Percentage of time process used by the CPU since last 
update

Nice Value Nice value ranges from -20 to +20 specifying process priority

Priority Current process priority

Size (KBytes) Total virtual size of process

Resident set size for 
Process (KBytes)

Resident size of process

Time Number of system and CPU seconds that a process has 
consumed
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Use the Activity Event Viewer to see specific event activity which has occurred on the system. 
You can determine which service events appear in the viewer by subscribing to them. For more 
information see, Subscribe to Activity Events on page 28.

Tip:
Tip: The Activity Event Viewer lists the last 25 activity events. You can change the 

maximum number of events that Health Manager displays by choosing Tools > 
Options. The default is 25 events.

You can change the event threshold that triggers the system status events (CPU, 
memory, and disk usage) by choosing Tools > Options. For more information, see Set 
Threshold Parameters for System Status on page 34.

You can set the e-mail address to which you want the Health Manager to send activity 
event notifications by choosing Tools > Options.

If you unsubscribe to all the services, then you will only be notified when a service 
changes status. 

To view system events:

1. Click the Activity Event Viewer icon on the Health Manager toolbar. Health Manager 
displays the Activity Event Viewer dialog box. The viewer shows the following information 
for each event:

● Event name

● Date and time of the event

● Dialer name

● Dialer IP address

● Service name associated with the event

● Status of the event with detailed information

Note:
Note: DIALERSTATUS is an event, and not a service. Therefore, the value of the 

service name field for DIALER STATUS is displayed as 0.

2. Click Close to close the dialog box and return to the main Health Manager statistics view.

Subscribe to Activity Events
You can determine which service events appear in the Activity Event Viewer by subscribing to 
them. For more information about the Activity Event Viewer, see View System Activity Events on 
page 27.
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Tip:
Tip: The Activity Event Viewer lists the last 25 activity events. You can change the 

maximum number of events Health Manager display by choosing Tools > 
Options. The default is 25 events. 

You can change the event threshold that triggers the system status events (CPU, 
memory, and disk usage) by choosing Tools > Options. For more information, see 
Set Threshold Parameters for System Status on page 34.

You can set the e-mail address to which you want the Health Manager to send activity 
event notifications by choosing Tools > Options.

If you unsubscribe to all the services, then you will only be notified when a service 
changes status. 

To subscribe to activity events:

1. Click the Action menu, and then click Subscribe to Service Events.

2. In the Subscribe to Activity Events dialog box, click on the service to subscribe. Health 
Manager displays a description of each service that you select at the bottom. You can also 
use the Select All or Unselect All buttons to subscribe or unsubscribe to events.

3. Click OK.

When an event occurs, Health Manager displays the Activity Event Viewer. The viewer 
shows you the following information for each event:

● Date and time of the event

● Dialer name

● Dialer IP address

● Service name associated with the event

● Status of the event with detailed information

● Event name

4. Click Close to close the dialog box and return to the main Health Manager statistics view.

Save Data as HTML
Save Health Manager data to an HTML file for viewing in a browser.

To save data as HTML:

1. From the File menu, click Save as HTML.

2. In the Save As dialog box, type a file name.

3. Click Save.
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Chapter 4: Maintaining Health Manager

Avaya Outbound Contact Express supports only a subset of the features of Avaya Proactive 
Contact. For the list of features not supported in Avaya Outbound Contact Express, see 
Features not supported in Avaya Outbound Contact Express on page 35.

This section contains the following topics:

● Configure Health Manager on page 31

● Start and Stop the Health Bridge Service on page 32

● Set Threshold Parameters for System Status on page 34

● License Configurator on page 32

Configure Health Manager
Use the Avaya Outbound Contact Express Configurator to set the primary dialer and the license 
server details and location. Health Manager displays the Configurator dialog box when you log 
in to the Health Manager for the first time. You might need to contact your system administrator 
for the information.

To configure Health Manager:

1. Run the Health manager application as an Administrator user.

2. From the Tools menu, click Mid-Tier Configurator or click the Mid-Tier configurator icon on 
the Health Manager toolbar.

3. In the Configurator dialog box, enter the following information:

● Primary Avaya Outbound Contact Express Details:

- Name: Enter the name of the primary dialer

- IP Address: Enter the primary dialer IP address

● Email Server Details:

- Name: Enter the name of the e-mail server you want to use with Health Manager 
e-mail notifications

- IP Address: Enter the e-mail server IP address

● Database Server Details:

- Name: Enter the name of your database server

- IP Address: Enter the database server IP address
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4. Click OK to save your settings.

! Important:
Important: If you change the primary dialer specification, you must stop and then restart the 

Health Bridge service. For more information, see Start and Stop the Health 
Bridge Service on page 32.

License Configurator
License Configurator is used to provide the URL of the WebLM server which provides the 
license to the Avaya Outbound Contact Express.

Note:
Note: Only Lead administrator and the default Tenant user can use this feature, not the 

Tenant user.

To change the License server URL:

1. From the Tools menu, click License Configurator.
2. In the License Configurator dialog box, specify the URL of the WebLM server which has the 

Avaya Outbound Contact Express license.

3. Click OK.

Start and Stop the Health Bridge Service
Avaya Outbound Contact Express Health Bridge is a service that provides information about 
Avaya Outbound Contact Express systems to Health Manager. This information includes the 
status of the services on the Dialing Servers, system health (CPU, disk, memory, and 
processes), and also includes the ability to activate and deactivate services.

The Health Bridge also reports on services and system functioning that may be hampered and 
may be down to Health Manager.

Note:
Note: The physical location of Health Bridge is in %PDSServices% directory in the C:\

Program Files\Avaya\Proactive Contact 5.1 \Services\Common directory. 
This location is the default location.

The Health Bridge can be in one of two states: stopped or started. Additionally, the system 
provides two intermediate states for Health Bridge: starting and stopping.
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! Important:
Important: You do not have to manually start Health Bridge. When you start Health Manager, 

Health Bridge starts automatically. 

You typically do this when you make configuration changes in Health Manager in the 
Configurator dialog box. For more information on the Configurator, see Configure Health 
Manager on page 31. 

! Important:
Important: Any changes made to the configuration require that you stop and then start the 

Health Bridge using one of the three methods described as follows.

You can start or stop Health Bridge services in any of the following three ways:

From the Microsoft® Management Console - 
To start or stop Health Bridge from the Microsoft Management Console:

1. From the Start menu, select Control Panel > Administrative Tools > Services. 

The system displays the Microsoft Management Console Services window with a list of 
services in the right pane.

2. Right-click the Health Bridge, then click Properties.

The system displays the Health Bridge properties dialog box.

3. Press Stop under Service status to stop Health Bridge.

4. Press Start under Service status to start Health Bridge.

From the Command Prompt - 
To start or stop Health Bridge from the command prompt:

1. From the Start menu, select All Programs > Accessories > Command Prompt. 
2. Type net stop HealthBridge at the prompt and press Enter.
3. Type net start HealthBridge at the prompt and press Enter.

From the Microsoft® Windows Task Manager - 
To stop Health Bridge from the Task Manager: 

1. Press Ctrl+Alt+Delete. 

2. Click Task Manager.
3. Click on the Process tab.

4. Locate HealthBridge.exe in the processes list.

5. Select HealthBridge.exe and click End Process.
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To start Health Bridge from Task Manager:

1. Press Ctrl+Alt+Delete.

2. Click Task Manager.
3. On the menu bar, click on File, and then click New Task (Run...).
4. In the Create New Task window, type HealthBridge.exe.

5. Click OK.

Set Threshold Parameters for System Status
Note:

Note: Only Lead administrator and the default Tenant user can use this feature, not the 
Tenant user.

You can change the thresholds that trigger activity events that appear in the Activity Event 
Viewer or that are sent in an e-mail to you.

Tip:
Tip: The Activity Event Viewer lists the last 25 activity events. You can change the 

maximum number of events that Health Manager displays by choosing Tools > 
Options. The default is 25 events. 

You can set the e-mail address to which you want Health Manager to send activity 
event notifications by choosing Tools > Options.

If you unsubscribe to all the services, then you will only be notified when a service 
changes status. 

For more information, see Subscribe to Activity Events on page 28.

To set activity event thresholds:

1. From the Tools menu, click Options.

2. Under System Parameter Settings, type a percentage for each of the following 
parameters:

● CPU threshold

● Memory usage

● Disk partition usage

The default percentage is 80%.
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