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Notice 

While reasonable efforts have been made to 
ensure that the information in this document 
is complete and accurate at the time of 
printing, Avaya assumes no liability for any 
errors. Avaya reserves the right to make 
changes and corrections to the information in 
this document without the obligation to notify 
any person or organization of such changes. 

Documentation disclaimer 

“Documentation” means information 
published by Avaya in varying mediums which 
may include product information, operating 
instructions and performance specifications 
that Avaya generally makes available to users 
of its products and Hosted Services. 
Documentation does not include marketing 
materials. Avaya shall not be responsible for 
any modifications, additions, or deletions to 
the original published version of 
documentation unless such modifications, 
additions, or deletions were performed by 
Avaya. End User agrees to indemnify and hold 
harmless Avaya, Avaya's agents, servants and 
employees against all claims, lawsuits, 
demands and judgments arising out of, or in 
connection with, subsequent modifications, 
additions or deletions to this documentation, 
to the extent made by End User. 

Link disclaimer 

Avaya is not responsible for the contents or 
reliability of any linked websites referenced 
within this site or documentation provided by 
Avaya. Avaya is not responsible for the 
accuracy of any information, statement or 
content provided on these sites and does not 
necessarily endorse the products, services, or 
information described or offered within them. 
Avaya does not guarantee that these links will 
work all the time and has no control over the 
availability of the linked pages. 

Warranty 

Avaya provides a limited warranty on its 
hardware and Software (“Product(s)”). Refer 
to your sales agreement to establish the 
terms of the limited warranty. In addition, 
Avaya’s standard warranty language, as well 
as information regarding support for this 
Product while under warranty is available to 
Avaya customers and other parties through 
the Avaya Support website: 
http://www.avaya.com/support 

Please note that if you acquired the 
Product(s) from an authorized Avaya reseller 
outside of the United States and Canada, the 
warranty is provided to you by said Avaya 
reseller and not by Avaya. “Software” means 
computer programs in object code, provided 
by Avaya or an authorized Avaya reseller, 
whether as stand‐alone products or pre‐
installed on hardware products, and any 
upgrades, updates, bug fixes, or modified 
versions thereto.  Hosted Service means a 
hosted service subscription that you acquire 
from either Avaya or an authorized Avaya 
reseller (as applicable) and which is described 
further in Hosted SAS or other service 
description documentation regarding the 
applicable hosted service.  If you purchase a 
Hosted Service subscription, the foregoing 
limited warranty may not apply but you may 
be entitled to support services in connection 
with the Hosted Service as described further 
in your service description documents for the 
applicable Hosted Service.  Contact Avaya or 
authorized Avaya reseller (as applicable) for 
more information.   

Hosted Service 

The following applies if you purchase a Hosted 
Service subscription from Avaya or an 
authorized Avaya reseller (as applicable), THE 
TERMS OF USE FOR HOSTED SERVICES ARE 
AVAILABLE ON THE AVAYA WEBSITE, 
http://support.avaya.com/LicenseInfo/ 
(“TERMS OF USE”), AND ARE APPLICABLE TO 
ANYONE WHO ACCESSES OR USES THE 
HOSTED SERVICE. BY ACCESSING OR USING 
THE HOSTED SERVICE, OR AUTHORIZING 
OTHERS TO DO SO, YOU, ON BEHALF OF 
YOURSELF AND THE ENTITY FOR WHOM YOU 
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ARE DOING SO (HEREINAFTER REFERRED TO 
INTERCHANGEABLY AS “YOU” AND “END 
USER”), AGREE TO THE TERMS OF USE.  IF 
YOU ARE ACCEPTING THE TERMS OF USE ON 
BEHALF A COMPANY OR OTHER LEGAL 
ENTITY, YOU REPRESENT THAT YOU HAVE THE 
AUTHORITY TO BIND SUCH ENTITY TO THESE 
TERMS OF USE.  IF YOU DO NOT HAVE SUCH 
AUTHORITY, OR IF YOU DO NOT WISH TO 
ACCEPT THESE TERMS OF USE, YOU MUST 
NOT ACCESS OR USE THE HOSTED SERVICE OR 
AUTHORIZE ANYONE TO ACCESS OR USE THE 
HOSTED SERVICE. YOUR USE OF THE HOSTED 
SERVICE SHALL BE LIMITED BY THE NUMBER 
AND TYPE OF LICENSES PURCHASED UNDER 
YOUR CONTRACT FOR THE HOSTED SERVICE, 
PROVIDED, HOWEVER, THAT FOR CERTAIN 
HOSTED SERVICES IF APPLICABLE, YOU MAY 
HAVE THE OPPORTUNITY TO USE FLEX 
LICENSES, WHICH WILL BE INVOICED 
ACCORDING TO ACTUAL USAGE ABOVE THE 
CONTRACT LICENSE LEVEL. CONTACT AVAYA 
OR AVAYA’S AUTHORIZED RESELLER FOR 
MORE INFORMATION ABOUT THE LICENSES 
FOR THE APPLICABLE HOSTED SERVICE, THE 
AVAILABILITY OF ANY FLEX LICENSES (IF 
APPLICABLE), PRICING AND BILLING 
INFORMATION, ANY MINIMUM LICENSE 
COMMITMENTS (IF APPLICABLE), AND OTHER 
IMPORTANT INFORMATION REGARDING THE 
HOSTED SERVICE. 

Copyright 

Except where expressly stated otherwise, no 
use should be made of materials on this site, 
the Documentation, Software, Hosted Service, 
or hardware provided by Avaya. All content 
on this site, the documentation, Hosted 
Service, and the Product provided by Avaya 
including the selection, arrangement and 
design of the content is owned either by 
Avaya or its licensors and is protected by 
copyright and other intellectual property laws 
including the sui generis rights relating to the 
protection of databases. You may not modify, 
copy, reproduce, republish, upload, post, 
transmit or distribute in any way any content, 
in whole or in part, including any code and 
software unless expressly authorized by 

Avaya. Unauthorized reproduction, 
transmission, dissemination, storage, and or 
use without the express written consent of 
Avaya can be a criminal, as well as a civil 
offense under the applicable law. 

Third Party Components  

“Third Party Components” mean certain 
software programs or portions thereof 
included in the Software   or Hosted Service 
which may contain software (including open 
source software) distributed under third party 
agreements (“Third Party Components”), 
which contain terms regarding the rights to 
use certain portions of the Software (“Third 
Party Terms”). As required, information 
regarding distributed Linux OS source code 
(for those Products that have distributed 
Linux OS source code) and identifying the 
copyright holders of the Third Party 
Components and the Third Party Terms that 
apply is available in the Documentation or on 
Avaya’s website at: 
http://support.avaya.com/Copyright. You 
agree to the Third Party Terms for any such 
Third Party Components. 

Preventing Toll Fraud 

“Toll Fraud” is the unauthorized use of your 
telecommunications system by an 
unauthorized party (for example, a person 
who is not a corporate employee, agent, 
subcontractor, or is not working on your 
company's behalf). Be aware that there can 
be a risk of Toll Fraud associated with your 
system and that, if Toll Fraud occurs, it can 
result in substantial additional charges for 
your telecommunications services. 

Avaya Toll Fraud intervention 

If you suspect that you are being victimized by 
Toll Fraud and you need technical assistance 
or support, call Technical Service Center Toll 
Fraud Intervention Hotline at +1‐800‐643‐
2353 for the United States and Canada. For 
additional support telephone numbers, see 
the Avaya Support website: 
http://support.avaya.com. Suspected security 
vulnerabilities with Avaya products should be 
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reported to Avaya by sending mail to: 
securityalerts@avaya.com. 

Trademarks 

The trademarks, logos and service marks 
(“Marks”) displayed in this site, the 
Documentation, Hosted Service(s), and 
Product(s) provided by Avaya are the 
registered or unregistered Marks of Avaya, its 
affiliates, or other third parties. Users are not 
permitted to use such Marks without prior 
written consent from Avaya or such third 
party which may own the Mark. Nothing 
contained in this site, the Documentation, 
Hosted Service(s) and Product(s) should be 
construed as granting, by implication, 
estoppel, or otherwise, any license or right in 
and to the Marks without the express written 
permission of Avaya or the applicable third 
party. 

Avaya is a registered trademark of Avaya Inc. 

All non‐Avaya trademarks are the property of 
their respective owners. 

Linux® is the registered trademark of Linus 
Torvalds in the U.S. and other countries. 

Downloading Documentation 

For the most current versions of 
Documentation, see the Avaya Support 
website: http://support.avaya.com. 

Contact Avaya Support 

See the Avaya Support website: 
http://support.avaya.com for Product or 
Hosted Service notices and articles, or to 
report a problem with your Avaya Product or 
Hosted Service. For a list of support telephone 
numbers and contact addresses, go to the 
Avaya Support website: 
http://support.avaya.com, scroll to the 
bottom of the page, and select Contact Avaya 
Support. 
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Chapter 1: Introduction 

Purpose 
This document describes how to set up the system for chat conversations 
between agents and visitors and script, test, approve, and deploy knowledge for 
the automated engine. 

Intended audience 
This document is for users of Automated Chat Management Interface who want to 
know how to start the Avaya Automated Chat system after the deployment 
installation. 

Related resources 
 

Documentation 

The following table lists the documents related to Avaya Automated Chat 2.0. 
Download the documents from the Avaya Support website 
at http://support.avaya.com. 

Title Description Audience 

Maintaining and 
Troubleshooting 
Avaya Automated 
Chat 

Provides maintenance and 
troubleshooting procedures of 
Avaya Automated Chat. 
 

• Sales engineers 
• BusinessPartners 
• Implementation 

engineers 

Upgrading Avaya 
Automated Chat 

Provides the sequence to 
upgrade Avaya Automated Chat. 

• Sales engineers 
• BusinessPartners 
• Implementation 

engineers 
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http://support.avaya.com/


Title Description Audience 

Using Avaya 
Automated Chat  

Provides the procedures to use 
Avaya Automated Chat. 

• Customers 
• Sales engineers 
• BusinessPartners 
• Implementation 

engineers 

Avaya Automated 
Chat Reference 
Manual 

Provides the procedures to use 
Avaya Automated Chat in an 
online format. 

• Customers 
• Sales engineers 
• BusinessPartners 
• Implementation 

engineers 

Installing Avaya 
Automated Chat 
 

Provides installation instructions 
to install Avaya Automated Chat. 
 

• Sales engineers 
• Business Partners 
• Implementation 

engineers 

Support 

Go to the Avaya Support website at http://support.avaya.com for the most up-to-
date documentation, product notices, and knowledge articles. You can also 
search for notices, release notes, downloads, user guides, and resolutions to 
issues. Use the Web service request system to create a service request. Chat 
with live agents to get answers to questions. If an issue requires additional 
expertise, agents can quickly connect you to a support team. 
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Chapter 2: Automated Chat 
Management Interface overview 

Avaya offers Avaya Automated Chat in a Software as a Service (SaaS) model. In this model, 
enterprises gain access only to the interfaces, and as the SaaS provider, Avaya centrally 
deploys and manages all components. 

The Automated Chat Management Interface application combines natural language, artificial 
intelligence, and intelligent algorithms to create a Q & A self-help application. The application 
integrates automatic conversation and live chat into a superior customer experience. 
Automated Chat Management Interface publishes the files in a format that the Conversation 
Engine uses to deploy Avaya Automated Chat. 

The following diagram shows an overview of the process flow. You might follow the process 
flow while creating a project, getting the project ready for deployment, and setting up sites 
for visitors and agents. 
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Chapter 3: Setup and scripting 

To install and script a project in Automated Chat Management Interface, you must perform 
the procedures described in this chapter. Start by creating user accounts with roles, and 
then create files and define conversational scripts. You must also create a branch label, 
configure a conversation engine, and then create the chat site. 

After you test and deploy the project, agents can chat with site visitors. 

Create users and assigning roles overview 
When you install Automated Chat Management Interface, you will have one super 
user installed with the name install. You can create following types of users: 

● Admin: Administrators create and manage user accounts, project 
branches, branch labels, chat engines and sites, and perform additional 
tasks using Automated Chat Management Interface. 

An administrator can be a super user or a user that you create using the 
administrator access while installing Automated Chat Management 
Interface. 

● Agent: Agents chat with visitors to specific sites, view chat logs, and run 
chat reports. 

● Supervisor: Supervisors manage agents, monitor agent chats, view chat 
logs, and run reports. The reports include analysis of agent activity, 
statistics and trends for the client, and tools for managing and improving 
automated features. 

● Knowledge Manager: Knowledge Managers create and manage the 
scripting rules for a visitor chat system for specific project branches. 

● AnswerDesk User: Phone agents join conversations with online agents, 
ask the automated engine questions, and perform external searches. 

After you log in to Automated Chat Management Interface: 

● Create one or more users with the appropriate log in access to log in to 
Automated Chat Management Interface. 

● Change the temporary password of the super user account that you 
created while installing Avaya Automated Chat. 
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Creating a new user 
Before you begin 

Get the credentials to log in to Automated Chat Management Interface as an 
administrator. 

About this task 

Create one or more respective users with the required class. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Administer > Users. 

Automated Chat Management Interface displays the administer users 
page. 

3. Click Add new User ( ) next to the Users list. 

Automated Chat Management Interface displays a New User dialog box 
for entering the user information. 

4. In the New User dialog box, enter the details in the following fields: 

● User Name: Enter a unique user name. After you create a user, you 
cannot change the user name later. 

● Chat Display Name: Enter the chat display name. This name 
appears when the user is chatting with any other user or site visitor.  

The chat display name can be the same as the user name or can be 
different from the user name. 

● Email: Enter a valid email address for the user. Avaya Automated 
Chat uses the email address to send password retrieval emails to 
users who forget or lose the passwords. 

● Password and Confirm Password: Enter the password and reenter 
the password. You can change the password later. 

5. Click Create. 

6. In the User Details section, enter the details in the following fields: 

● Chat Display Name: Displays the name that you have entered in the 
New User dialog box. You can modify this name. 

● Email: Displays the email address of the user. You can modify this 
email address. 

● User Classes: Select the required User Classes for the user. You 
can select multiple roles for the user. 
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● Use Override: Select this field to display the Max Chats Override 
field. 

○ Max Chats Override: Set the maximum number of concurrent 
chat conversations for the user by overriding the default value. 

To set the maximum number of concurrent chat conversations for 
all users, set the Default Max Chats field on the Account Details 
page. 

7. (Optional) If you selected Agent class access, in the Sites for User 
section, edit the sites for the branches that the user needs access to. 

8. (Optional) If you selected Knowledge Manager class access, in the 
Branch Details section, edit the specific Role Name for the branches that 
the user needs access to. 

9. Click Save. 

Editing branch details 
Before you begin 

Ensure that the user has Knowledge Manager class access. 

About this task 

Assign specific roles to a Knowledge Manager for each project branch so that the 
Knowledge Manager can gain access to the script. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Administer > Users. 

Automated Chat Management Interface displays the administer users 
page. 

3. In the Users list, click the user name to change the branch details of a 
user. 

In the User Details section, if the user has Knowledge Manager class 
access, Automated Chat Management Interface displays the Branch 
Details section. 

4. In the Branch Details section, enter the specific Role Name for the 
branches that you must provide access to the user. 

5. Click Save. 
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Editing sites for agent 
Before you begin 

Get the administrator credentials to log in to Automated Chat Management 
Interface as an administrator. 

About this task 

Assign an agent role to a user to provide access to specific chat sites. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Administer > Users. 

Automated Chat Management Interface displays the administer users 
page. 

3. In the Users list, click the user name to change the site access of a user. 

Automated Chat Management Interface displays the User Details section. 

If the user has Agent class access, Automated Chat Management 
Interface displays the Sites for User section. 

4. In the Sites for User section, select the sites for the project branches that 
you must provide access to the user. 

Note: A chat site is visible in the Sites for User list after the administrator 
defines the site access in Automated Chat Management Interface. 

5. Click Save. 

Results 

Agents can sign in to Automated Chat Management Interface and chat with 
visitors in the selected sites. 

Changing a password 
Before you begin 

Get the administrator credentials to log in to Automated Chat Management 
Interface as an administrator. 

About this task 

Use this procedure to change the password of a user. 
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Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Administer > Users. 

Automated Chat Management Interface displays the administer users 
page. 

3. In the Users list, click the user name to change the password of a user. 

Automated Chat Management Interface displays the User Details section. 

4. In the User Details section, click the Change Password link. 

Automated Chat Management Interface displays the Change Password 
dialog box. 

5. In the New Password field, type a new password. 

6. In the Confirm New Password field, reenter the same password. 

7. Click Change Password. 

The system saves the new password for this user account. You can notify 
the user about the new password. 

Creating a project 
Before you begin 

Get the administrator credentials to log in to Automated Chat Management 
Interface as an administrator. 

About this task 

To create a new chat system, you must first create a project in Automated Chat 
Management Interface. After you script the project, get the approval from the 
approval group, and then deploy the project for a visitor to gain access to the chat 
site. 

Use this procedure to create a new project in Automated Chat Management 
Interface. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Administer > Project Branches. 

Automated Chat Management Interface displays the administer project 
branches page. 

3. Click the New Project link at the top of the project list. 

Automated Chat Management Interface displays a new window. 
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4. In the Project field, type the new project name. 

5. Click Create New Project. 

Automated Chat Management Interface displays the new project name 
and details in the Project list. 

Create project files 
You can create different types of project files in a project branch. The AnswerBase 
file is the primary file in a project for defining conversational rules. The different 
project files are: 

● AnswerBases: Contain the conversational rules. The system uses the 
rules to process the questions that the visitors type in the automated chat 
system. You can create a new AnswerBase on the Administer Account 
Files page, or add an AnswerBase to a project. 

If you do not include any AnswerBases in the project, the AnswerBases do 
not appear in the File menu. 

● Procedures: Help you to gather specific information from the front-end 
user, such as data for a form and when you must present a sequence of 
information to the user. Procedures are different from user-directed 
conversations, which the inputs and outputs of your AnswerBase rules 
handle. 

● Synonym Sets: Help the engine to match variations of the Input text to a 
rule without requiring you to write additional inputs to handle words with 
similar meanings. 

● Code Modules: Contain computer programming methods. You can use 
code modules to organize methods into groups that the conversational 
rules and different project branches can process. 

● Points Tables: Apply to every rule and AnswerBase in the project. The 
point value that the engine assigns to a word depends on the importance 
of the word to all AnswerBases in that project. 

● Data Types: Provide you the option to store and organize information that 
you want to gain access to the conversational rules. Each data type object 
defines one or more columns or attributes and enables you to assign 
values to each column. 

● Replacement Profiles: Provide a way to replace input text that a front-end 
user enters or to replace output text that the text-to-speech program 
generates. 

For more information about the project files, see Automated Chat Management 
Interface Reference Manual. 
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Creating an AnswerBase file 
Before you begin 

Get the administrator credentials to log in to Automated Chat Management 
Interface as an administrator. 

About this task 

Create an AnswerBase file to define the rules and conversational inputs and 
outputs that the knowledge manager uses to automate a chat system for site 
visitors. 

You can add an AnswerBase file in multiple projects and edit the file separately for 
each project. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Administer > Account Files. 

Automated Chat Management Interface displays the administer account 
files page. 

3. In the Account File field, click the drop-down arrow and select 
AnswerBases. 

Automated Chat Management Interface displays the AnswerBase list. 

4. Click the New AnswerBase link at the top of the AnswerBase list. 

Automated Chat Management Interface displays a new window to create 
a new AnswerBase file. 

5. In the AnswerBase field, type the name of the new AnswerBase file. 

6. Click Create AnswerBase. 

Results 

Automated Chat Management Interface creates and displays the new 
AnswerBase file alphabetically in the list of AnswerBase files. 

To include the AnswerBase file in the project, you must add the AnswerBase file 
to a project. 

Next steps 

Assign the AnswerBase file to a project. 
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Add files to a project 
For a new project, the File menu only shows the Project Alias and Shortcut 
options. As you create project files and add files to the project, the File menu 
expands to provide you access to these files. 

Avaya Automated Chat groups the new files according to the following file types:  

AnswerBases, Procedures, Synonym Sets, Code Modules, Data Types, Points 
Tables, Replacement Profiles, Variables, and Cue Cards. 

Assigning the AnswerBase file to a 
project 

Before you begin 

Get the knowledge manager credentials to log in to Automated Chat Management 
Interface. 

Create the AnswerBase file. 

About this task 

Assign the AnswerBase file to a project to make the file available to the project. 

Procedure 

1. Log in to Automated Chat Management Interface as a knowledge 
manager. 

2. Click Automate > Script. 

Automated Chat Management Interface displays the Script page. 

3. Click the project branch menu ( ) and select an existing project from the 
list of projects. 

4. Click the select file menu ( ). 

Automated Chat Management Interface displays the list of files and links 
to Project Aliases, Shortcuts, Variables, Cue Cards, and Project 
Details. 

5. Click Project Details from the menu. 

Automated Chat Management Interface displays the following sections 
related to the project. 

 
Getting Started with Avaya Automated Chat 2.0     Comments? infodev@avaya.com       August 2013 
 

17 



 

● Minimum Percent To Match: Specifies the visitor input must match 
the Input words of a rule. This field is auto-populated with the default 
setting of 0.95. 

● Language: Assign and deploy a spell-checking dictionary for the 
front-end users of the project. 

● AnswerBases: List of the AnswerBase files that exist in Automated 
Chat Management Interface. 

● Procedures: List of the procedures files that exist in Automated 
Chat Management Interface. 

● Synonym Sets: List of the synonym sets files that exist in 
Automated Chat Management Interface. 

● Code Modules: List of the code modules files that exist in 
Automated Chat Management Interface. 

● Points Table: List of the points table files that exist in Automated 
Chat Management Interface. 

● Data Types: List of the data types files that exist in Automated Chat 
Management Interface. 

● Replacement Profiles: List of the replacement profiles files that 
exist in Automated Chat Management Interface. 

6. Click the AnswerBases section to view the list of AnswerBase files that 
exist in Automated Chat Management Interface. 

7. Select the AnswerBase files that you must include as part of the project. 

You can clear any of the previous selected AnswerBase files to exclude 
the file from the project. 

8. Click Update. 

Result 

Automated Chat Management Interface updates the project with the new file. If 
you clear any of the files in Step 7, the system removes the file from the project. 

You can see the newly included file in the select file menu ( ) on the Script 
page. 

Automated Chat Management Interface also displays an asterisk next to the 
project name on the Script page to indicate that the project has uncommitted 
changes. To commit the changes, see Commit the changes on page 31. 
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Define conversational scripts in the project 
Create topics and rules in the AnswerBase files to handle conversations with the 
visitors of a chat system. Topics are group of related rules. Rules are a collection 
of inputs to test against a visitor type. You must pair the inputs with one or more 
outputs to display to the visitor if the input matches. 

Opening an AnswerBase file 
Before you begin 

Get the knowledge manager credentials to log in to Automated Chat Management 
Interface. 

About this task 

Open the AnswerBase file that you assigned to a specific project. 

Procedure 

1. Log in to Automated Chat Management Interface as a knowledge 
manager. 

2. Click Automate > Script. 

Automated Chat Management Interface displays the Script page. 

3. Click the project branch menu ( ) and select the project that contains 
the AnswerBase file. 

4. Click the select file menu ( ) and select the AnswerBase file that you 
must edit. 

Result 

Automated Chat Management Interface displays the Topics list. In this window, 
you can create topics, rules, and inputs and outputs, to script automated 
conversations with visitors. 

Next steps 

Add a topic in an AnswerBase file. 
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Adding a topic in an AnswerBase file 
Before you begin 

Open the AnswerBase file to which you must add the topic and rules. 

About this task 

Add a topic in an AnswerBase file to group related rules. You must add at least a 
topic. 

Procedure 

1. In the Topics section, click Add new topic ( ). 

2. In the text field, type the name of the new topic. 

3. Click Add Category ( ) to save the new topic name. 

Automated Chat Management Interface saves the new topic in the 
AnswerBase file and displays the new topic in the Topics section. 

Next steps 

Add a rule in a topic. 

Adding a rule in a topic 
Before you begin 

Open the AnswerBase file and add a topic. 

About this task 

Rules are the key building blocks of a conversational process with the visitor. 

Rules are a collection of inputs to test against visitor text, paired with an output to 
display to the visitor if the system matches the inputs with the visitor text. 

You can define a child rule for a parent rule to handle specific responses when the 
parent rule matches the child rule. 

Procedure 

1. Click the topic for which you must add rules. 

2. In the Rules text field, type the name of the new rule. 

Note 
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If the Rules text field is not visible, click Add new rule ( ) next to 
Rules. Type the name of the new rule in the text field. 

3. Click Add Rule ( ) to save the new rule name. 

Automated Chat Management Interface saves the new rule in the current 
topic and displays the new rule in the Rules section.  

Result 

For the new rule, Automated Chat Management Interface opens the Inputs and 
Outputs section. 

You must define a default rule for each project to process any input from the 
visitor that does not match any other specific rule. For information about how to 
define a default rule, see Automated Chat Management Interface Reference 
Manual. 

Next steps 

Add an input in a rule. 

Adding an input in a rule 
Before you begin 

Open the AnswerBase file, and add a topic in a rule. 

About this task 

Inputs for a rule describe what text from a visitor matches the rule. You can add 
multiple inputs for a single rule so that the engine can match with greater 
accuracy. 

Procedure 

1. In the Inputs text field, type the input for the newly created rule. 

Note: 

If the Inputs text field is not visible, click Add new input ( ) next to 
Inputs. Type the name of the input in the text field. 

2. Click Add Input ( ) to save the new input name. 

Automated Chat Management Interface saves the new input in the current 
rule and displays the new input name in the Inputs list. 

3. In the Inputs list, click the input to add Input Details. 

4. In the Input Details section, enter the details in the following fields: 
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● Input: Do not change the displayed input name. If you change the 
name and click Save, the system displays the changed input name 
in the Inputs list. 

● Synonyms: Include synonyms that control whether an input 
matches the visitor text.  

For more information about synonyms, see Automated Chat 
Management Interface Reference Manual. 

● Condition: Include conditions that control whether an input matches 
the visitor text. 

For more information about condition, see Automated Chat 
Management Interface Reference Manual. 

Next steps 

Add an output in a rule. 

Adding an output in a rule 
Before you begin 

Open the AnswerBase file and add a topic, a rule, and an input. 

About this task 

Outputs of a rule define the exact text or other information that the system 
displays to a visitor based on the input that the visitor submits. 

Procedure 

1. In the Outputs text field, type the output for the newly created rule. 

Note:  

If the Outputs text field is not visible, click Add new output ( ) next 
to Outputs. Type the name of the output in the text field. 

2. Click Add Output ( ) to save the new output name. 

Automated Chat Management Interface saves the new output in the 
current rule and displays the output name in the Outputs list. 

3. In the Outputs list, click the output to add Output Details. 

4. In the Output Details section, enter the details in the following fields: 

● Output: Do not change the displayed output name. If you change 
the name and click Save, the system displays the changed output 
name in the Outputs list 
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● Condition: Include conditions that control what output the system 
must display to the visitor. 

For more information about conditions, see Automated Chat 
Management Interface Reference Manual. 

● External Commands: Include external commands to specify the 
action that the system performs when the system displays an output 
to the visitor. 

For more information about external commands, see Automated 
Chat Management Interface Reference Manual. 

Branch label 
A branch label always points to the most recent version of the project and you can 
use the branch label to deploy projects to the chat site. You can also use a branch 
label to update only the required setting files instead of updating all setting files 
each time. 

To create project branches, approvals, and deployments: 

● Create a project branch label and point the project branch to a project. 

● Create an approval branch before deploying the branch to production. 

● Change the branch label to use Latest Approved Sub Branch. 

● Deploy the branch through the branch label. 

● Create a new approval branch and continue deploying the same branch 
label for each subsequent deployment to production. 

Creating a branch label 
Before you begin 

Get the administrator credentials to log in to Automated Chat Management 
Interface. 

About this task 

Use this procedure to create a branch label of a project. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Administer > Branch Labels. 
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Automated Chat Management Interface displays the administer branch 
labels page. 

3. In the Labels text field, type the name of the label for the newly created 
project. 

Note:  

If the Labels text field is not visible, click Add new Label ( ) next to 
Labels. Type the name of the label in the text field. 

4. Click Add Label ( ) to save the new label name. 

Automated Chat Management Interface saves the new label and displays 
the new name of the label in the Labels list. 

In the center and right panes, Automated Chat Management Interface 
also displays the related settings to define the new branch label. 

5. In the center pane, enter the details in the following fields: 

a. Name: Do not change the displayed label name. If you change 
the name and click Save, the system displays the changed label 
name in the Labels list. 

b. Branch: Click the required project branch from the drop-down list. 

Automated Chat Management Interface associates the selected 
label to the specific branch. 

c. Use latest approved sub-branch: Select this check box and use 
approval branches for each new set of changes to deploy. 
Because a scripter might not need to select this check box to 
simplify the scripting and deployment process. 

6. In the Users that can Deploy section, select the users who can deploy 
the branch associated to this label. 

7. Click Save. 

Conversation engine 
A chat engine configuration defines a conversation engine that provides 
automated chat answers directly to visitors and offers real-time suggested 
answers for chat agents. 
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Creating a conversation engine 
Before you begin 

Get the administrator credentials to log in to Automated Chat Management 
Interface. 

About this task 

Use this procedure to create a conversation engine for a project. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Administer > Engine Configs. 

Automated Chat Management Interface displays the administer engine 
configs page. 

3. In the Engine Name text field, type the new engine name. 

Note:  

If the Engine Name text field is not visible, click Add new Engine ( ) 
next to Engine Name. Type the new name of the engine in the text field. 

4. Click Add Engine ( ) to save the new engine name. 

Automated Chat Management Interface saves the new engine name and 
displays the new engine name in the Engine Name list. 

Automated Chat Management Interface also displays the Conversation 
Engine Settings and the Backend Rule Search Settings sections to 
define the new engine. 

5. In the Conversation Engine Settings section, enter the details in the 
following fields: 

a. Name: Do not change the displayed conversation engine name. If 
you change the name and click Save, the system displays the 
changed conversation engine name in the Engine Name list. 

b. Base URL: Define the server location where you installed the 
conversation engine. The standard format is: 
http://<servername>/enginepost/. 

If you installed the conversation engine and Automated Chat 
Management Interface on the same server, the Base URL is: 
http://localhost/enginepost. 

c. Label: Click the required branch label from the drop-down list. 
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d. Min Autosend CF: Specify the minimum Confidence Factor (CF). 
If the CF value is less than the specified value, the conversation 
engine does not send an automatic response but provides a 
suggestion to the live chat Agent. The default value is 0.8. 

e. Min Suggestion CF: Specify the minimum Confidence Factor. If 
the CF value is less than the specified value, the conversation 
engine does not send an automatic response but provides a 
suggestion to the live chat Agent. The default value is 0.5. 

6. In the Backend Rule Search Settings section, do not change the values 
of the fields. If you must select Rule Search, see Enabling Rule Search on 
page 39 . 

7. Click Save. 

Chat site 
After you define an engine configuration, you must create a site. A site defines 
which engine configuration the front end must use when interacting with either the 
automated agent or when assigning a visitor to a live agent. You can assign live 
agents to various sites. 

Creating a chat site 
Before you begin 

Get the administrator credentials to log in to Automated Chat Management 
Interface. 

About this task 

An administrator can assign an engine to the site, assign users to the site, and 
assign optional external search engines. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Administer > Sites. 

Automated Chat Management Interface displays the administer sites 
page. 

3. In the Sites text field, type the name of the new chat site. 

Note:  

If the Sites text field is not visible, click Add new Site ( ) next to 
Sites. Type the new name of the chat site in the text field. 
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4. Click Add Site ( ) to save the new chat site. 

Automated Chat Management Interface saves the new chat site and 
displays the new chat site in the Sites list. 

Automated Chat Management Interface also displays the Details, 
Agents, External Search Engines, and Message Masks sections to 
define the new chat site. 

5. In the Details section, enter the details in the following fields: 

a. Site Name: Do not change the display name of the chat site. If 
you change the name and click Save, the system displays the 
changed site name in the Sites list. 

b. Conversation Engine: Click the required conversation engine 
that you must associate with this chat site from the drop-down list. 

For information about how to create a conversation engine, 
see Creating a conversation engine on page 25. 

c. Site Code: Read-only field. A site code is a unique identifier. The 
system uses the site code for the frontend interface to identify the 
engine configuration the system must use. 

The system also uses the site code dynamically within an 
answerbase to reassign the current interaction to a new engine 
configuration. 

d. AnswerDesk Site: Specify the site as an AnswerDesk site. The 
site is found as a list when an agent logs in to the AnswerDesk 
system. 

e. Agent Survey: Assign a survey that appears to agents chatting in 
this site. 

f. Description: (Optional) Type comments to provide information 
about the new chat site. 

6. In the Agents section, select Select All to assign all agents to the chat 
site. You can also select individual agents from the list. 

Only the selected agents receive visitor chats from this chat site. 

7. In the External Search Engines section, select the external search 
engines sites if you must allow agents to perform external website 
searches to get answers for questions of visitors.  

For information about how to define an external search engine, 
see Defining an external search engine on page 40. 

8. In the Message Masks section, select the message masks that you must 
apply to this chat site. 

9. Click Save. 

Automated Chat Management Interface creates the chat site with the 
selected settings. 
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When you are ready to verify the deployment, return to this page and click 
the Open Sample Frontend link. For more information about how to 
verify the deployment, see Verifying the deployment on page 34 

 



 

Chapter 4: Test, approve, and deploy 

After you set up and script a project, you need to test, approve, and deploy the project to 
enable agents to chat with site visitors. 

Test the project 
After you make changes to the automated chat rules of a project, you must test 
the rules in the chat engine simulator. If the test results are satisfactory, you can 
deploy the changes to the project. 

Publishing and simulating the project 
Before you begin 

Publish the changes to a testing location, and then run the engine simulator to test 
the changes with specific simulated visitor inputs. 

Get the administrator credentials to log in to Automated Chat Management 
Interface. 

About this task 

Use this procedure to run the engine simulator to test the project with specific user 
inputs. You can simulate the project based on the uncommitted changes, and the 
system tests the changes without affecting others working on the project. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Automate > Test Branch. 

Automated Chat Management Interface displays the automate test branch 
page. 

Note: 
To see the automate test branch page, you can also click Test 

Branch ( ) on the Script page after selecting a project. 
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3. In the automate test branch field, click the required branch that you must 
test locally from the drop-down list. 

4. Click Publish for Testing to publish the uncommitted changes into a local 
testing area. 

Automated Chat Management Interface displays the list of publishing 
actions ending with the message: Publishing Complete. 

5. Click Engine Sim to begin testing the uncommitted changes in the 
simulator. 

Automated Chat Management Interface displays the Engine Simulator 
window. In this window, you can enter the inputs and test the AnswerBase 
rules. 

6. In the Simulator section, click Input from the drop-down list to test 
conversational text. 

7. Click Send to send the _startup input that the system prepopulates in 
the text field. 

Automated Chat Management Interface starts loading the project files into 
system memory. Before typing other inputs, you must wait until 
Automated Chat Management Interface displays the Project 
finished loading message. 

8. In the text field, type additional conversational inputs that you must test. 

You can test this input by texting the way visitors might type and see how 
the conversation engine responds to the chat. 

9. Click Send. 

The simulator processes the input as if the input is sent from the visitor. 
After the conversation engine processes the input, simulator displays the 
information in the Response, Debug, and Details section. 

You can verify the additional conversational inputs by repeating Step 8 
and Step 9. 

In the Engine Simulator window, the History Log, Match Verifier, 
Regression Tester and Code Error Log tabs provide additional 
information about how the system simulated the inputs.  

For more information about the engine simulator, see Automated Chat 
Management Interface Reference Manual. 

10. Click Close. 

   



 

Commit the changes 
In a project branch, you must commit the changes to deploy the branch to the chat 
system. Until you comment the changes, other users who are working on the 
same project cannot see the changes. 

Committing the changes of a project 
branch 

Before you begin 

Get the knowledge manager credentials to log in to Automated Chat Management 
Interface. 

About this task 

Use this procedure to commit the changes of a project branch. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Automate > Commit Changes. 

Automated Chat Management Interface displays the automate commit 
changes page. 

3. In the Select Branch list, click the required branch with the changes that 
you want to commit. 

The system lists the branches that include changes in the menu with an 
asterisk beside the name. 

The system also displays the list of changes that the scripter makes to 
objects in the branch. 

4. On the Object Changes page, click the view link for each objects and 
perform the following actions: 

a. Click Show History ( ) to see the branch name, author name, 
when the change is made to the object, to delete working 
changes of an object, and to view the details of object. 

Automated Chat Management Interface displays a window with 
the history details. You can click the View Details link to review 
the details of the object. You can click Delete Working Change  
( ) to delete a particular object. 
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b. Click Show Object Details ( ) to review the details of the 
object. 

5. In the Commit Comments field, type a description for reference. 

6. Perform the following actions: 

● Click Commit Working Changes. 

If the commit is successful, Automated Chat Management Interface 
displays the message: Data Committed Successfully. No 
Conflicts Detected. You can click the Back To Last Object 
Scripted link to return to the automate script page. 

If conflicts occur when you commit the changes, Automated Chat 
Management Interface automatically overrides the previous changes 
with your changes.  

A conflict can occur when you are editing a rule in your Automated 
Chat Management Interface account, and another scripter edits the 
same rule and commits the change before your change. 

● Click Rollback Working Changes. 

Automated Chat Management Interface displays a message to 
confirm if you want to delete all working changes. If you click Ok, 
Automated Chat Management Interface abandons all uncommitted 
changes in the selected branch. 

Result 

Automated Chat Management Interface commits all objects and makes the branch 
available for deployment or for approval if you set up optionally. 

Approval branch 
When new conversational scripting is ready for visitors to use on a chat site, you 
can create, approve, and deploy an approval branch. 

Creating an approval branch 
Before you begin 

Get the administrator credentials to log in to Automated Chat Management 
Interface. 

About this task 

Create an approval branch when a project branch is ready for approval and 
deployment. 
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Approve an approval branch before deployment if you create an approval group 
for the branch. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Administer > Project Branches. 

Automated Chat Management Interface displays the administer project 
branches page. 

3. In the Create Branch For Approval column, click the Create link for the 
project branch that is ready to approve. 

If a user makes the changes to the branch but did not commit yet, the 
system displays the message: There are Uncommitted Objects in 
this branch. Do you want to create a branch for 
approval. 

4. Perform the following actions: 

● Click Yes, to create an approval branch without committing the 
changes. The uncommitted changes are not part of the new approval 
branch. 

Automated Chat Management Interface displays a window for 
entering the name of the approval branch. 

● Click No, to commit the changes before you create the new approval 
branch. 

In this case, you must review the changes, commit the changes, and 
perform the creating an approval branch procedure. 

5. In the New Branch for Approval field, type the name of the approval 
branch name. 

6. Click Create Approval Branch. 

Result 

Automated Chat Management Interface takes a snapshot of the branch and 
creates an approval branch that you can deploy. However, if you define an 
approval process for the project, you must get the approval of the branch before 
you deploy. 

Deploying a project branch 
Before you begin 

Get the administrator credentials to log in to Automated Chat Management 
Interface. 
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About this task 

Deploy the changes that you made to a project branch for visitors to use in the 
chat system. If you define an approval process for the project, the user from the 
approval group must approve the project branch before you deploy the project 
branch. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Automate > Deploy. 

Automated Chat Management Interface displays the automate deploy 
page. 

3. In the Automate Deploy text field, click the required label for the branch 
that you must deploy. 

Note: 
If you define an approval group for the project, the system displays a 
list of approved project branches in the automate deploy field. 

4. Click Deploy. 

Automated Chat Management Interface displays a list of deployment 
actions ending with the message: Deployment process finished. 

Result 

Automated Chat Management Interface deploys the project files and 
makes the files available to the chat system. 

Verifying the deployment 
Before you begin 

Get the administrator credentials to log in to Automated Chat Management 
Interface. 

About this task 

After you deploy a project branch, you can connect to the new chat system and 
verify that the chat system is working. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Administer > Sites. 

Automated Chat Management Interface displays the administer sites 
page. 
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3. In the Sites list, click the required site. 

Automated Chat Management Interface displays information about the 
sites. 

4. In the Details tab, click the Open Sample Frontend link. 

Automated Chat Management Interface displays a new window where you 
can chat as a site visitor and receive outputs from an agent or Avaya 
Automated Chat. 

5. Enter text in the text fields, and then click Send. 

The chat engine assigned to this site processes the input text. 

6. Continue sending text to the engine as if you are a site visitor. 

Automated Chat Management Interface interacts with the conversational 
text according to the scripted rules in the deployed project branch. 

7. Close the browser window. 

   



 

Chapter 5: Chat as an agent 

When the chat site is running and available for visitors, a chat agent can join conversations 
with site visitors. The agent must first gain access to the chat feature for the system to 
assign the chats. Then the agent can chat with a live visitor that the system assigns. 

The chat page displays the chat dashboard and a link to Start Chatting and Start 
AnswerDesk. 

Chat dashboard 
The chat page shows a dashboard summary of the list of sites, with statistics on 
agents, conversations, and duration of each conversation. Automated Chat 
Management Interface updates the statistics automatically. 

You can click a site name to see the summary of the workforce and visitors 
sections. 

● The workforce section displays the information about the chat agents, who 
are currently logged in to Automated Chat Management Interface.  

● The visitors section displays information about users of the chat system, 
who are conversing with either the engine, an agent, or who are waiting to 
chat with an agent. 

Gaining access to the chat feature 
Before you begin 

Get the agent credentials to log in to Automated Chat Management Interface. 

About this task 

An agent can join conversations with site visitors after gaining access to the chat 
feature. 

Procedure 

1. Log in to Automated Chat Management Interface as an agent. 

1. Click Chat > Start Chatting. 

The system displays the Avaya Automated Chat window. 

2. In the Status field at the top of the page, click UNAVAILABLE. 
 
Getting Started with Avaya Automated Chat 2.0     Comments? infodev@avaya.com       August 2013 
 

36 



 

Automated Chat Management Interface changes the status to 
AVAILABLE. 

Note: 
For users with only agent access, the default status is AVAILABLE. 

Automated Chat Management Interface automatically assigns new visitor 
chats to agents who are available, and who are chatting with fewer visitors 
than the number specified in the Max Chats setting for the agent. 

The Conversations tab displays the No Conversations message until 
the agent enters a conversation. The system lists each agent 
conversations with a chat icon to indicate the status of the conversation 
and adds the new conversations to the list. 

When an available agent receives a new chat from the system, the center 
chat box displays the text of the conversation that the visitor might have 
had with another agent or the automated chat system. 

If the agent chat browser window is not in focus, Automated Chat 
Management Interface displays a New Conversation notification in a pop-
up window. 

Note: 
Disable the pop-up blocker for your browser to receive notifications of 
new conversations. 

Next steps 

Chat with a visitor. 

Chatting with a visitor 
Before you begin 

Gain access to the chat feature. 

About this task 

When the system assigns a visitor chat to an available agent, the agent can 
communicate with the visitor. 

Procedure 

1. Read the visitors question in the scrolling chat box above the Chat tab. 

2. Click the Chat tab at the bottom of the chat box, if the Chat tab is not 
already active. 

3. In the Say field, type your response to the visitor. 
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4. Click Send. 

Automated Chat Management Interface displays your response in the 
scrolling chat box and in the visitors chat session. 

5. Continue conversing with the visitor to answer questions. 

For more information about additional functionality of agent chats, see Automated 
Chat Management Interface Reference Manual. 

 



 

Appendix 1: Additional procedures  

Enabling Rule search 
Before you begin 

Get the administrator credentials to log in to Automated Chat Management 
Interface. 

About this task 

Configure an engine to enable agents who are chatting with visitors to search the 
current AnswerBase in a project. Agents can use the search results to provide 
more information to the visitor. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Administer > Engine Configs. 

Automated Chat Management Interface displays the administer engine 
configs page. 

3. In the Engine Name section, click the engine for which you must enable 
the Rule search. 

Automated Chat Management Interface displays the Conversation 
Engine Settings and the Backend Rule Search Settings sections for 
the engine. 

4. In the Backend Rule Search Settings section, enter the details for the 
following fields: 

a. Disable Rule Search: Verify that the Disable Rule Search field 
is selected. If not, select this field to search the AnswerBase in a 
project. 

b. Base URL: Define the server location of Automated Chat 
Management Interface. The standard format is: 
http://<servername>/enginepost/. 

If you installed the conversation engine and Automated Chat 
Management Interface on the same server, the Base URL is: 
http://localhost/enginepost. 
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c. Number of Results: Type the maximum number of results that 
Automated Chat Management Interface must display to an agent 
during each Rule search. 

d. Minimum Score: Specify the minimum score, which is the score 
that the system requires to send a result to an agent. The 
minimum score is the confidence factor. 

5. Click Save. 

Defining an external search engine 
Before you begin 

Get the administrator credentials to log in to Automated Chat Management 
Interface. 

About this task 

Configure each chat site to enable agents who are chatting with visitors to perform 
searches. Agents can use external search engines, such as Google.com, or 
locally installed search engines such as Windows Search. Agents can use the 
results to provide additional information to the visitor. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Administer > External Search Configs. 

Automated Chat Management Interface displays the administer 
external search configs page. 

3. In the External Search Name text field, type the name of the new 
search site. 

Note:  
If the External Search Name text field is not visible, click Add new 
External Search ( ) next to External Search Name. Type the new 
name of the search site in the text field. 

4. Click Add External Search ( ) to save the new external search site. 

Automated Chat Management Interface saves the new external search 
site and displays the new search site in the External Search Name list. 

Automated Chat Management Interface also displays the fields to define 
the new engine. 

5. In the Name field, do not change the display name of the search site. 
If you change the name and click Save, the system displays the 
changed site name in the External Search Name list. 
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6. In the Base URL field, type the server location of the external search 
engine. 

7. In the Param Name field, type the parameters that you must send to 
the search engine. 

8. In the Method field, click the required method from the drop-down list. 
The options are GET or POST. 

9. Click Save. 

Approval group 
You can configure Automated Chat Management Interface to request an approval 
group for a project before you deploy the project for visitors to gain access. An 
approval group is optional and you can set the approval group when you need 
specific Automated Chat Management Interface users to approve the changes in 
a project. 

The first step of creating an approval process is to define an approval group which 
specifies the Automated Chat Management Interface users who can approve the 
changes in a project. If you create an approval branch for the project, one member 
of the approval group must approve the changes before you deploy the changes. 

Creating an approval group 
Before you begin 

Get the administrator credentials to log in to Automated Chat Management 
Interface. 

About this task 

Use this procedure to create an approval group. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Administer > Approvals. 

Automated Chat Management Interface displays the administer approval 
page. 

3. In the Approval Groups field, type the name of the new approval groups. 

Note:  
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If the Approval Groups text field is not visible, click Add new 
Approval Group ( ) next to Approval Groups. Type the name of 
the new approval groups in the text field. 

4. Click Add Approval Group ( ) to save the new approval groups. 

Automated Chat Management Interface saves the new approval groups 
and displays the new approval groups in the Approval Groups list. 

Automated Chat Management Interface also displays the list of users and 
project branches that you can assign to the new approval group. 

5. In the Users in Approval Group list, select Select All to assign all users 
to the approval group. You can also select individual users from the list. 

6. In the Branches list, select the projects that you must assign to the 
approval group. 

7. Click Save. 

Approving an approval branch for deployment 
Before you begin 

Get the administrator credentials to log in to Automated Chat Management 
Interface. 

About this task 

Approving an approval branch before deploying is an optional step of Automated 
Chat Management Interface.  

To approve an approval branch, first create an approval group for the project. 
Then the approved Automated Chat Management Interface users who are defined 
in the approval group can approve the approval branch. 

Procedure 

1. Log in to Automated Chat Management Interface as an administrator. 

2. Click Automate > Approve. 

Automated Chat Management Interface displays the automate approve 
page. 
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3. Click the Project drop-down list and choose the approval branch that you 
must approve. 

Automated Chat Management Interface displays the Commits Summary 
Since Branch Last Approval and Approval Summary sections. 

In the Commits Summary Since Branch Last Approval section, 
Automated Chat Management Interface displays the list of the users of the 
approval groups who have committed the changes since the last approval. 
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In the Approval Summary section, Automated Chat Management 
Interface displays the changes that are ready to approve, grouped by the 
type of object. 

4. In the Comments Summary Since Branch Last Approval section, click 
the view link to view the comments that are inserted by the users of the 
approval groups. 

5. In the Approval Summary section, click the view link for each object type 
to review the specific objects that changed. 

6. In the view window, click the View Details link for each object, add 
optional Comments, and if require, assign the objects to users to request 
information. 

7. In the view window, click Save Comments if you added comments. 

8. Click close from the view window to return to the automate approve page. 

9. In the Comments field, type a summary of the changes that you make. 

10. Perform the following actions: 

● Click Approve to approve the branch. 

Automated Chat Management Interface displays the message: You 
Have Successfully Approved The Branch. 

The project branch appears in the Project window of the list of 
branches that you can deploy. 

● Click Reject to reject the project branch and add your comments in 
the Comments field. 

Note: 
If any user from the approval group approves the project branch, the 
system approves the branch. 

After you approve the branch, you can deploy the project branch to the 
chat system. 
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Glossary 

A 
administrator: Creates and manages user accounts, project branches, branch labels, chat 
engines and sites. 

agent: Chat with front-end visitors, view chat logs, and run some reports. 

alias: Used as embedded variables within a project. 

AnswerBase: A set of conversational Rules that the chat engine uses to process front-end 
user inputs. 

approval branch: An optional branch of a project that can be approved and deployed. 

approval group: A group of users who can approve project branches for deploying. 

approve: An approval group can approve a project branch before deploying. 

B 
back-end user: Agents, Supervisors who chat with visitors (front-end users). 

BGate module: Extensible software modules defined in a Code Module to access customer-
specific back-office systems. 

C 
CF: Confidence factor. 

chat: Front-end users type input messages to receive help from agents. 

code module: Contains a set of computer programming methods that are written in the C# 
(C-Sharp) programming language to organize methods into groups that make sense to the 
conversational rules and different project branches. 

commit changes: Allows changes to be seen by other Automated Chat Management 
Interface users who are working on the same project. 

conditions: Controls exactly when a rule matches the user's text. 

confidence factor: Determines whether an answer generated by the engine is sent directly 
to the user or presented to the Agent as a suggested response. The is calculated by total 
matching word points divided by the total word points in the user's input (aka CF). 
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Conversation Engine: Automated Conversive Engine provides automated chat answers 
directly to front-end users. 

CSR: Customer Service Representative. 

CSV: Automated Chat Management Interface can export chat logs into a Comma Separated 
Value file. 

D 
data type: Stores and organizes information that can be accessed in rules. 

default max chats: The default maximum number of chat conversations that Agents may 
enter at one time, this can be overridden for a specific Agent in the Max Chats Override. 

deploy: Changes in a project can be deployed for visitors to the website. 

E 
engine configuration: Defines a Conversation Engine which provides automated chat 
answers to visitors. 

external command: Additional functions that are performed after a specific Rule Output or 
Procedure Output matches successfully and the output text is displayed to the front-end 
user. 

F 
file: Store Automated Chat Management Interface data and are listed in the File menu of the 
Script page. For example, AnswerBase file. 

front-end user: Visitors to the chat site who converse with Agents or the automated 
Automated Chat Management Interface system. 

I 
input: Text from a front-end user; the part of a Rules that defines what front-end user text 
will match the rule and causes it to be fired. 

K 
knowledge manager: Creates and manages the scripting rules for a visitor chat system. 
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M 
max chats override: Defines the maximum number of chats for a specific Agent, instead of 
using the Default Max Chats setting. 

O 
output: Defines the exact text or other information that is displayed to a user based on the 
input they submitted. 

P 
points table: A list of words and values which identify which words will be given more 
importance during engine matching. 

procedures: Define a step-by-step conversation that can be used to guide the user through 
a sequence of information. 

project branch: Multiple branches provide control over workflow in Automated Chat 
Management Interface. 

R 
replacement profile: Replace the text that was entered by the front-end user with other text, 
or specifies the output text for speech engines. 

roles: Types of users with different permissions and access in Automated Chat 
Management Interface. 

rule: Basic conversational unit in a chat system, consisting of inputs and outputs to define 
which user text matches and what is displayed. 

Rule Search: Agents can search the answerbase that is associated to the current chat. 

S 
sample frontend: A window that allows text to be sent the chat site for testing user inputs. 

scripting: Defines AnswerBase rules to process the input text of front-end users of a chat 
site. 

shortcut: Provides easier access to rules that have been defined in the current project 
branch. 

simulator: Runs a project to test the user inputs against the AnswerBase. 

step: A single section in a procedure. 
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suggestion: Displayed to an agent by Automated Chat Management Interface when the 
front-end user types input text that the engine recognizes. 

supervisor: Manage Agents, monitor chats, view chat logs, and run some reports. 

synonym groups: Reduce the number of Inputs you need to define in a rule by identifying 
words with similar meanings. 

T 
topic: Groups of rules. 

U 
user: Accounts in the Automated Chat Management Interface system. 

V 
variable: Store values that can be used in various Automated Chat Management Interface 
objects. 
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