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Notice
While reasonable efforts have been made to ensure that the
information in this document is complete and accurate at the time of
printing, Avaya assumes no liability for any errors. Avaya reserves
the right to make changes and corrections to the information in this
document without the obligation to notify any person or organization
of such changes.

Documentation disclaimer
“Documentation” means information published by Avaya in varying
mediums which may include product information, operating
instructions and performance specifications that Avaya may generally
make available to users of its products and Hosted Services.
Documentation does not include marketing materials. Avaya shall not
be responsible for any modifications, additions, or deletions to the
original published version of documentation unless such
modifications, additions, or deletions were performed by Avaya. End
User agrees to indemnify and hold harmless Avaya, Avaya's agents,
servants and employees against all claims, lawsuits, demands and
judgments arising out of, or in connection with, subsequent
modifications, additions or deletions to this documentation, to the
extent made by End User.

Link disclaimer
Avaya is not responsible for the contents or reliability of any linked
websites referenced within this site or documentation provided by
Avaya. Avaya is not responsible for the accuracy of any information,
statement or content provided on these sites and does not
necessarily endorse the products, services, or information described
or offered within them. Avaya does not guarantee that these links will
work all the time and has no control over the availability of the linked
pages.

Warranty
Avaya provides a limited warranty on Avaya hardware and software.
Refer to your sales agreement to establish the terms of the limited
warranty. In addition, Avaya’s standard warranty language, as well as
information regarding support for this product while under warranty is
available to Avaya customers and other parties through the Avaya
Support website: http://support.avaya.com or such successor site as
designated by Avaya. Please note that if you acquired the product(s)
from an authorized Avaya Channel Partner outside of the United
States and Canada, the warranty is provided to you by said Avaya
Channel Partner and not by Avaya.

Licenses
THE SOFTWARE LICENSE TERMS AVAILABLE ON THE AVAYA
WEBSITE, HTTP://SUPPORT.AVAYA.COM/LICENSEINFO OR
SUCH SUCCESSOR SITE AS DESIGNATED BY AVAYA, ARE
APPLICABLE TO ANYONE WHO DOWNLOADS, USES AND/OR
INSTALLS AVAYA SOFTWARE, PURCHASED FROM AVAYA INC.,
ANY AVAYA AFFILIATE, OR AN AVAYA CHANNEL PARTNER (AS
APPLICABLE) UNDER A COMMERCIAL AGREEMENT WITH
AVAYA OR AN AVAYA CHANNEL PARTNER. UNLESS
OTHERWISE AGREED TO BY AVAYA IN WRITING, AVAYA DOES
NOT EXTEND THIS LICENSE IF THE SOFTWARE WAS
OBTAINED FROM ANYONE OTHER THAN AVAYA, AN AVAYA
AFFILIATE OR AN AVAYA CHANNEL PARTNER; AVAYA
RESERVES THE RIGHT TO TAKE LEGAL ACTION AGAINST YOU
AND ANYONE ELSE USING OR SELLING THE SOFTWARE
WITHOUT A LICENSE. BY INSTALLING, DOWNLOADING OR
USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO,
YOU, ON BEHALF OF YOURSELF AND THE ENTITY FOR WHOM
YOU ARE INSTALLING, DOWNLOADING OR USING THE
SOFTWARE (HEREINAFTER REFERRED TO
INTERCHANGEABLY AS “YOU” AND “END USER”), AGREE TO
THESE TERMS AND CONDITIONS AND CREATE A BINDING
CONTRACT BETWEEN YOU AND AVAYA INC. OR THE
APPLICABLE AVAYA AFFILIATE (“AVAYA”).

Avaya grants you a license within the scope of the license types
described below, with the exception of Heritage Nortel Software, for
which the scope of the license is detailed below. Where the order
documentation does not expressly identify a license type, the
applicable license will be a Designated System License. The

applicable number of licenses and units of capacity for which the
license is granted will be one (1), unless a different number of
licenses or units of capacity is specified in the documentation or other
materials available to you. “Software” means Avaya’s computer
programs in object code, provided by Avaya or an Avaya Channel
Partner, whether as stand-alone products, pre-installed , or remotely
accessed on hardware products, and any upgrades, updates, bug
fixes, or modified versions thereto. “Designated Processor” means a
single stand-alone computing device. “Server” means a Designated
Processor that hosts a software application to be accessed by
multiple users. “Instance” means a single copy of the Software
executing at a particular time: (i) on one physical machine; or (ii) on
one deployed software virtual machine (“VM”) or similar deployment.

License types

• Designated System(s) License (DS). End User may install and
use each copy or an Instance of the Software only on a
number of Designated Processors up to the number indicated
in the order. Avaya may require the Designated Processor(s)
to be identified in the order by type, serial number, feature
key, Instance, location or other specific designation, or to be
provided by End User to Avaya through electronic means
established by Avaya specifically for this purpose.

• Concurrent User License (CU). End User may install and use
the Software on multiple Designated Processors or one or
more Servers, so long as only the licensed number of Units
are accessing and using the Software at any given time. A
“Unit” means the unit on which Avaya, at its sole discretion,
bases the pricing of its licenses and can be, without limitation,
an agent, port or user, an e-mail or voice mail account in the
name of a person or corporate function (e.g., webmaster or
helpdesk), or a directory entry in the administrative database
utilized by the Software that permits one user to interface with
the Software. Units may be linked to a specific, identified
Server or an Instance of the Software.

• Database License (DL). End User may install and use each
copy or an Instance of the Software on one Server or on
multiple Servers provided that each of the Servers on which
the Software is installed communicates with no more than an
Instance of the same database.

• CPU License (CP). End User may install and use each copy
or Instance of the Software on a number of Servers up to the
number indicated in the order provided that the performance
capacity of the Server(s) does not exceed the performance
capacity specified for the Software. End User may not re-
install or operate the Software on Server(s) with a larger
performance capacity without Avaya’s prior consent and
payment of an upgrade fee.

• Named User License (NU). You may: (i) install and use the
Software on a single Designated Processor or Server per
authorized Named User (defined below); or (ii) install and use
the Software on a Server so long as only authorized Named
Users access and use the Software. “Named User”, means a
user or device that has been expressly authorized by Avaya to
access and use the Software. At Avaya’s sole discretion, a
“Named User” may be, without limitation, designated by name,
corporate function (e.g., webmaster or helpdesk), an e-mail or
voice mail account in the name of a person or corporate
function, or a directory entry in the administrative database
utilized by the Software that permits one user to interface with
the Software.

• Shrinkwrap License (SR). You may install and use the
Software in accordance with the terms and conditions of the
applicable license agreements, such as “shrinkwrap” or
“clickthrough” license accompanying or applicable to the
Software (“Shrinkwrap License”).

Heritage Nortel Software
“Heritage Nortel Software” means the software that was acquired by
Avaya as part of its purchase of the Nortel Enterprise Solutions
Business in December 2009. The Heritage Nortel Software currently
available for license from Avaya is the software contained within the
list of Heritage Nortel Products located at http://support.avaya.com/
LicenseInfo/ under the link “Heritage Nortel Products”, or such
successor site as designated by Avaya. For Heritage Nortel
Software, Avaya grants Customer a license to use Heritage Nortel

http://support.avaya.com/
http://support.avaya.com/LicenseInfo
http://support.avaya.com/LicenseInfo/
http://support.avaya.com/LicenseInfo/


Software provided hereunder solely to the extent of the authorized
activation or authorized usage level, solely for the purpose specified
in the Documentation, and solely as embedded in, for execution on,
or (in the event the applicable Documentation permits installation on
non-Avaya equipment) for communication with Avaya equipment.
Charges for Heritage Nortel Software may be based on extent of
activation or use authorized as specified in an order or invoice.

Copyright
Except where expressly stated otherwise, no use should be made of
materials on this site, the Documentation, Software, Hosted Service,
or hardware provided by Avaya. All content on this site, the
documentation, Hosted Service, and the Product provided by Avaya
including the selection, arrangement and design of the content is
owned either by Avaya or its licensors and is protected by copyright
and other intellectual property laws including the sui generis rights
relating to the protection of databases. You may not modify, copy,
reproduce, republish, upload, post, transmit or distribute in any way
any content, in whole or in part, including any code and software
unless expressly authorized by Avaya. Unauthorized reproduction,
transmission, dissemination, storage, and or use without the express
written consent of Avaya can be a criminal, as well as a civil offense
under the applicable law.

Virtualization
Each product has its own ordering code and license types. Note that
each Instance of a product must be separately licensed and ordered.
For example, if the end user customer or Avaya Channel Partner
would like to install two Instances of the same type of products, then
two products of that type must be ordered.

Third Party Components
“Third Party Components” mean certain software programs or
portions thereof included in the Software or Hosted Service may
contain software (including open source software) distributed under
third party agreements (“Third Party Components”), which contain
terms regarding the rights to use certain portions of the Software
(“Third Party Terms”). As required, information regarding distributed
Linux OS source code (for those Products that have distributed Linux
OS source code) and identifying the copyright holders of the Third
Party Components and the Third Party Terms that apply is available
in the Documentation or on Avaya’s website at: http://
support.avaya.com/Copyright or such successor site as designated
by Avaya. You agree to the Third Party Terms for any such Third
Party Components

Preventing Toll Fraud
“Toll Fraud” is the unauthorized use of your telecommunications
system by an unauthorized party (for example, a person who is not a
corporate employee, agent, subcontractor, or is not working on your
company's behalf). Be aware that there can be a risk of Toll Fraud
associated with your system and that, if Toll Fraud occurs, it can
result in substantial additional charges for your telecommunications
services.

Avaya Toll Fraud intervention
If you suspect that you are being victimized by Toll Fraud and you
need technical assistance or support, call Technical Service Center
Toll Fraud Intervention Hotline at +1-800-643-2353 for the United
States and Canada. For additional support telephone numbers, see
the Avaya Support website: http://support.avaya.com or such
successor site as designated by Avaya. Suspected security
vulnerabilities with Avaya products should be reported to Avaya by
sending mail to: securityalerts@avaya.com.

Trademarks
The trademarks, logos and service marks (“Marks”) displayed in this
site, the documentation(s) and product(s) provided by Avaya are the
registered or unregistered Marks of Avaya, its affiliates, or other third
parties. Users are not permitted to use such Marks without prior
written consent from Avaya or such third party which may own the
Mark. Nothing contained in this site, the documentation and
product(s) should be construed as granting, by implication, estoppel,
or otherwise, any license or right in and to the Marks without the
express written permission of Avaya or the applicable third party.

Avaya and Avaya Aura® are trademarks of Avaya Inc. All non-Avaya
trademarks are the property of their respective owners.

Linux is the registered trademark of Linus Torvalds.

Downloading Documentation
For the most current versions of Documentation, see the Avaya
Support website: http://support.avaya.com, or such successor site as
designated by Avaya.

Contact Avaya Support
See the Avaya Support website: http://support.avaya.com for Product
or Hosted Service notices and articles, or to report a problem with
your Avaya Product or Hosted Service. For a list of support telephone
numbers and contact addresses, go to the Avaya Support website: 
http://support.avaya.com (or such successor site as designated by
Avaya), scroll to the bottom of the page, and select Contact Avaya
Support.

http://support.avaya.com/Copyright
http://support.avaya.com/Copyright
http://support.avaya.com
http://support.avaya.com
http://support.avaya.com
http://support.avaya.com


Contents

Chapter 1: Overview.................................................................................................................  6
Purpose.................................................................................................................................. 6
About the Avaya MS 7.6 appliance...........................................................................................  6
System requirements............................................................................................................... 6
Best practice recommendations................................................................................................ 7

Chapter 2: Deploying Avaya MS OVA.....................................................................................  9
Deploying the OVA file by using vSphere Client.........................................................................  9
Deploying the OVA file by using vSphere Web Client...............................................................  11
Deploying the OVA file without using vCenter..........................................................................  13

Chapter 3: Logging in to the Avaya MS appliance..............................................................  15
Element Manager..................................................................................................................  15
Accessing Avaya MS EM.......................................................................................................  15
Accessing Linux shells........................................................................................................... 16
Enabling Avaya support access..............................................................................................  16

Chapter 4: Network configuration.........................................................................................  17
Managing network configuration.............................................................................................  17

Chapter 5: VMware Tools.......................................................................................................  19
Updating VMware Tools......................................................................................................... 19

Chapter 6: Media file provisioning........................................................................................  21
Media file format.................................................................................................................... 21
Media storage in Avaya MS appliance..................................................................................... 21

Chapter 7: Backup and restore.............................................................................................. 22
Performing a backup.............................................................................................................. 22
Uploading and restoring backup files to the appliance..............................................................  23

Chapter 8: Updating Avaya MS.............................................................................................. 25
Uploading updates................................................................................................................  25
Applying updates................................................................................................................... 25
Removing updates................................................................................................................  27

Chapter 9: Avaya MS appliance upgrade.............................................................................  29
Upgrade overview.................................................................................................................  29

Simplex Avaya MS upgrade overview...............................................................................  29
N+1 load sharing cluster upgrade overview.......................................................................  29

Prerequisites for upgrade.......................................................................................................  30
Upgrading or redeploying the Avaya MS appliance..................................................................  30
Upgrading N+1 load sharing clusters......................................................................................  33

Chapter 10: Troubleshooting the Avaya MS appliance....................................................... 34
Overview..............................................................................................................................  34
Managing Avaya MS system services.....................................................................................  34

October 2015 Deploying and Updating Avaya Media Server using VMware® in the Virtualized
Environment 4

Comments on this document? infodev@avaya.com

mailto:infodev@avaya.com?subject=Deploying and Updating Avaya Media Server using VMware® in the Virtualized Environment


Unable to upload files larger than 2 GB...................................................................................  35
Backup or restore tasks fail....................................................................................................  35
Resetting locked login accounts.............................................................................................. 36
VM does not power on after initial deployment or after altering the VM resources.......................  36
While installing Avaya MS, use of the amspatch tool is specified...............................................  37

Contents

October 2015 Deploying and Updating Avaya Media Server using VMware® in the Virtualized
Environment 5

Comments on this document? infodev@avaya.com

mailto:infodev@avaya.com?subject=Deploying and Updating Avaya Media Server using VMware® in the Virtualized Environment


Chapter 1: Overview

Purpose
This document contains the procedures for deploying, upgrading, and updating Avaya Media Server
(MS) 7.6 appliances. Use this document when you are working with Avaya MS 7.6 as an appliance
on Virtual Machine (VM).

For installation types other than VM appliances, refer to Installing, Upgrading, and Patching Avaya
Media Server 7.6.

About the Avaya MS 7.6 appliance
A deployed Avaya MS 7.6 appliance includes the following:

• Preinstalled Avaya MS 7.6 software.

• Preinstalled Avaya MS Element Manager (EM).

• Security-hardened Linux operating system derived from Red Hat Enterprise Linux 6.

• Preconfigured support accounts.

System requirements
You can deploy an Avaya MS 7.6 appliance to an ESXi 5.1 or an ESXi 5.5 vSphere system. The
Avaya MS appliance is deployed by using vCenter or directly to a standalone ESXi host.

The ESXi host must meet the following system requirements:

ESXi host resource Requirement
CPU The core processor speed must be at least 2400 MHz. The reserved

CPU bandwidth on the ESXi host must be at least four times the
processor speed.

Memory The reserved RAM must be 4670 MB.
Disk space The disk storage must be 55 GB.

Table continues…
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ESXi host resource Requirement
Network bandwidth A dedicated 1 Gbps network interface or 1 Gbps of dedicated bandwidth

on a 10 Gbps network interface.

Best practice recommendations
Use the following best practice recommendations when deploying the Avaya MS appliance:

• When deploying to physical hardware that exceeds the minimum CPU requirements, ensure
that the VM properties are set so that the CPU reservations are the maximum possible.

• All physical servers that can host VM must have the same CPU, memory, and networking
specifications.

• Do not modify the memory reservation that is set for Avaya MS OVA.
• Physical CPUs on the host must not be oversubscribed with respect to vCPU count across all

VMs. A physical CPU refers to physical CPU cores and not to the threads of physical CPUs.
For example, the total number of vCPUs across all VMs, including Avaya MS, on an ESXi host
that has 12 physical cores, with 24 hyper threads, must not exceed 12.

• When deploying the OVA file, select the thick provision lazy zeroed option for the VM virtual
disks.

• The OVA file contains three virtual disks, which must remain co-located with VM to have
consistent and predictable performance.

• If the physical network interfaces on the ESXi host are 10 Gbps interfaces, then NetIOC and
traffic shaping should be performed to allocate the required 1 Gbps of network bandwidth for
Avaya MS VM.

• The following vSphere features are not supported and must not be configured for Avaya MS
appliances:

- vMotion for running VMs
- Storage vMotion
- High Availability
- Fault tolerance
- VM snapshots, which adversely impact VM disk performance.

• Avaya MS requires temporary work space in the /opt/avaya/app volume to create and
restore backup archives of the application content. The work space required is equal to two
times the amount of data stored in the Content Store. The work space is in addition to the disk
space required for the Avaya MS software, stored operational measurements, session detail
records, trace logs, and software updates.

The Avaya MS appliance is engineered to have Content Store with data of maximum 3.1 GB.
Therefore, backup and restore operations for 3.1 GB of data require 6.2 GB of free disk space
in /opt/avaya/app.

Best practice recommendations
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Old backup files should be removed to maintain free space on the system.

Overview
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Chapter 2: Deploying Avaya MS OVA

Deploying the OVA file by using vSphere Client
Before you begin
Install the vSphere Client Windows application on the workstation. Alternatively, follow the
procedure to use vSphere Web Client.

Obtain the Avaya MS 7.6 OVA file and save it on the workstation where you will be running vSphere
Client to configure the new VM.

Obtain the required networking settings for configuring the new VM. These settings can be from an
existing system if you are redeploying Avaya MS OVA.

Ensure that you power off the current Avaya MS appliance.

Procedure
1. Log in to the VMware host by using the vSphere Client Windows application provided by

VMware.

2. Navigate to Home > Inventory > Hosts and Clusters.

3. Expand the inventory tree of hosts and clusters to locate and select the target deployment
host.

4. Select File > Deploy OVF Template from the menu bar.

5. Click Browse and select the required Avaya MS OVA file.

6. Click Next.

7. Confirm the properties of the OVA file you selected on the OVF Template Details page.

8. Click Next.

9. To accept the End User License Agreement, click Accept.

10. Click Next.

11. Enter a name for the new Avaya MS VM.

12. Click Next.

13. Select the data store for the new VM.

14. Click Next.

15. Select the Thick Provision Lazy Zeroed disk format option.
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16. Click Next.

17. Select the required destination network.

18. Click Next.

19. Configure the details for the new VM on the Properties page.

20. Click Next.

21. On the Ready to Complete page, verify the options displayed.

• If the values are incorrect, click Back to make changes.

• Do not select the Power on after deployment option.

• If the values are correct, click Finish.

Wait for the deployment to complete. The time the system requires to complete the
deployment depends on the speed of the network connection and server.

Tip:

You can alter the configuration settings later by running the netSetup command in a
Linux shell.

22. Configure the CPU reservations for this host by using the following procedure:

a. Select the host for the VM in the inventory list of the vSphere Client window.

b. Click on the Summary tab.

c. Note the CPU core speed in GHz, displayed under General > CPU Cores. For
example, if the value for CPU Cores is 12 CPUs x 2.933 GHz then note the value
2.933.

d. Locate the new VM in the inventory list of the vSphere Client window and right-click on
it to select Edit Settings… from the menu.

e. On the Hardware tab of the Virtual Machine Properties window, note the number in
the Summary column for CPUs. For example, a typical value is 4.

f. Select the Resources tab.

g. Under Settings, click CPU.

h. Calculate the CPU reservation for the VM. Multiply the previously noted CPU core
speed by 1000 and by the previously noted CPU count. For example, 2.933 GHz x
1000 x 4 = 11732 MHz.

i. Clear the current value in the Reservation field under Resource Allocation and enter
the number of MHz calculated for the CPU reservation.

j. Click OK.

23. Locate your new VM in the inventory list of the vSphere Client window and right-click on it to
select Power > Power On.

24. (Optional) Open a console window to your VM by right-clicking the VM entry in the inventory
list and selecting Open Console.

Deploying Avaya MS OVA
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A console window opens and displays the progress of the VM system initializing.

25. When the VM initialization completes, you can log in by using the customer account that you
set up earlier.

Deploying the OVA file by using vSphere Web Client
Before you begin
The steps in this procedure use vSphere Web Client, which runs in a web browser. Alternatively,
follow the procedure to use vSphere Client, which is a Windows application you install on the
workstation.

Obtain the Avaya MS 7.6 OVA file and save it on the workstation where you will be running vSphere
Web Client to configure the new VM.

Obtain the required networking settings for configuring the new VM. These settings can be from an
existing system if you are redeploying Avaya MS OVA.

Ensure that you power off the current Avaya MS appliance.

Procedure
1. Log in to the VMware host by using the vSphere Web Client:

https://vCenterAddress:9443/vsphere-client
2. Click on vCenter in the vSphere Web Client navigator area on left.

3. Under Inventory Trees, click Hosts and Clusters.

4. Expand the inventory tree of hosts and clusters to locate and select the target deployment
host.

5. Right-click on the host and select Deploy OVF Template… from the menu.

6. If the Client Integration Access Control window pops up, click Allow.

7. For step 1a Select source, select Local file.

8. Click Browse.

9. Select OVA Packages (*.ova) from the file filter drop-down menu, in the lower-right of the
window.

10. Select the required Avaya MS OVA file.

11. Click Next.

12. Confirm the properties of the OVA file you selected on the Review details page.

13. Click Next.

14. To accept the End User License Agreement, click Accept.

15. Click Next.

Deploying the OVA file by using vSphere Web Client
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16. Enter a name for the new Avaya MS VM.

17. Click Next.

18. Expand the tree under the vCenter server and select the required datacenter folder.

19. Click Next.

20. Select Thick Provision Lazy Zeroed for the virtual disk format.

21. Select the required destination datastore.

22. Click Next.

23. Select the required destination network.

24. Click Next.

25. Expand Network Settings and configure the network details for the new VM on the
Customize template page.

26. Expand System Time Settings and configure the time settings.

27. Expand Customer Login Settings and configure the account settings.

28. Click Next.

29. On the Ready to complete page, verify the options displayed.

• If the values are incorrect, click Back to make changes.

• Do not select the Power on after deployment option.

• If the values are correct, click Finish.

Wait for the deployment to complete. The time the system requires to complete the
deployment depends on the speed of the network connection and server. The system
displays the progress under Recent Tasks > All.

Tip:

You can alter the configuration settings later by running the netSetup command in a
Linux shell.

30. Click the refresh arrow located to the left of your login ID at the top of the vSphere Web
Client page.

The system updates the inventory list and displays the new VM.

31. Configure the CPU reservations for the host by using the following procedure:

a. Select host for the VM in the inventory list of vSphere Web Client.

b. Click on the Manage tab.

c. Select Settings.

d. Expand Hardware and select Processors.

e. Note the CPU core speed in GHz, displayed under General > Processor speed. For
example, if the value for Processor speed is 2.933 GHz then note the value 2.933.

Deploying Avaya MS OVA
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f. Select the new VM in the inventory list of the vSphere Web Client page.
g. Select Edit Settings… from the Actions drop-down menu located above the content

area.
h. Select Virtual Hardware and note the number next to CPU. For example, a typical

value is 4.

i. Calculate the CPU reservation for the VM. Multiply the previously noted CPU core
speed by 1000 and by the previously noted CPU count. For example,

2.933 GHz x 1000 x 4 = 11732 MHz
j. Expand CPU.

k. Clear the current value in the Reservation field under CPU and enter the number of
MHz calculated for the CPU reservation. Ensure that the unit selected for the
Reservation field is MHz.

l. Click OK.

32. Select the new VM in the inventory list of the vSphere Web Client window and click on the
Summary tab.

33. Select Power On from the Actions menu.

34. (Optional) Open a console page to the VM by clicking on Launch Console on the
Summary tab.

A console window opens and displays the progress of the VM system initializing.

35. When the VM initialization completes, you can log in by using the customer account that you
set up earlier.

Deploying the OVA file without using vCenter
Before you begin
Install the vSphere Client Windows application on the workstation.

Obtain the Avaya MS 7.6 OVA file and save it on the workstation where you will be running vSphere
Client to configure the new VM.

Obtain the required networking settings for configuring the new VM. These settings can be from an
existing system if you are redeploying Avaya MS OVA.

Ensure that you power off the current Avaya MS appliance.

Procedure
1. Log in to the VMware host by using vSphere Client Windows application provided by

VMware.

2. Navigate to Home > Inventory.

3. Select the target deployment host in the inventory list.

Deploying the OVA file without using vCenter
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4. Select File > Deploy OVF Template from the menu bar.

5. Click Browse and select the required Avaya MS OVA file.

6. Click Next.

7. OVF template details.

8. Click Next.

9. To accept the End User License Agreement, click Accept.

10. Click Next.

11. Enter a name for the new Avaya MS VM.

12. Click Next.

13. Select the Thick Provision Lazy Zeroed disk format option.

14. Click Next.

15. Select the required destination network.

16. Click Next.

17. On the Ready to Complete page, verify the options displayed.

• If the values are incorrect, click Back to make changes.

• Do not select the Power on after deployment option.

• If the values are correct, click Finish.

Wait for the deployment to complete. The time required to complete the deployment depends
on the speed of the network connection and server.

18. Locate your new VM in the inventory list of the vSphere Client window and right-click on it to
select Power > Power On.

19. Immediately open a console window to the VM by right-clicking the VM entry in the inventory
list and selecting Open Console.

A console window opens and displays the progress of the VM system initializing.

20. Double-click in the console window to establish keyboard focus in the console.

21. Page through the End User License Agreement by using the spacebar and type yes to
accept the agreement and proceed.

22. After the VM system initialization completes, you are prompted to configure the VM. Type Y
to proceed.

23. When prompted, enter the management interface network parameters, date, time, and
customer account information.

Tip:

You can alter the configuration settings later by running the netSetup command in a
Linux shell.

Deploying Avaya MS OVA
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Chapter 3: Logging in to the Avaya MS
appliance

Element Manager
Element Manager (EM) is an optional, web-based administration tool that facilitates the operation,
administration, and maintenance (OAM) of Avaya MS.

For more information and detailed procedures about using Avaya MS EM, see Implementing and
Administering Avaya Media Server 7.6.

Accessing Avaya MS EM
Before you begin
EM is a component of the Avaya MS appliance. You must deploy Avaya MS OVA before you gain
access to EM.

About this task
You need to gain access to EM to perform some of the procedures in this document. Perform the
following procedure to gain access to Avaya MS EM on the Avaya MS appliance.

Procedure
1. In a web browser, type the following URL:

https://serverIP:8443/emlogin
serverIP is the IP address of Avaya MS. For example,

https://10.60.86.209:8443/emlogin
2. Sign in to Avaya MS EM by using the customer account username and password.

The customer account is created during the deployment procedure.
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Accessing Linux shells
You need to gain access to Linux shells to perform some of the procedures in this document. Use
Secure Shell (SSH) to access the Linux command-line on the Avaya MS appliance. Use the
customer account or support account credentials for SSH log in. The customer account is created
during deployment of the Avaya MS OVA.

The system supports a maximum of five simultaneous logins per user account. The system rejects
additional SSH and Putty sessions when five sessions are already logged in.

Enabling Avaya support access
Before you begin
Obtain the product specific XML authentication file from Avaya.

About this task
You can enable one of several pre-defined service accounts on the system so that Avaya personnel
can remotely access the system for support purposes. Access to the service accounts requires a
one-time set-up of the Avaya Access Security Gateway (ASG) authentication system. ASG employs
a challenge and response protocol to confirm the validity of the Avaya support personnel accessing
the system.

Perform the following procedure to install an authentication file and enable secure access for Avaya
support personnel.

Procedure
1. Log in to a Linux shell by using the customer account.

The customer account is created during the deployment procedure.

2. Transfer the authentication file to the home directory of the customer account by using the
sftp file transfer tool, or another similar tool.

If you are using a remote file transfer client like WinSCP or FileZilla to upload the
authentication file to the system, provide the customer account credentials to the tool.

3. Enable ASG by using the authentication file you uploaded with the following command:

loadpwd —f —l AuthFile.xml

Logging in to the Avaya MS appliance
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Chapter 4: Network configuration

Managing network configuration
About this task
Server networking information can be updated after an Avaya MS OVA is deployed to a VM by
using the netSetup in a Linux shell. The netSetup command guides you through the process of
updating the following settings:

• Time zone and UTC
• Date and time
• Hostname
• IP address
• Netmask
• Gateway address
• Domain name
• Up to three DNS server IP addresses
• Up to three NTP server IP addresses

Procedure
1. Log in to a Linux shell using the customer account.

2. Type the following command:

netSetup
3. Perform the following steps if you changed the IP addresses or hostname.

a. Navigate to EM > System Configuration > Network Settings > Interface
Assignment.

b. IP Interface Assignment fields show errors due to the IP address change. Select valid
IP addresses from the drop-down menus for each field showing Invalid.

c. If you are using security certificates with information dependent on FQDN or other
server specific information, create new certificates and update the certificates by
navigating to EM > Security Certificate Management.

d. If this server is a member of a load sharing cluster or High Availability cluster, then
navigate to EM > Cluster Configuration > Server Designation on each server and
ensure the IP address you just changed is updated on each server.
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e. If this is a Primary server of a master cluster, then replication clusters that point to the
master cluster must be updated with the new address of this server. On the Primary
node in each replication cluster, navigate to EM > Cluster Configuration >
Replication Settings > Master Cluster Primary Node Address.

For more information on configuring each item, see Implementing and Administering Avaya
Media Server 7.6.

4. Restart the system for the changes to take effect.

Network configuration
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Chapter 5: VMware Tools

Updating VMware Tools
Before you begin

• Perform updates during scheduled maintenance times.
• Ensure that the VM is running.
• Ensure that there is no traffic on Avaya MS.
• Back up the system.

In case of unforeseen problems during the update, you can use the backup to restore the
system to the previous configuration.

• Apply the tool updates to one node at a time in a cluster configuration while the other nodes in
the cluster maintain service.

About this task
In some instances, the version of VMware Tools included with the deployed VM does not match the
version that is required by the ESXi host, which is hosting the VM.

Perform the following procedure to update the version of VMware Tools to the version required by
the ESXi host.

Procedure
1. View the Summary tab for the VM in the vSphere client.

2. Determine if you need to update the VMware tools: If the VMware Tools field on the
Summary tab indicates (Out-of-date) then continue with the following steps to update
VMware Tools.

3. Perform the following steps if you are using vSphere Web Client:

a. Click Interactive Upgrade.

b. Select Interactive upgrade.

c. Click Upgrade.

Monitor the Recent Tasks section of vSphere Web Client page and wait for the
Initiated VMware Tools Installer Mount task to complete. A green checkmark
indicates the task is complete.

4. Perform the following steps if you are using vSphere Client:

a. Select the VM from list of VMs.
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b. Right-click on the VM and select Guest > Install/Upgrade VMware Tools.

c. Select Interactive Tools Upgrade.

d. Click OK.

Monitor the Recent Tasks section of vSphere Client and wait for the Initiated VMware
Tools Installer Mount task to complete.

5. Using the customer login credentials, open a Linux shell and run the following command to
update VMware Tools:

updateVMwareTools
6. Review the important messages displayed by the tool.

7. Type Y and press Enter to update VMware Tools.

After the tool update completes, the VM is automatically restarted to apply the changes.

Note:

If vSphere Client displays a question about a locked CD-ROM door, accept the default
answer of No and click OK to continue.

Important:

The update completes after a few minutes. Do not the interrupt the update by typing
Control-C or otherwise ending updateVMwareTools while it is running. Interrupting
the VMware tools update can leave the tools in an inoperable state, requiring
reinstallation. The VM can also be left in an unstable state requiring you to redeploy the
VM.

8. After the restart is complete, verify that the VMware Tools update was successful by
ensuring the VMware Tools field on the Summary tab for the VM indicates (Current). If you
are using vSphere Web Client, refresh the web page to update the display with the latest
status

VMware Tools
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Chapter 6: Media file provisioning

Media file format
The audio files played by Avaya MS must be encoded as 16 bit, 8 kHz, single channel, LPCM files.
However, you can use other sampling rates and codecs that are supported by Avaya MS. Avaya MS
does not support multiple channels, like stereo.

Media storage in Avaya MS appliance
Some applications require media files to be provisioned in a designated media file storage area for
application access. Using the customer account credentials, provision media files in the following
location:

/opt/avaya/app/localmedia
Important:

The files located in /opt/avaya/app/localmedia are removed when you uninstall Avaya
MS and select the option to completely remove all data. If Avaya MS is uninstalled with the
preserve data option, the files remain on the system.

Tip:

The default location of the Avaya MS media file storage area is not directly accessible by the
customer account. Therefore, provisioning is performed by using a customer account accessible
directory that is linked to Avaya MS default directory. For applications that require files in
$MASHOME/ma/MAS/platdata/filestorage, you must use the customer account and
provision the files in /opt/avaya/app/localmedia.

October 2015 Deploying and Updating Avaya Media Server using VMware® in the Virtualized
Environment 21

Comments on this document? infodev@avaya.com

mailto:infodev@avaya.com?subject=Deploying and Updating Avaya Media Server using VMware® in the Virtualized Environment


Chapter 7: Backup and restore

Performing a backup
About this task
Perform the following procedure to create a backup of the system configuration and application
content. For more information about backup and restore, see Implementing Avaya Media Server
7.6.

Procedure
1. To backup Avaya MS data, navigate to EM > Tools > Backup and Restore > Backup

Tasks.

2. Create or select an existing backup task that includes System Configuration and Application
Content backup types.

3. Click Run Now.

4. Monitor the Backup and Restore History Log at EM > Tools > Backup and Restore >
History Log.

After the backup is complete, the log shows a completed backup task entry.

5. If you are using an FTP backup destination, ensure that the backup files are saved to their
required FTP location.

There is one file for each backup type for a total of two backup files.

6. If you are using a local backup destination and about to perform an upgrade or redeploy of
Avaya Media Server (MS) OVA, you must move the backup files to a safe location by
performing the following steps:

a. Log in to a Linux shell using the customer account.
b. Change to the public directory by using the cdpub alias or the following command:

cd /opt/avaya/app/pub.
c. List the backups available on the local system by using the following command:

bkupFile –list
d. Move the most recent configuration and application data backups from the local backup

storage to the current directory by using the following commands:

bkupFile –retrieve SystemConfiguration_backup.zip
bkupFile –retrieve ApplicationContent_backup.zip
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e. Save both the backup files in a safe location by using the sftp file transfer tool, or
another similar tool, to transfer the files off the server.

f. After you confirm the files are safely saved, delete the backup files from the current
directory to free disk space.

Uploading and restoring backup files to the appliance
About this task
Use this procedure if you encounter errors when using EM to upload backup files to Avaya MS
appliance. Many browsers have a 2 GB limit on file upload. Perform the following procedure to
upload files larger than 2 GB.

Tip:
The latest versions of Chrome and Firefox browsers support file uploads greater than 2 GB

To use the normal EM web browser-based upload procedure, see uploading a backup file in
Implementing and Administering Avaya Media Server 7.6

Note:
After updating the Avaya MS 7.6 appliance, you can restore the data saved from the previous
Avaya MS 7.6 appliance. Do not use this restore procedure for upgrades from Avaya MS 7.5
appliances.

Procedure
1. Ensure that the system configuration and application content backup files saved earlier are

available on the new deployment by performing the following steps:

a. Log in to a Linux shell using the customer account.

b. Change to the public directory by using the cdpub alias or the following command:

cd /opt/avaya/app/pub.

c. Transfer the configuration and application data backups to the system by using the
sftp file transfer tool, or another similar tool.

d. Move the configuration and application data backups from the current directory in to the
local backup storage, by typing the following commands:

bkupFile —insert SystemConfiguration_backup.zip
bkupFile —insert ApplicationContent_backup.zip

e. Confirm the backup files are available on the local system by typing the following
command:

bkupFile —list
2. Log in to EM and restore the backup files to the new system by navigating to EM > Tools >

Backup and Restore > Restore.

Uploading and restoring backup files to the appliance
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3. In the Restore Source drop-down on the Restore page, click Default Backup Destination.

4. In the Restore Task List, select the backups from the list that you want to use for the
restore.

Important:

Restore the system configuration data before restoring the application content to ensure
the application content is restored to the configured location.

5. Click Restore Now.

6. On the Confirm Restore page, click Confirm to proceed with the restore.

The system invokes the restore task, and closes all EM connections until the system
completes the restoration.

Backup and restore
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Chapter 8: Updating Avaya MS

Uploading updates
Before you begin
Avaya MS updates contain service packs or feature packs and Quick Fix Engineering (QFE)
patches.

Use EM to upload updates to Avaya MS and make the updates available for installation.

Procedure
1. Navigate to EM > Tools > Manage Software > Updates > Upload Updates.

2. Click Browse to select the software update to upload.

The selected file must be an official Avaya MS update package in ISO or ZIP format.

3. Click Upload.

Your browser shows a progress spinner until the upload completes.

The web page refreshes when the update completes and displays the details of the update
including the filename of the uploaded file.

4. Use the chevron buttons to expand ( ) and collapse ( ) additional details about the update.

Applying updates
Before you begin
Ensure that you:

• Upload an update.
• Back up the system.

In case of unforeseen problems during the update installation, you can use the backup to
restore the system to the previous configuration.

• Apply the updates to one node at a time in a cluster configuration while the other nodes in the
cluster maintain service.

• Apply the updates for the standby server first and then apply the updates for the active server
when upgrading High Availability clusters.
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• Perform updates during scheduled maintenance times.

About this task
Perform the following procedure to update the system to the latest 7.6 software release with the
latest patches:

Procedure
1. Determine if you need to use the QFE procedure by performing the following steps:

a. Navigate to EM > Tools > Manage Software > Manage Updates.

b. Expand the Details section of the update by clicking on the chevron ( ) button.

c. Review the list of updates. If only QFEs are listed as Ready for Installation, then stop
using this procedure and perform the QFE installation procedure instead. See installing
a QFE patch in Installing, Upgrading and Patching Avaya MS 7.6.

2. Prevent new sessions from starting on the system by navigating to EM > System Status >
Element Status and click More Actions > Pending Lock.

3. Click Confirm.

4. Check for active sessions on the server by navigating to EM > System Status >
Monitoring > Active Sessions.

Wait for the active sessions to end. If you continue before all active sessions end, then the
system ends the remaining active sessions.

5. Lock Avaya MS by navigating to EM > System Status > Element Status and click More
Actions > Lock.

This also ends any remaining sessions.

6. Click Confirm.

7. After the system ends all the sessions, stop Avaya MS by navigating to EM > System
Status > Element Status and clicking Stop.

8. Click Confirm.

9. Using the customer login credentials, open a Linux shell and run the following command to
install the Avaya MS software and all QFE patches included in the update:

InstallMediaServer
10. Follow the prompts to complete the installation.

11. After the update completes, verify that the required software is installed by navigating to
EM > Tools > Manage Software > Inventory.

12. Start Avaya MS by navigating to EM > System Status > Element Status and clicking Start.

13. Click Confirm.

14. Select EM > System Status > Element Status > More Actions > Unlock.

15. Click Confirm.

Updating Avaya MS
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16. Check for any service-impacting alarms and perform an appropriate test of the system. For
example, place a call to the application.

Removing updates
Before you begin
Before proceeding with the software removal, ensure that you:

• Use Element Manager to upload the earlier software release so that you can reinstall the
earlier software. When uninstalling and preserving data to remove updates, you can only go
back to the previously installed software version. You cannot install a version older than the
software previously installed because the data is not compatible.

• Back up the system.

In case of unforeseen problems during the downgrade, you can use the backup to restore the
system to the previous configuration.

• Remove updates one node at a time in a cluster configuration. The other nodes in the cluster
maintain service.

• Remove the update from the standby server first and then remove the updates from the active
server when upgrading High Availability clusters.

About this task
The update removal procedure downgrades your software to the previous software version.

If you follow this procedure, you do not have to reconfigure or re-provision the system. All system
configuration and application content data are preserved.

Remove updates during scheduled maintenance times.

Perform the following procedure to remove an installed updates from your system:

Procedure
1. Prevent new sessions from starting on the system by navigating to EM > System Status >

Element Status and select More Actions > Pending Lock.

2. Click Confirm.

3. Check for active sessions on the server by navigating to EM > System Status >
Monitoring > Active Sessions.

Wait for the active sessions to end. If you continue before all active sessions end, the system
ends the remaining active sessions.

4. Lock Avaya MS by navigating to EM > System Status > Element Status and clicking More
Actions > Lock. This also ends any remaining sessions.

5. Click Confirm.

6. After the system ends the sessions, stop Avaya MS by navigating to EM > System Status >
Element Status and clicking Stop.

Removing updates
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7. Click Confirm.

8. Using the customer login credentials, open a Linux shell and run the following command to
uninstall the media server:

UninstallMediaServer
Ensure that you select the option to preserve system configuration and application content
data.

Important:

You lose all the data if you do not accept the default action to preserve system
configuration and application content data.

9. Run the following command to install the Avaya MS software and all QFE patches included
in the update:

InstallMediaServer
10. Follow the prompts to complete the installation.

The installer automatically detects the preserved configuration and application content data.
Therefore, the system does not prompt you to choose an installation location or to reselect
any other options. The installer uses the original location and selections.

11. Open EM and navigate to EM > Tools > Manage Software > Inventory.

12. Verify whether the software versions listed are correct.

13. Check for any service-impacting alarms and perform an appropriate test of the system. For
example, place a call to the application.

Updating Avaya MS
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Chapter 9: Avaya MS appliance upgrade

Upgrade overview
You can upgrade a system from Avaya MS 7.5 to Avaya MS 7.6 or redeploy an existing Avaya MS
7.6 appliance while preserving the configuration and application content.

The upgrade procedures set the operational state to Pending Lock. The purpose of placing Avaya
MS in the Pending Lock state is to ensure that the system does not start any new sessions. After all
the sessions on the server have ended, then the server can be upgraded without disruption to any
users.

When you are ready to upgrade the server, the operational state is set to Locked, which ends any
remaining active sessions. When the upgrade is complete, Avaya MS is restarted and set as
Unlocked so that incoming service requests are processed.

When you place Avaya MS in the Pending Lock state prior to or at the beginning of the upgrade
maintenance window, a minimum number of user sessions, if any, are present when the server is
upgraded.

Simplex Avaya MS upgrade overview
A standalone Avaya MS that is not part of a cluster is referred to as a simplex Avaya MS.

Avaya MS is upgraded as follows:

• Back up the server data.
• End active sessions by setting the server through a progression of Pending Lock, Lock, and

Stopped states.
• Power off the current Avaya MS appliance.
• Perform the procedure for upgrading or redeploying the Avaya MS appliance.
• Verify the system is functional and that there are no unexpected alarms.
• Back up the new system.

N+1 load sharing cluster upgrade overview
In load sharing Avaya MS installations, you can maintain continuous access to Avaya MS services
during upgrades, by upgrading one cluster server at a time. Either the Primary or Secondary server
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must remain in service for the cluster to remain operational. Cluster service is lost if the Primary and
Secondary servers are out of service at the same time.

N+1 load sharing clusters of Avaya MS nodes are upgraded as follows:

• For the Primary server, perform the procedure to upgrade a simplex Avaya MS.

Wait for any alarms to clear as the server returns to service after the upgrade.

• For each Standard server, perform the procedure to upgrade a simplex Avaya MS.

Wait for any alarms to clear as the server returns to service after the upgrade.

• For the Secondary server, perform the procedure to upgrade a simplex Avaya MS.

Prerequisites for upgrade
Prior to upgrading to Avaya MS 7.6, ensure that the current Avaya MS servers are on release 7.5 or
7.6. You can check the installed software version, by navigating to EM > System Status > Element
Status > Installed Software Packages.

Upgrading or redeploying the Avaya MS appliance
Before you begin

• Create Avaya MS backups. Avaya MS 7.5 or 7.6 configuration and application data backups
are required to preserve the data through the upgrade. Ensure that the backup files are saved
in a safe location off the server.

• If you are upgrading a server that is a member of a cluster, ensure that you are performing this
task as part of one of the cluster upgrade procedures before continuing. Ensure that you start
at the correct step in the following procedure, as specified by the cluster upgrade procedure.

• Perform upgrades during scheduled maintenance times.
• Ensure that you power down the current Avaya MS appliance and deploy the new Avaya MS

OVA prior to starting the upgrade procedure.

About this task
Use this procedure to update an Avaya MS appliance in the following cases:

• Upgrading from an Avaya MS 7.5 appliance.
• Redeploying an Avaya MS 7.6 appliance.

Procedure
1. Prevent new sessions from starting on the system by navigating to EM > System Status >

Element Status and select More Actions > Pending Lock.

2. Click Confirm.

Avaya MS appliance upgrade
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3. Check for active sessions on the server by navigating to EM > System Status >
Monitoring > Active Sessions.

Wait for the active sessions to end. If you continue before all active sessions end, then the
system ends the remaining active sessions.

4. Lock Avaya MS, by navigating to EM > System Status > Element Status and clicking More
Actions > Lock.

This also ends any remaining sessions.

5. Click Confirm.

6. After the system ends the sessions, stop Avaya MS by navigating to EM > System Status >
Element Status and clicking Stop.

7. Click Confirm.

8. Ensure that you have system configuration and application content data backups before
proceeding.

Backup files are used to upgrade the current data. All data will be lost if you do not have
backups of your current Avaya MS 7.5 or 7.6 data.

9. Power off the Avaya MS appliance VM.

10. Deploy the new Avaya MS 7.6 appliance using the new Avaya MS 7.6 OVA.

When configuring the new OVA, use the same network settings that were used for the
existing Avaya MS appliance.

11. After the OVA deploy completes, log in to the Avaya MS EM.

If security alert dialog boxes appear in the browser, accept the new security conditions to
proceed.

12. Stop Avaya MS by navigating to EM > System Status > Element Status and clicking Stop.

13. Click Confirm.

14. Perform the following steps if you are upgrading from Avaya MS 7.5:

a. Log in to a Linux shell using the customer account.

b. Change to the public directory by using the cdpub alias or the following command:

cd /opt/avaya/app/pub
c. Transfer the configuration and application data backups to the system by using the

sftp file transfer tool or another similar tool.

d. Use the upgrade tool to upgrade the system configuration data by entering the following
on the command-line:

amsupgrade SystemConfiguration_backup.zip

Upgrading or redeploying the Avaya MS appliance
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Important:

The system configuration data must be restored before the application data. For a
pair of backup files created together, the file with the lower task number in the
filename is the system configuration data.

e. Press Y to stop all Avaya MS services when prompted.

The tool upgrades the data.

f. Use the upgrade tool to upgrade the application data by entering the following on the
command-line:

amsupgrade ApplicationContent_backup.zip
g. Press Y to stop all Avaya MS services when prompted.

The tool upgrades the data.

Note:

The time required to complete the application content upgrade depends on the
amount of application content data in the backup file.

15. Perform the following steps if you are updating an Avaya MS 7.6 appliance by redeploying
the OVA:

a. Navigate to EM > Tools > Backup and Restore > Restore.

b. On the Restore page, in the Restore Source drop-down list, click Upload Backup
Files.

c. Click Browse to select the backup files.

You can upload a System Configuration and Application Content backup at the same
time.

Tip:

If your web browser encounters a problem when you are using the EM web
browser-based restore file upload feature, you can use an alternate file upload
procedure. For more information, see Uploading and restoring backup files to the
appliance.

d. On the Confirm Restore page, review the information and click Confirm to proceed with
the restore.

Note:

The time required to restore the application content depends on the amount of
application content data in the backup file.

16. Verify the required software is installed by navigating to EM > Tools > Manage Software >
Inventory.

17. Start Avaya MS by navigating to EM > System Status > Element Status and clicking Start.

18. Click Confirm.

Avaya MS appliance upgrade
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19. Check for any service-impacting alarms and perform an appropriate test for the system. For
example, place a call to the application.

Important:

Running the upgrade tool, as recommended in this procedure, ensures that the system
configuration parameters and all application data is upgraded and ready to use.
However, there are new and updated system configuration options in this release that
are not automatically configured. To ensure that the new options are configured
properly, see Implementing and Administering Avaya Media Server 7.6. Many systems
might not need any additional configuration.

Related links
Uploading and restoring backup files to the appliance on page 23

Upgrading N+1 load sharing clusters
About this task
Load sharing Avaya MS clusters can maintain continuous access to Avaya MS services during
upgrades by upgrading one cluster server at a time.

The Primary and Secondary nodes in the cluster require special consideration during the upgrade,
since these nodes have master Content Store components on them serving the data needs of the
entire cluster. To provide content access, either the Primary or Secondary server must remain in
service during the upgrade. Standard nodes can only connect to Primary or Secondary servers on
the same software release. To ensure that the Standard nodes have a connection to a Primary or
Secondary server on the same release during the cluster upgrade, the Secondary server is
upgraded last.

Perform the following procedure to upgrade Avaya MS N+1 load sharing clusters:

Procedure
1. For the Primary server, perform the procedure to upgrade a simplex Avaya MS.

Wait for any alarms to clear as the server returns to service after the upgrade.

2. For each Standard server, perform the procedure to upgrade a simplex Avaya MS.

Wait for any alarms to clear as the server returns to service after the upgrade.

3. For the Secondary server, perform the procedure to upgrade a simplex Avaya MS.

4. Verify the success of the installation. Check for any service-impacting alarms and perform a
test of the system. For example, place a call to an application, and verify all the nodes in the
cluster receive calls.

Related links
Upgrading or redeploying the Avaya MS appliance on page 30

Upgrading N+1 load sharing clusters

October 2015 Deploying and Updating Avaya Media Server using VMware® in the Virtualized
Environment 33

Comments on this document? infodev@avaya.com

mailto:infodev@avaya.com?subject=Deploying and Updating Avaya Media Server using VMware® in the Virtualized Environment


Chapter 10: Troubleshooting the Avaya MS
appliance

Overview
This chapter contains troubleshooting information specific to an Avaya MS appliance deployment.
For general Avaya MS troubleshooting, see the troubleshooting chapter in Implementing and
Administering Avaya Media Server 7.6.

Managing Avaya MS system services
Some support and troubleshooting procedures require managing the services which run
components of the Avaya MS. The following services are on the system:

Service name Description
avaya.mediaserver Avaya Media Server
avaya.em Avaya Media Server Element Manager
avaya.mysql Embedded MySQL database
avaya.plic Avaya Media Server license server
avaya.snmp Avaya Media Server Simple Network Management agent
avaya.sysmonitor Avaya Media Server System Monitor

For Avaya MS appliances, you can access Avaya MS services by using the following commands on
an Avaya MS appliance:

Service command Syntax
Status service serviceName status
Start service serviceName start
Stop service serviceName stop
Restart service serviceName restart

For example, the following command restarts the Avaya MS EM service:

service avaya.em restart
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Unable to upload files larger than 2 GB
You can encounter errors when using EM to upload large backup files to Avaya MS appliance. Many
browsers have a 2 GB limit on file upload.

Proposed Solutions
• Use the latest versions of the Chrome or Firefox browsers. These browsers support file

uploads greater than 2GB.
• Use the alternate upload procedure. For more information see, Uploading and restoring backup

files to the appliance.

Related links
Uploading and restoring backup files to the appliance on page 23

Backup or restore tasks fail
The system requires temporary work space to create and restore backup archives of the application
content. The work space required is equal to two times amount of data stored in the media server.
For example, a system which will contain 2 GB of data in the Content Store, the /opt/avaya/app
volume must be provisioned with at least 6 GB of space. This equates to 2 GB of stored data and 4
GB of required free workspace for backup and restore operations. Old backup files should be
removed to maintain free space on the system.

Perform the following procedure to ensure there is enough free disk space on the volume for a
backup or restore.

Proposed Solution
1. Log in to a Linux shell using the customer account.
2. Display the available disk space on the system by issuing the following command: df –h
3. Note the amount of space in the Avail column of the output for the line containing /opt/

avaya/app in the Mounted on column.

For example, in the following example output, the available space is 18 GB.
Filesystem                   Size  Used Avail Use% Mounted on
/dev/sda5                    4.0G  1.4G  2.4G  37% /
tmpfs                        2.2G  1.4M  2.2G   1% /dev/shm
/dev/sda1                    4.0G  177M  3.6G   5% /boot
/dev/mapper/storage_vg-var1  6.0G  184M  5.5G   4% /var
/dev/mapper/storage_vg-app    20G  1.1G   18G   6% /opt/avaya/app
/dev/mapper/storage_vg-home  3.0G   69M  2.8G   3% /home

4. Remove old backup files and other unnecessary files to create the required space. Perform
the following steps to remove backup files:

a. Use the following command to list the current backup files:
bkupFile –list

b. Remove a backup file with the following commands:

Unable to upload files larger than 2 GB
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bkupFile –retrieve filename
rm filename

Resetting locked login accounts
If you are unable to log in to the system, the account might be locked.

The system locks the customer account after four failed login attempts.

The system supports a maximum of five simultaneous logins per user account. The system rejects
additional SSH, SCP, and Putty sessions when the five sessions are already logged in.

Proposed Solution
1. Close unused sessions if the maximum number of sessions has been exceeded.
2. Before you log in again, wait for about 20 minutes for the system to reset the locked account.
3. Contact Avaya support.

Avaya support personnel with root access can reset accounts that get locked as a result of
too many failed log in attempts.

VM does not power on after initial deployment or after
altering the VM resources

If the system detects resource reservations that it cannot provide then the VM does not power on
and an error message is posted in the vSphere client.

If you are using the vSphere Web client, look for errors under Recent Tasks > All. Click on the error
for details.

If you are using the vSphere Client Windows application, the system displays a pop-up window with
the error.

From the displayed error, determine if you have a resource error similar to the following:

Error name:
Power on error: Failed to power on VM.
The error stack indicates:
Could not power on VM: Admission check failed for cpu resource. There 
are not enough CPU resources to satisfy the reservation requirements.
or
Could not power on VM: Admission check failed for memory resource. There 
are not enough memory resources to satisfy the reservation requirements.

Troubleshooting the Avaya MS appliance
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Proposed Solutions
Fixing CPU reservation errors: 

• Move this VM to a host where the specified CPU reservation can be fulfilled.
• Reduce the CPU reservations of other VMs on the same host.

Fixing memory reservation errors: 
• Move this VM to a host where the memory reservation can be fulfilled.
• Reduce the memory reservations of other VMs on the same host.

While installing Avaya MS, use of the amspatch tool is
specified

You see the following message when running the InstallMediaServer command:

Avaya Media Server version 7.6.0.792 is already installed on the system.
Use the "amspatch" command to manage the installation, removal, and 
listing of QFEs for this installed version.
Proposed Solution
If the version of Avaya MS currently installed on the system is the same as the version in the
update, then you must use the amspatch tool to apply any new updates to the system. See
installing a QFE patch in Installing, Upgrading and Patching Avaya MS 7.6.

While installing Avaya MS, use of the amspatch tool is specified
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