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Notice
While reasonable efforts have been made to ensure that the
information in this document is complete and accurate at the time of
printing, Avaya assumes no liability for any errors. Avaya reserves
the right to make changes and corrections to the information in this
document without the obligation to notify any person or organization
of such changes.
Documentation disclaimer
“Documentation” means information published by Avaya in varying
mediums which may include product information, operating
instructions and performance specifications that Avaya may generally
make available to users of its products and Hosted Services.
Documentation does not include marketing materials. Avaya shall not
be responsible for any modifications, additions, or deletions to the
original published version of documentation unless such
modifications, additions, or deletions were performed by Avaya. End
User agrees to indemnify and hold harmless Avaya, Avaya's agents,
servants and employees against all claims, lawsuits, demands and
judgments arising out of, or in connection with, subsequent
modifications, additions or deletions to this documentation, to the
extent made by End User.
Link disclaimer
Avaya is not responsible for the contents or reliability of any linked
websites referenced within this site or documentation provided by
Avaya. Avaya is not responsible for the accuracy of any information,
statement or content provided on these sites and does not
necessarily endorse the products, services, or information described
or offered within them. Avaya does not guarantee that these links will
work all the time and has no control over the availability of the linked
pages.
Warranty
Avaya provides a limited warranty on Avaya hardware and software.
Refer to your sales agreement to establish the terms of the limited
warranty. In addition, Avaya’s standard warranty language, as well as
information regarding support for this product while under warranty is
available to Avaya customers and other parties through the Avaya
Support website: https://support.avaya.com/helpcenter/
getGenericDetails?detailId=C20091120112456651010 under the link
“Warranty & Product Lifecycle” or such successor site as designated
by Avaya. Please note that if You acquired the product(s) from an
authorized Avaya Channel Partner outside of the United States and
Canada, the warranty is provided to You by said Avaya Channel
Partner and not by Avaya.
“Hosted Service” means a hosted service subscription that You
acquire from either Avaya or an authorized Avaya Channel Partner
(as applicable) and which is described further in Hosted SAS or other
service description documentation regarding the applicable hosted
service. If You purchase a Hosted Service subscription, the foregoing
limited warranty may not apply but You may be entitled to support
services in connection with the Hosted Service as described further
in your service description documents for the applicable Hosted
Service. Contact Avaya or Avaya Channel Partner (as applicable) for
more information.
Hosted Service
THE FOLLOWING APPLIES IF YOU PURCHASE A HOSTED
SERVICE SUBSCRIPTION FROM AVAYA OR AN AVAYA CHANNEL
PARTNER (AS APPLICABLE), THE TERMS OF USE FOR HOSTED
SERVICES ARE AVAILABLE ON THE AVAYA WEBSITE, HTTPS://
SUPPORT.AVAYA.COM/LICENSEINFO UNDER THE LINK “Avaya
Terms of Use for Hosted Services” OR SUCH SUCCESSOR SITE
AS DESIGNATED BY AVAYA, AND ARE APPLICABLE TO ANYONE
WHO ACCESSES OR USES THE HOSTED SERVICE. BY
ACCESSING OR USING THE HOSTED SERVICE, OR
AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND THE ENTITY FOR WHOM YOU ARE DOING SO
(HEREINAFTER REFERRED TO INTERCHANGEABLY AS “YOU”
AND “END USER”), AGREE TO THE TERMS OF USE. IF YOU ARE
ACCEPTING THE TERMS OF USE ON BEHALF A COMPANY OR
OTHER LEGAL ENTITY, YOU REPRESENT THAT YOU HAVE THE
AUTHORITY TO BIND SUCH ENTITY TO THESE TERMS OF USE.

IF YOU DO NOT HAVE SUCH AUTHORITY, OR IF YOU DO NOT
WISH TO ACCEPT THESE TERMS OF USE, YOU MUST NOT
ACCESS OR USE THE HOSTED SERVICE OR AUTHORIZE
ANYONE TO ACCESS OR USE THE HOSTED SERVICE. YOUR
USE OF THE HOSTED SERVICE SHALL BE LIMITED BY THE
NUMBER AND TYPE OF LICENSES PURCHASED UNDER YOUR
CONTRACT FOR THE HOSTED SERVICE, PROVIDED,
HOWEVER, THAT FOR CERTAIN HOSTED SERVICES IF
APPLICABLE, YOU MAY HAVE THE OPPORTUNITY TO USE FLEX
LICENSES, WHICH WILL BE INVOICED ACCORDING TO ACTUAL
USAGE ABOVE THE CONTRACT LICENSE LEVEL. CONTACT
AVAYA OR AVAYA’S CHANNEL PARTNER FOR MORE
INFORMATION ABOUT THE LICENSES FOR THE APPLICABLE
HOSTED SERVICE, THE AVAILABILITY OF ANY FLEX LICENSES
(IF APPLICABLE), PRICING AND BILLING INFORMATION, AND
OTHER IMPORTANT INFORMATION REGARDING THE HOSTED
SERVICE.
Licenses
THE SOFTWARE LICENSE TERMS AVAILABLE ON THE AVAYA
WEBSITE, HTTPS://SUPPORT.AVAYA.COM/LICENSEINFO,
UNDER THE LINK “AVAYA SOFTWARE LICENSE TERMS (Avaya
Products)” OR SUCH SUCCESSOR SITE AS DESIGNATED BY
AVAYA, ARE APPLICABLE TO ANYONE WHO DOWNLOADS,
USES AND/OR INSTALLS AVAYA SOFTWARE, PURCHASED
FROM AVAYA INC., ANY AVAYA AFFILIATE, OR AN AVAYA
CHANNEL PARTNER (AS APPLICABLE) UNDER A COMMERCIAL
AGREEMENT WITH AVAYA OR AN AVAYA CHANNEL PARTNER.
UNLESS OTHERWISE AGREED TO BY AVAYA IN WRITING,
AVAYA DOES NOT EXTEND THIS LICENSE IF THE SOFTWARE
WAS OBTAINED FROM ANYONE OTHER THAN AVAYA, AN AVAYA
AFFILIATE OR AN AVAYA CHANNEL PARTNER; AVAYA
RESERVES THE RIGHT TO TAKE LEGAL ACTION AGAINST YOU
AND ANYONE ELSE USING OR SELLING THE SOFTWARE
WITHOUT A LICENSE. BY INSTALLING, DOWNLOADING OR
USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO,
YOU, ON BEHALF OF YOURSELF AND THE ENTITY FOR WHOM
YOU ARE INSTALLING, DOWNLOADING OR USING THE
SOFTWARE (HEREINAFTER REFERRED TO
INTERCHANGEABLY AS “YOU” AND “END USER”), AGREE TO
THESE TERMS AND CONDITIONS AND CREATE A BINDING
CONTRACT BETWEEN YOU AND AVAYA INC. OR THE
APPLICABLE AVAYA AFFILIATE (“AVAYA”).
Avaya grants You a license within the scope of the license types
described below, with the exception of Heritage Nortel Software, for
which the scope of the license is detailed below. Where the order
documentation does not expressly identify a license type, the
applicable license will be a Designated System License. The
applicable number of licenses and units of capacity for which the
license is granted will be one (1), unless a different number of
licenses or units of capacity is specified in the documentation or other
materials available to You. “Software” means computer programs in
object code, provided by Avaya or an Avaya Channel Partner,
whether as stand-alone products, pre-installed on hardware products,
and any upgrades, updates, patches, bug fixes, or modified versions
thereto. “Designated Processor” means a single stand-alone
computing device. “Server” means a Designated Processor that
hosts a software application to be accessed by multiple users.
“Instance” means a single copy of the Software executing at a
particular time: (i) on one physical machine; or (ii) on one deployed
software virtual machine (“VM”) or similar deployment.
License types
Designated System(s) License (DS). End User may install and use
each copy or an Instance of the Software only on a number of
Designated Processors up to the number indicated in the order.
Avaya may require the Designated Processor(s) to be identified in
the order by type, serial number, feature key, Instance, location or
other specific designation, or to be provided by End User to Avaya
through electronic means established by Avaya specifically for this
purpose.
Concurrent User License (CU). End User may install and use the
Software on multiple Designated Processors or one or more Servers,
so long as only the licensed number of Units are accessing and using
the Software at any given time. A “Unit” means the unit on which
Avaya, at its sole discretion, bases the pricing of its licenses and can
be, without limitation, an agent, port or user, an e-mail or voice mail

https://support.avaya.com/helpcenter/getGenericDetails?detailId=C20091120112456651010
https://support.avaya.com/helpcenter/getGenericDetails?detailId=C20091120112456651010
https://support.avaya.com/LicenseInfo
https://support.avaya.com/LicenseInfo
https://support.avaya.com/LicenseInfo


account in the name of a person or corporate function (e.g.,
webmaster or helpdesk), or a directory entry in the administrative
database utilized by the Software that permits one user to interface
with the Software. Units may be linked to a specific, identified Server
or an Instance of the Software.
Database License (DL). End User may install and use each copy or
an Instance of the Software on one Server or on multiple Servers
provided that each of the Servers on which the Software is installed
communicates with no more than one Instance of the same
database.
CPU License (CP). End User may install and use each copy or
Instance of the Software on a number of Servers up to the number
indicated in the order provided that the performance capacity of the
Server(s) does not exceed the performance capacity specified for the
Software. End User may not re-install or operate the Software on
Server(s) with a larger performance capacity without Avaya’s prior
consent and payment of an upgrade fee.
Named User License (NU). You may: (i) install and use each copy or
Instance of the Software on a single Designated Processor or Server
per authorized Named User (defined below); or (ii) install and use
each copy or Instance of the Software on a Server so long as only
authorized Named Users access and use the Software. “Named
User”, means a user or device that has been expressly authorized by
Avaya to access and use the Software. At Avaya’s sole discretion, a
“Named User” may be, without limitation, designated by name,
corporate function (e.g., webmaster or helpdesk), an e-mail or voice
mail account in the name of a person or corporate function, or a
directory entry in the administrative database utilized by the Software
that permits one user to interface with the Software.
Shrinkwrap License (SR). You may install and use the Software in
accordance with the terms and conditions of the applicable license
agreements, such as “shrinkwrap” or “clickthrough” license
accompanying or applicable to the Software (“Shrinkwrap License”).
Heritage Nortel Software
“Heritage Nortel Software” means the software that was acquired by
Avaya as part of its purchase of the Nortel Enterprise Solutions
Business in December 2009. The Heritage Nortel Software is the
software contained within the list of Heritage Nortel Products located
at https://support.avaya.com/LicenseInfo under the link “Heritage
Nortel Products” or such successor site as designated by Avaya. For
Heritage Nortel Software, Avaya grants Customer a license to use
Heritage Nortel Software provided hereunder solely to the extent of
the authorized activation or authorized usage level, solely for the
purpose specified in the Documentation, and solely as embedded in,
for execution on, or for communication with Avaya equipment.
Charges for Heritage Nortel Software may be based on extent of
activation or use authorized as specified in an order or invoice.
Copyright
Except where expressly stated otherwise, no use should be made of
materials on this site, the Documentation, Software, Hosted Service,
or hardware provided by Avaya. All content on this site, the
documentation, Hosted Service, and the product provided by Avaya
including the selection, arrangement and design of the content is
owned either by Avaya or its licensors and is protected by copyright
and other intellectual property laws including the sui generis rights
relating to the protection of databases. You may not modify, copy,
reproduce, republish, upload, post, transmit or distribute in any way
any content, in whole or in part, including any code and software
unless expressly authorized by Avaya. Unauthorized reproduction,
transmission, dissemination, storage, and or use without the express
written consent of Avaya can be a criminal, as well as a civil offense
under the applicable law.
Virtualization
The following applies if the product is deployed on a virtual machine.
Each product has its own ordering code and license types. Note that
each Instance of a product must be separately licensed and ordered.
For example, if the end user customer or Avaya Channel Partner
would like to install two Instances of the same type of products, then
two products of that type must be ordered.
Third Party Components
“Third Party Components” mean certain software programs or
portions thereof included in the Software or Hosted Service may

contain software (including open source software) distributed under
third party agreements (“Third Party Components”), which contain
terms regarding the rights to use certain portions of the Software
(“Third Party Terms”). As required, information regarding distributed
Linux OS source code (for those products that have distributed Linux
OS source code) and identifying the copyright holders of the Third
Party Components and the Third Party Terms that apply is available
in the products, Documentation or on Avaya’s website at: https://
support.avaya.com/Copyright or such successor site as designated
by Avaya. The open source software license terms provided as Third
Party Terms are consistent with the license rights granted in these
Software License Terms, and may contain additional rights benefiting
You, such as modification and distribution of the open source
software. The Third Party Terms shall take precedence over these
Software License Terms, solely with respect to the applicable Third
Party Components to the extent that these Software License Terms
impose greater restrictions on You than the applicable Third Party
Terms.
The following applies if the H.264 (AVC) codec is distributed with the
product. THIS PRODUCT IS LICENSED UNDER THE AVC PATENT
PORTFOLIO LICENSE FOR THE PERSONAL USE OF A
CONSUMER OR OTHER USES IN WHICH IT DOES NOT RECEIVE
REMUNERATION TO (i) ENCODE VIDEO IN COMPLIANCE WITH
THE AVC STANDARD (“AVC VIDEO”) AND/OR (ii) DECODE AVC
VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A
PERSONAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO
PROVIDER LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS
GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE.
ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEG LA,
L.L.C. SEE HTTP://WWW.MPEGLA.COM.
Service Provider
THE FOLLOWING APPLIES TO AVAYA CHANNEL PARTNER’S
HOSTING OF AVAYA PRODUCTS OR SERVICES. THE PRODUCT
OR HOSTED SERVICE MAY USE THIRD PARTY COMPONENTS
SUBJECT TO THIRD PARTY TERMS AND REQUIRE A SERVICE
PROVIDER TO BE INDEPENDENTLY LICENSED DIRECTLY FROM
THE THIRD PARTY SUPPLIER. AN AVAYA CHANNEL PARTNER’S
HOSTING OF AVAYA PRODUCTS MUST BE AUTHORIZED IN
WRITING BY AVAYA AND IF THOSE HOSTED PRODUCTS USE
OR EMBED CERTAIN THIRD PARTY SOFTWARE, INCLUDING
BUT NOT LIMITED TO MICROSOFT SOFTWARE OR CODECS,
THE AVAYA CHANNEL PARTNER IS REQUIRED TO
INDEPENDENTLY OBTAIN ANY APPLICABLE LICENSE
AGREEMENTS, AT THE AVAYA CHANNEL PARTNER’S EXPENSE,
DIRECTLY FROM THE APPLICABLE THIRD PARTY SUPPLIER.
WITH RESPECT TO CODECS, IF THE AVAYA CHANNEL
PARTNER IS HOSTING ANY PRODUCTS THAT USE OR EMBED
THE G.729 CODEC, H.264 CODEC, OR H.265 CODEC, THE
AVAYA CHANNEL PARTNER ACKNOWLEDGES AND AGREES
THE AVAYA CHANNEL PARTNER IS RESPONSIBLE FOR ANY
AND ALL RELATED FEES AND/OR ROYALTIES. THE G.729
CODEC IS LICENSED BY SIPRO LAB TELECOM INC. SEE 
WWW.SIPRO.COM/CONTACT.HTML. THE H.264 (AVC) CODEC IS
LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE FOR
THE PERSONAL USE OF A CONSUMER OR OTHER USES IN
WHICH IT DOES NOT RECEIVE REMUNERATION TO: (I) ENCODE
VIDEO IN COMPLIANCE WITH THE AVC STANDARD (“AVC
VIDEO”) AND/OR (II) DECODE AVC VIDEO THAT WAS ENCODED
BY A CONSUMER ENGAGED IN A PERSONAL ACTIVITY AND/OR
WAS OBTAINED FROM A VIDEO PROVIDER LICENSED TO
PROVIDE AVC VIDEO. NO LICENSE IS GRANTED OR SHALL BE
IMPLIED FOR ANY OTHER USE. ADDITIONAL INFORMATION
FOR H.264 (AVC) AND H.265 (HEVC) CODECS MAY BE
OBTAINED FROM MPEG LA, L.L.C. SEE HTTP://
WWW.MPEGLA.COM.
Compliance with Laws
Customer acknowledges and agrees that it is responsible for
complying with any applicable laws and regulations, including, but not
limited to laws and regulations related to call recording, data privacy,
intellectual property, trade secret, fraud, and music performance
rights, in the country or territory where the Avaya product is used.
Preventing Toll Fraud
“Toll Fraud” is the unauthorized use of your telecommunications
system by an unauthorized party (for example, a person who is not a
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corporate employee, agent, subcontractor, or is not working on your
company's behalf). Be aware that there can be a risk of Toll Fraud
associated with your system and that, if Toll Fraud occurs, it can
result in substantial additional charges for your telecommunications
services.
Avaya Toll Fraud intervention
If You suspect that You are being victimized by Toll Fraud and You
need technical assistance or support, call Technical Service Center
Toll Fraud Intervention Hotline at +1-800-643-2353 for the United
States and Canada. For additional support telephone numbers, see
the Avaya Support website: https://support.avaya.com or such
successor site as designated by Avaya.
Security Vulnerabilities
Information about Avaya’s security support policies can be found in
the Security Policies and Support section of https://
support.avaya.com/security.
Suspected Avaya product security vulnerabilities are handled per the
Avaya Product Security Support Flow (https://
support.avaya.com/css/P8/documents/100161515).
Downloading Documentation
For the most current versions of Documentation, see the Avaya
Support website: https://support.avaya.com, or such successor site
as designated by Avaya.
Contact Avaya Support
See the Avaya Support website: https://support.avaya.com for
product or Hosted Service notices and articles, or to report a problem
with your Avaya product or Hosted Service. For a list of support
telephone numbers and contact addresses, go to the Avaya Support
website: https://support.avaya.com (or such successor site as
designated by Avaya), scroll to the bottom of the page, and select
Contact Avaya Support.
Trademarks
The trademarks, logos and service marks (“Marks”) displayed in this
site, the Documentation, Hosted Service(s), and product(s) provided
by Avaya are the registered or unregistered Marks of Avaya, its
affiliates, or other third parties. Users are not permitted to use such
Marks without prior written consent from Avaya or such third party
which may own the Mark. Nothing contained in this site, the
Documentation, Hosted Service(s) and product(s) should be
construed as granting, by implication, estoppel, or otherwise, any
license or right in and to the Marks without the express written
permission of Avaya or the applicable third party.
Avaya is a registered trademark of Avaya Inc.
All non-Avaya trademarks are the property of their respective owners.
Linux® is the registered trademark of Linus Torvalds in the U.S. and
other countries.
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Chapter 1: Introduction

Purpose
This document describes the methods and the system requirements used to create speech
applications that comply with VoiceXML version 2.1, call control applications that comply with
CCXML specification and, message applications that comply with TextXML, and mobile applications
that comply with the HTML5 specification.

Intended audience
This document is intended for anyone who wants to gain a high-level understanding of the product
features, functionality, capacities, and limitations within the context of solutions and verified
reference configurations.

New in this release
The following changes are introduced for Orchestration Designer 7.2:

• Engagement Development Platform is referred as Avaya Breeze™.
• Updated the system requirements to support Orchestration Designer 7.2.
• Added the procedure to install Orchestration Designer 7.2.
• Added the procedure to upgrade Orchestration Designer 7.2.

Warranty
Avaya Inc. provides a 90-day limited warranty on Orchestration Designer. Refer to your sales
agreement or other applicable documentation to establish the terms of the limited warranty. In
addition, Avaya’s standard warranty language as well as details regarding support for Orchestration
Designer, while under warranty, is available on the support website at http://www.avaya.com/
support.
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Viewing the Eclipse documentation
About this task
The documentation for Eclipse and supporting Eclipse components (GEF and WTP) is available at 
http://www.eclipse.org/documentation/, and in the form of an online Help.

• On the Help menu > click Help Contents.

Viewing the Orchestration Designer documentation
About this task
The Getting Started with Avaya Aura® Orchestration Designer guide is available on the
Orchestration Designer installation ISO image.
You can view the Orchestration Designer documentation on the Avaya support website:
http://support.avaya.com
The Orchestration Designer documentation is also available in the form of an online Help.

• On the Help menu, click Help Contents > Avaya Aura® Orchestration Designer - Self
Service.

Documentation for related products and technologies
Orchestration Designer depends on the use of several closely related software products and
technologies. When using Orchestration Designer, review the documentation of these related
products and technologies.
Avaya does not reproduce or package the documentation for these related products and
technologies. However, to help locate the appropriate documentation, review the following
resources:

Note:
The following URLs were valid at the time of publication of this document. Avaya is not
responsible if these URLs have changed. For more updated URLs, perform a search operation
online.

• For Eclipse and supporting Eclipse components (GEF and WTP), go to:
http://www.eclipse.org/documentation/
For more information, see Viewing the Eclipse documentation on page 8.

• For the Java SDK (Software Developer’s Kit), go to:
http://docs.oracle.com/javase/8/docs/index.html

Introduction
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• For Tomcat 7.0, or 8.0, go to:
http://tomcat.apache.org/tomcat-7.0-doc/index.html
http://tomcat.apache.org/tomcat-8.0-doc/index.html

• For IBM WebSphere or WebSphere Express, go to:
http://www.ibm.com/websphere

• For WebLogic, go to:
http://www.oracle.com/technetwork/middleware/weblogic/documentation/index.html

• For Redhat JBoss EAP, go to:
https://developers.redhat.com/products/eap/overview/

• For JBoss Wildfly, go to:
http://wildfly.org/

• For databases and JDBC implementation, go to:
http://www.sql.org/
http://www.firstsql.com/tutor.htm
http://java.sun.com/developer/onlineTraining/Database/JDBCShortCourse/jdbc/sql.html

• For Web services, go to:
http://www.w3.org/TR/wsdl
http://www.ws-i.org/Profiles/BasicProfile-1.1-2004-08-24.html

• For the W3C VoiceXML 2.0 Recommendation, go to:
http://www.w3.org/TR/voicexml20/

• For the W3C VoiceXML 2.1 Recommendation, go to:
http://www.w3.org/TR/voicexml21/

• For the W3C CCXML 1.0 Recommendation (January 19, 2007), go to:
http://www.w3.org/TR/ccxml/

• For the Speech Recognition Grammar Specification version 1.0, go to:
http://www.w3.org/TR/speech-grammar/#AppJ.5

Documentation for related products and technologies
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Chapter 2: Installation and configuration

Overview
Avaya Aura® Orchestration Designer (Orchestration Designer) is a Java-based tool that you can use
to create:

• Speech applications that comply with VoiceXML version 2.1.

• Call control applications that comply with CCXML version 1.0 January 19, 2007, specification.

• Message applications that comply with TextXML.

Designed as an Eclipse plug-in, Orchestration Designer provides an integrated GUI for the design
and implementation of:

• Speech applications that can operate with Interactive Response, Voice Portal, Media
Processing Server, and Avaya Aura® Experience Portal systems.

• Message applications that can operate with Avaya Aura® Experience Portal system.

• Data only applications that can operate with Avaya Aura® Experience Portal system

• HTML5 applications that can operate with Avaya Aura® Experience Portal system.

Orchestration Designer is a suite of self-service products and Avaya Contact Center products,
namely, Avaya Aura® Experience Portal, Avaya Interactive Response (IR), Media Processing Server
(MPS), and Avaya Aura® Contact Center. As a single tool, you can use Orchestration Designer to
design, simulate, and maintain the contact routing scripts with inbound and outbound self-service
support. Orchestration Designer accelerates the service design and deployment, reduces the cost,
and enhances the customer experience.

Orchestration Designer integrates seamlessly with Avaya Breeze™ and allows an Orchestration
Designer application to interact with the Engagement Designer workflows and pass the collected
data in several ways:

• Orchestration Designer can start a workflow and pass collected data to that workflow using
Context Store. This integration enables the workflow to process the information and complete
the transaction using the data that it receives from Orchestration Designer.

• Orchestration Designer supports integration of Orchestration Designer SMS and Email
applications with Engagement Designer workflow. The integration enables the Orchestration
Designer application to receive data from Engagement Designer workflow, interact using one
more text messages and return the data to the Engagement Designer workflow.
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Note:

Orchestration Designer 7.2 does not support the integration of Orchestration Designer
SMS and Email applications with Engagement Designer. So, the dynamic tasks to launch
the SMS and Email applications are disabled in the current release.

• A Engagement Designer workflow can initiate a new call to the customer and plug-in
Orchestration Designer into the call to provide IVR services.

• A Engagement Designer workflow can plug-in Orchestration Designer into an existing call.

Orchestration Designer works with widely accepted Eclipse.org development
framework.Orchestration Designer provides a drag-and-drop environment for development and
maintenance of speech, touchtone, and message applications.

Multi-Channel Self Service (MCSS)
The Multi-Channel Self Service (MCSS) primarily allows users to extend the current Experience
Portal or Orchestration Designer product capabilities to include channels other than inbound voice
(telephony).
Key capabilities of MCSS include:

• Application processing of inbound SMS and Email.
• Sending a response to an inbound SMS and Email.
• Sending outbound SMS and Email from applications (cross channel). A speech application

sending an SMS or Email confirmation, for example.
• New application type Web in Orchestration Designer.
• Application design palettes specific to a channel.
• Generic message flow with custom xml generation for social media and other channels.
• Transferring items to AACC agent for handling with reply via SMS and Email.
• Web channel to collect information via HTML5 pages

Inbound processing of SMS and Email adds text channels to the Experience Portal. You can build
Orchestration Designer applications to process and respond to incoming SMS and Email. In addition
the outbound SMS and Email allows an application on a given channel to provide additional
feedback to a user via another channel. For example, a speech application might send a
confirmation of a transaction to the user via email or SMS. Items that cannot be handled in Self
Service can be transferred to an AACC agent via a connector.

Features and benefits
Orchestration Designer:

• Simplifies development, integration, and reusability of speech and touchtone applications.
• Significantly reduces time and cost of application prototyping and design.
• Provides unprecedented coverage of customer self-service, employee-facing productivity, and

advanced call control application areas.

Features and benefits
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• Ensures consistent and more reliable deployment of voice supporting services and
applications.

• Maximizes the use of tooling investments for more rapid deployment of Web-based voice
applications through the open Eclipse-based framework.

• Integrates with Avaya Breeze™ and Avaya Context Store Snap-in providing a centralized
location to store context information.

• Provides the capability to integrate Orchestration Designer voice, SMS, and Email applications
with Engagement Designer and receive and send data to the Engagement Designer workflow.

• Provides support for mobile application with HTML5.

• Provides two-way integration with Avaya Breeze™ and Avaya Engagement Designer Snap-in.

• Provides multi-channel support.

• Starting with the JTAPI 3.1 driver, the OD CTI (AES) connector, can use the UCID (Universal
Call ID) to keep track of call ID’s. To use this feature, you must enable OD CTI (AES) connector
on your switch.

Note:

It is not mandatory to enable OD CTI (AES) connector. However, it will guarantee no call
ID’s are recycled which have been problematic in the past with high call volumes.

System requirements

License requirements
You must have a valid license to run Orchestration Designer applications on Avaya Aura®

Experience Portal, Avaya Voice Portal, Avaya Interactive Response (IR), Avaya Media Processing
Server (MPS), and other supported VXML platforms. Orchestration Designer licenses are free. You
can contact an Avaya sales representative or the channel manager to get the license file. Avaya
partners can log on to Partner Portal to find information about ordering additional licenses. If yes,
source it just like the other product names.
If you run the Orchestration Designer applications on Voice Portal, Avaya Aura® Experience Portal,
IR, or other Avaya products that use the WebLM license server, then Orchestration Designer does
not require a separate WebLM license server. You must install the Orchestration Designer license
on the existing WebLM license server that is installed with Voice Portal, Avaya Aura® Experience
Portal, IR, or other Avaya products that use the WebLM license server.
If you run the Orchestration Designer applications on MPS, then you must install the WebLM license
server and configure the license information of Orchestration Designer. You must install a separate
WebLM license server because the system does not install the WebLM license server during the
MPS installation.

Installation and configuration
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Orchestration Designer license has a grace period of 30 days. If the WebLM license server is
unavailable after Orchestration Designer obtains the license from the WebLM license server,
Orchestration Designer is available for use for 30 days.
You do not require a license to install or run the Eclipse-based Orchestration Designer development
and the simulation environment.

Related links
About the WebLM license server installation and configuration on page 17

Hardware requirements
The system that hosts the Orchestration Designer development environment must meet the
following hardware requirements:

Hardware Minimum requirement Preferred value
CPU speed 1 GHz 2 GHz
RAM 1 GB 2 GB
Hard disk drive 40 GB —
Monitor resolution 1024 x 768 pixels —

Software requirements
The system that hosts the Orchestration Designer development environment must have the
following software packages installed. You must install these packages before installing and
configuring Orchestration Designer. The software required to host the Orchestration Designer
development environment is available on the Orchestration Designer 7.2 ISO image.

Important:
To upgrade Orchestration Designer, see the following requirements:

Software requirement On ISO
image

Notes and links

You must have any one of the
following:

• Microsoft Windows 7
(Professional and Enterprise
versions)

• Microsoft Windows 10

No You can install Orchestration Designer on any of these
operating systems if you meet all hardware requirements
and install all the supporting software packages.

Note:

For the development environment, Orchestration
Designer supports Windows 7, 32 bit and 64 bit.
However, for 64 bit operating system, you must use 32
bit JRE and Eclipse version.

Table continues…

System requirements
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Software requirement On ISO
image

Notes and links

• Google Chrome 57

• Mozilla Firefox 43

• Microsoft Internet Explorer 11

No You must install Google Chrome 57, Microsoft Internet
Explorer 11, or Mozilla Firefox 43 for simulation of HTML5
application.

• J2SE Development Kit 7.0 (JDK
7.0)

• J2SE Development Kit 8.0 (JDK
8.0)

No The JDK includes the Java Run-Time Environment (JRE)
and command-line tools, compilers, and debuggers used in
developing applets and applications. Java 7 supports SHA2
certificates.

Note:

Orchestration Designer 7.2.0 requires Java version 7
or later. It is not backward compatible with earlier
versions. Orchestration Designer supports JDK 7 and
JDK 8 from Oracle and OpenJDK.

You must have any one of the
following:

• Eclipse-4.5-Prereq-AAOD.zip

• Eclipse-4.6-Prereq-AAOD.zip

Yes Eclipse is a Java-based open-source integrated
development environment (IDE) for software development.
Orchestration Designer runs as an Eclipse plug-in.

Orchestration Designer uses the Eclipse Graphical Editing
Framework plug-ins for Eclipse (GEF) for advanced
graphical functions. Orchestration Designer also includes
the support files for Call Control (CCXML) development.

Apache Tomcat 7.0 or Tomcat 8.0 Yes Tomcat generates and serves VoiceXML pages to the
Avaya Application Simulator.

Note:

• You must have administrative privileges when
running Tomcat.

• If you upgrade to Tomcat 8.0, you might need to
make small adjustments the first time you run
Tomcat. If your applications have manually
configured build paths or have resources in
common/lib or common/classes, then you must
manually update the build path to point to
<tomcat_installpath>/lib. You must put also
put any resources, such as libraries, in that folder.

Avaya Breeze™ 3.2 No Avaya Breeze™ provides a virtualized and secure
application platform where Java programmers can develop
and dynamically deploy advanced collaboration capabilities.
For more information on installing Avaya Breeze™, see
Deploying Avaya Breeze™.

Avaya Engagement Designer
Snap-in 3.2

No Avaya Engagement Designer Snap-in offers business
analysts, non-technical resources, and developers the
opportunity to write logical business process flows. These
process flows can leverage any Avaya Breeze™ snap-in

Table continues…

Installation and configuration
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Software requirement On ISO
image

Notes and links

that have an associated palette of tasks. For more
information on Avaya Engagement Designer Snap-in, see
Avaya Engagement Designer Reference.

Experience Portal Snap-in tasks:

• Launch SMS Service

• Launch Email Service

No Experience Portal Snap-in tasks to start Orchestration
Designer SMS and Email application. For more information
on Experience Portal Snap-in tasks, see Experience Portal
Tasks.

Note:

Orchestration Designer 7.2 does not support the
integration of Orchestration Designer SMS and Email
applications with Engagement Designer. So, the
dynamic tasks to launch the SMS and Email
applications are disabled in the current release.

Avaya Context Store Snap-in 3.2 No Avaya Context Store provides a flexible and easy
integration among different applications, providing a
centralized solution to store context information. For more
information on installing Avaya Context Store, see Avaya
Context Store Snap-in Reference.

Microsoft SAPI Speech 6.0 Yes Orchestration Designer uses Microsoft SAPI Speech during
application testing to perform automated speech
recognition (ASR) and text-to-speech (TTS) functions.

Note:

Microsoft Windows 7 already have Microsoft Speech
components installed.

If Microsoft SAPI Speech is installed on Windows 7,
verify if the Speech Recognition and Text-to-Speech
tabs are available in Control Panel > Speech
Recognition > Text-to-Speech.

Storm Codec 7.01.19 Yes You must install Storm Codec 7.01.19 only if you intend to
use 3GP video files for media.

To open the Storm Codec installer, see the installation
notes available on the ISO image.

Ambulant player 2.1 No Orchestration Designeruses Ambulant player 2.1 for playing
and previewing media files.

Do not use all menu, toolbar, and controls in the Ambulant
player 2.1.

Nuance Recognizer 9/10
(MRCPv1)

No You must acquire Nuance Recognizer directly from the
vendor.

Loquendo Speech Server 7/
MRCPv1 Server 7.2 or higher

No You must acquire Loquendo Speech Server directly from
the vendor.

Table continues…

System requirements
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Software requirement On ISO
image

Notes and links

Users launch the ISO image, and use the displayed HTML index page to navigate to the required resources
as specific locations on the ISO image are described here. By following these instructions, installation is
smoother because the online navigation documentation leads you along the correct installation path.
Following these instructions is the preferred method for using the ISO image and installing efficiently.

General Upgrades Notes
3.2.1 Before upgrading your application server, make

copies of tsapi.pro, ddconfig.xml,
trusted_weblm_certs.jksfiles files, so that
you can restore the files, if they are overwritten by
the upgrade.

3.2.2 The Orchestration Designer upgrade process does
not change any custom code. The application
developer must manually resolve the errors or
warnings resulting from OD version upgrades (such
as variable name changes) that affect the custom
code.

3.2.3 If you have an existing installation in which you have
updated the certificate file
(trusted_weblm_certs.jks), then you must
save a copy of the certificates file when reinstalling
the runtime support files.

3.2.4 When upgrading applications from Windows XP to
Windows 7, the call flow visual representation might
experience some issues because of the difference in
the graphics layer between the 2 Windows releases.
Some corrections are required.

3.2.5 Framework updates are there that might result in
Java compilation errors after upgrading. To correct
this, regenerate projects reporting errors.

3.2.6 Remove Older Jar files after upgrade. After
upgrading, ensure that you do not have old versions
of jar files on the application server: Some examples
are:

commons-httpclient-3.1.jar
commons-logging-1.1.1.jar
log4j-1.2.15.jar
wss4j-1.5.8.jar
scertcommon-07.01.08.04.jar
scertcommon-07.01.07.01.jar

Installation and configuration
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About the WebLM license server installation and
configuration

If you run the Orchestration Designer applications on MPS, then you must install the WebLM license
server and configure the license information of Orchestration Designer. You must install a separate
WebLM license server because the system does not install the WebLM license server during the
MPS installation.

Use the WebLM.war file that is available on the Orchestration Designer 7.2.0 installation ISO image
to install the WebLM license server software.

For versions WebLM 6.3.11 and above, the WebLM server accepts requests only over TLS 1.0 and
above. If the product application is configured to send requests on SSLv2 or SSLv3, then the
communication between the product application fails. So, if the product application is upgrading
WebLM to 6.3.11 and above, then ensure that the product application is configured to send requests
only over TLS 1.0 and above.

For information about installing and configuring the WebLM license server software, see the
Licensing Installation Instructions for WebLM guide and Licensing Release Notes for WebLM.

The WebLM.war file, Licensing Installation Instructions for WebLM guide, and Licensing Release
Notes for WebLM are available on the Orchestration Designer 7.2.0 installation ISO image at:

<absolute path of ISO image>:\Software\WebLM\
Related links

License requirements on page 12

Installing Orchestration Designer manually
Before you begin
Before installing the Orchestration Designer software, temporarily disable the antivirus software and
close any open or running applications. Orchestration Designer installation includes extracting Java-
related files from a compressed archive and the antivirus software can slow down the installation
process.

About this task
The Orchestration Designer installation ISO image contains the Orchestration Designer distribution
executable. Before running the executable, ensure that you meet all system requirements, as
mentioned in System requirements on page 12.

Important:
The procedure described in this section is for new installations of the Orchestration Designer
software. To upgrade Orchestration Designer, see About Orchestration Designer Upgrade on
page 30.

About the WebLM license server installation and configuration
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Procedure
1. Copy the Orchestration Designer installation ISO image to the local drive.

2. Download and install the JDK installer (Open or Oracle).

For Oracle JDK 7, see http://www.oracle.com/technetwork/java/javase/downloads/java-
archive-downloads-javase7-521261.html.

For Oracle JDK 8, see http://www.oracle.com/technetwork/java/javase/downloads/jdk8-
downloads-2133151.html.

3. Install Eclipse and all other Eclipse prerequisite features:

a. Locate the package file on the Orchestration Designer 7.2.0 ISO image. This file is
located in the following directory: <absolute path of ISO image>:\Software
\Eclipse\.

b. Extract the .zip file into an installation folder.

c. (Optional) Create a shortcut for the Eclipse executable. Eclipse launches Orchestration
Designer.

4. Install Orchestration Designer software:

a. Locate the AAOD_7.2.0.XXX.jar installation archive on the Orchestration Designer
7.2.0 ISO image and copy it to a temporary location.

The installation archive is located in the <absolute path of ISO image>:
\UpdateSites\ directory.

b. On the eclipse interface, click Help > Install New Software.

c. On the Available software page, click Add.

d. On the Add Repository page, enter a name and click Archive to specify the location of
the AAOD_7.2.0.XXX.jar file.

e. Click OK.

f. Click Select All.
g. On the Available software page, clear the Contact all update site sites during install

to find the required software check box and then click Next.
h. On the Install Details page, click Next.

The system displays Avaya Software License Agreement.

i. Review the license agreement and then click I accept the term of the license
agreement.

j. Click Finish.

k. When prompted to trust the certificates, click Select All, and click OK.

l. Click Restart Now to restart eclipse.

Installation and configuration
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5. Install Tomcat:

a. Locate the Tomcat distribution package on the Orchestration Designer 7.2.0 ISO image.

The Tomcat distribution package is located in the <absolute path of ISO
image>:\Software\Tomcat\ directory.

b. Extract the .zip file in a temporary folder.

c. Review the RUNNING.txt file for more installation instructions.

Important:

Do not install Tomcat as an NT service. Orchestration Designer does not support
this configuration because Tomcat does not start and stop appropriately when
developing applications.

6. (Optional) Install Microsoft Speech API 6.0:

a. Copy the Orchestration Designer 7.2.0 installation ISO image to the local drive.

b. Go to <absolute path of ISO image> > Software > MSSpeech
c. Double-click the Setup.exe file.

The system displays the Microsoft SAPI Speech wizard.

d. In the Welcome dialog box, click Next.
e. Accept the license terms and then click Next.
f. Enter a user name and the organization in the Customer Information dialog box, then

click Next.
g. Accept the default installation folder, when prompted, or navigate to another, if

applicable. Then, click Next.
h. Click Install to begin the Microsoft SAPI Speech installation.

i. Click Finish when the installation is complete.

7. (Optional) Optionally, install the Storm Codec 7.01.19. To start the Storm Codec 7.01.19,
refer the Installation Notes on the ISO image.

Note:
• After you complete the installation procedure, read the Eclipse “readme” file located in

the /readme subdirectory where Eclipse is installed. The Eclipse readme file includes
valuable information and tips for configuring Eclipse.

• Before you use Orchestration Designer, you must configure the basic settings. For
information about configuring your development environment settings, see Basic
configuration on page 21.

Installing Orchestration Designer manually
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Installing Orchestration Designer using pre-packaged
installation

Before you begin
Before you use the prepackaged Orchestration Designer installation, ensure you have installed the
Java Development Kit.

About this task
The Orchestration Designer ISO image contains a prepackaged Orchestration Designer installation
that contains both the Self Service and Contact Center features and also a Tomcat installation.

Procedure
1. Copy the Orchestration Designer installation ISO image to the local drive and navigate to the

root folder of the ISO image.

2. Copy the AAOD7.2.0 folder to C:\ directory on your computer.

3. Double-click eclipse.exe file in the AAOD7.2.0\eclipse folder to install and open
Orchestration Designer.

Tip:

To access the Orchestration Designer, you can create a shortcut to eclipse.exe and
make the shortcut in a convenient location.

4. Open Orchestration Designer and perform the following step to configure the preferences for
the location of the Tomcat installation:

Click Window > Preferences > Tomcat and set the Tomcat home value.

For example, if you copied the AAOD7.2.0 folder to your C:\ drive, then the Tomcat
home value is C:\AAOD7.2.0\apache-tomcat-7.0.55.

Viewing the version number of an installed Orchestration
Designer software

Procedure
1. On the Help menu, click About Eclipse SDK.

2. In the About Eclipse SDK dialog box, click Installation Details.

The system displays the Eclipse SDK Installation Details dialog box, which contains the
installation and configuration details.

Installation and configuration
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Basic configuration
Before you start creating Orchestration Designer projects, you must perform some basic
configurations to ensure that the environment is configured and ready to use.

Creating an Eclipse shortcut
About this task
After you complete installing all installation components, you can start Eclipse to access the
Orchestration Designer. For easy access to Eclipse, you can create a Windows desktop shortcut
icon to the eclipse.exe Eclipse executable file, which is located where Eclipse is installed.

Procedure
1. To create an Eclipse shortcut, right-click the eclipse.exe Eclipse executable file which is

located where Eclipse is installed, and then click Send To > Desktop (create shortcut).
2. Double-click the shortcut file to startOrchestration Designer.

The system displays the Workspace Launcher dialog box.

Setting up the workspace
About this task
After you start Orchestration Designer, through Eclipse, for the first time, the Eclipse Workspace
Launcher dialog box prompts you to specify a workspace location. Specify a directory to save all
Orchestration Designer project files.

Important:
If you are configuring a new version of Orchestration Designer, back up all files in the original
installation directory before configuring a new directory.

Procedure
1. Double-click eclipse.exe.

For more information, see Creating an Eclipse shortcut on page 21.

2. In the Workspace Launcher dialog box, click Browse to navigate to the location to set as the
workspace location.

The default directory is relative to the installation path of Eclipse. For example, C:\Eclipse
\workspace.

3. Click OK.

Basic configuration
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Note:

To stop the Workspace Launcher dialog box from prompting for this directory with every
start of Eclipse, select the Use this as the default and do not ask again check box,
and then click OK.

Settings configuration

Configuring the default perspective
About this task
You must configure the preferences for the first time you use Orchestration Designer. Orchestration
Designer uses these configured preferences on subsequent launches.

Procedure
1. On the Window menu, click Preferences.

2. In the Preferences dialog box, in the left navigation pane, double-click General.
3. Click Perspectives.

4. In the Open a new perspective area, click In the same window.

5. In the Fast Views area, click Within the perspective.

6. In the Open the associated perspective when creating a new project area, click Prompt.
7. In the Available perspectives pane, perform one of the following actions:

• Click Speech to set the Speech perspective as the default perspective.
• Click Call Control to set the Call Control perspective as the default perspective.
• Click Message to set the Message perspective as the default perspective.
• Click Web to set the Web perspective as the default perspective.

8. Click Make default.
9. Click Apply, and then click OK.

Configuring Tomcat preferences
About this task
Tomcat preferences provides settings that determine how Orchestration Designer works with the
Apache Tomcat servlet engine during simulations.
If you install Tomcat with the default settings, Tomcat preferences are already configured and you do
not have to configure Tomcat preferences again.

Installation and configuration
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Verify that the appropriate Tomcat version, home directory, and Contexts directory are populated.

Note:
If you are running only Orchestration Designer in your development environment, that is, if you
are not running deployed applications, you do not have to install the runtimeconfig to your local
Tomcat. This file is installed automatically. You only have to set up your production system when
you are deploying and running live applications.

Important:
Do not run the runtimeconfig on your ADE. If you do, connection timeout exceptions occur. To
recover, stop Tomcat, stop Orchestration Designer, restart Orchestration Designer, and change
your configuration in preferences.

Procedure
1. On the Window menu, click Preferences.

The system displays the Preferences dialog box.

2. In the left navigation pane, click Tomcat.
3. In the Tomcat version area, click the Tomcat version that is installed on your computer.

4. In the Tomcat home field, click Browse to navigate to and select the directory where
Tomcat is installed.

5. In the Context declaration mode area, click Context files.

6. In the Context directory field, click Browse to navigate to and select the context directory.

7. Click Apply, and then click OK.

Orchestration Designer preferences management

Considerations for enabling an HTTP or HTTPS proxy connection
The Orchestration Designer Preferences panel includes a setting to enable an HTTP or HTTPS
proxy connection.

Proxy settings are required when all of the following conditions are true:

• The system where Orchestration Designer is installed is behind a firewall.
• Access is required to resources that reside outside the firewall for your Orchestration Designer

speech projects. These resources can include Web services, databases, or other outside
resources.

• Access to these resources requires the use of either an HTTP or HTTPS proxy server.

When these conditions are true, proxy settings for Orchestration Designer must be configured, even
if proxy settings are already configured for your Internet browser or e-mail client. If you have a proxy

Orchestration Designer preferences management
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server configured for your Internet browser, use the same proxy settings for Orchestration Designer.
For more information, see Admin (ddadmin) Web application configuration in the Avaya Aura®

Orchestration Designer Developer’s Guide.

Related links
Enabling an HTTP or HTTPS proxy connection on page 24

Enabling an HTTP or HTTPS proxy connection
Procedure

1. On the Window menu, click Preferences.

2. In the Preferences dialog box, in the left navigation pane, double-click Avaya Aura.

3. Click Orchestration Designer.
4. In the Orchestration Designer pane, perform one of the following actions:

• In the Proxy Settings area, configure the HTTP proxy settings.

• In the HTTPS Proxy Settings area, configure the HTTPS proxy settings.

5. Click Apply, and then click OK.

Related links
Considerations for enabling an HTTP or HTTPS proxy connection on page 23
Orchestration Designer preferences field descriptions on page 26

Configuring the run-time license server
About this task

Note:
Specify a run-time license server only if you have Avaya Aura® Experience Portal, IR, or MPS
accessing your application from the development environment.
Run-time license to run applications using the Application Simulator is not needed.

Procedure
1. On the Window menu, click Preferences.

2. In the Preferences dialog box, in the left navigation pane, double-click Avaya Aura.

3. Click Orchestration Designer.
4. In the Orchestration Designer pane, in the Runtime License Server area, in the Server URI

field, type the URI of the run-time license server if you have Avaya Aura® Experience Portal,
IR, or MPS accessing your application from the development environment.

Installation and configuration
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The format for this URI is http://webServerName:port, where:

• webServerName is the fully qualified host name or IP address of your WebLM license
server.

• port is the number of the HTTP/HTTPS port the system uses to access the license server.

For example, http://licenseServer.myCompany.com:8080
5. In the License Check Timeout field, type the time in seconds that the system must wait for

a response from the WebLM license server while attempting to connect to the WebLM
license server.

The default value is zero seconds. Zero indicates that there is no timeout.

6. Click Apply, and then click OK.

Related links
Orchestration Designer preferences field descriptions on page 26

Removing the context files on closing a project
About this task
Tomcat opens the context files of all projects each time you simulate a project. Therefore,
Orchestration Designer performance can degrade if you have several workspaces with a huge
number of projects.
If you select the Remove context files on project close check box, Orchestration Designer
automatically deletes the corresponding context files when you close the Orchestration Designer
projects.
Orchestration Designer recreates the context file when a project is reopened. This improves the
performance by controlling the size of the workspaces.

Note:
This option does not affect the projects which are not opened in the current session. This
applies only to Orchestration Designer projects which you open and close subsequently.

Procedure
1. On the Window menu, click Preferences.

2. In the Preferences dialog box, in the left navigation pane, double-click Avaya Aura.

3. Click Orchestration Designer.
4. In the Orchestration Designer pane, in the Context Files area, select the Remove context

files on project close check box.

5. Click Apply, and then click OK.

Related links
Orchestration Designer preferences field descriptions on page 26
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Configuring the fetch secure port
About this task
To use HTTPS to get and post data from form nodes, such as prompt and collect, announce, menu,
record, and transfer, you can specify the port number used by the application server. If you are using
Tomcat, the default port is 8443.

Procedure
1. On the Window menu, click Preferences.

2. In the Preferences dialog box, in the left navigation pane, double-click Avaya Aura.

3. Click Orchestration Designer.
4. In the Orchestration Designer pane, in the Secure Fetch area, in the Secure Fetch Port

field, specify the port number used by the application server.

5. Click Apply, and then click OK.

Related links
Orchestration Designer preferences field descriptions on page 26

Orchestration Designer preferences field descriptions
Name Description
Proxy Settings  
Enable HTTP proxy connection Check box to enable HTTP proxy connection if you

need a proxy server for Internet access.
Ignore hosts with addresses The IP addresses. Orchestration Designer ignores

HTTP hosts with these addresses. For multiple
addresses, use either a comma or semicolon as a
separator character.

HTTP proxy host address The full HTTP path or the URL of the proxy server.
HTTP proxy host port The port that Orchestration Designer can use to

access the proxy server.
Copy HTTP settings to HTTPS To copy the configured HTTP settings to HTTPS

settings automatically.
HTTPS Proxy Settings  
Enable HTTPS proxy connection Check box to enable HTTPS proxy connection if you

need a proxy server for Internet access.

If you do not need a proxy server for Internet access,
clear this check box. If cleared, Orchestration
Designer disables the other options in this area.

Table continues…

Installation and configuration

July 2017 Getting Started with Avaya Aura® Orchestration Designer 26
Comments on this document? infodev@avaya.com

mailto:infodev@avaya.com?subject=Getting Started with Avaya Aura® Orchestration Designer


Name Description
Ignore HTTPS hosts with addresses The IP addresses. Orchestration Designer ignores

HTTPS hosts with these addresses. For multiple
addresses, use either a comma or a semicolon as a
separator character.

HTTPS proxy host address The full HTTPS path or the URL of the proxy server.

If you do not know this address, see the proxy server
settings for your Internet browser software.

HTTPS proxy host port The port that Orchestration Designer can use to
access the HTTPS proxy server

If you do not know the URI, contact the Avaya
technical service representative.

Note:

These settings are required even if proxy
options are set in Microsoft Internet Explorer or
any other Web browser.

Runtime License Server  
Server URI The URI of the run-time license server if you have

Avaya Aura® Experience Portal, IR, or MPS
accessing your application from the development
environment.

Note:

You must specify a run-time license server only
if you have Avaya Aura® Experience Portal, IR,
or MPS accessing your application from the
development environment.

You do not need a run-time license to run
applications using the Application Simulator.

The format for this URI is http://webServerName:port
where:

• webServerName is the fully qualified host name or
IP address of your WebLM license server.

• port is the number of the HTTP/HTTPS port the
system uses to access the license server.

For example, http://
licenseServer.myCompany.com:8080.

License Check Timeout The time in seconds that the system must wait for a
response from the WebLM license server while
attempting to connect to the WebLM license server.

The default value is zero seconds. Zero indicates
that no timeout is there.

Table continues…
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Name Description
Context Files  
Remove context files on project close Check box to automatically delete corresponding

context files when you close Orchestration Designer
projects.

Orchestration Designer recreates the context file
when a project is reopened. This improves the
performance by controlling the size of the
workspaces.

If you clear the Remove context files on project
close check box, Tomcat opens the context files of
all projects each time you simulate a project.
Therefore, Orchestration Designer performance can
degrade if you have several workspaces with a huge
number of projects.

Note:

This option does not affect the projects which
are not opened in the current session. This
applies only to Orchestration Designer projects
which you open and close subsequently.

Secure Fetch  
Secure Fetch Port The port number used by the application server if

you want to use HTTPS to get and post data from
form nodes, such as prompt and collect, announce,
menu, record, and transfer. If you are using Tomcat,
the default port is 8443.

Related links
Enabling an HTTP or HTTPS proxy connection on page 24
Configuring the run-time license server on page 24
Removing the context files on closing a project on page 25
Configuring the fetch secure port on page 26

Verifying the Java JRE
Procedure

1. On the Window menu, click Preferences.

2. In the Preferences dialog box, in the left navigation pane, double-click Java.

3. Click Installed JREs.
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4. Verify that jre7 or jre8 is selected. If jre7 or jre8 does not appear in the list, perform the
following action:

• Click Add to add the JRE. For more information, see the Java Development User Guide.

5. Click OK.

Setting the Java JDK compiler compliance level
Procedure

1. On the Window menu, click Preferences.

2. In the Preferences dialog box, in the left navigation pane, double-click Java.

3. Click Compiler.
4. In the JDK Compliance area, select the Compiler compliance level.
5. Click Apply, and then click OK.

Configuring Microsoft SAPI Speech for microphone input
About this task
Orchestration Designer uses the Microsoft Speech API 6.0 to handle ASR input from a microphone
during application simulation. To use the Microsoft SAPI Speech for ASR input, you must configure
the Microsoft SAPI Speech to use a microphone.

Procedure
1. On the system where Orchestration Designer is installed, open Control Panel.

2. Go to the speech recognition configuration.

3. With a microphone plugged in and turned on, speak into the microphone. The Level
indicator in the Microphone area must show that the system is receiving microphone input. If
Level indicator does not show, rectify the audio input source settings.

4. Follow the wizard steps to further tune the microphone settings.

5. Click OK.
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Installing sample applications
About this task
Orchestration Designer includes numerous sample applications. You can use these sample
applications to understand how finished applications work and operate, and how the features of
Orchestration Designer work.

Procedure
1. Navigate to the /Sample Applications directory on the Orchestration Designer

installation ISO image.

2. Locate and double-click the Avaya Aura® Orchestration Designer [version] Sample
Applications.doc file.

3. Follow the instructions in this file to install and configure Orchestration Designer sample
applications.

This file also contains detailed information about each sample application.

Important:

You can use included sample applications as technical samples for reference only, and
not production-ready applications.

About Orchestration Designer Upgrade
You can upgrade to Orchestration Designer 7.2 from following versions:

• Orchestration Designer 7.0
• Orchestration Designer 7.0.1
• Orchestration Designer 7.1

You can upgrade to Orchestration Designer 7.2 either by maintaining the previous environment or
without retaining the previous environment.

Note:
Upgrades to Orchestration Designer might require updates to connectors or other dependant
libraries on the application server. Avaya recommends that you update the connector
applicationsicconnector.war and aesconnector.war and run-time support files
(runtimeSupport platform.zip) after upgrading Orchestration Designer.

For more information about installing the run-time support files and connectors, see Prerequisite
files on the application server in Avaya Aura® Orchestration Designer Developer’s Guide.

Related links
Maintaining the 7.0 environment while installing 7.2.0 on page 31
Maintaining the 7.0.1 environment while installing 7.2.0 on page 32
Maintaining the 7.1 environment while installing 7.2.0 on page 33
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Recommended installation paths for multiple Orchestration Designer and Eclipse versions on
page 34
Installing 7.2.0 without retaining the 7.0 environment on page 34
Installing 7.2.0 without retaining the 7.0.1 environment on page 35
Installing 7.2.0 without retaining the 7.1 environment on page 36
Software requirements on page 13
Software requirements on page 13

Maintaining the 7.0 environment while installing 7.2.0
About this task
To retain the Orchestration Designer 7.0 environment, you can install Orchestration Designer 7.2.0
into a separate directory. You can retain the Orchestration Designer 7.0 environment for reasons
such as maintenance of 7.0 based applications.
For information about the recommended installation paths, see Recommended installation paths for
multiple Orchestration Designer and Eclipse versions on page 34.

Procedure
1. Save the Orchestration Designer 7.0 and Eclipse 3.6 installation and workspace.

Orchestration Designer 7.0 continues to use the previous Tomcat installation.

2. Install Orchestration Designer 7.2.0, and Tomcat 7.0 or 8.0. (Tomcat upgrade is optional) to a
separate location. For example, C:\OD7.2.0\.

Note:

You must install Tomcat under the Orchestration Designer 7.2.0 installation location to
keep it separate.

3. Upgrade Orchestration Designer 7.0 projects to Orchestration Designer 7.2.0 projects.
Perform the following actions:

a. Copy the projects from the Orchestration Designer 7.0 workspace to the Orchestration
Designer 7.2.0 workspace. Keep a copy of the projects in the 7.0 workspace to ensure
that you have a backup if upgrading problems.

b. Import the copied projects into Orchestration Designer 7.2.0.

The system converts the projects for Orchestration Designer 7.2.0. You cannot open
these projects in Orchestration Designer 7.0.

4. If you use a source control system, store the 7.0 application in a different location or a
different branch, so that you can maintain the old 7.0 application in the future.

Note:

After creating a new workspace during an upgrade, click Window > Preferences to
configure your preferences before importing old projects.
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Related links
About Orchestration Designer Upgrade on page 30

Maintaining the 7.0.1 environment while installing 7.2.0
About this task
To retain the Orchestration Designer 7.0.1 environment, you can install Orchestration Designer 7.2.0
into a separate directory. You can retain the Orchestration Designer 7.0.1 environment for reasons
such as maintenance of 7.0.1-based applications.
For information about the recommended installation paths, see Recommended installation paths for
multiple Orchestration Designer and Eclipse versions on page 34.

Procedure
1. Save the Orchestration Designer 7.0.1 and Eclipse 3.6 installation and workspace.

Orchestration Designer 7.0.1 continues to use the previous Tomcat installation.

2. Install Orchestration Designer 7.2.0, and Tomcat 7.0, or 8.0. (Tomcat upgrade is optional) to
a separate location. For example, C:\OD7.2.0\.

Note:

You must install Tomcat under the Orchestration Designer 7.2.0 installation location to
keep it separate.

3. Upgrade Orchestration Designer 7.0.1 projects to Orchestration Designer 7.2.0 projects.
Perform the following actions:

a. Copy the projects from the Orchestration Designer 7.0.1 workspace to the Orchestration
Designer 7.2.0 workspace. Keep a copy of the projects in the 7.0.1 workspace to
ensure that you have a backup if upgrading problems.

b. Import the copied projects into Orchestration Designer 7.2.0.

The system converts the projects for Orchestration Designer 7.2.0. You cannot open
these projects in Orchestration Designer 7.0.1.

4. If you use a source control system, store the 7.0 1 application in a different location or a
different branch, so that you can maintain the old 7.0 1 application in the future.

Note:

After creating a new workspace during an upgrade, click Window > Preferences to
configure your preferences before importing old projects.

Related links
About Orchestration Designer Upgrade on page 30

Installation and configuration

July 2017 Getting Started with Avaya Aura® Orchestration Designer 32
Comments on this document? infodev@avaya.com

mailto:infodev@avaya.com?subject=Getting Started with Avaya Aura® Orchestration Designer


Maintaining the 7.1 environment while installing 7.2.0
About this task
To retain the Orchestration Designer 7.1 environment, you can install Orchestration Designer 7.2.0
into a separate directory. You can retain the Orchestration Designer 7.1 environment for reasons
such as maintenance of 7.1 based applications.
For information about the recommended installation paths, see Recommended installation paths for
multiple Orchestration Designer and Eclipse versions on page 34.

Procedure
1. Save the Orchestration Designer 7.1 and Eclipse installation and workspace. Orchestration

Designer 7.0 continues to use the previous Tomcat installation.

2. Install Orchestration Designer 7.2.0, and Tomcat 7.0 or 8.0. (Tomcat upgrade is optional) to a
separate location. For example, C:\OD7.2.0\.

Note:

You must install Tomcat under the Orchestration Designer 7.2.0 installation location to
keep it separate.

3. Upgrade Orchestration Designer 7.1 projects to Orchestration Designer 7.2.0 projects.
Perform the following actions:

a. Copy the projects from the Orchestration Designer 7.1 workspace to the Orchestration
Designer 7.2.0 workspace. Keep a copy of the projects in the 7.1 workspace to ensure
that you have a backup if upgrading problems.

b. Import the copied projects into Orchestration Designer 7.2.0.

The system converts the projects for Orchestration Designer 7.2.0. You cannot open
these projects in Orchestration Designer 7.1.

4. If you use a source control system, store the 7.1 application in a different location or a
different branch, so that you can maintain the old 7.1 application in the future.

Note:

After creating a new workspace during an upgrade, click Window > Preferences to
configure your preferences before importing old projects.

Related links
About Orchestration Designer Upgrade on page 30
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Recommended installation paths for multiple Orchestration
Designer and Eclipse versions

The following example installation paths are recommended for multiple Orchestration Designer and
Eclipse versions. In these paths, (base) means any parent directory.
c:\(base)\OD7.0\
eclipse\ (Eclipse 4.2 install, with GEF 3.9 SDK, WTP SDK 3.4, emf-xsd 2.8, DTP 1.10
Orchestration Designer 7.0 features)
tomcat\ (Tomcat 6.0, or 7.0 for running Orchestration Designer 7.0 applications)

workspace\ (Orchestration Designer 7.0 projects)

These paths are convenient installation structure that retains the Orchestration Designer 7.0 and
Orchestration Designer 7.0.1 environments and the prerequisite software separate.
c:\(base)\OD7.0.1\
eclipse\ (Eclipse 4.2 install, with GEF 3.9 SDK, WTP SDK 3.4, emf-xsd 2.8, DTP 1.10
Orchestration Designer 7.0.1 features)
tomcat\ (Tomcat 7.0, or 8.0 for running Orchestration Designer 7.0.1 applications)

workspace\ (Orchestration Designer 7.0.1 projects)

These paths are convenient installation structure that retains the Orchestration Designer 7.0.1 and
Orchestration Designer 7.1.0 environments and the prerequisite software separate.
c:\(base)\OD7.1\
eclipse\ (Eclipse 4.2 install, with GEF 3.9 SDK, WTP SDK 3.4, emf-xsd 2.8, DTP 1.10
Orchestration Designer 7.1 features)
tomcat\ (Tomcat 7.0, or 8.0 for running Orchestration Designer 7.1 applications)

workspace\ (Orchestration Designer 7.1 projects)

These paths are convenient installation structure that retains the Orchestration Designer 7.1 and
Orchestration Designer 7.2.0 environments and the prerequisite software separate.

Related links
About Orchestration Designer Upgrade on page 30

Installing 7.2.0 without retaining the 7.0 environment
Procedure

1. Before uninstalling Orchestration Designer 7.0, create a backup copy of the projects in your
workspace.
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2. To uninstall Orchestration Designer, perform the following steps:

a. Go to Windows > Preferences > Install/Update.

b. In Install/Update wizard, click on Uninstall or update link.

c. In Installed Software tab, select Avaya Aura Orchestration Designer Developer
Guide.

d. Click Uninstall.

Depending on the location of your workspace, you can remove your projects by the uninstall
process.

3. Install Orchestration Designer 7.2.0 and the supporting software.

4. Copy the Orchestration Designer 7.0 projects from the backup into the Orchestration
Designer 7.2.0 workspace.

Keep copies of your old backups in the event stating the errors while upgrading.

5. Import each project into Orchestration Designer 7.2.0.

The system converts the projects for Orchestration Designer 7.2.0.

6. If you use a source control system, create a branch or store the 7.2.0 application in a
different location so that you can maintain the old 7.0 application in the future.

Note:

After creating a new workspace during an upgrade, click Window > Preferences to
configure your preferences before importing the old projects.

Related links
About Orchestration Designer Upgrade on page 30
Installing Orchestration Designer manually on page 17
Software requirements on page 13

Installing 7.2.0 without retaining the 7.0.1 environment
Procedure

1. Before uninstalling Orchestration Designer 7.0.1, create a backup copy of the projects in
your workspace.

2. To uninstall Orchestration Designer, perform the following steps:

a. Go to Windows > Preferences > Install/Update.

b. In Install/Update wizard, click on Uninstall or update link.

c. In Installed Software tab, select Avaya Aura Orchestration Designer Developer
Guide.

d. Click Uninstall.

About Orchestration Designer Upgrade

July 2017 Getting Started with Avaya Aura® Orchestration Designer 35
Comments on this document? infodev@avaya.com

mailto:infodev@avaya.com?subject=Getting Started with Avaya Aura® Orchestration Designer


Depending on the location of your workspace, you can remove your projects by the uninstall
process.

3. Install Orchestration Designer 7.2.0 and the supporting software.

4. Copy the Orchestration Designer 7.0.1 projects from the backup into the Orchestration
Designer 7.2.0 workspace.

Keep copies of your old backups in the event stating the errors while upgrading.

5. Import each project into Orchestration Designer 7.2.0.

The system converts the projects for Orchestration Designer 7.2.0.

6. If you use a source control system, create a branch or store the 7.2.0 application in a
different location so that you can maintain the old 7.0.1 application in the future.

Note:

After creating a new workspace during an upgrade, click Window > Preferences to
configure your preferences before importing the old projects.

Related links
About Orchestration Designer Upgrade on page 30
Installing Orchestration Designer manually on page 17
Software requirements on page 13

Installing 7.2.0 without retaining the 7.1 environment
Procedure

1. Before uninstalling Orchestration Designer 7.1, create a backup copy of the projects in your
workspace.

2. To uninstall Orchestration Designer, perform the following steps:

a. Go to Windows > Preferences > Install/Update.

b. In Install/Update wizard, click on Uninstall or update link.

c. In Installed Software tab, select Avaya Aura Orchestration Designer Developer
Guide.

d. Click Uninstall.

Depending on the location of your workspace, you can remove your projects by the uninstall
process.

3. Install Orchestration Designer 7.2.0 and the supporting software.

4. Copy the Orchestration Designer 7.1 projects from the backup into the Orchestration
Designer 7.2.0 workspace.

Keep copies of your old backups in the event stating the errors while upgrading.

5. Import each project into Orchestration Designer 7.2.0.
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The system converts the projects for Orchestration Designer 7.2.0.

6. If you use a source control system, create a branch or store the 7.2.0 application in a
different location so that you can maintain the old 7.1 application in the future.

Note:

After creating a new workspace during an upgrade, click Window > Preferences to
configure your preferences before importing the old projects.

Related links
About Orchestration Designer Upgrade on page 30
Installing Orchestration Designer manually on page 17
Software requirements on page 13

About Orchestration Designer patch updates
At this time, Avaya does not automatically alert you about the availability of new patches for
Orchestration Designer. Therefore, periodically check the Avaya support website for the availability
of patches. Or, as an alternative, use the Eclipse update mechanism to check for available updates.

The following sections describe the steps for installing Orchestration Designer patches:

• Before installing an Orchestration Designer patch update on page 37

• Installing an Orchestration Designer patch update on page 38

Note:

The procedure described in the Installing an Orchestration Designer patch update on
page 38 section is for installing patches or updates to a released software, and not for
upgrading software versions completely. For upgrading the software, see About
Orchestration Designer Upgrade on page 30.

Before installing an Orchestration Designer patch update
Before installing a patch update, back up all files in the default /eclipse installation directory, and in
the designated /workspace directory (if not a subdirectory of /eclipse). Backing up your files helps
you to revert an update.

To continue using the older version for existing applications, perform a “clean installation” of the new
version in a new directory.

Caution:

When opening an application created with an earlier release of Orchestration Designer,
Orchestration Designer prompts you to update the project to the new version. For project
conversion considerations, see the Release Notes.
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Installing an Orchestration Designer patch update
About this task
Avaya Support website releases Orchestration Designer patch updates. You can gain access to
these updates from within the Eclipse user interface (UI).

Note:
The procedure described in this section is for installing patches or updates to a released
software, and not for upgrading software versions completely. For upgrading the software, see 
About Orchestration Designer Upgrade on page 30.

Procedure
1. On the Help menu, click Install New Software.

2. In the Install dialog box, clear the Contact all update sites during install to find required
software check box.

3. In the Work with field, click the Orchestration Designer patch update website name that you
specified.

Note:

Ensure that the Orchestration Designer patch update website is added to Eclipse. For
more information, see Adding the website for Orchestration Designer patch updates on
page 39.

Note:

If you cannot connect to the update website, ensure that you have correctly configured
the proxy settings. The system automatically checks for the Orchestration Designer
patch updates. If patches or updates are found, the search mechanism returns the
results.

4. In the middle pane, select the Orchestration Designer patch updates that you want to install,
click Next, and then follow the prompts.

Caution:

You can use the Eclipse Install New Software mechanism for features besides
Orchestration Designer. To ensure that you install compatible features, Avaya
recommends that you update only the Orchestration Designer features.

If you are unsure which updates to install or if you have questions about the installation
procedure, contact Avaya Support at http://support.avaya.com.

Installation and configuration

July 2017 Getting Started with Avaya Aura® Orchestration Designer 38
Comments on this document? infodev@avaya.com

http://support.avaya.com
mailto:infodev@avaya.com?subject=Getting Started with Avaya Aura® Orchestration Designer


Adding the website for Orchestration Designer patch updates
About this task
To get Orchestration Designer patch updates, you must add the Orchestration Designer patch
update website to Eclipse.

Procedure
1. Perform one of the following actions:

• On the Help menu, click Install New Software, and then click the Available Software
Sites link.

• On the Window menu, click Preferences.

2. In the Preferences dialog box, double-click Install/Update.

3. Click Available Software Sites.

4. In the Available Software Sites pane, click Add.

5. In the Add Site dialog box, in the Name field, type a name for the Orchestration Designer
patch update website. For example, AAOD.

6. In the Location field, type http://support.avaya.com/
OrchestrationDesigner/SS/Updates/.

7. Click OK.
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Chapter 3: Resources

Related resources

Documentation
The following table lists the documents related to this product. Download the documents from the
Avaya Support website at http://support.avaya.com

Title Description Audience
Getting Started with Avaya Aura®

Orchestration Designer
This PDF document contains the information
needed to install and configure
Orchestration Designer for initial use, and to
understand the basics of Orchestration
Designer graphical user interface (GUI).

• Application
Developers

• Implementation
Engineers

Avaya Aura® Orchestration Designer
Developer’s Guide

This PDF document contains the same
information as available in the online Help,
but you can view or print the document
using Adobe Acrobat Reader.

Application
Developers

Avaya Aura® Orchestration Designer
online Help

The online Help provides detailed
information and procedures for using
Orchestration Designer features and options
to create speech, message, and call control
applications.

When installing Orchestration Designer, the
system installs the online Help as an
additional Eclipse plug-in.

• Application
Developers

• Implementation
Engineers

Programmer Reference Guide This online documentation is designed for
the programmers of Orchestration Designer.
This documentation includes:

• A Constants (Quick reference) guide.

• A Class Hierarchy reference guide.

• An API Reference guide.

Application
Developers
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Title Description Audience
Deploying Avaya Breeze™ This document provides information and

procedures on deploying the Avaya Breeze™

services.

• System
administrators

• Services and
Support personnel

• Avaya Professional
Services

• Implementation
engineers

Avaya Context Store Snap-in
Reference

This document is intended for anyone who
wants to install, configure, and administer
Context Store.

• Application
Developers

• Implementation
Engineers

Deploying Avaya Oceanalytics™

Insights
This document is intended for anyone who
wants to deploy Avaya Oceanalytics™

Insights.

• Application
Developers

• Implementation
Engineers

For information about viewing the Orchestration Designer documentation, see Viewing the
Orchestration Designer documentation on page 8.

Related links
Finding documents on the Avaya Support website on page 41

Finding documents on the Avaya Support website
About this task
Use this procedure to find product documentation on the Avaya Support website.

Procedure
1. Use a browser to navigate to the Avaya Support website at http://support.avaya.com/.

2. At the top of the screen, enter your username and password and click Login.

3. Put your cursor over Support by Product.
4. Click Documents.

5. In the Enter your Product Here search box, type the product name and then select the
product from the drop-down list.

6. If there is more than one release, select the appropriate release number from the Choose
Release drop-down list.

7. Use the Content Type filter on the left to select the type of document you are looking for, or
click Select All to see a list of all available documents.

For example, if you are looking for user guides, select User Guides in the Content Type
filter. Only documents in the selected category will appear in the list of documents.

Related resources
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8. Click Enter.
Related links

Documentation on page 40

Training
The following courses are available on the Avaya Learning website at www.avaya-learning.com.
After logging into the website, enter the course code or the course title in the Search field and click
Go to search for the course.

Course Code Course Title
4C00095W Avaya Aura Orchestration Designer for Developers
5C00092V Avaya Aura Experience Portal, Avaya Aura

Orchestration Designer, and Avaya Proactive
Outreach Manager Installation, Maintenance and
Troubleshooting Essentials

3610C Avaya Aura Contact Center - Orchestration Designer
Scripting

2C00081O Selling Avaya Aura Orchestration Designer
5C00080E Knowledge Access: Avaya Aura Contact Center

Orchestration Designer Scripting Administration
W: Web (online) course

V: Virtual

E: Self-paced in virtual campus

O: On Demand

Viewing Avaya Mentor videos
Avaya Mentor videos provide technical content on how to install, configure, and troubleshoot Avaya
products.

About this task
Videos are available on the Avaya Support website, listed under the video document type, and on
the Avaya-run channel on YouTube.

Procedure
• To find videos on the Avaya Support website, go to http://support.avaya.com and perform one

of the following actions:

- In Search, type Avaya Mentor Videos to see a list of the available videos.

- In Search, type the product name. On the Search Results page, select Video in the
Content Type column on the left.

Resources
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• To find the Avaya Mentor videos on YouTube, go to www.youtube.com/AvayaMentor and
perform one of the following actions:

- Enter a key word or key words in the Search Channel to search for a specific product or
topic.

- Scroll down Playlists, and click the name of a topic to see the available list of videos posted
on the website.

Note:

Videos are not available for all products.

Support
Go to the Avaya Support website at http://support.avaya.com for the most up-to-date
documentation, product notices, and knowledge articles. You can also search for release notes,
downloads, and resolutions to issues. Use the online service request system to create a service
request. Chat with live agents to get answers to questions, or request an agent to connect you to a
support team if an issue requires additional expertise.

Support
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Glossary

AACC Avaya Aura® Contact Center.

AAEP Avaya Aura® Experience Portal

AAS Avaya Application Simulator.

ADR See application detail record (ADR)  on page 44.

AMS Avaya Aura® Media Server.

ANI See automatic number identification (ANI)  on page 44.

API See application program interface (API)  on page 44.

application detail
record (ADR)

Data records which contain historical information about an application used
as part of a session. These records include information such as the session
ID number, a timestamp, and a “friendly name” string determined by the
developer who created the application.

application program
interface (API)

A set of routines, protocols, and tools for building software applications. A
good API makes it easier to develop a program by providing all the building
blocks.

application server A computer on which the Orchestration Designer speech application
resides and runs. This computer is also where the Orchestration Designer
run-time libraries are installed, thus making it possible to run Orchestration
Designer applications on that server. The IVR system must be configured to
start the speech application from this location.

ASR See automated speech recognition (ASR)  on page 44.

automated speech
recognition (ASR)

Technology that employs a computer to recognize spoken words and
respond appropriately.

automatic number
identification (ANI)

A service that provides the originating telephone number of a call coming in
to the system.

call flow As implemented in speech applications, the call flow determines how a call
is handled when it enters an interactive voice response system, based on
options offered to callers and their responses to those options.
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CCXML Call Control eXtensible Markup Language.

An emerging XML specification, being developed to work in conjunction
with VoiceXML and which addresses some of the technical limitations of
VoiceXML. It enables the processing of asynchronous events, filtering and
routing of incoming calls, and placement of outbound calls. Note that it is
not intended to replace VoiceXML but rather to supplement it. See Ian
Moraes’s excellent article, “VoiceXML, CCXML, SALT: Architectural Tools
for Enabling Speech Applications,” on the Internet.

Computer Telephony
Integration (CTI)

Software technology that integrates the use of telephones and computers
without the need for special telephones, connectors, computer circuit
packs, or other specialized hardware.

CTI See Computer Telephony Integration (CTI)  on page 45.

dialed number
identification service
(DNIS)

A service that identifies for the receiving system what telephone number
was dialed by the caller. In theAvaya Aura® Experience Portal system this is
often used to direct the call to a particular speech application, which is
identified with that dialed number.

DNIS See dialed number identification service (DNIS)  on page 45.

DTMF See dual tone multi-frequency (DTMF)  on page 45.

dual tone multi-
frequency (DTMF)

The system used by touchtone telephones, DTMF assigns a specific
frequency (consisting of two separate tones) to each telephone key on the
keypad, so that it can easily be identified by a microprocessor.

Eclipse A Java-based open-source extensible IDE (integrated development
environment) that provides application developers a feature-rich interface to
develop their applications. Orchestration Designer is designed as a set of
Eclipse plug-in modules that make it possible for application developers to
design and build speech applications without having to write the code
manually.

gateway A network point that acts as an entry point to another network. In the
context of Orchestration Designer and VoIP applications, a gateway is the
entry point, often associated with one or more switches, to the interactive
voice response (IVR) system application environment. See interactive voice
response (IVR) system  on page 46.

grammar Elements that recognize the input received through inbound voice calls and
messages.

In the context of IVR or speech applications, a grammar is a predefined set
of words or DTMF tones that a speech application uses in conjunction with
automated speech recognition (ASR) technology to interpret and respond to
caller inputs. That is, grammars are lists of possible responses that callers
make when responding to prompts by using spoken replies. Grammars

CCXML
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define which words or phrases the ASR engine can recognize and respond
to.

In the context of text-based applications, a grammar is a predefined set of
words in a message application that a text-processing system can use to
interpret and respond to an inbound SMS or email message. The text-
processing system collects and recognizes the input from inbound SMS
and email messages and uses this input to direct the flow of a message
application.

H.323 A hierarchical, IP-based telephony standard for connecting IP telephones
and speech applications to switches.

IC See Interaction Center (IC)  on page 46.

IDE See integrated development environment (IDE)  on page 46.

integrated
development
environment (IDE)

A software application that usually provides a GUI environment, a text
and/or code editor, a compiler and/or interpreter, and a debugger. This
environment means that application or web developers can develop, test,
and build their applications or Web sites within a single integrated space.

Interaction Center
(IC)

A multichannel contact management platform that enables businesses to
align real-time contact center operations with business objectives.

interactive voice
response (IVR)
system

A system, such as Avaya Aura® Experience Portal or Avaya IR, in which
callers interact with a self-service application to get information, conduct
transactions, or help with problems.

IVR system See interactive voice response (IVR) system  on page 46.

JDBC An application program interface (API)  on page 44 specification in which
programs written in Java connect with and access data contained in
database programs using Structured Query Language (SQL)  on page 48.

localization The process of modifying an application to operate and be understood in a
different language, or locale. This usually involves modifying any phrases,
prompts, and grammars associated with an application.

MPS Media Processing Server.

MRCP Media Resource Control Protocol.

NDM See Nuance Dialog Module (NDM) on page 47.

notebook (Also known as a tabbed or stacked notebook) In the Eclipse context, a
notebook is a set of views “stacked” on top of one another as a space
saving measure. The views in the notebook are accessible by clicking tabs
arranged along the top of the notebook. See the Eclipse documentation.

Glossary
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Nuance Dialog
Module (NDM)

Speech application modules produced by Nuance software products,
similar to speech application modules created by using Orchestration
Designer. You can use NDMs in the Orchestration Designer speech
applications. Orchestration Designer supports NDM version 5.0 and later.

Before version 5.0, Nuance Dialog Module (NDM) was known as Open
Speech Dialog Module (ODSM).

See Open Speech Dialog Module (OSDM)  on page 47.

Open Speech Dialog
Module (OSDM)

Speech application modules produced by Nuance software products,
similar to application modules created with Orchestration Designer. OSDMs
can be used in Orchestration Designer applications. (Orchestration
Designer supports the following OSDM versions: Address OSDM 2.0.3,
Core OSDM 2.0.4, and Name OSDM 2.0.1.)

OSDM is renamed to Nuance Dialog Module (NDM) from version 5.0 and
later.

OSDM See Open Speech Dialog Module (OSDM)  on page 47.

palette In the Orchestration Designer Editor views, this is the pane to the left of the
view, in which editor options are displayed and selected.

Real-time Transfer
Protocol (RTP)

A protocol for transmitting “real-time” data, such as audio or video data,
across the Internet. This protocol does not guarantee “real-time” delivery of
such data, but it does provide mechanisms to support data “streaming.”

RTP See Real-time Transfer Protocol (RTP)  on page 47.

RTSP The Real Time Streaming Protocol, serves as a control protocol, and as a
jumping off point for negotiating transports, such as RTP, multicast and
unicast, and negotiating codecs off of servers in a file format independent
way.

SCE See service creation environment (SCE)  on page 47.

service creation
environment (SCE)

A set of software tools used to develop, test, and debug speech
applications. Orchestration Designer is an SCE.

servlet A small program that runs on a server, often Java-based.

servlet engine A program that coordinates the overall operation and integration of a
number of servlets. In the context of Orchestration Designer, the supported
servlet engines are Apache Jakarta Tomcat, IBM WebSphere/WebSphere
Express, Oracle WebLogic, and JBoss AS7.

Session Initiation
Protocol (SIP)

A signaling protocol for the Internet that makes it possible to set up
conferencing, telephony, events notification, and instant messaging. Within

Nuance Dialog Module (NDM)

July 2017 Getting Started with Avaya Aura® Orchestration Designer 47
Comments on this document? infodev@avaya.com

mailto:infodev@avaya.com?subject=Getting Started with Avaya Aura® Orchestration Designer


a VoIP framework, it initiates call setup, routing, authentication, to endpoints
within an IP domain.

SIP See Session Initiation Protocol (SIP)  on page 47.

speech recognition See automated speech recognition (ASR)  on page 44.

speech synthesis See text-to-speech (TTS)  on page 49.

speech user
interface (SUI)

Any software interface in which the user interacts with the system using
speech commands and audio prompts.

SQL See Structured Query Language (SQL)  on page 48.

SSL Secure Sockets Layer.

A protocol for transmitting private data securely over the Internet. By
convention, URLs that use SSL require a connection using the HTTPS
protocol, rather than just HTTP.

SSML Speech Synthesis Markup Language.

A W3C standard designed to provide an XML-based markup language for
assisting with the generation of synthetic speech in Web and other
applications. The essential role of the markup language is to provide
authors of synthesizable content a standard way to control aspects of
speech such as pronunciation, volume, pitch, rate, and so forth, across
different synthesis-capable platforms.

stacked notebook See notebook  on page 46.

Structured Query
Language (SQL)

A standard interactive and programming language for getting data to and
from a database.

SUI See speech user interface (SUI)  on page 48.

tabbed notebook See notebook  on page 46.

TDD See Telecommunications Display Device (TDD)  on page 48.

Telecommunications
Display Device (TDD)

Sometimes designated as a teletypewriter (TTY) device, a telephone
equipped with a keyboard and display, used by hearing- or speech-impaired
callers to send and receive typed messages.

telephone user
interface (TUI)

Any software interface in which the user interacts with the system using a
telephone or similar device.

teletypewriter (TTY)
device

See Telecommunications Display Device (TDD)  on page 48.

Glossary
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text-to-speech (TTS) Technology by which information in text format is rendered as audio output
using a speech synthesis engine to simulate human speech.

TTS See text-to-speech (TTS)  on page 49.

TTY See Telecommunications Display Device (TDD)  on page 48.

TUI See telephone user interface (TUI)  on page 48.

vector A user-defined sequence of functions that may be performed, such as
routing the call to a destination, giving a busy signal, or playing a recorded
message.

VoiceXML (Sometimes presented as VXML) Voice eXtensible Markup Language.

A specification which provides for a user to interact with Internet-based
resources using voice recognition technology. Instead of a typical Web
browser that requires a combination of HTML, keyboard, and mouse
device, VoiceXML relies on an Internet voice browser and/or telephone.
Using VoiceXML, the user interacts with the Web “page” by listening to
audio outputs (either pre-recorded or using a technology such as TTS) and
by submitting input in the form of the user’s natural speaking voice and/or
manual responses, such as telephone key presses.

Web service A standardized way of offering Web-based applications or services.
Because Web services are Web-based and standards-based applications,
delivered over the Internet, Web services make it possible for organizations
to communicate and share data that use different file formats and
programming languages.

workspace In Orchestration Designer, the area within the Editor view used to build the
functionality for the selected editor. For example, in the Call Flow Editor,
this is the space to the right of the palette, in which you drag the nodes that
represent application functions.

See palette  on page 47.

WSDL Web services Description Language.

An XML-formatted language used to describe a Web service’s capabilities.

XML eXtensible Markup Language.

A specification for the presentation of Internet documents, one which
expands on the capabilities of HTML. A pared-down version of SGML
(Standard Generalized Markup Language), XML makes it possible for
designers to create their own customized tags, which in turn makes it
possible to do things over the Internet that cannot be done using simple
HTML.

text-to-speech (TTS)
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