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Introduction to J100 Series IP Phones 
Avaya J100 Series IP Phones provide a range of applications and features for unified communications. 

The phones leverage the enterprise IP network and eliminate the need of a separate voice network. The 

phones offer superior audio quality with the amplified handsets and customization with low power 

requirements in a Session Initiation Protocol (SIP) environment.  

The phones can be configured  

Supported models 
 

     

Deployment  
Avaya J100 IP Phones with Device Enrolment Service (DES)  

To ease deployment and to be able to plug in the phone right out of the box and have the phone 

automatically configure and login it is recommended to use the Device Enrolment Service (DES). 

DES allows the phone to be automatically pointed to the appropriate Provisioning Server (either 

custom provisioning server (below) or 3CX server. To use this service, you must have an account 

on DES. Please see “Installing and Administering Avaya J100 series IP Phone in third-party call 

control setup” for more information on the DES. Alternatively, the phone can be pointed to the 

Provisioning Server via DHCP.  

Avaya J100 IP Phones with a custom Provisioning Server 
You can configure a custom Provisioning Server and use it to provide the configuration files to 

the phones. The provisioning server hosts the J100Supgrade.txt file, the 

J100settings.txt file as well as other configuration files (e.g. language, images, 

certificates) needed to get the phone configured and connected to the network.  

Avaya J100 IP Phones with 3CX server           
With 3CX server, you can automatically create the appropriate device (J100settings.txt) and user 

(<MACaddress>.txtspecific configuration files from the management system on the 3CX 

Provisioning Server. In this configuration, the phone does not require a custom Provisioning 

Server and connects to the 3CX Provisioning Server instead. For more information specifically 

related to the 3CX Provisioning service please see the 3CX support portal  

https://www.3cx.com/support/ 
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Provisioning server 
The Provisioning Server is an HTTP or an HTTPS server that hosts the phone firmware and configuration 

files.  

Files on the Provisioning Server 
 

File name Content 

J100Supgrade.txt Contains pointers to the firmware and upgrade files 

J100setting.txt Contains the configurable parameters that apply to all devices in a 
given deployment 

<MACaddress>.txt 
 

 

Contains configurable parameters that apply to an individual device 
in a deployment (typically the username, extension and password) 

Resource files e.g. languages, background and screen saver images, ringtones, 
trust certificate files,  

 

Phone configuration 
You can configure Avaya J100 Series IP Phones to work in the 3CX environment in the following ways: 

• Centralized configuration using file server  

• Configuration through the web interface  

Please see “Installing and Administering Avaya J100 series IP Phone in third-party call control setup” for 

more information on the Configuration through the web interface. 

Centralized configuration 
You can bulk configure Avaya J100 Series IP Phones by using the 46xxsettings file. The phone can access 

the settings file via HTTP and HTTPS. 

The following configuration files must be available on the file server configured for the devices. 

Avaya J100 Configuration Files Level Description 

J100Supgrade.txt System Contains the device firmware load. 

46xxsettings.txt System Contains configurable parameters that 
apply to all devices in a given 
deployment. 

<MACaddress>.txt Subscriber Contains configurable parameters that 
apply to an individual device in a 
deployment  

 

System Level Configuration 
This section describes system-wide configuration items in the file that are 

generally required for each Avaya J129 IP Phone to work with. Subscriber-specific settings are described 
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in the next section. For parameter description, see the Installing and Administering Avaya J129 IP Phone 

in third-party call control setup  for J129. 

1.1.1 Configure Network Settings 

Step Command 

Step 1 SET ENABLE_UDP_TRANSPORT 1 

Step 2 SET DNSSRVR “8.8.8.8” 

Step 3 SET DOMAIN “” 

Step 4 SET SNTPSRVR pool.ntp.org 

Step 5 SET SNTP_SYNC_INTERVAL 144000 

1.1.2 Configure SIP Interface Settings 

Step Command 

Step 1 SET SIPDOMAIN "3cx.hcm.com" 

Step 2 SET SIP_CONTROLLER_LIST "3cx.hcm.com:5060;transport=tcp" (or udp, 

tls) 

Step 3 SET ENABLE_G711A 1  

Step 4 SET ENABLE_G711U 1 

Step 5 SET ENABLE_G722 1 

Step 6 SET ENABLE_G726 0 

Step 7 SET G726_PAYLOAD_TYPE 110 

Step 8 SET ENABLE_G729 1 

Step 9 SET ENABLE_OPUS 0 

Step 10 SET SEND_DTMF_TYPE 2 

Step 11 SET DTMF_PAYLOAD_TYPE 120 

Step 12 SET 100REL_SUPPORT 1 

Step 13 SET PLAY_TONE_UNTIL_RTP 1 

Step 14 SET SYMMETRIC_RTP 1 

Step 15 SET REGISTERWAIT 1200 

Step 16 SET WAIT_FOR_UNREGISTRATION_TIMER 32 

Step 17 SET WAIT_FOR_INVITE_RESPONSE_TIMEOUT 60 

Step 18 SET FAILED_SESSION_REMOVAL_TIMER 30 

Step 19 SET TCP_KEEP_ALIVE_STATUS 1 

Step 20 SET TCP_KEEP_ALIVE_TIME 60 

Step 21 SET TCP_KEEP_ALIVE_INTERVAL 10 

Step 22 SET SIP_TIMER_T1 500 

Step 23 SET SIP_TIMER_T2 4000 

http://3cx.hcm.com/
http://3cx.hcm.com/
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Step 24 SET SIP_TIMER_T4 5000 

Step 25 SET ENABLE_SIP_USER_ID 1 

Step 26 SET SIMULTANEOUS_REGISTRATIONS 1 

Step 27 SET LOCALLY_ENFORCE_PRIVACY_HEADER 1 

Step 28 SET ENABLE_STRICT_USER_VALIDATION 0 

1.1.3 Configure Service Settings 

Step Command 

Step 1 SET DIALPLAN [23]xxxx|91xxxxxxxxxx|9[2-9]xxxxxxxxx|7xxx 

Step 2 SET NO_DIGITS_TIMEOUT 20 

Step 3 SET INTER_DIGIT_TIMEOUT 5 

Step 4 SET CALLFWDSTAT 7 

Step 5 SET CALLFWDDELAY 1 

Step 6 SET ENABLE_DND 1 

Step 7 SET ENABLE_DND_PRIORITY_OVER_CFU_CFB 0 

Step 8 SET ENABLE_AUTO_ANSWER_SUPPORT 1 

Step 9 SET AUTO_ANSWER_MUTE_ENABLE 1 

Step 10 SET HOLD_REMINDER_TIMER 0 

Step 11 SET CONFERENCE_FACTORY_URI "conference@as.iop2..net" 

Step 12 SET SIPCONFERENCECONTINUE 0 

Step 13 SET PSTN_VM_NUM "*62" 

Step 14 SET SUBSCRIBE_LIST_NON_AVAYA "message-summary" 

Step 15 SET RINGTONESTYLE 0 

1.1.4 Configure J100 Settings file 

Step Command 

Step 1 SET ENABLE_AVAYA_ENVIRONMENT 0 

Step 2 SET DISCOVER_AVAYA_ENVIRONMENT 0 

Step 3 SET ENABLE_IPOFFICE 0 

Step 4 SET ENABLE_3PCC_ENVIRONMENT 1 

Step 5 SET 3PCC_SERVER_MODE 0 

Step 6 SET SIPDOMAIN "3cx.hcm.com" 

Step 7 SET TRUSTCERTS 3cx.pem 

Step 8 SET SIP_CONTROLLER_LIST "3cx.hcm.com:5060;transport=tcp" (or udp, 

tls) 

1.2 SIP Feature Configuration 

This section provides configuration instructions for SIP features supported by the phone. 

http://3cx.hcm.com/
http://3cx.hcm.com/


8 
 

1.2.1 Registration and P2Pcall with 3CX 

TCP configuration  

Configure J100 Settings file 

Step Command 

Step 1 SET SIP_CONTROLLER_LIST "3cx.hcm.com:5060;transport=tcp" 

 

In 3Cx server 

Step 1:  Go to Extensions > "Edit extension xxxx" > Phone Provisioning > SIP Transport: TCP 

 

TLS configuration  

Configure J100 Settings file 

Step Command 

Step 1 SET SIP_CONTROLLER_LIST "3cx.hcm.com:5061;transport=tls" 

Step 2 SET TRUSTCERTS 3cx.pem 

In 3Cx server 

Go to Extensions > "Edit extension xxxx" > Phone Provisioning > SIP Transport: TLS 

UDP configuration  

Configure J100 Settings file 

Step Command 

Step 1 J100 settings file: SET SIP_CONTROLLER_LIST "3cx.hcm.com:5060;transport=udp" 

In 3CX server 

http://3cx.hcm.com/
http://3cx.hcm.com/
http://3cx.hcm.com/
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Go to Extensions > "Edit extension xxxx" > Phone Provisioning > SIP Transport: UDP 

1.2.2 Transfer 

Attended transfer and blind transfer is supported in J100 Series IP Phones. 

1.2.3 Call pickup 

Go to Settings > PBX > General Options > Limit Call Pickup to calls received in their extension group:  

You can see that limit Call Pickup to calls received in their extension group is not selected -> 

calls can only be answered among extensions that are part of the same extension group. The extension 

group has the options “Can see group members”, “Can see group calls” and “Perform Operations (divert, 

transfer, pickup)” these are selected under the extension’s “Rights” tabConference. 

 

Select the Limit Call Pickup to calls received in their extension group: you will be able to pick up calls 

ringing on other extensions regardless of extension group membership and what is checked under 

the extension’s rights tab 

 

 

Groups > Add => create new group 
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Groups > “edit group xxx” > Members > Add => add extensions to group 
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Extensions > "Edit extension xxxx" > Rights > check the box: Perform operations (divert, transfer, 

pickup) => allow permission to pick up for users 
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Settings > Parameters > “PICKUP”: *20* => set pickup code 

 

 

1.2.4 Call Forward 

Configure J100 Settings file 

Step Command 

Step 1 SET CALLFWDSTAT 7 => display call forward, call forward-Busy, call forward-No Answers 
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In 3CX server 

Extensions > "Edit extension xxxx" > Forwarding Rules > Statuses: 

Available/Away/DND/Lunch/Business Trip => choose status you want to configure 

Extensions > "Edit extension xxxx" > Forwarding Rules > Statuses: Available > If I do not answer 
calls within: 10 Seconds and If I am busy or my phone is unregistered, forward calls to: 

• Forward to Voicemail 

• Forward to extensions 

• End call 

 

Extensions > "Edit extension xxxx" > Web Authentication > Enable Web client and Password - 

Username is extension number: “132456” => enable and set password for web client 
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On web browser: open web client of 3CX http://10.16.29.11/webclient/ and log in extension => 

choose status for extension 

 

1.2.5 Conference 

Configure J100 Settings files to default values. 

Do not set “CONFERENCE_FACTORY_URI” on settings file 

Meet-me conference  

Settings > Conferencing > Audio > Conference Extension: 50000 and Require Conference PIN: 

11111 => configure meet-me number and PIN  

http://10.16.29.11/webclient/
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1.2.6 MWI 

 

Configure J100 Settings file 

Step Command 

Step 1 SET PSTN_VM_NUM 98 

Step 2 SET SUBSCRIBE_LIST_NON_AVAYA message-summary 

 

In 3CX server 

Extensions > "Edit extension xxxx" > Voicemail > Enable Voicemail and PIN Number: 123456  
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Extensions > "Edit extension xxxx" > Forwarding Rules > Statuses: Available > If a call is 

unanswered for 10 Seconds or the user’s phone is unregistered, then calls can be forwarded to 

voicemail: 

 Forward to Voicemail 

 

Settings > Voicemail Settings > Voicemail Menu Extension Number: 99999 
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1.2.7 Emergency call 

Configure J100 Settings file 

Step Command 

Step 1 SET ENABLE_SHOW_EMERG_SK 2 

Step 2 SET ENABLE_SHOW_EMERG_SK_UNREG 2 

Step 3 SET PHNEMERGNUM 911 

 

NOTE: 

• Phone can’t end the emergency call on 3CX system 

• Phone can’t make an emergency call by pressing "Emerg" Softkey when logging out 

 

1.2.8  DND support 

Configure J100 Settings file 

Step Command 

Step 1 SET ENABLE_DND 1 

 

In 3CX server 

Extensions > "Edit extension xxxx" > Forwarding Rules > Statuses: DND > If I am away forward 
internal calls to: 

• Forward to Voicemail 
• Forward to extensions 
• End call 
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Extensions > "Edit extension xxxx" > Web Authentication > Enable Web client and Password - 

Username is extension number: “132456” => enable and set password for web client 

 

 

On web browser: open web client of 3CX http://10.16.29.11/webclient/ and log in extension => 
choose status “DND” for extension 

 

 

http://10.16.29.11/webclient/
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1.2.9  SRTP call support 

Extensions > "Edit extension xxxx" > Phone Provisioning > SIP Transport: TLS 

Extensions > "Edit extension xxxx" > Phone Provisioning > RTP Mode: 

• Allow Secure => This will allow Secure RTP and Non-Secure RTP 

• Only Secure => This will ONLY allow Secure RTP Connections 

 

 

NOTE: 

3CX doesn't support crypto 3-8, 9-11 (only support crypto 1 and 2) 

• Configuration: 
• No RTP encryption is needed - Set "Normal" on the PBX and disable it on the phone 
• RTP encryption is needed - Set "Only Secure" on the PBX and Mandatory (Compulsory) 

on the phone 
• The option "Allow Secure" that we have on the PBX, is used only for the 3CX clients. 

• 3CX does NOT support negotiation for SRTP/RTP with hard phones. For a J100 phone, users 
must pick either forced RTP or forced SRTP (set media encryption 9 for RTP, media encryption 
1 or media encryption 2 for SRTP) 
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1.2.10  Call park and unpark 

Settings > Parameters > PARK: *0, UNPARK: *1 => set dial codes for park and unpark 

 

Settings > Call Parking > Automatically unpark forgotten calls 

• Transfer to the user that originally parked the call 
• Extension 
• Send call to Voice mail of extension 

 

NOTE:  

Phone doesn’t hear music on hold after retrieving the parked call if the waiting phone is holding the 
call. Please refer to the below scenario for more details: 
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1. Phone A calls phone B. Phone B answers the call => A and B are in an active call 
2. Phone A parks the call to orbit 1 by making a blind transfer to *01 => Phone A parks the call 

successfully. Phone B hears parking music 
3. Phone B holds the call => Phone B holds the call successfully 
4. Phone C retrieves the parked call by dialing *11=> Phone C retrieves the parked call 

successfully but doesn’t hear music on hold 

Users Impact: 

1. During the waiting, the far-end user retrieves the parked call, the waiting user may have an 
important incoming call. he will answer the second call and the parked call will be held 
successfully 

2. After retrieving the parked call, the far-end user will think that there is a trouble with speech 
path because he doesn’t know the waiting user is holding the call. They will end the call before 
the waiting user resumes the call 

1.2.11  Automatic redial/callback 

Settings > PBX > Transfer Back on Busy > enter dial code and timeout 

 

1.2.12  Anonymous calling support 

Settings > Blacklisted Numbers > Add > Incoming caller ID to be blocked: *anonymous => reject 

anonymous call 
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1.2.13  DTMF support 

Extensions > "Edit extension xxx" > Phone Provisioning > DTMF Mode: 

• RFC2833: out-of-band (using RFC 2833 procedures) 
• In-Band 
• SIP INFO (is not supported by phone J100) 
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NOTE: 

• For RTP call: DTMF In-Band doesn't work with codecs G722, OPUS (works with G711A, 
G711U, G729) 

• For SRTP call: DTMF In-Band doesn't work with all codecs 

1.2.14  Busy Lamp Field Configuration 

Avaya J129 currently does not support this feature. Please see “Installing and Administering Avaya 

J100 series IP Phone in third-party call control setup” for more information on the Busy Lamp Field 

Configuration. 

1.2.15  Feature Key Synchronization Configuration 

Avaya J129 currently does not support this feature. 

1.2.16  Emergency Call Configuration 

Avaya J129 currently does not support this feature. 

1.2.17  User Service Configuration 

Avaya J129 currently does not support this feature. 

1.2.18  Directory Configuration 

Avaya J129 currently does not support this feature. 
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1.2.19  Call Logs Configuration 

Avaya J129 currently does not support this feature. 

1.2.20  Visual Voice Mail Configuration 

Avaya J129 currently does not support this feature. 


