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Notice
While reasonable efforts have been made to ensure that the
information in this document is complete and accurate at the time of
printing, Avaya assumes no liability for any errors. Avaya reserves
the right to make changes and corrections to the information in this
document without the obligation to notify any person or organization
of such changes.
Documentation disclaimer
“Documentation” means information published in varying mediums
which may include product information, operating instructions and
performance specifications that are generally made available to users
of products. Documentation does not include marketing materials.
Avaya shall not be responsible for any modifications, additions, or
deletions to the original published version of Documentation unless
such modifications, additions, or deletions were performed by or on
the express behalf of Avaya. End User agrees to indemnify and hold
harmless Avaya, Avaya's agents, servants and employees against all
claims, lawsuits, demands and judgments arising out of, or in
connection with, subsequent modifications, additions or deletions to
this documentation, to the extent made by End User.
Link disclaimer
Avaya is not responsible for the contents or reliability of any linked
websites referenced within this site or Documentation provided by
Avaya. Avaya is not responsible for the accuracy of any information,
statement or content provided on these sites and does not
necessarily endorse the products, services, or information described
or offered within them. Avaya does not guarantee that these links will
work all the time and has no control over the availability of the linked
pages.
Warranty
Avaya provides a limited warranty on Avaya hardware and software.
Refer to your sales agreement to establish the terms of the limited
warranty. In addition, Avaya’s standard warranty language, as well as
information regarding support for this product while under warranty is
available to Avaya customers and other parties through the Avaya
Support website: https://support.avaya.com/helpcenter/
getGenericDetails?detailId=C20091120112456651010 under the link
“Warranty & Product Lifecycle” or such successor site as designated
by Avaya. Please note that if You acquired the product(s) from an
authorized Avaya Channel Partner outside of the United States and
Canada, the warranty is provided to You by said Avaya Channel
Partner and not by Avaya.
“Hosted Service” means an Avaya hosted service subscription that
You acquire from either Avaya or an authorized Avaya Channel
Partner (as applicable) and which is described further in Hosted SAS
or other service description documentation regarding the applicable
hosted service. If You purchase a Hosted Service subscription, the
foregoing limited warranty may not apply but You may be entitled to
support services in connection with the Hosted Service as described
further in your service description documents for the applicable
Hosted Service. Contact Avaya or Avaya Channel Partner (as
applicable) for more information.
Hosted Service
THE FOLLOWING APPLIES ONLY IF YOU PURCHASE AN AVAYA
HOSTED SERVICE SUBSCRIPTION FROM AVAYA OR AN AVAYA
CHANNEL PARTNER (AS APPLICABLE), THE TERMS OF USE
FOR HOSTED SERVICES ARE AVAILABLE ON THE AVAYA
WEBSITE, HTTPS://SUPPORT.AVAYA.COM/LICENSEINFO UNDER
THE LINK “Avaya Terms of Use for Hosted Services” OR SUCH
SUCCESSOR SITE AS DESIGNATED BY AVAYA, AND ARE
APPLICABLE TO ANYONE WHO ACCESSES OR USES THE
HOSTED SERVICE. BY ACCESSING OR USING THE HOSTED
SERVICE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON
BEHALF OF YOURSELF AND THE ENTITY FOR WHOM YOU ARE
DOING SO (HEREINAFTER REFERRED TO INTERCHANGEABLY
AS “YOU” AND “END USER”), AGREE TO THE TERMS OF USE. IF
YOU ARE ACCEPTING THE TERMS OF USE ON BEHALF A
COMPANY OR OTHER LEGAL ENTITY, YOU REPRESENT THAT
YOU HAVE THE AUTHORITY TO BIND SUCH ENTITY TO THESE
TERMS OF USE. IF YOU DO NOT HAVE SUCH AUTHORITY, OR IF

YOU DO NOT WISH TO ACCEPT THESE TERMS OF USE, YOU
MUST NOT ACCESS OR USE THE HOSTED SERVICE OR
AUTHORIZE ANYONE TO ACCESS OR USE THE HOSTED
SERVICE.
Licenses
THE SOFTWARE LICENSE TERMS AVAILABLE ON THE AVAYA
WEBSITE, HTTPS://SUPPORT.AVAYA.COM/LICENSEINFO,
UNDER THE LINK “AVAYA SOFTWARE LICENSE TERMS (Avaya
Products)” OR SUCH SUCCESSOR SITE AS DESIGNATED BY
AVAYA, ARE APPLICABLE TO ANYONE WHO DOWNLOADS,
USES AND/OR INSTALLS AVAYA SOFTWARE, PURCHASED
FROM AVAYA INC., ANY AVAYA AFFILIATE, OR AN AVAYA
CHANNEL PARTNER (AS APPLICABLE) UNDER A COMMERCIAL
AGREEMENT WITH AVAYA OR AN AVAYA CHANNEL PARTNER.
UNLESS OTHERWISE AGREED TO BY AVAYA IN WRITING,
AVAYA DOES NOT EXTEND THIS LICENSE IF THE SOFTWARE
WAS OBTAINED FROM ANYONE OTHER THAN AVAYA, AN AVAYA
AFFILIATE OR AN AVAYA CHANNEL PARTNER; AVAYA
RESERVES THE RIGHT TO TAKE LEGAL ACTION AGAINST YOU
AND ANYONE ELSE USING OR SELLING THE SOFTWARE
WITHOUT A LICENSE. BY INSTALLING, DOWNLOADING OR
USING THE SOFTWARE, OR AUTHORIZING OTHERS TO DO SO,
YOU, ON BEHALF OF YOURSELF AND THE ENTITY FOR WHOM
YOU ARE INSTALLING, DOWNLOADING OR USING THE
SOFTWARE (HEREINAFTER REFERRED TO
INTERCHANGEABLY AS “YOU” AND “END USER”), AGREE TO
THESE TERMS AND CONDITIONS AND CREATE A BINDING
CONTRACT BETWEEN YOU AND AVAYA INC. OR THE
APPLICABLE AVAYA AFFILIATE (“AVAYA”).
Avaya grants You a license within the scope of the license types
described below, with the exception of Heritage Nortel Software, for
which the scope of the license is detailed below. Where the order
documentation does not expressly identify a license type, the
applicable license will be a Designated System License as set forth
below in the Designated System(s) License (DS) section as
applicable. The applicable number of licenses and units of capacity
for which the license is granted will be one (1), unless a different
number of licenses or units of capacity is specified in the
documentation or other materials available to You. “Software” means
computer programs in object code, provided by Avaya or an Avaya
Channel Partner, whether as stand-alone products, pre-installed on
hardware products, and any upgrades, updates, patches, bug fixes,
or modified versions thereto. “Designated Processor” means a single
stand-alone computing device. “Server” means a set of Designated
Processors that hosts (physically or virtually) a software application
to be accessed by multiple users. “Instance” means a single copy of
the Software executing at a particular time: (i) on one physical
machine; or (ii) on one deployed software virtual machine (“VM”) or
similar deployment.
License types
Concurrent User License (CU). End User may install and use the
Software on multiple Designated Processors or one or more Servers,
so long as only the licensed number of Units are accessing and using
the Software at any given time. A “Unit” means the unit on which
Avaya, at its sole discretion, bases the pricing of its licenses and can
be, without limitation, an agent, port or user, an e-mail or voice mail
account in the name of a person or corporate function (e.g.,
webmaster or helpdesk), or a directory entry in the administrative
database utilized by the Software that permits one user to interface
with the Software. Units may be linked to a specific, identified Server
or an Instance of the Software.
Heritage Nortel Software
“Heritage Nortel Software” means the software that was acquired by
Avaya as part of its purchase of the Nortel Enterprise Solutions
Business in December 2009. The Heritage Nortel Software is the
software contained within the list of Heritage Nortel Products located
at https://support.avaya.com/LicenseInfo under the link “Heritage
Nortel Products” or such successor site as designated by Avaya. For
Heritage Nortel Software, Avaya grants Customer a license to use
Heritage Nortel Software provided hereunder solely to the extent of
the authorized activation or authorized usage level, solely for the
purpose specified in the Documentation, and solely as embedded in,
for execution on, or for communication with Avaya equipment.
Charges for Heritage Nortel Software may be based on extent of
activation or use authorized as specified in an order or invoice.
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Copyright
Except where expressly stated otherwise, no use should be made of
materials on this site, the Documentation, Software, Hosted Service,
or hardware provided by Avaya. All content on this site, the
documentation, Hosted Service, and the product provided by Avaya
including the selection, arrangement and design of the content is
owned either by Avaya or its licensors and is protected by copyright
and other intellectual property laws including the sui generis rights
relating to the protection of databases. You may not modify, copy,
reproduce, republish, upload, post, transmit or distribute in any way
any content, in whole or in part, including any code and software
unless expressly authorized by Avaya. Unauthorized reproduction,
transmission, dissemination, storage, and or use without the express
written consent of Avaya can be a criminal, as well as a civil offense
under the applicable law.
Virtualization
The following applies if the product is deployed on a virtual machine.
Each product has its own ordering code and license types. Unless
otherwise stated, each Instance of a product must be separately
licensed and ordered. For example, if the end user customer or
Avaya Channel Partner would like to install two Instances of the
same type of products, then two products of that type must be
ordered.
Third Party Components
“Third Party Components” mean certain software programs or
portions thereof included in the Software or Hosted Service may
contain software (including open source software) distributed under
third party agreements (“Third Party Components”), which contain
terms regarding the rights to use certain portions of the Software
(“Third Party Terms”). As required, information regarding distributed
Linux OS source code (for those products that have distributed Linux
OS source code) and identifying the copyright holders of the Third
Party Components and the Third Party Terms that apply is available
in the products, Documentation or on Avaya’s website at: https://
support.avaya.com/Copyright or such successor site as designated
by Avaya. The open source software license terms provided as Third
Party Terms are consistent with the license rights granted in these
Software License Terms, and may contain additional rights benefiting
You, such as modification and distribution of the open source
software. The Third Party Terms shall take precedence over these
Software License Terms, solely with respect to the applicable Third
Party Components to the extent that these Software License Terms
impose greater restrictions on You than the applicable Third Party
Terms.
The following applies only if the H.264 (AVC) codec is distributed with
the product. THIS PRODUCT IS LICENSED UNDER THE AVC
PATENT PORTFOLIO LICENSE FOR THE PERSONAL USE OF A
CONSUMER OR OTHER USES IN WHICH IT DOES NOT RECEIVE
REMUNERATION TO (i) ENCODE VIDEO IN COMPLIANCE WITH
THE AVC STANDARD (“AVC VIDEO”) AND/OR (ii) DECODE AVC
VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A
PERSONAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO
PROVIDER LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS
GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE.
ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEG LA,
L.L.C. SEE HTTP://WWW.MPEGLA.COM.
Service Provider
THE FOLLOWING APPLIES TO AVAYA CHANNEL PARTNER’S
HOSTING OF AVAYA PRODUCTS OR SERVICES. THE PRODUCT
OR HOSTED SERVICE MAY USE THIRD PARTY COMPONENTS
SUBJECT TO THIRD PARTY TERMS AND REQUIRE A SERVICE
PROVIDER TO BE INDEPENDENTLY LICENSED DIRECTLY FROM
THE THIRD PARTY SUPPLIER. AN AVAYA CHANNEL PARTNER’S
HOSTING OF AVAYA PRODUCTS MUST BE AUTHORIZED IN
WRITING BY AVAYA AND IF THOSE HOSTED PRODUCTS USE
OR EMBED CERTAIN THIRD PARTY SOFTWARE, INCLUDING
BUT NOT LIMITED TO MICROSOFT SOFTWARE OR CODECS,
THE AVAYA CHANNEL PARTNER IS REQUIRED TO
INDEPENDENTLY OBTAIN ANY APPLICABLE LICENSE
AGREEMENTS, AT THE AVAYA CHANNEL PARTNER’S EXPENSE,
DIRECTLY FROM THE APPLICABLE THIRD PARTY SUPPLIER.
WITH RESPECT TO CODECS, IF THE AVAYA CHANNEL
PARTNER IS HOSTING ANY PRODUCTS THAT USE OR EMBED
THE H.264 CODEC OR H.265 CODEC, THE AVAYA CHANNEL

PARTNER ACKNOWLEDGES AND AGREES THE AVAYA
CHANNEL PARTNER IS RESPONSIBLE FOR ANY AND ALL
RELATED FEES AND/OR ROYALTIES. THE H.264 (AVC) CODEC
IS LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE
FOR THE PERSONAL USE OF A CONSUMER OR OTHER USES
IN WHICH IT DOES NOT RECEIVE REMUNERATION TO: (I)
ENCODE VIDEO IN COMPLIANCE WITH THE AVC STANDARD
(“AVC VIDEO”) AND/OR (II) DECODE AVC VIDEO THAT WAS
ENCODED BY A CONSUMER ENGAGED IN A PERSONAL
ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO PROVIDER
LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS GRANTED
OR SHALL BE IMPLIED FOR ANY OTHER USE. ADDITIONAL
INFORMATION FOR H.264 (AVC) AND H.265 (HEVC) CODECS
MAY BE OBTAINED FROM MPEG LA, L.L.C. SEE HTTP://
WWW.MPEGLA.COM.
Compliance with Laws
You acknowledge and agree that it is Your responsibility for
complying with any applicable laws and regulations, including, but not
limited to laws and regulations related to call recording, data privacy,
intellectual property, trade secret, fraud, and music performance
rights, in the country or territory where the Avaya product is used.
Preventing Toll Fraud
“Toll Fraud” is the unauthorized use of your telecommunications
system by an unauthorized party (for example, a person who is not a
corporate employee, agent, subcontractor, or is not working on your
company's behalf). Be aware that there can be a risk of Toll Fraud
associated with your system and that, if Toll Fraud occurs, it can
result in substantial additional charges for your telecommunications
services.
Avaya Toll Fraud intervention
If You suspect that You are being victimized by Toll Fraud and You
need technical assistance or support, call Technical Service Center
Toll Fraud Intervention Hotline at +1-800-643-2353 for the United
States and Canada. For additional support telephone numbers, see
the Avaya Support website: https://support.avaya.com or such
successor site as designated by Avaya.
Security Vulnerabilities
Information about Avaya’s security support policies can be found in
the Security Policies and Support section of https://
support.avaya.com/security.
Suspected Avaya product security vulnerabilities are handled per the
Avaya Product Security Support Flow (https://
support.avaya.com/css/P8/documents/100161515).
Downloading Documentation
For the most current versions of Documentation, see the Avaya
Support website: https://support.avaya.com, or such successor site
as designated by Avaya.
Contact Avaya Support
See the Avaya Support website: https://support.avaya.com for
product or Hosted Service notices and articles, or to report a problem
with your Avaya product or Hosted Service. For a list of support
telephone numbers and contact addresses, go to the Avaya Support
website: https://support.avaya.com (or such successor site as
designated by Avaya), scroll to the bottom of the page, and select
Contact Avaya Support.
Regulatory Statements
Trademarks
The trademarks, logos and service marks (“Marks”) displayed in this
site, the Documentation, Hosted Service(s), and product(s) provided
by Avaya are the registered or unregistered Marks of Avaya, its
affiliates, its licensors, its suppliers, or other third parties. Users are
not permitted to use such Marks without prior written consent from
Avaya or such third party which may own the Mark. Nothing
contained in this site, the Documentation, Hosted Service(s) and
product(s) should be construed as granting, by implication, estoppel,
or otherwise, any license or right in and to the Marks without the
express written permission of Avaya or the applicable third party.
Avaya is a registered trademark of Avaya Inc.
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All non-Avaya trademarks are the property of their respective owners.
Linux® is the registered trademark of Linus Torvalds in the U.S. and
other countries.
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Chapter 1: Introduction

Purpose
This document describes how to use Desktop Monitor in an Avaya Workforce Optimization Select
environment.

Supervisors can use this document to create and assign projects to employees in a contact center
environment. Employees can use the document to manage the projects assigned to them.
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Chapter 2: Desktop Monitor Overview

Desktop Monitor overview
Desktop Monitor is a client-server solution to capture and monitor employee desktops and identify
the quality of employees’ daily interactions. The solution provides access to customer information
from native and web-based applications. No additional programming or customization is required.
Desktop Monitor operates in two modes:

• Monitoring mode: The mode running on desktops of employees who are attending to voice
and non-voice interactions in the contact center. This is the default mode.

• Learning mode: The mode installed on the supervisor or manager’s desktop for monitoring
interactions of employees. When Learning Console is started, the monitoring mode
automatically changes to the learning mode.

Benefits
• Enables PCI compliance and security during event monitoring.
• Monitors web and native applications for compliance and adherence.
• Improves business processes, workflow, and rules.
• Identifies and measures training requirement for employees.
• Enhances organizational productivity with constant monitoring and recommending related

coaching requirements.

Features
• An easy-to-use, browser-based interface to configure the projects that require monitoring.
• Automatic detection of confidential data, such as credit card details, and masking of the

information for optimal security.
• Real time availability of user actions, events, triggers, and navigations.
• Integration with third-party applications, such as a Workforce Management tool.

Components
Desktop Monitor consists of the following components:

• Learning Console
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• Native resource files
• Web resource files
• Script Generator
• AvayaDesktopAgent.msi
• Unified Messaging
• Recorder
• Database
• Apache 2.4.25

Components
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Chapter 3: Certificate configuration for
Avaya Desktop Agent

Avaya Desktop Agent has a self-signed certificate. Ensure you replace this certificate with the third
party certificates after installation.
Replace the ScreenCapture.cer file with the Root certificate of the Certificate Authority. Ensure
you provide the Subject Alternative Name in the third party client certificate which is generated for
the Windows client machine. The Subject Alternative Name must contain the actual host name of
the machine and also localhost. If you do not mention localhost, then the registration request
from Avaya IX™ Workspaces to Screen service fails due to Unsecured certificate error. Ensure that
the browser using which the agent has logged into Avaya IX™ Workspaces also has a client
certificate generated from same Certificate Authority.
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Chapter 4: Navigation

Opening Learning Console
Before you begin
Install AvayaDesktopAgent.msi on each administrator and employee machine.

Procedure
1. Go to the location where LearningConsole.exe is located on your local machine. For

example: C:\DTA\ScreenCapture\DTA\LearningConsole.

2. Double-click LearningConsole.exe.

The system displays the AWFOS Desktop Monitor page with the option to create a new
project or open recent projects.

Menu options
Name Description
Project To configure and manage projects, applications, documents, forms, and

controls.
Actions To create custom user actions. The options are:

• Edit: Provides the option to edit a project.

• Delete: Provides the option to delete a project.

• Hierarchy: Displays the structure of events in a project.

• Recent Actions: Displays the recent user actions done on a project.
Help To view:

• A product overview of Learning Console.

• The help file to use Learning Console.
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Settings
Name Description
Preferences To set the location and preferred language on your local machine.

The options are:

• App. Data Path: The location where Learning Console is located. The
default location is C:\DesktopMonitor\AppData\. You can change
the location anytime.

• Culture: The option to set the language. The default option is en-us.

Navigation
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Chapter 5: Managing Learning Mode

Learning mode
When you install AvayaDesktopAgent.msi, the system runs the following .exe files in the
background:

• Screen.exe: Desktop Agent Service

• ScreenCapture.exe: Desktop Agent Application

In the Learning mode, one instance of Desktop Agent Service runs on each supervisor machine,
and one instance of Desktop Agent Application runs for every screen that each employee
accesses.
For example, if more than one user logs on to the same machine, then multiple Desktop Agent
Application instances are created.
The sequence of execution in the Learning mode is as follows:

1. The supervisor uses Learning Console to configure the events and controls that must be
monitored and captured.

2. The Desktop Agent Service starts Desktop Agent Application on the supervisor desktop.
The Desktop Agent Application injects the learning code into the application that must be
configured for monitoring on the employee desktop.
Desktop Monitor supports monitoring of web-based and native applications.
The injected code monitors the employees’ activities, captures the data coming from add-
ons or DLLs, and sends the data to Desktop Agent Application.

3. The Desktop Agent Application collects the incoming data and sends it to Learning
Console.

4. The Learning Console processes the data, generates an XML file, and sends the file to
Script Generator to generate project resource files.

5. The supervisor manually inserts the project resource files, js files and xml files, into the
database and in DTA_USER_ACCESS table with the help of database queries.
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Chapter 6: Managing Monitoring Mode

Monitoring mode
In Monitoring mode, you can use the following login types depending on your environment:

• Individual user login: One instance of Desktop Agent Service and one instance of Desktop
Agent Application run on each employee machine to be monitored. Example, desktop
environment.

• Single server multiple user login: One instance of Desktop Agent Service associated with
multiple users’ login and multiple instances of Desktop Agent Application run on employee
machine to be monitored. Example, Cywayitrix environment.

In the Monitoring mode, Avaya Desktop Agent Service runs on each employee machine to be
monitored.
The sequence of execution in the Monitoring mode is as follows:

1. When an employee logs on to the desktop, Desktop Agent Service sends a notification to
Desktop Agent Server.

2. Desktop Agent Server copies all the project resource files and XML files to Desktop Agent
Service and Desktop Agent Application on the local machine. The default location is C:
\ProgramData\Avaya\Data.

3. Desktop Agent Application processes these files and injects the code into the running
instances of Desktop Agent Server to capture the employee activities. The Desktop Agent
Server sends back the captured data and triggers to Desktop Agent Application.

4. The Desktop Agent Application collects and processes the data and generates events
such as Pause, Resume, Call Data, Start and Stop.

5. The event triggers are sent to the Desktop Agent Server through a Desktop Agent Service.
6. The Desktop Agent Server sends events to the Recorder, and then the Recorder updates

the Call Data in the database.
7. The program resource files and XML files have the list of URLs. When an agent opens a

document or application, the browser sends the URL information to the Desktop Agent
Application. The Desktop Agent Application verifies the URL in the program resource files
and XML files and injects the code into the browser.

8. Based on the triggers configured, you can capture:
• Application start and stop events.
• Contextual data such as application name, user ID, and machine name.
• Events with data and time.
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• Changes to fields or data within the application.
• Navigation information such as click, mouse over and mouse out.

Note:
• If a voice or a non voice interaction configured for screen capture recording is paused,

then during live monitoring or playback, Avaya Workforce Optimization Select displays

the  image to indicate that no screens are captured during the paused state.
• If a voice or non voice interaction configured for screen capture recording is terminated

when the recording is paused, then during playback, Avaya Workforce Optimization

Select displays the  image during the paused state and at the end of the screen cast.

Limitation
In Internet Explorer, when you create and try to reload the project or refresh the project URL, the
reload fails. This issue occurs because when you press the reload button or the refresh key (F5),
the system still uses the cached data. However, a user can manually reload the page by clicking
on the URL and then pressing the Enter key.

Monitoring mode
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Chapter 7: Managing Learning Console

Learning Console configuration
To successfully implement Desktop Agent, you must identify the applications that you must
monitor and track and then configure the Learning Console.
In the Learning mode, you can configure the Learning Console to capture:

• Web applications and native applications that a user visits.
• Screen images that a user browses or visits.
• Application-specific data such as specific button clicks or mouse out or mouse over or field

changed events.
• Business data associated with interactions.

You can configure all user-level activity and export it to agent desktops that are to be monitored.
Use Projects as a placeholder to define the applications that you must monitor, track, and analyze.
Each Project is an abstract entity that contains a collection of automation rules configured for the
Desktop Agent. Depending on the business problem that you want to address or the business
process that you want to improve, you can create more than one project.
The following diagram depicts the steps to create a project and assign it to a user:

October 2019 Using Desktop Monitor for Avaya Workforce Optimization Select 16
Comments on this document? infodev@avaya.com

mailto:infodev@avaya.com?subject=Using Desktop Monitor for Avaya Workforce Optimization Select


Creating a project

Adding applications to a project 

Adding documents to an application

Adding forms to a document

Adding controls to a form

Limitations: 
• Learning is not supported for cross domain URLs, iframes, plug-ins, and advertisements in

web URLs.
• Monitoring pop up windows, files, and buttons using the payload feature is not supported for

native apps.
• Learning and monitoring of  Avaya native apps made with .net, java apps are not supported

for native apps.
• Learning in high level apps or secure native apps is not available without administrative

permissions.
• Learning is not available for File Explorers and windows pop-ups.
• Monitoring is not available for multiple applications within the same native app.
• Learning is not supported in Citrix Zen Desktop.
• Call Data is not captured if the variable name is in upper case.
• Learning and monitoring are not supported in websites that contain document mode 7, 8, 9,

and 10. Only document mode 11 is supported.

Learning Console configuration checklist
This checklist provides the steps for configuring the Learning Console in Learning mode.

Learning Console configuration checklist
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No. Task Description Notes

1 Enable the Desktop
Monitor add-ons in the
following browsers:

• Internet Explorer

• Google Chrome

• Mozilla Firefox

See

• Enabling Desktop
Monitor add-ons in
Internet Explorer on
page 19.

• Enabling Desktop
Monitoradd-ons in
Google Chrome on
page 19.

2 Create a Project to
monitor applications on
employee desktop.

See Creating a project on
page 20.

2 Add applications. See Adding an application
to a project on page 21.

3 Add a document to
monitor.

See Adding a document to
an application on
page 23.

4 Add a form from which
you want to capture
data.

See

• Adding a default form on
page 25.

• Adding a custom form on
page 25.

5 Add controls to track and
analyze employee
actions.

See Adding controls on
page 26.

6 Add actions on which
you want to capture
employee actions.

See Adding actions to user
actions on page 28.

7 Add payloads to capture
data from employees’
desktop.

See Adding a Payload on
page 30.

8 Save the project. See Saving a project on
page 32.

9 Execute Database
scripts, and push
projects to agent
desktops to monitor.

For more information, see
Deploying Avaya
Workforce Optimization
Select with Avaya Aura®

Communication Manager
and Avaya Aura® Contact
Center .

Managing Learning Console
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Enabling the Desktop Monitor add-ons in different
browsers

Enabling Desktop Monitor add-ons in Internet Explorer
About this task
Use this procedure to enable the Desktop Monitor add-on, HarmonyBHO.dll for 32–bit machine or
HarmonyBHO64.dll for 64–bit machine, in Internet Explorer. By default, the browser add-ons for
Desktop Monitor are installed in the user’s local machine while installing Screen Capture.

Procedure
1. Click Start > Internet Explorer.
2. On Internet Explorer, click Tools > Manage add-ons.

3. On the Manage Add-ons page, click one of the following:

• HarmonyBHO.dll :Browser add-on for IE 32–bit machine.

• HarmonyBHO64.dll :Browser add-ons for IE 64–bit machine.

4. Click Enable > Close.

Next steps
Close the IE browser and open again.

Enabling Desktop Monitoradd-ons in Google Chrome
About this task
Use this procedure to enable the Desktop Monitor add-on, AvayaDesktopAgent in Google
Chrome. By default, the browser add-ons for Desktop Monitor are installed in the user’s local
machine while installing Screen Capture.

Procedure
1. Click Start > Google Chrome.

2. On Google Chrome, click Settings > Extensions.

3. On the Extensions page, select the Enable checkbox next to AvayaDesktopAgent and
close the window.

Next steps
Close the Chrome browser and open again.

Enabling the Desktop Monitor add-ons in different browsers
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Enabling Desktop Monitor add-ons in Mozilla Firefox
About this task
Use this procedure to enable the Desktop Monitor add-on, AvayaDESKTOPAGENT, in Mozilla
Firefox. By default, the browser add-ons for Desktop Monitor are installed in the user’s local
machine while installing Screen Capture.

Procedure
1. Click Start > Mozilla Firefox.

2. On Mozilla Firefox, click the Manage your add-ons > Extensions icons.

3. Click the Enable tab next to AvayaDESKTOPAGENT.

Next steps
Close the Mozilla Firefox browser and open the browser again.

Creating a project
About this task
Use this procedure to configure projects that define what applications you want to monitor on an
agent desktop.

Procedure
1. Start the Learning Console, and select one of the following:

• New Project
• Recent Projects

2. For a new project, enter a name and description.

3. Click OK.

Example
For example, if you want to create a project that captures back office desktop processes for
banking transactions, create a project named Back Office.

Editing a project
Before you begin
Create a project.

Managing Learning Console
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Procedure
1. On Learning Console, click Project > Recent > x.

Here, x is the name of the project that you want to edit.

2. Right-click on x and click Edit Project.

The system displays the Edit Project page.

3. Change the name and the description of the project.

4. Click OK.

Adding an application to a project
About this task
Use this procedure to add applications that you want the Desktop Monitor to monitor and capture.
You can add more than one application to a project.

Before you begin
Create a project.

Procedure
1. Right-click the project, and select Add Application.

2. Enter the required details in the following fields:

• Alias
• Name

3. In Category, click one of the following:

• Web Applications: In Domain, type the domain of the web.
• Native Applications: The Domain name changes to Executable and the Type field

changes to MFC. Click Browse to select the required .exe file.

4. Click one of the following:

• OK: To save the application details.
• OK & Add Another: To add another application.
• OK & Add Document: To add a document.
• Cancel: To cancel the process.

Next steps
Add a document.

Related links
Configure Application field descriptions on page 22

Adding an application to a project
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Configure Application field descriptions
Name Description
Alias The alias name of the application.
Name The name of the application.
Category The category of the application. The options are:

• Web Applications: Applications that run within a
browser.

• Native Applications: Applications that are native,
such as Notepad.

Type The type of application within a specific category.
The options are:

• Simple Web App (HTML/JS): Applicable for web
applications.

• MFC: Applicable for native applications.

• C/C++: Applicable for native applications.
Domain The domain name of the web application.

Learning Console displays this field only when you
select Web Applications in the Category field.

Executable The executable file of the native application.

Learning Console displays this field only when you
select Native Applications in the Category field.
You must use Browse to browse and select the
executable file.

Actions The user actions within the application. The options
are:

• Open

• Close

You can map custom events with each user action.
Instance Specific Expr Evaluation The mechanism for evaluating the user actions

coming from different instances of an application.
The options are:

• Automatic: Avaya Desktop Agent evaluates the
user actions automatically.

• Enable: Avaya Desktop Agent evaluates the user
actions independently grouped by the instance.

• Disable: Avaya Desktop Agent evaluates the user
actions as if they are coming from a single
instance of the application.

Managing Learning Console
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Related links
Adding an application to a project on page 21

Adding a document to an application
About this task
Use this procedure to create a document and capture the URL of the application for capturing
agent activities. You can add multiple documents to capture different pages within a single
application. You can add a document only in web applications, and not in native applications.
Note that if you refresh the page on Internet Explorer using the refresh key (F5), the Learning
Console does not reload the URL because the system uses cached data. However, a user can
manually reload the page by clicking on the URL and pressing the Enter key.

Before you begin
Add an application to a project.

Procedure
1. Open the web application that you want to monitor on the employee machine.

2. In Learning Console, right-click on the application, and click Add Document.
3. Reload the web application.

Learning Console displays a set of blank fields.

4. Enter the required information in the fields.

5. Click one of the following:

• OK: To save the document details.

• OK & Add Another:To add another document.

• OK & Add Form: To add a form to the document.

• Cancel: To cancel the process.

Next steps
Add a form.

Related links
Document field descriptions on page 24

Adding a document to an application
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Document field descriptions
Name Description
Alias The alias name for the document.
Name The name of the application.
Document The name of the document that contains the URL of the application.
URL Match The options used to search and match the URL of the application that is

monitored. The options are:

• Exact

The Learning Console searches for the exact match of the URL as
specified in the Document field. For example, if you set the Document
is http://google.com and select this option, the Learning Console
captures only the controls and triggers defined for this page.

• Partial Match

The Learning Console searches for keywords or strings to match in the
URL as specified in the Document field.

• RegEx

The Learning Console searches for a special text string used to
describe a search pattern in different applications.

Match Value The value to match when searching for Document.

The default is the value captured by the Spy tool. You can change the
value from the default value to another value.

User Actions The user actions for the document. The options are:

• Open

• Load

• Unload

For each of the above user actions, you can map actions such as
PAUSE, RESUME, START, STOP, and CALL_DATA. For example, you
can configure the application to pause when the page loads, and resume
when the page unloads.

Related links
Adding a document to an application on page 23
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Adding a default form
Before you begin
Add a document.

About this task
A form defines what you want to monitor or capture within a document. Add controls to define the
user activity that needs to be captured within a document. You can add multiple controls within a
form.

Note:

Native applications do not support forms.

Procedure
1. Right-click on the document and select Add Form.

2. Enter the name and alias name for the form.

3. To save the form, click OK.

4. To add another form, click OK & Add Another.
5. To add controls to the document, click OK & Add Controls.

Next steps
Add controls.

Adding a custom form
Before you begin
Add a document.

About this task
You can add forms under the default or custom categories.
A web page which has different sections within the page is captured as a custom form.

Note:

Learning is not supported for cross domain URLs, iframes, plug-ins, and advertisements in web
URLs.

Procedure
1. Drag and drop the spy (  ) icon to add a control to a form.

The system displays a message to confirm whether you want to add a custom form.

2. Type the required details.

Adding a default form
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3. To save the form, click OK.

4. To add another form, click OK & Add Another.
5. To add controls to the document, click OK & Add Controls.

Next steps
Add controls.

Related links
Custom form field descriptions on page 26

Custom form field descriptions
Name Description
Alias The alias name for the form.
Name The name of the form.
Form ID The class ID of the form.

This field is automatically populated when you capture the page using the
spy tool.

Form Class The name of the class.

This field is automatically populated when you capture the page using the
spy tool.

User Actions The user actions to be captured for the form. The options are:

• Load

• Unload

For each of the above user actions, you can map actions such as
PAUSE, START, RESUME, STOP, and CALL_DATA.

Related links
Adding a custom form on page 25

Adding controls
Before you begin
Add form to a document.

About this task
Add controls within a form to capture a particular action such as a click or a text input in the
application or page. Controls can be input text boxes, radio buttons, and checkboxes. You can
also add multiple controls to a form.

Managing Learning Console
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Note:

You cannot add drop down list as a control within a form.

Procedure
1. Right-click on the document, and select Add Form.

2. To add a control, drag the spy (  ) icon to the section in the page you want to capture.

The Learning Console automatically identifies the control properties.

3. On the web application page, drag and drop the spy tool on the control you want to
monitor.

The Learning Console automatically identifies the properties of the control.

4. If you want to enable monitoring of sibling control types, select Enable Sibling.

5. Select the appropriate user action that you want to monitor, and click OK.

Related links
Controls field descriptions on page 27

Controls field descriptions
Name Description
Alias The alias name for the control.
Name The name of the control.
Type The type of the control. This field is automatically populated when you

drag and drop the spy tool.

If you drop the spy tool on a button, the field is populated as Button.
ID The identifier that is unique to the type of the control. This field is

automatically populated.
Value The value, position, width, height of the control. This field is automatically

populated.
Class Name The class name of the control. This field is automatically populated.
Enable Sibling The option to enable monitoring of sibling control types. For example,

select the check box if you want to monitor when the agent clicks on any
or all of the buttons in a document.

Table continues…

Adding controls
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Name Description
User Actions The user actions for the control. The options are:

• Click

• Mouseover

• Mouseout

For each of the above user actions, you can map actions such as
PAUSE, RESUME, and CALL_DATA.

Note:

Native applications do not support mouseover and mouseout controls.

Related links
Adding controls on page 26

Adding actions to user actions
About this task
You can manually map one or more actions to every user action.

Procedure
1. In User Action, click the Manage User Action (  ) icon for the action that you want to

map to a user action.

2. On the Select Actions screen, select the checkbox from the Available Actions column, click
the icon, and click OK.

You can add one or more actions from the Available Actions column to the same user
action.

The Selected Actions column displays the actions that you have selected for an user
action.

3. (Optional) To remove one or more selected actions, select the checkbox from the Selected
Actions column, click the  icon and click OK.

Related links
Actions field descriptions on page 29
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Actions field descriptions
Name Description
TIMERS
PAUSE To capture critical information entered in the control that is mapped within

an application.

For example, to pause or mute voice recordings especially when the
customer is providing critical information like credit card details over the
phone.

RESUME To resume the capture of events within an application.

For example, you can use the action specifically after using the PAUSE
action.

CALL_DATA To capture the text entered by a user in the application that is configured
for monitoring.

STARTSCREEN To start screen capture on the user desktop.
STOPSCREEN To stop screen capture on the user desktop.

Related links
Adding actions to user actions on page 28

Payload
Payload is the data that a user enters, which is captured in Learning Console. Payload can be
divided on the following two types depending on the value it is assigned.

• Static Payload: A fixed value given to a control. You can specify a static payload for values
which never change.

• Dynamic Payload: Any value given at run time to a control that is whatever value the user
enters, the data is captured.

The data is captured in three different scenarios:

• Control and Payload are same

• Control and Payload are from same row

• Control and Payload are from different rows

Payload
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Adding a Payload
Before you begin
Add Actions

About this task
When you map a user action with Actions such as CALL_DATA, you can add Payload to define
whether the content that is captured must be static or dynamic.

Note:

For native applications, you cannot monitor pop-up windows, and files using the Payload feature.

Procedure
1. In Actions, select a user action on which you want to map a Payload.

2. Click the  icon on User Action.

3. On the Actions screen, select the Payload.

You can add one or more than one Payload for the same user action.

4. Select event call data.

5. Click Add Payload.

6. Click Dynamic Payload.

7. Drag the Spy icon on control.

8. In the Payload Name field, type Var1.

9. Click Add and save the project.

Related links
Add Payload field descriptions on page 30

Add Payload field descriptions
Static Payload

Name Description
Name The name of the payload.
Value The value of the payload.

Dynamic Payload

Name Description
Payload Name The name of the payload.

Table continues…
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Name Description
Control ID The identifier of the control.
Control Name The name of the control.
Control Class The class of the control.
Control Type The type of control.
Control Value The value of the control.
Value Filter RegEx The value based on which Avaya Desktop Agent

searches for a special text string.
Process Siblings The check box to process the sibling control types.

If you select this check box, you must select the
sibling of the control. You can add Sibling payloads
in three ways:

• Control and payload are same

• Control and payload are from the same row

• Control and payload are from the different rows

Related links
Adding a Payload on page 30

Siblings
Siblings are group of controls that consists of same properties in a particular form. Siblings can
also be same controls from same HTML parent.

Siblings are used when a user needs to add more than one control to an action. Siblings are
applicable to controls which consists of some common properties and for tabular data, such as,
rows and columns.

Refer to the following example table to understand the concept of Siblings in Learning Console:

Rank Team Matches Points Rating
1 A 24 3008 125
2 B 32 3376 106
3 C 36 3686 102

In this sample table, each column or row can be siblings of each other. For example, if you add 1
as a control in the Rank column, you can choose 2 as its sibling. When you enable sibling for 1
and add a user action for control, the user action is also valid for its siblings. For example, if you
added user action for control 1 to generate pause event, and click either of the siblings 2 or 3, the
pause event is generated.

Siblings
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The siblings payload can be added in the following three scenarios:

• Control and Payload are same

• Control and Payload are from the same row

• Control and Payload are from different rows

Adding siblings
About this task
Use this procedure to add siblings after you enable sibling in controls.

Before you begin
Add controls.

Procedure
1. While adding controls, select the Enable Siblings checkbox.

The system displays a pop-up window.

2. Drag and drop the Spy icon to the control you want to add as a sibling.

3. Click OK.

4. Select the Enable Sibling Processing checkbox.

5. On the Payload Name field, type var1.

6. Drag and drop the Spy icon on payload1 (control1).

7. Select the Process Sibling checkbox.

8. Drag and drop the Spy icon on another control, control2.

9. Click OK and save the project.

Saving a project
About this task
Use this procedure to save a project after you added all the hierarchal elements to the project.

Before you begin
Add all the required elements to the project.

Procedure
Click Project > Save.

Managing Learning Console
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Exporting a project
About this task
You can export a project for sharing the project with other users.
The supervisors with whom you share the project can the monitor configured agents.

Procedure
1. Click Project > Export

The system displays the Export Projects window.

2. Click the checkbox corresponding to the project you want to export and click OK.

To export all the projects, select the Select All checkbox.

The system saves the project with an .admb extension in your specified location on your
local machine, where admb stands for AWFOS Desktop Monitor Backup Files.

Importing a project
About this task
Use this procedure to import a project from your local machine. You can save a copy of the project
to create a backup, and then import the project later from your local machine to Learning Console
make changes in it.

Procedure
1. Click Project > Import.
2. Go to the location where you had saved your project with an .admb extension.

3. Click on the file you want to import and click Open.

The system displays the message: Project(s) imported successfully. Use the
project open dialog to open.

Deleting a project
Procedure

1. Click Project > Recent > x.

Here, x is the project that you want to delete.

2. Right- click on x > Delete Project.

Exporting a project
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The system displays the message: Deleting the project will cause all the
saved in this project to be permanently lost. Are you sure, you
want to delete this project?

3. Click Yes.
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Chapter 8: Monitor employee desktop

After you configure Learning Console and complete creating appropriate projects, you must push
the project XML files onto all the employee machines. For more information see, Deploying Avaya
Workforce Optimization Select with Avaya Aura® Communication Manager and Avaya Aura®

Contact Center .
The desktop application stops monitoring if an employee refreshes the page that needs to be
monitored using the refresh key (F5) in Internet Explorer. However, an employee can manually
reload the page by clicking on the URL and then pressing the Enter key.
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Chapter 9: Troubleshooting

Learning console not working
Condition
When a user tries to create or edit a project in Learning Console, the Learning Console
functionalities fail to work as desired.

Cause
The Desktop Monitor add-ons got deleted unintentionally from Internet Explorer, Mozilla Firefox,
and Google Chrome browsers.

Solution 1: To recover add-ons in Internet Explorer
Ensure that you have the following Broswer Helper Object (BHO) files in your screen folder:
• HarmonyBHO.dll: Browser add-ons for IE 32–bit
• HarmonyBHO64.dll: Browser add-ons for IE 64–bit

1. Click Start > Internet Explorer.
2. On the Internet Explorer Home page, click Tools > Manage add-ons
3. On the Manage Add-ons page, click the BHO files you added in Step 1.
4. Click Enable and close the page.
5. Restart the machine and check enable the add-ons after the restart.
6. (Optional) If the problem still persists, contact the system administrator.

Solution 2: To recover add-ons in Google Chrome
Ensure that you have the following files in your screen folder:
• harmonydta.crx
• ChromeNMH.exe
• harmonydta.xml
• manifest.json

Warning:
Before making changes in the registry, make sure you have a full backup of your system. If
anything goes wrong, you might end up losing all your data and reinstalling Windows.

1. To go to the registry, click Run on the Start menu, type regedit.

The system displays the Registry Editor page.
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2. On the Registry Editor page, go to HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node
\Google\Chrome\NativeMessagingHosts .

3. Right-click on the NativeMessagingHosts folder, click New > Key.

4. Rename the new key to chrome.dm.nativemessaging.host.win
5. Right-click on the NativeMessaging folder, click New > String Value.

6. Click on the New Value#1 row.
7. On the Edit String window, type the required information in the following fields:

• Value name: Default.

• Value data: C:\Program Files (x86)\Avaya\Screen\manifest.json
8. Click OK.
9. Check if the C:\\Program Files (x86)\\Avaya\\Screen\\ChromeNMH.exe file is

present in the manifest.json file.

10. On the Registry Editor page, go to HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node
\Policies\Google\Chrome\Extensions .

11. Right-click on the Extensions folder, click New > Key
12. Rename the new key to ExtensionInstallForcelist
13. Right-click on the Extensions folder, click New > String Value.

14. Click on the ExtensionInstallForcelist row.
15. On the Edit String window, type the required information in the following fields:

• Value name: 1.

• Value data: lbgpiikogfeokonlkmejcfpffgnonbcc;file:///C:/Program
Files (x86)/Avaya/Screen/harmonydta.xml

16. Click OK.
17. Go to the harmonydta.xml folder and edit add path to file:///C:/Program Files

(x86)/Avaya/Screen/HarmonyDTA.crx.

18. Restart the machine and enable the add-ons after the restart.
19. (Optional) If the problem still persists, contact the system administrator.

Solution 3a: To recover add-ons in Mozilla Firefox
You can use either Solution 3a or Solution 3b to recover the add-ons in Mozilla Firefox for 64–
bit machine. For 32–bit machine, use only Solution 3a.
Ensure that the following file is available in the screen folder: AvayaDESKTOPAGENT.xpi

Warning:
Before making changes in the registry, make sure you have a full backup of your system. If
anything goes wrong, you might end up losing all your data and reinstalling Windows.

1. Click Start > Mozilla Firefox .

Learning console not working
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2. Drag the AvayaDESKTOPAGENT.xpi file from the screen folder to the Firefox dashboard.

The system displays the message: This site would lie to install an add-on
in Firefox:

3. Click Install > OK.
4. Restart the machine and check enable the add-ons after the restart.
5. (Optional) If the problem still persists, contact the system administrator.

Solution 3b: To recover add-ons in Mozilla Firefox
You can use either Solution 3a or Solution 3b to recover the add-ons in Mozilla Firefox for 64–
bit machine.
Ensure that the following file is available in the screen folder: AvayaDESKTOPAGENT.xpi

Warning:
Before making changes in the registry, make sure you have a full backup of your system. If
anything goes wrong, you might end up losing all your data and reinstalling Windows.

1. To go to the registry, click Run on the Start menu, type regedit.

The system displays the Registry Editor page.
2. On the Registry Editor page, go to HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node

\Mozilla\Chrome\Firefox\Extensions .

3. Right-click on the Extensions folder, click New > Key.

4. Rename the new key to Extensions
5. Right-click on the Extensions folder, click New > String Value.

6. Click on the New Value#1 row.
7. On the Edit String window, type the required information in the following fields:

• Value name: harmonydta@avaya.com.

• Value data: C:\Program Files (x86)\Avaya\Screen
\AVAYADESKTOPAGENT.xpi

8. Click OK.
9. Restart the machine and check enable the add-ons after the restart.

10. (Optional) If the problem still persists, contact the system administrator.

Troubleshooting
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Error messages while installing and configuring Screen
Capture

Timer Expired error
Condition
Connection to proxy server failed and the reason code is 0. The system displays the error
message: Timer Expired.

Cause
The IP address of the proxy server in the screen registry is incorrect.

Solution
1. Right-click on the Start button and select Run.

The system displays the Run window.
2. In the Open field, type regedit and click OK.

3. On the Registry Editor window, go to HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node
\AVAYA\Screen .

4. Click the Screen folder.

5. In ConnectURL, enter the required IP address and restart ScreenCapture Service.
6. (Optional) If the IP address is correct, then check Tenant is set to Default and restart

ScreenCapture Service.

Invalid HTTP status error
Condition
Connection to proxy server failed and the reason code is 503. The description is Invalid HTTP
status.

Cause
The Unified Messaging service is down.

Solution
1. To open your Windows Services manager, do the following:

a. Right-click on the Start button and select Run.
The system displays the Run window.

b. In the Open field, type services.msc and click OK.

The system displays the Services window.
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2. On the Services page, click on the AWFOSMessaging service row.
3. To start the UM service, click on the Start link.

Underlying Transport error
Condition
DTA Resource Client connection to proxy failed and the reason code is 0. The description is
Underlying Transport Error.

Cause
The agent network id is not configured properly or the employee user name is missing in the
Avaya Workforce Optimization Select web.

Solution
1. Open the Avaya Workforce Optimization Select web url.
2. Navigate to the employee details and provide the correct user name.
3. In the harmony employee table on database, check if the user name is same as the

network ID.
Make the changes if the user name and the network ID are different.

4. Start the Unified Messaging services or the Screen services to view the changes.
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