
Avaya Network 
Configuration 

Manager User Guide 

May 2004



Avaya Network Configuration Manager User Guide

Copyright Avaya Inc. 2004 ALL RIGHTS RESERVED

The products, specifications, and other technical information regarding the products 
contained in this document are subject to change without notice. All information in this 
document is believed to be accurate and reliable, but is presented without warranty of any 
kind, express or implied, and users must take full responsibility for their application of any 
products specified in this document. Avaya disclaims responsibility for errors which may 
appear in this document, and it reserves the right, in its sole discretion and without notice, to 
make substitutions and modifications in the products and practices described in this 
document.

Avaya™, P580™ and SMON™ are trademarks of Avaya Inc.

© 2004 Avaya Inc. All rights reserved. All trademarks identified by the ® or ™ are registered 
trademarks or trademarks, respectively, of Avaya Inc. All other trademarks are the property 
of their respective owners.

Release 2.002



Table of Contents
Preface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . v

The Purpose of This Manual . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .v
Who Should Use This Manual  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .v
Organization of this Manual . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . vi

Chapter 1 — Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

Avaya Network Configuration Manager Overview  . . . . . . . . . . . . . .2
Starting and Closing Avaya Network Configuration Manager . . . . . .3
The User Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .4

Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .5
View Tabs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .6
The Table Area . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .6

The Device Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .6
The Library View  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .7

Dialog Area  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .7
Status Line . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .8

Using Tooltips . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .9
The Log . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .9
Setting Avaya Network Configuration Manager Options . . . . . . . . .11

General Tab  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .11
Select a Report Location . . . . . . . . . . . . . . . . . . . . . . . . . . .12
Select a Report Format . . . . . . . . . . . . . . . . . . . . . . . . . . . .12
Set the Default Action When Downloading . . . . . . . . . . . .12
Set the Program Used for Comparing Files . . . . . . . . . . . . .13

File Transfer Protocols Tab . . . . . . . . . . . . . . . . . . . . . . . . . . . . .13
Generating Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .15
Searching the Table  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .17
Comparing Configuration Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . .18
Using Avaya Network Configuration Manager Help  . . . . . . . . . . . .19

Opening the Help to the Contents Page  . . . . . . . . . . . . . . . . . .19
Opening the Help to a Topic of Interest . . . . . . . . . . . . . . . . . . .19

Chapter 2 — Saving Device Configurations. . . . . . . . . . . . . . . . . . . . 20

Using the Device Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .21
Information Displayed in the Device Table . . . . . . . . . . . . . . . .21
Filtering the Device Table  . . . . . . . . . . . . . . . . . . . . . . . . . . . . .22

Saving a Device Configuration . . . . . . . . . . . . . . . . . . . . . . . . . . . . .23
Creating a Backup Job  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .24
Avaya Network Configuration Manager User Guide iii



Table of Contents
Activating the Backup Wizard . . . . . . . . . . . . . . . . . . . . . . . . . .24
Backup Wizard Screens . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .25

Backup Wizard - Welcome Screen . . . . . . . . . . . . . . . . . . .25
Backup Wizard - Device Selection Screen  . . . . . . . . . . . . .26
Backup Wizard - File Type Screen  . . . . . . . . . . . . . . . . . . .27
Backup Wizard - Job Type Screen  . . . . . . . . . . . . . . . . . . .28
Backup Wizard - Job Name Screen  . . . . . . . . . . . . . . . . . .29
Backup Wizard - Period Parameters Screen . . . . . . . . . . . .30
Backup Wizard - Summary Screen . . . . . . . . . . . . . . . . . . .32

Managing Jobs  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .33

Chapter 3 — Downloading Configuration Files  . . . . . . . . . . . . . . . . 35

Using the Library View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .36
The Library Tree  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .36
The Library Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .37
Filtering the Library Table . . . . . . . . . . . . . . . . . . . . . . . . . . . . .38

Downloading  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .39
Editing Configuration Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .43

The Configuration Editor User Interface . . . . . . . . . . . . . . . . . .44
Configuration Editor Toolbar  . . . . . . . . . . . . . . . . . . . . . . .45
Editing Window  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .45
Status Bar  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .46

Saving Configuration Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . .47
Downloading Edited Files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . .47
Closing the Configuration Editor . . . . . . . . . . . . . . . . . . . . . . . .47

Appendix A — Menus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48

Avaya Network Configuration Manager Menus  . . . . . . . . . . . . . . .48
File Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .48
Edit Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .48
View Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .48
Actions Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .49
Tools Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .49
Help Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .49

Configuration Editor Menus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .50
File Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .50
Edit Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .50
Action Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .50
Help Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .51

Index. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
iv   Avaya Network Configuration Manager User Guide



Preface
Welcome to Avaya Network Configuration Manager. Avaya Network 
Configuration Manager is an application that enables you to backup and 
restore device configurations and configure groups of devices. 

This chapter provides an introduction to the structure and assumptions 
of this manual. It includes the following sections:

• The Purpose of This Manual - A description of the goals of this 
manual.

• Who Should Use This Manual - The intended audience of this 
manual.

• Organization of this Manual - A brief description of the 
subjects contained in the various chapters of this manual.

The Purpose of This Manual

The Avaya Network Configuration Manager User Guide contains 
information needed to use Avaya Network Configuration Manager 
efficiently and effectively.

Who Should Use This Manual

This manual is intended for network managers familiar with network 
management and its fundamental concepts.
Avaya Network Configuration Manager User Guide v
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Organization of this Manual

This manual is structured to reflect the following conceptual divisions:

• Preface - Describes the manual’s purpose, intended audience, and 
organization.

• Introduction - Provides an introduction to Avaya Network 
Configuration Manager, including instructions for starting and 
closing the application, information on the user interface, and 
instructions on changing Avaya Network Configuration Manager 
options.

• Saving Device Configurations - Provides a description of the 
Device Table and instructions on how to manually save a device’s 
configuration to a file and use the Backup Wizard to create and 
manage backup jobs.

• Downloading Configuration Files - Provides a description of 
the Library View, and instructions on how to edit a configuration 
file and download a file to a device.

• Menus - Provides the full structure of the menus in Avaya 
Network Configuration Manager.
 vi Avaya Network Configuration Manager User Guide
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Avaya Network Configu
Introduction
This chapter provides an introduction to the Avaya Network 
Configuration Manager. It includes the following sections:

• Avaya Network Configuration Manager Overview - An 
overview of Avaya Network Configuration Manager.

• Starting and Closing Avaya Network Configuration 
Manager - Instructions on how to access Avaya Network 
Configuration Manager from your management platform.

• The User Interface - An explanation of the Avaya Network 
Configuration Manager user interface.

• Using Tooltips - An explanation of the Avaya Network 
Configuration Manager tooltip feature.

• The Log - A description of the Avaya Network Configuration 
Manager log.

• Setting Avaya Network Configuration Manager Options - 
Instructions on setting Avaya Network Configuration Manager 
options.

• Generating Reports - Instructions on generating Avaya 
Network Configuration Manager reports.

• Searching the Table - Instructions on searching Avaya Network 
Configuration Manager tables.

• Comparing Configuration Files - Instructions on comparing 
configuration files in Avaya Network Configuration Manager.

• Using Avaya Network Configuration Manager Help - An 
explanation of the options for accessing on-line help in 
Avaya Network Configuration Manager.
ration Manager User Guide 1



Chapter 1
Avaya Network Configuration Manager 
Overview

Avaya Network Configuration Manager is an application that allows you 
to backup and restore device configurations and configure multiple 
devices. Avaya Network Configuration Manager uses Simple Network 
Management Protocol (SNMP) and Trivial File Transfer Protocol (TFTP) or 
Secure Copy Protocol (SCP) to exchange information with the devices in 
the network. 

When using SCP, an SCP server must be installed on the management 
station. After defining users on the SCP server, you can configure Avaya 
Network Configuration Manager as an SCP user.

When you make changes to a device’s configuration, you may find that 
the overall effect of the configuration change may have a negative effect 
on the performance of the device in your network. Avaya Network 
Configuration Manager provides a method for backing up device 
configurations before you make changes. In addition, you can schedule 
automatic, periodic backups. 

Device configurations are saved in files which are stored in a library. A 
configuration file can be downloaded to any appropriate device. For 
example, if you saved the configuration of an Avaya P580 Device, it can 
only be downloaded to an Avaya P580 Device. You can also select a group 
of devices to which you can download a single configuration file. This can 
result in a consistent configuration of the devices in your network.

* Note:  In this documentation, ‘uploading’ always refers to 
information being copied from the device to the application, 
and ‘downloading’ always refers to information being copied 
from the application to devices.
 2 Avaya Network Configuration Manager User Guide
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Starting and Closing Avaya Network 
Configuration Manager

To start Avaya Network Configuration Manager from HP OpenView NNM 
(UNIX or NT-OV), select Tools > Avaya > Avaya Network Configuration 
Manager. Avaya Network Configuration Manager opens.

To start Avaya Network Configuration Manager from Avaya Network 
Console, select Tools > Avaya Network Configuration Manager. Avaya 
Network Configuration Manager opens.

To close Avaya Network Configuration Manager, select File > Exit. Avaya 
Network Configuration Manager closes.
Avaya Network Configuration Manager User Guide 3
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The User Interface

The user interface consists of the following elements:

• Menu Bar - Menus for accessing Avaya Network Configuration 
Manager’s functions. For a list of menu items, refer to “Avaya 
Network Configuration Manager Menus” on page 48.

• Toolbar - Toolbar buttons for accessing Avaya Network 
Configuration Manager’s main functions.

• View Tabs - Tabs for switching between Download View and 
Library View.

• The Table Area - An area where the Device Table and Library 
Table open.

• Dialog Area - A window where all dialog boxes are displayed. 
When no dialog box is open, the Dialog Area disappears, and the 
Device Table expands to take its place.

• Status Line - An area at the bottom of the window where the 
communication status between Avaya Network Configuration 
Manager and network devices and other information is displayed.

Figure 1-1.  Avaya Network Configuration Manager User Interface

Menu
Bar

View Tabs

Table Area

Dialog Area

Status Line

Toolbar
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Toolbar

The Toolbar provides shortcuts to the main Avaya Network Configuration 
Manager functions.

The table below describes the buttons on the Toolbar and gives the 
equivalent menu options.

Table 1-1.  Toolbar Buttons

Button Description Menu Item

Opens the Report dialog box. File > Report

Opens the Options dialog box. File > Options

Opens the Compare Configurations 
dialog box.

Tools > Compare

Opens the configuration editor. Tools > Editor

Deletes the selected configuration 
files.

Edit > Delete

Opens the Find dialog box. Edit > Find

Refreshes device or file information. Actions > Rediscover

Opens the Upload dialog box. Actions > Upload

Opens the Download dialog box. Actions > Download

Opens the Jobs dialog box. Actions > Jobs

Opens the Backup dialog box. Actions > Backup

Opens the device manager for the 
selected device.

Tools > Device Manager

Opens context-sensitive on-line 
help.

Help > Help On
Avaya Network Configuration Manager User Guide 5
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View Tabs

The View Tabs are used to switch between the two views in the Table 
Area. To switch to a different view, click the appropriate View Tab. The 
selected view appears.

The Table Area

The Table Area is where devices and configuration files are displayed. 
There are two views available in the Table Area:

• The Device Table - Lists devices in the network.

• The Library View - Lists configuration files in the library.

To select an item in a table row, click anywhere in the row. 

To select a contiguous group of rows:

1.  Click the row at the top or bottom of the group.

2.  Press SHIFT, and click the row at the other extreme of the group. 
The two end rows and all of the rows between them are selected.

To select multiple rows that are not contiguous:

1.  Click one of the rows.

2.  Press CTRL, and click additional rows you want to select.

To sort a table by one of its columns, click the column header. To reverse 
the order of the sort, click the column header again.

The Device 
Table

The Device Table lists devices in the network and displays information 
about them. The Device Table is used for uploading configurations from 
devices and saving the configurations to files in the library.

Figure 1-2.  Device Table

For further information on using the Device Table to upload 
configurations, refer to Chapter 2, Saving Device Configurations.
 6 Avaya Network Configuration Manager User Guide
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The Library 
View

The Library View includes the Library Tree, which shows the device types 
in the network, and the Library Table, which lists the configuration files in 
the library. The Library Table is used for downloading configurations to 
appropriate devices. 

Figure 1-3.  The Library View

To expand or contract an element in the Library Tree, click the handle 
next to the element. The branch of the tree expands or contracts. 

For more information on the Library View, refer to “Using the Library 
View” on page 36.

Dialog Area

The area to the right of the Table Area is where all dialog boxes appear. 
This area can be resized by dragging the vertical splitter bar with the 
mouse. When a dialog box opens, it replaces the current dialog box in the 
Dialog Area. When no dialog box is open, the Dialog Area disappears, and 
the Table Area window expands to take its place.
Avaya Network Configuration Manager User Guide 7
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Status Line

The Status Line shows the following:

• A status message and graphic displaying the communication status 
between Avaya Network Configuration Manager and the devices 
on the network.

• The progress of uploads and downloads.

• A message specifying whether or not the Device Table is being 
filtered.

• When a configuration file is selected, the file type, the IP address 
and module number of the device from which the file was 
uploaded, and the date the file was created or last modified.

The table below shows the possible statuses with their corresponding 
graphics, and gives a short explanation for each status.

Table 1-2.  Communication Statuses

Status Graphic Description

Idle Avaya Network Configuration 
Manager is ready and no 
downloads are currently in 
progress.

Discovering devices Avaya Network Configuration 
Manager is currently 
communicating with a device.

Downloading Avaya Network Configuration 
Manager is uploading or 
downloading configuration 
files to or from devices.
 8 Avaya Network Configuration Manager User Guide
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Using Tooltips

Avaya Network Configuration Manager includes a tooltip feature that 
allows you to display additional information about devices and software 
versions. Tooltips are available in the following places:

• Device View - To display additional information about a device, 
place the cursor on the device’s IP Address column. After about 
one second, a tooltip appears with information about the device.

Figure 1-4.  Device View Tooltip

• Library View - To display information about a configuration file, 
place the cursor over a configuration file in the Library View. After 
about one second, a tooltip appears with information about the 
selected configuration.

Figure 1-5.  Library View Tooltip

To toggle the status of the tooltips feature, select View > ToolTip.

The Log

Avaya Network Configuration Manager keeps a log of all activity. New log 
information is appended to the end of the existing log. When you close 
Avaya Network Configuration Manager, the log is erased.

To view the log, select View > Log. The Log window opens.
Avaya Network Configuration Manager User Guide 9
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Figure 1-6.  Log Window

The following table provides a list of the fields in the log and their 
descriptions.

To clear all of the entries in the log, click Clear. The log is cleared.

To refresh the entries in the log, click Refresh. The log is refreshed.

To close the log, click . The Log Window closes.

Table 1-3.  Log Window

Field Description

Severity The severity of the event, as follows:

•  Normal - A successful action, such as a 
completed upload or download.

•  Warning - An unsuccessful action, such as 
failure to discover a device.

•  Major - An event relating to a failure to upload 
or download to a device.

Date The date and time at which the event occurred.

Source The source of the event. Possible sources include:

• IP Address (Device) - The source is the device with 
the specified IP address.

• IP Address (Module Number) - The source is the 
specified module number in the device.

• Library - The source is the Avaya Network 
Configuration Manager library.

Message A description of the event.
 10 Avaya Network Configuration Manager User Guide
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Setting Avaya Network Configuration Manager 
Options

Using the Options dialog box, you can configure Avaya Network 
Configuration Manager options. The General tab of the Options dialog 
box enables you to configure the default downloading action and the 
report type and path. The File Transfer Protocols tab of the Options dialog 
box enables you to configure the protocol to use for transferring files.

General Tab

To open the Options dialog box to the General tab:

Click Options.

Or

Select File > Options. The Options dialog box opens to the General 
tab.

Figure 1-7.  Options Dialog Box - General Tab

Using the General tab of the Options dialog box, you can:

• Select a Report Location

• Select a Report Format

• Set the Default Action When Downloading

• Set the Program Used for Comparing Files
Avaya Network Configuration Manager User Guide 11
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To undo all changes made in the Options dialog box before they are 
applied, click Revert. All unsaved changes to the dialog box are discarded.

Select a 
Report 
Location

Avaya Network Configuration Manager reports are saved on the 
computer from which the application is run. If you are running 
Avaya Network Configuration Manager via remote access, reports are 
saved on the client computer, not the server. 

To select a directory to which Avaya Network Configuration Manager 
reports are saved:

1.  Click ... in the Default Report Path section of the Options dialog box. A 
directory browser opens.

2.  Browse to the directory in which you want Avaya Network 
Configuration Manager to save reports.

3.  Click OK. The directory browser closes.

4.  Click Apply. Avaya Network Configuration Manager saves reports 
to the selected directory.

Select a 
Report 
Format

Avaya Network Configuration Manager can create text reports in one of 
these formats:

• CSV (Comma Separated) - The information in the table rows 
are separated by commas.

• Tab Delimited Format - The information in the table rows are 
separated by tabs.

To select a format for Avaya Network Configuration Manager reports:

1.  Select the desired report format from the Format of Report File 
pull-down listbox.

2.  Click Apply. The report format is configured.

Set the 
Default 
Action 
When 
Downloading

You can configure the default response of Avaya Network Configuration 
Manager when a download is going to start. The possible actions are:

• Request Confirmation - A confirmation dialog box opens asking you 
to confirm the download.

• Do Not Request Confirmation - Avaya Network Configuration 
Manager will start the download without requesting confirmation.
 12 Avaya Network Configuration Manager User Guide
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To configure the default action when downloading:

1.  Select the desired default action from the Default Action When 
Downloading pull-down listbox.

2.  Click Apply. The default action when downloading is configured.

Set the 
Program 
Used for 
Comparing 
Files

Avaya Network Configuration Manager enables you to compare 
configuration files between similar devices, or between different versions 
on the same device. This capability requires defining the software used to 
display the differences in the configuration files. 

To select a directory with the location of the software for Avaya 
Network Configuration Manager to use for comparing files:

1.  Click ... in the Path to Diff Program section of the Options dialog box. 
A directory browser opens.

2.  Browse to the directory with the software you want Avaya 
Network Configuration Manager to use to compare files.

3.  Click OK. The directory browser closes.

4.  Click Apply. Avaya Network Configuration Manager sets the chosen 
software for comparing configuration files.

File Transfer Protocols Tab

To open the Options dialog box to the File Transfer Protocols tab:

1.  Click Options.

Or

Select File > Options. The Options dialog box opens to the Options 
tab.

2.  Click File Transfer Protocols. The File Transfer Protocols tab of the 
Options dialog box appears.
Avaya Network Configuration Manager User Guide 13
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Figure 1-8.  Options Dialog Box - File Transfer Protocols Tab

Using the File Transfer Protocols tab of the Options dialog box, you can 
configure the protocols used for transferring files with Avaya Network 
Configuration Manager. 

The following table provides a list of the fields in the File Transfer 
Protocols tab of the Options dialog box and their descriptions.

Table 1-4.  Options Dialog Box - File Transfer Protocols Tab

Field Description

SCP Global Use The state of SCP usage for Avaya Network Configuration 
Manager. Possible values:

• Enabled - SCP is used for devices that support SCP. 
Devices that do not support SCP use FTP if FTP Global 
Use is enabled, otherwise TFTP is used.

• Disabled - SCP is not used. FTP is used for all devices 
if FTP Global Use is enabled, otherwise TFTP is used.

SCP User Name A user name defined on the SCP server. This is the SCP 
user that Avaya Network Configuration Manager will use.

SCP Password The password defined on the SCP server for the configured 
SCP user.
 14 Avaya Network Configuration Manager User Guide
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To apply the changes made in the File Transfer Protocols tab of the 
Options dialog box, click Apply.

Generating Reports

Avaya Network Configuration Manager can generate the following 
reports:

• Library Report - A report listing the configuration files stored in 
the library. (This information can be viewed in the Library Table.)

• Scheduled Jobs Report - A report listing scheduled backup jobs. 
(This information can be viewed in the Jobs dialog box.)

• Last Operations Report - A report listing the last 
upload/download operation on each device in the Device View. 
(This information can be viewed in the Device Table.)

Retype SCP 
Password

The password defined on the SCP server for the configured 
SCP user. The password is entered twice to ensure that it is 
entered correctly.

SCP Server 
Secure Path

The path to the root of the secure path configured on the 
SCP server.

FTP Global Use The state of FTP usage for Avaya Network Configuration 
Manager. Possible values:

• Enabled - If SCP is disabled, or SCP is not supported, 
then FTP is used for devices that support FTP. Devices 
that do not support FTP use TFTP.

• Disabled - FTP is not used. If SCP is disabled, or a 
device does not support SCP, then TFTP is used.

FTP User Name A user name defined on the FTP server. This is the FTP user 
that Avaya Network Configuration Manager will use.

FTP Password The password defined on the FTP server for the configured 
FTP user.

Retype FTP 
Password

The password defined on the FTP server for the configured 
FTP user. The password is entered twice to ensure that it is 
entered correctly.

FTP Server Path The path to the root of the secure path configured on the 
FTP server.

TFTP Server 
Secure Path

The path to the root of the secure path configured on the 
TFTP server.

Table 1-4.  Options Dialog Box - File Transfer Protocols Tab 

Field Description
Avaya Network Configuration Manager User Guide 15
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Reports are saved as text files, with the fields in each item separated by 
commas or tabs. For more information on configuring report options, 
refer to “General Tab” on page 11.

* Note:  Reports are saved on the computer from which the 
application is run. If you are running Avaya Network 
Configuration Manager via remote access, reports are saved 
on the client computer, not the server. 

To generate a report:

1.  Click Report.

Or

Select File > Report. The Report dialog box opens.

Figure 1-9.  Report Dialog Box

2.  Select a report format. For more information on report formats, 
refer to “Select a Report Format” on page 12.

3.  Select a report type.

4.  Enter a name for the report in the Report File Name field.

5.  Click OK. The selected report is generated and saved to the specified 
file.
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Searching the Table

You can search the Device Table to find a device or the Library Table to 
find a configuration file. When searching for a device, you can search 
using the device’s Name or IP address. When searching for a configuration 
file, you can search using the Name or IP address of the device from 
which the file was uploaded.

To search a table:

1.  Click the View Tab to open the table in which you want to search.

2.  Click Find.

Or

Select Edit > Find. The Find dialog box opens.

Figure 1-10.  Find Dialog Box

3.  Do one of the following:

— To find a device or configuration file by IP address:

a.  Click the Find by Device IP option button.

b.  Enter the device’s IP address.

— To find a device or configuration file by name:

a.  Click the Find by Device Best Name option button.

b.  Enter the device’s name.

4.  Click Find. The device or file is highlighted in the table.
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Comparing Configuration Files

This section explains how to compare configuration files with 
Avaya Network Configuration Manager. You can compare configuration 
files between similar devices listed in the Device Table, or between a 
current configuration file and a saved configuration.

To compare configuration files:

1.  Select a device in the Device Table that contains a file you want to 
compare. 

* Note:  You can also select both devices to compare from the Device 
Table, where the device which appears higher in the Device 
Table is considered the first device selected. You can re-sort 
the Device Table according to the device order needed. When 
choosing files by selecting both devices from the device table, 
perform step 2 followed by step 8.

2.  Click .

Or

Select Tools > Compare. The Compare Configurations dialog box 
opens.

Figure 1-11.  Compare Configurations Dialog Box

3.  Select a device in the Device Table that contains a file you want to 
compare.
 18 Avaya Network Configuration Manager User Guide



Introduction
4.  Select the type of file to be compared for the selected device on the 
Compare on this device drop-down listbox in the Compare 
Configurations dialog box. The possible files for comparison 
changes according to the device type selected.

5.  From the With drop-down listbox select to compare this file with a 
different device’s configuration file, or from a saved version of the 
configuration file.

6.  Select the file type with which to compare the selected file from the 
Configuration on device drop-down listbox.

7.  Select the device with the file for comparison from the table on the 
Compare Configurations dialog box.

8.  Click Compare. Avaya Network Configuration Manager compares 
the selected configuration files and opens the result in the software 
selected for file comparison. For more information on selecting the 
file comparison software, refer to “Set the Program Used for 
Comparing Files” on page 13.

Using Avaya Network Configuration Manager 
Help

This section explains how to use the on-line help in the Avaya Network 
Configuration Manager. The on-line help can be opened to the contents 
page or directly to a topic of interest.

Opening the Help to the Contents Page

To open the help to the contents page, select Help > Contents. The on-line 
help opens to the contents page.

Opening the Help to a Topic of Interest

To open the help directly to a topic of interest:

1.  Click Help.

Or

Select Help > Help On. The cursor changes to the shape of an arrow 
with a question mark.

2.  Click on a point of interest in the Avaya Network Configuration 
Manager. The help opens to a topic explaining the feature that was 
clicked.
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Avaya Network Configu
Saving Device 
Configurations
This chapter explains how to save device configurations. Avaya Network 
Configuration Manager enables you to manually save the configurations 
of selected devices and to create backup jobs for automatically saving the 
configuration of all or some of the devices listed in the Device Table. The 
Device Table lists discovered devices and displays information about 
them. 

This chapter includes the following sections:

• Using the Device Table - Describes the Device Table and its 
fields, and explains how to use the Device Table.

• Saving a Device Configuration - Instructions on how to 
manually save a device’s configuration to a file.

• Creating a Backup Job - Instructions on using the Backup 
Wizard, including an explanation of each of the wizard’s screens.

• Managing Jobs - Instructions on how manage jobs created by 
the Backup Wizard.
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Using the Device Table

This section describes the information in the Device Table and the Device 
Table’s functions. It includes the following topics:

• Information Displayed in the Device Table - Explains the 
information displayed in the various columns of the Device Table.

• Filtering the Device Table - Explains how to filter out devices in 
the Device Table.

Information Displayed in the Device Table

The Device Table displays the following information about each device:

• Name - Name of the device (as known to Avaya Network 
Configuration Manager).

• IP - IP address of the device.

• Module - The slot in which the module is located in the device. 
For stackable devices, this is the module’s position in the stack. 

• Type - The type of device.

• Last Operation - The last configuration operation performed on 
the device. Options are:

— Upload - The device’s configuration was uploaded manually.

— Backup - The device’s configuration was uploaded using an 
immediate backup.

— Backup:Job Name - The device’s configuration was 
automatically uploaded by the Job Name periodic backup job.

— Download - A configuration file was downloaded to the 
device.

• Time - The date and time at which the last operation occurred.

• By - The owner of the last operation.

To refresh the information in the Device Table, select View > Refresh. The 
Device Table is refreshed with the latest information from the 
management application.
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Filtering the Device Table

You can filter the Device Table in order to reduce the number of devices 
currently displayed. This can make it easier to work by eliminating 
devices from the display. You can later add these devices back to the list by 
removing the filter, without having to re-discover the devices.

When filtering, you can select families of devices and specific module 
types. Under each product family name, one or more module types are 
listed. To display module types, click the handle next to the product 
family.

When you select a product family, all the module types are automatically 
selected. You can then clear any module types that you do not want to 
select.

To filter the Device Table:

1.  Select Actions > Filter. The Filter dialog box opens.

Figure 2-1.  Filter Dialog Box

2.  Check the checkboxes of the device and modules types you want to 
see in the Device Table. Clear the checkboxes of the device and 
module types you do not want to appear in the Device Table. To 
select all device and module types, check All.

3.  Click Apply. The filter is activated and the dialog box closes.
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Saving a Device Configuration

To save a device’s configuration to a file in the library:

1.  Select a device in the Device Table.

* Note:  You can upload the configurations of several devices by 
selecting them before you open the Upload dialog box.

2.  Click Upload.

Or

Select Actions > Upload. The Upload dialog box opens displaying 
one row for each configuration type found in the selected device.

Figure 2-2.  Upload Dialog Box

3.  Select the configuration types you want to upload.

4.  Click Upload. A progress bar appears above the Upload button, and 
the upload begins. 

The progress bar next to each configuration type shows the progress of 
the upload of that configuration. The progress bar that appears above the 
Upload button shows the progress of the entire upload.
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Creating a Backup Job

The Backup Wizard provides a simple method of backing up the 
configurations of all or some of the devices in your network. In addition, 
using the Backup Wizard, you can schedule periodic automated backups. 
This can help you maintain an archive of your devices’ configurations 
over time. The Backup Wizard also enables you to edit existing backup 
jobs.

* Note:  If you configure a backup job from a workstation working via 
remote access, the backup files are saved on the server.

Activating the Backup Wizard

To create a new backup job:

Click Backup.

Or

Select Actions > Backup. 

Or

Click New in the Jobs dialog box. The Backup Wizard opens with 
the Backup Wizard - Welcome Screen screen.

To edit an existing backup job:

1.  Select a backup job in the Jobs dialog box.

2.  Click Edit. The Backup Wizard opens with the Backup Wizard - 
Device Selection Screen screen. The parameters of the selected 
backup job appear in the Backup Wizard screens.
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Backup Wizard Screens

This section provides detailed information on each of the Backup Wizard’s 
screens. To accept the default options for any screen, click Next. To return 
to an earlier screen, click Back. To exit the Backup Wizard without making 
any changes, click Cancel. 

The following sections describe each of the Backup Wizard screens.

Backup 
Wizard - 
Welcome 
Screen

Welcome to the Backup Wizard. The Backup Wizard provides a simple 
method for backing up the configurations of devices in your network.

Figure 2-3.  Backup Wizard - Welcome Screen

To continue, click Next. The Backup Wizard continues with the Backup 
Wizard - Device Selection Screen screen.
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Backup 
Wizard - 
Device 
Selection 
Screen

The Device Selection screen of the Backup Wizard, enables you to 
determine which device configurations to backup.

Figure 2-4.  Backup Wizard - Device Selection Screen

To determine the devices whose configurations to backup, select one of 
the option buttons. The options are:

• Selected Devices - Only the configuration of the devices selected 
in the Device Table are backed up.

• All Devices - The configuration of all devices shown in the Device 
Table are backed up.

* Note:  When All Devices is selected, only the configurations of devices 
currently displayed in the Device Table at the time of the 
backup job are backed up.

When you have selected a method for device selection, click Next. The 
Backup Wizard continues with the Backup Wizard - File Type Screen 
screen.
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Backup 
Wizard - 
File Type 
Screen

The File Type screen of the Backup Wizard enables you to select the 
configuration types to backup. The File Type screen displays the 
configuration types for each device that will be backed up.

Figure 2-5.  Backup Wizard - File Type Screen

Select the configuration types you want to back up. To select or deselect a 
configuration type, click on the row displaying the configuration type.

When you have selected the configuration types to backup, click Next. 
The Backup Wizard continues with the Backup Wizard - Job Type 
Screen screen.
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Backup 
Wizard - Job 
Type Screen

The Job Type screen of the Backup Wizard enables you to determine 
whether the current backup will be performed once or periodically.

Figure 2-6.  Backup Wizard - Job Type Screen

To determine the job type, select one of the option buttons. The options 
are:

• Immediate - The current backup is performed once, and the 
backup job’s options are not saved.

• Periodic - The current backup will be performed at user defined 
periods, and the backup job’s options are saved.

When you have selected a job type, click Next. If you selected Immediate, 
the Backup Wizard continues with the Backup Wizard - Summary 
Screen screen. If you selected Periodic, the Backup Wizard continues with 
the Backup Wizard - Job Name Screen screen.
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Backup 
Wizard - 
Job Name 
Screen

The Job Name screen of the Backup Wizard enables you to assign a name 
to the current backup job. After a backup, the job name appears in the 
Last Operation field of the Device Table.

Figure 2-7.  Backup Wizard - Job Name Screen

Enter a name for the backup job in the Job Name field.

When you have entered a name for the backup job, click Next. The 
Backup Wizard continues with the Backup Wizard - Period 
Parameters Screen screen.
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Backup 
Wizard - 
Period 
Parameters 
Screen

The Period Parameters screen of the Backup Wizard enables you to 
configure the frequency and time of periodic backups.

Figure 2-8.  Backup Wizard - Period Parameters Screen

To configure the frequency and time of backups:

1.  Select an hour from the Start Hour pull-down listbox to configure 
the start time for the backup job.

2.  Select an option button in the Recurrence Pattern section of the 
dialog box to configure the basis of the recurrence pattern. Possible 
options are:

— Daily - The backup job will be performed every x days. 

— Weekly - The backup job will be performed every x weeks.

— Monthly - The backup job will be performed every x months.

3.  Finish configuring the recurrence pattern by doing one of the 
following:

— If you selected the Daily option button, enter a number in the 
Every x Days field.
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— If you selected the Weekly option button.

a.  Enter a number in the Every x Week(s) field.

b.  Check the checkboxes next to the days of the week on 
which you want the backup job to run. 

— If you selected the Monthly option button.

a.  Enter a number in the Day x field. This is the day of the 
month on which the backup job will run. If the day does 
not exist in a given month, (e.g. the 30th day of February), 
the last day of the month will be substituted.

b.  Enter a number in the Every y Month(s) field.

4.  Enter a starting date in the Start Date field.

5.  Select an end of the recurrence range for the backup job. Possible 
range ends are:

— No end date - The backup job runs until it is deleted.

— End after x occurrences - Enter a number. The backup job runs x 
times, where x is the number entered.

— End by - Enter a date. The backup job runs until the date 
entered.

When you finish configuring the period parameters for the backup job, 
click Next. The Backup Wizard continues with the Backup Wizard - 
Summary Screen screen.
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Backup 
Wizard - 
Summary 
Screen

The Summary screen of the Backup Wizard displays a summary of the 
backup job configured using the previous screens.

Figure 2-9.  Backup Wizard - Summary Screen

To make any changes to the summary information:

1.  Click Back until you reach the appropriate screen.

2.  Change the backup job’s parameters.

3.  Click Next until you reach the Summary screen.

To start the backup job with the configured parameters, click Submit. 
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Managing Jobs

The Scheduled Jobs dialog box enables you to manage backup jobs 
created with the Backup Wizard. Using the Scheduled Jobs dialog box, 
you can create, edit, and delete backup jobs.

To view scheduled jobs:

Click Jobs.

Or

Select Actions > Jobs. The Scheduled Jobs dialog box opens.

Figure 2-10.  Scheduled Jobs Dialog Box

The top of the Scheduled Jobs dialog box contains a list of all periodic 
backup jobs configured on the network. The following table provides a list 
of the fields in the Jobs dialog box and their descriptions.

Table 2-1.  Scheduled Jobs Dialog Box Fields

Field Description

Name The name of the backup job.

Next 
Backup

The time and date of the next backup.
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To create a new backup job, click New job. The Backup Wizard opens with 
the Backup Wizard - Welcome Screen.

To edit a backup job:

1.  Select a backup job from the list of jobs.

2.  Click Edit. The Backup Wizard opens with the Backup Wizard - 
Device Selection Screen. The parameters of the selected backup 
job appear in the Backup Wizard screens.

To delete a backup job:

1.  Select a backup job from the list of jobs.

2.  Click Delete. A confirmation dialog box opens.

3.  Click Yes. The backup job is deleted.

Period The basis for the recurrence pattern of the job. Possible periods 
are:

• Daily - The backup is performed every x days.

• Weekly - The backup is performed every x weeks.

• Monthly - The backup is performed every x months.

Devices A list of the names of devices backed up by the backup job.

User The name of the person who created or last modified the 
backup job.

Table 2-1.  Scheduled Jobs Dialog Box Fields (Continued)

Field Description
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Downloading 
Configuration Files
This chapter explains how to download configuration files to the devices 
in the Device Table. It includes the following sections:

• Using the Library View - Describes the Library View including 
instructions on using the Library Tree and Library Table.

• Downloading - Provides instruction on how to download a 
configuration file to a device.

• Editing Configuration Files - Instructions on how to edit 
configuration files using the Configuration Editor.
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Using the Library View

This section describes the information in the Library View and explains 
how to use the Library Tree to filter the configuration files displayed in 
the Library Table. It includes the following topics:

• The Library Tree - Provides a description of the Library Tree.

• The Library Table - Explains the information displayed in the 
various columns of the Library Table.

• Filtering the Library Table - Provides instructions on how to use 
the Library Tree to filter the files displayed in the Library Table.

The Library Tree

The Library Tree shows the file types in the Library organized by device 
type. The Library Tree contains three levels:

• All - An icon representing the network. 

• Device Types - Icons representing all supported device types that 
appear in the network. 

• File Types - Checkboxes next to the configuration file types that 
are found in the specific device.

To expand or contract an element in the Library Tree, click the handle 
next to the element. The branch of the tree expands or contracts. 
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The Library Table

The Library Table displays the following information about each file in the 
library:

• Name/Desc - Name of the device (from the platform) from which 
the file was uploaded.

• IP - IP address of the device from which the file was uploaded.

• Module - The slot in which the module is located in the device 
from which the file was uploaded. For stackable devices, this is the 
module’s position in the stack. 

• Type - The file type. This consists of the appropriate device type 
and may also include information as to whether the file is a 
Running Configuration file or a Startup Configuration file.

• Created By - The source of the configuration file. Options are:

— Backup - The configuration file was created by an immediate 
backup job.

— Backup:Job Name - The configuration file was automatically 
uploaded by the Job Name backup job.

— Edit - The configuration file was created or modified using the 
File Editor.

— Unknown - The source of the configuration file is unknown.

• File - The command line interface (CLI) name of the configuration 
file.

• Time - The date and time at which the configuration file was 
created or last modified.

• User - The name of the person who created or last modified the 
configuration file.
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Filtering the Library Table

By default, all of the configuration files in the library are displayed in the 
Library Table. Filtering the files displayed in the Library Table can help 
you focus on the files with which you want to work. Files can be filtered 
by file type.

To hide displayed files, uncheck the checkbox next to the file type you do 
not want displayed in the Library Table. All files of the unchecked file type 
are removed from the Library Table.

To view files that are currently hidden, check the checkbox next to the file 
type you want displayed in the Library Table. All files whose file types are 
checked in the Library Tree are displayed in the Library Table.
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Downloading

* Note:  When you download a file, the protocol used appears in the 
log. For information about configuring the download 
protocol, refer to “File Transfer Protocols Tab” on page 13.

To download a configuration file to one or more devices:

1.  In the Library Table, select the configuration file you want to 
download to one or more devices.

2.  Click Download.

Or

Select Actions > Download. The Download dialog box opens.

Figure 3-1.  Download Dialog Box

The Download dialog box displays the file name and source and 
possible destinations for the file.

3.  Select modules or devices to which you want to download the 
selected configuration file. 

The Possible Destinations list contains a list of all modules and devices 
to which it is appropriate to download the selected configuration 
file. The configuration file is only downloaded to modules and 
devices in the Selected Destinations list.
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• To add modules or devices to the Selected Destinations list:

a.  Select modules or devices in the Possible Destinations list.

b.  Click . The selected modules or devices are added to the 
Selected Destinations list.

• To add all of the modules or devices in the Possible Destinations list to 
the Selected Destinations list, click . All of the modules or devices 
in the Possible Destinations list are added to the Selected Destinations 
list.

• To remove modules or devices from the Selected Destinations list:

a.  Select modules or devices in the Selected Destinations list.

b.  Click . The selected modules or devices are removed from 
the Selected Destinations list.

• To remove all of the modules or devices from the Selected 
Destinations list, click . All of the modules or devices in the 
Possible Destinations list are removed from the Selected Destinations 
list.

4.  Configure the reset after download option.

Some devices need to be reset after a download in order for the 
downloaded configuration to take effect. Using the Download 
dialog box, you can instruct the device to be reset when the 
download is completed. 

— To automatically reset the device after the download, check the 
Reset After Download checkbox. 

— If you do not want the device to reset after the download, clear 
the Reset After Download checkbox.

5.  Click Download. The Download Confirmation dialog box opens.

* Note:  If Default Action When Downloading is configured to Do Not 
Request Confirmation, the Download Confirmation dialog 
box does not open.
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Figure 3-2.  Download Confirmation Dialog Box

If the modules or devices in the Selected Destinations list exactly 
match the module or device from which the configuration file was 
uploaded, a confirmation dialog box opens with information about 
the configuration file and the selected devices. 

If the modules or devices in the Selected Destinations list do not 
exactly match the module or device from which the configuration 
file was uploaded, a warning message appears at the bottom of the 
dialog box. For example, this can occur when the device types are 
the same, but the modules or devices have different expansion 
modules or when a configuration file has been edited manually.

— To download the configuration file to the selected device, click 
Proceed. The selected configuration file is downloaded to the 
modules or devices in the Selected Destination list.

* Note:  Once the download process begins, it cannot be 
stopped.

CAUTION

If an inappropriate configuration file is downloaded to a 
module or device, you may lose contact with the 
device’s agent.
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— To edit the configuration file with the Configuration Editor, 
click Edit file. The Configuration Editor opens. After editing the 
file, you can initiate the download process from the 
Configuration Editor. For more information on the 
Configuration Editor, refer to “Editing Configuration Files” on 
page 43.

— To cancel the download, click Cancel. The download is 
cancelled.

6.  If the configuration was manually edited, the Download Warning 
dialog box opens.

Figure 3-3.  Download Warning Dialog Box

7.  To download the file, click Yes. The file is downloaded to the 
selected devices. To cancel the download, click No.
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Editing Configuration Files

Avaya Network Configuration Manager provides the ability to edit 
configuration files manually. The Configuration Editor is a simple text 
editor that opens with the selected configuration file. Each line of a 
configuration file corresponds to a single CLI (command line interface) 
command. For information on CLI commands, refer to the device’s User’s 
Guide. 

* Note:  Not all configuration files are editable.

In addition, you can add comments to a configuration file. Any line 
starting with the characters ‘!#’ is taken to be a comment and is ignored 
by the device.

Configuration files contain important information about the 
configuration of a device. If a configuration file contains inappropriate 
instructions for a device, it may impair the functioning of the device. 
Therefore, it is advisable to use the Configuration Editor only when 
making minor changes to configuration files.

CAUTION

Avaya Network Configuration Manager cannot verify the 
reliability of edited configuration files. Therefore, a warning 
dialog box appears every time you attempt to download a 
configuration that was edited manually. If you download a 
configuration file that has errors or is not appropriate for the 
device to which you download it, you may lose contact with the 
device’s agent.
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The Configuration Editor User Interface

To edit a configuration file:

1.  Select an editable configuration file in the Library View.

2.  Click Editor.

Or

Select Tools > Editor. The Configuration Editor opens with the 
selected configuration file.

Figure 3-4.  Configuration Editor

The Configuration Editor consists of the following components:

• Menu Bar - Menus for accessing all Configuration Editor 
functions. For more information on the Configuration Editor 
menus, refer to “Configuration Editor Menus” on page 50.

• Configuration Editor Toolbar - Toolbar buttons for accessing 
most of the Configuration Editor’s functions.

• Editing Window - A window where the text of the configuration 
file appears and can be edited.

• Status Bar - An area at the bottom of the Configuration Editor 
where information about the file being edited is displayed.

Menu Bar

Toolbar

Editing
Window

Status Bar
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Configuration 
Editor 
Toolbar

The Configuration Editor toolbar provides shortcuts to the main 
Configuration Editor functions.

The table below describes the buttons on the Configuration Editor toolbar 
and gives the equivalent menu options.

Editing 
Window

The Editing Window is the area where you edit the configuration file. You 
can edit a configuration file in the same manner you edit any text file. 
Text is entered using the keyboard and can be cut, copied, or pasted from 
within the Configuration Editor and from external text editing 
applications.

To cut text to the clipboard:

1.  Select the text you want to cut to the clipboard.

2.  Click .

Or

Select Edit > Cut. The selected text is cut to the clipboard.

To copy text to the clipboard:

1.  Select the text you want to copy to the clipboard.

2.  Click .

Table 3-1.  Configuration Editor Toolbar Buttons

Button Description Menu Item

Saves the edited configuration file. File > Save

Undoes the last action. Edit > Undo

Cuts the selected text to the 
clipboard.

Edit > Cut

Copies the selected text to the 
clipboard.

Edit > Copy

Pastes the selected text from the 
clipboard.

Edit > Paste

Opens the Download dialog box 
with the edited configuration.

Action > Download

Opens context-sensitive on-line 
help.

Help > Help On
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Or

Select Edit > Copy. The selected text is copied to the clipboard.

To paste text from the clipboard:

Click .

Or

Select Edit > Paste. The selected text is pasted from the clipboard.

Status Bar The Status Bar displays the following information:

• The type of device from which the original configuration file was 
uploaded.

• The IP address of the device from which the original configuration 
file was uploaded.

• The module number of the device from which the original 
configuration file was uploaded.

• The date the original configuration file was uploaded.

• An indicator showing whether the file was edited but not yet 
saved. If the configuration file in the Configuration Editor was 
edited but not yet saved, modified appears in the Configuration 
editor Status Bar.
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Saving Configuration Files

To save a new or edited configuration file:

1.  Click .

Or

Select File > Save. The File Description dialog box opens.

Figure 3-5.  File Description Dialog Box

2.  Enter a description for the configuration file.

3.  Click OK. The configuration file is saved with a version number 
appended to the filename. This prevents older versions of the file 
from being removed from the library. The new file appears in the 
Library Table.

Downloading Edited Files

If a configuration file was opened from the Download dialog box (refer to 
“Downloading” on page 39), you can return to the Download dialog box 
directly from the Configuration Editor. To download the edited 
configuration file to a device:

Click .

Or

Select Actions > Download. The Download dialog box opens.

For more information on downloading, refer to “Downloading” on 
page 39.

Closing the Configuration Editor

To close the Configuration Editor, select File > Close. The 
Configuration Editor closes.
Avaya Network Configuration Manager User Guide 47



A

Avaya Network Configu
Menus
This appendix gives the full structure of the menus in Avaya Network 
Configuration Manager, including the menus in the Configuration 
Editor.

Avaya Network Configuration Manager Menus

The following sections provide the structure of the menus in Avaya 
Network Configuration Manager.

File Menu

Edit Menu

View Menu

Table A-1.  File Menu

Item Description

Report Opens the Report dialog box.

Options Opens the Options dialog box.

Exit Exits Avaya Network Configuration Manager.

Table A-2.  Edit Menu 

Item Description

Delete Deletes the selected row or rows from the table.

Find Opens the Find dialog box.

Table A-3.  View Menu 

Item Description

ToolTip Enables tool tips in the Device Table.

Log Opens the log.
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Actions Menu

Tools Menu

Help Menu

Table A-4.  Actions Menu 

Item Description

Rediscover Rediscovers the information in the Device 
Table.

Upload Opens the Upload Configuration dialog box.

Download Opens the Download Configuration dialog 
box.

Jobs Opens the Jobs dialog box.

Backup Starts the Backup Wizard.

Filter Opens the Filter Devices dialog box.

Table A-5.  Tools Menu 

Item Description

Editor Opens the Configuration Editor with the 
selected configuration file.

Device Manager Opens the appropriate device manager for 
the selected device.

Compare Opens the Compare Configurations dialog 
box.

Table A-6.  Help Menu 

Item Description

Contents Opens the help module contents page for 
information.

Help On Opens the help module contents for 
context-sensitive on-line help.

About Avaya Network 
Configuration Manager

Opens a window containing copyright information 
about Avaya Network Configuration Manager.
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Appendix A
Configuration Editor Menus

The following section provide the full structure of the menus in the 
Configuration Editor.

File Menu

Edit Menu

Action Menu

Table A-7.  File Menu

Item Description

Save Opens the Save Configuration File dialog box.

Close Closes the Configuration Editor.

Table A-8.  Edit Menu 

Item Description

Cut Cuts the selected text to the clipboard.

Copy Copies the selected text to the clipboard.

Paste Pastes the text from the clipboard.

Undo Undoes the most recent action in the Configuration 
Editor.

Redo Reverses the last undo action in the Configuration 
Editor.

Table A-9.  Action Menu 

Item Description

Download Opens the Download Configuration dialog 
box.
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Menus
Help Menu

Table A-10.  Help Menu 

Item Description

Contents Opens the help module contents page for 
information.

Help On Opens the help module contents for 
context-sensitive on-line help.

About Opens a window containing copyright information 
about the Configuration Editor.
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