PHP is an HTML-embedded scripting language commonly used with the Apache HTTP Web server.
Multiple missing input sanitization flaws were discovered in PHP's exif extension. A specially-crafted image file could cause the PHP interpreter to crash or, possibly, disclose portions of its memory when a PHP script tried to extract Exchangeable image file format (Exif) metadata from the image file. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the names CVE-2009-2687 and CVE-2009-3292 to these issues.
A missing input sanitization flaw, leading to a buffer overflow, was discovered in PHP's gd library. A specially-crafted GD image file could cause the PHP interpreter to crash or, possibly, execute arbitrary code when opened. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2009-3546 to this issue.
It was discovered that PHP did not limit the maximum number of files that can be uploaded in one request. A remote attacker could use this flaw to instigate a denial of service by causing the PHP interpreter to use lots of system resources dealing with requests containing large amounts of files to be uploaded. This vulnerability depends on file uploads being enabled (which it is, in the default PHP configuration). The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2009-4017 to this issue.
Note: This update introduces a new configuration option, max_file_uploads, used for limiting the number of files that can be uploaded in one request. By default, the limit is 20 files per request.
It was discovered that PHP was affected by the previously published "null prefix attack", caused by incorrect handling of NUL characters in X.509 certificates. If an attacker is able to get a carefully-crafted certificate signed by a trusted Certificate Authority, the attacker could use the certificate during a man-in-the-middle attack and potentially confuse PHP into accepting it by mistake. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2009-3291 to this issue.
It was discovered that PHP's htmlspecialchars() function did not properly recognize partial multi-byte sequences for some multi-byte encodings, sending them to output without them being escaped. An attacker could use this flaw to perform a cross-site scripting attack. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2009-4142 to this issue.
More information about these vulnerabilities can be found in the security advisory issued by RedHat Linux:
| Product: | Affected Version(s): | Risk Level: | Actions: |
|---|---|---|---|
| Avaya Aura™ Communication Manager | 5.2.x and earlier | Low | Upgrade to CM 6.0 or later. |
| Avaya Intuity AUDIX LX | 2.0.x | Low | This advisory will not be addressed by Intuity AUDIX LX as no further releases are planned. |
| Avaya Message Networking | 3.1 | Low | Upgrade to MN 5.2 or later. |
| Avaya Aura™ SIP Enablement Services | 4.0 and later | Low | This advisory will not be addressed by SES as no further releases are planned. |
| Avaya Voice Portal | 4.0, 4.1, 5.0 | Low | Upgrade to VP 5.1 or later. |
| Avaya Aura™ Application Enablement Services | 3.x, 4.x, 5.2.x | Low | For AES 3.x or 4.0 thru 4.2.3 ugrade to AES 4.2.4 or later 4.2.x version. For AES 5.2.x upgrade to AES 6.1 or later. |
Avaya Aura™ Session Manager | 1.1, 5.2 | Low | Upgrade to SM 6.0 or later. |
Recommended Actions for System Products:
Avaya strongly recommends that customers follow
networking and security best practices by implementing
firewalls, ACLs, physical security or other appropriate
access restrictions. Though Avaya believes such
restrictions should always be in place; risk to Avaya's
product and the surrounding network from this potential
vulnerability may be mitigated by ensuring these
practices are implemented until such time as a product
update is available. Further restrictions as deemed
necessary based on the customer's security policies
may be required during this interim period.
Avaya software-only products operate on general-purpose operating systems. Occasionally vulnerabilities may be discovered in the underlying operating system or applications that come with the operating system. These vulnerabilities often do not impact the software-only product directly but may threaten the integrity of the underlying platform.
In the case of this advisory Avaya software-only products are not affected by the vulnerability directly but the underlying Linux platform may be. Customers should determine on which Linux operating system the product was installed and then follow that vendor's guidance.
| Product: | Actions: |
|---|---|
| CVLAN | Depending on the Operating System provided by customers, the affected package may be installed on the underlying Operating System supporting the CVLAN application. |
| Avaya Integrated Management Suite (IMS) | Depending on the Operating System provided by customers, the affected package may be installed on the underlying Operating System supporting the IMS application. |
| Voice Portal | Depending on the Operating System provided by customers, the affected package may be installed on the underlying Operating System supporting the Voice Portal application. |
| Avaya Aura™ Application Enablement Services 4.x | Depending on the Operating System provided by customers, the affected package may be installed on the underlying Operating System supporting the AES application. |
Recommended Actions for Software-Only Products:
In the event that the affected package is installed, Avaya recommends that customers follow recommended actions supplied by RedHat Linux.
Additional information may also be available via the Avaya support website and through your Avaya account representative. Please contact your Avaya product support representative, or dial 1-800-242-2121, with any questions.
ALL INFORMATION IS BELIEVED TO BE CORRECT AT THE TIME OF PUBLICATION AND IS PROVIDED "AS IS". AVAYA INC., ON BEHALF ITSELF AND ITS SUBSIDIARIES AND AFFILIATES (HEREINAFTER COLLECTIVELY REFERRED TO AS "AVAYA"), DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE AND FURTHERMORE, AVAYA MAKES NO REPRESENTATIONS OR WARRANTIES THAT THE STEPS RECOMMENDED WILL ELIMINATE SECURITY OR VIRUS THREATS TO CUSTOMERS' SYSTEMS. IN NO EVENT SHALL AVAYA BE LIABLE FOR ANY DAMAGES WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH THE INFORMATION OR RECOMMENDED ACTIONS PROVIDED HEREIN, INCLUDING DIRECT, INDIRECT, INCIDENTAL, STATUTORY, CONSEQUENTIAL DAMAGES, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF AVAYA HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
THE INFORMATION PROVIDED HERE DOES NOT AFFECT THE SUPPORT AGREEMENTS IN PLACE FOR AVAYA PRODUCTS. SUPPORT FOR AVAYA PRODUCTS CONTINUES TO BE EXECUTED AS PER EXISTING AGREEMENTS WITH AVAYA.
V 1.0 - January 21, 2010 - Initial Statement issued.
V 2.0 - March 29, 2010 - Added SM to affected products.
V 3.0 - July 13, 2010 - Changed SM actions.
V 4.0 - July 30, 2010 - Changed VP affected versions and actions.
V 5.0 - October 11, 2010 - Changed CM affected versions and CM and AES actions.
V 6.0 - September 19, 2011 - Changed AES actions and advisory status to final.
Send information regarding any discovered security problems with Avaya products to either the contact noted in the product's documentation or [email protected].
© 2010 Avaya Inc. All Rights Reserved. All trademarks identified by the ® or ™ are registered trademarks or trademarks, respectively, of Avaya Inc. All other trademarks are the property of their respective owners.