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materials. Avaya shall not be responsible for any modifications,
additions, or deletions to the original published version of
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Avaya is not responsible for the accuracy of any information, statement
or content provided on these sites and does not necessarily endorse
the products, services, or information described or offered within them.
Avaya does not guarantee that these links will work all the time and has
no control over the availability of the linked pages.
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(“Product(s)”). Refer to your sales agreement to establish the terms of
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TO TAKE LEGAL ACTION AGAINST YOU AND ANYONE ELSE
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DOWNLOADING OR USING THE SOFTWARE (HEREINAFTER
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AGREE TO THESE TERMS AND CONDITIONS AND CREATE A
BINDING CONTRACT BETWEEN YOU AND AVAYA INC. OR THE
APPLICABLE AVAYA AFFILIATE ( “AVAYA”).

Copyright

Except where expressly stated otherwise, no use should be made of
materials on this site, the Documentation, Software, or Hardware
provided by Avaya. All content on this site, the documentation and the
Product provided by Avaya including the selection, arrangement and
design of the content is owned either by Avaya or its licensors and is
protected by copyright and other intellectual property laws including the
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modify, copy, reproduce, republish, upload, post, transmit or distribute
in any way any content, in whole or in part, including any code and
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reproduction, transmission, dissemination, storage, and or use without
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civil offense under the applicable law.

Third-party components

Certain software programs or portions thereof included in the Product
may contain software distributed under third party agreements (“Third
Party Components”), which may contain terms that expand or limit
rights to use certain portions of the Product (“Third Party Terms”).
Information regarding distributed Linux OS source code (for those
Products that have distributed the Linux OS source code), and
identifying the copyright holders of the Third Party Components and the
Third Party Terms that apply to them is available on the Avaya Support
Web site: http://support.avaya.com/Copyright.

Trademarks

The trademarks, logos and service marks (“Marks”) displayed in this
site, the Documentation and Product(s) provided by Avaya are the
registered or unregistered Marks of Avaya, its affiliates, or other third
parties. Users are not permitted to use such Marks without prior written
consent from Avaya or such third party which may own the Mark.
Nothing contained in this site, the Documentation and Product(s)
should be construed as granting, by implication, estoppel, or otherwise,
any license or right in and to the Marks without the express written
permission of Avaya or the applicable third party.

Avaya is a registered trademark of Avaya Inc.

All non-Avaya trademarks are the property of their respective owners,
and “Linux” is a registered trademark of Linus Torvalds.

Downloading Documentation

For the most current versions of Documentation, see the Avaya
Support Web site: http://support.avaya.com.

Contact Avaya Support

See the Avaya Support Web site: http://support.avaya.com for product
notices and articles, or to report a problem with your Avaya product.
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the Avaya Support Web site: http://support.avaya.com, scroll to the
bottom of the page, and select Contact Avaya Support.
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Chapter 1: New in this release

The following sections describe what is new in routine maintenance procedures for Avaya Aura® Contact
Center Routine Maintenance (NN44400-514) Release 6.2.

Navigation
• Features on page 5

Features
See the following sections for information about feature changes.

• Certificate Store files on page 5

Certificate store files
Contact Center Manager Server uses Transport Layer Security (TLS) certificates to
communicate securely with Avaya Aura® Application Enablement Services.

You must back up and restore the CCMS Certificate Manager certificates manually. For more
information, see Backing up certificate store files on page 20 and Restoring certificate store
files on page 21.

For more information about TLS certificate store files, see Avaya Aura® Contact Center
Commissioning (NN44400-312).
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New in this release
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Chapter 2: Introduction

The Avaya Aura® Contact Center Routine Maintenance (NN44400-514) Release 6.2 contains the
procedures required for routine maintenance in Contact Center.

Prerequisites
• Read Avaya Aura® Contact Center Fundamentals (NN44400-110).

• Read Avaya Aura® Contact Center Planning and Engineering (NN44400-210).

• Complete Avaya Aura® Contact Center Installation Checklist (NN44400-310).

• Read Avaya Aura® Contact Center Installation (NN44400-311).

• Understand the Contact Center features that you purchased.

• Commission your Contact Center software.

Navigation
• Routine maintenance fundamentals on page 9
• Routine maintenance tasks for the Contact Center Manager Server and Communication

Control Toolkit on page 13
• Routine maintenance tasks for Contact Center Manager Administration on page 23
• Routine maintenance tasks for Contact Center Multimedia on page 35
• Routine maintenance tasks for Avaya Media Server on page 47
• Common routine maintenance tasks on page 57
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Related resources

Support
Visit the Avaya Support website at http://support.avaya.com for the most up-to-date
documentation, product notices, and knowledge articles. On the Avaya Support website at 
http://support.avaya.com, search for notices, release notes, downloads, user guides, and
resolutions to issues. Use the Web service request system to create a service request. Chat
with live agents to help answer questions. If an issue requires additional expertise, agents can
quickly connect you to a support team.

Avaya Mentor videos
Avaya Mentor is an Avaya-run channel on YouTube that includes technical content on how to
install, configure, and troubleshoot Avaya products.

Visit http://www.youtube.com/AvayaMentor and do one of the following:

• Enter a key word or key words in the Search channel to search for a specific product
or topic.

• Click the name of a playlist to scroll through the posted videos.

Introduction
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Chapter 3: Routine maintenance
fundamentals

This chapter describes the background information that you need to perform the required routine
maintenance tasks on your Avaya Aura® Contact Center servers. To protect data perform routine
maintenance at regular intervals.

Navigation
• Backup information on page 9
• Patching information on page 10
• Security updates on page 10
• Operating system updates on page 11

Backup information
All contact centers must perform regular backups of Contact Center databases to a secure
network drive. Regular backups help your Contact Center to recover from events such as data
loss and damage due to disk failures and power outages.

You can use the Database Maintenance Utility to back up and restore the database on the
Contact Center Manager Server, Communication Control Toolkit, and Contact Center
Multimedia servers. If your contact center server is running with a standby server, ensure that
you back up the primary server, not the standby server, to back up the most current data.

Take the backups for the servers all at the same time. Likewise, when you restore a database,
restore all databases to ensure the data is consistent across the Contact Center suite.

You can use the Contact Center Manager Administration Backup and Restore utility to back
up a preselected series of Contact Center Manager Administration files (including Historical
Reporting files, AD-LDS files, and database files).

If you work on a co-resident installation, you can use the same utilities, depending on what
type of server you are backing up.
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You can schedule single or multiple backup tasks on a daily, weekly, or monthly basis. However,
you cannot use this utility to back up operating system files or data files that are not related to
Contact Center Manager Administration.

Contact Center maintains a maximum of seven backup folders in the backup location. The
most recent backup file is in folder ..\backup_1\. The other backup folders, backup_2,
backup_3, and so on, contain progressively older backup files. When a new backup (either
manual or scheduled) is performed, all existing backup folders update to reflect the order of
the backup taken. When the maximum number of backup folders is reached, the oldest backup
is discarded and replaced with the second-oldest backup. All other backup files are adjusted
to reflect the order in which they are performed.

Patching information
Avaya supplies Service Packs for updates to Contact Center servers. Service Packs provide
planned product updates and bug fixes. Each Service Pack contains the latest fixes and the
content of all previous Service Packs. Each Service Pack provides urgent, individual fixes
required before the next Service Pack is available.

When you install the latest Service Pack, the installation program automatically uninstalls the
previous Service Pack. Because of this, do not uninstall a Service Pack before you install the
latest Service Pack.

Any Service Packs available at the time of shipping are included on the Avaya Aura® Contact
Center software DVD. For ongoing patches, you can locate all Service Packs on the Avaya
Network Web site www.avaya.com/support.

Security updates
Create a systematic and accountable process to identify and apply required security updates.
Due to the urgent nature of security vulnerabilities to the system, you must establish and follow
security guidelines and promptly install any security patches issued by Microsoft.

Back up your Contact Center applications before applying any security patches to the system
so that you can rollback the system, if necessary. If Contact Center does not function properly
after you apply a Microsoft security patch, then you must remove the patch and revert to the
previous version of Contact Center.

For more information see Avaya Aura® Contact Center Planning and Engineering
(NN44400-210).

Routine maintenance fundamentals
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Operating system updates
Download the latest supported operating system service pack from the Avaya hotfixes list to
ensure that your Contact Center server software functions correctly with the supported
operating system patches.

Operating system updates
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Routine maintenance fundamentals
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Chapter 4: Routine maintenance tasks for
Contact Center Manager Server
and Communication Control
Toolkit

Use the tasks described in this chapter to maintain Contact Center Manager Server and Communication
Control Toolkit.

Ensure that you perform the maintenance tasks for both servers at the same time.

Prerequisites for routine maintenance tasks for Contact
Center Manager Server and Communication Control
Toolkit

• Install and configure Contact Center Manager Server.

• Install and configure Communication Control Toolkit.

Navigation
• Creating a backup location on page 14
• Performing an immediate backup of the database on page 15
• Scheduling a backup of the database on page 16
• Recovering a scheduled backup on page 18
• Backing up the Database Integration Service on page 19
• Backing up certificate store files on page 20
• Restoring certificate store files on page 21
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Creating a backup location
Before you begin

• Ensure that you log on with a user account with full permissions to access the location where
you store the database backups.

About this task
Create a backup location on your network with the correct access permissions to ensure that
you have a designated location for the backup file.

 Important:
If either CCMS, CCT or CCMM are installed on standalone servers, the database backups
must not be contained in the same folder, as ADMIN databases stored in the same backup
folder overwrite each other.

Procedure

1. Click Start > All Programs > Avaya > Contact Center > Database Utilities >
Database Maintenance.

2. In the Database Maintenance dialog box, click Backup Locations.

3. In the right pane, click Create.

4. From the Drive Letter list, select a drive letter.

5. In the UNC Path text box, type the location to which to backup the database.

6. In the Username box, type the user name used to log on to the server specified in
the UNC Path box.

7. In the Password box, type the Windows password.

8. Click OK.

Variable definitions

Name Description

Drive Letter The drive letter represents the destination for
the backup file.

UNC Path The Uniform Naming Convention (UNC)
path, which is the IP Address and folder

Routine maintenance tasks for Contact Center Manager Server and Communication Control Toolkit
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Name Description

name of the server destination for the backup
file.
For example, the UNC path can be \
\192.167.140.0\dbbackup.

Username The user name, including server name and
user name for the backup destination
server.
For example, the username can be
192.167.140.45\administrator.

Password The password for the user that you configure
for the backup location.

Performing an immediate backup of the database
Before you begin

• Create a backup location if you want to use a network location for your backup.
• Know which applications you are backing up.

About this task
Perform an immediate backup of the database to save the current data. It is important to
complete this procedure after you complete your installation or when any significant change
occurs in the database, so that you can restore the database easily.

You can back up one or more Avaya Aura® Contact Center databases at one time. The backup
folder contains separate backup files for each database or folder you select.

If the Contact Center is running with a standby server, ensure that you back up the primary
server, not the standby server, to back up the most current data.

Perform backups during low traffic periods. CCMS services are not shut down during
backups.

Procedure

1. Click Start > All Programs > Avaya > Contact Center > Database Utilities >
Database Maintenance.

2. In the Database Maintenance dialog box, in the left pane, click Immediate
Backup.

3. In the Media Type section, select the Network Location option.

4. In the Applications section, select the check box beside each application you want
to back up.

Performing an immediate backup of the database
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5. From the Backup Location list, select the network drive where you want to store the
backup.

6. Click Backup.

7. Click Yes to confirm your choices.

8. Use the Progress information field to monitor the progress of the backup.

9. Click Exit to close the Database Maintenance utility.

Variable definitions

Name Description

Applications The Contact Center application databases
that you can back up.

• CCMS: Contact Center Manager Server
database

• CCT: Communication Control Toolkit
database

• ADMIN: common database for all Contact
Center applications

If an application is not available, you cannot
select it.

Backup Location The destination for the network disk. The
values are configured in Backup Locations.

Media type The type of media used for your backup file.
You can use a network disk location. If you
use a network disk location, you must
configure a destination before you can back
up the file.

Scheduling a backup of the database
Before you begin

• Create a backup location.
• Know which applications you are backing up.

Routine maintenance tasks for Contact Center Manager Server and Communication Control Toolkit
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About this task
Schedule a backup of the Contact Center Manager Server database to save the data regularly.
You must regularly back up the database to ensure you always have current information in
case you need to restore the data.

Contact Center stores up to seven backup files at each server location. The backup files are
stored in numbered backup directories (for example, Backup_1, Backup_2). File storage is
circular and, if necessary, the oldest backup file is deleted to allow new backup files to be stored
at a location.

You can back up one or more databases at one time. The backup folder contains separate
folders for each application you select. If you have two or more scheduled backups occurring
at the same time, the backups are queued and only one backup runs at a time.

You can verify that a scheduled backup ran successfully by viewing Contact Center events.
After the backup, an event message includes the scheduled backup by name and indicate if
it has finished successfully or if it has finished with an error. Details of the error are included.

Procedure

1. Click Start > All Programs > Avaya > Contact Center > Database Utilities >
Database Maintenance.

2. In the Database Maintenance dialog box, in the left pane, click Scheduled
Backup.

3. In the right pane, click Create.

4. Under General Properties, in the Name box, type a name for the scheduled
backup.

5. From the Media Type list, select Network Location.

6. In the Start Date box, type the date on which to begin scheduled backups.
OR
Click the calendar icon and select a date on which to begin scheduled backups.

7. In the Start Time box, select the time to start the backup.

8. From the Backup Location list, select a drive to store the backup.

9. From the Frequency list, select the frequency of the backup.

10. Under Applications, select the check box beside the applications you want to back
up.

11. Click OK.

12. Click Exit to close the Database Maintenance utility.

Scheduling a backup of the database
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Variable definitions

Name Description

Applications The Contact Center application databases
that you can back up.

• CCMS: Contact Center Manager Server
database

• CCT: Communication Control Toolkit
database

• ADMIN: common database for all Contact
Center applications

If an application is not available, you cannot
select it.

Backup Location The destination for the network disk. The
values are configured in the Backup
Locations.

Frequency The frequency of the backup. You can
choose from daily, weekly, monthly, or run
once.

Media type The type of media used for your backup file.
You can use a network disk location. If you
use a network disk location, you must
configure a destination before you can back
up the file.

Name Identifier for the scheduled backup. You must
identify each backup with a unique name.

Recovering a scheduled backup
Before you begin

• Ensure that you view the event in Windows Event Viewer and address the reason why the
scheduled backup failed.

About this task
Recover a scheduled backup if an error occurs while the backup is running. A scheduled
backup failure can occur for several reasons, for example, if the backup location is not available
or if there is not enough space to save the backup file. If an error occurs, the scheduled backup
stops running and an event is created. To view the event use Windows Event Viewer.

Routine maintenance tasks for Contact Center Manager Server and Communication Control Toolkit
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Procedure

1. Click Start > All Programs > Avaya > Contact Center > Database Utilities >
Database Maintenance.

2. In the Database Maintenance dialog box, in the left pane, click Scheduled
Backup.

3. Click the name of the scheduled backup you want to recover.

4. Click Recover.

5. Click OK.
To run the schedule next time the error is cleared and the scheduled backup is
recovered.

Backing up the Database Integration Service
Before you begin

• Ensure that you export only the ODBC DSNs created for use with the Database Integration
Wizard. Some Contact Center Manager Server DSNs reference a computer host name or
IP address. If you export the entire ODBC folder and restore these DSNs after an IP address
or host name change, the server can malfunction.

About this task
Back up the Database Integration Service to back up the current configuration. Avaya
recommends that you perform manual backups on the current configuration and that you
refresh the backups after using the Database Integration Wizard to make changes. The
Database Integration Wizard backup and restore is not included in the Contact Center Manager
Server backup and restore process.

Procedure

1. On the Contact Center Manager Server, click Start > Run.

2. In the Open box, type regedit.

3. Click OK.

4. In the Registry Editor, open the key HKEY_LOCAL_MACHINE\SOFTWARE
\Wow6432Node\Avaya\ICCM\HAI

5. From the File menu, select Export.

6. In the Export Registry File dialog box, type a name and location in which to store
the configuration file.

7. Click Save.

Backing up the Database Integration Service
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8. In the Registry Editor, open the key HKEY_LOCAL_MACHINE\SOFTWARE
\Wow6432Node\ODBC

9. From the File menu, select Export.

10. In the Export Registry File dialog box, type a suitable name and location to use for
storing the ODBC configuration file.

11. Click Save.

12. Close the Registry Editor.

Backing up certificate store files
Before you begin
Stop all services on the Contact Center Manager Server using the System Control and Monitor
Utility (SCMU).

About this task
Contact Center Manager Server uses Transport Layer Security (TLS) certificates to
communicate securely with Avaya Aura® Application Enablement Services.

You must back up CCMS Certificate Manager certificates.

Procedure

1. Click Start > All Programs > Avaya > Contact Center > Common Utilities.

2. Select Certificate Manager.

3. In the Certificate Manager window, from the Create Certificates for list, select
SIP.

4. Select the Store Maintenance tab.

5. In Certificates field, Certificate Manager lists all certificates in the store.

6. Select the required certificate files you want to back up.

7. To select the location for back up certificates store files, select Browse.

8. Select Backup.

9. Select Close.

10. Restart the Contact Center Manager Server services using SCMU.

Routine maintenance tasks for Contact Center Manager Server and Communication Control Toolkit
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Restoring certificate store files
Before you begin
Stop all services on the Contact Center Manager Server using the System Control and Monitor
Utility (SCMU).

About this task
Contact Center Manager Server uses Transport Layer Security (TLS) certificates to
communicate securely with Avaya Aura® Application Enablement Services.

You must restore the CCMS Certificate Manager certificates.

Procedure

1. Click Start > All Programs > Avaya > Contact Center > Common Utilities.

2. Select Certificate Manager.

3. In the Certificate Manager window, from the Create Certificates for list, select
SIP.

4. Select the Store Maintenance tab.

5. To select the location to restore the certificates store files, select Browse.

6. Select Restore.

7. Select Close.

8. Restart the Contact Center Manager Server services using SCMU.

Restoring certificate store files
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Chapter 5: Routine maintenance tasks for
Contact Center Manager
Administration

You must regularly back up the primary Contact Center Manager Administration (CCMA) server for the
following reasons:

• To avoid loss of data in the event of a server failure: schedule backups to back up your CCMA data
at least once a day (or more frequently, based on your Contact Center requirements). Schedule
backups during periods of low activity.

• If you upgrade CCMA or if you migrate CCMA to a new server: you must perform a full backup of
your CCMA data before you perform either task.

• To keep data synchronized between CCMA and CCMS: you must back up and restore CCMA data
and your Contact Center Manager Server data at the same time to ensure your contact center
functions correctly. If the Contact Center Manager Server files change infrequently, you can back up
only the CCMA data.

In a co-resident environment, when you perform a backup of the Contact Center Manager Server,
you must ensure that you back up the entire server and the associated databases, including CCMA.
This ensures that the data between the two applications is always synchronized. Furthermore, you
must store both backups in the same location.

If you install a replicating server, you must still perform regular backups. Unlike Active Directory
Lightweight Directory Services (AD-LDS) replication, backups provide snapshots of your CCMA data files
at moments in time. Backing up data, and not relying on AD-LDS replication as the only method of backing
up CCMA data, is important for the following two reasons:

• Not all CCMA data is stored in AD-LDS, and therefore is not replicated.

• You cannot use replication to roll back data to a specific time, which may be required.

In addition to backing up files, you must record your Real-Time Reporting configuration settings and your
Emergency Help configuration settings whenever these settings change. During the restoration process,
you must manually reconfigure these settings.
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Prerequisites for routine maintenance tasks for Contact
Center Manager Administration

• Install Contact Center Manager Administration. See Avaya Aura® Contact Center
Installation (NN44400-311).

• Commission Contact Center Manager Administration. See Avaya Aura® Contact
Center Commissioning (NN44400-312).

Navigation
• Backing up Contact Center Manager Administration on page 24
• Restoring the Contact Center Manager Administration on page 28

Backing up Contact Center Manager Administration
Before you begin

• Ensure that you have write privileges on the server where you want to store the CCMA
data you are backing up.

• Log on to the CCMA server with administrative privileges.

About this task
Back up Contact Center Manager Administration to a folder to create a snapshot of the
preselected CCMA data files. You can create the folder on the same server or on another
domain server.

The Backup and Restore utility is automatically installed on the CCMA server when you install
the CCMA software.

You use this utility to back up the files located in the following folders (where C is the drive on
which you installed CCMA):

• AD-LDS-specific data stored in the following folder:

C:\Program Files (x86)\Microsoft ADAM\
• Historical reporting template files (both imported and custom) and Audit Trail event logs

stored in the following folders:

C:\Avaya\Contact Center Manager Administration\Apps\Reporting\
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C:\Avaya\Contact Center Manager Administration\ Apps\Common\
• The Report Creation Wizard database files stored in the following folder:

C:\Avaya\Contact Center Manager Administration\Server\RCW\Data
• A record of displays for real-time reporting exported to the following folder:

C:\Avaya\Contact Center Manager Administration\Apps\Reporting\
• An index file for Custom Report Groups stored in the following folder:

C:\Avaya\Contact Center Manager Administration\Apps\AccessMgt\
• A record of displays for Emergency Help exported to the following folder:

C:\Avaya\Contact Center Manager Administration\Apps\EmergencyHelp\

Procedure

1. On the Contact Center Manager Administration server, click Start > All Programs
> Avaya > Contact Center Manager Administration > Configuration.

2. In the left pane of the Configuration window, expand Avaya, Applications.

3. In the Avaya Applications Configuration window, select Backup & Restore.

4. In the right-hand pane, click Backup & Restore.

5. In the Contact Center Manager Administration—Backup and Restore utility, select
the Backup tab.

6. In the Backup window, select the Drive or specify the Network Location where you
want to store the backup.

7. Click Next.

8. On the Schedule page, select an option to schedule the backups.

9. Define the backup schedule, and then click Next.

10. In the Username box on the User Account with Administrative Privileges page, type
a valid administrator user name for the server on which you want to store the
backup.

11. In the Password box, type the password for the specified administrator user.

12. If you selected a backup location on another server in a domain, type the domain
in the Domain field. The default option is this computer (that is, the Contact Center
Manager Administration server on which you are creating the backup).

13. Click Finish.

14. Click Close.
All backups are saved as CCMAFilesBackup<BackupDateTime>.package.

Backing up Contact Center Manager Administration
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Variable definitions

Name Description

Drive The local hard drive where you store the
backup.
This list shows available local hard drives
and any network drives mapped on the
server. Note that any drives included in the
backup (typically C: and D:) do not appear in
the list: these are not supported by the
backup application. DVD drives do not
appear in the list.

Network Location The network location where you want to store
the backup, in UNC format\Computer Name
\Folder.

Schedule options The time interval for scheduled backups.
This can be

• Daily (to schedule recurring backups once
a day)

• Weekly (to schedule recurring backups
once a week)

• Monthly (to schedule recurring backups
once a month)

• One Time Only (to schedule a one-time-
only backup at a time in the future)

• Run Now (to back up files immediately after
you enter a valid username and password)

If you select Monthly, you can schedule a
task only on the last day of the month that
contains the least number of days.
For example, if you want the backup to run
every month, then you can schedule it to
occur on day 28 only. However, if you clear
February from the schedule, then the last
possible day of a monthly schedule is 30. If
you clear April, June, September, and
November from the schedule, then the last
possible day of a monthly schedule is 31.

Username and Password You must configure a user name and
password with write privileges on the server
on which you want to store the backup.
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Name Description

Domain If you selected a backup location on another
server, type the domain of the server. The
username and password must be valid on
this domain and have administrative
privileges on the server specified in Network
Location.

Procedure job aid

Table 1: Data files stored on Contact Center server

Contact Center server Data files stored on server Business consequence of
CCMA server failure

Contact Center Manager
Administration server

• Schedule information for
historical reports

• Partitions, access classes,
report groups, and the
Contact Center Manager
Administration users

• Real-time display
configuration data and real-
time display filters

• Private historical reports

• Contact Center
Management scheduled
assignment information

If the Contact Center Manager
Administration server fails,
your supervisors and
administrators cannot access
the Contact Center Manager
Administration application.
Therefore, access to real-time
displays, agent desktop
display, schedule information
for historical reports, and all
data stored on in the
application is interrupted.

Contact Center Manager
Server

• Agents, supervisors,
skillsets and all their related
assignments (accessed
through Contact Center
Management)

• CDNs, DNISs and all other
data items (accessed
through the Configuration
component)

If your stand-alone Contact
Center Manager
Administration server fails,
calls continue to be routed
according to your defined
scripts and your Contact
Center can still receive calls
because all user and agent
assignments, CDNs, and
DNISs are stored on the
Contact Center Manager
Server.

Backing up Contact Center Manager Administration
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Restoring the Contact Center Manager Administration
database

Before you begin

• Know the network location (in Universal Naming Convention (UNC) format) of the drive for
the backed up database.

 Important:
Ensure that the target server has the same patch level as the source server.

 Important:
If you are restoring CCMA data to a Secondary CCMA server - In a High Availability
environment, only non-AD-LDS data is restored. This is automatically detected by the
Backup & Restore utility and only the required files are updated. This is because core
CCMA AD-LDS data is automatically received via AD-LDS replication.

About this task
Restore the Contact Center Manager Administration database after a failure or migration.

Procedure

1. On the new Contact Center Manager Administration server, choose Start > All
Programs > Avaya > Contact Center Manager Administration >
Configuration.

2. In the left pane of the Avaya Configuration window, expand Avaya, Applications,
Backup & Restore.

3. In the right pane, click Backup & Restore.

4. In the Contact Center Manager Administration- Backup And Restore dialog
box, click the Restore tab.

5. To select a backup file to restore from, click Browse.

6. In the Select a backup file dialog box, select the required .package file.

7. Click Open.

8. To restore the backup file data into CCMA, click Restore Files.
The restore completed successfully message box appears.

9. Click OK.
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Chapter 6: Routine maintenance tasks for
Security Framework

Use the tasks described in this chapter to maintain Security Framework.

Prerequisites for routine maintenance tasks for Security
Framework

• Install Security Framework. See Avaya Aura® Contact Center Installation
(NN44400-311).

• Commission Security Framework. See Avaya Aura® Contact Center Commissioning
(NN44400-312).

Navigation
• Backing up Security Framework on page 29
• Restoring Security Framework data on page 32

Backing up Security Framework
Before you begin

• Map a drive to the server in the domain where you want to back up Security
Framework.

• Ensure that the Avaya JBoss and Avaya Common Network Directory services are
running.

• Ensure that you have a user name and password configured with administrative privileges
on the server where you want to back up Security Framework.
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About this task
Back up the Security Framework data files to save a single file that is a snapshot of the Security
Framework files. Save the backup file to a predefined location on the same server or on another
server in the same domain.

The Backup and Restore utility for the Security Framework is automatically installed on the
server when you install the Security Framework software.

When you back up the files with this utility, the system creates a single file that you can then
use to restore the individual files. By default, this file is called
CCMA_Data_Backup_DateTimeStamp.package and it is placed in the same folder.

Procedure

1. On the Security Framework server, click Start > All Programs > Avaya > Contact
Center > Security Framework > Backup and Restore.

2. In the Security Framework - Backup and Restore utility, select the Backup tab.

3. In the Backup window, select File.

4. Accept or change the location of the backup file,
CCMA_Data_Backup_DateTimeStamp.package.

5. From the Archive Backup Files Every list, select the number of backup files to
keep in the backup location.

6. Click Next.

7. On the Schedule page, select an option to schedule the backups.

8. Define the backup schedule, and then click Next.

9. In the Username box on the User Account with Administrative Privileges page,
type a valid administrator user name.

10. In the Password box, type a valid administrator password.

11. If you selected a backup location on another server in a domain, from the Domain
list, select the domain.

12. Click Finish.

13. Click Close.

Variable definitions

Name Description

Archive Backup Files Every You can keep 2 to 10 backups, or all
backups.
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Name Description

This provides the flexibility to retain only the
most recent backups, to save space in your
backup location.

Backup file name This is the file that the utility creates when
you back up the files. The file contains a
snapshot of all Security Framework files that
you back up.
To change the default name or location of this
file, click Browse, navigate to the location in
which you want to store the file, and type a
new file name.
Avaya recommends that you change the
name of the backup file from
CCMA_Data_Backup_DateTimeStamp.pac
kage to
SF_7_[SPxx]_CCMA_Data_Backup_DateTi
meStamp.package where [SPxx] is replaced
with the last Service Pack installed.
To select a file location on another server in
the domain, you must map a drive to that
server and you must have read/write
privileges on that server.

Schedule definition You can schedule a task only on the last day
of the month that contains the least number
of days.
For example, if you want the backup to run
every month, then you can schedule it to
occur on day 28 only. However, if you clear
February from the schedule, then the last day
of a monthly schedule is 30. If you clear April,
June, September, and November from the
schedule, then the last day of a monthly
schedule is 31.

Schedule options The time interval for scheduled backups.
This can be

• Daily (to schedule recurring backups once
a day)

• Weekly (to schedule recurring backups
once a week)

• Monthly (to schedule recurring backups
once a month)

Backing up Security Framework
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Name Description

• One Time Only (to schedule a one-time-
only backup at a time in the future)

• Run Now (to back up files immediately after
you enter a valid username and password)

Username and Password You must configure a user name and
password with administrative privileges on
the server to which you back up.

Restoring Security Framework data
Before you begin

• Restore data that was backed up from the same release and version of the software as
is currently installed on the server.

• Do not attempt to restore data from previous Service Packs. If you restore data backed
up on previous versions, you corrupt your server.

About this task
Restore Security Framework data in the following situations:

• If you recover from a server hardware failure.
• If you lose data or need a previous version of the data.
• If you migrate data to a new server.

Procedure

1. On the Security Framework server, click Start > All Programs > Avaya > Contact
Center > Security Framework > Backup and Restore.

2. In the Security Framework - Backup and Restore utility, select the Restore
tab.

3. Click Restore Files.

4. Use the Backup and Restore Wizard, click Next.
OR
On the Windows Server Backup utility, click the Restore and Manage Media
tab.

5. Click the Restore and Manage Media tab.

6. In the left pane, select the most recent backup file (or the file containing the data to
restore).
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7. Expand the file.

8. Select the check box for each file to restore. To select all the files, select the check
box beside the parent file name.

9. Ensure you select the option to always replace the files on the computer.

10. Ensure that Original location appears in the Restore files to list.

11. Click Start Restore.

12. Choose Start > All Programs > Avaya > Contact Center > Security Framework
> Security Settings.

13. Select Restart Security Framework.

14. Click Close.

Restoring Security Framework data
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Chapter 7: Routine maintenance tasks for
Contact Center Multimedia

The Contact Center Multimedia database contains all multimedia contacts including the routing
information, customer details, and contact details for e-mail, outbound, instant messages, and Web
communications. To ensure that the database operates with maximum efficiency regular maintenance is
required.

It is important to perform database backups regularly, and with the Contact Center Manager Server and
Communication Control Toolkit backups, to have current information if you need to restore the database.
Perform a backup after you complete your installation or when any significant change occurs in the
database, so that you can restore the database easily.

You can periodically archive the information in the database to reduce the data stored in the multimedia
database.

You can archive data in the database by

• Outbound Campaign

• E-mail rule

• Closed Reason

• Skillset

Prerequisites for routine maintenance tasks for Contact
Center Multimedia

• Install and configure Contact Center Multimedia.

• If archiving data, determine which archive type to use.

• Shut down the Multimedia Services.

 Important:
If you manually modify data generated from an archive, the data may become
corrupt, resulting in the failure of future restores based on the data. For this reason,
Avaya cannot support application issues arising from manual modification of the data
generated by the archive process.
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Navigation
• Creating a backup location on page 36
• Performing an immediate backup of the database on page 37
• Scheduling a backup of the database on page 39
• Recovering a scheduled backup on page 40
• Starting the archive utility on page 41
• Archiving by outbound campaign on page 42
• Archiving by e-mail rule on page 43
• Archiving by skillset on page 44
• Archiving by closed reason on page 45
• Recovering from a failed archive on page 46

Creating a backup location
Before you begin

• Ensure that you have a user account with full permissions to access the location for the
database backups.

About this task
Create a backup location on your network with the correct access permissions to ensure that
you have a designated location for the backup file.

 Important:
If either CCMS, CCT or CCMM are installed on standalone servers, the database backups
must not be contained in the same folder, as ADMIN databases stored in the same backup
folder overwrite each other.

Procedure

1. Click Start > All Programs > Avaya > Contact Center > Database Utilities >
Database Maintenance.

2. In the Database Maintenance dialog box, click Backup Locations.

3. In the right pane, click Create.

4. From the Drive Letter list, select a drive letter.

5. In the UNC Path text box, type the location to which to backup the database.
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6. In the Username box, type the user name as the user logs on to the server specified
in the UNC Path text box.

7. In the Password box, type the Windows password.

8. Click OK.

Variable definitions

Name Description

Drive Letter The drive letter representing the destination
for the backup file.

UNC Path The IP Address and folder name of the server
destination for the backup file.
For example, the UNC path can be \
\192.167.140.0\dbbackup.

Username The user name, including server name and
user name for the backup destination
server.
For example, the Username can be
192.167.140.45\administrator.

Password The password for the user that you configure
for the backup location.

Performing an immediate backup of the database
Before you begin

• Create a backup location if you use a network location for your backup.
• Know which applications you are backing up.

About this task
Perform an immediate backup of the Contact Center Multimedia database to save the current
data. It is important to complete this procedure after you complete your installation or when
any significant change occurs in the database, so that you can restore the database easily.

You can back up one or more databases at one time. The backup folder contains separate
backup files for each database or folder you select.

If your Contact Center is running with a standby server, ensure that you back up the primary
server, not the standby server, to back up the most current data.

Performing an immediate backup of the database
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Avaya recommends that you perform backups during low traffic periods.

Procedure

1. Click Start > All Programs > Avaya > Contact Center > Database Utilities >
Database Maintenance.

2. In the Database Maintenance dialog box, in the left pane, click Immediate
Backup.

3. In the Media Type section, select the Network Location option.

4. In the Applications section, select the check box beside each application you want
to back up.

5. From the Backup Location list, select the network drive where you want to store
the backup.

6. Click Backup.

7. Click Yes to confirm your choices.

8. Use the Progress information field to monitor the progress of the backup.

9. Click Exit to the close the Database Maintenance utility.

Variable definitions

Name Description

Applications The Contact Center application databases
that you can back up.

• CCMM: Contact Center Multimedia
database

• ADMIN: common database for all Contact
Center applications

Backup Location The destination for the network disk. The
values are configured in Backup Locations.

Media type The type of media used for your backup file.
You can use a network disk location. If you
use a network disk location, you must
configure a destination before you can back
up the file.
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Scheduling a backup of the database
Before you begin

• Create a backup location.
• Know which applications you are backing up.

About this task
Schedule a backup of the Contact Center Multimedia database to save the data at regular
intervals. It is important to perform database backups regularly to have current information if
you need to restore the database.

Avaya Aura® Contact Center stores up to seven backup files at each server location. The
backup files are stored in numbered backup directories (for example, Backup_1, Backup_2).
File storage is circular and, if necessary, the oldest backup file is deleted to allow new backup
files to be stored at a location.

You can back up one or more databases at one time. The backup folder contains separate
backup files for each database or folder you select. If you have two scheduled backups
occurring at the same time, the backup file with the larger timeframe is performed first. For
example, if you have a weekly backup and a monthly backup scheduled at the same time, the
monthly backup runs first.

You can verify that a scheduled backup was successful by viewing Contact Center events.
After the backup, an event message includes the scheduled backup by name and indicates if
it has finished successfully or if it has finished with an error. Details of the error are included.

Procedure

1. Click Start > All Programs > Avaya > Contact Center > Database Utilities >
Database Maintenance.

2. In the Database Maintenance dialog box, in the left pane, click Scheduled
Backup.

3. In the right pane, click Create.

4. Under General Properties, in the Name box, type a name for the scheduled
backup.

5. From the Media Type list, select Network Location.

6. In the Start Date box, type the date on which to begin scheduled backups.
OR
Click the calendar icon and select a date on which to begin scheduled backups.

7. In the Start Time box, select the time to start the backup.

8. From the Backup Location list, select a drive to store the backup.

Scheduling a backup of the database
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9. From the Frequency list, select the frequency of the backup.
10. Under Applications, select the check box beside each application you want to back

up.
11. Click OK.
12. Click Exit to close the Database Maintenance utility.

Variable definitions

Name Description

Applications The database and applications of Contact
Center that you can back up.

• CCMM: Contact Center Multimedia
database

• ADMIN: common database for all Contact
Center applications

Backup Location The destination for the network disk. The
values are configured in the Backup
Locations.

Frequency The frequency of the backup. You can
choose from daily, weekly, monthly, or run
once.

Media type The type of media used for your backup file.
You can use a network disk location. If you
use a network disk location, you must
configure a destination before you can back
up the file.

Name Identifier for the scheduled backup. You can
identify each backup with a unique name.

Recovering a scheduled backup
Before you begin
• Ensure that you view the event in Windows Event Viewer and address the reason why the

scheduled backup failed.
About this task
Recover a scheduled backup if an error occurs while the backup is running. A scheduled
backup failure can occur for several reasons; for example, if the backup location is not available
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or if there is not enough space to save the backup file. If an error occurs, the scheduled backup
stops running and an event is created. To view the event use Windows Event Viewer.

Procedure

1. Click Start > All Programs > Avaya > Contact Center > Database Utilities >
Database Maintenance.

2. In the Database Maintenance dialog box, in the left pane, click Scheduled
Backup.

3. Click the name of the scheduled backup you want to recover.

4. Click Recover.

5. Click OK.
To run the schedule the next time the error is cleared and the scheduled backup is
recovered.

Starting the archive utility
Before you begin

• Log on to Contact Center Multimedia Administrator.

About this task
Start the archive utility to configure your archiving settings and to archive or restore the Contact
Center Multimedia database.

Procedure

1. Click Start > All Programs > Avaya > Contact Center > Database Utilities >
Archive/Restore.

2. Expand Database Administration.

3. Double-click Archive/Restore Utility.

4. Configure your archiving settings or select one of the following methods to archive
your data:

• Outbound Campaign (see Archiving by outbound campaign on page 42)

• E-mail rule (see Archiving by e-mail rule on page 43)

• Skillset (see Archiving by skillset on page 44)

• Closed Reason (see Archiving by closed reason on page 45)

Starting the archive utility
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Archiving by outbound campaign
Before you begin

• Start the archive utility. See Starting the archive utility on page 41.

About this task
Archive by outbound campaign to archive one complete campaign at a time. If you attempt to
archive an active campaign, you receive an error message. The Archive utility archives
campaign level information, such as the agent script and associated questions, to a file named
CampaignArchive.txt, and the all of the contact data associated with the campaign, such as
the responses to script questions and disposition code data to a file named
ContactArchive.txt.

A log file of the archive, ArchiveLogFile.txt, is stored in the archive folder you choose.

Procedure

1. In the archive utility, click the Archive By Outbound Campaign tab.

2. From the Inactive Campaign List, select the outbound campaign you want to
archive.

3. Click the right arrow to move the selected campaign to the list of campaigns to
archive.

4. To include customer data for the contacts in the outbound campaign, clear the
Delete Customer Data check box.

5. In the Archive Description or Comments box, type comments or information
about this archive.

6. Under Archive to Folder, browse to the folder where you want to store this archive.
The folder location you choose for the archive must contain no other files.

7. Click Archive.

8. On the calendar, select the date on which to create your archive.

9. Click Close.
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Archiving by e-mail rule
Before you begin

• Start the archive utility. See Starting the archive utility on page 41.

About this task
When you archive data by e-mail rule, the archive date defaults to six months before the current
date. You cannot select the current date. Only closed contacts within your selected date range
are archived.

Attachment files for e-mail messages are archived in an attachment folder under the folder
selected for the archive. All data is archived to a single text file named ContactArchive.txt. A
log file of the archive, ArchiveLogFile.txt, is stored in the archive folder you choose.

Procedure

1. On the Contact Center Archive & Restore Utility window, click Archive\Restore
Email Rule.

2. Click the Archive By Email Rule tab.

3. Under the E-mail Rules List, navigate through the list of mailboxes and select the
rules that you want to archive.

4. Click the right arrow to move the selected rule to the list of items to archive.

5. Repeat steps 3 and 4 for the number of rules you want to archive.

6. Under Contacts Closed on or Before, click the last date for which you want to archive
contacts.

7. To include customer data for the contacts with the selected items, clear the Delete
Customer Data check box.

8. In the Archive Description or Comments box, type comments or information
about this archive.

9. Under Archive to Folder, type or browse to the folder where you want to store the
current archive. The folder location you choose for the archive must not contain any
other files.

10. Click Archive.

11. On the calendar, select the date on which to create your archive.

12. Click Close.

Archiving by e-mail rule
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Archiving by skillset
Before you begin

• Start the archive utility. See Starting the archive utility on page 41.

About this task
When you archive by skillset, select a skillset from which you want to archive data. The archive
date defaults to six months before the selected date. You cannot select the current date. Only
closed contacts within your selected date range are archived.

Skillsets that are marked as deleted appear with an asterisk.

All contact data is archived to a single text file named ContactArchive.txt. A log file of the
archive, ArchiveLogFile.txt, is stored in the archive folder you choose.

Procedure

1. On the Contact Center Archive & Restore Utility window, click Archive\Restore
Skillset.

2. Click the Archive By Skillset tab.

3. Under the Skillset list, click a skillset that you want to archive.
Skillsets in the Skillset list marked with an asterisk are no longer in service.

4. Click the right arrow to move the selected skillset to the list of items to archive.

5. Repeat steps 3 and 4 for the number of skillsets you want to archive.

6. Under Contacts Closed on or Before, click the last date for which you want to archive
contacts.

7. To include customer data for the contacts with the selected items, clear the Delete
Archive Customer Data check box.

8. In the Archive Description or Comments box, type comments or information
about this archive.

9. Under Archive to Folder, type or browse to the folder where you want to store the
current archive. The folder location you choose for the archive must contain no other
files.

10. Click Archive.

11. On the calendar, select the date on which to create your archive.

12. Click Close.
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Archiving by closed reason
Before you begin

• Start the archive utility. See Starting the archive utility on page 41.

About this task
When you archive by closed reason, select a closed reason for which you want to archive data.
When you choose to archive by closed reason, the archive date defaults to six months before
the selected date. When you archive data, you cannot select the current date. Only closed
contacts within your selected date range are archived.

Closed reasons that are marked as deleted appear with an asterisk.

All contact data is archived to a single text file named ContactArchive.txt. A log file of the
archive, ArchiveLogFile.txt, is stored in the archive folder you choose.

Procedure

1. On the Contact Center Archive & Restore Utility window, click Archive\Restore
Closed Reason.

2. Click the Archive By Closed Reason tab.

3. Under the Closed Reason List, click a closed reason that you want to archive.
Closed reasons in the Closed reasons list marked with an asterisk are no longer in
service.

4. Click the right arrow to move the selected closed reason to the list of items to
archive.

5. Repeat steps 3 and 4 for the number of closed reason you want to archive.

6. Under Contacts Closed on or Before, click the last date for which you want to archive
contacts.

7. To include customer data for the contacts with the selected items, clear the Delete
Customer Data check box.

8. In the Archive Description or Comments box, type comments or information
about this archive.

9. Under Archive to Folder, type or browse to the folder where you want to store the
current archive. The folder location you choose for the archive must not contain any
other files.

10. Click Archive.

11. On the calendar, select the date to create your archive.

Archiving by closed reason
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12. Click Close.

Recovering from a failed archive
About this task
You can recover from a failed archive. If the system has a problem with the database or Contact
Center Multimedia server during an archive, the archive is marked as failed in the Archive
Manager list.

Procedure

1. From the Archive Manager list, select the failed archive.

2. Click Resume.
The archive continues.
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Chapter 8: Routine maintenance tasks for
Avaya Media Server

Use the tasks described in this chapter to maintain Avaya Media Server.

Navigation
• Creating a backup location on page 47
• Creating a manual backup definition on page 49
• Creating a scheduled backup definition on page 50
• Running a manual Avaya Media Server backup on page 52
• Restoring the Avaya Media Server backup on page 53
• Deleting the Avaya Media Server backup on page 53
• Modifying a backup definition on page 54
• Deleting a backup definition on page 55

Creating a backup destination
About this task
Add a backup destination to specify a location for storing backup files. If you do not specify a
destination for a backup task, the system stores the backup image in the default location.

You can configure any number of remote backup destinations. When performing remote
backup destinations, Element Manager (EM) uploads the backup files to the specified File
Transfer Protocol (FTP) server and then deletes the duplicate backup files from the Avaya
Media Server server. To perform a backup and restore, you must have permission to upload
files to the remote backup destination.

An Avaya MS server has one predefined backup destination, which the administrator cannot
configure: Default Backup Destination. If the administrator chooses to create a backup using
this destination, EM stores backup files in the predefined local directory on the Avaya MS
server: \Avaya\Multimedia_Applications\Avaya MS\platdata\EAM\Backups. The local backup
destination is not a shared folder, and the folder can be empty.
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Procedure

1. Log on to Element Manager.

2. In the navigation pane, click Tools > Backup and Restore > Backup
Destinations.

3. On the Backup Destinations page, click Add.

4. In the Destination Name field, type a unique name for the backup destination.

5. In the Host Name field, type the host name of the destination server.

6. In the User Name field, type a user name.

7. In the Password field, type a password.

8. In the Destination Path field, type the destination path.

9. Optionally, you can select the Remove the local temporary file after transfer
check box to remove the local backup file.

10. Optionally, click Test to test your connection.

11. Click Save.

Variable definitions

Name Description

Destination Name A mandatory, unique name for the backup
destination.

Host Name The name of the File Transfer Protocol (FTP)
server used for the backup.

User Name The user name required to connect to the
FTP server.

Password The password required to connect to the FTP
server.

Destination Path The path to the backup destination.

Remove local file after transfer Click to enable auto removal of the local
temporary backup file after it is transferred.
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Creating a manual backup definition
About this task
This procedure explains the steps to create a manual backup definition. The backup definition
contains information on what parts of the Avaya MS system to back up and where Avaya MS
saves the backup.

Procedure

1. Log on to Element Manager.

2. In the navigation pane, click Tools > Backup and Restore.

3. Select Backup Tasks.

4. On the Backup Tasks window, click Add. The Add New Backup Task window
appears.

5. Type a name for this backup in the Backup Task Name field.

6. Select the System Configuration, Application, and Network Data options.

7. Choose a backup destination. You can pick one of the existing backup destinations,
or click Add and specify a new one.
See Creating a backup destination on page 47.

8. Select Manually, as needed.

9. Click Save.

Variable definitions

Name Description

Backup Task Name field A unique name for the backup task.

Backup Type - System Configuration
check box

Select to back up the system configuration.

Backup Type - Application check box Select to back up the Application data.

Backup Type - Network Data check box Select to back up the Network Data.

Add button Select if you want to add an alternate backup
destination.

Creating a manual backup definition
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Name Description

Modify button Click if you want to modify the selected
backup destination. You cannot modify the
default destination.

Run Backup - Manually, as needed option
button

Select to create an unscheduled backup
task. This type of task must be run manually
by clicking Run Now on the Backup Tasks
page.

Save button Click to save the selected settings and return
to the previous screen. Your backup occurs
at the next scheduled time.

Cancel button Click to cancel the selected settings and
return to the previous screen.

Creating a scheduled backup definition
About this task
This procedure explains the steps to create a scheduled backup definition. The backup
definition contains information on what parts of the Avaya MS system to back up and where
Avaya MS saves the backup.

Procedure

1. Log on to Element Manager.

2. In the navigation pane, click Tools > Backup and Restore.

3. Select Backup Tasks.

4. On the Backup Tasks window, click Add. The Add New Backup Task window
appears.

5. Type a name for this backup in the Backup Task Name field.

6. Select the System Configuration, Application, and Network Data options.

7. Choose a backup destination. You can pick one of the existing backup destinations,
or click Add and specify a new one.
See Creating a backup destination on page 47.

8. Select Schedule.

9. Select the frequency of the backup from the Schedule Task drop-down list.

10. Specify the hour and minute of the backup using the Start Time drop-down list.
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11. Click Save.

Variable definitions

Name Description

Backup Task Name field A unique name for the backup task.

Backup Type - System Configuration
check box

Select to back up the system configuration.

Backup Type - Application check box Select to back up the Application data.

Backup Type - Network Data check box Select to back up the Network Data.

Add button Select if you want to add an alternate backup
destination.

Modify button Select if you want to modify the selected
backup destination. You cannot modify the
default destination.

Run Backup - Schedule option button Select to create a scheduled backup task,
and then choose the schedule properties
from the fields below.

Schedule Task pull down menu Choose the frequency of your scheduled
backup. Valid values are: Daily, Weekly,
Monthly, and Once. The available schedule
properties fields change depending on your
selection.

Weekdays check boxes For a daily backup, select the days when you
want the backup to occur.

Weekday pull down menu For a weekly backup, select the day of the
week when you want the backup to occur.

Day of the month(s) option button Select this option if you are creating a
monthly backup and want to specify first,
second, third, fourth, or last day of the
selected day of the week.

The X of the month(s) option button Select this option if you are creating a
monthly backup and want to specify the first,
second, third, fourth, or last day of the
selected months when you want the backup
to occur. This choice applies to all months
you selected.

Schedule task once field For backups scheduled to occur once only,
the date when you want the backup to occur.

Creating a scheduled backup definition
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Name Description

The date must be in the format DD/MM/
YYYY.

Start Time pull down menu Select the time when you want your
scheduled backup to begin.

Save button Select to save the selected settings and
return to the previous screen. Your backup
occurs at the next scheduled time.

Cancel button Select to cancel the selected settings and
return to the previous screen.

Running a manual Avaya Media Server backup
Before you begin

• Create a manual backup definition.
• Create and test a backup destination, if required.

About this task
This procedure explains how to run a manual Avaya Media Server backup. You must run a
backup both before and after making major changes to your system, such as upgrading the
system software or deleting a number of records.

You can run only one manual backup task at a time. If a task is scheduled to run while the
same task is manually invoked, then the scheduled task runs after the manually invoked task
finishes.

Procedure

1. Log on to Element Manager.

2. In the navigation pane, click Tools > Backup and Restore.

3. Select Backup Tasks.

4. On the Backup Tasks window, select the backup task that you want to run.

5. Click Run Now.
The Confirm Backup window appears, showing the backup task name and backup
type of the backup you are about to run.

6. Click Confirm.
The History Log window appears. When the backup is complete, the backup details
appear in the list.
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Restoring an Avaya Media Server backup
Before you begin

• Create a backup.

About this task
This procedure explains the steps you take to restore a backup of the Avaya MS server.

 Note:

Restoring a backup may impact running applications. Avaya MS closes until the system
completes the restoration. You must restart the system after the Avaya MS completes the
restore. The administrator must inform users when EM is available after the Avaya MS server
completes the restore.

Be careful when choosing a backup to restore, as there is the potential to clear data that is
currently on the system. Avaya recommends you back up the current system before restoring
an old backup.

Procedure

1. Log on to Element Manager.

2. In the navigation pane, click Tools > Backup and Restore > Restore.

3. On the Restore page, in the Restore Source list, select Upload Backup Files.

4. Click Browse and select the Avaya MS backup that you want to restore.

5. Click Upload Files.

6. On the Confirm Restore page, review the information and click Confirm to proceed
with the restore.

7. Restart the Avaya MS server.

Deleting an Avaya Media Server backup
Before you begin

• Create a backup.

Restoring an Avaya Media Server backup
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 Note:
Make sure you no longer need the backup file you have chosen to delete.

About this task
This procedure explains the steps you take to delete a backup of the Avaya MS server. You
must delete old backups to keep disk space clear, especially in the Default Backup Destination
which is on the Avaya MS server.

Procedure

1. Log on to Element Manager.

2. In the navigation pane, click Tools > Backup and Restore.

3. Select Restore.

4. On the Restore window, select a restore source location from the Restore Source
drop-down list.
Avaya MS lists the backups at that location in the Restore Task list.

5. Select the backup that you want to delete.

6. Click Delete.

Modifying a backup definition
Before you begin

• Ensure you have an existing backup definition that you want to change.

About this task
This procedure outlines the steps to modify a backup definition.

Procedure

1. Log on to Element Manager.

2. In the navigation pane, click Tools > Backup and Restore.

3. Select Backup Tasks.

4. On the Backup Tasks window, select the check box beside the backup task that you
want to modify.

5. Click Edit.
Avaya MS displays the Edit Backup Task window with the details of the task you
have chosen to edit.
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6. Change the parameters of the backup definition and click Save.

Deleting a backup definition
Before you begin

• Old or unwanted backup definitions exist on the Avaya MS server.

About this task
This procedure outlines the steps to delete a backup definition. If you create many definitions
it is good practice to review these from time to time and delete outdated definitions that you
do not use regularly.

Procedure

1. Log on to Element Manager.

2. In the navigation pane, click Tools > Backup and Restore.

3. Select Backup Tasks.

4. On the Backup Tasks window, select the check box beside the backup task that you
want to delete.

5. Click Delete.
Avaya MS displays the Remove Backup Task window with the details of the task
you have chose to delete.

6. Click Confirm to proceed with the deletion, or Cancel to exit the screen without
deleting the backup definition.

Deleting a backup definition
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Chapter 9: Common routine maintenance
tasks

This chapter describes how to perform routine maintenance tasks in Avaya Aura® Contact Center.

Prerequisites for performing common routine maintenance
tasks

• Ensure that you have registered as a user to access the www.avaya.com/support Web
site.

Navigation
• Downloading the latest Avaya documentation on page 57
• Verifying if installed patches are up-to-date on page 58
• Downloading the latest Contact Center patches to the server on page 58
• Installing Contact Center patches on page 59
• Installing the latest operating system service packs on page 60

Downloading the latest Avaya Aura® Contact Center
documentation

About this task
Download the latest Avaya Aura® Contact Center documentation to ensure that you have the
most recent updates. Updates in the documentation accurately reflect the latest software
changes.

Procedure

1. Log on to the Avaya Web site at www.avaya.com/support.
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2. Compare the versions of the Avaya Aura® Contact Center documentation on the
site with the versions you have.

3. If the version number on www.avaya.com is higher than the version number on the
documentation you have, download the latest version of the document.

4. Review the Avaya Web site for release notes and readme files.

Verifying if installed patches are up-to-date
Before you begin

• Look up the latest patches and upgrades for your Contact Center server at 
www.avaya.com/support.

• Review Avaya Aura® Contact Center Upgrade and Patches (NN44400-410) to understand
how to install missing patches.

About this task
Verify if installed patches are up-to-date by using the Contact Center Patch Viewer to view
available patches and to verify the patches that are already installed on the server. Use the
Patch Viewer to view the readme files associated with each patch.

Procedure

1. On the Contact Center server where you want to view available patches, click Start
> All Programs > Avaya > Contact Center > Common Utilities > Contact Center
Patch Viewer.

2. Compare the latest update name in the Patch Viewer with the latest patches listed
on the Avaya Web site.

Downloading the latest Contact Center patches to the
server

Before you begin

• Ensure that you use an account with administrator privileges on your server.

About this task
Download the latest Contact Center patches to the server from www.avaya.com/support to
ensure that you have the most current software.

Common routine maintenance tasks

58     Avaya Aura® Contact Center Routine Maintenance 30 July 2012
Comments? infodev@avaya.com

http://www.avaya.com
http://www.avaya.com/support
http://www.avaya.com/support
mailto:infodev@avaya.com?subject=Avaya Aura® Contact Center Routine Maintenance


Procedure

1. Log on to the server using an account with administrator privileges.

2. In Windows Explorer, browse to the patch folder on the Contact Center installation
DVD.

3. Download the latest service pack .msi file and save it on the Contact Center server
on the D: drive.

4. If a new service pack .msi file exists on www.avaya.com/support, download it and
save it on the Contact Center server.

5. Move the .msi files to <drive>:Avaya_Support\ProductUpdates\Log.

Installing Contact Center patches
Before you begin

• Download the latest documentation. See Downloading the latest Avaya documentation on
page 57.

• Download the latest appropriate service packs. See Downloading the latest Contact
Center patches to the server on page 58.

• Ensure that you use an account with administrator privileges on your server.
• Install patches in the following order:

- Contact Center Common Component patches
- service packs

About this task
Install the latest Contact Center patches to ensure that you have the most current development
updates.

The Contact Center Patch Viewer displays patches for installed Contact Center applications.

Procedure

1. Click Start > All Programs > Avaya > Contact Center > Common Utilities >
Contact Center > Patch Manager.

2. Click Install.

3. Click Browse and navigate to the folder where you downloaded the service
packs.

4. Click Scan for Updates.
The Contact Center Updates section displays the available service packs.

Installing Contact Center patches
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5. Select the appropriate service pack.

6. Click Install Selected Updates.
The Patch Manager installs the service pack and displays a confirmation
message.

7. Click Close.

8. Verify that the newly installed service pack appears under Installed Updates.

Installing the latest operating system service packs
Before you begin

• Access the Avaya hotfixes list on the Avaya Web site at www.avaya.com.
• Perform a backup of all application databases.
• Install and configure Microsoft Windows Server 2008 on your server.

About this task
Install the latest operating system service packs that are supported for Contact Center. You
must download the latest supported operating system service pack from the Avaya hotfixes
list to ensure your Contact Center server software functions correctly with the supported
operating system patches.

Procedure

1. Review the Contact Center Portfolio Service Packs Compatibility and Security
Hotfixes Applicability List, to determine the latest supported operating system
patch.

2. Download the Microsoft Windows Server 2008 service packs and hot fixes
appropriate for the Contact Center application software on this server.

3. Install the latest Windows Server 2008 service pack that is validated with the
Contact Center application software you installed on the server. Follow the Microsoft
installation instructions.
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