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Notice

While reasonable efforts have been made to ensure that the
information in this document is complete and accurate at the time of
printing, Avaya assumes no liability for any errors. Avaya reserves the
right to make changes and corrections to the information in this
document without the obligation to notify any person or organization of
such changes.

Documentation disclaimer

“Documentation” means information published by Avaya in varying
mediums which may include product information, operating instructions
and performance specifications that Avaya may generally make
available to users of its products and Hosted Services. Documentation
does not include marketing materials. Avaya shall not be responsible
for any modifications, additions, or deletions to the original published
version of documentation unless such modifications, additions, or
deletions were performed by Avaya. End User agrees to indemnify and
hold harmless Avaya, Avaya's agents, servants and employees against
all claims, lawsuits, demands and judgments arising out of, or in
connection with, subsequent modifications, additions or deletions to
this documentation, to the extent made by End User.

Link disclaimer

Avaya is not responsible for the contents or reliability of any linked
websites referenced within this site or documentation provided by
Avaya. Avaya is not responsible for the accuracy of any information,
statement or content provided on these sites and does not necessarily
endorse the products, services, or information described or offered
within them. Avaya does not guarantee that these links will work all the
time and has no control over the availability of the linked pages.

Warranty

Avaya provides a limited warranty on Avaya hardware and software.
Refer to your sales agreement to establish the terms of the limited
warranty. In addition, Avaya’s standard warranty language, as well as
information regarding support for this product while under warranty is
available to Avaya customers and other parties through the Avaya
Support website: http://support.avaya.com or such successor site as
designated by Avaya. Please note that if you acquired the product(s)
from an authorized Avaya Channel Partner outside of the United States
and Canada, the warranty is provided to you by said Avaya Channel
Partner and not by Avaya.

Licenses

THE SOFTWARE LICENSE TERMS AVAILABLE ON THE AVAYA
WEBSITE, HTTP://SUPPORT.AVAYA.COM/LICENSEINFO OR
SUCH SUCCESSOR SITE AS DESIGNATED BY AVAYA, ARE
APPLICABLE TO ANYONE WHO DOWNLOADS, USES AND/OR
INSTALLS AVAYA SOFTWARE, PURCHASED FROM AVAYA INC.,
ANY AVAYA AFFILIATE, OR AN AVAYA CHANNEL PARTNER (AS
APPLICABLE) UNDER A COMMERCIAL AGREEMENT WITH AVAYA
OR AN AVAYA CHANNEL PARTNER. UNLESS OTHERWISE
AGREED TO BY AVAYA IN WRITING, AVAYA DOES NOT EXTEND
THIS LICENSE IF THE SOFTWARE WAS OBTAINED FROM
ANYONE OTHER THAN AVAYA, AN AVAYA AFFILIATE OR AN
AVAYA CHANNEL PARTNER; AVAYA RESERVES THE RIGHT TO
TAKE LEGAL ACTION AGAINST YOU AND ANYONE ELSE USING
OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY
INSTALLING, DOWNLOADING OR USING THE SOFTWARE, OR
AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND THE ENTITY FOR WHOM YOU ARE INSTALLING,
DOWNLOADING OR USING THE SOFTWARE (HEREINAFTER
REFERRED TO INTERCHANGEABLY AS “YOU” AND “END USER”),
AGREE TO THESE TERMS AND CONDITIONS AND CREATE A
BINDING CONTRACT BETWEEN YOU AND AVAYA INC. OR THE
APPLICABLE AVAYA AFFILIATE (“AVAYA”).

Avaya grants you a license within the scope of the license types
described below, with the exception of Heritage Nortel Software, for
which the scope of the license is detailed below. Where the order
documentation does not expressly identify a license type, the
applicable license will be a Designated System License. The applicable
number of licenses and units of capacity for which the license is granted
will be one (1), unless a different number of licenses or units of capacity
is specified in the documentation or other materials available to you.
“Software” means Avaya’s computer programs in object code, provided
by Avaya or an Avaya Channel Partner, whether as stand-alone
products, pre-installed , or remotely accessed on hardware products,
and any upgrades, updates, bug fixes, or modified versions thereto.
“Designated Processor” means a single stand-alone computing device.
“Server” means a Designated Processor that hosts a software
application to be accessed by multiple users. “Instance” means a single
copy of the Software executing at a particular time: (i) on one physical
machine; or (ii) on one deployed software virtual machine (“VM”) or
similar deployment.

License types

Designated System(s) License (DS). End User may install and use
each copy or an Instance of the Software only on a number of
Designated Processors up to the number indicated in the order. Avaya
may require the Designated Processor(s) to be identified in the order
by type, serial number, feature key, Instance, location or other specific
designation, or to be provided by End User to Avaya through electronic
means established by Avaya specifically for this purpose.

Concurrent User License (CU). End User may install and use the
Software on multiple Designated Processors or one or more Servers,
so long as only the licensed number of Units are accessing and using
the Software at any given time. A “Unit” means the unit on which Avaya,
at its sole discretion, bases the pricing of its licenses and can be,
without limitation, an agent, port or user, an e-mail or voice mail account
in the name of a person or corporate function (e.g., webmaster or
helpdesk), or a directory entry in the administrative database utilized
by the Software that permits one user to interface with the Software.
Units may be linked to a specific, identified Server or an Instance of the
Software.

Shrinkwrap License (SR). You may install and use the Software in
accordance with the terms and conditions of the applicable license
agreements, such as “shrinkwrap” or “clickthrough” license
accompanying or applicable to the Software (“Shrinkwrap License”).

Heritage Nortel Software

“Heritage Nortel Software” means the software that was acquired by
Avaya as part of its purchase of the Nortel Enterprise Solutions
Business in December 2009. The Heritage Nortel Software currently
available for license from Avaya is the software contained within the list
of Heritage Nortel Products located at http://support.avaya.com/
LicenseInfo/ under the link “Heritage Nortel Products”, or such
successor site as designated by Avaya. For Heritage Nortel Software,
Avaya grants Customer a license to use Heritage Nortel Software
provided hereunder solely to the extent of the authorized activation or
authorized usage level, solely for the purpose specified in the
Documentation, and solely as embedded in, for execution on, or (in the
event the applicable Documentation permits installation on non-Avaya
equipment) for communication with Avaya equipment. Charges for
Heritage Nortel Software may be based on extent of activation or use
authorized as specified in an order or invoice.

Copyright

Except where expressly stated otherwise, no use should be made of
materials on this site, the Documentation, Software, Hosted Service,
or hardware provided by Avaya. All content on this site, the
documentation, Hosted Service, and the Product provided by Avaya
including the selection, arrangement and design of the content is
owned either by Avaya or its licensors and is protected by copyright
and other intellectual property laws including the sui generis rights
relating to the protection of databases. You may not modify, copy,
reproduce, republish, upload, post, transmit or distribute in any way any
content, in whole or in part, including any code and software unless
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expressly authorized by Avaya. Unauthorized reproduction,
transmission, dissemination, storage, and or use without the express
written consent of Avaya can be a criminal, as well as a civil offense
under the applicable law.

Third Party Components

“Third Party Components” mean certain software programs or portions
thereof included in the Software or Hosted Service may contain
software (including open source software) distributed under third party
agreements (“Third Party Components”), which contain terms
regarding the rights to use certain portions of the Software (“Third Party
Terms”). As required, information regarding distributed Linux OS
source code (for those Products that have distributed Linux OS source
code) and identifying the copyright holders of the Third Party
Components and the Third Party Terms that apply is available in the
Documentation or on Avaya’s website at: http://support.avaya.com/
Copyright or such successor site as designated by Avaya. You agree
to the Third Party Terms for any such Third Party Components

Preventing Toll Fraud

“Toll Fraud” is the unauthorized use of your telecommunications
system by an unauthorized party (for example, a person who is not a
corporate employee, agent, subcontractor, or is not working on your
company's behalf). Be aware that there can be a risk of Toll Fraud
associated with your system and that, if Toll Fraud occurs, it can result
in substantial additional charges for your telecommunications services.

Avaya Toll Fraud intervention

If you suspect that you are being victimized by Toll Fraud and you need
technical assistance or support, call Technical Service Center Toll
Fraud Intervention Hotline at +1-800-643-2353 for the United States
and Canada. For additional support telephone numbers, see the Avaya
Support website: http://support.avaya.com or such successor site as
designated by Avaya. Suspected security vulnerabilities with Avaya
products should be reported to Avaya by sending mail to:
securityalerts@avaya.com.

Trademarks

Avaya, the Avaya logo, Avaya Aura® Experience Portal, AvayaAura®

Communication Manager, and Avaya Aura® Orchestration Designer
are either registered trademarks or trademarks of Avaya Inc. in the
United States of America and/or other jurisdictions.

All non-Avaya trademarks are the property of their respective owners.
Linux® is the registered trademark of Linus Torvalds in the U.S. and
other countries.

Downloading Documentation

For the most current versions of Documentation, see the Avaya
Support website: http://support.avaya.com, or such successor site as
designated by Avaya.

Contact Avaya Support

See the Avaya Support website: http://support.avaya.com for Product
or Hosted Service notices and articles, or to report a problem with your
Avaya Product or Hosted Service. For a list of support telephone
numbers and contact addresses, go to the Avaya Support website: 
http://support.avaya.com (or such successor site as designated by
Avaya), scroll to the bottom of the page, and select Contact Avaya
Support.
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Chapter 1: About Orchestration Designer

Overview
Orchestration Designer is a Java-based tool that you can use to create:

• Speech applications that comply with VoiceXML version 2.1.

• Call control applications that comply with CCXML version 1.0 January 19, 2007,
specification.

• Message applications that comply with TextXML.

Designed as an Eclipse plug-in, Orchestration Designer provides an integrated GUI for the
design and implementation of:

• Speech applications that can operate with Interactive Response, Voice Portal, Media
Processing Server, and Avaya Aura® Experience Portal systems.

• Message applications that can operate with Avaya Aura® Experience Portal system.

Orchestration Designer is a suite for combination of self-service products and Avaya Contact
Center products, namely, Avaya Aura® Experience Portal, Avaya Interactive Response (IR),
Media Processing Server (MPS), and Avaya Aura® Contact Center. As a single tool, you can
use Orchestration Designer to design, simulate, and maintain contact routing scripts along with
inbound and outbound self-service support. Orchestration Designer accelerates the service
design and deployment, reduces the cost, and enhances the customer experience.

Orchestration Designer is based on the widely accepted Eclipse.org development framework.
It provides a drag-and-drop environment for development and maintenance of speech,
touchtone, and message applications.

Features and benefits
Orchestration Designer:

• Simplifies development, integration, and reusability of speech and touchtone
applications.

• Significantly reduces time and cost of application prototyping and design.
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• Provides unprecedented coverage of customer self-service, employee-facing
productivity, and advanced call control application areas.

• Ensures consistent and more reliable deployment of voice enabled services and
applications.

• Maximizes the use of existing tooling investments for more rapid deployment of Web-
based voice applications through the open Eclipse-based framework.

Audience
The intended audience of this documentation are users who need to:

• Install and configure Orchestration Designer.

• Upgrade Orchestration Designer.

• Install Orchestration Designer patch updates.

• Upgrade Avaya Aura® Contact Center plugin in Orchestration Designer.

Related topics:
Prerequisite knowledge on page 8

Prerequisite knowledge
The primary users of Orchestration Designer are likely to be highly knowledgeable and skilled
in telecommunications and Internet technologies. Therefore, this documentation does not
cover topics related to those areas. The users must be proficient and knowledgeable in the
following areas:

• The operating systems on which the users develop and deploy Orchestration Designer
applications.

• Computer networking concepts and technologies.

• Telecommunications concepts and technologies, including switches and gateways.

• Basic programming logic and practice.

 Note:
Although not required to develop applications in Orchestration Designer, knowledge
and experience of Java programming is helpful.

Orchestration Designer is built on several existing technologies and tools. Hence,
Orchestration Designer users must become familiar with the following technologies:

About Orchestration Designer
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• Eclipse open-source software

• Java servlet technology

• Servlet engine technologies

• Speech recognition and synthesis technologies

• Database administration

• Web service technologies

For more information about additional resources for these technologies, see Documentation
for related products and technologies on page 12.

Document changes since last issue
The following changes have been made to this document since the last issue:

• Support for Tomcat 7, JBoss AS7, and Java 7.

• Support for Eclipse 3.6 and Eclipse 3.7 instead of Eclipse 3.3 and Eclipse 3.4.

• Install and configure Microsoft SAPI Speech.

• Orchestration Designer patch updates.

• Avaya Aura® Contact Center plugin upgrade in Orchestration Designer.

Related resources

Documentation
The following table lists the documents related to this product. Download the documents from
the Avaya Support website at http://support.avaya.com

Title Description Audience
Getting Started with Avaya
Aura® Orchestration Designer

This PDF document contains the
information needed to install and
configure Orchestration Designer for
initial use, as well as to understand
the basics of Orchestration Designer
graphical user interface (GUI).

• Application
Developers

• Implementation
Engineers

Document changes since last issue
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Title Description Audience

Avaya Aura® Orchestration
Designer Developer’s Guide

This PDF document contains the
same information as available in the
online Help, but in a format that can
be printed or viewed using Adobe
Acrobat Reader.

Application
Developers

Avaya Aura® Orchestration
Designer online Help

The online Help provides detailed
information and procedures for using
Orchestration Designer features and
options to create speech, message,
and call control applications.
When installing Orchestration
Designer, the online Help is installed
as an additional Eclipse plug-in.

• Application
Developers

• Implementation
Engineers

Programmer Reference Guide This online documentation is
designed for the programmers of
Orchestration Designer. This
documentation includes:

• A Constants (Quick reference)
guide.

• A Class Hierarchy reference
guide.

• An API Reference guide.

Application
Developers

For information about viewing the Orchestration Designer documentation, see Viewing the
Orchestration Designer documentation on page 11.

Avaya Mentor videos
Avaya Mentor videos provide technical content on how to install, configure, and troubleshoot
Avaya products.

About this task
Videos are available on the Avaya Support website, listed under the video document type, and
on the Avaya-run channel on YouTube.

• To find videos on the Avaya Support website, go to http://support.avaya.com, select
the product name, and select the videos checkbox to see a list of available videos.

• To find the Avaya Mentor videos on YouTube, go to http://www.youtube.com/
AvayaMentor and perform one of the following actions:

- Enter a key word or key words in the Search Channel to search for a specific
product or topic.

About Orchestration Designer
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- Scroll down Playlists, and click the name of a topic to see the available list of videos
posted on the site.

 Note:
Videos are not available for all products.

Support
Visit the Avaya Support website at http://support.avaya.com for the most up-to-date
documentation, product notices, and knowledge articles. You can also search for release
notes, downloads, and resolutions to issues. Use the online service request system to create
a service request. Chat with live agents to get answers to questions, or request an agent to
connect you to a support team if an issue requires additional expertise.

Viewing the Eclipse documentation
About this task
The documentation for Eclipse and supporting Eclipse components (GEF and WTP) is
available at http://www.eclipse.org/documentation/, and is also available in the form of an
online Help.

• On the Help menu > click Help Contents.

Viewing the Orchestration Designer documentation
About this task
The Getting Started with Avaya Aura® Orchestration Designer guide is available on the
Orchestration Designer installation DVD.

You can view the Orchestration Designer documentation on the Avaya support Web site:

http://support.avaya.com

Support
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The Orchestration Designer documentation is also available in the form of an online Help.

• On the Help menu, click Help Contents > Avaya Aura® Orchestration Designer - Self
Service.

Documentation for related products and technologies
Orchestration Designer depends on the use of several closely related software products and
technologies. When using Orchestration Designer, review the documentation of these related
products and technologies.

Avaya does not reproduce or package the documentation for these related products and
technologies. However, to help locate the appropriate documentation, review the following
resources:

 Note:
The following URLs were valid at the time of publication of this document. Avaya is not
responsible if these URLs have changed. For more updated URLs, perform a search
operation online.

• For Eclipse and supporting Eclipse components (GEF and WTP), go to:

http://www.eclipse.org/documentation/

For more information, see Viewing the Eclipse documentation on page 11.
• For the Java SDK (Software Developer’s Kit), go to:

http://docs.oracle.com/javase/1.5.0/docs/index.html

http://docs.oracle.com/javase/6/docs/index.html

http://docs.oracle.com/javase/7/docs/index.html
• For Tomcat 5.5, 6.0, or 7.0, go to:

http://tomcat.apache.org/tomcat-5.5-doc/index.html

http://tomcat.apache.org/tomcat-6.0-doc/index.html

http://tomcat.apache.org/tomcat-7.0-doc/index.html
• For IBM WebSphere or WebSphere Express, go to:

http://www.ibm.com/websphere
• For WebLogic, go to:

http://www.oracle.com/appserver/weblogic/weblogic-suite.html
• For JBoss AS7, go to:

https://docs.jboss.org/author/display/AS7/Documentation
• For Microsoft SAPI Speech, go to:

About Orchestration Designer
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http://www.microsoft.com/speech/speech2007/downloads.mspx
• For databases and JDBC implementation, go to:

http://www.sql.org/

http://www.firstsql.com/tutor.htm

http://java.sun.com/developer/onlineTraining/Database/JDBCShortCourse/jdbc/sql.html
• For Web services, go to:

http://www.w3.org/TR/wsdl

http://www.ws-i.org/Profiles/BasicProfile-1.1-2004-08-24.html
• For the W3C VoiceXML 2.0 Recommendation, go to:

http://www.w3.org/TR/voicexml20/
• For the W3C VoiceXML 2.1 Recommendation, go to:

http://www.w3.org/TR/voicexml21/
• For the W3C CCXML 1.0 Recommendation (January 19, 2007), go to:

http://www.w3.org/TR/ccxml/
• For the Speech Recognition Grammar Specification version 1.0, go to:

http://www.w3.org/TR/speech-grammar/#AppJ.5

Documentation for related products and technologies
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Chapter 2: Installation and configuration

System requirements

License requirements
You need a valid license to run Orchestration Designer applications on Avaya Aura®

Experience Portal, Avaya Voice Portal, Avaya Interactive Response (IR), Avaya Media
Processing Server (MPS), and other supported VXML platforms. Orchestration Designer
licenses are free. You can contact an Avaya sales representative or channel manager to get
the license file. Avaya partners can log on to the Partner Portal to find information about
ordering additional licenses.

If you run the Orchestration Designer applications on Voice Portal, Avaya Aura® Experience
Portal, IR, or other Avaya products that use the WebLM license server, then Orchestration
Designer does not require a separate WebLM license server. Avaya recommends that you
install the Orchestration Designer license on the existing WebLM license server that is installed
with Voice Portal, Avaya Aura® Experience Portal, IR, or other Avaya products that use the
WebLM license server.

If you run the Orchestration Designer applications on MPS, then you must install the WebLM
license server and configure the license information of Orchestration Designer. You must install
a separate WebLM license server because the WebLM license server is not installed during
the MPS installation.

Orchestration Designer license has a grace period of 30 days. If the WebLM license server is
unavailable after Orchestration Designer obtains the license from the WebLM license server,
Orchestration Designer is available for use for 30 days.

You do not require a license to install or run the Eclipse-based Orchestration Designer
development and simulation environment.

Related topics:
About the WebLM license server installation and configuration on page 18

Getting Started with Avaya Aura® Orchestration Designer December 2013     15



Hardware requirements
The system that hosts the Orchestration Designer development environment must meet or
exceed the following hardware requirements:

Hardware Minimum Recommended
CPU speed 1 GHz 2 GHz

RAM 512 MB 1 GB

Hard disk drive 40 GB —

Monitor resolution 1024 x 768 pixels —

Software requirements
The system that hosts the Orchestration Designer development environment must have the
following software packages installed. You must install these packages before installing and
configuring Orchestration Designer. The software required to host the Orchestration Designer
development environment is available on the Orchestration Designer 7.0 distribution DVD.

 Important:
If you want to upgrade Orchestration Designer, see About Orchestration Designer 6.0 to
Orchestration Designer 7.0 upgrade on page 34.

Software requirement On DVD Notes and links
1

Any one of the following:

• Microsoft Windows XP
(Professional or Home
editions, Service Pack 2 or
later)

• Microsoft Windows 7
(Professional and
Enterprise versions)

• Microsoft Windows Vista
(Business or Ultimate
editions)

No You can install Orchestration Designer on any of
these operating systems as long as you meet all
the hardware requirements and install all the
supporting software packages.

 Note:
For the development environment,
Orchestration Designer supports Windows 7,
32 bit and 64 bit. However, for 64 bit operating
system, you must use 32 bit JRE and Eclipse
version.

Installation and configuration
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Software requirement On DVD Notes and links
1

Any one of the following:

• J2SE Development Kit 6.0
(JDK 6.0)

• J2SE Development Kit 7.0
(JDK 7.0)

Orchestration Designer 7.0
also supports existing JDK
1.5 and JDK 1.6.

Yes The JDK includes the Java Run-Time Environment
(JRE) and command-line tools, compilers, and
debuggers used in developing applets and
applications.

Any one of the following:

• Eclipse-3.7.1-Prereq-
AAOD.zip which includes:

- Eclipse 3.7 SDK

- GEF 3.7 SDK

- WTP SDK 3.3

- emf-xsd 2.7

- DTP 1.9

• Eclipse-3.6-Prereq-
AAOD.zip which includes:

- Eclipse 3.6 SDK

- GEF 3.6 SDK

- WTP SDK 3.2

- emf-xsd 2.6

- DTP 1.8

Yes Eclipse is a Java-based open-source integrated
development environment (IDE) for software
development. Orchestration Designer runs as an
Eclipse plug-in.
Orchestration Designer uses the Eclipse
Graphical Editing Framework plug-ins for Eclipse
(GEF) for advanced graphical functions. It also
includes the support files for Call Control (CCXML)
development.

Apache Tomcat 5.5, Tomcat
6.0, or Tomcat 7.0

Yes Tomcat generates and serves VoiceXML pages to
the Avaya Application Simulator.

 Note:

• You must have administrative privileges when
running Tomcat.

• If you upgrade to Tomcat 7.0, you might need
to make small adjustments the first time you
run Tomcat. If your applications have
manually configured build paths or have
resources in common/lib or common/classes,
then you must manually update the build path
to point to <tomcat_installpath>/lib and also
put any resources, such as libraries, in that
folder.

System requirements
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Software requirement On DVD Notes and links
1

Microsoft SAPI Speech 6.0 Yes Orchestration Designer uses Microsoft SAPI
Speech during application testing to perform
automated speech recognition (ASR) and text-to-
speech (TTS) functions.

 Note:
Microsoft Windows 7 and Windows Vista
already have Microsoft Speech components
installed.
If Microsoft SAPI Speech is already installed on
Windows XP, verify if the Speech
Recognition and Text-to-Speech tabs are
available in Control Panel > Speech.
If Microsoft SAPI Speech is already installed on
Windows 7, verify if the Speech Recognition
and Text-to-Speech tabs are available in
Control Panel > Speech Recognition > Text-
to-Speech.

Storm Codec 7.01.19 You need to install Storm Codec 7.01.19 only if you
intend to use 3GP video files for media.
To launch the Storm Codec installer, see the
installation notes available on the DVD.

Ambulant player 2.1 No Orchestration Designer uses Ambulant player 2.1
for playing and previewing media files.
Though Ambulant player 2.1 consists of all the
menu and toolbar options and controls, do not use
the options in the player.

1. Though specific locations on the DVD are described here, it is intended that users simply
launch the DVD, and use the displayed HTML index page to navigate to the required
resources.
By following these instructions, installation will be smoother because the online navigation
documentation leads you along the correct installation path. This is the preferred
methodology for using the DVD and installing efficiently.

About the WebLM license server installation and
configuration

If you run the Orchestration Designer applications on MPS, then you must install the WebLM
license server and configure the license information of Orchestration Designer. You must install
a separate WebLM license server because the WebLM license server is not installed during
the MPS installation.

Installation and configuration
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Use the WebLM.war file that is available on the Orchestration Designer 7.0 installation DVD
to install the WebLM license server software.

For information about installing and configuring the WebLM license server software, see the
Licensing Installation Instructions for WebLM 6.2 SP2 guide and Licensing Release Notes for
WebLM 6.2 SP2.

The WebLM.war file, Licensing Installation Instructions for WebLM 6.2 SP2 guide, and
Licensing Release Notes for WebLM 6.2 SP2 are available on the Orchestration Designer 7.0
installation DVD at:

<DVD_drive>:\Software\WebLM\

Related topics:
License requirements on page 15

Installing Orchestration Designer manually
About this task
The Orchestration Designer installation DVD contains the Orchestration Designer distribution
executable. Before running the executable, ensure that all system requirements are met as
mentioned in System requirements on page 15.

 Note:
Before installing the Orchestration Designer software, temporarily disable the antivirus
software and close any open or running applications. Orchestration Designer installation
involves extracting Java-related files from a compressed archive and the antivirus software
can slow down the installation process significantly.

 Important:
The procedure described in this section is for new installations of the Orchestration Designer
software. To upgrade Orchestration Designer, see About Orchestration Designer 6.0 to
Orchestration Designer 7.0 upgrade on page 34.

Procedure

1. Insert the Orchestration Designer installation DVD into the DVD drive.

2. Install JDK 6.0 or JDK 7.0:

a. Locate the JDK installer on the Orchestration Designer 7.0 DVD.
The JDK installer is located in the following directory: <DVD_drive>:
\Software\Java\

b. Double-click the downloaded executable file to install the JDK.

3. Install Eclipse and all other Eclipse prerequisite features:

Installing Orchestration Designer manually
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a. Locate the package file on the Orchestration Designer 7.0 DVD. This file is
located in the following directory: <DVD_drive>:\Software\Eclipse\

b. Extract the .zip file into an installation folder.
c. (Optional) If you want, create a shortcut for the Eclipse executable.

Orchestration Designer is launched through Eclipse.

 Note:
For Windows Vista Business, download the prerequisite .zip file before
extracting the prerequisite .zip file because the native extract from the Web
site does not work properly on Windows Vista Business.

4. Install Orchestration Designer software:

a. Locate the AAOD_7.0.0.XXX.jar installation archive on the Orchestration
Designer 7.0 DVD and copy it to a temporary location.
The installation archive is located in the <DVD_drive>:\UpdateSites\
directory.

b. On the eclipse interface, click Help > Install New Software.
c. On the Available software page, click Add.
d. On the Add Repository page, enter a name and click Archive to specify the

location of the AAOD_7.0.0.XXX.jar file.
e. Click OK.
f. Click Select All.
g. On the Available software page, clear the Contact all update site sites during

install to find the required software check box and click Next.
h. On the Install Details page, click Next.

The Avaya Software License Agreement is displayed.
i. Review the license agreement and click I accept the term of the license

agreement.
j. Click Finish.
k. When prompted to trust the certificates, click Select All, and click OK.
l. Click Restart Now to restart eclipse.

5. Install Tomcat:

a. Locate the Tomcat distribution package on the Orchestration Designer 7.0
DVD.
The Tomcat distribution package is located in the <DVD_drive>:\Software
\Tomcat\ directory.

b. Extract the .zip file in a temporary folder.
c. Review the RUNNING.txt file for additional installation instructions.
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 Important:
Do not install Tomcat as an NT service. Orchestration Designer does not
support this configuration because Tomcat does not start and stop
appropriately when developing applications.

 Note:
If more than one Java SDK is installed, then you must set the Tomcat JVM
Settings preferences option to JRE1.5.x. JRE1.5.x must be available in Java
before you select it in the Tomcat JVM Settings.

6. (Optional) Install Microsoft Speech API 6.0:

a. Insert the Orchestration Designer 7.0 installation DVD into the DVD drive.
b. Go to <DVD_drive> > Software > MSSpeech
c. Double-click the Setup.exe file.

The system displays the Microsoft SAPI Speech wizard.
d. In the Welcome dialog box, click Next.
e. Accept the license terms and click Next.
f. Enter a user name and organization in the Customer Information dialog box,

then click Next.
g. Accept the default installation folder, when prompted, or navigate to another, if

applicable. Then, click Next.
h. Click Install to begin the Microsoft SAPI Speech installation.
i. Click Finish when the installation is complete.

7. (Optional) Optionally, install the Storm Codec 7.01.19. To launch the Storm Codec
7.01.19, refer the Installation Notes on the DVD.

 Note:

• After you complete the installation procedure, read the Eclipse “readme” file
located in the /readme subdirectory where Eclipse is installed. The Eclipse
readme file includes valuable information and tips for configuring Eclipse.

• Before you use Orchestration Designer, you must configure the basic
settings. For information about configuring your development environment
settings, see Basic configuration on page 23.

Installing Orchestration Designer manually
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Installing Orchestration Designer using pre-packaged
installation

About this task
The Orchestration Designer DVD-ROM contains a pre-packaged Orchestration Designer
installation that contains both the Self Service and Contact Center features as well as a Tomcat
installation.

 Note:
Before you use the pre-packaged Orchestration Designer installation, you must have Java
Development Kit installed. If you do not have a Java Development Kit, use the installer
available on the DVD to install Java before continuing with the pre-packaged installation.

Procedure

1. Insert the Orchestration Designer installation DVD into the DVD drive and navigate
to the root folder of the DVD-ROM or ISO image.

2. Copy the AAOD7.0 folder to C:\ directory on your computer.

3. Double click eclipse.exe file in the AAOD7.0\eclipse folder to install and open
Orchestration Designer.

 Tip:
For easy access to Orchestration Designer, you can create a shortcut to
eclipse.exe and place the shortcut in a convenient location.

4. Open Orchestration Designer and perform the following step to configure the
preferences for the location of the Tomcat installation:

Click Window > Preferences > Tomcat and set the Tomcat home value.
For example, if you copied the AAOD7.0 folder to your C:\ drive, then the Tomcat
home value would be C:\AAOD7.0\apache-tomcat-7.0.26.
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Viewing the version number of an installed Orchestration
Designer software

Procedure

1. On the Help menu, click About Eclipse SDK.

2. In the About Eclipse SDK dialog box, click Installation Details.
The system displays the Eclipse SDK Installation Details dialog box, which contains
the installation and configuration details.

Basic configuration
After you install all the required software for Orchestration Designer and before you start
creating Orchestration Designer projects, you must perform some basic configurations to
ensure that the environment is properly configured and ready to use.

Creating an Eclipse shortcut
About this task
After you complete installing all the installation components, you can launch Eclipse to gain
access to Orchestration Designer. For easy access to Eclipse, you can create a Windows
desktop shortcut icon to the eclipse.exe Eclipse executable file, which is located where Eclipse
is installed.

Procedure

1. To create an Eclipse shortcut, right-click the eclipse.exe Eclipse executable file
which is located where Eclipse is installed, and then click Send To > Desktop
(create shortcut).

2. Double-click the shortcut file to launch Orchestration Designer.
The system displays the Workspace Launcher dialog box.

Viewing the version number of an installed Orchestration Designer software
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Setting up the workspace
About this task
After you launch Orchestration Designer, through Eclipse, for the first time, the Eclipse
Workspace Launcher dialog box prompts you to specify a workspace location. Specify a
directory where you want to save all Orchestration Designer project files.

 Important:
If you are configuring a new version of Orchestration Designer, back up all files in the original
installation directory before configuring a new directory.

Procedure

1. Double-click eclipse.exe.
For more information, see Creating an Eclipse shortcut on page 23.

2. In the Workspace Launcher dialog box, click Browse to navigate to the location that
you want to set as the workspace location.
The default directory is relative to the installation path of Eclipse. For example, C:
\Eclipse\workspace.

3. Click OK.

 Note:
To stop the Workspace Launcher dialog box from prompting for this directory with
every launch of Eclipse, select the Use this as the default and do not ask
again check box, and then click OK.

Preference settings configuration
You must configure the preferences the first time you use Orchestration Designer.
Orchestration Designer uses these configured preferences on subsequent launches.

Configuring the default perspective

Procedure

1. On the Window menu, click Preferences.

2. In the Preferences dialog box, in the left navigation pane, double-click General.

3. Click Perspectives.
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4. In the Open a new perspective area, click In the same window.

5. In the Fast Views area, click Within the perspective.

6. In the Open the associated perspective when creating a new project area, click
Prompt.

7. In the Available perspectives pane, perform one of the following actions:

• Click Speech to set the Speech perspective as the default perspective.

• Click Call Control to set the Call Control perspective as the default
perspective.

8. Click Make default.

9. Click Apply, and then click OK.

Configuring Tomcat preferences

About this task
Tomcat preferences provides settings that determine how Orchestration Designer works with
the Apache Tomcat servlet engine during simulations.

If Tomcat is installed with the default settings, Tomcat preferences are already configured. If
you have installed Tomcat with default settings, you need not configure Tomcat preferences
again.

Verify that the appropriate Tomcat version, home directory, and Contexts directory are
populated.

 Note:
If you are running only Orchestration Designer in your development environment, that is, if
you are not running deployed applications, you need not install the runtimeconfig to your
local Tomcat. This file is installed automatically. You only need to set up your production
system when you are deploying and running live applications.

 Important:
Do not run the runtimeconfig on your ADE. If you do, connection timeout exceptions will
occur. To recover, stop Tomcat, stop Orchestration Designer, restart Orchestration
Designer, and change your configuration in preferences.

 Note:
If more than one Java SDK is installed, then the Tomcat JVM settings preferences option
must be set to JRE1.5.x. JRE1.5.x needs to be available in Java before it can be selected
in the Tomcat JVM Settings.

Basic configuration
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Procedure

1. On the Window menu, click Preferences.
The system displays the Preferences dialog box.

2. In the left navigation pane, click Tomcat.

3. In the Tomcat version area, click the Tomcat version that is installed on your
computer.

4. In the Tomcat home field, click Browse to navigate to and select the directory
where Tomcat is installed.

5. In the Context declaration mode area, click Context files.

6. In the Context directory field, click Browse to navigate to and select the context
directory.

7. Click Apply, and then click OK.

Orchestration Designer preferences management
Considerations for enabling an HTTP or HTTPS proxy connection

The Orchestration Designer Preferences panel includes a setting to enable an HTTP or HTTPS
proxy connection.

Proxy settings are required when all of the following conditions are true:

• The system where Orchestration Designer is installed is behind a firewall.

• Access is required to resources that reside outside the firewall for your Orchestration
Designer speech projects. These resources can include Web services, databases, or
other outside resources.

• Access to these resources requires the use of either an HTTP or HTTPS proxy server.

When these conditions are true, proxy settings for Orchestration Designer must be configured,
even if proxy settings are already configured for your Internet browser or e-mail client. If you
have a proxy server configured for your Internet browser, use the same proxy settings for
Orchestration Designer. .For more information, see “Admin (ddadmin) Web application
configuration” in the Avaya Aura® Orchestration Designer Developer’s Guide

Related topics:
Enabling an HTTP or HTTPS proxy connection on page 26

Enabling an HTTP or HTTPS proxy connection
Procedure

1. On the Window menu, click Preferences.
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2. In the Preferences dialog box, in the left navigation pane, double-click Avaya
Aura.

3. Click Orchestration Designer.

4. In the Orchestration Designer pane, perform one of the following actions:

• In the Proxy Settings area, configure the HTTP proxy settings.

• In the HTTPS Proxy Settings area, configure the HTTPS proxy settings.

5. Click Apply, and then click OK.

Related topics:
Considerations for enabling an HTTP or HTTPS proxy connection on page 26
Orchestration Designer preferences field descriptions on page 29

Configuring the run-time license server
About this task

 Note:
You need to specify a run-time license server only if you have Avaya Aura® Experience
Portal, IR, or MPS accessing your application from the development environment.

You do not need a run-time license to run applications using the Application Simulator.

Procedure

1. On the Window menu, click Preferences.

2. In the Preferences dialog box, in the left navigation pane, double-click Avaya
Aura.

3. Click Orchestration Designer.

4. In the Orchestration Designer pane, in the Runtime License Server area, in the
Server URI field, type the URI of the run-time license server if you have Avaya Aura®

Experience Portal, IR, or MPS accessing your application from the development
environment.
The format for this URI is http://webServerName:port where:

• webServerName is the fully qualified host name or IP address of your WebLM
license server.

• port is the number of the HTTP/HTTPS port the system uses to access the
license server.

For example, http://licenseServer.myCompany.com:8080

5. In the License Check Timeout field, type the time in seconds that the system must
wait for a response from the WebLM license server while attempting to connect to
the WebLM license server.

Basic configuration
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The default value is zero seconds. Zero indicates that there is no timeout.

6. Click Apply, and then click OK.

Related topics:
Orchestration Designer preferences field descriptions on page 29

Removing the context files on closing a project
About this task
Tomcat opens the context files of all the projects each time you simulate a project. Therefore,
Orchestration Designer performance can degrade if you have several workspaces with a huge
number of projects.

If you select the Remove context files on project close check box, Orchestration Designer
automatically deletes the corresponding context files when you close the Orchestration
Designer projects.

Orchestration Designer recreates the context file when a project is reopened. This improves
the performance by controlling the size of the workspaces.

 Note:
This option does not affect the projects which are not opened in the current session. This
applies only to Orchestration Designer projects which you open and close subsequently.

Procedure

1. On the Window menu, click Preferences.

2. In the Preferences dialog box, in the left navigation pane, double-click Avaya
Aura.

3. Click Orchestration Designer.

4. In the Orchestration Designer pane, in the Context Files area, select the Remove
context files on project close check box.

5. Click Apply, and then click OK.

Related topics:
Orchestration Designer preferences field descriptions on page 29

Configuring the fetch secure port
About this task
If you want to use HTTPS to get and post data from form nodes, such as prompt and collect,
announce, menu, record, and transfer, you can specify the port number used by the application
server. If you are using Tomcat, the default port is 8443.
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Procedure

1. On the Window menu, click Preferences.

2. In the Preferences dialog box, in the left navigation pane, double-click Avaya
Aura.

3. Click Orchestration Designer.

4. In the Orchestration Designer pane, in the Secure Fetch area, in the Secure Fetch
Port field, specify the port number used by the application server.

5. Click Apply, and then click OK.

Related topics:
Orchestration Designer preferences field descriptions on page 29

Orchestration Designer preferences field descriptions

Name Description

Proxy Settings  

Enable HTTP proxy connection Check box to enable HTTP proxy connection
if you need a proxy server for Internet
access.

Ignore hosts with addresses The IP addresses. Orchestration Designer
ignores HTTP hosts with these addresses.
For multiple addresses, use either a comma
or semicolon as a separator character.

HTTP proxy host address The full HTTP path or the URL of the proxy
server.

HTTP proxy host port The port that Orchestration Designer can use
to access the proxy server.

Copy HTTP settings to HTTPS To copy the configured HTTP settings to
HTTPS settings automatically.

HTTPS Proxy Settings  

Enable HTTPS proxy connection Check box to enable HTTPS proxy
connection if you need a proxy server for
Internet access.
If you do not need a proxy server for Internet
access, clear this check box. If cleared,
Orchestration Designer disables the other
options in this area.

Ignore HTTPS hosts with addresses The IP addresses. Orchestration Designer
ignores HTTPS hosts with these addresses.

Basic configuration
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Name Description

For multiple addresses, use either a comma
or a semicolon as a separator character.

HTTPS proxy host address The full HTTPS path or the URL of the proxy
server.
If you do not know this address, look at the
proxy server settings for your Internet
browser software.

HTTPS proxy host port The port that Orchestration Designer can use
to access the HTTPS proxy server
If you do not know the URI, contact the Avaya
technical service representative.

 Note:
These settings are required even if proxy
options are also set in Microsoft Internet
Explorer or any other Web browser.

Runtime License Server  

Server URI The URI of the run-time license server if you
have Avaya Aura® Experience Portal, IR, or
MPS accessing your application from the
development environment.

 Note:
You need to specify a run-time license
server only if you have Avaya Aura®

Experience Portal, IR, or MPS accessing
your application from the development
environment.
You do not need a run-time license to run
applications using the Application
Simulator.

The format for this URI is http://
webServerName:port where:

• webServerName is the fully qualified host
name or IP address of your WebLM license
server.

• port is the number of the HTTP/HTTPS port
the system uses to access the license
server.

For example, http://
licenseServer.myCompany.com:8080

License Check Timeout The time in seconds that the system must
wait for a response from the WebLM license
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Name Description

server while attempting to connect to the
WebLM license server.
The default value is zero seconds. Zero
indicates that there is no timeout.

Context Files  

Remove context files on project close Check box to automatically delete
corresponding context files when you close
Orchestration Designer projects.
Orchestration Designer recreates the
context file when a project is reopened. This
improves the performance by controlling the
size of the workspaces.
If you clear the Remove context files on
project close check box, Tomcat opens the
context files of all the projects each time you
simulate a project. Therefore, Orchestration
Designer performance can degrade if you
have several workspaces with a huge
number of projects.

 Note:
This option does not affect the projects
which are not opened in the current
session. This applies only to
Orchestration Designer projects which
you open and close subsequently.

Secure Fetch  

Secure Fetch Port The port number used by the application
server if you want to use HTTPS to get and
post data from form nodes, such as prompt
and collect, announce, menu, record, and
transfer. If you are using Tomcat, the default
port is 8443.

Related topics:
Enabling an HTTP or HTTPS proxy connection on page 26
Configuring the run-time license server on page 27
Removing the context files on closing a project on page 28
Configuring the fetch secure port on page 28
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Verifying the Java JRE

Procedure

1. On the Window menu, click Preferences.

2. In the Preferences dialog box, in the left navigation pane, double-click Java.

3. Click Installed JREs.

4. Verify that jre1.5.x, jre1.6.x, or jre7 is selected. If jre1.5.x, jre1.6.x, and jre7 do not
appear in the list, perform the following action:

• Click Add to add the JRE. For more information, see the Java Development User
Guide.

5. Click OK.

Setting the Java JDK compiler compliance level

Procedure

1. On the Window menu, click Preferences.

2. In the Preferences dialog box, in the left navigation pane, double-click Java.

3. Click Compiler.

4. In the JDK Compliance area, in the Compiler compliance level field, perform one
of the following actions:

• Click 1.5 if you are using Eclipse 3.6.

• Click 1.5 if you are using Eclipse 3.7.

5. Click Apply, and then click OK.

Configuring Microsoft SAPI Speech for microphone input
About this task
Orchestration Designer uses the Microsoft Speech API 6.0 to handle ASR input from a
microphone during application simulation. To use the Microsoft SAPI Speech for ASR input,
you must configure the Microsoft SAPI Speech to use a microphone.
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Procedure

1. On the system where Orchestration Designer is installed, open Control Panel.

2. Perform one of the following actions:

• If you have Microsoft Windows XP installed on your computer, double-click
Speech.

• If you have Microsoft Windows 7 installed on your computer, double-click
Speech Recognition > Text-to-Speech.

3. In the Speech Properties dialog box, click the Speech Recognition tab.

4. With a microphone plugged in and turned on, speak into the microphone. The Level
indicator in the Microphone area should show that the system is receiving
microphone input. If it does not, click Audio Input and rectify the audio input source
settings.

5. Click Configure Microphone to further tune the microphone settings.

6. Click OK.

Installing sample applications
About this task
Orchestration Designer includes numerous sample applications. You can use these sample
application to understand how finished applications work and operate, and how the features
of Orchestration Designer work.

Procedure

1. Navigate to the /Sample Applications/files directory on the Orchestration
Designer installation DVD.

2. Locate and double-click the Avaya Aura® Orchestration Designer [version]
Sample Applications.doc file.

3. Follow the instructions in this file to install and configure Orchestration Designer
sample applications.
This file also contains detailed information about each sample application.

 Important:
Included sample applications are intended to be used as technical samples for
reference only, and not production-ready applications.

Installing sample applications
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About Orchestration Designer 6.0 to Orchestration Designer
7.0 upgrade

The procedure to upgrade Orchestration Designer 6.0 to Orchestration Designer 7.0 is slightly
different depending on whether the earlier version (6.0) is available while installing a concurrent
new version (7.0).

See the following sections:

• Maintaining the 6.0 environment while installing 7.0 on page 34

• Installing 7.0 without retaining the 6.0 environment on page 36

See the following sections for additional information:

• System requirements on page 15

• Installing Orchestration Designer manually on page 19

 Note:
Upgrades to Orchestration Designer might require updates to connectors or other
dependant libraries on the application server. Avaya recommends that you update the
connector applications (icconnector.war and aesconnector.war) and run-time
support files (runtimeSupport <platform>.zip) after upgrading Orchestration
Designer.

For more information about installing the run-time support files and connectors, see
Prerequisite files on the application server in Avaya Aura® Orchestration Designer
Developer’s Guide.

Maintaining the 6.0 environment while installing 7.0
About this task
To retain the Orchestration Designer 6.0 environment, you can install Orchestration Designer
7.0 into a separate directory. You can retain the Orchestration Designer 6.0 environment for
reasons such as maintenance of 6.0-based applications.

For information about the recommended installation paths, see Recommended installation
paths for multiple Orchestration Designer and Eclipse versions on page 35.

Procedure

1. Preserve the Orchestration Designer 6.0 and Eclipse 3.6 installation and
workspace. Orchestration Designer 6.0 continues to use the previous Tomcat
installation.
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2. Install Orchestration Designer 7.0, and Tomcat 5.5, 6.0, or 7.0. (Tomcat upgrade is
optional) to a separate location. For example, C:\OD7.0\.

 Note:
You must install Tomcat under the Orchestration Designer 7.0 installation
location to keep it separate.

3. Upgrade Orchestration Designer 6.0 projects to Orchestration Designer 7.0
projects. Perform the following actions:

a. Copy the projects from the Orchestration Designer 6.0 workspace to the
Orchestration Designer 7.0 workspace. Keep a copy of the projects in the 6.0
workspace to ensure that you have a backup in case of upgrade problems.

b. Import the copied projects into Orchestration Designer 7.0.
The system converts the projects for Orchestration Designer 7.0. You cannot
open these projects in Orchestration Designer 6.0.

4. If you use a source control system, store the 7.0 application in a different location
or a different branch, so that the old 6.0 application can be maintained in the
future.

 Note:
After creating a new workspace during an upgrade, click Window > Preferences
to configure your preferences before importing old projects. For more information,
Preference settings configuration on page 24.

Recommended installation paths for multiple Orchestration Designer and
Eclipse versions

The following example installation paths are recommended for multiple Orchestration Designer
and Eclipse versions. In these paths, (base) means any parent directory.

c:\(base)\OD6.0\

eclipse\ (Eclipse 3.6 install, with GEF 3.6, WTP SDK 3.2, EMF-SDO-XSD 2.6, with
Orchestration Designer 6.0 features, Eclipse 3.4 or 3.5 install, with GEF 3.4 or 3.5 respectively,
and Dialog Designer 5.1 features)

tomcat\ (Tomcat 5.5 or 6.0 for running Orchestration Designer 6.0 applications)

workspace\ (Orchestration Designer 6.0 projects)

c:\(base)\OD7.0\

eclipse\ (Eclipse 3.7 install, with GEF 3.7, WTP SDK 3.3, EMF-SDO-XSD 2.7, with
Orchestration Designer 7.0 features, Eclipse 3.4 or 3.5 install, with GEF 3.4 or 3.5 respectively,
and Orchestration Designer 6.0 features)

tomcat\ (Tomcat 5.5, 6.0, or 7.0 for running Orchestration Designer 7.0 applications)

About Orchestration Designer 6.0 to Orchestration Designer 7.0 upgrade
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workspace\ (Orchestration Designer 7.0 projects)

This is a convenient installation structure that retains the Orchestration Designer 6.0 and
Orchestration Designer 7.0 environments and prerequisite software separate.

Installing 7.0 without retaining the 6.0 environment
Procedure

1. Before uninstalling Orchestration Designer 6.0, create a backup copy of the projects
in your workspace.

2. Uninstall Orchestration Designer 6.0 by using Control Panel > Add or Remove
Programs.
Depending on the location of your workspace, your projects can be removed by the
uninstall process.

3. Install Orchestration Designer 7.0 and the supporting software.
For more information, see Software requirements on page 16 and Installing
Orchestration Designer manually on page 19.

4. Copy the Orchestration Designer 6.0 projects from the backup into the
Orchestration Designer 7.0 workspace.
It is a good idea to keep copies of your old backups in the event that there are errors
while upgrading.

5. Import each project into Orchestration Designer 7.0.
The system converts the projects for Orchestration Designer 7.0.

6. If you use a source control system, create a branch or store the 7.0 application in
a different location so that the old 6.0 application can be maintained in the future.

 Note:
After creating a new workspace during an upgrade, click Window > Preferences
to configure your preferences before importing the old projects. For more
information, see Preference settings configuration on page 24.

About Orchestration Designer patch updates
At this time, Avaya does not automatically alert you about the availability of new patches for
Orchestration Designer. Therefore, periodically check the Avaya support Web site for the
availability of patches. Or, as an alternative, use the Eclipse update mechanism to check for
available updates.
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The following sections describe the steps for installing Orchestration Designer patches:

• Before installing an Orchestration Designer patch update on page 37

• Installing an Orchestration Designer patch update on page 37

 Note:
The procedure described in the Installing an Orchestration Designer patch update on
page 37 section is for installing patches or updates to a released software, and not
for upgrading software versions completely. For upgrading the software, see About
Orchestration Designer 6.0 to Orchestration Designer 7.0 upgrade on page 34.

Before installing an Orchestration Designer patch update
Before installing a patch update, back up all files in the default /eclipse installation directory,
as well as all files in the designated /workspace directory (if not a subdirectory of /eclipse).
Backing up your files helps you to revert an update.

To continue using the older version for existing applications, perform a “clean installation” of
the new version in a new directory.

 Caution:
When opening an application created with a prior release of Orchestration Designer,
Orchestration Designer prompts you to update the project to the new version. For project
conversion considerations, refer to the Release Notes.

Installing an Orchestration Designer patch update
About this task
Orchestration Designer patch updates are released through the Avaya Support Web site. You
can gain access to these updates from within the Eclipse user interface (UI).

 Note:
The procedure described in this section is for installing patches or updates to a released
software, and not for upgrading software versions completely. For upgrading the software,
see About Orchestration Designer 6.0 to Orchestration Designer 7.0 upgrade on page 34.

Procedure

1. On the Help menu, click Install New Software.

2. In the Install dialog box, clear the Contact all update sites during install to find
required software check box.

About Orchestration Designer patch updates
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3. In the Work with field, click the Orchestration Designer patch update Web site name
that you specified.

 Note:
Be sure that the Orchestration Designer patch update Web site is added to
Eclipse. For more information, see Adding the Web site for Orchestration
Designer patch updates on page 38.

 Note:
If you are unable to connect to the update Web site, ensure that you have
correctly configured the proxy settings. The system automatically checks for the
Orchestration Designer patch updates. If patches or updates are found, the
search mechanism returns the results.

4. In the middle pane, select the Orchestration Designer patch updates that you want
to install, click Next, and then follow the prompts.

 Caution:
You can use the Eclipse Install New Software mechanism for features besides
Orchestration Designer. To ensure that you install compatible features, Avaya
recommends that you update only the Orchestration Designer features.

If you are not sure which updates to install or if you have questions about the
installation procedure, contact Avaya Support at http://support.avaya.com.

Adding the Web site for Orchestration Designer patch updates
About this task
To get Orchestration Designer patch updates, you must add the Orchestration Designer patch
update Web site to Eclipse.

Procedure

1. Perform one of the following actions:

• On the Help menu, click Install New Software, and then click the Available
Software Sites link.

• On the Window menu, click Preferences.

2. In the Preferences dialog box, double-click Install/Update.

3. Click Available Software Sites.

4. In the Available Software Sites pane, click Add.

Installation and configuration

38     Getting Started with Avaya Aura® Orchestration Designer December 2013
Comments? infodev@avaya.com

http://support.avaya.com
mailto:infodev@avaya.com?subject=Getting
Started with Avaya Aura® Orchestration Designer


5. In the Add Site dialog box, in the Name field, type a name for the Orchestration
Designer patch update Web site. For example, AAOD.

6. In the Location field, type http://support.avaya.com/
OrchestrationDesigner/SS/Updates/.

7. Click OK.

Installing the AACC OD plug-in in Orchestration Designer
Application Development Environment

About this task
You must install the AACC-OD plug-in on the Contact Center Manager Administration (CCMA)
Server to match with the version of the Avaya Aura® Contact Center Server.

 Note:
Be sure that you can access the CCMA server from the computer where Orchestration
Designer is installed.

If you are unable to connect to the CCMA server from Orchestration Designer, add the host
address of the CCMA server to the list of host addresses that Orchestration Designer must
ignore in the Orchestration Designer proxy settings. For more information, see Enabling an
HTTP or HTTPS proxy connection on page 26.

Perform the following steps to ensure that the AACC plug-in works with Orchestration Designer
7.0:

Procedure

1. Install Orchestration Designer.

2. (Optional) Perform the following steps if JRE 7.0 is not already installed:

a. Install JRE 7.0.
b. Copy the geronimo-jaxws_2.2_spec-1.0.jar and jaxb-

api-2.2.1.jar files to the JRE\lib\endorsed directory to configure
Eclipse to use JRE 7.0.

3. On the CCMA server, share the following folder D:\Avaya\Contact Center
\SCE_Server\update.

4. On the Orchestration Designer system, open a network drive and point it to the
shared drive on the CCMA server.

5. Open the Eclipse interface and click Help > Install new software .

6. In the Install wizard, click Add.

Installing the AACC OD plug-in in Orchestration Designer Application Development Environment
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7. On the Add Repository dialog box, click Local, select the network drive created in
step 4, and click OK.
The Install wizard shows the new version of AACC OD that is available for
download.

8. Click Select All and click Next twice.
The Avaya Software License Agreement is displayed.

9. Click I accept the terms of the license agreement and click Finish.

10. When the installation is complete, click OK to restart Eclipse.

Upgrading the Avaya Aura® Contact Center plugin in
Orchestration Designer

About this task

 Note:
Be sure that you can access the Contact Center Manager Administration (CCMA) server
from the computer where Orchestration Designer is installed.

If you are unable to connect to the CCMA server from Orchestration Designer, add the host
address of the CCMA server to the list of host addresses that Orchestration Designer must
ignore in the Orchestration Designer proxy settings. For more information, see Enabling an
HTTP or HTTPS proxy connection on page 26.

Procedure

1. On the CCMA server, share the \\Avaya\Contact Center\SCE_Server
\update folder.

2. On the computer where Orchestration Designer is installed, map a network drive to
the folder that you shared on the CCMA server. See Step 1.

3. Launch Orchestration Designer.

4. On the Help menu, click Install New Software.

5. In the Install wizard, click Add.

6. In the Add Repository dialog box, click Local.

7. In the Browse For Folder dialog box, browse to the folder that you mapped, and
then click OK. See Step 2.

8. In the Add Repository dialog box, click OK.
The system shows the latest version of Avaya Aura Orchestration Designer Contact
Center in the middle pane of the Install wizard.

Installation and configuration
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9. Select the check box that corresponds to the Avaya Aura Orchestration Designer
Contact Center version that you want to update, and then click Next.

10. On the Install Details page, verify the features that you want to update, and then
click Next.

11. On the Review Licenses page, click I accept the terms of the license
agreement, and then click Finish.

12. On the Selection Needed page, select the certificates, and then click OK.

13. In the Software Updates dialog box, click Restart Now to restart Eclipse.

Upgrading the Avaya Aura® Contact Center plugin in Orchestration Designer
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Glossary

AACC Avaya Aura® Contact Center.

AAEP Avaya Aura® Experience Portal

AAS Avaya Application Simulator.

ADR See application detail record (ADR)  on page 43.

AMS Avaya Media Server.

ANI See automatic number identification (ANI)  on page 43.

API See application program interface (API)  on page 43.

application detail
record (ADR)

Data records which contain historical information about an application
used as part of a session. These records include information such as the
session ID number, a timestamp, and a “friendly name” string determined
by the developer who created the application.

application
program interface
(API)

A set of routines, protocols, and tools for building software applications.
A good API makes it easier to develop a program by providing all the
building blocks.

application server A computer on which the Orchestration Designer speech application
resides and runs. This computer is also where the Orchestration
Designer run-time libraries are installed, thus making it possible to run
Orchestration Designer applications on that server. The IVR system must
be configured to start the speech application from this location.

ASR See automated speech recognition (ASR)  on page 43.

automatic number
identification (ANI)

A service that provides the originating telephone number of a call coming
in to the system.

automated speech
recognition (ASR)

Technology that employs a computer to recognize spoken words and
respond appropriately.

call flow As implemented in speech applications, the call flow determines how a
call is handled when it enters an interactive voice response system,
based on options offered to callers and their responses to those
options.

CCXML Call Control eXtensible Markup Language.
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An emerging XML specification, being developed to work in conjunction
with VoiceXML and which addresses some of the technical limitations of
VoiceXML. It enables the processing of asynchronous events, filtering
and routing of incoming calls, and placement of outbound calls. Note that
it is not intended to replace VoiceXML but rather to supplement it. See
Ian Moraes’s excellent article, “VoiceXML, CCXML, SALT: Architectural
Tools for Enabling Speech Applications,” on the Internet.

Computer
Telephony
Integration (CTI)

Software technology that integrates the use of telephones and
computers without the need for special telephones, connectors,
computer circuit packs, or other specialized hardware.

CTI See Computer Telephony Integration (CTI)  on page 44.

dialed number
identification
service (DNIS)

A service that identifies for the receiving system what telephone number
was dialed by the caller. In theAvaya Aura® Experience Portal system
this is often used to direct the call to a particular speech application,
which is identified with that dialed number.

DNIS See dialed number identification service (DNIS)  on page 44.

DTMF See dual tone multi-frequency (DTMF)  on page 44.

dual tone multi-
frequency (DTMF)

The system used by touchtone telephones, DTMF assigns a specific
frequency (consisting of two separate tones) to each telephone key on
the keypad, so that it can easily be identified by a microprocessor.

Eclipse A Java-based open-source extensible IDE (integrated development
environment) that provides application developers a feature-rich
interface to develop their applications. Orchestration Designer is
designed as a set of Eclipse plug-in modules that make it possible for
application developers to design and build speech applications without
having to write the code manually.

gateway A network point that acts as an entry point to another network. In the
context of Orchestration Designer and VoIP applications, a gateway is
the entry point, often associated with one or more switches, to the
interactive voice response (IVR) system application environment. See 
interactive voice response (IVR) system  on page 45.

grammar Elements that recognize the input received through inbound voice calls
and messages.

In the context of IVR or speech applications, a grammar is a predefined
set of words or DTMF tones that a speech application uses in conjunction
with automated speech recognition (ASR) technology to interpret and
respond to caller inputs. That is, grammars are lists of possible
responses that callers make when responding to prompts by using

Computer Telephony Integration (CTI)
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spoken replies. Grammars define which words or phrases the ASR
engine can recognize and respond to.

In the context of text-based applications, a grammar is a predefined set
of words in a message application that a text-processing system can use
to interpret and respond to an inbound SMS or email message. The text-
processing system collects and recognizes the input from inbound SMS
and email messages and uses this input to direct the flow of a message
application.

H.323 A hierarchical, IP-based telephony standard for connecting IP
telephones and speech applications to switches.

IC See Interaction Center (IC)  on page 45.

IDE See integrated development environment (IDE)  on page 45.

integrated
development
environment (IDE)

A software application that usually provides a GUI environment, a text
and/or code editor, a compiler and/or interpreter, and a debugger. This
environment means that application or web developers can develop, test,
and build their applications or Web sites within a single integrated
space.

Interaction Center
(IC)

A multichannel contact management platform that enables businesses
to align real-time contact center operations with business objectives.

interactive voice
response (IVR)
system

A system, such as Avaya Aura® Experience Portal or Avaya IR, in which
callers interact with a self-service application to get information, conduct
transactions, or help with problems.

IVR system See interactive voice response (IVR) system  on page 45.

JDBC An application program interface (API)  on page 43 specification in which
programs written in Java connect with and access data contained in
database programs using Structured Query Language (SQL)  on
page 47.

localization The process of modifying an application to operate and be understood
in a different language, or locale. This usually involves modifying any
phrases, prompts, and grammars associated with an application.

MAS Avaya Media Server.

MPS Media Processing Server.

MRCP Media Resource Control Protocol.

NDM See Nuance Dialog Module (NDM) on page 46.

NDM
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notebook (Also known as a tabbed or stacked notebook) In the Eclipse context, a
notebook is a set of views “stacked” on top of one another as a space
saving measure. The views in the notebook are accessible by clicking
tabs arranged along the top of the notebook. See the Eclipse
documentation.

Nuance Dialog
Module (NDM)

Speech application modules produced by Nuance software products,
similar to speech application modules created by using Orchestration
Designer. You can use NDMs in the Orchestration Designer speech
applications. Orchestration Designer supports NDM version 5.0 and
later.

Before version 5.0, Nuance Dialog Module (NDM) was known as Open
Speech Dialog Module (ODSM).

See Open Speech Dialog Module (OSDM)  on page 46.

Open Speech
Dialog Module
(OSDM)

Speech application modules produced by Nuance software products,
similar to application modules created with Orchestration Designer.
OSDMs can be used in Orchestration Designer applications.
(Orchestration Designer supports the following OSDM versions: Address
OSDM 2.0.3, Core OSDM 2.0.4, and Name OSDM 2.0.1.)

OSDM is renamed to Nuance Dialog Module (NDM) from version 5.0 and
later.

OSDM See Open Speech Dialog Module (OSDM)  on page 46.

palette In the Orchestration Designer Editor views, this is the pane to the left of
the view, in which editor options are displayed and selected.

Real-time Transfer
Protocol (RTP)

A protocol for transmitting “real-time” data, such as audio or video data,
across the Internet. This protocol does not guarantee “real-time” delivery
of such data, but it does provide mechanisms to support data
“streaming.”

RTP See Real-time Transfer Protocol (RTP)  on page 46.

RTSP The Real Time Streaming Protocol, serves as a control protocol, and as
a jumping off point for negotiating transports, such as RTP, multicast and
unicast, and negotiating codecs off of servers in a file format independent
way.

SCE See service creation environment (SCE)  on page 46.

service creation
environment
(SCE)

A set of software tools used to develop, test, and debug speech
applications. Orchestration Designer is an SCE.

servlet A small program that runs on a server, often Java-based.

notebook
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servlet engine A program that coordinates the overall operation and integration of a
number of servlets. In the context of Orchestration Designer, the
supported servlet engines are Apache Jakarta Tomcat, IBM WebSphere/
WebSphere Express, Oracle WebLogic, and JBoss AS7.

Session Initiation
Protocol (SIP)

A signaling protocol for the Internet that makes it possible to set up
conferencing, telephony, events notification, and instant messaging.
Within a VoIP framework, it initiates call setup, routing, authentication, to
endpoints within an IP domain.

SIP See Session Initiation Protocol (SIP)  on page 47.

speech
recognition

See automated speech recognition (ASR)  on page 43.

speech synthesis See text-to-speech (TTS)  on page 48.

speech user
interface (SUI)

Any software interface in which the user interacts with the system using
speech commands and audio prompts.

SQL See Structured Query Language (SQL)  on page 47.

SSL Secure Sockets Layer.

A protocol for transmitting private data securely over the Internet. By
convention, URLs that use SSL require a connection using the HTTPS
protocol, rather than just HTTP.

SSML Speech Synthesis Markup Language.

A W3C standard designed to provide an XML-based markup language
for assisting with the generation of synthetic speech in Web and other
applications. The essential role of the markup language is to provide
authors of synthesizable content a standard way to control aspects of
speech such as pronunciation, volume, pitch, rate, and so forth, across
different synthesis-capable platforms.

stacked notebook See notebook  on page 46.

Structured Query
Language (SQL)

A standard interactive and programming language for getting data to and
from a database.

SUI See speech user interface (SUI)  on page 47.

tabbed notebook See notebook  on page 46.

TDD See Telecommunications Display Device (TDD)  on page 48.

TDD
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Telecommunicatio
ns Display Device
(TDD)

Sometimes designated as a teletypewriter (TTY) device, a telephone
equipped with a keyboard and display, used by hearing- or speech-
impaired callers to send and receive typed messages.

telephone user
interface (TUI)

Any software interface in which the user interacts with the system using
a telephone or similar device.

teletypewriter
(TTY) device

See Telecommunications Display Device (TDD)  on page 48.

text-to-speech
(TTS)

Technology by which information in text format is rendered as audio
output using a speech synthesis engine to simulate human speech.

TTS See text-to-speech (TTS)  on page 48.

TTY See Telecommunications Display Device (TDD)  on page 48.

TUI See telephone user interface (TUI)  on page 48.

VoiceXML (Sometimes presented as VXML) Voice eXtensible Markup Language.

A specification which provides for a user to interact with Internet-based
resources using voice recognition technology. Instead of a typical Web
browser that requires a combination of HTML, keyboard, and mouse
device, VoiceXML relies on an Internet voice browser and/or telephone.
Using VoiceXML, the user interacts with the Web “page” by listening to
audio outputs (either pre-recorded or using a technology such as TTS)
and by submitting input in the form of the user’s natural speaking voice
and/or manual responses, such as telephone key presses.

Web service A standardized way of offering Web-based applications or services.
Because Web services are Web-based and standards-based
applications, delivered over the Internet, Web services make it possible
for organizations to communicate and share data that use different file
formats and programming languages.

workspace In Orchestration Designer, the area within the Editor view used to build
the functionality for the selected editor. For example, in the Call Flow
Editor, this is the space to the right of the palette, in which you drag the
nodes that represent application functions.

See palette  on page 46.

WSDL Web services Description Language.

An XML-formatted language used to describe a Web service’s
capabilities.

XML eXtensible Markup Language.

Telecommunications Display Device (TDD)
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A specification for the presentation of Internet documents, one which
expands on the capabilities of HTML. A pared-down version of SGML
(Standard Generalized Markup Language), XML makes it possible for
designers to create their own customized tags, which in turn makes it
possible to do things over the Internet that cannot be done using simple
HTML.

XML
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