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Chapter 1: Introduction

Purpose
This document provides deployment checklists and procedures for installing and configuring
a reference configuration. It also describes initial administration and basic maintenance
checklists and procedures.

Intended audience
This document is intended for personnel who deploy a verified reference configuration at a
customer site.

Document changes since last issue
The following changes have been made to this document since the last issue:

• Information about the Setup Wizard has been updated. Some procedures have been
removed from the document because those steps have been automated within the Setup
Wizard..

Related resources

Documentation
See the following related documents at http://support.avaya.com.
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Title Use this document to: Audience
Planning

Avaya IP Office Contact Center
Reference Configuration

Understand tested characteristics
and capabilities including
interoperability, performance
specifications, security, and licensing
for planning purposes.

Avaya
BusinessPartners
Avaya Sales

Implementation

Deploying IP Office Server
Edition Solution

To install, configure, and administer
the Server Edition.

Avaya
BusinessPartners
Avaya Sales

Installing Contact Recorder for
IP Office

Install and configure Contact
Recorder.

Avaya
BusinessPartners
Avaya sales
personnel

Installing IP500/ IP 500 V2 Install and configure IP 500 V2.

 Note:
IP Office Contact Center does not
support IP 500 V1.

Avaya
BusinessPartners
Avaya sales
personnel

Avaya IP Voice Quality Network
Requirements

Define the network segment between
IP Office Contact Center and IP
Office.

Avaya
BusinessPartners
Avaya sales
personnel

Administration

Installing Contact Recorder for
IP Office

Perform system administration
tasks.

System
administrators

Using Avaya IP Office Contact
Center Configuration Tool

Perform system administration
tasks.

System
administrators

Using Avaya IP Office Contact
Center Task Flow Editor

Perform system administration
tasks.

System
administrators

Using Avaya IP Office IVR
Editor

Perform system administration
tasks.

System
administrators

Using Avaya IP Office User
Interface Textblock
Administrator

Perform system administration
tasks.

System
administrators

User Guides

Using Avaya IP Office Contact
Center User Interface

Use the system features. Contact Center
agents

Introduction
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Contact Center
supervisors
System
administrators

Using Contact Recorder for IP
Office

Understand how to use Contact
Recorder

Contact Center
agents
Contact Center
supervisors
System
administrators

References

Avaya IP Office Task Reporting
Reference

Understand how to use Task
Reporting.

Contact Center
supervisors
System
administrators

Avaya IP Office Contact Center
Statistics Counter Reference

Understand how to use the Statistics
Counter function.

Contact Center
supervisors
System
administrators

Avaya IP Office Contact Center
xStat Server Reference

Understand how to use the xStat
Server function.

Contact Center
supervisors
System
administrators

Avaya IP Office Contact Center
Task Tags Reference

Understand the Task Tags and how
to reference them.

Contact Center
supervisors
System
administrators

Avaya Mentor videos
Avaya Mentor videos provide technical content on how to install, configure, and troubleshoot
Avaya products.

About this task
Videos are available on the Avaya Support website, listed under the video document type, and
on the Avaya-run channel on YouTube.

• To find videos on the Avaya Support website, go to http://support.avaya.com, select
the product name, and check the videos checkbox to see a list of available videos.

• To find the Avaya Mentor videos on YouTube, go to http://www.youtube.com/
AvayaMentor and perform one of the following actions:

- Enter a key word or key words in the Search Channel to search for a specific
product or topic.

Related resources
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- Scroll down Playlists, and click the name of a topic to see the available list of videos
posted on the site.

 Note:
Videos are not available for all products.

Support
Visit the Avaya Support website at http://support.avaya.com for the most up-to-date
documentation, product notices, and knowledge articles. You can also search for release
notes, downloads, and resolutions to issues. Use the online service request system to create
a service request. Chat with live agents to get answers to questions, or request an agent to
connect you to a support team if an issue requires additional expertise.

Introduction

10     Deploying IP Office Contact Center February 2014
Comments? infodev@avaya.com

http://support.avaya.com
mailto:infodev@avaya.com?subject=Deploying IP Office Contact Center


Chapter 2: Deployment process

The following flow chart illustrates the deployment process.
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Deployment process
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Chapter 3: Avaya IP Office Contact Center
overview

Avaya IP Office Contact Center provides inbound capabilities for contact centers that support 5 to 100
agents and supervisors. The system includes the following key features:

• Integrated contact center voice, email, and chat

• Supports a virtualized server environment

• Uses TCP and CORBA for stable and reliable communication

• Unified database access for all processes

• Unified tracing and logging for all components

• Easy to install and update

• Same interface for supervisor and agent with permission-based feature access

• Flexible routing with graphic interface for voice, email and chat in one task flow

• Integrated Voice Response

• Real-time statistics with interaction

Components

Component Version Platform Description
Infrastructure

IP Office Contact
Center server

9.0.2 Supplied by
Avaya
BusinessPartner.

Contains:

• IP Office Contact Center

• Sybase ASE

• IP Office Contact Center
databases

• Unified Media email
components
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Component Version Platform Description

• Interactive Voice
Response (IVR)
components

• Software drivers

IP Office server 9.0.2 IP500V2 for (1 to
30 agents)
or
IP Office Server
Edition server (1
to 100 agents)
or
Virtual Machine

Functions as a call center
solution for telephony tasks
and Voicemail Pro.
Must be the primary server
and can be used for other
nodes.
The system does not require
IP Office to process
applications such as email
and chat.

Extensible
Messaging and
Presence
Protocol (XMPP)
application server

Avaya supports the
following XMPP
servers:

• Jive Software®

Openfire 3.7.1

• Prosody 0.8.2

• ProcessOne
ejabbered 2.1.10

Server platform
provided and
maintained by the
customer

Chat functionality

Endpoints

Avaya 1400
series deskphone

Avaya 1600
series deskphone

Avaya 9500
series deskphone

Avaya 96x1
(H.323)
deskphone

6.2

Avaya 96x0
(H323)
deskphone

6.2

Applications

IP Office Contact
Center

9.0.2 IP Office Contact
Center Server

Includes:

• WebLM and license
clients

• Java Development Kit

Avaya IP Office Contact Center overview
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Component Version Platform Description

• Contact Center Tomcat

• Naming service

• Trace system

• Watchdog

• Service tools

• UI Session Manager

• Common Hardware
Abstraction Platform
(CHAP)

• PBX task server

• IP Office Task server

• Contact Center
applications

• IVR components

• Address Book server

• UM

• Statistics generator and
viewer

• Web Service Collection

Sybase ASE 15.5 IP Office Contact
Center server

• Contact Center (cc)
database

• Task Reporting (tr)
database

• Address book

• Chat (mediastore)
database

• UM (c3k) database

• UM Archive database

Administrator,
supervisor and
agent client
application

Microsoft® Windows
7, Windows 8.1, or
Windows Terminal
Server client
Internet Explorer 10

Provided by the
customer

Permission-based feature
access

Other software

Microsoft Excel
Adobe acrobat
reader

Provided by the
customer

To create the
Dataimport.exe and .csv
files.

Components
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Component Version Platform Description
To read the documentation.

Avaya IP Office Contact Center overview
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Chapter 4: Site preparation checklist

# Task Description Notes

1 Ensure all physical
components are
available on the
customer network.

IP Office Contact Center
server
IP Office server
XMPP server (optional for
chat functionality)
Agent workstations
Telephones

See platform requirements.

2 Ensure that the
additional hard disk
drives for IP Office
server type are
available. (Optional,
only if you want to use 
Contact Recorder on
page 53)

IP Office Server Edition
IP 500 V2

 Note:
IPOCC does not
support IP 500 V1
server.

For information about the
hard disk drive types
download the documents
from the HP support site or
Dell support site.
For information about adding
additional hard disk drives
see, Contact Recorder on
page 53.
For information about
deploying IP Office Server
Edition see, Deploying IP
Office Server Edition
Solution.
For information about
installing IP 500 V2 see,
Installing IP500/ IP 500 V2.

 Note:
To Ignite the additional
hard disk drive for Contact
Recorder see, Contact
Recorder on page 53.

3 Telephony and internet
services are in place.

Service Providers
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IP Office Contact Center server requirements
The requirements are as follows:

Operating system Microsoft® Windows Server 2008 R2 Standard 64–bit Edition SP1

Microsoft® Windows Server 2012 R2 Standard 64–bit Edition

Processor Intel Xenon E3 Quadcore 3.1 GHz

Memory 8 GB DDR3 ECC

Hard drive 1 Seagate ST500DM002 500 GB 7200 RPM, SATA 6 G 16 MB Cache

 Note:
Avaya recommends you to add an additional 500GB Hard Disk Drive
and RAID to support IP Office Contact Center.

Raid controller Raid Controller Intel C202 onboard
Disk space
allocations

- 500 GB disk space for complete OS, databases, and applications

Media DVD-ROM drive

Keyboard Multifunction keyboard

Network 1NIC 1 GB, network or Ethernet card

 Note:
IP Office Contact Center supports only one NIC. If you have multiple
NICs disable all the other NICs.

Agent workstation requirements

Processor Intel Pentium 4 processor 2.2 GHz or higher

Operating system Microsoft® Windows 7, or Windows 8.1
Memory Minimum 4 GB RAM

Hard disk Minimum 10 GB

Site preparation checklist
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Keyboard and mouse Multifunction keyboard and mouse
Browser Microsoft® Internet Explorer 8.x or higher

Mozilla Firefox 3.6 or higher

Network Ethernet card

Agent workstation requirements
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Chapter 5: Planning checklist

Plan for installation and configuration by meeting with the customer to collect site-specific information and
network information and to ensure that they are prepared for delivery and installation.

# Task Description Notes

1 Download documents
from the Avaya Support
Site Documents and
Downloads.

Use the planning
documents to ensure the
customer site is prepared
and use forms to gather
customer site-specific
data.

On the Avaya Support Site,
in the Enter Your Product
Here field, type IP
Office Contact
Center.

2 Complete the Avaya IP
Office Contact Center
Configuration
Worksheet.

Customer data includes:

• Server information

• Agent information

• Job codes

• Topic assignments

Download and use the
Microsoft® Excel
spreadsheet as a template.

3 Download the
documents from the HP
support site or Dell
Support site.

Use the respective guides
to add an additional hard
disk drive for Contact
Recorder.

4 Download documents
from the Avaya Support
Site Documents and
Downloads.

Use the planning
documents to install and
configure the IP Office
Server Edition or IP 500
V2

On the Avaya Support Site,
in the Enter Your Product
Here field, type IP
Office.

5 Plan endpoint
deployment.

Avaya 1400 series phone
Avaya 1600 series phone
Avaya 9500 series phone
Avaya 96x1 (H.323)
deskphone
Avaya 96x0 (H.323)
deskphone

6 Ensure customer has
required components.

XMPP server
Agent workstations

Use the Site preparation
checklist.
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Key customer configuration information

Using the IP Office Contact Center Configuration Worksheet
The worksheet is a Microsoft® Excel spreadsheet that captures and organizes customer site
information used by the installer during system configuration tasks. Each tab in the workbook
corresponds to an aspect of the system configuration.

Before you begin
Copy the Avaya IP Office Contact Center Configuration Worksheet from the IPOCC_DVD and
save it on a computer with Microsoft® Excel. Typically, Avaya IP Office Contact Center
Configuration Worksheet is located at Utilities.

About this task
Use the worksheet to collect customer configuration data and create export files for server
configuration.

Procedure

1. Open the spreadsheet .

2. Enable macros.

 Important:
Save the spreadsheet as .xlsm format to enable macros.

3. Use Save as to make a copy with a unique name for the customer.

4. Read the instructions on the Brief Instruction tab of the work sheet before you fill
in the required information, marked in red (mandatory field), within each tab.
The spreadsheet populates fields in the other tabs. For more information see, 
Important fields of the configuration worksheet on page 23.

The Change me fields in the spread sheet are optional, used for configuring the
chat and email.

5. Click Create Data Import to generate data import files.

Next steps
During configuration you need the DataImport.exe for IP Office Contact Center Server and
configuration.csv for IP Office.

Planning checklist
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Related topics:
Important field descriptions of the configuration worksheet on page 23

Important field descriptions of the configuration worksheet

 Note:
The following table lists only the minimum required fields that you need to fill in the
configuration worksheet. For more details, lookup the tool tips in the configuration
worksheet.

Name Description

Base Data tab Type the following:

• Name of the IP Office Contact Center

• Name of the chat server

• Chat and E-mail domain name. For
example, customer.com
(optional)

 Note:
Check the number range of topics. If you
make any change you must also update
the change in the Topics tab.

Chap tab Type the following ip address:

• IP Office Contact Center server

• IP Office

• DNS

• SIP domain

 Note:
The name of the SIP domain must be the
same as the SIP domain name in System
> LAN1 > VOIP tab of the IP Office
configuration. The name of the SIP
domain must be in lower case.
Verify the number for the SIP extensions.
Do not use this number in the IP Office. If
necessary change the partitioning of the
channels for Queuedevices and IVR. For
Queuedevices automatically the range
70000-70059, for IVR Ports 80000-80029
is used.

Key customer configuration information
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Name Description

Topic tab Type the topic details.

Agent groups tab Type the agent group details.

Agents tab Type the agent details.

Topic-AG-Assigment tab Type the topic and agent assignment
details.

Packaging and order codes
The following IP Office Contact Center license bundles are available:

Material code Description

306493 IP Office Contact Center Base 30

306640 IP Office Contact Center Base 100

306495 IP Office Contact Center 1 voice agent license with skills based
routing and call recording

306496 IP Office Contact Center 1 Multichannel License with email, chat and
outbound campaigns

306497 IP Office Contact Center 1 Supervisor License

306641 IP Office Contact Center Base 30 to Base 100 migration

IP Office Contact Center Base 30 bundle
IP Office Contact Center:

 Note:
Use Avaya WebLM to install the PLDS license.

PLDS license Description

VALUE_CIE_PX_IPO (1) Single PBX connection — IP Office

VALUE_CIE_IVR_CON (1) 1 CHAP port

VALUE_CIE_IVR_PORT (Channels 90) 90 channels (maximum for 32–bit CHAP)

VALUE_CIE_CC_CLIP 10000 addresses

VALUE_CIE_CC_TEAMLEADER (1) Enables supervisor application in UI for
preconfigured monitors and reports

VALUE_CIE_CC_SERVUSER (2) 2 concurrent service users needed for
configuration

Planning checklist
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PLDS license Description

VALUE_CIE_CC_UMR Required by C3000 server for email routing

VALUE_PHX_BASE 30 LIC Allows up to 30 agents to be active and
logged in

IP Office:

ADI license Description

CTI Pro License Enabled third-part TAPI license

VMPro Recording Administrators Enables Contact Recorder

Avaya IP Endpoint License For CHAP connection

Also requires IP Office Preferred Edition.

IP Office Contact Center Base 100 bundle
IP Office Contact Center:

 Note:
IP 500 V2 does not support the IP Office Contact Center Base 100 bundle.

PLDS license Description

VALUE_CIE_PX_IPO (1) Single PBX connection — IP Office

VALUE_CIE_IVR_CON (1) 1 CHAP port

VALUE_CIE_IVR_PORT (Channels 90) 90 channels (maximum for 32–bit CHAP)

VALUE_CIE_CC_CLIP 10000 addresses

VALUE_CIE_CC_TEAMLEADER (1) Enables supervisor application in UI for
preconfigured monitors and reports

VALUE_CIE_CC_SERVUSER (2) 2 concurrent service users needed for
configuration

VALUE_PHX_BASE 100 LIC Allows up to 100 agents to be active and
logged in

VALUE_CIE_CC_UMR Required by C3000 server for email routing

IP Office:

 Note:
Use IP Office Manager for Server Edition to install the license for IP Office Server Edition
and use IP Office Manager to install the licenses for IP 500 V2.

ADI license Description

CTI Pro License Enabled third-part TAPI license

Packaging and order codes
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ADI license Description

VMPro Recording Administrators Enables Contact Recorder

Avaya IP Endpoint License For CHAP connection

IP Office Contact Center 1 voice agent license with skills based routing and call
bundle
IP Office Contact Center:

PLDS license Description

VALUE_CIE_CC_USER_VOICE 1 license for each logged in telephony agent

VALUE_CIE_CC_MONTELUSER Extended voice features, 1 license for each
logged in telephony agent

IP Office:

ADI license Description

Preferred Edition Additional VoiceMail Ports Needed for 100% call recording

Also requires IP Office Preferred Edition.

IP Office Contact Center 1 multichannel agent license with email, chat and
outbound campaign bundle
IP Office Contact Center:

PLDS license Description

VALUE_CIE_CC_USER_CHAT 1 license for each logged in chat agent

VALUE_CIE_CC_USER_NONVOICE 1 license for each logged in email agent

VALUE_CIE_CC_TEXTMODULES 1 license for each agent for email textblocks

IP Office: None.

IP Office Contact Center 1 supervisor license bundle
This bundle includes the licenses in bundles 306495 and 306496 plus the following license:

IP Office Contact Center:

PLDS license Description

VALUE_CIE_CC_SUPERVISOR 1 license for supervisor functions and
configuring monitors and reports

VALUE_CIE_CC_TEAMLEADER 1 licence for using pre-configured realtime
and reports

IP Office: None.

Planning checklist
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IP Office Contact Center Base 30 to Base 100 migration bundle

PLDS license Description

VALUE_PHX_BASE 100 LIC Allows up to 100 agents to be active and
logged in

Related topics:
Installing Sybase Adaptive Server Enterprise on page 31

Packaging and order codes
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Chapter 6: Initial setup and connectivity

Software installation checklist

# Task Description Notes

1 Install the Microsoft®
Windows operating
system.

Microsoft® Windows Server 2008
R2 SP1, or Windows Server 2012
R2

2 Copy the installation
files from the DVD.

Copy from IPOCC-DVD (.iso) the
complete folder Install_Sybase to
local folder (e.g. c:\install) on
IPOCC server.

3 Install Sybase® ASE. Set the system administrator
password.

4 Install Microsoft®
Windows TAPI.

Enter switch IP address and
password.

5 Install IP Office
Contact Center

After installing the server
components of IPOCC, import the
data using Dataimport.exe

Related topics:
Installing Microsoft Windows Server on page 29
Installing Sybase Adaptive Server Enterprise on page 31
Installing and configuring Microsoft® Windows TAPI on page 31
Installing IP Office Contact Center on page 33

Installing Microsoft Windows Server
Procedure

1. Disable Power Management functions.
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2. Activate daylight savings time when setting the system time to the local time
zone.

3. Use TCP/IP as the network protocol.

4. Define the computer name.
Only use digits and letters for the computer name. Do not use the underscore
character. Begin the name with a letter. The name can consist of up to 30
characters.

5. Do not activate SNMP.

6. Enable error reporting unless you are setting up a test system. If you are setting up
a test system, complete the following steps:

a. On the Control Panel, click System.
b. On the Advanced tab, click Error Reporting.
c. Select Disable error reporting.
d. Click OK.

7. Set up a permanent IP address.
IP Office Contact Center works only with one IP address. IP Office Contact Center
does not support multiple IP addresses on the same NIC.

8. Create a system user and password.

a. Grant the user administration privileges to start services.
You must also grant the user the rights to add scheduled tasks. The user needs
this rights to install the Sybase server.

b. For security reasons, do not use the same username and password for other
computers on the network.

9. Ensure that the service Windows firewall is functional.

 Note:
If you need to use a firewall, configure the firewall settings using the appropriate
ports. See Port assignments.

10. In the Power Options Properties dialog box, on the Power Schemes tab, set the
following settings:

a. Set Turn off hard disks to Never.
b. Set System standby to Never.

To add the server to the list of trusted sites go to Internet Explorer > Internet
Options > Security > Trusted sites: http://<hostname>

Initial setup and connectivity
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Installing Sybase Adaptive Server Enterprise
Before you begin

• Copy the complete folder Install_Sybase on your computer from the IPOCC-DVD
or .iso.

 Important:
Do not change the name of the Install_Sybase folder.

• Log in as the system administrator.

Procedure

1. Execute the SybaseDB.exe file.

2. In the Sybase ASE Installer dialog box, select the drive for the database server.

a. In the SQL server name field, accept the default setting.
b. In the Password for user sa field, type the new password for the system

administrator (sa) account.
The password must be a combination of numbers and letters and must be at
least eight characters long.

c. In the Confirm password field, type the new password again.
d. Do not change the default values under Page Size and Hardware

resources.

3. Click Install.
The system installs Sybase ASE in about 20 minutes. The system displays the
Installation successfully finished
message.

4. Click OK.

5. Restart the server.

Related topics:
Packaging and order codes on page 24

Installing and configuring Microsoft® Windows TAPI
Procedure

1. Navigate to the TAPI installation executable on the server.
Typically, it is located at \Server\IPO TAPI\tapiSetup.exe

Software installation checklist
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2. Right-click the file and click Run as administrator from the pop-up menu.
The system displays Select a User Name.

 Note:
The system displays the default User Name and User Password.

a. Click Next.
The system displays the TAPI2 — InstallShield Wizard.

b. Click Next.
The system displays the Select Networked Telephone System.

c. Select the IP Office control unit.
The system displays the Select a User Name window, with the default User
Name and User Password.

d. Click Next.
The system displays the Ready to Install the Program window.

e. Click Install.
The system prompts you to restart the system.

f. Click Yes.
The system restarts and displays the Resuming the InstallShield Wizard for
TAPI2 .

g. Click Next.
The system displays the InstallShield Wizard Completed.

h. Click Finish.

3. Click Start > Control Panel and select Phones and Modem.

4. Select My Location and click Edit.

5. In the Edit Location dialog box, type the country and area code for the customer
site and click OK.

6. In the Phone and Modem dialog box, click Advanced.

7. Select Avaya IPO TAPI2 Service Provider and click Configure

8. In the Avaya TAPI2 configuration dialog box, enter the following settings:

a. In the Switch IP Address field, type the IP address of the IP Office server.
b. In the Switch Password field, type the password of the IP Office server.

The default password of the IP Office server is password. If you have changed
the default password of the IP Office server, please type the new password that
you typed in Security Settings > System > Unsecured Interfaces > System
Password.

c. Click OK.
d. Click Close.
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Installing IP Office Contact Center
About this task

 Note:
The system requires 26 GB disk space to perform a complete install. All databases are
automatically set to Automatic Expansion, so the databases of IP Office Contact Center can
expand in case the system reaches the initial configured database size.

Procedure

1. Install vcredist_x86_2008.exe and vcredist_x86_2010.exe .
Typically, it is located in Server\IP Office Contact Center of the install
DVD.

2. Navigate to the IP Office Contact Center setup wizard on the server.
Typically, it is located in Server\IP Office Contact Center of the install
DVD.

3. Double click the SetupWizard.exe file.
The system displays the Avaya IP Office Contact Center — Setup Wizard dialog
box.

4. Click Complete.

5. In the Settings for Avaya IP Office Contact Center installation dialog box , type the
sa password.
Type the password that you set for sa user when installing the Sybase server.
The system displays the ip address of the server in the Network Adapter IP
address field. If the system does not display the ip address of the server that you
are currently using, then type the ip address of the server.

6. Click Install.
The system displays the list of components installed.

7. Click Finished.

8. Restart the server.
After the system restarts, Watchdog configuration runs automatically.

Next steps
Select Start >Programs > Avaya IP Office Contact Center > Trace System > TT Display
and verify that all the all components are running.

Software installation checklist
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 Note:
Unless you install the licenses, the component SMTPConnector for Runlevel 14 and IVR
services stop automatically and turns red in TTDisplay and the Watchdog restarts the
SMTPConnector for Runlevel 14 and IVR services.

Licensing

Installing licenses
Before you begin

• Obtain the license file from the Avaya Product Licensing and Delivery System (PLDS)
website at https://plds.avaya.com.

About this task
If you experience problems while installing the license file, see the License file installation
errors section in Administering Avaya WebLM (stand-alone).

Procedure

1. Open a browser on IPOCC Server and type https://<hostname>:8443/
WebLM connect to WebLM.

2. In the login page do the following:

• In the User Name field, type admin.

• In the Password field, type weblmadmin.

The password is case sensitive.
If you are logging into WebLM for the first time, the system prompts you to change
the password.
Use the same password that you set as Sybase sa password.

3. In the left navigation pane, click Install license.

4. On the Install license page, enter the license file path. You can also click Browse
to select the license file.

5. Click Install to install the license file. WebLM displays a message upon successful
installation of the license file. The installation of the license file can fail for various
reasons, such as:

Initial setup and connectivity
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• WebLM finds an invalid digital signature on the license file. If you get such an
error, request PLDS to redeliver the license file.

• The current capacity use exceeds the capacity in the installed license.

Next steps
Restart the IPOCC watchdog service.

Licensing
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Chapter 7: Configuration

Component configuration checklist

# Task Description Notes

1 Import configuration
data file.

Import the
DataImport.exe
file.

Activate the Task Flow
editor

2 Configure IP Office
for telephony.

Import the
Configuration.c
sv file.
General system
settings
SIP extensions

3 Configure Contact
Recorder (optional)

Add additional HDD or
RAID on the Server
Edition Server
Partition using the
Ignition process
Mount the partition

You can use Contact
Recorder to manage,
archive and search your
voicemail recordings.

 Note:
For more information
see, Avaya IP Office
Contact Recorder  on
page 53

4 Configure Unified
Media components
(optional)

POP3 and IMAP4
(optional)

5 Configure chat
components.

XMPP server
(Optional)

Related topics:
Importing the IP Office Contact Center configuration data file on page 38
Importing the IP Office configuration data file on page 42
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Importing the IP Office Contact Center configuration data
file

Before you begin

1. Complete all the steps in Using the IP Office Contact Center Configuration
Worksheet on page 22.

2.
 Important:

Back up the cc and c3k databases. For more information, see Backing up a
database on page 62.

Procedure

1. Copy the DataImport.exe file to any folder on the computer where the database
is installed.

2. Double click DataImport.exe.
The system displays the CCImportJobber dialog box.

3. In the DB User field, type sa.

4. In the Password filed, type the password you set for sa user.

5. Click Import Data.

6. Click Finish.

7. Restart the IPOCC server after you import.

Next steps
Activate the task flow editor.

Related topics:
Activating task flow editor on page 38

Activating task flow editor
Before you begin
Select Start > Programs> Avaya IP Office Contact Center > Trace System > TT Display
and verify that all the processes are running.

Configuration
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About this task
Procedure

1. Select Start > Programs> Avaya IP Office Contact Center > User Interface.
The system displays the Avaya IP Office Contact Center log in page.

2. Type Administrator in the Username field.

3. Type the password in the Password field.
The default password is Administrator.

4. Click Login.
The system displays IP Office Contact Center window.

5. Select Go To > Task Flow Editor.

6. Click the Open icon.
The system displays Open task flow set.

7. Select Import TF-Set.

8. Click OK.
The system displays the Password dialog box. You do not have to type the
password.

9. Click OK.

10. Click Activate.
The system displays Task Flow set successfully activated message.

11. Click OK.

12. In the Task flow set menu, click Close.

13. In the Task flow set menu, click Default task flow set.
The system displays the Use default task flow set dialog box.

14. Select Import TF-set and click OK
The system displays the Password dialog box. You do not have to type the
password.

15. Click OK.

IP Office telephony integration
IP Office Contact Center uses the PBX within the Avaya IP Office for telephony tasks. It uses
other processes for email and chat and is does not depend on IP Office for those services.

IP Office telephony integration
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 Important:
The network segment between IP Office Contact Center and IP Office must correspond to
the Avaya VoIP specification. For more information, see Avaya IP Voice Quality Network
Requirements.

The following elements are required to connect to IP Officeversion 9.0:

• CTI-Pro license

• Avaya SIP User License 150 channels

• Essential and Preferred Edition IP500V2 server

• Linux server edition

IP Office Contact Center uses the following elements to interact with the IP OfficePBX:

• Microsoft Telephony Application Programming Interface (TAPI)

• IP Office task server

• Voice Extension Adapter (VEA)

• Common Hardware Abstraction Platform (CHAP)

• Interactive Voice Response (IVR)

Microsoft Telephony Application Programming Interface
IP Office Contact Center uses TAPI as the programming interface for telephony applications.
The PBX uses a corresponding TAPI driver.

IP Office task server
The IP Office task server adapts the telephone-specific behavior of the TAPI and makes it
available to the kernel process and the business logical components (BLCs) within the user
interface.

Kernel process functions: The task server uses a standardized definition for voice and email
task servers so that the kernel process doesn’t have to differentiate between the individual
media types and PBX types. The kernel process is notified by the task server interface
regarding:

• Call routing
• Agent monitoring
• Device monitoring
• Pending topic calls

The kernel process uses the task server services to forward topic calls to the correct
destinations such as:

• Agents
• Topics or queue devices
• Announcement scripts

Configuration
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• Telephones and lines or external numbers
• IVR

User interface functions: The business logical components (BLCs) within the IP Office
Contact Center user interface uses the task server to control agent telephones. Task server
services are available to the control basic telephone functions such as:

• Connecting and disconnecting
• Consultation
• Holding
• Call waiting
• Forwarding
• Conferencing
• Call diversion

The task server also controls third-party contact center functions such as:
• Job code input
• Signing on and off of agent groups
• Switching on wrap-up time
• Switching on pause

Voice Extension Adapter
The VEA controls the contact center routing and queuing devices using IP channels. IP Office
Contact Center uses the VEA for the following task server functions:

• Signalling a topic call
• Queuing calls on the queue device
• Switching calls to announcement scripts

When there is a pending call at a routing device, the VEA signals it as a route request.

The task server notifies the kernel. The VEA receives the call destination determined by the
kernel and vector processes from the task server. The following destinations are possible:

• Available agent
• Queue without announcement
• Queue with announcement through CHAP

When a call switches to a CHAP announcement, VEA routes the call to one of the queue
devices. Queue devices are VoIP channels between IP Office and CHAP. The CHAP
sends the required announcements to the queue device.

• Queue with announcement through IVR

When a call switches to an IVR announcement script, VEA initiates a call transfer to a
IVR channel.

• External destination

The IP Office task server and VEA can establish multiple connections in parallel and make
them available for allocation to available agents to carry out power and predictive dialer

IP Office telephony integration
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functions. Once the connection has been established and the called subscribes has answered,
the connection can be transferred to an available agent.

Common Hardware Abstraction Platform
The CHAP provides a specific adapter in the form of a dynamic linked library (DLL) for SIP
over IP. The CHAP also plays announcements which are stored in the database as WAV files.
The CHAP is also capable of DTMF recognition. A CHAPSync process connects the database
and the CHAP. The CHAP does not connect to the database directly. CHAPSync registers
changes to the CHAP configuration data in the database and forwards the changes to the
CHAP. The CHAP writes the data to a local properties file.

Related topics:
IP Office server configuration checklist on page 42
Importing the IP Office configuration data file on page 42
Configuring IP Office on page 43

IP Office server configuration checklist
Configuring IP Office
Use IP Office Manager to complete the following configuration tasks.

# Task Description Notes

1 Import the data file. Configuration.csv
2 Configure general

system settings.
VoIP
SIP Register
DNS

Importing the IP Office configuration data file
Before you begin

Complete all the steps in Using the Avaya IP Office Contact Center Configuration
Worksheet on page 22.

 Note:
The short codes targeted for each Topic that you create must exist and be the same for the
Server Edition Secondary server and Server Edition Expansion System .

Configuration
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Procedure

1. Copy the configuration.csv file to any folder on the computer where you have
installed IP Office Manager.

2. Start IP Office Manager, and select the IP Office server.

3. Click File > Import/Export > Import.

4. Select Configuration .

5. Navigate to the location where you copied the configuration.csv file and select
it.

6. Click OK to import the file.

Next steps
Complete the steps in Configuring IP Office on page 43.

Configuring IP Office
Before you begin
Complete all the steps in Importing the IP Office configuration data file on page 42.

 Important:
To avoid restarting the TAPI service every time you add a user in IP Office who is also an
IPOCC user, Avaya recommends you to create a pool of users to be used by IPOCC
Agents. When you configure an Agent in IPOCC, the Agent can login as a user that you
have already reserved.

 Note:
After you create a pool of users you must restart the TAPI service on the IPOCC server, so
that the users are available for the IPOCC server. When the system has exhausted all the
users in the pool that you created, you can create a new pool of users and restart the TAPI
service.

About this task
For more information about the configuration settings, see the IP Office Manager document.

Procedure

1. Select System > LAN 1.

2. In the VoIP tab, set the following values and settings:

a. Select H323 Gatekeeper Enable.

IP Office telephony integration
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b. Select SIP Trunks Enable.
c. Select SIP Registrar Enable.

3. In the SIP Registrar tab, set the following values and settings:

a. In the Domain Name field, enter server domain name. For example: st4–
ipo1.qas. This is the local SIP registrar domain name through which SIP
endpoints register with the IP Office system.
The domain name must be the same domain name that you typed in Avaya IP
Office Configuration Worksheet.

b. In Layer 4 Protocol, select UDP, TCP, and TLS. Use default ports.
c. Click OK.

4. Select Extension.
Select the SIP extension that you created for the CHAP connection to the IPOCC
server, then click VoIP tab.

5. Select Custom from the Codec Selection drop-down list.

6. List only G.711 ALAW 64K and G.711 ULAW 64k under Selected.
The system functions only if you list both G.711 ALAW 64K and G.711 ULAW
64k under Selected.
Move the other codecs under Unused list.

7. Click OK.

8. To add the ADI licenses do the following:

a. Select License .
b. Click Add.
c. Type the license key in the License Key field.

The system displays the type of license, the status of the license, instances,
and the date of expiry.

9. Click OK.

10. To send the configuration to the IP Office system, select File > Save
Configuration.

11. Restart the IP Office system.

12. Restart the IP Office Contact Center server.

Configuration
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Chat configuration

Configuring the XMPP server

Configuring the XMPP server

Use Jive Software® Openfire, Prosody, or ProcessOne ejabbered to configure the XMPP
server.

• For complete Openfire documentation, go to http://www.igniterealtime.org/projects/
openfire/documentation.jsp.

• For complete Prosody documentation, go to http://prosody.im/.
• For complete ejabbered documentation, go to http://www.process-one.net/en/ejabberd/.

Before you begin

Install a new XMPP server or use an existing XMPP server. For more information about
installing and configuring an XMPP server, see the related documents of the
manufacturer.

 Note:
The domain name of the XMPP server must be the same domain name that you typed in
the Avaya IP Office Contact Center Configuration Worksheet.

About this task

 Note:

• For every topic in the IP Office Contact Center system you must create a user on the
XMPP server.

• The password of the XMPP server user must be the same as the password that you
typed in the Avaya IP Office Contact Center Configuration Worksheet. The default
password in the Avaya IP Office Contact Center Configuration Worksheet is
cc123456.

Installing IP Office Contact Center User Interface
Install the User Interface on every client computer. You can also install the client components
on a IP Office Contact Center server. Use the User Interface only for the configuration. When

Chat configuration
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you use Realtime Information and Reporting as clients on the IP Office Contact Center server,
then the performance of the process is affected.

Before you begin

• Administrator rights — You must have administrator rights to install the User Interface
software. However, you do not need administrator rights to use the User Interface.

• Proxy server — For information about the proxy settings, see Proxy server on page 
47

• Check for the following on a workstation:
- Switch on the client computer.
- Install the operating system and connect the computer to the network.
- Install and configure TCP/IP.
- Log in as the system administrator.
- Close all the Windows applications.

Procedure

1. Double click Contact Center User Interface.msi.
The system displays the IP Office Contact Center User Interface window.

2. Click Next.
The system displays the End-User License Agreement dialog.

To install, read the license agreement and accept the terms in the agreement.

3. Click Next.
The system displays the Choose Setup Type dialog box.

4. Click Complete.
The system displays the General settings dialog box.

a. In the Hostname of IPOCC Server field, type the host name or the TCP/IP
number of the IP Office Contact Center server .

b. In the Hostname of the License Server field, type the host name or the TCP/
IP number of the license server.
The default license server is the IP Office Contact Center server.

5. Click Next.
The system displays the Ready to install User Interface dialog box.

6. Click Install.

7. Click Yes.

8. Click Finish.

Configuration
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Related topics:
Proxy server on page 47

Proxy server
Hyper Text Transfer Protocol (HTTP) is used to gain access to the Internet in the network of
a company network. When implementing HTTP, you can use an automatic configuration script
for the LAN settings. To ensure that the Web applications on IP Office Contact Center are
functional, you must set some exceptions rules in the LAN settings of the browser or modify
the automatic configuration script.

For more information, consult the system administrator of your company network.

Security

Password guidelines
Password
Follow these rules when setting your password:

• The password must be at least 8 characters long.
• The password must contain a combination of at least three of the following character

types: lowercase letters, uppercase letters, numbers, and special characters.
• Do not use your first name, last name, or any other personal information.
• Change your password once in every 90 days.
• The passwords are case-sensitive.

Operating system
Always use the latest security update from Microsoft.

Security certificates
If you are using the web applications through SSL encryption, the browser displays a security
warning notifying you that the security certificate for the site is deficient. A valid security
certificate is not part of the IP Office Contact Center installation. If you want to avoid the security
warnings for SSL, you must obtain a valid security certificate from a certification service
provider.

Security
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Virus scan software considerations
The IP Office Contact Center has been tested with the following virus scan software:

• McAfee 8.5.0i, 8.7.0i and 8.8.0i

• F-Secure Anti-Virus for Windows Servers 7.00 and 7.2.0

• Kaspersky 6.0.2.678

• Panda Admin secure 2006

• Symantec Norton Antivirus

• Avira Server Security 2012

Database access rights and security
The access rights and security features of the databases are governed by the how the system
is administered using the Sybase ASE administration tools. For more information on Sybase
and security, go to http://www.sybase.com.

Installation and update access
Only the system administrator user can use the installation and update features. The account
is secured with a password.

Reporting and real-time information server access
Within the database, the system uses identifiers that can be assigned to user names in the
database table. The system saves reporting data in coded form as basic values. Only the
server process can evaluate these basic values using programmed algorithms and generate
readable reporting data from them.

User interface access
Only those users with user accounts authorized by the system administrator can access the
report generation features. Additional privileges control which reporting types can be used.
The system administrator assigns authorizations and privileges or they can be assigned during
system configuration. Further security for the data is offered by the implemented Four-Eye
Principle. This principle allows access to reporting data only when two passwords are entered.
This enables works councils and other employee representatives to fulfill their rights.

Configuration
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Optional and customized functionality

Managing email security
To increase security and prevent SPAM, use the E-mail configuration to block or allow certain
domains, IP addresses and valid senders for email messages.

Procedure

1. Open User Interface.

2. Select Go to > E-mail configuration.

3. Select a server from the list.

4. Click C3000 SMTP Connector.

5. On the Security tab, click Add to add domains, IP addresses or valid senders.

6. Restart the service.

Setting UMR database fill thresholds
You can use the E-mail configuration to set threshold values and query intervals for the UMR
runtime database.

Avaya recommends setting up a SMTP message to be generated on the message output in
TTrace to inform the system administrator with the database threshold status. The system
administrator can then take action to avoid system shutdown.

Procedure

1. Open User Interface.

2. Select Go to > E-mail configuration.

3. On the System tab, enter the following values:

a. In the DB size checking interval (minutes) field, specify the query interval for
the database fill level in minutes. If the fill level exceeds a configured threshold
value, the system generates a TTrace message. Default is 15 minutes.

b. In the Level for info message (%) field, specify the level in percent at which a
TTrace information message will be generated. Default is 80%.

Optional and customized functionality
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c. In the Level for alarm message (%) field, specify the level in percent at which
an alarm message will be generated. Default is 90%.

d. In the Current DB size (%) field, the system displays the current database fill
level. The SMTP connector or POP3 or IMAP4 client evaluates this value. If the
level is exceeded, no more emails are accepted or retrieved.

Uninstalling Sybase Adaptive Server Enterprise
Before you begin
If you have installed IP Office Contact Center databases, then remove all  database setups
using the control panel.

About this task
To uninstall Sybase Adaptive Server Enterprise, run the following steps as an Administrator:

Procedure

1. Start Sybase > Adaptive Server Enterprise > Server Config.

2. Select Products > Backup Server.

3. Click Remove Backup Server.

4. Click Ok.
If, there are several instances of the backup server, then you must remove all the
instances of the backup server.
The system displays:
Quit Remove Backup Server! Continue?

5. Click Yes.
The system displays:
Quit Exit SyConfig and Reboot now

6. Click Ok.

7. Select Products > Adaptive Server.

8. Click Remove Adaptive Server.
If, there are several instances of the backup server, then you must remove all the
instances of the backup server.
The system displays:
Quit Remove Adaptive Server! Continue?

9. Click Yes.
The system displays:
Quit Exit SyConfig and Reboot now

10. Click Ok.

Configuration

50     Deploying IP Office Contact Center February 2014
Comments? infodev@avaya.com

mailto:infodev@avaya.com?subject=Deploying IP Office Contact Center


11. Click Exit.

12. Start the computer.

13. Start Control Panel — Software.

14. Select Sybase Software Developer’s Kit.

15. Click Change/Remove.

16. Click Next in all the following dialog boxes.

17. Select Sybase Adaptive Server Enterprise Suite.

18. Click Change/Remove.

19. Click Next in all the following dialog boxes.

20. Delete the installation paths.
For example, c:\sybase.

Result
The system uninstalls Sybase Adaptive Server Enterprise.

Component management

Changing a server host name
About this task

 Note:
You can change the server host name only for a newly installed database.

Procedure

1. Open the Utilities folder on the computer where the database is installed.
Typically, it is located in the root folder of the IPOCC installation kit.

2. Double-click AdjustHostname.

3. Type the User and Password that you set for the database.

4. Type the name of the host in the Hostname field.

5. Click Apply.
The system displays the Adjustment of hostname and computer IP
finished. message.

Component management
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6. Click OK.

Next steps
Restart the system.

Changing the server address on the client
If you change the IP address of the IP Office Contact Center server, you must also change the
server address setting on the IP Office Contact Center client.

Procedure

1. On the IP Office Contact Center client, from the Windows Start menu, open Control
Panel.

2. Select Programs and Features.

3. Select IP Office Contact Center User Interface and then click Change.

4. Click Next and then click Modify.

5. Click Next.

6. In the Hostname of IPOCC Server field, enter the IP address of the IP Office
Contact Center server.

7. In the Hostname of License Server field, enter the IP address of the IP Office
Contact Center server.

8. Click Next.

9. Click Change.

10. Click Finish.

Address book administration

Address Book Administrator

The UMR Client module contains the address book functionality. The address book server
displays address book information to agents. Use the Address Book Administrator module to
configure the address book server and connect to address books.

For more information, see Using Avaya IP Office Contact Center Address Book
Administrator.

Configuration
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Avaya IP Office Contact Recorder
Contact Recorder stores and catalogs the voicemail recordings so that you can access and
retrieve the voicemail recordings.

To install Contact Recorder on the IP Office Server Edition server, you must add an additional
hard disk drive on the IP Office Server Edition server.

For more information about installing Contact Recorder see, Contact Recorder for IP Office
Installationmanual. For more information about using Contact Recorder see, Using Contact
Recorder manual. For information about administering Contact Recorder see, Administering
Contact Recorder manual.

Related topics:
Additional hard disk drives on page 53
Creating an additional hard disk drive on a DL360G7 server of the IP Office Server Edition on
page 54
Creating an additional hard disk drive on a Dell R210II server of the IP Office Server
Edition on page 56
Configuring the additional hard disk drive using the ignition process on page 56
Replacing a failed hard disk drive on page 59

Additional hard disk drives
IP Office Server Edition release 9.0.2 supports the following operations:

• Additional hard disk drives that are fitted prior to the initial installation.
• Additional hard disk drives that are added before the installation not upgrade over an

existing IP Office Server Edition release 8.1 or 9.0.

Order codes for the servers and hard disk drives

Product Order code Notes

Avaya Dell PowerEdge R210
II server

302788, 302786 Ignited either as Server
Edition Primary server or as
an Application Server with a
single additional hard disk
drive.

Avaya HP ProLiant
DL360G7 server

270393 Ignited either as Server
Edition Primary server or as
an Application Server with
either a single additional hard

Avaya IP Office Contact Recorder
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disk drive or two additional
hard disk drives.

Dell R210 II Additional HDD 700506869 R210 II XL 500GB 7200 HDD

HP DL360G7 Additional
HDD

700501314 DL360G7 SRVR 300GB 10K
SAS 2.5" HDD

Creating an additional hard disk drive on a DL360G7 server of the
IP Office Server Edition

You can create an additional single hard disk drive or a pair of mirrored RAID (Redundant
Array of Independent Drives) drives.

 Note:
You can create an additional single drive on slot 3 of the server and it is not mirrored image.
However, you create a pair of RAID drives on slot 3 and slot 4 of the server and these drives
are the mirrored images of each other.

Before you begin

1. Go to the HP support site and download the related guide of the server.
2. Turn off the power supply to the server.
3. Remove the disks in the slots.

 Note:
To create a single hard disk drive remove the disk in the slot 3.

To create a pair of mirrored RAID drives remove the disks in slot 3 and slot 4.
4. Insert the new hard disk drives into the slots from which you removed the disks.

 Note:
The product ID for the new drives is : 700501314. For more information see,
Installing a SAS hard drive section of the guide you downloaded from the HP
support site.

About this task

 Note:
Create the additional hard drives and then change the BIOS settings. These changes are
specific to the server and configuration but in general the template in BIOS has two visible
Logical Drives: one for primary hard drive and the other one for the additional hard drive that
you created.
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Procedure

1. Turn on the power supply to the server.
The server restarts.

2. When the system displays the message Press any Key to view Option ROM
messages, press any key on the keyboard.

3. When the system displays the message Slot 0 HP Smart Array 4101
Controller Initializing, press the function key F8 .
The system displays the Main Menu list.

4. Select the Create Logical Drive option.
The system displays the Option ROM Configuraion for Arrays, version 8.x.x.x
page.

5. Do the following:

• To configure a single hard disk drive do the following:

i. In the Available Physical Drives section, select the drive on Bay 3.

ii. In the RAID Configurations section, select RAID 0

iii. In the Maximum Boot partition section, select Disable (4GB
maximum).

To configure a pair for mirrored RAID disk drives do the following:

i. In the Available Physical Drives section, select the drives on Bay 3
and Bay 4.

ii. In the RAID Configurations section, select RAID 1 + 0

iii. In the Maximum Boot partition section, select Disable (4GB
maximum).

6. Press the <Enter key> to save the configuration.

7. Press the function key F8 to confirm the configuration.
The system displays the Main Menu list.

8. Select the option Select View Logical Drive.
The system displays the drives that you created.

 Note:
If the system does not display the drives that you created complete step 5 to step
8.

9. Press the <ESC key>.

Result
The IP Office Server Edition version 9.0.2 or later recognizes the drives that you created.
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Creating an additional hard disk drive on a Dell R210II server of the
IP Office Server Edition

Before you begin

1. Go to the Dell support site and download the related guide of the server.
2. Turn off the power supply to the server.
3. Open the system. For more information about opening the system see, Opening

the system section of the guide.
4. Install the additional hard disk drive in the Optical drive. For more information about

installing the hard disk drive see, Installing a Hard Drive section of the guide.

Procedure

1. Turn on the power supply to the server.

2. To open the BIOS settings press the function key F2.

3. Select SATA Settings and press the <Enter key>.

4. Select Port B.

Change Off to Auto.

5. Press the <ESC key>.

6. Save the changes and exit.

Result
The IP Office Server Edition version 9.0.2 or later recognizes the drives that you created.

Configuring the additional hard disk drive using the ignition
process

If an additional hard disk drive is present, the system detects it and prompts the user to create
up to three partitions on the hard disk drive, and to mount it in a specified location. The system
creates a sub folder for each partition in a location that you specify.

 Note:
If an additional drive is not present, the system displays a message No new hardware
available. You can add the additional hard disk drive and restart the ignition process.
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Before you begin

• Check if the two logical drives are defined in the BIOS settings.
• The additional hard drive should be a new one else format the hard disk using the run

command mkfs.ext4 <device> and then insert the disk in the slot.

About this task
This procedure provides only the steps to configure the additional hard disk drive using the
Ignition process. For more information about Ignition process on a IP Office Server Edition
server, see Configuring IP Office Server Edition using Ignition section of the Deploying IP Office
Server Edition document.

For more information about Ignition process on an Application Server, see Server Ignition
section of the Installing Contact Recorder for IP Office.

Do the following the Hardware page of the Ignition process:

Procedure

1. In the Additional Hardware Settings section, enable Create Partitions.

2. The following fields must have the value 0:

• Partition 1 size (GB)

• Partition 2 size (GB)

• Partition 3 size (GB)

3. Enable Mount Hardware.
If you do not enable Mount Hardware, the drive will not be mounted and the mount
point path can be blank, but the hard drive will be formatted and partitioned.
You can also mount the hard disk drive using the Linux Platform settings.
The system prompts you to type the Mount Point.

4. In the Mount Point field, type /CSIPORec.

Related topics:
Mounting the hard disk drives on page 57
Installing and configuring Contact Recorder on page 58

Mounting the hard disk drives

Before you begin
Start Linux Platform settings for IP Office Server Edition server. For more information about
Linux Platform settings, see Deploying IP Office Server Edition guide.

Start the Web Control Panel for the Application Server.
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About this task
If you do not mount the hard disks during the Ignition process, you can mount the hard disks
using the Linux Platform settings.

If you add an additional hard disk drive after Ignition and if the system recognizes the additional
hard disk drive that you just added, then the system updates the Settings > System page of
the Linux Platform settings or the Web Control Panel.

Procedure

1. Select Settings > System.

2. In the Additional Hardware Settings section the system displays the details of the
hard disk drive.

3. Enable Active.

4. In the Mount Point Path filed, type /CSIPORec.
If the drive is mounted, the system displays the current mount point path. If the drive
is partitioned, the system displays the parent folder of the partitions' subfolders.
Otherwise the Mount Point Path field is empty.

5. Click Save.

Example
To unmount the hard disk drive do not select Activate.

 Note:
The value for Mount Point Path filed, must be /CSIPORec.

Installing and configuring Contact Recorder

The Contact Recorder rpm is not installed by default on the IP Office server. The rpm is
packaged with the image and you can install Contact Recorder using IP Office Web
Manager.

Before you begin
Start Linux Platform settings for the IP Office Server Edition server. For more information about
Linux Platform settings, see Deploying IP Office Server Edition guide.

Start the Web Control Panel for the Application Server.

Procedure

1. Select Updates

2. Click Install for Contact Recorder application.
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After the system installs the application, the system updates the application in the
System page. However, you will need to start the service.

 Note:
Before you start the service ensure that the Mount Point Path filed, is set as/
CSIPORec. For more information see, Mounting the hard disk drives on
page 57.

3. To start the Contact Recorder service on the System page, click Start.

Next steps
Start the Contact Recorder Service and go to the Contact Recorder Administration page.

1. Go to General Set up tab and set the Call Storage Path to /CSIPORec.

 Note:
You must set the Call Storage Path field to /CSIPORec for the Contact Recorder
to use the additional hard disk drive.

2. Restart the Contact Recorder service using the Linux Platform settings or the Web
Control Panel.

Replacing a failed hard disk drive
Before you begin
Shutdown the server using IP Office Web Manager.

Procedure

1. Remove and replace the additional hard disk drive.
Check if the system recognizes the new hard disk drive in the BIOS settings

2. If the system recognizes the hard drive, the system updates the Settings > System
tab of the Linux Platform settings.
If the system does not recognize the hard disk drive, check if the replacement drive
is of the correct type and check the BIOS settings.

3. Set the mount point to /CSIPORec, then and save the configuration.
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Chapter 8: Initial administration

Routine maintenance

Routine maintenance checklist
Routine maintenance tasks consist of daily, weekly, and monthly backups and software version
updates.

# Task Description Notes

1 Back up the
database daily.

2 Improve the
database access
time monthly or up to
every 3 months.

After initial installation,
when more changes
typically occur, Avaya
recommends a weekly
interval.
The interval depends
on the data quantity.
Smaller data quantities
require longer
intervals.

This process can take
several hours.

3 Reorganize the UM
database monthly.

Some tables in the
database are called
data-only locked (DOL)
tables. These tables
have different
structures than those
used as all pages
locked (APL) tables.

4 Perform periodic
database updates.

5 Perform periodic
system diagnostics.
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Related topics:
GUID-4D28F74C-6214-4801-A0D1-08340DFEA102
GUID-083C4BF3-6B10-46D9-84B7-0680F8B25D84
Backing up a database on page 62
Reorganizing the UM database on page 64
Restoring a database on page 66
Verifying server and backup page sizes on page 67
Separating log and data segments on page 68
Verifying telephony on page 71
Using database backup compression on page 81
Checking database used and free space and memory capacity on page 91

Backing up a database
Use database backups to analyze errors, to restore lost data, and to maintain transaction logs
for the Sybase Adaptive Server Enterprise (ASE) system.

 Tip:
You can back up a database to a file and copy it to a newly created database.

 Tip:
Alternatively, you can back up all databases using a batch file. Typically, it is located at
\Utilities .

1. Open the command prompt.

2. Copy the batch.bat file from the \Utilities directory to the hard disk.

3. Type backup <password> <targetpath>.

Where,

<password> is the sa password.

<targetpath> is the location where you want to save the databases.

Before you begin

If you are backing up the database to a server location, ensure that the server is within
the same system as the Sybase ASE installation.

About this task
You can back up a database to a file on another server in the enterprise or to a DAT tape using
the Sybase Central administration tool. You can back up a database while the system is
running.

Use the following guidelines for database backups:
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• Complete a full backup after initial installation
• Back up all databases daily.

 Tip:
If backup server space is limited, you can use backup compression. For more information,
see Using database backup compression on page 81.

See the Sybase online help for more information.

Procedure

1. Click Start > Sybase Central.

2. Click Connect > Connect to Adaptive Server Enterprise.

3. In the Connect dialog box, enter the uesrname sa.

4. Enter the password.
If you have forgotten the password, see Resetting the database sa password on
page 87.

5. Click OK.

6. Right-click the database name.

7. On the pop-up menu, click Backup.

8. Select the database.

9. Select Backup the entire database.

10. Click Next.

11. Click Add.

12. Select Explicit dump device.

13. Enter the file name for the backup including the file path.
For example: z:\DBBackup\db_cc.bck

14. Click OK.

15. Click Next.

16. Accept the defaults.

17. Click Next.

18. Accept the defaults.
The backup begins. The amount of time the backup takes depends on the size of
the database.

19. Click Finish.

20. Check the log for errors.
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Improving database access time
When you make data changes in the database tables, the database access time increases
over time, specifically for reporting tables. To counteract this performance loss, Avaya
recommends that you update the index reporting at regular intervals.

About this task
This process can take several hours.

Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type isql —U sa —P password and press Enter.
If you have forgotten the password, see Forgotten the password to login as sa on
page 87.

3. At the command prompt, type use dbname, where dbname is the name of the
database you want to improve, and press Enter..

4. Type go and press Enter.

5. Type exec sp_m_updatestatus and press Enter.

6. Type go and press Enter.

Reorganizing the UM database
Some database tables are called data only locked (DOL) tables. These tables have different
management structures than the all pages locked (APL) tables. Avaya recommends that you
maintain DOL tables monthly to ensure that they function efficiently. The DOL tables are:

• C3K_ADDRESSEE

• C3K_DOCPROP

• C3K_DOCUMENT

• C3K_DOCUMENT_INDEX

• C3K_EVENT

• C3K_METAREQUEST

• C3K_REQUEST
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About this task
Use Microsoft Windows Task Scheduler or create a Scheduled Task in Windows 2003 to run
a script to reorganize the DOL tables.

Procedure

1. Using a text file editor, create a SQL script called reorgC3K.sql.
The text file should contain the following lines:
use c3k
go
reorg conpact C3K_ADDRESSEE
go
reorg conpact C3K_DOCPROP
go
reorg conpact C3K_DOCUMENT
go
reorg conpact C3K_DOCUMENT_INDEX
go
reorg conpact C3K_EVENT
go
reorg conpact C3K_METAREQUEST
go
reorg conpact C3K_REQUEST
go

2. Using a text file editor, create a batch file called reorgC3K.bat that runs the new
reorgC3K.sql file.
For example:
@ECHO OFF
setlocal ENABLEEXTENSIONS ENABLEDELAYDEXPANSION

set UID=sa
set PWD=PASSWORD

echo ---------------------------------------------
echo REORG BEGIN %date% %time:~0,8%
echo.
isql -Jutf8 -U%UID% -P%PWD% -ireorgC3K.sql -p
echo.
echo REORG END     %date% %time:~0,8%
echo.
endlocal

where PASSWORD is the sa password for your system.

3. Save both files to a folder.
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For example: c:\reorg_task
4. Start Task Scheduler in Windows.

5. Create a new task to run the batch file on a monthly schedule.
For example:

c:\reorg_task\reorgC3K.bat>> reorg.log 2>% 1

Restoring a database
Before you begin

• Stop the Watchdog service.
• Ensure that the following database size settings match:

- Size of the database device
- Size of the log device
- Page size

• Ensure that no active database connection exists.

Procedure

1. Click Start > Sybase Central.

2. Click Connect > Connect to Adaptive Server Enterprise.

3. In the Connect dialog box, enter the uesrname sa.

4. Enter the password.
If you have forgotten the password, see Resetting the database sa password on
page 87.

5. Click OK.

6. On the pop-up menu, click Restore.

7. Select Restore the entire database.

8. Click Next.

9. Click Add.

10. Click Next.

11. Click Add.

12. Select Explicit dump device.

13. Enter the file name for the backup including the file path.
For example: z:\DBBackup\db_cc.bck

Initial administration

66     Deploying IP Office Contact Center February 2014
Comments? infodev@avaya.com

mailto:infodev@avaya.com?subject=Deploying IP Office Contact Center


14. Click OK.

15. Click Next.

16. Accept the defaults.

17. Click Next.

18. Accept the defaults.

19. Click Finish.

20. Right-click the database.

21. On the pop-up menu, click Online.

Next steps
If you restore a database to a new computer, for example, in the case of a hardware
replacement, then you must separate the log and data segments.

If problems occur after you restore a database, see Problems after restoring a database on
page 98.

Related topics:
Verifying server and backup page sizes on page 67
Separating log and data segments on page 68

Verifying server and backup page sizes

About this task
Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type isql —U sa —P password and press Enter.
If you have forgotten the password, see Forgotten the password to login as sa on
page 87.

3. At the command prompt, type select @@maxpagesize and press Enter.

4. Type go and press Enter.
The screen displays one of the following:

• 2048 for a server page size of 2K

• 8192 for a server page size of 8K

5. To verify the backup page size, at the command prompt, type load database
dbname from ‘pfadname\filepath’ with headeronly and press Enter.
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6. Type go and press Enter.
As an example, the screen displays the following information:
Backup Server session id is:    5.  Use this value when executing the 
'sp_volchanged' sysetm stored procedure after fulfilling any volume change 
request from the Backup Server.
...
Oct 01 20:05:. Database page size is 8192.
Database contains 156672 pages; checkpoint RID=(Rid pageid = 0x23alf; row 
num = 0x3a); next object ID=157292639; sort order ID=101, status=12; 
charset id=190
...

Separating log and data segments

If you restore a database to a computer other than the one on which you created the database,
then it is possible that log and data segments are no longer separated on the appropriate
devices. When the log and data segments are not separate, performance reduction and
extended start times may occur. Restore the separation between the log and data
segments.

About this task
The following steps use the cc database as an example. Replace cc in the steps below with
the name of the database that you are trying to repair.

Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type isql —U sa —P password and press Enter.
If you have forgotten the password, see Forgotten the password to login as sa on
page 87.

3. At the command prompt, type sp_helpdb dbname and press Enter.

4. Type go and press Enter.
As an example, the screen displays the following information:
name                          db_size
                owner                          dbid
                created
                durability
                lobcomplvl
                inrowlen
                status
----------------------------------------------------------------
----------------------------------------------------------------
cc                             1700,0 MB
                cuser
                Mar 26, 2014
                full
                       NULL
                     NULL
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                trunc log on chkpt, ddl in tran, abort tran on log full, 
mixed log and data

If mixed log and data appears in the output, then log and data segments are not
separated.

5. Ensure that no other users are logged in to the database. At the command prompt
type sp_m_connections and press Enter.

6. Type go and press Enter.

7. Type sp_sh_dboption dbname, single, true and press Enter.

8. Type go and press Enter.

9. Type use dbname and press Enter.

10. Type go and press Enter.

11. Log in to Sybase Central with the sa user ID.

12. Open the folder Databases.

13. Right click on database cc and select Properties.

14. Select the Options tab and check single user.

15. Click Apply.

16. Click the Devices tab and select cclogdev and then click Move log.

17. Click OK.

18. Expand the navigation tree entry for database cc.

19. In the Segments folder, right click logsegment and select Properties.

20. In the Devices folder, select ccdev and click Remove.

21. Click OK.

22. Right click database cc and select Properties.

23. Click the Options tab and uncheck single user.

24. Click OK.

25. Open a command window, type isql -Usa -P<sybasepassword> and press
Enter.

26. Type use cc and press Enter.

27. Type go and press Enter.

28. Type sp_dropsegment 'logsegment', 'cc', 'ccdev' and press Enter.

29. Type go and press Enter.

30. Type sp_extendsegment ‚default’, cc, ccdev and press Enter.

31. Type go and press Enter.
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32. Type sp_extendsegment ‚system’, cc, ccdev and press Enter.

33. Type go and press Enter.

34. Type quit and press Enter.
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Chapter 9: Post-installation verification

Logging in as an agent
Procedure

1. Select Start > Programs > Avaya IP Office Contact Center > User Interface.
The system displays the Avaya IP Office Contact Center login page.

2. Select Agent1 from the Username drop-down list.
You can choose Agent1, or Agent2, or Agent3.

3. Type the default password cc123456.

4. Select the IP Office extension of the agent from the Telephone Extension.

5. Click Login.
The system displays the IP Office Contact Center window.

Related topics:
Verifying telephony on page 71
Verifying chat functionality on page 72
Verifying email on page 72

Verifying telephony
Procedure

1. Login as a Agent

2. Select Go to > Telephony.

3. Select Sign on all AGs.

4. Make test calls.
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Verifying chat functionality
Procedure

1. Login as a Agent

2. Select Go to > Chat.

3. Select Sign on all AGs.

4. Open chat requests to the XMPP server with a chat client such as Gajim

Verifying email
Procedure

1. Login as a Agent

2. Select Go to > email.

3. Select Sign on all AGs.

4. Send emails to the IP Office Contact Center system.

Logging in as a supervisor
Procedure

1. Select Start > Programs > Avaya IP Office Contact Center > User Interface.
The system displays the Avaya IP Office Contact Center login page.

2. Select Supervisor from the Username drop-down list.

3. Type the default password cc123456.

4. Select the IP Office extension of the supervisor from the Telephone Extension.

5. Click Login.
The system displays the IP Office Contact Center window.
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Related topics:
Verifying realtime information on page 73

Verifying realtime information
Procedure

1. Login as a Supervisor

2. Select Go to > Realtime information.

3. Select AG_Default in Predefined..

4. Select an AG.

5. Check the realtime information.

6. Select Topic_Default in Predefined.

7. Select a Topic.

8. Check the realtime information.

Logging in as a supervisor
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Chapter 10: Installation on a virtual server

You can install IP Office Contact Center on a VMware virtual server. The Open Virtualization Archive
(OVA) file contains a pre-installed IP Office Contact Center instance that can be deployed on VMware
Hypervisor.

In this OVA distribution, automatic Windows updates are not enabled. If you want to turn on automatic
Windows updates, choose the option to Download updates but let me choose whether to install
them. Download only important updates.

In this OVA distribution, remote connections to the IP Office Contact Center server are allowed.

Installing the OVA file on VMware
Before you begin
The following requirements must be met.

• VMware ESXi 5.1 or greater installed and configured
• You must use the ESXi hardware with a CPU clock speed greater than or equal to 2.4

GHz. For full performance, use ESXi Hardware with a CPU clock speed greater than or
equal to 3 GHz.

• Virtualized IP Office Contact Center needs the following resources on the VMware host:

- 250 GB disk space, thick provisioning
- 8 GB memory
- 1 CPU, 4 core

Reserve memory and CPU resources using vSphere Client for the IP Office Contact
Centerserver. Select Edit settings > Resources or create an own resource pool for the
IP Office Contact Center server. Reserve a minimum of 6 GB Memory and 4x max. CPU
clock. For example: For ESXi hardware with a CPU of 2.4 GHz clock speed, you must
reserve 9600 MHz.

•
 Note:

To activate the Windows 2012 operating system you need a valid product registration
key. Contact Microsoft or an authorized reseller to procure the Windows operating
system.

Microsoft operating system licenses are specific to the hardware and limited to only 4
processors on that hardware. If you run the software on more than 4 processors, then
you need additional licenses.
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Procedure

1. Start the VMware vSphere client.

2. Log in to the vCenter server with a user ID that has permission to deploy new virtual
machines.

3. From the File menu, select Deploy OVF Template and the load the IP Office
Contact Center OVA file.

4. Enter a name and location for the IP Office Contact Center server.

5. For storage, choose the local storage device or a SAN storage device.

6. For the disk format, the following options are supported.

• Thick Provisioning Lazy Zeroed

• Thick Provisioning Eager Zeroed

7. Start the IP Office Contact Center virtual server machine.

8. Launch the virtual machine console from the vSphere client.

9. During the initialization of Windows, you must enter the following information.

• Country or region.

• App language (you must select English).

• Keyboard layout

• Product key (if you don’t have a product key, you can skip this setting.

• A password for the Administrator user.

10. After Windows initialization is complete, log in as Administrator.

11. Locate the readme.rtf file on the desktop. Open the readme.rtf file and follow
the instructions.

Setting up the network
Procedure

1. In the Windows task bar, in the system tray, right click Network and Sharing
Center.

2. In the Network and Sharing Center window, click Ethernet.

3. Click Properties.
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4. Click the check box to uncheck Internet Protocol Version 6 (TCP/IPv6).

5. Click the check box to check Internet Protocol Version 4 (TCP/IPv4).

6. Click Properties.

 Note:
Do not activate Obtain an IP address automatically.

7. Enter the appropriate information for the following fields:

• IP Address

• Subnet Mask

• Default Gateway

• Preferred DNS Server

8. Click OK.

9. Click Close and then click Close again.

Setting the computer name and activating Windows
Before you begin

 Note:
To activate the Windows 2012 operating system you need a valid product registration key.
Contact Microsoft or an authorized reseller to procure the Windows operating system.

Procedure

1. Open a Windows Explorer window.

2. Right click This PC and then select Properties.

3. Click on the Change Settings link associated with Computer Name.

4. Click Change.

5. Enter a computer name and click OK.
Use only computer names with the numbers 0-9 and letters A-Z, a-z. Do not use
special characters.

6. You receive the prompt You must restart your computer to apply these
changes. Click Restart Later.

7. Click Activate Windows.

Setting the computer name and activating Windows
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Ensure that you have access to the internet.

8. Enter the Windows product key and then click Close.

9. Reboot the machine.

Applying the configuration changes
Procedure

1. Log in to Windows.

2. On the desktop, double click the Services shortcut.

3. Stop the IPOCC Watchdog service.

4. Close the applications TT Display and TT Console.

5. From the Windows Start menu, open Control Panel.

6. Click Phone and Modem.

7. Click the Advanced tab and then select Avaya IP Office TAPI2 Service
Provider.

8. In the Switch IP Address field, enter the IP address of the IP Office system.

9. The Switch Password field is set to the default value password. This value must
match the IP Office system password.
On IP Office, the system password is set at Security Settings > System >
Unsecured Interfaces > System > Password

10. On the desktop, double click AdjustHostname.exe.

11. Once the configuration has been applied, you are prompted for the user name and
password for Database Access. Enter the user name sa and enter the password
Administrator.
Ensure that the password that you set for sa user and the WebLM is the same.

12. Click Apply.

13. Once the AdjustHostname process has completed, reboot the machine.
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Importing customer data
Before starting this procedure, wait for complete start of IP Office Contact Center processes.
You can verify process start with TT Display.

In this procedure, you will use the Data Import Tool (DataImport.exe) which you have created
with the Excel template Avaya_IP_Office_Contact_Center_Configuration.xltm to import
your customer data.

Procedure

Use the DataImport tool to import customer data.

Installing a license
Before you begin
In order to generate a valid license, you need the MAC address of the virtual server. You can
determine the MAC address using the vSphere client.

1. Select Edit Settings and then click on the Hardware tab.
2. Click Network Adapter 1 and then look for the MAC Address.

Use the Avaya Product Licensing and Delivery System (PLDS) at https://plds.avaya.com to
generate and download license files. PLDS is an online, Web-based tool for managing license
entitlements and electronic delivery of software and related license files.

Procedure

1. On the IP Office Contact Centerserver, open a web browser and connect to WebLM
using the address https://<hostname>:8443/WebLM.
Where <hostname> is the host name of the IP Office Contact Centerserver.
Note that WebLM is case sensitive.

2. Login with the user ID admin and the password weblmadmin.

3. You must change the password after the first login and then log in with the new
password.
Ensure that the password that you set for sa user and the WebLM is the same.

4. Click Install license.

5. Navigate to your license file and click Install.

Importing customer data
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6. Click Licensed Products to check your license.

7. Restart the IPOCC Watchdog process.
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Chapter 11: Optimization

Database optimization

Creating a connection profile in Sybase Central
About this task
Create a connection profile for the CC database in Sybase Central to start the application
without the need to enter the sa user ID each time.

Procedure

1. Start Sybase Central.

2. On the Tools menu, select Connection Profile.

3. Click New.

4. Enter a name for the profile. For example, cc.

5. Click OK.

6. Select the new connection profile.

7. Click Start enable.

8. Click Close.

Using database backup compression
If your backup server space is limited, compression allows you to store larger databases
without using large amounts of hard drive space.

Before you begin

• Ensure that you have network access to a backup server.
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 Tip:
Set up an account in the service manager to allow the SybaseBckServer service to
access the network backup server. The folder address for the backup files must be an
UNC address. For example: \\myServer\myPath\myFile.

About this task
You can choose from different compression levels between 1 and 9: 1 is the smallest amount
of compression and 9 is the largest. Higher compression levels require more time for the
backup to complete. You can also choose compression level 100 or 101 which use less CPU-
intensive compression algorithms and work more quickly.

Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type isql —U sa —P password and press Enter.
If you have forgotten the password, see Forgotten the password to login as sa on
page 87.

3. Optional. Set the Allow remote access parameter on the remote server if it has
not already been set.

a. At the command prompt, type: sp_configure ‘allow remote access’,
1 and press Enter.

b. Type go and press Enter.
c. Add the following lines to the %SYBASE%\ini\sql file on the source server:

master=NLWNSCK, targetserver,5001
query=NLWNSCK, targetserver,5001

4. At the command prompt type go and press Enter.

5. To restore a database from a compressed backup file, type load database
dbname from ‘path\filename’ and press Enter.

6. Type go and press Enter.

Moving a database to another device
Before you begin
Stop all database activities.

About this task
Use mirroring to move a database to another device. There are three main steps to moving a
database using this method:
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1. Mirror the original device on a new device.
2. Define the second device as the primary device.
3. Suspend the mirroring.

In most cases data and transaction logs are on different devices. With the removal of a
database you can also move the transaction log. If the data and transaction log are on different
physical hard drives, then this can positively affect the performance.

 Note:
The duration of the mirroring depends on the size of the device and the flow rate of the
involved hard drives.

Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type isql —U sa —P password and press Enter.
If you have forgotten the password, see Forgotten the password to login as sa on
page 87.

3. At the command prompt, type sp_configure ‘disable disk mirroring’,
0 and press Enter.

4. Type go and press Enter.

5. Type shutdown and press Enter.

6. Type go and press Enter.

7. Start the Sybase SQL Server.
8. At the command prompt, type disk mirror name = ‘dbname’, mirror =

‘new location path and .dat filename’ and press Enter.

9. Type go and press Enter.

10. Type disk unmirror name = ‘dbname’, side = ‘primary’, mode =
remove and press Enter.

11. Type go and press Enter.

12. Type sp_configure ‘disable disk mirroring’, 1 and press Enter.

13. Type go and press Enter.

14. Restart the Sybase SQL Server.

Example
The system displays status information. For example:
Creating the physical file for the mirror...
Starting Dynamic Mirroring of 131072 pages for logical device 'ccdev'.
           512 pages mirrored...
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Deploying IP Office Contact Center February 2014     83



          1024 pages mirrored...
          1536 pages mirrored...
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Chapter 12: Troubleshooting

General troubleshooting information

File locations
If you are using Microsoft Windows 2008, the system files and log files are stored in the
following locations:

Files Location

All IP Office Contact Center component files C:\Program Files (x86)\Avaya
\IP Office Contact Center\

Watchdog files C:\Program Files (x86)\Avaya
\IP Office Contact Center
\Watchdog

Task flow data files and recorded message
files

During activation of a task flow, the task flow
is exported and the exported file with suffix
cfe is stored in the folder C:\Users
\Public\Documents
Voice messages recorded with the internal
IVR are stored in the folder C:
\ProgramData\Avaya\IP Office
Contact Center\VoiceControl
\work\DefaultRecordings

Task flow export files If you use a User Interface on a server, the
TaskFlow Editor export files will be stored
here:
C:\Users\Public\Documents.

Error dump files C:\Users\username\AppData
\Local\Temp\
or
C:\ProgramData\Microsoft
\Windows\WER\ReportQueue\
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Files Location

TTrace log files C:\ProgramData\Avaya
\TTLogfiles

Exported statistic reports C:\ProgramData\reporting data
Installation logs SetupWizard and every setup created is

stored in a log file in the folder C:\Users
\<LOGGEDIN USER>\AppData
\Local\Temp

Sybase Log Logs for database issues are ASE.log and
ASE_BS.log. Both in C:\Sybase
\ASE-15_0\install

Creating an error dump file
An application debugging process is not available with Microsoft Windows 2008 or Windows
2012. You can create an error dump output file after an error occurs in a system component.
Use this file to submit to Avaya support to help with the debugging process.

Before you begin
Edit the HKLM\SOFTWARE\Microsoft\Windows\Windows Error Reporting\ entry in the
Windows registry. Change the DWORD parameter to ForceQueue with a value of 1.

Procedure

1. Click Start.

2. Enter View all problem reports.

3. Click View all problem reports.

4. To view a problem report, double-click on a report entry in the list. If a report exists,
the list displays View a temporary copy of these files.
For more information, see http://msdn.microsoft.com/en-us/library/
bb787181%28v=VS.85%29.aspx.
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Database diagnostics and stored procedures

Forgotten the password to log in as sa

If you forget the password for the sa login, you can start the server with a simultaneously
generated password.

Before you begin
Stop the Sybase SQLServer_servername service.

About this task
This procedure produces many outputs. Set the window buffer to the maximum value of 9999.
Alternatively, you can write the output to a file.

Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type sqlsrvr —p sa and press Enter.

3. Search the output for the string New SSO password for sa: and note the
password.

4. Login using the new password.

5. Change the password.

a. At the command prompt, type isql —U sa —P password and press
Enter.

b. Type sp_password currentPassword, newPassword and press Enter.
c. Type go and press Enter.
d. Type shutdown and press Enter.
e. Type go and press Enter.

6. Restart the Sybase SQLServer_servername service.

Related topics:
Changing the password using Sybase central on page 87

Changing the password using Sybase central
Procedure

1. Right-click sa in the folder Logins.
The system displays a context menu.

General troubleshooting information
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2. Select Properties.

3. Click Register Parameters.

4. Click Change Password.

5. Type the new password.

6. Click OK.

Finding system information

About this task
View Sybase ASE common configuration settings.

Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type isql —U sa —P password and press Enter.
If you have forgotten the password, see Forgotten the password to login as sa on
page 87.

3. At the command prompt, type sp_m_systeminfo and press Enter.

4. Type go and press Enter.

Result
As an example, the system displays the following information:
Version Information
===================================

server: Adaptive Server Enterprise/15.5/EBF 18373 SMP ESD#3/P/NT (IX86)/Windows 
2003/asear155/2531/32-bit/OPT/Fri Jan 15 01:57:26 2014

Server Configuration
===================================

page size:                8k
max memory:                262144 2k pages, 512 MB
memory left:                5372 2k pages, 10 MB
procedure cache:                24576 2k pages, 48 MB
data cache:                291260 kByte
nbr of connections:    200
max online engines:                3
engines at startup:                3

Databases
=========
name        size(MB    used(MB)    free(MB
------------------------- ------------ ----------- ------------
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adb        500    78    422
adbtmp        50    7    43
Addressbook    12    7    5
c3k        1024    65    959
c3ktmp        100    7    93
cc        1176    367    809
cctmp        200    8    192
mediastore    100    10    90
mediatmp        50    7    43
tempdb        112    8    104
tr        1400    29    1371
trtmp        50    7    43
umarchive    700    22    678
umarchivetmp    100    7    93

Related topics:
Finding the error log file on page 89
Finding the database server name on page 89
Finding the database server version numbers on page 90
Finding the open server and client library version numbers on page 90

Finding the error log file
Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type isql —U sa —P password and press Enter.
If you have forgotten the password, see Forgotten the password to login as sa on
page 87.

3. At the command prompt, type select @@errorlog and press Enter.

4. Type go and press Enter.

Example
The system displays the error log file path and filename. For example:
-------------------------------------
C:\Sybase\ASE-15_0\install\ASE.log

Finding the database server name
Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type isql —U sa —P password and press Enter.
If you have forgotten the password, see Forgotten the password to login as sa on
page 87.

3. At the command prompt, type select @@servername and press Enter.

General troubleshooting information
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4. Type go and press Enter.

Example
The system displays the name of the database server. For example:
-------------------------------
ASE

Finding the database server version numbers
Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type isql —U sa —P password and press Enter.
If you have forgotten the password, see Forgotten the password to login as sa on
page 87.

3. At the command prompt, type select @@version and press Enter.

4. Type go and press Enter.

Example
The system displays the database server version numbers. For example:
--------------------------------------------------------------
--------------------------------------------------------------
Adaptive Server Enterprise/15.5/EBF 17218 SMP/P/NT (IX86)/Windows 2003/ase155/2
                 391/322-bit/OPT Mon Nov 09 14:18:14 2014

Finding the open server and client library version numbers
Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type isql —U sa —P password and press Enter.
If you have forgotten the password, see Forgotten the password to login as sa on
page 87.

3. At the command prompt, type bcp —v and press Enter.

4. Type go and press Enter.

Example
The system displays the database server version numbers. For example:
Sybase CTBCP Utility/15.5/P-EBF17949 ESD #5/PC Intel/BUILD1550-007/OPT/Tue Nov 25 
00:45:29 2014

Troubleshooting
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Checking database used and free space and memory capacity

Check the following characteristics of a database:

• Size

• Used space

• Free space

Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type isql —U sa —P password and press Enter.
If you have forgotten the password, see Forgotten the password to login as sa on
page 87.

3. At the command prompt, type sp_m_checkspace dbname, where dbname is the
name of the database that you want to check, and press Enter.

4. Type go and press Enter.
The system displays size, used space, and free space. For example:
  DB Name                                        size         used          free
----------------------------------------------- ------------ 
------------- -----------
cc                                               1024MB       171MB         853MB

(1 row affected)
 DB Name                                        size         used          free
----------------------------------------------- ------------ 
------------- -----------
cc                                               200MB        1MB           
199MB

Setting database free memory threshold values

When the acb, cc, and tr database free memory threshold values reach 80%, 85%, and 90%,
the system adds warning messages to the db_srv log file and Sybase error log file. For
example:
free space threshold passed db-=cc, segment=default, fill level=80% (13300 pages 
left), status=1

About this task
Set the high, medium, and low free memory threshold values to tell the system when to add
warning messages to the log file. The default values are 80%, 85%, and 90%.
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Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type isql —U sa —P password and press Enter.
If you have forgotten the password, see Forgotten the password to login as sa on
page 87.

3. Type sp_m_setthresholds dbname, high, medium, low and press
Enter.
For example:

1> sp_m_setthresholds adb, 20, 15, 10

 Tip:
Enter a ? in place of the dbname to see Sybase help for the stored procedure.

4. Type go and press Enter.

Using stored procedures

You can use the stored procedures to query the database memory capacity and the
connections to the database server.

See the Sybase online help for more information.

Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type isql —U sa —P password and press Enter.
If you have forgotten the password, see Forgotten the password to login as sa on
page 87.

3. At the command prompt, type the stored procedures command and press Enter
and the required variables and values, if necessary.

4. Type go and press Enter.
The system displays the information defined by the command.
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Troubleshooting configuration errors

Error: 100011 Data not found or changed

Error code 100011 Data not found or changed

Trigger component UMR Admin

Problem description
When trying to configure an agent’s email account, the UMR Admin component displays the
error message listed above or this message:
E-Mail is already assigned to a user ...!

While you can delete an agent in the system, the C3000 system does not allow user deletion.
The C3000 system identifies users with the @ symbol and a sequential number. For example,
username@1.

Solution

Procedure

Do not edit or select deleted agents in UMR Admin.

Error: 1205 Your server command was deadlocked

Error code 1205 Your server command (process id 127) was
deadlocked with another process and has been chosen
as deadlock victim. Re-run your command.

Trigger component Sybase ASE

Problem description
In a deadlock situation, two or more processes wait for resources such as a table or an index
while it is in use by another process. The process with the smallest computing time is typically
terminated. Deadlocks add an error message to the db_srv log file.

Troubleshooting configuration errors
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Solution

About this task
If deadlocks occur frequently, you can configure the error message output to provide additional
information such as current process and the SQL query to the log file. Use that information to
manage database processing delays. For more information see, Database processing
delays on page 95 and Multiple processor optimization.

Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type isql —U sa —P password and press Enter.
If you have forgotten the password, see Forgotten the password to login as sa on
page 87.

3. At the command prompt, type sp_configure ‘print deadlock
information’, 1 and press Enter.

4. Type go and press Enter.

Error: Cannot connect to Windows Firewall

Error code Cannot connect to Windows Firewall

Trigger component Microsoft Windows Firewall Internet Connection Sharing (ICS)

Problem description
The Naming Service and the License Client installation process accesses the Windows
Firewall ICS service. If the Windows Firewall service is not active, an error occurs.

Solution

Procedure

1. Click Start > Settings > Control Panel.

2. Double-click Windows Firewall.
If the ICS service is not running, this step will start the service.

3. Continue with the system installation.
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Agent receives a winmail.dat or win.dat file
An agent may receive an email with an attached file named winmail.dat or win.dat. The
agent cannot open this file using the normal method.

Solution

Microsoft uses a proprietary format called Transport Neutral Encapsulation Format (TNEF) for
the attached files.

Procedure

Use an application such as Winmail Opener to open the attachment.
The application is available from the Internet. For more information, see http://
support.microsoft.com/kb/241538/.

Database processing delays
If a process accesses a table, the system locks the table and its parts. If another process tries
to access the same data structure, that process must wait until the lock is released. Locking
can lead to processing delays. A problem can also occur if a process does not release a lock
because of an error.

Solution

About this task
Determine if a process has locked a table. Assign a system process identifier (spid) to a
process to be able to terminate the blocking process.

Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type isql —U sa —P password and press Enter.
If you have forgotten the password, see Forgotten the password to login as sa on
page 87.

3. Type sp_who and press Enter.

4. Type go and press Enter.
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The system displays a list of existing processes and a number greater than or less
than 0 in the blk_spid column if the process is blocked. The number corresponds
to blocking process’s spid.

5. Type sp_m_connections and press Enter.

6. Type go and press Enter.

7. Type kill spid and press Enter.

8. Type go and press Enter.
The system terminates the process by rolls back the blocking transaction.

 Tip:
If the process does not terminate, you can reset the ASE server.

Java does not work after hardware change
Java does not work after you change hardware components.

Solution

Java cannot access the network adapter after a hardware change.

Procedure

1. Uninstall the Java Development Kit (JDK).

2. Reinstall JDK.

Java processes do not start
If Java processes do not start it may be because the virus scanner takes longer than 30
seconds to check the processes.

Solution

Change the virus scanner scan time maximum to 30 seconds.

Procedure

1. Right-click McAfee on the task bar.
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2. Select Manage Features > VirusScan Enterprise from the menu.

3. Right-click On-Access Scanner.

4. Click Properties.

5. Under Scan time, change Maximum scan time (seconds) to 30.

6. Alternatively, you can change the following setting for all system Java processes in
the _wrapper.conf file.
wrapper.startup timeout = 30

Messages cannot be sent through SMTP Connector
If you use McAfee 8.0 virus scanner, you cannot send messages through SMTP Connector
unless it is included in the trusted program list.

Solution

McAfee blocks port 25 which is typically used for the SMTP protocol. Add the SMTP Connector
as a trusted program to the McAfee trusted program list.

Procedure

1. Right-click McAfee on the task bar.

2. Select Manage Features > VirusScan Enterprise from the menu.

3. Double-click Access Protection.

4. Select the Port Blocking tab.

5. Select Prevent mass mailing worms from sending mail.

6. Click Edit.

7. Add SMTPConnector.exe to the list.
If you want to send voice messages which are recorded with internal IVR, you must
add ivr.exe.

8. Exit VirusScan Console.

OmniNames does not start
The Corba name services will not start if you change hardware or network settings.
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Solution

Delete the log files.

Procedure

1. In the c:\Documents and Settings\All Users\Application Data
\omniORB folder, if available, delete the following files:

• omninames_hostname.log
• omninames_hostname.bak

2. Delete the file omninames.errlog.

3. Restart the service.

Problems after restoring a database
After restoring a CC, c3k, or adb database backups to the master database, processes may
not register correctly to the database. The following error message may appear:user xy is
not a valid user in database xyz.

This can occur if you install the software, backup the database, reinstall the software, and then
try to restore the backup.

Solution

Change the suid in the system table sysusers of the appropriate database. The example
below refers to the CC database.

Procedure

1. Click Start > Run... and enter c:\Windows\system32\cmd.exe to open the MS-
DOS Command Prompt window. Click OK.

2. At the command prompt, type isql —U sa —P password and press Enter.
If you have forgotten the password, see Forgotten the password to login as sa on
page 87.

3. At the command prompt, type use dbname, where dbname is the name of the
database. Press Enter.

4. Type go and press Enter.

5. Type exec sp_configure ‘allow updates’, 1 and press Enter.
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6. Type go and press Enter.

7. Type use dbname and press Enter.

8. Type go and press Enter.

9. Type update sysusers set suid = master..syslogins.suid from
master..syslogins where master..syslogins.name =
sysusers.name

10. Type go and press Enter.

11. Type exec sp_configure 'allow updates', 0 and press Enter.

12. Type go and press Enter.

Reporting viewer or WebLM is not working
You cannot connect to the web server when using the reporting viewer or WebLM because
the browser proxy server exception is not present.

Solution

If Microsoft Internet Explorer is using a proxy server, you must configure an exception.

Procedure

1. Start Microsoft Internet Explorer.

2. Click Tools > Internet Options.

3. On the Connections tab, under LAN Settings, click Settings.

4. Under Proxy server, click Advanced.

5. Under Exceptions, enter the following exceptions where PC host name is the host
name of the computer running the reporting viewer or WebLM:

• PC host name:8443 for WebLM.

• PC host name:8080 for reporting viewer.

6. Click OK.

7. Click OK.

8. Click OK.
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Tomcat applications are not running
Tomcat applications will not run in Secure Socket Layer (SSL) mode if the host name is not in
the trusted site list.

Solution

Procedure

Add the Tomcat server host name as a trusted site in the Microsoft Internet Explorer
configuration on the agent’s computer.

Unable to enter the terminal when you start the User Interface of the
IP Office Contact Center server.

The User Interface of the IP Office Contact Center server is to configure the active Taskflow
as an Administrator. However, to enable an agent to enter the terminal number on the server
for test calls:

1. Select Start > Control Panel > Programs > Programs and Features.
2. Select IP Office Contact Center User Interface.
3. Click Change.
4. Click Next.
5. Click Modify.
6. Click Next.
7. Click Next.
8. Enable Activate terminal selection.
9. Click Next.

10. Click Change.
11. Click Finish.

Voice Control does not load IVR script
Voice Control does not run an IVR script.
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Solution

Procedure

Ensure that references used in scripts, variables, and tags, etc. are available and
defined.

Voice Control Logic element condition not processed correctly
The system processes a condition in a Voice Control Logic element incorrectly.

Solution

Procedure

Do not use the words lower or upper as part of the variable name.

Troubleshooting configuration errors
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Troubleshooting
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Appendix A: IP Office Contact Center
processes

Processes that are started with Watchdog
The following processes are started by Watchdog:

• omniORB Naming service
• lna
• TRDB
• MediaStoreDB
• Tomcat
• TaskserverManager
• CHAP
• IPOTaskserver
• Avaya Chap Sync
• Avaya VEA
• chat
• reconstr
• Kernel
• vectors
• VC
• Monitor
• Statistic
• TRS
• SessionManager
• StatGen
• ADB
• c3kDB-Server
• c3kLNA-Server
• C3000 Server
• UmrConfigServer
• UmrTaskserver
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• C3000 ClientAdapter
• SMTP Connector
• POP3IMAP$Client
• Text TemplateServer
• Rod CommandExecuter
• Rod Achie
• Rod Rodomat
• Rod Scheduler Server
• Rod Reposerv
• lad
• OD
• disk

IP Office Contact Center processes
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Glossary

CHAP CHAP stands for Common Hardware Abstraction Platform. CHAP is an
abstraction layer that supports different types of hardware such as ISDN,
OpenH323, TAPI, and TSAPI.

HTTP HTTP stands for HyperText Transfer Protocol. HTTP is a general, status-
less, object-oriented protocol for data transfer within the framework of
the World Wide Web (WWW)

HTTPS HTTPS stands for Hypertext Transfer Protocol Secure and is a network
protocol that enables a secure HTTP connection between computers.
The data are encoded via SSL to make them tap-proof.

Internet Protocol A connectionless protocol that operates at Layer 3 of the Open Systems
Interconnect (OSI) model. Internet Protocol (IP) is used for Internet
addressing and routing packets over multiple networks to a final
destination. IP works in conjunction with Transmission Control Protocol
(TCP), and is identified as TCP/IP.

ODBC ODBC stands for Open DataBase Connectivity. ODBC is a standardized
database interface that uses the SQL database language.

PBX PBX stands for Private Branch eXchange or a telecommunications
system. It is a device for connecting internal telephones to each other
and to the public telecommunications network. It can also have data
transfer functions.

SIP Session Initiation Protocol. Mostly used protocol for telephony
systems.

TCP TCP stands for Transmission Control Protocol. TCP is a connection-
oriented transmission protocol for use in packet-switched networks. This
protocol is based on IP protocol, supports transport layer functions and
establishes a secure connection between the instances before
transferring data.

UDP UDP stands for User Datagram Protocol.

UMR UMR stands for Unified Messaging Routing.
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