OpenSSL is a toolkit that implements the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) protocols, as well as a full-strength, general purpose cryptography library.
It was found that OpenSSL clients and servers could be forced, via a specially crafted handshake packet, to use weak keying material for communication. A man-in-the-middle attacker could use this flaw to decrypt and modify traffic between a client and a server. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0224 to this issue.
Note: In order to exploit this flaw, both the server and the client must be using a vulnerable version of OpenSSL; the server must be using OpenSSL version 1.0.1 and above, and the client must be using any version of OpenSSL. For more information about this flaw, refer to: https://access.redhat.com/site/articles/904433
A buffer overflow flaw was found in the way OpenSSL handled invalid DTLS packet fragments. A remote attacker could possibly use this flaw to execute arbitrary code on a DTLS client or server. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0195 to this issue.
Multiple flaws were found in the way OpenSSL handled read and write buffers when the SSL_MODE_RELEASE_BUFFERS mode was enabled. A TLS/SSL client or server using OpenSSL could crash or unexpectedly drop connections when processing certain SSL traffic. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the names CVE-2010-5298 and CVE-2014-0198 to these issues.
A denial of service flaw was found in the way OpenSSL handled certain DTLS ServerHello requests. A specially crafted DTLS handshake packet could cause a DTLS client using OpenSSL to crash. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-0221 to this issue.
A NULL pointer dereference flaw was found in the way OpenSSL performed anonymous Elliptic Curve Diffie Hellman (ECDH) key exchange. A specially crafted handshake packet could cause a TLS/SSL client that has the anonymous ECDH cipher suite enabled to crash. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2014-3470 to this issue.
More information about these vulnerabilities can be found in the security advisory issued by Red Hat:
| Product: | Affected Version(s): | Risk Level: | Actions: |
|---|---|---|---|
| Avaya CMS | R17 thru R17 R3 | Medium | Upgrade to R17 R4 or later. |
| Avaya Aura® Collaboration Environment | 2.x | Medium | Upgrade to 3.0 or later. |
| Avaya Aura® Experience Portal | 6.0 thru 6.0.3, 7.x | Medium | For 6.0, upgrade to 6.0.3 and Avaya Linux for 6.0.3 and install Security Updates for 6.0.3. For 6.0.3, install Security Updates for 6.0.3. For 7.0, install Security Updates for 7.0. For 7.0.1, install Security Updates for 7.0.1. |
| Avaya IP Office Server Edition | 8.1, 9.0 | Medium | Upgrade to 9.1 or later. |
| Avaya IP Office Application Server | 9.0 | Medium | Upgrade to 9.1 or later |
| Avaya one-X® Client Enablement Services | 6.2 thru 6.2 SP2 | Medium | Upgrade to 6.2 SP3 or later. |
| Avaya Aura® Session Manager | 6.3 thru 6.3.8 | Medium | Upgrade to 6.3.9 or later |
Recommended Actions for System Products:
Avaya strongly recommends following networking and
security best practices by implementing firewalls, ACLs,
physical security or other appropriate access restrictions.
Though Avaya believes such restrictions should always be in
place, risk to Avaya products and the surrounding network
from this potential vulnerability may be mitigated by
ensuring these practices are implemented until such time as
an Avaya provided product update or the recommended Avaya
action is applied.
Further restrictions as deemed necessary based on the
customer's security policies may be required during this
interim period, but the System Product operating system or
application should not be modified unless the change is
approved by Avaya. Making changes that are not approved may
void the Avaya product service contract.
When determining risk, Avaya takes into account many factors as outlined by Avaya's Security Vulnerability Classification Policy. The following table describes factors that mitigate the risk of specific vulnerabilities for affected Avaya products:
| Vulnerability | Mitigating Factors |
|---|---|
|
CVE-2010-5298 CVE-2014-0198 CVE-2014-0224 |
These are a Medium risk due to the potential exposure of sensitive information or connection termination (Denial of Service). |
|
CVE-2014-0195 CVE-2014-0221 CVE-2014-3470 |
These are a Low risk as ECC and/or DTLS are not used by default. |
Avaya software-only products operate on general-purpose operating systems. Occasionally vulnerabilities may be discovered in the underlying operating system or applications that come with the operating system. These vulnerabilities often do not impact the software-only product directly but may threaten the integrity of the underlying platform.
In the case of this advisory Avaya software-only products are not affected by the vulnerability directly but the underlying Linux platform may be. Customers should determine on which Linux operating system the product was installed and then follow that vendor's guidance.
| Product: | Actions: |
|---|---|
| Avaya Aura® Experience Portal | Depending on the Operating System installed, the affected package may be installed on the underlying Operating System supporting the EP application. |
Recommended Actions for Software-Only Products:
In the event that the affected package is installed, Avaya recommends following recommended actions supplied by Red Hat regarding their Enterprise Linux.
Additional information may also be available via the Avaya support website and through your Avaya account representative. Please contact your Avaya product support representative, or dial 1-800-242-2121, with any questions.
ALL INFORMATION IS BELIEVED TO BE CORRECT AT THE TIME OF PUBLICATION AND IS PROVIDED "AS IS". AVAYA INC., ON BEHALF ITSELF AND ITS SUBSIDIARIES AND AFFILIATES (HEREINAFTER COLLECTIVELY REFERRED TO AS "AVAYA"), DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE AND FURTHERMORE, AVAYA MAKES NO REPRESENTATIONS OR WARRANTIES THAT THE STEPS RECOMMENDED WILL ELIMINATE SECURITY OR VIRUS THREATS TO CUSTOMERS' SYSTEMS. IN NO EVENT SHALL AVAYA BE LIABLE FOR ANY DAMAGES WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH THE INFORMATION OR RECOMMENDED ACTIONS PROVIDED HEREIN, INCLUDING DIRECT, INDIRECT, INCIDENTAL, STATUTORY, CONSEQUENTIAL DAMAGES, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF AVAYA HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
THE INFORMATION PROVIDED HERE DOES NOT AFFECT THE SUPPORT AGREEMENTS IN PLACE FOR AVAYA PRODUCTS. SUPPORT FOR AVAYA PRODUCTS CONTINUES TO BE EXECUTED AS PER EXISTING AGREEMENTS WITH AVAYA.
V 1.0 - June 18, 2014 - Initial Statement issued.
V 2.0 - August 20, 2014 - Updated CE, CES and SM affected versions and actions.
V 3.0 - February 23, 2015 - Updated CMS, EP, IPO and IPOAS affected versions and actions.
Avaya customers or Business Partners should report any security issues found with Avaya products via the standard support process.
Independent security researchers can contact Avaya at
[email protected].
Linux® is the registered trademark of Linus Torvalds in the U.S. and other countries.
© 2014 Avaya Inc. All Rights Reserved. All trademarks identifying Avaya products by the ® or ™ are registered trademarks or trademarks, respectively, of Avaya Inc. All other trademarks are the property of their respective owners.