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Notice

While reasonable efforts have been made to ensure that the
information in this document is complete and accurate at the time of
printing, Avaya assumes no liability for any errors. Avaya reserves
the right to make changes and corrections to the information in this
document without the obligation to notify any person or organization
of such changes.

Documentation disclaimer

“Documentation” means information published by Avaya in varying
mediums which may include product information, operating
instructions and performance specifications that Avaya generally
makes available to users of its products. Documentation does not
include marketing materials. Avaya shall not be responsible for any
modifications, additions, or deletions to the original published version
of documentation unless such modifications, additions, or deletions
were performed by Avaya. End User agrees to indemnify and hold
harmless Avaya, Avaya's agents, servants and employees against all
claims, lawsuits, demands and judgments arising out of, or in
connection with, subsequent modifications, additions or deletions to
this documentation, to the extent made by End User.

Link disclaimer

Avaya is not responsible for the contents or reliability of any linked
websites referenced within this site or documentation provided by
Avaya. Avaya is not responsible for the accuracy of any information,
statement or content provided on these sites and does not
necessarily endorse the products, services, or information described
or offered within them. Avaya does not guarantee that these links will
work all the time and has no control over the availability of the linked
pages.

Warranty

Avaya provides a limited warranty on its hardware and Software
(“Product(s)”). Refer to your sales agreement to establish the terms
of the limited warranty. In addition, Avaya’s standard warranty
language, as well as information regarding support for this Product
while under warranty is available to Avaya customers and other
parties through the Avaya Support website: http://support.avaya.com.
Please note that if you acquired the Product(s) from an authorized
Avaya reseller outside of the United States and Canada, the warranty
is provided to you by said Avaya reseller and not by Avaya.
“Software” means computer programs in object code, provided by
Avaya or an Avaya Channel Partner, whether as stand-alone
products or pre-installed on hardware products, and any upgrades,
updates, bug fixes, or modified versions thereto.

Licenses

THE SOFTWARE LICENSE TERMS AVAILABLE ON THE AVAYA
WEBSITE, HTTP://SUPPORT.AVAYA.COM/LICENSEINFO/ ARE
APPLICABLE TO ANYONE WHO DOWNLOADS, USES AND/OR
INSTALLS AVAYA SOFTWARE, PURCHASED FROM AVAYA INC.,
ANY AVAYA AFFILIATE, OR AN AUTHORIZED AVAYA RESELLER
(AS APPLICABLE) UNDER A COMMERCIAL AGREEMENT WITH
AVAYA OR AN AUTHORIZED AVAYA RESELLER. UNLESS
OTHERWISE AGREED TO BY AVAYA IN WRITING, AVAYA DOES
NOT EXTEND THIS LICENSE IF THE SOFTWARE WAS OBTAINED
FROM ANYONE OTHER THAN AVAYA, AN AVAYA AFFILIATE OR
AN AVAYA AUTHORIZED RESELLER; AVAYA RESERVES THE
RIGHT TO TAKE LEGAL ACTION AGAINST YOU AND ANYONE
ELSE USING OR SELLING THE SOFTWARE WITHOUT A
LICENSE. BY INSTALLING, DOWNLOADING OR USING THE
SOFTWARE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON
BEHALF OF YOURSELF AND THE ENTITY FOR WHOM YOU ARE
INSTALLING, DOWNLOADING OR USING THE SOFTWARE
(HEREINAFTER REFERRED TO INTERCHANGEABLY AS “YOU”
AND “END USER”), AGREE TO THESE TERMS AND CONDITIONS
AND CREATE A BINDING CONTRACT BETWEEN YOU AND
AVAYA INC. OR THE APPLICABLE AVAYA AFFILIATE (“AVAYA”).

Avaya grants you a license within the scope of the license types
described below, with the exception of Heritage Nortel Software, for
which the scope of the license is detailed below. Where the order
documentation does not expressly identify a license type, the
applicable license will be a Designated System License. The

applicable number of licenses and units of capacity for which the
license is granted will be one (1), unless a different number of
licenses or units of capacity is specified in the documentation or other
materials available to you. “Designated Processor” means a single
stand-alone computing device. “Server” means a Designated
Processor that hosts a software application to be accessed by
multiple users.

Heritage Nortel Software

“Heritage Nortel Software” means the software that was acquired by
Avaya as part of its purchase of the Nortel Enterprise Solutions
Business in December 2009. The Heritage Nortel Software currently
available for license from Avaya is the software contained within the
list of Heritage Nortel Products located at http://support.avaya.com/
Licenselnfo under the link “Heritage Nortel Products”. For Heritage
Nortel Software, Avaya grants Customer a license to use Heritage
Nortel Software provided hereunder solely to the extent of the
authorized activation or authorized usage level, solely for the purpose
specified in the Documentation, and solely as embedded in, for
execution on, or (in the event the applicable Documentation permits
installation on non-Avaya equipment) for communication with Avaya
equipment. Charges for Heritage Nortel Software may be based on
extent of activation or use authorized as specified in an order or
invoice.

Copyright

Except where expressly stated otherwise, no use should be made of
materials on this site, the Documentation, Software, or hardware
provided by Avaya. All content on this site, the documentation and
the Product provided by Avaya including the selection, arrangement
and design of the content is owned either by Avaya or its licensors
and is protected by copyright and other intellectual property laws
including the sui generis rights relating to the protection of databases.
You may not modify, copy, reproduce, republish, upload, post,
transmit or distribute in any way any content, in whole or in part,
including any code and software unless expressly authorized by
Avaya. Unauthorized reproduction, transmission, dissemination,
storage, and or use without the express written consent of Avaya can
be a criminal, as well as a civil offense under the applicable law.

Third Party Components

“Third Party Components” mean certain software programs or
portions thereof included in the Software that may contain software
(including open source software) distributed under third party
agreements (“Third Party Components”), which contain terms
regarding the rights to use certain portions of the Software (“Third
Party Terms”). Information regarding distributed Linux OS source
code (for those Products that have distributed Linux OS source code)
and identifying the copyright holders of the Third Party Components
and the Third Party Terms that apply is available in the
Documentation or on Avaya’s website at: http://support.avaya.com/
Copyright. You agree to the Third Party Terms for any such Third
Party Components.

Note to Service Provider

The Product may use Third Party Components that have Third Party
Terms that do not allow hosting and may need to be independently
licensed for such purpose.

Preventing Toll Fraud

“Toll Fraud” is the unauthorized use of your telecommunications
system by an unauthorized party (for example, a person who is not a
corporate employee, agent, subcontractor, or is not working on your
company's behalf). Be aware that there can be a risk of Toll Fraud
associated with your system and that, if Toll Fraud occurs, it can
result in substantial additional charges for your telecommunications
services.

Avaya Toll Fraud Intervention

If you suspect that you are being victimized by Toll Fraud and you
need technical assistance or support, call Technical Service Center
Toll Fraud Intervention Hotline at +1-800-643-2353 for the United
States and Canada. For additional support telephone numbers, see
the Avaya Support website: http://support.avaya.com. Suspected
security vulnerabilities with Avaya products should be reported to
Avaya by sending mail to: securityalerts@avaya.com.
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Trademarks

The trademarks, logos and service marks (“Marks”) displayed in this
site, the Documentation and Product(s) provided by Avaya are the
registered or unregistered Marks of Avaya, its affiliates, or other third
parties. Users are not permitted to use such Marks without prior
written consent from Avaya or such third party which may own the
Mark. Nothing contained in this site, the Documentation and
Product(s) should be construed as granting, by implication, estoppel,
or otherwise, any license or right in and to the Marks without the
express written permission of Avaya or the applicable third party.

Avaya is a registered trademark of Avaya Inc.

All non-Avaya trademarks are the property of their respective owners,
and “Linux” is a registered trademark of Linus Torvalds.

Downloading Documentation

For the most current versions of Documentation, see the Avaya
Support website: http://support.avaya.com.

Contact Avaya Support

See the Avaya Support website: http://support.avaya.com for product
notices and articles, or to report a problem with your Avaya product.
For a list of support telephone numbers and contact addresses, go to
the Avaya Support website: http://support.avaya.com, scroll to the
bottom of the page, and select Contact Avaya Support.
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Chapter 1: Voicemail Pro

Voicemail Pro

The diagram illustrates a Voicemail Pro system with some of the setup options.

This manual covers the installation of a Windows base Voicemail Pro server with IP Office. The
installation of Linux based servers is covered separately in the manuals for deploying a Unified
Communications Module, Application Server or Server Edition system.

ContactStore
Woicemail Woice Recordings
Serder Library
(Cational]
LAMN k“;
0
|F Cffice
{lFoiemai! Aro) %

E-mail Server
(Oational)

Wt

IP Office The IP Office Voicemail Pro licenses on page 10 are entered into the

Control Unit configuration of the IP Office system. The licenses are required to activate
Voicemail Pro features. You can run an unlicensed Voicemail Pro service for
demonstration and testing for a duration of two hours only. License keys are

October 2018 Deploying Avaya IP Office™ Platform Voicemail Pro (Windows)

Comments on this document? infodev@avaya.com



mailto:infodev@avaya.com?subject=Deploying Avaya IP Office™ Platform Voicemail Pro (Windows)

Voicemail Pro

Voicemail Pro
Server

Voicemail Pro
Client

Telephone
Extension

User's

Computer

E-mail Server

ContactStore
Server

October 2018

issued against and validated against the unique serial number of the feature
key dongle used by the IP Office.

The Voicemail Pro service is installed on a server computer. This becomes
the computer where messages and other data are stored for the mailboxes
and services provided by Voicemail Pro. The server can be a Windows or
Linux based server.

There are a number of scenarios where multiple Voicemail Pro servers can
be supported. For example, to provide a backup Voicemail Pro server or to
support multiple IP Office systems in a network. See Centralized Voicemail
Pro Server on page 113.

The Voicemail Pro Client is used to administer the Voicemail Pro service. The
client is a Windows application that you can install on another computer to
allow remote administration of the server. Only one client can connect to the
server at any time.

The version of a Voicemail Pro client used with a Voicemail Pro server should
match. If the Voicemail Pro client is used to load a call flow from an earlier
version of Voicemail Pro server, you will be warned that if you edit the call
flow you will not be able to save it back to the original server. If the client is
used to load a call flow from a later version of Voicemail Pro server it will stop
the action and prompt that the call flow cannot be loaded.

For internal extensions, the Voicemail Pro server provides message waiting
indication. This is done automatically for the telephone user's own mailbox.
However, the user can also be configured to receive message waiting
indication for other mailboxes.

In addition to accessing mailbox voicemail messages through the telephone,
there is a range of methods for accessing messages from a user's computer.
This can be by web browser, IMAP e-mail account, Exchange server e-mail
account, and various other options. The IP Office one-X Portal for IP Office
application can also be used.

Using an e-mail server, Voicemail Pro can provide a number of services. This
includes the ability to send message alerts or message copies. For Exchange
e-mail servers, with the forward to e-mail option, the Exchange server can be
used as the message store with users accessing their messages using
Exchange clients such as Microsoft Outlook, Outlook Web Access, and so
on.

In addition to taking voicemail messages, the Voicemail Pro can be used for
automatic and manual call recordings. These recordings are stored in the
Voicemail Pro server mailboxes. ContactStore for IP Office is an additional
licensed application to which recordings can be transferred for long term
storage. ContactStore supports archiving to DVD, access by web browser,
and searching based on call details.

Deploying Avaya IP Office™ Platform Voicemail Pro (Windows)
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Voicemail Pro

Installation of ContactStore for IP Office is covered in its own separate
installation manual. For proper functioning, install and test Voicemail Pro
before installing ContactStore for IP Office.

Supported languages

By default, the prompts installed match the installer language selection plus English. If other
languages are required, they need to be selected by doing a custom installation. The installable
Voicemail Pro prompts are listed in the table below. The availability of a language in voicemail
does not necessarily indicate support for IP Office in a country that uses that language.

Language WAV folder Fallback selection TTS Windows
Brazilian Portuguese ptb >pt>en. o
Chinese (Cantonese) zzh >en > enu. of
Chinese (Mandarin) ch >en > enu. o
Danish da >en. o
Dutch nl > en. o
English UK en >en. o
English US enu > en. of
Finnish fi >en. of
French fr > frc > en. o
French Canadian frc >fr>enu>en. o
German de >en. o
Greek el > en. o
Hungarian hu >en. X
Italian it > en. o
Japanese ip >en. X
Korean ko > en. o
Latin Spanish eso >es>enu>en. o
Mediterranean heb > en. X
Norwegian no >en. o
Polish pl >en. o
Portuguese pt > ptb > en. o
Russian ru > en. o
Spanish es >eso >en. o
Spanish (Colombia) eso >es >enu>en. o
Swedish sV >en. o
Turkish trk > en. X
October 2018 Deploying Avaya IP Office™ Platform Voicemail Pro (Windows) 9
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Voicemail Pro

When the IP Office routes a call to the Voicemail Pro server, it indicates the locale for which
matching prompts should be provided, if available. Within the IP Office configuration, a locale is
always set for the system. However, differing locales can be set for each user, incoming call route,
and short codes in addition to the default system locale.

The locale sent to the Voicemail Pro server by the IP Office is determined as follows:

Locale source Usage

The short code locale, if set, is used if the call is routed to voicemail using the

Short Code Locale short code.

If no user or incoming call route locale is set, system locale is used, unless

SELETD (HeeE (R overridden by a short code locale.

Incoming Call Route

Locale The incoming call route locale, if set, is used if the caller is external.

User Locale The user locale, if set, is used if the caller is internal.

If the prompts matching the IP Office locale are not available, the Voicemail Pro server will provide
prompts from a fallback language, if available. The above table of languages lists the order of
fallback selection.

If required, the language provided by a voicemail call flow can be changed using a =T Select
System Prompt Language action.

TTY Teletype Prompts

TTY (Teletype (Textphone)) is included in the list of installable languages. TTY is a text-based
system that is used to provide services to users with impaired hearing.

Voicemail Pro licenses

The Help > About screen in the voicemail client can be used to check which IP Office the
Voicemail Pro server is working and the licenses it has received from that IP Office.

The license keys are entered into the IP Office configuration using the IP Office Manager. If the
Voicemail Pro server is installed without licenses, it will run for 2 hours and then shut down.

For IP Office Release 6 and higher, support for Voicemail Pro is enabled by the addition of a
Preferred Edition license.

Preferred Edition (Voicemail Pro)

This license enables support for Voicemail Pro as the IP Office voicemail server with four
voicemail ports. A Voicemail Pro server with the Preferred Edition license provides the services
listed below. Additional licenses can be added for additional voicemail features, these are detailed
separately. The Preferred Edition license was previously called Voicemail Pro (4 ports).

Server Edition

On IP Office Server Edition, the Server Edition license provides all the Voicemail Pro features that
are provided by the Preferred Edition license on IP500 V2.
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Voicemail Pro

Additional Voicemail Pro Messaging Ports

The required license for Voicemail Pro server support [Preferred Edition (Voicemail Pro)] also
enables four voicemail ports. This license can be used to add additional voicemail ports up to the
maximum capacity of the IP Office system (IP500 V2 = 40, IP Office Server Edition = 250). This
license was previously called Additional Voicemail Pro (ports).

VMPro Recordings Administrators

To support ContactStore in a small community network (SCN), all the IP Offices in the SCN
require either their own Advanced Edition license or the VMPro Recordings Administrators license.

VMPro Networked Messaging

Enables the VPNM (Voicemail Pro Networked Messaging) functionality within Voicemail Pro.
Enabling VPNM is required for message exchange with remote Voicemail Pro systems and Avaya
Interchange systems.

VMPro TTS (Generic)

This legacy license enables use of text-to-speech facilities using third-party TTS software with
Voicemail Pro. One license per simultaneous instance of TTS usage. The IP Office Advanced
Edition license also enables eight ports of generic TTS.

VMPro TTS (ScanSoft)

This legacy license enables use of text-to-speech facilities using Avaya-supplied TTS software
with Voicemail Pro running on a Windows server. One license per simultaneous instance of TTS
usage.

Legacy licenses
The following legacy licenses are still supported by IP Office Release 6 and higher.

UMS Web Services: This legacy license is used to enable UMS voicemail services support for
users set to the Basic User profile. Other users are enabled for UMS through their licensed user
profile.

Number of simultaneous users

All connections between the Voicemail Pro server and IP Office are through LAN using data
channels. The maximum number of data channels that can be used for Windows voicemail server
operation at any moment are shown below.

IP Office Maximum for Voicemail Pro
IP500 V2 40

The actual number of simultaneous users is determined by the licenses for Voicemail Pro added to
the IP Office configuration. Note that some specific functions can have voicemail channels
reserved for their use or can have channel restrictions.

October 2018 Deploying Avaya IP Office™ Platform Voicemail Pro (Windows) 11

Comments on this document? infodev@avaya.com



mailto:infodev@avaya.com?subject=Deploying Avaya IP Office™ Platform Voicemail Pro (Windows)

Chapter 2: Installation

Server installation

This section covers the installation of the Voicemail Pro server on a Windows server computer.
Voicemail Pro can be installed with the IP Office IP500 V2 systems other than those being used as
Server Edition expansion units:

Mixing Linux and Windows servers

In scenarios where multiple Voicemail Pro servers are used, a mix of Windows-based servers and
Linux-based servers (IP Office Application Server and/or UCM module) can be used.

Related links
Centralized Voicemail Pro overview on page 87

General installation requirements

Here is a list of general requirements for all types of voicemail installation.

* A client computer with IP Office Manager and Microsoft .NET Framework versions 2.0
installed on it. If NET 2.0 is not detected, you will be prompted to install it before the
Voicemail Pro installation proceeds.

* A license for Voicemail Pro and any additional voicemail ports is required. If Voicemail Pro
Server is installed without a license it will run for two hours and then shut down.

* Licenses for any other Voicemail Pro components being installed, see Voicemail Pro
licenses on page 10.

« Latest version of the IP Office Applications DVD along with the latest fixes and patches. To
get the latest version of a required software, visit http://support.avaya.com.

0 Tip:
» Before you begin to install Voicemail Pro, check that the computer that you are using can

connect to the IP Office unit and that you can load and save a configuration file using IP
Office Manager.

» Switch off any computer and hard disk sleep, power down, suspend, hibernation modes.
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General installation requirements

* Install the Voicemail Pro software using an account with full administrator rights on the
computer. The service subsequently runs under that account. If you prefer, create a
separate account for this purpose and configure it such that the account password does
not expire.

Computer specifications

The Voicemail Pro application requires various licenses entered into the IP Office configuration to
control the features it offers and the number of simultaneous connections. For more information,
see Number of simultaneous users on page 11.

The Voicemail Pro software can be installed as separate Voicemail Pro client and server parts.
You can perform remote administration of the Voicemail Pro server from a computer with just the
Voicemail Pro client installed. A copy of the client is automatically installed locally with the
Voicemail Pro server.

Source

DVD IP Office Application DVD (Disk 1)
Languages See Supported Languages on page 9.
IP500 V2 +# |P Office Preferred Edition.

License + See below.

The Voicemail Pro server part of the software consists of several components in addition to the
core server software, these are:

« Campaigns: The Voicemail Pro can be configured to run a campaign. This consists of a
series of questions for which the Voicemail Pro records the callers answer or key presses.
With International Time Zone (ITZ) support, the Voicemail Pro records the IP Office time and
not the Voicemail Pro local time. The resulting recordings can then be played back by users.
Users can use the web aspect of campaigns to perform this playback and processing of
campaign recordings via their web browser. This requires 1IS web server to be run on the
same computer as the Voicemail Pro software. If not already installed, the Voicemail Pro
installer enables and configures IIS on the server.

* UMS Web Voicemail: Users can use UMS to access their voicemail mailbox using either an
IMAP compatible e-mail program or through their web browser. This requires IS web server
to be run on the same computer as the Voicemail Pro software. If not already installed, the
Voicemail Pro installer with enable and configure IIS on the server. It also installs PHP if not
detected as already present.

» Text to Speech (TTS): Through adding additional licenses, the Voicemail Pro is able to use
the TTS functions of Windows to speak text and numbers to callers in addition to recording
prompts. This is intended mainly for scenarios where the Voicemail Pro is obtaining text and
number values from a customer database.

Installation on Windows server operating systems

On many Windows server computers, while the Windows Audio components are present by
default they are not always enabled. If this is the case the playback of voice prompts may be
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‘choppy' and the TTS (if installed) will not work. However, enabling Windows Audio does not
require the server computer to have a sound card installed.

1. Verify that you have full administrator rights for the computer.
2. Click Start > Administrative Tools > Services.

3. If the status of the Windows Audio service is not Started, start the service and set the
Startup Type to Automatic.

© Note:

1. Do not use the Large Fonts setting, as it may cause options on some screens to
become inaccessible.

2. For a good connection speed, use a 100 Mbps network card.
3. Free disk space requirements are also subject to the message storage required.

For more information, see Disk space requirements on page 17

Basic Voicemail Pro

Minimum hardware requirements
RAM 256MB
Hard Disk Free Space 2GB

° Note:

Add 0.5MB per minute of message and prompt storage
space as per your requirements.

Processor Pentium P4 1.4GHz P4 1.4GHz
Celeron Any 1.7GHz Any 1.7GHz
AMD Any 1.4GHz

Operating System Support

Server OS Service
Windows 2008 R2 Server o
Windows 2012/2012 R2 Server o
Windows 2016 Server o
Client OS

Windows 7 o
Windows 8.1 o
Windows 10 o

Voicemail Pro plus UMS Web Voicemail and/or Campaigns

Minimum hardware requirements
RAM 512MB

Table continues...
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Minimum hardware requirements

Hard disk free space 2GB
Processor Pentium P4 2.8GHz
Celeron Not tested.
AMD Athlon XP 3000+, Athlon 64

The following table provides a list of the operating systems that are supported for the server.

Server OS Service
Windows 2008 R2 Server .
Windows 2012/2012 R2 Server "
Windows 2016 Server o

* Both Web Campaigns and UMS Web Voicemail require the 1S web server on the Voicemail
Pro server computer to be enabled. This requires IIS web server to be run on the same
computer as the Voicemail Pro software. If not already installed, the Voicemail Pro installer
enables and configures IIS on the server. It already installed, it must have the following IS
components enabled:

- CGlI
- ASP .Net
- lIS 6 Metabase Compatibility

* UMS requires PHP to be installed on the server. The Voicemail Pro installer installs PHP if it
is not detected as already present.

* On Windows 2012, you also need to install ASP.NET 3.5.
» UMS Web Voicemail installs PHP if not detected as already installed.

Voicemail Pro plus IVR and/or TTS

Minimum hardware requirements: Basic Voicemail Pro
RAM 512MB
Hard disk free space 20GB
Pentium P4 2.8GHz
Processor Celeron Not tested.
AMD Athlon XP 3000+, Athlon 64

The following table provides a list of the operating systems that are supported for the server.

Server OS Service
Windows 2008 R2 Server o
Windows 2012/2012 R2 Server o
Windows 2016 Server o+

If the database being queried is located on the Voicemail Pro server, the query speed of the
database will be affected by the amount of memory available. You must take into account the
memory requirements of the database being queried.
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Pre-requisites: For systems running Windows 2012, install .NET Framework 3.5 Features.
Ports
The Voicemail Pro service uses the following ports:

Port Number Type Description

Used to listen for SMTP
connections.

25 TCP

Used to receive time requests
(RFC 868).

Used to interchange the status,
configuration, and program data.

37 UDP

69 ubP

Used to service HTTP requests
(Web Voicemail, mobility clients,
80 TCP one-X Portal for IP Office) for
Voicemail Pro server running on
Windows.

143 TCP Used to service IMAP4 requests.

Used as the default port to write
syslogs to a syslog server.

514 ubP

Used to service IMAP4 requests
over SSL.

Used to receive requests from IP
Office PBX.

50791 Used to receive requests from
one-X Portal for IP Office and to

TCP ; .

receive connections from the

Voicemail Pro Client application.

993 TCP

uUbP

Used to communicate with the

50792 TCP MAPI Proxy service.

Used to service HTTP requests
(Web Voicemail, mobility clients,
8000 TCP one-X Portal for IP Office) for
Voicemail Pro server running on
Linux.

© Note:

Voicemail can use additional ports for connection to services such as a third-party database or
Microsoft Exchange.

A Caution:

* Do not install Voicemail Pro server on a computer that runs the Domain Name System
(DNS) Server service. Doing so may prevent the Voicemail Pro service from obtaining
the ports that the Voicemail Pro service requires to function correctly.
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* Do not install Voicemail Pro on a computer that runs an Exchange server. Doing so may
create conflicts between the Voicemail Pro servers SMTP settings and those of the
Exchange server.

Network requirements

* The computer should be configured and tested for TCP/IP networking.

» The Voicemail Pro server computer must be connected to the IP Office Control Unit directly
or through a LAN switch.

« If directly connected, changing the settings of the computer network card to match the IP
Office control unit can resolve some issues. This should be done according to the computer
or network card manufacturer's instructions. The options for IP Office LAN ports are:

+ All IP Office LAN ports are 10Mbps/100Mbps auto sensing.

If not directly connected, using any of the above settings must be supported and matched by the
intervening network equipment.

» The computer must have a static IP address.

« If the IP Office is acting as a DHCP server, it defaults to using 192.168.42.2 to
192.168.42.201 for DHCP clients. This leaves 192.168.42.202 to 192.168.42.254 for devices
that require fixed IP addresses.

Disk space requirements

The following disk space requirements are only approximations:

At least 2GB of free disk space is required on the operating system drive (by default c:),
regardless of to which drive Voicemail Pro is actually installed.

» A compact Voicemail Pro installation requires 130MB.
* A typical installation requires approximately 255MB.
» A custom installation requires up to 2GB of disk space.

* However, prompts and recorded messages consume an additional 0.5MB of disk space per
minute. For a busy environment you can expect to require at least 1000 minutes of message
recording space, that is 0.5GB.

* If you are installing the client only, you can expect to require at least 170MB.

Web server operation

If a Web browser access is required, the Microsoft IIS Web Server must be installed on the server
computer before Voicemail Pro is installed:

* Microsoft web server products run as services and require Voicemail Pro to also run as a
service.
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* Internet Information Server 5.0 or higher is required.

SFTP server requirements

To be able to use some of the features of Voicemail Pro server (for example, the remote backup
operation, VRLA, and so on), you must install and configure an SFTP server. You can choose to
install any of the commercial or free SFTP server applications. However, ensure the following for
the SFTP server to work with the Voicemail Pro server:

» Configure port 22 to accept incoming connections to the SFTP server.
» Create a separate user account on the SFTP server for use with the Voicemail Pro server.

* If the SFTP server application requires you to set permissions for the user account, set the
Read, Write, and Delete file permissions and the List, Create, and Delete folder permissions
for the user account.

SFTP configuration requirements for VRLA feature on Linux-based server

For the VRLA feature to work on a Linux-based Voicemail Pro server, you must:
* Install the SFTP server on the computer that runs the ContactStore application.

+ Set the Home directory of the user account such that the VRL directory (specified by the
value of the registry entry HKEY_LOCAL_MACHINE > SOFTWARE > Network Alchemy >
Voicemail > Directories > VRLDir on a 32-bit system and HKEY_LOCAL_MACHINE >
SOFTWARE > Wow6432Node > Network Alchemy > Voicemail > Directories > VRLDir
on a 64-bit system) lies inside the SFTP directory structure.

For example, if you set C:\asdf\xyz as the VRL directory, then set either C: \asdf\xyz or
C:\asdf as the Home directory of the SFTP user account.

Testing and troubleshooting the SFTP connection
Procedure

1. Log in to the command line interface as the root user on the Voicemail Pro server.

2. Enter Sftp <username>Q@sftpIP, where <username> is the username of the SFTP
user account.

3. Enter the password of the SFTP user account.
The SFTP connection should get established.
4. If the SFTP connection is not established, then:

a. On the computer that runs the SFTP server, check if any other application is using
port 22 for an SFTP connection. If yes, stop the application.

b. Clear all the entries in /root/.ssh/known hosts that are associated with the IP
address of the SFTP server.
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Server/Client installation

The Voicemail Pro installation software for Windows offers a number of different types of
installation. The key types are client only, compact, typical and custom. These differ in the
components installed as detailed in the table below.

Sub Installation Type Notes
Component Client Compact Typical Custom

Voicemail
Pro

Component

o J o J

Voicemail

Pro Service & o % o

Installs the
prompts that
best match
the server
computer
Voicemail locale plus

Pro English
prompts. For
Languages o o o o an
installation
with
additional
languages
use the
Custom
installation
option.

Not available
for
b4 b4 o vy installation
on an XP Pro
server.

Only
available for
Web Voicemail (UMS) X X % Y, installation

on server
operating
systems.

Voicemail Pro Campaign
Web Component

Performing pre-installation checks
Procedure

1. Log on to the server computer using the user account under which you intend the
Voicemail Pro server or service to run. This user account must have full administrator
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rights to the server computer. You must update the Voicemail Pro service password if the
user account password is changed.

2. In IP Office Manager, check that the correct licenses for Voicemail Pro have been installed
and show a status of Valid.

3. For installations other than client-only and compact, check that the required pre-installation
processes have been completed.

+ Installing Web Campaigns on page 24

» Voicemail E-mail on page 52
* UMS Web Services on page 28

- Web Voicemail installation on page 33

- UMS Exchange configuration on page 42

+ Centralized Voicemail Pro on page 87

» Text To Speech (TTS) installation on page 71

Related links
Voicemail Pro licenses on page 10

Checking that Windows Audio is enabled
About this task

On many Windows server computers, while the Windows Audio components are present by
default they are not always enabled. If this is the case the playback of voice prompts may be
“choppy” and the TTS (if installed) will not work. However, enabling Windows Audio does not
require the server computer to have a sound card installed.

Procedure
1. Verify that you have full administrator rights for the computer.
2. Click Start > Administrative Tools > Services.

3. If the status of the Windows Audio service is not Started, start the service and set the
Startup Type to Automatic.

Installing the Voicemail Pro software components
Procedure

1. Insert the IP Office Applications DVD.
2. Click the link for Voicemail Pro, and then double-click setup.exe.

The Choose Setup Language menu displays.
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. Select the language for the installation process. Click OK.

This language is used for the installation process and does not affect the language
prompts that are installed.

The Preparing Installation menu displays.

. Voicemail Pro requires Microsoft .NET 2.0 Framework. If this is not detected, you are

prompted to install it. Click Yes to install Microsoft .NET 2.0 Framework.

5. If the Modify, repair or remove the program window displays, follow the upgrade process.

6. From the Welcome window, click Next.
The Customer Information menu displays.
7. Use the default names or enter a user and company name. These settings do not affect
the Voicemail Pro installation.
8. Select the option Anyone who uses this computer (all users).
9. Click Next.
10. From the Choose Destination Location menu, click Next.
For ease of maintenance, use the default folder location if possible.
11. Click Next.
The Messaging Components menu displays.
12. Choose one of the following options:
» Voicemail Pro (Full)
* Voicemail Pro Client - Only
13. Click Next.
Voicemail Pro (Full) Go to the setup type step on page 21.
Voicemail Pro Client - The Setup Status menu displays. This shows you the progress of the
Only file installation. Go to the restart step on page 22.

14. From the Setup Type menu, select one of the following options and click Next.

Compact | The Service Account Name window displays. This window is used to select the
account under which the Voicemail Pro services will be run following installation.

Typical The Service Account Name window displays.

Custom | The Select Features menu displays. Select the components required for the
installation and click Next.

15. From the Service Account Name window, enter the user name and password used by the
account. Alternatively, click Browse and select a name from the list of available computer
or network accounts.

16. Click Next.
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17.

18.

19.

20.
21.

22.

23.

24.

25.

26.

October 2018

The account name and password are validated. If the validation fails, the system prompts
you to create a new account that matches the details entered.

From the Select Program Folder menu, click Next.

By default, the program folder for the Voicemail Pro client is set to IP Office. For ease of
maintenance, use this option unless there is a specific reason to use a different folder.

The Start Copying Files menu displays. It shows a summary of the components that are
about to be installed.

Check that this list is as expected. If for any reason the details are not what you expect,
click Back and make the required changes. When you are satisfied that the details are
correct, click Next to start copying the files.

The Setup Status menu is displayed. This shows you the progress of the file installation.
For a client-only installation, the software installation process is now complete.

© Note:

You may get the prompt to reset IIS. If so, click Yes to reset IIS. If you click No, some
of the functionalities may not be available until you restart IIS.

After the InstallShield Wizard Complete menu displays, depending on the operating
system and the components installed, you may be prompted to restart the computer. If so,
select Yes, | want to restart my computer now.

Click Finish.
If the computer restarts, log in to continue the installation process.

The installation process continues by requesting a number of configuration settings used
by the voicemail server services. This is used to enter the account that the Voicemail Pro
server should use for e-mail functions.

Enter the name of the e-mail account, or click Browse to select an account. Click Next.
The IP Office Voicemail Pro SMTP E-mail Settings window opens.

In the Mail Server box, type the name of the SMTP mail server or use the name that is
proposed.

This should be the fully-qualified domain name.

In the Port Number box, type the number of the receiving port on the SMTP mail server.
The default is 25.

To enforce server authentication, check the Server Requires Authentication box.

This is optional. If you check this box, you also need to provide the required Account
Name and Password. You can also choose whether or not to set the Use Challenge
Response Authentication option.

Click Finish.
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The e-mail settings are validated. An error message is displayed if the system fails to
connect to an SMTP server. Click OK to acknowledge the message.

27. If doing a custom installation to install a specific Voicemail Pro feature, refer to the
appropriate section for details of any actions that need to be performed after the
installation of the Voicemail Pro server software.

+ Web Campaigns Installation on page 24

» Voicemail E-mail Installation on page 52
+ UMS Web Voicemail on page 28

- Web Voicemail Installation on page 33

- UMS Exchange configuration on page 42

» Centralized Voicemail Pro on page 87

* Installing Text to Speech Features on page 71

Result

You have now finished installing the Voicemail Pro server and client software.

Checking the client to server connection
About this task

Following installation of the server and client, you should check operation by using the client to
connect to the server.

Procedure
1. Click Start > Programs > IP Office > Voicemail Pro.
The Voicemail Pro Client starts and the main window opens.
2. In the navigation panel, click Voicemail Pro Administrators.
3. From the Administrator account. double-click on the account.
You can also right-click and select Modify.
4. Change the Password and Confirm Password to a new value than the default
(Administrator).
Initialize the server call flow by clicking the % Save and Make Live icon.
6. Select Yes.

The file root . vmp is created on the server. This is the compiled non-editable version of
the call flow that is used by the server.

7. Test the voicemail operation.

Test that the system is running by dialing *17 from any extension. You should hear the
mailbox announcement.
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Next steps

You can now start configuring the operation of the voicemail server. For example, changing the
system preferences.

Modifying the installed components
Procedure

1.

Open the Windows Control Panel.

2. Click Programs > Programs and Features.

3. In the list of installed programs, select IP Office Voicemail Pro and click Change.

The installation wizard for IP Office Voicemail Pro opens up.

. Select Modify and click Next.

The Select Features menu displays.
Select the check boxes for all the features in the list that you want to install.

If you clear the check box for a feature that is already installed, the installation wizard
uninstalls the feature.

. Click Next.

The Service Account Name window displays.

Installing Web campaigns
About this task

The Web campaigns component of Voicemail Pro requires IIS to be installed and running on the
server computer.

Procedure

1.

Check that IIS is installed and running on the server computer.

Windows Server 2008 R2 IIS does not support legacy IS applications such as campaigns
by default. To fix this, you can install IS from the Windows installation disk and select
Legacy IIS support during the installation.

. Check that the server computer can be browsed from the other computers on the customer

network.

If the Voicemail Pro server software has not yet been installed, run the Voicemail Pro
software installation and select Voicemail Pro (Full).

. Select either Typical or Custom.

5. If you selected Custom, select Voicemail Pro Campaign Web Component in the list of

October 2018

components.
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6. If the Voicemail Pro server software is already installed, modify the installed components
and select Voicemail Pro Campaign Web Component in the list of components.

Configuring the Windows 2008 server for web campaigns
About this task

The following configuration changes are required for IIS version 7 after installation of the Voicemail
Pro Web campaigns component.

Procedure
1. Click Start > Administrative Tools > Internet Information Services (lIS) Manager.
2. In the Connections pane, click the server node in the tree.

The server Home page displays.

In Features View, double-click Handler Mappings.

Click Edit Feature Permissions.

Check the Scripts and Execute check boxes.

Click OK.

In the Connections pane, expand the server node in the tree.

© N o o bk~ ®

Expand the Sites node, then expand the Default Web Site node, and select Campaign.
The Campaign Home page is displayed.

9. In Features View, double-click Authentication.
10. Click ASP .NET Impersonation.

11. In the Actions pane, click Disable.

Starting Voicemail Pro Services manually

About this task

If you have installed Voicemail Pro successfully and rebooted the server computer, then the
voicemail service starts automatically. However, you can restart the service manually, if required.
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Procedure

1. Click Start > Administrative Tools > Services.

| | T B H OH I
“. Services (Local) Harne = | Description | status |statupType  {logonas | |
GL Telephony Provides Telephony... Manual Metwork Se...
\E;)_;Thread Ordering 5e... Provides ordered e... Manual Lacal Service
{CLTP AutoConnect Se... ThinPrint .print com...  Started Manual Lacal System
{%TP W Gateway Ser... ThinPrint .print com... Manual Lacal System
'f.:_’;TPM Base Services Enables accessto b, IManual Lacal Service
{,;}_;UPnP Device Host Allows UPRP device. ., Disabled Local Service
-{,\:‘_‘;User Profile Service  This service is respo...  Starked Automatic Local System
~$\n‘irtual Disk. Provides manageme. .. Manual Local System

'fJ’ WMware Tools Service  Provides support Fo.,.  Started Automatic Local System
Mware Upgrade H,..  Virtual hardware up,..  Started Automatic Local System

email Pro Service Started Autornatic S\ Administra. ..
&hvolume Shadow Copy  Manages and imple... Manual Local System
{.:_’;Windows Audio Manages audio for ... Marual Local Service
\S;)_;Windows Audio End... Manages audio devi... Manual Local Syskem
Ehwindows Color Sys...  The WesPlugInervi... Manual Laocal Service
\S&Windows Driver Fo... Manages user-mod... Manual Local System :j
%\ Extended }\ Standard

The Voicemail Pro Service should be visible. Its Status should be Started and the
Startup Type should be set to Automatic. Other services may be present depending on
the installed Voicemail Pro features. The Voicemail Pro Service is the main Voicemail Pro
service. This is the only service that needs to be stopped and restarted. It stops and
restarts the other services that it uses.

2. Close Services.

Setting the Voicemail Pro Service or computer to restart
automatically

About this task

The following action is optional. If a fault causes the Voicemail Pro service to stop, the fault should
be investigated and fixed. However, setting the options to restart the services or the computer
automatically will minimize the disruption to the Voicemail Pro users.

Procedure

1. Click Start > Administrative Tools > Services.

2. Right-click Voicemail Pro Service and select Properties.
3. Select the Recovery tab.
4

. Select the items in the drop-down lists to specify the action that the computer must take in
case of failures.
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Using a batch file to start services

About this task

In some instances, certain computers might not respond quickly enough to start all of the Avaya
services in the correct order. In this circumstance, you should create a batch file that delays the
start of these services until the computer is fully running.

Avaya IP Office Services can be started successfully at system start-up using a scheduled task
that initiates the batch file below. This batch file ensures that the services will start successfully
and in the correct order.

Procedure
1. Set all Avaya services listed below to Manual start. Do not include Key Server.
2. Create the batch file below and save it to $SYSTEMROOT%.
Only include lines for the services that are installed.
@echo off
rem Wait 60 seconds before execute.
timeout /t 60

net start Voicemail Pro Service

3. Create a scheduled task to start the batch file at system start-up.

Upgrading a Windows Voicemail Pro Server

Before you begin

Voicemail Pro supports upgrades from only the two previous versions of Voicemail Pro. To
upgrade from earlier versions of Voicemail Pro, you must first upgrade your setup to one of the
two previous versions.

About this task
Use this procedure to upgrade to Voicemail Pro from one of the two previous versions:
Procedure

1. Insert the IP Office Applications DVD. Click on the link for Voicemail Pro and then double-
click on setup.exe.

The system displays a prompt to select the installation language.
2. Select the installation language, and click OK.

The system displays the IP Office Voicemail Pro <Installed Release> is
current installed. Would you like to do a major upgrade to IP
Office Voicemail Pro 9.0? message.

3. Click Yes.

The system displays the Select Features dialog box.
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. Select the items that you want to install.

5. (Optional) If you want to uninstall an item that is already installed, clear the check box

10.

1.

12.

Next s

corresponding to item in the list.

. Click Next.

The system displays the Select account name dialog box.

. Click Next.

After validating the account details, the system displays the Start Copying Files dialog box.

. Click Next to start the upgrade.

The system displays the Setup Status dialog box, which displays the progress of the
upgrade.

After the installation is complete, click Finish.

The system displays the E-mail settings dialog box.

Enter your e-mail account details and click Next.

The system displays the SMTP E-mail settings dialog box.
Enter your SMTP E-mail details and click Finish.

© Note:

If an error occurs, the system also displays the SMTP Error on page 108.

The system validates the SMTP settings that you enter and displays the Do you wish
to start the service now? message.

Click Yes.
The installation of the Voicemail Pro 9.0 is complete.

teps

Dial *17 from any extension to test the system. The system should play the mailbox
announcement.

© Note:

After upgrade, the general system preference Client/Server Connection Timeout (mins) is

res

et to the default value 5.

UMS Web Services

Voicemail Pro supports user mailboxes and hunt group mailboxes to be accessed using the
additional methods listed below.
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IMAP e-mail client
support

Web voicemail
access

UMS Exchange
configuration

UMS Web Services

This method supports mailbox access using any e-mail client that
supports IMAP, for example Outlook and Lotus Notes. The Voicemail Pro
server computer acts as the IMAP server.

This method supports mailbox access using a web browser. Messages
can be played back to an IP Office telephone extension or through the
computer if the browser is audio enabled. Web Voicemail requires the

Voicemail Pro server to also run IIS and PHP.

A user or group can be configured to have their voicemail messages
forwarded to the inbox of an Exchange server e-mail account. Telephone,
including Visual Voice, mailbox access is redirected to that e-mail inbox as
the store for voicemail messages. Alternatively, the user can access their
voicemail messages using Outlook or any other mechanisms supported
by the Exchange server.

Use of these options requires the user to be licensed, either using an appropriate IP Office user
profile license or the legacy UMS Web Services license.

. . . Exchange
Feature Web Voicemail IMAP Client 2010/2013/2016
Playback via computer. o o o
Playbaf:k via User v x X"
Extension.
Save message Wav to " s s
computer.
Forward. messages to v x x
other voicemail mailbox.
Forward messages to x i .,..r
other e-mail mailbox.
Undelete manually v v s
deleted messages.
Mark message as s s s
unread.
Change voicemail s " »
password.
. . . Exchange
Show message types Web Voicemail IMAP client 2010/2013/2016
- New (Unread). o o o
- Old (read). of o of
- Saved. o o *
Table continues...
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Show message types Web Voicemail IMAP client 205(;;(222:2/%%16
- Priority. o ul 7
- Private. X1 X l
- Deleted. o o o

IMAP installation

Voicemail Pro supports mailbox synchronization with e-mail clients that can support IMAP (Internet
Message Access Protocol) accounts. Examples are Outlook, Outlook Express and Lotus Notes.

Once configured, the IMAP folder and the mailbox are synchronized whenever the IMAP folder is
opened. The method of indication of the different message types will depend on the e-mail client
being used and is not controlled by the Voicemail Pro.

¥ Inbox - Outlook Express

File Edit \iew

- e @ e
Folders

I‘_:ﬁ] Cutlook Express
- @ Local Folders

i Inbio
@ Cutbox

'{ﬁl Sent Ikems
(& Deleted Ttems
B} Drafts

= % Woicemail
@ Inbox

Toals

E[=E

|
f l_'r

Message Help h
X | S- | W B
Xy @ From Subjeck Feceived ¢
B TlEsrett  Intermabvoicefroirom Exbrect ESOHEORE- B0
B TlEsrett  Intermabvoicefroirom Exbrect SHOHEIRE 3T
!0 TEdreit  Intermolbvsice el from Edncid SO 3 aE
!0 SiExtnzol Internal woice mail From Extniz01 24/01/2008 13:39
8 SYExknz0l Internal woice mail From Extniz01 24/01f2008 1427
8 EAExtn201 Internal voice mail from Extn201  12,/02/2008 13:17
!0 SiExtnzol Internal woice mail From Extniz01 12)02/2008 13:20
B TlEsrett  Intermabvoicefroirom Exbrect FROREONE505

8 message(s), 5 unread

@ Warking Online

I‘_‘E Mo new messages

The number of mailboxes that can be configured for IMAP and/or web access is controlled by

licenses.

The Voicemail Pro IMAP server installation

The IMAP server is installed as a part of the Voicemail Pro service installation. It uses the IP
address of the Voicemail Pro server computer and runs on the standard IMAP port 143. To prevent

1 Private messages are not indicated, however the web voicemail does not support the forwarding of private messages.
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UMS Web Services

any conflicts with the Voicemail Pro IMAP server, do not run any other IMAP server on the same
computer.

IP Office for Web Services

Licensing IP Office for Web Services

UMS web services can be licensed in a number of ways by licenses added to the IP Office
configuration:

User licensing:

User licensing is done as follows.

» Users whose Profile is set to Teleworker User or Power User can be licensed using the
Teleworker Profile or Power User Profile licenses.

» User's whose Profile is set to Basic User can be licensed using the legacy UMS Web
Services licenses.

Hunt group licensing:

* Hunt groups are licensed by UMS Web Services licenses.

Licensing hunt groups
Procedure

1.

Start IP Office Manager.

2. Receive the configuration from the IP Office associated with the Voicemail Proserver.
3.
4
5

In the = Licenses section, add the required licenses.

. Merge the configuration back to the IP Office and then receive the configuration again.

. In the = Licenses section, check that the License Status of the licenses is now shown as

Valid.

6. Start the Voicemail Pro client.
7. Select Help > About.

The screen lists the Web Services as Started and shows the number of UMS licenses.

Configuring users for UMS
Procedure

1.

N o o s~ e DN
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Start IP Office Manager.

Receive the configuration from the IP Office system hosting the user.
Select § User and then select the required user.

Set their Profile to either Teleworker or Power User.

Select the Voicemail tab.

Enable UMS Web Services and click OK.

Merge the configuration back to the IP Office.
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Configuring hunt groups for UMS
About this task

Access to hunt group mailboxes using UMS is supported for Voicemail Pro 5.0+.

Procedure

1.

o a0k~ w DN

User e-m

Start IP Office Manager.

Receive the configuration from the IP Office system hosting the hunt group.
Select the hunt group.

Select the Voicemail tab.

Enable UMS Web Services and click OK.

Merge the configuration back to the IP Office.

ail account configuration

The exact method of configuration of an IMAP account depends on the IMAP client being used by
the user. For example, it may be required to enable some field with dummy data in order for the e-
mail client to accept the account even though those settings are not used by the Voicemail Pro
IMAP server.

The general details that are required are:

IMAP account setting IP Office value

Incoming server

Voicemail Pro server IP address or domain name

address.
Account Name User name or extension number.
Password User voicemail code.

Configuring a user e-mail account in Outlook
Procedure

1.

a & DN
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Select Tools > Options.

Select Mail Setup > E-mail Accounts.
Select Add a new e-mail account.
Select IMAP as the server type.

In Server Information for Incoming mail server and Outgoing mail server, enter the IP
address or domain name address of the Voicemail Pro server computer.

In Logon Information, enter the user's extension number and voicemail code as the User
Name and Password.

. Click Next.
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Configuring a user e-mail account in Outlook Express
Procedure

1.

2
3.
4

Select Tools > Accounts.

. Select Add > Mail.

Enter a descriptive name such as Voicemail and click Next.

. Enter an e-mail address.

This e-mail address value is not used, but a value must be entered to move to the next
screen.

5. Click Next.

6. Set My incoming mail server is a to IMAP.

7. In the Incoming server field, enter the IP address or domain name address of the

Voicemail Pro server computer.

8. Enter a value in the Outgoing mail server field.
This mail server value is not used, but a value must be entered to move to the next screen.
9. Click Next.
10. For Account Name, enter the user's extension number or name in the IP Office
configuration.
11. For Password, enter the user's Voicemail Code.
12. Click Next and then Finish.
Web Voicemail installation
Voicemail Pro 4.2+ supports Web access to user mailboxes. Users are then able to play their

messages, mark them as saved or deleted, or forward messages to another mailbox. Playback is
through an IP Office extension or through the audio facilities of the computer.
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T e —— =
From To LU= ]
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Web Voicemail installation requirements

The Web Voicemail component is selectable as part of a custom Voicemail Pro installation. Note
the prerequisites below before doing the Web Voicemail installation.

IS Web
Server

PHP

Licenses

UMS web
services
licensing

October 2018

Must be installed on the voicemail server computer before the Voicemail Pro
Web Voicemail component is installed.

Web Voicemail uses PHP. If an existing PHP is not detected, the Voicemail Pro
installation installs its own PHP

The use of Web Voicemail and the number of users who can be configured to
access it are controlled by the UMS Web Services license entered in the IP
Office configuration.

UMS web services can be licensed in a number of ways by licenses added to
the IP Office configuration:
User Licensing: User licensing is done as follows.

» Users whose Profile is set to Teleworker User or Power User can be
licensed using the Teleworker Profile or Power User Profile licenses.

» User's whose Profile is set to Basic User can be licensed using the legacy
UMS Web Services licenses.

Hunt Group Licensing:
* Hunt groups are licensed by UMS Web Services licenses.
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Computer The computer name is used as part of its URL on the network. Set the name to
name\URL something that appropriately indicates its purpose and that can be used as part
of the URL for the Web server within the customer's domain.

Remove IMS Voicemail Pro UMS is not supported on systems that are using Voicemail Pro
IMS. IMS must be removed before UMS can be selected for installation.
User and browser requirements

For users to access Web Voicemail, they require a Web browser that meets the following
requirements.

Javascript- Web Voicemail is tested against the following browsers. Other browser can
enabled Web also work if they support JavaScript and CSS.
browser

* Internet Explorer V8.0 or higher

» Mozilla Firefox V3.0 or higher.

* Opera V10.0 or higher.

Computer Using browser access, you can playback messages either via an IP Office

playback extension or through the web browser. Avaya test browser playback using
the following Windows media players.

* Windows Media Player 10.

* Windows Media Player 11.

* Quick Time 7.4.

« VLC 0.8.
User name and Once enabled for UMS Web Services in the IP Office configuration, to log on
password using Web Voicemail, the user needs to know their Name and Voicemail

Code as set in the IP Office configuration. Note that this is the Name and not
the Full Name..

Installing Voicemail Pro Software with Web Voicemail Component
About this task
The Web Voicemail component is installed as part of a Custom Voicemail Pro installation.
Procedure

1. Verify that IIS is installed and running on the Voicemail Pro server computer. Check that it
can be browsed from user computers.

While the server can be browsed by IP address, the URL used by users is based on the
server's computer name within the customer domain. Check that the Web server can be
browsed from user computers using the server's computer name as part of the URL.

2. Insert the IP Office Applications DVD.

3. Click on the link for Voicemail Pro, and then double-click on setup.exe.
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The Choose Setup Language window opens.

. When asked for the type of Voicemail Pro install to perform, select Voicemail Pro (Full).

5. On the next screen, select Custom.

6. In the list of components, scroll down and select Web Voicemail.

IP Office

Do not change any of the other selections unless you understand the requirements for
those components.

Follow the remainder of the installation process and reboot the Voicemail Pro server when
required.

for Web Services

Licensing IP Office for Web Services

UMS w
configu

eb services can be licensed in a number of ways by licenses added to the IP Office
ration:

User licensing:

User licensing is done as follows.

» Users whose Profile is set to Teleworker User or Power User can be licensed using the
Teleworker Profile or Power User Profile licenses.

» User's whose Profile is set to Basic User can be licensed using the legacy UMS Web
Services licenses.

Hunt group licensing:

* Hunt groups are licensed by UMS Web Services licenses.

Licensin

g hunt groups

Procedure

1.

o &~ @D

Start IP Office Manager.

Receive the configuration from the IP Office associated with the Voicemail Proserver.
In the = Licenses section, add the required licenses.

Merge the configuration back to the IP Office and then receive the configuration again.

In the = Licenses section, check that the License Status of the licenses is now shown as
Valid.

6. Start the Voicemail Pro client.
7. Select Help > About.

The screen lists the Web Services as Started and shows the number of UMS licenses.

Configuring users for UMS
Procedure

1.
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Start IP Office Manager.
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7.

UMS Web Services

Receive the configuration from the IP Office system hosting the user.
Select § User and then select the required user.

Set their Profile to either Teleworker or Power User.

Select the Voicemail tab.

Enable UMS Web Services and click OK.

Merge the configuration back to the IP Office.

Configuring hunt groups for UMS
About this task

Access to hunt group mailboxes using UMS is supported for Voicemail Pro 5.0+.

Procedure

1.

2

Start IP Office Manager.

Receive the configuration from the IP Office system hosting the hunt group.
Select the hunt group.

Select the Voicemail tab.

Enable UMS Web Services and click OK.

Merge the configuration back to the IP Office.

Enabling Web Voicemail
About this task

If the Exchange server and Voicemail Pro are installed on the same computer, the security
settings of the Exchange server override the Voicemail Pro settings. So, if you access Web
Voicemail with default settings, you may receive this error message, HTTP Error 403.4 -
Forbidden.

© Note:

If the Exchange server and Voicemail Pro are not installed on the same computer, you do not
need to enable Web Voicemail explicitly.

Follow the below procedure to enable Web Voicemail:

Procedure

1.

o &~ e DN
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Click Start > Administrative Tools > Internet Information Services (IIS) Manager.

In the Connections pane, expand the Sites node and click Default Web Site in the tree.
In Features View, double-click SSL Settings.

Clear the Require SSL check box.

Restart the |IS service.
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Enabling browser access to Web Voicemail and ContactStore
About this task

It is possible to run ContactStore and UMS Web Voicemail on the same server computer. However
some additional steps are required after the installation to enable browser access to both
applications.

Procedure

1. Install UMS Web Voicemail.
Install ContactStore.
Reboot the server.

Within services, stop the ContactStore service.

a &~ DN

Using a Web browser, access a voicemail mailbox using UMS Web Voicemail.
6. Restart the ContactStore service.
Result

Both applications are now accessible using the Web browser.

Checking playback control
About this task

UMS message playback through the Web browser is tested and supported with Windows Media
Player. Other audio playback controls may work, but they have not been tested.

Depending on your Web browser, use one of the following procedures to check that the audio
playback is associated with the Windows Media Player.

Firefox
Procedure
1. Select Tools > Options > Applications or Tools > Options > Content > File Types >
Manage.
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2.

In the search box, enter x-mplayer?2.

Options

o[ @ & &

Fain Tabs Content  Applications  Privacy  Security  Advanced

3

Search: | w-mplawverZ

| | Clear

Conkent Type Ackion

=

E indows Media Audio/Video plawlist (... @ Use windows Media Plaver (default)

| ok

] [ Cancel ] [ Help

UMS Web Services

3. Check that Action is set to Use Windows Media Player or Use Windows Media Player

Opera

plug-in Dynamic Link Library.

Procedure

1.
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Select Tools > Preferences.
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2. Select Downloads and use the search box to find x-mplayer2.

Preferences

Browsing ':L =-rpl - |»f Hide file types opened with Opera
Search
Mokifications +MIME type File extensionis) Mew,

application)x-mplayerz &

Delete

Cankent

Fonts Edit. ..
Dawinloads

Programs

File type

Histary
Cookies

Security
rekwork,

MIME kype File extensions

Toolbars Action
Shortcuts

Voice

I Show download dialog

I Open with Opera

I Save todisk

| | ©Open when transfer is complete

|| Donot ask for Folder, but save directly ko

I\ Cpen with default application

I Open with ather application

| | Pass web address directly to application

(@ Use plug-in

Windows Media Playver Plug-in Dynamic Link, Librarsy

3. Check that the setting is set to Use plug-in and Windows Media Player Plug-In Dynamic

Link Library.
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Internet Explorer
About this task
Internet Explorer uses the application associated with the wav file type for Windows.
Procedure
1. Select My Computer.
2. Select Tools > Folder Options.
3. Select File Types.

4. Locate and select the wav extension type.

Folder Dptions

General | View | File Tvpes | Offline Files

R egisterad file types:

Extenzionz  File Types 25
SxlwieB  Address Book File
|41 i Wave Sound
B Wit Windows Media Audio shorbcut
i_iﬁjWBK Microzoft word Backup Documnent
:__ﬁ WCS “Web Site Content Source
|#]WDP  Windows Media Phota

ﬂ'nn’l:DD LR ey v

Dretailz far Wik extenszion

Openz with: @ YWindaows Media Player

Filez with extenzion "Wk are of type "Wave Sound’. To change
zettings that affect all " ave Sound' files, click Advanced.

| Adwanced |

k. ] [ Cancel

5. Check that the details show Windows Media Player as the selected application for this file
type.
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UMS Exchange configuration

A UMS user or group can be configured to have their voicemail messages forwarded to the inbox

of an Exchange server e-mail account. They can then access their voicemail messages using

Outlook and playback those messages on their computer. Alternatively any other mechanisms
supported by Exchange Server Unified Messaging can be used. Access to the messages from an
IP Office telephone is still supported, including Visual Voice.

Voicemail messages in an Exchange inbox are not visible to UMS IMAP and UMS Web Voicemail,
however Exchange provides its own methods to use IMAP and Web browsing with Exchange

mailboxes.

© Note:

When using an Exchange server as the message store for a user's voicemail messages, the
Voicemail Pro server will deliver messages to the Exchange server on completion of the

recording. However, the presentation to Outlook and back to the Voicemail Pro server for
message waiting indication (MWI) and access via telephone is delayed by Exchange server
processing. The delay is typically 1 or 2 minutes. The same delay also applies to changes in
the message status that affect message waiting indication.

(~ Inbox - Microsoft Outlook

File Edit View Go

Tools  Acdions  Help

SdMew ~ | @50 (23 X | CaReply S8 Replyto Al

Mail
Favorite Folders
L] Inbox
Unread Mail
L[=F| Sent Items
Mail Folders

O] All Mail Ttems

= €4t Mailbox - agentl
1 backup
{3 Deleted Items
L Drafts
L] Inbox
g Junk E-mail
= Cutbox
[ Quarantine

@

*

4 | B

L4 Inbox

Arranged By: Date

= Last Week

=1 Administratar

(=] Two Weeks Ago

Type a question for help
= Forward | B2 W Q L send/Regeive - [ | [l Searchaddressbocks  « | @)

&) Play ?"j Flay on Fhone | (2] Edit Motes

P ¥ || Voicemail Message (Extn2205 > Extn2207) From:2205

Mewest ontop Administrator
Thu 23,04/2009 15:04
Wed 29/04 agentl
E 1]

=T
(>) OO OO

éf)‘_\‘ Administrator

23/04/2009

Voicemail Message (Extn2205 > Ext.., U

IP Office Voicemail redirected message

The following are the prerequisites for UMS Exchange:

Exchange
Server

Voicemail
Pro

October 2018

*

ieg oq-o]

|odde Bupwoidn opy Eﬂé

* The Exchange server must be configured with the Unified Messaging Server
Role selected.

+ A Dial Plan must be created on the Exchange server. This can be a blank dial

plan but it must exist.

» Within the Exchange server settings for each mailbox, select Enable Unified

Messaging.

* The Voicemail Pro server must be configured for MAPI-based voicemail e-

mail.
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» The supported MAPI applications are Exchange server and Microsoft Outlook.

IP Office -+ The user or hunt group must be licensed and enabled for UMS Web Services.

* The user or hunt group's Voicemail E-mail mode must be set to Forward.
Related links

Configuring Exchange Server for Unified Messaging on page 43
MAPI setup on page 55

Configuring Exchange Server for Unified Messaging
About this task

The following procedures provide a simple overview of the minimum steps required to configure
Exchange Server for Unified Messaging. For details, refer to the Microsoft documentation.

Configuring Exchange Server 2010 for Unified Messaging Server Role
About this task

To support UMS Exchange Server 2010 operation, configure the Exchange Sever to include
Unified Messaging Server Role.

Procedure

1. In the Windows Control Panel, select Program and Features.

2. Select Microsoft Exchange Server 2010, and click Change.

&l Programs and Features IH[=] E3
Q,\ J s -(Canh‘al Panel ~ Programs ~ Programs and Features) - & I Search Programs and Features EJ
Conbrol Panel Home Uninstall or change a program
view installed updates To uninstall a program, select it from the list and then click Uninstall, Change, or Repair.
B Turn Windows Features on or off
Instal 2 program from the network | rsonze T Uninstal @) =~ @
Name _~ | +| Publisher | +| tnstal... | =] size |+ version |:
@IP Office Yoicemail Pro MAPL Avaya 11/18/2011 1.95ME  8.0.5.20
(|2 Microsoft Exchange Server 2010 Microsoft Corporation 11f17j2011 14.1.218.15 )
£, Microsoft Outlook 2010 Microsoft: Corporation iijigfzon 14.0.4763,1000
@Wlware Tools \iware, Inc, 11172011 17.9M6 7.5.5.7026
VEWNC Free Edition 4.1.3 RealyNC Ltd, 11182011 4.1.3

The wizard for changing Exchange Server setup is started.
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3. Click Next.
VA Exchange Server 2010 Setup
Exchangs (Server Role Selection )
B | srtensnce Mods Select the Exchange server roles pou want to nstall on this computer:
] 2a¥ Maibox Role — Description
[ Server Role Selection | AN The Urdied Messaging server ole provides
Honionas Chacks = W Clhent Access Role connectivity between a corporate telephony
- - system and lthe Exchange seiver, Clhents can
Progess L Hub Transport Rele access their malboxes from a telephone and
m = = : receive voice mail messages in their malbox.
1 Completion [:' =¥ Urnified Messaging Fh:nlej
[ Edge Transpost Role
2 ¥ Management Tool —Disk Space
Disk space required: 1333.0 MB

Dk space avalabla: 306846 MB

Specily the path for the Exchange Server nstallation files:

[D:s Browse... |

Specify the path for the Exchange Server program files:
|C:\Progeam Files\Microsoft\Exchange Server\V14 Browse
[~ Automatically install Windows Serves roles and features requined for Exchangs Server

_ teo | <Bock |[[_new> I Cancel |

4. In the Server Role Selection list, check that Unified Messaging Server Role is one of
the selected roles.

5. Click Next through the wizard, and then click Finish.

Next steps
Configure mailboxes on Exchange Server 2010.

Related links

#unique_ 57

#unique 58
Configuring mailboxes on Exchange Server 2010 on page 44

Configuring mailboxes on Exchange Server 2010

Before you begin
Configure Exchange Server 2010 for Unified Messaging Server Role.
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Procedure

1. Select Start > All Programs > Microsoft Exchange Server 2010 > Exchange Server
Management Console.

Expand the Server Configuration list.

The Unified Messaging role is included in the list.

[ exchange Management Console [_[O[x]
File Action Yiew Help
e | 2mEE

L] Microsoft Exchange Es Unified Messaging
1 [ Microsoft Exchange On-Premises (v
[ reate Filter

[ o) Organization Configuration fa
2 Maibox Rols Version
W IN-PF1NHI9FCF4 Hub Transpart, Client Acc

1 object
Status

- Export List...

.. Version 14.1 (Buld 218.15)  Enabled View 4
®|

G Refresh
£, Recipient Conrfiguration

H v

£ Hub Transport

3. Create a Unified Messaging dial plan.

a. Expand the Organization Configuration and select Unified Messaging.

B xchange Management Console =1 E3
File Action  Wiew Help

o [e= ==
= [ 2[mlEE
L) Microsoft Exchange BE Unified Messaging I EN | Actions
= [ES Microsoft Exchange On-Premises (v - =
UM Dial Flans | Lt 10 Gateways | UM Maibox Policies | UM Auto attendants | Unified
s Pommeran
8| Chent Access
= R New UM [P Gat
. Hu Name_~ [# Diges [[Associsted UM Servers | Associatza Ut || = sy
i rew UM Maibosx Policy...
] T There are no kems to show in this viev,
# %, Recipéent Configuration

& New UM Auto Attendant. ..
& Toobaox

= Export List ..

View

@ Refresh

b. Select the UM Dial Plans tab, and in the Actions list, select New UM Dial Plan.
The New UM Dial Plan wizard starts.
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T,
S e UM el Py

T~
ST |

[ Introduction Introduction

Thig wizard helps pou create a UM dial plan for uze by Microzoft Exchange Unified

1 Set UM Servers Meszaging. A dial plan iz a grouping of unique telephone extension numbers.
1 Mew UM Dial Plan MNarne:

: IF Office
. Completion I

Murnber of digits in estension nurbers:

[5

LB type:

ITeIephnne E stenzion j
WolP security:

ILInsecurecI -

Countre/Region code:

[1

Help | < Back | Meut » I Cancel |

c. Create a plan similar to the one shown above. The number of digits is not important
but must be matched later in the process. The simplest option is to set it to match the
length of your IP Office extension.

d. Click Next.

e. On the Set UM Servers screen, click Add to select the UM server that you want to
add to the UM dial plan.

f. Click Next.
g. Click New, and then click Finish.
4. Select the mailboxes that you want the Unified Server role to be available on.

a. Expand the Recipient Configuration section, and select Mailbox.
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b. Right-click the configuration settings used for general mailbox users, and select
Enable Unified Messaging.

| B Exchange Management Console =] E3
File Action  Wiew  Help
e | 2w -Hifm J
[ Morosoft Exchange ¥ Mailbox - Entire Forest i) | Actions
=) |2 Microsoft Exchange On-Premiges (v [~ -
[ 252 Organization Configuration § Create Fiker
B Server Configuration - i T — == 2, Modify the Masirmum Number of Recipient. ..
I, Recipéent. Corfiguration | Disay e Hhas Organizational Unit gecpient Type |
5 Maik rl_g_;ndmimszrabur Administrstor vmproitt10.localfUsers User Maibox | & Find...
L DEhioton Group reaDiscovery Search Maillbox  DiscoverySearchiMailboxd...  vmproitt10.localfUsers Discovery Maikt a3 Mew Maibax, ..
L Mall Contact Userapps VIRkaELLS locall L =T
&3 Disconnected Mailbox Enable Archive... 5 Expart List...
) Move Request Disable View »
i Toolbox Remave
Enable Unified Mezsaging. .. @, Refresh
Mew Local Move Request. .. H rer
New Rernate Move Request...
it ————y
Manage Send As Permission... - N
Manage Full Access Permission... Lq Enable Archive...
i) Disable
Send Mai
. 75 Remove
Properties
(g Enable Unified Messaging..
Help 5
= MNew Local Move Request...

The Enable Unified Messaging wizard for the mailbox starts.

/ ‘fq Enable Unified Messaging

'-..___-[' |
[ Introduction Introduction : : 7 . : :
The zelected mailbox will be enabled for Unified Mezsaging. Upon completion, an e-mail
Extensian mezzage will be zent to the mailbox notifing the uzer that they have been enabled for
= Caonfiguration Unified Meszaging. The message will include the PIM and the number ta dial to gain access
b their mailbow, By default, an estengsion number and PIM are automatically generated. oo
Enable Urnified can alzo manually zpecify an extergion number and FIN.
= Meszaging

Urnified Mezzaging Mailbos Policy:

| Comnplation IIF' Oftice Default Palicy

FIM Settings

| % Automaticaly generate PIM to access Outlook Voice Sccess

" Manually specify PIM: I

[” Require user to reset PIN at first telephone logon

-] Unified Messaging is & premium feature and requires an Exchange Enterprize Client
Access License [CAL) to enable it for the mailbos,

Help | ¢ Back I Cancel I

c. For the Unified Messaging Mailbox Policy, click Browse and select the dial plan
created earlier.
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d. Select Automatically generate PIN to access Outlook Voice Access, and click
Next.

/ *:44 Enable Unified Messaging
<0

B |riroduction E xtenzion Configuration

T Automaticaly-generated mailbos extension

o Extension
Canfiguration (ﬁ“ Manuallp-ertered mailbox extension: j 5555?1
Enable Unified SIP Resource |dentifier
= Meszaging

; Thiz refers to a SIP address of a UM-enabled user when a SIF LRI dial plak is used. Far
| Completion examplz, tonpsmith@contozo.com. When an E.164 dial plan is used, this would refer to the
E. 164 addrezs of the user. For example, +14255051234.

& Automaticaly-generated SIP resource identifier;

[ ¥ Manually-entered SIP resource identifier;

Help | < Back I Mest » I Cancel

e. Select Manually entered mailbox extension.

f. Enter a number that matches the number of digits specified in the UM Dial Plan
created earlier.

The actual number entered does not need to match an IP Office extension.
g. Click Next.
h. Select Enable, and then click Finish.

Related links

#unique_57
Configuring Exchange Server 2010 for Unified Messaging Server Role on page 43

#unique 58
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Configuring registry settings
About this task

By default, UMS Exchange supports only up to 166 users. In order to support more number of
users, proceed as follows:

Procedure

1.
2.

On the computer hosting the Exchange server, open Registry Editor.

Under HKEY LOCAL MACHINE/SYSTEM/CurrentControlSet/Services/
MSExchangeIS/ParametersSystem, add a new key MaxObjsPerMapiSession.

Under the new key, create a new DWORD Value objtMessageView, and set the value to
thrice the number of required users.

For example, to support 500 users, set the value to 1500.

Restart the Microsoft Exchange Information Store service.

Assigning permission to users for MAPI

Assigning Send As permissions
About this task

Use this procedure to assign security permissions to the user under whose account MAPI service
is to be executed.

Procedure

1.

Log on to the Active Directory server using an account that has Domain Administrator
privileges.

2. Click Start > Administrative Tools > Active Directory Users and Computers.

3. On the View menu, click Advanced Features.

4. In the left pane of the Active Directory Users and Computers dialog box, right-click the

® N o o

©

October 2018

domain, and select Properties.

In the Properties dialog box, select the Security tab.
Click Advanced.

In the Advanced Security Settings dialog box, click Add.

In the Select Users, Computers, Service Account, or Group dialog box, add the user
account.

Click OK.

. In the Apply to field, select Descendant User objects.
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11. In the Permissions box, select Send As permissions.

12. Click OK to close the Permission Entry dialog box.

13. Click OK to close the Advanced Security Settings dialog box.

14. Click OK to close the Properties dialog box.

15. To prevent the Send As permissions from being removed, proceed as follows:

The system periodically applies a security descriptor to the following groups, which
removes the Send As permissions from these groups.

» Administrators

* Domain Administrators

The following steps prevent the removal of the Send As permissions.
a. Click Start > Run.
b. Enter cmd, and click OK.

© Note:

You must be a member of the domain administrator group.
c. In the command window, enter the following command.

dsacls "cn=adminsdholder, cn=system,dc=<xxx>,dc=<yyy>" /G "\<MM
Security Group>:CA;Send As"

w here,

* dc=<xxx>, dc=<yyy> is the fully-qualified name of the customer domain (for
example, dc=Avaya, dc=com)

* <MAPI> is the name of the service permissions group

It takes at least an hour for the security permissions to replicate the user account.

Assigning permissions on Exchange Server 2010
About this task

If user account is on Exchange 2010 server, proceed as follows to assign additional permissions
to the user account:

Procedure

1. Verify that the user to be added is a member of the Exchange recipient Administrator
group.

2. Log on to the Active Directory server using an account that has privileges to assign
permissions to accounts, such as administrator.

3. Click Start > Administrative Tools > Active Directory Sites and Services.

4. In the left pane, select Active Directory Sites and Services.
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5. On the View menu, click Show Services Node.

In the left pane, expand Services, expand Microsoft Exchange, and then locate the
appropriate Exchange Organization.

Right-click the Exchange Organization, and select Properties.

8. In the Properties dialog box, click the Security tab. If the Security tab is not visible, add
the ShowSecurityPage registry key.
9. Click Add.

10. In the Select Users, Computers, Service Accounts, or Groups dialog box, add the user
account.

11. Click OK.

12. Under Permissions for the group, select Read, and click Apply.

13. Click Advanced.

14. On the Permissions tab of the Advanced Security Settings dialog box, select the check
box at the bottom of the dialog box. This applies the permissions inherited from the parent
to this object and its child objects.

15. Click Add and add the user account.

16. Click OK.

17. In the Apply to field, select This object and all descendant objects.

18. Verify that the following box is not selected: Apply these permissions to objects and/or
containers within this container only.

19. In the Permissions field, select the required permissions.

* List contents
* Read all properties
» Write all properties
* Read permissions
* Create all child objects
* Administer information store
* Create named properties in the information store
* Receive As
» Send As
* View information store status
20. If displayed, also select the following permissions:
* Read
* Execute
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21. Click OK.

Voicemail Email

Voicemail E-mail features of the Voicemail Pro server provide a number of e-mail functions.

Forward a message to e-mail: If the Voicemail Pro server is set to IP Office mailbox mode,
mailbox users are able to manually forward an voicemail message to their e-mail.

Automatic new voicemail messages: For all mailbox modes, users can use voicemail e-mail to
automatically have a message sent to their e-mail whenever they receive a new voicemail
message. The e-mail can be a simple alert or it can include a copy of the voicemail as an
attachment.

eMail action: With customized call flows, an eMail action can be used to send a caller's recorded
voicemail message to a specified e-mail address.

UMS Exchange: In conjunction with Exchange server and Microsoft Outlook, users are able to
use their Outlook inbox as their mailbox for voicemail messages. If the Exchange server is 2010
and the mailbox is configured for Unified Messaging, the users will also have the ability to play the
message within Outlook, if using Microsoft Outlook 2010.

Voicemail E-mail features require the Voicemail Pro server to be configured for access to either an
SMTP e-mail server or to a MAPI e-mail server via a MAPI enabled e-mail client program on the
Voicemail Pro server computer.

SMTP Installation: This is an e-mail standard supported by most e-mail servers. It is the default
e-mail mode for theVoicemail Pro server.

MAPI Installation: MAPI requires a MAPI compliant e-mail client program to be installed on the
Voicemail Pro server. The supported MAPI client is Outlook. It also requires the Voicemail Pro
service to be run using a user account that is able to send e-mails via that MAPI client. The exact
method of integration between the Voicemail Pro server and the MAPI e-mail client depends on
whether the Voicemail Pro server is part of a work group or a domain. This guide contains
examples for both approaches.

The MAPI process described in this guide is based on Microsoft Windows 2000 Professional with
Microsoft Outlook 2000 and Microsoft Outlook Express 5.5. Steps may differ depending on the
version of Windows and e-mail client used.

© Note:

* MAPI is not shipped with the Exchange server as standard. However, it can be installed
separately. For details, see http://support.microsoft.com/kb/945835.

* Microsoft does not support installing Exchange Server components and Microsoft
Outlook on the same computer. For details, see http://support.microsoft.com/kb/266418.
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Configuring the server SMTP e-mail settings
Procedure

1.
2.

N o gk~ w

Open the Voicemail Pro Client application.

Click ~rd Preferences, and select General.

Click the Email tab.

On the MAPI sub tab, verify that the Enable MAPI check box is not selected.

Click the SMTP Sender sub tab.

Select the Logging check box to enable SMTP logging by the server.

Specify the list of SMTP servers to which the Voicemail Pro server sends messages.

 To add a server entry, click dr.

SMTP Sender Configuration x|

— SMTP Server

Mail Domain: Ivmpro1 example.com

Mail Server: Ivmpro1 example.com

Port Number: |25

Sender: Ivmpro @vmpro1.example.com|

T Server requires authentication

Account Name: I

Password I

™ Use Challenge Response Authentication (ERAM-MDS]

ok | Cancel | Help

* To edit a server entry, click B

« To delete a server entry, click *.

8. Click OK.

9

" Click ﬁ Save and Make Live.

SMTP Sender field descriptions

Name Description
Logging Enables SMTP logging.
Servers Used to enter details of the SMTP server or servers to which the
Voicemail Pro server send its messages.
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SMTP Sender Configuration field descriptions

Name

Description

Mail Domain

The usage depends on whether the mail domain is the first
server entry in the list or a subsequent entry.

For more information, see About using mail domains on
page 54.

Server

Specifies the IP address or fully-qualified domain name of the
SMTP server to which messages are sent.

Voicemail Pro supports SMTP communication over both -
SSL/TLS and plain text.

 For the first server entry in the list — Where messaging
between Voicemail Pro servers is being used (central, backup
and or distributed servers), the first entry is used and will
match the domain set above.

» For subsequent entries — The address of the e-mail server
that handles e-mails for recipients other than another Voicemail
Pro server on the network.

Port Number

This is the port number on the SMTP server to which the
messages are sent. Port number for an external SMTP server
can be different depending on whether you want to send the
messages in secure mode or non-secure mode.

Sender (Identifier)

Note that some servers will only accept e-mails from a specific
sender or sender domain. If left blank, the Voicemail Pro server
will insert a sender using either the e-mail address set for the
voicemail mailbox user if set or otherwise using the best
matching name it can resolve from the IP Office.

Server Requires Authentication

This check box indicates whether the connection to send SMTP
messages to the mail server requires authentication with that
server. The authentication is typically the name and password of
a mailbox account configured on that server.

Account Name

Sets the name to use for authentication.

Password

Sets the password to use for authentication.

User Challenge Response
Authentication (Cram MD5)

If this check box is selected, the name and password are sent
using Cram MD5.

About using mail domains

First entries in a list

This is the default outgoing e-mail settings. It also sets the mail destination domain on which the
Voicemail Pro server filters incoming messages (see below) and so is repeated on the SMTP

Receiver tab.

For messaging between Voicemail Pro servers, the first entry in the SMTP Sender list must be the
one configured and used. Each server uses the SMTP server service on the same server
computer as the voicemail service. For example a Windows based servers uses the SMTP e-mail
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provided by the IIS on the same server. The voicemail service also uses the domain set to filter
incoming SMTP mails received by the SMTP server. For this to work, the domain entered should
be the fully qualified name of the server on which the Voicemail Pro server is running, for example
vmprol .example.com. Any incoming messages where the recipient mail domain is not exactly
the same as the specified domain are ignored. The recipient can either by vmsyncmaster,
vmsyncslave or the name or extension of a mailbox on the Voicemail Pro server, for example
Extn20l@vmprocentral.example.comor 201@vmprocentral .example.com.

Subsequent entries

The domain specifies that these settings should be used for e-mails sent to the matching domain.
The entry must be a fully qualified name resolvable by DNS or an IP address.

MAPI setup

Installing Voicemail Pro for MAPI in a domain

About this task
Before you begin to install the Voicemail Pro software, you must do the following procedures.

Related links
MAPI setup on page 55
Creating a voicemail domain account on page 55
Configuring Outlook for Voicemail Email on page 56
Installing the Voicemail Pro software on page 57
Adding a port to the Windows firewall on page 57
Switching Voicemail Pro to MAPI on page 58

Creating a voicemail domain account
Procedure

1. Make sure that the computer running the Voicemail server is a member of the domain.

To join the domain, you need access to a log account that has administrative permissions
on the domain as well as on the server computer. Contact your domain administrator to get
access to such an account.

2. On the Exchange server, create an account called Voicemail on the domain and an
associated mailbox.

Provide a secure password.

Check the User Cannot Change Password and Password Never Expires boxes.
Log on to the voicemail server computer using a domain administrator account.
Click Start > Administrative Tools > Computer Management.

In the left pane, expand Local Users and Groups, and click Groups.

© N o o ke

Double-click Administrators, and click Add.
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9.

Click Locations and select the domain name in the list.

10. In the Enter the object names to select field, type voicemail and click Check Names.

1.

Select Voicemail in the list and click OK followed by OK.

Next steps

Configuring Outlook for voicemail e-mail on page 56

Configuring Outlook for Voicemail Email

About

this task

To configure Outlook on your system, perform the following steps:

Procedure

17.
18.
19.
20.
21.

October 2018

. On the desktop, right-click the Outlook icon and select Properties.

On the General tab, select Add.

Select Microsoft Exchange Server.

Click Next.

In the Server field, enter the name of the Exchange server.

In the Mailbox field, enter Voicemail.

Click Next.

When you are asked if you travel with this computer, select No.
Click Next.

Click Finish.

. Highlight the MS Exchange Settings and click Properties.
. Highlight Microsoft Exchange Server and click Properties.
. Click Check name.

. If the name is resolved, select Apply.

. Click OK, OK, and Close to shut the mail settings.

. Do not continue until the name has been resolved correctly with the Exchange server. If

the name is not resolved, check the account details with the Exchange Administrator.
Open Outlook and select Yes to register Outlook as the default e-mail application.
Select Tools > Options.

Click the Preferences tab.

Click Email Options.

Uncheck Save copies of messages in Sent Items folder.
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You might want this option selected during initial setup to aid troubleshooting. However,
due to the size of wav file message attachments, you should uncheck this field after
installation testing is completed.

22. Log on to the computer running the Voicemail Pro Server using the voicemail account.
23. From Outlook, send a message directly to an extension user.
If this message is received correctly, you can continue installing the Voicemail Pro
software.
Next steps

Installing the Voicemail Pro software on page 57

Installing the Voicemail Pro software

About this task
To install Voicemail Pro software, perform the following steps:

Procedure

1.
2.
3.

Log off and log on using the Voicemail account and password.
Install the required Voicemail Pro software.

When the system prompts for a user name and password for the Voicemail Pro service,
enter the Voicemail account details.

Restart the server and log on using the Voicemail account.

5. When SMTP e-mail details are requested, enter no values and ignore the error message

6.
7.

following the SMTP check.
Start the Voicemail Pro service.

Check that the basic voicemail services start and operate correctly.

Related links
Starting Voicemail Pro Services manually on page 25

Adding a port to the Windows firewall
About this task

Voicemail Pro installed on Linux uses MAPI service as a proxy to the Microsoft Exchange server.
Voicemail Pro will send commands to the MAPI service, which in turn will send the corresponding
MAPI commands to the Exchange server. The responses from the Exchange server are relayed
back to the Voicemail Pro server using the MAPI service.

For the client servers to communicate with the Voicemail Pro server, add the port that the MAPI
service uses to the Windows firewall.

Procedure

1.
2.

October 2018

Open the Windows Control Panel.

Open System and Security > Windows Firewall.

Deploying Avaya IP Office™ Platform Voicemail Pro (Windows) 57

Comments on this document? infodev@avaya.com



mailto:infodev@avaya.com?subject=Deploying Avaya IP Office™ Platform Voicemail Pro (Windows)

Installation

3. Click Advanced settings.
4. Click Inbound Rules in the left pane.
5. Click New Rule in the right pane.

The New Inbound Rule Wizard opens.
6. Select Port and click Next.

7. Select TCP and enter the port number that the MAPI service uses in the Specific local
ports field.

8. Click Next.

9. Select Allow the connection and click Next.
10. Check the Domain, Private, and Public check boxes.
11. Click Next.
12. Enter a name for the rule and click Finish.

13. Click Outbound Rules in the left pane and repeat step 5 on page 58 to step 12 on
page 58.

Next steps
Switching Voicemail Pro to MAPI on page 58

Switching Voicemail Pro to MAPI

About this task

By default, the Voicemail Pro server is configured for SMTP e-mail mode. However, if MAPI
settings are entered it will switch to MAPI mode. Some options are not available if you are working
offline. You must be working online to use this feature.

Procedure
1. Start the Voicemail Pro client.

2. Click - Preferences, and select General.

3. Click the Email tab.
4. Click the MAPI sub tab.

5. Select the Enable MAPI check box to switch the Voicemail Pro server to use MAPI for its
e-mail options rather than SMTP..

6. In the Profile field, choose a MAPI e-mail account that is already configured and is able to
send e-mails from the MAPI client on the voicemail server.

7. Click OK.

" Click % Save and Make Live.
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MAPI field descriptions
x|

"General I Directories  Email | Housekeeping I SMNMP Alarm I Outcalling
MAPI | SMTP Sender | SMTP Receiver |

¥ Enable MAFI
Details

Profiles: MS Exchange Settings j

ok |  cancel | Hep |

Name Description

Enable MAPI Select this check box if you want the Voicemail Pro server to use
MAPI for the e-mail options rather than SMTP.

Profiles Use this field to select the MAPI e-mail account that you want the

Voicemail Pro server to use to provide visibility to the e-mail
account mailboxes for which it requires access. You must create
the profiles on the MAPI e-mail client on the server computer,
and configure the profiles such that the Windows account
running the Voicemail Pro service can use them.

Installing Voicemail Pro for MAPI in a workgroup
About this task

The user name and password created are requested as part of the installation of the Voicemail
Pro service. Install the Microsoft Outlook software on the computer before configuring it.

By default, Voicemail Pro is set to use SMTP for emails. You need to change this to MAPI.

You also need to set the SMTP e-mail account settings on the Voicemail Pro so that they match
those of the customer's email server.

Related links
MAPI setup on page 55
Creating a voicemail user account on page 60
Configuring Outlook Express for internet mail on page 60
Configuring Outlook for internet mail on page 61
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Configuring Outlook for the Exchange server on page 63

Installing the Voicemail Pro software on page 57

Switching Voicemail Pro to MAPI on page 58

Changing the SMTP e-mail account settings on page 65

Creating a voicemail user account
About this task

For an example, this procedure uses the name of the created user account as “Voicemail”.

Procedure

1.

Log on to the server computer using an administrator account.

2. Open the Windows Control Panel.

3. Click User Accounts > Add or remove user accounts.

4. Click Create a new account.

5. Enter voicemail as the new account name and select Administrator as the account
type.

6. Click Create Account.
The new account, Voicemail, is created and added to the list of user accounts.

7. Click Voicemail and create a secure password for the account.

Next steps

Continue with one of the following procedures as appropriate to the installed MAPI client and
method for sending e-mail.

» Configuring Outlook Express for internet mail on page 60

» Configuring Outlook for internet mail on page 61

» Configuring Outlook for the Exchange Server on page 63

Configuring Outlook Express for internet mail
Procedure

1.

Click the Outlook Express icon to start the Configuration wizard.

2. In the Display name box, enter voicemail.
3.
4

. Select | already have an e-mail address that I'd like to use and enter the e-mail

Click Next.

address.

For example, voicemail@example.com

5. Click Next.

October 2018

Enter the name or address of the Incoming mail server and the outgoing mail server.
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© Note:

If you enter the name, configure the IP address of the DNS Server in the voicemail
computer.

7. Click Next.

8. Enter the e-mail account name and password.

9.
10.
1.
12.
13.
14.
15.
16.
17.
18.
19.
20.
21.

22.
23.

For example, Voicemail

Select Remember password.

Click Next.

Click Finish to complete the wizard.

Open Outlook Express and select Tools > Options.
Click the General tab.

Uncheck Send and Receive messages at Start up.
Uncheck Check for new messages every.

Select the Send tab.

Uncheck Save copy of sent messages in the 'Sent Items' folder.
Check Send messages immediately.

Under Mail Sending Format select Plain Text.
Click OK.

Log on to the server computer using the account that will be used for the Voicemail Pro
server.

From Outlook or Outlook Express, send a message direct to an extension user.

If this message is received correctly, continue with installing the Voicemail Pro software.

Next steps

Installing the Voicemail Pro software on page 57

Configuring Outlook for internet mail
About this task

For the installation of Outlook to work correctly, follow the following setup process. You can
configure Outlook in two ways. If you use the wizard prior to completing the steps below, Outlook
sends incorrect messages.

Procedure

1.
2.
3.
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Right-click the Outlook icon on the desktop and select Properties.
Select Add.

Select Internet E-mail and click OK.
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For Mail Account, enter Voicemail.

5. For User Information, enter Vvoicemail as the name.

For the E-mail address, enter your address.

For example, voicemail@example.com

. Select the Servers tab.

Enter the name or IP address of the Outgoing mail server and Incoming mail server.
Enter the account name and password.
For example, Voicemail.

You can leave the Incoming Mail Server details blank as Outlook does not need to check
for mail.

10. Select Remember password.

11. Select the Connection tab.

12. Select Connect using my local area network (LAN) and click Next.

13. Click OK.

14. Click Next.

15. Accept the default path for file creation.

16. Select Next, then Finish, and then Close.

17. Open Outlook.

18. On the E-mail Service Option screen, select Internet Only.

19. Click Next.

20. Select Yes to register Outlook as the default e-mail application.

21. Select Tools > Options.

22. Click the Preferences tab.

23. Click E-mail Options.

24. Uncheck Save copies of messages in Sent Items folder.
You might want this option selected during initial setup and troubleshooting. Due to the size
of wav file message attachments, it is advisable to uncheck it after installation is complete.

25. Log on to the server computer using the account used for the Voicemail Pro server.

26. From Outlook or Outlook Express, send a message directly to an extension user.

27. If this message is received correctly, continue with installing the Voicemail Pro software.

Next steps

Installing the Voicemail Pro software on page 57
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Configuring Outlook for the Exchange server

About this task

This option can be selected if Outlook is to be configured to connect to the Exchange server, using
a valid user name and password, while the Voicemail computer remains a member of a work

group.

Procedure

1.

16.
17.
18.
19.
20.

21.
22.

October 2018

Create a new mailbox on the Exchange server, and assign it the same password as has
been configured on the voicemail computer.

For example, Voicemail

Clear User must Change password at Next Logon and select Password Never
Expires.

On the voicemail computer, logon with the Voicemail account.

Right-click the Outlook icon on the desktop and select Properties.

Select Add.

Highlight Microsoft Exchange Server and click OK.

Type in the Exchange server name and enter Voicemail in the Mailbox field.
Highlight the MS Exchange Settings.

Click Properties.

Highlight Microsoft Exchange Server.

. Click Properties.

. Click Check name.

. If the name is resolved, select Apply.

. Click OK, OK and Close to shut the mail settings.

. Do not continue until the name has been resolved correctly with the Exchange server. If

the name is not resolved, check the account details with the Exchange administrator.
Open Outlook and select Yes to register Outlook as the default e-mail application.
Select Tools > Options.

Click the Preferences tab.

Click E-mail Options.

Uncheck Save copies of messages in Sent Items folder.

You might want this option selected during initial setup and troubleshooting. Due to the size
of wav file message attachments, it is advisable to uncheck it after installation is complete.

Log on to the server computer using the account used for the Voicemail Pro server.

From Outlook or Outlook Express, send a message directly to an extension user.
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23. If this message is received correctly, continue with installing the Voicemail Pro software.

Next steps

Installing the Voicemail Pro software on page 57

Installing the Voicemail Pro software
About this task
To install Voicemail Pro software, perform the following steps:
Procedure
1. Log off and log on using the Voicemail account and password.
2. Install the required Voicemail Pro software.

3. When the system prompts for a user name and password for the Voicemail Pro service,
enter the Voicemail account details.

4. Restart the server and log on using the Voicemail account.

5. When SMTP e-mail details are requested, enter no values and ignore the error message
following the SMTP check.

6. Start the Voicemail Pro service.
7. Check that the basic voicemail services start and operate correctly.

Related links
Starting Voicemail Pro Services manually on page 25

Switching Voicemail Pro to MAPI
About this task

By default, the Voicemail Pro server is configured for SMTP e-mail mode. However, if MAPI
settings are entered it will switch to MAPI mode. Some options are not available if you are working
offline. You must be working online to use this feature.

Procedure
1. Start the Voicemail Pro client.

2. Click - Preferences, and select General.

3. Click the Email tab.
4. Click the MAPI sub tab.

5. Select the Enable MAPI check box to switch the Voicemail Pro server to use MAPI for its
e-mail options rather than SMTP..

6. In the Profile field, choose a MAPI e-mail account that is already configured and is able to
send e-mails from the MAPI client on the voicemail server.

7. Click OK.
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8. Click @ Save and Make Live.

Changing the SMTP e-mail account settings
Procedure

1. Open the Windows Control Panel.

? sotoct 13
Select =2 IP Office Voicemail Pro.

3. Select the SMTP Email Settings tab.

Swstemn Settings I Path Settings I Email Settings  SMTP Email Settings

—SMTP Server
kil Server: |smtp.example.cnm
Fart Humber: IEE
b ail Drop: II::'\Inetpul:u'\mailmnt'xDer J

1 Server requires authentication

Account Hame: I

Pazzword: I

[T Use Challenge Fesponse Suthentication [CRARM-MD 5]

Voicemail Email

4. Enter the settings to match the customer's e-mail server and the e-mail account configured

on that server for the Voicemail Pro service.
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5. Click the Email Settings tab.

Syztem Settingsl Path Settings  Email Settings | SMTP Email Settingsl

—Account Detalls

FEIVES Browse |

— Meszage Parameters

The following zettings are uzed to contral whether the Vaicemail
mezsage iz gent az a wave file within the email meszzage.

v &

¥ Embed wave file in meszage

6. Enter the e-mail address for the account setup on the customer's e-mail server for the
Voicemail Pro service.

7. Click Check to test the connection to the specified e-mail account.
8. Click OK.

Voicemail Email operation

User and group configuration
The e-mail address for each user and hunt group is set through the IP Office configuration.
The following fields on the Voicemail tab are set for a user and group configuration.
* Voicemail Email
* Voicemail Email radio buttons
Voicemail Email usage

Use of voicemail e-mail requires the Voicemail Pro server to have been configured to use either a
local MAPI e-mail client or an SMTP e-mail server account. See Voicemail Email on page 52.

Use of voicemail e-mail for sending (automatic or manual) e-mail messages with wav files
attached requires discretion, as a one-minute message creates a wav file of 1MB size.

If voicemail e-mail is turned off, users can change their voicemail e-mail mode using Visual Voice.
If the voicemail server is set to IP Office mode, a user can also change their voicemail e-mail
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mode through the telephone prompts. The ability to change the voicemail e-mail mode can also be
provided in a call flow using a Personal Options Menu action or a Generic action.

If the voicemail server is set to IP Office mode, users can manually forward a message to e-mail.
About copying e-mails

When e-mails are copied, there is no mailbox synchronization between the e-mail and voicemail
mailboxes. For example, reading and deletion of the e-mail message does not affect the message
in the voicemail mailbox or the message waiting indication provided for that new message.

About forwarding e-mails

When e-mail is set to forwarding, each time a new voicemail message is received in the voicemail
mailbox, that message is attached to an e-mail and sent to the e-mail address. No copy of the
voicemail message is retained in the voicemail mailbox and there is no message waiting
indication. There is no mailbox synchronization between the e-mail and voicemail mailboxes.
Users can also select this mode by dialing *01 from their extension.

Voicemail Pro 5.0+ supports voicemail e-mail to an Exchange server e-mail account. For users
and groups also enabled for UMS Web Services, this significantly changes their mailbox
operation. The Exchange server inbox is used as their voicemail message store and features such
as message waiting indication are set by new messages in that location rather than the voicemail
mailbox on the voicemail server. Telephone access to voicemail messages, including Visual Voice
access, is redirected to the Exchange server mailbox.

Voicemail field descriptions

Menu Pragramming | Mobility | Phone Manager Options || Hunt Group Membership | Announcements || Personal Directory

User | Woicemal |pND || ShortCodes | Source Mumbers | Telsphony | Forwarding | Dial In || Woice Recording | Button Programming

Yoicemail Code Vaoicemail On
Confirm Yoicemail Code [] waicemai Help
Yoicemail Ernail [] woicemai Ringhack:

‘oicemail Email Reading

CIFF Copy Forward Alert [] UM ‘web Services

DTMF Ereakout

Reception [ Breakout (DTMF O) | Systern Defaulk ()

Breakout (DTMF 23 Systemn Defaulk ()

Breakout (DTMF 3) System Default ()
Name Description
Voicemail Code and Confirm Sets or changes the user's mailbox passcode.
Voicemail Code

Table continues...
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Name

Description

If the voicemail server is set to Intuity Emulation mode, mailbox
users are asked to set a voicemail code the first time that they
access the mailbox.

Voicemail Email

Sets the user or group e-mail address used by the voicemail
server for voicemail e-mail operation. When an address is
entered, additional Voicemail Email controls display that are
used to configure the type of voicemail e-mail service that should
be provided.

Default = Blank (No voicemail e-mail features).

Voicemail Help

For voicemail systems running IP Office mailbox mode, this
option controls whether users retrieving messages are
automatically given an additional prompt “For help at any time
press 8.”

If switched off, users can still press 8 for help. For voicemail
systems running in Intuity emulation mode, this option has no
effect. On those systems the default access greeting always
includes the prompt “For help at any time, press *4” (*H in the US
locale).

Voicemail Ringback

When on, if the user has a new message, the voicemail server
can call the user's extension whenever the extension changes
from off-hook to on-hook. The voicemail server will not ring the
extension more than once every 30 seconds.

Default = Off.

Voicemail On

When on, the mailbox is used by the IP Office to answer the
user's unanswered calls or calls when the user's extension
returns busy. Note that selecting off does not disable use of the
user's mailbox. Messages can still be forward to their mailbox
and recordings can be placed in it. The mailbox can also still be
accessed to collect messages.

Default = On.

Voicemail Email Reading

Enabled for TTS e-mail reading.

Broadcast

Voicemail messages left for the hunt group are forwarded to the
mailboxes of the individual group members. The original
message in the hunt group mailbox is deleted after being
broadcast.

UMS Web Services

If selected, the user is able to use UMS to access their mailbox.
Using the UMS options, messages can be accessed via a Web
browser, an IMAP compatible e-mail application, or an Exchange
server e-mail account. This function is subject to licenses.

For more information, see UMS Web Services on page 28.

For hunt groups, the hunt group mailbox is accessed using UMS
using a Web browser or an IMAP-compatible e-mail
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Voicemail Email

If an e-mail address is entered for the user or group, additional options are selectable. These
control the mode of automatic voicemail e-mail operation provided by the voicemail server
whenever the voicemail mailbox receives a new voicemail message. Default = Off.

Name Description

Off If off, none of the options are used for automatic voicemail e-
mail. Users can also select this mode by dialing *03 from their
extension.

Copy If this mode is selected, each time a new voicemail message is
received in the voicemail mailbox, a copy of the message is
attached to an e-mail and sent to the e-mail address.

Forward If this mode is selected, each time a new voicemail message is
received in the voicemail mailbox, that message is attached to
an e-mail and sent to the e-mail address.

Alert If this mode is selected, each time a new voicemail message is

received in the voicemail mailbox, a simple e-mail message is
sent to the e-mail address. This is an e-mail message
announcing details of the voicemail message but with no copy of
the voicemail message attached. Users can also select this
mode by dialing *02 from their extension.

DTMF Breakout fields

Name

Description

Reception / Breakout (DTMF 0)

The number to which a caller is transferred if they press 0 while
listening to the mailbox greeting rather than leaving a message
(*0 on embedded voicemail).

Breakout (DTMF 2)

The number to which a caller is transferred if they press 2 while
listening to the mailbox greeting rather than leaving a message
(*2 on embedded voicemail). For pre-5.0 systems this option is
not support for Voicemail Pro running in IP Office mailbox mode.

Breakout (DTMF 3)

The number to which a caller is transferred if they press 3 while
listening to the mailbox greeting rather than leaving a message
(*3 on embedded voicemail). For pre-5.0 systems this option is
not support for Voicemail Pro running in IP Office mailbox mode.

How voicemail e-mail messages look

Messages sent by a user or group's voicemail e-mail settings contain the following sections:

To The user or group e-mail address.
From The name and address setting of the e-mail client
account.
Table continues...
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Subject Voicemail message that consists of calling number
> user name and From:calling number.

Body If the user or group's voicemail e-mail mode is set to
Copy or Forward, the message body contains the
IP Office Voicemail redirected message.

Attachment When using Copy or Forward mode, the message is
attached as a wav file.

Messages sent through a Voicemail Pro eMail action are configurable, see The Voicemail Pro
eMail Action on page 70.

The Voicemail Pro eMail action

The @ eMail action in Voicemail Pro can be used to send messages through e-mail in response
to caller actions in the voicemail call flow. The action can also attach a wav file.

Mg Yoicemail Pro Client  { Intuity : -|0O| x|
File Edit Actions Administration  Help

Mmm Loa| 3 2 &||4- &

Modules > eMail

S EEN
INEHt
E| ..... £ Default Start Points Properties for eMail K E4
....... -% Callect ﬁenerall Eritry Prompts  Spesific I Fiepu:urtingl Hesultsl
------- ﬂé Leave —Send e-mail
....... -é Callback Send e-mail to
....... .% Queued Iray.charles@mydamain.cnm
------- 85 Sl ueved Subject

I"-.J'l:nicemail Fro Meszage

Content

IThis meszade was forwarded by a Waicermail Pro email ac

e .é eMail Aittach file to e-mai
I3 &

HB Path iz assumed to be on the Yoicemail Server

(0] Cancel Help |

In the example above, the eMail action follows a Voice Question action. The $ in the eMail
action's Attach file to e-mail field instructs it to use the file recorded by the preceding Voice
Question action.
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The same method can be used with a Leave Mail action. Note however that the Leave Mail
action must be set to a valid target mailbox which will then have a copy of the message.

Alternatively, the eMail action can attach a prerecorded wav file by specifying the file name. That
named file can be created by an Edit Play List action.

Text To Speech (TTS) installation

The Voicemail Pro server uses Text To Speech (TTS) in the following ways:

» Speak text in call flows using the = Speak Text action. The text can include variables passed
from other actions including database actions.

* When installed in parallel with Voicemail Email, TTS can be used to provide e-mail reading to
selected mailbox users.

» TTS can be used by theVoicemail Pro client user to record prompts used by call flow actions.

Related links
Voicemail Email on page 52
Setting up Text To Speech to read e-mail on page 73

Windows TTS licensing

Voicemail Pro TTS requires the server computer to have a Microsoft SAPI 5 compatible TTS
engine installed and a valid license entry.

E-mail Users who want to use this feature must have their user profile configured as

Reading either Mobile User or Power User using Mobile User Profile or Power User
Profile licenses. In addition, IP Office with a Windows-based Voicemail Pro
server must have a VMPro TTS (Generic) or a VMPro TTS (ScanSoft) license
and IP Office with a Windows-based Voicemail Pro server must have a VMPro
TTS Professional license for e-mail reading to work.

Speak Text The license for this operation depends on whether you are using the Avaya-

Actions / supplied ScanSoft TTS speech engine or a third-party generic TTS speech
Prompt engine (including the TTS speech engines included in Microsoft operating
Recording systems).

* Generic TTS — The use of up to eight simultaneous generic TTS ports is
enabled by the Advanced Edition license. Alternatively separate VMPro TTS
(Generic) licenses can be added.

* Avaya ScanSoft TTS — The use of the Avaya-supplied ScanSoft TTS engine
is licensed by the addition of VMPro TTS (ScanSoft) licenses to the IP Office
configuration.
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Generic TTS licensing

If you add both generic TTS and ScanSoft TTS licenses, the system will use both of the TTS
engines for calls on a first-come-first-serve basis. You will not be able to control the use of TTS
engine for particular calls. Therefore, license only one type of TTS engine within a system.

Languages

For Voicemail Pro 5.0 or higher on Windows, the TTS engine supports the same set of languages
as Voicemail Pro speech prompts except for Hungarian.

For Voicemail Pro 8.0 or higher on Linux, the TTS engine supports the same set of languages as
Voicemail Pro speech prompts except for Hungarian, Korean, and Chinese (Cantonese). For
these unsupported languages, there will be no alternate languages selected. If any of the three
unsupported languages is configured in Voicemail Pro 8.0 or higher, then TTS will not play
anything.

If more than one TTS language is installed, use the Select System Prompt Language action to
switch TTS to a different language from the selected default.

Checking that Windows Audio is enabled
About this task

On many Windows server computers, while the Windows Audio components are present by
default they are not always enabled. If this is the case the playback of voice prompts may be
“choppy” and the TTS (if installed) will not work. However, enabling Windows Audio does not
require the server computer to have a sound card installed.

Procedure
1. Verify that you have full administrator rights for the computer.
2. Click Start > Administrative Tools > Services.

3. If the status of the Windows Audio service is not Started, start the service and set the
Startup Type to Automatic.

Installing Generic Text To Speech
Procedure

1. Install and test Voicemail Pro as normal.

2. Using IP Office Manager, add the Advanced Edition or VMPro TTS (Generic) license into
the IP Office configuration.
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3. Send the new configuration to the IP Office system.

4. Reload the IP Office configuration into IP Office Manager and check that the status of the
license has changed to Valid.

5. The Voicemail Pro installation includes the default Microsoft TTS engines (Microsoft Sam,
Mike, Mary, and Simplified Chinese) as standard. If another third-party SAPI 5 compatible
TTS engine is going to be used, install that software.

6. If the system is licensed for generic TTS, Voicemail Pro automatically discovers any SAPI
5 installed engine. If there is no third-party engine, then the Microsoft third-party engine is
used.

Installing Avaya Text To Speech

About this task

The Avaya TTS engine for Voicemail Pro is supplied on media disks (x2) separate from the
Voicemail Pro software installation media. By default, TTS engine installation also includes
installation of the English US and English UK language packs.

Procedure
1. Install and test Voicemail Pro as normal.

2. Using IP Office Manager, add the VMPro TTS (ScanSoft) license into the IP Office
configuration.

3. Send the new configuration to the IP Office system.

4. Reload the IP Office configuration into IP Office Manager and check that the status of the
license has changed to Valid.

5. Insert the first Avaya TTS DVD.
The installation auto-starts.
6. Follow the prompts and install the required languages.

7. If the system is licensed for Avaya TTS, the ScanSoft engine is automatically used.

Setting up Text To Speech to read e-mail

Before you begin

» The Voicemail Pro server must have been installed and configured to support Voicemail
Email.

« E-mail reading can only be enabled for IP Office users whose Profile setting is set to Mobile
User or Power User. IP Office must have a VMPro TTS (Generic) or a VMPro TTS
(ScanSoft) license for e-mail reading to work with a Windows-based Voicemail Pro server
and a VMPro TTS Professional license for e-mail reading to work with a Linux-based
Voicemail Pro server.
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* This feature is supported only for Intuity mode. Users hear their new voicemail messages and
then the number of “Messages with text”. Before each e-mail is spoken, details of who it is
from, when the message was sent, and the size are given. These details assist you in
deciding to skip large or non-urgent e-mails.

« E-mail reading cannot be used for e-mails in HTML format. If HTML messages are received,
all of the code will be read out as a message.

About this task

In conjunction with MAPI e-mail clients and Exchange server, TTS can be used to read new e-
mails in a user's e-mail inbox when they access their voicemail mailbox.

Procedure
1. Within the IP Office configuration, display the settings for the user.

2. On the User tab, set the user's Profile to either Mobile User or Power User.

Menu Programming | Mobiliky | Phone Manager Options I Hunt Group Membership I Announcements | Personal Directory I

Liser |\-'|:|icernail | DHD | ShortCodes I Source Mumbers I Telephany | Faorwarding I Dial In I Yoice Recording | Button Prograrming

Mame IExthDl

Password I

Confirm Password I

Full Mame [lbert

Extension [201

Locale | =l

Priority E |
[Profile [Mobile User =l ]

r Receptionist

3. On the Voicemail tab, enter the user's e-mail address in the Voicemail Email field.

4. Enable the Voicemail Email Reading field.

Menu Prugrammlng | Tahiliby I Phone Manager Opkions | Hunt Group Membership | Announcements | Personal Directory |

User {| DMD | ShortCodes | Source Mumbers | Telephorny | Forwarding | Dial In | Woice Recording | Button Programming

Voicemaill Cade I**** V¥ vaicemail on

hetekok

Confirm Yoicemail Code I I~ voicemail Help

[Voicemail Ermail Itest@example.com ] I~ voicemail Ringback,

( ¥ vaicemail Emai Readingj

™ UM3 web Services
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Troubleshooting

Starting Voicemail Pro Services manually

About this task

If you have installed Voicemail Pro successfully and rebooted the server computer, then the
voicemail service starts automatically. However, you can restart the service manually, if required.

Procedure
1. Click Start > Administrative Tools > Services.

Q Services

File  aAction  Wiew Help

&= = | [ L B

., Services (Local) Mame = i Diescription Status j Startup Type Log On As _:_j
5k Telephony Provides Telephory... Manual MNetwork Se...
{,;)_;Thread Crdering Se... Provides ordered e... Manual Local Service
{GETP AutoConnect Se...  ThinPrint .print com..,  Started Manual Local System
{;};.TP WiZ Gateway Ser...  ThinPrink ,print com... Manual Laocal System
'f.:_’;TPM Base Services Enables accessta b, Manual Local Service
\S;z_‘;UPnP Device Host Allowss UPRP device. .. Disabled Laocal Service
iChUser Profile Service  This service is respo...  Started Autornatic Local System
\S;"a‘;.\n'irtual Disk, Provides manageme. .. Manual Laocal System
'f._:_’;VMware Tools Service  Provides support Fo...  Started Autarnatic Lacal System

Mware Upgrade H...  Virtual hardware up...  Started Automatic Local System

email Pro e Started Autornatic A Administra. ..
Lvolume Shadow Copy  Manages and imple. .. Manual Local System
{,:_’;Windows Audio Manages audio for ... Manual Local Service
\E;)_;Windows Audio End... Manages audio devi... Manual Local System
Ehwindows Color Sys... The WesPlugIngersi. ., Manual Local Service
~%Windows Driver Fo... Manages user-mod... Manual Local System :j
% Extended )\ Standard

The Voicemail Pro Service should be visible. Its Status should be Started and the
Startup Type should be set to Automatic. Other services may be present depending on
the installed Voicemail Pro features. The Voicemail Pro Service is the main Voicemail Pro
service. This is the only service that needs to be stopped and restarted. It stops and
restarts the other services that it uses.

2. Close Services.

Setting the Voicemail Pro Service or computer to restart
automatically

About this task

The following action is optional. If a fault causes the Voicemail Pro service to stop, the fault should
be investigated and fixed. However, setting the options to restart the services or the computer
automatically will minimize the disruption to the Voicemail Pro users.
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Installation

Procedure

1.

Click Start > Administrative Tools > Services.

2. Right-click Voicemail Pro Service and select Properties.
3.
4

. Select the items in the drop-down lists to specify the action that the computer must take in

Select the Recovery tab.

case of failures.

Using a batch file to start services

About this task

In some instances, certain computers might not respond quickly enough to start all of the Avaya
services in the correct order. In this circumstance, you should create a batch file that delays the
start of these services until the computer is fully running.

Avaya IP Office Services can be started successfully at system start-up using a scheduled task
that initiates the batch file below. This batch file ensures that the services will start successfully
and in the correct order.

Procedure

1.
2.

3.

Set all Avaya services listed below to Manual start. Do not include Key Server.
Create the batch file below and save it to $SYSTEMROOT%.

Only include lines for the services that are installed.

@echo off

rem Wait 60 seconds before execute.
timeout /t 60

net start Voicemail Pro Service

Create a scheduled task to start the batch file at system start-up.

Service Log On Failure

About this task

The voicemail service will not start if the account specified during its installation does not have the
right to log on as a service. This process details how to apply that right to an existing account on
the server.

Procedure

1.

Open Local Security Policy.

2. In the console tree, double-click Local Policies.
3. click User Rights Assignments.
4. In the details pane, double-click Log on as a service.
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Troubleshooting

5. Click Add User or Group and add the appropriate account to the list of accounts that

possess the Log on as a service right.

Voicemail Pro User

Log

User authentication failures are logged in the event viewer, under VMPro User Log.

gtumputer Management

File  Action View Help

ME B

€= 2 mH=

é- Computer Management {Local) Level

| Date and Time | Source

| Event ID| Task Cakegaor |

= '[[’j System Tools
':E-:l Task Scheduler
= @ Event Yiewer
Bl [ Custam Yiews
| Server Roles
T Administrative Eve
» "Windows Logs
“ Applications and Servi
5| Hardware Everts
5| Internet Explorer

EE|

| Actions

¥MPro User Log

v

< Open Saved Log...

Create Custom Yiew. ..
Import Custom Yiew..,
Clear Log...

Filter Current Log. ..

Properties

4| Key Management
| Microsoft
4| ¥MPra User Log
| windaws Powerst
-4 Subscriptions
| Shared Faolders

Find. ..

CED =«

Sawve Al Events As...

Attach a Task To this Log...

d _
i-: Local Users and Groups Wiga »
Eé‘i‘::il Performance o Refresh
== Device Manager Ed —
=l =5 Storage E Help »
= Disk Management
_'::';_- Services and Applications Log Marne: :I
Source: Logged: J

EwentID: Task Categon:

Lewel: Keyeord s -
4| | 3

| | N

The following details are logged:
* UserlD
* Tool name

+ |P address of the client trying to log in

Viewing log details
Procedure
1. Click Start > Administrative Tools > Computer Management.

2. In the left pane, expand System Tools > Event Viewer > Applications and Services
Logs.
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Installation

3. Click VMPro User Log in the tree to view the details.

About DbgView

Many applications, including Voicemail Pro, output activity messages that are viewable in Debug
View (DbgView). This application can be downloaded at http://marketingtools.avaya.com/
knowledgebase/tools/debug.

File Edit Wew Help

03/04 15:38:335.531 Dhgout (01,51 2816,285%92: Dl1IMainChinstDLL=0x10000000, fdwReason=DLL_THREAD_| DETA &
03,04 15:38:33.906 vmprovss (09,5) 2816,2872: Create New User 192.168.42. l port=4095
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03,04 15:38:33.906 vmprov5s (09,3) 2816,2872: VB Scripting is WOT licenced
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03,04 15:38:33.906 vmprov5s (09,3) 2516,2872: gcanzoft TTS sSupport s nNOT 1icenced
03/04 15:38:33.906 vmprowis (09,3 2816,2872: Generic TTS Support is NOT Ticenced
03,04 15:38:33.906 vmprovss (09,5) 2816,2872: BulkInforequest 192.168.42.1 3

03/04 15:38:33.906 vmprowis (09,5 2816,2872: PEx Requesting ALaw companding

03,04 15:38:33.906 vmprovss (09,5) 2816,2872: Initialize Sequencer tx_seg=0, rx_seg=0

03/04 15:38:33.906 vmprowss (09,5) 2816,2872: TFTPLoadFile 192.168.42.1

03,04 15:38:33.906 vmprovss (09,5) 2816,2872: 0 mailboxes were open Chut not actiwve) when flushed
03,/04 15:38:33. 906 Dhoout {01,551 2816,2612: DlIMainChinstDLL=0x10000000, fdwReason=DLL_THREAD_ATTA
03/04 15:38:33.906 Dhgout (01,5) 2816,2900: D1IMainChinstoLL=0x10000000, fdwReason=DLL _THREAD_ATTA
0304 15:38:33. 0908 wmnrnwGs (00,57 2R1A.2R7> . newTo: sstartTask 102 16AR. 471 X

JReady

Installing Debug View
Procedure

1. Download the DbgView zip file.

http://marketingtools.avaya.com/knowledgebase/tools/debug

2. Unpack the files into a folder such as c: \debug on the server computer.
3. Run DbgView.exe.

Events are shown in the DbgView window. These can be logged to a file if required. The
level of detail shown can be filtered to show more or less activity.

Using Debug View for logging

Procedure

1. Run DbgView.exe.
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2. Select File > Log Preferences.

Select Logging Information

Log Mode
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Cancel

Troubleshooting

3. Set the logging details that are required and click OK.

The debug log files can be opened in programs such as WordPad.

While DbgView is running, the viewable trace is also copied to the specified file.

Using Debug View for filtering

Procedure

1. Select View > Debug Filters.

Configure Debug Filters
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2. Select the module for which you want to increase or decrease reporting.

3. In the right hand panel, adjust the level of reporting.

4. Close the Configure Debug Filters window.
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Installation

The voicemail console

The voicemail console mode (that is running as the voicemail service in Interact with desktop
mode) is no longer used. Running services in this mode is not supported by Microsoft on Vista or
Server 2008.

Instead, use the debug viewer to view voicemail server activity as it occurs.
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Chapter 3: Using the Voicemail Pro client

About this task

The Voicemail Pro client is used to administer the Voicemail Pro server. This section covers the
basic operation of the Voicemail Pro client to connect to a Voicemail Pro server. For details on
administration using the Voicemail Pro client, see Avaya IP Office Administering Voicemail Pro
(15-601063).

For a Windows-based server, the client can be installed on the same server and used locally to
administer the server. The client can also be installed separately on another Windows computer and
then used to remotely administer the server.

Logging in to the Voicemail Pro server
About this task

If you start the Voicemail Pro client on the same computer as the Voicemail Pro server, the system
automatically loads the settings to manage the server. You will have full access to all the servers
settings, and you do not need to login with an administrator account name and password.

To connect to a remoteVoicemail Pro server, you need to login using the name and password of
an administrator account already configured on that server. The default account name is
Administrator and the password is Administrator. After logging in with this account, you
should change the password from that default value.

Starting the Voicemail Pro client
Procedure

1. From the Start menu, select Programs > IP Office > Voicemail Pro Client.
The Voicemail Pro Client window opens.

If the client has been started before, it starts in the same mode as it used previously. If it
fails to do that, or if this is the first time that the client has been started, the Select Mode
menu displays.
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Using the Voicemail Pro client

B Select Voicemail Pro Client Mode

Select Mode

) Online  [WmPro server iz on LAN o'Wl |
(%) Offline [ Oifine mode for Windows |

) Offline [ Offline mode for Lince)

[ ] l [ Cancel ] [ Help ]

2. Select either of the Offline modes to import and export voicemail call flow and module files
without being connected to any Voicemail Pro server.

3. To connect to a Voicemail Pro server, select Online.

& VmPro Login E|
Pleaze enter a User Mame. This iz the name that the worl:ztation zoftware
inztalled on this PC will use.
Lodin
Ilzer Mame: | |
|Jzer Passward: | |
it Mameh P Address: |'|E|2_1 BO.0.203 w | [ Browse, . ]
Back ] [ Login ] [ Cancel ] [ Help ]

4. Enter the name and password for an administrator account on the Voicemail Pro server.

» These fields are not required if accessing a Voicemail Pro server on the same computer
as the client.

* The default account name is Administrator and the password is Administrator.
After logging in with this account, you should change the password from the default
values.

* If three consecutive login attempts fail for an administrator account name, the account is
locked for an hour.

5. In the Unit Name\lP Address field, enter the DNS name or IP address of the Voicemail

Pro server.
Alternatively, click Browse to search the local network for a server and select a server from
the results.
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Logging in to the Voicemail Pro server

Select Networked Voicemail System E'
Mame P Address Yerzion | Type
TECHFUBSERVER 192.168.0.203 E.1.04  “mPro

Cancel

© Note:

As Voicemail Pro client cannot find Voicemail Pro server running on Unified
Communications Module, you cannot use Browse to connect to Voicemail Pro server
installed on Unified Communications Module.

If connected to a remote server, the Confirm Callflow Download window displays. If you
select Download, any existing call flow that you have loaded in the client is overwritten.
For more details, see Call flows on page 84.

Confirm Callflow Download

The callflow on the chent iz different to the callflow on 192.168.0.203.
YWiould you like to download the callflaw from 192.168.0.2037

[ Dowrload H Cancel H Help ]

6. To log in automatically to the selected Voicemail Pro server when you launch Voicemail Pro
client next time, select the Remember Me check box.

7. If this is the first time that the Voicemail Pro server has been logged into, you should first
change the default remote access account.

+ If you logged in remotely using the default account, select File > Change Password.

* If you logged in locally, select Voicemail Pro Administrators in the navigation panel.
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Using the Voicemail Pro client

Call flows

When you connect to a server across a LAN or WAN to view or modify the call flow on the server,
a check is made to see if the call flow that is stored locally on the client is the same. The call flow
on the server might be different to the call flow on the client because:

» The local call flow is older than the version on the server, for example if the call flow on the
server has been modified by another Client connection.

» The local call flow is newer than the version on the server, for example if the call flow on the
server has been worked on while the local Client was being used in offline mode.

» The local call flow is from a different server, for example if you are connecting to a different
server to the one from which the call flow was previously downloaded.

If the call flow is the same, no data will need to be copied from the server to the client. If the call
flow is different you can chose to download the call flow from the server or to use the local call
flow.

You can upload the local call flow to the server using the Save or Save and Make Live options
from the File menu.

Related links
Saving changes and making them live on page 85

Confirm Callflow Download field descriptions

Confirm Callflow Download

The callflow on the chent iz different ta the callflaw on 192.168.0.203.
“whould you like to download the callflov from 1321680 2037
D owriload ] [ Cancel ] [ Help
Button Description
Download Downloads the call flow from the server.
Cancel Exits the window.

Continue offline message

Only one Voicemail Pro client can be connected to a Voicemail Pro server at any time. To prevent
an idle client session from blocking the server, a Client/Server Connection Timeout (mins)
setting is used to disconnect the idle client session. By default, the timeout is set to 5 minutes.
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Saving changes and making them live

If your Voicemail Pro client session has timed out, the Voicemail Pro client prompts you whether to
re-establish the session or close. You are then able to continue working in offline mode or to close
the client.

Saving changes and making them live
About this task

The call flow settings shown and edited using the Voicemail Pro client are stored in a database
file, vmdata .mdb, on the Voicemail Pro server. However, when edited, the changes are not
automatically applied to the operation of the Voicemail Pro server. Instead, the database file must
be converted to a separate file, Root . vmp, that being the file that is used by the Voicemail Pro
server for its current operation.

Saving the configuration and making it live
Procedure

Choose % Save & Make Live to save the settings as the Root . vmp file used by the Voicemail
Pro server.

If you are working remotely in Offline mode, you are prompted to select whether to save your
changes to the local database or to the remote server.

Saving the configuration to a file without making it live
About this task

Call flow settings can be saved to a . vmp file and then included in the operation of another
voicemail system.

Procedure
1. Choose | Save as to save the database as a . vmp file with the name that you specify.

2. Copy the file to other systems, as needed.
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Using the Voicemail Pro client

Logging out
About this task

It can be useful to connect to a system to download the current system configuration and then
disconnect and make changes offline. You can then test configuration changes offline before
applying them to a live system.

* Logging out is not the same as closing down with the Exit option. See Closing the Voicemail
Pro client on page 86.

« If the client and server are installed on the same computer, the Log Out option is not
available.

Procedure
From the File menu, select Log Out.

You are logged out of the Voicemail Pro server and placed in offline mode. You can either make
configuration changes offline and then log back in when you are ready, or log on to a different
server to work.

Related links
Logging in to the Voicemail Pro server on page 81

Closing the Voicemail Pro client
About this task

When you have finished working, you can close down the Voicemail Pro Client.
Procedure
1. From the File menu, select Exit.

* If you have not made any changes, the Voicemail Pro Client closes and you are returned
to the desktop.

* If you have made any changes, you are prompted whether to save the changes.
2. Select one of the following options.
* If you do not want to save the changes, click No.
No changes are saved.
+ If you want to save the changes, click Yes.
The changes are saved but not made live.

3. If you want to make the changes live, click Save & make Live.
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Chapter 4: Centralized Voicemail Pro
overview

A Small Community Network (SCN) consists of several |IP Office telephone systems. These are
connected using H323 Lines where the Supplementary Services settings of the lines has been set to
IP Office SCN. For details, see Avaya IP Office Manager (15-601011).

Within a Small Community Network, several options for providing voicemail are described in this
topic.

Centralized voicemail

Centralized
\oicemail

Server IP Office

Central
|P Office

aw

Centralized Voicemail Pro uses a single Voicemail Pro server to provide voicemail services for all IP
Office s in the Small Community Network. Except for use of ContactStore, only the central IP Office
hosting the Voicemail Pro server requires licensing for Voicemail Pro operation and features.

|P Office
(Cemtralized)

Licenses: The central IP Office is licensed as normal for Voicemail Pro operation and the voicemail
features required. The other IP Office s only require licenses for UMS and or for ContactStore if
required.

For more information, see Centralized voicemail on page 89.

Centralized voicemail with fallback IP Office

Centralized
Waicemail
Server

Fallback
|P Office
. (Cortralized)

IP Office

W

October 2018 Deploying Avaya IP Office™ Platform Voicemail Pro (Windows) 87

Comments on this document? infodev@avaya.com



mailto:infodev@avaya.com?subject=Deploying Avaya IP Office™ Platform Voicemail Pro (Windows)

Centralized Voicemail Pro overview

Control of the Voicemail Pro server can be taken over by another IP Office if the central IP Office
becomes unavailable. Available with IP Office Release 5.0+ with Voicemail Pro 5.0+.

Licenses: The fallback IP Office that takes over control of the Voicemail Pro requires licenses for
Voicemail Pro operation and the features required during fallback.

Centralized voicemail with a backup Voicemail Pro server

Backup

Yoicemail §
Server
[+

IP Office

fca'?ﬂ'a‘i

IF Office

. rcemrau

The central IP Office hosting the Voicemail Pro server can be configured with the IP address of a
backup Voicemail Pro server. During normal operation, call flows and other settings on the backup
server are kept synchronized with those of the primary Voicemail Pro server. If the primary Voicemail
Pro server becomes unavailable to the network, voicemail services are provided by the backup

Voicemail Pro server.

« Available with IP Office Release 6.0+ with Voicemail Pro 6.0+.

+ SMTP SSL/TLS communication is used to exchange information between the servers. If the
servers fail to connect using SSL/TLS over SMTP, then plain text communication is used.

Licenses: The existing licenses are used.

For more information, see Centralized voicemail with a backup voicemail server on page 92.

Centralized voicemail with distributed Voicemail Pro servers

Distributed
Yoicemail Server

SMTP
Centralized

Volcemall Server @
+ SMTP Server

IP Office

lDf'sh'bu

Central
|P Office

&l Fro) ”

|P Office
bl zed)

Other IP Office s in the Small Community Network can host their own Voicemail Pro server. That
server is then used for the IP Office's voicemail functions except message storage.

« Available with IP Office Release 6.0+ with Voicemail Pro 6.0+.

+ SMTP SSL/TLS communication is used to exchange information between the servers. If the
servers fail to connect using SSL/TLS over SMTP, then plain text communication is used.
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Centralized voicemail

» The distributed Voicemail Pro server provides all voicemail services except voicemail collection
for its associated IP Office.

Licenses: Each IP Office using a distributed Voicemail Pro server must have licenses for Voicemail
Pro operation and the voicemail features required.

For more information, see Centralized voicemail with distributed voicemail servers on page 95.

In all the cases above, the central Voicemail Pro server remains the store for messages and
recordings (except for Exchange UMS users). The central Voicemail Pro server does message
waiting indication and is the Voicemail Pro server used for message collection. Only when the
central server is temporarily unavailable will the backup or any distributed server do message
storage and collection. In those scenarios, when the central server is restored, messages collected
by the backup or distributed servers are forwarded to the central server.

Combinations of the solutions above can be deployed. For example, you can use a backup server
and fallback IP Office control.

For more information, see Combined options on page 99.

Centralized voicemail

Within a Small Community Network, a single Voicemail Pro server can be used to provide
voicemail features for all the IP Offices in the SCN.

Centralized
Yoicemail

Server |F Office

(Certralized)

Central
|P Office

lfoicea & Fm)

IP Office

One IP Office is configured for operation with the Voicemail Pro server as normal, including the
license for voicemail operation and the features required. This IP Office is then regarded as the
central IP Office for voicemail.

Within the other IP Office systems, the voicemail settings are configured to indicate that they get
their voicemail services from the central IP Office. These IP Offices do not need licenses for
voicemail (except for ContactStore and or UMS if required).

With the International Time Zone functionality available on the central Voicemail Pro server, the
users of the IP offices located in different time zones across the globe receive messages in their
voicemail system with their respective time stamp. In the sample scenario, the three IP Offices
located in different time zones connect to each other. Two of the IP Offices are located in different
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Centralized Voicemail Pro overview

geographical locations and are connected to the central IP Office. The Voicemail Pro server
connects to the central IP Office. In this setup, the system stores the voicemail messages on the
centralized Voicemail Pro. Each IP Office is set up to use Simple Network Time Protocol (SNTP) .

In the centralized Voicemail Pro setup, the time source of the IP Office network must be SNTP
(Simple Network Time Protocol).

Simple Network Time Protocol (SNTP) is an Internet standard protocol (built on top of TCP/IP) that

provides accurate synchronization to the millisecond of computer clock times in a network of
computers. It synchronizes all the IP Office s in an SCN configuration.

Summary of IP Office settings

Once the IP Office SCN has been setup, the following settings are used in the IP Office systems to
provide voicemail operation for all the IP Office s.

IP Office settings

Central IP Office

Other IP Office s

Voicemail type

Voicemail Pro

Centralized voicemail

Voicemail IP address

Set to the Voicemail Pro server
computer's IP address.

Not used.

Voicemail destination

Not used.

Set to the Outgoing Group ID of
the H323 Line to the central IP
Office.

Licenses

This system needs licenses for all
the Voicemail Pro features
required.

The other IP Office s only require
licenses for UMS and or for
ContactStore if required.

When accessing a Voicemail Pro server that is acting as centralized Voicemail Pro server, the
Voicemail Pro displays Centralized Voicemail in the title bar.

Related links

Voicemail Pro licenses on page 10

Fallback IP Office control

IP Office Release 5.0+ supports a number of fallback features for Small Community Networks. In
conjunction with Voicemail Pro 5.0+, fallback can include one of the IP Office s assuming control
of the Voicemail Pro server should the central IP Office become unavailable on the network.

Normal operation

During normal operation, voicemail services for the Small Community Network are provided by the
central IP Office communicating with the Voicemail Pro server.
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Fallback IP Office control

Centralized
Wolce mail
SErVEr

Fallback
P Office

Central

P Office

_ (Centraliz=d)

Fallback control operation

If the central IP Office becomes unavailable to the network, control of voicemail services for the
Small Community Network is taken over by the fallback IP Office.

Centralized
Yoicemail
Server

Fallback
|F Office

|F Office

N fCentra
A Caution:

During the transition of voicemail control, access to voicemail may be unavailable for several
minutes. Existing voicemail calls are disconnected and new calls are routed as if voicemail is
unavailable. The same applies when the central IP Office is restored.

Setup and requirements for voicemail fallback

Within the configuration of the central IP Office hosting the Voicemail Pro server, on the H323 Line
to the fallback IP Office:

* The Supplementary Services setting should be changed from IP Office - SCN to IP Office -
SCN Fallback.

* The option Backs up my Voicemail should then be selected from the SCN Backup
Options.

The fallback IP Office is configured for centralized voicemail as normal. However its configuration
must also include licenses for the Voicemail Pro support and the voicemail features required
during fallback.
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Backup voicemail server operation

For IP Office Release 6.0 or later, the central IP Office hosting the Voicemail Pro server can be
configured with the IP address of a backup Voicemail Pro server. If the central Voicemail Pro
server becomes unavailable to the network, the backup server will be used to provide voicemail
services. This option requires the Voicemail Pro servers to be running Voicemail Pro Release 6.0
or later.

During normal operation

Centralized voicemail with a backup server during normal operation.

Backup
Yoicemail Server
Centralized  spTp :‘;.;‘ IP Office
Waoicemail 0 {Canbralized)
Server
3=

I[P Office

{Certralized)

+ Voicemail services and message storage for the IP Offices is provided by the central
Voicemail Pro server.

« Call flows, greetings, recorded names, and configuration settings on the backup Voicemail
Pro server are synchronized with those on the central Voicemail Pro server. The configuration
settings that are synchronized include the registry settings, user variables, SMTP mappings,
and alarms. However, the directory locations, settings specific to Voicemail Pro client,
Voicemail Pro IIS port settings, Campaign settings, Service SID of the Voicemail Pro service,
and backup configuration settings are not synchronized.

* Messages are synchronized, but the central Voicemail Pro server remains the message
store.

» The central and backup servers are synchronized regularly at defined intervals using SMTP
SSL/TLS communication between the servers. If the servers fail to connect using SSL/TLS
over SMTP, then plain text communication is used.

During backup operation

Centralized voicemail with a backup server during backup operation.
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Backup voicemail server operation

Backup

Yoicemail 3\?
Server
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|F Office
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Central
P Cffice
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If the central Voicemail Pro server become unavailable to the network:
» The backup Voicemail Pro server provides voicemail services to the IP Offices.
* New messages are stored on the backup server.

After backup operation

When the central server is restored to the network:

 Call flows, greetings, recorded names, and configuration settings on the central server are
synchronized with those on the backup server.

» The central server sends a signal to the backup server to indicate that it is ready to resume
control as the active Voicemail Pro server.

* Depending on the mode of failback operation configured, the system administrator or the
backup server initiates failback operation to reinstate the central server as the active
Voicemail Pro server.

- Manual Failback
- Graceful Failback
- Automatic Failback

© Note:

For details on configuring failback operation on backup server, see the "Configuring
Failback Operation on Backup Server" section in Avaya IP Office Administering
Voicemail Pro (15-601063).

* Any new calls that arrive when failback operation is in progress are lost.

* If the backup server becomes unavailable to the network before failback operation, the
central sever resumes control as the active Voicemail Pro server.

+ Call flows defined on the central server are synchronized with the backup server.
+ Call flows defined on the central server cannot be modified on the backup server.
* Call flows cannot be defined on the backup server.

« Call flows defined on a distributed server are not synchronized to the central or backup
servers.

October 2018 Deploying Avaya IP Office™ Platform Voicemail Pro (Windows)

Comments on this document? infodev@avaya.com

93


mailto:infodev@avaya.com?subject=Deploying Avaya IP Office™ Platform Voicemail Pro (Windows)

Centralized Voicemail Pro overview

Related links
Backup server configuration on page 94
Manual failback on page 94
Graceful failback on page 95
Automatic failback on page 95

Backup server configuration
1. The Voicemail Pro server software is installed as normal on the backup server computer.
The voicemail server is not specifically configured as being a backup server.

2. The central IP Office hosting the primary voicemail server is configured with the IP
addresses of both the primary voicemail server and the backup voicemail server.

Swsbern | LAMNL | LANZ | DNS Yoicemail Telephory || Directory Services | System Events | SMTP | SMDR | Twinning || YCM CCR
Yoicemail Type Woicemail Lite/Pro + | [¥] Messages Button Goes To Yisual Yoice

Woicemail Destination

Woicemail IP Address 192 . 168 42 201

[ Backup Yoicemail [P Address | 192 156 42 211 ]

3. The other IP Office s are configured for centralized or distributed voicemail as normal.

Manual failback
The following is the sequence of events for the manual failback operation of the backup server:

1. The backup server functions as the active Voicemail Pro server until the system
administrator shuts down the backup server.

2. The system administrator chooses one of the following options to shutdown the backup
server:

* If no voicemail calls are active on the backup server, shutdown the backup server
immediately.

* If some voicemail calls are active on the backup server, suspend the backup server
operation to prevent any new voicemail calls. Then, shutdown the backup server
immediately after all the active voicemail calls on the backup server come to an end.

* If some voicemail calls are active on the backup server, suspend the backup server
operation to prevent any new voicemail calls. Then, shutdown the backup server
immediately after the number of active voicemail calls on the backup server reduces
significantly.

3. When the backup server shuts down, the central server resumes control as the active
Voicemail Pro server.

Related links
Graceful failback on page 95

October 2018 Deploying Avaya IP Office™ Platform Voicemail Pro (Windows) 94

Comments on this document? infodev@avaya.com



mailto:infodev@avaya.com?subject=Deploying Avaya IP Office™ Platform Voicemail Pro (Windows)

Distributed voicemail servers

Automatic failback on page 95

Graceful failback

The following is the sequence of events for the graceful failback operation of the backup server:

1. The backup server functions as the active Voicemail Pro server while voicemail calls are
active on the backup server.

2. The backup server hands over the control to the central server immediately after all the
active voicemail calls on the backup server come to an end.
Related links
Manual failback on page 94
Automatic failback on page 95

Automatic failback

The following is the sequence of events for the automatic failback operation of the backup server:

1. The backup server enters the suspend mode to prevent any new voicemail calls and starts
a countdown timer for the failback operation timeout.

2. The backup server functions as the active Voicemail Pro server until any one of the
following events:

+ All active voicemail calls on the backup server come to an end.
» Timeout period for failback operation is elapsed.

3. The backup server hands over the control to the central Voicemail Pro server immediately
after any one of the aforementioned events.

© Note:

If the failback operation timeout is set to 0, the hand over of the control is immediate.

Related links
Manual failback on page 94
Graceful failback on page 95

Distributed voicemail servers

For IP Office Release 6.0 and higher, remote IP Office s in the Small Community Network can be
associated with another Voicemail Pro server in addition to the centralized Voicemail Pro server.
The additional distributed server then provides all voicemail services (except message storage
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and collection) for that IP Office. This requires the remote IP Office to have licenses for voicemail
operation and the features it requires.

While the distributed server does message recording, it forwards all messages to the central
Voicemail Pro server. The messages are transferred between systems using an IIS SMTP e-mail
services. For mailbox users, message waiting indication and message collection is still done using
the central Voicemail Pro server. With the support of International Time Zone (ITZ) functionality,
the users of the IP Office s located across the globe receive messages in their voicemail system
with their respective local time stamp.

Centralized voicemail with additional distributed voicemail servers

Distributed
Yoicemall Server

SMTR
Zentralized
Voicemail Server
+ SMTF Server

P Office
(¥ striterbed)

P Office

{Cemtralizad)

In this scenario, the three IP Office s located in different time zones connect to each other. Two of
the IP Office s are located in different geographical locations and are connected to the Central IP
Office. The Central IP Office connects to a central Voicemail Pro server and the other IP Office s
connect to the Distributed Voicemail Pro server, an additional voicemail server added to the Small
Community Network. Each IP Office is set up to use Simple Network Time Protocol (SNTP), the
time source of the IP Office Network.

Simple Network Time Protocol (SNTP) is an Internet standard protocol (built on top of TCP/IP) that
provides accurate synchronization to the millisecond of computer clock times in a network of
computers. It synchronizes all the IP Office s in an SCN configuration.

» Other IP Office s continue to use centralized voicemail as normal.

» An IP Office that is using a distributed Voicemail Pro server cannot also be used as the
fallback IP Office for the central Voicemail Pro server.

* SMTP SSL/TLS communication is used to exchange information between the servers. If the
servers fail to connect using SSL/TLS over SMTP, then plain text communication is used.

October 2018 Deploying Avaya IP Office™ Platform Voicemail Pro (Windows) 96

Comments on this document? infodev@avaya.com



mailto:infodev@avaya.com?subject=Deploying Avaya IP Office™ Platform Voicemail Pro (Windows)

Distributed voicemail servers

© Note:

In the distributed Voicemail Pro set up, ITZ functions similar to the centralized Voicemail Pro
set up.

Multiple distributed servers

Distribute d
YWoicemall Server

Centralized @
Voicemall Server

+ SMTF Server

P Office
(st purbed)

Central
|F Office

lidz e i Ao

Additional distributed Voicemail Pro servers can be added as required by the individual IP Office
sites in the Small Community Network.
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Sharing distributed voicemail servers

Distributed
Yoicemall Server

Centralized
Voicemail Server
+ SMTF Server

P Office
(¥ striterbed)

P Office
(Dlistribubed)

The same distributed Voicemail Pro server can be shared by several IP Office s. The services it
provided to each depends on the licenses that each has.

Summary of IP Office configuration settings for distributed

voicemail servers

IP Office settings

Central IP Office

Other IP Office s

IP Office with
distributed server

Voicemail type

Voicemail Pro

Centralized voicemail

Distributed voicemail

Voicemail IP address

Set to the central
Voicemail Pro server

computer's IP address.

Not used.

Set to the distributed
Voicemail Pro server

computer's IP address.

Voicemail destination

Not used.

Set to the Outgoing
Group ID of the H323
Line to the central IP
Office.

Set to the Outgoing
Group ID of the H323
Line to the central IP
Office.

Licenses

This system needs
licenses for Voicemail
Pro and all voicemail
features required.

The other IP Office s
only require licenses for
UMS and or for

ContactStore if required.

This system needs
licenses for Voicemail
Pro and all voicemail
features required.

Related links
Voicemail Pro licenses on page 10
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Combined options

Distributed voicemail server configuration

1. The centralized voicemail server for the SCN and its central IP Office are configured as
normal.

2. The Voicemail Pro server software is installed as normal any distributed voicemail server
computer. The distributed voicemail server is not specifically configured as being a
distributed server.

3. Each IP Office hosting a distributed voicemail server is configured with the Voicemail Type
set to Distributed Voicemail.

Swstern | LAMD | LANZ | DNS Woicemail Telephory | Direckory Services || System Events | SMTP || SMDR || Twinning | WCM CCR

Vaicemal Type Distributed Yoicemail w Messages Button Goes To Yisual Yoice
voicemall Destination 10 w
Yoicemall IP Address 192 . 168 42 212

Backup Yoicemail IP Address

» The Voicemail Destination is set the Outgoing Group ID of the H323 trunk to the
central IP Office hosting the centralized voicemail server.

» The Voicemail IP Address is set to the IP address of the computer running the
distributed voicemail server for the IP Office.

© Note:

If you are using Voicemail Pro in a distributed environment, a distributed server delivers a
recorded message to the central Voicemail Pro server on completion of the recording.
However, the presentation to the Voicemail Pro server for message waiting indication (MWI1)
and access via telephone might be delayed because of the internal processing of the
message and the network latency. The delay might be up to 2 minutes in high traffic situations.

Combined options

The various centralized voicemail options (standard, fallback, backup and distributed) can be used
within the same Small Community Network.
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Distributed
Yoicemail Server
+ SMTF Server

Backup
Voicemail |a
Server

Centralized
Yoicemall Server
+ SMTF Server

|F Office
(istrifuted )

Central
[P Office

linicenr i P

» An IP Office using a distributed voicemail cannot be used as the fallback IP Office for the
central IP Office.

+ A distributed Voicemail Pro server cannot also be used as the backup Voicemail Pro server.

Example: Combined fallback control and backup server operation

In this example, the fallback IP Office control and backup voicemail server operation are
combined.

Central IP Office unavailable

Central Voicemail server controlled by fallback IP Office

Backup
Yoicemail | Fallback
Centralized Server | .
Yoicemail o - fon:e
Server S
ﬁ\-..
.
DS ¢ osen S
o
S
P Office
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Combined options

If the central IP Office becomes unavailable on the network, the fallback IP Office takes over
control of voicemail services using the centralized Voicemail Pro server.

Central voicemail unavailable
Backup Voicemail Pro server controlled by central IP Office

Backup

Yaoicemail ;;:
SEerver

[P Cffice

nicem 2 Aol

IF Ciffice

[Cantalized)

If the central Voicemail Pro server becomes unavailable on the network, the central IP Office
switches to using the backup Voicemail Pro server.

Central IP Office and central Voicemail Pro server unavailable
Combined backup Voicemail Pro server and fallback IP Office operation

Backup
Wolcemail |
oy
Server ‘?:,
=
- .
» Sy
N I < T
|
P Office
(Camtralized)
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If both the central IP Office and the central Voicemail Pro server become unavailable to the
network, voicemail services will switch to the backup Voicemail Pro server under control of the
fallback IP Office.

Installation notes

Configuring SMTP
About this task

Both the distributed voicemail and backup voicemail scenarios use the same mechanism for the
information exchange between the servers. That mechanism uses the SMTP SSL/TLS
communication between the Voicemail Pro servers. If the servers fail to connect using SSL/TLS
over SMTP, then plain text communication is used. Note that this means that a server with
Microsoft Exchange installed (such as an SBS server) cannot be used because Exchange
replaces the SMTP service.

The following procedure applies to both scenarios unless specifically stated as otherwise.
Procedure
1. Install and enable IIS.

All the Voicemail Pro servers (central, distributed and backup) require IS to be installed
and enabled on the server before installation of the Voicemail Pro server software.

Start the Internet Information Services manager.
Right-click on Default SMTP Virtual Server and select Properties.
Select the Messages tab.

a o oo

Deselect the Limit Message Size and Limit number of messages per connection
options.

2. Configure each Voicemail Pro server for SMTP e-mail via IIS.
Following installation of the Voicemail Pro server software, it should be configured for

SMTP e-mail operation. By default, the Voicemail Pro server installs defaulted to SMTP e-
mail operation. However this should be checked.

a. Start the Voicemail Pro Client.

b. Click ';'}rJ Preferences and select General.

c. Click the Email tab.
d. Verify that the MAPI settings are not enabled.
e. Select the SMTP Sender sub tab.

The first entry in the list must be configured for SMTP between the Voicemail Pro
servers.
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f. Set the Domain and Server to the fully qualified domain name of the Voicemail Pro
server.

For a Windows-based Voicemail Pro server, these e-mails are received on port 25 by
IIS and are placed in its mail drop folder.

System Preferences f'5_<|

General Direu:tu:-ries| Ernail |Hnusekeeping SHMP Alarm || Outcalling

MaPl | SMTP Sender | SMTP Receiver

g 2 X [ Losgig 42 ¥

Dramain Server Part Mo | dentifier Atk
wvmprol.exa..  vmprol.edample.c.. 25 vmpro@ymprol.example.cam None
example.com  smtp.example.com 25 Mone
wahioo, com gmtp.yahoo. com 25 Mone
< )

[ ] l [ Cancel ] [ Help

g. To obtain the name, right-click My Computer and select Properties.

The Computer Name tab shows the information that should be used as Full
computer name. The name must be used. IP addresses are not used.
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System Properties

System Restore Automatic: Updates Remaote

eneral Computer Mame Hardware Advanced

Q Windowes uzes the following information to identify your computer
an the retwork.

Computer description; ||

For example; "= Production Server"” ar
"Accounting Server.

Full computer name: vimprol example.com

Dramair: Example com

h. Select the SMTP Receiver sub tab.
x

General I Directories  Email | Housekeeping I SNMP Alam I Outealing I
'MAPI | SMTP Sender SMTP Receiver |

SMTP Receiver | Intemal =l
Port |25
Domain I\rrnpro1 example.com

[ ok | conca | Hep |

i. Setthe SMTP Receiver as External and set the Drop Folder address to be the IIS
mail drop folder (usually C:\Inetpub\mailroot\Drop).

j- Click OK.

3. Click ﬁ Save & Make Live.

4. Verify that Port 25 is not blocked.

Many firewalls block access to port 25 by default. Check that the firewall software on the
server is configured to include VMProv5Svc.exe as an exception.
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5. (Optional) Set DNS host routing by locating the C: \Windows\System32\drivers\etc
\hosts file and open it in a text editor such as WordPad.

SMTP operation uses fully qualified domain names that need to be resolved to IP
addresses by the network's DNS server. For name resolution, the hosts files on each
server can be used. Note however that if this method is used, any changes to IP
addresses of servers needs to be reflected in the file update.

6. Add IP address and fully qualified domain name entries for each of the other Voicemail
Pro servers.

Voicemail Pro Configuration

In all scenarios, each Voicemail Pro server should use the same basic configuration settings. For
example, the same voicemail mode (Intuity or IP Office) and the same housekeeping settings.

IP Office configuration

Centralized voicemail server operation configuration

The centralized Voicemail Pro server for the SCN and its central IP Office are configured as
normal.

Each IP Office not hosting a distributed Voicemail Pro server is configured with the Voicemail
Type set to Centralized Voicemail.

Swskem || LAML | LANZ || DNS Yoicemail Telephory | Directory Services | Syskem Events || SMTP | SMDR. || Twinning || WCM iR

Yoicemail Tvpe Centralized Y oicemail w Messages Button Goes To Visual Yaice
Yoicemail Destination 10 w

Yoicemail IP Address

Backup Woicemail IP Address

The Voicemail Destination is set the Outgoing Group ID of the H323 trunk to the central IP
Office hosting the centralized Voicemail Pro server.

Distributed voicemail server operation configuration

1. The centralized voicemail server for the SCN and its central IP Office are configured as
normal.

2. The Voicemail Pro server software is installed as normal any distributed voicemail server
computer. The distributed voicemail server is not specifically configured as being a
distributed server.

3. Each IP Office hosting a distributed voicemail server is configured with the Voicemail Type
set to Distributed Voicemail.
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Swstern | LAMD | LANZ | DNS Woicemail Telephory | Direckory Services || System Events | SMTP || SMDR || Twinning | WCM CCR

Vaicemal Type Distributed Yoicemail w Messages Button Goes To Yisual Yoice
voicemall Destination 10 w
Yoicemall IP Address 192 . 168 42 212

Backup Yoicemail IP Address

» The Voicemail Destination is set the Outgoing Group ID of the H323 trunk to the
central IP Office hosting the centralized voicemail server.

» The Voicemail IP Address is set to the IP address of the computer running the
distributed voicemail server for the IP Office.

Backup server operation configuration

1. The Voicemail Pro server software is installed as normal on the backup server computer.
The voicemail server is not specifically configured as being a backup server.

2. The central IP Office hosting the primary voicemail server is configured with the IP
addresses of both the primary voicemail server and the backup voicemail server.

System | LAML | LANZ || DNS Yaicemai Telephony | Direckory Services || System Events | SMTP || SMDR. | Twinning | <M CCR
Vaicemall Type Yoicemail Lite/Pro v Messages Button Goes To Visual Voice
Yoicemail Destination

Yoicemail IP Address 192 . 168 42 201

[ Backup Yoicemail IP Address | 192 . 156 42 211 ]

3. The other IP Office s are configured for centralized or distributed voicemail as normal.
Server connection tests

You can use the following tests to check the connection to the central server. Always use the fully-
qualified domain name of each server.

Ping test: Makes a ping from the server to the central server. For example, ping
vmmprol .example.com. You should see a series of four successful replies from the sever.

Telnet test: Makes a telnet test from the server to the central server. For example, telnet
vimprol .example.com 25.You should receive a response from the e-mail server within IIS.
Enter quit to close the telnet connection.

To check the connection from the central server, you can repeat the ping and telnet tests. This
time from the central server to the backup or distributed server.

Voicemail Pro client status

When connected to a Voicemail Pro server using the Voicemail Pro client, the client title bar
displays the role of that Voicemail Pro server; Centralized Voicemail, Backup Voicemail or
Distributed Voicemail.
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] ¥Yoicemail Pro Client  {Intuity)- Local

Installation notes

Fle  Edit Administration  Help

Hé&ld D@ 2 g

oo e

tj OOEQO7O2EF2F [192.168.42.1)
F P Moicemail Pro Administrators

lame |IPAddess | Version| Type | Last Activity | Resul

partnerzp kimister.com 192168.4210 G060 Distibuted 27/11/2009 09:44 Up-ToDate

I-i-l T2 Server Queues

ﬂ Distributed

When connected to the backup Voicemail Pro server, if it is the active server, the title changes
from Backup Voicemail to Backup Voicemail (Live).

When connected to the centralized Voicemail Pro server, the Distributed Voicemails folder can

be selected to display details of the distributed servers and the state of the connection with each.

The Result is either:
* In Progress — The servers are synchronizing information via SMTP.

* Up-To-Date — The servers are synchronized.

Deploying Avaya IP Office™ Platform Voicemail Pro (Windows)

Comments on this document? infodev@avaya.com

October 2018

107


mailto:infodev@avaya.com?subject=Deploying Avaya IP Office™ Platform Voicemail Pro (Windows)

Appendix A: SMTP logging

SMTP error logging is enabled to generate a log of SMTP activity.

For a Windows-based Voicemail Pro installation, the activity is logged in a file in C: \Program

Files\Avaya\IP Office\Voicemail Pro\VM\logs. The file name includes a date stamp for
the day on which it is generated.
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Appendix B: Verifying the host key of the

SFTP server

About this task

If you are trying to connect to a SFTP server for the first time, the connection may fail with an error
message about the authenticity of the host. The behavior is a feature of the SSH protocol and is
designed to protect you from a spoofing attack. To proceed, verify the host key of the SFTP server.

Procedure

1.

o M 0N

Log in to the computer that runs the Voicemail Pro service using the same Windows account
that is used to start the service.

Open the WinSCP application.

Click New.

Enter the required details in the Host name and User name fields.
Click Login.

A message is displayed that includes the host key of the SFTP server.

If you trust the displayed host key, click Yes to save the host key in the cache. Otherwise,
get the host key from your system administrator, and match it with the displayed host key
before you click Yes.

Enter the password to verify the connectivity to the remote SFTP server.
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Appendix C: Installing Voicemail Pro as an
ACM Gateway

About this task

Complete the steps in this section to install Voicemail Pro as an ACM Gateway. There is only one
type of installation for the Voicemail Pro ACM Gateway. Therefore, you are not offered the choice of
custom, compact or typical during the installation process.

Procedure
1. Insert the IP Office Applications DVD.
2. Click Voicemail Pro, and then double-click setup.exe.
The Choose Setup Language window opens.
3. Select the installation language.
This language is used for the installation and for the default language prompts.
4. Click OK.
Installation preparation begins.

5. Voicemail Pro requires Microsoft .NET 2.0 Framework. If this version is not detected, you are
prompted to install it. Click Yes to install Microsoft .NET 2.0 Framework and follow the
instructions on the screen.

6. If the Modify, repair or remove the program window displays, follow the upgrade process.
7. In the Welcome window, click Next.

8. In the Customer Information window, type a user name and the company name, or use the
default names that are proposed.

These settings do not affect Voicemail Pro when it is installed.

9. In the same window, choose the option that determines who should be able to use Voicemail
Pro when it has been installed.

If you prefer, choose the Anyone who uses this computer (all users) option.

10. In the Customer Information window, click Next.
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11. In the Choose Destination Location window, choose one of the following options:
* Click Browse and locate the folder where the Voicemail Pro files are to be installed.
* Click Next to use the proposed folder.
12. In the Messaging Components window, select ACM Gateway.
13. Click Next.
The Service Account Name window opens. Details of the default administrator account may
already be filled in.
14. Choose one of the following options:
» Type the User Name and Password for the user account under which the Voicemail Pro
service should run.
This should be the voicemail account created previously on the domain and Exchange
server.
* Click Browse and select from the list of available computer or network accounts.
* Click Next to use the proposed account details.
The Select Program Folder window opens.
15. By default, the program folders are created in a folder called IP Office. You can specify a
different folder or select one from the list of existing folders.
* To specify a different folder, type the folder name in the Program Folders box.
* To use an existing folder, highlight a name in the list of existing folders.
16. Click Next.
The account details that you entered are verified.
17. If you entered a user name that does not exist, the system prompts you to create a new
computer user account with the specified name and password. Click Yes.
The Select Program Folder window opens.
18. Select the program folder where you would like the icons for the Voicemail Pro components
to be added. By default, the program icons are added to IP Office.
19. Click Next.
The Start Copying Files window opens. Before any copying starts, you are presented with a
summary of the settings that you have chosen so far.
20. Review the settings to make sure that they are what you expect.
« If for any reason the details are not what you expect, click Back and make the required
changes.
* When you are satisfied that the details are correct, click Next to start copying the files.
The Setup Status window opens to keep you informed while the installation takes place.
21. When the installation is complete, you are prompted to restart the computer. Choose Yes |
want to restart my computer now.
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Installing Voicemail Pro as an ACM Gateway

22. Click Finish to restart the computer.
23. When the computer restarts, log back in.
The IP Office Voicemail Pro - ACM Gateway Settings window opens.
24. In the Mail Server box, type the name of the mail server to use.
25. Choose one of the following options.
* Message Networking/Interchange to use Interchange
* Modular Messaging to use Modular Messaging
26. Click Next.
The IP Office Voicemail Pro SMTP Email Settings window opens
27. In the Mail Server box, type the name of the SMTP mail server.
This should be the fully-qualified domain name.
28. In the Port Number box, type the number of the receiving port on the SMTP mail server.
The default is 25.

29. In the Mail Drop box, type the name of the destination folder for outgoing e-mails on the
SMTP Server

Alternatively, click the Browse button and select the folder to use.

30. (Optional) To enforce server authentication, check the Server Requires Authentication
box.

If you check this option, you also need to enter the account name and password. You can
also choose whether or not to set the Use Challenge Response Authentication option.

31. Click Finish.
The e-mail settings are validated.
32. You see one of the following results:

« If everything has been installed correctly and the license requirements are met, you are
prompted to start the Voicemail service.

* If the system fails to connect to the SMTP server, an error message displays. You might
need to start the Voicemail service manually.

33. Click OK to acknowledge the message.
Result
You have now finished installing the Voicemail Pro ACM Gateway software.
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Glossary

Centralized Voicemail
Pro Server

Distributed Voicemail
Pro Server

MAPI

Simple Network Time
Protocol (SNTP)

Voice Recording
Library (VRL)

Voicemail Private
Networked
Messaging (VPNM)

October 2018

Centralized Voicemail Pro uses a single Voicemail Pro server to provide
voicemail services for all IP Office s in the Small Community Network.
Except for use of ContactStore, only the central IP Office hosting the
Voicemail Pro server requires licensing for Voicemail Pro operation and
features.

For IP Office Release 6.0 and higher, remote IP Office s in the Small
Community Network can be associated with another Voicemail Pro server
in addition to the centralized Voicemail Pro server. The additional
distributed server then provides all voicemail services (except message
storage and collection) for that IP Office. This requires the remote IP
Office to have licenses for voicemail operation and the features it
requires.

Message Application Programming Interface (MAPI) is a Microsoft
Windows system architecture that supports adding messaging
functionality into applications. MAPI-enabled e-mail applications can
share e-mails and also work together to distribute the mail.

Simple Network Time Protocol (SNTP) is an Internet standard protocol
(built on top of TCP/IP) that provides accurate synchronization to the
millisecond of computer clock times in a network of computers. It
synchronizes all the IP Office s in an SCN configuration.

Using the Voice Recording Library (VRL) operation, Voicemail Pro can
transfer specific users' automatic and/or manually recorded calls to a
third-party application. Users can select VRL as the destination for calls
recorded via a Leave Mail action in a call flow.

Currently, this mode of operation is only supported with the Contact Store
for IP Office application from Witness Systems. This application provides
tools to sort, search and playback recordings. It also supports the
archiving of recordings to DVD.

Voicemail Private Networked Messaging (VPNM) is a set of preferences
available only if you have selected VPNM during installation and is
licensed within the IP Office configuration. It is used to add a list of the
remote VPNM servers and mailbox users on those servers.
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