Web traffic optimization
If you are using the CNA system to optimize your Web site traffic, your network should meet the following requirements:
- Multi-homed connectivity to the Internet (at least two service providers)
- Full BGP feed from at least one of your service providers
- DNS implementation that provides the following:
- address rotation (ability to round-robin destination addresses in reply to successive requests)
- high availability, in which the DNS server conducts health checks and won’t return a destination if the target server is not in operation (GSLB--global server load balancer--is strongly recommended, though some form of direct-server return is a viable alternative. For information on getting packets through firewalls, see Active Measurement VIPs in Chapter 4: Server-Based Measurement of the CNA Basic Monitoring Guide. For information on preventing health checks from skewing traffic measurements, see Chapter 6: Decision Policies and Application Models in the CNA Basic Monitoring Guide.
- If Network Address Translation (NAT, as defined in RFC 2663) is in place between the CNA system and your service providers, you must ensure that remote-side responses to CNA measurement-traffic packets arrive at the USTAT’s VIP with original, or natural, addressing intact
- Edge routers must support BGP4 (as defined in RFC 1771 and RFC 1657) and Policy Based Routing (PBR)
|
|