Avaya Support Forums

Avaya Support Forums (http://support.avaya.com/forums/index.php)
-   Avaya Breeze™ Collaboratory (http://support.avaya.com/forums/forumdisplay.php?f=77)
-   -   ContextStore collaboratory sdk url (http://support.avaya.com/forums/showthread.php?t=12065)

dbrund 10-12-2016 06:58 AM

ContextStore collaboratory sdk url
 
We are trying to connect to the ContextStore sdk in the collaboratory using a Java snapin. From the example in the ContextStore sdk, we need to call ContextStoreServiceFactory.getContextStoreWebServi ce("url"). We have tried using the FQDN and the IP address for the Breeze server that hosts our ContextStore (we are able to hit it with Postman and to connect to it using Engagement Designer) and we have tried 127.0.0.1 (not expecting it to work).

So, do we need to deploy something else to our collaboratory in order for the endpoint to be seen or is there a specific URL that we should be hitting?

lucas3 10-13-2016 01:03 PM

Hi dbrund,
What is your CE lab number?

dbrund 10-14-2016 08:30 AM

Our lab number is 105.

lucas3 10-17-2016 09:00 AM

You would need to use the SIP/HTTP external IP of the Breeze1 server, where csrest and csmanager are installed.

http://135.169.17.45/services/CSRest/cs/contexts/

dbrund 10-17-2016 02:15 PM

I tried http://135.169.17.45/services/CSRest/cs/contexts/ without success (works very well with Postman).

What I am trying to do is use the Context Store sdk following the example shown at: Avaya-CS-SDK\ContextStore-2.65\CS SDK\CS SDK API\examples\ExampleSDKClient.java. In that they set contextStore = ContextStoreServiceFactory.getContextStoreWebServi ce(HOST); where HOST is defined as 127.0.0.1 (my mistake to put URL in the original post instead of HOST). Following that code, I never hit the Exception in the try/catch block. I added a finally block, which I hit but contextStore is always null.

joele 10-18-2016 11:58 AM

I'm sorry, if this is a stupid question, but have you changed HOST from 127.0.0.1 to 135.169.17.45?

dbrund 10-19-2016 07:57 AM

Yes. I have tried the following:

contextStore = ContextStoreServiceFactory.getContextStoreWebServi ce("135.169.17.45");
contextStore = ContextStoreServiceFactory.getContextStoreWebServi ce("breeze1-105.collaboratory.avaya.com");
contextStore = ContextStoreServiceFactory.getContextStoreWebServi ce("http://135.169.17.45/services/CSRest/cs/contexts/");
contextStore = ContextStoreServiceFactory.getContextStoreWebServi ce("127.0.0.1");

The code is in an init() method in the myCallListener class created by the Avaya archeytype. The code currently looks like:

Code:

        public void init() {
                logger.info("Entered call listener...");
        try {
                    logger.info("setting contextstore service...");
                        contextStore = ContextStoreServiceFactory.getContextStoreWebService("135.169.17.45");
                        logger.info("context store service set...");
                }
        catch (Exception e) {
                logger.info("caught exception: " + e.getMessage());
        }
        finally {
                logger.info("In finally block");
                if (contextStore == null){
                        logger.info("contextStore is null");
                }
                else {
                        logger.info("contextStore is not null");
                        logger.info(contextStore.toString());
                }
        }

When I deploy the service and look at the log file, the statements in red are shown.

sdervan 10-19-2016 12:04 PM

1 Attachment(s)
Hi Dennis,


To access any services on Breeze clusters, the security module IP address of the Breeze node must be used. This IP is labelled "SIP Entity IP address" in Server Administration page of Breeze Element Manager, i.e. 135.169.17.45 for this Collaboratory.

In a multi-node cluster, there's a cluster IP which should be used instead.


I've compiled the sample client code provided in the CS Java SDK zip file on DevConnect and have verified that it can successfully access and submit requests to this Collaboratory cluster at IP 135.169.17.45.

Advised on our call yesterday, I've executed these tests in unsecured mode (there's a handy checkbox in our test client to disable this).

I used Maven to build the sample client - I've attached the POM file I used to build the sample client (had to add .txt extension as .xml is not permitted)


Regards,
Siobhán

lucas3 10-26-2016 10:05 AM

Dennis,

Were you able to get this to work following Siobhan's instructions?

sdervan 11-01-2016 05:12 AM

Futher advice provided via email
 
Hi Michelle,

Dennis contacted the CS team directly over email as he was blocked by the security configuration of his application using the SDK.

I highlighted the lines in provided sample client code which illustrate how to disable the HTTPS security requirement to get his application working over HTTP initially (i.e. set the system property cs.sdk.http to "yes").

I have not received explicit confirmation from Dennis that he has been able to progress further with his application but have not received any other queries either.

Regards,
Siobhán


All times are GMT -7. The time now is 06:57 PM.