Avaya Support Forums

Avaya Support Forums (http://support.avaya.com/forums/index.php)
-   Avaya Breeze™ Collaboratory (http://support.avaya.com/forums/forumdisplay.php?f=77)
-   -   Dynamic Task Types in Engagement Designer (http://support.avaya.com/forums/showthread.php?t=10858)

davis626 01-12-2016 09:21 AM

Dynamic Task Types in Engagement Designer
Where can I find documentation for creation of Dynamic Task Types in Engagement Designer?

mmontgom 01-13-2016 02:36 PM

Reference this link for Dynamic Task ED documents

davis626 01-14-2016 09:55 AM

Online search does not provide specifics regarding missing SDK elements for archetype
Obviously I had already searched the Avaya Support site. The issue is that the SDK for EDP 3.1 does not include the archetype for tasks. So doing a Maven build for anything other than a service isn't included that I can see.

I need the cba-maven-plugin which should include the jar necessary to include the com.avaya:avaya-archetype (Tasks).

mmontgom 01-14-2016 04:01 PM

Dynamic Task Types in Engagement Designer
Found out that that document is being complied. In the meantime is it possible for you to send me your contact information so that we can setup a session to get your issue resolved with our EDP group tomorrow?

vjheath 01-14-2016 08:13 PM

OSGi dynamic tasks document
1 Attachment(s)
There is a formal version of the requested document under development, but this document should prove useful in the interim.

mmontgom 01-15-2016 05:07 AM

OSGi dynamic tasks document
Great!! I will let you know once the completed document from Avaya is ready, Will try and get a ETA.

ander548 09-13-2016 10:32 AM

I installed the Avaya Breeze SDK, elcipse, etc back in January 2016, and I'm trying to create scaffolding for a dynamic task, but it doesn't seem like I have the correct archetype loaded? Are there instructions somewhere on what I need to update to be able to create dynamic tasks?

This link below is what I'm working with and it says to run this command (mvn archetype:generate -DarchetypeCatalog=local) and select "(Engagement Designer Task Archetype)" which I don't see as an option?



aanurag 09-14-2016 06:43 AM

Did you install ED sdk ? That would provide the archetype

eliaidam 09-14-2016 06:56 AM

Instructions for installing Engagement Designer SDK are in the document you referenced, pages 8-9.

ander548 09-15-2016 03:30 AM

Yeah, I installed everything earlier this year and it all works, but wasn't sure which part I needed to update to get the task archetype. I'll reinstall ED SDK and hopefully that will update me to have a dynamic task option. Thanks!

ander548 09-19-2016 12:25 PM

1 Attachment(s)
I got the correct archetypes loaded and now I can successfully create the scaffolding for a dynamic task, but I get several warnings and errors when I try to build. Attached is the command line output of me creating the scaffolding, changing to the directory of the mytask it created and running "mvn clean package". One weird error is this:

[ERROR] error reading C:\Users\canderson\.m2\repository\com\avaya\collab oration\
pi-3.1.1-; error in opening zip file

This file exists in this path with ".lastupdated" at the end, and it doesn't appear to be a real jar. It's contents are just this text:

#NOTE: This is an Aether internal implementation file, its format can be changed without prior notice.
#Mon Sep 19 08:41:30 EDT 2016

agrace 09-23-2016 07:19 AM

I just ran into this issue also. I solved it by installing the previous release of the Breeze SDK. (the 3.1.1 version, NOT the There are some version mismatches when using the latest versions of each SDK.

That said, it builds, installs, and allows me to run it in a workflow but seems to have some issues still. I can't get it to log anything and it breaks when I try to play VXML

ander548 09-25-2016 08:33 AM

Thanks SO much for that tip! I've been beating my head against a wall for a week, and once I installed 3.1.1 it worked!! I was able to build a skeleton dynamic task and get it to show up in ED as a snap-in in my drawer. Thanks again!

agrace 09-26-2016 07:25 AM

Now I just need to figure out why my task stalls the workflow when I do anything more than return

ander548 09-26-2016 12:26 PM

I haven't gotten that far yet :) Do you happen to know the process for getting your dynamic task to show up in the EDP toolbar? I installed my svar and had it showing up in my drawer on the toolbar, but then deleted the old one and re-loaded a new svar and now I can't get it to show up. I saw somewhere it said to reboot the cluster, so I tried that and now a bunch of the standard drawers are missing! What controls what shows up in the toolbar? Also, any idea on how you can test the dynamic task without loading it into a workflow? I tried the Admin Console URL to create an instance of it, but it doesn't show up there. Thanks, and if I get that far I'll let you know if mine stalls the workflow!

agrace 09-26-2016 01:47 PM

Make sure that you have all of the following in your tasks.json file (specifically the mapping and properties) It seems like if this file doesn't follow the schema, Engagement Designer kinda just craps out.

Also, there is some significant lag between installing a version of a snap-in and the changes being reflected in the workflow editor. Rebooting the cluster seems to force the change to take but I've had better luck with just going for a short walk around the office and coming back.

"name": "Sample",
"name": "Hello",
"snapinVersion": "3.0",
"displayName": "Hello",
"tag": "hello",
"svg": "hello",
"helpUrl": "hello.html",
"tile": "blue",
"serviceName": "CollabDesigner",
"custom": "true",
"nodeType": "activity",
"modelClass": "com.test.breeze.tasktype2.HelloModel",
"executionClass": "com.tes.breeze.tasktype2.HelloExecution",
"mapping": "[\"input\", \"output\"]",
"properties": [
"input_schema": "{
title: InputSchema,
type: object,
properties: {
ucid_var: {
type: string

"output_schema": "{
title: OutputSchema,
type: object,
properties: {
title: {
type: string

I'm really interested in seeing if you run into the same issue that I do...

ander548 09-26-2016 03:15 PM

I used a pretty basic tasks.json like you have when it eventually showed up in the editor (I tried all kinds of things and it just finally showed up so probably wasn't anything I did). But, now I've added some things to the schema and it builds and loads fine, but maybe that's why it won't show up now. Any idea where you'd find out what's wrong with it? I did notice that their basic json doesn't have quotes around things like type: string, but in my editor it liked things like this: "type": "string". I'll maybe check the logs to see if anything doesn't like that, but weird that it just wouldn't show up at all. I deleted it and am reloading just to make sure and I'll give it more time and see...

agrace 09-26-2016 03:22 PM

yeah, the schema parts "json" isn't actually json because the properties aren't quoted themselves. Probably because it would be a pain to escape all of the quotes in the already quoted schema.

That might be your issue

ander548 09-26-2016 05:11 PM

Yeah, I'm trying to test that now, so we'll see. Any idea how you can test the task directly somehow? It would be nice if it showed up with the workflows that you can create an instance of directly to test.

ander548 09-26-2016 07:20 PM

Thanks again! That was why my snap-in wasn't showing up in the toolbar (I assume). I removed the quotes in the fake json and that works. Is yours freezing the workflow in debug? Mine simply takes an input value, adds a string to it and outputs it, just to test the basics and it seems to work fine in debug mode.

ander548 09-27-2016 06:54 AM

I got my basic task loaded and showing up now, and if I just return a text output it seems to run fine, but I added a simple http post and although it builds, when I try to use it in a workflow I get an error. I posted it in a new thread with an image of the error and asking for details on how to debug these dynamic tasks.


All times are GMT -7. The time now is 04:55 AM.