Avaya Support Forums

Avaya Support Forums (http://support.avaya.com/forums/index.php)
-   Avaya Breeze™ Collaboratory (http://support.avaya.com/forums/forumdisplay.php?f=77)
-   -   Dynamic Task with HTTP post missing dependencies (http://support.avaya.com/forums/showthread.php?t=12087)

ander548 10-17-2016 12:29 PM

Dynamic Task with HTTP post missing dependencies
 
I have created the scaffolding for a dynamic task with a single added input/output value and it seems to work fine when I install it in ED and test it in a workflow. But, when I try to add the following code below, it installs but I get workflow errors that seem to be pointing to ClassNotFound type errors in the EngagementDesigner.log. My guess is that I'm either using the wrong objects to do an HTTP POST with Breeze, or missing some dependencies. Does anyone have an example of some code to do an HTTP POST in Breeze with the necessary Maven dependencies? Here is what I have. Note that this builds with "mvn clean package" fine and the svar loads/installs in ED, but I get an error when I use it in a workflow. The EngagementDesigner logs (with this code) are saying ClassNotFoundException for org.apache.http.ssl.SSLContext.

NOTE: My project zip file is too large to upload here, but I have uploaded to a post on the devconnect forum here:

http://www.devconnectprogram.com/for...ist/20155.page

Code in my execute method of HelloExecution.java with simple HTTP POST to a test url (Open to a more Breeze-friendly code sample):

CloseableHttpClient httpclient = HttpClients.createDefault();
HttpPost httpPost = new HttpPost("http://testurl.com");
CloseableHttpResponse response2 = httpclient.execute(httpPost);
response2.close();

imports added to top of HelloExecution.java:

import org.apache.http.client.methods.CloseableHttpRespon se;
import org.apache.http.client.methods.HttpPost;
import org.apache.http.impl.client.CloseableHttpClient;
import org.apache.http.impl.client.HttpClients;
import org.apache.http.HttpRequest;

dependencies added to my pom.xml:

<dependency>
<groupId>org.apache.commons</groupId>
<artifactId>commons-configuration2</artifactId>
<version>2.1</version>
<scope>compile</scope>
</dependency>
<dependency>
<groupId>org.apache.httpcomponents</groupId>
<artifactId>httpclient</artifactId>
<version>4.5.2</version>
<type>jar</type>
<scope>compile</scope>
</dependency>
<dependency>
<groupId>commons-logging</groupId>
<artifactId>commons-logging</artifactId>
<version>1.1.1</version>
<scope>compile</scope>
</dependency>

Import-Package setting in pom.xml (I keep adding classes to this each time I get ClassNotFound in the log and it fixes the one I added and gets another one. With this code, it is griping about org.apache.http.ssl.SSLContext, but if I add that to the Import-Package I get "Failed to Deploy" when I try to install the svar. So I'm not sure what's going on:

<Import-Package>org.apache.http.util,org.apache.http.proto col,org.apache.http,org.apache.http.config,org.apa che.http.client.methods,org.apache.http.impl.clien t.*,com.avaya.collaboration.util.logger,javax.pers istence,org.json,com.avaya.app.entity,com.avaya.wo rkflow.*,com.roobroo.*;!*</Import-Package>

mmontgom 10-18-2016 06:37 AM

Dynamic Task with HTTP post missing dependencies
 
Hello Carver,

We are looking into this issue. We get back with you shortly to give you some directions for resolving this issue. with HTTP post missing dependencies. ED 3.2 is not yet been released.

Mark M

mmontgom 10-23-2016 06:55 PM

Dynamic Task with HttP Post missing dependencies
 
Carver,

Design is creating a 3.2 GA load template to upgrade the labs.. looks like it will be early next week when we will be able to upgrade Mutare, to resolve dependency issues. Will update you next week to to let you know when lab is ready. Please backup any snapins.

mmontgom 10-31-2016 09:11 AM

HTTP : Dynamic Task issue with Collaboratory l
 
Carver if you are not using WCC/ECC, we can start the (manual) upgrade to 3.2 today (Monday) . This is, provided you are not using WCC/ECC, for now. We are currently working an issue related to WCC/ECC, we can later back port fix for WCC/ECC issue or you can wait unilt 3.2 template is completed.

ander548 10-31-2016 01:20 PM

We do not use WCC/ECC so I think we should be fine. Please let me know when it is upgraded (and which lab it is, since we have 2). Thanks!

ander548 11-01-2016 11:59 AM

Also, I have downloaded and installed the 3.2 SDK but what else do I need to do to get my project to build using 3.2? After installing the 3.2 SDK, do I just go back to my project directory and run "mvn clean package" like I've been doing? Or is there something else I need to do to get it built in 3.2? I've got 2 previous versions of SDK installed as well, and don't see any way to uninstall them. Thanks!

mmontgom 11-01-2016 01:35 PM

Dynamic Task with HTTP post missing dependencies
 
Design will be updating your lab. They will be updating lab 159. But will delete and rebuild it. You will need to remove data off the VMs before they delete it. Please let me know when this has been done to design can rebuild lab.

ander548 11-01-2016 01:36 PM

I don't have anything on the lab that I need, so update away. Thx

mmontgom 11-01-2016 01:37 PM

Dynamic Task with HTTP post missing dependencies
 
Once you can confirm when lab can be rebuild, Will let you know when you can access lab 159, once rebuild has been completed.

mmontgom 11-01-2016 01:39 PM

Dynamic Task with HTTP post missing dependencies
 
Tanks I will let you know when lab rebuild has been completed.


All times are GMT -7. The time now is 12:07 AM.