Avaya Support Forums

Avaya Support Forums (http://support.avaya.com/forums/index.php)
-   IP Office Contact Center (http://support.avaya.com/forums/forumdisplay.php?f=67)
-   -   Chat issue installing WebChatApp on Tomcat (http://support.avaya.com/forums/showthread.php?t=11356)

wdrew 04-26-2016 09:26 PM

Chat issue installing WebChatApp on Tomcat
I've installed an IPOCC system on an IP500V2 that is currently at R9.1.6. Voice is just fine. I've configured the CHAT per the Chat Services Guide with Openfire running on a separate xmpp server; using a guest account on Openfire we've tested the Chat configuration and task flow into the IPOCC and it's working just fine (just as we did in training). The web developer that works for the customer is having issues trying to get the WebChatApp working (from the examples folder on the distribution). There's a reference elsewhere in this forum of a step-by-step guide for a developer to use in configuring the Chat however it does not exist on the IPOCC ISO distribution for 9.1.x so if it's available elsewhere and someone knows where please let me know. :)

The 'help' text in the examples folder(s) is rather sparse and our thought is that we're missing something. The following is from the web developer and is more specific to the problem:

We're having issues getting the WebChatApp up and running. I've followed all the install instructions, modifying the properties file to match our config and placing the .war file and .properties files in the indicated directories.

Tomcat detects and installs WebChatApp but it won't start. When I try to manually start the app through Tomcat's web interface I get the following error messages in the Stderr file:

26-Apr-2016 09:07:07.899 SEVERE [http-apr-8080-exec-47] org.apache.catalina.core.StandardContext.startInte rnal One or more listeners failed to start. Full details will be found in the appropriate container log file

26-Apr-2016 09:07:07.899 SEVERE [http-apr-8080-exec-47] org.apache.catalina.core.StandardContext.startInte rnal Context [/WebChatApp] startup failed due to previous errors

26-Apr-2016 09:07:07.899 WARNING [http-apr-8080-exec-47] org.apache.catalina.loader.WebappClassLoaderBase.c learReferencesThreads The web application [WebChatApp] appears to have started a thread named [com.comergo.base.ttrace.client.link.appdriver.Comm andEmitter] but has failed to stop it. This is very likely to create a memory leak. Stack trace of thread:
java.lang.Object.wait(Native Method)
com.comergo.base.ttrace.client.link.util.MessageQu eue.getNext(Unknown Source)
com.comergo.base.ttrace.client.link.appdriver.Comm andEmitter.run(Unknown Source)

Here are the specs for our tomcat installation:

Tomcat Version: 8.0.33
Java version: 1.7.0_91-Avaya-b01

Any help on this issue would be greatly appreciated!

marquardt 04-27-2016 04:07 AM

Check WebChatApp.properties
Example: WebChatApp.properties


You can also use WebChatDialog

josep79 04-29-2016 07:18 AM

Still not working
1 Attachment(s)
I am the web developer working on this project.

I have confirmed that we have the correct lines in the WebChatApp.properties file, which I have attached. The app will not start at all in Tomcat. We get the same error messages in the log file that are listed in the first post.

marquardt 05-01-2016 10:58 PM

TopicID must not contain spaces
see description
# The listoftopicsthatcanbeconnected
# theformatofthelistiscommaseparated: <entry>,<entry>,......
# eonentryhastheformat <TopicID>:<JabberID> whereTopicID must not contain spaces

josep79 05-02-2016 11:36 AM

I changed the topic to:


The app does not start and I still get the same error messages in the log.

schopdekar 05-03-2016 03:02 AM

In TTConsole, under WebChat->WebChatDialog what messages are seen ?

Please clear up all messages, restart Tomcat WWW, and post the messages.

All times are GMT -7. The time now is 08:30 AM.