Avaya Support Forums

Avaya Support Forums (http://support.avaya.com/forums/index.php)
-   Contact Center Applications (http://support.avaya.com/forums/forumdisplay.php?f=3)
-   -   tomcat becomes non responsive (http://support.avaya.com/forums/showthread.php?t=11251)

mamb 04-05-2016 08:12 AM

tomcat becomes non responsive
 
Hello All,
we have below call sequence and facing an issue where the tomcat becomes non responsive at one point.

sequence:
1.OD-app calls LaunchCCXML(.) and MPP selects one of the free H323 port (always from ascending order) and dial to Agent VDN.
2.From Agent VDN call queue to Agent skill and routes to one of the free agent
3.After call get established OD-app plays the agent menu and agent hears full prompt and press some digits.
4.OD-app put the call on hold using CTI node
5.Then OD-app dial to customer using CTI node.
6.Sequence:
6.1.OD-app call the CTI dial node
6.2.Aes-connector.jar initiate the dial operation and wait in Mutex thread for events.
6.3.Before even receiving the alerting event the aes-connector receives disconnect event.
6.4.From aes-connector side it does the cleanup but the thread which is waiting in Mutex is not released for ever.
7.When this problem occurs slowly all the threads get blocked and at one point tomcat is unable to respond for new request until tomcat service restart.

Restart of tomcat services required.

1. Any inputs on how to identify who or from where the disconnect event is raised.?
2. This issue occurs randomly.

Thanks

nelr 05-03-2016 06:37 AM

Best bet is logs. Make sure that you apply proper logging in your applications.

PSI Probe (https://github.com/psi-probe/psi-probe) is also a good tool to install onto Tomcat that will give you better insight into the status of tomcat and current sessions.


All times are GMT -7. The time now is 06:24 PM.