Avaya Support Forums

Avaya Support Forums (http://support.avaya.com/forums/index.php)
-   Contact Center Applications (http://support.avaya.com/forums/forumdisplay.php?f=3)
-   -   CMS Supervisor R17 [line 7] (null) (http://support.avaya.com/forums/showthread.php?t=4452)

scottsealey 04-02-2014 01:01 PM

CMS Supervisor R17 [line 7] (null)
I recently upgraded to Windows 7 and am now using CMS Supervisor R17. The problem I am having is when I run any script, I get the error- (null) [Line 7] (null). I have deleted all my scripts and created them over, but I still get the same error every time. I used to run these same scripts on CMS Supervisor R16 on Window XP with no issues. Below is one of the scripts created with CMS R17 that I am troubleshooting with. I "XX" out the IP on this post for security reasons. Any assistance on resolving this issue is greatly appreciated.

Public Sub Main()

'## cvs_cmd_begin
'## ID = 2001
'## Description = "Report: Integrated: Split/Skill: Comparison Report: Export Data"
'## Parameters.Add "Report: Integrated: Split/Skill: Comparison Report: Export Data","_Desc"
'## Parameters.Add "Reports","_Catalog"
'## Parameters.Add "2","_Action"
'## Parameters.Add "1","_Quit"
'## Parameters.Add "Integrated\Split/Skill\Comparison Report","_Report"
'## Parameters.Add "1","_ACD"
'## Parameters.Add "270","_Top"
'## Parameters.Add "0","_Left"
'## Parameters.Add "9555","_Width"
'## Parameters.Add "11655","_Height"
'## Parameters.Add "The report Integrated\Split/Skill\Comparison Report was not found on ACD 1.","_ReportNotFound"
'## Parameters.Add "*","_BeginProperties"
'## Parameters.Add "12;13;418;419;410;411;57;58;424;425;414;415;210;2 11;161;162;422;423;308;309;86;87;416;417;412;413;4 26;427;420;421;279","Splits/Skills"
'## Parameters.Add "*","_EndProperties"
'## Parameters.Add "*","_BeginViews"
'## Parameters.Add "G1,0,0;0,2,0","data"
'## Parameters.Add "*","_EndViews"
'## Parameters.Add "C:\ACD Reports\ACD1daily-afterhours.xls","_Output"
'## Parameters.Add "9","_FldSep"
'## Parameters.Add "0","_TextDelim"
'## Parameters.Add "True","_NullToZero"
'## Parameters.Add "False","_Labels"
'## Parameters.Add "False","_DurSecs"

On Error Resume Next

cvsSrv.Reports.ACD = 1
Set Info = cvsSrv.Reports.Reports("Integrated\Split/Skill\Comparison Report")

If Info Is Nothing Then
If cvsSrv.Interactive Then
MsgBox "The report Integrated\Split/Skill\Comparison Report was not found on ACD 1.", vbCritical Or vbOKOnly, "Avaya CMS Supervisor"
Set Log = CreateObject("ACSERR.cvsLog")
Log.AutoLogWrite "The report Integrated\Split/Skill\Comparison Report was not found on ACD 1."
Set Log = Nothing
End If

b = cvsSrv.Reports.CreateReport(Info,Rep)
If b Then

Rep.Window.Top = 270
Rep.Window.Left = 0
Rep.Window.Width = 9555
Rep.Window.Height = 11655

Rep.SetProperty "Splits/Skills","12;13;418;419;410;411;57;58;424;425;414;4 15;210;211;161;162;422;423;308;309;86;87;416;417;4 12;413;426;427;420;421;279"

Rep.ReportView.Add "G1,0,0;0,2,0","data"

b = Rep.ExportData("C:\Users\ssealey\Documents\Region 6\ACD Reports\ACD1daily-afterhours.xls", 9, 0, True, False, False)


If Not cvsSrv.Interactive Then cvsSrv.ActiveTasks.Remove Rep.TaskID
Set Rep = Nothing
End If

End If
Set Info = Nothing
'## cvs_cmd_end

End Sub

shaikht 04-02-2014 11:14 PM


Line 7 null error was known issue for r17LA8.

Are you using same supervsior or latest one ie LA18.

scottsealey 04-03-2014 05:48 AM

The file I installed with is SetupSup_LA18.exe.

shaikht 04-03-2014 10:54 PM

Thanks for the reply.

LA.18 do not have any issues and script works well on the version.

Try to have a simple script and test if that is working fine. If it also fails, try with reinstallation of supervisor.

I hope it helps.

scottsealey 04-04-2014 05:22 AM

I am running this same version on two different Windows 7 computers. Both give the same error with whatever script I run. The CMS server version I am using is R16.3. Might that have something to do with the error?

shaikht 04-04-2014 05:57 AM

Nothing to do from server side. Have you tried with a short script, may be just print the report.

scottsealey 04-04-2014 06:54 AM

I'm sorry, I'm afraid I'm not familiar with creating scripts other than through the Edit/Export All Data.. option. There is an option to save a script in the Report option, but I don't see anything on how to make the script print.

scottsealey 04-04-2014 06:58 AM

I can print directly from a report if that is what you meant.:o

shaikht 04-07-2014 01:51 AM


Thats correct. I was looking to have script to just collect data in file using edit/export all data.

If that is working fine, script need to be looked upon.

shaikht 04-07-2014 01:55 AM

Another thing can be done to isolate the issue. As you informed that it was working fine on XP/supervisor 16, try to have r16 supervisor on windows 7. If still it do not worked, something need to do on windows 7 for the script.

scottsealey 04-08-2014 09:06 AM

Okay, I will try and get the previous version installed and give it a try. I will post back soon.

scottsealey 04-08-2014 10:38 AM

I tried Setup_KD22.exe and it does the same thing. I will look into Windows 7 and reply if I find a resolution for your reference. Thanks for the help!

acsit 05-08-2014 11:00 AM

I have a user that is having the same problem. We went from R14 to R17 and started having issues. I did learn there is an issue with trying to schedule the script using windows scheduler in Windows 7 and we had to resort to a 3rd party app to do that. The user is also getting Line 7 errors but it doesn't happen every day.

kharv 01-23-2015 02:25 AM

I am also facing the same issue .

Windows : 7
supervisor : R17
CMS server : 16.1

Error : connection specified to the CMS server was dropped

I can access the server using the SSH 22 .

I suspect something to do with windows telnet setting .

Need suggestion

gem 02-04-2015 07:33 PM

del file CVS_Cache.tmp. and try again
C:\Users\xxx\AppData\Roaming\Avaya\CMS Supervisor RxxCache\

All times are GMT -7. The time now is 09:59 AM.