Avaya Support Forums

Avaya Support Forums (http://support.avaya.com/forums/index.php)
-   IP Office Contact Center (http://support.avaya.com/forums/forumdisplay.php?f=67)
-   -   IPOCC switching OFF Agent's telephony (http://support.avaya.com/forums/showthread.php?t=11749)

jtarjanyi 07-05-2016 05:15 AM

IPOCC switching OFF Agent's telephony
 
Hello,

Is anybody face the following issue?

In a new installation of IPOCC (9.1.7) the customer want to use one-x communicator for Agnet. Because of the Power user license are not concurent, I create IPO users for the workplace, so it have different extension number from the Agent.

After the installation I have import all Agent with their skills, Topics, etc.
I have 40 Agent license, however have 65 Agent, but is cuncurent so I think it is not a problem. To make softphone as choosable extension from IPOCC client I have added softphones extension to IPOCC telephone settings.

Later I recognized the IPOCC start switching OFF Agents telephony settings, and with the syncronization of IPOCC-IPO it delete Agnets from IPO.

Anybody have idea why this happaned ???

lebon 07-05-2016 07:44 AM

you create a "user profil" and apply to the "Agent"
Utilisateur\Telephony\Supervisor
Agent IPOCC => Agent

After IPOCC synchronyse only the "name"

jtarjanyi 07-05-2016 11:22 AM

Quote:

Originally Posted by lebon (Post 27687)
you create a "user profil" and apply to the "Agent"
Utilisateur\Telephony\Supervisor
Agent IPOCC => Agent

After IPOCC synchronyse only the "name"

Sorry I cannot catch you. Yes I have apply profile on agent. Those control agnets belongs to which AgentGroup, and who has supervisor priviliges. It works fine in a previous installation.

jtarjanyi 07-05-2016 03:27 PM

Ahh Ok, I catch it.
All Agent in IPO is set up as AGENT, but IPOCC still deleting :(

jtarjanyi 07-05-2016 03:28 PM

Quote:

Originally Posted by lebon (Post 27687)
you create a "user profil" and apply to the "Agent"
Utilisateur\Telephony\Supervisor
Agent IPOCC => Agent

After IPOCC synchronyse only the "name"

Ahh Ok, I catch it.
All Agent in IPO is set up as Agent IPOCC => Agent, but IPOCC still deleting :(

In the IPOSyncService log I saw lots of java error like this:

B9396a 01:19:50.345 TC_Error Exception occurred during authentication:java.lang.Exception: connect timed out
B9399a 01:19:51.054 TC_Error Exception occurred while getting user: java.lang.NullPointerException
B9400a 01:19:51.054 TC_General User added is not of type IPOCC Agent. Hence ignoring

Little bit later:

B9748a 01:21:35.906 TC_General User is present in IPOCC DPamfileHence deleting
B9755a 01:21:40.644 TC_General Deleting Agent Adolhan
B9847a 01:21:40.696 TC_General Agent Adolhan telephony deleted in IPOCC having guid 78AF8400482911DF994C204747987F5A
B9895a 01:21:40.779 TC_General Telephone removed successfully for agent Adolhan having guid 78AF8400482911DF994C204747987F5A
B9896a 01:21:40.808 TC_General Updating cache after deleting agent Adolhan
B9897a 01:21:40.809 TC_General deleting name from guid map after deleting agent Adolhan
B9898a 01:21:40.809 TC_General Deleting Agent BNitu
B9988a 01:21:41.015 TC_General Agent BNitu telephony deleted in IPOCC having guid 8B29A080482911DF997E204747987F5A
C0038a 01:21:41.058 TC_General Telephone removed successfully for agent BNitu having guid 8B29A080482911DF997E204747987F5A

schopdekar 07-06-2016 12:12 AM

Sync service will delete if Telephony is removed from IPOCC.
Can you please check the profile. Whether it has telephony enabled ?

Agents on IPOCC and similar named User on IPO will be synchronized.

jtarjanyi 07-06-2016 01:05 AM

Im have generate the initial configuration with the Excel-macro, and yes, the profile wich assigned to the agent contains telephony. After the restart all agent has telephony. If wainting some time (4-5 mins) I saw those exepsion on TTLogs, and IPOCC start removing it. I don't know what should I check.

schopdekar 07-06-2016 01:46 AM

In TTrace, for IPO Sync Service please enable ISS_DB* flags. That will give more verbose logs.

In the Sync Service logs you can check for something like "SMAClientConnector.onMessage() Received notification...." these are the notifications received from IPOffice.

If the agents in IPOCC are properly marked for Telephony and Users in IPO are also properly marked. Then please restart Sync Service (from windows services) . That will clear any notifications it has in its cache.
If the state is proper, the next time Sync Service runs it should not delete the telephony part.

jtarjanyi 07-06-2016 05:17 AM

Quote:

Originally Posted by schopdekar (Post 27708)
In TTrace, for IPO Sync Service please enable ISS_DB* flags. That will give more verbose logs.

In the Sync Service logs you can check for something like "SMAClientConnector.onMessage() Received notification...." these are the notifications received from IPOffice.

If the agents in IPOCC are properly marked for Telephony and Users in IPO are also properly marked. Then please restart Sync Service (from windows services) . That will clear any notifications it has in its cache.
If the state is proper, the next time Sync Service runs it should not delete the telephony part.

I have make a try and make initial configuration via WebAdministration Page of IPOCC, with limited agnet, but got the same result.

I put the IpoSyncService log here : http://pastebin.com/AJ9c8F5k

schopdekar 07-06-2016 05:54 AM

From the logs, there seems to be some issues.

=> Which was the IPOCC version from which you upgraded ?

=> Seems the network connection between IPO and IPOCC is going up/down, or the IPO Web Manager is going up/down. That is reflected as "connect timed out" in logs. This needs to be corrected. Can you please check the state of WebManager in IPO. You can view service state on IPO dashboard (port 7071).

=> Can you please check IPO Sync Service Configuration. If earlier this was working well, this should be correct, unless someone changed the credentials at IPO end.
The configuration is under PBX -> PBXServer -> Conf Access. Please verify the credentials. The port should be 7070 in case of IPO Server edition.

=> Sync Service received notifications from IPO related to User's. And these User's didn't had agent type set. Normally Sync Service discards there notifications, unless the User name matches that of an IPOCC Agent, in which case, it is an indication to remove Telephony of IPOCC Agent. That's why Sync Service deleted agents from IPOCC.
e.g. agent BCurmei
Sync service added this Agent in IPOCC (or enabled its telephony)
D6887d 14:29:55.397 TC_General Adding agent BCurmei
D6888d 14:29:55.398 ISS_DB_interact ISS: GlobalAccountDAO::addGlobalAccount, agentID com.tenovis.cc.base.CCIdStruct@270be048, Name BCurmei
D6912d 14:29:55.405 TC_General Add/Update done successfully in global account for BCurmei
D6913d 14:29:55.409 ISS_DB_interact ISS: PABXAgent::addAgent() Add database
D7062d 14:29:55.439 TC_General Agent BCurmei having guid 89F80A80482911DF9974204747987F5A Added in IPOCC
D7067d 14:29:55.446 TC_General Updating map after adding in PABXAGENT and GLOBALACCOUNT for BCurmei
D7068d 14:29:55.446 ISS_DB_interact ISS: addPABXDevice:: add Agent in DB
D7124d 14:29:55.461 TC_General Telephone extension 6321added/updated successfully for agent BCurmei



Later Sync Service received a notification from IPO
F1592d 15:00:17.363 TC_General SMAClientConnector.onMessage() Received notification...

This notification didn't had the user "BCurmei" marked as IPOCC Agent. Hence Sync Service removed Telephony of that agent from IPOCC.




=> One possibility is that that User's are being re-created in IPO, and this is causing the issue.
If the user's/Agents are being edited either from IPOCC or IPO it is better. Having them edited from both places can cause issues.


All times are GMT -7. The time now is 08:24 AM.