View Single Post
  #1  
Old 06-01-2012, 01:17 PM
jacob27 jacob27 is offline
Aspiring Member
 
Join Date: Sep 2011
Posts: 2
jacob27 has 10 reputation points
Default EC500 iPhone 3g no caller id 2G OK

Carrier is AT&T, when EC500 is on and iPhone is in 2G no issues. Enable 3G and Unknown Caller appears.

Change to a different carrier non-ATT (different PN) and it works in 3G

Tried the following, from another post, and it did not resolve the problem:
AT&T Cingular is becoming more stringent it seems on requiring CLID numbers to come through in 10-digit format. Many of their trunks don't know what to do with a shorter extension (in our case 4 digits) being passed from your switch. (We have no issue when mapped to Verizon or Sprint/Nextel devices.)

To ensure you are sending 10 digits on station-to-station calls where EC500 is active, change off-pbx-telephone configuration set (usually 1). Calling Number Style needs to be changed from 'pbx' to 'network.'

The only thing impacted by this change is caller ID on the mobile device a station is mapped to. I made the change globally since we're only using configuration set 1, but if your other users like seeing the extension come across so they can see at a glance it's an internal call, you do have the option to give your Cingular users their own configuration set where everything is the same except for the 'Calling Number Style' setting.
Reply With Quote