Avaya Support Forums  

Go Back   Avaya Support Forums > Contact Center Applications

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 04-05-2016, 09:12 AM
mamb mamb is offline
Whiz
 
Join Date: Jun 2015
Posts: 26
mamb has 10 reputation points
Default tomcat becomes non responsive

Hello All,
we have below call sequence and facing an issue where the tomcat becomes non responsive at one point.

sequence:
1.OD-app calls LaunchCCXML(….) and MPP selects one of the free H323 port (always from ascending order) and dial to Agent VDN.
2.From Agent VDN call queue to Agent skill and routes to one of the free agent
3.After call get established OD-app plays the agent menu and agent hears full prompt and press some digits.
4.OD-app put the call on hold using CTI node
5.Then OD-app dial to customer using CTI node.
6.Sequence:
6.1.OD-app call the CTI dial node
6.2.Aes-connector.jar initiate the dial operation and wait in Mutex thread for events.
6.3.Before even receiving the alerting event the aes-connector receives disconnect event.
6.4.From aes-connector side it does the cleanup but the thread which is waiting in Mutex is not released for ever.
7.When this problem occurs slowly all the threads get blocked and at one point tomcat is unable to respond for new request until tomcat service restart.

Restart of tomcat services required.

1. Any inputs on how to identify who or from where the disconnect event is raised.?
2. This issue occurs randomly.

Thanks
Reply With Quote
  #2  
Old 05-03-2016, 07:37 AM
nelr nelr is offline
Hot Shot
 
Join Date: Sep 2014
Location: Cape Town, South Africa
Posts: 19
nelr has 10 reputation points
Default

Best bet is logs. Make sure that you apply proper logging in your applications.

PSI Probe (https://github.com/psi-probe/psi-probe) is also a good tool to install onto Tomcat that will give you better insight into the status of tomcat and current sessions.
Reply With Quote
Reply

Tags
aes-connector, cti, dial, tomcat

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:33 PM.

This Forum is provided solely for the use and convenience of Avaya customers and partners. Use of the Forum is subject to the Terms and Use and Privacy Statement found at www.avaya.com. No other use is permitted. The Forum including all content posted is “AS IS” and Avaya expressly disclaims all warranties and/or guarantees as to its accuracy, reliability, usefulness, quality or non-infringement of intellectual property. Avaya reserves the right to remove any content posted on the Forum at any time and for whatever reason.

Avaya will not be liable for any content posted on this Forum, including, without limitation, any errors or omissions or for any losses or damages of any kind incurred as a result of use or reliance on any content, regardless of its origin.

You expressly understand and agree that you assume all risks associated with use or reliance on this content.