Avaya Support Forums  

Go Back   Avaya Support Forums > Avaya Aura & Unified Communications

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-15-2019, 07:04 AM
hajek2's Avatar
hajek2 hajek2 is offline
Member
 
Join Date: Sep 2019
Posts: 2
hajek2 has 11 reputation points
Angry KVM OVA bugs: SMGR HW resources

SMGR is checking the HW resources and it is doing it wrong!

SMGR-8.1.0.0.733078-KVM-47.ova (SMGR81GA007), patched SMGR81GA013, SMGR81GA018 and SMGR81SSP01

/opt/Avaya/vsp/VEProfile/VEProfile.sh:55
Code:
allocated_cpu=`cat /proc/cpuinfo  | grep processor  | wc -l`
This is terribly wrong approach because if the work ‘processor’ is in the actual name then it produces double CPU count:


Solution is in including tabulator and colon (additionally matching the word from the beginning of line with ^) in the grep:
Code:
cat /proc/cpuinfo | grep -P "^processor\t:" | wc -l
or parse /bin/lscpu (util-linux) output or just simply use /bin/nproc (GNU coreutils) which is also present in the system!


... btw. next issue is that if configuration changes one can’t run the VM and it shuts down itself without warning (lame):




... and please don't tell me to change CPU type to 'host' ... I already did that but it doesn't change the thing that script is buggy.

Last edited by hajek2; 09-17-2019 at 04:53 AM. Reason: sytem info
Reply With Quote
  #2  
Old 09-16-2019, 05:41 AM
mlombardi1's Avatar
mlombardi1 mlombardi1 is offline
Genius
 
Join Date: Sep 2010
Location: New York
Posts: 396
mlombardi1 has 25 to 49 reputation pointsmlombardi1 has 25 to 49 reputation pointsmlombardi1 has 25 to 49 reputation points
Default

Good info. Avaya development needs to see this post.
Reply With Quote
Reply

Tags
bug, hw detection, kvm, smgr

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:15 PM.

This Forum is provided solely for the use and convenience of Avaya customers and partners. Use of the Forum is subject to the Terms and Use and Privacy Statement found at www.avaya.com. No other use is permitted. The Forum including all content posted is “AS IS” and Avaya expressly disclaims all warranties and/or guarantees as to its accuracy, reliability, usefulness, quality or non-infringement of intellectual property. Avaya reserves the right to remove any content posted on the Forum at any time and for whatever reason.

Avaya will not be liable for any content posted on this Forum, including, without limitation, any errors or omissions or for any losses or damages of any kind incurred as a result of use or reliance on any content, regardless of its origin.

You expressly understand and agree that you assume all risks associated with use or reliance on this content.