Avaya Support Forums  

Go Back   Avaya Support Forums > Contact Center Applications

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-17-2015, 07:43 AM
jacks196 jacks196 is offline
Whiz
 
Join Date: Oct 2014
Location: Sheffield, England
Posts: 44
jacks196 has 12 reputation points
Default AACC Multimedia email with TLS

We are trying to configure CCMM to retrieve email from our Exchange servers using POP3 and TLS security. We have configured everything according to the AACC Admin guide regarding importing the certificates into Java and have configured the TLS security with the CCMM Administration tool.

When CCMM tries to poll an Exchange mailbox we receive the error below:

"javax.mail.AuthenticationFailedException: Command is not valid in this state."

I have run a Wireshark trace on CCMM whilst the server is trying to poll the mailbox and can see that CCMM is passing the user name for the mailbox to Exchange as plain text, Exchange then rejects the request as our Exchange servers will only accept traffic encrypted with TLS.

Anyone any ideas, if Avaya will only work by sending the mailbox username and password to Exchange as plain text then using TLS seems like a pointless feature and it will unfortunately mean we are unable to use email within AACC ?

Reply With Quote
  #2  
Old 08-26-2015, 05:26 AM
jacks196 jacks196 is offline
Whiz
 
Join Date: Oct 2014
Location: Sheffield, England
Posts: 44
jacks196 has 12 reputation points
Default

Now working - selecting TLS as the encryption method wouldn't work no matter what I tried, but selecting SSL worked without any problems.

....pitty that sensitive customer emails are stored as plain text within the CCMM database though, encyrpting the traffic between CCMM / Exchange is just like plugging one hole in a cullendar!

Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:18 AM.

This Forum is provided solely for the use and convenience of Avaya customers and partners. Use of the Forum is subject to the Terms and Use and Privacy Statement found at www.avaya.com. No other use is permitted. The Forum including all content posted is “AS IS” and Avaya expressly disclaims all warranties and/or guarantees as to its accuracy, reliability, usefulness, quality or non-infringement of intellectual property. Avaya reserves the right to remove any content posted on the Forum at any time and for whatever reason.

Avaya will not be liable for any content posted on this Forum, including, without limitation, any errors or omissions or for any losses or damages of any kind incurred as a result of use or reliance on any content, regardless of its origin.

You expressly understand and agree that you assume all risks associated with use or reliance on this content.