Avaya Support Forums  

Go Back   Avaya Support Forums > Small and Medium Business Communications

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 05-18-2018, 06:10 AM
carba11 carba11 is offline
Aspiring Member
 
Join Date: Sep 2017
Posts: 1
carba11 has 10 reputation points
Default Error 461 REST API

Hello, I try to use Management API to get users in Avaya IP Office 10.1.1.0 compilación 3. When I send the request the response is:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?><response status="0"><data><ws_object error_node="true"><SMAError><error><error_code>461 :SessionTimeout</error_code><error_desc>[[ portal hostname ]]</error_desc><errorLocation>[[ portal hostname ]]</errorLocation></error></SMAError></ws_object></data></response>


The query request is:

url: https://[[ portal hostname ]]:7070/WebManagement/ws/sdk/admin/v1/users
Content-Type: application/json
Authorization: Basic Y2FyYmFsbGU6UmFwdG9yMzUw
X-User-Client: Avaya-WebAdmin
X-User-Agent: Avaya-SDKUser
Reply With Quote
  #2  
Old 03-18-2019, 02:16 PM
fwilkepcs fwilkepcs is offline
Genius
 
Join Date: Nov 2013
Location: Germany
Posts: 360
fwilkepcs has 18 reputation pointsfwilkepcs has 18 reputation points
Default

Hi!


Did you find a solution to that? I can call the API three times without issue. The fourth time I get that error.


Funny thing is that I can't find the error (461) as an official error code anywhere.
Reply With Quote
  #3  
Old 05-02-2019, 09:50 AM
fwilkepcs fwilkepcs is offline
Genius
 
Join Date: Nov 2013
Location: Germany
Posts: 360
fwilkepcs has 18 reputation pointsfwilkepcs has 18 reputation points
Default

I am a little further. It seems that the authentication URI can be called only five times before you run into the timeout. Probably the session remain open and more than five parallel sessions are not allowed.

I called the auth URI only once now and triggered the following calls (i.e. to get the users out of the IPO) multiple times. It worked fine calling the data about 10 timees.

I have to adjust my script to handle that.
Reply With Quote
  #4  
Old 07-16-2019, 03:27 AM
nsivar nsivar is offline
Aspiring Member
 
Join Date: Dec 2018
Posts: 2
nsivar has 10 reputation points
Default

Quote:
Originally Posted by fwilkepcs View Post
Hi!


Did you find a solution to that? I can call the API three times without issue. The fourth time I get that error.


Funny thing is that I can't find the error (461) as an official error code anywhere.
Did you find any solution for this error??
Reply With Quote
  #5  
Old 07-16-2019, 03:28 AM
nsivar nsivar is offline
Aspiring Member
 
Join Date: Dec 2018
Posts: 2
nsivar has 10 reputation points
Default

Quote:
Originally Posted by carba11 View Post
Hello, I try to use Management API to get users in Avaya IP Office 10.1.1.0 compilación 3. When I send the request the response is:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?><response status="0"><data><ws_object error_node="true"><SMAError><error><error_code>461 :SessionTimeout</error_code><error_desc>[[ portal hostname ]]</error_desc><errorLocation>[[ portal hostname ]]</errorLocation></error></SMAError></ws_object></data></response>


The query request is:

url: https://[[ portal hostname ]]:7070/WebManagement/ws/sdk/admin/v1/users
Content-Type: application/json
Authorization: Basic Y2FyYmFsbGU6UmFwdG9yMzUw
X-User-Client: Avaya-WebAdmin
X-User-Agent: Avaya-SDKUser
How to overcome this issue ??
Reply With Quote
Reply

Tags
api, ipoffice, managemente

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:16 PM.

This Forum is provided solely for the use and convenience of Avaya customers and partners. Use of the Forum is subject to the Terms and Use and Privacy Statement found at www.avaya.com. No other use is permitted. The Forum including all content posted is “AS IS” and Avaya expressly disclaims all warranties and/or guarantees as to its accuracy, reliability, usefulness, quality or non-infringement of intellectual property. Avaya reserves the right to remove any content posted on the Forum at any time and for whatever reason.

Avaya will not be liable for any content posted on this Forum, including, without limitation, any errors or omissions or for any losses or damages of any kind incurred as a result of use or reliance on any content, regardless of its origin.

You expressly understand and agree that you assume all risks associated with use or reliance on this content.