Avaya Support Forums  

Go Back   Avaya Support Forums > IP Office Contact Center

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10-16-2015, 01:34 AM
singh414 singh414 is offline
Member
 
Join Date: May 2014
Posts: 9
singh414 has 10 reputation points
Default Timed Call Back Request

Hello Everyone,

Has any one designed an IVR in IPOCC where caller gets option to leave his number and the time for a call back.

Can anyone please share inputs regarding the above scenario.

Thanks & Regards
Reply With Quote
  #2  
Old 10-18-2015, 06:29 AM
verma62 verma62 is offline
Brainiac
 
Join Date: Apr 2015
Posts: 59
verma62 has 10 reputation points
Default

Hi Singh,

This is achievable, you can find sample of call back request example in IPOCC sample folders. In this example IVR takes the current time for the call back request. Now you have to modify the IVR to get the time of call for the Call Back and also further modify the existing database operations to insert new time for call back.

But one thing I have noticed in IPOCC is that default database connection(ODBC) frequently get disconnected and start giving exceptions. I am not sure if others have faced these issues or not, or may be the way I missed few configuration while implementing ODBC connectivity.
Reply With Quote
  #3  
Old 10-18-2015, 10:59 PM
kruegerb kruegerb is offline
Genius
.
 
Join Date: Oct 2013
Location: Stuttgart-Germany
Posts: 276
kruegerb has 12 reputation points
Default

@Verma32: you said "is that default database connection(ODBC) frequently get disconnected and start giving exceptions": have you more Details? when does this occur and where have you seen the exceptions? Have you checked the IVR script to make sure that DB session always closed when call ended?

Last edited by kruegerb; 10-21-2015 at 03:50 AM.
Reply With Quote
  #4  
Old 10-19-2015, 12:47 AM
singh414 singh414 is offline
Member
 
Join Date: May 2014
Posts: 9
singh414 has 10 reputation points
Default

@verma32 : do you have any example of the logic which you have followed. I have developed one flow but it is not taking and inserting the time in the Database. It would be helpful if you could share the script for reference.
Reply With Quote
  #5  
Old 10-26-2015, 07:32 AM
verma62 verma62 is offline
Brainiac
 
Join Date: Apr 2015
Posts: 59
verma62 has 10 reputation points
Default

Dear Singh,

I don't have script available as of now with me, but error you may be getting should be related to SQL query. As far I understand the example shared in IPOCC folder takes the current date time and run the sql script. May be it can help,

I will try to build a sample code for you also but running very tight on schedule so don't know when will I get time.

Thanks,
Rajat Verma
Reply With Quote
  #6  
Old 10-26-2015, 07:41 AM
verma62 verma62 is offline
Brainiac
 
Join Date: Apr 2015
Posts: 59
verma62 has 10 reputation points
Default

Dear Kruegerb,

Thanks for your response, you always come to our rescue whenever we face serious problem with IPOCC.

Regarding the database error, we are using IPOCC over windows 2012 server. I have successfully created the ODBC driver 32 bit to get connected with MSSQL database, after the configuration when I do the test connection it executes without any issues.

Now same driver I am using in IPOCC IVR script and able to fetch/insert values from database. However after some time(I don't have definite time interval) we started facing exceptions in IVR whenever we do database operation. But when I again configure the ODBC driver with passing the username and pwd, and do test connection this issue is resolved for some time

Below are the logs for your reference

E5089v 15:24:00.579 TC_General [0x00005E34] VUS_Element::ElemTrace(Retrieved Choice Id from data,Survey-demo,0x375B1AE0,0,0x2C8E6)::run(0xD353015611010000 ) Retrieved ChoiceId- 21, For QuestionId-7, DTMF -5
E5090v 15:24:00.581 TC_Warning [0x00005E34] DB_Connection::getNumberOfRows(Snug-Survey-db,db_user,75654672) Error: 24000
E5091v 15:24:00.581 TC_Warning [0x00005E34] [Microsoft][ODBC SQL Server Driver]Invalid cursor state
E5092v 15:24:00.581 TC_General [0x00005E34] VUS_Element::ElemTrace(Decresing Question Counter,Survey-demo,0x375B1AE0,0,0x2C8E6)::run(0xD353015611010A00 ) Decresing the value of question counter, new value - 4
E5749v 15:24:04.420 TC_General [0x00005E34] VUS_Element::ElemTrace(Retrieved Choice Id from data,Survey-demo,0x375B1AE0,0,0x2C8E6)::run(0xD353015611010000 ) Retrieved ChoiceId- 28, For QuestionId-8, DTMF -3
E5750v 15:24:04.422 TC_Warning [0x00005E34] DB_Connection::getNumberOfRows(Snug-Survey-db,db_user,75655552) Error: 24000
E5751v 15:24:04.422 TC_Warning [0x00005E34] [Microsoft][ODBC SQL Server Driver]Invalid cursor state
E5752v 15:24:04.422 TC_General [0x00005E34] VUS_Element::ElemTrace(Decresing Question Counter,Survey-demo,0x375B1AE0,0,0x2C8E6)::run(0xD353015611010A00 ) Decresing the value of question counter, new value - 3
E5763v 15:24:08.959 TC_General [0x00005E34] VUS_Element::ElemTrace(Retrieved Choice Id from data,Survey-demo,0x375B1AE0,0,0x2C8E6)::run(0xD353015611010000 ) Retrieved ChoiceId- 32, For QuestionId-9, DTMF -4
E5764v 15:24:08.961 TC_Warning [0x00005E34] DB_Connection::getNumberOfRows(Snug-Survey-db,db_user,17359480) Error: 24000
E5765v 15:24:08.961 TC_Warning [0x00005E34] [Microsoft][ODBC SQL Server Driver]Invalid cursor state



I checked the "Invalid cursor state" in Microsoft blogs and found this a known issues while using ODBC drivers, don't know how to overcome this.

Just for information at the same time I am using custom made connectors which are interacting with same database server and there the queries are getting successfully ecxectued. Checked this with both Java code and Visual c# code.
Reply With Quote
  #7  
Old 10-30-2015, 12:01 AM
singh414 singh414 is offline
Member
 
Join Date: May 2014
Posts: 9
singh414 has 10 reputation points
Default

Thanks Rajat I Understand and it will be very helpful if you can provide that or any logic idea for the script so that we can capture the time and insert it to initialize the call job at the mentioned time.

@Kruegerb, any idea how this can be achieved

@Rajat : I faced similar problem where the ODBC connection to the DB was getting dropped and when i reconfigured the ODBC driver again entirely it started behaving normally. Have you tried that out. Also is your Database present locally.

Thanks & Regards,
Vinay Singh
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:16 PM.

This Forum is provided solely for the use and convenience of Avaya customers and partners. Use of the Forum is subject to the Terms and Use and Privacy Statement found at www.avaya.com. No other use is permitted. The Forum including all content posted is “AS IS” and Avaya expressly disclaims all warranties and/or guarantees as to its accuracy, reliability, usefulness, quality or non-infringement of intellectual property. Avaya reserves the right to remove any content posted on the Forum at any time and for whatever reason.

Avaya will not be liable for any content posted on this Forum, including, without limitation, any errors or omissions or for any losses or damages of any kind incurred as a result of use or reliance on any content, regardless of its origin.

You expressly understand and agree that you assume all risks associated with use or reliance on this content.