Avaya Support Forums  

Go Back   Avaya Support Forums > Enterprise PBX Communications Systems

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 05-20-2010, 08:34 AM
mtippitt0533 mtippitt0533 is offline
Aspiring Member
 
Join Date: May 2010
Posts: 2
mtippitt0533 has 10 reputation points
Default Denial event 1189 on remote call termination/hangup

Denial event 1189 on remote call termination/hang up
I have a Cisco Call Manager system with an ISDN PRI connected to a 2600 router. I am migrating this office to an Avaya CM solution. When swinging the PRI over to the Avaya I am able to get the signal group and trunk to go in service but I am having a strange problem. Calls to local numbers work, but if the remote end hangs up the phone the avaya phone gets a busy tone and has to time out before it will disconnect.. A trace shows a denial event when the remote end hangs up. This issue doesn't happen on long distance calls or on the Cisco system that the office has today. Configs are below including the cisco router config. I did try setting protocol c in the DS1 circuit pack because I saw mention that c is for DMS100 (Cisco config) but the trunk was out of service FE-PINS when I did that. I have also tried d but still had sam FE-PINS error on trunks.Any ideas?

Thanks.

time data
21:20:52 active trunk-group 1 member 23 cid 0x2a8
21:21:00 denial event 1189: Normal, unspecified D1=0x8c3 D2=0x93041f21:21:00 idle trunk-group 1 member 23 cid 0x2a8
VOIP data from: [10.194.7.16]:2058
21:21:01 Jitter:0 0 0 0 0 0 0 0 0 0: Buff:11 WC:5 Avg:0
21:21:01 Pkloss:0 0 0 0 0 0 0 0 0 0: Oofo:0 WC:0 Avg:0
VOIP data from: [10.194.7.16]:2058
21:21:11 Jitter:0 0 0 0 0 0 0 0 0 0: Buff:11 WC:5 Avg:0
21:21:11 Pkloss:0 0 0 0 0 0 0 0 0 0: Oofo:0 WC:0 Avg:0
VOIP data from: [10.194.7.16]:2058
21:21:21 Jitter:0 0 0 0 0 0 0 0 0 0: Buff:12 WC:5 Avg:0
21:21:21 Pkloss:0 0 0 0 0 0 0 0 0 0: Oofo:0 WC:0 Avg:0
VOIP data from: [10.194.7.16]:2058
21:21:31 Jitter:0 0 0 0 0 0 0 0 0 0: Buff:12 WC:5 Avg:0
21:21:31 Pkloss:0 0 0 0 0 0 0 0 0 0: Oofo:0 WC:0 Avg:0
VOIP data from: [10.194.7.16]:2058
time data
21:21:41 Jitter:0 0 0 0 0 0 0 0 0 0: Buff:12 WC:5 Avg:0
21:21:41 Pkloss:0 0 0 0 0 0 0 0 0 0: Oofo:0 WC:0 Avg:0
21:21:45 idle cid 0x2a8


Here is my Avaya config

Code:
DS1 CIRCUIT PACK Location: 001V5 Name: Main Circuit Bit Rate: 1.544 Line Coding: b8zs Line Compensation: 1 Framing Mode: esf Signaling Mode: isdn-pri Connect: network TN-C7 Long Timers? n Country Protocol: 1Interworking Message: PROGress Protocol Version: bInterface Companding: mulaw CRC? n Idle Code: 11111111 DCP/Analog Bearer Capability: 3.1kHz T303 Timer(sec): 4 Slip Detection? n Near-end CSU Type: other Echo Cancellation? n Block Progress Indicator? n display signaling-group 1 Page 1 of 5 SIGNALING GROUP Group Number: 1 Group Type: isdn-pri Associated Signaling? y Max number of NCA TSC: 0 Primary D-Channel: 001V524 Max number of CA TSC: 0 Trunk Group for NCA TSC: 1 Trunk Group for Channel Selection: 1 TSC Supplementary Service Protocol: a display trunk-group 1 Page 1 of 21 TRUNK GROUPGroup Number: 1 Group Type: isdn CDR Reports: y Group Name: OUTSIDE CALL COR: 1 TN: 1 TAC: #801 Direction: two-way Outgoing Display? n Carrier Medium: PRI/BRI Dial Access? n Busy Threshold: 255 Night Service:Queue Length: 0Service Type: public-ntwrk Auth Code? n TestCall ITC: rest Far End Test Line No:TestCall BCC: 4display trunk-group 1 Page 2 of 21 Group Type: isdnTRUNK PARAMETERS Codeset to Send Display: 6 Codeset to Send National IEs: 6 Max Message Size to Send: 260 Charge Advice: none Supplementary Service Protocol: a Digit Handling (in/out): enbloc/enbloc Trunk Hunt: cyclical Digital Loss Group: 13Incoming Calling Number - Delete: Insert: Format: Bit Rate: 1200 Synchronization: async Duplex: full Disconnect Supervision - In? y Out? y Answer Supervision Timeout: 0 Administer Timers? n CONNECT Reliable When Call Leaves ISDN? n



And the working Cisco config..

version 12.4
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
!
aaa new-model
!
!
aaa authentication login default local
!
aaa session-id common
!
resource policy
!
clock timezone EST -5
clock summer-time EST recurring
no network-clock-participate slot 1
no network-clock-participate wic 0
voice-card 1
!
ip cef
!
!
!
!
isdn switch-type primary-dms100
!
!
voice call carrier capacity active
voice rtp send-recv
!
voice service voip
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco
h323
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
codec preference 3 g729br8
!
!
!
voice class h323 1
h225 timeout tcp establish 3
!
!
!
!
!
!
!
!
!
!
!
controller T1 1/0
framing esf
linecode b8zs
cablelength short 133
pri-group timeslots 1-24
!
class-map match-all call-control
match ip precedence 3
class-map match-any voice
match ip rtp 16384 16383
!
!
policy-map VOICE
class voice
priority percent 40
class call-control
bandwidth percent 5
class class-default
fair-queue
!
!
!
!
interface FastEthernet0/0
ip address 10.194.7.252 255.255.255.0
speed 100
full-duplex
h323-gateway voip bind srcaddr 10.194.7.252
!
interface Serial1/0:23
no ip address
encapsulation hdlc
no logging event link-status
isdn switch-type primary-dms100
isdn incoming-voice voice
isdn map address 911 plan unknown type unknown
no cdp enable
!
ip route 0.0.0.0 0.0.0.0 10.194.7.254
!
ip http server
no ip http secure-server
!
logging history warnings
logging 10.194.5.41
!
!
control-plane
!
!
!
voice-port 1/0:23
input gain -3
output attenuation 3
no vad
!
!
!
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
destination-pattern .T
progress_ind setup enable 3
progress_ind connect enable 8
incoming called-number .
direct-inward-dial
port 1/0:23
!
!
ntp authenticate
ntp trusted-key 1024
ntp clock-period 17179682
!
end


I am assuming that the issue is with the DMS Protocol. I have tried using C and D
Reply With Quote
  #2  
Old 05-26-2010, 01:16 AM
aviswanathan's Avatar
aviswanathan aviswanathan is offline
Hot Shot
.
 
Join Date: Feb 2010
Location: Pune
Posts: 19
aviswanathan has 11 reputation points
Default

Please go through link

http://www.cisco.com/en/US/tech/tk10...803d22cd.shtml

Here they have put Q Sig Integration. Since you are using b I believe you are also trying to achieve the same. If this does not help open a ticket with Avaya CM Backbone.

Thank you
Reply With Quote
  #3  
Old 05-26-2010, 04:52 PM
rogerg's Avatar
rogerg rogerg is offline
Brainiac
 
Join Date: Jan 2010
Location: Houston, Tx
Posts: 51
rogerg has 10 reputation points
Default

The issue the original poster is asking about is regarding an AVAYA configured for ISDN PRI from a CO providing ISDN NI2 / DMS100.

The issue only occurs when a user dials an at&t mobile phone and the called user disconnects. All other calls are completed normal.

If a user calls other than an at&t mobile phone and the called party disconnects, the list trace shows a cause-code of 16 (Normal Call Clearing).

If a user calls an at&t mobile phone and the called party disconnects, the list trace shows a cause-code 31 (Normal, Unspecified). The local ISDN provider also sees at&t sending the cause-code 31. The local ISDN provider is simply passing the code to the AVAYA.

Is there away to have CM map cause-code 31 to a normal disconnect, or is there another way to allow CM to terminate the call instead of sending busy-tone to the AVAYA handset?
__________________
Gary Rogerson
AVAYA ACE
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:40 AM.

This Forum is provided solely for the use and convenience of Avaya customers and partners. Use of the Forum is subject to the Terms and Use and Privacy Statement found at www.avaya.com. No other use is permitted. The Forum including all content posted is “AS IS” and Avaya expressly disclaims all warranties and/or guarantees as to its accuracy, reliability, usefulness, quality or non-infringement of intellectual property. Avaya reserves the right to remove any content posted on the Forum at any time and for whatever reason.

Avaya will not be liable for any content posted on this Forum, including, without limitation, any errors or omissions or for any losses or damages of any kind incurred as a result of use or reliance on any content, regardless of its origin.

You expressly understand and agree that you assume all risks associated with use or reliance on this content.