Avaya Support Forums  

Go Back   Avaya Support Forums > Contact Center Applications

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 05-13-2015, 07:25 AM
frade2 frade2 is offline
Whiz
 
Join Date: Jan 2014
Posts: 38
frade2 has 11 reputation points
Default EMC Desktop Hanged/freezed when using iexplore.exe as External Application

Hi experts,

I have an Elite Multichannel enviroment, where I have to open an URL between work item, when call from specific VDN is established in Agent Desktop.

We have found a solution (which we think is the best) using external application iexplore.exe, and configuring "External Application 1" and also using Rules with specific URL based on the VDN of the incoming call. Let me show you what i have configured in the .ini file (we dont use templates):
-------------------------------------
[External Application 1]
Display Delay Interval Seconds = 1
Display In Tool Window = False
Allow Tool Window To Dock Bottom = True
Allow Tool Window To Dock Top = True
Allow Tool Window To Dock Left = True
Allow Tool Window To Dock Right = True
External Application Name = iexplore.exe
External Application Command Line =
Title Text = 060
Allow To Close = True
Launch Application When Host Started = False
Incoming Call VDN List =
Icon File Full Path = ExternalApp.ICO
Tool Window Key =
Focus Application When Window Selected = True


Rule2 = When Voice.WIEstablished And CalledDN = 1993001 Do ReturnEvent Container.LaunchNewExternalApplicationWindow,exter nalAppConfigSectionName=External Application 1,externalAppCommandLine=http://10.252.138.110/Script/index1nivel.html?VDN=%VDN%&calledDN=%CalledDN%&Age ntID=%AgentID%&StationDN=%StationDN%,callIDToClose WindowWhenCallDropped=%CallID% Then Stop Else Stop
---------------------------------

This solution "works" but often we have found, in certain scenarios (not always the same...ie when agent drops the call etc...) the EMC Desktop freezes and we have to restart again because it doesnt work. We have test without external application and works much more better.

Please, Could you confirm me if I 'm using external Application to upen an URL as is suppose to work, or i have to do some other thing?
Do you have any idea why EMC Desktop freezes or why is happening this behaviour?

You all are my last hope

THANKS in ADVANCE!!
David
Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:59 PM.

This Forum is provided solely for the use and convenience of Avaya customers and partners. Use of the Forum is subject to the Terms and Use and Privacy Statement found at www.avaya.com. No other use is permitted. The Forum including all content posted is “AS IS” and Avaya expressly disclaims all warranties and/or guarantees as to its accuracy, reliability, usefulness, quality or non-infringement of intellectual property. Avaya reserves the right to remove any content posted on the Forum at any time and for whatever reason.

Avaya will not be liable for any content posted on this Forum, including, without limitation, any errors or omissions or for any losses or damages of any kind incurred as a result of use or reliance on any content, regardless of its origin.

You expressly understand and agree that you assume all risks associated with use or reliance on this content.