Avaya Support Forums  

Go Back   Avaya Support Forums > IP Office Contact Center

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 07-22-2015, 09:23 AM
johnbriggs johnbriggs is offline
Member
.
 
Join Date: Aug 2014
Posts: 8
johnbriggs has 10 reputation points
Exclamation ### connection to CHAP failed ###

Greetings all,

After a recent reboot, when making a single voice call into IPOCC, the CHAP service fails.

The TT Console (VEA) shows the following lines when the issue occurs:

TC_General [Thread-2945 ] - connection to CHAP lost
TC_Service - 28.000.0201 Connection to CHAP lost.


Chap recovers after approximately 40 seconds.

Any thoughts on what the issue might be or steps to troubleshoot this issue further is greatly appreciated.
Reply With Quote
  #2  
Old 07-27-2015, 12:23 PM
fcassity fcassity is offline
Hot Shot
.
 
Join Date: Feb 2012
Location: Inside Sales - Miami, FL US
Posts: 16
fcassity has 10 reputation points
Default

Any ideas on this? We can only have one call before it fails.
Reply With Quote
  #3  
Old 07-29-2015, 03:36 AM
kruegerb kruegerb is offline
Genius
.
 
Join Date: Oct 2013
Location: Stuttgart-Germany
Posts: 276
kruegerb has 12 reputation points
Default

have you checked the chap configuration? Is the SIP link between Chap and IPO working (check in chap ttrace)? check in IPO Manger for SIP extension Device Type (should be “Avaya IP Office Contact Center"). Is process chap sync running?

Last edited by kruegerb; 07-29-2015 at 09:26 AM.
Reply With Quote
  #4  
Old 07-30-2015, 10:56 AM
fcassity fcassity is offline
Hot Shot
.
 
Join Date: Feb 2012
Location: Inside Sales - Miami, FL US
Posts: 16
fcassity has 10 reputation points
Default

We have reviewed the CHAP configuration and it looks right. The Extension for the Contact Center is showing a type as "Avaya IP Office Contact Center".

The Chap Sync is running.
Reply With Quote
  #5  
Old 08-04-2015, 12:06 PM
johnbriggs johnbriggs is offline
Member
.
 
Join Date: Aug 2014
Posts: 8
johnbriggs has 10 reputation points
Default info from TTRace CHAP

When a call comes in, the CHAP service fails. Below is the text from TT from when the call arrives until TTrace stops. The call remains active, but no other calls can be received until the CHAP recovers.

C0191a 14:44:56.914 CHAP_PhoneAdapterProxy ocPhoneAdapterCBProxy:nOffered (sipadapter.dll(IPO-SIPEXT-IP-1)) contr=1 callID=934 media=2 calling=1819 called=1901 redir= orig= info=8714BD0A000001320000076B8714BD0A0000013200000 769
C0192a 14:44:56.914 CHAP_Adapter ocLineOwnerList::vAddLineOwnerImpl owner=0x0
C0193a 14:44:56.914 CHAP_Adapter ocLineOwnerList::vShowListInTrace entry=1 line=0 callID=0 is inuse=0 owner=0x105B9F0 ch=0 isAttached=0 isDuplicated=0 isInfo=1
C0194a 14:44:56.914 CHAP_Adapter ocLineOwnerList::vShowListInTrace entry=2 line=0 callID=0 is inuse=0 owner=0xB29F1D0 ch=0 isAttached=0 isDuplicated=0 isInfo=1
C0195a 14:44:56.914 CHAP_Adapter ocLineOwnerList::vShowListInTrace entry=3 line=1 callID=934 is inuse=0 owner=0x0 ch=94287553888257 isAttached=0 isDuplicated=0 isInfo=0
C0196a 14:44:56.914 CHAP_Adapter ocLineOwnerList::vShowListInTrace entryCount=3
C0201a 14:44:58.065 CHAP_Adapter ocLineOwnerList::bHasApplUsedAllLicenses() 0 of 30 are used.
C0202a 14:44:58.065 CHAP_Adapter ocLineOwnerList::bHasApplUsedAllLicenses() 0 of 30 are used.
C0203a 14:44:58.065 CHAP_Adapter ocAdapter:oGetPhone4Service(IPO-SIPEXT-IP-1) Test line=1 from=1900 to=80029.
C0204a 14:44:58.065 CHAP_Adapter ocLineOwnerList::bIsLineOccupied line=1 is free
C0205a 14:44:58.065 CHAP_Adapter ocAdapter:oGetPhone4Service(IPO-SIPEXT-IP-1) line=1 inService=1 is OK.
C0206a 14:44:58.065 CHAP_Adapter ocLineOwnerList::bHasApplUsedAllLicenses() 0 of 30 are used.
C0207a 14:44:58.065 CHAP_Adapter ocAdapter:oGetPhone4Service(IPO-SIPEXT-IP-1) Test line=1 from=1900 to=80029.
C0208a 14:44:58.065 CHAP_Adapter ocLineOwnerList::bIsLineOccupied line=1 is free
C0209a 14:44:58.065 CHAP_Adapter ocAdapter:oGetPhone4Service(IPO-SIPEXT-IP-1) line=1 inService=1 is OK.
C0210a 14:44:58.065 CHAP_Adapter ocLineOwnerList::vAddLineOwnerImpl owner=0xb371800
C0211a 14:44:58.065 CHAP_Adapter ocAdapter::Init(IPO-SIPEXT-IP-1) listEntries=4 controller=1
C0212a 14:44:58.065 CHAP_Adapter ocAdapter::zSSTransferCall(IPO-SIPEXT-IP-1) owner=0xB371800 ch=94287553888257 destNo=1809
C0213a 14:44:58.066 CHAP_Adapter ocLineOwnerList::vRemoveLineOwnerFromListImpl owner=0xb371800
C0214a 14:44:58.066 CHAP_Adapter ocLineOwnerList::zRemoveSingleLineOwnerWithNoCall owner=0xb371800 result=1
C0215a 14:44:58.066 CHAP_Adapter ocAdapter::zRegisterOwnerForCall owner=0xb371800 resType=14 xCH=94287553888257 zLine=1 zCallID=934
C0216a 14:44:58.066 CHAP_Adapter ocAdapter::zSendStandardEvent(IPO-SIPEXT-IP-1) event=RES_EVT_EXTERN_INTERRUPT, service=0xb371800, xCh=94287553888257
C0217a 14:44:58.066 CHAP_PhoneAdapterProxy ocPhoneAdapterProxy::eResetMediaBuffer (sipadapter.dll(IPO-SIPEXT-IP-1)) contr=1 callID=934
C0218a 14:44:58.066 CHAP_Adapter ocAdapter::zSendStandardEvent(IPO-SIPEXT-IP-1) event=RES_EVT_DONE_STOPREAD_FILE, service=0xb371800, xCh=94287553888257
C0219a 14:44:58.066 CHAP_PhoneAdapterProxy ocPhoneAdapterProxy::eDeflect (sipadapter.dll(IPO-SIPEXT-IP-1)) contr=1 callID=934
C0220a 14:44:58.066 CHAP_PhoneAdapterProxy ocPhoneAdapterCBProxy:nEvent (sipadapter.dll(IPO-SIPEXT-IP-1)) contr=1 callID=934 eventCode=1 eventData=NUMBERINFO: number=1809, type=0 (unknown), reason=sstransfer
C0241a 14:44:58 4-Aug-2015
C0242a TTrace: Disconnected

At the same time in the IP Office Monitor trace, there is a TCP error 104 between the IP Office and the IPOCC server.

08:50:36 1224789127mS ERR: TCP Connection error 104 for Src=135.20.189.10:5060 Dst=135.20.189.19:56402
08:50:36 1224789127mS ERR: TCP Connection error 104 for Src=135.20.189.10:5888 Dst=135.20.189.19:5100


Any thoughts? Does this help?

Last edited by johnbriggs; 08-04-2015 at 12:25 PM.
Reply With Quote
  #6  
Old 12-07-2015, 03:39 PM
contr50 contr50 is offline
Member
 
Join Date: Nov 2015
Posts: 4
contr50 has 10 reputation points
Default

Hi,

how did you fix this? I think I have the same problem. IPOCC works fine with four calls. when traffic incresaes it fails and it seem like a resource problem.

regards
Reply With Quote
  #7  
Old 12-08-2015, 12:50 AM
huntertech huntertech is offline
Hot Shot
 
Join Date: Dec 2014
Location: Wall Township, NJ
Posts: 19
huntertech has 10 reputation points
Default

On the IPO / System / Telephony

What is your maximum SIP calls set to?
Reply With Quote
  #8  
Old 12-08-2015, 03:46 AM
george6 george6 is offline
Whiz
.
 
Join Date: Sep 2015
Posts: 28
george6 has 11 reputation points
Default

If configuration is looking Ok, Can you enable CHAP_NetworkServiceImpl and CHAP_NetworkService for CHAP and reattach? And the Trace Output of CHAP_ShowPropertyFile command in CHAP trace.

Last edited by george6; 12-08-2015 at 04:18 AM.
Reply With Quote
  #9  
Old 12-09-2015, 08:52 AM
contr50 contr50 is offline
Member
 
Join Date: Nov 2015
Posts: 4
contr50 has 10 reputation points
Default

Quote:
Originally Posted by huntertech View Post
On the IPO / System / Telephony

What is your maximum SIP calls set to?
In System -> Telephony it has 100 simultaneous sip

this is the setting you asked for?
Reply With Quote
  #10  
Old 12-09-2015, 09:10 AM
contr50 contr50 is offline
Member
 
Join Date: Nov 2015
Posts: 4
contr50 has 10 reputation points
Default

Quote:
Originally Posted by george6 View Post
If configuration is looking Ok, Can you enable CHAP_NetworkServiceImpl and CHAP_NetworkService for CHAP and reattach? And the Trace Output of CHAP_ShowPropertyFile command in CHAP trace.
The property file seem OK. I checked Chap resources and they are connected and free.

N2678b 11:05:00.281 TT_Command CHAP_ShowPropertyFile() received
N2679b 11:05:00.282 TC_General
[CHAP_ENVIRONMENT] MusicOnHold = INF*"C:\Program Files (x86)\Avaya\IP Office Contact Center\Chap\VoiceFiles\easy.wav"
[CORBA] omninamesport = 2809
[CORBA] omninamesserver = MXMEXAWLIPOCALL
[CORBA] orbport = 0
[HARDWARE_ADAPTER] Adapter1 = SIPEXT,IPO-SIPEXT-IP-1,sipadapter.dll
[IPO-SIPEXT-IP-1] DNSServerIP1 = 8.8.8.8
[IPO-SIPEXT-IP-1] EndpointPassword1 = D1246D50C3580F87D0F17EB79EFAC33CDC0D449F00661995A2 97111CDE072D837A30546E1CA115A6E67CD30215C301
[IPO-SIPEXT-IP-1] EndpointUser1 = 4000
[IPO-SIPEXT-IP-1] EndpointUserAgent1 = Avaya CIE
[IPO-SIPEXT-IP-1] FaxToneDuration =
[IPO-SIPEXT-IP-1] FaxToneThreshold =
[IPO-SIPEXT-IP-1] FullQualifiedLocalHostName1 =
[IPO-SIPEXT-IP-1] Line1 = 4900-4999;70000-70199;80000-80049,300
[IPO-SIPEXT-IP-1] LocalDomainName1 = sip.mydomain.int
[IPO-SIPEXT-IP-1] LocalHostName1 = MXMEXAWLIPOCALL
[IPO-SIPEXT-IP-1] LocalIPAddress1 = 7.206.0.251
[IPO-SIPEXT-IP-1] LocalRTPPortRange1 = 49152-53247
[IPO-SIPEXT-IP-1] LocalSignalPort1 = 5100
[IPO-SIPEXT-IP-1] MaxCallCountPerSecond1 =
[IPO-SIPEXT-IP-1] MaxMultiMediaTimer =
[IPO-SIPEXT-IP-1] NetworkQuality1 =
[IPO-SIPEXT-IP-1] NodeNumberUCIDonMakeCall1 =
[IPO-SIPEXT-IP-1] PBXDomainName1 = sip.mydomain.int
[IPO-SIPEXT-IP-1] PBXIPAddress1 = 7.206.0.253
[IPO-SIPEXT-IP-1] PBXPingPeriod1 =
[IPO-SIPEXT-IP-1] PBXSignalPort1 = 5060
[IPO-SIPEXT-IP-1] RTPPayloadType1 = 101
[IPO-SIPEXT-IP-1] RingTone =
[IPO-SIPEXT-IP-1] SRTP1 = false
[IPO-SIPEXT-IP-1] SuppressUCIDonMakeCall1 =
[IPO-SIPEXT-IP-1] TransportTypeProtocol1 = TCP
[IPO-SIPEXT-IP-1] Trunk1 = false
[RESOURCE_POOL] Pool1 = RES_68614a56d8010000,IPO-SIPEXT-IP-1,70000-70199,200
[RESOURCE_POOL] Pool2 = RES_9f6f4a560a016700,IPO-SIPEXT-IP-1,80000-80049,50
[RESOURCE_POOL] Pool3 = RES_68614a56d8010000,IPO-SIPEXT-IP-1,4900-4999,50
[TTRACE] ttraceport = 10300
[TTRACE] ttraceserver = MXMEXAWLIPOCALL
N2680b 11:05:00.282 TT_Command CHAP_ShowPropertyFile() ready

Last edited by contr50; 12-10-2015 at 03:25 PM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:22 PM.

This Forum is provided solely for the use and convenience of Avaya customers and partners. Use of the Forum is subject to the Terms and Use and Privacy Statement found at www.avaya.com. No other use is permitted. The Forum including all content posted is “AS IS” and Avaya expressly disclaims all warranties and/or guarantees as to its accuracy, reliability, usefulness, quality or non-infringement of intellectual property. Avaya reserves the right to remove any content posted on the Forum at any time and for whatever reason.

Avaya will not be liable for any content posted on this Forum, including, without limitation, any errors or omissions or for any losses or damages of any kind incurred as a result of use or reliance on any content, regardless of its origin.

You expressly understand and agree that you assume all risks associated with use or reliance on this content.