Avaya Support Forums  

Go Back   Avaya Support Forums > Contact Center Applications

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 05-29-2017, 01:15 AM
ameli ameli is offline
Aspiring Member
 
Join Date: Apr 2017
Location: Italy
Posts: 1
ameli has 10 reputation points
Default Transfer doesn't transfer

Hi,
I have a problem:
I'm using Avaya Aura Orchestration Designer and the platform Experience Portal.
I created a flow that works correctly on the Application Simulator, but when I try to mount it on the virtual machine, the transfer doesn't work correctly.

the flow is:
a menu that transfers the call with an AACC BLIND TRANSFER to a number that it reads from an xml document.

I thought that maybe the problem is that it reads the number from an xml file cause I used a parse to read that and the type of the value is Node, with the function:
mySession.getVariable("<variable_to_transfer>").ge tSimpleVariable().setValue(elementNode.getFirstChi ld().getNodeValue()); but also if I use something like:
mySession.getVariable("<variable_to_transfer>").ge tSimpleVariable().setValue(1234);
it doesn't transfer.

the vxml generated about the <transfer> element is the below, I think that is correct:
Code:
  
  8:<transfer name="XferTo" dest="tel:
  9: 2222
10: " type="blind" connecttimeout="0s" maxtime="0s"> 
11:<catch event="connection.disconnect.transfer"> 
12:<submit next="EndCall?___DDSESSIONID=BDFB08961BEE6DB163B42C2A4B1C1CC0%3A%2FTest3" namelist="XferTo" method="get"/> 
13:</catch> 
14:<filled> 
15:</filled> 
16:</transfer>
Where the next element is a Return node called EndCall and the XferTo is my AACC Blind Transfer node.

I tried also with another simple flow: start->menu->AACCBlindTransfer->end. it doesn't work too.

Using the tracing with an application that is already running and my application, the result is the same, but my application is pending after this, while the one is yet running, will complete.
Below the log.

Code:
REFER sip:1234567890@company.com:5060;maddr=192.168.1.6;transport=tcp;user=phone;gsid=51e5d310-407f-11e7-adc9-00505685ac1c SIP/2.0                |
        |From: <sip:2495@company.com;user=phone>;tag=5621d23bfd3ee7186fe0016ac922a                                                                         |
        |To: <sip:1234567890@company.com;user=phone>;tag=ab931828-7c08110a-13c4-55013-9c90a7-69087969-9c90a7                                               |
        |Call-ID: ab595ca8-7c08110a-13c4-55013-9c90a7-7c08f51b-9c90a7                                                                                       |
        |CSeq: 1 REFER |
        |Max-Forwards: 70                                                                                                                                   |
        |Route: <sip:25372ba8@192.168.1.5;transport=tcp;lr>                                                                                                 |
        |Route: <sip:10.17.8.93:15060;transport=tcp;ibmsid=local.1490346099583_6363788_6364860;lr>                                                          |
        |Route: <sip:25372ba8@192.168.1.5;transport=tcp;lr>                                                                                                 |
        |Via: SIP/2.0/TCP 192.168.1.8;branch=z9hG4bK40ab223efd3ee7187fe0016ac922a                                                                         |
        |User-Agent: Avaya-VoicePortal/192.168.1.7                                                                                                        |
        |Av-Global-Session-ID: 51e5d310-407f-11e7-adc9-00505685ac1c                                                                                         |
        |Contact: <sip:2495@192.168.1.8;transport=tcp>                                                                                                    |
        |Refer-To: <sip:8569@company.com;user=phone?P-Intrinsics=>                                                                                         |
        |Content-Length: 0
I asked on the https://www.devconnectprogram.com/fo...ist/21037.page, where WilsonYu said to me to ask here for help on the platform, cause in his opinion the problem is on the platform and not on the flow.

I really don't know where is the problem, I hope that you can help me.

Thanks!

Last edited by ameli; 05-29-2017 at 03:40 AM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:55 PM.

This Forum is provided solely for the use and convenience of Avaya customers and partners. Use of the Forum is subject to the Terms and Use and Privacy Statement found at www.avaya.com. No other use is permitted. The Forum including all content posted is “AS IS” and Avaya expressly disclaims all warranties and/or guarantees as to its accuracy, reliability, usefulness, quality or non-infringement of intellectual property. Avaya reserves the right to remove any content posted on the Forum at any time and for whatever reason.

Avaya will not be liable for any content posted on this Forum, including, without limitation, any errors or omissions or for any losses or damages of any kind incurred as a result of use or reliance on any content, regardless of its origin.

You expressly understand and agree that you assume all risks associated with use or reliance on this content.