Avaya Support Forums  

Go Back   Avaya Support Forums > IP Office Contact Center

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 04-26-2016, 08:26 PM
wdrew wdrew is offline
Member
 
Join Date: Feb 2016
Posts: 4
wdrew has 10 reputation points
Question Chat issue installing WebChatApp on Tomcat

I've installed an IPOCC system on an IP500V2 that is currently at R9.1.6. Voice is just fine. I've configured the CHAT per the Chat Services Guide with Openfire running on a separate xmpp server; using a guest account on Openfire we've tested the Chat configuration and task flow into the IPOCC and it's working just fine (just as we did in training). The web developer that works for the customer is having issues trying to get the WebChatApp working (from the examples folder on the distribution). There's a reference elsewhere in this forum of a step-by-step guide for a developer to use in configuring the Chat however it does not exist on the IPOCC ISO distribution for 9.1.x so if it's available elsewhere and someone knows where please let me know.

The 'help' text in the examples folder(s) is rather sparse and our thought is that we're missing something. The following is from the web developer and is more specific to the problem:

We're having issues getting the WebChatApp up and running. I've followed all the install instructions, modifying the properties file to match our config and placing the .war file and .properties files in the indicated directories.

Tomcat detects and installs WebChatApp but it won't start. When I try to manually start the app through Tomcat's web interface I get the following error messages in the Stderr file:

26-Apr-2016 09:07:07.899 SEVERE [http-apr-8080-exec-47] org.apache.catalina.core.StandardContext.startInte rnal One or more listeners failed to start. Full details will be found in the appropriate container log file

26-Apr-2016 09:07:07.899 SEVERE [http-apr-8080-exec-47] org.apache.catalina.core.StandardContext.startInte rnal Context [/WebChatApp] startup failed due to previous errors

26-Apr-2016 09:07:07.899 WARNING [http-apr-8080-exec-47] org.apache.catalina.loader.WebappClassLoaderBase.c learReferencesThreads The web application [WebChatApp] appears to have started a thread named [com.comergo.base.ttrace.client.link.appdriver.Comm andEmitter] but has failed to stop it. This is very likely to create a memory leak. Stack trace of thread:
java.lang.Object.wait(Native Method)
java.lang.Object.wait(Object.java:503)
com.comergo.base.ttrace.client.link.util.MessageQu eue.getNext(Unknown Source)
com.comergo.base.ttrace.client.link.appdriver.Comm andEmitter.run(Unknown Source)

Here are the specs for our tomcat installation:

Tomcat Version: 8.0.33
Java version: 1.7.0_91-Avaya-b01

Any help on this issue would be greatly appreciated!
Reply With Quote
  #2  
Old 04-27-2016, 03:07 AM
marquardt marquardt is offline
Guru
.
 
Join Date: May 2014
Location: Stuttgart - Germany
Posts: 190
marquardt has 14 reputation pointsmarquardt has 14 reputation points
Default Check WebChatApp.properties

Example: WebChatApp.properties

https://drive.google.com/drive/folde...WxlWlJfZG1Tb3M


You can also use WebChatDialog
Reply With Quote
  #3  
Old 04-29-2016, 06:18 AM
josep79 josep79 is offline
Aspiring Member
 
Join Date: Apr 2016
Posts: 2
josep79 has 10 reputation points
Default Still not working

I am the web developer working on this project.

I have confirmed that we have the correct lines in the WebChatApp.properties file, which I have attached. The app will not start at all in Tomcat. We get the same error messages in the log file that are listed in the first post.
Attached Images
File Type: png webchat settings.png (15.6 KB, 19 views)
Reply With Quote
  #4  
Old 05-01-2016, 09:58 PM
marquardt marquardt is offline
Guru
.
 
Join Date: May 2014
Location: Stuttgart - Germany
Posts: 190
marquardt has 14 reputation pointsmarquardt has 14 reputation points
Default TopicID must not contain spaces

see description
# The listoftopicsthatcanbeconnected
# theformatofthelistiscommaseparated: <entry>,<entry>,......
# eonentryhastheformat <TopicID>:<JabberID> whereTopicID must not contain spaces
Reply With Quote
  #5  
Old 05-02-2016, 10:36 AM
josep79 josep79 is offline
Aspiring Member
 
Join Date: Apr 2016
Posts: 2
josep79 has 10 reputation points
Default

I changed the topic to:

Topics=Enrollment:webchat@chat.doane.local

The app does not start and I still get the same error messages in the log.
Reply With Quote
  #6  
Old 05-03-2016, 02:02 AM
schopdekar schopdekar is offline
Whiz
.
 
Join Date: Aug 2015
Location: Pune, India
Posts: 40
schopdekar has 10 reputation points
Default

In TTConsole, under WebChat->WebChatDialog what messages are seen ?

Please clear up all messages, restart Tomcat WWW, and post the messages.
Reply With Quote
Reply

Tags
chat, ipocc, webchatapp

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:02 AM.

This Forum is provided solely for the use and convenience of Avaya customers and partners. Use of the Forum is subject to the Terms and Use and Privacy Statement found at www.avaya.com. No other use is permitted. The Forum including all content posted is “AS IS” and Avaya expressly disclaims all warranties and/or guarantees as to its accuracy, reliability, usefulness, quality or non-infringement of intellectual property. Avaya reserves the right to remove any content posted on the Forum at any time and for whatever reason.

Avaya will not be liable for any content posted on this Forum, including, without limitation, any errors or omissions or for any losses or damages of any kind incurred as a result of use or reliance on any content, regardless of its origin.

You expressly understand and agree that you assume all risks associated with use or reliance on this content.