Avaya Support Forums  

Go Back   Avaya Support Forums > Contact Center Applications

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-02-2012, 01:59 AM
tmerkouris tmerkouris is offline
Hot Shot
 
Join Date: Mar 2010
Posts: 14
tmerkouris has 10 reputation points
Default AACC 6.2 email issue

We have installed AACC 6.2 with multimedia in a co-resident environment.
While the mm outbound functionality works fine, the email does not.
We are using email account which is not on same domain with AACC and emails never arrive to multimedia.

Any idea what might go wrong?
Thanks.
Reply With Quote
  #2  
Old 03-02-2012, 04:24 AM
phemming phemming is offline
Guru
 
Join Date: Jun 2010
Location: Birmingham,UK
Posts: 150
phemming has 10 reputation points
Default

Sounds like configuration or firewall to me
Can you telnet to your email server from the MM server?
If not MM will never recieve emails
Reply With Quote
  #3  
Old 03-05-2012, 02:23 AM
tmerkouris tmerkouris is offline
Hot Shot
 
Join Date: Mar 2010
Posts: 14
tmerkouris has 10 reputation points
Default

Problem solved.
Because we used gmail account, we needed to make some changes to mailservice.properties.

For AACC CCMM Email service to connect correctly to the GMAIL server over SSL we need to follow the steps:
  • Using a web browser (IE / Firefox) login to GMAIL. Then export the certificate to a file in the disk.
  • You have to import this certificate to the cacerts of the jre the EMAIL serivice is using
    • Since the AACC installation have two JREs so we have to do it in both since we don’t know which of them the AACC is using
    • so issue the following command
      keytool -v -importcert -alias gmail -file mail.google.com -keystore C:\Program Files\Java\jre\lib\security\cacerts
      keytool -v -importcert -alias gmail -file
      mail.google.com -keystore C:\Program Files (x86)\Java\jre\lib\security\cacerts

      The password is: changeit
  • Edit the folder D:\Avaya\Contact Center\Multimedia Server\Server Applications\EMAIL there is a file mailservice.properties
  • For Incoming Mail
    • In this file change the property : mail.store.protocol=pop3s
  • For Outgoing
    • In this file change the property : mail.transport.protocol=smtp
    • In this file change the property : mail.smtp.aut=true
    • In this file change the property : mail.smtp.starttls.enable=true
  • Optionally open the debug property mail.debug=true and check the file C:\Windows\SysWOW64\javamailtracelog.txt to see errors etc.
  • The log file for the email service is : D:\Avaya\Logs\CCMM\CCMM_EmailManager_1.log
Finally, in the CCMM administration needs two email recipients, one mail store and one email alias.


Hope this helps anyone who come across with same issue.


Best Regards,
Thomas
Reply With Quote
  #4  
Old 09-25-2012, 02:38 PM
sfitzg sfitzg is offline
Guru
 
Join Date: Jul 2010
Location: Auckland, New Zealand
Posts: 190
sfitzg has 10 reputation points
Default

A life saver. Thank you Thomas this resolved my issue I had with a customer who required POP3 SSL to MS Exchange.
Reply With Quote
  #5  
Old 09-25-2012, 11:55 PM
stphnwd's Avatar
stphnwd stphnwd is offline
Brainiac
.
 
Join Date: Jan 2011
Location: USA
Posts: 52
stphnwd has 10 reputation points
Default

FYI updating CCMM Email to use SSL/TLS is documented.
Reply With Quote
  #6  
Old 09-26-2012, 02:04 AM
sfitzg sfitzg is offline
Guru
 
Join Date: Jul 2010
Location: Auckland, New Zealand
Posts: 190
sfitzg has 10 reputation points
Default

Correct. However I would say that it is poorly documented at best and plain inaccurate at worst for someone who has never used Keytool before. Thomas post lays it out clearly what is required and can be adapted within minutes.
Reply With Quote
  #7  
Old 09-27-2012, 10:46 PM
stphnwd's Avatar
stphnwd stphnwd is offline
Brainiac
.
 
Join Date: Jan 2011
Location: USA
Posts: 52
stphnwd has 10 reputation points
Default

Completely agree as well.
Reply With Quote
  #8  
Old 11-09-2012, 07:13 AM
jeanr jeanr is offline
Member
 
Join Date: Nov 2012
Posts: 7
jeanr has 10 reputation points
Default

I tried to follow the documentation AACC server administration Enabling SSL on the Email Manager with no success.
It is not the same procedure as tmerkouris one.



In my environnement AACC 6.2 SP6 there is not "mail.smtp.aut=" and "mail.smtp.starttls.enable=" properties.
mail.transport.protocol=smtp is already set up like that by default, why you didn't change it to smtps ?
Reply With Quote
  #9  
Old 11-09-2012, 10:17 AM
sfitzg sfitzg is offline
Guru
 
Join Date: Jul 2010
Location: Auckland, New Zealand
Posts: 190
sfitzg has 10 reputation points
Default

My customers requirement was to secure POP3 only, not SMTP so I have not tried it sorry.
Reply With Quote
  #10  
Old 11-12-2012, 03:00 AM
jeanr jeanr is offline
Member
 
Join Date: Nov 2012
Posts: 7
jeanr has 10 reputation points
Default

ok,
mail.smtp.aut="
and
"mail.smtp.starttls.enable="

those properties has been modified or added?
Because i can't find them on my file
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:07 AM.

This Forum is provided solely for the use and convenience of Avaya customers and partners. Use of the Forum is subject to the Terms and Use and Privacy Statement found at www.avaya.com. No other use is permitted. The Forum including all content posted is “AS IS” and Avaya expressly disclaims all warranties and/or guarantees as to its accuracy, reliability, usefulness, quality or non-infringement of intellectual property. Avaya reserves the right to remove any content posted on the Forum at any time and for whatever reason.

Avaya will not be liable for any content posted on this Forum, including, without limitation, any errors or omissions or for any losses or damages of any kind incurred as a result of use or reliance on any content, regardless of its origin.

You expressly understand and agree that you assume all risks associated with use or reliance on this content.