Avaya Support Forums  

Go Back   Avaya Support Forums > Small and Medium Business Communications

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 02-06-2015, 09:25 AM
peter290 peter290 is offline
Aspiring Member
 
Join Date: Jan 2015
Posts: 2
peter290 has 10 reputation points
Default One-X Mobile and iPhone 6

Hello All,

I am a new Avaya tech and have been taking the AIPS training courses to familiarize myself with IP Office but am stuck on an issue.

We have 2 IP Office Systems in our Office. One physical ip 500 v2 with a seperate application server. The second is virtual IPO for demo's located on my laptop in VMware Player, both are running 9.1. Both are setup and have basic functionality but I am not able to get mobile clients to connect to One-X. Whenever I open the App on the iphone and direct it to the server on port 8444 the app instantly closes. When I run the app on the android phone it says Login Failed : Server Credentials incorrect or server not available. The logs for the android device are pasted below. This has been tested on several iphones and a Samsung Galaxy. The Communicator and Softphone on windows desktops both connect to one-x fine and can make and take calls.

Setup tested on both separate systems: a valid user is created with a power user license and all of the passwords are generated. The certificate for one-x is emailed to the phone and installed. The user connects over wifi on the same subnet as the one-x server. The phone is setup with the correct IP, port 8444, and valid user info. I am unclear if port 8444 is correct because Avaya's documentation is atrocious in my opinion. I have also tried 8443, 5222, 9443, and the default 7777. All of which are referenced across the documentation.

I'm not sure where to go from here, this happens on both the physical and virtual server. I have checked the logs on the one-x server and there is nothing related to user logins. All of the services are started on the app server and the virtual server. The devices are connected over wireless and are on the same subnet as the servers. I can access the web interface from the mobile browsers so I know it can see the server. The android clients logs are below, they make no sense to me. It says login failure but also says Success?

02-06 10:18:21.371 D/onexSettings(11398): SetLoginInfo: ----------- LoginInfo Start----------
02-06 10:18:21.371 D/onexSettings(11398): HostName = 10.10.200.250
02-06 10:18:21.371 D/onexSettings(11398): Port = 8444
02-06 10:18:21.371 D/onexSettings(11398): userName = Wade
02-06 10:18:21.371 D/onexSettings(11398): Password = *****
02-06 10:18:21.371 D/onexSettings(11398): UseSsl = true
02-06 10:18:21.371 D/onexSettings(11398): ----------- LoginInfo End----------
02-06 10:18:21.371 D/LoginWorker(11398): Login worker got perform login signal.
02-06 10:18:21.371 D/LoginWorker(11398): *Wait finished. Starting Login workflow...
02-06 10:18:21.371 D/LoginWorker(11398): runLoginWorkflow: ST
02-06 10:18:21.371 D/LoginWorker(11398): runLogin: 10.10.200.250:8444 ssl on user:Wade
02-06 10:18:21.371 D/oneXPreferences(11398): getLastKnownSessionId():
02-06 10:18:21.371 D/LoginWorker(11398): Creating socket
02-06 10:18:21.421 D/LoginWorker(11398): loginThread: send LoginReq: LoginRequest [username=Wade, password=*****, manufacturer=samsung, model=SCH-I545, language=English, version=6.2.2, isJailbrokenDevice=false, deviceId=990003451650721]
02-06 10:18:21.461 D/ResponseHandler Main(11398): handleData: Main
02-06 10:18:21.471 D/RequestHandler Main(11398): sendObject succ: 1
02-06 10:18:21.471 D/RequestHandler Main(11398): req:1
02-06 10:18:21.471 D/ResponseHandler Main(11398): LoginThread
02-06 10:18:31.641 D/ResponseHandler Main(11398): handleData: readingFailedrotocol java.io.IOException: readBytes: EOF
02-06 10:18:31.641 D/ResponseHandler Main(11398): Closing socket.
02-06 10:18:31.651 D/ResponseHandler Main(11398): !Close socket: re-login
02-06 10:18:31.651 D/LoginHandler(11398): Trying to reconnects: already tryin: false, attempt: 0
02-06 10:18:31.651 D/oneXPreferences(11398): LoginPreferenceSet: false
02-06 10:18:31.651 D/LoginWorker(11398): ServerOpResult = GENERAL_ERROR ErrorCode = SUCCESS Message =
02-06 10:18:31.651 D/LoginWorker(11398): *Waiting for Login req..
02-06 10:18:34.654 D/Engine (11398): Login Failed: GENERAL_ERROR retry:false
02-06 10:18:34.654 D/LoginActivity(11398): loginFinished: GENERAL_ERROR
02-06 10:18:37.046 D/oneXStrings(11398): getLogEmailSubject: Android: Avaya one-X® Mobile Diagnostic Logs
02-06 10:18:37.296 E/ViewRootImpl(11398): sendUserActionEvent() mView == null
02-06 10:18:41.130 W/IInputConnectionWrapper(11398): showStatusIcon on inactive InputConnection
02-06 10:19:31.049 W/IInputConnectionWrapper(11398): getTextBeforeCursor on inactive InputConnection
02-06 10:19:31.059 W/IInputConnectionWrapper(11398): getCursorCapsMode on inactive InputConnection
02-06 10:19:31.059 W/IInputConnectionWrapper(11398): getCursorCapsMode on inactive InputConnection
02-06 10:19:31.269 D/OneX_Screen_Receiver(11398): Got SCREEN OFF
02-06 10:19:39.287 D/OneX_Screen_Receiver(11398): Got SCREEN ON
02-06 10:19:39.287 D/LoginHandler(11398): Trying to reconnects: already tryin: false, attempt: 0
02-06 10:19:39.287 D/oneXPreferences(11398): LoginPreferenceSet: false
02-06 10:19:44.422 D/onexSettings(11398): SetLoginInfo: ----------- LoginInfo Start----------
02-06 10:19:44.422 D/onexSettings(11398): HostName = 10.10.200.250
02-06 10:19:44.422 D/onexSettings(11398): Port = 8444
02-06 10:19:44.422 D/onexSettings(11398): userName = Wade
02-06 10:19:44.422 D/onexSettings(11398): Password = *****
02-06 10:19:44.422 D/onexSettings(11398): UseSsl = true
02-06 10:19:44.422 D/onexSettings(11398): ----------- LoginInfo End----------
02-06 10:19:44.422 D/LoginWorker(11398): Login worker got perform login signal.
02-06 10:19:44.422 D/LoginWorker(11398): *Wait finished. Starting Login workflow...
02-06 10:19:44.422 D/LoginWorker(11398): runLoginWorkflow: ST
02-06 10:19:44.422 D/LoginWorker(11398): runLogin: 10.10.200.250:8444 ssl on user:Wade
02-06 10:19:44.422 D/oneXPreferences(11398): getLastKnownSessionId():
02-06 10:19:44.422 D/LoginWorker(11398): Creating socket
02-06 10:19:44.482 D/LoginWorker(11398): loginThread: send LoginReq: LoginRequest [username=Wade, password=*****, manufacturer=samsung, model=SCH-I545, language=English, version=6.2.2, isJailbrokenDevice=false, deviceId=990003451650721]
02-06 10:19:44.532 D/ResponseHandler Main(11398): handleData: Main
02-06 10:19:44.562 D/RequestHandler Main(11398): sendObject succ: 2
02-06 10:19:44.562 D/RequestHandler Main(11398): req:2
02-06 10:19:44.562 D/ResponseHandler Main(11398): LoginThread
02-06 10:19:54.692 D/ResponseHandler Main(11398): handleData: readingFailedrotocol java.io.IOException: readBytes: EOF
02-06 10:19:54.692 D/ResponseHandler Main(11398): Closing socket.
02-06 10:19:54.692 D/ResponseHandler Main(11398): !Close socket: re-login
02-06 10:19:54.692 D/LoginHandler(11398): Trying to reconnects: already tryin: false, attempt: 0
02-06 10:19:54.692 D/oneXPreferences(11398): LoginPreferenceSet: false
02-06 10:19:54.692 D/LoginWorker(11398): ServerOpResult = GENERAL_ERROR ErrorCode = SUCCESS Message =
02-06 10:19:54.692 D/LoginWorker(11398): *Waiting for Login req..
02-06 10:19:57.705 D/Engine (11398): Login Failed: GENERAL_ERROR retry:false
02-06 10:19:57.725 D/LoginActivity(11398): loginFinished: GENERAL_ERROR
02-06 10:20:01.529 D/oneXStrings(11398): getLogEmailSubject: Android: Avaya one-X® Mobile Diagnostic Logs

Last edited by peter290; 02-06-2015 at 09:30 AM.
Reply With Quote
 

Tags
ip office, one-x mobile

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:48 AM.

This Forum is provided solely for the use and convenience of Avaya customers and partners. Use of the Forum is subject to the Terms and Use and Privacy Statement found at www.avaya.com. No other use is permitted. The Forum including all content posted is “AS IS” and Avaya expressly disclaims all warranties and/or guarantees as to its accuracy, reliability, usefulness, quality or non-infringement of intellectual property. Avaya reserves the right to remove any content posted on the Forum at any time and for whatever reason.

Avaya will not be liable for any content posted on this Forum, including, without limitation, any errors or omissions or for any losses or damages of any kind incurred as a result of use or reliance on any content, regardless of its origin.

You expressly understand and agree that you assume all risks associated with use or reliance on this content.