AES: WebLM License Server Timeouts and Grace Periods
SOLN261013 | Version: 43.0 | Published: 12/17/2014 | Updated: 10/13/2020
Available To: Customer, Partner, Internal,
Categories: Alarms/Error Codes, Avaya Aura® Application Enablement Services, Break/Fix, Computer Telephony, Troubleshooting
Details

AES 6.3.X all offer types including System Platform, VMWare and Bundled Server.

AES 7.0.1.x ,7.1.x, and 8.0x using remote WebLM hosted on System Manager or Standalone WebLM.

Problem Clarification

Many problems can be reported related to WebLM timeouts and or communication failures.  This may include agent login problems, call recording port registration problems and performance problems for the AES.

RESPONSE - Got CM_RST_FAILURE - InvokeId = 5706, SwitchId = 186, ClientId = 1, Time = 0, ErrorCode = 0, ErrorDescription = Registration Reject reason: resourceUnavailable

ERROR:WARNING:TSAPI:G3PD:L 2928:C 210:[Audit-SWLINK1] The PBX object for PBX SWLINK1 is locked by PBX 1 Thread.  The Audit 1 Thread sent a Universal Failure Confirmation event to session ID 218 for a CSTA_SNAPSHOT_DEVICE request.  Error count 1.

After looking further, we noticed many more errors surrounding these thread lock errors, seeming to indicate a communication error with the WebLM licensing server.  The WebLM in this case was hosted on CDOM, within the same System Platform.

ERROR:WARNING:TSAPI:TSAPI Users->countingAcquire:acquire() failed: Timeout occurred contacting license server:
ERROR:WARNING:TSAPI:GenericLicense::SetMode:License mode changed to LICENSE_ERROR; cause: Timeout occurred contacting license server:; grace period: 2592000 secs
ERROR:WARNING:TSAPI:Audit:Timed out on G3PDMutex0 <-- Mutex errors are an indication that the AES / CM link is dropping
ERROR:CRITICAL:licenseInfo:createLicenseManager:Could not access WebLM server at "
https://xx.xx.xx.xxx:52233/WebLM/LicenseServer": Timeout occurred contacting license server:
ERROR:WARNING:TSAPI:GenericLicense::SetMode:License mode changed to LICENSE_NORMAL; cause: Initialize license as normal 

[craft@AES logs]$ vi log.20170926
11:12:09.320 ERROR:CRITICAL:TSAPI:RenewTimeoutEH::handle_timeout:renewAllLicenses failed: Timeout occured contacting license server:
11:12:09.320 ERROR:WARNING:TSAPI:GenericLicense::SetMode:License mode changed to LICENSE_ERROR; cause: Timeout occured contacting license server:; grace period: 2592000 secs
11:13:09.514 ERROR:WARNING:TSAPI:GenericLicense::SetMode:License mode changed to LICENSE_NORMAL; cause: Initialize license as normal
11:14:28.336 ERROR:CRITICAL:TSAPI:RenewTimeoutEH::handle_timeout:renewAllLicenses failed: Timeout occured contacting license server:
11:14:28.336 ERROR:WARNING:TSAPI:GenericLicense::SetMode:License mode changed to LICENSE_ERROR; cause: Timeout occured contacting license server:; grace period: 2592000 secs
11:15:28.622 ERROR:WARNING:TSAPI:GenericLicense::SetMode:License mode changed to LICENSE_NORMAL; cause: Initialize license as normal
22:03:31.112 ERROR:WARNING:TSAPI:TSERVER:PeerAcceptor.cpp/358 93 accept() failed for client xxx.xxx.xxx.xxx and driver service AVAYA#SWLINK#CSTA-S#AES; errno=62: Timer expired
 

Solution