CM - Some inbound calls are not being recorded by ACR,denial event 2176 is seen in MST trace.


Doc ID    SOLN229880
Version:    2.0
Status:    Published
Published date:    06 Dec 2017
Created Date:    31 May 2013
Author:   
arvizu
 

Details

Calls are not being recorded by ACR
Some inbound calls are not being recorded by ACR,this started to happen suddenly without changes on the system.

System version is:

CM Reports as: R015x.02.1.016.4 patch 20636 (combo 20445 20634)

MST reports a denial event 2176 after the single-step-conference to include the IP_API_A extension in the call

216604 14:38:59.434 14 Denial Event Trace (2176 DNY_STRTQ931_FAIL_3X)
Event Type = 2176 (DNY_STRTQ931_FAIL_3X)
Data1 = 0x00005ef3 = Internal PBX number for extension #40461
Data2 = 10.3.6.30 = AES IP

This denial event is generated when the PBX cannot reach the extension to put it in the conference call. And, after about 15 seconds (3 attempts of 5s) the PBX send the response to AES:

218804 14:39:16.710 57 0000000b <-- DOMAIN crv 1_01ea no response !
<- FACILITY return error: single_step conference
<- | CAUSE local pvt netwk |cv pvt netwk serv local usr:18. No user respondinghace 10 diasno seninguno

Problem Clarification

Some incound calls are not being recorded by ACR,this happens randomly in all system campaigns

Cause

IP_API_A extensions don't have a TCP Socket assigned

REGISTERED IP STATIONS

Station Ext Set Type/ Prod ID/ TCP Station IP Address/
or Orig Port Net Rgn Release Skt Gatekeeper IP Address
------------- --------- ---------- --- ---------------------------------------
40461 4624 IP_API_A n 10.3.6.30
33 3.2040 10.3.1.62

So the extensions are out-of-communication but not out-of-service

Solution

1 –Run BUSYOUT and RELEASE for all extensions with TCP socket NO to establish the socket again, monitor to see if denial event persists after that.

2 –In case the denial event persists:

Network-region was programmed with the parameter Near End Establishes TCP Signaling Socket? Y . With that, PBX was responsible to establish the TCP signaling to AES. I recommended to change it to NO and then, the FAR-END (AES) would establish it. This parameter is called TTL.
With this, a problem with TCP socket is recognized by AES and ACR will receive the information.
 

To identify the cause of TCP socket NO we will need to change it back and collect a sniffer trace between AES and PBX, so I think we could consider the high traffic over PROCR and the statements below when the TTL is enabled:
1. In heavy occupancy situations, the establishment of the TCP signaling connection between endpoint and CM will be delayed.
2. The direction of the connection is reversed; CM will connect out to the IP endpoint.
3. Resiliency to TCP connection failure. If a connection fails, the system will not rush to reestablish the connection but connection can be triggered by endpoints (ARQ message.)
4. Registration persistence. The registration will persist for TTL duration regardless of TCP connection failure, network outages, or even restarts of the endpoint ( not power outage.)


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