Avaya one X Agent : Unable to register station or Agent, due to unknown reasons


Doc ID    SOLN265849
Version:    8.0
Status:    Published
Published date:    25 Sep 2020
Created Date:    25 Mar 2015
Author:   
Dan Morrissey
 

Details

When trying to log in on the Cisco VPN, the TCP connection on port 61440 is being refused.

Monitored VPN firewall (Cisco ASA5520, running Cisco Adaptive Security Appliance Software Version 8.4(7)) while attempting to log into station via one-X Agent 2.5:

Mar 16 2015 15:18:53 602101 PMTU-D packet 1444 bytes greater than effective mtu 1300, dest_addr=*.*.*.*, src_addr=*.*.*.*, prot=UDP

Feb 22 2015 09:06:31 602101 PMTU-D packet 1448 bytes greater than effective mtu 1300, dest_addr=*.*.*.*, src_addr=*.*.*.*, prot=UDP


Endpointlog.txt
[03/24/2015 11:39:11:269] ERR: SIGNAL: Q931: closeSignalingChannel(). Signaling channel ended closed by the application.
[03/24/2015 11:39:11:269] ERR: SIGNAL: H323: RegistrationFailed(): display error= 0.
[03/24/2015 11:39:11:269] ERR: USER: H323SignalMgr: eH323_LINK_RECOVERY_IN_PROGRESS = true
[03/24/2015 11:39:11:488] ERR: SESSION: Move to next server in ASL
[03/24/2015 11:39:11:488] ALT: USER: H323: Local IP address to reach * is *
[03/24/2015 11:39:11:488] ERR: SIGNAL: RAS : sendGRQ() ENTERED. RAS state= 1.
[03/24/2015 11:39:11:488] ERR: SIGNAL: RAS : usStartTimer: timerId: 0 timeout=5 seconds
[03/24/2015 11:39:11:675] ERR: SIGNAL: RAS : sendRRQ() ENTERED SENDRRQ
[03/24/2015 11:39:11:675] ERR: SIGNAL: RAS : usStartTimer: timerId: 1 timeout=3 seconds
[03/24/2015 11:39:14:424] ERR: DHCP: CDhcpDataAdaptor::ReadData Error
[03/24/2015 11:39:14:877] ERR: SIGNAL: RAS : usStartTimer: timerId: 1 timeout=3 seconds
[03/24/2015 11:39:18:156] ERR: SIGNAL: RAS : usStartTimer: timerId: 1 timeout=3 seconds

Problem Clarification

When trying to log in on the Cisco VPN, a list trace station shows TCP connection on port 61440 is closed and the One X Agent generates the error:  "Your login attempt was unsuccessful for unknown reasons....." This started after the upgrade from IP Agent to One X Agent.

 

Cause

One-X Agent uses (TTS) which is enabled by default, IP Agent does not use such protocol.

Time-to-Service (TTS)

The IP Endpoint Time-to-Service (TTS) feature was introduced in Software Release 1.2, along with Avaya Communication Manager (CM) Release 4.0. TTS changes the way IP endpoints register with their gatekeeper, reducing the time to come into service. Currently, IP endpoints are brought into service in two steps, which are coupled (1) H.323 registration and (2) TCP socket establishment for call signaling. The TTS feature de-couples these steps. In CM 4.0, IP endpoints can be enabled for service with just the registration step. TCP sockets are established later, as needed.

The TTS feature also changes the direction of socket establishment. With TTS, Communication Manager, rather than the endpoint, initiates socket establishment, which further improves performance. In CM 4.0, TTS is enabled by default, but can be disabled for all IP endpoints in a given IP network region by changing the IP Network form. TTS applies only to IP endpoints whose firmware has been updated to support this feature. It does not apply to the following endpoints: third party H.323, DCP, BRI, and analog. For more information, see the Administrator Guide for Avaya Communications Manager (Document Number 03-300509).

Solution

Set the "Near end establishes TCP signalling socket", to 'n' on the network region settings page on the Communication Manager and One X Agent was able to log in.

Additional Relevant Phrases

OneX Agent 2.5.58020.0 SP6 with Citrix 7.6 version. Station & agent will not connect Unable to register station or Agent

Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy