CMS Supervisor: Skill assignment is out of order after performing Agent Skill Changes.


Doc ID    SOLN340537
Version:    3.0
Status:    Published
Published date:    26 Jun 2019
Created Date:    13 Jun 2019
Author:   
Jean-Francois Gionet
 

Details

Specific to CMS Supervisor R18.1 MB 06, MB 07 or MB 08.

Any CMS server release.

Problem Clarification

Agent staffing issue. Skill changes made via CMS Supervisor R18.1, either manually or using automatic scripts results in skills being assigned out of order.

Top Skill is not longer Top as defined in the Skill Change, this can cause call routing issues especially when CMS interacts with 3rd party products.

This issue occurs when the agent in question is already staffed to at least 2 skills prior to the skill change.

Cause

Product defect - Changes made to the CMS Supervisor Code for the R18.1 release is the cause behind this issue.

Solution

The changes made in Supervisor R18.1 were reverted for the Supervisor R19 release due to this problem.

Use either:

R18.0 Supervisor: https://support.avaya.com/downloads/download-details.action?contentId=C201592485797830_9&productId=P1052&releaseId=18.0.x

or

R19.0 Supervisor: https://support.avaya.com/downloads/download-details.action?contentId=C20195311149239870_7&productId=P1052&releaseId=19.0.x

Please note that CMS Supervisor R18.0 is still compatible with CMS server R18.1.


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