Master/standby not syncing after Standby IP address change.


Doc ID    SOLN341639
Version:    1.0
Status:    Published
Published date:    18 Jul 2019
Author:   
ybathla
 

Details

ACR 12.0

Problem Clarification

ACR 12 Master/standby not syncing after Standby IP address change.

Cause

Customer/BP didn't put the Master ACR IP adress on the Standby ACR. As a result, Certral dB still consider previous IP address as Standby ACR. Hence, Current Standby ACR and Master ACR did not synronized.

Solution

The tables of postgres dB modified where IP address changes from Old (192.168.171.246) to New(192.168.171.241).

First Step: Take Backup of the master and standby ACR

Execute following queries after accessing database:

 

 

Take a INUM which is appeared on master ACR, but not standby ACR. In this we consider INUM 802763000469812
 
Execute following queries:
 
  • Update jobqueue set params=’192.168.171.241:8080’ where params =’192.168.171.246:8080’ and inum=802763000469812;                                                                             // this will only update 1 inum
 
Then make an attempt to search this call on standby. If this goes fine then
 
  • Update jobqueue set params=’192.168.171.241:8080’ where params =’192.168.171.246:8080’;                                                                    // this will update all the jobid’s in jobqueue.
 

  • service cscm stop                                   à                                                                                                          Stop ACR
Connect to the Master PostgreSQL db
  • eware=> select * from settings where settingkey like '%client%';      
 
settingkey    |                    value
-----------------+---------------------------------------------             à                                                    Current Value                                                 
flags.clientids     |   882764/4/192.168.171.246;802763/1/127.0.0.1
 
  • update settings set value = '882764/4/192.168.171.241;802763/1/127.0.0.1' where settingkey = 'flags.clientids';
 
  • eware=> select * from settings where settingkey like '%client%';      
 
settingkey    |                    value
-----------------+---------------------------------------------             à                                                    Expected Value                                                 
flags.clientids     |   882764/4/192.168.171.241;802763/1/127.0.0.1
 

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