Avaya Support Forums

Avaya Support Forums (http://support.avaya.com/forums/index.php)
-   Mobile Communications (http://support.avaya.com/forums/forumdisplay.php?f=5)
-   -   Android not "remembering" One-X Mobile password (http://support.avaya.com/forums/showthread.php?t=2393)

marcsuttle 01-10-2013 09:09 AM

Android not "remembering" One-X Mobile password
 
We are using Avaya CES with the One-X Mobile client on a variety of Androids and iPhones. Everything is functioning as it should with one glaring exception - my Samsung Galaxy Nexus (unlocked v4.2.1 obtained directly from Google - running on AT&T) will not remember the password. Once I manually reenter the password all is okay - but I have to do this every time I exit then reopen the app. This is the only 4.2 Android device in use.

I can login on other user's devices (Androids/iPhones) with my credentials and the password is retained every time - including other versions (Verizon) of the Galaxy Nexus.

The app has been removed and reinstalled multiple times. I've searched and found many examples of various Androids not retaining passwords but none offer a solution.

mmaster 01-28-2013 04:41 AM

I seem to have a similar problem not being able to login on 4.2.1, and I have the following in my Android logcat:

Code:

D/oneXApp ( 8186): Avaya one-X Mobile 6.1.2 is starting
D/oneXApp ( 8186): Logging level is set to 3
D/oneXApp ( 8186): oneXApp:Application locale set to English (United States)
D/oneXApp ( 8186): oneXApp:initEngine:st
D/oneXApp ( 8186): en:Avaya one-X Mobile 6.1.2 is starting
D/oneXApp ( 8186): en: Engine:init
D/oneXApp ( 8186): oneXApp:T:ClientActivityMonitor: ctor(): idleVal=240000
D/oneXApp ( 8186): oneXApp:T:Init req and response handler
D/oneXApp ( 8186): oneXApp:T:LoginHandler:Create login worker:Init
D/oneXApp ( 8186): VM:VM dir =/storage/emulated/0/Android/data/com.avaya.android.onex/files/voicemails
D/oneXApp ( 8186): en:Engine init complete
D/oneXApp ( 8186): oneXApp:T:*Waiting for Login req..
D/oneXApp ( 8186): prefs:LoginPreferenceSet: true
D/oneXApp ( 8186): HomeA:Home::onCreate()
D/oneXApp ( 8186): oneXApp:getLoginInfoFromPreferences
D/oneXApp ( 8186): oneXApp:T:SetLoginInfo: ----------- LoginInfo Start----------
D/oneXApp ( 8186): HostName = onexcesus1a.avaya.com
D/oneXApp ( 8186): Port    = 7777
D/oneXApp ( 8186): userName = mmaster
D/oneXApp ( 8186): Password = *****
D/oneXApp ( 8186): UseSsl  = true
D/oneXApp ( 8186): ----------- LoginInfo End----------
D/oneXApp ( 8186): oneXApp:T:Login worker got perform login signal.
D/oneXApp ( 8186): oneXApp:T:*Wait finished. Starting Login workflow...
D/oneXApp ( 8186): oneXApp:T:runLoginWorkflow: ST
D/oneXApp ( 8186): loginWk:runLogin: onexcesus1a.avaya.com:7777 ssl on user:mmaster
D/oneXApp ( 8186): oneXApp:T: getLastKnownSessionId():9f1b6370-5f79-11e2-82f8-0000870b1bc4
D/oneXApp ( 8186): oneXApp:T:calling engineStatusListeners() with new status: LOGIN_IN_PROGRESS
D/oneXApp ( 8186): oneXApp:T:loginThread: send LoginReq:ST
D/oneXApp ( 8186): oneXApp:T:Engine Status changed to LOGIN_IN_PROGRESS
D/oneXApp ( 8186): reqh.main:sendObject succ: 1
D/oneXApp ( 8186): resph.main:handleResponse apiResponse: 1 101 thread: main LOGIN
E/oneXApp ( 8186): ResponseErrorHandler main:Error:LOGIN_FAILED Code: LOGIN_FAILED: Login failed for mmaster:null
D/oneXApp ( 8186): resph.main:handleResponse: LOGIN_FAILED
E/oneXApp ( 8186): loginWk:****Last Error: LOGIN_FAILED
D/oneXApp ( 8186): loginWk:LOGIN_FAILED
D/oneXApp ( 8186): oneXApp:T:*Waiting for Login req..
D/oneXApp ( 8186): oneXApp:T:calling engineStatusListeners() with new status: DISCONNECTED
D/oneXApp ( 8186): en:Login Failed: GENERAL_ERROR retry:true
D/oneXApp ( 8186): oneXApp:T:calling engineStatusListeners() with new status: RECONNECT_IN_PROGRESS
D/oneXApp ( 8186): prefs:LoginPreferenceSet: true
D/oneXApp ( 8186): loginh:reLoginWithReconnect:ST
D/oneXApp ( 8186): oneXApp:T:getLoginFailedNotificationText: one-X┬ Mobile login failed.
D/oneXApp ( 8186): oneXApp:T:Engine Status changed to RECONNECT_IN_PROGRESS
D/oneXApp ( 8186): oneXApp:T:Engine Status changed to RECONNECT_IN_PROGRESS
D/oneXApp ( 8186): oneXApp:T:Login worker got perform login signal.
D/oneXApp ( 8186): oneXApp:T:*Wait finished. Starting Login workflow...
D/oneXApp ( 8186): oneXApp:T:runLoginWorkflow: ST
D/oneXApp ( 8186): loginWk:runLogin: onexcesus1a.avaya.com:7777 ssl on user:mmaster
D/oneXApp ( 8186): oneXApp:T: getLastKnownSessionId():9f1b6370-5f79-11e2-82f8-0000870b1bc4
D/oneXApp ( 8186): resph.main:handleData: readingFailed:protocol java.io.IOException: readBytes: EOF
D/oneXApp ( 8186): oneXApp:T:Closing socket.
D/oneXApp ( 8186): oneXApp:T:!Close socket: re-login
D/oneXApp ( 8186): oneXApp:T:calling engineStatusListeners() with new status: DISCONNECTED
D/oneXApp ( 8186): oneXApp:T:calling engineStatusListeners() with new status: RECONNECT_IN_PROGRESS
D/oneXApp ( 8186): oneXApp:T:Engine Status changed to RECONNECT_IN_PROGRESS
D/oneXApp ( 8186): oneXApp:T:Engine Status changed to RECONNECT_IN_PROGRESS
D/oneXApp ( 8186): oneXApp:T:calling engineStatusListeners() with new status: LOGIN_IN_PROGRESS
D/oneXApp ( 8186): oneXApp:T:loginThread: send LoginReq:ST
D/oneXApp ( 8186): oneXApp:T:Engine Status changed to LOGIN_IN_PROGRESS


cheima 06-20-2013 10:16 AM

Same problem here
 
Sorry this is not a reply with a solution. I want to mention I have the same problem.
Using one-x Mobile 6.1.2. It does not remember the password.
If I exit the program and open again, it throws up an error "Login Failed"
If I touch the error message to open it, it takes me to the login screen where the login Name and Password are blank.
I fill those in, and it connects.
Then at some point it will prompt for Voice-mail PIN. I enter that and touch Done, and I am fine. I'm logged in and it all works.
However, if I go to Settings / Account Information, the Password and Voice-mail PIN fields are blank.
If I fill them in, it will say, Please restart the application for settings to take effect.
If I then Exit the application and then open it again, the cycle of errors starts again.
If I reboot my phone and open the app again, the cycle of errors starts again.

marcsuttle 06-20-2013 10:37 AM

Coincidentally a little over a week ago one of the local Avaya technical resources I deal with received word that one-X Mobile "CFE" might work. I downloaded it and it appears to have resolved the problem. I was told an update for 6.1 is still due out I think in July.

cheima 06-20-2013 11:31 AM

CFE alternative
 
Hi, thanks. I didn't mention that I had been using CFE (6.2) and true, I found it does not have this problem!
I recently went back to 6.1.2 though, because CFE has performance problems with the Corporate Directory :rolleyes:. I've also been told that 6.2 is being developed to support the CES v 6.2, which is not released yet either.
Thanks for the reply. I look forward to an update to 6.1.2!


All times are GMT -7. The time now is 04:05 AM.