Avaya Support Forums  

Go Back   Avaya Support Forums > IP Telephony and Convergence

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-08-2014, 03:11 PM
mbong mbong is offline
Hot Shot
 
Join Date: Aug 2012
Posts: 12
mbong has 11 reputation points
Question Enabling Syslog for 9611G Phone

Using 9611G with 6.3037 firmware for H.323, I cannot seem to get syslog output working.

I've set the LOGSRVR option that I've been using with 9630G and 4621SW sets also on H.323 firmwares.

I've tried setting the following parameters as well:
SET LOGLOCAL 8
SET LOCAL_LOG_LEVEL 3
SET LOG_CATEGORY DHCP,NETMGR,AUDIO


I've also set the LOG option on the phone to DEBUG (and tried other options as well).

Am I missing a parameter to enable syslog on the 9611G?

Thanks in advance for any assistance.
Reply With Quote
  #2  
Old 09-08-2014, 11:15 PM
sunilkumarv sunilkumarv is offline
Guru
.
 
Join Date: Mar 2010
Location: India
Posts: 124
sunilkumarv has 24 reputation pointssunilkumarv has 24 reputation points
Default

hello,

here is the procedure

In the 46xxsettings.txt file under the “EVENT LOGGING SETTINGS”

· SET LOGSRVR X.X.X.X (Where X.X.X.X is the IP address of the Syslog Server/PC you already setup with syslog server application. Make sure that the syslog server and phones are reachable in the Network)
· On the settings file, SET LOGLOCAL 8 (For debug level).

For 46xx, 96xx, 16xx and 96x1-H323 phones:
Enter MUTE CRAFT #. Scroll down to Debug and set it ON. Also scroll down to Log and set it to Debug.
· Reboot the phones to pickup the new settings file.
· Make sure that the Syslog Server is up and running at this time to capture any event on the phones
· Do the test to reproduce problem
Reply With Quote
  #3  
Old 09-15-2014, 02:36 PM
mbong mbong is offline
Hot Shot
 
Join Date: Aug 2012
Posts: 12
mbong has 11 reputation points
Default

Hi sunilkumarv. Thanks for your response.

I tried the settings changes you noted, however I cannot find a DEBUG option from the phone on the 9611G. I tried adding SET NVDEBUG 1 to the settings file, but that didn't seem to do anything.

I do see a DEBUG option on a 9630G set, but checking that setting it is set to Off and syslog is working from that phone.

I want to add that I am trying to get this working on our phones with VPN enabled. I don't think that should make a difference with the syslog though.
Reply With Quote
  #4  
Old 09-16-2014, 01:56 AM
sunilkumarv sunilkumarv is offline
Guru
.
 
Join Date: Mar 2010
Location: India
Posts: 124
sunilkumarv has 24 reputation pointssunilkumarv has 24 reputation points
Default

I checked this on a 9608 phone 6.4fw as i dont have 9611G phone which i can use right now. i did not see debug option initially in craft menu.

i added below changes in the settings file, rebooted the phone and now i could see the debug option.

SET LOGLOCAL 5
SET LOCAL_LOG_LEVEL 7

I believe the phones may not be picking the settings file, you can use HTTP and then run a sniffer and see if the phones are taking the right settings files

Regards
Sunil
__________________
Regards,
Sunil

AVAYA| Voice: US:- +1 720 444 5271, India: +91 80 6715 3277 | Email:sunilkumarv@avaya.com|
Reply With Quote
  #5  
Old 09-16-2014, 04:25 AM
gwebster gwebster is offline
Guru
.
 
Join Date: Mar 2010
Location: Ottawa
Posts: 143
gwebster has 25 to 49 reputation pointsgwebster has 25 to 49 reputation points
Default

With current releases of software on the 9611G and 9630G, you need to change the CRAFT password from it's default in order to access the DEBUG menu.
Reply With Quote
  #6  
Old 12-18-2014, 08:45 AM
mbong mbong is offline
Hot Shot
 
Join Date: Aug 2012
Posts: 12
mbong has 11 reputation points
Default

Thanks gwebster. I was able to get to the DEBUG menu by changing the CRAFT password. However, that didn't get me closer to getting the syslog working on the 9611G.

Currently, we have syslog working on a 9611G in the office by setting the LOGSRVR and going into the phone and changing the LOG setting to anything other than Disabled. Is there any way we can set this LOG setting from the settings.txt file? Changing around LOGLOCAL, LOCAL_LOG_LEVEL, and/or LOG_CATEGORY didn't seem to have any effect.

We are still not getting any syslog data from a 9611G connected to our system via VPN. We've had no issues with syslog on 9630G and 4621SW over VPN. I would think this rules out any port issues.
Reply With Quote
  #7  
Old 12-18-2014, 09:00 AM
mlombardi1's Avatar
mlombardi1 mlombardi1 is offline
Legend
 
Join Date: Sep 2010
Location: New York
Posts: 457
mlombardi1 has 25 to 49 reputation pointsmlombardi1 has 25 to 49 reputation pointsmlombardi1 has 25 to 49 reputation points
Default

Maybe this?

######### DEBUGGING SETTINGS (96x1 H.323 only) ###########
##
## LOGTOFILE specifies whether logging of optional debug messages
## to an internal file will be enabled or disabled.
## Value Operation
## 0 Disabled (default)
## 1 Enabled
## This parameter is supported by:
## 96x1 H.323 R6.2.3 and later
## B189 H.323 R1.0 and later
## SET LOGTOFILE 1
Reply With Quote
  #8  
Old 02-02-2015, 06:59 AM
mbong mbong is offline
Hot Shot
 
Join Date: Aug 2012
Posts: 12
mbong has 11 reputation points
Default

Just to note, I did try the LOGTOFILE setting. It's set to 1, but we are still not getting Syslog data from a 9611G on VPN.
Reply With Quote
  #9  
Old 07-21-2015, 02:33 PM
wstg wstg is offline
Aspiring Member
 
Join Date: Dec 2014
Posts: 1
wstg has 10 reputation points
Default Syslog

Go back into the phone via craft procedure, scroll down until you see a section called log. Set it to debug and save. This worked for me on a 9621G.

Within my 46xxsettings.txt:
a. LOGSRVR 192.168.1.4 in this case the IP is my desktop computers IP.
b. LOGLOCAL 8 – specifies the severity levels of events logged to the phone. 8 is Debug, Informational, Notice, Warning, Error, Critical, Alert and Emergency events are logged.
c. LOCAL_LOG_LEVEL – Set this to 7 Debug.
Reply With Quote
  #10  
Old 02-18-2016, 01:23 PM
mbong mbong is offline
Hot Shot
 
Join Date: Aug 2012
Posts: 12
mbong has 11 reputation points
Solution Confirmed Resolved with Release 6.6.1

Recently, I contacted Avaya support again about this after trying what I thought was the latest release. I was promptly informed:
H323 96x1G VPN phones support syslog beginning with 6.6.1.

Yay, it is working now. Doesn't have quite the same info as the 9630G or 4621IP SW phones, but finally I can get certificate expiration info.
Reply With Quote
Reply

Tags
9611g, syslog

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:34 AM.

This Forum is provided solely for the use and convenience of Avaya customers and partners. Use of the Forum is subject to the Terms and Use and Privacy Statement found at www.avaya.com. No other use is permitted. The Forum including all content posted is “AS IS” and Avaya expressly disclaims all warranties and/or guarantees as to its accuracy, reliability, usefulness, quality or non-infringement of intellectual property. Avaya reserves the right to remove any content posted on the Forum at any time and for whatever reason.

Avaya will not be liable for any content posted on this Forum, including, without limitation, any errors or omissions or for any losses or damages of any kind incurred as a result of use or reliance on any content, regardless of its origin.

You expressly understand and agree that you assume all risks associated with use or reliance on this content.