SMGR error when trying to change endpoints: Some internal error has occurred in the service. Please contact the


Doc ID    SOLN259357
Version:    3.0
Status:    Published
Published date:    18 Jul 2016
Created Date:    13 Nov 2014
Author:   
Levente Szabo
 

Details

System Manager (SMGR) 6.3.9 patch 2.
 

 

Problem Clarification

In SMGR there was a custom role created e.g. "Test-CM-Only-Change". This role has only rights to make changes to Communication Manager. Now when trying to change an endpoint and trying to commit the change the following error messages is displayed:

"Some internal error has occurred in the service. Please contact the support team."

This error message is also displayed if trying to cancel the change.

Cause

SMGR configuration issue

Solution

Sometimes SMGR permissions can work in mysterious ways and the user might need to be given permission to tasks / objects, that are indirectly associated with the action carried out.

This was the case with this problem, too.

Two additional items needed to be added to the permission mapping to make the endpoint administration properly work for the said object:

• The permission to View Communication Manager Templates; explanation: There are templates linked to each endpoint and when an endpoint is changed a query is run on the template as well, the user requires the ability to view the templates in order to the query to complete successfully. (This was why SMGR displayed the error.)
• The permission to schedule on Demand Scheduled Jobs; explanation: Necessary to be able to delete stations. The removal of stations is being done through scheduler jobs, that user has to have permissions to create.

With the current configuration of this custom role "Test-CM-Only-Change" it is now possible to create, change and delete endpoints as well.


See attached screen shot of the role.

Attachment File


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