Details
Cs1000M SG, Upgrade from release x.x to 7.65P
Problem Clarification
INIs occurred on site during the upgrade of CS1000M SG from release 4.50 to 7065, CPP4 processor.
Cause
RDS logs.
[0887] 29/08/2013 21:07:45 BUG7058 SWD: Swd watchdog timer expired on task tLS,
TID: 0x10e58718, 1 time(s), PC=0x23d78f1, PRI=60, STATUS=DELAY
edi = 10e58718 esi = 0000012c ebp = 10e586bc esp = 10e586a4
ebx = 10e58718 edx = 00000001 ecx = 04cdec48 eax = 00000000
eflags = 00000246 pc = 023d78f1
Return Address Stack:
00fa7d96 (hiPJobServer+1e6)
0228a90c (vxTaskEntry+c)
Stack (top = 0x10e586a4):
[0888] 29/08/2013 21:07:46 BUG7060 SWD: HARDWARE WATCHDOG INTERRUPT EVENT
edi = 00001202 esi = 00a01b94 ebp = 04b11fc4 esp = 04b11f94
ebx = 04b11f9c edx = 00000101 ecx = 0fd91e00 eax = 00000200
eflags = 00000216 pc = 01a65484
Interrupt level: 1
Return Address Stack:
00320aeb (sysNmiIsr+9b)
04cda1dc (_ebss+1cc1dc)
Exact Root cause is unknown. It was found that semWatch feature affects system behavior - with semWatch feature enabled INI occurs after first watchdog. With semWatch disabled INI doesn't occurs (when debug shel is active).
WrapEnabled flag is used to enable this feature. It's enabled by default.
Solution
Design team has developed MPLR32939 which will prevent the continuous warm start.
Please open an SR to Avaya and request MPLR32939 (CPP4/7.6) and follow the below action plan
1) Install MPLR32939
pdt> pload
Patch filename? p32939_1.pp4
Retain patch (y/n)? [y] y
Days patch vulnerable to sysload? [3] 0
In-service initialize threshold? [5] 0
In-service days to monitor inits? [7] 0
2) On active CS, perform the following command in PDT:
taskSwitchMonStart
3) After first watchdog(if occurs) please perform the following command:
storeTaskSwitchResult
After this log file will be created.
Note that if INI/warmstart persist even after patch installation please open DBG shell (pdt> debug)
Then execute commands mentioned in steps (2) and (3) from DBG shell.
You can close DBG shell using debug end command.
Provide the logs to Avaya Support for further investigation.
KB Article is SOLN236602 and please note this patch has been marked as LTD.
Cs1000M SG, Upgrade from release x.x to 7.65P
Problem Clarification
INIs occurred on site during the upgrade of CS1000M SG from release 4.50 to 7065, CPP4 processor.
Cause
RDS logs.
[0887] 29/08/2013 21:07:45 BUG7058 SWD: Swd watchdog timer expired on task tLS,
TID: 0x10e58718, 1 time(s), PC=0x23d78f1, PRI=60, STATUS=DELAY
edi = 10e58718 esi = 0000012c ebp = 10e586bc esp = 10e586a4
ebx = 10e58718 edx = 00000001 ecx = 04cdec48 eax = 00000000
eflags = 00000246 pc = 023d78f1
Return Address Stack:
00fa7d96 (hiPJobServer+1e6)
0228a90c (vxTaskEntry+c)
Stack (top = 0x10e586a4):
[0888] 29/08/2013 21:07:46 BUG7060 SWD: HARDWARE WATCHDOG INTERRUPT EVENT
edi = 00001202 esi = 00a01b94 ebp = 04b11fc4 esp = 04b11f94
ebx = 04b11f9c edx = 00000101 ecx = 0fd91e00 eax = 00000200
eflags = 00000216 pc = 01a65484
Interrupt level: 1
Return Address Stack:
00320aeb (sysNmiIsr+9b)
04cda1dc (_ebss+1cc1dc)
Exact Root cause is unknown. It was found that semWatch feature affects system behavior - with semWatch feature enabled INI occurs after first watchdog. With semWatch disabled INI doesn't occurs (when debug shel is active).
WrapEnabled flag is used to enable this feature. It's enabled by default.
Solution
Design team has developed MPLR32939 which will prevent the continuous warm start.
Please open an SR to Avaya and request MPLR32939 (CPP4/7.6) and follow the below action plan
1) Install MPLR32939
pdt> pload
Patch filename? p32939_1.pp4
Retain patch (y/n)? [y] y
Days patch vulnerable to sysload? [3] 0
In-service initialize threshold? [5] 0
In-service days to monitor inits? [7] 0
2) On active CS, perform the following command in PDT:
taskSwitchMonStart
3) After first watchdog(if occurs) please perform the following command:
storeTaskSwitchResult
After this log file will be created.
Note that if INI/warmstart persist even after patch installation please open DBG shell (pdt> debug)
Then execute commands mentioned in steps (2) and (3) from DBG shell.
You can close DBG shell using debug end command.
Provide the logs to Avaya Support for further investigation.
KB Article is SOLN236602 and please note this patch has been marked as LTD.